Contents

Welcome to Corel Painter ................................................................................................................................................................... 23
  Using the documentation .................................................................................................................................................................. 23
  Adjusting the Help window text size ........................................................................................................................................... 26
  Hints and tooltips .............................................................................................................................................................................. 26
  Welcome Screen ................................................................................................................................................................................... 27
  Additional resources ............................................................................................................................................................................. 28
  Feedback ............................................................................................................................................................................................... 28
  Registration .......................................................................................................................................................................................... 28
  About Corel Corporation .................................................................................................................................................................... 28

What’s new in Corel Painter 2020 .................................................................................................................................................... 29
  What’s new in this version of Corel Painter ......................................................................................................................................... 29
  What was new in earlier versions of Corel Painter ............................................................................................................................. 34

Workspace tour ................................................................................................................................................................................... 57
  Corel Painter terms ............................................................................................................................................................................ 57
  Exploring the Document window .................................................................................................................................................. 59
  Choosing a workspace layout ............................................................................................................................................................ 61
  Exploring the toolbox ......................................................................................................................................................................... 62
  Displaying the toolbox ......................................................................................................................................................................... 67
  Displaying the Media Selector bar .................................................................................................................................................. 67
  Displaying the property bars ........................................................................................................................................................... 68
  Exploring the Navigator panel ........................................................................................................................................................... 70
  Displaying and customizing the Brush Selector ................................................................................................................................ 71
  Displaying the command bar ............................................................................................................................................................ 76
  Rearranging panels and palettes ...................................................................................................................................................... 76
  Exploring panels ................................................................................................................................................................................... 80
  Working with sliders ............................................................................................................................................................................. 83
  Creating and modifying custom palettes ........................................................................................................................................ 84
  Renaming and deleting custom palettes ........................................................................................................................................... 85
Saving, exporting, and importing custom palettes ................................................................. 86
Working with libraries .............................................................................................................. 87
Creating, importing, exporting, and deleting workspaces ...................................................... 88
Restoring the default Corel Painter settings ......................................................................... 89

A short tour of Corel Painter for users of Adobe Photoshop ................................................. 91

Creating, navigating, and manipulating documents ............................................................... 95
Creating documents ................................................................................................................. 96
Understanding resolution ..................................................................................................... 97
Opening and placing files ..................................................................................................... 98
Creating and opening templates ............................................................................................ 101
Switching document views ................................................................................................ 101
Navigating images and viewing image information .............................................................. 102
Zooming images .................................................................................................................... 104
Rotating images and the canvas ............................................................................................ 106
Flipping images ..................................................................................................................... 108
Repositioning images ........................................................................................................... 110
Cropping images .................................................................................................................. 110
Resizing images and the canvas ............................................................................................ 111
Saving and backing up files ................................................................................................ 113
Choosing a file format .......................................................................................................... 114
Emailing documents ............................................................................................................. 116
Closing documents and quitting the application .................................................................... 116
Using two monitors .............................................................................................................. 117
Support for tablets and other devices ............................................................................... 117
Multi-touch support ............................................................................................................. 117
Wacom Intuos support ......................................................................................................... 119
Drag-and-drop features ....................................................................................................... 120

Evaluating your system and optimizing application settings for Corel Painter......................... 121
Evaluating your system .......................................................................................................... 121
Understanding test results ................................................................................................. 122
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exploring painting media</td>
<td>149</td>
</tr>
<tr>
<td>Working with the canvas and layers</td>
<td>149</td>
</tr>
<tr>
<td>Displaying reference images</td>
<td>150</td>
</tr>
<tr>
<td>Clearing the canvas</td>
<td>151</td>
</tr>
<tr>
<td>Setting up the drawing cursor</td>
<td>151</td>
</tr>
<tr>
<td>Using a stylus vs. a mouse</td>
<td>152</td>
</tr>
<tr>
<td>Applying freehand and straight brushstrokes</td>
<td>156</td>
</tr>
<tr>
<td>Constraining, fading, and undoing strokes</td>
<td>158</td>
</tr>
<tr>
<td>Aligning brushstrokes to paths and shapes</td>
<td>158</td>
</tr>
<tr>
<td>Making 360° strokes</td>
<td>159</td>
</tr>
<tr>
<td>Erasing image areas</td>
<td>159</td>
</tr>
<tr>
<td>Letting media pool</td>
<td>161</td>
</tr>
<tr>
<td>Recording and playing back brushstrokes</td>
<td>161</td>
</tr>
<tr>
<td>Reference: Troubleshooting</td>
<td>162</td>
</tr>
<tr>
<td>Working with paper texture and grain</td>
<td>165</td>
</tr>
<tr>
<td>Applying paper texture</td>
<td>165</td>
</tr>
<tr>
<td>Creating and deleting paper textures</td>
<td>166</td>
</tr>
<tr>
<td>Managing paper textures</td>
<td>167</td>
</tr>
<tr>
<td>Rotating paper texture</td>
<td>168</td>
</tr>
<tr>
<td>Inverting and scaling paper grain</td>
<td>168</td>
</tr>
<tr>
<td>Controlling brightness and contrast of paper grain</td>
<td>169</td>
</tr>
<tr>
<td>Adjusting grain direction and behavior</td>
<td>170</td>
</tr>
<tr>
<td>Auto-painting photos</td>
<td>173</td>
</tr>
<tr>
<td>Creating underpaintings</td>
<td>174</td>
</tr>
<tr>
<td>Auto-cloning photos</td>
<td>176</td>
</tr>
<tr>
<td>Auto-painting photos</td>
<td>176</td>
</tr>
<tr>
<td>Restoring detail to paintings</td>
<td>179</td>
</tr>
<tr>
<td>Image cloning and sampling</td>
<td>181</td>
</tr>
<tr>
<td>Cloning workflows</td>
<td>182</td>
</tr>
<tr>
<td>Using embedded images as clone sources</td>
<td>186</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Using textures as clone sources</td>
<td>190</td>
</tr>
<tr>
<td>Using patterns as clone sources</td>
<td>192</td>
</tr>
<tr>
<td>Working with embedded clone sources</td>
<td>193</td>
</tr>
<tr>
<td>Setting cloning preferences</td>
<td>194</td>
</tr>
<tr>
<td>Cloning brushes and controls</td>
<td>195</td>
</tr>
<tr>
<td>Cloning image areas</td>
<td>203</td>
</tr>
<tr>
<td>Applying transformations when sampling</td>
<td>205</td>
</tr>
<tr>
<td>Using selections and transformations when sampling</td>
<td>212</td>
</tr>
<tr>
<td>Filling an area with a sampled image</td>
<td>213</td>
</tr>
<tr>
<td>Working with composition tools, symmetry tools, rulers, and guides</td>
<td>215</td>
</tr>
<tr>
<td>Using the Layout Grid</td>
<td>215</td>
</tr>
<tr>
<td>Using the Mirror Painting mode</td>
<td>218</td>
</tr>
<tr>
<td>Using the Kaleidoscope Painting mode</td>
<td>220</td>
</tr>
<tr>
<td>Using perspective guides</td>
<td>222</td>
</tr>
<tr>
<td>Using the Divine Proportion tool</td>
<td>228</td>
</tr>
<tr>
<td>Using rulers</td>
<td>231</td>
</tr>
<tr>
<td>Using guides</td>
<td>232</td>
</tr>
<tr>
<td>Using Snap to Guides</td>
<td>233</td>
</tr>
<tr>
<td>Using the grid</td>
<td>233</td>
</tr>
<tr>
<td>Using Snap to Virtual Grid</td>
<td>234</td>
</tr>
<tr>
<td>Color</td>
<td>235</td>
</tr>
<tr>
<td>Choosing colors from the Color panel</td>
<td>236</td>
</tr>
<tr>
<td>Resizing the Color panel</td>
<td>239</td>
</tr>
<tr>
<td>Showing or hiding Color panel components</td>
<td>239</td>
</tr>
<tr>
<td>Using the color selector</td>
<td>239</td>
</tr>
<tr>
<td>Changing the paper color</td>
<td>243</td>
</tr>
<tr>
<td>Sampling colors from images</td>
<td>244</td>
</tr>
<tr>
<td>Cloning color</td>
<td>245</td>
</tr>
<tr>
<td>Creating two-color brushstrokes</td>
<td>245</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Exploring the Mixer panel and mixing controls.</td>
<td>246</td>
</tr>
<tr>
<td>Displaying and resizing the Mixer panel.</td>
<td>247</td>
</tr>
<tr>
<td>Mixing, sampling, and applying colors from the Mixer pad.</td>
<td>248</td>
</tr>
<tr>
<td>Opening images in the Mixer panel.</td>
<td>250</td>
</tr>
<tr>
<td>Changing and saving the Mixer color swatches.</td>
<td>251</td>
</tr>
<tr>
<td>Saving Mixer panel colors to a color set.</td>
<td>251</td>
</tr>
<tr>
<td>Clearing and resetting Mixer panel colors.</td>
<td>252</td>
</tr>
<tr>
<td>Saving the Mixer pad.</td>
<td>252</td>
</tr>
<tr>
<td>Loading color swatches and Mixer pad files.</td>
<td>253</td>
</tr>
<tr>
<td>Working with color sets.</td>
<td>253</td>
</tr>
<tr>
<td>Customizing the layouts of color sets.</td>
<td>255</td>
</tr>
<tr>
<td>Creating and exporting color sets.</td>
<td>255</td>
</tr>
<tr>
<td>Editing color sets.</td>
<td>256</td>
</tr>
<tr>
<td>Working with color harmonies.</td>
<td>257</td>
</tr>
<tr>
<td>Setting color variability.</td>
<td>259</td>
</tr>
<tr>
<td>Setting Color Expression.</td>
<td>260</td>
</tr>
<tr>
<td>Loading multiple colors.</td>
<td>260</td>
</tr>
<tr>
<td>Working with color fills.</td>
<td>260</td>
</tr>
<tr>
<td>Applying a color as a fill.</td>
<td>261</td>
</tr>
<tr>
<td>Limiting and preventing leakage.</td>
<td>262</td>
</tr>
<tr>
<td>Color management.</td>
<td>265</td>
</tr>
<tr>
<td>Understanding color management.</td>
<td>265</td>
</tr>
<tr>
<td>Specifying the default RGB color profile.</td>
<td>268</td>
</tr>
<tr>
<td>Embedding color profiles when saving files.</td>
<td>269</td>
</tr>
<tr>
<td>Specifying the default CMYK color profile for converting CMYK images to RGB.</td>
<td>269</td>
</tr>
<tr>
<td>Previewing and soft-proofing color profiles.</td>
<td>270</td>
</tr>
<tr>
<td>Assigning or removing color profiles.</td>
<td>271</td>
</tr>
<tr>
<td>Converting color profiles.</td>
<td>271</td>
</tr>
<tr>
<td>Working with color profile policies.</td>
<td>272</td>
</tr>
<tr>
<td>Working with presets.</td>
<td>273</td>
</tr>
</tbody>
</table>
Correcting and adjusting colors

Correcting colors using curves

Adjusting brightness and contrast

Using the curve to correct colors

Drawing freehand curves to adjust colors

Specifying the curve values to adjust colors

Adjusting hue, saturation, and value

Adjusting selected colors

Equalizing images

Matching color and brightness across images

Inverting colors

Posterizing an image

Applying video legal colors

Dodging and burning

Libraries

Importing and exporting libraries

Creating and removing libraries

Modifying the display of media panels

Moving, renaming, and deleting library resources

Restoring default libraries

Selecting, managing, and creating brushes

Understanding brushes

Searching and selecting brushes

Acquiring brushes

Setting basic brush attributes

Working with brushes using the property bars

Renaming brush categories and variants

Saving and deleting brush variants

Restoring default brush variants
### Exploring brush categories
- Acrylics and Gouache
- Airbrushes
- Artists’ Favorites
- Artists’ Oils
- Audio Expression
- Blenders
- Chalk, Pastel, and Crayons
- Cloners
- Dab Stencils
- Digital Watercolor
- Dynamic Speckles
- Erasers
- F-X
- Glazing brushes
- Image Hose
- Impasto
- Liquid Ink
- Markers
- Oils
- Palette Knives and Sponges
- Particles
- Pattern Pens
- Pens and pencils
- Real Watercolor
Real Wet Oil ...................................................................................................................................................................................... 353
Selection brushes................................................................................................................................................................................354
Simple................................................................................................................................................................................................ 355
Smart Strokes..................................................................................................................................................................................... 355
Sumi-e................................................................................................................................................................................................ 357
Texture brushes...................................................................................................................................................................................358
Thick Paint..........................................................................................................................................................................................361
Watercolor..........................................................................................................................................................................................363

Exploring brush categories in the Natural Media Brushes library ......................................................................................................365
HARD MEDIA - Pencils.......................................................................................................................................................................365
HARD MEDIA - Charcoal................................................................................................................................................................... 366
HARD MEDIA - Conte........................................................................................................................................................................366
HARD MEDIA - Pastels.......................................................................................................................................................................366
INK - Pens......................................................................................................................................................................................... 367
INK - Markers.................................................................................................................................................................................... 367
PAINT - Oils....................................................................................................................................................................................... 368
PAINT - Acrylics................................................................................................................................................................................. 368
PAINT - Glazing................................................................................................................................................................................. 368
REFINING - Blenders..........................................................................................................................................................................369
REFINING - Erasers...........................................................................................................................................................................369
PAINT - Airbrushes.............................................................................................................................................................................369
PAINT - Watercolor...........................................................................................................................................................................370

Adjusting brushes with brush controls............................................................................................................................................371
Exploring Brush Controls...................................................................................................................................................................372
Expression settings..............................................................................................................................................................................373
Audio Expression................................................................................................................................................................................ 374
Previewing brushstrokes and brush dabs.........................................................................................................................................376
Calibrating brush variants.................................................................................................................................................................377
General controls..................................................................................................................................................................................378
General controls: Dab types................................................................................................................................................................. 378
General controls: Stroke types............................................................................................................................................................ 382
General controls: Methods and subcategories.................................................................................................................................. 383
General controls: Source...................................................................................................................................................................... 387
Performance controls.......................................................................................................................................................................... 387
Opacity controls.................................................................................................................................................................................. 388
Grain controls....................................................................................................................................................................................... 390
Stroke Attributes controls...................................................................................................................................................................... 392
Size controls........................................................................................................................................................................................... 394
Angle controls....................................................................................................................................................................................... 397
Spacing controls.................................................................................................................................................................................... 400
Changing dab profiles.......................................................................................................................................................................... 401
Jitter controls....................................................................................................................................................................................... 403
Real Watercolor controls....................................................................................................................................................................... 405
Real Wet Oil controls............................................................................................................................................................................. 408
Computed Circular controls................................................................................................................................................................. 413
Hard Media controls............................................................................................................................................................................. 413
Bristle controls....................................................................................................................................................................................... 413
RealBristle controls................................................................................................................................................................................ 414
Static Bristle controls........................................................................................................................................................................... 414
Airbrush controls.................................................................................................................................................................................. 416
Artists’ Oils controls................................................................................................................................................................................ 419
Impasto controls.................................................................................................................................................................................... 421
Digital Watercolor controls................................................................................................................................................................. 421
Water controls.......................................................................................................................................................................................... 421
Liquid Ink controls.................................................................................................................................................................................. 425
Stroke Jitter controls............................................................................................................................................................................. 430
Blending controls.................................................................................................................................................................................... 431
Mouse controls...................................................................................................................................................................................... 434
Smoothing controls................................................................................................................................................................................ 435
Image Hose controls............................................................................................................................................................................. 436
Using focus and esoterica effects........................................................................................................................................651

Applying Smart Blur..................................................................................................................................................651
Applying Camera Motion Blur.....................................................................................................................................652
Applying Depth of Field................................................................................................................................................653
Applying Glass Distortion........................................................................................................................................655
Applying Motion Blur..................................................................................................................................................657
Sharpening focus........................................................................................................................................................658
Softening focus..........................................................................................................................................................659
Applying Zoom Blur....................................................................................................................................................660
Applying Marbling.......................................................................................................................................................660
Automatically cloning an image..................................................................................................................................662
Applying the Auto Van Gogh effect..........................................................................................................................663
Applying Blobs..........................................................................................................................................................664
Creating custom tiles....................................................................................................................................................665
Applying Grid Paper....................................................................................................................................................668
Applying Growth effects..........................................................................................................................................668
Applying Highpass.......................................................................................................................................................669
Applying the Maze effect........................................................................................................................................670
Placing elements.........................................................................................................................................................671
Applying the Pop Art Fill effect..................................................................................................................................672

Using lighting and surface texture effects...............................................................................................................675

Applying preset lighting effects..................................................................................................................................676
Adding, deleting, and repositioning lights..................................................................................................................676
Adjusting light properties........................................................................................................................................677
Using paper to create texture................................................................................................................................678
Using 3D brushstrokes to create texture.....................................................................................................................679
Using image luminance to create texture..................................................................................................................680
Using clone source or pattern luminance to create texture......................................................................................680
Creating embossed effects........................................................................................................................................681
Using channels and layer masks to create texture......................................................................................................682
Creating reflection maps....................................................................................................................................................................683
Adjusting texture lighting................................................................................................................................................................. 684
Apply Surface Texture controls..........................................................................................................................................................685
Applying the Apply Screen effect................................................................................................................................................... 686
Applying the Color Overlay effect................................................................................................................................................... 687
Applying the Dye Concentration effect..............................................................................................................................................689
Applying the Express Texture effect................................................................................................................................................... 691
Applying a warp effect......................................................................................................................................................................692
Applying the Woodcut effect........................................................................................................................................................... 694
Applying the Distress effect...............................................................................................................................................................696
Applying the Serigraphy effect.......................................................................................................................................................... 697
Applying the Sketch effect................................................................................................................................................................ 698

Dynamic Plug-ins............................................................................................................................................................................... 701
Getting started with dynamic plug-ins.............................................................................................................................................. 702
Modifying and deleting dynamic layers............................................................................................................................................ 702
Converting dynamic layers................................................................................................................................................................702
Applying the Brightness and Contrast dynamic plug-in..................................................................................................................... 703
Applying the Burn dynamic plug-in...............................................................................................................................................703
Applying the Tear dynamic plug-in....................................................................................................................................................705
Applying the Bevel World dynamic plug-in....................................................................................................................................706
Applying the Equalize dynamic plug-in............................................................................................................................................707
Applying the Glass Distortion dynamic plug-in... ................................................................................................................................ 708
Applying the Kaleidoscope dynamic plug-in... ................................................................................................................................ 710
Applying the Liquid Lens dynamic plug-in.........................................................................................................................................711
Applying the Liquid Metal dynamic plug-in.......................................................................................................................................714
Applying the Posterize dynamic plug-in.............................................................................................................................................721

Patterns..............................................................................................................................................................................................723
Applying pattern fills......................................................................................................................................................................... 723
Painting with patterns......................................................................................................................................................................725
Creating and editing patterns............................................................................................................................................................726
Creating seamless patterns................................................................................................................................................................ 729
Creating fractal patterns....................................................................................................................................................................731

Gradients........................................................................................................................................................................................... 735
Applying gradients............................................................................................................................................................................. 737
Editing gradients................................................................................................................................................................................ 740
Applying paint effects to gradients....................................................................................................................................................744
Creating gradients.............................................................................................................................................................................. 746
Replacing image colors with gradient colors.................................................................................................................................... 749

Mosaics and tessellations................................................................................................................................................................. 751
Creating a mosaic............................................................................................................................................................................. 752
Selecting and removing tiles.............................................................................................................................................................754
Specifying tile and grout color.......................................................................................................................................................... 755
Adjusting mosaic tile dimensions and randomness............................................................................................................................756
Filling an area with tiles.................................................................................................................................................................... 759
Creating 3D tiles................................................................................................................................................................................760
Re-rendering mosaic tiles...................................................................................................................................................................761
Stroking and filling a selection with mosaic tiles................................................................................................................................ 761
Adding mosaic effects to an image..................................................................................................................................................762
Creating tessellations.......................................................................................................................................................................763

Weaves...............................................................................................................................................................................................767
Applying weaves.................................................................................................................................................................................767
Editing and saving weaves...............................................................................................................................................................768
Creating weave patterns....................................................................................................................................................................770
Using the Edit Weave dialog box.......................................................................................................................................................770
Defining warp and weft expressions..............................................................................................................................................771
Defining warp and weft color expressions.....................................................................................................................................773
Designing the tie-up............................................................................................................................................................................774
Reference: Expression operators.........................................................................................................................................................776
Shapes

Getting started with shapes

Drawing shapes

Drawing lines and curves

Setting preferences for drawing shapes

Selecting a shape

Modifying shape outlines and fills

Adding, deleting, and moving anchor points

Adjusting curvature

Cutting and joining shape segments

Converting shapes to image layers

Converting selections to shapes

Resizing, rotating, skewing, and flipping shapes

Duplicating shapes

Combining shapes

Blending shapes

Saving a shape outline as a selection

Exporting Adobe Illustrator shapes

Adding text

Adding text to images

Formatting text

Aligning text

Adjusting text kerning and leading

Stretching, rotating, and skewing text

Adding drop shadows to text

Applying effects to text

Applying curves to text

Converting text layers

Dropping text
Using scripts to automate tasks....................................................................................................................................................... 831
Getting started with scripts............................................................................................................................................................ 831
Displaying the Scripts panel........................................................................................................................................................... 832
Recording and playing scripts.......................................................................................................................................................... 832
Enabling and playing background scripts...................................................................................................................................... 834
Creating resolution-independent scripts.......................................................................................................................................... 834
Editing, renaming, and deleting scripts........................................................................................................................................ 835
Converting scripts to movies............................................................................................................................................................ 836
Importing and exporting scripts....................................................................................................................................................... 837
Importing and exporting script libraries.......................................................................................................................................... 837

Working with animation and digital videos........................................................................................................................................ 815
Choosing an animation workflow........................................................................................................................................................... 815
Creating frame-by-frame animation.................................................................................................................................................... 817
Opening a Corel Painter movie............................................................................................................................................................. 818
Importing QuickTime and AVI files................................................................................................................................................... 819
Selecting movie frames....................................................................................................................................................................... 819
Editing frame content.......................................................................................................................................................................... 819
Applying effects to a single frame....................................................................................................................................................... 820
Previewing animations........................................................................................................................................................................... 820
Using onion skinning........................................................................................................................................................................... 821
Animating with layers........................................................................................................................................................................... 821
Adding, deleting, and erasing frames.................................................................................................................................................. 822
Repeating frames.................................................................................................................................................................................. 822
Inserting movies................................................................................................................................................................................... 823
Rotoscoping.......................................................................................................................................................................................... 824
Applying scripts to movies................................................................................................................................................................... 824
Exporting movies as QuickTime......................................................................................................................................................... 825
Exporting movies as AVI....................................................................................................................................................................... 826
Importing and exporting numbered files........................................................................................................................................... 827
Exporting animated GIFs...................................................................................................................................................................... 828

Importing and exporting script libraries.......................................................................................................................................... 837
Displaying the Scripts panel............................................................................................................................................................... 832
Recording and playing scripts............................................................................................................................................................ 832
Enabling and playing background scripts...................................................................................................................................... 834
Creating resolution-independent scripts.......................................................................................................................................... 834
Editing, renaming, and deleting scripts........................................................................................................................................ 835
Converting scripts to movies............................................................................................................................................................ 836
Importing and exporting scripts....................................................................................................................................................... 837
Importing and exporting script libraries.......................................................................................................................................... 837
Creating and deleting script libraries................................................................. 838

**Printing images**........................................................................................................ 839
  Printing basics............................................................................................................. 839
  Printing images.......................................................................................................... 840
  Saving files in EPS format for printing...................................................................... 841
  Printing composite images.......................................................................................... 842
  Printing shapes........................................................................................................... 842

**Notes for users of Adobe Photoshop**........................................................................ 845
  Comparing terminology in Corel Painter and Adobe Photoshop............................... 845
  Comparing tools in Corel Painter and Adobe Photoshop........................................... 846
  Frequently asked questions from users of Adobe Photoshop...................................... 847

**Setting preferences**.................................................................................................. 849
  General preferences..................................................................................................... 849
  Brush cursor preferences............................................................................................ 851
  Interface preferences.................................................................................................. 852
  Performance preferences............................................................................................ 854
  Shapes preferences...................................................................................................... 855
  Cloning preferences.................................................................................................... 856
  Tablet preferences....................................................................................................... 857
  Connections preferences............................................................................................ 857

**Web**.................................................................................................................................. 859
  Choosing web-safe colors........................................................................................ 859
  Posterizing using color sets...................................................................................... 859
  Choosing web-friendly brushes............................................................................... 860
  Creating transparent GIFs........................................................................................ 861
  Reducing the number of colors in GIF files............................................................. 862
  Creating image maps.................................................................................................. 863
  Creating server-side image maps............................................................................. 865
Welcome to Corel Painter

Corel® Painter® 2020 is the ultimate digital art studio. Its inventive drawing tools, realistic brushes, cloning capabilities, and customizable features let you expand your creative output in exciting new ways. When you use the pressure-sensitive brushes of Corel Painter, they become fluid extensions of your hand, so the resulting brushstrokes are unrivaled in texture and precision. What’s more, features such as the ability to build your own Natural-Media® brushes and customize how brushes interact with the canvas give you countless ways to develop your artistic ideas. Corel Painter takes you far beyond what’s possible in a traditional art environment.

This section contains the following topics:

• “Using the documentation” (page 23)
• “Adjusting the Help window text size” (page 26)
• “Hints and tooltips” (page 26)
• “Welcome Screen” (page 27)
• “Additional resources” (page 28)
• “Registration” (page 28)
• “Feedback” (page 28)
• “About Corel Corporation” (page 28)

Using the documentation

You can learn to use the product in various ways: by accessing the Help, Hints, and tooltips; by reading the Quick Start Guide; by viewing video tutorials, and by exploring the resources on the Corel Painter website (www.painterartist.com). You can also check the Readme file (readme.html), which is available at the root of the DVD.

Server-based Help (Windows)

The server-based Help gives you access to a full range of up-to-date topics in a searchable format. You need to have an active internet connection to access the server-based help.

User Guide PDF

If you often work offline, you can download the Corel Painter 2020 User Guide, which provides all Help topics in a print-friendly PDF file.

Quick Start Guide

The Introduction to Corel Painter 2020 Guide provides an overview of the most common product features and workflows, helping you get started quickly with the application. This guide also includes information about new features to introduce upgrading users to Corel Painter 2020.
Video learning resources

You can access video learning resources from within the help. The video tutorials show you how to use various brush technologies, such as Thick Paint, Drip and Liquid, Dab Stencils, Selection brushes, Texture brushes, and Glazing brushes and help you get the most out of features such as image cloning, gradients, texture synthesis, and more. Whether you are a new or long-time user, you will find useful tips to boost your productivity and expand your experience. Please note that closed captions are available only in some languages.

Documentation conventions

The following table describes the conventions used in the Help.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>macOS and Windows commands</td>
<td>Commands for macOS and Windows sometimes appear within the same procedural step, with the operating systems specified in parentheses.</td>
<td>Hold down Command (macOS) or Ctrl (Windows).</td>
</tr>
<tr>
<td>Modifier keys (Command, Option, Ctrl, Alt)</td>
<td>Names of modifier keys for macOS and Windows sometimes appear within the same procedural step, with the operating systems specified in parentheses.</td>
<td>Command + I (macOS) or Ctrl + I (Windows)</td>
</tr>
<tr>
<td>Menu commands (Choose X menu ➜ menu item)</td>
<td>You choose a menu name by clicking it, and then you click to choose a menu item from the list.</td>
<td>Choose File ➜ Quick Clone</td>
</tr>
<tr>
<td>Header bar</td>
<td>A header bar is located at the top or side of some workspace components, such as the toolbox, property bar, and panels.</td>
<td></td>
</tr>
<tr>
<td>Panel tab</td>
<td>The panel tab appears at the top of a panel. You can click a panel tab to expand that panel.</td>
<td></td>
</tr>
<tr>
<td>Panel options menu</td>
<td>Clicking the panel options menu button displays a pop-up menu with additional commands.</td>
<td></td>
</tr>
<tr>
<td>Convention</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>Flyout</td>
<td>Flyouts are containers shared by certain tools in the toolbox. You can open a flyout by clicking and holding down the tool on the flyout that is displayed.</td>
<td>By clicking and holding down the Layer Adjuster tool in the toolbox, you can display a flyout that includes the Transform tool.</td>
</tr>
</tbody>
</table>

- A note contains information that is important to the steps that precede it. Often, a note describes conditions under which the procedure can be performed. This command is available only if you have turned off a selection.

- A tip contains suggestions related to the procedure. Some tips present alternative methods of performing the steps, or information about other benefits and uses of the procedure. You can choose a brush category and variant in the main application or in the Brush library panel.

To access the Help

- Choose Help ➤ Corel Painter 2020 Help (macOS) or Help Topics (Windows).

To use the Help

1. Choose Help ➤ Corel Painter 2020 Help (macOS) or Help topics (Windows).
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse through Help topics</td>
<td>Click the Contents tab, and click a topic in the left pane.</td>
</tr>
<tr>
<td>Use the index</td>
<td>Click the Index tab, and scroll through the entries to find a topic.</td>
</tr>
<tr>
<td>Search the full text of the Help</td>
<td>(macOS) Type a word or phrase in the Search box in the upper-right corner of the Help window, and press Return.</td>
</tr>
</tbody>
</table>

(Windows) Click the Search tab, type a word or phrase in the box, and click Go. Note that the search feature does not support quotation marks. If you enclose the word or expression in quotation marks, the search will not produce any results.

To access the Corel Painter 2020 User Guide

- Choose Help ➤ User Guide.
To access the Introduction to Corel Painter 2020 Guide
• Choose Help ▶ Introduction to Corel Painter 2020 (PDF).

Adjusting the Help window text size
You can adjust the size of the text that displays in the Help window by adjusting the zoom level in your browser. Adjusting the zoom level quickly increases the size of all web page elements, including text and images. You can adjust zoom levels in Internet Explorer, Chrome, Firefox, and Apple Help. Some browsers may offer additional controls for customizing the font size of the display text. For more information, see the Help for your browser.

To adjust the size of text in Firefox and Chrome
• In the browser, do one of the following:
  • To increase the zoom level, press Ctrl and + (Windows), or Command and + (macOS).
  • To decrease the zoom level, press Ctrl and - (Windows), or Command and - (macOS).

To adjust the size of text in Internet Explorer
• In the Internet Explorer browser, do one of the following:
  • To increase the zoom level, press Ctrl and +.
  • To decrease the zoom level, press Ctrl and -.

To adjust the size of text in Apple Help
• In the Apple Help viewer, do one of the following:
  • To increase the zoom level, press Command and +.
  • To decrease the zoom level, press Command and -.

Hints and tooltips
Hints can help you get started quickly with Painter brushes and tools. Specific hints are displayed if the active brush uses one of the following brush technologies: Watercolor, Real Watercolor, Liquid Ink, Cloner, Particles, Dynamic Speckles, or Impasto. If the active brush uses another brush technology, the Hints panel shows tips about finding and modifying brushes. When you click a tool, the Hints panel shows a description of all tools in the toolbox. All hints include links to relevant Help topics that provide comprehensive information about the corresponding brush features or tools.

Tooltips provide helpful information about application controls when you position the pointer over icons, buttons, and other user interface elements. Some tooltips include illustrations that show the effect of using high and low values of specific settings. You set tooltip preferences to hide illustrations from tooltips, decreasing the space a tooltip takes on screen. You can choose to display the illustrations in tooltips at any time.
To access Hints

* Choose Help › Hints.

To set tooltip preferences

1. Do one of the following:
   * (macOS) Choose Corel Painter 2020 › Preferences › General.
   * (Windows) Choose Edit › Preferences › General.
2. In the Tooltips area, enable one of the following options:
   * Text and images
   * Text only

Welcome Screen

The Welcome Screen appears when you start the application. With the Welcome Screen, you can quickly start or open an image, choose a workspace that suits your needs, access online learning videos, find new brushes and other content online, and get inspired by a gallery of original artwork created with Corel Painter.

To access the Welcome screen

* Click Help › Welcome.

To hide the Welcome screen at startup, in the Welcome screen, hover over the button in the top-right corner, and disable the Show this at startup check box. This check box is not available in trial versions of the product.
To close the Welcome screen
• Press Esc.

Additional resources
You can access additional Corel Painter resources online to learn more about the product and connect with the Corel Painter community.

<table>
<thead>
<tr>
<th>Resources</th>
<th>To access</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corel Painter website</td>
<td><a href="http://www.painterartist.com">http://www.painterartist.com</a></td>
</tr>
<tr>
<td>Corel Painter Tutorials</td>
<td><a href="http://www.youtube.com/user/PainterTutorials">http://www.youtube.com/user/PainterTutorials</a></td>
</tr>
<tr>
<td>Corel Painter on Twitter</td>
<td><a href="http://www.twitter.com/corelpainter">http://www.twitter.com/corelpainter</a></td>
</tr>
<tr>
<td>Corel Painter on Facebook</td>
<td><a href="http://www.facebook.com/corelpainter">http://www.facebook.com/corelpainter</a></td>
</tr>
</tbody>
</table>

Feedback
We value any feedback that you may have about the product or the Help content. To provide feedback about a specific Help topic, scroll to the bottom of any Help topic and click the “Was this page helpful?” link.

Registration
Registering Corel products is important. Registration provides you with timely access to the latest product updates, valuable information about product releases and access to free downloads.

If you skipped the registration process when installing Corel Painter 2020, you can register at www.corel.com/support/register.

About Corel Corporation
Over the years, Corel has brought a spirit of innovation to the development of a range of award-winning products that includes graphics, painting, photo, video and office software. We’ve also earned a reputation for delivering high-quality products that are easy to learn and use, and help people achieve new levels of productivity.

Corel Painter takes you far beyond what’s possible in a traditional art environment. This section contains the following topics:

- “What’s new in this version of Corel Painter” (page 29)
- “What was new in earlier versions of Corel Painter” (page 34)

What’s new in this version of Corel Painter

New! Automatic performance optimization

To help ensure that you have the best digital painting experience, Painter 2020 introduces the Brush Accelerator. This new utility evaluates your system’s processor (CPU), graphics processor (GPU) and memory, and then optimizes application settings to maximize performance. Many Painter brushes can now leverage the computation power of your system’s GPU, using it to deliver faster brushing, as well as smoother document rendering and manipulation. You’ll also get suggestions on how to upgrade system components, as well as recommendations on which brush categories are most compatible with your computer.
The Brush Accelerator evaluates your system and generates a report that lets you view the test results.

The new Performance panel lets you quickly see whether the currently selected brush can take advantage of your system's multi-core processor, AVX2 or GPU. You can use the names of those performance-boosting technologies as search terms to find brushes that leverage them. What’s more, Painter 2020 introduces two new brush categories designed with performance in mind — Fast and Simple and Fast and Ornate.

For more information, see “Evaluating your system and optimizing application settings for Corel Painter” on page 121 and “Performance controls” on page 387.

Enhanced! UI elements

A re-imagined UI helps you work faster and more efficiently by giving you quick access to frequently used options. Revamped property bars, flyouts, and palettes for brushes and tools put the most important controls at your fingertips. Intuitive labeling and grouping of property bar settings reduce the need to open panels, so you have more room to paint. The Library panels have been streamlined to be easier to use and free up screen space when you’re working with papers, patterns, textures and more. When the Brush tool is active, the property bar and Advanced Brush Controls give you a better understanding of the brush shape and the media that you’re using. The Advanced Brush Controls button now also gives quick access to the General panel. What’s more, Perspective Guides and Mirror Painting are accessible in fewer clicks.
Enhanced! Brush visuals

Enhanced dab and stroke previews are great time-savers in Painter 2020. Improved visuals mean you don’t need to hover over brush strokes to get an idea of what they’ll look like, and it’s easier than ever to distinguish between popular dab types. There’s also a new option to display a slimmer, more compact version of the Brush Selector to give you even more painting pixels.

For more information, see “Displaying and customizing the Brush Selector” on page 71.
New! Color selection features

Color-selection controls are more accessible and consistent throughout Painter 2020. Redesigned color ramps in sliders make choosing the perfect color a breeze, and frequently used dialog boxes offer familiar, intuitive color pickers. A new preview takes the guesswork out of how colors will look together by showing you the new and current colors side-by-side. The temporal color selector now offers the ability to clone color, as well as a mode that reconfigures the selector for left-handed artists. You can tailor the Color panel to display only the features you need, giving you more space to paint. In addition, you can open the temporal color selector by double-clicking a swatch in the Color panel. And new harmony options let you choose a color and then use it as the foundation of a set of colors that work well together aesthetically.

For more information, see “Choosing colors from the Color panel” on page 236, “Showing or hiding Color panel components” on page 239, “Using the color selector” on page 239, and “Working with color harmonies” on page 257.
Warm and cold colors are created for vibrant and energetic color schemes. From left to right, the five color swatches of the Complementary harmony are: Main color (1) and its direct complementary color (5); (2), (3), and (4) are a blend of the two complementary colors.

Enhanced! Brush switching and Eraser tool performance

The redesigned Brush Selector bar now includes a button to reactivate your last-used brush, allowing you to rapidly switch between variants. This new feature can also be added to a custom palette or assigned a shortcut key. What’s more, enhancements to Eraser tool provide a smoother, lag-free painting experience and more customization options.

For more information, see “To select the previous brush variant” on page 301.

Enhanced! Layer workflow

Painter 2020 offers a series of advancements to the layer workflow. More frequently used commands have been added to the Options menu in the Layers panel, saving you time. Other enhancements include the ability to lock the canvas, more layer pasting choices, and improved layer collapsing and selection.

For more information, see “Layers” on page 569.
What was new in earlier versions of Corel Painter

This topic describes what was new in earlier versions of Corel Painter.

What was new in Corel Painter 2019

Enhanced! Performance

Thanks to enhanced support for multi-core processors and CPUs that use AVX2 extensions, as well as extensive code optimizations, this is the fastest version of Painter yet. A huge selection of brushes are noticeably faster — some as much as twice as fast. You can also take advantage of faster document rendering when zooming, panning and rotating — up to 50% faster.

New! Dark user interface theme

You can choose a refreshing, professional interface that makes your artwork the focus. We have meticulously transformed the main user interface elements in Corel Painter 2019 to reveal a darker theme that allows the interface to melt away and painting to take center stage. For more information about themes, see “Interface preferences” on page 852.

The dark theme allows the painting to take center stage. Artwork by Pavel Goloviy.
New! Application icons and controls

Corel Painter 2019 delivers a crisper, cleaner and more responsive environment with over 650 redesigned icons that make the application easier on the eyes, simpler to understand, and more efficient to use. Try the new slider functionality using modifier keys to precisely select values. For information about sliders, see “Working with sliders” on page 83.

New! Brushes and patterns

With 36 remarkable new brushes, it’s easier than ever to gain inspiration for fresh creations. Enjoy the new Stamps brush category along with a host of additional brushes that round out popular categories such as Selections, Airbrushes, Blenders, Dab Stencils, Glazing, Real Watercolor, Real Wet Oil, Sargent, and Thick Paint. In addition, there are five new patterns that are custom designed for concept artists and video game designers, but also open a world of creative possibilities for any artist.

The new Stamps brush category includes variants like Atomic (left), Scar (middle), and Tree (right).

Enhanced! Color workflow

Redesigned grabbers in the Color wheel make it easier to see and set colors in the Hue Ring and Saturation/Value Triangle. The new grabbers are also in the Temporal color selector, which can now be pinned so that it’s always at your fingertips. For more information, see “Using the color selector” on page 239.
Enhanced Color wheel selector grabbers help you select colors with ease.

New! Enhanced brush ghost

The Enhanced brush ghost displays a representation of a brush variant when the Brush tool is selected, but not actively painting. The instant you start applying media, the Enhanced brush ghost changes to an icon. This delivers a more responsive creative experience, without any lag time, by using strokes that always track directly beneath your stylus. For more information about brush cursor settings, see “Brush cursor preferences” on page 851.
Enhanced! Windows Multi-touch

Multi-touch enhancements provide a natural sketching and painting experience that you will truly enjoy. Take advantage of a more intuitive way to simultaneously pan, zoom and smoothly rotate your canvas using two fingers on a Windows touch device. To reset your painting view, simply double-tap with two fingers. For more information, see “Multi-touch support” on page 117.

New! Drag to zoom functionality

You can zoom in and out of your document quickly by clicking and dragging with your stylus or mouse. Move to the right to zoom in, and move to the left to zoom out. Holding down the Shift key while clicking and dragging zooms into a specific area of interest. For more information about zoom modes, see “Zooming images” on page 104.

What was new in Corel Painter 2018

Corel Painter 2018 introduced the following features and enhancements, which are also available in Corel Painter 2020.

New! Thick Paint

Thick Paint has brushes inspired by traditional tools that you’d instantly recognize in any art supply store. There are a range of bristle brushes and palette knives carefully crafted to deliver the feel and behavior you’d expect. These new brushes use paint that has pigment and volume that behaves just like real paint. This means you can blend, build up, push, pull and scrape the paint using the pressure, tilt, and rotation of your stylus.

These variants deliver versatile, scalable brush loading, so you can spend more time focusing on your work and less on the UI. Using a quick keyboard shortcut and dragging, you can precisely load the brush on the fly, thanks to a cursor that displays the amount of paint you’ve loaded and the color.
Just like in the real world, you can create strokes that have ridges of paint within. But what really makes the ridging pop, of course, is shadows in the canyons of the stroke. With that in mind, Painter lets you adjust the shadow strength and ambient lighting to get depth in a brushstroke like never before. What’s more, the ability to tweak the transparency of brushstrokes and control how paper texture interacts with the paint opens up a world of creative possibilities.

The Thick Paint property bar offers presets for painting technique, as well as quick access to settings that allow you to prevent the brush from running out of paint and control how new brushstrokes blend with existing ones. This makes it easy to jump in and get stunning results right away. Or if you’d rather tinker and experiment to get a certain look, there are new Thick Paint panels where you can modify controls. For more information, see “Thick Paint” on page 537.

Enhanced! Cloning

A range of cloning enhancements lets photo artists to do more, in less time.

You can increase the sophistication of your photo composites in Painter 2018 with new cloning transparency support. You can use transparent and semi-transparent clone sources when creating a collage, so all elements in a composite interact naturally. And for even more accurate transparency cloning, there’s a precise cloning option that picks up colors from the center of the brush dab.

Photo artists can use a texture as a clone source. Transformations can be applied to texture clone sources, so you can resize and shape them to easily and intuitively craft a composite.

The user interface has been streamlined to simplify switching between clone sources. The revamped cloning controls give you more space to work, but not at the expense of easy access to the settings you need most. All critical cloning controls are easily accessible from a flyout.
on the property bar. Whatever your favorite cloning workflow is, Painter 2018 has you covered. Whether tracing paper or a crosshair cloning
cursor works best for you, the choice is yours.

And when you find or create a clone source that you want to reuse, you can save it with the image as an embedded source or as a texture in
the Texture library so it’s always at your fingertips. There’s also an option that lets you embed a clone source in a document, saving you time
finding the source when you get back to work and simplifying sharing with other photo artists. For more information, see “Image cloning
and sampling” on page 181.

Use cloning techniques to transform your photo into a work of art. Artwork by Bill McEntee

Enhanced! Drip and Liquid brush technologies

Brushes that use the Drip method (all subcategories) or the Plug-in method (Liquid Brush subcategory) are even more versatile in Painter
2018. Take, for example, the Sargent Brush, one of most popular Painter brush variants ever. Loved by artists for its rich brushstrokes, the
Sargent Brush can now be used on an empty layer to blend the currently selected color with an oil-like transparency. Alternatively, you can
use variants that use drip or liquid technologies to pick up color from underlying layers. What’s more, this step forward in brush technology
offers artists of all stripes a range of fresh brushes, opening up a world of possibilities. For more information, see “Drip” on page 385.
New! Texture synthesis

The limitless creative possibilities that made Texture Painting an instant favorite with concept artists and character designers just got even more powerful thanks to the addition of the Synthesis feature. It allows you to capture and synthesize an area of a texture or document and reproduce it on a larger scale, using all the visual elements of the input sample. During the synthesis process, properties of the selected area are randomized, creating a new texture based on settings that you’ve chosen. You can then paint with it to give every texture brushstroke even more depth and detail.

Synthesis gives digital artists of all stripes the ability to create vibrant, one-of-a-kind textures. Because you can also use part of an image, you can use favorite brushstrokes as the DNA of a new texture, offering infinite possibilities. The synthesized texture can then be used just like any other texture or it can be exported to a layer.

And you can fill with texture, whether you created it using the Synthesis feature, imported it to use with a Texture Painting brush, or found it in the Texture library. For more information, see “Creating textures” on page 494.
Corel Painter generates a large texture (left) from a small sample (right) by taking into account its structural content. Image (right) by Henk Dawson

**New! 2.5D Thick Texture brushes**

Concept artists and character designers love Texture Painting for its ability to deliver powerful realism, and Painter 2018 takes the experience to a whole new level. New 2.5D Thick Texture brushes apply strokes that feel like they are jumping off the canvas. Do you need to make a character authentically reptilian? You can paint thick, exotic scales that look like they’re rising off the canvas. Or when you need to make skin more lifelike, Thick Texture brushes let you paint cavernous pores and amplify them by adjusting the directional lighting and appearance of depth. For more information, see “Add depth to a Texture brush” on page 491.
New! Selection Brush tool and Selection brushes

Because selections are critical to so many digital-art workflows, Corel Painter 2018 gives you more choices when you need to isolate an area of an image. How much time could you save if you could create a selection as easily and precisely as you can apply a brushstroke? The new Selection Brush tool lets you do just that. To make it easier to distinguish between selected and protected areas, you can display a color overlay when you apply a stroke. You can fine-tune the overlay to make it suit the document that you’re working in. There’s a new Selection brush category with new variants designed specifically for creating selections when working with a complex shape or image area. There’s also the option of turning any stamp-based brush variant into a selection tool, giving you even more flexibility. What’s more, you can tweak a brush just as if you were using it to paint, then save it as a custom selection variant for reuse. And in response to artist feedback, there are a series of selection improvements in Painter 2018. For more information, see “Selecting areas by painting” on page 622.

Examples of selections (right) created with brushes that use the Selection method. The color overlay (left) that appears as you paint helps to distinguish selected areas from protected areas.

New! Natural Media Brushes library

The new Natural-Media brush library makes it easy for artists transitioning from traditional to digital art. It gives quick, one-stop access to brushes that mimic traditional media, from pencils and pastels to oils and acrylics, and much more. If you’ve used it in the real world, chances are you’ll find the digital equivalent in the Natural-Media brush library. You can access the new collection by opening the Brush Selector and choosing Natural Media Brushes from the Brush Library list box. For more information, see “Exploring brush categories in the Natural Media Brushes library” on page 365.
New! Random grain rotation

Another user request in Painter 2018 is random grain rotation. This new feature slightly rotates the paper grain in each stroke, giving brushstrokes a more natural, organic look. For more information, see “Grain controls” on page 390.

What was new in Corel Painter 2017

Corel Painter 2017 introduced the following features and enhancements, which are also available in Corel Painter 2020.

New! Texture Painting

This groundbreaking new brush category with source-blending technology makes it easy to integrate complex textures into your work. Whether you’re aiming for a look that is more lifelike or one that’s completely futuristic, or you want to make a digital painting look authentically timeworn, Texture Painting offers limitless possibilities.
Texture Painting isn’t simply manipulating a layer’s opacity. It lets you intelligently blend a texture into existing content using a range of stylus expressions, such as pressure. It respects the transparency of the selected texture, giving you full control of when, where, and how much texture is used. You start by choosing or creating a texture and pairing it with brushes designed specifically for adding texture. And by combining Texture brushes, flexible brush customization options, and the ability to capture and import your own textures, you can add any number of surfaces styles to your work. You can even add Dab Stencils, grain, and smudging to the brushes with all the speed, precision and control you expect from Painter. In addition, you can make your own custom textures from scratch or by modifying a preset texture. For more information see “Texture painting” on page 483.

A 3D model is rendered into a 2D bitmap image (left). Texture is added to the image in Corel Painter to give the character more appeal and realism (right). Artwork by Mike Thompson.

New! Interactive Gradient tool

In Corel Painter, getting stunning painted backgrounds is easier than ever with the new Interactive Gradient tool. It lets you quickly create and edit a gradient to give paintings a range of depth and lighting variations. If you’re just starting a new document, you can kick-start things by filling the background with a gradient and experimenting with different preset styles. Or if you have an existing sketch or painting, you can apply and tweak a gradient in context of your work with edit nodes. Corel Painter has a library of gradients to choose from, or you can create your own and save it for reuse. For more information see “Applying gradients” on page 737.
New! Gradient Express Painting

When a blank white canvas is blocking your creativity or you need a back-drop for a new concept design, the new Express Paint feature lets you create stunning gradients in a matter of seconds. The new Express Paint feature allows you to apply a wide variety of painting styles automatically to any gradient, creating the speed and inspiration you need in virtually any composition. For more information, see “Applying paint effects to gradients” on page 744.

New! Dab Stencils

Corel Painter gives artists more power to craft and create expressive, unique brushstrokes. Dab Stencils let you change the brushstroke opacity before you paint, basing it on the active paper, flow map or texture. You can fine-tune exactly how much source texture to reveal as you paint and link Dab Stencils to a variety of real-time stylus input factors. Using them with the new Texture Brush variants gives you even greater control over the look and feel of your brushstrokes. For more information, see “Dab Stencil controls” on page 445.
New! Glazing Brushes

Some of the best Painter developments have been the result of user suggestions. Here’s another one — Glazing Brushes. They let you control the evolution of your painting using velvety, translucent paint transitions just like the Renaissance masters. Glazing Brushes deliver stroke-level opacity, so the paint of each brushstroke is applied independently. The paint that each dab deposits on the canvas builds up smoothly from a minimum to a maximum. This creates a smooth blend between colors, with no unwanted colors where dabs overlap. You’ll really see Glazing Brushes at their best when you fluctuate stylus pressure in a single brushstroke. For more information, see “Glazing controls” on page 450.
Glazing brushes were used in this artwork by Héctor Sevilla Luján.

Enhanced! Dropper Tool

Corel Painter makes it easier than ever to sample color. Sometimes what appears to be a solid-colored area is actually subtly shaded or dithered, so what you see onscreen isn’t what you get when you sample a single pixel. Now you can get the color that you’re seeing with new Dropper tool options that let you average the colors of pixels in larger sample areas, ranging from 3 × 3 to 101 × 101 pixels. What’s more, you can sample a color from the active layer or from all visible layers. For more information, see “Sampling colors from images” on page 244.

New! Palette Drawers

Having the tools that you need right at your fingertips isn’t only important for your productivity, it’s critical for your creativity. That’s why Corel Painter introduces Palette Drawers. This new workflow enhancement strikes the perfect balance between uncluttering your workspace and keeping essential tools handy by letting you combine panels and custom palettes in a convenient grouping — for a particular workflow or project — so the controls and settings are just a click away. And when you’re not using a Palette Drawer, it collapses, freeing up your work area. For more information, see “Rearranging panels and palettes” on page 76.

Enhanced! Property bars

Optimizing brush and tool settings is important. But time spent tweaking controls is time not spent painting. That's why the property bars have been enhanced to make it easier to adjust brushes. For example, when the Brush tool is active, the enhanced property bar gives you quick access to a range of relevant brush-related panels, saving you time clicking through menus. It also lets you choose new dab profiles on the fly, select media like paper, and view brushstroke info. There’s also a new Extended property bar that gives quick access to even more settings. For more information, see “Working with brushes using the property bars” on page 306.
You can access brush controls quickly from the property bar (left) and the extended property bar (right). This example shows the property bar for a selected Particle brush with the Size flyout open and the extended property bar with the Dab Options flyout open.

Enhanced! Brush Selector panel

Corel Painter gives you quicker and easier access to one of the things that makes Painter an industry leader in digital painting — our unrivaled selection of brushes. To that end, you can now display the Brush Selector as a panel. That way, your recently used brush variants are at your fingertips, the entire Brush Library is readily accessible, and you can position it wherever it suits your workflow. And the latest brush packs are available from directly within the Brush Selector. For more information, see “Displaying and customizing the Brush Selector” on page 71.
Enhanced! Artists’ Layouts

Just getting started with a new project in concept art, fine art, illustration, photo-art or manga? This collection of pre-defined user-interface arrangements is designed to kick-start a variety of digital art workflows by displaying only the relevant palettes and tools. There’s even one that displays only minimal UI, freeing up space for tablet users. You can also choose the two workspace layouts that you use most often and quickly switch between them to suit the current task or the display mode of your device using the Quick Switch feature. For more information, see “Choosing a workspace layout” on page 61.

What was new in Corel Painter 2016

Corel Painter 2016 introduced the following features and enhancements, which are also available in Corel Painter 2020.

Rotatable media

In Corel Painter 2016, you can change the angle of paper textures and flow maps to get an unprecedented variety in the look of your brushstrokes. For more information see “Rotating paper texture” on page 168 and “To customize a flow map” on page 509.
Default-settings restoration

Corel Painter 2016 makes it easier to preserve custom content when you reset the application to its factory settings. Now when you restore default settings, you can maintain custom brushes and palettes, paper textures, nozzles, scripts and more. In previous versions, retaining any customizations required exporting libraries, restoring default settings, and then importing the libraries. For more information, see “Restoring the default Corel Painter settings” on page 89.

Dynamic Speckles

This feature combines Particle System physics and brush-thickness control linked to your touch, allowing you to create luscious Natural-Media brushstrokes or progressive-looking Pollock splatters. You can use this feature with select Bristle, RealBristle and Particle brushes, so you can take full advantage of those revolutionary, Painter-exclusive technologies. For more information, see “Dynamic Speckles controls” on page 443.

Audio Expression

Corel Painter 2016 lets you use an audio input device, such as a microphone, or internal audio to modify the look and feel of any brush. For example, your brushstrokes may change their appearance in synch with streaming music. Audio Expression allows you to link a variety of brush controls to audio input. In addition, you can adjust the strength of an audio signal, controlling its impact on a brush. For example, if you link brush size to quiet audio, increasing the strength will result in wider brushstrokes. Conversely, if the audio is loud, decreasing the strength will result in narrower brushstrokes. In addition, you can set the range of the audio expression to achieve a wider range of brushstroke variation (for example, minimum to maximum brushstroke width) regardless of whether the audio is consistently strong, low, or varies. For more information, see “Audio Expression” on page 374.

Document Views

Whether you are working on a project, showing your work, or demonstrating a technique, Corel Painter 2016 makes it even easier to switch between document views. You can switch document views from the toolbox, the Window menu, and by using keyboard shortcuts. The Default view shows all the open documents together with commonly used application controls while the Single Document view lets you focus on the active document. The Presentation Mode hides the menu bar and the taskbar of the operating system, leaving only essential controls. For more information, see “Switching document views” on page 101.
Brush Hints

Depending on the brush type you are currently working with, context-sensitive brush hints (Help ➤ Hints) provide useful tips about brush technologies. It’s a great way to discover different ways you can take advantage of a variety of unique Corel Painter features, including Particles, Watercolor brushes, Liquid Ink, Cloner, Impasto, and the new Dynamic Speckles.

Visual tooltips

Some tooltips include illustrations that show the effect of using high and low values of specific settings.

Adobe® Photoshop® brush file import

With Corel Painter 2016, you can import the brush stamps of pixel-based Adobe Photoshop brushes stored in Adobe Brush Resource (ABR) files. These files contain a collection of Adobe Photoshop brushes, including shape, texture, dynamics, and other brush information. All
other brush attributes specified in the ABR files are not imported, but can be fully customized in Corel Painter. For more information, see “Importing Photoshop brush images” on page 314.

![Image](image.png)

Each imported brush stamp appears as a new brush variant.

**Custom content sharing**

Corel Painter 2016 simplifies sharing content saved in a custom palette. When you save a custom palette as a Painter Custom Toolbox (BOX) file, all custom brushes, papers, patterns and flow maps in the palette are saved with the file.

![Image](image.png)

You can share content saved to a custom palette.

**Welcome Screen**

With the Welcome Screen, you can quickly start or open an image, choose a workspace that suits your needs, access online learning videos, find new brushes and other content online, and get inspired by a gallery of original artwork created with Corel Painter. The Welcome Screen appears when you start the application, and you can also access it by clicking Help ▶ Welcome.

**Special media brushes**

Corel Painter 2016 offers additional dab types, which are methods for applying media to the canvas. The new dab types use both Particles and Liquid Ink or Watercolor dabs. These combination dab types include: Liquid Ink Gravity Particles, Liquid Ink Flow Particles, Liquid Ink Spring Particles, Watercolor Gravity Particles, Watercolor Flow Particles, and Watercolor Spring Particles.
Layer blending

Whether you are painting with a single color or blending two or more colors on a layer, the Enhanced Layer Blending option can help you produce brushstrokes without white fringes. For more information, see “Blending controls” on page 431.

![Brushstrokes without (left) and with (right) Enhanced Layer Blending](image)

What was new in Corel Painter 2015

Corel Painter 2015 introduced the following features and enhancements, which are also available in Corel Painter 2020.

**Revolutionary digital brushes**

**Particle Brushes**

These new physics-inspired brushes produce rich, chaotic strokes by emitting particles from a central point that create lines and patterns as they move across the canvas. This revolutionary brush category allows a wide variety of artists to push their creative visions further, whether in photo art, illustration, concept art, traditional art, and more.

For more information, see “Particle brushes” on page 467.

**Jitter Smoothing**

Corel Painter X3 saw the introduction of Universal Jitter, which allows you to add randomness to your brushstrokes by integrating the Jitter expression in a range of brush controls. The addition of Jitter Smoothing helps you give your brushstrokes an even more natural, organic look.
Enhanced speed and performance

Native 64-bit application for macOS

Users on the macOS will notice extended processing power right away, especially during operations that require big data transfers, such as opening files, switching clone sources, working with multiple layers, using large documents and more.

Enhanced cross-platform performance

With the latest round of CPU performance optimizations, brushes perform faster, so you can concentrate on your art and forget about technology.

Enhanced real-time effect preview

You can now preview effects in real-time on the canvas so you instantly get an idea how the whole painting will look.

Enhanced brush tracking

Because each artist uses a different strength or pressure level in a stroke, the enhanced Brush Tracking utility helps calculate the appropriate settings for pressure and velocity. The new visual power curve helps you control universal application pressure-sensitive memory and instantly apply the settings to the current brush variant. There are default pressure curves to choose from, or you can tweak the curve and save it as a preset. You can also make practice strokes with a variant on the canvas while you’re calibrating the brush tracking so you can draw from with the most realistic, accurate brushstroke information possible. For more information, see “Brush tracking and calibration” on page 146.

A fully responsive experience

Custom user-interface palette arrangements

Inspired by Painter artists, this collection of new pre-defined user-interface arrangements is designed to kick-start a variety of digital-art workflows by displaying only the relevant palettes and tools. There’s one for illustrating, creating photo art, and getting started with the revolutionary new Particle brushes. There’s even one that displays only minimal UI, freeing up space for tablet users. For more information, see “Choosing a workspace layout” on page 61.

Fresh new content

You can add an extra special touch to your artwork with new, freshly inspirational papers, nozzles, images, patterns, weaves, gradients and more. Some of the updates are designed specifically for different types of digital artists, so whether you’re an illustrator or photo artist, you can be sure to find compelling content to work with.

Mobile art that moves you

Real-Time Stylus and Windows Tablet PC support

You can combine your Tablet PC with Windows Real-Time Stylus support to capture whatever inspires you on the fly. Support for the Windows Real-Time Stylus delivers truly responsive pressure-sensitivity, and depending on the device, tilt. What’s more, there’s...
no stylus driver to install, so you can use Corel Painter right away. For more information, see “Support for tablets and other devices” on page 117.

Painter Mobile for Android

The Painter Mobile for Android app gives you the ability to paint anywhere, anytime. When it's time to finalize your work, you can import it directly into Corel Painter to add professional finishing touches.

Particle brushes were used to create the sparks and wisps of smoke in this image. Artwork by Don Seegmiller

Angle Jitter applied to a brushstroke without Jitter Smoothing (top) and with Jitter Smoothing (bottom).
Real-Time Stylus and Windows Tablet PC support let you create art on the go.
Workspace tour

The Corel Painter workspace has been designed to give you easy access to tools, effects, commands, and features. The workspace is organized by using a series of menus, selectors, panels, and interactive palettes.

This section contains the following topics:
- “Corel Painter terms” (page 57)
- “Exploring the Document window” (page 59)
- “Choosing a workspace layout” (page 61)
- “Exploring the toolbox” (page 62)
- “Displaying the toolbox” (page 67)
- “Displaying the property bars” (page 68)
- “Exploring the Navigator panel” (page 70)
- “Displaying and customizing the Brush Selector” (page 71)
- “Displaying the command bar” (page 76)
- “Rearranging panels and palettes” (page 76)
- “Exploring panels” (page 80)
- “Working with sliders” (page 83)
- “Creating and modifying custom palettes” (page 84)
- “Renaming and deleting custom palettes” (page 85)
- “Saving, exporting, and importing custom palettes” (page 86)
- “Working with libraries” (page 87)
- “Creating, importing, exporting, and deleting workspaces” (page 88)
- “Restoring the default Corel Painter settings” (page 89)

Corel Painter terms

Before you get started with Corel Painter, you should be familiar with the following terms.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canvas</td>
<td>The canvas is the rectangular work area inside the document window. In addition, the canvas serves as the background layer of</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pixels-per-inch (ppi)</td>
<td>The default unit of measurement for resolution in Corel Painter. Pixels-per-inch (ppi) is equivalent to dots per inch (dpi).</td>
</tr>
<tr>
<td>Layer</td>
<td>Layers are independent image elements that stack on top of the canvas. You can manipulate the content of a layer without altering the canvas. Layers let you experiment with different compositions and effects without risking an unwanted, permanent edit.</td>
</tr>
<tr>
<td>Brush category</td>
<td>Brush categories are groups of similar brushes and media.</td>
</tr>
<tr>
<td>Brush variant</td>
<td>Brush variants are specific brushes and brush settings within a brush category.</td>
</tr>
<tr>
<td>Dab types</td>
<td>The dab type controls the way a brush applies color to the painting surface. In Corel Painter, there are numerous dab types that fall under two dab type groups: rendered and dab-based, also known as pixel-based.</td>
</tr>
<tr>
<td>Rendered dab type</td>
<td>The rendered dab type produces continuous, smooth-edged strokes. For example, Camel Hair and Airbrush use the rendered dab type.</td>
</tr>
<tr>
<td>Dab-based dab type</td>
<td>The dab-based dab types produce brushstrokes that are made up of tiny dabs of color that are closely spaced together so they appear smooth.</td>
</tr>
<tr>
<td>Panel</td>
<td>A panel is a single tabbed container that displays commands, controls, and settings for a specific feature. Panels reside in a palette. For example, the Color panel contains controls that allow you to choose colors.</td>
</tr>
<tr>
<td>Palette</td>
<td>A palette is a container for one or multiple panels.</td>
</tr>
<tr>
<td>Paper</td>
<td>Paper allows you to control both the color and texture of the canvas.</td>
</tr>
<tr>
<td>Clone source</td>
<td>The clone source determines the image, or image area, that you want to reproduce through cloning. A document can include multiple clone sources.</td>
</tr>
<tr>
<td>Clone document</td>
<td>The clone document is created by copying the original clone source image which allows you to reproduce a painterly version of the source image. A copy of the clone source is embedded in the clone.</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Document</td>
<td>In addition, you can add multiple clone sources to a clone document.</td>
</tr>
<tr>
<td>Image sampling</td>
<td>Image sampling lets you copy part of one image and reuse it elsewhere in the image or in another image. You can sample an image by using the <strong>Rubber Stamp</strong> tool, a <strong>Cloner</strong> brush that supports offset sampling, or a <strong>Cloner</strong> brush that supports multi-point sampling. Sampling is similar to cloning, but, unlike cloning, it does not create a separate document that stores clone sources.</td>
</tr>
<tr>
<td>Composite method</td>
<td>A composite method, which is similar to blend modes in Adobe Photoshop, lets you change how a layer blends with an underlying image.</td>
</tr>
</tbody>
</table>

**Exploring the Document window**

The document window is the area outside the canvas that is bordered by scroll bars and application controls.
Circled numbers correspond to the numbers in the following table, which describes the main components of the application window.

<table>
<thead>
<tr>
<th>Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Menu bar</td>
<td>Lets you access tools and features using pull-down menu options</td>
</tr>
<tr>
<td>2. Brush Selector bar</td>
<td>Lets you open the Brush library panel to choose a brush category and variant. It also allows you to open and manage brush libraries.</td>
</tr>
</tbody>
</table>
### Part Description

3. **Property bar**
   Displays commands that relate to the active tool or object. For example, when the **Fill** tool is active, the fill property bar displays commands for filling selected areas. Controls on the property bar are organized logically for ease of use. Group labels help you find, understand, and use commands quickly and efficiently.

4. **Advanced Brush Controls**
   An advanced brush controls panel that generates a grouping of brush control panels relevant to the currently selected brush and provides access to the Brush Accelerator utility that gives insight into how Painter will perform on your system.

5. **Palette drawer**
   You can turn a palette into a palette drawer, so you can quickly collapse it to save screen space.

6. **Color panel**
   Lets you select a color and view information about the selected color.

7. **Color harmonies**
   Let you use harmony rules to create color harmonies.

8. **Layers panel**
   Lets you manage the hierarchy of layers and includes controls for creating, selecting, hiding, locking, deleting, naming, and grouping layers.

9. **Toolbox**
   Lets you access tools for creating, filling, and modifying an image.

10. **Canvas**
    The canvas is the rectangular work area inside the document window whose size determines the size of the image you create. The canvas acts as the image background and, unlike a layer, it is always locked.

### Choosing a workspace layout

A workspace layout (also known as “palette arrangement”) displays, hides, and positions workspace elements such as palettes and panels to suit a specific workflow. Corel Painter 2020 offers the following preset workspace layouts:

- **New to Painter** — Displays the most essential controls together with the **Hints** panel to help you get started quickly with Corel Painter.
- **Classic** — Ideal for users who have experience with previous versions of Corel Painter and are looking for a seamless transition to a familiar environment.
- **Default** — The default workspace layout that works well for most computers. For more information, see “Exploring the Document window” on page 59.
- **Simple** — Displays minimal user interface that includes the toolbox, the menu bar, and the property bar. This layout is ideal for small screens.
- **Concept Art** — Provides quick access to gradients, texture painting controls and Glazing brushes. Brush and media palettes are logically grouped in palette drawers to save screen space.
- **Illustration** — Displays the Reference Image panel, papers, gradients, and Glazing brushes.
- **Fine Art** — Provides quick access to traditional media brushes, glazing and blending controls.
• **Photo Art** — Displays palettes commonly used by photo artists, providing optimal setup for cloning photos, textures, and paintings

• **Manga Art** — Provides quick access to brushes, gradients as well as blending, smoothing and glazing controls

The Quick Switch feature lets you choose two workspace layouts that you use most often and quickly switch between them to suit the current task or the display mode of your device. This feature is especially useful on multi- or dual-mode devices. For example, you can select Default as Layout 1 and Simple as Layout 2. When you flip the display panel from Notebook to Tablet mode, the Simple workspace layout is automatically displayed, letting you work in an un-cluttered minimalistic user interface.

**To choose a workspace layout**

• Choose **Window  Layout**, and choose a layout.

  You can also choose a layout from the Welcome screen (**Help  Welcome**) by clicking the **Get Started** tab and selecting a layout in the **Arrange my Workspace** area.

**To switch between workspace layouts**

1. Choose **Window  Layout  Quick Switch  Layout 1**, and choose a layout.

2. Choose **Window  Layout  Quick Switch  Layout 2**, and choose a layout.

3. To switch between Layout 1 and Layout 2, do one of the following:
   • Reposition the display panel of your dual- or multi-mode device (for example, from Notebook mode to Tablet mode).
   • Choose **Window  Layout  Quick Switch  Toggle Layout**.

   You can switch between factory workspace layouts or custom workspace layouts that you created. For information about creating and saving custom workspace layouts, see “Rearranging panels and palettes” on page 76.

**Exploring the toolbox**

You can use the tools in the toolbox to paint, draw lines and shapes, fill shapes with color, view and navigate documents, and make selections.

You can access and change tool options and settings from the property bar. Tool settings are retained when you switch from one tool to another. You can also use the property bar to restore the default settings of the selected tool.

The following table provides descriptions of the tools in the Corel Painter toolbox.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color tools</td>
<td></td>
</tr>
</tbody>
</table>

The **Brush** tool lets you paint and draw on the canvas or a layer. Brush categories include pencils, pens, chalk, airbrushes, oil paints, watercolors, and more. When the **Brush** tool is selected, you can choose specific brushes from the Brush library panel. For more information, see “Selecting, managing, and creating brushes” on page 299.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Dropper tool" /></td>
<td>The <strong>Dropper</strong> tool lets you pick up a color from an existing image. The property bar shows the values of the color. When you select a color with the <strong>Dropper</strong> tool, that color becomes the current color in the <strong>Color</strong> panel. For more information, see “Sampling colors from images” on page 244.</td>
</tr>
<tr>
<td><img src="image" alt="Interactive Gradient tool" /></td>
<td>The <strong>Interactive Gradient</strong> tool lets you apply a gradient to an image by filling an area, such as the canvas, a selection, layer, or channel. For more information, see “Applying gradients” on page 737.</td>
</tr>
<tr>
<td><img src="image" alt="Paint Bucket tool" /></td>
<td>The <strong>Paint Bucket</strong> tool lets you fill an area with media, such as a color, gradient, pattern, weave, or clone. The property bar shows options for the areas that you can fill and the media that you can use. For more information, see “Working with color fills” on page 260.</td>
</tr>
<tr>
<td><img src="image" alt="Eraser tool" /></td>
<td>The <strong>Eraser</strong> tool lets you remove unwanted areas from an image. For more information, see “Erasing image areas” on page 159.</td>
</tr>
<tr>
<td><img src="image" alt="Selection tools" /></td>
<td><strong>Selection tools</strong></td>
</tr>
<tr>
<td><img src="image" alt="Layer Adjuster tool" /></td>
<td>The <strong>Layer Adjuster</strong> tool is used to select, move, and manipulate layers. For more information, see “Displaying the Layers panel” on page 572.</td>
</tr>
<tr>
<td><img src="image" alt="Transform tool" /></td>
<td>The <strong>Transform</strong> tool lets you modify selected areas of an image by using different transformation modes. For more information, see “Preparing selections for transformations” on page 641.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangular Selection tool" /></td>
<td>The <strong>Rectangular Selection</strong> tool lets you create rectangular selections. For more information, see “Getting started with selections” on page 620.</td>
</tr>
<tr>
<td><img src="image" alt="Oval Selection tool" /></td>
<td>The <strong>Oval Selection</strong> tool lets you create oval selections. For more information, see “Getting started with selections” on page 620.</td>
</tr>
<tr>
<td><img src="image" alt="Lasso tool" /></td>
<td>The <strong>Lasso</strong> tool lets you draw a freehand selection. For more information, see “Getting started with selections” on page 620.</td>
</tr>
<tr>
<td><img src="image" alt="Polygonal Selection tool" /></td>
<td>The <strong>Polygonal Selection</strong> tool lets you select an area by clicking different points on the image to anchor straight line segments. For more information, see “Creating path-based selections” on page 627.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Magic Wand" /></td>
<td>The <strong>Magic Wand</strong> tool lets you select an area of similar color by clicking or dragging in an image. For more information, see “Creating pixel-based selections” on page 629.</td>
</tr>
<tr>
<td><img src="image" alt="Selection Brush" /></td>
<td><strong>Selection Brush</strong> tool lets you create a freehand selection by painting. For more information see “Selecting areas by painting” on page 622.</td>
</tr>
<tr>
<td><img src="image" alt="Selection Adjuster" /></td>
<td>The <strong>Selection Adjuster</strong> tool lets you select, move, and manipulate selections created with the <strong>Rectangular</strong>, <strong>Oval</strong>, and <strong>Lasso</strong> selection tools and selections converted from shapes. For more information, see “Preparing selections for transformations” on page 641.</td>
</tr>
<tr>
<td><img src="image" alt="Crop" /></td>
<td>The <strong>Crop</strong> tool lets you remove unwanted edges from an image. For more information, see “Cropping images” on page 110.</td>
</tr>
</tbody>
</table>

### Shape tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Pen" /></td>
<td>The <strong>Pen</strong> tool lets you create straight lines and curves in objects. For more information, see “Drawing lines and curves” on page 788.</td>
</tr>
<tr>
<td><img src="image" alt="Quick Curve" /></td>
<td>The <strong>Quick Curve</strong> tool lets you create shape paths by drawing freehand curves. For more information, see “Adjusting curvature” on page 797.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangular Shape" /></td>
<td>The <strong>Rectangular Shape</strong> tool lets you create rectangles and squares. For more information, see “Drawing shapes” on page 786.</td>
</tr>
<tr>
<td><img src="image" alt="Oval Shape" /></td>
<td>The <strong>Oval Shape</strong> tool lets you create circles and ovals. For more information, see “Drawing shapes” on page 786.</td>
</tr>
<tr>
<td><img src="image" alt="Text" /></td>
<td>The <strong>Text</strong> tool creates text shapes. Use the <strong>Text</strong> panel to set the font, point size, and tracking. For more information, see “Adding text” on page 807.</td>
</tr>
<tr>
<td><img src="image" alt="Shape Selection" /></td>
<td>The <strong>Shape Selection</strong> tool is for editing <strong>Bézier</strong> curves. You use the <strong>Shape Selection</strong> tool to select and move anchor points and adjust their control handles. For more information, see “Selecting a shape” on page 793.</td>
</tr>
<tr>
<td><img src="image" alt="Scissors" /></td>
<td>The <strong>Scissors</strong> tool lets you cut an open or closed segment. If the segment is closed, after you click on a line or point, the shape path becomes open. For more information, see “Cutting and joining shape segments” on page 798.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="Image" alt="Add Point" /></td>
<td>The <strong>Add Point</strong> tool lets you create a new anchor point on a shape path. For more information, see “Adding, deleting, and moving anchor points” on page 795.</td>
</tr>
<tr>
<td><img src="Image" alt="Remove Point" /></td>
<td>The <strong>Remove Point</strong> tool lets you remove an anchor point from a shape path. For more information, see “Adding, deleting, and moving anchor points” on page 795.</td>
</tr>
<tr>
<td><img src="Image" alt="Convert Point" /></td>
<td>The <strong>Convert Point</strong> tool is used to convert between smooth and corner anchor points. For more information, see “Adjusting curvature” on page 797.</td>
</tr>
<tr>
<td><strong>Photo tools</strong></td>
<td></td>
</tr>
<tr>
<td><img src="Image" alt="Cloner" /></td>
<td>The <strong>Cloner</strong> tool gives you quick access to the last Cloner brush variant you used. For more information, see “Painting in the clone” on page 185.</td>
</tr>
<tr>
<td><img src="Image" alt="Rubber Stamp" /></td>
<td>The <strong>Rubber Stamp</strong> tool gives you quick access to the <strong>Straight Cloner</strong> brush variant, and lets you to sample areas within an image or between images. For more information, see “Cloning image areas” on page 203.</td>
</tr>
<tr>
<td><img src="Image" alt="Dodge" /></td>
<td>The <strong>Dodge</strong> tool lets you lighten the highlights, midtones, and shadows in an image. For more information, see “Dodging and burning” on page 290.</td>
</tr>
<tr>
<td><img src="Image" alt="Burn" /></td>
<td>The <strong>Burn</strong> tool lets you darken the highlights, midtones, and shadows in an image. For more information, see “Dodging and burning” on page 290.</td>
</tr>
<tr>
<td><strong>Symmetry tools</strong></td>
<td></td>
</tr>
<tr>
<td><img src="Image" alt="Mirror Painting" /></td>
<td>The <strong>Mirror Painting</strong> mode lets you create a perfectly symmetrical painting. For more information, see “Using the Mirror Painting mode” on page 218.</td>
</tr>
<tr>
<td><img src="Image" alt="Kaleidoscope" /></td>
<td>The <strong>Kaleidoscope</strong> mode lets you transform basic brushstrokes into colorful and symmetrical kaleidoscope images. For more information, see “Using the Kaleidoscope Painting mode” on page 220.</td>
</tr>
<tr>
<td><strong>Composition tools</strong></td>
<td></td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Divine Proportion tool" /></td>
<td>The <strong>Divine Proportion</strong> tool lets you plan compositions by using guides based on a classical composition method. For more information, see “Using the Divine Proportion tool” on page 228.</td>
</tr>
<tr>
<td><img src="image" alt="Layout Grid tool" /></td>
<td>The <strong>Layout Grid</strong> tool lets you divide your canvas so that you can plan your composition. For example, you can divide your canvas into thirds vertically and horizontally to use the compositional rule of thirds. For more information, see “Using the Layout Grid” on page 215.</td>
</tr>
<tr>
<td><img src="image" alt="Perspective Guides tool" /></td>
<td>The <strong>Perspective Guides</strong> tool lets you display guides using one, two or three-point perspective. For more information, see “Using perspective guides” on page 222.</td>
</tr>
</tbody>
</table>

**Navigation tools**

| ![Grabber tool](image) | The **Grabber** tool lets you scroll through an image quickly. For more information, see “Repositioning images” on page 110. |
| ![Magnifier tool](image) | The **Magnifier** tool lets you magnify areas of an image when you are performing detailed work, or reduce areas to get an overall view of an image. For more information, see “Zooming images” on page 104. |
| ![Rotate Page tool](image) | The **Rotate Page** tool lets you rotate an image window to accommodate the way you naturally draw. For more information, see “Rotating images and the canvas” on page 106. |

**Selectors**

| ![View selector](image) | The **View** selector allows you to switch between document views and viewing modes. For more information, see “Switching document views” on page 101. |

**To reset the default tool settings**
- Click the **Reset Tool** button on the property bar.

The **Reset Tool** button on the property bar has the same icon as the selected tool in the toolbox.

![Various Reset Tool buttons for the Grabber property bar](image)
Displaying the toolbox

The toolbox is open by default, but you can close it. In addition, to minimize the space required to display the toolbox, tools of similar function are grouped together and they are accessible from flyout menus. The button for only one of these tools is displayed at a given time on the toolbox. A flyout menu is indicated by a triangle in the lower-right corner of the button. You can open a flyout to access all of its tools.

You can also reposition the toolbox by moving it in the application window. In addition, you can change the toolbox display. For example, you can arrange the tools in two columns instead of one or change the toolbox orientation from vertical to horizontal. If you are working with a tablet or low-resolution display, or you prefer to work in an uncluttered workspace, you can display a simpler version of the toolbox that includes fewer tools.


To open or close the toolbox

- Choose Window ➤ Toolbox.

You can also close the toolbox by clicking the close button on the toolbox header bar.

To access tools grouped in flyouts

1 In the toolbox, click and hold the tool icon whose flyout you want to open. A flyout menu of the entire group of related tools appears.

2 Click the tool that you want to use.
   The tool you’ve chosen appears in the toolbox.

To move the toolbox

- Drag the toolbox header bar to a new location in the application window.

To change the toolbox display

1 Do one of the following:
   - (macOS) Choose Corel Painter 2020 ➤ Preferences ➤ Interface.
   - (Windows) Choose Edit ➤ Preferences ➤ Interface.

2 Choose an option from the Toolbox Layout list box.

Displaying the Media Selector bar

The Media Selector bar gives you quick access to the libraries for the following Corel Painter media:
The Media Selector bar is open by default, but you can close it at any time.

You can also reposition the Media Selector bar by moving it in the application window. In addition, you can change the Media Selector bar display. For example, you can change the Media Selector bar orientation or increase the size of the buttons.

To open or close the Media Selector bar
* Choose Window ▶ Media Selector.

You can also close the Media Selector bar by clicking the close button on the header bar.

To move the Media Selector bar
* Drag the Media Selector bar header to a new location in the application window.

To change the Media Selector bar display
1. Do one of the following:
   * (macOS) Choose Corel Painter 2020 ▶ Preferences ▶ Interface.
   * (Windows) Choose Edit ▶ Preferences ▶ Interface.
2. Choose an option from the Media Layout list box.

Displaying the property bars

The property bar displays the most commonly used functions that are relevant to the active brush or tool.

Controls on the property bar are organized logically for ease of use. Group labels help you find, understand, and use commands quickly and efficiently. You can show and hide group labels. Depending on the brush category and variant you select, the property bar contains flyouts that allow you to access brush settings without the need to open different panels.
The property bar for a Real Watercolor brush variant: (1) the Stroke flyout; (2) the Flow map flyout; (3) the Real Watercolor flyout button; (4) the Dab Options flyout; (5) the Static Bristle flyout button; (6) The Advanced Brush Controls button lets you access the panels related to the active brush variant. The background shape of icons indicates their use. A square background (3) signifies that the control gives access to settings that let you modify the media properties of a brush. Icons with a round background (4, 5) give access to settings that control the shaping of a brush.

By default, the property bar is displayed in the application window docked below the menu bar, but you can close it. You can also move the property bar or dock it to the application window.

**To open or close the property bar**

- Choose **Window ▶ Property Bar**.

All commands that were available on the Extended Property Bar in previous version of Corel Painter are now available on the property bar; however, you can still access the Extended Property Bar by choosing **Window ▶ Extended Property Bar**.

You can also close the property bar by clicking the close button on the header bar.

**To move or dock the property bar**

- Perform a task from the following table.
To move the property bar, drag the header bar to a new location. To dock the property bar, drag the header bar and place it under the menu bar. The property snaps into place.

To show or hide group labels
1. Do one of the following:
   - (macOS) Choose **Corel Painter 2020** menu ➤ Preferences ➤ Interface.
   - (Windows) Choose **Edit** ➤ Preferences ➤ Interface.
2. In the **Property Bar** area, enable one of the following options:
   - Tall (with group labels) — to display the group labels
   - Short (without group labels) — to hide the group labels

Exploring the Navigator panel

The **Navigator** panel is a convenient tool for managing many aspects of a document. You can use the **Navigator** panel to better orient yourself in the document window and modify the document window display. For example, when you’re working at a high zoom level, or with a large image, you can use the **Navigator** panel’s small canvas preview to display the entire image without having to zoom out. You can also move to a different image area without having to adjust the zoom level. In addition, you can change the zoom level or rotate the canvas from the **Navigator** panel.

The **Navigator** lets you enable various tools such as the drawing modes, Impasto information, tracing paper, grids, and color management.
The Navigator panel also displays document information such as the X and Y coordinates and the cursor position to help you navigate the image. You can also view document width, height, and resolution. For more information, see “Navigating images and viewing image information” on page 102.

Displaying and customizing the Brush Selector

The Brush Selector lets you choose a brush library, select a brush from a brush category, and browse additional brush packs that can complement your creative set of brushes. It also allows you to view the most recently used brushes and organize and display brushes in various ways. For example, you can hide the recently used brushes to save screen space or hide brush categories and variants to expose the brushes that you use most.

Circled numbers correspond to the numbers in the following table, which describes the main components of the Brush Selector.

<table>
<thead>
<tr>
<th>Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Last Used Brush</td>
<td>Lets you access the previously used brush variant</td>
</tr>
<tr>
<td>2. Brush Selector Bar</td>
<td>Lets you access the Brush Selector flyout</td>
</tr>
<tr>
<td>Part</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>3. Brush Library Selector</td>
<td>Lets you choose a brush library</td>
</tr>
<tr>
<td>4. Recent Brushes</td>
<td>Displays the recently used brushes. The list includes only brushes from the currently selected brush library. Switching to a different brush library clears the most recently used brushes list.</td>
</tr>
<tr>
<td>5. Brush Pack Promotions bar</td>
<td>Lets you access the Brush Pack Selector and purchase brush packs</td>
</tr>
<tr>
<td>6. Brush Pack Promotions list</td>
<td>Lets you browse the available brush packs</td>
</tr>
<tr>
<td>7. Brush library options button</td>
<td>Lets you access commands that help you organize and display brushes in various ways</td>
</tr>
<tr>
<td>8. Brush categories</td>
<td>Lets you browse all categories in a brush library. Brush categories are groups of similar brushes and media.</td>
</tr>
<tr>
<td>9. Brush library panel</td>
<td>Lets you browse the brush categories and variants in the currently selected library</td>
</tr>
<tr>
<td>10. Brush variants</td>
<td>Lets you browse the brush variants in a category. Brush variants are specific brushes and brush settings within a brush category.</td>
</tr>
</tbody>
</table>

The Brush Selector is also available as a floating panel that you can keep open to access brushes quickly and easily while you are painting. The Brush Selector panel has two viewing modes: compact and full view. In full view, both the brush categories and variants are displayed. In compact view, only the brush variants are displayed, which lets you see more brushes at a glance without the need to scroll. For more information about grouping, resizing, and docking panels, see “Rearranging panels and palettes” on page 76.
To show or hide the Brush Selector

- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To show or hide</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Brush Selector bar</td>
<td>Choose Window ➤ Brush Selector ➤ Bar.</td>
</tr>
<tr>
<td>The Brush Selector panel in full view</td>
<td>Choose Window ➤ Brush Selector ➤ Panel (Full View).</td>
</tr>
<tr>
<td>The Brush Selector panel in compact view</td>
<td>Choose Window ➤ Brush Selector ➤ Panel (Compact).</td>
</tr>
</tbody>
</table>

You can close the Brush Selector bar and Brush Selector panel by clicking the Close button on the header bar.
To show or hide the Brush Pack Promotions bar

• In the Brush Selector, click the Brush library options button ☐, and choose Show Brush Pack Promotions.

To show or hide brush pack promotions

• In the Brush Selector, click the toggle button ▶ to display or hide the list of brush pack promotions.

This feature is available only when the Brush library panel is in full view.

To show or hide the Brush Library Selector

• In the Brush Selector, click the Brush library options button ☐, and choose Show Brush Library Selector.

To show or hide recently used brushes

• In the Brush Selector, click the Brush library options button ☐, and choose Show Recent Brushes.

This feature is available only when the Brush library panel is in full view.

The list of recently used brushes includes only brushes from the currently selected brush library. Switching to a different brush library clears the most recently used brushes list.

To show or hide the dab and stroke preview window

• In the Brush Selector, click the Brush library options button ☐, and choose Show Dab and Stroke Preview.

This feature is available only when the Brush library panel is in full view.

To modify the display of brush categories and variants

• In the Brush Selector, perform a task from the following table.

To Modify the display of brush categories

Do the following

Click the Brush library options button ☐, choose Category Display, and choose one of the following:

• Categories as Icons
• Categories as List

Modify the display of brush variants

Click the Brush library options button ☐, choose Variant Display, and choose one of the following:

• Show Dab Preview
• Show List
• Show Stroke Preview
Hide a brush category
Right-click a brush category, and choose Hide Category.

Hide a brush variant
Right-click a brush variant, and choose Hide Variant.

Show all previously hidden brush categories
Click the Brush library options button, choose Category Display, and choose Show All Categories.

Show all previously hidden brush variants
Click the Brush library options button, choose Variant Display, and choose Show All Variants.

Customize a brush category or brush variant icon
Right-click a brush category or variant, and choose Set Custom Icon. Choose the drive and folder where the image is stored. Click the image file and click Open.

To resize the Brush Selector
• Point to the edge of the panel. When the cursor changes to a double-sided arrow, drag the edge of the panel to resize it.

By default, when group labels are displayed, the height of the Brush Selector bar is the same as that of the property bar. However, if you want to make it more compact, you can change its height. For more information, see “Interface preferences” on page 852.

To move the Brush Selector
• Perform a task from the following table.

To
Do the following
Move the Brush Selector panel
Drag the Brush Selector header bar to a new location in the application window.

Dock the Brush Selector bar
Drag the Brush Selector header bar to the edge of the application window or a panel. The bar snaps into place.

To display the Brush Selector as a floating panel
• Perform a task from the following table:

To display
Do the following
The Brush Selector panel in full view
Choose Window  ▶ Brush Selector ▶ Panel (Full View).

The Brush Selector panel in compact view
Choose Window  ▶ Brush Selector ▶ Panel (Compact).
Displaying the command bar

The command bar gives you quick access to commonly used commands such as starting and saving documents, undoing and redoing actions, cutting and pasting, and accessing brush tracking options. Displaying the command bar is especially useful for tablets and other small-screen devices.

You can change the orientation of the command bar.

To display the command bar

• Choose Window  Command Bar.

To change the orientation of the command bar

1 Do one of the following:
  * (macOS) Choose Corel Painter 2020  Preferences  Interface.
  * (Windows) Choose Edit  Preferences  Interface.

2 From the Command Bar Layout list box, choose an option.

Rearranging panels and palettes

Whether you are new to digital painting software or a long-time user, Corel Painter makes it easy to adapt your design space to your needs. The interactive panels in Corel Painter are single tabbed containers that let you access content libraries, commands, controls, and settings. Panels are stored in palettes.

You can increase your efficiency by arranging task-related or frequently used panels into palettes. For example, you can display all color-specific panels in one color palette, or display panels individually. A palette can contain one or more panels.
This palette includes three color-related panels: Color, Mixer, and Color Set Libraries. You can access a panel's content by clicking its tabs.

Corel Painter includes the Brush controls palette, which is a preset palette that groups all panels that contain brush-related settings.

You can add panels to and remove panels from a palette. You can also reposition a panel within a palette group or move a panel to another palette group. You can turn a palette into a palette drawer, so you can quickly collapse it to save screen space. At any time, you can turn a palette drawer back into a regular palette. You can resize and reposition a palette drawer like any other palette group.

You can display and hide a panel or palette. When you hide a panel or palette, they are no longer displayed in the application window. If you want to keep the panel or palette at hand, but save screen space, you can resize or collapse them.

You can also arrange panels and palettes in the application window to quickly access the tools and controls that you use most often or to maximize screen space. Palettes and panels float in the workspace. Docking attaches the panel or palette to the vertical edge of the application window. Undocking detaches them from other parts of the workspace, so you can move them. To perform docking, you need to grab a panel’s tab or a palette’s header bar.

You can save the arrangement of palettes as a custom workspace layout for later use, and you can delete this custom workspace layout when you no longer need it.

To group panels into palettes
- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group panels into a palette</td>
<td>Drag a panel by its tab to another open panel to create a group.</td>
</tr>
<tr>
<td>Add a panel to a palette group</td>
<td>Drag the panel tab to the palette.</td>
</tr>
<tr>
<td>Remove a panel from a palette group</td>
<td>Drag the panel tab out of the palette.</td>
</tr>
<tr>
<td>Reposition a panel in a palette group</td>
<td>Drag the panel tab to a new location in the palette.</td>
</tr>
</tbody>
</table>
To create a palette drawer
  • Click the Palette Drawer toggle button on the palette header bar, and click Palette Drawer.

To rename a palette drawer, click the Palette Drawer toggle button on the palette header bar, click Rename, and type a new name.

To turn a drawer into a regular palette, click the Palette Drawer toggle button on the drawer header bar, and then click Palette Drawer.

To hide or show a panel, palette, or palette drawer
  • Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide a panel</td>
<td>Click the Close button on the panel tab.</td>
</tr>
<tr>
<td>Hide a palette or palette group</td>
<td>Click the Close button on the header bar.</td>
</tr>
<tr>
<td>Show a panel</td>
<td>Choose Window ▶ [Panel name].</td>
</tr>
<tr>
<td>Show a palette drawer</td>
<td>Choose Window ▶ Palette Drawers ▶ [Palette Drawer name].</td>
</tr>
</tbody>
</table>

When you choose Window ▶ Show Panels, only the panels that were open when you chose Hide Panels are displayed.

You can restore a previously hidden palette by choosing Window, and choosing the name of a panel that is contained in the palette.

To expand or collapse a panel or a palette drawer
  • Perform a task from the following table.

<table>
<thead>
<tr>
<th>To expand or collapse</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A panel</td>
<td>Double-click the panel tab.</td>
</tr>
<tr>
<td>A palette drawer</td>
<td>Double-click the header bar of the palette drawer.</td>
</tr>
</tbody>
</table>

To resize a panel or palette
  • Perform a task from the following table.
To

Do the following

Resize a panel or palette proportionally
Point to the lower-right corner of the panel or palette. When the cursor changes to a double-sided arrow, drag the panel or palette to resize it.

Resize a panel or palette vertically
Point to the lower edge of the panel or palette. When the cursor changes to a double-sided arrow, drag the edge of the panel or palette to resize it.

Resize a panel or palette horizontally
Point to the right edge of a panel or palette header. When the cursor changes to a double-sided arrow, drag the edge of the panel or palette to resize it.

To dock or undock a palette

To

Do the following

Dock a palette
Drag the palette header bar, or the blank space to the right of the tabs, to the vertical edge of the application window. The palette snaps into place when it lines up with the edge.

Undock a palette
Drag the blank area to the right of the panel tabs away from the edge of the application window.

Dock a palette drawer
Before you dock the palettes in a palette drawer, save your arrangement of palettes as a custom layout so you can return to it at any time. Choose the palette drawer that you want to dock. Click the Palette Drawer toggle button on the palette header bar, and disable Palette drawer. Grab the header bar, and drag the entire group of palettes towards the vertical edge of the application window. Ensure the cursor goes all the way to the edge of the application window. When a blue highlight appears, release the mouse button or lift the stylus. The palettes snap into place. After you dock the drawers that you want, save your layout.

Tips:
- You can undock the palettes, but only one at a time.
- You can quickly return to the arrangement of palettes that you saved in the first step by choosing Window → Layout → [Layout name], where Layout name is the name of your custom layout.

Dock a panel
Drag the panel tab to the vertical edge of the application window. The panel snaps into place when it lines up with the edge.

Undock a panel
Drag the panel tab away from the application window.
If there’s not enough space along the vertical edge of the application window (for example, if you have a lot of expanded palettes), you may not be able to dock a panel or a palette. Collapse one or multiple panels to create sufficient space for docking.

You cannot dock panels or palettes with toolbars.

To access additional panel options
• In the panel, click the Panel options button, and choose an option.

To save an arrangement of palettes as a workspace layout
1 Choose Window ▸ Layout ▸ Save Layout.
2 In the Palette Layout Name dialog box, type a name in the New Layout list box.
   The workspace layout appears as a menu item under Window ▸ Layout.

You can display a saved arrangement of palettes by choosing Window ▸ Layout ▸ [Layout name].

You can restore the default palette arrangement at any time by choosing Window ▸ Layout ▸ Default.

To delete a workspace layout
1 Choose Window ▸ Layout ▸ Delete Layout.
2 In the Delete Palette Layout dialog box, choose a layout from the Palette Layout list box.

Exploring panels
The following table contains a list of the panels available in Corel Painter.

<table>
<thead>
<tr>
<th>Panel</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brush Control panels</td>
<td>Allow you to customize brush variants. For more information, see “Adjusting brushes with brush controls” on page 371.</td>
</tr>
</tbody>
</table>

The brush control panels are included in the Brush Controls palette. They include the following panels: General, Stroke Attributes, Opacity, Grain, Dab Profile, Size, Bristles, Spacing, Smoothing, Angle, Static Bristle, Computed Circular, Blending, Rake, Multi, Mouse, Cloning, Impasto, Image Hose, Airbrush, Water, Liquid Ink, Digital Watercolor, Artists’ Oils, Real Watercolor, Real Wet Oil, Stroke Jitter, RealBristle™, Hard Media, Color Variability, Color Expression, Brush Calibration, Dab Preview, Stroke Preview, Particles (General, Flow, Gravity, Spring), Audio Expression, Dynamic Speckles, Glazing, Dab Stencils, and Texture Brushes.

Advanced Brush Controls panel
Generates a grouping of brush control panels that are relevant to the currently selected brush. For more information, see “Exploring Brush Controls” on page 372.
<table>
<thead>
<tr>
<th>Panel</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color panels</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Color Panel (Full View)</strong></td>
<td>Let you choose main and additional colors for painting in Corel Painter documents. For more information, see “Choosing colors from the Color panel” on page 236.</td>
</tr>
<tr>
<td><strong>Color Panel (Compact)</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Harmonies</strong></td>
<td>Lets you use harmony rules to create color harmonies</td>
</tr>
<tr>
<td><strong>Mixer</strong></td>
<td>Lets you mix and blend colors as you would on an artist’s palette. For more information, see “Exploring the Mixer panel and mixing controls” on page 246.</td>
</tr>
<tr>
<td><strong>Color Set Libraries</strong></td>
<td>Displays the colors in the current color set so you can organize groups of colors. For more information, refer to “Working with color sets” on page 253.</td>
</tr>
<tr>
<td><strong>Papers panel</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Papers</strong></td>
<td>Lets you apply and edit paper textures as well as open and manage paper libraries</td>
</tr>
<tr>
<td><strong>Media panels</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Patterns, Gradients, Nozzles, Looks, Textures, and Weaves</strong> panels</td>
<td>Let you apply and edit patterns, gradients, textures, and weaves as well as open and manage media libraries</td>
</tr>
<tr>
<td><strong>Image Portfolio and Selection Portfolio</strong></td>
<td>Contain all images or selections in the current library. You can view the items as thumbnails or in a list as well as preview the current item. For more information, see “Storing layers as images in the Image Portfolio” on page 606 and “Working with the Selection Portfolio” on page 636.</td>
</tr>
<tr>
<td><strong>Flow Maps panel</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Flow Maps</strong></td>
<td>Lets you apply and manipulate flow maps as well as open, manage, and navigate flow map libraries. For more information, see “Applying and adjusting flow maps” on page 505 and “Choosing flow maps and compatible brush variants” on page 506.</td>
</tr>
<tr>
<td><strong>Navigator, Clone Source, and Reference Image panels</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Navigator</strong></td>
<td>Lets you navigate the document window. You can also view document information, such as width and height; X and Y coordinates and the cursor position; context-sensitive information based on a selected tool; and unit information, such as pixels,</td>
</tr>
<tr>
<td>Panel</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Navigator panel</td>
<td>inches, and resolution. For more information, see “Exploring the Navigator panel” on page 70.</td>
</tr>
<tr>
<td>Clone Source panel</td>
<td>Lets you open and manage clone sources. For more information, see “Cloning workflows” on page 182.</td>
</tr>
<tr>
<td>Reference Image panel</td>
<td>Lets you display an inspirational image in the document window while maintaining focus on the canvas. For more information, see “Displaying reference images” on page 150.</td>
</tr>
<tr>
<td>Layers and Channels panels</td>
<td></td>
</tr>
<tr>
<td>Layers</td>
<td>Lets you preview and arrange all layers in a Corel Painter document. You can use Dynamic Plug-ins, add new layers (including Watercolor and Liquid Ink layers), create layer masks, and delete layers. In addition, you can set the composite method and depth, adjust the opacity, and lock and unlock layers. For more information, see “Layers” on page 569.</td>
</tr>
<tr>
<td>Channels</td>
<td>Lets you preview thumbnails of all the channels in a Corel Painter document, including RGB composite channels, layer masks, and alpha channels. From the panel, you can also load, save, and invert existing channels, and create new channels. For more information, see “Alpha Channels” on page 609.</td>
</tr>
<tr>
<td>Auto-Painting panels</td>
<td></td>
</tr>
<tr>
<td>Underpainting</td>
<td>Lets you adjust tone, color, and detail in a photo in preparation for auto-painting. This panel is used in the first step of the photo-painting process. For more information, see “Creating underpaintings” on page 174.</td>
</tr>
<tr>
<td>Auto-Painting</td>
<td>Lets you specify a range of settings that control how brushstrokes are applied. This panel is used in the second step of the photo-painting process. For more information, see “Auto-painting photos” on page 176.</td>
</tr>
<tr>
<td>Restoration</td>
<td>Lets you fine-tune a painting by providing brushes that help you restore detail. This panel is used in the third step of the photo-painting process. For more information, see “Restoring detail to paintings” on page 179.</td>
</tr>
<tr>
<td>Composition panels</td>
<td></td>
</tr>
<tr>
<td>Divine Proportion</td>
<td>Lets you customize the Divine Proportion guide — a tool that helps you plan a layout according to a classic composition method. For</td>
</tr>
</tbody>
</table>
Panel  Description
more information, see “Using the Divine Proportion tool” on page 228.

Layout Grid  Lets you customize the Layout Grid — a tool that helps you divide your canvas so that you can plan your composition. For more information, see “Using the Layout Grid” on page 215.

Text and Scripts panels

Text  Lets you perform all text-related tasks, such as choosing fonts, adjusting opacity, and applying drop shadows. For more information, refer to “Adding text” on page 807.

Scripts  Lets you access all commands and settings related to scripts. For example, you can open, close, play, and record scripts from the Scripts panel. For more information, see “Using scripts to automate tasks” on page 831.

Working with sliders
In many panels and property bars in Corel Painter, sliders let you interactively adjust brush settings.

The label (1), drag area (2), and control point (3) of a slider. As you hover over a slider, the end point (3) is highlighted.

With sliders, you can change values in many different ways. Click anywhere along a slider or grab the control point and drag. Adjust a value with great precision by using modifier keys or adjust values in 1% increments.

To adjust a value
• Do one of the following:
  • Click anywhere along a slider.

  • Drag the control point.

  • Click anywhere along a slider and drag.
To adjust a value with precision
• Hold down Command (macOS) or Ctrl (Windows) and drag.

To adjust a value in 1% increments
• Click anywhere along a slider and use the arrow keys.

Creating and modifying custom palettes
You can create custom palettes to speed up your work and quickly access the brushes, papers, flow maps, media, menu commands, and tools that you use most often. For example, you can place items from the Brush library panel or any of the Media panels in a custom palette. You can also add commands from the main menus or panel options to custom palettes.

Items that appear on a custom palette are references (aliases or shortcuts) to the original. This means that if you change the original — for example, by modifying and saving a brush variant — the custom panel button loads the newest version. However, if you delete the original, Corel Painter won’t be able to find the item again to load in the custom palette.

You can change how items on a custom palette are displayed. For example, you can display them as text, icons, or wide icons.

Custom palettes behave like the standard panels. For more information about working with panels, see “Rearranging panels and palettes” on page 76.

To quickly create a custom palette
• Press Shift, and do any of the following:
  • Drag a brush variant from the Brush Selector panel to the document window.
  • Drag a paper, flow map, or media library thumbnail from the Paper libraries (Window ➤ Media Panels ➤ Papers), Flow Map libraries (Window ➤ Media Panels ➤ Flow Maps), or the other Media panels (Window ➤ Media Panels ➤ [Textures, Patterns, Gradients, Nozzles, Looks, Weaves Library Panel]) to the document window.

To add menu commands, controls, or tools to a custom palette
1 Choose Window ➤ Custom Palette ➤ Add Command.
2 From the Select Custom Palette list box, choose New to create a new palette or select an existing custom palette.
3 With the Create Palette/Add Command dialog box open, perform a task from the following table:

<table>
<thead>
<tr>
<th>To add</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A menu item</td>
<td>Choose a menu item from a default Corel Painter menu.</td>
</tr>
<tr>
<td>Additional controls</td>
<td>Choose a menu item from the Other menu.</td>
</tr>
<tr>
<td>A panel, or any item included in a panel’s options flyout menu</td>
<td>Choose a menu item from the Panel Menus menu.</td>
</tr>
<tr>
<td>A toolbox tool</td>
<td>Choose a menu item from the Tools menu.</td>
</tr>
<tr>
<td>An item from an open palette</td>
<td>Click the item.</td>
</tr>
</tbody>
</table>

4 In the Create Palette/Add Command dialog box, click Add, and then click OK.
You can add brush variants that are stored in different brush libraries to the same custom palette. When you choose a brush variant from the custom palette, the brush library in which the brush variant is stored is automatically loaded in the Brush library panel. This allows you to quickly switch between brush libraries.

**To rearrange controls on a custom palette**
- Hold down Shift and drag a control on a custom palette to a new position.

**To open or close a custom palette**
- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a custom palette</td>
<td>Choose Window ➤ Custom Palette ➤ [Custom Panel Name].</td>
</tr>
<tr>
<td>Close a custom palette</td>
<td>On the custom panel header bar, click the Close button.</td>
</tr>
</tbody>
</table>

**To change the appearance of items on a custom palette**

1. Do one of the following:
   - (macOS) Holding down Control, click an item.
   - (Windows) Right-click an item.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a custom icon</td>
<td>Choose Set Custom Icon, and locate the image you want.</td>
</tr>
<tr>
<td>Display a text label for each item</td>
<td>Choose Text View.</td>
</tr>
<tr>
<td>Display an icon for each item</td>
<td>Choose Icon View or Wide Icon View.</td>
</tr>
</tbody>
</table>

To change the size of the icons, click the Options button in the custom palette, and choose Small Icons or Large Icons.

**Renaming and deleting custom palettes**

You can manage your custom palettes in the Custom Palette Organizer. Corel Painter names custom palettes “Custom 1”, “Custom 2,” and so on. For ease of use, you can rename them.

Corel Painter keeps your custom palettes from one session to the next. You can also save a custom palette to a file. For more information, see “Saving, exporting, and importing custom palettes” on page 86.

You can delete obsolete custom palettes or those you don’t use very often.
To rename a custom palette

1. Choose Window ▶ Custom Palette ▶ Organizer.
2. Choose a palette from the Custom Palette list.
3. Click Rename.
4. In the Palette Name dialog box, type a name in the New Palette text box.

To delete a custom palette

1. Choose Window ▶ Custom Palette ▶ Organizer.
2. Choose a palette from the Custom Palette list.
3. Click Delete.

Saving, exporting, and importing custom palettes

You can save a custom palette as a Painter Custom Toolbox (BOX) file so that its custom content such as custom brushes, papers, patterns, and flow maps are saved with the file. You can share the saved custom toolbox (palette) with others or store it for later use.

You can also export a custom palette to the Painter Palette File (PAL) format to make it compatible with earlier versions of Corel Painter. However, any custom content included in the palette is not saved with the file.

To save a custom palette as a custom toolbox

1. Choose Window ▶ Custom Palette ▶ Organizer.
2. Choose a palette from the Custom Palette list.
3. Click Save As BOX.
4. In the New Palette File dialog box, type a name in the File Name text box.
5. Choose the drive and folder where you want to save the file.
   It’s a good idea to store all saved palettes in the same folder.

Custom nozzles, scripts, gradients, looks, and weaves are not supported. Buttons for such custom content will not function when the custom toolbox is imported.

Any non-custom items that are already in the application appear as duplicates.

To export a custom palette

1. Choose Window ▶ Custom Palette ▶ Organizer.
2. Choose a palette from the Custom Palette list.
3. Click Export As PAL.
4. In the New Palette File dialog box, type a name in the File Name text box.
5. Choose the drive and folder where you want to save the file.
   It’s a good idea to store all exported palettes in the same folder.

Custom content is not saved with the file.
To import a custom palette

1. Choose Window ▶ Custom Palette ▶ Organizer.
2. In the Custom Palette Organizer, choose a palette from the Custom Palette list.
3. Click Import.
4. In the Open Palette File dialog box, choose the file where the custom palette is saved.
5. Click Open.

Only custom palette files created with Corel Painter version 8.1 or later are supported. Custom palettes created with version 7 or earlier cannot be loaded.

Working with libraries

A library is a storage place that helps you organize and manage a collection of similar items, such as brushes or paper textures. For example, the default paper textures are contained in the Paper Textures library, which is loaded by default when you open Corel Painter. As you customize paper textures and other resources, you can save them to your own libraries. Libraries are available for brushes, gradients, layers, lighting, looks, nozzles, paper textures, patterns, selections, scripts, and weaves. For more information, see “Libraries” on page 293 and “Importing and exporting brush libraries, categories, and variants” on page 312.

The Papers panel lets you choose, organize, and apply paper textures.
Creating, importing, exporting, and deleting workspaces

Corel Painter lets you completely customize your workspace to suit your workflow needs. You can customize Brush libraries, Paper libraries, and Portfolios and save these changes to use later. In addition, you can easily create multiple workspaces, each with different libraries and portfolios. You can even share these customized workspaces with others by importing or exporting them. However, if you are importing a workspace that was created in an older version of Corel Painter, only libraries and custom palettes are preserved in Corel Painter 2020.

You can also delete any obsolete workspaces.

**To create a new workspace**
1. Choose **Window** ➤ **Workspace** ➤ **New Workspace**.
2. Type a name in the **Workspace Name** text box.
3. From the **Based On** list box, choose the workspace on which you want to base the new workspace.
4. Click **Save**.

The application switches to the new workspace.

**To switch to a different workspace**
• Choose **Window** ➤ **Workspace** ➤ [Workspace Name].

**To import a workspace**
1. Choose **Window** ➤ **Workspace** ➤ **Import Workspace**.
2. Choose the workspace file that you want to import.
3. Click **Open**.

**To export a workspace**
1. Choose **Window** ➤ **Workspace** ➤ **Export Workspace**.
2. Choose the workspace that you want to export.
3. Click **Save**.

**To revert to the default workspace**
• Choose **Window** ➤ **Workspace** ➤ **Default**.

Corel Painter lets you modify the default workspace, so this workspace may eventually differ from the factory default workspace. If you restore the factory default workspace, you will lose all customizations unless you save the workspace. For more information, see “Restoring the default Corel Painter settings” on page 89.

**To delete a workspace**
1. Choose **Window** ➤ **Workspace** ➤ **Delete Workspace**.
2. From the **Workspace** list box, choose the workspace that you want to delete.
3. Click **Delete**.

If you are trying to remove the active workspace, you may be prompted to choose a new active workspace.
Restoring the default Corel Painter settings

When restoring the Corel Painter workspace to its default factory settings, you can keep some customizations, or you can remove all modifications that you made to the application.

The following customizations can be kept:
• All custom brushes
• All other libraries (papers, scripts, nozzles, etc.). This option lets you save all papers, flow maps, patterns, gradients, nozzles, looks, weaves, images, selections, and scripts.
• Custom palettes. Note that palette location and icon settings will be lost.

The following customizations are lost after Corel Painter is restored to its default settings:
• Palette Layout(s)
• Color Sets
• All preferences (Preferences dialog box)
• Customized keyboard shortcuts
• Brush tracking and calibration settings
• Recent brushes
• Color Management presets
• Perspective Guides, Layout, and Divine Proportion presets

You can reset all workspaces — the current one and any workspaces you created or imported, or you can reset only the current workspace.

To restore Corel Painter to its default factory settings
1 Hold down Shift, and start Corel Painter.
2 Choose one of the following options:
   • Keep some customizations — lets you keep custom brushes, other customized libraries as well as custom palettes
   • Restore all settings to factory defaults — removes all customizations that you made to the application including custom brushes and palettes
3 Click one of the following buttons:
   • Reset All Workspaces — resets the current workspace and any other workspaces you created or imported
   • Reset Current Workspace — resets only the current workspace

When you choose to restore all workspaces, all custom workspaces are deleted. Only the default workspace is preserved and restored to the factory settings.
A short tour of Corel Painter for users of Adobe Photoshop

by Cher Threinen-Pendarvis

Corel Painter is known for its responsive, realistic brushes, multitude of rich textures, and fabulous special effects, which cannot be found in any other program. The biggest difference that you will notice between Adobe Photoshop and Corel Painter is the warmth and texture of the Natural-Media brushes and paper textures of Corel Painter. You’ll find brushes with realistic bristles that lay down oily paint and dry-media brushes, such as variants in the Chalk and Pastels categories, that are sensitive to textures on the canvas. Now, let’s get started!

Before we begin the tour, you need to make sure that you are displaying the default panels and palettes. To display the default settings, choose the Window menu, and choose Arrange Palettes ▶ Default.

Property bar

At the very top of the screen, you’ll see the property bar, which is similar to the Options bar in Photoshop. The property bar changes contextually, depending on the tool that you choose from the toolbox.

Brush Selector bar

On the far left of the property bar is the Brush Selector bar, which lets you open the Brush library panel. The Brush library panel contains the amazing brush categories and brush variants of Corel Painter, such as the Real Watercolor Brushes category and its variants.
Color panel

On the upper right corner of your screen you’ll see the large, beautiful Color panel, which lets you choose colors. You can choose colors by using the Hue Ring and the Saturation/Value Triangle. However, if you prefer to mix color by using numbers, you can adjust the three sliders that are located under the Hue Ring. By clicking the panel options button on the right side of the Color panel, you can set the sliders to display either Red, Green, and Blue, or Hue, Saturation, and Value.

Also located on the Color panel is the Clone Color button, a useful control that lets you paint with color from a source image. On the left of the Color panel are the Main Color swatch or Additional Color swatch. The color swatches in Corel Painter operate differently than the Foreground and Background Color squares in Photoshop. To change the color, you can double-click either the Main Color swatch or the Additional Color swatch and then choose a new color on the Hue Ring. Or you can click in the Saturation/Value Triangle to choose a new tint or shade. You can use the additional color to create gradients or to use brushes that paint more than one color. Unlike the Background Color in Photoshop, the additional color does not affect the canvas.

Before moving on with the tour, click the Main Color swatch to select it.
In Corel Painter, you can resize the Color panel by dragging the handle in the lower-right corner of the panel to resize it. Resizing the Color panel lets you select colors more accurately.

Textures

A basic paper texture is automatically loaded when you start Corel Painter. You can access additional rich paper textures by clicking the Grain flyout button on the property bar or opening the Papers panel (Window menu ➤ Media Panels ➤ Papers).

Layers and mask channels

In Corel Painter, you can open Photoshop files that contain pixel-based layers and layer masks. You can access and edit the layers and layer masks by using the Layers panel, much like in Photoshop. The files you open in Corel Painter have multiple channels intact.
Photoshop Layer Styles

If you are using native Photoshop layer styles, such as the Drop Shadow layer style, make sure that you preserve the original Photoshop file in your archive before you convert the layer style information. That is, save the file with the live layer styles in the Photoshop (PSD) file format, and then save a new copy of this file. In the new file, convert the layer style information into pixel-based layers before importing the file into Corel Painter.

To convert a layer that has a Drop Shadow layer style, select the layer, and then choose Layers ➤ Layers Style ➤ Create Layer. A word of caution: Some aspects of the effects cannot be reproduced with standard layers.

File formats

Corel Painter gives you the flexibility of opening Photoshop (PSD) files that are saved in RGB, CMYK, and grayscale modes while preserving pixel-based layers and mask channels (also referred to as alpha channels). You can also open TIFF files in Corel Painter, but only one mask channel is preserved. Layered TIFF (TIF) files that you create in Photoshop are flattened when you open them in Corel Painter. When you work exclusively with RIFF (RIF), which is the native file format for Corel Painter, you retain Corel Painter specific elements when saving files. For instance, special paint media layers, such as Watercolor layers, require the RIFF format to retain the live “wet” capabilities. However, if you open a Photoshop file in Corel Painter but plan on reopening the file in Photoshop, you should continue to save the file to the Photoshop format.

Now roll up your sleeves, grab your stylus, and continue to explore Corel Painter.

About the author

An award-winning artist and author, Cher Threinen-Pendarvis is a pioneer in digital art. She has been widely recognized for her mastery of Corel Painter, Adobe Photoshop, and the Wacom pressure-sensitive tablet and has used these electronic tools since they were first released. Her artwork has been exhibited worldwide, her articles and art have been published in many books and periodicals, and she is a member of the San Diego Museum of Art Artist Guild. She has taught Corel Painter and Adobe Photoshop workshops around the world and is the principal of the consulting firm Cher Threinen Design. Cher is the author of The Photoshop and Painter Artist Tablet Book, Creative Techniques in Digital Painting, Beyond Digital Photography, and all nine editions of The Painter Wow! book. Visit Cher's web site at: www.pendarvis-studios.com.
Creating, navigating, and manipulating documents

The Corel Painter application provides a digital workspace in which you can create new images, or alter existing images, by using the Natural-Media tools and effects. Your working image, known as a document, is displayed in a document window. This document window includes navigation and productivity features to help you work efficiently.

As you create an image, you can save your document in various file formats, such as RIFF (the native Corel Painter format), JPEG, TIFF, and PSD (Adobe Photoshop). Corel Painter also lets you open or import images saved in many other file formats.

This section contains the following topics:

- “Creating documents” (page 96)
- “Understanding resolution” (page 97)
- “Opening and placing files” (page 98)
- “Creating and opening templates” (page 101)
- “Switching document views” (page 101)
- “Navigating images and viewing image information” (page 102)
- “Zooming images” (page 104)
- “Rotating images and the canvas” (page 106)
- “Flipping images” (page 108)
- “Repositioning images” (page 110)
- “Cropping images” (page 110)
- “Resizing images and the canvas” (page 111)
- “Saving and backing up files” (page 113)
- “Choosing a file format” (page 114)
- “Emailing documents” (page 116)
- “Closing documents and quitting the application” (page 116)
- “Using two monitors” (page 117)
- “Support for tablets and other devices” (page 117)
- “Multi-touch support” (page 117)
- “Wacom Intuos support” (page 119)
- “Drag-and-drop features” (page 120)
Creating documents

To start an image from a blank canvas, you must create a new document. This allows you to specify the canvas settings, such as width, height, and resolution. The size of the canvas determines the size of the image when it is printed. When you create a new document, first set the resolution, and then specify the width and the height. For more information about resolution, see "Understanding resolution" on page 97. To quickly get started, you can choose from a list of preset canvas settings. However, you can also specify custom settings, which you can save as a preset for future use. You can also specify the canvas color and texture.

Canvas size and aspect ratio

When you set the canvas size, choose options that correspond to the image’s destination. If you plan to print your work, the canvas dimensions determine the size of your artwork when it is printed. Consider the largest size at which you plan to print your artwork, as well as any smaller copies that you may need.

It is always better to start with a bigger canvas, because you can decrease the width and height of your image at any point without affecting its quality. A large size makes it easier to preserve image detail if you need to produce a smaller version of the image. However, if you start with a smaller image and then increase the image dimensions, the application inserts new pixels between existing pixels, and their colors are based on the colors of adjacent pixels. If you increase image dimensions significantly, images may appear stretched and pixelated.

When choosing a canvas size, make sure your document has the proper aspect ratio that will allow you to print to common canvas and paper sizes without cropping your artwork (for example, 8 in by 10 in, 11 in by 14 in, 16 in by 20 in, 18 in by 24 in, etc.).

For example, you can set the resolution of a new image at 300 pixels per inch (ppi), the width to 16 inches, and the height to 24 inches. This large size makes it easier to maintain image quality when you need to produce a smaller version of the image.

Note that the bigger the canvas size and resolution, the more pixels there are in a brushstroke, and the harder it may become for your computer to process it. To ensure optimal brush and application performance, experiment to find the largest canvas dimensions that work best for your painting and for your software and hardware configuration.

For information about resizing images, “Resizing images and the canvas” on page 111.

 Pixels-per-inch (ppi) is equivalent to dots per inch (dpi).

The maximum canvas size is 16,382 x 16,382 pixels. To prevent performance issues, start with a canvas that is smaller than 16,382 x 16,382 because layers expand when paint and effects are applied close to their edges.

To create a new document

1 Choose File ➤ New.
2 Type a filename in the **Image Name** text box.

3 From the **Canvas Preset** list box, choose a preset to automatically determine the size, resolution, color of the canvas, and the paper texture.

**You can also**

- **Change the unit of measurement for the document**: Choose a unit of measurement from the list box located to the right of the **Width** and **Height** boxes.

- **Change the document size**: Type values in the **Width** and **Height** boxes.

- **Change the number of pixels-per-inch (ppi) or pixels per centimeter that make up an image**: Type a value in the **Resolution** box.

- **Change the resolution type**: Choose a resolution type from the list box located to the right of the **Resolution** box.

- **Change the color of the canvas**: Click the **Color** selector, and choose a paper color from the color picker.

- **Change the texture of the canvas**: Click the **Paper** selector, and choose a paper texture from the **Papers** panel.

In the **New Image** dialog box, setting the document’s pixels-per-inch is equivalent to setting its dots per inch (dpi). For more information, see “Understanding resolution” on page 97.

**To create a custom canvas preset**

1 Choose **File** \(\rightarrow\) **New**.

2 Choose the settings that you want to save as a canvas preset.

3 Click the **Add** button \(\rightarrow\).

4 In the **Add Preset** dialog box, type a name in the **Preset Name** text box.

A custom canvas preset is not a template. Unlike a template, it does not allow you to store any content. A custom canvas preset allows you to store only canvas dimensions, resolution, color, and texture.

You can delete a canvas preset by choosing the preset name from the **Canvas Preset** list box and clicking the **Delete** button \(\rightarrow\).

**Understanding resolution**

When you work with images in a digital workspace, it is helpful to understand the concept and applications of resolution. Resolution refers to the amount of visual detail contained in an image.
A document’s resolution affects both its appearance on your computer screen and its print quality. You can specify a document’s resolution when you create a new document, save, or export a file.

Resolution and screen appearance

Most monitors have a resolution of 72 pixels-per-inch (ppi). The Corel Painter display default is 72 ppi, which means that each pixel in the Corel Painter image occupies one pixel on your monitor. The display resolution does not affect the document’s actual number of pixels-per-inch — it affects only how the image is displayed on the monitor.

For example, a 300-ppi image is displayed on-screen at approximately four times its actual size. Because each pixel in the Corel Painter image occupies one pixel on your monitor, and the monitor’s pixels are approximately four times the size of the image’s pixels (72 ppi versus 330 ppi), the image must appear four times larger on-screen in order to display all of the pixels. In other words, your 300-ppi document will be printed at approximately one-quarter of its on-screen size. To view the image at its actual size, you can set the zoom level to 25%.

If you set the dimensions in pixels and then change the number of pixels-per-inch (resolution), this change will affect the size of the printed image. If you set your document size in inches, centimeters, points, or picas and then change the resolution, the dimensions of the printed image will not be affected.

Pixels-per-inch (ppi) is equivalent to dots per inch (dpi).

An example of a high-resolution (left) and low-resolution (right) image. In printing terms, a higher dpi means that the printer will place more dots of ink for every inch of artwork.

Resolution and print quality

The resolution of output devices (printers) is measured in dots per inch, and in the case of halftones, lines per inch (lpi). Output device resolutions vary, depending on the type of press and paper used. In general, a photograph is output at a crisp 150 lpi if printed on glossy magazine stock, and at 85 lpi if printed on newspaper stock.

If you are using a personal laser or inkjet printer, set your document size in inches, centimeters, points, or picas at the dots-per-inch setting specific to your printer. For most artwork, 300 dpi is preferred. Most printers produce excellent output from images set at 300 ppi. Increasing the file’s pixels-per-inch setting does not necessarily improve the output and may create a large, unwieldy file.

You can use 150 dpi for large prints because the difference in print quality is not very noticeable on large pieces when you look at the prints from a distance.

If you are using a commercial printer or a more sophisticated output device, the dimensions of the image should always be set to the actual size that you want the image to appear in the printed piece. A good rule of thumb is to set the number of pixels-per-inch to twice the desired lines per inch. So, at 150 lpi, the setting should be twice that, or 300 ppi; at 85 lpi, the setting should be 170 ppi. If you have questions about the resolution of specific output devices, it’s a good idea to check with the print service provider.

Opening and placing files

You can open files that were created in Corel Painter or in other applications. For example, you can open a file from another graphics application and use Corel Painter to add brushstrokes, tints, or paper textures.
You can also place a file in an existing Corel Painter document. The placed image becomes a new reference layer in the document — you can transform (resize, rotate, or slant) it on-screen by dragging its handles. A placed file maintains its link to the source file until you commit it to the standard layer format.

For more information, see "Working with reference layers" on page 605.

**Supported file formats**

Corel Painter lets you open the following file formats:

- RIFF (RIF) — native Corel Painter format
- TIFF (TIF)
- PNG
- CMYK TIF (TIF) — Because Corel Painter works with RGB colors, the CMYK TIF files that you open or import in the application are converted to an RGB color profile.
- Adobe Photoshop formats (PSD) — Corel Painter preserves layers, layer masks, alpha channels, and composite methods. Layer effects and adjustment layers are not supported and should be merged or flattened in Adobe Photoshop.
- Windows Bitmap (BMP)
- PC Paintbrush (PCX)
- TARGA (TGA)
- GIF — Corel Painter does not convert GIF animations to frame stacks.
- JPEG (JPG)

Windows only

- Frame stacks (FRM) — Corel Painter animation files
- QuickTime (MOV), Video for Windows (AVI), and numbered files. For more information, see “Opening a Corel Painter movie” on page 818 or "Importing and exporting numbered files" on page 827.
Corel Painter does not support LZW compressed TIFF file format. Only uncompressed TIFF files can be opened in Corel Painter.

To open a document

1. Choose File ➤ Open.
   Corel Painter displays the folder of the last file you opened.
2. In the Open dialog box, locate the file that you want to open.
   For each image, Corel Painter lists the dimensions (in pixels), file size, and file format. Files saved in Corel Painter include thumbnails for browsing.
3. Click Open.

The File menu also offers you a shortcut to previously opened documents. You can find your file in the recently opened files list by choosing File ➤ Recent, and clicking the filename to open the file.

To browse for a document (macOS)

1. Choose File ➤ Open.
2. Click Browse.
   The Browse dialog box shows thumbnails for all the RIFF files in a folder.
3. Double-click the filename, or select a file, and click Open.

To place a file

1. Choose File ➤ Place.
2. Select an image file, and click Open.
   The Place dialog box appears.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Place the image in a specific location in the document window</td>
<td>Click the area in the document window where you want to place the image.</td>
</tr>
<tr>
<td>Place the image in the center of the document window</td>
<td>Click OK.</td>
</tr>
<tr>
<td>Scale the image before placing</td>
<td>In the Scaling area, type a value in both the Horizontal and Vertical boxes.</td>
</tr>
<tr>
<td>Maintain the image proportions when scaling</td>
<td>In the Scaling area, enable the Constrain Aspect Ratio check box.</td>
</tr>
<tr>
<td>Retain the image mask</td>
<td>Enable the Retain Alpha check box. The image mask becomes a layer mask.</td>
</tr>
</tbody>
</table>
If the placed image contains a mask and you do not enable the Retain Alpha check box when placing, the image mask is discarded.

Creating and opening templates

If you regularly work with documents that contain similar dimensions, formatting, and resolution, you can create document templates so that you don’t have to start each document from scratch. When creating a template, you can add content to the canvas and save it as part of the template.

To save a document as a template
1. Create a file with the sizing, formatting, and resolution attributes you want.
2. Choose File > Save As.
3. In the Save (macOS) or Save Image As (Windows) dialog box, save the file to one of the following folders in your user folder:
   - (macOS) Corel Painter 2020\Support Files\Templates
   - (Windows) AppData\Roaming\Corel\Painter 2020\Default\Templates

   If you want the template to display under File > Open Template, you need to close and then reopen Corel Painter.

   In a multiuser environment, only users with Administrator status can add files to the Templates folder.
   In Windows, you need to ensure that all hidden files are displayed in order to access the AppData folder.

To open a document template
* Choose File > Open Template > {template name}.

You can also open a template by choosing Help > Welcome, and then choosing a template from the Document Template list.

Switching document views

You can switch between document views and viewing modes to suit your needs. The default setting Single Document View displays only the active document, hiding the other open documents. The Multi-document View displays all open documents. Both views display all standard tools in the workspace. For example, the menu bar, property bar, Brush selector bar, toolbox, and a few additional panels are readily accessible.

You can enable Presentation Mode, which hides your computer’s desktop and taskbar and centers the document window over a solid background. All Corel Painter features work when you use Presentation Mode. On macOS, Presentation Mode lets you display only one document at a time (Single Document View). On Windows, Presentation Mode lets you display one document or multiple documents (Multi-document View).

You can switch document views and viewing modes by using the Window menu, the toolbox, and keyboard shortcuts.
You can also change the default document view mode for the application. For more information, see “Interface preferences” on page 852.

To switch views

- Choose Window, and choose any of the following commands:
  - Single Document View — to switch between Multi-document View and Single Document View
  - Presentation Mode — to enable or disable Presentation Mode

You can switch views by clicking the Single Document View button and the Presentation Mode button in the toolbox.

You can also switch between Multi-document View and Single Document View by pressing Command + M (macOS) or Ctrl + M (Windows).

On Windows, you can enable and disable Presentation Mode by pressing F11.

Navigating images and viewing image information

You can use the Navigator panel to better orient yourself in the document window. For example, when you’re working at a high zoom level or with a large image, you can use the Navigator panel’s small canvas preview to display the entire image without having to zoom out. You can also move to a different image area without adjusting the zoom level. In addition, you can highlight which area is currently displayed in the document window.
The Navigator also lets you view the X and Y coordinates and cursor position to help you navigate the image. In addition, you can view document information, such as width and height; and unit information, such as pixels, inches, and resolution.

You can customize the appearance of the Navigator panel by hiding the image information area or the controls.

To display the Navigator panel
1. Choose Window ➤ Navigator.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to a different area of the image</td>
<td>In the Navigator panel, click a different</td>
</tr>
<tr>
<td>without adjusting the zoom level</td>
<td>area of the canvas preview.</td>
</tr>
<tr>
<td>Zoom to a specific magnification level</td>
<td>Open the Zoom Canvas list box, and adjust</td>
</tr>
<tr>
<td>in the document window</td>
<td>the zoom level slider.</td>
</tr>
<tr>
<td>Rotate the image in the document</td>
<td>Open the Rotate Canvas list box, and adjust</td>
</tr>
<tr>
<td>window</td>
<td>the rotation slider.</td>
</tr>
</tbody>
</table>

From the Navigator panel, you can also enable various tools by clicking the Open Navigator Settings button and choosing an option. The available tools include the drawing modes, Impasto, tracing paper, grids, and color management.
To hide or show the information area or controls of the Navigator panel

- In the **Navigator** panel, click the **Navigator options** button 📘, and disable one of the following options:
  - **Navigator Frame** — In the Navigator canvas preview window, hides the frame that shows the area that is currently displayed in the document window
  - **View Controls** — Hides the Navigator controls, such as canvas preview so that you can view the entire image without having to zoom out. You can also move to a different image area without adjusting the zoom level.
  - **Info** — Hides the X and Y coordinates, cursor position, and document information, such as width and height, and unit information, such as pixels, inches, and resolution

### Zooming images

By default, images are displayed at 100% magnification; however, you can zoom in to get a closer look at image detail or zoom out to view a larger portion of the image. You can change the level of magnification by zooming in and out with the **Magnifier** tool, resetting magnification, or zooming to fit the screen.

![The Magnifier tool lets you zoom in and out by clicking in the document window.](image)

The zoom mode you choose determines how the modifier **Shift** key affects the function of the **Magnifier** tool. For example, to zoom over an area in the default **Drag to Zoom** mode, you simply need to drag to the left or right; however, to perform the same task in the **Select Zoom Area** mode, you need to hold down **Shift** while dragging. Choose the mode that best fits your workflow. If you often zoom quickly in and out, but you rarely need to select specific areas, you may choose the **Drag to Zoom** mode. However, if your workflow requires that you often select specific areas to get a closer look at image detail, you can choose the **Select Zoom Area** mode; in this mode, you zoom in to a specific area by simply dragging across the area.

#### To zoom in preset increments

1. Click the **Magnifier** tool 🌱 in the toolbox or press **M**.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Click the image where you want to magnify it. The <strong>Magnifier</strong> cursor 🕣 shows a plus sign (+), which indicates that you are increasing the magnification (zooming in).</td>
</tr>
</tbody>
</table>
To Zoom out

Do the following

Hold down Option (macOS) or Alt (Windows) and click the image.
A minus sign (−) appears on the Magnifier cursor ☰, which indicates that you are decreasing the magnification (zooming out).

Each click increases or decreases the magnification to the next level, as defined in the Zoom Level box on the property bar.

You can also zoom in using the following keyboard shortcuts:

- (macOS) Hold down Command, and press + (plus sign).
- (Windows) Hold down Ctrl, and press + (plus sign).

You can also zoom out using the following keyboard shortcuts:

- (macOS) Hold down Command, and press – (minus sign).
- (Windows) Hold down Ctrl, and press – (minus sign).

When using a mouse, you can zoom in to or out from the image by using the mouse wheel.

To set the zoom mode

1. Click the Magnifier tool in the toolbox or press M.
2. On the property bar, choose an option from the Zoom Mode list box:
   - Drag to Zoom
   - Select Zoom Area

Corel Painter keeps the zoom mode setting from one session to the next.

To zoom by dragging

1. Click the Magnifier tool in the toolbox or press M.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>In this mode</th>
<th>Do one of the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Drag to Zoom</td>
<td>• Drag up.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Drag to the right.</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Select Zoom Area</td>
<td>• Hold down Shift and drag down.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Hold down Shift and drag to the left.</td>
</tr>
</tbody>
</table>

To zoom by selecting an area

1. Click the Magnifier tool in the toolbox or press M.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>In this mode</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drag to Zoom</td>
<td>Hold down Shift and drag across the area you want to magnify.</td>
</tr>
<tr>
<td>Select Zoom Area</td>
<td>Drag across the area you want to magnify.</td>
</tr>
</tbody>
</table>

To zoom to a specific magnification level
- Choose Window ➤ Navigator, and type a value in the Zoom canvas box.
  If you prefer, open the Zoom Canvas slider, and adjust the zoom level.

To reset magnification to 100%
- Double-click the Magnifier tool in the toolbox.

You can also reset magnification to 100% by clicking the Reset tool on the property bar or the Reset Zoom to 100% button in the Navigator panel.

To zoom to fit the screen
- Choose Window ➤ Zoom to Fit.
  Corel Painter generates a view of the entire document to fit your document window.

You can also zoom to fit the screen by clicking the Fit Screen button on the property bar.

To set zooming performance preferences
1 Click the Magnifier tool in the toolbox.
2 Click one of the following buttons on the property bar:
   - High Quality Display — smooths objects to minimize pixelation when zooming
   - Area Averaging — increases the speed at which the screen is drawn when you are viewing an image at less than 100% magnification. Enabling this option may decrease accuracy.

You can also specify zooming preferences by clicking Edit ➤ Preferences ➤ Performance, and enabling options in the View Options area.

Rotating images and the canvas
You can rotate an image on the screen to accommodate the way you draw naturally. You can also rotate the canvas to change the image orientation.
Rotating an image onscreen is meant for drawing purposes only; whereas rotating the canvas modifies the appearance of the image. For example, if you print an image that you rotated onscreen, the rotation is not reflected in the printed image. However, if you rotate the canvas of the image, the rotation is reflected in the printed image.

You can rotate an image or the canvas by a predefined amount, or you can choose the amount of rotation. You can also reset the original orientation of an image.

**To rotate an image**

1. From the toolbox, click the Rotate Page tool 
   
   If you prefer using a keyboard shortcut, hold down Option + Spacebar (macOS) or Spacebar + Alt (Windows).
   The cursor changes to a hand with a pointing finger 🖐️.

2. Drag in the document window to rotate the image.
   The new rotation angle appears on the property bar.

**You can also**

Constrain rotation to 90° increments

Hold down Shift while rotating.

Rotate an image by specifying a rotation angle

Type a rotation angle in the Rotation Angle box on the property bar or in the Navigator panel.

You can also rotate an image from the Navigator panel by typing a value in the Rotate canvas box or by opening the Rotate Canvas slider and adjusting the rotation.

**To reset the original orientation of an image**

1. In the toolbox, click the Rotate Page tool 

2. Do one of the following:

   • Click once in the document window.
   • Double-click the Rotate Page tool 
   • On the property bar, click the Reset Tool button 🔄.
You can also reset image rotation from the Navigator panel by clicking the Reset Rotation button.

To rotate the canvas
1. Choose Canvas ➤ Rotate Canvas.
2. Perform a task from the following table.

You can also

<table>
<thead>
<tr>
<th>Task</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the Canvas layer 180 degrees</td>
<td>Choose Canvas ➤ Rotate Canvas ➤ 180.</td>
</tr>
<tr>
<td>Rotate the Canvas layer 90 degrees clockwise</td>
<td>Choose Canvas ➤ Rotate Canvas ➤ 90 CW.</td>
</tr>
<tr>
<td>Rotate the Canvas layer 90 degrees counterclockwise</td>
<td>Choose Canvas ➤ Rotate Canvas ➤ 90 CCW.</td>
</tr>
<tr>
<td>Rotate the Canvas layer by a user-defined amount</td>
<td>Choose Canvas ➤ Rotate Canvas ➤ Arbitrary, and type a value in the Angle box.</td>
</tr>
</tbody>
</table>

If your document has layers of different types, you are prompted to commit all of them to default, pixel-based layers.

Flipping images
You can flip the canvas and all of its associated layers together, or you can flip a layer, selection, or the canvas individually. You can flip all or parts of an image horizontally (from left to right) or vertically (from top to bottom).
To flip the canvas and layers together

1. Choose **Canvas ➤ Rotate Canvas**.

2. Choose one of the following:
   - **Flip Canvas Horizontal**
   - **Flip Canvas Vertical**

   If your document has layers of different types, you are prompted to commit all of them to a default, pixel-based layer.

To flip the canvas, a layer, or a selection individually

1. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To flip</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The canvas</td>
<td>Click the <strong>Canvas</strong> in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td>A layer</td>
<td>Click one or multiple layers in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td>A selection</td>
<td>Click a selection tool from the toolbox, and drag in the document window to select an area.</td>
</tr>
</tbody>
</table>

2. Choose **Edit**, and choose one of the following:
   - **Flip Horizontal**
   - **Flip Vertical**
Repositioning images

You can reposition an image in the Corel Painter workspace in order to view, or work on, a different area of an image. You can also view a different area of an image when you’re zoomed in.

To reposition a document

1. In the toolbox, click the **Grabber** tool.
   
   The cursor changes to the **Grabber** tool.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll through the image</td>
<td>Drag in the document window.</td>
</tr>
<tr>
<td>Center the image</td>
<td>Click once in the document window.</td>
</tr>
</tbody>
</table>

You can also activate the **Grabber** tool by holding down the spacebar.

To reposition a document while zoomed in

1. Choose **Window** ➤ **Navigator**.

2. In the **Navigator** panel, click a different area of the preview area.

   If the **Navigator** frame is displayed, you can drag the frame to a different area of the canvas preview.

Cropping images

You can remove unwanted edges from the image with the **Crop** tool. You can adjust the aspect ratio of the cropped image and choose to maintain the aspect ratio. You can also remove unwanted areas of an image by resizing the canvas area. For more information, see “Resizing images and the canvas” on page 111.

To crop an image

1. In the toolbox, click the **Crop** tool.

2. Drag inside the image to define the rectangular area that you want to keep.
   
   You can adjust the rectangle by dragging a corner or any of its edges.

3. When you’re ready to execute the crop, click the **Commit Crop** button on the property bar.

   To cancel the crop, click the **Cancel Crop** button on the property bar.

   You can also execute the crop by double-clicking inside the rectangle.
To constrain cropping to a square
1. In the toolbox, click the Crop tool.
2. Hold down Shift, and drag to define the area for cropping.
3. Double-click inside the square.

To adjust the aspect ratio of the cropped image
1. In the toolbox, click the Crop tool.
2. On the property bar, type values in the Crop Ratio Width and Crop Ratio Height boxes.

Resizing images and the canvas
You can change the physical dimensions of an image by resizing the canvas and the image together, or by resizing the canvas area only. It is important to understand the distinction between the two resizing techniques.

When you resize the canvas and image together, the image dimensions and resolution change, but the image appearance doesn’t change. For example, if you resize a 300 ppi image to 150 ppi, the image size is smaller, but it looks the same.

The image was resized by modifying the resolution. Artwork by Chris Melby.
Alternatively, when you resize only the canvas area, both the image dimensions and appearance change. For example, if you increase the size of the canvas, a border appears around the image. If you decrease the size of the canvas, the edge of the canvas is trimmed. In addition, the image resolution is affected.

The canvas area is resized in order to apply an empty border around the edge of an image. Artwork by Chris Melby.
Changing the height and width of an image without changing the resolution results in quality loss. Left to right: image with smaller dimensions, original image, image with larger dimensions.

It is also important to note that the size of the onscreen image is affected by the pixel height and width of the image, the zoom level, and the monitor settings. As a result, an image may be displayed as a different size onscreen than when it is printed. For more information, see “Understanding resolution” on page 97 and “Creating documents” on page 96.

To resize the canvas and image content together

1. Choose Canvas ➤ Resize.
2. In the New Size area, type values in the Width and Height boxes.
   - If you enable the Constrain File Size check box, you need to type a value only in one of the boxes; the other values are adjusted automatically.
   - If you choose pixels or percent as the unit and enter a value, the Constrain File Size check box is automatically disabled.

   Increasing the image dimensions significantly may cause the image to appear stretched and pixelated.

To resize the canvas area

1. Choose Canvas ➤ Canvas Size.
2. In the Canvas Size dialog box, specify the number of pixels you want to add to any side of the canvas.
   - To reduce, or trim, the canvas size, specify negative values.

Saving and backing up files

You can save a file in its current format or in a different format. You can also track the changes that you make to a file by saving multiple versions of the file, also known as iterations. In addition, you have the option of creating backup files every time you save a document.

When you save an iteration of a file, an updated version of the file is saved with a version number added to the filename. For example, if you saved the original file as Image.RIF and then save an iteration of the file, the latest version of the file is saved as Image_001.RIF.
For each subsequent iterative save that you perform, the number added to the filename increases by 1, for example, Image_002.RIF and Image_003.RIF. Iterative saving is useful if you need to revert to an older version of a file, or simply to track your progress over time.

To save a file in its current format

- Choose File ➤ Save.

To save a file with a different name or in a different format

1. Choose File ➤ Save As.
2. In the Save (macOS) or Save Image As (Windows) dialog box, use the controls to specify a location, file name, and format.

To perform an iterative save

- Choose File ➤ Iterative Save.

The location of the last file saved is stored and used for iterative saves unless you specify a new location.

You can also perform an iterative save by pressing Command + Option + S (macOS) or Ctrl + Alt + S (Windows).

To create a backup file when saving

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ➤ Preferences.
   - (Windows) Choose Edit ➤ Preferences.
2. In the Preferences list of categories, click General.
3. Enable the Create backup on Save check box.

Choosing a file format

When you save a file, you must choose a file format. The following section contains information about some of the supported file formats.

Saving RIFF files

RIFF is the Corel Painter file format, which retains special information about your document. For example, a RIFF file maintains all layers.

RIFF files are best used as “work-in-progress” files. It is recommended that you always save files in RIFF format, and then save to GIF, JPEG, TIF, or another file format when a file is ready for production.

Corel Painter lets you compress files and save disk space with a lossless compression method. When saving in RIFF format, you can minimize the file size on your hard disk by ensuring that the Uncompressed option is disabled by default.

Saving JPEG files

Corel Painter supports the JPEG file format. Unlike GIF, the JPEG file format displays a full range of colors.

The JPEG file format lets you compress your file on a scale of Fair to Excellent, where quality is directly proportional to file size. These quality settings will let you achieve compression ratios ranging from less than 10:1 to greater than 100:1. JPEG is a “lossy” file format, meaning that a compressed JPEG file will not be identical, pixel-for-pixel, to the original. However, because the JPEG algorithm takes into account the sensitivity of the eye to different colors, the higher-quality settings should achieve visually satisfying results.

You can assign a URL to layers and placed images and then save the file in GIF or JPEG format to produce an image map. For more information, see “Creating image maps” on page 863.

When you save a file in JPEG format, Corel Painter displays the JPEG Encoding Quality dialog box, with the following options:
• The **Quality** options — **Excellent**, **High**, **Good**, and **Fair** — let you set the degree of file compression. The **Excellent** option compresses the least, but retains the most data. **Fair** compresses the most, but loses the most data. You can also use the **Quality** slider to adjust file compression.

• The **Smoothness** slider applies smoothing to the entire image. This is useful when using the **Fair** option to blur the edges of JPEG artifacts. The default is 0. Keep in mind that using a high smoothness setting can cause blurring.

• The **Progressive** JPEG check box creates a progressive JPEG file. The progressive format is useful for files designed for the Web. As the name implies, the progressive format displays an image in stages — as a series of scans — while the file downloads. The first scan is a low-quality image; the following scans improve in quality. This allows the user to see the whole image quickly.

• The **HTML Map Options** — **NCSA Map File**, **CERN Map File**, and **Client Side Map File** — let you generate an image map. (NCSA refers to the National Center for Supercomputing Applications, and CERN refers to the Conseil Europeen pour la Recherche Nucléaire.) Use the NCSA Map File or CERN Map File option to generate a server-side image map. Use the Client Side Map File option to generate a client-side image map.

For more information, see “Creating image maps” on page 863.

It is best not to decompress and recompress a file multiple times. Although JPEG can compress and discard data that is not visible or obvious, the degradation of the data can affect the condition of your file.

When a file has lost a significant amount of data, block patterns may appear in areas of the image. If you try to use the **Apply Surface Texture** feature on a JPEG file, you may find that the block patterns become more prominent.

**Saving GIF files**

Corel Painter lets you save documents as GIF files. GIF, a file format using 8 or fewer bits, is commonly used to display graphics on the Web. When you save a GIF file, you can choose settings from 4 Colors to 256 Colors. You can choose how your colors will be displayed and what part of your image will be transparent.

You can enable the **Color Set** option to force all colors in the color table of the GIF file to match the colors in the current color set. This option can be useful when you are doing Web work, especially if you want to constrain colors to a specific color set or control the number of colors on a Web page, thus controlling the image file size.

The **Imaging Method** setting determines how a 24-bit Corel Painter document will be converted to the limited number of colors that GIF uses. If you choose **Quantize to Nearest Color**, Corel Painter may replace some colors with colors that are located next to each pixel. If you choose **Dither Colors**, Corel Painter applies a pattern to the chosen colors to generate a more accurate, less banded result.

Corel Painter can also save a frame stack as a GIF animation file. For more information, see “Exporting animated GIFs” on page 828.

If you want your image to have transparency, enable the **Output Transparency** check box. Most programs that display GIF files support transparency, but for those that don’t, you should specify the color of the “transparent” area. If your image will be displayed on the Web, enable the **Background is WWW Gray** option. You can also choose to use the background color of your Web page by enabling the **Background is BG Color** option.

For programs that support transparency, your selection will determine which areas are transparent. The **Threshold** slider determines which selection (loaded mask) value becomes transparent. You can see how the **Threshold** slider affects the transparency of your image in the Preview window of the dialog box. Transparency is displayed in the Preview window by a rectangular lattice. You can toggle between the Preview window and your **Save As GIF** options to the results you want. Enable the **Interlaced** check box if your image will be displayed on a Web page.

For more information, see “Selections and transformations” on page 619.

**Saving RGB TIF files**

The TIF format facilitates exchange between applications and computer platforms. It is a widely supported bitmap image format that lets you save RGB color profile information.

**Saving Adobe Photoshop (PSD) files**

Corel Painter can save files in Adobe Photoshop (PSD) format. For optimum compatibility, shapes and text are rasterized, and masks are placed in channels.

When you save a file in PSD format, you can embed the RGB color profile, as you do when saving in TIF format.
Saving Encapsulated PostScript (EPS) files

The encapsulated PostScript (EPS) files in Corel Painter conform to the Desktop Color Separation (DCS) 2.0 format (EPS-DCS 5 file format). Although Corel Painter saves files in EPS-DCS, it can’t read EPS-DCS. If you plan to save an image in EPS-DCS, it’s a good idea to save it in another format first, so that you’ll have a copy of it that you can reopen in Corel Painter.

When you save an image as an EPS-DCS file with Preview Options turned on, Corel Painter uses the loaded International Color Consortium (ICC) profile to prepare the separation files. For more information, see “Printing images” on page 839.

Although you can save your images as CMYK EPS separations, Corel Painter can’t open or edit CMYK files.

When you save a file in EPS-DCS, Corel Painter opens the EPS Save Options dialog box, with these options:

- **Hex (ASCII) Picture Data** provides another way of storing PostScript information. Some page design programs require that this option be checked. The file sizes will be approximately twice as large when saved with this option.
- **Preview options** — No Preview, Black and White Preview, and Color Preview — specify whether to save preview data and in what format. The resulting preview file is a low-resolution (72-ppi) file.

  If you have an older laser printer, you must use the black and white preview to print these files. Although the preview or display is black and white, the color information remains intact.

Emailing documents

Corel Painter lets you email documents by using the default email application installed on your computer.

**To email a document**

1. Choose **File ➤ Email Image**.
2. Type the image name in the **Image Name** text box.
3. In the **Select Image Format** area, enable one of the following options:
   - JPEG
   - PNG
   - TIFF

Closing documents and quitting the application

You can close documents or quit Corel Painter by using menu commands, keyboard shortcuts, or the **Close** button of the current window.

**To close a document**

- Choose **File ➤ Close**.

**You can also**

- **Close the current window**
  - Click the **Close** button.

- **Close the current document by using a keyboard shortcut**
  - Press **Command + W** (macOS) or **Ctrl + W** (Windows).

**To quit Corel Painter**

- **Do one of the following:**
• (Windows) Choose File ▶ Exit.

You can also quit Corel Painter by pressing Command + Q (macOS) or Ctrl + Q (Windows).

Using two monitors

The Corel Painter user interface can be displayed across two or more monitors. You can drag any of the Corel Painter panels, palettes, the property bar, and the toolbox to any monitor; however, each panel or palette must be displayed entirely on one monitor at a time. If a panel or palette straddles two monitors, it automatically snaps to the nearest vertical edge of the monitor displaying the large portion of the panel or palette. If the panel or palette is displayed equally on both monitors, it snaps to the vertical edge of the left monitor.

For best performance, make sure that both monitors are set to the same resolution. In Windows, you must stretch the application window to straddle both monitors, then redesign your workspace. For information about configuring your system so that Corel Painter is displayed across two or more monitors, refer to the documentation of your operating system.

Support for tablets and other devices

Corel Painter supports Wacom-compatible tablets and devices as well as devices that support the Real-Time Stylus (RTS) feature of the Windows operating system. Both groups have multi-touch capabilities.

Wacom-compatible devices are supported on both macOS and Windows. For more information, see “Wacom Intuos support” on page 119. RTS-compatible devices include tablet PCs and graphics tablets and are supported only on Windows.

By default, Corel Painter uses tablet options that are suitable for Wacom-compatible devices. To take full advantage of your RTS-compatible graphics tablet or other device with Corel Painter, you must configure it first. Otherwise, you cannot use stylus information such as pressure and tilt to adjust and control brushstrokes.

To configure your device (Windows)

1. Make sure your device is connected and has the latest driver software installed.
2. Choose Edit ▶ Preferences ▶ Tablet.
3. Depending on your stylus input device, enable one of the following options in the Tablet settings area:
   • Wacom-compatible device (Wintab)
   • RTS-compatible device (Real-Time Stylus)
4. Restart Corel Painter.

Multi-touch support

Corel Painter supports two ways of working with gestures: with multi-touch mode enabled (default) or disabled.

When you enable multi-touch support, you can simultaneously pan, rotate, and zoom the canvas. This provides a seamless and responsive way of positioning and navigating the canvas. For example, you can rotate and move the canvas at the same time by moving two fingers in a circular motion while simultaneously swiping them across the tablet. You can also rotate and zoom by moving two fingers in a circular motion while simultaneously pinching the fingers together, or pulling them apart. In addition, you can quickly restore the canvas position, rotation, and zoom level.
You can simultaneously perform panning (1), zooming (2), and rotating (3).

You can also change the reference point, around which rotating and zooming takes place. If you’re not using a multi-touch tablet, by default the reference point is located at the center of the image. However, when using a multi-touch tablet, the reference point changes depending on the finger positions. Corel Painter sets the reference point at the center of the space that’s between your two fingers.

Changing the finger positions from the center of the image (1) allows you to move the reference point (2).

When the multi-touch mode is disabled, you cannot simultaneously pan, rotate, and zoom the canvas. Disabling multi-touch is useful if you find that the canvas moves unexpectedly or that brushstrokes do not apply paint as expected.

To restore the canvas position, rotation, and zoom level

• Double-tap two fingers simultaneously on the tablet.

To enable or disable multi-touch support (macOS)

1 Choose Corel Painter 2020 ▶ Preferences ▶ Tablet.
2 Enable or disable the Enable multi-touch for Wacom devices option.

To enable or disable multi-touch support (Windows)

1 Choose Edit ▶ Preferences ▶ Tablet.
2 In the Multi-touch options area, enable or disable the Enable multi-touch check box.
   If multi-touch support is enabled, choose one of the following options:
• **Wacom and Windows touch devices (recommended)** — This option provides enhanced support both for Windows touch systems and Wacom Intuos Pro, Cintiq, and other Wacom-compatible devices. Use this option if you have a Wacom tablet connected to a Windows touch-enabled device and you want to manipulate your document both with the Wacom tablet and the touchscreen device.

• **Wacom device** — This option, available both on macOS and Windows, provides enhanced support only for Wacom Intuos Pro, Cintiq, and other Wacom-compatible devices.

• **Windows touch device** — This option provides enhanced support only for Windows touch-enabled devices, for example, Surface Pro tablets with a touch screen. With this option, your gestures on the tablet or device behave the same way in Corel Painter as in other applications.

### Wacom Intuos support

Corel Painter supports the use of Wacom® Intuos® tablet, pen, and airbrush technology.

**Painting with an Intuos tablet and pen**

The Intuos tablet provides increased pressure sensitivity to help you create smooth curves, gradual transitions, and precise brushstrokes. When using an Intuos tablet with Corel Painter, you can take advantage of tilt and bearing input in exciting ways.

**Customizing brush tracking**

Every artist uses different pressure when drawing on an Intuos tablet. The Corel Painter brush tracking preferences help you customize your Intuos tablet to meet your pressure sensitivity needs. For more information, see “Brush tracking and calibration” on page 146.

**Linking stylus features to Expression settings**

The Expression settings in the brush control panels let you tie brush features like Opacity, Grain, Angle, Size, Jitter, Resaturation, Bleed, Flow, and Depth to stylus data, such as Velocity, Direction, Pressure, Wheel (for airbrushes), Tilt, and Bearing. For more information, see “Expression settings” on page 373.

**Using the Min Size setting**

In Corel Painter, the Min Size setting lets you take full advantage of stylus input data. When Size is set in the Expression panel of the Brush Controls palette to respond to stylus pressure, and the Min Size setting is set to a small percentage of the brush size, the strokes you make with the stylus create amazingly realistic results.

**Using the Intuos airbrush wheel**

The Intuos Airbrush — the first true computer airbrush — provides fingertip media flow control. Corel Painter airbrushes respond to angle (tilt), bearing (direction), and flow (wheel setting) data from the Intuos stylus, allowing for a truly realistic brushstroke. For example, as you tilt your stylus, specks of media land on the paper in a way that reflects that tilt. Corel Painter airbrushes create conic sections that mirror your stylus movements.

Corel Painter airbrushes take advantage of the Intuos Airbrush stylus wheel control. Like the needle control on a real airbrush, the Intuos wheel control adjusts airbrush flow, or how much medium is applied. For more information, see “Airbrushes” on page 457.

**Painting with the Wacom Art Pen**

For more information, see “Barrel rotation” on page 154.

**Using multiple Intuos pens**

All Intuos pens — both standard and airbrush — feature Tool ID, which lets you configure and work with multiple pens during a Corel Painter session. For example, let’s assume you have two Intuos pens: Pen 1 and Pen 2. Pen 1 is set to an Oil brush variant; Pen 2 is set to an Artists variant.

Every time you bring Pen 1 into the tablet’s proximity, Corel Painter automatically changes the active brush to the Oil brush. Every time you bring Pen 2 into the tablet’s proximity, Corel Painter switches to the Artists brush. If you’ve adjusted the tool assigned to a pen’s size or other settings, Corel Painter remembers those changes for the next time you use that pen.
Drag-and-drop features

Corel Painter supports drag-and-drop copying of documents and layers from one window to another.

Dragging layers between documents

You can copy layers between Corel Painter documents by dragging from one window to the other. When you drag a layer to a new document, the layer keeps its original properties. For more information, see "Moving layers" on page 580.

Dragging between programs

Corel Painter supports drag-and-drop functionality between applications. This can be a quick, convenient way to acquire images. For example, you can drag files from Adobe Photoshop directly into Corel Painter.
Evaluating your system and optimizing application settings for Corel Painter

The Brush Accelerator utility gives insight into how Painter will perform on your system by evaluating how well its processor (CPU), graphics processor (GPU), and memory (RAM) meet recommended performance specifications and then optimizes application settings to leverage system hardware.

This section contains the following topics:
- “Evaluating your system” (page 121)
- “Understanding test results” (page 122)

Evaluating your system

It typically takes only a few minutes to run the Brush Accelerator. Before running the test, you should save and close all open documents.

During the test, it’s recommended to close all unnecessary applications. Interacting with other applications while the Brush Accelerator is running can affect the test results. The test may take several minutes.

To run the Brush Accelerator

1. On the Welcome Screen, click the Performance tab. If the Welcome Screen isn’t open, choose Help ➤ Welcome.
2. Click Optimize Now.

To cancel the test at any time, press Esc.

If your report scores are low, you can still run Painter. For the best experience, try using the Fast and Simple brush category and working on smaller documents.

You can also run the Brush Accelerator from the Performance page of the Preferences dialog box (for more information, see “Performance preferences” on page 854), the Performance panel (for more information, see “Performance controls” on page 387), and the Advanced Brush Controls panel.
Understanding test results

If you see...

Results displayed in green
System exceeds recommended specifications.

Results displayed in red
System is below recommended specifications.

Results displayed in yellow
System components meet recommended specifications.

Brush Benchmark score and rating
Represents the general speed of brush performance and rates your system. If you see a low Brush Benchmark, consider updating your GPU.

Painter Accelerators
Indicates which components (processor multi-core, processor extensions, graphics processor, memory) contribute to brush speed, and how each one of them affects brush performance. Not all systems have all of these components.

If a detected graphics processor doesn't appear as a Painter Accelerator, it is not being used by Painter. Consider updating your GPU.

Overall system score
Indicates how your system measures up to recommended specifications.

Processor (CPU) warning
System doesn't have the recommended number of cores. More cores will enhance system performance.

Extensions (CPU) warning
System doesn’t have a CPU with AVX2. Systems with an AVX2-compatible CPU deliver enhanced performance.

Graphics processor warning
System's GPU isn't OpenCL 1.2 compliant, making it incompatible with Painter. Check driver compatibility and consider updating your drivers.

Memory warning
System doesn't have the recommended level of RAM. Performance will be enhanced on a system with more RAM.

Recommended system actions
Provides suggestions to increase performance for any component that falls below recommended specifications.

Recommended brushes
Provides suggestions for brush categories that work well with your system.
Keyboard shortcuts

Many features in Corel Painter have keyboard shortcuts which allow you to access a variety of tools quickly and easily using the keyboard, rather than selecting them from a menu or panel.

The four modifier keys on a macOS-compatible keyboard are Command, Option, Shift, and the Spacebar.

The four modifier keys on the Windows keyboard are Ctrl, Alt, Shift, and the Spacebar.

The keyboard shortcuts rely on four modifier keys on macOS-compatible and Windows keyboards: Command, Option, Shift, and the Spacebar on the macOS; and Ctrl, Alt, Shift, and the Spacebar on Windows.
Some of the same key combinations are reused to provide different actions depending on which tool is currently selected. For example, holding down the Shift key while using the Rectangle shape tool constrains the shape to a square; whereas holding down the Shift key while using a Cloning brush sets the clone destination.

This section contains the following topics:
- “Customizing keys” (page 124)
- “Toolbox commands” (page 126)
- “Panel commands” (page 128)
- “Corel Painter menu commands (macOS)” (page 129)
- “File menu commands” (page 129)
- “Edit menu commands” (page 130)
- “Canvas menu commands” (page 130)
- “Layers menu commands” (page 131)
- “Select menu commands” (page 131)
- “Shapes menu commands” (page 132)
- “Effects menu commands” (page 132)
- “Window menu commands” (page 132)
- “Help menu commands” (page 133)
- “Screen navigation” (page 133)
- “Panel navigation” (page 133)
- “Panel menu commands” (page 133)
- “Brush tools” (page 134)
- “Selection tools” (page 136)
- “Adjuster tools” (page 136)
- “Shape tools” (page 138)
- “Animation” (page 139)
- “Lighting” (page 139)
- “Layer selection tools” (page 139)
- “Mosaics” (page 140)
- “Other commands” (page 140)

Customizing keys

Corel Painter lets you assign commands to keys on your keyboard. This saves you time by giving you immediate keyboard access to your favorite commands. Along with character, numeric, function, and modifier keys, you can also use Tab, Backspace (Windows), Delete, Insert, Home, End, Page Up, Page Down, Up Arrow, Down Arrow, Left Arrow, Right Arrow, and Spacebar. You can use keys already used for other shortcuts.

You can also create a collection of keyboard shortcuts, or key sets, based on changes to the default key set. For easy reference, you can generate an HTML summary of a key set.

To assign commands to keys

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ➔ Preferences ➔ Customize Keys.
   - (Windows) Choose Edit ➔ Preferences ➔ Customize Keys.
   
     If you want to modify keyboard shortcuts that you previously stored in a key set, choose the key set from the Key Set list box.

2. Choose one of the following options from the Shortcuts list box:
   - Application Menus — lets you create or modify menu bar command shortcuts
   - Panel Menus — lets you create or modify panel menu command shortcuts
   - Tools — lets you create or modify tools shortcuts
• **Other** — lets you create or modify command shortcuts for items that are not menus, panels, or tools

3. Choose a command from the **Application Commands** list.

4. In the **Shortcut** column next to the command, type the shortcut keys you want to assign.

   If you typed a unique shortcut key, you can click **OK** to exit the **Preferences** dialog box.

   If the shortcut you assigned is already in use, a message appears below the **Application Commands** list. To proceed, you need to perform a task from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign the shortcut to the selected command while deleting the shortcut key from the conflicting command</td>
<td>Click <strong>Accept</strong>.</td>
</tr>
<tr>
<td>Assign the shortcut to the new command and then assign another keyboard shortcut to the conflicting command</td>
<td>Click <strong>Accept</strong> and <strong>Go To Conflict</strong>.</td>
</tr>
</tbody>
</table>

**To revert keyboard shortcuts**

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revert the last keyboard shortcut you created or modified</td>
<td>Click <strong>Undo</strong>.</td>
</tr>
<tr>
<td>Revert to all keyboard shortcuts you created or modified since you opened the <strong>Preferences</strong> dialog box</td>
<td>Click <strong>Reset</strong>. In the warning dialog box, click <strong>Yes</strong>.</td>
</tr>
<tr>
<td>Revert all keyboard shortcuts to their default settings</td>
<td>Click <strong>Defaults</strong>. In the warning dialog box, click <strong>Yes</strong>.</td>
</tr>
</tbody>
</table>

**To manage key sets (macOS)**

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open an existing key set</td>
<td>Click <strong>Open</strong>. In the <strong>Open Key Set</strong> dialog box, select a key set, and click <strong>Open</strong>.</td>
</tr>
<tr>
<td>Create a new key set from the existing key set</td>
<td>Click <strong>New</strong>. In the <strong>Save New Key Set</strong> dialog box, type a name for the key set in the <strong>Save As</strong> box, and click <strong>Save</strong>.</td>
</tr>
<tr>
<td>Save the active key set</td>
<td>Click <strong>Save</strong>. In the <strong>Save Key Set</strong> dialog box, type a name for the key set in the <strong>Save As</strong> box, and click <strong>Save</strong>.</td>
</tr>
<tr>
<td>Create an HTML summary of the active key set</td>
<td>Click <strong>Export to HTML</strong>. In the <strong>Save Summary</strong> dialog box, type a name in the <strong>Save As</strong> box, and click <strong>Save</strong>.</td>
</tr>
<tr>
<td>Delete the active key set</td>
<td>Click <strong>Delete</strong>.</td>
</tr>
</tbody>
</table>
Key set files created on the macOS cannot be imported into Corel Painter on Windows. Likewise, key set files created on Windows cannot be imported into Corel Painter on the macOS.

To manage key sets (Windows)

To

Do the following

Open an existing key set

Click the Open button in the Open Key Set dialog box, select a key set, and click Open.

Create a new key set from the existing key set

Click the New From Existing button in the Save New Key Set dialog box, type a name for the key set in the Filename box, and click Save.

Save the active key set

Click the Save Active Set button in the Save Key Set dialog box, type a name for the key set in the Filename box, and click Save.

Create an HTML summary of the active key set

Click the Create HTML Summary button in the Save Summary dialog box, type a name in the Filename box, and click Save.

Delete the active key set

Click the Delete button.

Key set files created on the macOS cannot be imported into Corel Painter on Windows. Likewise, key set files created on Windows cannot be imported into Corel Painter on the macOS.

Toolbox commands

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Shortcut key</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Navigation and Utility tools</strong></td>
<td></td>
</tr>
<tr>
<td>Magnifier</td>
<td>M</td>
</tr>
<tr>
<td>Grabber</td>
<td>G</td>
</tr>
<tr>
<td>Rotate Page</td>
<td>E</td>
</tr>
<tr>
<td>Divine Proportion</td>
<td></td>
</tr>
<tr>
<td>Tool name</td>
<td>Shortcut key</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Layout Grid</td>
<td>/</td>
</tr>
<tr>
<td>Perspective Guides (opens property bar)</td>
<td>.</td>
</tr>
<tr>
<td>Crop</td>
<td>C</td>
</tr>
</tbody>
</table>

### Drawing and painting tools

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Shortcut key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brush (Freehand line)</td>
<td>B</td>
</tr>
<tr>
<td>Brush (Straight line)</td>
<td>V</td>
</tr>
<tr>
<td>Paint Bucket</td>
<td>K</td>
</tr>
<tr>
<td>Dropper</td>
<td>D</td>
</tr>
<tr>
<td>Dodge</td>
<td>-</td>
</tr>
<tr>
<td>Burn</td>
<td>=</td>
</tr>
<tr>
<td>Cloner</td>
<td>;</td>
</tr>
<tr>
<td>Rubber Stamp</td>
<td>'</td>
</tr>
<tr>
<td>Eraser</td>
<td>N</td>
</tr>
</tbody>
</table>

### Selection tools

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Shortcut key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular selection</td>
<td>R</td>
</tr>
<tr>
<td>Oval selection</td>
<td>O</td>
</tr>
<tr>
<td>Lasso</td>
<td>L</td>
</tr>
<tr>
<td>Polygonal selection</td>
<td>Shift + L</td>
</tr>
<tr>
<td>Magic wand</td>
<td>W</td>
</tr>
</tbody>
</table>

### Adjuster tools

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Shortcut key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer adjuster</td>
<td>F</td>
</tr>
<tr>
<td>Selection adjuster</td>
<td>S</td>
</tr>
<tr>
<td>Tool name</td>
<td>Shortcut key</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>Shape selection</td>
<td>H</td>
</tr>
</tbody>
</table>

**Shape design tools**

- Pen                  P
- Quick curve           Q
- Text                 T

**Shape object tools**

- Rectangular shape    I
- Oval shape           J

**Shape edit tools**

- Scissors             Z
- Add point            A
- Convert point        Y
- Remove point         X

**Transform tool**

- Transform tool       Option + Command + T (macOS)
                        Alt + Ctrl + T (Windows)

**Symmetry tools**

- Mirror tool          ‘

Kaleidoscope tool       Shift + ‘

**Panel commands**
<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brush controls panel (General or All)</td>
<td>Command + B</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Colors</td>
<td>Command + 1</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>Mixer</td>
<td>Command + 2</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>Color sets</td>
<td>Command + 3</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Layers</td>
<td>Command + 4</td>
<td>Ctrl + 4</td>
</tr>
<tr>
<td>Channels</td>
<td>Command + 5</td>
<td>Ctrl + 5</td>
</tr>
<tr>
<td>Clone source</td>
<td>Command + 6</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>Navigator</td>
<td>Command + 7</td>
<td>Ctrl + 7</td>
</tr>
<tr>
<td>Patterns</td>
<td>Command + 8</td>
<td>Ctrl + 8</td>
</tr>
<tr>
<td>Papers</td>
<td>Command + 9</td>
<td>Ctrl + 9</td>
</tr>
</tbody>
</table>

**Corel Painter menu commands (macOS)**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferences ▶ General</td>
<td>Command + ,</td>
</tr>
<tr>
<td>Preferences ▶ Brush Tracking</td>
<td>Command + Shift + ,</td>
</tr>
<tr>
<td>Preferences ▶ Customize Keys</td>
<td>Command + Option + ,</td>
</tr>
<tr>
<td>Hide Corel Painter 2020</td>
<td>Command + H</td>
</tr>
<tr>
<td>Hide others</td>
<td>Command + Option + H</td>
</tr>
<tr>
<td>Quit</td>
<td>Command + Q</td>
</tr>
</tbody>
</table>

**File menu commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Command + N</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Open</td>
<td>Command + O</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Close</td>
<td>Command + W</td>
<td>Ctrl + W</td>
</tr>
<tr>
<td>Save</td>
<td>Command + S</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Save as</td>
<td>Shift + Command + S</td>
<td>Shift + Ctrl + S</td>
</tr>
<tr>
<td>Iterative save</td>
<td>Command + Option + S</td>
<td>Ctrl + Alt + S</td>
</tr>
<tr>
<td>E-mail image</td>
<td>Option + Command + E</td>
<td>Alt + Ctrl + E</td>
</tr>
<tr>
<td>Page setup</td>
<td>Shift + Command + P</td>
<td>Shift + Ctrl + P</td>
</tr>
<tr>
<td>Print</td>
<td>Command + P</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Exit (Windows)</td>
<td></td>
<td>Ctrl + Q</td>
</tr>
</tbody>
</table>

### Edit menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Command + Z</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command + Y</td>
<td>Ctrl + Y</td>
</tr>
<tr>
<td>Fade</td>
<td>Command + Shift + F</td>
<td>Ctrl + Shift + F</td>
</tr>
<tr>
<td>Cut</td>
<td>Command + X</td>
<td>Ctrl + X</td>
</tr>
<tr>
<td>Copy</td>
<td>Command + C</td>
<td>Ctrl + C</td>
</tr>
<tr>
<td>Copy merged</td>
<td>Command + Option + C</td>
<td>Shift + Ctrl + C</td>
</tr>
<tr>
<td>Paste</td>
<td>Shift + Command + V</td>
<td>Shift + Ctrl + V</td>
</tr>
<tr>
<td>Paste in place</td>
<td>Command + V</td>
<td>Ctrl + V</td>
</tr>
<tr>
<td>Fill</td>
<td>Command + F</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>Free transform</td>
<td>Option + Command + T</td>
<td>Alt + Ctrl + T</td>
</tr>
<tr>
<td>Preferences ▸ General</td>
<td></td>
<td>Ctrl + ,</td>
</tr>
<tr>
<td>Preferences ▸ Brush tracking</td>
<td></td>
<td>Shift + Ctrl + ,</td>
</tr>
<tr>
<td>Preferences ▸ Customize Keys</td>
<td></td>
<td>Ctrl + Alt + ,</td>
</tr>
</tbody>
</table>

### Canvas menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize</td>
<td>Shift + Command + R</td>
<td>Shift + Ctrl + R</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Tracing paper</td>
<td>Command + T</td>
<td>Ctrl + T</td>
</tr>
<tr>
<td>Show/Hide rulers</td>
<td>Command + R</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Symmetry ▶ Mirror Mode</td>
<td>Option + Command + M</td>
<td>Ctrl + Alt + M</td>
</tr>
<tr>
<td>Symmetry ▶ Show/Hide Mirror</td>
<td>Shift + Command + M</td>
<td>Ctrl + Shift + M</td>
</tr>
<tr>
<td>Symmetry ▶ Kaleidoscope Mode</td>
<td>Command + K</td>
<td>Ctrl + K</td>
</tr>
<tr>
<td>Symmetry ▶ Show/Hide Kaleidoscope Planes</td>
<td>Command + Shift + K</td>
<td>Ctrl + Shift + K</td>
</tr>
<tr>
<td>Show/Hide guides</td>
<td>Command + ;</td>
<td>Ctrl + ;</td>
</tr>
<tr>
<td>Snap to guides</td>
<td>Shift + Command + ;</td>
<td>Shift + Ctrl + ;</td>
</tr>
<tr>
<td>Show/Hide grid</td>
<td>Command + '</td>
<td>Ctrl + '</td>
</tr>
<tr>
<td>Color management settings</td>
<td>Option + Command + K</td>
<td>Alt + Ctrl + K</td>
</tr>
</tbody>
</table>

### Layers menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>New layer</td>
<td>Command + Shift + N</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>Select all layers</td>
<td>Command + Shift + 1</td>
<td>Ctrl + Shift + 1</td>
</tr>
<tr>
<td>Group</td>
<td>Command + G</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Command + U</td>
<td>Ctrl + U</td>
</tr>
<tr>
<td>Collapse</td>
<td>Command + E</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Dry digital watercolor</td>
<td>Command + Shift + L</td>
<td>Ctrl + Shift + L</td>
</tr>
</tbody>
</table>

### Select menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Command + A</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>None</td>
<td>Command + D</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Invert</td>
<td>Command + I</td>
<td>Ctrl + I</td>
</tr>
</tbody>
</table>
Command  macOS  Windows
Reselect  Shift + Command + D  Shift + Ctrl + D
Hide marquee  Shift + Command + H  Shift + Ctrl + H
Load selection  Shift + Command + G  Shift + Ctrl + G

Shapes menu commands

Command  macOS  Windows
Join endpoints  Shift + J  Shift + J
Duplicate  Command + ]  Ctrl + ]
Set shape attributes  Command + [  Ctrl + [

Effects menu commands

Command  macOS  Windows
Last effect  Command + /  Ctrl + /
2nd Last Effect  Command + Option + /  Ctrl + Alt + /
Tonal Control  Adjust Colors  Shift + Command + A  Ctrl + Shift + A
Tonal Control  Brightness/Contrast  Shift + Command + B  Ctrl + Shift + B
Tonal Control  Equalize  Shift + Command + E  Ctrl + Shift + E
Tonal Control  Negative  Shift + Command + I  Ctrl + Shift + I

Window menu commands

Command  macOS  Windows
Panels  Tab  Tab
Zoom in  Command + Plus sign  Ctrl + Plus sign
Zoom out  Command + Minus sign  Ctrl + Minus sign
Zoom to fit  Command + 0  Ctrl + 0
Actual size  Command + Option + 0  Ctrl + Alt + 0
### Command shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide application UI</td>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Hide panels</td>
<td>Shift + Tab</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Single document view</td>
<td>Command + M</td>
<td>Ctrl + M</td>
</tr>
</tbody>
</table>

### Help menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corel Painter 2020 Help</td>
<td>F1</td>
<td>F1</td>
</tr>
</tbody>
</table>

### Screen navigation

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll image with grabber</td>
<td>Spacebar</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Center image</td>
<td>Spacebar + click</td>
<td>Spacebar + click</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Spacebar + Command + click</td>
<td>Spacebar + Ctrl + click</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Spacebar + Command + Option + click</td>
<td>Spacebar + Ctrl + Alt + click</td>
</tr>
<tr>
<td>Rotate image</td>
<td>Spacebar + Option + drag</td>
<td>Spacebar + Alt + drag</td>
</tr>
<tr>
<td>Constrain rotate to 90 degrees</td>
<td>Shift + Option + Spacebar + drag</td>
<td>Spacebar + Alt + Shift + drag</td>
</tr>
<tr>
<td>Orient screen to default view</td>
<td>Shift + Option + click</td>
<td>Shift + Alt + click</td>
</tr>
</tbody>
</table>

### Panel navigation

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll contents of panel</td>
<td>Option + click + drag</td>
<td>Alt + click + drag</td>
</tr>
<tr>
<td>Expand/Collapse all panels</td>
<td>Shift + click on Open/Close triangle</td>
<td>Shift + click on Open/Close triangle</td>
</tr>
</tbody>
</table>

### Panel menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layers panel</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>New layer</td>
<td>Command + Shift + N</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>Group layers</td>
<td>Command + G</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>Ungroup layers</td>
<td>Command + U</td>
<td>Ctrl + U</td>
</tr>
<tr>
<td>Collapse layers</td>
<td>Command + E</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Select all layers</td>
<td>Command + Shift + 1</td>
<td>Ctrl + Shift + 1</td>
</tr>
<tr>
<td>Dry digital watercolor layer</td>
<td>Command + Shift + L</td>
<td>Ctrl + Shift + L</td>
</tr>
<tr>
<td><strong>Colors panel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toggle between main and additional</td>
<td>Shift + S</td>
<td>Shift + S</td>
</tr>
<tr>
<td>colors</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard colors</td>
<td>Shift + O</td>
<td>Shift + O</td>
</tr>
<tr>
<td>Use clone color</td>
<td>U</td>
<td>U</td>
</tr>
<tr>
<td><strong>Mixer panel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>When apply color tool or mix color</td>
<td></td>
<td></td>
</tr>
<tr>
<td>tool active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pan tool</td>
<td>Spacebar</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Zoom tool (zoom-in)</td>
<td>Command + Spacebar</td>
<td>Ctrl + Spacebar</td>
</tr>
<tr>
<td>Zoom tool (zoom-out)</td>
<td>Command + Spacebar + Option</td>
<td>Ctrl + Spacebar + Alt</td>
</tr>
<tr>
<td><strong>Channels panel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>Command + Shift + U</td>
<td>Ctrl + Shift + U</td>
</tr>
<tr>
<td><strong>Gradients panel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit gradient</td>
<td>Command + Shift + E</td>
<td>Ctrl + Shift + E</td>
</tr>
<tr>
<td><strong>Brush tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Command</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Brush controls</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dropper</td>
<td>Option</td>
<td>Alt</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Layer adjuster</td>
<td>Command</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Resize brush</td>
<td>Option + Command</td>
<td>Alt + Ctrl</td>
</tr>
<tr>
<td>Increase current brush size incrementally</td>
<td>]</td>
<td>]</td>
</tr>
<tr>
<td>Decrease current brush size incrementally</td>
<td>[</td>
<td>[</td>
</tr>
<tr>
<td>Constrain to 45 degrees</td>
<td>Shift</td>
<td>Shift</td>
</tr>
<tr>
<td>Adjust opacity in 10% increments</td>
<td>1 to 0 keys</td>
<td>1 to 0 keys</td>
</tr>
<tr>
<td>Unconstrained draw</td>
<td>Shift + 1</td>
<td>Shift + 1</td>
</tr>
<tr>
<td>Draw outside</td>
<td>Shift + 2</td>
<td>Shift + 2</td>
</tr>
<tr>
<td>Draw inside</td>
<td>Shift + 3</td>
<td>Shift + 3</td>
</tr>
<tr>
<td>Load nozzle</td>
<td>Command + L</td>
<td>Ctrl + L</td>
</tr>
</tbody>
</table>

**Cloners**

| Set clone source                             | Option                 | Alt                    |
| Set clone destination                        | Option + Shift         | Alt + Shift            |
| Re-link clone source                         | Command + Option + Clone | Ctrl + Alt + Clone |

**Colors**

| Correct colors                               | Command + Shift + K    | Ctrl + Shift + K       |
| Toggle between main and additional colors    | Shift + X              | Shift + X              |

**Gradations**

| Adjust spiral                                | Command + Angle Adjuster | Ctrl + Angle Adjuster |

**Paint bucket**
<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Limit fill extent</td>
<td>Drag</td>
<td>Drag</td>
</tr>
<tr>
<td>Dropper</td>
<td>Option</td>
<td>Alt</td>
</tr>
</tbody>
</table>

### Selection tools

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rectangle, Oval, and Lasso selection tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constrain to square or circle</td>
<td>Hold down Shift after you start to drag.</td>
<td>Hold down Shift after you start to drag.</td>
</tr>
<tr>
<td>Add to selection</td>
<td>Shift</td>
<td>Shift</td>
</tr>
<tr>
<td>Subtract from selection</td>
<td>Option</td>
<td>Alt</td>
</tr>
</tbody>
</table>

### Magic wand

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add color to selection</td>
<td>Shift + click</td>
<td>Shift + click</td>
</tr>
<tr>
<td>Add range of colors to selection</td>
<td>Shift + drag</td>
<td>Shift + drag</td>
</tr>
<tr>
<td>Remove color from selection</td>
<td>Option + click</td>
<td>Alt + click</td>
</tr>
<tr>
<td>Remove range of colors from selection</td>
<td>Option + drag</td>
<td>Alt + drag</td>
</tr>
</tbody>
</table>

### Adjuster tools

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer adjuster</td>
<td>Command (except when either the screen navigation or Shape tools are selected)</td>
<td>Ctrl (except when either the screen navigation or Shape tools are selected)</td>
</tr>
<tr>
<td>Selection adjuster</td>
<td>Command (when Selection tools are selected)</td>
<td>Ctrl (when Selection tools are selected)</td>
</tr>
<tr>
<td>Shape selection tool</td>
<td>Command (when Shape tools are selected)</td>
<td>Ctrl (when Shape tools are selected)</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td><strong>Layer adjuster</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Duplicate</td>
<td>Option + drag</td>
<td>Alt + drag</td>
</tr>
<tr>
<td>Delete layer</td>
<td>Command + Shift + D</td>
<td>Ctrl + Shift + D</td>
</tr>
<tr>
<td>Move layer by one screen pixel</td>
<td>Arrow keys</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Hide/Display marquee</td>
<td>Command + Shift + H</td>
<td>Ctrl + Shift + H</td>
</tr>
<tr>
<td>Attribute dialog box for current layer</td>
<td>Enter</td>
<td>Enter</td>
</tr>
<tr>
<td>Adjust opacity in 10% increments</td>
<td>1 to 0 keys</td>
<td>1 to 0 keys</td>
</tr>
<tr>
<td>Select all layers</td>
<td>Command + Shift + A</td>
<td>none</td>
</tr>
<tr>
<td>Deselect layers</td>
<td>Command + Shift + D</td>
<td>none</td>
</tr>
<tr>
<td>Select/Deselect mode</td>
<td>Command + Shift</td>
<td>Ctrl + Shift</td>
</tr>
</tbody>
</table>

**Selection adjuster**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reposition</td>
<td>Click inside active selection, and drag</td>
<td>Click inside active selection, and drag</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Option + drag</td>
<td>Alt + drag</td>
</tr>
<tr>
<td>Move selection by one screen pixel</td>
<td>Arrow keys, on canvas</td>
<td>Arrow keys, on canvas</td>
</tr>
<tr>
<td>Delete current selection</td>
<td>Delete</td>
<td>Backspace</td>
</tr>
<tr>
<td>Select/Deselect mode</td>
<td>Shift</td>
<td>Shift</td>
</tr>
</tbody>
</table>

**Free transform**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distort</td>
<td>Option + corner handles</td>
<td>Alt + corner handles</td>
</tr>
<tr>
<td>Perspective distort</td>
<td>Command + Option + corner handles</td>
<td>Ctrl + Alt + corner handles</td>
</tr>
<tr>
<td>Operation</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td><strong>Resize</strong></td>
<td>Corner handles</td>
<td>Corner handles</td>
</tr>
<tr>
<td><strong>Resize/Preserve aspect</strong></td>
<td>Shift + corner handles</td>
<td>Shift + corner handles</td>
</tr>
<tr>
<td><strong>Resize/One dimension</strong></td>
<td>Side handles</td>
<td>Side handles</td>
</tr>
<tr>
<td><strong>Rotate</strong></td>
<td>Command + corner handles</td>
<td>Ctrl + corner handles</td>
</tr>
<tr>
<td><strong>Skew</strong></td>
<td>Command + side handles</td>
<td>Ctrl + side handles</td>
</tr>
</tbody>
</table>

### Shape tools

<table>
<thead>
<tr>
<th>Operation</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Shape selection tool</strong></td>
<td>Command</td>
<td>Ctrl</td>
</tr>
<tr>
<td><strong>Shape design tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Pen</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Add to current point</strong></td>
<td>Click last point</td>
<td>Click last point</td>
</tr>
<tr>
<td><strong>Quick curve</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Add to current endpoint</strong></td>
<td>Click and draw from endpoint</td>
<td>Click and draw from endpoint</td>
</tr>
<tr>
<td><strong>Shape objects tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Rectangle</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Constrain to square</strong></td>
<td>Shift + click</td>
<td>Shift + click</td>
</tr>
<tr>
<td><strong>Circle</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Constrain to circle</strong></td>
<td>Shift + click</td>
<td>Shift + click</td>
</tr>
</tbody>
</table>

Shape selection tool
<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Direct selection</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select start point of shape</td>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Select endpoint of shape</td>
<td>End</td>
<td>End</td>
</tr>
<tr>
<td>Select previous point in shape</td>
<td>Page up</td>
<td>Page up</td>
</tr>
<tr>
<td>Select next point in shape</td>
<td>Page down</td>
<td>Page down</td>
</tr>
<tr>
<td>Move path by one screen pixel</td>
<td>Arrow keys</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Delete selected (closed) shape</td>
<td>Delete</td>
<td>Backspace</td>
</tr>
<tr>
<td><strong>Animation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>First frame of stack</td>
<td>Home</td>
<td>Home</td>
</tr>
<tr>
<td>Last frame of stack</td>
<td>End</td>
<td>End</td>
</tr>
<tr>
<td>Next frame</td>
<td>Page up</td>
<td>Page up</td>
</tr>
<tr>
<td>Previous frame</td>
<td>Page down</td>
<td>Page down</td>
</tr>
<tr>
<td>Stop at current frame</td>
<td>Option + Stop</td>
<td>Alt + Stop</td>
</tr>
<tr>
<td>Stop and return to current starting frame</td>
<td>Command + .</td>
<td>Ctrl + .</td>
</tr>
<tr>
<td><strong>Lighting</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>Lighting mover</td>
<td>Shift + Command + L</td>
<td>Shift + Ctrl + L</td>
</tr>
<tr>
<td><strong>Layer selection tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>Group</td>
<td>Command + G</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Command + U</td>
<td>Ctrl + U</td>
</tr>
</tbody>
</table>

**Mosaics**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Get tile color</td>
<td>Option + click tile</td>
<td>Alt + click tile</td>
</tr>
<tr>
<td>Get tile shape</td>
<td>Command + click tile</td>
<td>Ctrl + click tile</td>
</tr>
<tr>
<td>Delete tile</td>
<td>Shift + click tile</td>
<td>Shift + click tile</td>
</tr>
<tr>
<td>Select all tiles</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Deselect all tiles</td>
<td>D</td>
<td>D</td>
</tr>
<tr>
<td>Change selected tiles to current color</td>
<td>C</td>
<td>C</td>
</tr>
<tr>
<td>Tint selected tiles with current color</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Vary color of selected tiles</td>
<td>V</td>
<td>V</td>
</tr>
</tbody>
</table>

**Other commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>macOS</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add current color to color set</td>
<td>Command + Shift + T</td>
<td>Ctrl + Shift + T</td>
</tr>
<tr>
<td>Swap colors</td>
<td>Shift + S</td>
<td>Shift + S</td>
</tr>
<tr>
<td>Use Clone Color</td>
<td>Command + Shift + Y</td>
<td>Ctrl + Shift + Y</td>
</tr>
<tr>
<td>Next document</td>
<td>Ctrl + Tab</td>
<td></td>
</tr>
<tr>
<td>Previous document</td>
<td>Ctrl + Shift + Tab</td>
<td></td>
</tr>
<tr>
<td>Tightest enclosing group</td>
<td>Command + Shift + Q</td>
<td>Ctrl + Shift + Q</td>
</tr>
<tr>
<td>Select none</td>
<td>Command + Shift + 2</td>
<td>Ctrl + Shift + 2</td>
</tr>
<tr>
<td>Nudge 1 pixel</td>
<td>Arrow key</td>
<td>Arrow key</td>
</tr>
<tr>
<td>Nudge 4 pixels</td>
<td>Shift + Arrow key</td>
<td>Shift + Arrow key</td>
</tr>
<tr>
<td>Memory info</td>
<td>Shift + I</td>
<td>Shift + I</td>
</tr>
<tr>
<td>Command</td>
<td>macOS</td>
<td>Windows</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>--------------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Zoom to actual pixels</td>
<td>Command + Option + 0</td>
<td>Ctrl + Alt + 0</td>
</tr>
<tr>
<td>Close all windows</td>
<td>Command + Shift + W</td>
<td>Ctrl + Shift + W</td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Command + Option + \</td>
<td>Ctrl + Alt + \</td>
</tr>
<tr>
<td>Toggle pinned temporal color selector</td>
<td>Command + Option + 1</td>
<td>Ctrl + Alt + 1</td>
</tr>
<tr>
<td>Transform duplicate</td>
<td>Command + Shift + Option + T</td>
<td>Ctrl + Alt + Shift + T</td>
</tr>
<tr>
<td>Delete selection or node</td>
<td>Delete</td>
<td>Backspace</td>
</tr>
<tr>
<td>Delete layer</td>
<td>Command + Delete</td>
<td>Ctrl + Backspace</td>
</tr>
<tr>
<td>Perspective Guides — Reposition one vanishing point and the associated primary lines together</td>
<td>Hold down Shift and drag the vanishing point to a new position.</td>
<td>Hold down Shift and drag the vanishing point to a new position.</td>
</tr>
<tr>
<td>Perspective Guides — Reposition all vanishing points and primary lines together</td>
<td>Hold down Command + Shift (macOS) or Ctrl + Shift (Windows), and drag the vanishing point to a new position.</td>
<td>Hold down Command + Shift (macOS) or Ctrl + Shift (Windows), and drag the vanishing point to a new position.</td>
</tr>
</tbody>
</table>
Painting

The Corel Painter application lets you draw and paint as you might with real artists’ tools and media. In your studio, you use brushes, pens, pencils, chalk, airbrushes, and palette knives to make marks on a canvas or piece of paper. With Corel Painter, an infinite variety of marks are possible.

This section contains the following topics:
- “Choosing a painting workflow” (page 143)
- “Brush tracking and calibration” (page 146)
- “Exploring painting media” (page 149)
- “Working with the canvas and layers” (page 149)
- “Displaying reference images” (page 150)
- “Clearing the canvas” (page 151)
- “Setting up the drawing cursor” (page 151)
- “Using a stylus vs. a mouse” (page 152)
- “Applying freehand and straight brushstrokes” (page 156)
- “Constraining, fading, and undoing strokes” (page 158)
- “Aligning brushstrokes to paths and shapes” (page 158)
- “Making 360° strokes” (page 159)
- “Erasing image areas” (page 159)
- “Letting media pool” (page 161)
- “Recording and playing back brushstrokes” (page 161)
- “Reference: Troubleshooting” (page 162)

Choosing a painting workflow

Corel Painter includes a wide array of tools and features that allow you to create original artwork. The purpose of this topic is to introduce you to the two most-common Corel Painter workflows and refer you to Help topics that provide more information about each of these workflows.

Workflow 1: Start with a photo

Using Corel Painter’s powerful cloning tools, you can quickly transform a digital photo into a painting.
The photo (left) was cloned (right) to begin the painting process.

<table>
<thead>
<tr>
<th>Workflow step</th>
<th>Help topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Open a photo for painting</td>
<td>“Opening and placing files” on page 98</td>
</tr>
<tr>
<td>2. Prepare a photo for cloning</td>
<td>“To clone an image by using Quick Clone” on page 188</td>
</tr>
<tr>
<td>3. Paint the clone</td>
<td>“Painting in the clone” on page 185</td>
</tr>
<tr>
<td>4. Save the photo painting</td>
<td>“Saving and backing up files” on page 113</td>
</tr>
</tbody>
</table>

You can also create a photo-painting by using the Auto-painting feature. For more information, see “Auto-painting photos” on page 176.

Workflow 2: Start with a sketch

In Corel Painter, you can quickly create a sketch of a photo so you can use it as a guide for applying color. To maintain the integrity of the sketch, you should apply color to layers, and not directly to the sketch. In addition, depending on the desired effect, using layers gives you the option of incorporating the sketch markings in the final image. If you don’t want the sketch to be visible in the final image, you can delete the sketch by clearing the canvas. When you’re done, you can drop the layers to the canvas.
The photo (left) was transformed into a sketch (right) to begin the painting process.

**Workflow**

1. Choose a photo
   
   “Opening and placing files” on page 98

2. Convert a photo into a sketch
   
   “Applying the Sketch effect” on page 698

3. Create a layer
   
   “Creating and deleting layers” on page 574

4. Apply a brushstroke to the layer
   
   “Painting on layers” on page 591

5. Clear the canvas
   
   “Clearing the canvas” on page 151

6. Drop layers to the canvas
   
   “Dropping layers with the canvas” on page 590

**Workflow 3: Start with a blank canvas**

You can also start a project from scratch by choosing a paper texture and a brush, and applying color to the canvas.

You can start with a blank canvas (left) and use your imagination, and the Corel Painter tools, to create a work of art.
Workflow

1. Choose a paper texture
   "Applying paper texture“ on page 165

2. Choose a brush
   “Selecting, managing, and creating brushes“ on page 299

3. Choose a color
   “Choosing colors from the Color panel” on page 236

4. Apply a brushstroke to the canvas
   “Applying freehand and straight brushstrokes“ on page 156

Brush tracking and calibration

When you draw with traditional media, the amount of pressure that you use with a tool determines the density and width of your strokes. Using a pressure-sensitive stylus with Corel Painter gives you the same kind of control. Because each artist uses a different strength or pressure level in a stroke, you can adjust Corel Painter to match your stroke strength for all brushes by using the Brush Tracking preferences, or for a specific brush, by using the Brush Calibration controls.

Brush Tracking for all brush variants

Brush Tracking is particularly useful for artists with a light touch. If a light stroke leaves no color on the canvas, you can use Brush Tracking to increase sensitivity for all brushes. Corel Painter saves Brush Tracking between sessions, so whatever tracking sensitivity you set will be the default the next time you open the application.

Abrupt changes in the width or density of your strokes shows that you need to adjust your Brush Tracking preferences.

The most common way of adjusting brush tracking is to apply a typical brushstroke, such as a wavy stroke, to the scratch pad. Corel Painter then uses your stroke to calculate the appropriate pressure and velocity settings for all brush variants. However, you can also specify pressure and velocity values.
Use the scratch pad in the Brush Tracking dialog box to customize how Corel Painter responds to your stroke pressure and speed.

In addition, Corel Painter includes the following brush tracking presets that you can choose from: Default, Legacy, and Linear.

The graph in the Brush Tracking dialog box shows how increasing the pen pressure affects brushstrokes, which are referred to as “output” in the graph.

By default, brush tracking settings apply to all brush variants, but you can also limit them to only the current brush variant.

**Brush Calibration for individual brush variants**

The Brush Calibration controls are very useful for adjusting individual brush variants. You can modify the pressure of your stroke on the scratch pad to achieve different results. For example, you could use a light touch when sketching with a pencil brush variant, but set more pressure when using an oil paint brush variant. Corel Painter saves Brush Calibration control settings with the brush variant, so whatever sensitivity you set will be the default the next time you choose the brush variant. If you set Brush Calibration for a specific brush in addition to general Brush Tracking preferences, the Brush Calibration settings override the Brush Tracking preferences.

**Manually adjusting pressure and velocity**

When you use the scratch pad to set brush tracking and calibration, Corel Painter calculates the pressure and velocity settings for you. However, you can manually adjust these settings. For example, you can adjust the stroke pressure to achieve a full pressure range with a softer or harder touch by using the Scale and Power sliders for pressure. You can also adjust the stroke velocity to achieve a full velocity range with a slower or faster stroke by using the Scale and Power sliders for velocity.
To ensure that a brush control is using the pressure or velocity settings, you need to set the brush control Expression setting to Pressure or Velocity. For more information, see “Expression settings” on page 373.

To set brush tracking

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Brush Tracking.
   - (Windows) Choose Edit ➤ Preferences ➤ Brush Tracking.

2. Drag in the scratch pad by using a “normal” stroke.
   Use the pressure and speed you prefer when drawing or painting. This allows the Brush Tracker to calculate the appropriate speed and pressure settings for the brush.
   If you are using a Wacom-compatible tablet, you can also apply brushstrokes in the document to preview the results and make adjustments as needed.

   To adjust the settings manually, perform a task from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Achieve a full pressure range with a softer or harder touch</td>
<td>In the Pressure area, move the Scale and Power sliders.</td>
</tr>
<tr>
<td>Achieve a full velocity range with a slower or faster motion</td>
<td>In the Velocity area, move the Scale and Power sliders.</td>
</tr>
<tr>
<td>Limit brush tracking to the current brush variant</td>
<td>Enable the Apply to current brush variant check box.</td>
</tr>
</tbody>
</table>

To choose a brush tracking preset

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 ➤ Preferences ➤ Brush Tracking.
   - (Windows) Choose Edit ➤ Preferences ➤ Brush Tracking.

2. Choose one of the following presets from the Preset list box:
   - Default — suitable for most artists. The preset also provides a good starting point for brush tracking adjustments.
   - Legacy — default brush tracking in Corel Painter X3 and earlier versions
   - Linear — pressure changes impact the brushstroke in a linear fashion. Each small variation in pen pressure changes the brushstroke.

   You can also

   Save brush tracking settings as a custom preset
   Adjust any settings you want in the Brush Tracking dialog box. Click the Add button ➤. In the Add Preset dialog box, type a name in the Preset Name text box.

   Delete a custom brush tracking preset
   Choose the preset from the Preset list box, and click the Delete button ➤.
1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category, and click a brush variant.
3. Choose **Window ▶ Brush Control Panels ▶ Brush Calibration**.
4. Enable the **Enable Brush Calibration** check box.
5. Click the **Set brush calibration settings** button.
6. Drag in the scratch pad by using a "normal" stroke.

   Use the pressure and speed you prefer when drawing or painting. This allows the **Brush Tracker** to calculate the appropriate speed and pressure settings for the brush.

   To adjust the settings manually, perform a task from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Achieve a full pressure range with a softer or harder touch</td>
<td>Adjust the <strong>Pressure Scale</strong> and <strong>Pressure Power</strong> sliders.</td>
</tr>
<tr>
<td>Achieve a full velocity range with a slower or faster motion</td>
<td>Adjust the <strong>Velocity Scale</strong> and <strong>Velocity Power</strong> sliders.</td>
</tr>
</tbody>
</table>

### Exploring painting media

Corel Painter lets you apply a wide variety of media to the canvas. For example, you can use a brush to apply colors directly from a color panel or apply a color that you mixed on the Mixer Pad. You can also paint by using a gradient, pattern, or clone.

The following table lists the media that you can apply to the canvas or layer and references to the related topic in the Help.

<table>
<thead>
<tr>
<th>Media</th>
<th>For information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>“Choosing colors from the Color panel” on page 236</td>
</tr>
<tr>
<td>Mixer pad</td>
<td>“Exploring the Mixer panel and mixing controls” on page 246</td>
</tr>
<tr>
<td>Two-color</td>
<td>“Creating two-color brushstrokes” on page 245</td>
</tr>
<tr>
<td>Gradients</td>
<td>“Applying gradients” on page 737</td>
</tr>
<tr>
<td>Patterns</td>
<td>“Painting with patterns” on page 725</td>
</tr>
<tr>
<td>Cloners</td>
<td>“Painting in the clone” on page 185</td>
</tr>
</tbody>
</table>

### Working with the canvas and layers

In Corel Painter, you have the option of painting directly on the canvas by applying brushstrokes or by creating a layer and applying brushstrokes on it. Working with layers allows you to protect the canvas from any unwanted changes. When you select a layer in the Layers panel, that layer becomes the target for your brushstrokes. For more information, see “Getting started with layers” on page 570.

The result of any brushstroke you make depends on the following:

- The brush category (or drawing tool) you choose
• The brush variant you select within the brush category
• The brush controls you set, such as brush size, opacity, and the amount of color penetrating paper texture
• The paper texture
• The color, gradient, or pattern you use as media
• The brush method

If you are using a Watercolor brush, you can paint only on a Watercolor layer. If you are using a Liquid Ink brush, you can paint only on a Liquid Ink layer. For more information, refer to “Working with the Watercolor layer” on page 462 and “Working with Liquid Ink brushes” on page 553.

If you try to paint on a shape, dynamic layer, or reference layer, you must commit it to a standard layer so that your brushstrokes are accepted.

You can also select a channel or a layer mask as the target for your brushstrokes. For more information, see “Creating and copying channels” on page 609 or “Creating and deleting layer masks” on page 600.

When you have an active selection, painting is confined to the selection by default. For more information, see “Selections and transformations” on page 619.

When you use complex brush variants, you see a dotted line on the canvas before the mark appears. For example, the Gloopy variant of the Impasto brush is complex, and it delays the appearance of the stroke onscreen. When you experience a delay, you can continue applying strokes, without losing any stroke data, while waiting for the stroke to appear on the screen.

Displaying reference images

In Corel Painter, you can open an inspirational photo or image that you want to reference in a painting by using the Reference Image panel.

You can reposition or magnify the reference image while maintaining focus on your painting. In addition, you can sample a color directly from the reference image and apply it to your painting. If you plan on using reference images strictly for color sampling, you may prefer opening images directly in the Mixer panel instead. This technique allows you to sample and mix the image colors. For more information, see “Opening images in the Mixer panel” on page 250.

We recommend using reference images that are a maximum of 1600 X 1600 pixels. You can open reference images that are saved as the following file formats: JPG, PNG, RIFF, and PSD.

To display a reference image

1 Choose Window ➤ Reference Image.
2 In the Reference Image panel, click the Open a Reference Image button 

3 In the Open Reference Image dialog box, locate the file that you want to open.

4 Click Open.

When you open RIFF, TIFF, and PSD files that contains layers in the Reference Image panel, all layers are flattened.

To move a reference image

1 In the Reference Image panel, click the Grabber tool 🖐️.

2 Drag the image to a new position in the Reference Image window.

To zoom in and out of a reference image

1 In the Reference Image panel, click the Magnifier tool 🕵️️.

2 Do one of the following:
   • To zoom in, click in the Reference Image window.
   • To zoom out, hold down Command (macOS) or Ctrl (Windows), and click in the Reference Image window.

To sample a color in a reference image

1 In the Reference Image panel, click the Dropper tool 🎨.

2 Move the cursor to the color that you want to sample, and click it.
   The color swatch is updated to display the color you’ve selected.

Clearing the canvas

You can erase the canvas by clearing its contents. Clearing the canvas does not delete the canvas, it only removes its content. In Corel Painter, you cannot delete the canvas.

To clear the canvas

1 Choose Window » Layers.

2 In the Layers panel, click the Canvas to select it.

3 Choose Select » All.

4 Choose Edit » Clear.

Setting up the drawing cursor

You can choose a drawing cursor type, specify whether to see the enhanced brush ghost or an icon when painting, and specify a number of settings for the drawing cursor icon, such as icon shape, color, and orientation. For information on modifying the appearance of the brush cursor, see “Brush cursor preferences” on page 851.
Using a stylus vs. a mouse

Overall, a stylus provides more control and interactivity than a mouse because it gives you the most responsive digital painting experience by allowing your hand and brush to work fluidly as one. While a mouse is a great pointing device, it is not particularly convenient for painting. A mouse can only move on a flat, two-dimensional surface. A tablet stylus, on the other hand, has the ability to sense the motions of your wrist, hand, and arm. This gives you an authentic feel, accuracy, and control.

Corel Painter lets you produce realistic brushstrokes that fade in and out; change size, opacity, and angle; and penetrate based on stylus input data such as velocity, direction, pressure, airbrush fingerwheel, tilt, and bearing.

You can link brush settings (such as size, opacity, and angle) to stylus input data (such as velocity, direction, pressure, airbrush fingerwheel, tilt, and bearing). Refer to “Expression settings” on page 373 for more information about linking brush settings to stylus input controls.

If you don’t have a stylus, you can adjust the mouse so it simulates stylus pressure, tilt, bearing, and fingerwheel settings. For more information, see “Mouse controls” on page 434.

Pressure

Many Corel Painter brushes respond to stylus pressure. Depending on the variant settings, greater stylus pressure can increase the width of a brushstroke, the penetration of color, or the degree of other effects. The Corel Painter airbrushes also respond to the fingerwheel on the Wacom Intuos airbrush, simulating a needle control that adjusts how much ink is sprayed.

In theory, a mouse has no pressure information because a mouse button is either “on” (button down) or “off” (button up). However, with Corel Painter you can simulate stylus pressure. If you are using a mouse with Corel Painter, you can compensate for the lack of pressure information by adjusting size, opacity, and grain on the property bar. For example, reducing opacity or grain can produce the same results as pressing more lightly with a stylus.

Tilt

Some brush variants, such as the Smeary Flat variant in the Oils category, react to stylus tilt (how close to vertical the stylus is held).

Tilt can significantly affect brushstrokes. If you get unexpected results, especially with bristle-type brushes or airbrushes, you can try reducing the tilt of your stylus. Extreme tilt angles are usually undesirable.
An example of an airbrush variant (Coarse, Paint – “Airbrushes” (page 319)) that reacts to tilt. (left) The stylus is perpendicular to the tablet, (middle and right) varying degrees of tilt produce different marks.

A brushstroke with a pencil variant, Real 6B Soft Pencil (“Pens and pencils” (page 348)). The mark varies in width as you change the tilt of the stylus. When you hold the stylus straight up, you get a fine line; as you start to tilt the stylus, the line gets thicker.

Bearing

Pen bearing (the compass direction in which the stylus is pointing) lets you use the direction in which the tilted stylus is rotated to vary brush marks.

Examples of brushstrokes that are affected by pen bearing: (left) Grainy Oils Jitter (“Thick Paint” (page 361)), (right) Fan Brush (“PAINT - Acrylics” (page 368))

Wheel

Corel Painter airbrushes respond to the fingerwheel on the Wacom Intuos airbrush, simulating a needle control that adjusts how much ink is sprayed.
Like the needle control on real airbrushes, the fingerwheel control adjusts airbrush flow — that is, how much media is applied by an airbrush stroke.

Some Corel Painter airbrushes, for example, the Coarse Spray Jitter variant ("Airbrushes" (page 319)), take advantage of stylus fingerwheel controls.

**Barrel rotation**

If you have a flat-tip Intuos Art Pen that supports 360-degree barrel rotation, you can vary your brushstrokes based on the rotation of the stylus.

As you rotate the barrel of the Intuos Art Pen, the flat brush follows the rotation of the pen and you can create wide or narrow strokes.

The dot that appears along the outer circle of the enhanced brush ghost indicates the pen rotation.

**Direction**

Brushstrokes can respond to the direction in which the stylus is moving.
A sample brushstroke created with the Flow Fur Tail 2 variant (“Particles” (page 345)). As you change the stroke path, the fur hairs change direction.

Velocity

Brushstrokes can vary in response to the rate at which the pen moves across the tablet.

A brushstroke (Leaky Pen variant, “Pens and pencils” (page 348)) with low velocity (left) and high velocity (right)

Random

You can adjust brushstrokes on a random basis to produce more realistic results. Randomness contributes to the aesthetics of a painting because minor irregularities occur in natural structures.

A brushstroke (Spray-Size-P variant, “Image Hose” (page 338)) with randomness (right) and without randomness (left)

Source

You can adjust brushstrokes according to the luminance of the clone source.
To adjust pressure, tilt, and bearing when using a mouse

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Mouse**.
2. Move the **Pressure** slider.
   - A 100% setting uses maximum pressure.
3. Move the **Tilt** slider.
   - A 90° setting simulates a stylus that is perpendicular to the tablet.
4. Move the **Bearing** slider.
   - A setting of zero indicates that if a stylus were in use, it would be pointing left.
5. Move the **Rotation** slider.
   - A 360° setting simulates a stylus that completes a 360°-barrel rotation.

To see the effect of the tilt setting, apply a stroke to the drawing window using the **Fine Spray** variant of the **Airbrush** category.

To adjust fingerwheel settings when using a mouse

1. Choose **Window** ➤ **Brush Control Panels** ➤ **General**.
2. Choose **Wheel** from the **Expression** list box.
3. Choose **Window** ➤ **Brush Control Panels** ➤ **Mouse**.
4. Move the **Wheel** slider.
   - A 90% setting indicates that if a stylus were in use, it would be perpendicular to the tablet.

Applying freehand and straight brushstrokes

You can draw unconstrained lines by using the freehand drawing style, or you can draw straight lines.

When you draw a freehand stroke, you can drag with any motion or in any direction. The stroke follows your path.
When you draw a straight line stroke, Corel Painter connects points with a straight line.

To create a straight line stroke, you click to add the first point and then click or drag to create the stroke.

To draw freehand lines
1. On the Brush property bar, click the Freehand Strokes button.
2. Drag on the canvas.

You can use shortcut keys to toggle between the freehand and straight line drawing styles. Press B to choose the freehand style, or V to choose the straight-line style.

To draw straight lines
1. On the Brush property bar, click the Straight line strokes button.
2. Click a point on the canvas where you want to start your line.
3. Do one of the following:
   - Click the point where you want to end the line.
   - Drag to place the end point exactly where you want it.
   Corel Painter connects the first and second points with a straight line.
4. To continue drawing from the second point, click or drag to create additional points on the canvas.
   Corel Painter connects each point with a straight line.
5. To end a line, do one of the following:
   - Press Return (macOS) or Enter (Windows) to close the polygon. The final point is connected to the origin with a straight line.
   - Click the Freehand Strokes button to return to the freehand drawing style without closing the polygon.
6. Press V to end the current polygon without closing it, so that you can begin a new one.
7. Drag on the canvas.

You can also paint in a straight line by holding down Shift as you drag on the canvas.
Constraining, fading, and undoing strokes

Using the freehand stroke drawing style, you can constrain your strokes to a straight line. The angle you draw depends on the orientation of the stroke.

You can also make a stroke less opaque, or more translucent, by fading the stroke.

In this example, a brushstroke was applied to the canvas (left) and then fade was applied to the brushstroke (right) by using the Fade dialog box (center).

In addition, you can undo a stroke. You can also control how many individual strokes can be undone, see “Performance preferences” on page 854.

To constrain freehand strokes
• Hold down Shift as you drag.

To fade a stroke
1 Choose Edit ➤ Fade.
2 Drag the Undo Amount slider.
   The Preview window displays the results of your selection.

To undo a stroke
• Choose Edit ➤ Undo Brush Stroke.

You can also undo a stroke by pressing Command + Z (macOS) or Ctrl + Z (Windows).

Aligning brushstrokes to paths and shapes

You can automatically align a brushstroke to a path or the edge of a shape. You do this by determining the tolerance area, that is, how close the brushstroke must be to the path or shape for automatic alignment to occur. If the brushstroke is within the tolerance area, the brushstroke snaps to the path or shape; if the brushstroke is outside of the tolerance area, no brushstroke is applied.
You can align brushstrokes to paths (left) and to shapes (right).

To align a brushstroke to a path or shape

1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category and a brush variant.
3. On the property bar, click the Align to Path button.

Brushstrokes within the tolerance area of a path or shape are automatically aligned.

If there are multiple shapes within the tolerance area, the brushstroke is aligned to the shape on the selected layer.

To set the tolerance area for brushstroke alignment

1. Choose one of the following:
   - (macOS) Corel Painter 2020 menu ➤ Preferences
   - (Windows) Edit ➤ Preferences
2. In the Preferences list of categories, click General.
3. Type a number in the Align Brush to Path tolerance box.

The tolerance area is measured in pixels and must be between 1 and 999.

Making 360° strokes

Because there are no restrictions on bearing (stylus direction) in Corel Painter, you can create full 360° strokes with noncomputed brushes by completing an arc without interruption. Computed brushes use bearing, with the exception of those that use the Rendered dab type, so you cannot use them to create 360° strokes.

Erasing image areas

You can erase any part of your image with the Eraser tool or an Eraser brush. Corel Painter lets you fully customize the Eraser tool by using the property bar or the General panel. For example, on the property bar, you can adjust the width of the brushstrokes, control the opacity of erased areas, and select from a great variety of dab profiles. You can link opacity and size to stylus pressure or specify a fixed value. To learn more about the options that you can set on the General panel, see “General controls” on page 378.
To erase an image area

1. In the **Layers** panel, choose the layer on which you want to erase.
2. Choose the **Eraser** tool 🖌️ in the toolbox.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Set size | On the property bar, type a value in the **Size** box or move the **Size** slider.  
**Tip:** To link size to an expression, click the **Size** flyout button 🔄, and choose an option from the **Expression** list box.  
For more information about size controls, see “Size controls” on page 394. |
| Set opacity | On the property bar, type a percentage in the **Opacity** box or move the **Opacity** slider.  
**Tip:** To link opacity to an expression, click the **Opacity** flyout button 🔄, and choose an option from the **Expression** list box.  
For more information about opacity controls, see “Opacity controls” on page 388. |
| Choose a dab profile | On the property bar, click a **Dab** profile button. |

You can erase in straight lines by clicking the **Straight line strokes** button 🖋️ on the property bar, clicking a point on the canvas where you want to start your line, and clicking where you want to end the line.

You can also erase image areas by choosing the **Brush** tool 🍃 in the toolbox and choosing **Erasers** from the Brush Category selector on the Brush Selector bar. For more information about Eraser brushes and a list of sample brushstrokes, see “Erasers” on page 334.
Letting media pool

Corel Painter computed brushes allow media to build up or “pool” when you move a brush slowly. Pooling creates very realistic strokes, especially with airbrushes. You can also cause media to pool by simply touching and pausing with the selected brush.

With an airbrush, paint pools when you pause in a stroke for 1 second (left), 4 seconds (middle), and 7 seconds (right).

To enable media pooling

1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing.
2. Enable the Continuous Time Deposition check box.

When the Continuous Time Deposition check box is disabled, you must move the brush (even just slightly) to cause media to be deposited.

Recording and playing back brushstrokes

Corel Painter plays back any stroke you record, wherever you click in the document window. In this way, you can easily create a series of identical strokes — for example, when you create hatching effects.

Another way to use a recorded stroke is with Auto Playback, which lets you repeat the recorded stroke at random positions on the page. You can also save recorded strokes for later use. You can play back saved strokes, and you can paint with the data from a saved stroke. This way of working can be particularly useful if you work sometimes with a stylus and sometimes with a mouse: you can record the brushstrokes you make with a stylus, save them for later use, and then use a mouse to obtain the data from that stroke, allowing stylus-quality results.

Corel Painter has a number of brushstroke scripts that can be played back on their own or used in conjunction with an original brushstroke. When you use a brushstroke script, your freehand brushstrokes adhere to the stroke data in the script. This allows you to emulate features of a tablet and stylus while using a mouse.
To record a stroke
• Choose Brushes ➤ Record Stroke.

The next brushstroke you make is saved in memory.

To play back a stroke
1 Choose Brushes ➤ Playback Stroke.
2 Click where you want to repeat the stroke.
Corel Painter centers the stroke on the point on which you click. You can repeat the stroke as many times as you want.
3 Choose Brushes ➤ Playback Stroke to turn off playback.

To play back strokes randomly
• Choose Brushes ➤ Auto Playback.
Corel Painter repeats the stroke at random positions until you click.

To save a stroke
1 Choose Brushes ➤ Save Stroke.
2 In the Save Stroke dialog box, type a name.
Corel Painter adds the stroke to the list of saved strokes.

To select a saved stroke
• Choose Brushes ➤ Strokes, and choose a saved stroke.
The selected stroke is used when you play back strokes or use stroke data.

To use stroke data
1 Choose Brushes ➤ Strokes, and choose one of the following:
• Pressure Modulate — varies the stylus pressure in a brushstroke
• 360° Bearing Rotate — rotates the stylus bearing by 360°
• Size/Bearing Modulate — varies the size of the brush tip and stylus bearing in a brushstroke
• Size/Tilt Modulate — varies the size of the brush tip and tilt of the stylus in a brushstroke
• Fade In/Out — the start point and endpoint of a brushstroke
• Short Stroke — decreases the length of a brushstroke
• Bearing Rotate — rotates stylus bearing in a brushstroke
You can also base stroke data on brushstrokes that you’ve already saved.
2 Choose Brushes ➤ Use Stroke Data.
3 Draw brushstrokes.

Reference: Troubleshooting
This topic describes some of the reasons why a brushstroke may not appear:
• Main color — In the Color panel, what color is the Main Color (front) swatch? Is it a color that will show up when applied to your image? If not, click the Main Color swatch, and then set a different color.
• Opacity — Check the Opacity setting on the property bar and, if necessary, adjust the pop-up slider to increase opacity.
• Brush method — The brush method determines the basic nature of a brush. To check the brush method, choose Window ➤ Brush Control Panels ➤ General. If you’re drawing with a light color on a dark background, the method must be set to Cover in order to show the lighter color.

• Drawing mode — When you make a selection, the drawing mode determines what part of the selection is protected. For more information, see “Choosing the protected area of a selection” on page 633.

For more troubleshooting tips, see “My brushes stopped working.” on page 870
Working with paper texture and grain

With traditional art media, the results from using a marking tool depend on the texture of the surface to which it is applied. Corel Painter allows you to control the texture of the canvas to achieve the results you would expect from using traditional media on a given surface — pencil on watercolor paper, felt pens on cotton paper, chalk on the sidewalk, and so on. You can also create your own paper textures and adjust the grain of paper textures.

You can use paper textures in many ways. Brushes interact with paper “grain,” just as traditional tools react with the texture of the surfaces beneath them. Working with paper grains is useful when you use the Apply Surface Texture command or other effects, such as Glass Distortion. You can select different paper textures, modify them, organize them in libraries, and even create your own custom textures.

In Corel Painter, brushes that react with paper texture have a “grainy” method. For more information about brush methods, see “General controls: Methods and subcategories” on page 383.

This section contains the following topics:

• “Applying paper texture” (page 165)
• “Creating and deleting paper textures” (page 166)
• “Managing paper textures” (page 167)
• “Rotating paper texture” (page 168)
• “Inverting and scaling paper grain” (page 168)
• “Controlling brightness and contrast of paper grain” (page 169)
• “Adjusting grain direction and behavior” (page 170)

The terms “paper grain” and “paper texture” are used synonymously.

Applying paper texture

Corel Painter allows you to apply paper texture to the canvas. In general, you can define texture as the roughness or coarseness of a surface, which you can both see and feel. In Corel Painter, however, texture modifies only the appearance of the image, to give you the illusion of surface roughness. It also interacts by subtly or dramatically altering the appearance of brushstrokes.

In addition, certain brushes include a “grainy” method subcategory that is specifically designed to react with the paper texture and grain. Some brushes also let you determine the amount of grain that is revealed by each brushstroke. For more information about brush methods, see “General controls: Methods and subcategories” on page 383.
It is important to note that some brushes, such as those in the **Airbrushes** category, don’t reveal paper texture in their brushstrokes. This behavior corresponds with that of a traditional airbrush.

Corel Painter includes several default paper textures that are stored in the **Papers Textures** library. For more information about working with libraries, see “Working with libraries” on page 87. Additional paper textures are also provided on the Corel Painter DVD and on the Corel website.

### To apply a paper texture

- In the **Papers** panel (Window ➤ Media Panels ➤ Papers), click a paper texture swatch in the **Paper Textures** area.

![Image of paper texture swatches]

The currently selected paper is saved with the document. This includes custom paper textures that may not be saved in a paper texture library.

When the **Brush** tool is selected, you can choose a paper texture by clicking the **Grain** flyout button on the property bar and clicking a paper texture swatch. For more information, see “To apply a paper texture using the property bar” on page 308.

### Creating and deleting paper textures

You can create your own paper texture by choosing a pattern and then modifying the spacing of the pattern elements. You can also modify the angle of the pattern elements to alter the direction of the texture.

![Image of a paper texture]

You can also create a paper texture by selecting an area of an image and converting it into a paper texture.
To create a paper texture
1. Choose Window ➤ Media Panels ➤ Papers.
2. In the Papers panel, click the Make Paper button.
3. In the Make Paper dialog box, choose a pattern from the Pattern list box.
4. Adjust the Spacing slider.
   Moving the Spacing slider to the right opens up the space between rows and columns in the selected pattern. It also increases the size of the pattern.
5. Adjust the Angle slider.
   Moving the Angle slider changes the direction of the texture rows.
6. Type a name in the Save As box.
7. Click OK.
   The paper texture appears as the last selection in the Papers panel.

To capture a paper texture
1. Open or create an image.
2. Choose the Rectangular Selection tool from the toolbox.
3. Drag in the document window to select the area of the image that you want to capture as a paper texture.
4. In the Papers panel, click the Capture Paper button.
   If you want to blend the distinction between tile borders, in the Capture Paper dialog box drag the Crossfade slider to the right.
5. Type a name in the Save As box.
   The paper texture is added to the currently selected library.

The Make Fractal Pattern feature and certain weaves also produce excellent paper textures. For more information, see “Creating fractal patterns” on page 731.

Managing paper textures
You can organize and manage paper textures. The Papers panel displays the default Papers library, the custom libraries that you create, and any custom libraries that you import.

To delete a paper texture
1. In the Papers panel (Window ➤ Media Panels ➤ Papers), click a paper texture swatch in the Paper Textures area.
2. Click the Delete Paper button.
To rename a paper texture

1. In the Papers panel (Window ➔ Media Panels ➔ Papers), right-click (Windows) or Control-click (macOS) a paper texture swatch in the Paper Textures area, and choose Rename Paper.
2. Type a name in the New Name box.

Rotating paper texture

You can rotate paper texture at any angle to achieve the artistic look you want.

A brushstroke applied to a non-rotated paper texture (top) and a rotated paper texture (bottom)

To rotate a paper texture

1. Do one of the following:
   - On the Brush tool property bar, click the Grain flyout button.
   - Choose Window ➔ Media Panels ➔ Papers to open the Papers panel.
2. Click a paper texture swatch in the Paper Textures area.
3. Move the Angle slider.

Inverting and scaling paper grain

Paper texture can be visualized as a three-dimensional landscape made up of grains. The size, shape, and spacing of the grains determine the pattern and direction of the paper texture. When applying media to the canvas, brushes react to paper texture by coloring the grain peaks and ignoring the valleys. However, Corel Painter allows you to invert this effect to make color fill the grain valleys instead of the peaks. You can also resize the paper grain by adjusting the scale.

To invert paper grain

1. Do one of the following:
   - On the Brush tool property bar, click the Grain flyout button.
   - Choose Window ➔ Media Panels ➔ Papers to open the Papers panel.
2. Click a paper texture swatch in the Paper Textures area.
3. Click the Invert button.
You can also invert paper texture by clicking the Paper options button in the Papers panel, and choosing Invert Paper.

The green brushstroke was painted with the paper grain inverted.

To scale paper grain

1. Do one of the following:
   - On the Brush tool property bar, click the Grain flyout button.
   - Choose Window ➔ Media Panels ➔ Papers to open the Papers panel.
2. Click a paper texture swatch in the Paper Textures area.
3. Adjust the Scale slider to resize the paper grain.

As you move the slider, the Paper Preview window updates to display the new grain size. You can scale texture down to 25% or up to 400%.

Scaling large textures can use a great deal of Random Access Memory (RAM). Most textures in Corel Painter range from 50 to 400 pixels square at 100% scaling.

Controlling brightness and contrast of paper grain

Brightness can be thought of as controlling the depth of the paper grain. The effect of lowering the paper’s brightness is similar to that of using a more shallow grain.

Contrast can be thought of as controlling the steepness of the paper grain. The grain in higher-contrast paper changes from high to low more quickly and with fewer intermediate levels than the grain in lower-contrast paper.

To change paper grain brightness

1. Do one of the following:
   - On the Brush tool property bar, click the Grain flyout button.
   - Choose Window ➔ Media Panels ➔ Papers to open the Papers panel.
2 Click a paper texture swatch in the **Paper Textures** area.

3 Adjust the **Brightness** slider.

**To change paper grain contrast**

1 Do one of the following:
   - On the **Brush** tool property bar, click the **Grain** flyout button.
   - Choose **Window** ➤ **Media Panels** ➤ **Papers** to open the **Papers** panel.

2 Click a paper texture swatch in the **Paper Textures** area.

3 Adjust the **Contrast** slider.

**Adjusting grain direction and behavior**

When you use a brush that interacts with paper grain, the results appear with each stroke. If you have a stylus and tablet, you can adjust paper grain by changing the stroke of the stylus on a pressure-sensitive tablet. In most cases, a light stroke colors only the peaks and ridges of the grain. A heavy stroke fills color deep into the pockets and valleys. You can also affect the brush interaction with paper grain by changing the brush grain settings.

If you want a uniform paper grain across an image, create your artwork first, and then apply the grain as a surface texture. If you apply paper texture before you create an image, the texture is erasable, and you cannot erase the paper texture without erasing brushstrokes at the same time. For this reason, it is usually best to add paper texture as a last step in developing your image.

By default, paper grain is fixed, which means that the texture is in the same position each time you apply a brushstroke. You can change this setting if you want grain to be applied randomly.

You can also change the look of brushstrokes by having the paper grain interact with stroke direction. This option works best when you paint with a stylus and use certain papers and brushes.

When you find a brush and paper combination that you really like, you can save it as a new look in the **Look Libraries**. For more information about saving looks, see “Saving a brush look” on page 315.

**To randomize paper grain**

1 Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Media** ➤ **Grain**.

2 Enable the **Random Grain Rotation** check box.

The **Random Grain Rotation** check box is not available for all brushes.

**To enable directional paper grain**

1 Do one of the following:
   - On the **Brush** tool property bar, click the **Grain** flyout button.
   - Choose **Window** ➤ **Media Panels** ➤ **Papers** to open the **Papers** panel.

2 Click a paper texture swatch in the **Paper Textures** area.

3 Click the **Direction** button.
Factors such as stylus pressure, paper, and brush variant affect the appearance of brushstrokes when the Direction Toggle button is enabled. Papers with pronounced grain, such as Wood Grain and Gessoed Canvas, produce the best results.
Auto-painting photos

Corel Painter’s auto-painting tools streamline the process of creating a painting that is based on a digital image or scanned photo. Previous experience with digital art is not required to use these tools.

The auto-painting process involves four basic steps:

**Step 1: Underpainting**
Prepare a photo for painting by using the Underpainting panel (Window ➤ Auto-Painting Panels ➤ Underpainting). This step is optional.

For more information about underpaintings, see “Creating underpaintings” on page 174.

**Step 2: Auto-cloning**
Clone the photo by clicking the Auto Clone button in the Underpainting panel.

For more information, see “Auto-cloning photos” on page 176.

**Step 3: Auto-painting**
Apply brushstrokes to the canvas by using the Auto-Painting panel (Window ➤ Auto-Painting Panels ➤ Auto-Painting).

For more information, see “Auto-painting photos” on page 176.

**Step 4: Fine-tuning**
Fine-tune your artwork by restoring some detail to the image (Window ➤ Auto-Painting Panels ➤ Restoration).

For more information, see “Restoring detail to paintings” on page 179.
The Auto-Painting panels — Underpainting, Auto-Painting, and Restoration — are grouped together. The Underpainting panel lets you create an underpainting and auto-clone the photo (Steps 1 and 2). Next, you can quickly access the Auto-Painting panel to create the painting (Step 3). Finally, you can go to the Restoration panel to fine-tune your painting (Step 4).

Creating underpaintings

An underpainting is a version of the photo in which you adjust the photo’s colors, tones, and sharpness. The purpose of the underpainting is to prepare it for auto-painting. For example, you can darken colors to simulate the colors used in an 18th-century painting, or you can soften colors to simulate the colors found in watercolor paintings. After retouching a photo, you must clone it to preserve it and prepare it for auto-painting. For more information, see “Auto-cloning photos” on page 176.

Choosing an underpainting method

Depending on the effect you want to achieve, you can choose one of the following methods for creating an underpainting:

- Quickly simulate the color and tone used in some popular art styles, such as watercolor paintings or chalk drawings, by using a Color Scheme preset.
- Match the color and tone of your underpainting to an existing image, such as a photo, scanned image, or digital artwork.
- Quickly lighten, darken, or shift the color or contrast of your photo by using a Photo Enhance preset.
- Adjust individual settings in the Photo Enhance area, and save the settings as a custom preset.
To create an underpainting

1. Open the image that you want to auto-paint.
2. Choose Window ➤ Auto-Painting Panels ➤ Underpainting.
3. In the Underpainting panel, choose a preset from the Color Scheme list box.
4. Choose a preset from the Photo Enhance list box.
5. In the Photo Enhance area, move any of the following sliders:
   - Brightness — lets you brighten or darken the photo
   - Contrast — lets you increase or decrease the difference in tone between the dark and light areas of the photo
   - Hue — lets you shift the color balance of the photo. For example, you can correct a color cast or apply a cast to create a special effect.
   - Saturation — lets you adjust the vividness of colors
   - Value — lets you brighten or darken the photo by using the HSV color space values
   - Smart Blur — lets you adjust the level of detail in the photo. More detail is maintained in high-contrast areas than in low-contrast areas.

   A preview of the change is shown in the photo, but the change is not applied until you click the Apply Underpainting button.

6. Click the Apply Underpainting button to create the underpainting.

   The button becomes grayed out after the underpainting is created.

Before clicking the Apply Underpainting button, you can return the photo to its original state by clicking the Reset Underpainting button.

You can add an edge effect to simulate the unpainted edge of a canvas or to create a frame effect by choosing an edge from the Edge Effect list box and moving the Amount slider.

To save underpainting settings as a preset

1. In the Underpainting panel, adjust the Photo Enhance sliders to achieve the style you want.
2. Click the Add Preset button.
3. In the Save Preset dialog box, type a name for your preset.

   The preset appears in the Photo Enhance list box.
You can delete a preset by choosing it in the Photo Enhance list box and clicking the Delete Preset button.

To create an underpainting by matching the color and tone of another image
1. Open the image that you want to use as a source for color matching.
2. Open the image that you want to use as an underpainting.
   This image is now the active document.
3. In the Underpainting panel, choose the filename for the source image from the Color Scheme list box.
   The underpainting is automatically updated with the color scheme from the source image.
   If you want to fine-tune the underpainting, you can adjust the Photo Enhance settings.
4. Click the Apply Underpainting button.

Auto-cloning photos
Creating a clone allows Corel Painter to borrow colors from a photo in order to recreate it as a painting on a blank canvas. For detailed information about cloning, see “Image cloning and sampling” on page 181.

To auto-clone a photo
• In the Underpainting panel (Window ➔ Auto-Painting Panels ➔ Underpainting), click the Auto Clone button.

Auto-painting photos
After the photo is cloned, you can start the auto-painting process.

If you want to isolate an area for auto-painting, you can create a selection first. In the final result, the areas protected by the selection are filled with the canvas color. For information about selections, see “Selections and transformations” on page 619.
You can control the speed of auto-painting so that you can see how and where individual strokes are applied. You can also stop the auto-painting process at any time.

**Smart Stroke painting**

You can choose a Smart Stroke brush variant and let the Smart Stroke painting and settings do the work. Although the Smart Stroke brush variants are optimized for auto-painting, you can also use any Cloner brush variant. You can choose from the following options:

- **Smart Stroke Painting** — automatically applies paint strokes that follow forms in the photo
- **Smart Settings** — changes the size, length, and pressure of brushstrokes in areas of greater detail. This option can be used with Smart Stroke painting to preserve detail from the source photo.

**Customizing stroke settings**

If you want more control over how the brushstrokes interact with the canvas, you can set individual stroke settings as follows:

- **Stroke** — lets you choose a brushstroke. You can also add custom brushstrokes to the list.
- **Randomness** — introduces an “accidental” quality in color and stroke. Randomness contributes to the appealing, unique look of artwork created with Corel Painter. You can control the randomness of the following settings:
  - **Pressure** — lets you set a value from 0 to 100 to specify the amount of pressure with which brushstrokes are applied. This setting represents the percentage of the preset pressure for the Stroke option.
  - **Length** — lets you set a value from 0 to 100 to specify the length of the brushstrokes. This setting represents the percentage of the preset length for the Stroke option.
  - **Rotation** — lets you set a value from 0 to 360 degrees to specify the rotation of the brushstrokes.
  - **Brush Size** — lets you set the brush size

You can also record a custom brushstroke.

**To auto-paint a photo by using Smart Stroke painting**

1. Select the clone document in the application window.
   
   If you want to auto-paint only specific areas in a photo, click a selection tool in the toolbox, and create a selection.

2. In the Brush Selector, choose the **Smart Strokes** brush category, and choose a brush variant.
   
   **Note:** You can also use any variant in the Cloners category.

3. In the **Auto-Painting** panel (Window ➤ Auto-Painting Panels ➤ Auto-Painting), enable the **Smart Stroke Painting** check box.
   
   You can turn off tracing paper to view the auto-painting progression by pressing **Command + T** (macOS) or **Ctrl + T** (Windows).

4. Click the **Play** button ▶.
   
   Brushstrokes are applied automatically.
5. Click the **Stop** button when you are satisfied with the results.

   If you do not click the **Stop** button, auto-painting stops at the end of the brushstroke cycle.

**You can also**

- Set paint strokes to adjust automatically in size, length, and pressure to areas of greater detail: Enable the **Smart Settings** check box.
- Control the speed at which brushstrokes are applied: Move the **Speed** slider.
- Vary the brushstrokes: Move the **Randomness** slider. The settings in the slider determine the range of randomness for **Pressure**, **Length**, and **Rotation**. For example, if the **Randomness for pressure** slider is set to 32% and the **Randomness** slider is set to 64%, the pressure for each stroke is between 0% and 32% with a variation of 64%.
- Vary the pressure of the brushstrokes: Click the **Randomness for pressure** button, and then move the slider.
- Vary the length of the brushstrokes: Click the **Randomness for length** button, and then move the slider.

**To auto-paint a photo by using a custom stroke**

1. Select the clone document in the application window.
   - If you want to auto-paint only specific areas in a photo, click a selection tool in the toolbox, and create a selection.
2. In the Brush Selector, choose the **Cloners** brush category, and choose a brush variant.
3. In the **Auto-Painting** panel, choose a stroke from the **Stroke** list box.
   - You can turn off tracing paper to view the auto-painting progression by pressing **Command + T** (macOS) or **Ctrl + T** (Windows).
4. Click the **Play** button. Brushstrokes are applied automatically.
5. Click the **Stop** button when you are satisfied with the results.
   - If you do not click the **Stop** button, auto-painting stops at the end of the brushstroke cycle.

**You can also**

- If only a solid color is used for painting, undo the auto-painting, and make sure that the **Clone Color** button in the **Color** panel is enabled.
You can also

Vary the rotation of the brushstrokes
Click the Randomness for rotation button, and then move the slider.

Change the size of the brushstrokes
Move the Brush Size slider.

Control the speed at which brushstrokes are applied
Move the Speed slider.

You can use a custom stroke by clicking the Recording Options button and choosing Record Stroke. Paint a stroke on the canvas, and choose Save Stroke from the same menu. Your stroke is added to the Stroke list box. For more information, see “Recording and playing back brushstrokes” on page 161.

Restoring detail to paintings
After the auto-painting process is complete, you can use the Restoration panel to recover detail from the original photo, if necessary. For example, the Restoration panel is ideal for restoring some detail in the area of a subject’s eyes in a portrait.

You can restore detail from the original photo by using brushes in the Restoration panel.

The Restoration panel gives you access to two cloner brushes, which you can use in specific areas of your photo to restore detail. You can adjust the settings for these brushes on the property bar.

To restore photo detail
1. Choose Window ➤ Auto-Painting Panels ➤ Restoration.
2. In the Restoration panel, click one of the following buttons:
   * Soft Edge Cloner Brush — activates the Soft Cloner brush variant, which restores detail gradually
   * Hard Edge Cloner Brush — activates the Straight Cloner brush variant, which restores detail quickly with a few brushstrokes
3. Move the Brush Size slider.
4. Paint over the area in which you want to restore detail.
   To preview and fine-tune the painting, you can turn off and on tracing paper by pressing Command + T (macOS) or Ctrl + T (Windows).
Corel Painter includes powerful image cloning tools to help you transform an existing image, such as a photograph, into a work of art.

*Use cloning techniques to give your digital photographs a second life. Original photo (left) and artwork (right) by Karen Bonaker.*
You can also use image sampling tools and techniques to sample a portion of an image so you can use it elsewhere. Sampling is a useful technique for retouching photographs.

This section contains the following topics:

- “Cloning workflows” (page 182)
- “Using embedded images as clone sources” (page 186)
- “Using textures as clone sources” (page 190)
- “Using patterns as clone sources” (page 192)
- “Working with embedded clone sources” (page 193)
- “Setting cloning preferences” (page 194)
- “Cloning brushes and controls” (page 195)
- “Cloning image areas” (page 203)
- “Applying transformations when sampling” (page 205)
- “Using selections and transformations when sampling” (page 212)
- “Filling an area with a sampled image” (page 213)

### Cloning workflows

The most common workflows for photo painting and creating composite images (such as collages) include:

**Workflow I: Turn a photo into a painting**

<table>
<thead>
<tr>
<th>Workflow step</th>
<th>Help topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Open a photo for painting</td>
<td>“Opening and placing files” on page 98</td>
</tr>
</tbody>
</table>
Workflow step | Help topic
--- | ---
2. Clone a photo | “To clone an image by using Quick Clone” on page 188
3. (optional) Add an additional clone source | “To embed an additional clone source image into a document” on page 189
| “To use a texture as a clone source” on page 191
| “To use a pattern as a clone source” on page 192
4. (optional) Edit an embedded clone source | “Working with embedded clone sources” on page 193
5. Paint in the clone | “Painting in the clone” on page 185

Workflow II: Create a composite image

Workflow step | Help topic
--- | ---
1. Create the assets that you need (images, textures, and patterns) and add them to a library | “Creating textures” on page 494
| “Using textures in photo painting and image compositing” on page 502
| “Creating and editing patterns” on page 726
2. Create a new document | “Creating documents” on page 96
3. Add content assets as clone sources | “To embed an additional clone source image into a document” on page 189
| “To use a texture as a clone source” on page 191
| “To use a pattern as a clone source” on page 192
4. (optional) Edit a clone source to suit your composition and concept | “To apply a transformation to a texture” on page 499
| “To edit a texture” on page 500
| “To edit a texture clone source” on page 191
5. (optional) Edit an embedded clone source | “Working with embedded clone sources” on page 193
6. Paint in the clone | “Painting in the clone” on page 185

Choosing an image
The first step is to choose a document, such as a photo or another image, that you want to clone, or create a new document.
In this example, the artist started by cloning a photo and then painted in the clone. Original photo (top) and artwork (bottom) by Mary Ann Rolfe.

Working with clone sources

A clone source is a reference — a guide — for brush colors. You clone (copy) color from a clone source and apply it to a destination canvas (clone document). A clone source may or may not be embedded. Embedding a clone source allows you to keep it with your document and switch quickly between clone sources as you paint.

You can use images, textures, and patterns as clone sources. If you plan to use a clone source only once — for example, if you want to turn a photo into a painting — you can embed it as an image. If you plan to reuse a content asset as a clone source in multiple projects, you can store it as a texture or pattern in the Texture or Pattern library, respectively. Corel Painter supports PNG and RIFF clone sources with transparency and lets you easily transform textures in the context of your composition to make them suit your artistic vision.
Clone a photograph to create a unique work of art, or import your content assets as textures and reuse them as clone sources in different projects. A transparent PNG (1) and a texture (2) were used as clone sources in the clone document (3). Images and artwork by Karen Bonaker.

If you want to borrow elements from different images and combine them in the clone document to create a composite image, you can use multiple clone sources.

**Painting in the clone**

After choosing a clone source, pick a brush and apply strokes to the canvas or let Corel Painter automatically apply brushstrokes for you.

**Cloner brushes**

To quickly get started with cloning, choose any of the brush variants available in the Cloners brush category. If you prefer to create your own custom variant, see “Cloning brushes and controls” on page 195 for detailed information on cloning controls.

**Auto-painting**

Using a cloner brush may take a long time if you’re working on a large area. To work more quickly, you can have Corel Painter automatically apply brushstrokes for you. For detailed information on auto-painting, see “Auto-painting photos” on page 176.

You can also use the Auto Clone effect. For more information, see “Automatically cloning an image” on page 662.

You can also have Corel Painter place directional brushstrokes to produce a Van Gogh–like rendition of a cloned image. For more information, see “Applying the Auto Van Gogh effect” on page 663.

**Additional clone painting techniques**

The following table describes different techniques for painting a clone.

<table>
<thead>
<tr>
<th>To create a mosaic or tessellation by using a source image</th>
<th>For information, see</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Creating a mosaic” on page 752</td>
<td></td>
</tr>
</tbody>
</table>
To

Add three-dimensional effects by applying surface texture

Create a selection or channel

For information, see

"Using 3D brushstrokes to create texture" on page 679

"Selections and transformations" on page 619 and "Alpha Channels" on page 609

Displaying the clone source image or texture

If you want to use the clone source image or texture as a reference while painting in the clone, you can display it in a separate window.

![Clone source image](image1)

The clone source image (right) is displayed and arranged side by side with the clone document (left). As you paint in the clone document (left), the crosshair cursor in the source image window (right) identifies the area where you are painting.

You can quickly switch between clone sources as you paint.

Using embedded images as clone sources

When you want to clone a document, such as a photo or another image, you can use Quick Clone. Corel Painter automatically sets up the workspace to start painting in the clone:

- creates a new document (called a clone document or simply a clone)
- embeds a copy (called an embedded clone source) of the original image
- closes the clone source image
- clears the canvas
- enables tracing paper
- selects a cloner brush

If the original document has layers, cloning creates a fully composited copy — that is, all layers in the image are dropped automatically.

You can change the Quick Clone preferences. For more information, see “Setting cloning preferences” on page 194.
The sunflowers (1) and background (2) images were embedded as clone sources into the clone document (3). Both embedded clone sources (4 and 5) are displayed in the Clone Source panel (6). Images and artwork by Karen Bonaker.

You can also start from a blank document and add one or more clone sources.

After you clone an image, a copy of the image is automatically embedded in the clone document and the relationship with the original image is broken. Consequently, if you modify the original image, the changes are not reflected in the embedded clone source image. If you make changes to the original image and you want to use the most up-to-date version in your clone document, you need to add it as a new clone source, and then delete the older version. You can also edit the embedded clone source image. For more information, see “To edit an embedded clone source image” on page 193.

You can enable tracing paper, which helps you apply clone colors precisely. Tracing paper displays a faded-out version of the source image in the clone document. Unlike traditional tracing paper, the Corel Painter tracing paper is not a real object, such as a layer or a document. It's a viewing mode that allows you to see the clone source image and use it as a reference when painting. When you enable tracing paper and start painting, the media is applied to the clone document the way it would be applied to traditional tracing paper.
When you enable tracing paper (left), you can see a faded-out version of the clone source image (right). Artwork by Henk Dawson.

If you can’t see all image details when tracing paper is enabled, you can toggle the tracing paper view to switch between showing and hiding the clone source. You can also control the opacity of the tracing paper.

To clone an image by using Quick Clone

1. Open the image that you want to clone.
2. Choose File ➔ Quick Clone.
3. Apply brushstrokes to the canvas.

Tip: To auto-paint an image, in the Auto-painting panel (Window ➔ Auto-Painting Panels ➔ Auto-Painting), enable Smart Stroke Painting, and click Play. For more information, see “Auto-painting photos” on page 176.

Transparency is fully supported only in PNG and RIFF images.

If you enabled the Switch to cloner brushes check box in the Preferences dialog box, the last Cloner brush that you used is automatically selected. For more information about cloning preferences, see “Cloning brushes and controls” on page 195.

If you select a Cloner brush and switch to offset sampling while cloning an image, the Offset Sampling option is automatically selected from the Source list in the Clone Source panel. It is also important to note that the sampling reference point is not treated as an embedded clone source and does not appear in the Clone Source panel. For more information, see “Cloning image areas” on page 203.
You can also clone an image by opening the image and choosing File ▶ Clone. Corel Painter creates a clone document and embeds a copy of the original image in the document. If you want to paint in the clone colors on a blank canvas, clear the clone document by choosing Select ▶ All, and then choosing Edit ▶ Clear. Apply brushstrokes to the canvas by using a cloner brush, or choose any brush and set it to clone color.

To embed a clone source image into a new document
1 Create a new document.
2 In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.
3 In the Embed Source Image dialog box, do one of the following:
   • To browse for a file, enable the Browse option.
   • To clone a currently open document, enable the Current Document option, and choose a document from the list box.
   • To embed the active texture, enable the Current Texture option.
4 Click OK.
5 In the Brush Selector, choose a cloner brush.
6 Apply brushstrokes to the canvas.

To auto-paint an image, in the Auto-painting panel (Window ▶ Auto-Painting Panels ▶ Auto-Painting), enable Smart Stroke Painting, and click Play. For more information, see “Auto-painting photos” on page 176.

To edit an embedded clone source image, follow the steps in the procedure “To edit an embedded clone source image” on page 193.

To embed an additional clone source image into a document
1 Open a clone document.
2 In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.
3 Click the Embed Source Image button.
4 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse for a file</td>
<td>Click Browse. Locate the folder that contains the image that you want to use, select the image, and click Open.</td>
</tr>
<tr>
<td>Clone an open document</td>
<td>Click a document in the list.</td>
</tr>
<tr>
<td>Embed the active texture</td>
<td>Click Current Texture.</td>
</tr>
</tbody>
</table>
To enable tracing paper
• In the Clone Source panel (Window ▶ Clone Source), enable the Toggle Tracing Paper check box.

To change the opacity of the tracing paper, move the Opacity slider.
To use a keyboard shortcut, press Command + T (macOS) or Ctrl + T (Windows).

You can also enable tracing paper from the Navigator panel by clicking the Open Navigator Settings button and choosing Toggle Tracing Paper.

To display a clone source image
1 In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.
2 Enable the Show Source Image (with crosshair cursor) check box.

The clone source image appears in a separate document window.

Using textures as clone sources

You can use a texture as a clone source. Explore the preset textures provided with Corel Painter, or create your own custom textures. For more information, see “Creating textures” on page 494. If you have content assets that you want to reuse, add them to the Texture library as textures, and then use them in your projects.

Create your content assets, import them into the Texture library, and use them as clone sources in your painting or photo collage.

Before you clone a texture, you can modify its appearance to suit your artistic vision. For more information, see “To apply a transformation to a texture” on page 499 and “To edit a texture” on page 500.
As your composition progresses, you can further modify a clone source texture in the context of your painting. When you finish editing the texture and return to the clone document, you have the option to update the active clone source texture or create a new texture and add it to the current Texture library. Note that with both options, all layers will be merged and the undo levels will be lost. If you have added layers that you want to preserve, you need to export the source texture as a new document before you return to the clone source document.

If you want to keep a copy of the texture with the clone document, you can embed it, so the next time you open the document or share it with someone else, the texture will be in the document. For more information about embedding clone sources, see “Working with embedded clone sources” on page 193.

To use a texture as a clone source

1. Create a new document or open an image.
2. In the Clone Source panel (Window ▶ Clone Source), choose Texture from the Source list box.
3. Click a texture thumbnail in the Painter Textures library.
   - If you want to see a representation of the texture in the document window, enable the Show Texture check box.
   - Tip: To adjust the texture visibility, move the Visibility slider.
4. In the Brush Selector, choose a cloner brush.
5. Apply brushstrokes to the canvas.

To auto-paint a texture, in the Auto-painting panel (Window ▶ Auto-Painting Panels ▶ Auto-Painting), enable Smart Stroke Painting, and click Play. For more information, see “Auto-painting photos” on page 176.

You can also

Transform a texture clone source

Follow the steps in the procedure “To apply a transformation to a texture” on page 499.

Modify a texture clone source

Follow the steps in the procedure “To edit a texture” on page 500.

To edit a texture clone source

1. Create a new document or open an image.
2. In the Clone Source panel (Window ▶ Clone Source), choose Texture from the Source list box.
3. Click a texture thumbnail in the Painter Textures library.
   - If you want to see a representation of the texture in the document window, enable the Show Texture check box.
   - Tip: To adjust the texture visibility, move the Visibility slider.
4. Enable the Show Source Image (with crosshair cursor) check box.
5. Click in the Source Image window.
   - The Edit Source Texture dialog box opens to provide instructions on how to proceed after editing a texture clone source.
6. Click OK.
7. In the Source Image window, edit the clone source texture.
   - If you want to preserve all layers and export the source texture as a new document, choose File ▶ Export Source Image. In the Export Source Image As dialog box, choose the drive and folder where you want to save the file. Type a filename in the Save As (macOS) or File Name (Windows) text box, and click Save.
8. Click in the clone document.
9. In the Edit Source Texture Options dialog box, enable one of the following options:
   - Create New — creates a new texture and saves it to the current Texture library, flattening all layers and deleting all undo levels
   - Update — replaces the current texture, flattening all layers and deleting all undo levels

Image cloning and sampling | 191
To embed a texture as a clone source image

1. Create a new document or open an image.
2. In the Clone Source panel (Window ▸ Clone Source), choose Texture from the Source list box.
3. Right-click a texture thumbnail (Windows) or hold down Control and click a texture thumbnail (macOS), and click Embed Texture as Clone Source Image.

You can also embed a texture as a clone source image by selecting the texture in the Textures panel (Window ▸ Media Panels ▸ Textures), clicking the panel options button, and clicking Embed Texture as Clone Source Image.

To display a clone source texture

1. In the Clone Source panel (Window ▸ Clone Source), choose Texture from the Source list box.
2. Enable the Show Source Image (with crosshair cursor) check box.
   The clone source texture appears in a separate document window.

Using patterns as clone sources

You can also use patterns as clone sources. For more information about patterns, see "Patterns" on page 723.

To use a pattern as a clone source

1. Create a new document or open an image.
2. In the Clone Source panel (Window ▸ Clone Source), choose Current Pattern from the Source list box, and click a pattern thumbnail in the Painter Patterns library.
3. Apply brushstrokes to the canvas.

   To auto-paint a pattern, in the Auto-painting panel (Window ▸ Auto-Painting Panels ▸ Auto-Painting), enable Smart Stroke Painting, and click Play. For more information, see "Auto-painting photos" on page 176.
When you delete all clone sources, the **Current Pattern** option is automatically selected in the **Source** list box, and you paint with the active pattern.

**Working with embedded clone sources**

When you embed a clone source, it is saved with your document for future use. The embedded image is best described as a snapshot of a selected image or texture at a given time. Once a copy of the source clone is embedded into the document, the relationship with the original image or texture is broken. However, you can edit the embedded image to change its appearance. For example, you can add layers or apply effects to the source image. When the source image modifications are complete, you have various options for working with the edited image.

![The Adjust Colors effect was applied to the source image (right). However, the edit is not yet reflected in the embedded clone source image (left). Artwork (left) by Claudia Salguero.](image)

You can save the changes to the source image by updating the currently selected clone source, or by creating a new image from the edited source. You can also discard any changes that you make to the embedded source image. It’s important to note that if you choose to update the active clone source or create a new clone source, all layers will be merged and the undo levels will be lost. If you want to retain the layers, export the source image as a new document and then update the embedded source image to continue cloning. Once the source image is exported as a new document, the relationship with the embedded source image is broken.

You can switch between embedded clone sources as you work on your composite image.

**To edit an embedded clone source image**

1. In the **Clone Source** panel (Window ▶ Clone Source), choose **Embedded Image** from the **Source** list box.
2. Click a thumbnail in the list of embedded clone sources.
3. Enable the **Show Source Image (with crosshair cursor)** check box.
4. Click in the **Source Image** window.
The **Edit Embedded Source Image** dialog box opens to provide instructions on how to proceed after editing a source image. Click **OK**.

5. In the **Source Image** window, edit the source image.

   If you want to preserve all layers and export the source image as a new document, choose **File ➤ Export Source Image**. In the **Export Source Image As** dialog box, choose the drive and folder where you want to save the file. Type a filename in the **Save As** (macOS) or **File Name** (Windows) text box, and click **Save**.

6. Click in the clone document.

7. In the **Edit Embedded Source Image Options** dialog box, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace the selected clone source image</td>
<td>Enable the <strong>Update</strong> option. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Create a new clone source image</td>
<td>Enable the <strong>Create New</strong> option. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>The new clone source image appears in the <strong>Clone Source</strong> panel.</td>
<td></td>
</tr>
<tr>
<td>Discard the changes made to the source image</td>
<td>Enable the <strong>Discard</strong> option. Click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>

After you make changes to the clone source image in the **Source Image** window, you can also export it by pressing **Command + Shift + S** (macOS) or **Ctrl + Shift + S** (Windows).

To switch between embedded clone sources

1. In the **Clone Source** panel (Window ➤ Clone Source), choose **Embedded Image** from the **Source** list box.

2. Click a thumbnail in the list of embedded clone sources.

3. Apply brushstrokes to the canvas.

4. To work with a different clone source, click the clone source in the list of embedded clone sources.

**Setting cloning preferences**

You can set various cloning preferences. For example, you can choose to always use the last selected cloner brush variant or enable tracing paper.

To customize cloning behavior

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Cloning.
   - (Windows) Choose **Edit ➤ Preferences ➤ Cloning**.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keep the file that was used as the clone source open.*</td>
<td>Disable the Close source image check box.</td>
</tr>
<tr>
<td>Close the image that was used as the clone source*</td>
<td>Enable the Close source image check box.</td>
</tr>
</tbody>
</table>
To | Do the following
---|---
Open the Clone Source panel automatically* | Enable the **Open Clone Source panel** check box.
Start painting in the clone colors on a clear canvas* | Enable the **Clear Canvas** check box.
Activate tracing paper* | Enable the **Turn on Tracing Paper** check box.
Activate the last cloner brush variant* | Enable the **Switch to cloner brushes** check box.
Use the current brush variant to clone the underlying color* | Enable the **Clone color** check box.
To enable the **Clone color** check box, you must disable the **Switch to cloner brushes** check box.
Display a warning when changes are made to the embedded clone source image | Enable the **Show Edit Source Image dialog box** check box.

* Please note that all settings marked with an asterisk apply only to Quick Clone.

**Cloning brushes and controls**

Painting with a cloner brush is a great way to obtain an artistic rendering from photographic source material. Choose the **Cloner** tool to automatically enable the brush variants in the **Cloners** brush category. Some variants, such as the **Straight Cloner**, reproduce a source image directly, but most variants let you reproduce a source image with media effects, such as paper grain and specialized dabs.

![An example of a cloner brush variant](image)

For a list of the cloner brush variants available in the Painter 2020 Brushes library, see “Cloners” on page 327.

You can customize existing cloner brush variants or create new variants by using the brush controls. For more information, see “Adjusting brushes with brush controls” on page 371.

**Cloning method**

You can also expand Corel Painter's cloning capabilities by turning almost any brush variant into a cloner. Brush variants that use the **Cloning** method reproduce the source image while effectively “filtering” it, which allows you to create an artistic rendering of an image.
An example of a brush variant using a cloning method

Because the **Cloning** method uses a full set of pixels from the original document for each brush dab, you get a truer copy of the original than you might by using the **Clone Color** button. Unlike the **Clone Color** option, the **Cloning** method preserves the original image texture in the clone. The **Cloning** method is good to use when you want to precisely recreate portions of a source image.

Brushes that use build-up methods, like pencils and felt pens, build toward black. If you clone with one of these brushes in a dark area of your image, you may not achieve the desired results. Use the **Opacity** slider on the property bar to control how rapidly these brushes build up to black. You can also choose chalk or one of the other tools that cover underlying colors.

**Cloning controls**

The **Cloning** controls are specific to brushes that use the **Cloning** method and the **Clone Color** option.

**Clone Color**

The **Clone Color** control directs a brush to pick up color from a source image. **Clone Color** takes averaged samples of color from the clone source, resulting in an approximation of the original. The **Clone Color** option is also available on the **Color** panel and the temporal color selector. For information about using different clone types, see “Cloning color” on page 245.

**Precise Sampling**

The **Precise Sampling** control directs a brush to sample color from the center of the dab and is useful when using a large dab to clone images with transparency. It is supported for brushes that use the following dab types: Circular, Computed Circular, Captured, Single-Pixel, Static Bristle, Dynamic Speckle Bristle, and Dynamic Speckle Particle types (Flow, Gravity, and Spring).

**Variability**

When you work with brushes using the **Cloning** method, you can modify the **Variability** to control the offset of the clone based on the location of the source image. When **Variability** is set at zero, the pixels of the source and destination images correspond precisely. Using a cover brush at full **Opacity** (and no **Grain**) simply recreates the source image.
Introducing a degree of randomness disturbs the pixel-to-pixel correspondence. The resultant variations distance the clone from its photographic source, which can contribute to a Natural-Media appearance.

**How Often**

The **How Often** controls allow you to set the period between random offsets.

**Random Clone Source**

**Random Clone Source** randomly samples the source document and then places strokes in the clone document. There is no correspondence between the samples taken from the source and where they are placed in the clone. The result is a random pattern of the predominant colors and edges of the source. The brush and stroke determine the nature of the pattern.

You might use **Random Clone Source** with a faint stipple brush to add “noise” to an image. In this case, the clone source image merely contains the noise colors that you wish to add.
Clone Type

The Clone Type control lets you choose among several cloning variations. These variations are arranged according to the number of reference points used. With two or more reference points, you can apply a transformation (rotate, skew, scale, mirror, and perspective) during cloning. For complete information on using the different clone types, refer to “Image cloning and sampling” on page 181.

- **Normal (0)**, or zero-point, cloning references the upper-left corners of the source and destination documents and patterns. This means that the pixels of the destination document correspond directly to the pixels of the source document. This type of cloning, in which no transformations occur, is the basic type of cloning between documents.

- **Offset (1)** cloning offsets the image from the source. The source and destination areas can be at different locations in the same or different documents. Offset cloning is basic point-to-point cloning and is useful for retouching photographs. For more information, see “Cloning image areas” on page 203.

- **Rotate & Scale (2)** cloning rotates and scales the source image using two reference points.

- **Scale (2)** cloning scales the source image using two reference points. The distance between the two destination points, in relation to the distance between the two source points, determines the scaling transformation.
• **Rotate (2)** cloning rotates the source image using two reference points. The line between the two destination points in relation to the line between the two source points determines the rotation transformation.

• **Rotate & Mirror (2)** cloning rotates and mirrors (flips) the source image using two reference points.

• **Rotate, Scale, & Shear (3)** cloning rotates, scales, and shears (slants) the source image using three reference points. The relative positions of the three source and the three destination reference points determine the transformation effect.
• Bilinear (4) cloning applies a bilinear warp to the source image using four reference points. The relative positions of the four source and the four destination points describe the bilinear transformation.

• Perspective (4) cloning applies perspective to the source image using four reference points. The relative positions of the four source and the four destination points describe the perspective transformation.

Obey Source Selection

The Obey Source Selection option uses any selection in the clone source region to constrain painting in the destination. If a transform Clone Type is used, the selection is appropriately transformed. This option is available only with the Cloning method.

Copy Source Selection
When **Copy Source Selection** is enabled, the **Cloner** brush reproduces the source selection information in the destination selection. This option is available only with the **Cloning** method.

**4-Point Tiling**

With the **4-Point Tiling** check box enabled, your clone source is tiled in a repeating pattern.

**Using brush loading**

For greater color accuracy while cloning, you can use the brush loading option to pick up individual colors in different regions of the brush dab.

Without brush loading, the **Clone Color** option uses a single, averaged color from the source for each brush dab. This results in an approximation of the original and lets you create an artistic impression of the source.

**To choose a cloner brush**

1. With a clone source selected, click the **Cloner** tool in the toolbox.
   - The **Cloners** brush category and a cloner brush variant are automatically selected.
   - If you want to change the brush variant, in the Brush Selector, click a different **Cloners** brush variant.
2. On the property bar, adjust any of the brush properties and settings.
   - For increased color accuracy, you can enable the **Brush Loading** option. For more information, see “Using brush loading” on page 201.

**To transform a brush variant into a cloner brush**

1. With a clone source selected, click the **Brush** tool in the toolbox.
2. In the Brush Selector, click a brush category and a brush variant.
3. In the **General** panel (Window ▶ Brush Control Panels ▶ General), choose Cloning from the Method list box.
4. From the Subcategory list box, choose one of the following options:
   - **Hard Cover Cloning** — results in partially anti-aliased brushstrokes that hide underlying strokes
   - **Soft Cover Cloning** — produces anti-aliased brushstrokes that cover layered ones
   - **Grainy Hard Cover Cloning** — works like **Hard Cover Cloning**, but brushstrokes also interact with paper grain
   - **Grainy Soft Cover Cloning** — works like **Soft Cover Cloning**, but brushstrokes also interact with paper grain
   - **Drip Cloning** — pushes color around as if it were wet, cloning the original with distortions based on your stroke
5. In the **Cloning** panel (Window ▶ Clone Source), choose Normal from the Clone Type list box.
   - The additional cloning types allow you to apply transformation to the clone. For more information, see “Applying transformations when sampling” on page 205.

You can also transform a brush into a cloner brush by choosing a brush in the Brush Selector and clicking the **Clone Color** button in the **Color** panel (Window ▶ Color Panels ▶ Color Panel (Full View)). Enabling the **Clone Color** option disables the **Color** panel and the color information is pulled from the clone source.
If you change brushes while cloning images, you must click the **Clone Color** button again.

If you change the brush or variant, the clone color is automatically disabled. To continue working with the clone color, re-enable the clone color.

For more information about methods and subcategories, see “General controls: Methods and subcategories” on page 383.

**To set clone color**

- In the Cloning panel (Window → Clone Source), enable the **Clone Color** check box.

**To sample color from the center of the dab**

- In the Cloning panel (Window → Clone Source), enable the **Precise Sampling** check box.

**To set clone type**

- In the Cloning panel (Window → Clone Source), choose a type from the **Clone Type** list box.

**To constrain painting in the destination**

- In the Cloning panel (Window → Clone Source), enable the **Obey Source Selection** check box.

**To reproduce the source selection information in the destination selection**

- In the Cloning panel (Window → Clone Source), enable the **Copy Source Selection** check box.

**To tile clone source**

- In the Cloning panel (Window → Clone Source), enable the **4-Point Tiling** check box.

**To set clone location variability**

- In the Cloning panel (Window → Clone Source), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increase the range (distance) that the sample can be offset</td>
<td>In the Clone Location area, move the Variability slider to the right.</td>
</tr>
<tr>
<td>Limit the offset variability so that the source and destination images correspond more precisely</td>
<td>In the Clone Location area, move the Variability slider to the left.</td>
</tr>
</tbody>
</table>

Clone location sliders have no effect when **Clone Color** is enabled in the Color panel. They have an effect only when a Clone method is used.

**To set the period between random offsets**

- In the Cloning panel (Window → Clone Source), perform a task from the following table.
To clone an image area, you must set a sampling reference point and then set destination reference points. Sampling reference points specify the area of the document that you want to reuse, or clone. Destination reference points determine the area where you want the sampled image to appear. To identify which area of the source document you are sampling, a crosshair cursor appears.

It is important to note that the sampling reference point, also known as the source, is not treated as a clone source. The sampled area does not appear in the Clone Source panel.

To perform offset sampling in a document

1. Click the Rubber Stamp tool 🪝 in the toolbox.
   - If you want to adjust the size of the sampled area, type a value in the Size box, or adjust the slider on the property bar.
2. Hold down Option (macOS) or Alt (Windows), and click to set the source reference point.
   - A green marker appears on the image to indicate the reference point for the source image.
3. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click to set the destination reference point.
   - A red marker appears on the image to indicate the destination point.
4. Apply brushstrokes to the destination area to reveal the sampled area.
You can disable offset sampling by clicking the **Clone Color** button 🎨 in the **Color** panel or by choosing a non-Cloner brush variant in the Brush Selector.

You can also

Adjust the clone color opacity

On the property bar, type a percentage in the **Opacity** box, or move the slider.

Adjust the randomized jitter of the brushstroke

On the property bar, type a value in the **Stroke Jitter** box, or move the slider.

You can also enable offset sampling by clicking the **Cloner** tool 🎨 in the toolbox.

You can set the destination area before painting by clicking while holding down **Option + Shift** (macOS) or **Alt + Shift** (Windows). A red marker indicates the destination area.

**To perform offset sampling between documents**

1. Open both the image that you want to use as a sampling source and the image that you want to use as a destination.
   If you want to view both images at once, you may want to arrange them side by side.

2. With the source image selected, click the **Cloner** tool 🎨 in the toolbox.
   If you want to change the brush variant, click the Brush Selector, and click a Cloners brush variant in the Brush library panel.

3. Hold down **Option** (macOS) or **Alt** (Windows), and click the source document to set the sample source area reference point.
   A green numbered marker appears on the image to indicate the reference point for the source area.

4. Hold down **Option + Shift** (macOS) or **Alt + Shift** (Windows), and click the destination document to set the destination reference point.

5. In the destination document, apply brushstrokes to the canvas.

You can disable offset sampling by clicking the **Clone Color** button 🎨 in the **Color** panel or by choosing a non-Cloner brush variant in the Brush Selector.

You can also

Adjust the size of the brushstroke

Type a value in the **Size** box, or move the slider on the property bar.

Adjust the clone color opacity

On the property bar, type a percentage in the **Opacity** box, or move the slider.

Control the amount of color that is replenished in a stroke

On the property bar, type a percentage in the **Resat** box, or move the slider.

Control how much the brush colors smear underlying colors, including the paper color

On the property bar, type a percentage in the **Bleed** box, or move the slider.
You can also

Adjust bristle separation

On the property bar, type a value in the Feature box, or move the slider. The higher the setting, the farther apart the bristle hairs will appear.

Scale the brushstroke proportionally with the brush size

Click the Scale Feature With Brush Size button on the property bar.

Applying transformations when sampling

Corel Painter allows you to sample part of an image and apply a transformation to the sample when you reuse it elsewhere. This technique is also referred to as multi-point cloning. You can apply transformations such as scaling, rotating, shearing (also referred to as skewing), and perspective.

Multi-point sampling brush variants

To apply transformations when sampling, you can select a multi-point cloning brush variant from the Cloners brush category, or you can use any brush variant that supports the cloning method. For more information, see “To transform a brush variant into a cloner brush” on page 201.

The following table describes the multi-point sampling brush variants, which are included in the Painter 2015 brush library. For information on choosing brush libraries, see “Exploring brush categories” on page 317.

<table>
<thead>
<tr>
<th>Multi-point Cloners brush variant</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate, Scale 2P</td>
<td>Rotate, Scale 2P lets you turn the sampled area around its center of rotation and size it to a percentage of its original size. Rotate, Scale 2P uses two reference points.</td>
</tr>
</tbody>
</table>
Multi-point Cloners brush variant

Scale 2P lets you size the sampled area to a percentage of its original size. Scale 2P uses two reference points.

Rotate 2P lets you turn the sampled area around its center of rotation. Rotate 2P uses two reference points.

Rotate, Mirror 2P lets you turn the sampled area around its center of rotation while creating a horizontal or vertical mirror image of the clone source. Rotate, Mirror 2P uses two reference points.
Multi-point Cloners brush variant

**Rotate, Scale, Shear 3P** lets you turn the sampled area around its center of rotation, while sizing it to a percentage of its original size and skewing its appearance. **Rotate, Scale, Shear 3P** uses three reference points.

**Bilinear 4P** lets you stretch, or warp, the sampled area disproportionately. You can also tile the clone source. **Bilinear 4P** uses four reference points.

**Perspective 4P** lets you give the sampled area the appearance of depth. **Perspective Tiling 4P** also lets you tile the sampled area. **Perspective 4P** uses four reference points.

Reference points

After selecting a brush variant, you need to set the sample and destination reference points in the image. The number of reference points depends on the type of transformation that you choose. The reference points allow you to identify the sample area, position the destination, and control the transformation. After the points are set, you can apply brushstrokes to the destination area to gradually reveal the transformed sample. You can insert source points in one document and destination points in another, or you can insert both sets of points in the same document.
Tiling

Tiling allows you to fill a space by repeating a small sampled image. The 4-Point Tiling option is available for Bilinear and Perspective cloning only.

The four sample reference points define the sampled area, which is temporarily converted into a pattern tile. In the clone destination, the tile is warped according to the relative positions of the source and destination reference points and repeated as necessary to cover the area. If you want to save the sampled area for future use, you can capture it as a pattern. For more information, see “Creating and editing patterns” on page 726.

Tiling is particularly useful when you want to fill an area with the sample source. For more information, see “Filling an area with a sampled image” on page 213.

Cloning controls

For detailed information about multi-point sampling controls, see “Cloning brushes and controls” on page 195.

To scale the sample source

1. Click the Cloner tool in the toolbox.

2. In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3. Click the Cloners brush category, and click the XScale 2P brush variant.

   When you choose the XScale 2P brush variant, the Scale (2) clone type is automatically selected in the Cloning panel (Window → Clone Source).

4. Hold down Option (macOS) or Alt (Windows), and click in the image to set the two sample reference points.

5. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click to set the two destination reference points.

   The relative distance between the two destination points and the two source points determines the amount of scaling that is applied to the sample. For example, if the line between the two destination points is longer than the line between the two source points, the sample is scaled up. Conversely, if the line between the two destination points is shorter than the line between the two source points, the sample is scaled down.
To achieve the best scaling results, set the sample reference points at the outer edges of the object that you want to sample to better delineate its size. This ensures that the object will be scaled proportionally.

To rotate the sample source

1. Click the Cloner tool  in the toolbox.

2. In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3. Click the Cloners brush category, and click the XRotate 2P brush variant.

   - When you choose the XRotate 2P brush variant, the Rotate (2) clone type is automatically selected in the Cloning panel (Window  Clone Source).

4. Hold down Option (macOS) or Alt (Windows), and click in the image to set the two sample reference points.

5. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click in the image to set the two destination reference points.

   - The relative difference between the angle of the line of the two destination points and the two sample reference points determines the angle of rotation of the sample. If the line angle does not change, the position of the destination points relative to the sample points also affects the rotation. For example, if you set the sample points vertically from bottom to top, but then set the destination points at the same vertical angle but from top to bottom, the sampled image will be flipped 180 degrees.

6. Apply brushstrokes to the destination area.

   - You can disable offset sampling by clicking the Clone Color button  in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

   - The line length does not affect the rotation.

To rotate and mirror the sample source

1. Click the Cloner tool  in the toolbox.

2. In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3. Click the Cloners brush category, and click the XRotate, Mirror 2P brush variant.

   - When you choose the XRotate, Mirror 2P, the XRotate & Mirror (2) clone type is automatically selected in the Cloning panel (Window  Clone Source).

4. Hold down Option (macOS) or Alt (Windows), and click in the image to set the two sample reference points.

5. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click in the image to set the two destination reference points.

   - The relative difference between the angle of the line of the two destination points and the two sample points determines the angle of rotation of the mirrored clone image.

   - If the line angle does not change, the position of the destination points relative to the sample points also affects the rotation. For example, if you set the sample points vertically from bottom to top, but then set the destination points at the same vertical angle but from top to bottom, the sampled image will be flipped 180 degrees.

   - If you want to mirror the sample, without any rotation, set both the sample and destination points in the same position.

6. Apply brushstrokes to the destination area.

   - You can disable offset sampling by clicking the Clone Color button  in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.
To rotate and scale the sample source

1. Click the Cloner tool 🎨 in the toolbox.

2. In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3. Click the Cloners brush category, and click the XRotate, Scale 2P brush variant.
   When you choose the XRotate, Scale 2P brush variant, the XRotate & Scale (2) clone type is automatically selected in the Cloning panel (Window ➤ Clone Source).

4. Hold down Option (macOS) or Alt (Windows), and click in the image to set the sample reference points.

5. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click in the image to set the two destination reference points.
   The relative distance between the two destination points and the two sample points determines the amount of scaling that is applied to the sample. In addition, the relative difference between of the angle of the line of the two destination points and the two sample reference points determines the angle of rotation of the mirrored sample image. In cases where the line angle does not change, the position of the destination points relative to the sample points also affects the rotation.

6. Apply brushstrokes to the destination area.
   You can disable offset sampling by clicking the Clone Color button 🚪 in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

To rotate, scale, and shear the sample source

1. Click the Cloner tool 🎨 in the toolbox.

2. In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3. Click the Cloners brush category, and click the XRotate, Scale, Shear 3P brush variant.
   When you choose the XRotate, Scale, Shear 3P brush variant, the XRotate, Scale, Shear (3) clone type is automatically selected in the Cloning panel (Window ➤ Clone Source).

4. Hold down Option (macOS) or Alt (Windows), and click in the image to set the three sample reference points.

5. Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click in the image to set the three destination reference points.
   When all three points are inserted, a triangle is created. The length of the line segments controls the scaling of the sample, the angling of the line segments controls the rotation, and the degree of slanting controls the shearing, also referred to as skewing.
Sample source–destination reference points are set for Rotate, Scale, & Shear.

6 Apply brushstrokes to the destination area.

You can disable offset sampling by clicking the Clone Color button in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

To warp the sample source

1 Click the Cloner tool in the toolbox.

2 In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3 Click the Cloners brush category, and click the XBilinear 4P brush variant.

When you choose the XBilinear 4P brush variant, the XBilinear 4P clone type is automatically selected in the Cloning panel (Window  Cloning Source).

4 Hold down Option (macOS) or Alt (Windows), and click to set the four sample reference points.

5 Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click to set the four destination reference points.

6 The relative positions of all four sample and four destination points affect the warping of the sample.

7 Apply brushstrokes to the destination area.

You can disable offset sampling by clicking the Clone Color button in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

You can tile the sample by enabling the 4-Point Tiling check box in the Cloning brush control panel.

To add perspective to the clone source

1 Click the Cloner tool in the toolbox.

2 In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

3 Click the Cloners brush category, and click the XPerspective 4P brush variant.

If you want the clone to produce a tiling effect, click the XPerspective Tiling 4P brush variant.

When you choose the XPerspective 4P brush variant, the XPerspective 4P clone type is automatically selected in the Cloning panel (Window  Cloning Source).

4 Hold down Option (macOS) or Alt (Windows), and click in the image to set the four sample reference points.

5 Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click in the image to set the four destination reference points.

The relative position of the four sample and four destination points controls the perspective transformation. To achieve a simple perspective transformation, set the four sample points to form a rectangle, and then set the four destination points to form a trapeze.
6 Apply brushstrokes to the destination area.

You can disable offset sampling by clicking the **Clone Color** button 🌿 in the **Color** panel or by choosing a non-Cloner brush variant in the Brush Selector.

**To move previously set reference points**

1 Do one of the following:
   - Hold down **Option** (macOS) or **Alt** (Windows) to display the sample points.
   - Hold down **Option** + **Shift** (macOS) or **Alt** + **Shift** (Windows) to display the destination points.

2 With the reference points displayed, drag a point to a new location.

**Using selections and transformations when sampling**

You can use a selection when sampling an image area in two ways: by making brushstrokes in the destination image obey the selection in the sample source image, or by copying the active selection in the sample source region. These two options can be used individually or together.

These selection options require a **Cloning** method. They do not work for brushes of other methods that use the **Clone Color** button 🌿 on the **Color** panel.

*Use Obey Source Selection to paint in the area that corresponds to the source selection.*

*Use Copy Source Selection to sample both the selection and the color.*

**To sample an area of an image by using a source selection**

1 Choose a selection tool from the toolbox, and select the area of the image that you want to sample.
If you want to closely outline the sample source area, choose the Lasso tool. For information about setting up a selection, see "Creating path-based selections" on page 627.

2 Click the Cloner tool in the toolbox.

3 In the Brush Selector, click the Cloners category, and click a brush variant.

4 In the Cloning panel (Window > Clone Source), enable the Clone Color check box.

5 Enable any of the following options:
   • Obey Source Selection — respects the content of the active sample source selection. When you paint in the destination, the brushstrokes are constrained to a region that corresponds to the sample source selection. For sampling types that apply a transformation, the selection is transformed.
   • Copy Source Selection — copies the active selection in the source region. When you paint in the destination, your brushstrokes sample the selection’s pixels as well as the RGB pixels. For sampling types that apply a transformation, the copied selection is transformed. Copy Source Selection is often used together with Obey Source Selection.

6 Hold down Option (macOS) or Alt (Windows), and click to set the sample source reference points.

7 Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click to set the destination reference points.
   The number of points depends on the brush variant that you chose.

8 Apply brushstrokes to the destination area.

   You can disable offset sampling by clicking the Clone Color button in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

   This image uses Rotate & Scale sampling with both Obey Source Selection and Copy Source Selection enabled.

Filling an area with a sampled image

You can apply a transformed sample by filling, instead of using a brush. Filling allows you to cover a large area evenly, without much effort. Filling is supported only when you use perspective or bilinear sampling, with or without tiling.

To apply a transformed sample as a fill, you need to set both sample source and destination reference points, as you would when applying a sample with a brush. For information, see "Applying transformations when sampling" on page 205.

If you want to save the sample source reference area as a pattern for future use, you can capture the pattern. For more information, see "Creating and editing patterns" on page 726.

To fill with a transformed source image

1 In the Brush Selector, choose the Painter 2015 brushes library from the Brush library list box.

2 Click the Cloners brush category, and click a brush variant that allows you to select four sample source and four destination points:
   • XPerspective 4P
   • XPerspective Tiling 4P
• XBilinear 4P

3 In the Cloning panel (Window ▶ Clone Source), enable the Clone Color check box.

4 Do one of the following:
   • If you chose the XPerspective 4P or XPerspective Tiling 4P variant, choose Perspective from the Clone Type list box.
   • If you chose the XBilinear 4P variant, choose Bilinear from the Clone Type list box.

5 Hold down Option (macOS) or Alt (Windows), and click to set the four sample source reference points.

6 Hold down Option + Shift (macOS) or Alt + Shift (Windows), and click to set the four destination reference points.

7 Click the Paint Bucket tool 🖌️ in the toolbox.

8 Choose Source Image from the Fill list box on the property bar.

9 Click in the destination area to apply the fill.

You can disable offset sampling by clicking the Clone Color button 🌻 in the Color panel or by choosing a non-Cloner brush variant in the Brush Selector.

The destination points determine where the transformation occurs.

You can use transformed clone information to make a brick pattern become a steep wall.
Working with composition tools, symmetry tools, rulers, and guides

The placement of objects in a painting can dramatically affect the overall appearance of the finished work. Corel Painter includes many tools and features to help you compose, size, and position images and image elements. For example, you can display the rulers or the grid to help you position image elements with precision. You can also use symmetry tools, such as the Mirror Painting tool, to achieve visual balance.

This section contains the following topics:
• “Using the Layout Grid” (page 215)
• “Using the Mirror Painting mode” (page 218)
• “Using the Kaleidoscope Painting mode” (page 220)
• “Using perspective guides” (page 222)
• “Using the Divine Proportion tool” (page 228)
• “Using rulers” (page 231)
• “Using guides” (page 232)
• “Using Snap to Guides” (page 233)
• “Using the grid” (page 233)
• “Using Snap to Virtual Grid” (page 234)

Using the Layout Grid

The Layout Grid provides an easy way to divide your canvas so that you can plan your composition. For example, you can divide your canvas into thirds vertically and horizontally to use the compositional rule of thirds. From the Layout Grid panel, you can access grid settings, such as the number of divisions, size, angle, color, and opacity of the grid. You can adjust these settings while you work and save them as a preset for future drawings and paintings. You can also move the grid to a new position. You can restore the default settings of the Layout Grid tool at any time.

The Layout Grid also lets you divide the canvas into compositional sections based on the proportions of the canvas. This nonprinting grid is used primarily for composing artwork before you begin drawing or painting.
The Layout Grid helps you compose images. Artwork by Chris Melby.

To show or hide the Layout Grid

- Choose Canvas > Compositions, and choose either Show Layout Grid or Hide Layout Grid.

You can also show or hide the grid by clicking the Layout Grid tool in the toolbox and enabling the Layout Grid check box on the property bar.

To set Layout Grid options

1. Choose Window > Composition Panels > Layout Grid.

   In the Layout Grid panel, ensure that the Layout Grid check box is enabled.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the number of vertical and horizontal divisions</td>
<td>In the Divisions area, type values in the Vertical box and the Horizontal box.</td>
</tr>
<tr>
<td></td>
<td>If you want to link the Vertical and Horizontal values, click the Synchronize Divisions button.</td>
</tr>
<tr>
<td>Resize the grid</td>
<td>In the Size area, move the Vertical slider to set the height, and move the Horizontal slider to set the width.</td>
</tr>
</tbody>
</table>
To Do the following

- If you want to resize the grid proportionally, enable the Synchronize Sizes button.

- Type a value in the Rotate box to set the degree of the angle.

- In the Display area, click the Horizontal or Vertical color picker, and choose a color.

- Move the Opacity slider to the left to increase transparency. Move the slider to the right to increase opacity.

You can also set some Layout Grid options by clicking the Layout Grid tool in the toolbox, and modifying the settings you want on the property bar.

To save Layout Grid settings as a preset

1. In the Layout Grid panel, modify the settings you want, and click the Add button.
2. In the Add Preset dialog box, type a name for your preset in the Preset Name box.
3. Click Save.

   The preset appears in the Preset list box.

You can also save a preset by clicking the Layout Grid tool in the toolbox and clicking the Add button on the property bar.

To delete a Layout Grid preset

1. In the Layout Grid panel, choose the preset you want to delete from the Preset list box.
2. Click the Delete button.

   You can also delete a preset by clicking the Layout Grid tool in the toolbox, selecting a preset from the Preset list box on the property bar, and clicking the Delete button.

To choose a Layout Grid preset

• In the Layout Grid panel, choose a preset from the Preset list box.

To move a Layout Grid

1. In the toolbox, click the Layout Grid tool.
The cursor changes to a hand icon 

2 In the document window, drag the grid to a new position.

To restore the default settings of the Layout Grid tool
* Click the Reset button on the property bar.

Using the Mirror Painting mode

In Corel Painter, you can create a symmetrical painting by using the Mirror Painting mode. When you enable the Mirror Painting mode, a symmetry plane appears in the drawing window that lets you paint one half of an object while Corel Painter automatically replicates a mirror image of the opposing side of the object by reproducing the brushstrokes. For example, if you want to paint a symmetrical face, simply paint one half of the face and Corel Painter automatically completes the other half.

When using the Mirror Painting mode, the brushstrokes that you apply on one side of the plane may occasionally look different in the opposite plane. For example, if you start the Mirror Painting on a canvas that contains previously applied brushstrokes, the mirrored brushstrokes blend with the colors that are already on the canvas. In addition, if you’re applying randomized brushstrokes, such as a nozzle, the mirrored brushstrokes are also randomly applied.

The green line that is displayed in the middle of the document window represents the mirror plane.

You can position the mirror symmetry planes horizontally, vertically, or both horizontally and vertically in the document window. You can also control the placement of the mirror planes by moving or rotating the planes. You can restore the default settings of the Mirror Painting tool at any time.
To create a mirror painting
1 Click the Brush Selector on the Brush Selector bar.
2 In the Brush library panel, click a brush category, and click a brush variant.
3 Click the Stroke Options flyout button \( \text{Mirror Painting} \) on the property bar, and click \( \text{Mirror Painting} \).
4 Apply a brushstroke in the mirror symmetry planes.

You can also

Show or hide mirror symmetry planes

Choose a preset

Choose the \text{Mirror Painting} tool

Show or hide the \text{Mirror Painting} panel

Position the mirror symmetry planes horizontally or vertically in the document window

The \text{Brush} tool is the only tool that you can use to create mirror and kaleidoscope paintings. Other tools, such as the \text{Shape} tool, are not supported.

To show or hide the mirror symmetry plane while painting, press \text{Command} + \text{Shift} + \text{M} (macOS) or \text{Ctrl} + \text{Shift} + \text{M} (Windows).

To control the display of the mirror symmetry planes
1 Click \text{Window} \rightarrow \text{Composition Panels} \rightarrow \text{Mirror Painting}.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify an angle of rotation</td>
<td>Type a value in the Rotation Angle box.</td>
</tr>
<tr>
<td>Rotate the planes in the drawing window</td>
<td>Point to a plane until the cursor changes into a rotation angle cursor ( \text{rotation} ), and then drag to rotate the plane.</td>
</tr>
</tbody>
</table>
To Do the following

Change the plane position

Hover over the center point of the plane until the cursor changes into a four-headed arrow, and then drag the plane to a new location in the drawing window.

Change the color of the planes

Click the Symmetry Plane Color button, and choose a color from the color picker.

💡 You can also control the display of the mirror planes by clicking the Mirror Painting tool in the toolbox, and adjusting the settings on the property bar.

To restore the default settings of the Mirror Painting tool

• Click the Reset button on the property bar.

Using the Kaleidoscope Painting mode

Corel Painter lets you to transform basic brushstrokes into a colorful and symmetrical kaleidoscope image. When you paint a brushstroke in one kaleidoscope segment, multiple reflections of the brushstroke appear in the other segments. You can apply between 3 to 12 mirror planes to a kaleidoscope. You can also rotate or reposition the mirror planes to expose different colors and patterns. You can restore the default settings of the Kaleidoscope tool at any time.
To create a kaleidoscope painting

1. In the toolbox, click the Kaleidoscope tool.
2. In the Segments box on the property bar, type the number of planes that you want to display.
3. Click the Brush Selector on the Brush Selector bar.
4. In the Brush library panel, click a brush category, and click a brush variant.
5. Apply brushstrokes in any of the kaleidoscope segments.

   If you want to achieve a spiralling effect, apply brushstrokes across multiple segments.
To Do the following

Hide the kaleidoscope planes while painting
Click the Mirror Planes toggle button 🔄 on the Kaleidoscope tool 🌍 property bar.

Disable the Kaleidoscope Painting mode
Disable the Kaleidoscope check box on the Kaleidoscope tool 🌍 property bar.

The Brush tool is the only tool that you can use to create mirror and kaleidoscope paintings. Other tools, such as the Shape tool, are not supported.

To control the display of the kaleidoscope planes
1 In the toolbox, click the Kaleidoscope tool 🌍.
2 Perform a task from the following table:

To Do the following

Specify an angle of rotation
On the property bar, type a value in the Rotation Angle box.

Rotate the plane in the drawing window
Point to a plane until the cursor changes to a rotation angle cursor 🔄, and then drag to rotate the plane.

Change the plane position
Point to the center point of the planes until the cursor changes into a four-headed arrow 🔄, and then drag it to a new location in the drawing window.

Change the color of the plane
Click the Symmetry Plane Color button, and choose a color from the color picker.

To restore the default settings of the Kaleidoscope Painting tool
• Click the Reset Kaleidoscope button 🌍 on the property bar.

Using perspective guides
You can display non-printing perspective guides to paint objects that give the impression that they are receding, or vanishing, from view.
Corel Painter provides a selection of presets, which include different configurations of the perspective guides. The presets have one, two, or three vanishing points that help set the direction of the perspective. You can modify a preset and save it. You can also delete presets and restore the default settings of presets.

You can display the perspective guides simply as a visual aid, or you can choose to paint in perspective mode. In this mode, Corel Painter aligns the brushstrokes you apply in the document window to the vanishing points.

Depending on your workflow, you may choose to adjust the perspective guide settings by using the Stroke flyout on the Brush tool property bar, the property bar of the Perspective Guides tool, or the Perspective Guides panel. If using the feature for the first time, select the Perspective Guides tool, adjust the options you want, and save them as a preset once you are happy with your setup. When you start painting, you can quickly enable or disable the guides, change view options, and choose presets from the Stroke Options flyout on the Brush tool property bar. If you need to edit and reposition lines and vanishing points at any time, however, you can access the Perspective Guides tool from the Stroke Options flyout. When your changes are complete and you save your settings as presets, you have to select the Brush tool again to continue painting. If you often make changes to the guides, you can place the Perspective Guides panel in your workspace and keep it open. The panel allows you to access and adjust all perspective guide-related settings without the need to switch between tools.
You can modify the appearance of perspective guides by repositioning the vanishing point, the horizon line, and the primary lines. When you reposition the vanishing point, you can reposition both the horizon and the primary lines, or you can reposition only the primary lines by constraining the movement of the vanishing point along the horizon line. You can also rotate the primary lines to best suit your needs.

As you drag the vanishing point to a new location, both the horizon and primary lines are repositioned.

Hold down Shift as you drag the vanishing point to constrain the movement of the vanishing point along the horizon line and reposition only the primary lines.

In addition, you can change the color and opacity of all lines. You can also increase or decrease the density of the intermediate lines. You can hide the perspective guides when you no longer need them.

**To paint in perspective**

1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category, and click a brush variant.
3. Click the **Stroke Options** flyout button on the property bar, and click **Perspective Guides**.
4. Apply brushstrokes in the document window.
You can also

Show or hide the primary lines

Click the Stroke Options flyout button \( \) on the property bar, and click Primary Lines \( \) .

Show or hide the horizon line

Click the Stroke Options flyout button \( \) on the property bar, and click Horizon Line \( \).

Show or hide the intermediate lines

Click the Stroke Options flyout button \( \), and click Intermediate Lines \( \).

Choose a preset

Choose an option from the Preset list.

Edit and reposition lines and vanishing points with the Perspective Guides tool

Click the Perspective Guides Tool \( \).

Show or hide the Perspective Guides panel

Click Perspective Guides Panel \( \).

To exit the perspective painting mode at any time, click the Stroke Options flyout button \( \) on the property bar, and click Align to Guides \( \).

You can also show or hide the perspective guides by clicking the Perspective Guides tool \( \) in the toolbox, enabling or disabling the Perspective Guides check box on the property bar.

You can also enable or disable perspective mode by clicking the Perspective Guides tool \( \) in the toolbox, enabling the Perspective Guides check box on the property bar, and then enabling or disabling the Align to Guides check box on the property bar.

To better display the guides, make sure you are in Full Screen mode. This allows you to reposition the guides to best suit your needs.

To reposition lines and the vanishing point

1. Do one of the following:
   * Click the Stroke Options flyout button \( \) on the Brush tool \( \) property bar, and click the Perspective Guides Tool \( \).
   * In the toolbox, click the Perspective Guides tool \( \).
2. Perform a task from the following table.
To

Do the following

Reposition a vanishing point

In the document window, drag the vanishing point to a new position.

Constrain the movement of a vanishing point to the horizon line

Hold down Shift and drag the vanishing point to a new position.

Reposition the horizon line

Drag the horizon line up or down.

Reposition a primary line

Drag the primary line's position handle to a new position.

Rotate a primary line

Drag a rotation handle to change the line angle.

Reposition all vanishing points and primary lines as a group

Hold down Command + Shift (macOS) or Ctrl + Shift (Windows), and drag the vanishing point to a new position.

Move the primary line position handle

Drag the position handle along the primary line.

Tip: To save your settings as a preset, click the Preset flyout button on the property bar, choose Add from the list, enter a preset name, and click Save.

To display the Perspective Guides panel

• Click Window ➤ Composition Panels ➤ Perspective Guides.

To control the display of the primary lines

1 In the Perspective Guides panel (Window ➤ Composition Panels ➤ Perspective Guides), enable the Perspective Guides check box.

2 Perform a task from the following table.

To

Do the following

Show or hide the primary lines

Click the Primary Lines button.

Change the opacity of the primary lines

In the Primary Lines area, move the Opacity slider.

Change the color of the primary lines

In the Primary Lines area, click the Color picker, and choose a color.

💡

You can also control the display of the primary lines by clicking the Perspective Guides tool in the toolbox and adjusting any of the primary lines settings on the property bar.
To control the display of the horizon line
1  In the Perspective Guides panel (Window ▶ Composition Panels ▶ Perspective Guides), enable the Perspective Guides check box.
2  Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide the horizon line</td>
<td>Click the Horizon Line button 🔖.</td>
</tr>
<tr>
<td>Change the opacity of the horizon line</td>
<td>In the Horizon Line area, move the Opacity slider.</td>
</tr>
<tr>
<td>Change the color of the horizon line</td>
<td>In the Horizon Line area, click the Color picker, and choose a color.</td>
</tr>
</tbody>
</table>

You can also control the display of the horizon line by clicking the Perspective Guides tool 🧲 in the toolbox and adjusting any of the horizon line settings on the property bar.

To control the display of the intermediate lines
1  In the Perspective Guides panel (Window ▶ Composition Panels ▶ Perspective Guides), enable the Perspective Guides check box.
2  Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide the intermediate lines</td>
<td>Click the Intermediate Lines button 🔖.</td>
</tr>
<tr>
<td>Change the opacity of the intermediate lines</td>
<td>In the Intermediate Lines area, move the Opacity slider.</td>
</tr>
<tr>
<td>Change the color of the intermediate lines</td>
<td>In the Intermediate Lines area, click the Color picker, and choose a color.</td>
</tr>
<tr>
<td>Change the line density</td>
<td>In the Intermediate Lines area, move the Density slider.</td>
</tr>
</tbody>
</table>

You can also control the display of the intermediate lines by clicking the Perspective Guides tool 🧲 in the toolbox and adjusting any of the intermediate lines settings on the property bar.

To save perspective guide settings as a preset
1  In the Perspective Guides panel, modify the settings you want.
2  Click the Add Preset button 📐.
3  In the Add Preset dialog box, type a name for your preset in the Preset Name box.
4 Click Save.

The preset appears in the presets list.

If you export your workspace, any perspective guides presets that you created are saved with the workspace.

You can also add a preset by clicking the Perspective Guides tool in the toolbox, enabling the Perspective Guides check box on the property bar, clicking the Preset flyout button, choosing Add from the list, entering a name, and clicking Save.

To delete a perspective guide preset
1 In the toolbox, click the Perspective Guides tool.
   If the perspective guides are not displayed, enable the Perspective Guides check box.
2 Click the Preset flyout button on the property bar, and then choose Delete from the list.
3 Choose a preset from the Preset Name list box.
4 Click Yes.

You can also delete a preset by clicking the Perspective Guides panel button on the property bar, clicking the Delete Preset button, choosing a preset name, and clicking Yes.

To reset the Perspective Guides tool
1 In the toolbox, click the Perspective Guides tool.
2 Click the Reset Tool button on the property bar.

Using the Divine Proportion tool

The Divine Proportion tool lets you use guides based on a classical composition method of the same name. When planning your artwork, you can use the guides to create a sense of proportion, which helps maintain interest as the eye of the viewer travels across a drawing or painting.

Divine Proportion — helps identify where to place focal areas in artwork by using classical composition. This nonprinting layout is primarily used for composing artwork before you begin drawing or painting.
The Divine Proportion tool can help you establish focal areas.

The Divine Proportion panel lets you change the orientation, size, angle, color, and opacity of the Divine Proportion guide that appears on the canvas. You can also adjust the number of levels to determine how many times a section divides within itself, creating a spiral. You can adjust these settings while you work, and you can save them as a preset. You can also move the Divine Proportion guide to a new position.

To show or hide the Divine Proportion guides

- Choose Canvas ➤ Compositions, and then choose either Show Divine Proportion or Hide Divine Proportion.

You can also show or hide the Divine Proportion guides by clicking the Divine Proportion tool in the toolbox and enabling or disabling the Divine Proportion check box on the property bar.

To set Divine Proportion options

1. Choose Window ➤ Composition Panels ➤ Divine Proportion.

   The Divine Proportion panel appears.

2. In the Divine Proportion panel, enable the Divine Proportion check box, and perform a task from the following table.
To 

Do the following

Set orientation

In the Orientation area, click one of the Landscape or Portrait buttons.

Resize the guide

Move the Size slider to the right to increase the size. Move the slider to the left to decrease the size.

Size is measured as a percentage of the width or height of the canvas, depending on whether the orientation is Landscape or Portrait.

Change the angle

Type a value in the Rotate box to set the degree of the angle.

Change the color of the grid, spiral, or axis

In the Display area, click the Grid, Spiral, or Axis color picker, and choose a color.

Change the opacity

Move the Opacity slider to the left to increase transparency. Move the slider to the right to increase opacity.

Change the numbers of levels

Move the Levels slider to the right to increase the number of levels. Move the slider to the left to decrease the number of levels.

You can also set some Divine Proportion options by clicking the Divine Proportion tool in the toolbox and modifying the settings that you want on the property bar.

To save Divine Proportion settings as a preset

1 In the Divine Proportion panel, modify the settings you want, and click the Add button.

2 In the Add Preset dialog box, type a name for your preset in the Preset Name box.

3 Click Save.

The preset appears in the Type list box.

You can also save a preset by clicking the Divine Proportion tool in the toolbox and clicking the Add button on the property bar.

To delete a Divine Proportion preset

1 In the Divine Proportion panel, choose the preset you want to delete from the Type list box.

2 Click the Delete button.
You can also delete a preset by clicking the Divine Proportion tool in the toolbox, selecting a preset from the Presets list box on the property bar, and clicking the Delete button.

To choose a Divine Proportion preset
• In the Divine Proportion panel, choose a preset from the Preset list box.

To move the Divine Proportion guide
1 In the toolbox, click the Divine Proportion tool.
   The cursor changes to a hand icon.
2 In the document window, drag the Divine Proportion guides to a new position.

Using rulers
Corel Painter lets you show or hide rulers along the top and left sides of the document window. Each mark on a ruler is known as a tick and represents the selected unit of measurement. You can set the unit of measurement to pixels, inches, centimeters, points, or picas.

As you rotate an image in the document window, the rulers scroll to show the position of the canvas in the document window. The origin of the document is the intersection of the zero (0) ticks on each ruler. By default, the origin is the upper left corner of the canvas. Changing the origin resets the location of the zero ticks on the rulers.

To show or hide rulers
• Choose Canvas > Rulers, and choose either Show Rulers or Hide Rulers.

To set the ruler units
1 Choose Canvas > Rulers > Ruler Options.
2 In the Ruler Options dialog box, choose a unit of measurement from the Ruler Units list box.

You can also open the Ruler Options dialog box by holding down Option (macOS) or Alt (Windows) and clicking the ruler.

To change the document origin
1 Click the box at the intersection of the rulers (upper-left corner of the document window).
2 Drag diagonally into the document window.
   Crosshairs mark the new origin point.
3 Drag the crosshairs to the desired position.
   The ruler numbers update to show the new origin as 0,0.

To restore the origin
• Double-click the box at the intersection of the rulers (upper-left corner of the document window).
Using guides

Guides are nonprinting lines that appear over the image in the document window. They are very helpful in aligning image elements. You can place guides at any position in the document window and easily reposition and remove them. If you enable the Snap to Ruler Ticks option, the guides you create will land precisely on the tick marks. Each guide also has options that let you change its color and lock it so that it can’t be dragged.

To show or hide guides

• Choose Canvas ➔ Guides ➔ Show Guides or Hide Guides.

To create a guide

1. Show the rulers and the guides.
2. Click in a ruler at the position where you want to place the guide.

   A guide appears in the document window and a triangular marker appears in the ruler.

   A black triangle marks the guide’s position in the ruler.

To reposition a guide

• Drag the guide’s marker to any point of the ruler.

   You can also double-click the guide’s marker to display the Guide Options dialog box, and enter a value in the Guide Position box.

To enable the Snap to Ruler Ticks option

• Choose Canvas ➔ Rulers ➔ Snap to Ruler Ticks.

To set a guide’s color

1. Double-click the guide’s marker.
2. In the Guide Options dialog box, click the Guide Color chip, and choose a color.

   To change the color of all guides, enable the Same Color for All Guides check box.
To lock or unlock a guide
1. Double-click the guide’s marker to display the Guide Options dialog box.
2. Enable or disable the Lock Guide check box.

To remove a guide
• Drag the guide’s marker off the edge of the document window.

To remove all guides
1. Double-click the guide’s marker to display the Guide Options dialog box.
2. Click Delete All Guides.

Using Snap to Guides
The Snap to Guides option enables selections and tool operations to “snap” to a guide within 6 pixels of the cursor (or edge).

The following operations respect Snap to Guides:
• Dragging with the Rectangular Selection and Oval Selection tools
• Dragging with the Crop tool
• Drawing straight lines with the Brush tool
• Clicks made with the Pen tool
• Clicking with the Text tool to create a text entry point
• Clicking and dragging with the Paint Bucket tool and Magnifier tool
• Dragging shapes and selections. The edges of the content and the selection rectangle for the shapes and selections snap to the guides. The cursor — wherever it might be in the object — also snaps to the guide.
• Dragging the handles of reference layers, shapes, and selections to transform them
• Dragging with the Selection Adjuster tool or Layer Adjuster tool

To enable Snap to Guides
• Choose Canvas ➤ Guides ➤ Snap to Guides.
  The option is enabled when the menu item has a check mark beside it.

Using the grid
Corel Painter provides a virtual grid to help you in laying down brushstrokes or creating shapes. You can align and snap image elements to a basic grid. You can set the types, size, line thickness, and color of the grid. You can also print gridlines.

To show the virtual grid
• Choose Canvas ➤ Virtual Grid ➤ Show Virtual Grid.
  A non-printing grid appears.
You can also activate the grid from the Navigator panel by clicking the Open Navigator Settings button and choosing Show Grid.

To hide the virtual grid
* Choose Canvas ➤ Virtual Grid ➤ Hide Virtual Grid.

You can also deactivate the virtual grid from the Navigator panel by clicking the Open Navigator Settings button and choosing Hide Virtual Grid.

To set grid options
1 Choose Canvas ➤ Virtual Grid ➤ Virtual Grid Options.
2 In the Grid Options dialog box, choose a grid type from the Grid Type list box.
3 Type values in any of the following boxes:
   * Horizontal Spacing
   * Vertical Spacing
   The unit of measure can be in pixels, inches, centimeters, points, picas, columns (2 in. wide), or percent.
4 Click the Grid Color chip to set the color of the gridlines.
5 Click the Background chip to set the grid’s background color.

To print gridlines
* Choose Effects ➤ Esoterica ➤ Grid Paper.

Using Snap to Virtual Grid
The Snap to Virtual Grid option enables certain tool operations to “snap” to a grid within 6 pixels of the cursor.

The following tools respect Snap to Virtual Grid:
* Pen tool
* Shape Selection tool
* Convert Point tool
* Text tool

To enable Snap to Virtual Grid
* Choose Canvas ➤ Virtual Grid ➤ Snap to Virtual Grid.

The option is enabled when the menu item has a check mark beside it.
Color

Corel Painter offers many ways to select color and apply it to your image. For example, you can change the paper color, choose colors for your brushstrokes, or apply a color fill to an entire image or selection.

You can select colors in several ways. You can use

- the color swatches in the Color panel
- the color selector
- the Harmonies panel
- the Dropper tool, which samples color from the image
- the Use Clone Color setting, which pulls color from a source
- the Mixer panel
- the Color Sets panel

This section contains the following topics:

- “Choosing colors from the Color panel” (page 236)
- “Resizing the Color panel” (page 239)
- “Showing or hiding Color panel components” (page 239)
- “Using the color selector” (page 239)
- “Changing the paper color” (page 243)
- “Sampling colors from images” (page 244)
- “Cloning color” (page 245)
- “Creating two-color brushstrokes” (page 245)
- “Exploring the Mixer panel and mixing controls” (page 246)
- “Displaying and resizing the Mixer panel” (page 247)
- “Mixing, sampling, and applying colors from the Mixer pad” (page 248)
- “Opening images in the Mixer panel” (page 250)
- “Changing and saving the Mixer color swatches” (page 251)
- “Saving Mixer panel colors to a color set” (page 251)
- “Clearing and resetting Mixer panel colors” (page 252)
- “Saving the Mixer pad” (page 252)
- “Loading color swatches and Mixer pad files” (page 253)
- “Working with color sets” (page 253)
- “Customizing the layouts of color sets” (page 255)
- “Creating and exporting color sets” (page 255)
Choosing colors from the Color panel

You can use the Color panel to select a color and view information about the selected color. The Color panel has two viewing modes: compact and full view. In full view, both the color wheel and sliders are displayed. In compact view, only the sliders are displayed.

In the Color panel, you can choose a color from the Hue Ring and adjust the color from the Saturation/Value Triangle. The following information can help you adjust colors by using the Saturation/Value Triangle.

- Color values span the Saturation/Value Triangle from top to bottom. The top of the triangle represents the highest value (white), and the bottom of the triangle represents the lowest value (black).
• Saturation levels increase from left to right. Dragging to the right, or clicking on the right, produces purer colors within the predominant hue. Dragging to the left, or clicking on the left, reduces the color saturation and produces “muddier” or grayer colors.

You can also set the Hue, Saturation, Value (HSV) and standard Red, Green, Blue (RGB) values for the selected color.

The Main and Additional Color swatches display in the Color panel and the toolbox. They include two overlapping swatches: the front swatch displays the selected Main color and the back swatch displays the selected Additional color.

The Additional color is used when applying more than one color, as in two-color brushstrokes, two-point gradients, and Image Hose effects. It is not what other graphics applications refer to as the “background color.” In Corel Painter, the background color is the paper color.

You can preview a new color before selecting it. When you interact with the Hue Ring, the Saturation/Value triangle, or the sliders, the left half of the color swatch displays a preview of the new color and the right half shows the current color.

You can also enable the Clone Color option from the Color panel. For more information, see “Cloning color” on page 245.

To display the Color panel
• Perform a task from the following table.

To display the Color panel in | Do the following
---|---
Full view | Choose Window ➤ Color Panels ➤ Color Panel (Full View).
Compact view | Choose Window ➤ Color Panels ➤ Color Panel (Compact).

To show or hide the color wheel when using the Color panel in full view, see “To show or hide the color wheel” on page 239.

To choose a hue and color from the Color panel
1 Choose Window ➤ Color Panels ➤ Color Panel (Full View).
2 Drag the handle on the Hue Ring to select the predominant hue.
   The Saturation/Value Triangle displays all available colors within that selected hue.
3 Select a color on the Saturation/Value Triangle by dragging the circle or by clicking the color you want.
You can also select a hue by clicking anywhere on the Hue Ring (in the Standard Colors view) or on the hue indicator (in the Small Colors view).

To choose the Main color
- In the Color panel, click the front swatch, and choose a color.

To choose the Additional color
- In the Color panel, click the back swatch, and choose a color.

To work with the Main color, click the front swatch to reselect it.

To switch between the Main and Additional colors
- Click the Color Swap icon in the lower-left corner of the Color Selector.

You can also switch between the Main color and the Additional color by pressing Shift + S or Shift + X.
To switch between RGB and HSV values

1. Choose Window ▶ Color Panels ▶ Color Panel (Full View).
2. Click the Color options button  , and choose one of the following options:
   - Display as RGB
   - Display as HSV
3. Move the sliders to adjust the values, or type new values in the boxes.
   
   You can preview the new color in the Main Color (front) swatch and the Additional Color (back) swatch.

Resizing the Color panel

You can customize the Color panel by changing its width and height. For instance, you can increase the panel size in order to select colors more accurately, and then decrease the panel size in order to focus on the canvas. When the Color panel is in full view, you can change both its width and height. When the Color panel is in compact view, you can change only its width. For detailed information about resizing panels, see “To resize a panel or palette” on page 78.

Showing or hiding Color panel components

You can show or hide the Color panel components.

To show or hide the color wheel

1. Choose Window ▶ Color Panels ▶ Color Panel (Full View).
2. Click the Color options button  , and choose Color Wheel.
   
   A check mark indicates that it is displayed.

To show or hide the color sliders

1. Choose Window ▶ Color Panels ▶ Color Panel (Full View).
2. Click the Color options button  , and choose Color Sliders.
   
   A check mark indicates that it is displayed.

To show or hide the Clone Color button

• In the Color panel, click the Color options button  , and choose Clone Color Button.
   
   A check mark indicates that it is displayed.

Using the color selector

The color selector is a floating color palette that displays in the document window and allows you to view and choose colors in the context of your image.
Display the color selector over your image to choose colors based on the colors in your image. Artwork by Skip Allen

The color selector is similar to the **Color** panel and consists of two components: the **Hue Ring** and the **Saturation/Value Triangle**.
Saturation levels can be set from left to right. Dragging or clicking to the right increases the saturation and produces purer colors within the predominant hue. Dragging or clicking to the left reduces the level of color saturation, producing “muddier” or grayer colors.

Values can be set from top to bottom. The top of the triangle is the highest value (white), and the bottom is the lowest value (black).

You can preview a new color before selecting it. When you interact with the Hue Ring or the Saturation/Value triangle in the color selector, the left half of the color swatch displays a preview of the new color and the right half shows the existing color.

You can also enable the **Clone Color** option from the color selector. For more information, see “Cloning color” on page 245.

The color selector is available both as a temporal palette that disappears after you pick a color and click in the document window and as a palette that can stay open as long as you need it. You can easily move the color selector in the document window and resize it to take a closer look at colors. You can also configure the color selector for left-handed artists.

**To display the color selector**

- Press **Command + Option + 1** (macOS) or **Ctrl + Alt + 1** (Windows).

You can customize the keyboard shortcut for displaying the color selector by choosing **Corel Painter 2020 menu ➤ Preferences** (macOS) or **Edit ➤ Preferences** (Windows), and choosing **Customize Keys**. In the **Customize Keys** dialog box, choose **Other** from...
the Shortcuts for (macOS) or Shortcuts (Windows) list box, click Toggle Color Selector, and enter a new shortcut key in the Shortcut column and click OK.

When you display the color selector for the first time, it appears in the center of the document window; every subsequent time, it appears where you last placed it.

When unpinned, the temporal color selector appears under your cursor.

If you are using a Wacom tablet, you can also assign a shortcut to the stylus button.

You can also display the temporal color selector by double-clicking the Main or Additional Color swatches in the Color panel.

To display the color selector in the Simple layout (Window ➤ Layout ➤ Simple), you can click the Color Selector button in the toolbox.

By default, the Color Selector tool is available only in the toolbox of the Simple layout. To make it available in all layouts, you can add it to a custom palette. For information about creating custom palettes, see “Creating and modifying custom palettes” on page 84.

To pin the color selector

* In the color selector, click the Options menu, and choose Pin.

A check mark indicates that the color selector is pinned.

To choose a color on the color selector

1 In the color selector, click a color on the Hue Ring.

2 Inside the Hue Ring, click the Saturation/Value Triangle to set the exact shade that you want.

The color is displayed as the current color.

To switch between the Main and Additional colors when using the color selector, click the Options menu, and choose Swap Colors.

To resize the color selector

* Position the cursor over the clear edge of the color selector and when the crosshair cursor appears, drag until the color selector is the size you want.

To move the color selector

* Click anywhere in the grab area and drag the color selector to a new position.
To enable Clone Color in the color selector

* In the color selector, click the Options menu \( \equiv \), and choose Use Clone Color.

A check mark indicates that it is enabled.

To enable left-handed mode in the color selector

* In the color selector, click the Options menu \( \equiv \), and choose Left-Handed.

A check mark indicates that it is enabled.

Changing the paper color

You can change a document’s paper color — the color of the background canvas — at any time.

To change the existing paper color

1. Choose a Main Color from the Color panel.
2. Choose Canvas  Set Paper Color.

The paper color is not displayed until you paint with a variant that exposes paper color.
Do not use a bleach variant to expose the new paper color unless the paper color is white. Bleach variants erase to white, regardless of the paper color.

Sampling colors from images

You can select, or sample, a color from an existing image so that you can apply it to other areas in an image. You can sample a color from one or more selected layers or from all visible layers. By default, you sample a single pixel from the image window. In addition, you can sample pixels from a selected area. When you sample color from an area, Corel Painter averages the colors of pixels in the selected area. You can set the sample area size to 3 × 3, 5 × 5, 11 × 11, 31 × 31, 51 × 51, and 101 × 101 pixels.

To sample a color from an image

1. On the Color Selector in the toolbox, click the Main Color or Additional Color.
2. Click the Dropper tool in the toolbox.
3. Choose an option from the Sample Size list box on the property bar.
   - **Point sample** — lets you sample the color of a single pixel
   - **3 × 3** — lets you sample the average color value in a 3 × 3 pixel area
   - **5 × 5** — lets you sample the average color value in a 5 × 5 pixel area
   - **11 × 11** — lets you sample the average color value in a 11 × 11 pixel area
   - **31 × 31** — lets you sample the average color value in a 31 × 31 pixel area
   - **51 × 51** — lets you sample the average color value in a 51 × 51 pixel area
   - **101 × 101** — lets you sample the average color value in a 101 × 101 pixel area
4. Choose an option from the Sample list box on the property bar.
   - **Selected layer(s)** — lets you sample a color from the active layer or one or more selected layers
   - **All Visible Layers** — lets you sample a color from all underlying layers that are visible
5. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample a color from the active layer</td>
<td>Click in the image.</td>
</tr>
<tr>
<td>Sample a color from selected layers</td>
<td>Select the layers in the Layers panel and click in the image.</td>
</tr>
<tr>
<td>Sample color from all visible layers</td>
<td>Click in the image.</td>
</tr>
</tbody>
</table>

The Dropper tool does not pick up color in areas of transparency; it returns the last color that you sampled. The Dropper tool picks up visible color only; it cannot be used to select a hidden color.

The Dropper tool works with the Brush, Crop, Pen, Rectangular Shape, Oval Shape, Text, Shape Selection, Scissors, Add Point, Remove Point, Convert Point, and Paint Bucket tools.
You can quickly access the Dropper tool from the toolbox by clicking the Brush tool in the toolbox, and then pressing Option (macOS) or Alt (Windows) or by pressing D on the keyboard.

Cloning color

Cloning a color lets you pick up dabs of color from an original (source) image and apply the same color to a clone (destination). Brushes that use dab-based dab types produce a color based on samples of color from the clone source, which results in an approximation of the original color. Brushes that use rendered dab types sample several colors and load each color onto individual bristles, which allows startlingly realistic results. For more information, see “Painting in the clone” on page 185.

Creating two-color brushstrokes

Selected brush categories include variants that support two-color brushstrokes. For example, the Acrylics, Calligraphy, and Chalk categories include variants that allow you to produce two-color brushstrokes. They are also known as noncomputed dab types, which are dab-based, as opposed to rendered. For more information, see “General controls: Dab types” on page 378.

You can choose the two colors used by the brushstroke by specifying both a Main and an Additional Color. If you have only a Main Color selected, you produce a solid-color brushstroke. You can then use the Color Expression panel to determine when Corel Painter uses one color or the other. For more information, see “Setting Color Expression” on page 260.

To set up a two-color brushstroke

1. In the Color panel, click the Main Color (front) swatch.
2. Click a color on the Saturation/Value Triangle.
3. Click the Additional Color (back) swatch.
4. Click a color on the Saturation/Value Triangle.
5. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Color Expression.
   Displaying the Color Expression panel helps you determine which brush variants support two-color brushstrokes.
6. Click the Brush Selector on the Brush Selector bar.
7. In the Brush library panel, click a brush category and a brush variant.
   If the Expression list box is grayed out in the Color Expression panel, the brush variant does not support two-color brushstrokes.
8. In the Color Expression panel, choose Direction from the Expression list box.
For information about using the Color Sets panel, see “Working with color sets” on page 253.

For information about using Color Expressions, see “Setting Color Expression” on page 260.

For different results, try different Expression settings. For example, choose Pressure to create color transitions based on the pressure you apply with your stylus.

You can also choose a color from a color set. For more information, see “Working with color sets” on page 253.

Exploring the Mixer panel and mixing controls

The Mixer panel lets you mimic the experience of mixing colors on a traditional artist’s palette. In the Mixer panel, you can access color swatches and various tools that let you mix colors. You can then apply two or more colors to the Mixer pad, the mixing area at the center of the Mixer panel, and then blend them together to create a new color.

You can save, load, and reset colors in the Mixer panel. In addition, you can save colors as Mixer swatches and save colors to color sets.

Understanding the Mixer panel controls

The controls in the Mixer panel are used to apply, mix, sample, and clear color on the Mixer pad.

The following table describes all of the Mixer panel tools.

<table>
<thead>
<tr>
<th>Mixer panel tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dirty Brush Mode tool</td>
<td>Lets you apply colors that were mixed in the Mixer panel to the canvas. The Dirty Brush Mode tool is active by default and</td>
</tr>
</tbody>
</table>
Mixer panel tool

Description

can be used with brush variants that support mixing. For more information, see “Mixing, sampling, and applying colors from the Mixer pad” on page 248.

Apply Color tool

Acts as a loaded paint source; applies color to the Mixer pad. Color loaded on the Apply Color tool blends with color already in the Mixer pad.

Mix Color tool

Mixes colors already in the Mixer pad; does not add new colors to the Mixer pad.

Sample Color tool

Samples color in the Mixer pad for use on the canvas. The sampled color becomes the Main Color in the Color panel.

Sample Multiple Colors tool

Samples multiple colors in the Mixer pad. The size of the sample area is determined by the Change Brush Size slider. You can use the sampled color on the canvas.

Zoom tool

Lets you zoom in and out of areas in the Mixer pad

Pan tool

Lets you scroll through the Mixer pad

Using the Clear and Reset Canvas button

The Clear and Reset Canvas button erases the contents of the Mixer pad and resets the zoom level to 100%. It does not, however, reset the brush size.

Using the Change Brush Size slider

The Change Brush Size slider lets you increase or decrease the size of the Apply Color tool and the Mix Color tool. The Change Brush Size slider also lets you set the size of the sample area in the Mixer pad when sampling with the Sample Multiple Colors tool. If you adjust the Change Brush Size slider, the new value is retained when you reopen the application.

Displaying and resizing the Mixer panel

To display the Mixer panel, you can use the Window menu, or you can use a keyboard shortcut. You can start mixing colors using the default Mixer Pad or you can load one of the inspirational Mixer Pads that were designed for you by various expert Corel Painter artists.

If you need more space to mix your colors, you can undock the Mixer panel and resize it. Increasing the size of the Mixer panel also gives you access to additional Mixer swatches. For more information, see “Changing and saving the Mixer color swatches” on page 251.

You can also change the background of the Mixer pad, the surface on which you mix color.
To display the Mixer panel

- Choose Window ▶ Color Panels ▶ Mixer.

You can also display the Mixer panel by pressing Command + 2 (macOS) or Ctrl + 2 (Windows).

To choose a Mixer Pad

1. Choose Window ▶ Color Panels ▶ Mixer.
2. Click the Mixer options button ⬈️, and choose one of the following:
   - Restore Jeremy Sutton’s Mixer Pad
   - Restore John Malcom’s Mixer Pad
   - Restore Karen Bonaker’s Mixer Pad
   - Restore Skip Allen’s Mixer Pad
   - Restore Default Mixer

To resize the Mixer panel

- With the Mixer panel undocked, drag the resize handle at the lower-right corner of the main window of the panel.

To change the Mixer pad background

1. Choose Window ▶ Color Panels ▶ Mixer.
2. Click the Mixer options button ⬈️, and choose Change Mixer Background.
3. In the Color dialog box, choose a background color.

Mixing, sampling, and applying colors from the Mixer pad

You can create a color in the Mixer panel and then sample it to apply it to the canvas.

In addition, some brush variants that support mixing allow you to mix colors in the Mixer panel and apply them directly to the canvas without sampling, which mimics the traditional experience of mixing color on an artist’s palette. The brush variants that support mixing use the following dab types: Camel Hair, Flat, Bristle Spray, Watercolor Camel Hair, Watercolor Flat, and Watercolor Bristle Spray. The dab
type for a brush variant appears in the General panel of the Brush Controls palette. These brush variants also allow you to sample multiple colors simultaneously to produce multi-colored brushstrokes.

![Image of brush variants](image)

You can sample multiple colors in the Mixer panel and paint directly on the canvas.

When you have finished mixing and sampling colors, you can clear the mixer pad, or save it as a mixer pad (MXS) file that you can open and use later. For more information, see “Saving the Mixer pad” on page 252.

To mix colors
1. Choose **Window** ➤ **Color Panels** ➤ **Mixer**.
2. Click the **Apply Color** tool in the Mixer panel.
3. Choose a color from a Mixer swatch, and paint on the Mixer pad.
4. Choose a second color from the Mixer swatch, and paint on the Mixer pad.
5. Do one of the following:
   - Use the **Apply Color** tool to add to and blend the colors.
   - Use the **Mix Color** tool to blend the colors.

To sample a color from the Mixer pad
1. Choose **Window** ➤ **Color Panels** ➤ **Mixer**.
2. Click the **Sample Color** tool.
3. On the Mixer pad, click the color you want to sample.
   - The sampled color becomes the **Main Color** in the image.

To paint from the Mixer panel
1. Mix the color you want in the Mixer panel.
   - The **Dirty Brush Mode** tool is active by default. If it is not active, click the **Dirty Brush Mode** tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, choose a brush category and variant that supports mixing.
4. Paint in the document window.
   - The last color on the **Apply Color** tool or **Mix Color** tool is used in the brushstroke.
To verify if a brush variant supports mixing, you can click Window ➤ Brush Control Panels ➤ General, and ensure that one of the following dab types is selected: Camel Hair, Flat, Bristle Spray, Watercolor Camel Hair, Watercolor Flat, and Watercolor Bristle Spray.

To sample multiple colors

1. In the Brush library panel, choose a brush category and variant that supports mixing.
2. Mix the color you want in the Mixer panel.
3. Move the Change Brush Size slider to set the size of the sample area.
   - The size of the sample area is displayed to the right of the slider and is measured in pixels.
4. Click the Sample Multiple Color tool, and click the area of the Mixer pad that you want to sample.

Opening images in the Mixer panel

You can now load an external image file in the Mixer panel so that you can sample and mix the image colors. For example, you can open a photo and then blend its colors directly in the Mixer pad to create new colors. You can open PNG, RIFF, TIFF, JPEG, and PSD files in the Mixer panel.

An example of importing a photo in the Mixer panel (left) to transform the photo into a Mixer Pad

To open an image in the Mixer panel

1. Click the Mixer options button, and choose Open Mixer Pad.
2. In the Open Mixer Pad dialog box, choose the image file format from the list box.
3. Browse to the folder where the image file is stored.
4. Choose the image, and click Open.
Changing and saving the Mixer color swatches

You can store commonly used colors in Mixer color swatches at the top of the Mixer panel and then use these colors on the Mixer pad. A series of colors appears by default; however, this color series can be changed to suit the individual preferences of the artist. You can save the Mixer color swatches that you create.

To change a Mixer swatch color
1. Choose Window ➤ Color Panels ➤ Mixer.
2. In the Mixer panel, click the Sample Color tool, and choose a color for the swatch.
3. Press Command (macOS) or Ctrl (Windows) and then click the Mixer swatch that you want to change.
   The new color appears in the Mixer swatch.

To save colors in the Mixer panel
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Click the Mixer options button, and choose Save Mixer Colors.
3. In the Save Mixer Colors dialog box, type a name for the Mixer colors and choose where you want to save the Mixer swatches (MSW) file.
4. Click Save.

Saving Mixer panel colors to a color set

You can add individual colors that you saved as color swatches to the currently selected color set. For example, if you mixed colors that you are particularly happy with, you can save them to a color set. You can also create a color set from the colors on the Mixer pad. You can also choose the maximum number of colors that you want to retain from the Mixer pad. For more information, see “Working with color sets” on page 253.

To add a Mixer color swatch to a color set
1. In the Mixer panel, click the Sample Color tool, and choose the Mixer swatch that you want to save to a color set.
2. Click the Mixer options button, and choose Add Swatch to Color Set.
   The selected color is added to the current color set.

To create a color set from the Mixer Pad
1. In the Mixer panel, click the Mixer options button, and choose New Color Set from Mixer Pad.
2. In the New Colorset dialog box, type a name in the Name text box.
3. Adjust the Max Colors slider to set the maximum number of colors that you want to add to the color set.
4. Click OK.
5. To access the new colors, choose Window ➤ Color Panels ➤ Color Sets.
Clearing and resetting Mixer panel colors

There are various options for clearing and restoring both the Mixer pad and Mixer color swatches. You can clear all colors from the Mixer pad to start mixing colors from scratch. You can also restore the Mixer pad to the default colors.

In addition, you can reset the Mixer color swatches to the factory default colors.

You can revert to the factory default color swatch colors.

To clear the Mixer pad
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Do one of the following:
   - Click the Mixer options button, and choose Clear Mixer Pad.
   - In the Mixer panel, click the Clear and Reset Canvas button.

To restore the default Mixer pad
- Click the Mixer options button, and choose Restore Default Mixer.

To reset Mixer color swatches
- Click the Mixer options button, and choose Reset Mixer Colors.

Saving the Mixer pad

When you have finished mixing and sampling colors, you can save the Mixer pad contents as a Mixer pad (MXS) file that you can open and use later. In addition, you can also save a Mixer pad as a PNG file.

To save a new version of the Mixer pad
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Click the Mixer options button, and choose Save Mixer Pad.
3. In the Save Mixer Pad dialog box, type a name for the Mixer colors, and choose where you want to save the Mixer pad (MXS) file.
4. Click Save.

To save a Mixer pad as a PNG file
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Click the Mixer options button, and choose Save Mixer Pad.
3. In the Save Mixer Pad dialog box, type a name in the File Name box.
4. Choose choose PNG from the Save As Type list box.
5. Click Save.
**Loading color swatches and Mixer pad files**

You can load previously saved Mixer color swatches or Mixer pad files (MXS) in the Mixer panel.

**To load colors in the Mixer panel**
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Click the Mixer options button ☰, and choose Load Mixer Colors.
3. In the Load Mixer Colors dialog box, choose the Mixer swatch (MSW) file that you want to load.
4. Click Open.

You can also load a color set in the Mixer panel by clicking the Mixer options button ☰, choosing Load Mixer Colors. In the Load Mixer Colors dialog box, go to Corel\Painter 2020\Support Files\Color Sets\[Color Set Name], type *.* in the File name box, and press Enter. A list of hidden user files appears. Double-click a color set.

**To load a saved version of the Mixer pad**
1. Choose Window ➤ Color Panels ➤ Mixer.
2. Click the Mixer options button ☰, and choose Open Mixer Pad.
3. In the Open Mixer Pad dialog box, choose the Mixer pad (MXS) file that you want to open.
4. Click Open.

**Working with color sets**

Color sets are collections of colors that help you organize and store colors. Some color sets are organized by both name and color relationship. Corel Painter provides several color sets — Painter Colors, macOS and Windows system palettes, and the PANTONE MATCHING SYSTEM are a few. You can open any of the available color sets, choose a color from the color set, and then apply it to a brushstroke. You can open multiple color sets at a time.

In addition, you can import a color set to access additional colors. For example, you can import a color set that you created in a previous version of Corel Painter.

If you need to find a specific color in a color set, you can search for the color by name or have Corel Painter find the color that comes closest to matching the current color.
To display the Color Sets panel

- Choose Window ▶ Color Panels ▶ Color Sets.

To open a color set

- In the Color Set Libraries panel, click the Color Set Libraries options button ▶, and choose Color Set Libraries, and choose a color set from the list.

To choose a color from a color set

- In the Color Set Libraries panel, click a color.

To import a color set

1. In the Color Set Libraries panel, click the Import Color Set button ⌘.
2. In the Select Color Set dialog box, click the Color Sets folder, choose a color set, and click Open.

To find a color in a color set

1. In the Color Set Libraries panel, click the Search for Color button 🔍.
2. In the Find Color dialog box, do one of the following:
   • Enable the By name option, and type a name in the box.
   • Enable Closest to current color.
3. Click Begin.
4. Click OK when the desired color is found.

   If the color set is visible, Corel Painter surrounds the found color with a selection frame.

   If you search for a color by name, but a color with that name is not found, the OK button is not available (it is grayed out).
Customizing the layouts of color sets

You can arrange colors in a color set in various ways. You can sort by hue, luminance, and saturation; determine the size of color swatches; decide whether to have grid lines; and display the colors in a list in order to view the color names.

To change how colors are sorted

1. Choose **Window ▶ Color Panels ▶ Color Sets**.
2. In the **Color Set Libraries** panel, click the Color Set options button and choose Sort Order.
3. Choose one of the following options:
   - **Saved** — sorts colors in the order in which they were originally entered.
   - **HLS** — sorts colors by hue, luminance, and saturation.
   - **LHS** — sorts colors by luminance, hue, and saturation.
   - **SHL** — sorts colors by saturation, hue, and luminance.

To adjust the size of the color swatches

- In the **Color Set Libraries** panel, click the Color Set options button, choose Color Set Library View, and choose one of the following options:
  - **Small**
  - **Medium**
  - **Large**

To display the color swatches as a list

- In the **Color Set Libraries** panel, click the Color Set options button, choose Color Set Library View, and choose List.

Creating and exporting color sets

You can create color sets to control the colors in particular projects or to create groups of favorite painting colors. Creating clearly named color sets can be very useful. For example, you could name a color set Shades of Purple, Hero Image, My Crayons, or Rollover Buttons — all offering you easy access to recognizable color sets.

You can create color sets from

- an image
- a selection on an image
- a layer
- the **Mixer** panel

Once a color set is created, you can add additional colors to the color set. You can also export the color set.

To create a color set

1. Choose **Window ▶ Color Panels ▶ Color Sets**.
2. In the **Color Set Libraries** panel, click the New Color Set button and choose one of the following options:
   - **New Color Set from Image** — includes all image colors in the color set. This option is available only if an image is open.
   - **New Color Set from Layer** — includes all colors that are found in the active layer in the color set. This option is available only if an active layer is selected in the image.
• **New Color Set from Selection** — Includes all colors in the selected area of the image in the color set. This option is available only if the image has an active selection.

• **New Color Set from Mixer Pad** — Includes all colors that are used in the Mixer panel in the color set.

3 In the **New Color Set** dialog box, type a name in the Name text box.

4 Adjust the Max Colors slider to set the maximum number of colors that you want to add to the color set.

For information about adding colors to a color set, see “Editing color sets” on page 256.

For more information about selecting colors, see “Choosing colors from the Color panel” on page 236.

### To export a color set

1 In the **Color Set Libraries** panel, click the Export Color Set button.

2 Choose the name of the color set that you want to export from the Library list box.

3 Click OK.

4 Choose the drive and folder where you want to save the file.

   If you want to rename the color set, type a name for the color set in the File name box.

5 Click Save.

### Editing color sets

You can customize color sets by adding, deleting, or replacing colors. You can also append colors to a color set. This is useful if you want to use colors from multiple color sets. In addition, you can name or rename individual colors in a color set.

Naming colors in a color set can be useful. You can then search for a color by name, or annotate the colors you use, right in the document window. For more information, see “To find a color in a color set” on page 254.

### To add a color to a color set

1 In the **Color** panel, choose a color.

2 In the **Color Set Libraries** panel, choose the color set where you want to add the selected color.

3 Click the **Add Color to Color Set** button.

You can also

| Add a sampled color to a color set | Click the Dropper tool in the toolbox, click a color in the image, then click the Add Color to Color Set button. |
| Add a color from another color set | Drag a color swatch from one color set to another. |

### To delete a color

1 In the **Color Set Libraries** panel, choose a color and click the **Delete Color from Color Set** button.

2 In the warning dialog box, click Yes.

   Corel Painter deletes the chosen color from the color set.
To replace a color
1. Choose the color you want to add from the Color panel, a color set, or an existing image.
2. Hold down Command (macOS) or Ctrl (Windows), and click the color you want to replace.
   The new color replaces the old one in the color set.

To show or hide a color
- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide a color</td>
<td>Right-click a color swatch in the Color Set Libraries panel, and choose Hide Color.</td>
</tr>
</tbody>
</table>
| Show all hidden colors | In the Color Set Libraries panel, click the Color Set options button  
|                     | choose Color Set Library View, and choose Show All Hidden Items. |

To name or rename a color
1. Right-click a color swatch in the Color Set Libraries panel, and choose Rename Color.
2. Type a color name in the New name box.
   Color names can contain up to 31 characters.

To restore the default color set
- In the Color Set Libraries panel, click the Color Set options button  
  choose Restore a Default Color Set.

Working with color harmonies
Corel Painter lets you create a color harmony, a set of colors that work well together aesthetically. The resulting color scheme contains a set of colors that are created based on the chosen mode, and its base color is the Main Color in the Color panel.
Warm and cold colors are created for vibrant and energetic color schemes. From left to right, the five color swatches of the Complementary harmony are: Main color (1) and its direct complementary color (5); (2), (3), and (4) are a blend of the two complementary colors.

Once you create a color harmony, you may choose to lock it to prevent changes to the colors. When a harmony is not locked, the colors in the color harmony are linked to the Main Color in the color wheel. Changing the Main Color dynamically updates the swatches in the color harmony, and vice versa, clicking a color harmony swatch updates the Main Color in the color wheel. When you lock a harmony, selecting a new Main Color in the color wheel does not affect the color harmony colors, however, clicking a color harmony swatch still updates the Main Color in the color wheel. When you unlock a color harmony, it is updated immediately based on the Main Color in the color wheel.

You can save a color harmony for future use. Color harmonies are saved as color sets and appear in the Color Set Libraries panel (Window ▸ Color Panels ▸ Color Sets).

To create a color harmony

- Do one of the following:
  - Choose a color in the Color panel.
  - Double-click the Main Color or Additional Color swatches in the Color panel to display the floating color selector, and choose a color in the context of your painting.
Corel Painter automatically applies the **Complementary** color harmony mode and creates a color palette, which appears in the **Harmonies** panel.

If you select a swatch in the color harmony, the harmony is updated using that swatch as the base color.

**To lock or unlock a color harmony**

- Click the **Lock** button next to the color harmony.

**To show or hide the color harmony swatches**

- In the **Harmonies** panel, click the Color options button and choose a color harmony option:
  - **Analogous Harmony** — includes colors that are next to each other on the color wheel, creating clear and smooth color schemes. The Main Color is the middle of five swatches.
  - **Complementary Harmony** — balances the Main Color with the opposite color on the color wheel. Warm and cold colors are created for vibrant and energetic color schemes. From left to right, the five color swatches are: Main color (1) and its direct complementary color (5); (2), (3), and (4) are a blend of the two complementary colors.
  - **Split Complementary Harmony** — balances the Main Color with colors that are situated close to the opposite end of the color wheel, forming a triangle. This harmony rule usually creates color schemes of soft contrast. The Main Color is the leftmost of three swatches.
  - **Tetradic Harmony** — based on a pair of colors and their complements on the color wheel. This rule usually creates bold color harmonies and requires careful planning when used. The Main Color is the leftmost of four swatches.
  - **Monochromatic Light Harmony** — creates smooth color schemes that include five colors: the Main Color, which is the leftmost color, and four variations that increase in lightness in increments of 10%
  - **Monochromatic Dark Harmony** — creates smooth color schemes that include five colors: the Main Color, which is the leftmost color, and four variations that increase in darkness in increments of 10%

**To save a color harmony as a color set**

1. In the **Harmonies** panel, click the **Add Swatches to Color Set** button next to the color harmony.
2. In the **New Library** dialog box, type a name in the **Save As** box, and click **OK**.

   The new set appears at the bottom of the **Color Sets Libraries** panel (Window > Color Panels > Color Sets).

**To show or hide the Harmonies panel**

- Click **Window > Color Panels > Harmonies**.

**Setting color variability**

Color variability allows you to create brushstrokes of more than one color. Variability can be used to enhance the Natural-Media appearance of your work. For more information, see “Color Variability controls” on page 439.
Setting Color Expression

Color expression determines where Corel Painter should use the Main or Additional Color in an image. For more information, see “Color Expression controls” on page 441.

Loading multiple colors

Imagine the ability to load color at a bristle level, picking up different colors with each “hair” of a brush — as though filling tiny ink wells. Imagine also the ability to move multiple colors along with a palette knife, dragging them across your canvas or paper. The Brush Loading feature affects how paint comes off a brush and what happens to the pixels underneath.

When Brush Loading is not active, brushes interact with previously applied colors by sampling underlying pixels and then loading the brush with one new color — the average of those that were sampled. With Brush Loading active, brushes can literally “pick up” existing colors, hair by hair. This capability offers truer color interaction, astounding color variations, and better cloning results.

To paint with multiple colors

1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category and a brush variant.
3. Choose Window ▶ Brush Control Panels ▶ General.
4. Choose Static Bristle from the Dab Type list box.
5. Choose Multi from the Stroke Type list box.
6. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Blending.
7. In the Blending panel, enable the Brush Loading check box.
   This step activates the brush’s ability to pick up underlying colors.
8. Adjust the Resaturation and Bleed sliders.
   The Bleed setting determines how much underlying paint is affected by the brushstroke. A higher Bleed setting, combined with a low Resaturation setting, can enhance the Brush Loading feature. A resaturation value of 0, combined with different levels of bleed, will cause your brush to smear image color, rather than deposit it. In this case, the lower the bleed, the longer the smear.
9. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Spacing.
10. In the Spacing panel, adjust the Spacing and Min Spacing sliders to create fewer “echo” artifacts in your smeared stroke.
11. Drag a brushstroke through existing paint to see how the paint is “picked up” from the underlying pixels and moved across the canvas.

   It is easier to see the Brush Loading feature if the canvas is not white. To fill the canvas with another color, see “Applying a color as a fill” on page 261.

   You can tie brush controls like Bleed to the Controller setting in the Color Expression panel. For example, if you choose Pressure, each stroke bleeds more or less, depending on how hard you press the stylus. For more information, see “Expression settings” on page 373.

Working with color fills

Corel Painter gives you many options for filling images with color. You can apply a color fill to only part of an image, to a layer of an image, to an alpha channel, or to an entire image. You can also fill image areas based on pixel color.

In addition, you can apply gradients, patterns, and weaves as fills. The following table lists the various ways to apply fills to an image and where to find more information.
**Applying a color as a fill**

Corel Painter gives you different options for applying a color as a fill. You can quickly apply a fill to a selected area of an image or you can apply a fill to the entire image based on a selected pixel color. When filling an image with a selected pixel color, you can apply the fill directly to the canvas or to a channel. Corel Painter fills areas of the image based on color boundaries, as well as the specified tolerance and feather settings.

Tolerance allows you to set the amount of variance allowed from the color of the selected pixel. With a low tolerance setting, Corel Painter fills only contiguous pixels that are very close to the selected pixel color. With a high tolerance setting, Corel Painter fills a greater range of colors.

Feathering softens the edges of the fill by controlling the fill opacity for pixels with colors outside the tolerance range. For example, if feather is set to zero (the default), only pixels in the tolerance range are filled. With a low feather setting, pixels with colors just outside the Tolerance range receive partial fill. Increasing the feather setting increases the range of colors that receive partial fill. Pixels with colors farther from the tolerance range receive a more transparent fill. Typically, when feather is set high, tolerance is set low.

You can also fill the interior of an area that is bound by lines. This is especially useful for producing solid fills of regions bounded by anti-aliased lines. If you want to fill regions completely, without affecting the lines, you can first copy the lines to a selection. Then, when you fill the cells, the lines are protected.

**To apply a color fill**

1. In the **Color** panel, click the **Main Color** (front) swatch in the Color Selector, and choose a color.

2. To apply a gradient to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.
   - A channel — Click a channel in the **Channels** panel.

3. Choose **Edit** ➤ **Fill**.
   If you prefer, press **Command** + F (macOS) or **Ctrl** + F (Windows).

4. In the **Fill** dialog box, choose **Current Color** from the **Fill with** list box.

5. Adjust the **Opacity** slider.

**To apply a pixel-based color fill**

1. Choose **Window** ➤ **Color Panels** ➤ **Color Sets**.

2. In the **Color Sets** panel, click the Color Sets options button , and choose **New Color Set from Image**.
3 In the New Colorset dialog box, type a name in the Name text box.

4 Choose the Paint Bucket tool from the toolbox.

5 On the property bar, click one of the following buttons:
   - Fill Image
   - Fill Cell

6 Choose the Current Color option from the Fill list box.

7 Open the Select Fill panel, and choose a color.
   The image color set displays in the Select Fill palette.

8 Click the image in the drawing window.
   If the result is not what you want, undo the fill, change the settings, and try again.

You can also

Specify the range of colors to be filled
   On the property bar, type a value in the Tolerance box or adjust the slider.

Specify the fill opacity for pixels outside of the tolerance range
   On the property bar, type a value in the Feather box or adjust the slider.

Soften the edges of the fill
   On the property bar, click the Anti-Alias button.
   Anti-aliasing is desirable when the Feather setting is set to zero or extremely low.

You can constrain the fill to a rectangular area by dragging with the Paint Bucket tool.

Limiting and preventing leakage

In complex drawings, lines don’t always meet, which can cause the fill to leak into areas that you don’t want filled — sometimes through the whole image. You can’t always tell if there’s a leak just by looking at your image. If you click a small area and see the prompt, Now Looking for Extent of Fill, there’s probably a leak, and Corel Painter is preparing to fill a bigger area than you had in mind. In this case, you can abort the fill.

You can limit leakage to a specific rectangular area. In typical cartoon line work, unbounded areas — for example, hair, tail feathers, and brush bristles — sometimes must be filled. By limiting leakage to a specific area, you can close off these items. You can also close leaks by copying the lines to a selection, saving the selection to a channel, editing the channel, and then reloading it to the selection. For more information about editing channels, refer to “Editing channels” on page 615.

To undo a fill

• To undo a fill, do one of the following:
  • Choose Edit » Undo Paint Bucket Fill.
  • Press Command + Z (macOS), or Ctrl + Z (Windows).
To limit leakage

1. Choose the Paint Bucket tool from the toolbox.
2. On the property bar, click the Fill Cell button or the Fill Image button.
3. Drag to create a rectangle that just covers the area you want to fill.
   If there is no leak, only the area within the lines is filled. If there is a leak, the fill goes outside the area, but not beyond the constraints of your rectangle.

To close a leak

1. Copy the lines to a selection.
2. Choose Select > Save Selection.
3. In the Save Selection dialog box, choose New from the Save to list box.
4. Click OK. A new channel is displayed in the Channels panel.
5. In the Channels panel, display and select the channel.
6. Click the Brush Selector on the Brush Selector bar.
7. In the Brush library panel, choose the same brush you used to create the lines.
8. In the Color panel, set black as the current Main Color.
9. Paint in the channel to close the gaps.
10. Choose Select > Load Selection.
11. In the Load Selection dialog box, choose the modified channel from the Load From list box.
12. Enable the Replace Selection option to replace the original with the edited version.
   If you want to adjust the mask threshold, double-click the Paint Bucket tool in the toolbox, and move the slider.

The channel does not have to be selected to contain the fill. If you deselect the channel in the Channels panel, the loaded selection is still in effect.

Edit the channel to close leaks. Remember to load the channel back into the selection after editing.
Corel Painter lets you manage colors when you create or open images, or place images in a document. The color management controls help ensure that colors are consistent when you work with images from various sources, such as Adobe Photoshop or a digital camera. In addition, you can store color information in a document by embedding a color profile in the file when you save it.

This section contains the following topics:
• “Understanding color management” (page 265)
• “Specifying the default RGB color profile” (page 268)
• “Embedding color profiles when saving files” (page 269)
• “Specifying the default CMYK color profile for converting CMYK images to RGB” (page 269)
• “Previewing and soft-proofing color profiles” (page 270)
• “Assigning or removing color profiles” (page 271)
• “Converting color profiles” (page 271)
• “Working with color profile policies” (page 272)
• “Working with presets” (page 273)

Understanding color management

This section provides answers to some commonly asked questions about color management.

What is color management?

Color management is a process that lets you predict and control color reproduction, regardless of the source or destination of the image. For example, a monitor displays a different set of colors than a printer reproduces, so you may see colors on-screen that cannot be printed. If you want to reduce color discrepancies, you can use color management to ensure a more accurate color representation when an image is viewed, modified, or printed.

During the digital imaging process, different tools are used to capture, modify, and print images. In a typical workflow, you capture an image by using a digital camera, upload the image to a computer, modify the image in a photo-editing application, and print the image. Each of these tools has a different way of interpreting color. In addition, each has its own range of available colors, called a color space, which is a set of numbers that define how each color is represented. A color space is a subset of a color model (for example, CMYK or RGB).

Consider a color in the color space of your digital camera: a vivid blue RGB color with the values Red = 0, Green = 0, and Blue = 255. This color may appear as a different color in the color space of your monitor. In addition, the color space of your printer may not contain a match for this color. As a result, when your document moves through the workflow, this vivid blue color gets lost in the translation and is not accurately reproduced.
Each tool speaks a unique language when it comes to color. One number in the color space of a digital camera may represent an entirely different color in the color space of a monitor. As a result, when an image moves through the workflow, the colors get lost in the translation and are not accurately reproduced. A color management system is designed to improve the communication of color in the workflow so that the color of the output matches your intended color.

A color management system, also known as a color engine, uses color profiles to translate the color values from the source, which ensures a more accurate color reproduction at the destination. A color profile contains the data that the color management system requires to translate colors. Many standard color profiles are available. In addition, color profiles exist for different brands of monitors, scanners, digital cameras, and printers.

Why do I need color management?

If your document requires accurate color representation, you should consider using color management. The complexity of your workflow and the ultimate destination of the images are also important considerations. If your documents are destined only for online viewing, color management may not be as important. However, if you plan to open images in another application, such as Adobe Photoshop, or if you are creating images for print or multiple types of output, the use of color management is essential.

Color management lets you do the following:

• reproduce colors consistently across your digital imaging workflow, especially when opening documents that were created in other applications
• reproduce colors consistently when sharing files with others
• preview, or soft-proof, colors before they are printed
• reduce the need to adjust and correct images when sending images to different destinations

A color management system does not offer identical color matching (this is not technically possible), but it greatly improves the color representation.

Is my monitor displaying the right colors?

How you perceive the color that your monitor displays is another important factor in managing color consistency. Your perception is influenced by the environment in which you are viewing the images. Here are some ways to neutralize your viewing environment.

• Ensure that your room has a consistent flow of light. For example, if the room is filled with sunlight, use a shade, or if possible, work in a room without windows.
• To ensure accuracy in perceiving colors, some graphics professionals work in windowless rooms with gray or neutral walls and ceilings. If these conditions do not match the room you work in, you can invest in a monitor hood, or you can create one by using black cardboard and tape.
• Don’t wear bright clothing that can clash with the display of colors on the monitor. For example, wearing a white shirt reflects on the monitor and alters your perception of color.
• Set the monitor background to a neutral color, such as gray, or apply a grayscale image. Avoid using colorful wallpapers and screensavers.

Calibration and profiling of the monitor, also known as characterization, are also important steps for ensuring color accuracy. Calibration helps ensure consistency in the colors that are displayed on the monitor. After calibration, you can create a color profile of the monitor, which contains the details of how the monitor interprets colors. The profile is then shared with other devices. Calibration and profiling work together to achieve color accuracy. If a monitor is incorrectly calibrated, its color profile is not useful.
Calibration and profiling usually require a special calibration device and specialized software. Keep in mind that improper calibration may do more harm than good. You can find additional information about monitor calibration and custom color profiles by researching color-management techniques and products. You can also refer to the documentation that was provided with your operating system or monitor.

Should I assign or convert color profiles?

In deciding whether to assign or convert a color profile, you should first consider the results that each action produces. When you assign a color profile in Corel Painter, the color values, or numbers, in the document do not change. Instead, the application simply uses the color profile to interpret the colors in an image. However, when you convert a color profile, the color values in the document change. Instead of assigning a color profile, the application translates one color profile to another. Converting a color profile does more than affect the display of colors — it produces irreversible changes to the colors in the document.

The best practice is to choose a working color space, such as sRGB, when you create an image and to use the same color profile throughout your workflow. You should avoid assigning and converting color profiles. However, you may encounter scenarios that require you to switch to a different color profile.

For example, if you receive a file from someone, and no color profile is embedded in the file, you should assign a color profile to the file. In this way, you can retain the file’s original color values.

You should choose the conversion option only if you are preparing the file for a specific output, such as a printer. After the data has been changed to accommodate the destination profile, conversion back to the original color profile is often not suitable.

What is a rendering intent?

A color management system can perform effective translation of colors from the source to multiple outputs. However, when matching colors from one color space to another, a color management system may be unable to match certain colors. These “out-of-gamut” colors can dramatically change the look of the image, depending on how they are interpreted by the color management system. Fortunately, you can choose a rendering intent to instruct the color management system how to interpret the out-of-gamut colors.

Many colors in an sRGB (1) document may be out of gamut for the U.S. Web Coated (SWOP) v2 color space (2). The out-of-gamut colors (3) are mapped into gamut according to the rendering intent.

The rendering intent that you choose depends on the graphical content of the image.
This is an example of three types of images and their corresponding rendering intents.

- **Perceptual** — Choose this rendering intent for photographs and bitmaps that contain many out-of-gamut colors. The overall color appearance is preserved by changing all colors, including in-gamut colors, to fit within the destination’s range of colors at the destination. This rendering intent maintains the relationships between colors to produce the best results. In general, the Perceptual rendering intent is best for giclée prints.

- **Saturation** — Choose this rendering intent to produce more concentrated solid colors in business graphics, such as charts and graphs. Colors may be less accurate than those produced by other rendering intents.

- **Relative Colorimetric** — Choose this rendering intent for logos or other graphics to preserve original colors. If a match is not found for the source colors, then the closest possible match is found. This rendering intent causes the white point to shift. In other words, if you are printing on white paper, the white areas of an image use the white of the paper to reproduce the color. Therefore, this rendering intent is a good option for printing images.

- **Absolute Colorimetric** — Choose this rendering intent for logos, or other graphics, that require very precise colors. If no match is found for the source colors, then the closest possible match is used. The Absolute Colorimetric and Relative Colorimetric rendering intents are similar, but the Absolute Colorimetric rendering intent preserves the white point through the conversion and does not adjust for the whiteness of the paper. This option is used mainly for proofing.

**What is soft-proofing?**

Soft-proofing provides an on-screen preview of the image as it will appear when it is reproduced by a specific printer or displayed on a specific monitor. This technique simulates the “hard-proofing” stage in a traditional printing workflow.

Unlike hard-proofing, soft-proofing lets you look at the final result without committing ink to paper. For example, you can preview what the printed image will look like when a specific brand of printer is used. You can also preview what the image will look like on another type of monitor.

To simulate the output colors that are produced by a device, you need to choose the color profile of the device. Because the color spaces of the document and device are different, some document colors may not have matches in the gamut of the device color space. These out-of-gamut colors can dramatically change the look of the image, depending on how they are interpreted by the color management system. You can choose a rendering intent to instruct the color management system how to interpret the out-of-gamut colors. For information about rendering intents, see “What is a rendering intent?” on page 267.

For information about soft-proofing an image, see “To soft-proof an image” on page 270.

**Specifying the default RGB color profile**

To use color management in Corel Painter, you can start by specifying the default RGB color profile that you want to assign to all new documents.

The default settings in Corel Painter produce good color results, but you can change these default settings so that they suit your specific workflow. The Corel Painter default color profile is sRGB IEC61966-2-1 black scaled. You can visit the International Color Consortium (ICC) website [http://www.color.org/findprofile.xalter](http://www.color.org/findprofile.xalter) to find more information about this profile.

When you create images in another application, such as Adobe Photoshop, you should use the same default color profile that you will use when opening the file in Corel Painter. In addition, you should always embed the color profile when saving a document in Corel Painter or Adobe Photoshop, so that the document retains the color information. For more information, see “Embedding color profiles when saving files” on page 269.
To change the default RGB color profile
1. Choose Canvas ➤ Color Management Settings.
2. Choose a color profile from the Default RGB Profile list box.

The factory default color profile for Corel Painter is sRGB, which is the default color profile for many monitors, digital cameras, and even some printers.

You can also access the Color Management Settings dialog box from the Navigator panel by clicking the Open Navigator Settings button ▽, clicking Color Management, and choosing Color Management Settings.

Embedding color profiles when saving files
Embedding a color profile attaches the color profile to the document to ensure that the same colors you used are shared with anyone who views or prints the document. In this way, you help ensure color consistency when files are viewed, modified, or reproduced.

If you did not assign a color profile to the file, the default color profile is embedded.

The following file formats support color profile embedding:
• RIFF (RIF)
• TIFF (TIF)
• Photoshop (PSD)
• JPEG
• Portable Network Graphics (PNG)

To embed a color profile when saving a file
1. Choose File ➤ Save As.
2. In the Save Image As dialog box, use the controls to specify a location and filename.
3. From the Format list box (macOS) or the Save As Type list box (Windows), choose one of the following file formats:
   • RIFF Files (*.RIF; *.RIFF)
   • TIF Files (*.TIF; *.TIFF)
   • Photoshop Files (*.PSD)
   • JPEG Files (*.JPG; *.JPEG)
   • PNG Files (*.PNG)
4. Enable the Embed Profile check box.

If you do not want to embed the color profile, you need to disable the Embed Profile check box.

Specifying the default CMYK color profile for converting CMYK images to RGB
Because Corel Painter works with RGB colors, all CMYK images that you open or import in the application are converted to an RGB color profile. You can specify the default CMYK profile that Corel Painter uses to convert the CMYK images to RGB. The following file formats are supported for CMYK images:
• RIFF (RIF)
• TIFF (TIF)
• Photoshop (PSD)
• JPEG
• Portable Network Graphic (PNG)

To specify the default CMYK color profile for converting CMYK images to RGB
1. Choose Canvas ➤ Color Management Settings.
2. Choose a color profile from the Default CMYK Conversion Profile list box.

You can also access the Color Management Settings dialog box from the Navigator panel by clicking the Open Navigator Settings button, clicking Color Management, and choosing Color Management Settings.

Previewing and soft-proofing color profiles
After an RGB profile is selected for the document, you can preview the image with the default color profile applied. You can also soft-proof images, which means to preview on-screen what the image will look like when it is printed with a specific printer, or when it is displayed on another type of monitor. You can also soft-proof by using a specific rendering intent. For more information, see “What is a rendering intent?” on page 267. After soft-proofing an image, you can turn off the soft-proofing feature.

To preview a color profile
1. Choose Window ➤ Navigator.
2. Click the Open Navigator Settings button, click Color Management Settings, and choose the name of the color profile that you want to preview.

To soft-proof an image
1. Choose Canvas ➤ Color Proofing Settings.
2. To simulate the output colors that are produced by a specific device, choose a profile from the Simulate Device list box. The list includes all color profiles installed on your computer.
3. Choose a rendering intent from the Rendering Intent list box.
4. Enable the Turn On Color Proofing Mode check box.
Simulating printer output may cause on-screen colors to appear dull because all colors are brought into a CMYK color space, which has a smaller gamut than an RGB color space. After soft proofing an image, you can turn off the soft proofing feature.

The accuracy of the simulation depends on factors such as the quality of your monitor, the color profile of the monitor and the output device, and the ambient lighting in your work area.

To turn off soft-proofing

* Choose Canvas  Color Proofing Mode.

Assigning or removing color profiles

You can change the appearance of a document by assigning a new color profile. A color profile contains the data that the color management system requires to translate colors from one color space to another. The default color profile for Corel Painter is sRGB IEC61966-2-1 noBPC, but you can choose from a list of Standard ICC color profiles.

When you assign a new profile, the color values, or numbers, in the document do not change. When you enable color management and display a document, the colors in the document represent an interpretation of the assigned color profile. For more information, see ”Should I assign or convert color profiles?” on page 267.

You can also remove an assigned color profile from a document. In other words, color management is no longer applied to the document. The color values are retained, however.

To assign or remove a color profile

1. Choose Canvas  Assign Profile.
2. Enable one of the following color profile options:
   - Use Default RGB Profile — applies the default RGB profile to the document
   - Use Profile — applies a color profile to the document but does not convert the original colors. If you enable this option, you must choose a color profile.
   - Do Not Color Manage — retains the color values without associating them with a color profile

If you have color profiles installed on your computer, Corel Painter includes them in the list of available color profiles.

You can also assign a color profile from the Navigator panel by clicking the Open Navigator Settings button , clicking Color Management, and choosing Assign Profile.

Converting color profiles

Corel Painter lets you convert the color profile of a document to another color profile. Converting a color profile differs from assigning a color profile, which involves only the translation of one color profile to another and affects only the display of color. When you convert one color profile to another, the color values in the document are irreversibly changed. For more information, see ”Should I assign or convert color profiles?” on page 267.

Corel Painter also lets you choose the color management engine that is used for converting color profiles. The color management engine, also known as a color management module (CMM), uses the information in the color profiles to translate the color values. The resulting translation of the color values may differ, depending on the color management engine.
In addition, you can flatten images when converting color profiles. Flattening images drops all the layers onto the background canvas.

To convert a color profile

1. Choose Canvas > Convert To Profile.
2. Choose a new color profile from the New Color Profile list box.

You can also

Choose a color engine

Choose a color engine from the Color Engine list box.

Choose a rendering intent

Choose a rendering intent from the Rendering Intent list box.

Flatten all layers in the image

Enable the Flatten Image option.

You can also convert the color profile from the Navigator panel by clicking the Open Navigator Settings button, clicking Color Management, and choosing Convert To Profile.

Working with color profile policies

Corel Painter lets you create color profile policies for opening and placing both RGB and CMYK images. The options that you choose for the Color Profile Policy determine how colors are managed in images that you open and work with in the application.

When creating a color profile policy for opening and placing images, you can specify the following:

- RGB color profile to apply to images
- CMYK color profile for converting images to RGB
- color engine
- rendering intent (depends on image content)

For more information, see “What is a rendering intent?” on page 267.

The color profile policy lets you display warning messages when a document has a mismatched or missing color profile. In the case of a mismatched color profile, you can choose a new color profile. If the document does not have a color profile associated with it, you can apply a new color profile or choose not to use color management with the document.

To create a color profile policy

1. Choose Canvas > Color Management Settings.
2. Choose one of the following options from the RGB Images list box:
   - Use embedded profile — applies the embedded RGB color profile to RGB images that you open or import
   - Use default RGB profile — converts the image by using the default RGB color profile that you specify in the color management settings
3. Choose one of the following options from the Convert CMYK Images list box:
   - Use default CMYK profile — converts to RGB by using the default CMYK color profile that you specify in the color management settings
   - Use embedded profile — converts to RGB by using the embedded CMYK color profile
4. Choose a color engine from the Color Engine list box.
5 From the Rendering Intent list box, choose one of the following options:

- **Perceptual** — is recommended for a variety of images, especially bitmaps and photographs
- **Saturation** — is best for vector graphics (lines, text, and solid-colored objects, such as charts)
- **Relative Colorimetric** — is ideal for producing proofs on inkjet printers
- **Absolute Colorimetric** — preserves the white point and can be used to proof images

If you want to display a warning message when you open a document that has a mismatched color profile, enable the Profile Mismatch check box.

For more complete descriptions of rendering intents, see "What is a rendering intent?" on page 267.

You can also access the Color Management Settings dialog box from the Navigator panel by clicking the Open Navigator Settings button, clicking Color Management, and choosing Color Management Settings.

**Working with presets**

Corel Painter provides color management presets, which are default settings that you can apply to a document. They are useful if you do not feel comfortable changing the settings in the Color Management Settings dialog box. You can also create your own presets, which allows you to retain all of your selections in the Color Management Settings dialog box and reuse them in other documents. If you no longer need a preset, you can delete it.

**To choose a preset**

1. Choose Canvas ➤ Color Management Settings.
2. Choose a preset from the Preset list box.

**To add a preset**

1. Choose Canvas ➤ Color Management Settings.
2. In the Color Management Settings dialog box, use the controls to specify color management settings.
3. Click the Add button next to the Preset list box.
4. Type a name for the preset in the Preset Name box.

**To delete a preset**

1. Choose Canvas ➤ Color Management Settings.
2. Choose a preset from the Preset list box.
3 Click the **Delete** button next to the **Preset** list box.

A warning box appears and asks you if you want to delete the preset.

4 Click **Yes**.

You can also access the **Color Management Settings** dialog box from the **Navigator** panel by clicking the **Open Navigator Settings** button, clicking **Color Management**, and choosing **Color Management Settings**.
Correcting and adjusting colors

Corel Painter includes a variety of effects and tools that let you correct and adjust image colors. For example, you can use the effects to fix a color-casted or washed-out photo. You can also use the effects to creatively alter image colors using techniques such as posterizing or inverting.

This section contains the following topics:

- "Correcting colors using curves" (page 275)
- "Adjusting brightness and contrast" (page 276)
- "Using the curve to correct colors" (page 279)
- "Drawing freehand curves to adjust colors" (page 280)
- "Specifying the curve values to adjust colors" (page 281)
- "Adjusting hue, saturation, and value" (page 282)
- "Adjusting selected colors" (page 284)
- "Equalizing images" (page 287)
- "Matching color and brightness across images" (page 288)
- "Inverting colors" (page 289)
- "Posterizing an image" (page 289)
- "Applying video legal colors" (page 290)
- "Dodging and burning" (page 290)

Correcting colors using curves

Corel Painter lets you correct colors by using curves to adjust the relative amounts of the color components in an image. You can adjust the curves for red, green, blue, or all three color components at once. Modifying a curve individually is useful for correcting an unwanted color cast. The curves describe how the input color values are adjusted to create the output (corrected) color values.
A visual representation of the curve

The horizontal axis represents the input (original color) values. The vertical axis represents the output (corrected) values. Before you adjust a curve, it appears perfectly diagonally (45°), which indicates that all input and output values are equal. Corel Painter maps light values at the top of the graph and darker values at the bottom. When you edit RGB curves, the current color is indicated by a colored point on the curve. For example, if you’re editing the color blue, dragging the curve below the diagonal line subtracts blue from the image and adds its complimentary color yellow. Alternatively, dragging above the line intensifies the color blue.

You can use any of the following curve methods to correct colors:

- Curve
- Freehand
- Advanced

You can use the Color Correction dialog box to correct colors.

Use the Color Correction dialog box to correct colors

You can use a single curve method, or a combination of curve methods, to adjust the image.

You can apply color correction to a selection, a layer, or the entire image.

- If there is no selection, the correction is applied to the entire image.
- To correct the color of only a section of the canvas, select the area by using a selection tool before applying the color correction. For more information about these tools, refer to “Getting started with selections” on page 620.
- To correct the color of a layer, select the layer before applying the color correction. For more information about selecting a layer, refer to “Selecting layers” on page 577.
- To apply color correction to a shape, dynamic layer, text layer, or reference layer, you must first commit the layer to an image layer.

Adjusting brightness and contrast

Corel Painter offers two different methods for adjusting image brightness and contrast. You can adjust brightness and contrast more quickly by using the Brightness/Contrast effect, or more precisely by using the curve in the Color Correction dialog box.
When using the **Brightness/Contrast** effect, you can adjust all image colors at once.

![Before (left) and after (right) applying the Brightness/Contrast effect](image)

When using the curve, you can adjust the contrast or brightness of colors while maintaining the tonal transitions in the original image. You can adjust all colors at once, or adjust R, G, and B individually. As you adjust the **Contrast** or **Brightness** sliders, the endpoints of the curves remain fixed. Because the effect maintains the levels from the original image, there are always 256 distinct levels, regardless of how much you adjust the sliders.

Contrast adjusts the difference between light and dark values. As you increase the contrast, the curve takes on an “S” shape, indicating that light colors are becoming lighter and dark colors darker. If you decrease the contrast, the curve takes on an inverted “S” shape and tones down the contrast of all midtone colors.

![An image before adjusting brightness and contrast by using the curve](image)

![An example of increasing the contrast by using the curve](image)

Brightness moves all values on a curve to a brighter tone or darker tone.
To quickly adjust brightness and contrast

1. To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Tonal Control ➤ Brightness/Contrast.

3. Move the Brightness slider to adjust image brightness.

4. Move the Contrast slider to adjust image contrast.

💡
You can reset the sliders to the default settings by clicking Reset.

You can compare the adjusted image with the original image by enabling and disabling the Preview check box.

To adjust brightness and contrast by using the curve

1. Choose Effects ➤ Tonal Control ➤ Correct Colors.

2. In the Color Correction dialog box, choose Curve from the Method list box.

3. Click one of the following Channel buttons:
   • Red — allows you to adjust only the red curve
   • Green — allows you to adjust only the green curve
   • Blue — allows you to adjust only the blue curve
   • Master — allows you to adjust all color curves at once

4. Move any of the following sliders:
   • Brightness — lets you brighten or darken the selected color(s). This control can correct exposure problems caused by too much light (overexposure) or too little light (underexposure).
   • Contrast — increases or decreases the difference in tone between the dark and light areas of an image
You can clear all corrections so that you can start again by clicking Reset.
You can compare the adjusted image with the original image by enabling and disabling the Preview check box.

Using the curve to correct colors

You can use the Curve method to drag the color curves to reshape them. This method lets you create very specific changes in color values.

You can control the overall effect by using the Effect slider. The slider controls how much of the curve moves in response to dragging. When the slider is all the way to the right, the entire curve moves. As the value is reduced, a smaller portion of the curve moves.

The Curve method lets you perform color and tonal corrections by adjusting either individual color channels (R, G, or B) or the master channel (all channels combined).

To quickly adjust colors, you can use the automatic correction controls.

To correct colors using the curve

1 Choose Effects ➤ Tonal Control ➤ Correct Colors.
2 In the Color Correction dialog box, choose Curve from the Method list box.
3 Click one of the following Channel buttons:
   • Red — allows you to adjust only the red curve
   • Green — allows you to adjust only the green curve
   • Blue — allows you to adjust only the blue curve
• **Master** — allows you to adjust all color curves at once

4 Drag the **Effect** slider to the right to increase the range of the curve that’s affected when you drag it, or drag it to the left to decrease range.

5 Position the crosshair cursor over the diagonal line, and drag the curve. Dragging the curve down increases shadows and dragging it up increases highlights.

**You can also**

Automatically correct the contrast and color in an image Choose **Auto-set** from the **Curve Preset** list box.

Automatically adjust the contrast in an image according to the white point Choose **White Point** from the **Curve Preset** list box.

Automatically adjust the contrast in an image according to the black point Choose **Black Point** from the **Curve Preset** list box.

Clear all corrections Click **Reset**.

**Drawing freehand curves to adjust colors**

You can use the **Freehand** method to adjust colors. This method lets you draw a curve to produce dramatic results. It’s particularly useful for creating posterized or solarized effects.

![](image)

**Freehand method of color correction**

**To adjust colors by using the Freehand method**

1 Choose **Effects** ➔ **Tonal Control** ➔ **Correct Colors**.

2 In the **Color Correction** dialog box, choose **Freehand** from the Method list box.

3 Click one of the following **Channel** buttons:
   • **Red** — allows you to adjust only the red curve
   • **Green** — allows you to adjust only the green curve
   • **Blue** — allows you to adjust only the blue curve
   • **Master** — allows you to adjust all color curves at once

4 Drag the pointer over the graph to draw a new curve. Drawing a curve below the middle line increases shadows and drawing a curve above the middle line increases highlights.
You can clear all corrections so that you can start again by clicking **Reset**.

You can compare the adjusted image with the original image by enabling and disabling the **Preview** check box.

### Specifying the curve values to adjust colors

You can use the **Advanced** method to more accurately adjust colors using the curve. You can adjust the 1/4 Tone, Midtone, and 3/4 Tone ranges by manually dragging the curves of red, green, and blue. You can also adjust color by setting the percentage of red, green, and blue at five specific points in the curve: **Highlight**, **1/4 Tone**, **Midtone**, **3/4 Tone**, and **Shadow**.

![Curve diagram](image)

*Each section of the curve controls the balance between the shadows, midtones, and highlights of an image. Setting values in the upper portion of the grid lightens the image; whereas setting values in the lower portion of the grid darkens the image.*

![Image with modified tones](image)

*Various tone curves were modified to achieve this look.*

You can compare the adjusted image with the original image by enabling and disabling the **Preview** check box.

### To adjust 1/4 tone, midtone, and 3/4 tone by dragging color curves

1. Choose **Effects > Tonal Control > Correct Colors**.
2. In the **Color Correction** dialog box, choose **Advanced** from the list box.
3. Click one of the following **Channel** buttons:
   - **Red** — allows you to adjust only the red curve
   - **Green** — allows you to adjust only the green curve
   - **Blue** — allows you to adjust only the blue curve
4. Drag a node on the diagonal line. Dragging the curve down darkens the image and dragging it up lightens the image.
To adjust colors by specifying curve values

1. Choose Effects ▶ Tonal Control ▶ Correct Colors.
2. In the Color Correction dialog box, choose Advanced from the Method list box.
3. Type percentage values for Red, Green, or Blue in the following columns:
   - **Highlight** — adjusts the image highlights (lower portion of the graph)
   - **1/4 Tone** — adjusts the image contrast
   - **Midtone** — adjusts the image contrast
   - **3/4 Tone** — adjusts the image contrast
   - **Shadow** — adjusts the image shadows (upper portion of the graph)

Typing positive percentages, such as 89%, sets values in the upper portion of the graph, which lightens the image. Typing negative percentages, such as -89%, sets values in the lower portion of the graph and darkens the image. Typing the same percentage value for each color applies the change equally.

Adjusting hue, saturation, and value

The Adjust Colors effect lets you control the hue, saturation, and value of an image in much the same way as you would adjust your television. It also lets you adjust the image colors equally or by using the luminosity of an external source.

When using luminosity to adjust colors, pixels with higher luminance undergo greater color adjustments.

You can choose any of the following adjustment methods:
- **Uniform Color** — adjusts all pixels equally
- **Paper** — uses the selected paper grain to control the color adjustment
- **Image Luminance** — uses the luminance of the image as the model for color adjustment. Areas of greater luminance are adjusted more.
- **Original Luminance** — uses the luminance of the clone source as the model for color adjustment. If you have not set up a clone source, the current pattern is used.
- **[Alpha channel]** or **[Layer mask]** — sets the selected alpha channel or layer mask as the model for controlling color adjustment. For example, a black-to-white gradation in the channel or mask lets you adjust the color progressively across the image. In black areas of the channel or mask, colors are not changed. In white areas of the channel or mask, the adjustment applies fully. Transitional areas receive proportional color adjustments.

*Use the Adjust Color dialog box to change the hue, saturation, and value of an image.*
To adjust colors equally
1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
2 Choose Effects ▶ Tonal Control ▶ Adjust Colors.
3 Choose Uniform Color from the Using list box.
4 Adjust any of the Adjust Colors controls. For information, see “Adjust Colors controls” on page 284.

To adjust colors by using paper luminance
1 Do one of the following:
   • On the Brush tool property bar, click the Grain flyout button.
   • Choose Window ▶ Media Panels ▶ Papers to open the Papers panel.
2 Click a paper texture swatch in the Paper Textures area.
3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
4 Choose Effects ▶ Tonal Control ▶ Adjust Colors.
5 Choose Paper from the Using list box.
6 Adjust any of the Adjust Colors controls. For information, see “Adjust Colors controls” on page 284.

To adjust colors by using image luminance
1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
2 Choose Effects ▶ Tonal Control ▶ Adjust Colors.
3 Choose Image Luminance from the Using list box.
4 Adjust any of the Adjust Colors controls. For information, see “Adjust Colors controls” on page 284.

To adjust colors by using clone, texture, or pattern luminance
1 Perform a task from the following table.
2 In the Clone Source panel (Window ▶ Clone Source), perform a task from the following table.

To use                  Do the following

A clone source
Choose Embedded Image from the Source list box.
In the Embed Source Image dialog box, do one of the following:
• To browse for a file, enable the Browse option.
• To clone a currently open document, enable the Current Document option, and choose a document from the list box.
• To embed the active texture, enable the Current Texture option.
To use

Do the following

Click OK.

A texture

Choose Texture from the Source list box, and click a texture swatch in the Painter Textures area.

A pattern

Choose Current Pattern from the Source list box, and click a pattern swatch in the Painter Patterns area.

3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

4 Choose Effects ▶ Tonal Control ▶ Adjust Colors.

5 Choose Original Luminance from the Using list box.

6 Adjust any of the Adjust Colors controls. For information, see “Adjust Colors controls” on page 284.

Adjust Colors controls

• Hue Shift — adjusts the hue of pixels
• Saturation — adjusts the amount of pure hue in the color
• Value — adjusts color brightness. Moving the slider to the left darkens colors.
• Reset — resets the sliders to their default settings

Adjusting selected colors

The Adjust Selected Colors effect is similar to the Adjust Colors effect, but it works only on a specified range of colors within an image. You choose a color in an image and adjust colors within a range of that color. You could, for example, change yellow peppers to red peppers.

You can adjust colors that are exactly the same as the color you select, or you can choose colors within a range, based on proximity (on the color wheel or the color space) to the selected color.

The Range sliders determine the extent of the HSV color space around the selected center color.

By combining these settings, you can set up a very specific range of colors to adjust. For example, you can limit changes to a precise shade of red.
The **Feather** sliders affect the softness at the edge of the selected colors. These sliders can help you create smoother transitions between the replaced color and the original.

![A replaced color with and without feathering](image)

You can choose from any of the following adjustment methods:

- **Uniform Color** — adjusts all pixels equally
- **Paper** — uses the selected paper grain to control the color adjustment
- **Image Luminance** — uses the luminance of the image as the model for color adjustment. Areas of greater luminance are adjusted more.
- **Original Luminance** — uses the luminance of the clone source as the model for color adjustment. If you have not set up a clone source, the current pattern is used.

**To adjust a selected color**

1. Choose **Effects ➤ Tonal Control ➤ Adjust Selected Colors**.
   - The **Adjust Selected Colors** dialog box appears.
2. Move the cursor over the image in the document window (the cursor becomes a dropper), and click the color you want to adjust.
   - The **Color** panel displays the selected color as the main color.
3. Choose **Uniform Color** from the **Using** list box.
4. Adjust any of the **Adjust Selected Colors** controls. For information, see “Adjust Selected Colors controls” on page 286.

**To adjust selected colors by using paper luminance**

1. Do one of the following:
   - On the **Brush** tool property bar, click the **Grain** flyout button.
   - Choose **Window ➤ Media Panels ➤ Papers** to open the **Papers** panel.
2. Click a paper texture swatch in the **Paper Textures** area.
3. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.
4. Choose **Effects ➤ Tonal Control ➤ Adjust Selected Colors**.
5. Choose **Paper** from the **Using** list box.
6. Adjust any of the **Adjust Selected Colors** controls. For information, see “Adjust Selected Colors controls” on page 286.
To adjust colors by using image luminance

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects ➤ Tonal Control ➤ Adjust Selected Colors.
3. Choose Image Luminance from the Using list box.
4. Adjust any of the Adjust Selected Colors controls. For information, see “Adjust Selected Colors controls” on page 286.

To adjust colors by using clone, texture, or pattern luminance

1. In the Clone Source panel (Window ➤ Clone Source), perform a task from the following table.

<table>
<thead>
<tr>
<th>To use</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A clone source</td>
<td>Choose Embedded Image from the Source list box.</td>
</tr>
<tr>
<td></td>
<td>In the Embed Source Image dialog box, do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To browse for a file, enable the Browse option.</td>
</tr>
<tr>
<td></td>
<td>• To clone a currently open document, enable the Current Document option, and choose a document from the list box.</td>
</tr>
<tr>
<td></td>
<td>• To embed the active texture, enable the Current Texture option.</td>
</tr>
<tr>
<td></td>
<td>Click OK.</td>
</tr>
<tr>
<td>A texture</td>
<td>Choose Texture from the Source list box, and click a texture swatch in the Painter Textures area.</td>
</tr>
<tr>
<td>A pattern</td>
<td>Choose Current Pattern from the Source list box, and click a pattern swatch in the Painter Patterns area.</td>
</tr>
</tbody>
</table>

2. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
3. Choose Effects ➤ Tonal Control ➤ Adjust Selected Colors.
4. Choose Paper from the Using list box.
5. Adjust any of the Adjust Selected Colors controls. For information, see “Adjust Selected Colors controls” on page 286.

Adjust Selected Colors controls

The following controls in the Select area let you refine the color selection.

**Hue controls**
- **Range** — controls the number of hues adjusted. Only hues within the specified percentage of hues on the color wheel are adjusted.
- **Feather** — controls the softness at the edge of the selected hues

**Saturation controls**
- **Range** — controls the range of saturation adjusted. Only saturations within this range are adjusted.
- **Feather** — controls the softness at the edge of the range of saturated colors
Value controls

- **Range** — controls the range of values adjusted
- **Feather** — controls the softness at the edge of the selected values

Moving the **Range** sliders to the right increases the amount of color space affected and creates smoother transitions between the replaced color and the original.

The following controls in the **Replace** area let you refine the adjusted colors.

- **Hue** — adjusts the colors of the pixels by changing their hue. Moving the slider to the right increases the hue.
- **Saturation** — adjusts the amount of pure hue in the color. Moving the slider all the way to the left creates a grayscale image.
- **Value** — adjusts color brightness. Moving the slider to the left darkens colors.

The following controls can help you preview and reset adjustments.

- **Preview** — enable this check box to preview the adjustments in the document window
- **Reset** — resets the sliders to their default settings

**Equalizing images**

Corel Painter includes various options for equalizing images. Equalizing involves increasing the contrast by resetting the darkest and lightest points and then evenly distributing the values across those two points.

You can produce an equalizing effect by automatically or manually adjusting the black and white points in an image.

You can also equalize an image by using the **Equalize** effect. This effect allows you to adjust contrast, adjust black and white points, and distribute the brightness levels throughout the entire range of available levels. In addition, you can equalize an image by creating a histogram showing the number of pixels for each brightness level value and then adjusting those values. The **Equalize** effect also allows gamma adjustment, which lightens or darkens an image without changing highlights or shadows.

![Before (left) and after (right) applying the Equalize effect](image)

**To automatically set black and white points**

1. Choose **Effects ➤ Tonal Control ➤ Correct Colors**.
2. In the **Color Correction** dialog box, choose **Curve** from the **Method** list box.
3. From the **Curve Preset** list box, choose **Auto Set**.

**To manually set black or white points**

1. Choose the **Dropper** tool from the toolbox.
2. In the document window, click the color you want to assign as the darkest or lightest point.
3. Choose **Effects ➤ Tonal Control ➤ Correct Colors**.
4. In the **Color Correction** dialog box, choose **Curve** from the list box.
5. From the **Curve Preset** list box, choose one of the following:
• **Black Point** — assigns all colors equal to or darker than the current main color to black
• **White Point** — assigns all colors equal to or lighter than the current main color to white

To equalize colors
1. To apply the effect to:
   • The canvas — Click the **Canvas** in the **Layers** panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the **Layers** panel.
2. From the menu bar, choose **Effects**  **Tonal Control**  **Equalize**.
   Corel Painter automatically adjusts the image or selection so that the lightest color is white and the darkest color is black.
3. In the **Equalize** dialog box, adjust contrast by dragging the black and white markers under the histogram, or type values in the **Black** box and **White** box.
   Any values in the image located to the right of the white marker become white; any values to the left of the black marker become black.
4. Move the **Gamma** slider.
   Moving the slider to the right darkens the image; moving the slider to the left lightens the image.
   Changing the gamma adjusts only the midtones of an image and leaves the black and white areas untouched.
5. Click **OK** to apply changes.
   A preview of the changes is applied to the original image, but the changes are not final until you click **OK**. If you want to revert to the original image, click **Cancel**.

Matching color and brightness across images
The **Match Palette** effect lets you apply the color and brightness of a source image to a destination image. For example, you can match the colors in a photo to the colors in a favorite painting. You can then clone and paint your photo in the same style as your favorite painting.
You can also use the **Match Palette** effect to ensure that the color and brightness in a group of photos is consistent.

To match colors across images
1. Open both the source image and the destination image.
2. Select the destination image.
3. Choose **Effects**  **Tonal Control**  **Match Palette**.
4. From the **Source** list box, select the source image.
   The filenames for all open images appear in the list box.
5. Adjust any of the following sliders:
   • **Color** — lets you determine how the colors from the source image blend with the colors in the destination image. At higher settings, more source color is applied.
• **Variance (Color)** — lets you adjust the range of the source colors. Higher settings increase the number of shades used from the source image.

• **Brightness** — lets you determine how the luminance from the source image blends with the luminance in the destination image. Higher settings pull more highlights and shadows from the source image into the destination image.

• **Variance (Brightness)** — lets you adjust the range of highlights and shadows. Higher settings increase the contrast between the highlights and shadows.

6 Move the **Amount** slider to specify the overall intensity of the other settings.

Start at **100%**, and decrease the amount until you are satisfied with the results.

### Inverting colors

The **Negative** effect inverts all the colors in an image, or in the selected layer.

![Positive and negative versions of an image](image)

**Positive (left) and negative (right) versions of an image**

**To invert colors**

1. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects** ➤ **Tonal Control** ➤ **Negative**.

### Posterizing an image

Corel Painter offers two different options for posterizing images. You can use the **Posterize** effect to reduce the number of color levels contained in an image.

You can also posterize an image by specifying a color set. This effect lets you replace image colors with those of a specified colors set. This is useful for multimedia work, as well as applications such as silkscreening. You can use this effect to reduce the number of colors in an image.

**To posterize an image**

1. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects** ➤ **Tonal Control** ➤ **Posterize**.

3. In the **Posterize** dialog box, specify a number of levels.

   The fewer levels you specify, the more dramatic the effect.
To posterize an image combined with a paper grain, refer to “Applying the Apply Screen effect” on page 686.

To posterize to two levels and also adjust the brightness, refer to “Equalizing images” on page 287.

**To posterize an image by using a color set**

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Window  ▶️ Color Panels ▶️ Color Sets.

3. Click the Color set libraries options button , choose Color Set Libraries, and choose a color set from the list.


   The image is replaced with the colors in the current color set.

**Applying video legal colors**

You can apply an effect that adjusts the colors in an image so they are compatible with video. Colors that aren’t possible in video are converted to video legal colors.

Only bright yellows and cyans are not video legal. Corel Painter supports both the National Television System Committee (NTSC) for video systems in the U.S. and Phase Alternation by Line (PAL) for video systems in Europe.

**To apply video legal colors**

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ▶️ Tonal Control ▶️ Video Legal Colors.

3. In the Video Legal Colors dialog box, choose NTSC or PAL from the System list box.

**Dodging and burning**

The Dodge and Burn tools let you adjust the highlights, midtones, and shadows in an image. The Dodge tool lightens the tone; the Burn tool darkens it. You can dodge and burn anywhere in a photo, affecting an area as large or as small as you like.

**To lighten the tone**

1. Choose the Dodge tool  from the toolbox.

2. On the property bar, move the Size slider , or type a value in the Size box.

3. Move the Opacity slider , or type a value in the Opacity box.

4. Drag the brush in the image to apply the effect.
The Dodge tool was used to lighten the girl’s eye.

To darken the tone

1. Choose the Burn tool  from the toolbox.
   If the Burn tool is not displayed in the toolbox, hold down the Dodge tool  to open the tool flyout.

2. On the property bar, move the Size slider , or type a value in the Size box.

3. Move the Opacity slider , or type a value in the Opacity box.

4. Drag the brush in the image to apply the effect.

The Burn tool was used to reduce the strong highlights on the faces.
Libraries

A library is a storage place for a collection of tools or media. In Corel Painter, default libraries are available for the following resources: brushes, papers, color sets, gradients, looks, nozzles, textures, patterns, selections, scripts, images, weaves, and flow maps. The default libraries contain a vast array of resources that are ready for you to use. In addition, you can create your own libraries to better organize resources, or to store customized resources.

This section contains the following topics:
- “Importing and exporting libraries” (page 293)
- “Creating and removing libraries” (page 294)
- “Modifying the display of media panels” (page 295)
- “Moving, renaming, and deleting library resources” (page 296)
- “Restoring default libraries” (page 297)

Importing and exporting libraries

Corel Painter lets you import and export libraries. For example, you can open a library that was created in a previous version of Corel Painter. You can also open multiple libraries at once, except in the Brush library panel. For more information, see “Creating and deleting brush libraries” on page 311.

All of the Corel Painter tools and media that are included in the application are stored in default libraries. For example, the default papers that are included in Corel Painter are contained in the Paper Textures libraries. When you first open a library in a media panel, the content of the default library for that given tool or media is displayed in the panel.

To import a library

1. Depending on the media panel, do one of the following:
   - Click the Manage Libraries flyout button and then click Import [Resource type] Library.
     For example, if you want to open a paper textures library, click the Manage Libraries flyout button in the Papers panel, and then click Import Paper Library.
   - Click the Import [Resource type] Library button.
     For example, if you want to open a Brush Looks library, click the Import Look Library button in the Looks panel.
2. Choose the drive and folder where the library is stored.
Click Open.

The imported library displays at the bottom of the panel window. Depending on the size of the panel, you may need to scroll to see the imported library.

To import a library created in a previous version of Corel Painter

1  Depending on the media panel, do one of the following:
   • Click the Manage Libraries flyout button \[\text{\button}{\text{Manage Libraries}}\] and then click Import Legacy [Resource type] Library.
   • Click the media panel’s options button \[\text{\button}{\text{Options}}\], and choose Import Legacy [Resource type] Library.

2  Choose the drive and folder where the library is stored.

3  Click Open.

The imported library displays at the bottom of the panel window.

To export a library

1  Depending on the media panel, do one of the following:
   • Click the Manage Libraries flyout button \[\text{\button}{\text{Manage Libraries}}\] and then click Export [Resource type] Library.
     For example, if you want to export a gradient library, click the Manage Libraries flyout button \[\text{\button}{\text{Manage Libraries}}\] in the Gradients panel, and then click Export Gradient Library.
   • Click the Export [Resource type] Library button \[\text{\button}{\text{Export}}\].
     For example, if you want to export a nozzle library, click the Export Nozzle Library button \[\text{\button}{\text{Export Nozzle Library}}\] in the Nozzles panel.

2  In the Choose Library dialog box, choose the library that you want to export from the Library list box.

3  Choose the drive and folder where you want to store the library.

4  Click Save.

Creating and removing libraries

Libraries allow you to store and organize tools and media to make it easier for you to locate and access them. When you create a new resource, such as a gradient, it is automatically saved to the current library. However, you can create a custom library and move the resource to that library. In addition, you can copy any of the default resources to a custom library. If you no longer need a library, you can remove it.

The method for creating a library is the same for most tools and media, except for brush libraries. For more information, see “Creating and deleting brush libraries” on page 311.

To create a library

1  Depending on the media panel, do one of the following:
   • Click the Manage Libraries flyout button \[\text{\button}{\text{Manage Libraries}}\] and then click New [Resource type] Library.
     For example, if you want to create a flow map library, click the Manage Libraries flyout button \[\text{\button}{\text{Manage Libraries}}\] in the Flow Maps panel, and then click New Flow Maps Library.
   • Click the New [Resource type] Library button \[\text{\button}{\text{New}}\].
     For example, if you want to create a new selection portfolio, click the New Selection Portfolio button \[\text{\button}{\text{New Selection Portfolio}}\] in the Selections panel.
In the New Library dialog box, type a name in the Save As box. A header bar for the new library appears at the bottom of the media panel and its title appears in the list of available libraries. The new library also contains one swatch by default.

When you save an item, Corel Painter adds it to the currently selected library. If you want to store the item in a different library, make sure you select the correct library before saving the item. You can move items between libraries later, but switching libraries before saving the resource will spare you that extra step.

To add an existing resource to a library
• In a media panel, drag an item from one library to the library where you want to add the resource.

When you create a new resource, such as a brush variant, paper, or weave, it is automatically saved to the currently selected library. For more information about creating resources, please refer to the Help chapter that pertains to the resource.

Over time, with additions and deletions, library file sizes are compounded. In some cases, you may lose items if you restore a default library. For best results, save new resources to new libraries, and limit the number of resources in each library.

To remove a library
1 Click the media panel’s options button , choose Remove [Resource type] Library.
2 Choose the library that you want to remove from the Library list box.

The Remove [Resource type] Library command is available only in the Textures, Papers, Flow Maps, Patterns, and Gradients panels.

Modifying the display of media panels
You can modify the appearance of media panels by changing the way they are organized and displayed. You can show or hide some user interface elements if you don’t need them. You can resize a media panel to control the space that it takes in the application window. You can also change the display size of the resource icons. If you do not need to use some of the resource swatches, you can hide them. In addition, if you create a new resource, you can create a custom icon for the resource.

To modify the display of a media panel
1 Open a media panel.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize the media panel</td>
<td>Point to the edge of the panel. When the cursor changes to a double-sided arrow, drag the edge of the panel to resize it.</td>
</tr>
<tr>
<td>Show or hide the [resource type] preview</td>
<td>Click the media panel’s options button , and choose Show Preview.</td>
</tr>
</tbody>
</table>
Show or hide sliders

Click the media panel’s options button 
and choose **Show Sliders**.

Resize the library swatches

Depending on the media panel, do one of the following:

- Click the Manage Libraries flyout button 
  and click **[Resource type] Library View**.
- Click the media panel’s options button 
  and choose **[Resource type] Library View**.

Choose one of the following options:

- Small
- Medium
- Large

Display the library swatches as a list

Depending on the media panel, do one of the following:

- Click the Manage Libraries flyout button 
  and click **[Resource type] Library View**.
- Click the media panel’s options button 
  and choose **[Resource type] Library View**.

Choose **List**.

Hide a library swatch

Right-click (Windows) or Control-click (macOS) a library resource swatch, and choose **Hide [Resource type]**.

Show all swatches that were previously hidden

Depending on the media panel, do one of the following:

- Click the Manage Libraries flyout button 

- Click the media panel’s options button 
  and choose **[Resource type] Library View**.

Choose **Show All Hidden Items**.

Customize a swatch icon

Right-click (Windows) or Control-click (macOS) a resource swatch, and choose **Set Custom Icon**. Choose the drive and folder where the image is stored. Click the image file and click **Open**.

Moving, renaming, and deleting library resources

You can move a library resource to a new position within a library, or drag it to a different library. You can also rename resources, such as renaming a paper or gradient, to give them more descriptive names. You can also delete an item from a library, including a default library. You can also restore the default library to the factory settings. For information, see “Restoring default libraries” on page 297.

To move a library resource

- In a media panel, do one of the following:
  - Drag a resource swatch to another position within the library.
  - Drag a resource swatch to another library.
If you’re dragging a swatch to a different library, you cannot position the swatch at the end of the library. You must place the swatch in between, or before, an existing swatch.

To rename a library resource
1. In a media panel, right-click (Windows) or Control-click (macOS) the resource that you want to rename, and choose Rename [Resource]. (e.g. Rename Paper)
2. In the Rename dialog box, type the new name in the Rename [Resource] text box.

To delete a library resource
1. In a media panel, click the resource that you want to delete.
2. Click the Delete [Resource] button.

⚠️ Do not delete default resource files or folders.

Restoring default libraries
You can restore a default library at any time. When you restore the default libraries, all custom resources are removed for all libraries.

To restore a default library
- Depending on the media panel, do one of the following:
  - Click the Manage Libraries flyout button, and then click Restore Default [Resource] Library.
  - Click the panel’s options button, and choose Restore Default [Resource] Library.
Selecting, managing, and creating brushes

Corel Painter offers an impressive array of realistic and responsive brushes that you can use to apply media to the canvas. For example, you can choose a brush with realistic bristles that apply oil, watercolor, or acrylic paint. You can also choose a dry media brush, such as chalk or charcoal.

This section contains the following topics:
- “Understanding brushes” (page 299)
- “Searching and selecting brushes” (page 300)
- “Exploring brush categories” (page 317)
- “Exploring brush categories in the Natural Media Brushes library” (page 365)
- “Acquiring brushes” (page 301)
- “Setting basic brush attributes” (page 303)
- “Working with brushes using the property bars” (page 306)
- “Renaming brush categories and variants” (page 309)
- “Saving and deleting brush variants” (page 309)
- “Restoring default brush variants” (page 310)
- “Creating and deleting brush categories” (page 311)
- “Creating and deleting brush libraries” (page 311)
- “Importing and exporting brush libraries, categories, and variants” (page 312)
- “Importing Photoshop brush images” (page 314)
- “Saving a brush look” (page 315)
- “Creating brush dabs” (page 315)

Understanding brushes

Corel Painter offers users a wide range of preset brushes that are designed with the real media in mind, so you can predict how a brush will behave.

In an art store, if the brushes in one aisle don’t produce the results you want, you can try a different aisle. Similarly, with Corel Painter, individual brushes, known as brush variants, are stored in the Brush library panel in different brush categories. You can use the brush variants as they are, or you can adjust them to suit your purposes. Many artists use brush variants with only minor adjustments — to size, opacity, or grain (how brushstrokes interact with paper texture).
To modify a brush variant extensively, or to create a new brush variant, you can adjust the brush controls. For more information, see “Adjusting brushes with brush controls” on page 371 or “Saving and deleting brush variants” on page 309.

Most Corel Painter brushes apply media, such as a color, gradient, or pattern, to an image. However, some brushes make changes to media already in the image. For example, the **Just Add Water** brush variant (in the **Blenders** brush category) smudges and dilutes existing colors in the image with smooth, anti-aliased brushstrokes. Using one of these brushes on a blank area of the canvas has no effect.

Corel Painter includes a batch of Natural-Media brushes that use a media application method called “rendered dab types” to produce wonderfully realistic, continuous, smooth-edged brushstrokes. They are fast and more consistent because the brushstrokes appear as you draw, and are not created by applying dabs of color. In fact, you can’t draw fast enough to leave dabs or dots of color in a brushstroke. These brushes allow for rich features that are not possible with the application of dab-based media. You can take better advantage of tilt and angle, and you can paint with patterns or gradients. For more information, see “General controls: Dab types” on page 378.

### Searching and selecting brushes

In Corel Painter, you can find brush variants by searching or browsing the currently selected brush library.

You can quickly search the content of the currently selected brush library to find brushes that match a specific description. You can perform a search by entering one attribute, or a combination of brush attributes. For example, typing the search terms “pencil real” generates a list of all “Real Pencil” brush variants.

You can also look for brush variants by browsing the brush categories in the Brush library panel. The Brush Selector displays a preview the variant’s brush dab and brush stroke. For more information about the Brush Selector, see “Displaying and customizing the Brush Selector” on page 71.

![Brush library panel](image)

In full view, the Brush library panel lets you choose a brush category (left) and a brush variant (right).

In full view, the Brush library panel displays the most recently used brushes at the top of the panel. For even greater convenience, you can access the last used brush from a button on the Brush Selector bar.

The default Corel Painter brush variants are displayed in the Brush library panel until you open or import a different brush library. In addition, the Brush library panel displays only one brush library at a time. For more information, see “Importing and exporting brush libraries, categories, and variants” on page 312.
If you’re looking for a brush from a previous version of Corel Painter, you can reload the old version’s brush library. For more information, see “Importing and exporting brush libraries, categories, and variants” on page 312.

For information on brush categories included in the Painter brush libraries as well as sample brushstrokes, see “Exploring brush categories” on page 317.

For information on brush categories included in the Natural Media Brushes library, see “Exploring brush categories in the Natural Media Brushes library” on page 365.

To select a brush category and variant

1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click a brush category, and click a brush variant.

To select a brush category when using the Brush Selector in compact view (Window ➤ Brush Selector ➤ Panel (Compact)), click the Category flyout button, and click a category.

To select the previous brush variant

- On the Brush Selector bar, click the Last Used Brush button.

You can also select the last brush variant that you used by clicking Brushes ➤ Select Previous Variant.

You can assign a keyboard shortcut to this command. For more information, see “To assign commands to keys” on page 124.

To search for brush variants

1. Click Window ➤ Search.
2. In the Search bar, type one attribute or a combination of brush attributes in the Search text box.
3. Choose a brush variant from the list.

The Search bar is displayed by default only in the Classic layout and is located to the right of the property bar, in the upper-right corner of the document window. To display the Search bar in all other layouts, click Window ➤ Search.

You can search for new or updated brushes in Corel Painter 2020 by typing 2020 in the Search box.

You can use GPU, AVX2, and Multi-core (or “Multicore”) as search terms to find brushes that leverage those technologies.

Acquiring brushes

You can expand your collection of brushes by purchasing creative brush packs from within Corel Painter.
New brush packs appear in the Brush Selector. Choose from a selection of creative brush packs for enhancing photos, designs, and paintings to enrich your projects.

The selection is updated with new offerings as they become available. After you purchase a brush pack, it is installed and appears as the active brush in the Brush Selector. For more information about the Brush Selector, see “Displaying and customizing the Brush Selector” on page 71.

If you reinstall Corel Painter or install it on another computer, you can restore your purchases. This will help you download the items that you have already purchased and reinstall them.

If you want to import brushes that you have used in another version of Corel Painter, see “Importing and exporting brush libraries, categories, and variants” on page 312.

To acquire a brush pack

1. Do one of the following:
   - Click the Brush Selector on the Brush Selector bar.
   - Click Window  Brush Selector  Panel (Full View).

2. In the Brush Selector, click the toggle button to display the list of brush pack promotions.

   To sort brush packs by category, choose a category from the list box at the top of the promotions list.

3. Click a brush pack.
   A dialog box opens with the brush pack selected.

4. Click Buy now and follow the onscreen instructions to purchase the item.
   The brush pack that you purchased is installed and appears as the active brush in the Brush Selector.

   The brush packs that you purchase are added to the default Painter 2020 Brushes library. If you are currently using another brush library, for example, Painter 2016 Brushes, you have to switch to the default Painter 2020 Brushes library to access the new brush packs.
To acquire a brush pack when using the Brush Selector in compact view (Brush Selector ▶ Panel (Compact)), click the Brush Pack Promotions bar to display the list of brush pack promotions.

**To restore your purchases**

1. Click Help ▶ Restore Purchases
2. In the dialog box that appears, type the email address that was used to make the purchases, and click Continue.
   A list of your purchases is displayed.
   If prompted for an administrator permission, enter your system password to continue with the installation.
3. Click Close.
   The brush packs that you have purchased are installed and added to the default Painter 2020 Brushes library.

This procedure can help you restore only brush packs that you purchased from within Corel Painter.

**Setting basic brush attributes**

To quickly get started in Corel Painter, you specify basic brush attributes, such as brush size, opacity, and grain, on the property bar. Size determines the dimension of a single brush dab. You can also use the ghost brush to determine if a change in size is required. For more information, see “Setting up the drawing cursor” on page 151.

---

The ghost brush, the circle displayed to the right of the brushstroke, appears when a brush is selected and positioned over the canvas. It mirrors the size and shape of the brush dab.

Opacity controls the degree to which a stroke covers or builds up on the underlying pixels.

80% opacity (top) and 20% opacity (bottom)

Grain controls the interaction of color with the paper texture.

You can also set brush attributes, such as angle and squeeze, dynamically onscreen. A circle appears onscreen in the document window that lets you size and shape the brush within the context of the image.
The circle provides a visual representation of the brush size onscreen.

You can also access additional brush controls to further customize brushes. For example, you can set a minimum brushstroke size to control the tapering and widening of brushstrokes as stylus pressure or direction is varied. For more information, see “Adjusting brushes with brush controls” on page 371.

**To set brush size**

1. In the toolbox, click the **Brush** tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click a brush category, and click a brush variant.
4. On the property bar, move the **Size** slider, or type a value in the **Size** box.

   If you want to scale the brushstroke feature proportionally with the brush size, click the **Scale Feature with Brush Size** button on the property bar, which is available for some brushes.

   Corel Painter may need to rebuild the brush after you resize it; therefore, you can expect a short delay.

   You can also increase brush size incrementally by pressing the right square bracket ( ] ) key or decrease brush size by pressing the left square bracket ( [ ) key.

   You can specify the default brush size increment value in pixels by choosing **Corel Painter 2020 ➤ Preferences ➤ General** (macOS) or **Edit ➤ Preferences ➤ General** (Windows) and typing a pixel value in the **Brush size increment** box.

   You can also disable the scaling option in all areas by choosing **Corel Painter 2020 ➤ Preferences ➤ General** (macOS) or **Edit ➤ Preferences ➤ General** (Windows) and enabling the **Disable feature scaling when resizing brush**.

**To set opacity**

1. In the toolbox, click the **Brush** tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click a brush category, and click a brush variant.
4. On the property bar, move the **Opacity** slider, or type a percentage in the **Opacity** box.

   When the **Opacity** setting is low, the applied color is thin, so you can see through to the underlying colors. When the setting is high, the applied color covers underlying pixels more completely.
Some methods and dab types do not allow you to adjust opacity.

When the Brush tool is active, you can set opacity by pressing a number key. Each number key is mapped to a fixed percentage. For example, 1 equals 10% opacity, 5 equals 50% opacity, and 0 equals 100% opacity.

To set grain
1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click a brush category, and click a brush variant.
4. On the property bar, move the Grain slider, or type a percentage in the Grain box.

Move the slider to the left to reduce penetration and reveal more texture. Move it to the right to increase penetration and reveal less grain.

For liquid media brushes, Grain controls the amount of “pull.” For other brushes, such as airbrushes, the Grain slider is not available.

To set brush attributes onscreen
• Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the brush size</td>
<td>Hold down Command + Option (macOS) or Ctrl + Alt (Windows), and drag the crosshair cursor to display the Radius circle in the document window. Keep dragging until the circle is set to the size that you want, and then release the stylus or mouse button.</td>
</tr>
<tr>
<td>Change the brush opacity</td>
<td>Hold down Command + Option (macOS) or Ctrl + Alt (Windows), and click the crosshair cursor to display the Radius circle in the document window. While pressing the stylus, or holding down the left mouse button, release the keys, and press Command (macOS) or Ctrl (Windows) once. Drag the Opacity circle in the image window until the circle is set to the opacity that you want, and then release the stylus or mouse button.</td>
</tr>
<tr>
<td>Change the brush squeeze setting</td>
<td>Hold down Command + Option (macOS) or Ctrl + Alt (Windows), and click the crosshair cursor to display the Radius circle in the document window. While pressing the stylus, or holding down the left mouse button, release the keys, and press Command (macOS) or Ctrl (Windows) twice. Drag the Squeeze circle in the document window until the circle is set to the brush squeeze that you want, and then release the stylus or mouse button.</td>
</tr>
</tbody>
</table>
To

Change the brush angle

Do the following

Hold down **Command + Option** (macOS) or **Ctrl + Alt** (Windows), and click the crosshair cursor to display the Radius circle in the document window. While pressing the stylus, or holding down the left mouse button, release the keys, and press **Command** (macOS) or **Ctrl** (Windows) three times. Drag the Angle circle in the document window until the circle is set to the angle that you want, and then release the stylus or mouse button.

You can also revert to an onscreen brush sizing control that has the look and feel of the brush sizing control in earlier versions of Corel Painter by choosing **Corel Painter 2020 ▶ Preferences ▶ General** (macOS) or **Edit ▶ Preferences ▶ General** (Windows) and enabling the **Simplified brush resizing control (Legacy-style)** check box.

**Working with brushes using the property bars**

When the Brush tool is selected, you can access and change brush options and settings on the property bar. The property bar displays one set of options and settings, such as brush size, opacity, and stroke attributes, that are available for all brush categories, and another related to the selected brush category. You can use the property bar to restore the default settings of a brush. Depending on the selected brush variant, the property bar may also let you choose a paper texture, dab type, and blending options. The flyouts on the property bar simplify the process of finding controls and media relevant for a brush and let you quickly access advanced controls for a brush instead of opening different brush control panels. For example, if you are working with a Dynamic Speckles brush variant, you can quickly access the relevant options by clicking the **Show or hide the Dynamic Speckle** flyout button.

For more information about modifying the individual controls, see “Selecting, managing, and creating brushes” on page 299. For more information about working with property bars, see “Displaying the property bars” on page 68.

**To choose a stroke type on the property bar**

1. In the toolbox, click the **Brush tool**.

2. On the property bar (**Window ▶ Property Bar**), click one of the following buttons:
   - **Freehand strokes** button — to draw freehand lines
   - **Straight line strokes** button — to draw straight lines

You can also

**Align a brushstroke to a path or shape**

Click the **Stroke Options** flyout button, and click **Align to Path**.

**Align brushstrokes to perspective guides**

Click the **Stroke Options** flyout button, and click **Perspective Guides**.
To set brush size options on the property bar

1. In the toolbox, click the Brush tool.

2. On the property bar (Window \ Property Bar), type a value in the Size box, or open the Size flyout, and move the Size slider.

You can also

Link the size settings to a specific stylus or mouse movement

Set the percentage of variability that you want the expression to apply to brush size

Link brush size to audio

Reverse the effect of an Expression setting on brush size

You can restore a default brush variant by clicking the Reset Tool button.

To set brush opacity options on the property bar

1. In the toolbox, click the Brush tool.

2. On the property bar (Window \ Property Bar), type a percentage in the Opacity box, or open the Opacity flyout, and move the Opacity slider.

You can also

Link the opacity settings to a specific stylus or mouse movement

Set the percentage of variability that you want the expression to apply to brush opacity

Link brush opacity to audio
You can also

Reverse the effect of an Expression setting on brush opacity.

Open the Opacity flyout button, and click the Invert Opacity Expression button.

You can restore a default brush variant by clicking the Reset Tool button.

To apply a paper texture using the property bar

1. In the toolbox, click the Brush tool.
2. On the property bar (Window ➤ Property Bar), click the Paper selector flyout button.
3. In the Paper Textures area, click a paper texture swatch.

You can also

Set grain.

Move the Grain slider, or type a percentage in the Grain box.

Move the slider to the left to reduce penetration and reveal more texture. Move it to the right to increase penetration and reveal less grain.

These options are not available for all brush variants.

For more information about paper textures, see “Applying paper texture” on page 165.

You can restore a default brush variant by clicking the Reset Tool button.

To choose a dab profile using the property bar

1. In the toolbox, click the Brush tool.
2. On the property bar, click the Dab Options flyout button, and choose an option.

To display relevant brush control panels using the property bar

1. In the toolbox, click the Brush tool.
2. On the property bar, click the Advanced Brush Controls button.
Renaming brush categories and variants

You can rename brush categories and variants.

To rename brush categories and variants
1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rename a brush category</td>
<td>Right-click a brush category, choose Rename Category, and type a name for the category.</td>
</tr>
<tr>
<td>Rename a brush variant</td>
<td>Right-click a brush variant, choose Rename Variant, and type a name for the variant.</td>
</tr>
</tbody>
</table>

Saving and deleting brush variants

You can save a customized brush variant for future use. When saving a brush variant, you have the option of saving to the currently selected brush category, or saving to a new brush category that you create. The new brush variant is always saved to the currently selected brush library. You can also delete the brush variants that you create.

In addition, you can save the variant as a look. Variant settings are included when you save a look, but looks can also include paper texture, pattern, gradient, and nozzle data. For more information, see “Saving a brush look” on page 315.

To save a brush variant
1. In the Brush library panel, click the brush variant that you want to save.
2. Choose Brushes ➤ Save Variant.
3. In the Save Variant dialog box, type a name for the new variant.
4. Choose the category in which you want to save the variant from the Brush Category list box.
   If you want the current main and additional colors to be saved with the variant, enable the Save Current Color check box. You do not need to enable the option if the variant uses the Clone Color option.
5. Click Save.

The new variant appears on the variant menu, in the currently selected brush category.

You can also

Copy the variant to another category

With a variant selected, click the Brush library options button \[\text{Copy Variant}\], and choose Copy Variant. Choose the destination brush category from the Copy Variant To list box. (Remember to delete the variant in the category from which it was copied.)
When you create a new variant, the variant files are saved in the operating system’s Users folder. The variant is stored in the brush category folder that was selected when the variant was saved.

You can also create a new brush category by clicking the Add New Brush Category button in the Save Variant dialog box and typing a name in the New Category Name text box.

You can also save a brush variant from the Brush library panel by clicking the Brush library options button and choosing Save Variant.

You can also copy brush variants at the root of the category folder by copying the brush variant files (XML, NIB, STK, and, in some instances, a JPEG file) to the desired category. This is a useful method when you need to copy multiple variant files to a new category.

To delete a brush variant
1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category, and then click the brush variant that you want to delete.
3. Choose Brushes > Remove Variant.
4. Click Yes to delete the variant.

The variant’s related files (XML, NIB, STK, and, in some instances, a JPEG file) are deleted from the operating system’s Users folder.

You cannot delete any of the default brush variants.

You can also delete a brush variant from the Brush library panel by clicking the Brush library options button and choosing Remove Variant.

Restoring default brush variants

You can restore any modified brush variant to its default settings. For information about restoring all factory default settings, see “Restoring the default Corel Painter settings” on page 89.

To restore a default brush variant
1. Click the Brush Selector on the Brush Selector bar.
2. In the Brush library panel, click a brush category, and then click the brush variant that you want to restore.
3. In the Brush library panel, click the Brush library options button, and choose Restore Default Variant.

If you want to restore all brush variants to their default settings, click the Brush library options button, and choose Restore All Default Variants.

You can also restore a default brush variant by clicking the Reset Tool button on the property bar.
Creating and deleting brush categories

You can create a brush category to store new brush variants or to organize existing variants for a specific workflow or project. You can also delete a brush category.

To create a new brush category
1. Choose **Brushes ➤ New Brush Category**.
2. Type a name in the **New Category Name** text box.

The new brush category appears in the **Brush Category** list of the Brush library panel and contains the currently selected brush variant, because a brush category must contain at least one brush variant.

You can also change the brush category icon by right-clicking a category in the Brush library panel, choosing **Set Custom Icon**, and choosing the image that you want to display as the category icon.

You can also create a new brush category from the Brush library panel by clicking the Brush library options button and choosing **New Brush Category**.

To remove a brush category
1. Choose **Brushes ➤ Remove Brush Category**.
2. In the **Choose Brush Category** dialog box, choose a category from the **Category** list box.
3. Click **OK**.
   A warning message about deleting the brush category appears.
4. Click **OK**.

You cannot remove any of the default Painter brush categories.

You can also remove a brush category from the Brush library panel by clicking the Brush library options button and choosing **Remove Brush Category**.

Creating and deleting brush libraries

You can create a brush library by modifying the contents of an existing brush library and then exporting it. You cannot create a brush library from scratch. To modify an existing brush library for export, you can add new brush categories and variants. You can also exclude brush categories and variants from export by hiding them in the brush library panel. After you’ve exported the modified library, you can import it as a new brush library. In addition, you can delete a brush library from within Corel Painter.

To create a brush library
1. In the Brush library panel, display the brush library that you want to copy.
   To exclude brush categories and variants from the exported brush library, you can hide them by doing the following:
   - Right-click a brush category, and choose **Hide Category**.
   - Right-click a brush variant, and choose **Hide Variant**.
2 Click Brushes ▶ Export ▶ Brush Library.
3 In the Choose Brush Library dialog box, choose the brush library that you want to export from the Library list box.
4 Click OK.
5 In the Export Brush Library dialog box, type a name for the new library in the File Name text box.
6 Click Save.
7 Click Brushes ▶ Import ▶ Brush Library.
8 In the Import Brush Library dialog box, choose the exported library, and click Open.

This is the recommended method for creating a new brush library in Corel Painter 12 Update 1 and later. In previous versions of Corel Painter, the only method for creating a new library was by manipulating brush files in the operating system file browser. Currently, there is no method for creating blank brush libraries.

To delete a brush library
1 In the Brush library panel, click the Brush library options button ▼, and choose Remove Brush Library.
2 Choose a brush library from the list box.
   If you are trying to remove the active library, which is the library currently open in the Brush library panel, you are prompted to choose a new active library.

You cannot delete any of the default Painter brush libraries.

Importing and exporting brush libraries, categories, and variants
You can import and export brush libraries, categories, and variants. This allows you to work with brush resources that were created by others, or share them with others. You can only import brush libraries, categories, and variants that were previously exported by you or someone else from Corel Painter 12 Update 1 or later.

You can share exported brush resources (brush libraries, categories, and variants) only with users who have Corel Painter 12 Update 1 or later installed. The brush source files of Corel Painter 12 Update 1 or later are not supported in older versions of Corel Painter, including Corel Painter 12 and Service Pack 1.

It is important to note that you can display only one library at a time in the Brush library panel.

Corel Painter 11 (or earlier) brush libraries
You can open brush libraries that were created in an older version of Corel Painter. In Corel Painter 11 and earlier versions, brush variants are individual XML files organized in brush category folders within brush libraries. To use older brush libraries, you must first copy them to Corel\Painter 2020\Brushes. After you copy the files, you can access them through the Brush library panel or the Brushes menu.

Brush libraries that are not in the Brushes folder are not recognized or visible within Corel Painter. The folder structure of brush libraries must match that of the default Painter Brushes library folder (Corel\Painter 2020\Brushes\[library folder]\[category folder]\[variantFile.xml]). If you want to copy only a few brush variants, you must still add them to a brush library while following the correct folder structure.

When you open the older library, you can export it. This converts the brush library to the new brush library format.

To import a brush library
1 Click Brushes ▶ Import ▶ Brush Library.
2 In the Import Brush Library dialog box, browse to the folder where the brush library is stored.
3 Choose the brush library, and click **Open**.

The imported brush library is displayed in the Brush library panel.

You can also import a brush library from the Brush library panel by clicking the Brush library options button 
, choosing **Import**, and choosing **Brush Library**.

You can also import a brush library from the file browser of your operating system by double-clicking a brush library file.

**To import a legacy Corel Painter brush library**

1 In the file browser of your operating system, browse to the location where the legacy brush library folder is stored.

2 Copy the files.

3 Paste the library folder in the **Corel\Painter 2020\Brushes** folder.

4 Ensure that the library folder is writable by doing the following:
   - (macOS) While pressing **Control**, click the brush library folder, and click **Get Info**. In the **Info** dialog box, disable the **Locked** check box. Repeat for subfolders and files.
   - (Windows) Right-click the brush library folder, and choose **Properties**. On the **General** page, disable the **Read-only** check box, and click **Apply**. In the **Confirm Attribute Changes** dialog box, enable the **Apply Changes to This Folder, Subfolders and Files** option.

5 In Corel Painter, click the Brush Selector on the Brush Selector bar.

6 In the Brush library panel, click the Brush library options button 
, and choose **Brush Library** > **Painter Brushes**.

**To export a brush library**

1 Click **Brushes** > **Export** > **Brush Library**.

2 In the **Choose Brush Library** dialog box, choose the brush library that you want to export from the **Library** list box.

3 In the **Export Brush Library** dialog box, browse to the folder where you want to store the library.
   
   To rename the brush library, type a name in the **File Name** box.

4 Click **Save**.

You can also export a brush library from the Brush library panel by clicking the Brush library options button 
, choosing **Export**, and choosing **Brush Library**.

**To import a brush category**

1 Click **Brushes** > **Import** > **Category**.

2 In the **Import Brush Category** dialog box, browse to the folder where the brush category is stored.

3 Choose the brush category, and click **Open**.

You can also import a brush category from the Brush library panel by clicking the Brush library options button 
, choosing **Import**, and choosing **Category**.

You can also import a brush category from the file browser of your operating system by double-clicking a brush category file. The brush category automatically appears in the Brush library panel.
To export a brush category

1. Click **Brushes > Export > Category**.
2. In the **Choose Brush Category** dialog box, choose a brush category from the **Category** list box.
3. Click **OK**.
4. In the **Export Brush Category** dialog box, click **Save**.

To rename the brush category, type a name in the **File Name** box.

You can also export a brush category from the Brush library panel by clicking the Brush library options button, choosing **Export**, and choosing **Category**.

To import a brush variant

1. Click **Brushes > Import > Brush**.
2. In the **Import Brush Variant** dialog box, browse to the folder where the brush variant is stored.
3. Choose the brush variant file, and click **Open**.
4. In the **Save Variant** dialog box, choose the brush category where you want to store the variant from the **Brush Category** list box.

To rename the brush variant, type a name in the **Save Variant As** text box.

5. Click **Save**.

You can also create a new brush category while in the **Save Variant** dialog box by clicking the **Add New Brush Category** button and typing a name in the **New Category Name** text box.

You can also import a brush variant from the Brush library panel by clicking the Brush library options button, choosing **Import**, and choosing **Brush**.

You can also import a brush variant from the file browser of your operating system by double-clicking a brush variant file. The brush variant automatically appears in the Brush library panel.

To export a brush variant

1. In the Brush library panel, click the brush variant that you want to export.
2. Click **Brushes > Export > Brush**.
3. In the **Export Brush** dialog box, click **Save**.

To rename the brush variant, type a name in the **File Name** box.

You can also export a brush variant from the Brush library panel by clicking the Brush library options button, choosing **Export**, and choosing **Brush**.

Importing Photoshop brush images

You can import the brush dab shapes, also known as brush stamps, of Photoshop brushes saved to Adobe Brush Resource (ABR) files. All other brush attributes specified in the ABR files, such as texture and dynamics, are not imported and can be fully customized.
The brush stamps contained in an ABR file are imported as a new brush category that you can name. Each imported brush stamp appears as a new brush variant.

To import Photoshop brush stamps as new Painter brushes

1. Click **Brushes** ➤ **Import** ➤ **New from Photoshop Brush Stamps (ABR)**.
2. In the **New Brush Category** dialog box, type a name in the **New Category Name** box.

You can import only the brush stamps of pixel-based brushes.

Saving a brush look

A look retains all brush variant settings, plus the paper, pattern, gradient, or nozzle settings. For example, if you customize a brush variant and paper texture to achieve a specific effect that you want to use in the future, you can save these settings as a look. When you save a look, it is added to the **Look Libraries** panel.

A brush variant is not itself associated with information about underlying texture or other elements. The look, on the other hand, is associated with additional information about a particular variant. Regardless of a document’s current libraries, when you select a look, you use the elements that are part of that look.

To save a look

1. Choose **Window** ➤ **Media Panels** ➤ **Looks**.
2. Create a look by choosing a brush variant and any additional settings that you want to save with the look.
3. Apply a brushstroke to the canvas.
4. Click the **Rectangular Selection** tool, and drag to select a portion of the image or brushstroke, so you can use it as an icon for the look.
5. In the toolbox, click the Brush tool.
6. Click the Look Libraries options button, and choose **Save Look**.
7. In the **New Look** dialog box, type a name for the look in the **Save As** box.

The new look appears as the last item in the **Brush Looks** panel.

To apply a saved look

1. From the Media Selector bar, click the Look Selector button.
2. Choose a look from the **Brush Looks** panel.
3. Paint in the document window.

Creating brush dabs

You can create your own brush dab shapes by creating a shape, selecting it, and then capturing it as a dab.
To create a brush dab shape

1. On a white background, draw a shape in black color.
   If you are drawing on a layer, drop the layer to the canvas when you complete the shape. (See “To drop a layer” on page 590.) Use shades of gray to define the transparent areas of the dab.
   To follow stroke direction, a captured brush set must face toward the right side.

2. Choose the **Rectangular Selection** tool from the toolbox.

3. Drag across your brush shape to create a selection. For a square selection, hold down **Shift** after you start dragging.

4. Click the Brush Selector on the Brush Selector bar.

5. In the Brush library panel, choose the brush category in which you want to save the variant for the captured dab shape.

6. Click the Brush library options button, and choose **Capture Dab**.

7. If necessary, choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Size**, and change the settings.

8. Choose **Select** ➤ **None**, and draw with the brush on the canvas.
   
   If you like the results you’ve captured, you can save the brush as a new variant. For information about how to save customized brushes for later use, see “Saving and deleting brush variants” on page 309.

Corel Painter uses the area you selected in step 3 to set the brush size. When the brush is created, the selected area is sampled to compute each brush dab.

If the original area requires scaling to the size of the brush dab, sampling can appear aliased. The greater the scaling, the more aliasing is apparent. To prevent too much aliasing from appearing, create a shape with soft (grayscale) edges that is close to the size you’ll be using.

You can paint with a captured brush just as you would with other brushes.
Exploring brush categories

Corel Painter brushes are organized in brush libraries, and the brushes in each library are grouped in brush categories. This chapter contains descriptions of brush categories included in the Painter brush libraries as well as sample brushstrokes. The brush categories are presented in alphabetical order. Note that not all brush categories and brush variants are available in each Painter brush library. Also, brush category names may vary slightly across the different brush libraries.

To change the brush library, click the Brush tool in the toolbox, click the Brush Selector on the Brush Selector bar, and choose a brush library from the Brush library list box.

To choose a brush category and a brush variant, on the Brush Library panel, choose a brush category, and then click a brush variant.

List of brush categories

- "Acrylics and Gouache" (page 318)
- "Airbrushes" (page 319)
- "Artists’ Favorites" (page 320)
- "Artists’ Oils" (page 321)
- "Audio Expression" (page 322)
- "Blenders" (page 324)
- "Chalk, Pastel, and Crayons" (page 325)
- "Cloners" (page 327)
- "Dab Stencils" (page 329)
- "Digital Watercolor" (page 331)
- "Dynamic Speckles" (page 333)
- "Erasers" (page 334)
- "F-X" (page 335)
- "Glazing brushes" (page 336)
- "Image Hose" (page 338)
- "Impasto" (page 339)
- "Liquid Ink" (page 341)
- "Markers" (page 342)
- "Oils" (page 343)
- "Palette Knives and Sponges" (page 344)
- "Particles" (page 345)
Acrylics and Gouache

The Acrylic brush variants, much like their real-world counterparts, are versatile brushes that let you apply quick-drying paints to the canvas. Most of the brushes allow you to cover underlying brushstrokes and many are capable of multicolored brushstrokes. In addition, a few Acrylic brush variants interact with underlying pixels to create realistic effects.

Gouache brush variants let you paint with the fluidity of watercolors and the opacity of acrylics. These variants range from fine, detail brushes, to flat or thick brushes. Brushstrokes created with Gouache brush variants cover underlying brushstrokes.
Airbrushes

Airbrushes apply fine sprays of color, which carefully mirror the feel of a real airbrush in action. However, some variants have a different way of building up color. Most airbrushes support color buildup on a single brushstroke. However, some of the digital airbrushes do not. To achieve color buildup with the digital airbrushes, you need to overlay multiple brushstrokes.

The Wacom airbrush styluses are fully compatible with the variants in the Airbrushes category. For more information, see “Airbrush controls” on page 416.
Artists’ Favorites

The Artists’ Favorites brush variants help you paint in the styles of master artists. For example, you can paint in the style of Vincent Van Gogh, with multishaded brushstrokes, or in the style of Georges Seurat, with multiple dots combining to form an image.
When you use any of the Artist brush variants, dragging quickly produces wider brushstrokes. You can use the Color Variability settings to adjust how the Artist brushstrokes are colored.

Blurred

Glow

Impressionist Blender Jitter

Impressionist

Sargent Brush

Scratchboard Tool

Artists’ Oils

Blender Bristle

Blender Palette Knife

Bristle Brush
Audio Expression

The Audio Expression brushes let you use audio from your computer’s microphone, or internal audio to modify the look and feel of brushstrokes. For more information, see “Audio Expression” on page 374.
Cloud Puff Audio Scrambler
Masked Pattern Audio Pen
Palette Knife Cloner Audio Dancer
Particle Audio Dancer
Particle Audio Static
Particle Grainy Audio Spray
Particle Origami Audio Pulse
Real Watercolor Audio Pulse
Soft Speckle Audio Pulse
Speckle Airbrush Audio Pulse
Speckle Crayon Audio Pulse
Speckle Liquid Ink Audio Spatter
Blenders

Blenders brushes affect underlying pixels by moving and mixing them. The variants can reproduce the effects of blending paint by applying water or oil. You can also smooth drawing lines and create shading just as you would on a pencil sketch or charcoal drawing.
Chalk, Pastel, and Crayons

Chalk brush variants produce the thick, rich texture of natural chalk sticks, and have strokes that interact with the paper grain. The opacity is linked to stylus pressure.

Crayons offer a range of styles. From soft and dull, to waxy and grainy, they produce textured strokes that interact with the paper grain. As with other dry media brush variants, the opacity is linked to stylus pressure.

Pastels, which include oil pastels, range from hard pastel styles that reveal the paper grain to extra soft pastels that glide on to completely cover existing strokes. Opacity is linked to stylus pressure.

The oil pastel brush variants produce the thick, rich texture of natural pastel sticks. Most oil pastel brush variants cover existing strokes with the current paint color. However, the Variable Oil Pastel brush variant blends the underlying color into the stroke. As with other dry media brush variants, opacity is linked to stylus pressure.

Similar to Chalk, Conte brush variants produce textured strokes that interact with the paper grain. As with other dry media brush variants, the opacity is linked to stylus pressure.
Cloners

The Cloner brush variants behave like other brush variants, except that they take color from a cloned or sampled source. These variants recreate the source imagery while effectively filtering it, reproducing the image in an artistic style, such as pastel chalk or watercolor. For more information, see “Cloning brushes and controls” on page 195 and “Image cloning and sampling” on page 181.
Bristle Blender Cloner

Camel Impasto Cloner 2

Chalk Cloner 2

Cloner Spray

Fiber Cloner 2

Flat Impasto Cloner 2

Furry Cloner

Impasto Cloner Jitter Etch 2

Particle Flow Bristle Fine Cloner 2

Particle Spring Oil Mop Cloner 2

Particle Spring Worm Hole Cloner 2

Soft Cloner 2
Dab Stencils

The Dab Stencil brush variants knock out areas of the brush dab by making them more transparent. They use stencil media such as papers, flow maps, or textures. For more information, see “Dab Stencil controls” on page 445.
Digital Watercolor

Digital Watercolor brush variants produce watercolor effects that react with the canvas texture. Unlike Watercolor brush variants, which work with the Watercolor Layer, Digital Watercolor brushstrokes can be applied directly to any standard pixel-based layers, including the canvas. For example, if you’re applying watercolor effects to a photo, Digital Watercolor brushstrokes can be applied directly to the image. If you’re creating a realistic watercolor from scratch, the Real Watercolor or Watercolor brush variants allow colors to flow, mix, and absorb more realistically. For more information, see “Real Watercolor controls” on page 405 and “Digital Watercolor controls” on page 421.

The width of Digital Watercolor brushstrokes is affected by stylus pressure, with the exception of the Wet Eraser brush variant.
Coarse Water 2
Fine Tip Water 2
Gentle Wet Eraser
New Simple Diffuser
New Simple Water
Pure Water Bristle 2
Salt
Simple Water 2
Soft Round Blender
Spatter Water 2
Speckle Coarse Dry Brush
Stencil Flow Map - Grainy
Dynamic Speckles

The Dynamic Speckles brush variants generate a continuous brushstroke from discrete spots of color or speckles. For more information, see “Dynamic Speckles controls” on page 443.
Erasers

There are three types of Eraser brush variants: Eraser, Bleach, and Darkener. Eraser brush variants erase down to the paper color. Bleach brush variants erase to white, gradually lightening by removing color. Darkener brush variants are the inverse of Bleach variants. Darkener brush variants gradually increase color density, building colors toward black. With all Eraser brush variants, pressure determines how much you erase.
F-X brush variants can give you an array of creative results. Some add color; others affect underlying pixels. The best way to appreciate the F-X brush variants is to experiment with them on an image and a blank canvas.
Glazing brushes

In Glazing brushes, opacity builds up smoothly from a minimum to a maximum along the brushstroke, eliminating harsh transitions and evenly blending colors. Glazing brushes can help you fill an area with long continuous strokes that have a very soft gradation from the beginning of the mark to the end. For more information about glazing controls, see “Glazing controls” on page 450.
Image Hose

The **Image Hose** is a special brush that applies images instead of color. The images it “paints” with come from special image files called nozzles. Each nozzle file contains multiple images that are organized by characteristics such as size, color, and angle. Each characteristic (parameter) can be linked to a stylus attribute (animator), such as **Velocity**, **Pressure**, and **Direction**. For more information, see “Image Hose controls” on page 436 and “Image hose” on page 517.

The name of each **Image Hose** variant tells you which parameter and animator are in effect. For example, the **Linear-Size-P Angle-R** brush variant links size to stylus pressure (P) and sets the angle randomly (R).
Impasto

Impasto brush variants use the classic technique of applying thick paint on a canvas to create depth. The depth information for the brushstroke is stored with the layer, but you need to display the Impasto information to view it. For information, see “Impasto controls” on page 421 and “Impasto” on page 559.

Some variants, such as Acid Etch, Clear Varnish, Depth Rake, and Texturizer-Clear, apply depth effects to underlying pixels. Other variants apply three-dimensional brushstrokes with the current paint color.
**Liquid Ink**

*Liquid Ink* brush variants combine ink and paint to create a thick, liquid paint effect. There are three main types of *Liquid Ink* brush variants: ones that apply ink, ones that remove ink to create a resist effect, and ones that soften edges. A new layer is created automatically when you first apply a brushstroke. You can also create 3D effects with Liquid Ink. For information, see “Liquid Ink controls” on page 425 and “Liquid Ink” on page 553.
Markers

The brush variants in the **Marker** category replicate conventional, real-world markers. The brush variants range from fine point to blunt and have a variety of nib shapes and opacity levels.

The strokes that you make with some of the **Marker** variants closely reflect those of traditional, high-quality markers, mainly because of the way the **Marker** variants interact with the canvas. For example, the **Flat Rendering Marker** allows color buildup and pooling. For more information, see “Hard Media” on page 511.
Oils

Oils brush variants let you create effects you’d expect from oil paints. Some variants are semitransparent and can be used to produce a glazed effect. Other variants are opaque and cover underlying brushstrokes.

Some Oil brush variants let you mix media as though you were working with traditional oil paints. You can use colors mixed on the Mixer pad and apply them directly to the canvas. The colors can then be blended with the oils already on the canvas. In addition, you can load multiple colors from the Mixer pad. Some Oil brush variants load the brush with a finite amount of oil, which is then transferred to the image. As you apply a brushstroke to the canvas, the brush loses oil, and the brushstroke becomes fainter. Because layers don’t have the oily properties of the canvas, brushstrokes applied to a layer don’t fade as rapidly.

Some Oil brush variants are palette knives that let you mix paint directly on the canvas. There are six brush tip profiles designed specifically for Oil brushes. For more information, see “Artists’ Oils controls” on page 419 and “Artists’ Oils brush tip profiles” on page 402.
Palette Knives and Sponges

You can use Palette Knives brush variants to scrape, push, or pick up and drag colors in your image. Only one Palette Knives brush variant, the Loaded Palette Knife, applies the current paint color. The Palette Knives dabs are always parallel to the shaft of the stylus.
**Sponges** let you create a variety of textures by applying the current paint color to cover or blend existing colors. Some **Sponge** brush variants apply dabs of paint at random angles with each click of a stylus. Wet sponge brush variants, such as **Grainy Wet Sponge**, apply sponge dabs as you drag across the canvas. The **Smeary Wet Sponge** variant lets you blend the current paint color with existing colors as you drag across the canvas.

**Parties**

Particle brushes are physics-inspired brushes that give a unique look and feel to your artwork. They emit particles from a central point, and in turn the particles draw a pattern of lines (paths) as they move across the canvas. For more information, see "**Particle brushes**" on page 467.
Pattern Pens

Pattern Pens brush variants let you use a brush to apply a pattern to an image. You can vary features such as the size of the pattern and the transparency. For example, Pattern Pen Micro decreases the size of the pattern, and Pattern Pen Transparent applies a semitransparent version of the pattern. For more information, see “Painting with patterns” on page 725.
Pens and pencils

**Pens** brush variants, like the **Scratchboard Rake** and **Bamboo Pen**, create realistic effects without the drawbacks of traditional pens, which can clog, spatter, or run dry.

Whether you want to reproduce the look of calligraphy pen strokes on a grainy texture, or the smooth strokes of a calligraphy brush, the **Calligraphy** brush variants offer you a range of creative options.

**Pencil** brush variants are great for any artwork that would traditionally require pencils, from rough sketches to fine-line drawings. Like their natural counterparts, **Pencil** brush variants interact with canvas texture. All variants build to black and link opacity to stylus pressure. The width of **Pencil** strokes varies according to the speed of the stroke, so dragging quickly produces a thinner line and dragging slowly leaves a thicker line.
Exploring brush categories

- 2B Pencil
- Calligraphy brush
- Coit Pen
- Cover Colored Pencil
- Cover Pencil
- Croquil Pen 2
- Flat Color 2
- Grad Pen
- Grad Repeat Pen
- Gravity Lazy Sketch
- Greasy Pencil 2
- Leaky Pen
Real Watercolor

The brushstrokes of the **Real Watercolor** brush variants flow and apply pigments in a very natural way, helping you create realistic watercolor paintings. In addition, the brushstrokes interact with the paper texture and grain to produce results you would expect from real-world watercolors. You can modify the **Real Watercolor** brush controls to achieve different effects. For more information, see "Real Watercolor controls" on page 405.
Real Water Sketcher
Real Wet Brush 2
Real Wet Detail
Real Wet Flowmap Wash
Flow Map - Dry
Real Wet Sponge
Speckle Runny Palette Knife
Speckle Tiger Lily
Splatter Dry
Wet Eraser
Real Wet Oil

The Real Wet Oil brush variants help you achieve realistic oil brushstrokes. The Real Wet Oil brush variants let you control paint viscosity and color concentration, similar to mixing oil paint and a medium. You can also modify the Real Wet Oil brush controls to achieve different effects. For more information, see “Real Wet Oil controls” on page 408.
Selection brushes

Selection brushes let you create freehand selections by painting. For more information, see “Selecting areas by painting” on page 622.
Simple

The Simple brush category includes commonly used brush variants from other brush categories to help you get started with your sketching and painting tasks. You can access quickly a pencil, pen, marker, airbrush, blender brush and an eraser.

2B Pencil  
Digital Airbrush  
Eraser  

Flat Color 2  
Just Add Water

Smart Strokes

Smart Strokes brush variants are based on popular brush variants from other brush categories, but they are optimized to work with the Photo Painting System. For more information about the Photo Painting System, see “Auto-painting photos” on page 176.
Watercolor Broad Brush  Watercolor Runny  Watercolor Soft Diffused Brush

Watercolor Spatter Water

**Sumi-e**

*Sumi-e* brush variants let you create flowing sumi-e-style brushstrokes. In addition, various brush sizes and shapes are available to help you recreate traditional sumi-e brushstrokes.

Dry Ink Sumi-e 2  Flat Wet Sumi-e 2  Thick Blossom Sumi-e

Wet Bristle Sumi-e
Texture brushes

Texture brushes let you add textures to your projects by taking the color and luminance components of a source image — the texture — and transposing them onto another surface — your painting — using different brush methods. For more information, see “Texture painting” on page 483.

Texture Cover
Soft Luminance to Texture Color

Soft Luminance

Static Bristle Grainy Luminance

Stencil Flow Map - Soft - Color Control

Stencil Flow Map - Variable Color

Stencil Texture - Captured - Color Control

Stencil Texture - Subtle Captured Blender

Texture Source Blending

Basic - Color Control

Captured - Texture to Color Control

Captured Tinted Texture
Thick Paint

Thick Paint brushes offer a natural media experience with the look and feel of thick paint and traditional impasto. They can help you paint beautiful images by adding texture, movement, or a 3D look regardless whether you are creating traditional art, photo art, or an illustration. For more information, see “Thick Paint” on page 537.
Watercolor

Watercolor brush variants paint onto a watercolor layer, which enables the colors to flow, mix, and absorb into the paper. The watercolor layer is created automatically when you first apply a brushstroke with a Watercolor brush variant. The layer lets you control the wetness and evaporation rate of the paper to effectively simulate conventional watercolor media. Most Watercolor brush variants interact with the canvas texture. You can use Watercolor brush variants to apply a watercolor effect to a photo by lifting the canvas to the watercolor layer. For more information, see "Water controls" on page 421 and "Watercolor" on page 461.

For more information about additional watercolor brush variants, see "Real Watercolor" on page 351.

To paint directly on the canvas, use a Digital Watercolor brush variant.
Exploring brush categories in the Natural Media Brushes library

Corel Painter brushes are organized in brush libraries, and the brushes in each library are grouped in brush categories. This chapter contains descriptions of brush categories included in the Natural Media Brushes library, as well as sample brushstrokes. The Natural Media Brushes library makes it easy for artists to transition from traditional to digital art. It gives quick, one-stop access to brushes that mimic traditional media, from pencils and pastels to oils and acrylics, and much more. If you’ve used it in the real world, chances are you’ll find the digital equivalent in the Natural Media Brushes library.

To access the Natural Media Brushes Library, in the Brush Selector, choose Natural Media Brushes from the Brush Library list box.

To choose a brush category and a brush variant, in the Brush Selector, choose a brush category, and then click a brush variant.

List of brush categories

• “HARD MEDIA - Pencils” (page 365)
• “HARD MEDIA - Charcoal” (page 366)
• “HARD MEDIA - Conte” (page 366)
• “HARD MEDIA - Pastels” (page 366)
• “INK - Pens” (page 367)
• “INK - Markers” (page 367)
• “PAINT - Oils” (page 368)
• “PAINT - Acrylics” (page 368)
• “PAINT - Glazing” (page 368)
• “REFINING - Blenders” (page 369)
• “REFINING - Erasers” (page 369)
• “PAINT - Airbrushes” (page 369)
• “PAINT - Watercolor” (page 370)

HARD MEDIA - Pencils

At your fingertips are a complete set of graphite pencils in a range of standard hardesses, perfect for initial sketches or detailed pencil drawings. The 2B pencil is also offered in a range of sharpnesses for further expressive possibilities.
HARD MEDIA - Charcoal

Capture the simple beauty of charcoal drawing, where all you need is just one or at most a handful of charcoals together with your choice of paper.

HARD MEDIA - Conte

Conte crayons are available in a few shapes.

HARD MEDIA - Pastels

A standard range of commonly used pastel types, including soft, hard, pencils and oils, many featuring loose grainy texture. They are well suited to layering, and can easily be smudged and blended when used in conjunction with tools from the Blenders category.
INK - Pens
A set of black technical pens ideally suited to illustration, linework, and lettering, in a range of common tip sizes.

INK - Markers
A set of art markers with different tip sizes and types.
PAINT - Oils
You can almost smell these oils, which are provided in a range of paint thicknesses to choose from. Also at your fingertips are a range of tools that you can use to apply the paint, including various brush shapes along with a set of palette knives. This category is based on the Thick Paint technology.

Angle Brush
Detail Brush
Fan Brush

PAINT - Acrylics
Further expressive range is made possible by this category, which combines a range of brushes and palette knives for applying heavy-body acrylic.

Angle Brush
Detail Brush
Fan Brush

PAINT - Glazing
A simple set of brushes and a sponge for applying beautiful translucent glaze that dries quickly and does not disturb or mix with underlying layers of color.
REFINING - Blenders
A set of the most common blending tools, both dry and wet, designed to work across a wide range of media in the Natural Media Brushes Library.

REFINING - Erasers
Soft and hard-edged erasers to remove or refine existing strokes.

PAINT - Airbrushes
A selection of the most common airbrush tips that allow for easy layering of color with softly defined edges.
PAINT - Watercolor

The look and experience of traditional watercolor painting, with a range of methods for applying and manipulating the paint, and control over how wet and diluted the paint is. The paint flows on the page in real time.
Adjusting brushes with brush controls

Like a fully stocked art store, Corel Painter supplies you with many different brushes and drawing tools, each with modifiable characteristics. This chapter provides descriptions and procedures for customizing and saving the many parameters of any brush type.

This section contains the following topics:
- “Exploring Brush Controls” (page 372)
- “Expression settings” (page 373)
- “Audio Expression” (page 374)
- “Previewing brushstrokes and brush dabs” (page 376)
- “Calibrating brush variants” (page 377)
- “General controls” (page 378)
- “General controls: Dab types” (page 378)
- “General controls: Stroke types” (page 382)
- “General controls: Methods and subcategories” (page 383)
- “General controls: Source” (page 387)
- “Performance controls” (page 387)
- “Opacity controls” (page 388)
- “Grain controls” (page 390)
- “Stroke Attributes controls” (page 392)
- “Size controls” (page 394)
- “Angle controls” (page 397)
- “Spacing controls” (page 400)
- “Changing dab profiles” (page 401)
- “Jitter controls” (page 403)
- “Real Watercolor controls” (page 405)
- “Real Wet Oil controls” (page 408)
- “Computed Circular controls” (page 413)
- “Hard Media controls” (page 413)
- “Bristle controls” (page 413)
- “RealBristle controls” (page 414)
- “Static Bristle controls” (page 414)
- “Airbrush controls” (page 416)
- “Artists’ Oils controls” (page 419)
- “Impasto controls” (page 421)
Exploring Brush Controls

You can apply media to the canvas by using a ready-to-use default brush variant from the impressive Corel Painter brush library. You can also modify a brush variant to meet a particular need. The brush controls are divided into multiple brush control panels that allow you to adjust a brush variant while you work, or alter an existing variant to create a new variant.

Corel Painter also includes an advanced brush controls panel that generates a grouping of brush control panels that are relevant to the currently selected brush. The Edit panel makes it easy to switch between editing the controls that affect brush shape and editing controls that affect brush media.

You can use the brush controls to adjust the Corel Painter brushes in many different ways, such as change their size, shape, angle, flow, and much more. In fact, the Corel Painter default brush variants are built by adjusting the same set of brush controls in order to emulate a real-life painting or drawing tool.

Changes that you make to brush variants, including basic controls such as Size and Opacity, are retained until you restore the brush variant. You can also save custom brushes as the default, as new variants, or as looks. For more information, see “Saving and deleting brush variants” on page 309 and “Saving a brush look” on page 315.

Modifying Brush Variants

When you modify a brush variant using the brush controls, the modified brush variant information is stored in the variant’s XML, NIB, STK, and in some instances, JPEG files that are found in the operating system’s User folder:

\Users\(user name)\AppData\Roaming\Corel\Painter 2020\Default\Brushes\Painter Brushes folder (Windows)

When you start Corel Painter, the application applies the modified settings to the brush variant, instead of the default settings. However, the default settings are not lost, they remain stored in the application folder. If you decide to reset a brush variant’s default settings, the modified brush variant files are automatically deleted from the Users folder.

To open a brush control panel

* Choose Window ➤ Brush Control Panels, and choose a brush control panel from the list.

To open all general brush controls panels at once

* Choose Window ➤ Brush Control Panels ➤ General.
You can also open all brush control panels at once by pressing Command + B (macOS) or Ctrl + B (Windows). To close all brush control panels at once, the General brush control panel must be docked with the other brush control panels.

To use the advanced brush control panel

1. With a brush variant selected, click the Advanced Brush Controls button on the property bar.
2. In the Edit panel, click the Shape button or Media button, and adjust the controls in any of the panels.

To close a brush control panel

- Click the Close button on the brush control panel title bar.

Expression settings

Corel Painter lets you control brush effects along the stroke based on a number of real-time input factors. For example, many brushes vary their opacity or size in response to changes in stylus pressure. These responses reflect their default settings. You can use the Expression settings to vary these effects in response to other factors, such as stroke direction or velocity.

Expression settings are linked to the following controls: Opacity, Grain, Size, Angle, Airbrush (Feature and Flow), Thick Paint, Impasto, Liquid Ink, Stroke Jitter, Blending (Saturation and Bleed), Color Expression, and Particles. In addition, for some of the brush controls that use Expression, you can adjust the Min setting to specify the range of variation that you want the expression to apply. The Min setting represents a percentage of the specific setting, such as Opacity, and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression on the Opacity panel, set the Opacity slider to 50%, and then set the Min Opacity slider to 20%, the more stylus pressure you apply, the more opaque the brushstroke will be.

Direction adjusts the angle value of the direction controller. When the expression is set to Direction, it specifies the angle at which a brushstroke narrows or widens, which is particularly useful for calligraphic effects.

Some brush controls such as Size, Opacity, Angle, Stroke Jitter, Color Expression, and Color Variability can also be linked to audio input. For more information, see “Audio Expression” on page 374.

To choose an Expression setting

1. Open any of the following brush control panels: Opacity, Grain, Size, Angle, Airbrush (Feature and Flow), Impasto, Liquid Ink, Stroke Jitter, Blending (Saturation and Bleed), Color Expression, or any of the Particles or Thick Paint panels.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable the expression setting</td>
<td>Choose None from the Expression list box.</td>
</tr>
<tr>
<td>Adjust the brushstroke based on the dragging speed</td>
<td>Choose Velocity from the Expression list box. Dragging quickly minimizes the setting; dragging slowly increases it.</td>
</tr>
<tr>
<td>Adjust the selected brushstroke based on the direction of the stroke</td>
<td>Choose Direction from the Expression list box, and move the Direction slider.</td>
</tr>
<tr>
<td>Adjust the brushstroke based on stylus pressure</td>
<td>Choose Pressure from the Expression list box. Greater pressure increases the setting for that brush feature.</td>
</tr>
</tbody>
</table>
To

Adjust the brushstroke based on the wheel setting on an airbrush stylus, specifically the Intuos Airbrush stylus

Choose **Wheel** from the **Expression** list box. The maximum value is set when the wheel is pushed all the way forward. The minimum is set when the wheel is pushed all the way back.

Adjust the brushstroke based on the angle of the stylus from the tablet

Choose **Tilt** from the **Expression** list box. For example, when the stylus is perpendicular to the tablet, Tilt is set at zero.

Adjust the brushstroke according to the direction in which the stylus points

Choose **Bearing** from the **Expression** list box.

Adjust the brushstroke as you turn a flat-tip Intuos Art Pen that supports 360-degrees of barrel rotation sensitivity

Choose **Rotation** from the **Expression** list box.

Adjust the brushstroke according to the luminance of the clone source

Choose **Source** from the **Expression** list box. Higher luminance (closer to white) increases the setting for that component, producing a wider stroke.

Adjust the brushstroke on a random basis

Choose **Random** from the **Expression** list box.

Reverse the effect of an **Expression** setting

Click the **Invert** button 🌱

---

Not all stylus models convey tilt, rotation, or bearing information.

### Audio Expression

The **Audio Expression** feature lets you use audio from your computer’s microphone, or internal audio to modify the look and feel of any brush. For example, your brushstrokes may change their appearance in synch with streaming music. Audio Expression can also help you capture the ambient sounds and the atmosphere of the surroundings while working on a project.

Audio Expression allows you to link audio input to controls on any of the following brush panels: **Size**, **Opacity**, **Angle**, **Stroke Jitter**, **Color Expression**, **Color Variability**, **Dynamic Speckles**, **Grain**, **Airbrush**, **Liquid Ink**, **Particles - Common**, **Flow Particles**, **Gravity Particles**, and **Spring Particles**. You can link one or more brush attributes to audio. For example, if you link audio to brush size, angle, and color variability, brushstrokes will change their width, angle and color in synch with the audio input.

---

The width (size) of the brushstroke changes in synch with the audio signal.
Left: A steady audio signal does not change the opacity of the brushstroke. Right: Opacity changes in synch with the audio signal.

In addition, you can adjust the strength of an audio signal, controlling its impact on a brush. For example, if you link brush size to quiet audio, increasing the strength will result in wider brushstrokes. Conversely, if the audio is loud, decreasing the strength will result in narrower brushstrokes. In addition, you can set the range of the audio expression to achieve a wider range of brushstroke variation (for example, minimum to maximum brushstroke width) regardless of whether the audio is consistently strong, low, or varies.

Audio Expression can be used together with other expressions to control brush attributes. For example, you can apply both pressure and audio expression to control how brush size varies. For more information about expressions, see “Expression settings” on page 373.

For a list of sample brushstrokes using Audio Expression, see “Audio Expression” on page 322.

To link brush attributes and effects to audio

1. Choose Window ➤ Audio ➤ Audio Settings Panel.
2. Enable the Enable Audio Input check box.
3. Choose an audio source from the Input list box.
5. Click the Audio Expression button ( ).

You can also enable audio input by choosing Window ➤ Audio ➤ Enable Audio Input.

You can also select an audio source by choosing Window ➤ Audio ➤ Input, and choosing an audio source.

To choose audio expression settings

1. Choose Window ➤ Audio ➤ Audio Settings Panel.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the strength of an audio signal</td>
<td>Move the Strength slider. While observing the input level indicator below the Input list box, adjust the Strength slider according to the sound. Red indicates that the maximum strength has been achieved.</td>
</tr>
<tr>
<td>Set the range of audio expression</td>
<td>Move the Range slider.</td>
</tr>
</tbody>
</table>
To do the following

While observing the input level indicator below the Input list box, adjust the Range slider according to the sound. Red indicates that the maximum range has been achieved.

Use low values for low audio, medium values for varying audio, and high values for strong audio.

Previewing brushstrokes and brush dabs

The Stroke Preview and Dab Preview panels include preview windows that show how brush control changes affect the appearance of the currently selected variant’s brushstrokes and brush dabs. Both preview panels display changes in real-time. In addition, the Stroke Preview panel reflects how brushstrokes blend with colors and textures. For example, if you change the brush size (Size panel) or dab type (General panel), you can preview the impact of the changes on both the dab and stroke.

The Dab Preview window lets you choose different viewing modes, to reveal different aspects of the brush dabs.

The Dab Preview window lets you toggle between Size and Shape, Hard Media, and Brush Dab views.

In the Size and Shape view, concentric circles show the minimum and maximum sizes of a brush. The inner (black) circle shows the minimum dab width. The outer (gray) circle shows the maximum dab width. Remember that some brushes vary the line width based on pressure or stroke speed. The difference between the diameter of the two circles shows the range in which the stroke width can vary.

In the Hard Media view, you can preview what a Hard Media, such as a Pencil variant, will look like at various angles. This is useful when modifying the settings in the Hard Media brush control panel. The dab appears in the Dab Preview window at the corresponding angle.

In the Dab Preview, shading shows the density distribution of the brush tip. The density distribution describes how much of the medium is conveyed by a given point on the brush dab. For example, an individual dab made by an airbrush produces a soft-edged circular mark with minimum density at the outer edge of the dab. Density increases inward to a maximum value at the exact center of the dab. The Dab Preview cannot be used for the Image Hose or rendered dab types.

To preview brushstrokes

• Choose Window ➤ Brush Control Panels ➤ Stroke Preview.

To preview dabs

1 Choose Window ➤ Brush Control Panels ➤ Dab Preview.

2 In the Dab Profile panel, click one of the following buttons:

• Preview Size and Shape

• Preview Hard Media

• Preview Brush Dab

The Dab Preview window supports only views of dab based brushes.
You can switch between the different preview modes by clicking in the preview window.

Calibrating brush variants

When you draw with traditional media, the amount of pressure that you use with a tool determines the density and width of your strokes. Using a pressure-sensitive stylus with Corel Painter gives you this same kind of control. Because each artist uses a different strength or pressure level in a stroke, you can calibrate individual brush variants to match your stroke strength.

The most common way of adjusting brush calibration is to apply a typical brush stroke, such as a wavy stroke, to the scratch pad. Corel Painter then uses your stroke to calculate the appropriate pressure and velocity settings for the brush variant.

For example, you can set less pressure when sketching with a pencil brush variant, but set more pressure when using an oil paint brush variant. Corel Painter saves Brush Calibration control settings with the brush variant, so whatever sensitivity you set will be the default the next time you choose the brush variant. If you set Brush Calibration for a specific brush in addition to general Brush Tracking preferences, the Brush Calibration settings override the Brush Tracking preferences. For more information, see “Brush tracking and calibration” on page 146.

When you use the scratch pad to set brush calibration, Corel Painter calculates the pressure and velocity settings for you. However, you can manually adjust these settings. For example, you can adjust the stroke pressure to achieve a full pressure range (Pressure Scale slider) using a softer or harder touch (Pressure Power slider). You can also adjust the stroke velocity to achieve a full velocity range (Velocity Scale slider) with a slower or faster stroke (Velocity Power slider).

To ensure that a brush control is using the pressure or velocity settings, you need to set the brush control Expression setting to Pressure or Velocity. For more information, see “Expression settings” on page 373.

To calibrate a brush variant

1. With a brush variant selected, choose Window ➤ Brush Control Panels ➤ Brush Calibration.
2. Enable the Enable Brush Calibration check box.
3. Click the Set brush calibration settings button.
   The Brush Tracker appears.
   Use the pressure and speed you prefer when drawing or painting. This allows the Brush Tracker to calculate the appropriate speed and pressure settings for the brush.

If you want to adjust the settings manually, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Achieve a full pressure range with a softer or harder touch</td>
<td>Adjust the Pressure Scale and Pressure Power sliders.</td>
</tr>
<tr>
<td>Achieve the full velocity range with a slower or faster motion</td>
<td>Adjust the Velocity Scale and Velocity Power sliders.</td>
</tr>
</tbody>
</table>

You can also access the Brush Calibration panel by clicking the Advanced Brush Controls button on the Brush tool property bar.
General controls

Corel Painter provides extensive control over brush properties and dab types. You can also choose how brushstrokes interact with existing color in the image.

To learn about the controls included in the General panel, see the following topics:
- “General controls: Dab types” (page 378)
- “General controls: Stroke types” (page 382)
- “General controls: Methods and subcategories” (page 383)
- “General controls: Source” (page 387)

General controls: Dab types

When you choose a dab type, you’re choosing a method for applying media to the canvas. Corel Painter uses rendered dab types that are computed during the stroke.

Earlier versions of Corel Painter used “dab-based” media application, in which brushes applied small dots of media to create brushstrokes. With the spacing between dabs set small, strokes appear smooth. If you zoom in enough, you can probably tell that the brushstroke is made up of tiny dabs of color. If you make a rapid brushstroke or set large spacing between dabs, strokes can become trails of dots.

Rendered dab types create continuous, smooth-edged strokes. They’re fast and less prone to artifacts than dab-based media application. In fact, you can’t draw fast enough to leave dabs or dots of color showing in a stroke, because they’re just not there. Rendered dab types allow rich new features that were not possible with dab-based media application.

![Image of scratchboard tool](image)

The Scratchboard Tool variant of the Pens and Pencils brush category illustrates the smooth stroke that can be accomplished with the rendered dab types.

Corel Painter brushes use dab-based or rendered dab types:

<table>
<thead>
<tr>
<th>Dab-based dab type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circular</td>
<td>Dabs are controlled by the sliders in the Size and Angle brush control panels.</td>
</tr>
<tr>
<td>Computed Circular</td>
<td>Controlled by the sliders in the Computed Circular brush control panel. This dab type allows you to customize the brush dab profile. For more information, see “Computed Circular controls” on page 413.</td>
</tr>
<tr>
<td>Single-Pixel</td>
<td>Consists of one pixel only. You can’t change its size. You use single-pixel brushes when you zoom in for editing at the pixel level.</td>
</tr>
</tbody>
</table>
### Dab-based dab type

<table>
<thead>
<tr>
<th>Dab Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static Bristle</td>
<td>Controlled by the sliders in the <strong>Size</strong> brush control panel. When the Static Bristle dab type is selected, the preview grid displays a bristly profile.</td>
</tr>
<tr>
<td>Captured</td>
<td>Shapes that you create and capture. For more information, see “Creating brush dabs” on page 315.</td>
</tr>
<tr>
<td>Erase All</td>
<td>Dabs that let you erase parts of images</td>
</tr>
</tbody>
</table>

*In the image: A captured dab lets you paint with specific shapes and designs that you create.*

### Rendered dab type

<table>
<thead>
<tr>
<th>Dab Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camel Hair</td>
<td>Creates bristle brushes with circular arrays of bristles. Individual brush hairs can have their own color, and they can also pick up underlying colors independently of the <strong>Brush Loading</strong> option. By increasing color variability in Corel Painter, you can make each hair a separate color. For more information, see “Setting color variability” on page 259.  The <strong>Feature</strong> slider in the <strong>Bristles</strong> panel separates bristles. The higher the setting, the farther apart the hairs will appear. Using a low setting makes the strokes more solid. For more information about the <strong>Size</strong> controls, see “Size controls” on page 394.</td>
</tr>
<tr>
<td>Flat</td>
<td>Creates flat brushes such as those used to apply paint to houses or walls. Brushes that use Flat dabs respond to bearing and allow for flat or narrow strokes, depending on how the stylus is held. Flat dabs are always perpendicular to the shaft of the stylus.  The <strong>Feature</strong> setting in the <strong>Bristles</strong> panel separates bristles.</td>
</tr>
<tr>
<td>Palette Knife</td>
<td>Creates brushes that are the opposite of Flat dab brushes. With resaturation set low, you can use these brushes to scrape, push, pick up, or rapidly drag colors along. Palette Knife dabs are always parallel to the shaft of the stylus.</td>
</tr>
<tr>
<td>Rendered dab type</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Rendered dab type</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Bristle Spray</strong></td>
<td>The <em>Feature</em> setting in the <em>Bristles</em> panel separates bristles. Creates brushes that can use airbrush controls. These brushes recognize tilt, which separates bristles on the opposite side of the tilt. By adjusting the <em>Feature</em> slider in the <em>Bristles</em> panel, you can separate bristles.</td>
</tr>
<tr>
<td><strong>Airbrush</strong></td>
<td>Creates brushes that act like airbrushes. Bearing (direction) and angle (tilt) affect the eccentricity of the resulting conic section. The <em>Feature</em> slider in the <em>Airbrush</em> panel controls the size of the individual droplets of media. Setting the <em>Feature</em> slider too high might produce undesirable artifacts. You can reverse the spray direction when you paint by enabling the <em>Continuous Time Deposition</em> check box in the <em>Spacing</em> panel, and by holding down Option + Shift (macOS) or Alt + Shift (Windows).</td>
</tr>
<tr>
<td><strong>Pixel Airbrush</strong></td>
<td>Creates brushes that work like airbrushes. Brushes that use Pixel Airbrush dabs cannot use the <em>Feature</em> slider to control the size of individual droplets of media. You can reverse the spray direction when you paint by enabling the <em>Continuous Time Deposition</em> check box in the <em>Spacing</em> panel, and by holding down Option + Shift (macOS) or Alt + Shift (Windows).</td>
</tr>
<tr>
<td><strong>Line Airbrush</strong></td>
<td>Creates brushes that work like airbrushes. Brushes that use Line Airbrush dabs spray lines instead of droplets of media. You can reverse the spray direction when you paint by enabling the <em>Continuous Time Deposition</em> check box in the <em>Spacing</em> panel, and by holding down Option + Shift (macOS) or Alt + Shift (Windows).</td>
</tr>
<tr>
<td><strong>Projected</strong></td>
<td>Creates brushes that act like airbrushes. Brushes created with <em>Projected</em> dabs work similarly to the airbrush from previous versions of the application, but react to bearing and angle data. They create conic sections with an overall softness. You can reverse the spray direction when you paint by enabling the <em>Continuous Time Deposition</em> check box in the <em>Spacing</em> panel, and by holding down Option + Shift (macOS) or Alt + Shift (Windows).</td>
</tr>
<tr>
<td><strong>Rendered</strong></td>
<td>Creates brushes that conform the source to a stroke. Use the <em>Source</em> list box to control what is mapped into the computed brushstrokes. For more information, see “General controls: Source” on page 387.</td>
</tr>
</tbody>
</table>
Corel Painter also includes other dab types that do not fall under the dab-based or rendered dab types.

Other dab types

**Liquid Ink**

Liquid Ink dabs create liquid paint effects that simulate traditional ink-based media. You can give a Liquid Ink brushstroke the appearance of height by applying lighting effects. There are five types of Liquid Ink dab types: Liquid Ink Camel Hair, Liquid Ink Flat, Liquid Ink Palette Knife, Liquid Ink Bristle Spray, and Liquid Ink Airbrush.

**Watercolor dabs**

Watercolor dabs create brushes that work like watercolor brushes. The colors flow and mix and absorb into the paper. You can control the wetness and evaporation rate of the paper. There are five types of Watercolor dab types: Watercolor Camel Hair, Watercolor Flat, Watercolor Palette Knife, Watercolor Bristle Spray, and Watercolor Airbrush.

**Artists’ Oil dabs**

Artists’ Oil dabs produce brushes that work like real-world, high quality oil brushes. There are three types of Artists’ Oils dabs: Artists’ Oils Camel Hair, Artists’ Oils Flat, and Artists’ Oils.

**Thin Line Particles**

With this dab type, brushes emit particles from a central point, and in turn the particles draw a pattern of lines (paths) as they move across the canvas. This dab type includes Thin Line Gravity Particles, Thin Line Flow Particles, and Thin Line Spring Particles.

**Particles combined with Liquid Ink or Watercolor**

Additional dab types are available that use both Particles and Liquid Ink or Watercolor dabs. These combination dab types include: Liquid Ink Gravity Particles, Liquid Ink Flow Particles, Liquid Ink Spring Particles, Watercolor Gravity Particles, Watercolor Flow Particles, and Watercolor Spring Particles.

**Dynamic Speckles combined with Particles, Bristle, or RealBristle**

Dynamic Speckle dab types create brushstrokes with thicker lines from discrete spots of color. The speckles in the brushstroke are generated as you paint. These dab types include Dynamic Speckle Gravity Particles, Dynamic Speckle Flow Particles, Dynamic Speckle Spring Particles, and Dynamic Speckle Bristle.
To choose a dab type

1. Choose **Window ➤ Brush Control Panels ➤ General**.
2. Choose a dab type from the **Dab Type** list box.

**General controls: Stroke types**

The **Stroke Type** determines how a brushstroke applies media. Corel Painter brushes use one of the following stroke types.

- **The Single** stroke type draws one dab path that corresponds exactly to your brushstroke. You can use **Static Bristle, Captured**, or one of the bristly rendered dab types (such as **Camel Hair**) with the **Single** stroke type to create the effect of multiple bristles.

  ![Image](image.png)

  *The Single stroke type has one dab path.*

- **The Multi stroke** type draws a set of randomly distributed dab paths, positioned around the brushstroke you make. These dabs leave dab paths that are not parallel and might overlap. The **Multi stroke** type may produce different results each time you use it. For more information, see “Multi controls” on page 439.
  
  - Increasing the **Stroke Jitter** value in the **Stroke Jitter** panel spreads out the strokes in a multi-stroke brush.
  
  - Increasing the amount of bristles can increase the density of the brushstroke. For more information, see “Multi controls” on page 439.
  
  - Multi-stroke brushes are computed before you apply them, therefore, the computing process can delay their appearance on the canvas. Because of this delay, multi-stroke brushes work best when you apply short, controlled strokes.

  ![Image](image.png)

  *The Multi stroke type draws a set of randomly distributed dab paths.*

- **The Rake** stroke type draws a set of evenly distributed dab paths. The several dab paths in a rake brushstroke are parallel. You can control all other aspects of the stroke by using settings in the **Rake** brush control panel.
  
  - Each bristle in a **Rake** brush can have a different color. Increasing Color Variability in Corel Painter causes bristles to be colored differently.

  ![Image](image.png)

  *A Rake stroke is composed of evenly distributed dab paths.*

- **The Hose** stroke type applies only to the **Image Hose**. It’s a single stroke composed of the current Image Hose Nozzle file. For more information about the **Image Hose** and Nozzle files, see “Image hose” on page 517.

  ![Image](image.png)
The Hose stroke type uses the current Nozzle file as media.

- The **Glazing** stroke type draws brushstrokes with smooth opacity build-up from the beginning of the mark to the end. The paint that each dab deposits on the canvas is temporarily added to an invisible layer, and then the layer is dropped down onto the canvas.

  In a Glazing stroke type, opacity builds up gradually from a minimum to a maximum along a brushstroke.

**To choose a stroke type**

1. Choose **Window** ▶ **Brush Control Panels** ▶ **General**.
2. Choose a stroke type from the **Stroke Type** list box.

   If a stroke type is not available (appears greyed out), it’s not supported by the currently selected brush variant and dab type.

**General controls: Methods and subcategories**

The brush method defines the most basic level of brush behavior and is the foundation on which all other brush variables are built. The method and method subcategory represent attributes of the stroke’s appearance.

Because the method sets a brush variant’s most basic behavior, you can alter a variant’s behavior by changing its method. For example, suppose you want a stroke that looks like charcoal, but instead of hiding underlying strokes, you want the brushstrokes to build to black. You can get this effect by changing the method to **Buildup**. Perhaps you want a variant of the **Pens** brush category to smear underlying colors. You can change its method from **Cover** to **Drip**. Some brush effects are less easily affected by other methods, and results may differ.

Each method can have several variations, called method subcategories. These subcategories further refine the brush behavior. The following terms are used in describing most method subcategories:

- Soft methods produce strokes with feathered edges.
- Flat methods produce hard, aliased strokes with pixelated edges.
- Hard methods produce smooth strokes.
- Grainy methods produce brushstrokes that react to paper texture.
- The words “edge” and “variable” are sometimes used to describe a method subcategory. Edge strokes are thick and sticky-looking. Variable strokes are affected by tilt and direction.

Combining a method with a method subcategory results in a specific brush style that you can assign to a given brush. For example, **Grainy Hard Cover** brushstrokes interact with paper grain and are semi anti-aliased so that they hide underlying pixels. **Grainy Hard Cover** is the default method for **Chalk** and **Charcoal**.
Corel Painter supplies the following methods:

- “Buildup” (page 384)
- “Cover” (page 384)
- “Eraser” (page 384)
- “Drip” (page 385)
- “Cloning” (page 385)
- “Digital Wet” (page 386)
- “Marker” (page 386)
- “Selection” (page 386)
- “Wet” (page 386)
- “Plug-in” (page 386)

Buildup

The Buildup methods allow you to produce brushstrokes that build towards black as they are overlaid. A real-world example of buildup is the felt pen: scribble on the page with blue, then scribble on top of that with green, and then red. The scribbled area keeps getting darker, approaching black. Even if you were to apply a bright color like yellow, you couldn’t lighten the scribble — it would stay dark. Crayons and Felt Pens are buildup brushes.

Cover

The Cover methods produce brushstrokes that cover underlying strokes, as oil paint does in traditional painting. No matter what colors you use, you can always apply a layer of paint that completely hides what’s underneath. Even with a black background, a thick layer of yellow remains pure yellow. Some Chalk and Pen variants are examples of brushes that use the Cover method.

Eraser

The Eraser methods erase, lighten, darken, or smear the underlying colors.
Drip

The Drip methods interact with the underlying colors to distort the image.

Brushes using this method, for example the Sargent Brush (Artists’ Favorites category) and the Smeary Wet Sponge (Palette Knives and Sponges category), mix in the current color with the underlying brushstrokes, creating a nice oily effect. The brushes work both on the canvas and on a layer, support transparency, and work in conjunction with preserve transparency and selections. Paint expressive luscious brushstrokes with these brushes that blend, smear, push, and pull color similarly to wet oil paint.

Cloning

The Cloning methods take images from a clone source and re-create them in another location, often rendering them in a Natural-Media style. For more information about painting a clone, see “Painting in the clone” on page 185.
Digital Wet

The Digital Wet method applies digital watercolor brushstrokes to the canvas or a regular layer. For more information, see "Working with Digital Watercolor brushes" on page 464.

Marker

The Marker method lets you simulate the use of professional markers for drawing and creating renderings. For more information, see “Markers” on page 515.

Selection

The Selection method allows you to create freehand selections by painting with brushes that use the following dab types: Circular, Computed Circular, Captured, Single-Pixel, Static Bristle, Dynamic Speckle Bristle, and Dynamic Speckle Particle types (Flow, Gravity, and Spring). For more information, see "Selecting areas by painting" on page 622.

Wet

The Wet method applies brushstrokes to a Watercolor layer. For more information, see "Working with the Watercolor layer" on page 462.

Plug-in

Plug-in is a special category of method subcategories. It defines no specific brush behavior, but is an open door to a wide range of subcategories.

It’s well worth your time to browse through the Plug-in method subcategories. There, you’ll find methods such as Left Twirl, which simulates the dab and brushstroke of an Impressionist performing left-handed twirls.
To choose a method and subcategory

1 Choose Window ▶ Brush Control Panels ▶ General.
2 Choose a method from the Method list box.
3 Choose a subcategory from the Subcategory list box.

The Method and Subcategory options are available only with circular, single-pixel, static bristle, captured, and eraser dab types.

General controls: Source

The Source setting lets you specify the media that is applied by the brush variant. Source applies only to some dab types, such as Line Airbrush, Projected, and Rendered. For more information about setting a media source, see “Exploring painting media” on page 149.

Corel Painter brushes use one of the following source types:
• Color applies primary or secondary color.
• Gradient applies the current gradient across the length of the stroke. For more information, see “Applying gradients” on page 737.
• Gradient Repeat applies the current gradient repeatedly along the stroke. For more information, see “Applying gradients” on page 737.
• Pattern paints with a pattern containing no mask information. For more information, see “Painting with patterns” on page 725.
• Pattern With Mask paints with a pattern limited by the pattern’s mask. For more information, see “Painting with patterns” on page 725.
• Pattern As Opacity paints a pattern in which the luminance of the pattern becomes the opacity of the stroke. For more information, see “Painting with patterns” on page 725.

To choose a media source

1 Choose Window ▶ Brush Control Panels ▶ General.
2 Choose a source from the Source list box.

Performance controls

You can quickly see whether the currently selected brush can take advantage of your system’s multi-core processor (CPU), AVX2 extensions of the CPU, or graphics processor (GPU) technologies. You can also run the Brush Accelerator to evaluate your system and optimize application settings.

Your system has been evaluated and application settings optimized, and the selected brush can take advantage of the technology.

Your system has been evaluated and application settings optimized. The selected brush can take advantage of the technology, but your system is below the baseline requirements for it to do so.
You can disable your system's GPU for the currently selected brush, allowing you to experiment with performance settings.

The Performance panel also lets you know if your system's GPU has been disabled for all brushes or if the number of cores allocated to Painter is insufficient. For more information, see “Performance preferences” on page 854.

To disable GPU support for the currently selected brush
1. Choose Window \ Brush Control Panels \ Performance.
2. Enable the Disable GPU for this brush check box.

To evaluate your system and optimize application settings
1. Choose Window \ Brush Control Panels \ Performance.
2. Click the Brush Accelerator button 🔄.

If the Brush Accelerator utility has already been run, the button displays as 🔄.

You can also run the Brush Accelerator utility from the Welcome Screen (Help \ Welcome Screen).

Opacity controls
Opacity lets you control how Corel Painter varies the density of the media that you apply to the canvas. The Opacity controls let you set opacity levels for the currently selected brush.

You can also use the Expression settings to link opacity to various stylus or mouse movements. For example, you can link the opacity of an Airbrush variant to stylus pressure. Heavier pressure produces more opaque strokes. For more information, see “Expression settings” on page 373.

You can also adjust the Min setting to specify the range of variability that you want the expression to apply. The Min Opacity setting represents a percentage of the Opacity setting and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression on the Opacity panel, set the Opacity slider to 20%, and then set the Min Opacity slider to 50%, the opacity will vary from 10% to 20% every time you apply pressure during a brushstroke.

You can increase the variation of the opacity effect by adjusting Opacity Jitter, which enhances the natural appearance of brushstrokes. You can also use the Smoothness slider to smooth the opacity variation in a brushstroke for a more organic look.

-Digital Airbrush brushstrokes without Opacity Jitter (left) and with Opacity Jitter (right)
Audio Expression lets you link opacity to audio input from your microphone, or internal audio such as streaming music. The brushstroke becomes more or less opaque as the strength of the audio signal changes.

To set brush opacity
1. Choose Window ➔ Brush Control Panels ➔ Brush Media ➔ Opacity.
2. Move the Opacity slider to the left to reduce opacity, or to the right to increase opacity.

You can also

- Link the opacity settings to a specific stylus or mouse movement
  - Choose an option from the Expression list box.
- Set the percentage of variability that you want the expression to apply
  - Move the Min Opacity slider.
- Adjust the angle of the Direction expression
  - Move the Direction slider.
- Adjust the amount of variation that is applied to Opacity
  - Move the Opacity Jitter slider.
- Smooth the opacity variation
  - Move the Smoothness slider.
- Link opacity to audio
  - Click the Audio Expression button (Audio).
  - To choose an audio input and adjust audio settings, choose Window ➔ Audio ➔ Audio Settings Panel. For more information, see “Audio Expression” on page 374.

When adjusting Opacity Jitter, make sure the Min Opacity slider is not set to 100%. Setting the Min Opacity to 100% stops Opacity Jitter from occurring.

You can also set brush opacity dynamically onscreen. For more information, see “To set brush attributes onscreen” on page 305.
Grain controls

Grain lets you control the amount of paper texture that brushstrokes reveal. You can link grain to various stylus or mouse movements. For example, if you link grain to pressure, increasing the pressure causes the pencil to “dig into” the paper and produce a grainier brushstroke. For more information, see “Expression settings” on page 373. You can also specify the range of variability that you want the expression to apply by adjusting the Min setting. The Min Grain setting represents a percentage of the Grain setting, and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression on the Grain panel and set the Grain slider to 100% and the Min Grain slider to 10%, the amount of grain revealed will vary from 10% to 100% every time you apply pressure during a brushstroke. You can smooth the grain jitter in a brushstroke for a more organic look. You can also link grain to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

![Using Audio Expression to vary grain](image)

Normally, when you make a brushstroke, the paper grain is fixed, which means that the texture is in the same position. To get organic, non-repetitive looking marks, you can vary the paper grain position for each dab in a brushstroke (Random Grain Position) or rotate the paper grain for each new brushstroke (Random Grain Rotation).

![A brushstroke with Random Grain Position disabled (left) and enabled (right). Grain position varies from dab to dab within the brushstroke.](image)
Adjusting brushes with brush controls | 391

Brushstrokes with Random Grain Rotation disabled (left) and enabled (right). Grain rotation varies every time you lay down a brushstroke.

Varying grain position and rotation makes paper textures look more natural and helps reduce repetition with Captured dab brushes. Image by Karen Bonaker

In addition, you can use the paper’s brightness and contrast settings to control brush–grain interaction. For more information, see “Working with paper texture and grain” on page 165 and “Expression settings” on page 373.

To set grain
1. Choose Window ⏯ Brush Control Panels ⏯ Brush Media ⏯ Grain.
2. Move the Grain slider to adjust the penetration of a brushstroke into the grain.
You can also

- Link the grain settings to a specific stylus or mouse movement
  Choose an option from the Expression list box.

- Set the minimum level of grain a brushstroke reveals when linked to a specific stylus or mouse movement
  Move the Min Grain slider.

- Specify the angle at which a brushstroke shows grain
  Move the Direction slider.

- Set the amount of grain variation
  Move the Grain Jitter slider.

- Smooth the grain jitter in a brushstroke
  Move the Smoothness slider.

- Vary grain rotation within each brushstroke
  Enable the Random Grain Rotation check box.

- Vary grain position within each brushstroke
  Enable the Random Grain Position check box.

When adjusting Grain Jitter, make sure the Min Grain slider is not set to 100%. Setting the Min Grain to 100% stops Grain Jitter from occurring.

**Stroke Attributes controls**

You can apply a merge mode to a brush variant to control how brushstrokes interact with the underlying colors within the currently selected layer or the canvas. This technique allows you to produce similar results to applying composite method to layers. In addition, it allows you to control where the effect is applied. For more information about composite methods, see “Blending layers by using composite methods” on page 594.

You can set some stroke attributes on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

**To apply a merge mode**

1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Stroke Attributes.
2. Enable the Use Stroke Attributes check box.
4. From the Merge Mode list box, choose one of the following merge modes:

<table>
<thead>
<tr>
<th>Merge Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Creates a new color by combining the luminance of the underlying color with the hue and saturation of the brushstroke color. This method is the opposite of Luminosity.</td>
</tr>
<tr>
<td>Merge Mode</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Colorize</td>
<td>Replaces the hue and saturation of the underlying color with the hue and saturation of the brushstroke color. You can use this mode to apply color to a grayscale image.</td>
</tr>
<tr>
<td>Darken</td>
<td>Darkens the underlying color with the brushstroke color — whichever is darker</td>
</tr>
<tr>
<td>Default</td>
<td>Covers and hides the underlying brushstrokes</td>
</tr>
<tr>
<td>Difference</td>
<td>Subtracts one color from the other, depending on which color has a greater brightness value</td>
</tr>
<tr>
<td>Dissolve</td>
<td>Combines the underlying color with the brushstroke color, based on opacity</td>
</tr>
<tr>
<td>Gel</td>
<td>Tints the underlying color with the brushstroke color. For example, a yellow brushstroke gives the underlying color a yellow cast.</td>
</tr>
<tr>
<td>GelCover</td>
<td>Uses a combination of the Default method and the Gel method</td>
</tr>
<tr>
<td>Hard Light</td>
<td>Multiplies, or screens colors, depending on the luminance of the underlying color</td>
</tr>
<tr>
<td>Hue</td>
<td>Creates a color by combining the luminance and saturation of the underlying color with the hue of the brushstroke color</td>
</tr>
<tr>
<td>Lighten</td>
<td>Colors with the underlying color or the brushstroke color — whichever is lighter</td>
</tr>
<tr>
<td>Luminosity</td>
<td>Creates a new color from the hue and saturation of the underlying color and the luminance of the brushstroke color. This method is the opposite of Color.</td>
</tr>
<tr>
<td>Magic Combine</td>
<td>Combines the brushstroke color with the underlying color based on luminance. The parts of the brushstroke that are lighter than the underlying color are visible. The parts that are darker are replaced by the lighter area of the underlying color.</td>
</tr>
<tr>
<td>Multiply</td>
<td>Combines colors to create a darker color</td>
</tr>
<tr>
<td>Normal</td>
<td>Works like the Default method; the brushstroke covers the underlying color.</td>
</tr>
</tbody>
</table>
Merge Mode

Overlay
Combines colors while preserving the highlights and shadows of the underlying color.

Pseudocolor
Translates the brushstroke’s luminance into hue.

Reverse-Out
Inverts the colors beneath it.

Saturation
Creates a color by combining the luminance and hue of the image color with the saturation of the layer color.

Screen
Combines colors to create a lighter color.

Shadow Map
Blocks light and combines colors while preserving the shadows of the underlying color.

Soft Light
Darkens or lightens colors depending on the luminance of the underlying color.

Size controls

The Size brush controls determine how Corel Painter varies the width of the brushstroke.

Size lets you control the width of the brush and the brushstroke. As size changes, you may need to adjust the spacing controls for brushes that use nonrendered or dab-based dab types to prevent gaps from appearing in the stroke.

You can choose an Expression setting to create a brush that responds to subtle hand movements. For more information, see “Expression settings” on page 373. You can also adjust the Min setting to specify the range of variability that you want the expression to apply. The Min Size setting represents a percentage of the Size setting and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression on the Size panel, set the Size slider to 40 and set the Min Size slider to 50%, the stroke sizes will vary from 20% to 40% every time you apply pressure. The Min Size control allows you to create a brushstroke that is amazingly realistic. As stylus pressure eases, brushstrokes taper. As pressure increases, brushstrokes widen, just as they would with a real brush.
The minimum and maximum sizes of a stroke can be linked to Expression settings, such as pressure or velocity. The small black circle shows the minimum stroke size, and the gray circle shows the maximum stroke size.

The **Size Jitter** control lets you introduce more variation to the size of the brushstroke, which enhances the responsiveness and natural appearance of the brushstrokes. You can also use the **Smoothness** slider to smooth the size variation for a more organic look.

**Audio Expression** lets you link brush size to audio input from your microphone, or internal audio such as streaming music. The brushstroke becomes wider or narrower as the strength of the audio signal changes.

**Size Step** controls the transition between narrow and wide sections of a stroke.
To set brush size

1 Choose **Window ▶ Brush Control Panels ▶ Brush Shape ▶ Size**.
2 Move the **Size** slider to the right to make the brush larger, which makes the transition appear more abrupt. Move the slider to the left to make the brush smaller, which produces a smoother transition.

You can also

- Adjust the amount of variation that is applied to **Size**
  - Move the **Size Jitter** slider.

- Smooth the size variation
  - Move the **Smoothness** slider.

- Link size to audio
  - Click the **Audio Expression** button ( ).
  - To choose an audio input and adjust audio settings, choose **Window ▶ Audio ▶ Audio Settings Panel**. For more information, see “Audio Expression” on page 374.

- Link the size settings to a specific stylus or mouse movement
  - Choose an option from the **Expression** list box.

- Set the percentage of variability that you want the expression to apply
  - Move the **Min Size** slider.

- Adjust the angle of the **Direction** expression
  - Move the **Direction** slider.

You can also set the brush size dynamically onscreen. For more information, see “To set brush attributes onscreen” on page 305.

When adjusting **Size Jitter**, make sure the **Min Size** slider is not set to 100%. Setting the **Min Size** to 100% stops **Size Jitter** from occurring.

You can also change the brush size from the property bar by adjusting the **Size** slider ( ) or typing a value in the **Size** box.

To set stroke transition

1 Choose **Window ▶ Brush Control Panels ▶ Brush Shape ▶ Size**.
2 Move the **Size Step** slider to the right to increase the transition between brush sizes. Move it to the left to make the transitions smaller.

To switch the brush size preview mode

1 Choose **Window ▶ Brush Control Panels ▶ Dab Preview**.
2 Click the **Preview Size and Shape** button ( ).
Angle controls

The Angle controls let you change the shape of a brush. Some Angle controls work in conjunction with Expression settings. For more information, see “Expression settings” on page 373.

The Squeeze setting lets you control the shape of the brush dab. Squeezing a brush changes it from round to elliptical. You use the Squeeze controls with Circular and Captured dab types.

![Brushstrokes with Squeeze set to 100% (left) and 25% (right)](image)

This brushstroke created with Pen brush uses the Squeeze control to produce a calligraphy effect.

The Angle slider controls the angle of an elliptical brush dab and the length of the ellipse. It is significant only for dabs with Squeeze settings under 100%. You can use Angle controls with Circular and Captured dab types.

![Brushstrokes with Angle set to 90° (top) and 45° (bottom)](image)

The Angle Jitter control lets you introduce variation to the angle of the brushstrokes, which enhances their responsiveness and natural appearance. You can use the Smoothness slider to smooth the angle variation in a brushstroke for a more organic look.
Felt Marker brushstrokes without Angle Jitter (left) and with Angle Jitter (right)

Angle Jitter applied to a brushstroke without jitter smoothing (top) and with jitter smoothing (bottom)

Angle Jitter applied to an Image Hose brushstroke without jitter smoothing (top) and with jitter smoothing (bottom)

Audio Expression lets you link angle variation to audio input from your microphone, or internal audio such as streaming music. The dab angle changes in synch with the audio signal.

Changing dab angle in synch with audio

For dab-based brushes, the Ang Range setting lets you specify a range of dab angles that may appear in a brushstroke. To take advantage of this feature, you must use the Expression settings to base the angle on some factor, such as stroke direction or bearing. For more information, see “Expression settings” on page 373.

Brushstrokes with Ang Range set to 0° (left) and 180° (right)
For dab-based brushes, the Ang Step slider controls the increment of change for brushes with an Ang Range setting greater than 0°. For example, setting the Ang Step to 5° produces a brush dab every 5° within the current Ang Range setting.

To set brush shape
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Angle.
2. Move the Squeeze slider to the left to make the brush dab more elliptical. Move it to the right to make it rounder.

You can also change the brush shape dynamically onscreen. For more information, see “To set brush attributes onscreen” on page 305.

To apply an expression to the brush angle
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Angle.
2. Choose an option from the Expression list box.
   - If you want to switch the effect of the expression, click the Invert button.
   - If you chose Direction from the Expression list box, move the Direction slider until the desired angle is achieved.
   - To link the brush angle to an audio signal, click the Audio Expression button.

To set elliptical brush dab angle
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Angle.
2. Move the Angle slider to the right to rotate the dab counterclockwise. Move the slider to the left to rotate the brush clockwise.

To set brush dab angle range
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Angle.
2. Move the Ang Range slider to the right to increase the range of angles that can appear in a dab. Move the slider to the left to reduce the range of angles that can appear in a stroke.
   - Setting this slider to 360° allows for any angle in your stroke.

To set angle variation using jitter
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Angle.
   - To smooth the angle variation, move the Smoothness slider.
To set brush angle increment

1. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Angle.
2. Move the Ang Step slider to the right to produce fewer angles between dabs. Move it to the left to create more angles between dabs.

Spacing controls

When a brushstroke uses a dab-based dab type, Corel Painter creates the stroke with a series of dabs. By adjusting the spacing between those dabs, you can control the continuity of the brushstroke.

The Spacing control allow you to set the distance between brush dabs in a stroke. The Min Spacing slider specifies the minimum number of pixels between dabs. If you don’t want a continuous stroke, you can adjust the Min Spacing to create a dotted or dashed line. Each dot or dash represents one brush dab.

Brushstrokes with Min Spacing set to 2.0 (top) and 10.5 (bottom)

Continuous Time Deposition controls whether you must move a brush before a medium is applied. With Continuous Time Deposition enabled, the medium begins flowing at the first touch.

Brushes that use rendered dab types take full advantage of this setting, which causes the medium to pool realistically when the stroke is slowed or paused. Brushes that use dab-based dab types require a full pause in the stroke before the medium begins to pool. You use Continuous Time Deposition mostly with airbrush tools.

With Continuous Time Deposition disabled, you must move a brush before the medium flows.

Boost allows you to optimize the performance of brushstrokes. However, a high-boost level may produce a less accurate brushstroke that appears a little jagged. This setting applies only to specific brush dab types, such as Flat and Camel hair.

To set spacing between brush dabs

1. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Spacing.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increase the distance between dabs</td>
<td>Move the Spacing slider to the right.</td>
</tr>
<tr>
<td>Decrease the distance between dabs</td>
<td>Move the Spacing slider to the left until the dabs begin to overlap. Overlapping increases the density of the stroke and makes it look more continuous.</td>
</tr>
</tbody>
</table>
To adjust brushes with brush controls:

To set the size of the dab to equal the spacing:
Set the size of the dab to equal the spacing. Move the Spacing slider to the right to 100%. For example, a dab that is 10 pixels across is repeated every 10 pixels.

To set minimum dab spacing:
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing.
2. Move the Min Spacing slider to the right to increase the minimum spacing between dabs. Move it to the left to decrease the minimum spacing between dabs.

To set continuous time deposition:
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing.
2. Enable the Continuous Time Deposition check box.

To boost brushstrokes:
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing.
2. Move the Boost slider to the right to increase brush performance. Move it to the left to decrease brush performance.

Starting with low boost values (under 10%) can significantly increase brush performance.

Changing dab profiles:
The Dab Profile panel displays a selection of dab profiles that you can apply to your brushes. Each brush tip profile shows a cross-section of density distribution across the diameter of the dab. You can think of a brush tip profile as a bell-curve graph representing the density spread across the brush dab.

Different media have different density distributions. Changes in the density distribution produce different marking qualities in a brushstroke. For rendered airbrush dab types, the brush tip profile controls the concentration of the spray.

Each Corel Painter brush uses one of the following brush tip profiles:

<table>
<thead>
<tr>
<th>Profile</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointed Profile</td>
<td>Provides maximum density at the center, with rapid falloff to the edge.</td>
</tr>
<tr>
<td>Medium Profile</td>
<td>Has a wide area of greater density at the center, with rapid falloff to the edge.</td>
</tr>
<tr>
<td>Linear Profile</td>
<td>Provides maximum density at the center, with even falloff to the edge.</td>
</tr>
</tbody>
</table>
### Corel Painter 2020 User Guide

**Profile**

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dull Profile</strong></td>
</tr>
<tr>
<td><strong>Watercolor Profile</strong></td>
</tr>
<tr>
<td><strong>1-Pixel Edge</strong></td>
</tr>
</tbody>
</table>

### Artists' Oils brush tip profiles

There are six brush tips designed specifically for Artists' Oils brushes. You can also use any brush tip, listed in the table above, with Artists' Oils brushes.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Artists' Oils profile</strong></td>
</tr>
<tr>
<td><strong>Soft Round</strong></td>
</tr>
<tr>
<td><strong>Pointed Rake</strong></td>
</tr>
<tr>
<td><strong>Flat Rake</strong></td>
</tr>
<tr>
<td><strong>Flat</strong></td>
</tr>
<tr>
<td><strong>Chisel</strong></td>
</tr>
<tr>
<td><strong>Wedge</strong></td>
</tr>
</tbody>
</table>
Hard Media Profiles

There are six tip profiles designed specifically for the **Hard Media** variants.

<table>
<thead>
<tr>
<th>Hard Media profile</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pencil Profile</td>
<td>Provides a sharper tip when perpendicular to the tablet and a wider, softer tip when at an angle.</td>
</tr>
<tr>
<td>Medium Profile</td>
<td>Has a wide area of greater density at the center, with rapid falloff toward the edge.</td>
</tr>
<tr>
<td>Linear Profile</td>
<td>Provides maximum density at the center, with even falloff toward the edge.</td>
</tr>
<tr>
<td>Pointed Profile</td>
<td>Provides maximum density at the center, with rapid falloff toward the edge.</td>
</tr>
<tr>
<td>Dull Profile</td>
<td>Provides maximum density at the center, with high-density weighting toward the edge.</td>
</tr>
<tr>
<td>1-Pixel Edge</td>
<td>Provides maximum density throughout, with rapid falloff toward the edge, producing a 1-pixel, anti-aliased edge.</td>
</tr>
</tbody>
</table>

To choose a brush tip profile

1. Choose **Window ➤ Brush Control Panels ➤ Brush Shape ➤ Dab Profile**.
2. In the **Dab Profile** panel, click a brush tip profile icon.

**Jitter controls**

Corel Painter includes a collection of Jitter brushes that let you introduce a range of random behaviors to brushstrokes to produce more realistic results. You can use the preset Jitter brush variants and adjust them as needed. You can also save these customized brushes as new Jitter brush variants.

Corel Painter includes several preset Jitter brush variants. You can use the variants as they are or customize them by using the Jitter controls to build your own Jitter brushes.
An example of the Impressionist brush variant (no Jitter) (left) and the Impressionist Blender Jitter brush variant (right) that has Opacity Jitter and Color Jitter.

The Jitter brush variants are found in many different brush categories. The easiest way to find a Jitter brush variant is to use the Search bar.

You can control the amount of Jitter a brush produces. The Jitter controls that you can modify are determined by the Jitter brush variant that you choose. For example, if you choose the Coarse Spray Jitter brush variant from the Airbrushes category, you can adjust the following Jitter controls: Size Jitter (Size brush control panel), Feature Jitter and Flow Jitter (Airbrush brush control panel), Opacity Jitter (Opacity brush control panel), and Stroke Jitter (Stroke Jitter brush control panel).

To quickly find the Jitter brush controls for a selected brush, you can let Corel Painter generate a group of all the relevant brush controls panels for your selected brush variant. This narrows down your search for Jitter controls by limiting the number of brush control panels that are available for your selected brush. For more information, see “Working with brushes using the property bars” on page 306.

The following table lists all of the brush control panels that include Jitter controls and where you can find more detailed information about these brush controls in the Help.

<table>
<thead>
<tr>
<th>Brush control panel with Jitter controls</th>
<th>For more information, see</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opacity</td>
<td>“Opacity controls” on 388</td>
</tr>
<tr>
<td>Grain</td>
<td>“Grain controls” on 390</td>
</tr>
<tr>
<td>Size</td>
<td>“Size controls” on 394</td>
</tr>
<tr>
<td>Angle</td>
<td>“Angle controls” on 397</td>
</tr>
<tr>
<td>Airbrush</td>
<td>“Airbrush controls” on 416</td>
</tr>
<tr>
<td>Impasto</td>
<td>“Impasto controls” on 421</td>
</tr>
<tr>
<td>Color Expression</td>
<td>“Color Expression controls” on 441</td>
</tr>
<tr>
<td>Stroke Jitter</td>
<td>“Stroke Jitter controls” on 430</td>
</tr>
</tbody>
</table>

To find a Jitter variant

1. On the Search bar, type jitter in the Search text box, and press Enter.
   The Search bar is located to the right of the property bar, in the upper-right corner of the document window.
2. Click a Jitter brush variant in the list of search results.
Real Watercolor controls

The Corel Painter Real Watercolor brush controls help you achieve very realistic watercolor brushstrokes. The controls simulate working with a watercolor brush, watercolor paper, pigments, and a glass of water. You can adjust pigment levels and water consistency to achieve natural flow and pigment settling effects. The following section describes the Real Watercolor brush controls in more detail.

Brush controls

The Real Watercolor brush-related controls let you set the amount of water and pigment that the brush deposits on the paper.

![Brushstrokes set at a lower Wetness setting (left) and higher Wetness setting (right)](image)

Water controls

The Real Watercolor water-related controls let you adjust the water viscosity, or thickness, in order to control the way it flows and spreads on the surface of the paper. For example, if the water viscosity is high, it will produce a runny effect and the water will flow and spread easily. If the water viscosity is low and thick, it will have a tendency to pool, instead of flow. You can also adjust the speed at which the water dries, which influences how and where the pigment settles on the paper.

![Brushstrokes set at a lower Viscosity setting (left) and higher Viscosity setting (right)](image)

Flow controls

The Flow controls let you enable and choose flow maps, so you can introduce an additional surface texture that promotes greater water displacement. For more information, see "Getting started with flow maps" on page 505. You can also adjust the Flow Resistance to control the effect the paper grain or flow map texture has on the direction of the water flow.

![Brushstrokes set at a lower Flow Resistance setting (left) and higher Flow Resistance setting (right)](image)
Pigment controls

The Pigment controls let you adjust how much pigment is deposited on the paper after the water evaporates and how quickly the pigment settles on the paper. You can also specify the degree to which water is able to lift dry pigment from the paper.

![Brushstrokes set at a higher Settling Rate (left) and a lower Settling Rate (right)]

Paper controls

With the Paper controls, you can adjust how the Real Watercolor brushes interact with paper texture and grain. You can adjust the paper roughness, which affects all other paper settings.

![Brushstrokes set at a lower Roughness setting (left) and higher Roughness setting (right)]

In addition, you can set the rate at which the paper grain can absorb water and control the amount of pigment that settles into the valleys of the paper grain when it dries.

Wind controls

The Wind controls let you control the angle at which water flows on the paper. You can also specify the amount of wind force exerted on the water.

![Brushstrokes set at a lower Angle and Force settings (left) and higher Angle and Force settings (right)]

Diffusion controls

The diffusion controls allow you to manage how and when the pigment is diffused on the paper. You can specify that diffusion be precisely applied to ensure accurate water flow. You can also delay diffusion so the effect is applied only after you complete a brushstroke. In addition, you can choose to suspend diffusion temporarily. This lets you apply multiple brushstrokes to the paper before applying the diffusion, to apply the effect to all brushstrokes at once. You can also specify the number of flow steps to be completed during animation. This controls the rate at which the visual flow of the pigment refreshes onscreen. For example, you can specify a lower number of steps for smaller brushes and a higher number of steps for bigger brushes.

For a list of sample Real Watercolor brushstrokes, see “Real Watercolor” on page 351.
To adjust the Real Watercolor controls

1. Choose **Window ▶ Brush Control Panels ▶ Brush Media ▶ Real Watercolor**.

2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the amount of water the brush deposits on the paper</td>
<td>In the <strong>Brush</strong> area, move the <strong>Wetness</strong> slider to adjust the amount of water.</td>
</tr>
<tr>
<td>Set the amount of pigment the brush deposits on the paper</td>
<td>In the <strong>Brush</strong> area, move the <strong>Concentration</strong> slider to adjust the amount of pigment.</td>
</tr>
<tr>
<td>Adjust the water thickness to control the way it flows and spreads on the surface of the paper</td>
<td>In the <strong>Water</strong> area, move the <strong>Viscosity</strong> slider to adjust the thickness.</td>
</tr>
<tr>
<td>Adjust the speed at which the water dries</td>
<td>In the <strong>Water</strong> area, move the <strong>Evaporation Rate</strong> slider to adjust the effect.</td>
</tr>
<tr>
<td>Adjust the degree to which the flow map surface, or the paper texture, affects the direction of the water flow</td>
<td>In the <strong>Flow</strong> area, move the <strong>Flow Resistance</strong> slider to adjust the effect.</td>
</tr>
<tr>
<td>Adjust the amount of pigment deposited on the paper after the water evaporates</td>
<td>In the <strong>Pigment</strong> area, move the <strong>Settling Rate</strong> slider to adjust the amount of pigment.</td>
</tr>
<tr>
<td>Control how quickly the pigment settles on the paper</td>
<td>In the <strong>Pigment</strong> area, move the <strong>Weight</strong> slider to the left to achieve a lighter pigment or to the right to achieve a heavier pigment. A lighter weight pigment flows with the water longer, whereas a heavier pigment settles onto the paper very quickly.</td>
</tr>
<tr>
<td>Specify the degree to which water is able to lift dry pigment from the paper</td>
<td>In the <strong>Pigment</strong> area, move the <strong>Pickup</strong> slider to adjust the amount of pigment pickup.</td>
</tr>
<tr>
<td>Adjust the paper roughness</td>
<td>In the <strong>Paper</strong> area, move the <strong>Roughness</strong> slider to the left to decrease the paper roughness or to the right to increase the paper roughness. This impacts flow resistance, dry rate, and pigment granulation.</td>
</tr>
<tr>
<td>Adjust the rate at which the paper grain can absorb water</td>
<td>In the <strong>Paper</strong> area, move the <strong>Dry Rate</strong> slider to the left to decrease the speed of absorption or to the right to increase the speed of absorption.</td>
</tr>
<tr>
<td>Control the amount of pigment that settles into the valleys of the paper grain when it dries</td>
<td>In the <strong>Paper</strong> area, move the <strong>Granulation</strong> slider to adjust the effect.</td>
</tr>
<tr>
<td>Control the angle at which water flows on the paper</td>
<td>In the <strong>Wind</strong> area, move the <strong>Angle</strong> slider to adjust the angle.</td>
</tr>
</tbody>
</table>
To specify the amount of wind force exerted on water, which affects the way it flows on the paper, do the following:

- In the **Wind** area, move the **Force** slider to adjust the force.

You can optimize the performance of **Real Watercolor** and **Real Wet Oil** brushes by temporarily disabling **High Quality Display**. Click the **Magnifier** tool in the toolbox, and click the **High Quality Display** button on the property bar.

### To apply a flow map when using a Real Watercolor brush

1. In the Brush library panel, choose a Real Watercolor brush variant.
2. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Media** ➤ **Real Watercolor**.
3. In the **Flow** area, enable the **Flow Map** option to set the **Source**.

To maximize the effect of flow maps, you need to ensure that the **Wetness** control is set high and the **Evaporation Rate** control is set low.

### To control Real Watercolor diffusion

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Media** ➤ **Real Watercolor**.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply diffusion precisely to ensure accurate water flow</td>
<td>Enable the <strong>Accurate Diffusion</strong> check box.</td>
</tr>
<tr>
<td>Delay diffusion until the brushstroke is complete</td>
<td>Enable the <strong>Delay Diffusion</strong> check box.</td>
</tr>
<tr>
<td>Suspend diffusion temporarily</td>
<td>Enable the <strong>Pause Diffusion</strong> check box or click the <strong>Pause Diffusion</strong> button on the property bar to suspend the diffusion. You need to disable the check box to perform the diffusion.</td>
</tr>
<tr>
<td>Specify the speed at which the pigment is revealed onscreen</td>
<td>Move the <strong>Animation Step</strong> slider to the left to lower the speed of the animation or to the right to increase the speed. Specifying a lower <strong>Animation Step</strong>, such as 0, produces a smoother effect.</td>
</tr>
</tbody>
</table>

### Real Wet Oil controls

The **Real Wet Oil** brush variants help you achieve realistic oil brushstrokes. For example, you can control paint viscosity and color concentration, similar to mixing oil paint and a medium. The following section describes the **Real Wet Oil** brush controls in more detail.
Brush controls

The Real Wet Oil brush-specific controls let you set the amount of liquid and paint that the brush deposits on the canvas.

Brushstrokes set at a lower Wetness setting (left) and higher Wetness setting (right)

Liquid Flow controls

The Liquid Flow controls let you adjust the liquid viscosity, or thickness, in order to control the way it’s applied to the canvas. For example, if the liquid viscosity is high, the paint spreads easily and looks smooth. If the liquid viscosity is low and thick, the paint does not spread as easily and creates the illusion of texture.

Brushstrokes set at a lower Viscosity setting (left) and higher Viscosity setting (right)

You can also adjust the speed at which the liquid evaporates, which influences how the paint dries on the canvas.

Brushstrokes set at a lower Evaporation Rate (left) and higher Evaporation Rate (right)

Flow controls

The Flow controls let you enable and choose flow maps, so you can introduce an additional surface texture to promote greater liquid displacement. For more information, see “Getting started with flow maps” on page 505. You can also adjust the flow resistance to control how paint spreads on the canvas or flow map.

Brushstrokes set at a lower Flow Resistance setting (left) and higher Flow Resistance setting (right)
Paint controls

The Paint controls let you modify the look and feel of paint on the canvas. For example, you can adjust the opacity of the paint deposited on the canvas after the oil dries. You can also specify how easily the paint blends and the degree to which oil is able to lift dry paint from the canvas.

Canvas controls

With the canvas controls, you can adjust how the Real Wet Oil brushes interact with canvas texture and grain. For example, you can adjust the canvas roughness, which affects all other canvas settings.

Wind controls

The Wind controls let you set the angle at which the paint spreads on the canvas. You can also specify the amount of wind force exerted on the paint.

Diffusion controls

The Diffusion controls allow you to manage how and when the paint is diffused on the canvas. You can specify that diffusion be precisely applied to ensure accurate paint dispersion. You can also delay diffusion so the effect is applied only after you complete a brushstroke. In addition, you can choose to suspend diffusion temporarily. This lets you apply multiple brushstrokes to the canvas before applying the diffusion, to apply the effect to all brushstrokes at once. You can also specify the number of flow steps to be completed during animation. This controls the rate at which the visual flow of the paint refreshes onscreen. For example, you can specify a lower number of steps for smaller brushes and a higher number of steps for bigger brushes.
You can set some Real Wet Oil options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

For a list of sample Real Wet Oil brushstrokes, see “Real Wet Oil” on page 353.

**To adjust the Real Wet Oil controls**

1. Choose `Window` > `Brush Control Panels` > `Brush Media` > `Real Wet Oil`.

2. Perform an action from the following table.

| To set the amount of oil the brush deposits on the canvas | In the `Brush` area, move the `Wetness` slider to adjust the amount of liquid. |
| Set the concentration of paint the brush deposits on the canvas | In the `Brush` area, move the `Concentration` slider to adjust the amount of pigment. |
| Adjust the oil thickness to control the way it spreads on the surface of the canvas | In the `Liquid Flow` area, move the `Viscosity` slider to adjust the viscosity effect. |
| Adjust the speed at which the paint dries | In the `Liquid Flow` area, move the `Evaporation Rate` slider to adjust the effect. |
| Adjust the degree to which the flow map surface, or the paper texture, affects the direction of the water flow | In the `Flow` area, move the `Flow Resistance` slider to adjust the effect. |
| Adjust the opacity of the paint deposited on the canvas after the oil dries | In the `Paint` area, move the `Settling Rate` slider to the left to decrease the amount of paint (more opacity) or to the right to increase the amount of paint (less opacity). |
| Control how easily the paint colors mix on the canvas | In the `Paint` area, move the `Blend Rate` slider to the left to decrease the blending capacity or to the right to increase the blending capacity. |
| Specify the degree to which oil is able to lift dry paint from the canvas | In the `Paint` area, move the `Pickup` slider to adjust the amount of paint pickup. |
| Adjust the canvas roughness | In the `Canvas` area, move the `Roughness` slider to the left to decrease the canvas roughness or to the right to increase the canvas roughness. (This impacts flow resistance, dry rate, and paint granulation.) |
| Control the effect canvas grain has on the direction of the paint flow | In the `Canvas` area, move the `Flow Resistance` slider to adjust the flow resistance. |
| Adjust the rate at which the canvas grain can absorb paint | In the `Canvas` area, move the `Dry Rate` slider to adjust the speed of absorption. |
To

Control the degree to which paint settles into the valleys of the canvas grain when it dries

Control the angle at which paint spreads on the canvas

Specify the amount of wind force exerted on paint, which affects the way it spreads on the canvas

💡

You can improve the appearance of the visual flow of paint onscreen by clicking the Magnifier tool in the toolbox, and disabling the High Quality Display button on the property bar.

To apply a flow map when using a Real Wet Oil brush

1 In the Brush library panel, choose a Real Wet Oil brush variant.
2 Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Real Wet Oil.
3 In the Flow area, enable the Flow Map option to set the Source.

💡

To maximize the effect of flow maps, you need to ensure that the Wetness control is set high and the Evaporation Rate control is set low.

To control Real Wet Oil diffusion

1 Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Real Wet Oil.
2 Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply diffusion precisely to ensure accurate water flow</td>
<td>Enable the Accurate Diffusion check box.</td>
</tr>
<tr>
<td>Delay diffusion until the brushstroke is complete</td>
<td>Enable the Delay Diffusion check box.</td>
</tr>
<tr>
<td>Suspend diffusion temporarily</td>
<td>Enable the Pause Diffusion check box to suspend the diffusion. You need to disable the check box to perform the diffusion.</td>
</tr>
<tr>
<td>Specify the speed at which the paint is revealed onscreen</td>
<td>Move the Animation Step slider to the left to lower the speed of the animation or to the right to increase the speed. Specifying a lower Animation Step, such as 0, produces a smoother effect.</td>
</tr>
</tbody>
</table>
Computed Circular controls

The Computed Circular controls allow you to specify the tip profile of brushes using the Computed Circular dab type. For example, you can customize the dab opacity and hardness, which controls the color density at the outer edge of the dab.

You can set some Computed Circular controls on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

To customize a Computed Circular dab profile

1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Computed Circular.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify dab opacity</td>
<td>Move the Dab Opacity slider to the left to reduce the opacity. Move it to the right to increase the opacity.</td>
</tr>
<tr>
<td>Control the color density at the edge of the dab</td>
<td>Move the Dab Hardness slider to the left to reduce the color density and create a soft dab. Move it to the right to increase the color density and create a hard dab.</td>
</tr>
</tbody>
</table>

Hard Media controls

The Hard Media controls let you customize drawing and sketching tools with more precision. You can adjust several Hard Media variants, which include blenders, pencils, chalks, Conté, crayons, pastels, markers, and erasers. The Hard Media controls can be used only with the Circular, Captured, and Eraser dab types. For more information, see “Hard Media” on page 511.

Bristle controls

The Bristle controls allow you to adjust the appearance of bristle brushes, such as Camel Hair, Flat, Palette Knife, and Bristle Spray. You can specify the number of bristles, or bristle density (Feature). You can also control how far the bristles spray out, or fan out, when applying brushstrokes (Spread). This control is linked to the Tilt expression. For example, the more you tilt the stylus, the greater the bristles will fan out.

You can also specify that bristles scale relative to the size of the brush. This ensures that the feature is distributed proportionally to match the size of the brush.

You can set some bristle options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

To adjust bristle controls

1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Bristles.
2. Perform an action from the following table:
To Do the following

Specify the number of bristles
Move the Feature slider. The higher the setting, the denser the brush bristles.

Adjust the fanning of the bristles
Move the Spread slider. This control is linked to the Tilt expression.

To scale bristles with the brush size
1 Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Bristles.
2 Enable the Scale Feature with Brush Size check box.

You can also scale a brushstroke’s features with the brush size by clicking the Scale Feature with Brush Size button on the Brush property bar.

You can also disable the scaling option in all areas by choosing Corel Painter 2020 menu ➤ Preferences ➤ General (macOS) or Edit ➤ Preferences ➤ General (Windows), and enable the Disable feature scaling when resizing brush.

RealBristle controls

RealBristle controls let you choose a brush tip profile, adjust the brush, and determine how the brush interacts with the surface of the canvas. For more information about RealBristle controls, see “Modifying RealBristle settings” on page 534.

Static Bristle controls

The Static Bristle controls help you create the look of a real brushstroke, complete with the striations that hairs on a real brush make. Use the Static Bristle controls to design the individual bristles in a single brush dab.

You can also preview a “soft” view of the dab to display how the bristle dabs change. For more information, see “To switch the brush size preview mode” on page 396.

If you choose Rake as the stroke type, you can adjust brush scale and contact angle. For more information, see “Rake controls” on page 436.

The Thickness slider controls the diameter of separate bristles.

Brushstrokes with Thickness set to 17% (left) and 87% (right)

Clumpiness lets you control how bristles adhere to each other by applying a random variance to the thickness of each bristle, which makes some of the bristles look like they are clumping together. Clumpiness is proportional to Thickness.
The **Hair Scale** lets you control the density of bristles in the brush dab and, therefore, the number of bristles in the dab.

**Scale/Size** lets you control the degree of size variation applied to the bristles of a brush. At 0%, there is no size change applied to the bristles. Setting this slider to a value greater than 0% creates a set of scaled iterations of the dab.

At a **Scale/Size** setting of 100%, when the brush size changes, the bristles scale in proportion to the size. At a **Scale/Size** setting of 8%, when the brush size changes, the bristles remain a constant absolute size. The **Scale/Size** control is invalid if a size range is not specified (that is, if **Min Size** is set to 100%).

**To set bristle thickness**

1. Choose **Window ▶ Brush Control Panels ▶ Brush Shape ▶ Static Bristle**.
Move the **Thickness** slider to the left to reduce the density of the medium left by the stroke. Move it to the right to increase brush density.

When the slider is moved fully to the left, the brush leaves a faint stroke — even if **Opacity** is set to 100%.

### To set clumping of bristles

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Static Bristle**.
2. Move the **Clumpiness** slider to the left to reduce bristle clumping. Move it to the right to increase bristle clumping.

### To set bristle density

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Static Bristle**.
2. Move the **Hair Scale** slider to the left to reduce the amount of bristle density and create a fine-hair brush. Move it to the right to increase density.

### To scale bristles according to brush size

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Static Bristle**.
2. Move the **Scale/Size** slider to the left to reduce the degree of size variation. Move it to the right to increase size variation.

### Airbrush controls

The **Airbrush** controls allow you to adjust the amount and the displacement of the media that is applied by an airbrush.

**Feature** lets you set the maximum size of the individual droplets.

**Flow** controls how much media is applied by an airbrush stroke. The **Flow** control acts like the needle control on a real airbrush. Because the airbrush dab types deposit many small dabs to create their spray-paint look, you might need to cut down on the flow to speed up the airbrush.

You can also link the **Flow** and **Feature** controls to a specific stylus or mouse movement. You can choose different **Expression** settings for each. For example, you can link **Flow** to the **Pressure** expression and link **Feature** to the **Tilt** expression. In addition, you can link the **Flow** and **Feature** controls to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

You can also adjust the **Min** setting to specify the range of variability that you want the expression to apply. The **Min Flow** and **Min Feature** settings represent a percentage of the **Flow** and **Feature** settings and they must be linked to an expression to have an effect. For example, if you link the **Pressure** expression to the **Flow** control, set the **Flow** slider to 40% and set the **Min Flow** slider to 50%, the amount of flow will vary from 20% to 40% every time you apply pressure with the stylus.
Spread controls how paint spreads out as it is applied. In other words, it sets the size of the cone of spread from the tip of the airbrush or spray can. A good range for the Spread setting is 30% to 40%. Narrow settings for Spread and Angle can cause problems. Narrow settings for Spread and Tilt can cause paint to be deposited away from the cursor.

Flow Jitter and Feature Jitter let you adjust the amount of variation that you want these controls to apply when using the airbrush, which produces more realistic results. You can use the Smoothness sliders to smooth the jitter for a more organic look.

You can set some Airbrush options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.
For a list of sample Airbrush brushstrokes, see "Airbrushes" on page 319.

**To set the size of individual droplets**

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Airbrush**.
2. Move the **Feature** slider to set the maximum size of individual droplets. The higher the setting, the bigger the paint droplets.

**You can also**

- Set the minimum size of the individual droplets: Move the **Min Feature** slider.
- Specify the range of variation that is applied to the size of the droplets: Move the **Feature Jitter** slider.
- Smooth the variation in the droplet size: Move the **Smoothness** slider.
- Link the droplet size to a specific stylus or mouse movement: Choose an option from the **Expression** list box.
- Specify the angle at which the droplet size starts to vary: Move the **Direction** slider.

> When adjusting **Feature Jitter**, make sure the **Min Feature** slider is not set to 100%. Setting the **Min Feature** to 100% stops **Feature Jitter** from occurring.

**To set paint spread**

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Airbrush**.
2. Move the **Spread** slider to the left to reduce the amount of spread, or to the right to increase the amount of spread.

**To set the amount of media to apply with a brushstroke**

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Shape** ➤ **Airbrush**.
2. Move the **Flow** slider to the left to reduce the amount of media applied with a stroke, or to the right to increase it.

**You can also**

- Specify the minimum amount of media to apply with a brushstroke: Move the **Min Flow** slider.
- Specify the range of variation that is applied to the media flow: Move the **Flow Jitter** slider.
- Smooth the variation in the paint flow: Move the **Smoothness** slider.
- Link the media flow controls to a specific stylus or mouse movement: Choose an option from the **Expression** list box.
You can also

Specify the angle at which the paint flow starts to vary Move the Direction slider.

When adjusting Flow Jitter, make sure the Min Flow slider is not set to 100%. Setting the Min Flow to 100% stops Flow Jitter from occurring.

Artists’ Oils controls

The Artists’ Oils controls are divided into three components: Paint, Brush, and Canvas. You can control Artists’ Oils brush size and opacity with a tablet expression. For more information, see “Expression settings” on page 373.

The Grain slider on the General panel affects the look of Artists’ Oils by controlling the level at which paper absorbs paint. When the Grain slider is set to 0%, the paper absorbs a very limited amount of paint; no paper grain is visible in the stroke and the paint color appears lighter. When Grain is set to 100%, the paper completely absorbs the paint; no paper grain is visible, and the paint color appears darker. Grain is visible with Artists’ Oils when Grain is set between 1% and 99%. As an Artists’ Oils brush runs out of paint, paper grain becomes more visible, so Amount also affects how much grain appears.

Artists’ Oil brushes hold a finite amount of paint. As the paint runs out, the stroke becomes fainter.

Paint

Amount determines how much paint is loaded before each new brushstroke. The more paint you load, the longer the brushstroke lasts.

Viscosity controls the rate at which a brush runs out of paint. The higher the viscosity, the faster the brush runs out of paint, creating shorter brushstrokes.

Blend controls how the paint color mixes with paint already on the canvas. High blend levels allow paint on the brush to blend easily with existing paint.

Brush

Bristling controls the amount of bristling at the tail and tip of a brushstroke. For example, you can adjust bristling to increase the irregularity of the brush bristles.

Clumpiness controls brush bristle fineness. For example, you can increase the amount of brush hair variation, or clumpiness.
Trail-off determines the length of a brushstroke tail when the brush is running out of paint. This doesn’t change the length of the brushstroke, just the look of the end of the stroke. For example, you can adjust the trail-off to produce a longer trail-off effect of the brushstroke tail.

Canvas

Wetness determines the wetness of the paint on the canvas. This affects how paint from a brushstroke interacts with paint already on the canvas.

Painting in Dirty Mode

Painting in Dirty Mode allows you to further replicate the experience of using artists’ oil paints in the real world. In this mode, any paint remaining on the brush upon completion of a brushstroke is left to interact with paint loaded for the next brushstroke. When you select another color, the brush is cleared of remaining paint.

You can set some Artists’ Oils controls on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

For a list of sample Artists’ Oils brushstrokes, see “Artists’ Oils” on page 321.

To set the amount of Artists’ Oils paint loaded

1. With an Artists’ Oils brush selected, choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Artists’ Oils.
   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.
2. Move the Amount slider to the right to increase the amount of paint loaded for each brushstroke.

To set the viscosity of Artists’ Oils paint

1. With an Artists’ Oils brush selected, choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Artists’ Oils.
   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.
2. Move the Viscosity slider to the right to increase the rate at which a brush runs out of paint.

   It is important to note that higher viscosity settings make for a shorter brushstroke.

To set Artists’ Oils paint blending

1. With an Artists’ Oils brush selected, choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Artists’ Oils.
   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.
2. Move the Blend slider to the right to increase the blending of brushstroke paint and existing paint.

   You can also set how Artists’ Oils paint blend on the Blend slider on the Artists’ Oils property bar.

To set Artists’ Oils brush bristling

1. With an Artists’ Oils brush selected, choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Artists’ Oils.
   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.
2. Move the Bristling slider to the right to increase the length of the bristling at the tip and tail of the brushstroke.
To set Artists’ Oils brushstroke trail-off

1. With an Artists’ Oils brush selected, choose Window > Brush Control Panels > Brush Media > Artists’ Oils.

   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.

2. Move the Trail-off slider to the right to increase the length of a brushstroke tail when the brush is running out of paint.

To set canvas wetness for Artists’ Oils

1. With an Artists’ Oils brush selected, choose Window > Brush Control Panels > Brush Media > Artists’ Oils.

   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.

2. Move the Wetness slider to the right to increase the mixing of brushstroke color and existing color.

You can also set how Artists’ Oils paints blend on the Blend slider on the Artists’ Oils property bar.

To paint in Dirty Mode

1. With an Artists’ Oils brush selected, choose Window > Brush Control Panels > Brush Media > Artists’ Oils.

   If the controls on the Artists’ Oils panel are not available (appear gray), the selected Oils brush variant is not supported by the Artists’ Oils controls. For example, any Oils brush variant name that begins with Real are supported brush variants.

2. Enable the Dirty Mode check box to allow the paint that remains on the brush after you complete a brushstroke to mix with the paint loaded for the next brushstroke.

Impasto controls

The Impasto brush controls let you modify and create brush variants that give the illusion of depth. The controls allow you to choose different methods for applying and controlling the appearance of depth. For more information, see “Impasto” on page 559 and “Adjusting and creating Impasto brushes” on page 560.

Some Impasto controls work in conjunction with Expression settings. For more information, see “Expression settings” on page 373.

Digital Watercolor controls

Digital Watercolor controls let you create effects similar to those of watercolor brushes without requiring a separate layer.

You can use Diffusion to create soft, feathery edges on the brushstrokes.

Wet Fringe controls the amount of pooling of water and paint at the edges of Digital Watercolor brushstrokes. For more information about wet fringe, see “Working with Digital Watercolor brushes” on page 464.

Water controls

Water controls work with Watercolor layers. A Watercolor layer is automatically created when you apply a stroke with a Watercolor brush. The layer can be edited from the Layers panel.

Wetness controls the dilution and the spread of paint. As Wetness is increased, the resulting stroke expands over a larger area, eliminating the appearance of brush hairs.
Pickup controls how much dry paint gets picked up during diffusion. Lower values mean that there is no mixing or leaching of paints. Higher values produce more leaching.

Dry Rate controls the rate at which water dries during diffusion. Lower values cause greater spread; higher values reduce the amount of spread.

The evaporation threshold (Evap Thresh slider) controls the minimum amount of water that can still diffuse. Lower values cause greater spread; higher values reduce the amount of spread.
The diffusion setting (Diffuse Amt slider) controls the amount of paint diffused. Using high diffusion creates soft edges that feather into the grain, as though you were painting on wet absorbent paper. Using low diffusion is similar to painting on dry paper.

The capillary factor (Cap Factor slider) controls the grain’s effect on diffusion. Lower values result in a smoother edge.

The grain soak-in (Gn Soak-In slider) controls the amount of paint that soaks into the grain when paint is drying. You can lower both capillary factor and grain soak-in values to reduce grain effects.

Enable the Accurate Diffusion check box to use a smaller diffusion window. Disabling Accurate Diffusion results in a larger, less accurate window being used.
You can specify the amount of wind force exerted on the diffusing particles. Set the **Wind Force** to zero to turn off directional diffusion.

![Brushstrokes with Wind Force set to 0% (top) and 25% (bottom)](image)

You can specify wind direction, which controls the direction in which the particles diffuse. This can be used to simulate tilting of a wet watercolor image to introduce the paint migration effects of gravity.

![Brushstrokes with Wind Angle set to 270° (top) and 180° (bottom)](image)

You can set some watercolor options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

For a list of sample Digital Watercolor brushstrokes, see “Digital Watercolor” on page 331.

**To adjust watercolor controls**

1. Choose **Window** ➤ **Brush Control Panels** ➤ **Brush Media** ➤ **Watercolor**.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust wetness</td>
<td>Move the <strong>Wetness</strong> slider to the left to create a more uniform brushstroke, or to the right to have the water flow more in the direction of the wind.</td>
</tr>
<tr>
<td>Set paint pickup</td>
<td>Move the <strong>Pickup</strong> slider to the right to increase the amount of leaching, or to the left to reduce it.</td>
</tr>
<tr>
<td>Set the dry rate</td>
<td>Move the <strong>Dry Rate</strong> slider to the right to reduce the amount of spread, or to the left to increase it.</td>
</tr>
<tr>
<td>Set the evaporation threshold</td>
<td>Move the <strong>Evap Threshold</strong> slider to the right to reduce the amount of spread, or to the left to increase it.</td>
</tr>
</tbody>
</table>
To Do the following

Set the diffusion amount
Move the Diffuse Amt slider right to create soft edges that feather into the grain, or to the left to emulate painting on dry paper.

Set the effect of grain on diffusion
Move the Cap Factor slider to the right to create rougher edges, or to the left to create smoother, more continuous results.

Set grain soak-in
Move the Grn Soak-In slider to the right to create rougher surfaces, or to the left to create smoother, more continuous results.

Set accurate diffusion
Enable the Accurate Diffusion check box.

Set wind force
Move the Wind Force slider to the right to increase wind force, or to the left to decrease it.

Set wind direction
Move the Wind Angle slider to the right to increase angle.

Delay diffusion
Enable the Delay Diffusion check box. Diffusion begins when you finish the brushstroke.

💡 When you enable the Delay Diffusion check box, you increase the speed of Watercolor brush variants.

**Liquid Ink controls**

Liquid Ink controls work with Liquid Ink layers. You can use the Liquid Ink controls to specify qualities such as type, smoothness, and volume of a brushstroke. You can adjust the Liquid Ink controls when you select a Liquid Ink brush.

Liquid Ink is divided into two basic properties: Ink and Color. The Ink component provides the form of the brushstroke, while the Color component applies color to the Ink form. The Ink and Color components can be used together or controlled separately.

The following describes the available Ink types.

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Ink Plus Color" /></td>
<td>Ink Plus Color applies the currently selected color to the Ink form.</td>
</tr>
</tbody>
</table>
Example

Description

**Ink Only** applies only the ink component.

**Color Only** applies only the color component.

**Soften Ink Plus Color** applies color to an ink form, causing inks and colors to blend into one another.

**Soften Ink Only** applies only the ink component.

**Soften Color Only** applies only the color component.

**Resist** repels ink.

**Erase** deletes ink and color.
**Example**

| Presoftened Ink Plus Color | is applied in conjunction with surface depth effects. |

**Smoothness** controls the “tack” of the brushstrokes. Lower values result in coarser brushstrokes. Higher values cause brushstrokes to appear smoother.

*Brushstrokes with Smoothness set to 0% (top) and 100% (bottom)*

**Volume** controls the height of the brushstroke, or the amount of medium applied to the image. Higher values result in thicker strokes.

*Brushstrokes with Volume set to 100% (top) and 500% (bottom)*

You can also use the **Expression** settings to link **Volume** to various stylus or mouse movements. For example, you can link **Volume** to the **Wheel** expression to control the amount of spray from the **Liquid Ink** airbrush by adjusting the wheel on the airbrush stylus. The wheel on the stylus acts like a needle control on a real airbrush.

**Volume** can also be linked to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

*Using Audio Expression to vary Volume*

In addition, you can adjust the **Min Volume** setting to specify the range of variability that you want the expression to apply. The **Min Volume** setting represents a percentage of the **Volume** setting and it must be linked to an expression to have an effect. For example, if you choose the **Wheel** expression on the **Liquid Ink** panel, set the **Volume** slider to 40%, and then set the **Min Volume** slider to 50%, the volume will vary from 20% to 40% every time you use the stylus wheel to apply spray.

You can use the **Depth** controls to give **Liquid Ink** brushstrokes the appearance of height. For more information about **Depth** controls, see “Impasto controls” on page 421.
**Volume Jitter** controls the randomness in volume within the brushstroke. A value of zero results in a perfectly smooth brushstroke.

![Brushstrokes with Volume Jitter](image)

*Brushstrokes with Volume Jitter set to 0% (top) and 100% (bottom)*

**Size Jitter** controls the randomness in size within a brushstroke. A value of zero results in a perfectly smooth brushstroke.

![Brushstrokes with Size Jitter](image)

*Brushstrokes with Size Jitter set to 0% (top) and 100% (bottom)*

**Setting the appearance of ink droplets**

Descriptions of the controls in the **Ink Droplets** area follow.

**Thickness** controls the thickness of the bristles. Higher values cause the bristles to stick together and result in a smoother brushstroke. Lower values cause the individual brushstrokes to become visible.

![Brushstrokes with Thickness](image)

*Brushstrokes with Thickness set to 3% (top) and 20% (bottom)*

**Volume Jitter** controls the variation in bristle height (length). A value of zero signifies that all the bristles are of equal height.

![Brushstrokes with Volume Jitter](image)

*Brushstrokes with Volume Jitter set to 0% (top) and 75% (bottom)*

**Size Jitter** controls the variation in bristle width. A value of zero signifies that all the bristles are of equal width.
Feature lets you adjust the size and count of the ink droplets. When used with a Particle brush, this control affects only the size of the particles. When used with a Bristle brush, both bristle size and count are impacted.

For a list of sample Liquid Ink brushstrokes, see "Liquid Ink" on page 341.

To choose an ink type
1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.
2. Choose a liquid ink type from the Ink Type list box.

To set smoothness
1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.
2. Adjust the Smoothness slider.
   Lower values result in coarse brushstrokes. Higher values cause brushstrokes to blend into one another and appear smoother.

To set ink volume
1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.
2. Move the Volume slider.
   Higher values result in thicker strokes.

To apply an expression to ink volume
1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.
2. Choose an option from the Expression list box.

You can also

Set the percentage of variability that you want the expression to apply
Move the Min Volume slider.

Adjust the angle of the Direction expression
Move the Direction slider until the desired angle is achieved.

Reverse the effect of an Expression setting
Click the Invert button.

To set random volume
1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.
2 In the Randomness area, move the Volume Jitter slider. Lower values result in more uniform brushstrokes.

To set random size
1 Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Liquid Ink.
2 In the Randomness area, move the Size Jitter slider. Lower values result in more uniformly sized brushstrokes.

To set bristle thickness
1 Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Liquid Ink.
2 Move the Thickness slider. Higher values result in strokes in which individual bristles are less visible.

To vary bristle length
1 Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Liquid Ink.
2 In the Ink Droplets area, move the Volume Jitter slider. Higher values result in a greater variation in the length of brush bristles.

To vary bristle width
1 Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Liquid Ink.
2 In the Ink Droplets area, move the Size Jitter slider. Higher values result in a greater variation in the width of brush bristles.

To adjust the size and count of the ink droplets
1 Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Liquid Ink.
2 Move the Feature slider.

Stroke Jitter controls

The Stroke Jitter controls introduces a randomized jitter to the brushstroke. Instead of appearing directly along the stroke, dabs appear randomly outside the brushstroke path. You can also set an Expression setting to further control the Stroke Jitter effect. For more information, see “Expression settings” on page 373.

You can set some stroke jitter options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.
Audio Expression lets you link the Stroke Jitter effect to audio input from your microphone, or internal audio such as streaming music. The jitter changes in synch with the audio signal.

You can also find feature-specific jitter controls on the following brush control panels: Opacity, Grain, Size, Angle, Airbrush, Impasto, and Color Expression.

To set stroke jitter

2. Move the Stroke Jitter slider to the left to decrease brushstroke deviation from the path you draw, or to the right to increase the deviation.

You can also

Specify the angle at which the brushstroke starts to deviate from the path you draw

Move the Direction slider until the desired angle is achieved.

Reverse the effect of an Expression setting

Click the Invert button.

Link stroke jitter to an audio signal

Click the Audio Expression button.

To choose an audio input and adjust audio settings, choose Window ▶ Audio ▶ Audio Settings Panel. For more information, see “Audio Expression” on page 374.

Blending controls

The Blending controls determine how a brush conveys its medium (color) to the paper. You can choose from several preset to suit your needs.

Whether you are painting with a single color or blending two or more colors on a layer, the Enhanced Layer Blending option can help you produce brushstrokes without white fringes. This option uses improved transparency support.
The **Bleed**, **Resaturation**, and **Dryout** controls work together to determine how much color a brush has at the start and finish of a stroke. **Resaturation** lets you control the amount of color that is replenished in a stroke. If it is set at zero, the brush does not produce any color. When **Resaturation** is less than 10% (and **Bleed** is less), a brushstrokes fades in gently. When the **Resaturation** slider is set at zero and **Bleed** is set high, an airbrush can move underlying colors, as when just the airbrush hose is used to blow paint around on the canvas.

**Bleed** lets you control how much the brush colors smear underlying colors, including the paper color. When **Bleed** is higher than resaturation, more color bleeds than covers, so the stroke never reaches full opacity.

You can also apply an **Expression** setting to the **Resat** and **Bleed** controls to link them to a stylus or mouse movement. You can choose different **Expression** settings for each. For example, you can link **Resat** to the **Pressure** expression and link **Bleed** to the **Velocity** expression.

You can also adjust the **Min** setting to specify the range of variability that you want each expression to apply. The **Min Resat** and **Min Bleed** settings represent a percentage of the **Resat** and **Bleed** settings and they must be linked to an expression to have an effect. For example, if you link the **Pressure** expression to the **Resat** control, set the **Resat** slider to 40% and set the **Min Resat** slider to 50%, the amount of resaturation will vary from 20% to 40% every time you apply pressure with the stylus.
Brush Loading affects how dab-based brushes interact with underlying pixels and works in conjunction with Resat and Bleed. When Brush Loading is active, brushes can pick up existing colors, hair by hair. This capability offers truer color interaction, astounding color-variations, smearing, and better cloning results. For more information about dab-based brushes, see “General controls: Dab types” on page 378.

When Brush Loading is not active, brushes interact with previously applied colors by sampling underlying pixels and then loading the brush with one new color — the average of the colors that were sampled. When you use Brush Loading, it’s best to use a very low setting for spacing. For more information, see “Spacing controls” on page 400.

The Dryout control determines how quickly a brush runs out of medium. Dryout is measured in pixels. Moving the slider to the left causes a brush’s reservoir to empty more quickly. This can produce brushstrokes that fade out gently. If Dryout is set high, the brush never runs out of color.

Dryout works in conjunction with Bleed, so Bleed must be set above zero if you want to take advantage of Dryout. You can modulate the Dryout effect by changing the Bleed setting.

You can set some blending options on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

For a list of sample brushstrokes that use blending, see “Blenders” on page 324.

To choose a blending preset
1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Blending.
2. Choose a preset from the Presets list box.

To choose enhanced layer blending
1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Blending.
2. Enable the Enhanced Layer Blending check box.
3. Choose a preset from the Presets list box.

To set color bleed
1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Blending.
2. Move the Bleed slider to the left to reduce the amount of interaction with underlying pixels. Move it to the right to increase the interaction.

You can also

Link the size settings to a specific stylus or mouse movement
Choose an option from the Expression list box.
You can also

Set the percentage of variability that you want the expression to apply
Move the Min Bleed slider.

Adjust the angle of the Direction expression
Move the Direction slider.

To set resaturation

1. Choose Window > Brush Control Panels > Brush Media > Blending.
2. Move the Resaturation slider to the left to reduce the amount of color replenished in a stroke. Move it to the right to increase the amount of color.

You can also

Link the size settings to a specific stylus or mouse movement
Choose an option from the Expression list box.

Set the percentage of variability that you want the expression to apply
Move the Min Resat slider.

Adjust the angle of the Direction expression
Move the Direction slider.

To set brush dryout

1. Choose Window > Brush Control Panels > Brush Media > Blending.
2. Move the Dryout slider to the left to shorten the distance the brush can move before it dries out. Move it to the right to lengthen the distance.
   If you want the brushstroke to gradually become fully transparent, enable the Dryout to transparency check box.

To enable brush loading

1. Choose Window > Brush Control Panels > Brush Media > Blending.
2. Enable the Brush Loading check box.

Mouse controls

In theory, a mouse has no pressure information. A mouse button is either on (button down), or off (button up). However, the Corel Painter Mouse controls let you simulate the following stylus settings:

- Pressure (how hard you would be pressing with a stylus)
- Tilt (how close to vertical the stylus is held)
- Bearing (the compass direction in which the stylus is pointing)
- Rotation (to simulate using a flat-tip stylus that supports 360-degree rotation)
- Wheel (how much ink is sprayed).

For more information, see “Using a stylus vs. a mouse” on page 152.
You can record and save brushstrokes created with a stylus and then have Corel Painter use the saved settings for the stroke when you switch to a mouse. For more information about using saved brushstrokes to further enhance mouse functionality, see “Recording and playing back brushstrokes” on page 161.

To set pressure for the mouse
1. Choose Window ➤ Brush Control Panels ➤ Mouse.
2. Move the Pressure slider.
   A 100% setting uses maximum pressure.

To set tilt for the mouse
1. Choose Window ➤ Brush Control Panels ➤ Mouse.
2. Move the Tilt slider.
   A 90º setting indicates that if a stylus were in use, it would be perpendicular to the tablet.

To set bearing for the mouse
1. Choose Window ➤ Brush Control Panels ➤ Mouse.
2. Move the Bearing slider.
   A setting of 0º indicates that if a stylus were in use, it would be pointing left.

To set rotation for the mouse
1. Choose Window ➤ Brush Control Panels ➤ Mouse.
2. Move the Rotation slider.
   A 360º setting simulates a stylus that completes a 360º barrel rotation.

Rotation is supported only when you are using a brush with the Expression setting set to Rotation. For more information, see “Expression settings” on page 373.

To set ink flow for the mouse
1. Choose Window ➤ Brush Control Panels ➤ Mouse.
2. Move the Wheel slider.
   A setting of 100% indicates that maximum flow is in effect.

Smoothing controls

The Smoothing controls allow you to soften the appearance of brushstrokes.

Damping smooths otherwise jagged brushstrokes for brushes that use rendered dab types. Higher values make the stroke smoother. (Damping suspends a stroke in an area by using calculations to even out edges and reduce jaggedness.)

High values of Damping round out corners of a stroke. A value of 50% works best. Higher values might be necessary for jittery input devices such as a mouse.
**Cubic Interpolation** smooths jagged brushstrokes by adding points to dab paths, primarily for brushes that use dab-based dab types. Unlike **Damping**, which uses mathematical calculations to smooth jagged edges, **Cubic Interpolation** inserts additional points into dab paths, which are used to replot brushstrokes. With particle brushes, higher values result in more particles.

**Cubic Interpolation** is best for dab-based dab types, while **Damping** is best for rendered dab types.

**To set smooth rendered dab strokes**
1. Choose **Window**  **Brush Control Panels**  **Brush Shape**  **Smoothing**.
2. Move the **Damping** slider to the right to even out jagged strokes. Move it to the left to allow for more ragged transitions between points on the stroke.

**To set smooth strokes by adding path points**
1. Choose **Window**  **Brush Control Panels**  **Brush Shape**  **Smoothing**.
2. In the **Cubic Interpolation** area, move the **Points** slider to the right to add points and even out jagged strokes. Move it to the left to decrease the number of additional points.

**Image Hose controls**

The **Image Hose** controls let you design nozzles designated **Rank 1**, **2**, and **3**. For more information, see “Image hose” on page 517.

The settings for each rank consist of the **Expression** settings plus the **Sequential** setting. For more information, see “Expression settings” on page 373.

**Rank 1**
The **Rank 1** control lets you assign an input to locate **Rank 1** imagery within an **Image Hose** nozzle.

**Rank 2**
The **Rank 2** control lets you assign an input to locate **Rank 2** imagery within an **Image Hose** nozzle.

**Rank 3**
The **Rank 3** control lets you assign an input to locate **Rank 3** imagery within an **Image Hose** nozzle.

For a list of sample Image Hose brushstrokes, see “Image Hose” on page 338.

**To choose expression settings for ranks**
1. Choose **Window**  **Brush Control Panels**  **Brush Media**  **Image Hose**.
2. Choose a setting from each of the **Rank** list boxes.
   - To pick out nozzles from the index in order, you can choose **Sequential** from any of the Rank list boxes.

For more information, see “Expression settings” on page 373.

**Rake controls**
The **Rake** controls let you control the sophisticated features of a **Rake** stroke, which maintains the angle of the brush head as the stroke changes direction. As the brush turns, bristles come in and out of contact with the painting surface.
The **Contact Ang** slider adjusts how much of the brush touches the painting surface — in other words, the number of rake “tines” that touch the canvas at any one time.

![Brushstrokes with Contact Ang set to 180° (left), 125° (middle), and right 0° (right), with a Brush Scale setting of 450%](image)

**Brush Scale** controls the spacing between individual bristles that compose the **Rake**. The size of each dab is determined in the **Size** brush control panel. For more information, see “Spacing controls” on page 400.

![Brushstrokes with Brush Scale set to 2500% (left) and 0% (right)](image)

When you turn a real brush to paint a curve, bristles at the edges move in and out of contact with the painting surface, depending on the brush’s location on the curve (inside or outside). **Turn Amount** simulates this bristle displacement by controlling the displacement of inside and outside bristles.

![Brushstrokes with Turn Amount set to 0% (left) and 150% (right)](image)

The **Bristle** controls set the number of bristles or dabs used for **Rake** stroke types.

The **Spread Bristles** control dynamically adjusts brush scale on the basis of stylus pressure. The harder you press, the more the brush fans out. If you want to maintain the spread, regardless of pressure, disable the option.
Soften Bristle Edge makes a brush’s outer dabs semitransparent. This option is particularly effective when used with Turn Amount.

To set brush contact angle
1. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Rake.
2. Move the Contact Ang slider to the left to create a low contact angle (few of the dabs are in contact with the paper). Move the slider all the way to the right to create a high contact angle (all the dabs are in contact with the paper).

To set brush scale
1. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Rake.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring the scale closer to equaling the dab width</td>
<td>Move the Brush Scale slider to the right. When the scale is 100%, the stroke width equals the dab width multiplied by the number of dabs.</td>
</tr>
<tr>
<td>Cause dabs to overlap</td>
<td>Move the Brush Scale slider to the left. When the scale is less than 100%, the dabs overlap. Overlapping dabs create a natural, subtle stroke when used with Turn Amount and Soften Bristle Edge.</td>
</tr>
</tbody>
</table>

To set bristle displacement
1. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Rake.
2. Perform a task from the following table.
To

| Increase the degree to which the displacement changes are based on the direction of the brush | Move the Turn Amount slider to the right. |
| Decrease the degree to which the displacement changes are based on the direction of the brush | Move the Turn Amount slider to the left. |

To adjust the number of Rake brush bristles
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Rake.
2. Move the Bristle slider to adjust the number of bristles.

To set bristle spacing
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Rake.
2. Enable the Spread Bristles check box.

To soften bristle edge
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Rake.
2. Enable the Soften Bristle Edge check box.

Multi controls
You can set the number of bristles used for brushes set to the Multi stroke type. For more information, see “General controls: Stroke types” on page 382.

To adjust the number of Multi brush bristles
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Multi.
2. Move the Bristles slider to adjust the number of bristles.

Color Variability controls
Color variability allows you to create brushstrokes of more than one color. Color variability can be set for HSV or RGB mode, and it can be based on the current gradient or color set. For information about color sets, see “Working with color sets” on page 253 and “Creating and exporting color sets” on page 255.

Examples of brushstrokes with color variability: (left) Speckle Crayon Audio Pulse (Audio Expression category), (middle) Greasy Pencil (Pens and pencils category); (right) Gravity Real Wet Oil (Particles category)

You can also use the Smoothness slider to smooth the color variability in a brushstroke for a more organic look.
Color Variability applied to a brushstroke without smoothing (top) and with smoothing (bottom)

Color Variability based on a color set applied without smoothing (top) and with smoothing (bottom)

**Audio Expression** lets you link color variability to audio input from your microphone, or internal audio such as streaming music. The brushstroke colors vary in sync with the changes of the audio signal.

To display the Color Variability panel
- Choose `Window` ➤ `Brush Control Panels` ➤ `Brush Media` ➤ `Color Variability`.

To set color variability in HSV mode
1. In the **Color** panel, choose a main color.
2. Choose `Window` ➤ `Brush Control Panels` ➤ `Brush Media` ➤ `Color Variability`.
3. Choose in **HSV** from the list box.
4. Adjust the **Hue Variability**, **Saturation Variability**, and **Value Variability** sliders to control hue, saturation, and value ranges for color variability:
   - Moving the ±H slider to the right increases the number of hues in the resulting brushstroke. These colors are the ones adjacent to the selected color on the color wheel.
   - Moving the ±S slider to the right increases variability in the color intensity of the brushstroke.
   - Moving the ±V slider to the right increases variability in the brightness of the brushstroke.

You can try different hue, saturation, and variability settings with any of the brushes to produce interesting results.

To smooth the color variability in the brushstroke, move the **Smoothness** slider.

When you save a brush variant, the current color variability setting is also saved.

When working with brushes like the **Van Gogh** and **Seurat** variants of the Artists brush category, you can add a natural, almost 3D appearance to your webpage images by increasing the hue, saturation, and value settings.
To set color variability in RGB mode
1 In the Color panel, choose a main color.
2 Choose Window Brush Control Panels Brush Media Color Variability.
3 Choose in RGB from the list box.
4 Move the ±R, ±G, and ±B sliders to control color variability of red, green, and blue values.
   To smooth the color variability in the brushstroke, move the Smoothness slider.

To set color variability based on the current gradient
1 In the Color panel, choose a main color.
2 Choose Window Brush Control Panels Brush Media Color Variability.
3 Choose from Gradient from the list box.
   Color variability is now based on random colors from the current gradient.
   To smooth the color variability in the brushstroke, move the Smoothness slider.

To set color variability based on the current color set
1 In the Color panel, choose a main color.
2 Choose Window Brush Control Panels Brush Media Color Variability.
3 Choose from Color Set from the list box.
   Color variability is now based on random colors from the current color set.
   To smooth the color variability along the brushstroke, move the Smoothness slider.

To ignore color set variability
1 Choose Window Brush Control Panels Brush Media Color Variability.
2 Enable the Ignore color variability from color sets check box.

To link color variability to audio
1 Choose Window Brush Control Panels Brush Media Color Variability.
2 Click the Audio Expression button ( ).
   To choose an audio input and adjust audio settings, choose Window Audio Audio Settings Panel. For more information, see "Audio Expression" on page 374.

Color Expression controls
Color Expression determines whether Corel Painter should use the main or additional color in an image. Using Color Expression, you can introduce input (such as direction) which controls output when you apply two-color brushstrokes. You can control the variation between the main and additional colors in a brushstroke by adjusting Color Jitter. You can also smooth the variation between the main and additional colors along the brushstroke.
You can also link color variation in brushstrokes to audio input from your microphone, or internal audio such as streaming music.

To set color expression controls

1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Color Expression.
2. In the Color Expression panel, choose one of the following options from the Expression list box:
   - None — applies no adjustment to the color expression
   - Velocity — adjusts the color expression based on the dragging speed
   - Direction — adjusts the color expression based on the direction of the stroke, and according to the value you set with the slider or in the box
   - Pressure — adjusts the color expression based on stylus pressure
   - Wheel — adjusts the color expression based on the wheel settings on an airbrush stylus, specifically the Wacom Intuos Airbrush stylus
   - Tilt — adjusts the color expression based on the angle of the stylus from the tablet
   - Bearing — adjusts the color expression based on the direction in which the stylus points
   - Rotation — adjusts the color expression based on the rotation of the stylus
   - Source — adjusts the color expression based on the luminance of the clone source
   - Random — adjusts the color expression at random

   If you want to switch the main and additional colors, click the Invert button.

   If you chose Direction from the Expression list box, move the Direction slider until the desired angle is achieved.

To control the variation between the main and additional colors in a brushstroke

1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Color Expression.
2. Move the Color Jitter slider.

   To smooth the color variation along the brushstroke, move the Smoothness slider.
To link color expression to audio

1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Color Expression.

2. Click the Audio Expression button ( ).

   To choose an audio input and adjust audio settings, choose Window ➤ Audio Expression ➤ Audio Settings Panel. For more information, see “Audio Expression” on page 374.

Dynamic Speckles controls

Dynamic Speckles generate a continuous brushstroke from discrete spots of color or speckles. The speckles in the brushstroke are truly dynamic — they are generated as you paint.

To modify the appearance of the brushstrokes, you can adjust the number of dynamic speckles and change their size. You can connect speckle size to an expression such as pressure or velocity so that the speckles grow or shrink in response to subtle hand movements.

You can specify the range of speckle size variability that you want the expression to apply by moving the Min Size slider. This setting represents a percentage of the Size setting. For example, if you connect speckle size with pressure and set Min Size to 20% and Size to 70%, the speckle size will change from 20% to 70% when you apply pressure during a brushstroke.

If the size of the brush is linked to an expression, you can scale the speckle size and count to match the brushstroke width so that the overall stroke appearance is preserved. You can control the extent to which the speckles are scaled.

You can link speckle size to an audio signal. For more information, see “To link brush attributes and effects to audio” on page 375.
Dynamic speckles can have soft or hard edges.

You can change the size of the speckles and their opacity randomly for a more organic look. In addition, you can vary the size and opacity of dynamic speckles by applying jitter, and you can smooth the jitter effect for more natural-looking brushstrokes.

For a list of sample brushstrokes using the Dynamic Speckles technology, see “Dynamic Speckles” on page 333.

To find a Dynamic Speckles brush variant

1. In the Search bar, type Dynamic Speckle in the Search box. The Search bar is located to the right of the property bar, in the upper-right corner of the document window.
2. Choose a brush variant from the list of search results.

To adjust the properties of a Dynamic Speckle brush variant

1. Select a Dynamic Speckle brush variant.
2. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Dynamic Speckle.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the number of dynamic speckles</td>
<td>Move the Count slider.</td>
</tr>
<tr>
<td>Adjust the size of dynamic speckles</td>
<td>Move the Size slider.</td>
</tr>
<tr>
<td>Set the range of speckle size variability</td>
<td>Move the Min Size slider.</td>
</tr>
<tr>
<td>Link speckle size to an expression</td>
<td>From the Expression list box, choose an expression.</td>
</tr>
<tr>
<td>Adjust the number and size of dynamic speckles to match brush size changes</td>
<td>Move the Scale with Size slider. Higher values result in more accurate scaling.</td>
</tr>
</tbody>
</table>
To

Create speckles with soft or hard edges

Do the following

Click the **Hard** or **Soft** button.

Vary the size of dynamic speckles

Move the **Random Thickness** slider. Higher values vary the size more randomly.

To apply additional size variation, enable the **Jitter** check box. Move the **Smoothness** slider for a more organic look.

Vary the opacity of dynamic speckles

Move the **Random Opacity** slider.

To apply additional **Opacity** variation, enable the **Jitter** check box. Move the **Smoothness** slider for a more organic look.

---

**To apply Dynamic Speckles to a brush variant**

1. Choose a RealBristle, bristle, or Particle brush variant from the Brush Selector.

2. Choose **Window ➤ Brush Control Panels ➤ General**.

3. From the **Dab Type** list box, choose one of the following:
   - Dynamic Speckle Gravity Particles — to use with a gravity particle brush
   - Dynamic Speckle Flow Particles — to use with a flow particle brush
   - Dynamic Speckle Spring Particles — to use with a spring particle brush
   - Dynamic Speckle Bristle — to use with a bristle or RealBristle brush

4. To modify Dynamic Speckles properties, choose **Window ➤ Brush Control Panels ➤ Brush Shape ➤ Dynamic Speckle**, and adjust the settings you want in the Dynamic Speckle panel.

---

**Dab Stencil controls**

Dab Stencil masks brush dabs before you apply a brushstroke, letting you add control and creative touch to a wide range of brushes — from blending brushes, to Watercolor and Impasto. Applying a dab stencil knocks out areas of the brush dab by making them more transparent. It is as if the brush dab becomes a stamp that has elevated and indented areas. The brush applies more paint with the elevated areas of the dab, and less or no paint at all with the indented areas.

You can choose a dab stencil source from a variety of stencil media such as paper, flow maps, and textures.
The brushstrokes in this artwork use the Dab Stencil feature. Artwork by Melissa Gallo.

From left to right: Using paper, flow map, and texture as a dab stencil source

You can adjust the properties of the dab stencil to change the look of the brushstrokes. For example, you can use the **Strength** and **Min Strength** controls to adjust the maximum and minimum opacity of the dab stencil. When the dab stencil is at maximum strength (100%), it is the most opaque and makes the dab areas that it covers the most transparent. In addition, you can apply jitter to vary the opacity of the dab stencil, and you can smooth the jitter for more natural-looking brushstrokes. You can link a dab stencil to an expression so that dab stencil opacity changes in response to specific mouse or stylus movement, such as pressure, direction or velocity.
You can also link a dab stencil to audio input from your microphone, or internal audio such as streaming music. The opacity (strength) of the dab stencil varies in sync with the changes of the audio signal.

The Dab Stencil feature differs from grain in several ways. Dab stencils vary the opacity of the dab before you apply a brushstroke and can be applied only to dab-based brushes. While grain works only with paper textures, dab stencils can use flow maps and other textures as well. Also, dab stencils work with methods and subcategories that currently do not support grain. For example, you can apply a dab stencil to a glow brush.
Applying the same paper texture by using Grain (left) and applying a dab stencil (right)

Glow brushes work well with the Dab Stencil feature to create interesting texture and lighting effects. From left to right: A paper, texture, and a flow map are used as dab stencil sources.

You can use the Dab Stencil feature together with texture brushes to create impactful and controlled brushstrokes. For more information about texture brushes, see “Texture painting” on page 483.

Texture brushes and dab stencil brushes are used together with the shown texture and other paper textures to create the sphere surface on the right.

Dab Stencil can also be combined with Impasto brushes to add a realistic, three-dimensional look and feel to an image.
For a list of sample Dab Stencil brushstrokes, see “Dab Stencils” on page 329.

To apply a dab stencil to a brush variant
1 Choose a dab-based brush variant from the Brush Selector.
   Dab Stencil works well with brushes that use any of the following dab types: Captured, Dynamic Speckles, Circular, Computed Circular, and Static Bristle.

2 On the extended property bar, open the Dab Options flyout, and enable the Apply Dab Stencil check box.
   If the extended property bar isn’t open, choose Window ➤ Extended Property Bar.

3 Adjust any properties you want. For more information, see “To adjust the properties of a dab stencil” on page 449.

You can also apply a dab stencil from the Dab Stencil panel (Window ➤ Brush Control Panels ➤ Brush Shape ➤ Dab Stencil).

To adjust the properties of a dab stencil
1 Choose a Dab Stencil brush variant or a brush variant that supports Dab Stencil.

2 Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Dab Stencil.

3 Make sure the Apply Dab Stencil check box is enabled.

4 From the Source list box, choose one of the following options:
   • Flow Map — to use a flow map as the stencil source
   • Paper — to use a paper texture as the stencil source
   • Texture — to use a texture as the stencil source. If you want to display a preview of the texture in the image window, enable the Show Texture check box.

5 Click the selector button next to the Source list box, and choose the flow map, paper texture, or texture you want to use as a source.
To edit the source, click the **Toggle [Source Name] Panel** button, and adjust any attributes you want on the corresponding panel. For more information about editing the dab stencil source, see “To customize a flow map” on page 509, "Working with paper texture and grain" on page 165 or “Customizing Texture brushes” on page 487.

To adjust the Dab Stencil properties, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the maximum level of opacity that the stencil applies to the dab</td>
<td>Move the <strong>Strength</strong> slider.</td>
</tr>
<tr>
<td>Specify the minimum level of opacity that the stencil applies to the dab</td>
<td>Move the <strong>Min Strength</strong> slider.</td>
</tr>
<tr>
<td>Set the range of opacity variability of the dab stencil based on the maximum and minimum strength settings</td>
<td>Move the <strong>Strength Jitter</strong> slider.</td>
</tr>
<tr>
<td>Smooth the jitter of opacity variability of the dab stencil</td>
<td>Click the <strong>Smoothness</strong> slider.</td>
</tr>
<tr>
<td>Link Dab Stencil to an expression</td>
<td>From the <strong>Expression</strong> list box, choose an expression.</td>
</tr>
<tr>
<td>Link Dab Stencil to audio</td>
<td>Click the <strong>Audio Expression</strong> button <img src="image" alt="Audio Expression" />.</td>
</tr>
<tr>
<td>To choose an audio input and adjust audio settings, choose <strong>Window ➤ Audio Expression ➤ Audio Settings Panel</strong>. For more information, see “Audio Expression” on page 374.</td>
<td></td>
</tr>
<tr>
<td>Adjust the angle of the <strong>Direction</strong> expression</td>
<td>Move the <strong>Direction</strong> slider.</td>
</tr>
<tr>
<td>Reverse the effect of an <strong>Expression</strong> setting</td>
<td>Click the <strong>Invert</strong> button <img src="image" alt="Invert" />.</td>
</tr>
</tbody>
</table>

**Glazing controls**

There are multiple ways to control the opacity of the paint deposited with a brush. Glazing (**Window ➤ Brush Control Panels ➤ Brush Media ➤ Glazing**) lets you specify the maximum level of opacity in a brushstroke.

Glazing allows you to work with very high levels of transparency and paint with light, semi-transparent brushstrokes.
Glazing is different from Brush opacity (Window ▶ Brush Control Panels ▶ Brush Media ▶ Opacity), which controls the opacity of each dab (or bristle for other brush types.) If you set Glazing to 20%, the opacity in a single brushstroke will never exceed 20%. Within that 20% range, you can specify the opacity of each dab from 1% to 100%. For example, if you set dab opacity to 100%, the paint that a brushstroke will deposit will still be only 20% of the selected color. Brush opacity allows you to gradually build up to the selected color and Glazing determines what that color is. The lower the Brush opacity, the slower you build up to the color specified by Glazing in a single brushstroke.

Glazing brushes can help you fill an area with long continuous strokes that have a very soft gradation from the beginning of the mark to the end.
Glazing brushes create a nice smooth blend between colors; there are no artifacts in the areas where the dabs overlap.

You can add grain to Glazing brushes, however, you will see overlaps.

Glazing is available to all stamp-based brushes and can be linked to specific stylus or mouse movements. For more information, see “Expression settings” on page 373.
Glazing works well with the following dab types: (from top to bottom) Captured, Circular, Computed Circular, Static Bristle.

You can use merge modes to control how brushstrokes interact with the underlying colors on the active layer or the canvas.

For a list of sample Glazing brushstrokes, see “Glazing brushes” on page 336.

To adjust Glazing properties:

1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Glazing to display the Glazing panel.
2. From the Merge Mode list box, choose a merge mode.
   For a detailed description of each merge mode, see “To apply a merge mode” on page 392.
3. Move the Glazing slider to set the maximum level of opacity in a brushstroke.

You can also

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link brushstroke opacity to an expression such as pressure, tilt,</td>
<td>Choose an option from the Expression list box.</td>
</tr>
<tr>
<td>direction to vary the opacity in a brushstroke</td>
<td></td>
</tr>
</tbody>
</table>
To Do the following

Reverse the effect of an Expression setting

Click the Invert Glazing Expression button.

Link brushstroke opacity to audio expression

Click the Audio Expression button.

Set the minimum level of opacity in a brushstroke

Move the Min Glazing slider.

The Min Glazing setting represents a percentage of the Glazing setting and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression, set Glazing to 100%, and set the Min Glazing to 10%, the opacity will vary from 10% to 100% every time you apply pressure in a brushstroke.

Set the range of opacity variability in a brushstroke

Move the Glazing Jitter slider.

Move the slider to the right to randomly vary the opacity of a brushstroke.

Smooth the jitter in a brushstroke

Move the Smoothness slider.

A brushstroke with Glazing set to 100%, (top) Min Glazing set to 80%, and (bottom) Min Glazing set to 20%
To | Do the following
---|---
Specify the angle at which a brushstroke changes opacity | Move the Direction slider.

Glazing brushes work only with the **Glazing** stroke type. For more information, see “General controls: Stroke types” on page 382. The controls on the **Glazing** panel are grayed out when you select a stroke type that is not supported, such as Single, Multi, Rake, and Hose.

If there are unwanted overlaps in your Glazing brush, try the following:

- Set **Opacity** (Window ➤ Brush Control Panels ➤ Brush Media ➤ Opacity) to 100%, **Opacity Jitter** to 0%, and **Opacity Expression** to None.
- Set **Grain** (Window ➤ Brush Control Panels ➤ Brush Media ➤ Grain) to 0%, **Grain Jitter** to 0%, and **Grain Expression** to None.
- Set **Dab Opacity** (Window ➤ Brush Control Panels ➤ Brush Shape ➤ Computed Circular) for Computer Circular brushes to 100%.
Airbrushes

The Corel Painter computed airbrushes are so realistic, you feel as though you’re using a real airbrush. For more about computed brushes, refer to “General controls: Dab types” on page 378.

The best way to get used to the Corel Painter airbrushes is to play with them. Select each variant and spray paint onto the canvas without worrying about running out of compressed air. With computed airbrushes, you can paint with color, patterns, or variants. One variant blows hairlike strokes; another variant just blows existing paint around on the canvas, like a hose without an airbrush attached.

Try using the Fine Spray variant in the Airbrushes category for an example of how Bearing and Flow settings combine to give realistic airbrush results.

For information about the Airbrush controls, see “Airbrush controls” on page 416.

Previous versions of digital airbrushes projected a thin mist of dots (or paint dabs) onto the canvas. The Digital Airbrush variant (named Fat Stroke in previous versions of Corel Painter) is included in the default brush library. With a digital airbrush, dots are laid down, or sprayed, within a circular area, resembling the circle thrown by a flashlight that is perfectly perpendicular to a piece of paper. The area of application remains circular, regardless of tilt, bearing, or stylus pressure. Density, or flow, adjustments can be mimicked with adjustments to the Opacity setting.

Now, airbrushes respond to angle (tilt), bearing (direction), and flow (fingerwheel setting) data from a stylus, allowing for a truly realistic brushstroke. For example, as you tilt your stylus, specks of media land on the paper in a way that reflects that tilt. Imagine, again, the circle of light thrown by a flashlight. The moment the flashlight is no longer perpendicular to the paper, the shape of the cone of light changes, creating a conic section. In the same manner, Corel Painter airbrushes create conic sections that mirror your stylus movements.
Angle and tilt determine the shape and size of the conic section created by Corel Painter airbrushes, which resembles a circle of light from a flashlight that is no longer perpendicular to the paper.

Extreme-tilt angles affect large areas of the canvas. This can slow the brush down as it tries to squirt paint too far from the stylus.

**Adjusting airbrush spread and flow**

**Adjusting spread**

You can adjust airbrush spread, which affects how paint spreads out as it is applied. In other words, it sets the size of area where the paint will be applied.

A good range for the *Spread* setting is 30° to 40°. Narrow settings for *Spread* and *Angle* can cause problems. Combined with a very tilted stylus, a narrow setting for *Spread* can cause paint to be deposited away from the cursor.

**Varying edges**

You can vary the edges of the paint sprayed from an airbrush to achieve desired softness by selecting a brush tip profile. Each profile gives you a different edge to the paint you spray. For more information, refer to “Changing dab profiles” on page 401.

**Adjusting flow**

Although you can still adjust *Opacity* to apply fainter or darker dots of media, some Corel Painter airbrushes, for example, the *Fine Wheel Airbrush* variant, take advantage of stylus fingerwheel controls. Like the needle control on real airbrushes, the fingerwheel control adjusts airbrush flow — that is, how much media is applied.
Airbrushes | 459

Controlling droplet size

You can control the size of the airbrush droplets. This is not the same as adjusting the size of the brush (the larger the brush, the more droplets are sprayed).

Very large droplets may produce unexpected results.

The Feature setting is not available for variants that use the Pixel Airbrush or Line Airbrush dab types.

To increase or decrease media flow from an airbrush

1. Move the stylus fingerwheel toward the tip (or forward), to decrease flow. Move it away from the tip (or backward), to increase flow.

You can also control media flow from an airbrush by adjusting the Flow and Min Flow sliders in the Airbrush panel in the Brush Controls palette. Flow sets the maximum flow. Min Flow sets the minimum amount of flow as a percentage of Flow.

Depending on the Airbrush variant, you can reverse the effect of moving the airbrush fingerwheel by enabling the Invert button in the Color Expression panel, or by clicking the Invert Flow Expression button in the Airbrush panel in the Brush Controls palette.

In the Airbrush panel in the Brush Controls palette, you can also determine flow based on stylus information, such as velocity or pressure, by choosing an expression from the Flow Expression list box.

To change the size of airbrush droplets

2. Choose Airbrush from the Dab Type list box.
3. In the Brush palette, click the Size tab to open the Size panel.
4. In the Size panel, move the Size slider.
5. Move the Feature slider to the left for smaller droplets, or to the right for larger droplets.
Watercolor

Corel Painter features different tools and controls that allow you to produce natural-looking watercolor effects. The tools include watercolor brushes that are stored in the following brush categories.

<table>
<thead>
<tr>
<th>Brush category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real Watercolor</td>
<td>The Real Watercolor brushes allow you to apply pigment to the paper in a very realistic way. They include brush control options that allow you to precisely control water and paper interactions. The Real Watercolor brushes are applied to the Watercolor layer.</td>
</tr>
<tr>
<td>Watercolor</td>
<td>The Watercolor brushes are designed to produce natural-looking effects. They include brush control options that allow you to control color diffusion and some water and paper interactions. The Watercolor brushes are applied to the Watercolor layer.</td>
</tr>
<tr>
<td>Digital Watercolor</td>
<td>The Digital Watercolor brushes let you apply watercolor effects directly to the canvas or a default layer, without the need for a Watercolor Layer. However, the brush control options for Digital Watercolor are limited.</td>
</tr>
</tbody>
</table>

You can also alter the appearance of watercolor by changing the paper texture and modifying the brush controls.

This section contains the following topics:

- "Working with the Watercolor layer" (page 462)
- "Watercolor brushes and paper texture interaction" (page 463)
- "Working with Real Watercolor brushes" (page 463)
- "Working with Watercolor brushes" (page 464)
- "Working with Digital Watercolor brushes" (page 464)
Working with the Watercolor layer

Both the Real Watercolor and Watercolor brushes paint into a watercolor layer, which enables the colors to flow and mix and absorb into the paper. In Corel Painter, you can edit the Watercolor layer as you would any other layer without changing anything in the image layer. For example, you can draw pencil outlines in the image layer and then overlay watercolor shading without smudging the pencil lines.

You can sketch on one layer and paint with watercolors on a separate Watercolor layer.

You can transfer, or lift, information from the canvas to the Watercolor layer. This is useful if you want to apply Watercolor effects to a photograph. You can also wet the Watercolor layer, which activates a diffusion process.

To create a new Watercolor layer

2. In the Layers panel, click the Layer options button , and choose New Watercolor Layer.

If you select a Real Watercolor or Watercolor brush variant from the Brush library, a Watercolor layer is automatically created when you apply a brushstroke to the document window.

To transfer the canvas to a Watercolor layer

1. Open the image that you want to convert to a watercolor in the document window.
2. Choose Window ➤ Layers.
   If the image contains multiple layers, you can drop all of the layers onto the canvas by clicking the Layer options button in the Layers panel, and choosing Drop All.
3. In the Layers panel, click the Layer options button , and choose Lift Canvas to Watercolor Layer.
   Once the layer content is lifted from the canvas, the canvas is blank.

To wet the Watercolor layer

2. In the Layers panel, click the Layer options button , and choose Wet Entire Watercolor Layer.
To work with a dry surface, click the Layer options button in the Layers panel, and choose Dry Watercolor Layer.

Watercolor brushes and paper texture interaction

The watercolor brushes interact with paper texture and grain — the colors flow, mix, and are absorbed into the paper. The luminance information of the paper grain is used to determine how the paint diffuses into the paper. It also affects how the pigment settles onto the paper when it dries.

You can experiment by adjusting the sliders in the Papers panel to see their effect on the watercolor brushes. The Paper Scale slider controls the size of the grain. The Paper Contrast slider, as it applies to the Watercolor layer, controls the height of the grain surface. Adjusting the Paper Contrast slider to the right increases the height of the grain and adds more texture as a result. For more information, see “Controlling brightness and contrast of paper grain” on page 169.

In addition, the Real Watercolor brushes include controls that allow you to further control the paper interaction. For more information, see “Working with Real Watercolor brushes” on page 463.

Working with Real Watercolor brushes

The Real Watercolor brush variants let you produce very realistic watercolor brushstrokes because they replicate real world watercolor media. Corel Painter simulates the look and feel of blending pigments with water so they interact with paper in a very natural way. When working with Real Watercolor brushes, the brushstrokes are applied to the Watercolor layer.

Using Real Watercolor brush variants

You can get started quickly with the Real Watercolor brushes by choosing one of the available brush variants. However, you can also customize a brush variant by using the Real Watercolor brush controls. For more information, see “Real Watercolor controls” on page 405.

To choose a Real Watercolor brush variant

1. In the toolbox, click the Brush tool.

2. Click the Brush Selector on the Brush Selector bar.

3. In the Brush library panel, click the Real Watercolor brush category, and click a brush variant.

To customize a Real Watercolor brush variant

- Choose Window > Brush Control Panels > Brush Media > Real Watercolor.

  For more information about each of the Real Watercolor controls, see “Real Watercolor controls” on page 405.
Working with Watercolor brushes

The Watercolor brush variants produce natural-looking watercolor effects. When working with Watercolor brushes, the brushstrokes are applied to the Watercolor layer. All Watercolor brush variants, except Wet Eraser, interact with the canvas texture.

Stylus pressure affects the width of the brushstroke for all Watercolor brush variants except Wet Eraser. Increased pressure widens a brushstroke; less pressure narrows a stroke.

If too many strokes are made within a short period, particularly with slow-drying brushes, the application can become slower. In this situation, it is best to wait for the drying process to finish before continuing.

Watercolor Dab Types

For more information about Watercolor Dab Types, see “General controls: Dab types” on page 378.

Water Controls

When you select a Watercolor brush, you can adjust the Water controls which allow you to specify various settings for the Watercolor brushes. For example, you can adjust brush size, control diffusion, and determine how the paper texture will interact with the brushstrokes. For more information, see “Water controls” on page 421.

A watercolor stroke before diffusion (left) and after diffusion (right)

To choose a Watercolor brush variant

1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the Watercolor brush category, and click a brush variant.

To customize a Watercolor brush variant

Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Watercolor.

For more information about each of the Watercolor controls, see “Water controls” on page 421.

Working with Digital Watercolor brushes

The Digital Watercolor brushes paint directly on both the Canvas layer or a default layer so you can create effects similar to those of Watercolor brushes without using a separate layer.
You can use Digital Watercolor brushes to create effects similar to those produced with Watercolor brushes, without having to create a separate layer. Settings such as Diffusion, Opacity, and Wet Fringe control the appearance of the stroke.

**Digital Watercolor Diffusion**

Digital Watercolor brushes also use diffusion to create soft, feathery edges on the brushstrokes. You can adjust the amount of diffusion by using the controls on the property bar.

**Wet Fringe**

The *Wet Fringe* slider controls the amount of water pooling and paint at the edges of Digital Watercolor brushstrokes. You can dynamically adjust the wet fringe on any Digital Watercolor brushstroke before you dry it. Dynamically adjusting the Wet Fringe affects every wet Digital Watercolor brushstroke, which remains wet until you dry it.

When you’re satisfied with the wet fringe, it’s a good idea to dry Digital Watercolor brushstrokes. This allows you to dynamically adjust the Wet Fringe on future Digital Watercolor brushstrokes without affecting existing brushstrokes that you’re satisfied with.

**To choose a Digital Watercolor brush variant**

1. In the toolbox, click the *Brush* tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the *Digital Watercolor* brush category, and click a brush variant.

**To adjust diffusion**

1. With a Digital Watercolor brush variant selected, adjust the *Diffusion* slider on the property bar. Drag the slider to the right to increase diffusion, or to the left to decrease diffusion.
2. Apply one or more strokes with a Digital Watercolor variant. If you would like to restrict the diffusion to a region, make a selection with any selection tool. The diffusion effect will apply only within the selection.

The Diffusion slider is also accessible from the Digital Watercolor panel. You can open the panel by choosing *Window* ➤ *Brush Control Panels* ➤ *Brush Media* ➤ *Digital Watercolor*.

**To adjust wet fringe**

1. Apply one or more strokes with a Digital Watercolor variant. If you would like to restrict the diffusion to a region, make a selection with any selection tool. The pooling effect will apply only within the selection.
2. On the property bar, adjust the *Wet Fringe* slider on the property bar. Drag the slider to the right to increase pooling, or to the left to decrease pooling.
You can also adjust wet fringe before applying brushstrokes by adjusting the Wet Fringe slider.

The Wet Fringe slider is also accessible from the Digital Watercolor panel in the Brush Controls palette. You can open the panel by choosing Window ➤ Brush Control Panels ➤ Brush Media ➤ Digital Watercolor.

To dry Digital Watercolor brushstrokes

• Choose Layer ➤ Dry Digital Watercolor.

After you dry a Digital Watercolor brushstroke, you can no longer adjust its wet fringe.
Particle brushes

Particle brushes are physics-inspired brushes that give a unique look and feel to your artwork. They emit particles from a central point, and in turn the particles draw a pattern of lines (paths) as they move across the canvas.

You can control the particle paths with precision or introduce randomness in the brushstroke movement by using the Particle brush controls. Particle brushes are capable of wide-ranging creative variation when you adjust the parameters of each brush variant.

In addition, you can streamline your workflow by choosing the New Brushes workspace layout, which displays the palettes of the Particle brushes.

Depending on the movement of the particles around the central point, there are three types of Particle brushes: Gravity, Flow, and Spring brushes. A dark background is ideal for most of these brushes.

You can use dynamic speckles with Particle brushes for brushstrokes with a different look and feel.

You can set some Particle controls on the property bar. For more information, see “To choose a dab profile using the property bar” on page 308.

For a list of sample brushstrokes created with Particle brushes, see “Particles” on page 345.

This section contains the following topics:

- “Gravity Particle brushes” (page 468)
- “Flow Particle brushes” (page 470)
- “Spring Particle brushes” (page 472)
- “Common Particle brush controls” (page 475)
- “Particles - Thin Lines brush controls” (page 478)
- “Using Dynamic Speckles with Particle brushes” (page 480)
Gravity Particle brushes were used to create smoke and Aurora Borealis effects in this artwork, as well as to enhance the water reflections.

Gravity Particle brushes

Gravity Particle brushes create sweeping marks that dramatically shrink and grow with movement. The movement of the particles in a Gravity brush resembles planetary movement, as the particle paths are greatly influenced by velocity, acceleration, and other forces. Depending on the speed of the stroke, the particles can stay tight within the brushstroke, or they can be pulled apart by forces.

Gravity brushes include the following variants:

- Gravity Bristle
- Gravity Jagged Light Pen
- Gravity Lazy Sketch
Gravity Particle brush controls

You can customize Gravity Particle brushes by using the Gravity Particles control panel, which includes the Velocity, Acceleration, and Spin Rate controls.

The Velocity slider sets the base speed of all particles. Use it together with the Acceleration slider to control the forward movement of the particles.

The Acceleration slider sets the distance between particle paths.

![Image](image1.png)

*Left: Low velocity and acceleration. Right: High velocity and acceleration*

A brushstroke with low velocity and acceleration (left) and high velocity and acceleration (right)

The Spin Rate slider sets the speed at which the particles spin around the cursor. Slower spin rates allow the particles to track the cursor closely, while higher spin rates allow the particles to travel further away from the cursor.

![Image](image2.png)

*Low spin rate (left) and high spin rate (right)*

A brushstroke with low spin rate (left) and high spin rate (right)

You can also associate the spin rate with an expression by choosing an option from the Expression list box. For more information about Expression controls, see "Expression settings" on page 373. In addition, you can link spin rate to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.
For information about common Particle brush settings, see “Common Particle brush controls” on page 475.

For information about other brush settings, see “Adjusting brushes with brush controls” on page 371.

To choose a Gravity Particle brush variant

1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the Particles brush category, and click a Gravity Particle brush variant.

To customize a Gravity Particle brush variant

1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Gravity Particles.
2. Adjust any of the settings in the Gravity Particles panel.
4. Adjust any of the settings in the Particles - Common panel.

For more information see “Common Particle brush controls” on page 475.

Flow Particle brushes

Flow Particle brushes emit short-lived particles that flow out from the center of the brushstroke across the canvas and gradually fade. Their movement resembles that of fireworks. As they flow, they encounter forces that change their path, resulting in a chaotic or controlled movement. The Flow brushes are easily influenced by force, chaos, and flow maps. For more information about flow maps, see “Applying and adjusting flow maps” on page 505.

Flow brushes include the following variants:
• Flow Organic Texture
• Flow Flare
• Flow Sparkler Glow

Flow Particle brush controls

You can customize Flow Particle brushes by using the Flow Particles control panel, which includes the Position Jitter, Randomize Chaos, and Enhance Flow Map controls.

The Position Jitter slider lets you vary the starting position of the particles. You can also associate the position jitter with an expression by choosing an option from the Expression list box. For more information about Expression controls, see “Expression settings” on page 373. In addition, you can link position jitter to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

The Randomize Chaos check box lets you change the chaos pattern randomly for a more organic look.

The Enhance Flow Map controls include the Edge slider and the Brightness slider, which modify the brushstroke based on the edge and brightness of the flow map.
To choose a Flow Particle brush variant

1. In the toolbox, click the Brush tool 🖌.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the Particles brush category, and click a Flow Particle brush variant.

To customize a Flow Particle brush variant

1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Flow Particles.
2. Adjust any of the settings in the Flow Particles panel.
4. Adjust any of the settings in the Particles - Common panel.

   For more information see “Common Particle brush controls” on page 475.

Spring Particle brushes

Spring Particle brushes consist of a net of particles held together by elastic springs. Since the particles are connected to each other, they don’t spread out across the canvas but bounce back toward the center of the brushstroke. The brushstroke mark is determined by the individual paths of the particles and the flexibility of the springs between them.

Spring Particle brush controls

You can customize Spring Particle brushes by using the Spring Particles control panel, which includes the Appearance, Stiffness, Stiffness Jitter, Length Jitter, and Minimum Length controls.

The Appearance controls let you choose a Nucleus, Chain, or Geometric appearance for the particle pattern.

- **Nucleus** — Particles spring outward from the brush path.
• **Chain** — A chain of particles whips around the brush path.
• **Geometric** — Particles form a geometric shape around the brush path.

The **Random Length** slider randomly varies the length of individual springs. Once adjusted, the lengths remain constant during the brushstroke.
The Stiffness slider controls the strength of the springs. Low values produce more relaxed springs, which allows the particles to move more freely in relation to each other. You can also associate the stiffness with an expression by choosing an option from the Expression list box. The Stiffness Jitter slider randomly varies the strength of individual springs.

You can also link stiffness to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

The Minimum Length slider sets the initial length of the springs. Low values allow springs to stretch more.
To choose a Spring Particle brush variant
1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the Particles brush category, and click a Spring Particle brush variant.

To customize a Spring Particle brush variant
1. Choose Window ➔ Brush Control Panels ➔ Brush Shape ➔ Spring Particles.
2. Adjust any of the settings in the Spring Particles panel.
4. Adjust any of the settings in the Particles - Common panel.

For more information see “Common Particle brush controls” on page 475.

Common Particle brush controls
Brush controls common to all Particle brushes are accessible through the Particles - Common control panel.

The Count slider sets the number of particles in a brushstroke, and in turn the number of paths rendered during the stroke.
The **Global Chaos** slider applies chaos to all particles equally, so that they move chaotically but in unison. The **Local Chaos** slider randomly applies chaos to individual particles in the brush. The **Smoothness** slider smooths the chaos for a more organic look. You can also associate global and local chaos with an expression.
The **Damping** slider allows or inhibits particle movement. Low damping allows particles to move faster and be more responsive to any forces affecting their movement. High damping reduces all forces affecting particle movement, and the movement itself becomes slow and heavy. The **Damping Jitter** slider applies damping at random to individual particles.

The **Force** slider applies global directional force to all particle movement. The effect is similar to the effect of wind on watercolor. The **Direction** slider sets the direction of the global force in degrees. You can also associate force and direction with an expression.
The **Flow Map** slider sets the degree to which particle movement is affected by the flow map. For more information about flow maps, see “Applying and adjusting flow maps” on page 505.

![A brushstroke without (left) and with (right) a flow map applied](image)

You can link force, direction, global chaos, and local chaos to audio input from your microphone, or internal audio such as streaming music. For more information, see “Audio Expression” on page 374.

![Using Audio Expression to vary force](image)

![Using Audio Expression to vary direction](image)

![Using Audio Expression to vary global chaos](image)

![Using Audio Expression to vary local chaos](image)

**To access the common Particle brush controls**

1. Choose **Window** → **Brush Control Panels** → **Brush Shape** → **Particles - Common**.

2. Adjust any of the settings in the **Particles - Common** panel.

**Particles - Thin Lines brush controls**

Particle brushes emit particles from a central point, and in turn the particles draw a pattern of lines (paths) as they move across the canvas. You can adjust the appearance of the lines by using the controls on the **Particle - Thin Lines** brush panel. The lines of Particle brushes that use dynamic speckles can be adjusted by using the **Dynamic Speckles** panel. For more information, see “Using Dynamic Speckles with Particle brushes” on page 480.
The **Glow** check box makes particles shine, with colors building up to white. A dark background is required.

The **Weight** slider sets the opacity of particle paths. Use it together with **Weight Jitter** to add depth and dimension to rendered paths. The **Weight Jitter** slider randomly varies the opacity of individual particle paths.

In addition, the **Particles - Thin Lines** panel includes two controls to adjust the opacity of Spring Particle brushes. The **Path Opacity** slider sets the opacity of the particle path (the mark that each particle makes on the canvas). The **Spring Opacity** slider sets the opacity of the springs (the links between the particles).
To access the Particles - Thin Lines brush controls

2. Adjust any of the settings in the Particles - Thin Lines panel.

Using Dynamic Speckles with Particle brushes

Some Particle brushes can be used with dynamic speckles to create thicker, more pronounced brushstrokes. Dynamic speckles generate a continuous brushstroke from discrete spots of color or speckles. The speckles in the brushstroke are truly dynamic — they are generated as you paint.

To use dynamic speckles, you must choose a Dynamic Speckle dab type from the General brush control panel (Window ▶ Brush Control Panels ▶ General). For more information, see “Dynamic Speckles controls” on page 443.
A Spring Particle brushstroke (left) and a Dynamic Speckle Spring Particle brushstroke (right)
Texture painting

Corel Painter lets you paint with Texture brushes that create the appearance of surface texture. This brush category with source-blending technology makes it easy to integrate complex textures into your work. Whether you’re aiming for a look that is more lifelike or one that’s completely futuristic, or you want to make a digital painting look authentically timeworn, Texture Painting offers limitless possibilities.

Blend a texture into your painting to simulate cracked or peeling paint. Artwork by Cher Pendarvis.

3D artists can import a rendered version of a 3D model into Painter and add textures or perform touch-up work with Painter tools.
A 3D model is rendered into a 2D bitmap image (left); Texture is added to the image in Corel Painter to give the character more appeal and realism (right). Artwork by Mike Thompson.

Artists who start in grayscale can take their works to the next level by blending different textures into their grayscale paintings.
Texture Painting isn’t simply manipulating a layer’s opacity. It lets you intelligently blend a texture into existing content using a range of stylus expressions, such as pressure. It respects the transparency of the selected texture, giving you full control of when, where, and how much texture is used. You start by choosing or creating a texture and pairing it with brushes designed specifically for adding texture. And by combining Texture brushes, flexible brush customization options, and the ability to capture and import your own textures, you can add any number of surfaces styles to your work. You can even add Dab Stencils, grain, and smudging to the brushes with all the speed, precision and control you expect from Painter. In addition, you can make your own custom textures from scratch or by modifying a preset texture. For more information about textures, see “Textures” on page 493.

This section includes the following topics:
- “Painting with textures” (page 485)
- “Customizing Texture brushes” (page 487)

**Painting with textures**

Texture painting lets you add textures to your projects by taking the color and luminance components of a source image — the texture — and transposing them onto another surface — your painting — using different brush methods. Texture painting works with brushes that use any of the following dab types: Circular, Computed Circular, Captured, Single-Pixel, Dynamic Speckle Bristle, and Particle types (Flow, Gravity, and Spring).
You can display a representation of the texture onscreen to help you move it, position it precisely, and manipulate it in relation to the underlying brushstrokes or image. In addition, you can control how much of the underlying image you see through a texture. If you don’t want to see the texture or it’s obscuring your ability to paint, you can hide it.

You can quickly adjust the visibility of a texture by using the controls on the property bar: (1) Show Texture button; (2) Visibility slider.

Before you apply a texture, you can modify its appearance to suit your composition and concept. For more information, see “Transforming and editing textures” on page 499.

When you apply textures, you can specify how Texture brushes interact with previously applied brushstrokes. For more information, see “Customizing Texture brushes” on page 487.

### To paint with a texture

1. In the toolbox, click the **Brush tool**  
2. Click the Brush Selector on the Brush Selector bar.  
3. In the Brush library panel, click a Texture brush category and a brush variant.  
4. Click the Texture selector on the property bar, and click a texture.  

   If you can’t see a representation of the texture in the document window, click the **Show Texture** button on the property bar.

5. Choose settings from the property bar.

6. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To paint on</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The canvas</td>
<td>Select the canvas in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td>A layer</td>
<td>Select a layer in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: If you are painting with a brush that uses <strong>Source Blending</strong>, click the <strong>Pick Up Underlying Color</strong> button. For information about source blending, see “Blend the texture with the underlying image” on page 491.</td>
</tr>
</tbody>
</table>

486 | Corel Painter 2020 User Guide
7 Paint in the document window.

For information on creating, importing, transforming, and modifying textures, see “Textures” on page 493.

To show or hide the display of textures

• Click the Show Texture button on the property bar.

You can assign a shortcut key to this command. For more information, see “Customizing keys” on page 124.

To control texture visibility

• On the property bar, move the Visibility slider, or type a percentage in the Visibility box.
  A low value reveals more of the underlying brushstrokes.

To invert a texture

• Click the Invert Texture button.

Customizing Texture brushes

To quickly get started with texture painting, choose any of the brush variants available in the Texture Cover and Texture Source Blending brush categories. In addition, Corel Painter gives you full control to create custom Texture brushes.

There are a number of different methods that allow you to specify whether a Texture brush uses the color, luminance, or both the color and luminance information of a selected texture and whether it interacts with paper grain.

An example of a Texture brush variant (left), a Grainy Texture Luminance brush variant (middle), and a Grainy Texture Chroma variant (right)

You can control the amount of texture that a brushstroke reveals.
You can also specify how Texture brushes interact with paint already applied to the canvas. For example, Texture brushes can either cover or blend with the underlying image to create amazing effects.

Texture brushes can use the original texture color or mix the texture color with a different color. For example, if the texture that you want to use doesn't match the tone and color of your composition, you can sample a color from your painting and mix it with the texture color. You can choose an expression such as pressure, tilt, direction to vary the amount of color you mix into the texture. For more information, see “Expression settings” on page 373.
You can smudge a texture. Smudging reveals a little of the current texture as you push, pull, and smear pixels. You can choose a fixed amount of smudging or vary the effect with an expression. For example, if you link smudging to stylus pressure, light pressure will reveal more texture detail, increased pressure will reveal less detail.

For even more astonishing results, you can use dab stencils to shape the dab and modify the opacity of Texture brushes. For information about dab stencils, see “Dab Stencil controls” on page 445.

Texture brushes can have depth and support the impasto Depth and Color and Depth drawing methods. Corel Painter uses the luminance (brightness) information in the texture to determine how much depth is applied within a stroke. Light areas of the texture receive more depth; dark areas receive less. Black areas appear flat. For more information about impasto methods, see “Adjusting and creating Impasto brushes” on page 560. You can add or remove depth, and control the effect by manipulating the lighting of the painted result. Add depth to Texture brushes to create pores on skin, scales on a lizard, thick brick walls, and prickly pebble board.
An example of a Texture brush that uses the impasto Depth method (left) and the impasto Color and Depth method (right)

Experiment with different brush settings to produce the effect you like. Texture brush settings are saved as part of a brush variant or applied to any active brush. For more information, see “Adjusting brushes with brush controls” on page 371.

After you customize a Texture brush variant, you can associate it with a texture and save it as a brush look for use in future projects. When you save a look, it is added to the Look Libraries panel. For more information, see “Saving a brush look” on page 315.

For a list of sample brushstrokes using Texture brushes, see “Texture brushes” on page 358.

To customize a Texture brush

1. In the toolbox, click the Brush tool.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click a Texture brush category and a brush variant.
4. On the General panel (Window → Brush Control Panels → General), choose one of the following methods from the Subcategory list box:
   - Texture — uses both the color and luminance information of the texture
   - Grainy Texture — works like Texture but also interacts with paper grain
   - Texture Luminance — uses only the luminance (lighting) information of the texture
   - Grainy Texture Luminance — works like Texture Luminance but also interacts with paper grain
   - Texture Chroma — uses only the color information of the texture
   - Grainy Texture Chroma — works like Texture Chroma but also interacts with paper grain
5. Click the Texture Brushes flyout button on the property bar, and click Texture Brushes Panel.
6. In the Texture Brushes panel, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the maximum amount of texture a brushstroke reveals</td>
<td>Move the Strength slider.</td>
</tr>
</tbody>
</table>
To

Blend the texture with the underlying image

Control the color of a texture

Smudge a texture

You can also

Add depth to a Texture brush

Do the following

Enable the Source Blending check box.

Enable the Color Control check box. Enable one of the following options:

• **Current Color** — lets you mix the original texture color with the selected color
• **Texture Color** — lets you use the original texture color

Tips:

• To control the amount of color you apply with a brushstroke, move the Amount slider.
• You can choose an expression such as pressure, tilt, direction to vary the amount of color mixed into the texture.

Notes:

• The Color Control option is not available for brushes that use the Texture Chroma or Grainy Texture Chroma methods.
• The Texture Color option is available only for brushes that use the Texture Luminance and Grainy Texture Luminance methods.

Enable the Texture Smudging check box. Move the Amount slider to adjust the smudging amount.

Tip:

• To link texture smudging to an expression such as pressure, tilt, direction, choose an option from the Expression list box.

In the Impasto panel (Window ➤ Brush Control Panels ➤ Brush Media ➤ Impasto), choose one of the following drawing methods from the Draw To list box:

• **Color and Depth**
• **Depth**

From the Depth Method list box, choose Texture Luminance to use the texture luminance to control the appearance of depth. Drag the Depth slider to the right to increase depth, or to the left to decrease it.

Tips:

• To adjust the appearance of depth, click Canvas ➤ Surface Lighting, and adjust the sliders in the Appearance of Depth area.
• To adjust the ambient and directional lighting, click Canvas ➤ Surface Lighting, and experiment with the controls in the Ambient Lighting and Directional Lighting area, respectively.

For detailed information about the impasto depth controls, see “Adjusting and creating Impasto brushes” on page 560.
When painting with brushes that use **Source Blending**, you may notice overlaps when you overlay brushstrokes. To paint without overlaps, in the **Texture Brushes** panel, disable the **Source Blending** option and set the texture **Strength** to 100%. In the **Layers** panel, add a new layer, and choose the **Overlay** method from the **Composite Method** list box. Move the **Opacity** slider to adjust the intensity of the brush marks. This workflow produces results that are very similar to **Source Blending**.
Textures

Textures are an essential tool in digital painting. Whether you are an illustrator, character designer, concept artist, or photography hobbyist, Corel Painter can help you integrate intricate textures into your projects, add detail to your marks, and expand your creativity. You can add textures to the sky, land, and sea and paint nature scenes and environments. You can use textures to create the look of pores, scales, feathers, fur and add realism to your characters. Whether it's wood, glass, or metal, textures can simulate the appearance of materials. Aging textures can add natural-looking cracks and breaks to your paintings.

You can use textures in texture painting. For more information, see “Texture painting” on page 483.

You can also use textures in photo painting. For more information, see “To use a texture as a clone source” on page 191.
Explore the collection of textures in Corel Painter to find some interesting and useful textures that can spark ideas for your work, create your own custom textures, or import your library of content assets that you have built up over time.

Whether you choose a texture from the library of preset textures available in the application or create your own texture, Corel Painter provides powerful controls that let you synthesize, manipulate, and modify textures to achieve dramatic and unique effects.

This section includes the following topics:
- “Creating textures” (page 494)
- “Transforming and editing textures” (page 499)
- “Applying textures as fills” (page 500)
- “Using textures in photo painting and image compositing” (page 502)
- “Working with Texture libraries” (page 502)

Creating textures

You can use the preset textures provided with Corel Painter. In addition, you can import or create custom textures.

You create a texture by capturing the canvas or a layer. You can also create a texture from a selected area in an image. Textures are saved in the Corel Painter texture library format.
You can also create a texture by using Texture synthesis. The effect lets you generate a new image based on elements of a source texture or document. Corel Painter reproduces the original image on a larger scale by using all the visual elements in the input sample. Use the effect to expand small textures and create textures from brushstrokes in your document.

First, choose a source image. You can synthesize an image from a texture or from content in a Corel Painter document. When choosing a source image, you may find the following tips helpful.

- A big variance in color cast or brightness in the source image may result in a noticeable seam in the synthesized texture where the color or brightness varies greatly across the edge of the tiles. For best results, use images with similar color cast, brightness, and contrast across the image.
- Use source textures that are neither regular (with exact repeating patterns) nor very noisy (random), but somewhere in between.
- Use images that have some repeating similarity across the image.
- Avoid exactly repeating geometric patterns.
- Avoid very chaotic images that have little repeating similarity or pattern.
- Avoid images that have vignetting or other significant changes in appearance around the edges, or make a selection in the image to avoid the unwanted areas.
- Ensure there are many repetitions of the objects or features in an image. Avoid having unique objects and features (for example, a single green apple in a pile of red apples) or large objects and features that take up more than 10% of the image. These will not have any other features to match with and will make the resulting image fragmented and repetitive.
- Objects or features in an image should have a roughly similar size to other similar objects in the image. For example, in an image with apples and oranges, the apples should be approximately similar in size to the other apples; the oranges can be a different size as long as they are also approximately similar to the other oranges.
- Avoid images with perspective that make similar objects in the foreground and background have different sizes. You can use images with perspective provided objects across the image are similar in size.

Next, define an area within the source image that you want to use as an input sample. For best results, select a small area.

Once you decide which area you want to sample, you have to define the size of the synthesis building blocks — the tiles. The texture synthesis process works by taking an input seed — a tile — and randomizing it. The tile size you choose depends on the source image. In images with repeated shapes, lines, or colors, you can get good results with small tiles; in images without patterns, bigger tiles will allow you to include all the elements you need. Start with a tile size that is about 20% of the selection size, and experiment with increasing or decreasing the tile size until Corel Painter generates a pattern that you like.
You can regenerate a texture multiple times. Every time you apply the effect, Corel Painter creates an image with a different pattern and associates a random value — called a seed — with that pattern. You can manually enter random seed values, or you can let Corel Painter automatically generate them. The advantage of entering the seed values manually is that, as you try different values, you can choose the value that produces the desired result and reapply it. Preview the result in the document window and experiment until Corel Painter generates a pattern that you like.

When you are satisfied with the appearance, you can save the resulting image as a texture in the currently selected Texture library or send it to a new layer. You can specify the width and height of the resulting image. The maximum document size is 16,382 by 16,382 pixels; however, it may take a long time to synthesize images that exceed 2500 pixels.

All preset and custom textures are stored in libraries. For more information, see “Working with Texture libraries” on page 502.
To create a texture by capturing an area

1. Open or create an image.
2. Perform a task from the following table.

To create a texture from | Do the following
--- | ---
The canvas | Select the canvas in the Layers panel.
A layer | Select a layer in the Layers panel.
A selection | Choose the Rectangular Selection tool from the toolbox. Drag in the document window to select the area of the image that you want to capture as a texture.

3. In the Textures panel (Window | Media Panels | Textures), click the Capture Texture button.
4. Enter a name in the Save As box. The texture is added to the currently selected library.

When you create a texture from a layer, Corel Painter preserves the transparent areas.

To create a texture by using Texture synthesis

1. Open or create a document.
2. In the Texture Synthesis panel (Window | Media Panels | Texture Synthesis), choose a source image by performing a task from the following table.

To synthesize an image from | Do the following
--- | ---
A texture | Choose Texture from the Source list box, click the Texture selector, and click a texture.
Content in the active document | Choose Document from the Source list box.

Note: In a multi-layer document, all visible layers are merged, and the flattened image is used as a base for the synthesis.

3. Choose the Rectangular Selection tool in the toolbox.
4. In the document window, drag to define the sampling area that will be used to synthesize the new image.
   Note: Ensure your selection is 4 by 4 pixels or larger.
5. Move the Side Length slider to adjust the tile size.
   Note: Tiles have a square shape.
6. Generate the synthesized image by performing a task from the following table.
To

Generate a texture with a different pattern each time

Do the following

Enable the Random Seed check box.

Note: Each time you click the button, Corel Painter creates an image with a different pattern. Experiment until an image that you like is generated.

Generate the same pattern every time

Do the following

Disable the Random Seed check box. Enter a value in the Seed box.

Note:
• Each time you enter a value, Corel Painter creates an image with a different pattern. Note the value that produces an image that you like and re-enter it to get the desired result.

Tip:
• Click the Generate a texture with different pattern button to generate a different seed number.

7 Perform a task from the following table.

To send the synthesized image to

Do the following

A new layer

Enable the New Layer option.

The active Texture library

Enable the Texture Library option.

8 Type values in the Width and Height boxes to specify the size of the resulting image.

Note: Images that exceed 2500 pixels may take a long time to synthesize.

9 Click the Start button.

Tip: To stop the synthesis at any time, click the Stop button.

If texture synthesis doesn’t start, try one of the following:

• Make sure you select Document or Texture from the Source list box. This option is reset after each synthesis so you need to choose Document or Texture again to perform another synthesis.

• Delete the existing selection by holding down Ctrl + D (Windows) or Command + D (macOS), and then make a new rectangular selection.

If the texture that you want to synthesize is bigger than the size of your document, you will not be able to see the entire texture when sending the texture to a new layer.
For best results, use images with similar color cast, brightness, and contrast across the image. To improve the variance of an image, open the image in Corel Painter, click Effects ➤ Tonal Control ➤ Match Palette, move the Variance (Color) and Variance (Brightness) sliders to the left to reduce the color and brightness variance, and click OK.

If the colors in the source image don't match, try creating a grayscale version of the image. Click Effects ➤ Tonal Control ➤ Adjust Colors. Move the Saturation slider to the left for a less colorful image, or choose the lowest value for pure grayscale, and click OK. This is also useful for synthesizing textures that don't require color, such as images for papers and flow maps.

If the appearance of the resulting image is too repetitive, enable the Scramble option or try decreasing the tile size. If the resulting image is lacking in detail or objects or features are cut out of the source image, try increasing the tile size.

If texture synthesis is taking a long time, try making a small selection (for example, 250 pixels by 250 pixels) and choosing a small output size (for example, 1000 pixels by 1000 pixels) first.

To import a texture
1. In the Textures panel (Window ➤ Media Panels ➤ Textures), click the Import Texture button.
2. In the Import Texture dialog box, browse to the folder where the texture is stored.
3. Choose a texture, and click Open.

The texture is added to the current library.

You can also import multiple textures.

Transparency is supported only for PNG images.

The size of the texture depends on the original size of the image that you import. If you prefer not to resize the texture in Corel Painter, make sure you import it at the size you need it. For best results, use high-resolution images.

The texture that you import should not exceed the maximum size of 16,382 x 16,382 pixels.

Transforming and editing textures

You can scale, rotate, skew, or distort a texture interactively in the image window.

You can also edit a texture to modify its appearance. When you finish adjusting a texture and you are satisfied with the result, you can save it and begin painting with it. When you save a texture, it is added to the current texture library.

To apply a transformation to a texture
1. Create or open a document.
2. In the Transform Textures panel (Window ➤ Media Panels ➤ Transform Textures), click one of the following buttons:
   * Move and Size — lets you reposition and resize a texture
   * Scale — lets you change the width and height of a texture
   * Rotate — lets you turn a texture around its center axis
   * Skew — lets you slant the vertical and horizontal dimensions of a texture nonproportionally
   * Distort — lets you move the corners of a texture in different directions
   * Perspective Distortion — lets you move the corner of a texture to apply a one-point perspective
3. Click Commit.
To save the texture as a new library item, click **Save As**. The texture is added to the currently selected library.

After you finish making changes to a texture, it is recommended that you save it, so you can use it in the future.

To reset the texture origin point, click the **Reset reference point** button.

To discard the changes that you have made to the selected texture and continue painting, click **Cancel**.

**To edit a texture**

1. Create or open a document.
2. In the **Textures** panel (Window ➤ Media Panels ➤ Textures), hold down **Control** and click a texture (macOS), or right-click a texture (Windows), and choose **Export Texture to New Layer**. A new layer with the name of the texture appears above the active layer.
3. Make changes to the texture in the document window. To add the modified texture to the active Texture library, click the texture layer in the **Layers** panel, and then click the **Capture Texture** button in the **Textures** panel. Enter a name in the **Save As** box.

The size of the new layer is based on the document size. If the texture is smaller than the document, the space around the texture will be transparent. When you select, move, copy, or transform the layer, its bounding box shrinks to the texture size.

**Applying textures as fills**

Corel Painter lets you apply texture fills to images.
To apply a texture as a fill

1. Create or open a document.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To fill</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The canvas</td>
<td>Select the canvas in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td>A layer</td>
<td>Select a layer in the <strong>Layers</strong> panel.</td>
</tr>
<tr>
<td>A selection</td>
<td>Choose a selection brush from the Brush Selector Panel (Window ▶ Brush Selector ▶ Panel (Full View)) or a selection tool from the toolbox. Drag in the document window to select the area of the image that you want to fill.</td>
</tr>
</tbody>
</table>

3. Click the **Paint Bucket** tool in the toolbox.
On the property bar, click the **Fill Image** button.

From the **Fill** list box on the property bar, choose **Texture**.

Click the **Fill** selector on the property bar, and click a texture.

In the document window, click the canvas, selection, or layer.

You can also

Specify the range of colors to be filled

On the property bar, type a value in the **Tolerance** box or move the slider.

Specify the texture opacity for pixels outside the tolerance range

On the property bar, type a value in the **Feather** box or move the slider.

Soften the edges of the texture

On the property bar, click the **Anti-Alias** button.

Anti-aliasing is desirable when the **Feather** setting is extremely low or set to zero.

You can also choose a texture by clicking **Edit** ➤ **Fill**. In the **Fill** dialog box, choose **Texture** from the **Fill with** list box, and click the **Fill** selector. Move the **Opacity** slider to adjust the texture opacity, and click **OK**. Texture transparency is maintained.

Using textures in photo painting and image compositing

You can use textures in photo painting and creating composite images. For information about using textures as clone sources, see “To use a texture as a clone source” on page 191. After you create or modify a texture, you can embed it as a clone source. For information about working with embedded clone sources, see “Working with embedded clone sources” on page 193. Store your content assets as textures in a texture library and reuse them in your projects.

To embed a texture as a clone source

1. Create or open a document.
2. In the **Textures** panel (Window ➤ Media Panels ➤ Textures), select a texture, and click the **Embed Texture as Clone Source Image** button.

   The texture appears in the **Clone Source** panel (Window ➤ Clone Source) as an embedded clone source image.

   Transparency in PNG images is maintained.

Working with Texture libraries

You can organize and manage textures from the **Textures** panel. The **Textures** panel displays the default Textures library, the custom libraries that you create, and any custom libraries that you import. When you create a new texture, it is automatically saved to the current library. However, you can create a custom library and move the texture to that library. Texture libraries are saved in the `.texturelibrary` format.
For more information about creating, importing, exporting, removing, and restoring libraries, and moving textures between libraries, see “Libraries” on page 293.

To access the Textures panel

- Click Window ▶ Media Panels ▶ Textures.
Applying and adjusting flow maps

Flow maps are designed to maximize the creative potential of the Real Watercolor brushes and the Particle brushes by adding a textured surface that helps direct the flow of paint.

This section contains the following topics:
- “Getting started with flow maps” (page 505)
- “Choosing flow maps and compatible brush variants” (page 506)
- “Enabling flow maps and controlling flow resistance” (page 507)
- “Customizing flow maps” (page 508)

Getting started with flow maps

You can use flow maps when working with Real Watercolor and Particle brushes to create textured surfaces that help direct the flow of paint. Flow maps are similar to paper textures; however, the surfaces that they create have higher peaks and deeper valleys that allow for greater water displacement. The flow map relief encourages the paint to flow and settle in unique and irregular patterns. You can use flow maps in combination with paper texture to retain the paper grain.

A flow map (1) works with paper texture (2) to add relief to the image and encourage water displacement. The elevated areas (3) in the flow map help direct the flow of water (4).
This Real Watercolor brush variant is used with paper texture (1). The same brushstroke is used in combination with paper texture and the Gravel flow map (2).

Although flow maps are intended for Real Watercolor brushes, you can also use them with Real Wet Oil brushes.

Choosing flow maps and compatible brush variants

To quickly get started with flow maps, you can choose one of the flow map brush variants. They are available under the Real Watercolor brush category. These brush variants enable flow maps by default. You can experiment and choose a different flow map to produce the effect you like.
To choose a flow map brush variant
1. From the Brush library panel, choose the *Real Watercolor* brush category.
2. Choose one of the following brush variants:
   - Melted Flowmap
   - Noisy Flowmap Fringe
   - Wet Flowmap Fringe
   - Real Wet Flowmap Wash

To choose a flow map
1. Choose a flow map brush variant.
2. On the *Brush* tool property bar, click the *Flow Map* flyout button.
3. Click a flow map swatch in the *Flow Map Textures* area.

You can also choose a flow map in the *Flow Maps* panel (Window > Media Panels > Flow Maps).

Enabling flow maps and controlling flow resistance

You can choose an existing Real Watercolor brush variant and then manually enable flow maps. You can also adjust the flow resistance of a brush to enhance the flow map interaction. Flow resistance lets you control the degree to which the flow map surface, or the paper texture, affects the direction of the water flow.
When the flow resistance is set low, the water flows freely across the canvas (1), when the resistance is set high, the flow is obstructed (2).

Brushstrokes using the Noisy Flowmap Fringe brush variant set at a flow resistance of 0 (1), 33 (2), 66 (3), and 100% (4) with the Clouds flow map selected.

To enable flow maps and control flow resistance
1. In the Brush library panel, choose a Real Watercolor brush variant.
2. Choose Window ➔ Brush Control Panels ➔ Brush Media ➔ Real Watercolor.
3. In the Flow area, enable the Flow Map option to set the Source.
4. Move the Flow Resistance slider to adjust the resistance.

Moving the slider to the right increases the effect.

To maximize the effect of flow maps, you need to ensure that the Wetness control is set high and the Evaporation Rate control is set low.

You can also adjust the flow resistance of the Real Wet Oil brush variants by choosing Window ➔ Brush Control Panels ➔ Brush Media ➔ Real Wet Oil.

Customizing flow maps
You can create a custom flow map by using an existing paper texture or by capturing an area of an image.
To customize an existing flow map, you can rotate it. You can also modify the scale, contrast, and several other settings of a flow map the same way that you would modify paper texture. For more information, see “Working with paper texture and grain” on page 165. Note that flow maps benefit from increased scale and contrast; therefore, if you create a flow map from a paper texture or image, you should increase the scale and contrast.

An area of an image was selected (1) to create a flow map (2).

To create a flow map from a paper texture
1. In the Papers panel (Window ➤ Media Panels ➤ Papers), click a paper texture swatch.
2. In the Flow Maps panel (Window ➤ Media Panels ➤ Flow Maps), click the Create From Current Paper button.
   If you want to rename the flow map, right-click (Windows) or Control-click (macOS) the swatch, and choose Rename Flow Map.

To capture a flow map from an image
1. Open or create an image.
2. Choose the Rectangular Selection tool from the toolbox.
3. Drag in the document window to select the area of the image.
4. In the Flow Maps panel (Window ➤ Media Panels ➤ Flow Maps), click the Capture Flow Map button.
   If you want to blend the distinction between tile borders, drag the Crossfade slider to the right in the Capture Flow Map dialog box.
5. Type a name in the Save As text box.
   The flow map is added to the currently selected library.

To customize a flow map
1. In the Flow Maps panel (Window ➤ Media Panels ➤ Flow Maps), click a flow map swatch in the Flow Map Textures area.
2. Perform one or more actions from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate a flow map</td>
<td>Move the Angle slider.</td>
</tr>
<tr>
<td>Invert the flow map effect</td>
<td>Click the Invert button.</td>
</tr>
<tr>
<td>Resize the flow map pattern</td>
<td>Move the Scale slider.</td>
</tr>
<tr>
<td>To</td>
<td>Do the following</td>
</tr>
<tr>
<td>------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Control the contrast of the flow map</td>
<td>Move the <strong>Contrast</strong> slider. A higher setting alternates the flow map pattern from high to low more quickly and with fewer intermediate levels than a lower setting.</td>
</tr>
<tr>
<td>Control the brightness of the flow map</td>
<td>Move the <strong>Brightness</strong> slider.</td>
</tr>
</tbody>
</table>

When the **Brush tool** is active, you can customize the currently selected flow map by clicking the **Flow Map** flyout button on the property bar and adjusting the settings you want.
Corel Painter lets you simulate many different types of traditional hard media, such as pencils, pens, and markers. The hard media brush controls and variants give you a wide range of options for creating drawings, sketches, and renderings. You can use the preset variants or create your own collection of customized Hard Media brush variants.

This section contains the following topics:
- “Choosing a Hard Media variant” (page 511)
- “Modifying Hard Media profiles” (page 512)
- “Controlling the behavior of Hard Media variants” (page 513)
- “Previewing Hard Media dabs” (page 514)

Choosing a Hard Media variant

Corel Painter includes a vast array of preset Hard Media brush variants. You can use the variants as they are or customize them by using the Hard Media controls to build your own Hard Media toolkit. For information, see “Controlling the behavior of Hard Media variants” on page 513 and “Modifying Hard Media profiles” on page 512.

The Hard Media brush variants are found in different brush categories such as Pens and Pencils, Erasers, Markers, and more. The easiest way to find a Hard Media brush variant is to use the Search bar.

For a list of sample brushstrokes created with variants from the Markers and Pens and Pencils categories, see “Markers” on page 342 and “Pens and pencils” on page 348.
To find a Hard Media variant
1 On the Search bar, type **hard media** in the Search text box.
   The Search bar is located to the right of the property bar, in the upper-right corner of the document window.
2 Click a Hard Media brush variant in the list of search results.

**Modifying Hard Media profiles**

You can modify Hard Media profiles to change the shape and size of the dabs that you apply to the canvas. By changing the profile, you can simulate the real-world hard media that have different shapes, sharpness, or thickness. Using the **Hard Media** controls, you can change the size, and choose one of six profiles to modify the shape.

<table>
<thead>
<tr>
<th>Hard Media profile</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pencil Profile</td>
<td>Provides a sharper tip when perpendicular to the tablet, and provides a wider, softer tip when at an angle.</td>
</tr>
<tr>
<td>Medium Profile</td>
<td>Has a wide area of greater density at the center, with rapid falloff toward the edge.</td>
</tr>
<tr>
<td>Linear Profile</td>
<td>Provides maximum density at the center, with even falloff toward the edge.</td>
</tr>
<tr>
<td>Pointed Profile</td>
<td>Provides maximum density at the center, with rapid falloff toward the edge.</td>
</tr>
<tr>
<td>Dull Profile</td>
<td>Provides maximum density at the center, with high-density weighting toward the edge.</td>
</tr>
<tr>
<td>1-Pixel Edge</td>
<td>Provides maximum density throughout, with rapid falloff toward the edge, producing a 1-pixel, anti-aliased edge.</td>
</tr>
</tbody>
</table>

When changing the shape, you can use the **Squeeze** controls to specify the vertical and horizontal ranges of the dab. For example, tilting the tool while drawing can change the dab shape from round to elliptical. You can also change the size of the tip.

The Hard Media controls are usable only with the **Circular**, **Captured**, and **Eraser** dab types. For more information about dab types, see “General controls” on page 378.
You can also save your customized Hard Media variant. For more information, see “Adjusting brushes with brush controls” on page 371.

To choose a Hard Media tip profile
2. Click the Hard Media tip profile that you want to use.

To set the Hard Media tip size
1. With a Hard Media variant selected, choose Window  Brush Control Panels  Brush Shape  Size.
2. Move the Size slider to the right to increase the size of the tip, or move the slider to the left to decrease the size of the tip.

To set the Hard Media tip shape
2. In the Squeeze area, adjust any of the following sliders:
   • V Min — sets the amount of squeeze applied to the dab on the vertical axis. This setting represents the dab at its smallest.
   • V Max — sets the amount of squeeze applied to the dab on the vertical axis. This setting represents the dab at its maximum size.
   • H Min — sets the amount of squeeze applied to the dab on the horizontal axis. This setting represents the dab at its smallest.
   • H Max — sets the amount of squeeze applied to the dab on the horizontal axis. This setting represents the dab at its maximum size.

Controlling the behavior of Hard Media variants
Corel Painter lets you control how a Hard Media variant behaves when you apply strokes to the canvas. The Stepping slider controls the transition between narrow and wide sections of a stroke. Moving the slider to the right makes the transition appear more abrupt, and moving it to the left makes the transition smoother.

The Transition Range sliders let you determine the angle at which you transition from a fine point to a wider stroke when tilting your stylus. This control lets you simulate the look and feel of hard media such as pencils or markers. A real-world example of this would be holding a sharp pencil perpendicular to a piece of paper. When you draw at a 90° angle, you produce a very narrow or hard line. If you tilt your pencil to a 60° angle, you produce a wider or softer line.

The Hard Media controls are usable only with the Circular, Captured, and Eraser dab types. For more information, see “General controls” on page 378.

To set the Hard Media size step
2. Move the Size Step slider to the right to produce fewer angles between dabs, or move it to the left to create more angles between dabs.
To set the Hard Media transition range

2. Move the Start slider to set the angle at which the transition will start.
   Moving the slider to the right increases the angle; moving the slider to the left decreases the angle.
3. Move the Finish slider to set the angle at which the transition will finish.
   Moving the slider to the right increases the angle; moving the slider to the left decreases the angle.

Previewing Hard Media dabs

As you modify the Hard Media variants, you can preview your changes to see how they affect the dab shape and size in the Dab Profile panel. You can toggle between different views of the dab, including the Hard Media view. For more information about these views, see “Changing dab profiles” on page 401.

To choose a brush dab preview option

1. Choose Window ➔ Brush Control Panels ➔ Brush Shape ➔ Dab Profile.
2. In the Dab Profile panel, click the Brush Dab Preview Window until the desired preview appears.
Markers

Corel Painter includes a Markers brush category to simulate the professional markers that are used by illustrators, graphic designers, industrial designers, and architects for drawing and creating renderings.

This section contains the following topics:
- “Getting started with markers” (page 515)
- “Customizing markers” (page 516)

Getting started with markers

The brush variants in the Markers category replicate traditional markers used for drawing and creating renderings.

You can choose any of the following rendering marker variants from the Markers brush category:

- Art Marker
- Chisel Tip Marker
- Dirty Marker
- Felt Art Marker
- Fine Point Marker
- Fine Tip
- Leaky Marker
- Pointy Rendering Markers
- Blunt Tip
- Design Marker
- Dry Chisel Tip Marker
- Felt Marker
- Fine Tip Marker
- Flat Rendering Marker
- Medium Tip Felt Pens
- Round Tip Marker
Scratchy Dry Tip Marker

Thick n Thin Marker

Worn Marker Jitter

The strokes that you make with the Marker variants closely reflect those of traditional, high-quality markers, mainly because of the way the Marker variants interact with the canvas. For example, the Flat Rendering Marker in Corel Painter allow color buildup and pooling. One continuous brushstroke at a constant speed lays down one consistent color. However, if you lift the stylus, or release the mouse button, the color builds up, as it would with conventional markers. The Marker variants also let you overlay strokes, and because the applied color is somewhat transparent, the underlying colors show through.

The color builds up only when you either lift your stylus up from the tablet or let go of the left mouse button. Slowing down or stopping does not cause build up.

For a list of sample brushstrokes created with Marker variants, see “Markers” on page 342.

To choose a marker variant

1. Click the Brush selector on the Brush Selector bar.
2. In the Brush library panel, click the Markers brush category, and click a marker brush variant.

Customizing markers

You can customize a preset Marker variant by using various brush controls, such as General controls or Size controls. In addition, you can change the look of Markers more precisely by using the Hard Media controls that are specifically designed for modifying drawing media, such as markers and pencils. For more information about the Hard Media options, see “Hard Media” on page 511. For more information about customizing brushes, see “Adjusting brushes with brush controls” on page 371.

You can also save your customized Marker variant. For more information, see “Saving and deleting brush variants” on page 309.
The Image hose lets you paint with images instead of painting with color. The images flowing from the hose change as you make a brushstroke. You can modify the appearance of the default Image hose elements or create your own set of images so you can paint with a unique image series.

This section contains the following topics:
- “Painting with the Image hose” (page 517)
- “Adjusting the opacity and color of image hose elements” (page 519)
- “Adjusting the size and spacing of image hose elements” (page 520)
- “Indexing nozzle files” (page 521)
- “Understanding nozzles, ranks, and indexing” (page 522)
- “Creating a 1-Rank nozzle” (page 524)
- “Creating a 2-Rank nozzle” (page 526)
- “Creating a 3-Rank nozzle” (page 527)
- “Loading and managing nozzle files” (page 529)
- “Creating a nozzle from a movie” (page 530)

Painting with the Image hose

To start painting with the Image hose, you need to choose the Image Hose category from the Brush library, select an Image hose variant, and then choose the imagery that you want to apply. The imagery is stored in a nozzle file. For example, you can load images of any
description — leaves, bark, grass, stones, people, or whatever you want. When you paint with these image elements, you can build them into coherent shapes, such as a tree, hill, cobblestone street, or crowd of people.

As with other Corel Painter brushes, the Image hose has several variants. These built-in variants combine nozzle control factors (indexing rules) with brush settings to create different hose effects.

Variants are divided into two types — **Spray** and **Linear** — according to the placement of images in relation to the stroke. **Spray** variants scatter images. **Linear** variants place images directly on the stroke path. Variants also differ in the way they link the size and angle of images to factors such as stylus tilt, pressure, and position.

A variant’s name contains important information. For example, the variant’s name **Linear-Size-P Angle-D** indicates that this is a **Linear** variant that links the size of images you paint to the stylus pressure (P) and places them at an angle based on the direction (D) of the stroke. The letters R, W, and B in variants’ names signify Random, Wheel, and Bearing. For more information, see “Color Expression controls” on page 441 and “Understanding nozzles, ranks, and indexing” on page 522.

You can use these variants as a starting point and then adjust the brush and nozzle controls to deliver the images just as you want them. For more information, see “Adjusting the opacity and color of image hose elements” on page 519 and “Adjusting the size and spacing of image hose elements” on page 520.

You can also control the image output by increasing stylus pressure, so you can paint larger or more colorful images, or by changing the direction of the stroke, so you can change the angle of the images.

For a list of sample Image Hose brushstrokes, see “Image Hose” on page 338.

**To use the Image hose**

1. Choose the **Brush** tool from the toolbox.
2. Click the Brush Selector on the Brush Selector bar.
3. In the Brush library panel, click the **Image Hose** brush category, and click a brush variant.
4. Choose **Window** ➤ **Media Panels** ➤ **Nozzles**.
5. In the **Nozzles** panel, choose a nozzle from the list box.
   - You can also paint with nozzle files that you have created. For more information, see “Loading and managing nozzle files” on page 529.
6. Make a brushstroke on the canvas.
The Image hose deposits 24-bit images with an 8-bit mask. The mask enables you to layer the images gently, without aliased edges or artifacts.

Adjusting the opacity and color of image hose elements

You can change the appearance of the image hose elements by adjusting the opacity or color. For example, you can adjust the opacity to add transparency to the nozzle images and allow the background colors to show through.

You can change the opacity of Image hose strokes. Settings shown are 100% opacity (left) and 20% opacity (right).

You can also mix the additional color with the nozzle images to adjust the shading of image elements. If the Additional Color slider is set to 100%, the nozzle images remain unaffected. As you move the slider to the left, more of the additional color appears in the elements.

To adjust the opacity of image hose elements

• On the property bar, move the Opacity slider.

You can also randomize the effect by choosing Window ➤ Brush Control Panels ➤ Brush Media ➤ Opacity. In the Opacity panel, choose Random from the Expression list box.
To adjust the color of image hose elements
1. In the Color panel, click the Additional Color swatch and choose a color.
2. On the property bar, move the Additional Color slider.

You can also vary the additional color that is mixed with the nozzle images by moving the Additional Color Jitter slider on the property bar.

Adjusting the size and spacing of image hose elements
You can scale the size of image elements that are applied by the Image hose. At 100%, the images are the same size as they are in the nozzle file.

You can also control the space between images.

Because spacing is based on the diameter of the brush, the Size settings also affect image spacing. For example, increasing the brush size adds space between the images applied with the hose.

The Min Size slider also affects the size of images applied by the Image hose. When set to stylus pressure or direction, the Min Size setting determines the range within which the images you apply will vary in size. For more information, see “Spacing controls” on page 400 and “Size controls” on page 394.

You can also randomize the proximity of images to the stroke path by increasing jitter.

To adjust the scale of the image hose elements
1. Choose Window ➤ Media Panels ➤ Nozzles.
2. In the Nozzles panel, click the Nozzle options button ☰, and choose Set Nozzle Scale.
3. Type a value in the New Scale box.

You can also change the scale of the elements by moving the Size slider on the property bar, just as you would with other brushes.

To adjust the spacing between Image hose elements
1. Choose Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing.
2. Move the Spacing slider.
3. Move the Min Spacing slider.

To randomize the spacing between Image hose elements
• On the property bar, move the Stroke Jitter slider to the right.
Indexing nozzle files

A nozzle file can contain any number of images. Usually, the images are similar and form a logical series — that is, the images progress along some order. For example, the images might increase in size or advance in angle. It is not necessary for images to progress in a logical series, but the Image hose is more effective when they do.

"Indexing" refers to the method used to select particular images from the many images in a nozzle file. You can apply indexing rules to control the sequencing of nozzle images. For example, you can set up the nozzle so that by pressing harder with a pressure-sensitive stylus, you paint with larger images.

Ranks and indexing rules

Image nozzle files can be created with one, two, or three image progressions known as “ranks.” Corel Painter offers these three rankings, so each nozzle file can be identified as a 1-Rank, 2-Rank, or 3-Rank nozzle. For more information, see “Creating a 1-Rank nozzle” on page 524.

The following indexing rules are available for each rank in Corel Painter:

- **None** returns one element only — the last in the rank.
- **Velocity** indexes images from the rank based on the speed of the stroke. A faster stroke delivers elements from later in the rank. Velocity is often used with a mouse to mimic pressure. Velocity can be difficult to control. For this reason, you might want to use it in a rank with few elements.
- **Direction** indexes images from the rank based on the direction of the stroke. The first item in the rank corresponds to a left-to-right stroke (toward 3 o’clock). As the stroke direction progresses counterclockwise, the Image hose delivers subsequent images from the rank. The number of elements in the rank determines the directional change required to index a different element. For example, a nozzle file that contains 72 images at progressive angles delivers a different item at every 5° of stroke direction (360° divided by 72 equals 5°).

![This Arrow nozzle is an example of indexing based on Direction.](image)

- **Pressure** indexes images based on stylus pressure. Greater pressure selects images from later in the rank. Pressure works only with pressure-sensitive tablets. Pressure is a great control for requesting images from a nozzle. For example, if you set up your nozzle file to progress from small to large images, heavier strokes deliver larger images.
- **Wheel** indexes images based on the wheel setting on an airbrush stylus.
- **Tilt** indexes images based on the tilt of the stylus. Not all stylus models convey this information. This control does not work with a mouse.
- **Bearing** indexes images based on the position of the stylus. Not all stylus models convey this information. This control does not work with a mouse.
- **Rotation** indexes images based on the rotation of a flat-tip stylus that supports 360-degree rotation.
- **Source** delivers images based on the luminance of pixels in the clone source (or current pattern if you have not set a clone source). The pixels of the working document have a direct correspondence with the pixels of the clone source image. As the luminance increases, Source delivers images from later in the rank. For best results, the clone source should have the same dimensions as the document in which you’re working. For more information, see “Painting in the clone” on page 185. Depending on the nozzle you’re using, Source can be quite useful. For example, if the source image is black on the left and progresses through gradations to white on the right, the Image hose delivers images from the start of the rank at the left of the document, in the dark area. As the brush moves to the right into the lighter area, the Image hose delivers images from later in the rank. To take advantage of this feature, you may want to create a special source image for the single purpose of controlling the Image hose. The clone source image or pattern for controlling the Image hose may be grayscale. Remember, Corel Painter uses only the luminance values.
• **Random** selects images from the rank at random. Randomness can add irregularity of color and texture to the areas you paint with the Image hose. This contributes to the aesthetics of the painting, because minor irregularities occur in natural structures.

• **Sequential** indexes images in the order they appear in the rank — moving left to right, and top to bottom.

To change the indexing rule

1. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Image Hose.
2. For each rank in the nozzle, choose an indexing rule from the list box.

   If you choose **Direction**, adjust the **Direction** slider.

   If you want to invert the effect of the indexing rule, click the **Invert Rank** button. For example, if you choose **Pressure** for an indexing rule, greater stylus pressure selects images from later in the rank. Inverting the rank produces the opposite result — greater stylus pressure delivers images from earlier in the rank.

The indexing rules for **Rank 2** and **Rank 3** have no effect on a **1-Rank** nozzle.

**Understanding nozzles, ranks, and indexing**

You can create custom nozzles for the Image hose by choosing a series of images and then applying ranks and indexing rules. After saving a custom nozzle, you can load it so you can use it in an image. For more information, see “Loading and managing nozzle files” on page 529.

You can create a simple nozzle (1-Rank) or, as your Image hose requirements become more exacting, you can create complex nozzles (2-Rank or 3-Rank) that involve two or three progressions — for example, images getting larger and changing angle. In this case, you’ll use one input factor to determine image size and use another factor to determine image angle.

**Introducing the rank indexing system**

A 1-Rank indexing system is simply a numbered sequence. You can locate any element in the sequence by specifying its number — for example, “Item 3.”
A **2-Rank** indexing system uses two perpendicular indexes. The first rank extends horizontally and the second extends vertically. Again, you’ll vary input to locate an item for either rank. You can think of indexing in the two ranks as “selecting a column” and “selecting a row.” The Image hose delivers the image that is located where the selected column and row intersect. For this to work properly, you must use different indexing rules (input factors) for selecting in each rank.

A **3-Rank** indexing system extends the **2-Rank** model. The third rank is created by repeating the 2-Rank “set.” Within the selected set, the **1-Rank** and **2-Rank** indexing (described above) is used. You must use different indexing rules for selecting in each rank.

A **3-Rank** indexing system can be used with calendar dates. Any day — past, present, or future — can be located by specifying the month, day, and year. For example, “February 25, 1962 (2/25/1962).”

**Designing nozzles: 1, 2, or 3 ranks**

A nozzle file contains a series of images arranged in a regular grid. Usually, the images are progressive in terms of size, shape, angle, or color. Progression is not necessary, but it increases the sophistication of the Image hose. For example, a nozzle file with images progressing in size can be set up so that greater stylus pressure paints incrementally larger images.

![A 1-Rank nozzle progresses in one dimension. In this example, changing angle is the first rank.](image1.png)

If you want a two-dimensional progression, such as having image elements increasing in size and changing angle, you need to set up your images as a **2-Rank** nozzle file. Painting with a **2-Rank** nozzle, you can control where your image comes from in terms of both progressions. In this case, you use a different input factor to control the location of the image elements in each rank.

![A 2-Rank nozzle progresses in two dimensions. In this example, changing angle is the first rank, and changing size is the second rank.](image2.png)

You can extend the nozzle to a third progression, creating a **3-Rank** nozzle. Again, you use a separate indexing rule (input factor) to control the location in each rank. If you use one indexing rule to control two ranks, some image elements become unavailable. In the following image, **Rank 3** is a progression in color. You might control this final rank with randomness, velocity, or source — depending on your plans for the image.
Color is the third rank in this 3-Rank nozzle.

It is recommended that you consider how you will control each rank before you build a nozzle. The way you lay out the images can limit the ways you can control the indexing. Before you begin building a nozzle, you must decide which rank level you need as well as how many elements you want in each progression. For more information, see “To change the indexing rule” on page 522.

Preparing images

Regardless of the rank level of the nozzle you are making or the method you use to build it, the following tips will help you develop the individual images.

Each element in an Image hose nozzle must be selected. The selection allows you to paint with images of irregular shape. Only what is inside the selection will flow from the Image hose.

You might want to work by creating a silhouette of the image shape as a selection, and then fill in the color information later. With soft edges to the selection, you can create images that are anti-aliased automatically. This improves the continuity across an area of hosed images.

You can create Image hose nozzles from layers. As you create image elements, turn them into layers. If the layer looks good when dropped on different backgrounds, the image will look good as a nozzle element. Building a nozzle from layers offers advantages in convenience as well.

Another technique is to float the image on a black background and add a drop shadow. This will enhance the appearance of three dimensions, as image elements build up in layers. When all elements have the shadow in the same position, the light source appears the same across the painted area. For more information, see “Layers” on page 569.

Creating a 1-Rank nozzle

To create a 1-Rank nozzle, first you create the images that you want to include in the nozzle. Each image must be created on a separate layer. You can then select and group the individual layers and save the nozzle file in the RIFF format. To use the new 1-Rank nozzle, you load it in the nozzle library. For more information, see “Loading and managing nozzle files” on page 529.

In a 1-Rank nozzle, the images do not need to be in one line. Corel Painter wraps images onto several lines to create a document of reasonable shape. Corel Painter follows a mathematical rule in reconstructing the rank of images. This rule is contained in the nozzle definition. For more information, see “To build a 2-Rank nozzle” on page 526.
Nozzles are most useful when they deliver similar images with some irregularity — for example, butterflies on flowers.

To create a 1-Rank nozzle from layers
2. Click the New Layer button.
3. Create an image element to be used as a nozzle.
   The alignment of layers in the document doesn’t affect the nozzle-building process.
4. Repeat steps 2 and 3 to create additional image elements.
   Rearrange the layer hierarchy to create the progression you want in the nozzle. The top layer on the list will be the first element in the nozzle sequence. Moving down the list advances through the element progression.
5. Hold down the Shift key, and select the layers that you want to add to the nozzle.
6. Click the Layer Commands button and choose Group Layers.
   All items are now part of the same group.
7. Choose Window ➤ Media Panels ➤ Nozzles.
8. In the Nozzles panel, click the Nozzle options button, and choose Make Nozzle From Group.
   Corel Painter creates a new, untitled image. This is your nozzle file.
9. From the menu bar, choose File ➤ Save.
   Save the file to the RIFF format.
Creating a 2-Rank nozzle

If you want to create a 2-Rank nozzle, such as a nozzle with a two-dimensional progression, you need to set up the nozzle images accordingly. Unlike 1-Rank nozzles, nozzles of two and three ranks cannot be created from a layer group. You must build these nozzles manually. The indexing system requires the nozzle images to fit in a grid. You can create a nozzle file by setting up a grid and placing an image element at the center of each cell.

The cell size is based on the smallest rectangle that will hold the largest image element (including its selection). To make sure that your images fit in the grid, copy your largest image element to a layer. After you have set up the nozzle images in the grid, you can build your nozzle. For more information, see “Creating and deleting layers” on page 574.

To determine the grid cell size and nozzle dimensions

1. In the toolbox, click the Layer Adjuster tool, enable the Auto-Select Layer check box on the property bar, and in the document window click the layer with the largest image element that you want to include in the nozzle.

   Corel Painter displays the pixel width and height of the layer’s content in the Navigator panel. To display the Navigator panel, choose Window ➤ Navigator.

   You might want to use slightly larger values for the grid cell size.

2. Multiply the number of items in Rank-1 by the cell width.

   This value is the nozzle’s width.

3. Multiply the number of items in Rank-2 by the cell height.

   This value is the nozzle’s height.

To create the grid

1. From the menu bar, choose File ➤ New, and enter the nozzle’s width and height in the Width and Height boxes.

   You must enter the nozzle’s width and height that you calculated in steps 3 and 4 of “To determine the grid cell size and nozzle dimensions” on page 526.

2. From the menu bar, choose Canvas ➤ Virtual Grid ➤ Virtual Grid Options.

3. In the Grid Options dialog box, set the Horizontal spacing and Vertical spacing to the values of the cell width and height, and click OK.

   You need to enter the cell width and height from step 1 of “To determine the grid cell size and nozzle dimensions” on page 526.

4. Show the grid by choosing Canvas ➤ Virtual Grid ➤ Show Virtual Grid.

   The grid should describe the number of elements you want in each rank — Rank 1 horizontally and Rank 2 vertically.

To build a 2-Rank nozzle

1. Place one image element in the center of each grid cell.

   Follow an appropriate progression based on your intentions for controlling this nozzle.

   The easiest way to do this is with layers. When you bring image elements into the grid as layers, they bring their layer masks with them. If the image elements are layers in different files, it is easier to open the files one at a time.

2. From the menu bar, choose Window ➤ Layers.

3. In the Layers panel, select all layers.

4. Click the Layer options button, and choose Drop and Select.

5. From the menu bar, choose File ➤ Save As, and save the file in RIFF format.
In this finished 2-Rank nozzle, variety is the first rank, and size is the second rank.

To paint with your new nozzle file, you’ll need to load it first. For more information, see “To load a 1-Rank nozzle file” on page 529.

Creating a 3-Rank nozzle

You can create a 3-Rank nozzle using the grid method.

This nozzle file has three items in Rank 1, three items in Rank 2, and three items in Rank 3.
528 | Corel Painter 2020 User Guide

Painting with the 3-Rank nozzle “Broken Shells”

To create a 3-Rank nozzle

1. Build or open a 2-Rank file.
2. Determine the number of elements you want in the third rank.
3. Choose Window → Navigator to display the Navigator panel, and check the height of the current nozzle file.
4. Multiply the number of items in the third rank by the height of the file.
   The result will be the height of your 3-Rank nozzle file.
5. Choose Select → Reselect.
6. Choose Select → Float.
7. Choose Edit → Copy.
   Now you must extend this file vertically to accommodate the items in the third rank.
8. In the Layers panel, select the canvas.
9. From the menu bar, choose Canvas → Canvas Size.
10. To set the canvas to the height of your 3-Rank nozzle, add the correct number of pixels in the Add: pixels to bottom box.
   The value you need is the difference between the height of the 3-Rank nozzle calculated in step 4 and the height of the open 2-Rank nozzle.
   Now you can develop images for each item (set) in the third rank.
11. Choose Edit → Paste, and position the pasted layer in the area you added.
    The images should be centered in the grid cells.
    If necessary, modify the images in this layer.
12. Select both layers in the Layers panel.
13. Click the Layer options button ⬇️, and choose Drop and Select.
14. Choose File → Save, and save the file in RIFF format.
   If you previously defined this file as a nozzle, you must edit the definition to describe the three ranks you created.
15. Choose File → Get Info, and edit the nozzle definition in the File Information dialog box.
   For example, the nozzle definition “Image hose 3 by 3” describes a 2-Rank nozzle with three image elements (items) in Rank 1 and three image elements in Rank 2. Suppose the new nozzle has three image elements in Rank 3. To paint with images from all three ranks, you need to change the nozzle definition to “Image hose 3 by 3 by 3”.

To paint with your new nozzle file, you first need to load it. For more information, see “To load a 1-Rank nozzle file” on page 529.
Loading and managing nozzle files

To paint with a custom nozzle file, one that isn’t available in a nozzle library, you need to load it in the application. You can also store custom nozzle files by adding them to a nozzle library. For information about painting with nozzle files using an Image hose variant, see “Painting with the Image hose” on page 517.

To load a 1-Rank nozzle file

1. Choose Window ➤ Media Panels ➤ Nozzles.
2. In the Nozzles panel, click the Nozzle options button , and choose Load Nozzle.
3. Choose a nozzle from the Open dialog box, and click Open.
4. You can now paint with the nozzle.

To load a 2-Rank or 3-Rank nozzle file

1. Choose Window ➤ Media Panels ➤ Nozzles.
2. In the Nozzles panel, click the Nozzle options button , and choose Load Nozzle.
3. Choose a nozzle from the Open dialog box, and click Open.
4. In the Item Width and Item Height boxes in the Nozzle Definition dialog box, enter the values you set in the nozzle file. These values describe the grid cell size.
   - If you are not sure about these values, first open the nozzle file, and choose File ➤ Get Info. The File Information dialog displays all the information you need. For example, “Image hose 3 by 2 items (height 100, width 100)” indicates that this is a 2-Rank nozzle, with three image elements in Rank 1 (horizontal progression) and two image elements in Rank 2 (vertical progression). Item width and height are 100 pixels each (grid cell size of 100 by 100 pixels).
5. In the Index Rank box, enter 2 for a 2-Rank nozzle and 3 for 3-Rank nozzle.
6. In the Rank columns, enter the number of image elements used in each rank of the nozzle file.
   - If this is a 2-Rank nozzle file, enter 1 in the Rank 3 column.
   - If the values you enter do not describe the file, Corel Painter won’t accept them. In other words, the “number of items” in Rank 1 (horizontal progression) multiplied by the “item width” must equal the width of the nozzle file; the “number of items” in Rank 2 (vertical progression) multiplied by the “item height” must equal the height of the nozzle file.
   - Remember, you still need to describe the indexing rule for each rank.

   Corel Painter needs the information you enter in the Nozzle Definition dialog box to index images correctly.

To add a nozzle to the library

1. Choose Window ➤ Media Panels ➤ Nozzles.
2. In the Nozzles panel, click the Nozzle options button , and choose Load Nozzle.
3. Locate your nozzle file in the dialog box, and click Open.
   - If necessary, enter the values to define the number of elements, their size, and rank.
4. In the Nozzles panel, click the Nozzle options button , and choose Add Nozzle to Library.
5. In the Save Nozzle dialog box, name the nozzle.
To retrieve and edit a nozzle

1. Choose **Window** ➤ **Media Panels** ➤ **Nozzles**.

2. In the **Nozzles** panel, click the Nozzle options button ➤ , and choose **Check Out Nozzle**.

3. In the **Check Out Nozzle** dialog box, type a value in the **Scale** box.
   - Corel Painter opens the nozzle file in an image window.

4. Choose **Select** ➤ **Reselect**.

5. If necessary, edit the file.
   - Make sure to keep the selections.

6. Choose **File** ➤ **Save As**, and save the file to the folder you want.
   - If you want to protect your original nozzle, save the file under a different name.

7. Choose **Window** ➤ **Media Panels** ➤ **Nozzles**.

8. In the **Nozzles** panel, click the Nozzle options button ➤ , and choose **Load Nozzle**, and select the nozzle you just saved.

9. To put the nozzle back in the library, click the Nozzle options button ➤ , and choose **Add Nozzle to Library**.

Creating a nozzle from a movie

(Windows only)

On the Windows operating system, Corel Painter lets you create an Image hose nozzle from a movie. This allows you to transform each frame of a Corel Painter movie into Image hose imagery. The frame size describes the item size. If you’re creating a movie just to turn it into a nozzle, set the frame size just large enough to hold your largest image element. You can use the selection in each frame to control the shape of the images.

The **Make Nozzle From Movie** command automatically creates a 1-Rank nozzle. If you want, you can use this technique to create a 2-Rank nozzle.

To make a nozzle file from a movie

1. Open the movie that you want to turn into a nozzle file.

2. Choose **Window** ➤ **Media Panels** ➤ **Nozzles**.

3. In the **Nozzles** panel, click the Nozzle options button ➤ , and choose **Make Nozzle From Movie**.

   - An untitled image file appears containing each movie frame.

4. If you didn’t create selections in a frame of the frame stack, you can create the selections now.

   - Remember, each image element must be included in the selection.

5. Save the file in RIFF format.

   - You can now load and use this file as you would any 1-Rank nozzle file.

To make a 2-Rank nozzle from a movie

1. Choose **Movie** ➤ **New Movie**, and start a movie.

   - The frame size (canvas width and height) should be just large enough to hold your largest image element.

   - The total number of frames must equal the number of elements in Rank 1 multiplied by the number of elements in Rank 2. For example, for a 2-rank nozzle with three items in Rank 1 and three items in Rank 2, the movie needs to contain nine frames.

2. Add an image element to the first frame. You can add image elements by using selections or layers.
3 In the Layers panel, click the Layer options button, and choose Drop and Select.

4 Move to the second frame, and add an image element. Edit the image element if necessary, and repeat step 3 before moving to the next frame.

5 Continue adding image elements to the remaining frames. Make sure to apply the Drop and Select command before moving to a new frame.

You need to arrange image elements in sets according to the second rank. In the following example, the second rank progression for the new nozzle is changing color. The movie is organized in three color sets. Frames 1 to 3 form the red set; frames 4 to 6, the green set, and frames 7 to 9, the yellow set. Each set is the first rank progression (changing angle) for the new nozzle and contains images that are the same color but are placed at a different angle.

The image elements in this movie are arranged in color sets according to the second rank.

6 In the Frame Stacks panel, click the Rewind button to return to the first frame of the movie.

7 Choose Window ➤ Media Panels ➤ Nozzles.

8 In the Nozzles panel, click the Nozzle options button, and choose Make Nozzle From Movie.

A new file appears.

The resulting nozzle file from the movie in the previous example.

9 From the menu bar, choose File ➤ Get Info.

The File Information dialog box holds the information Corel Painter uses to index in this file.

10 Edit the statement to describe the nozzle index you created.
For example, the statement "Image hose 9 items" describes a 1-Rank nozzle with nine image elements. To describe a 2-Rank nozzle with three items in Rank 1 and three items in Rank 2, you need to change the statement to “Image hose 3 by 3 items.”

11 Save the file.

To paint with the new nozzle file, you need to load it first. For more information, see “To load a 2-Rank or 3-Rank nozzle file” on page 529.

Do not allow empty frames at the end of the movie.
RealBristle brushes

RealBristle brushes bring a new level of realism to the digital painting experience by simulating the natural movement of an artist’s brush. The resulting brushstrokes and their interaction with the canvas more closely reflect the look and feel of working with a traditional art brush.

RealBristle brush variants are based on brush variants from different brush categories, such as Acrylics, Oils, and Watercolor.

When you work with RealBristle brushes, enabling the Enhanced Brush Ghost option gives you more visual feedback about your brush. For more information, see “Setting up the drawing cursor” on page 151.

This section contains the following topics:
- “Getting started with RealBristle brushes” (page 533)
- “Modifying RealBristle settings” (page 534)
- “Using RealBristle brushes with Dynamic Speckles” (page 536)

Getting started with RealBristle brushes

RealBristle brush variants are stored in various brush categories. They consist of a broad range of bristle-based brushes that let you apply brushstrokes to the canvas or a layer.

To choose a RealBristle brush variant

1. Click the Brush Selector on the Brush Selector bar.
2 In the Brush library panel, click a brush category that contains a RealBristle variant, and click a RealBristle brush variant.

You can find RealBristle brush variants in brush categories such as Acrylics, Oils, and Watercolor. Their names begin with the word “Real.”

Modifying RealBristle settings

You can work with a preset RealBristle brush variant or customize a preset brush and save it as a new brush variant. The RealBristle panel gives you easy access to settings that let you modify a brush variant.

The following diagram outlines some key terminology used to describe RealBristle brushes and their settings.

The RealBristle panel

The RealBristle panel contains the following settings:

Roundness — lets you control the rounding along the width of the brush and overall shape of the brush. With a round brush, lower values flatten the brush to create an elliptical shape (can be flattened to a minimum thickness of 10% of the diameter). With a flat brush, lower values create a brush with more angular corners (90 degree edges as opposed to rounded edges).

Expression — lets you choose an expression, such as direction or velocity, to rotate the brush. For information about expression settings, see “Expression settings” on page 373.

Bristle length — lets you control the length of the bristles, from the end of the ferrule to the tip of the brush. The bristle length is calculated by multiplying the brush size value by the bristle length value you choose. For example, if your Brush size setting is 20, and your Bristle length setting is 2, the length of the bristles is 40.

Profile length — lets you control the length of the profile as a percentage of the overall length of the bristles.
Although quite different in shape, both brushes have a Profile length of approximately 50%.

**Bristle rigidity** — lets you control the flexibility of the bristles. Lower values create a more flexible brush, similar to a sable hair brush; higher values create a more rigid brush, similar to a hog hair brush.

The brush on the left has a Bristle rigidity setting of approximately 90%; the brush on the right has a setting of approximately 30%.

**Fanning** — lets you control how the bristles spread out from the ferrule. Lower values keep the bristles closer together, creating a more pointed tip; higher values spread the bristles out.

The brush on the left represents a Fanning setting of 100%; the brush on the right represents a setting of 0%.

**Friction** — lets you control how smoothly the bristles move across the canvas. This setting works in conjunction with the **Rigidity** setting. Lower values produce smoother strokes; higher values produce more textured, splayed brushstrokes.

**Height** — lets you control the minimum distance between the ferrule and the canvas. Higher values let you paint with the tip of the brush only; lower values let you compress the bristles against the canvas, causing the bristles to splay in different directions.

The brush on the left represents a Height setting of 100%; the brush on the right represents a height setting of 50%.

To open the RealBristle panel

* Choose **Window** ▶ **Brush Control Panels** ▶ **Brush Shape** ▶ **RealBristle**.
To customize a RealBristle brush variant

1. Click the Brush Selector on the Brush Selector bar.

2. In the Brush library panel, click a brush category that contains a RealBristle variant, such as Acrylics, Oils, and Watercolor, then click a RealBristle brush variant.

3. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ RealBristle.
   If the selected brush variant is a true RealBristle brush, the controls in the RealBristle panel are available.

4. In the RealBristle panel, enable the Enable RealBristle check box.

5. Choose Window ▶ Brush Control Panels ▶ Brush Shape ▶ Dab Profile.

6. In the Dab Profile panel, click the brush tip profile that you want to use.

7. In the RealBristle panel, adjust any of the Brush sliders.

8. In the RealBristle panel, adjust any of the Surface sliders.

By enabling the Enable RealBristle check box, you can create RealBristle brushes from any brush variant that uses the following Dab types: Camel Hair, Flat, Palette Knife, or Bristle Spray.

Using RealBristle brushes with Dynamic Speckles

Some RealBristle brushes can be used with dynamic speckles to create thicker, more pronounced strokes. To use dynamic speckles with a RealBristle brush, you must first choose the Dynamic Speckle Bristle dab type from the General brush control panel. For more information, see “Dynamic Speckles controls” on page 443.
Thick Paint

Thick Paint brushes offer a natural-media experience with the look and feel of thick paint and traditional impasto. They can help you paint beautiful images by adding depth, texture, or movement regardless of whether you are creating traditional art, photo art, or illustrations.

Thick Paint brushes create visible brush and knife marks in the painting. Artwork by Cher Pendarvis.
Thick Paint brushes apply paint that you can blend, build up, push, pull, and scrape. You can use these brushes to create dry and semi-transparent brushstrokes, reveal or hide paper texture, and blend brushstrokes naturally. In addition, you can displace and carve paint, creating indents in the brushstrokes.

Thick Paint brushes can be adjusted with the help of presets and special Thick Paint controls. You can use the pressure, the tilt, and even the rotation of your stylus to control and vary your brushstrokes with ease.

Thick Paint brushstrokes are applied on special layers. You can adjust the properties of these layers for a more or less pronounced thick-paint effect.

Brushstrokes applied with Thick Paint brushes reflect the light in a specific way. You can adjust the lighting and shadows in the brushstrokes to fine-tune brushstroke appearance and set the lighting of your image.

Thick Paint brushes create brushstrokes similar to Impasto brushstrokes but with a more realistic look and feel. For information about Impasto, see “Impasto” on page 559.

This section includes the following topics:
- “Painting with Thick Paint” (page 538)
- “Thick Paint - Media controls” (page 541)
- “Thick Paint - Brush controls” (page 545)
- “Adjusting Thick Paint layers” (page 548)
- “Adjusting Thick Paint lighting” (page 549)
- “Cloning with Thick Paint brushes” (page 552)

Painting with Thick Paint

There are two types of Thick Paint brushes: bristle brushes and palette knives. Bristle brushes let you apply thick paint while simulating the movement of a traditional artist brush; palette knives let you scrape, push, and drag colors in your image.

To find a brush that has the specific shape or mark you need, browse the Thick Brush variants accessible from the Brush Selector. If you are looking for a Thick Paint Bristle brush, you can choose from shapes such as Angle, Detail, Fan, Flat, Filbert, Rigger, and Round. All Thick Paint Palette Knife brushes have the same bar shape.

Once you find the brush you want, you can start painting. You can also quickly adjust brushstroke appearance by accessing presets and other controls from the property bar.
Technique presets

Depending on the technique you want to use, you can choose from the following presets:

**Thick** lets you add thick, rich brushstrokes that have a very pronounced impasto effect.

**Soft** lets you apply smooth, flat, and fluid brushstrokes that are ideal for adding detail to an image or filling large areas.

**Thin** lets you apply thin brushstrokes that lightly cover existing strokes and can reveal some paper texture.

**Dry** lets you paint long, crisp brushstrokes, with visible bristle marks. With this preset, you can use the brush to skim the surface, applying a light touch to create fully opaque brushstrokes. You can also use **Dry** for brushstrokes that drag existing paint.
Loading paint

Most Thick Paint brushes are loaded with a certain amount of paint. You can adjust the amount of paint on your Thick Paint brush before you start painting. That way, you don’t need to interrupt your painting to refill with paint.

Thick Paint controls

Special Thick Paint brush controls let you customize your brushstrokes and create your own Thick Paint brushes. These controls are grouped into two panels: Thick Paint - Media and Thick Paint - Brush. The Media controls let you customize the paint applied by the Thick Paint brush. The Brush controls let you customize the behavior of the brush. Most controls are common for Thick Paint Bristle brushes and Thick Paint Palette Knife brushes. For more information, see “Thick Paint - Media controls” on page 541 and “Thick Paint - Brush controls” on page 545.

In addition, you can add RealBristle features to your Thick Paint Bristle brushes. For more information about RealBristle features, see “Modifying RealBristle settings” on page 534.

You can also improve the brush performance of Thick Paint brushes.

To paint with a Thick Paint brush

1 In the toolbox, click the Brush tool .
2 Click the Brush Selector on the Brush Selector bar.
3 In the Brush library panel, click the Thick Paint brush category, and click a brush variant.
4 Paint in the document window.

To choose a Thick Paint technique

1 Select a Thick Paint brush.
2 On the property bar, click the Technique button , and choose a preset technique.

To load a Thick Paint brush with paint

1 Select a Thick Paint brush variant.
2 Click the Paint Load button on the property bar.
3 Drag in the document window to load the brush with the amount of paint you want.

The Paint Load control that appears shows the amount of paint loaded on the brush.

You can create a custom shortcut to access the Paint Load control. Choose Corel Painter 2020 menu Preferences Customize Keys (macOS) or Edit Preferences Customize Keys (Windows). From the Shortcuts (Windows) or Shortcuts for (macOS) list box, choose Other. In the list of Application Commands, scroll down to the Thick Paint Load (onscreen) command. In the
Shortcut column next to the command, type the shortcut keys you want to assign. Click OK. If the shortcut you assigned is already in use, a message appears below the Application Commands list. To proceed, click one of the following:

- **Accept** — to assign the shortcut to the Thick Paint Load (onscreen) command while deleting the shortcut key from the conflicting command
- **Accept and Go To Conflict** (Windows) or **Apply and Reassign** (macOS) — to assign the shortcut to the Thick Paint Load (onscreen) command and then assign another keyboard shortcut to the conflicting command

You can also load paint onscreen by using keyboard shortcuts, similarly to the way you can change brush attributes such as size, opacity, squeeze, and angle. First, hold down Command + Option (macOS) or Ctrl + Alt (Windows), and drag in the document window to resize the brush. Release the keys without releasing the mouse button or lifting the stylus, and then press Command (macOS) or Ctrl (Windows) several times to cycle through opacity, squeeze, and angle until the Paint Load control is displayed. Next, drag in the document window to load the brush.

**To improve the performance of Thick Paint brushes**

- Do any of the following:
  - In the toolbox, click the Grabber tool Click the High Quality Display button on the property bar to disable it.
  - If the Navigator panel is displayed, hide it by clicking Window ▶️ Navigator or Cmd + 7 (macOS) or Ctrl + 7 (Windows).
  - Use thick paint without ambient lighting. See “To disable ambient lighting” on page 551.
  - Increase the spacing between the droplets of paint. Select a Thick Paint brush variant. Click the Thick Paint – Media flyout button on the property bar, and click Thick Paint - Media Panel . Adjust the Spacing slider. Higher values result in improved brush performance.
  - Decrease the brush density. Select a Thick Paint brush variant. Click the Thick Paint – Brush flyout button on the property bar, and click Thick Paint - Brush Panel . Move the Brush Density slider to the left by very small amounts (for example, decrease the value by 2%) to reduce the number of bristles in the brush.

**Thick Paint - Media controls**

To customize Thick Paint brushes, you can adjust the paint and the painting surface from the Thick Paint - Media panel (Window ▶️ Brush Control Panels ▶️ Brush Media ▶️ Thick Paint - Media). All controls in this panel are available for both Thick Paint Bristle and Thick Paint Palette Knife brushes.

**Type**

You can set the brush to apply, plow, or erase paint, with or without adding grain. The following paint types are available:

- **Paint** — lets you apply thick paint with the brush.
- **Paint with Grain** — lets you apply thick paint and add grain to the painting surface at the same time.
- **Plow Paint** — lets you push paint forward and out.
- **Plow Paint with Grain** — lets you push paint forward and out, and adds paper grain at the same time.
- **Erase** — lets you erase existing paint.
Deposit controls let you adjust how paint is deposited on the layer.

**Rate** helps you set the speed at which the paint is deposited. The faster the rate, the more paint is deposited along the brushstroke, and the faster the brush will run of paint. High Rate values produce thicker and shorter brushstrokes; low Rate values produce longer and thinner brushstrokes.

When you use an expression such as velocity or pressure, you can vary the deposit rate by using your stylus. The **Min Rate** control lets you set the minimum rate of paint deposit for the linked expression. For information about expression settings, see “Expression settings” on page 373.
**Rate Jitter** allows you to vary the deposit rate in a brushstroke. Low values produce smoother and more uniform brushstrokes; higher values result in more varied, organic-looking brushstrokes. For best results, specify a value close to the **Radius Jitter** value.

![Rate Jitter values: low (left), high (right)](image)

**Smoothness** lets you smooth the deposit rate jitter in a brushstroke.

![Smoothness values: low (left), high (right)](image)

Brushstrokes from left to right: without Deposit Jitter, with Deposit Jitter, and with Deposit Jitter and Smoothness

**Canvas**

**Canvas** controls affect how the current brush interacts with existing paint.

**Wetness** determines the wetness of the paint on the canvas and lets you adjust how much paint is picked up by the brush. Higher Wetness values result in more paint being picked up by the brush.

![Wetness values: low (left), medium (middle), high (right)](image)

**Expression** allows you to vary wetness by using your stylus. **Min Wetness** lets you specify the minimum wetness value of the paint on the canvas.

For example, if you choose pressure as an expression, the harder you press with the stylus, the more paint is picked up by the brush. You can reverse the effect of the expression by using the **Reverse** button so that light pressure increases paint wetness instead of decreasing it.

**Grain Height** allows you to set how high the grain is. Higher values reveal more paper grain.
Droplets

The controls in the **Droplets** area let you control the size of the paint drops that the brush deposits on the canvas. **Radius** allows you to adjust the radius of the paint droplets applied by the brush.

**Expression** lets you choose a real-time input factor such as the pressure or direction of your stylus to vary the droplet size. If you don’t want the paint drops to be too small, you can set a minimum radius value by using the **Min Radius** control. You can also reverse the effect of the linked expression on the droplet radius by using the **Reverse** button.

**Radius Jitter** lets you vary the radius of the paint droplets. For best results, specify a value close to the **Rate Jitter** value. **Smoothness** lets you smooth the radius jitter.

**Spacing** controls the distance between the droplets of paint.

**Hardness** controls how the paint droplets join together. High values create ridges in the brushstrokes, making it appear coarse. Low values create softer brushstrokes with more gradual transitions in height.
To adjust the media of a Thick Paint brush
1 In the toolbox, click the _Brush_ tool.

2 Click the Brush Selector on the Brush Selector bar.

3 In the Brush library panel, click the _Thick Paint_ brush category, and click a brush variant.

4 On the property bar, click the _Thick Paint – Media_ flyout button, and click _Thick Paint - Media Panel_.

5 In the _Thick Paint - Media_ panel, adjust any settings you want.

**Thick Paint - Brush controls**

You can adjust the behavior of Thick Paint brushes by using the controls in the Thick Paint - Brush panel (Window _ Brush Control Panels _ Brush Shape _ Thick Paint - Brush).

**Paint Loading**

_Infinite Paint_ lets you prevent the selected brush from running out of paint.

When you disable the _Infinite Paint_ check box, you can use the _Paint Load_ slider to specify how much paint to load on the brush. In some cases, you may not want to load any paint on the brush. For example, if you want to scrape or drag existing paint with a Thick Paint Palette Knife brush, specify a value of 0.

**Brush Density** lets you adjust the number of bristles in the brush. High density values create thicker brushstrokes.

**Blending**

_Resaturation_ controls the amount of the currently selected color that is replenished in a stroke. A lower Resaturation value makes the brushstroke fade in gently.
Expression lets you choose a real-time input factor such as the pressure of your stylus to vary the resaturation. Min Resat lets you specify the minimum amount of the selected color that is replenished in a stroke for the linked expression. For detailed information about expression settings, see “Expression settings” on page 373.

Bleed controls how much the brushstrokes blend with existing paint. With low bleed values, brushstrokes tend to cover existing colors. With higher bleed values, brushstrokes blend better with existing colors.

You can choose an expression from the Expression list box to vary the bleed by using your stylus. The Min Bleed slider lets you specify the minimum bleed for the linked expression.

You can reverse the effect of an expression on the resaturation and bleed by using the Reverse buttons.

Clumpiness
Clumpiness lets you control how bristles adhere to each other by applying a random variance to the thickness of each bristle, which makes some of the bristles look like they are clumping together. The controls in this area let you vary the radius, length, and thickness of the brush bristles.

Bristling lets you vary the radius of the bristles within the brush.

Paint varies bristle length and thickness for a more natural brushstroke.

Color varies how individual bristles blend color.

Palette Knife
The controls in this area have an effect only on Thick Paint Palette Knife brushes.

Corner Tilt allows you to use the tilt of your stylus to vary the angle of the palette knife. When you disable the Corner Tilt check box, the palette knife angle does not change: the palette knife remains flat, and the brush mark shape remains the same.
Corner Tilt disabled (left), Corner Tilt enabled (right)

Left to right: brushstrokes with and without corner tilt

Start lets you set the tilt angle of your stylus at which the palette knife starts to transition from corner to flat.

End lets you set the tilt angle of your stylus at which the palette knife becomes flat. The angle and brush mark of the palette knife change only when you tilt the stylus within the range set by the Start and End angles.

Start tilt angle of the stylus (left); end tilt angle of the stylus (right)

Plow

Strength lets you adjust how much paint is displaced by the brush.

Strength values: low (left), high (right)
Expression lets you vary plow strength. The Min Strength slider lets you specify the minimum amount of paint that is displaced with the linked expression. The Reverse button lets you reverse the effect of the expression on the plow strength.

Radius lets you specify how widely the displaced paint is spread.

To adjust the brush attributes of a Thick Paint brush
1 In the Brush Library panel, select a Thick Paint brush from the Thick Paint brush category.
2 On the property bar, click the Thick Paint – Brush flyout button, and click Thick Paint - Brush Panel.
3 In the Thick Paint - Brush panel, adjust any settings you want.

To use the tilt of your stylus to vary the angle of a Thick Paint Palette Knife
1 In the Brush Library panel, select a Thick Paint Palette Knife from the Thick Paint brush category.
2 On the property bar, click the Thick Paint – Brush flyout button, and click Thick Paint - Brush Panel.
3 In the Palette Knife area of the Thick Paint - Brush panel, enable the Corner Tilt check box.
4 In the Start box, type a value to set the tilt angle of your stylus at which the palette knife edge starts to transition from corner to flat.
5 In the End box, type a value to specify the tilt angle of your stylus at which the palette knife edge becomes flat.
6 Paint in the document, using the tilt of your stylus to change the palette knife from corner to flat and back.

Adjusting Thick Paint layers
Thick Paint brushes work on special Thick Paint layers. You can experiment with the Thick Paint layer settings to control the appearance of thick paint on the layer. Increase the amount of thick paint to increase the height of the elevated areas in the brushstrokes, creating a more pronounced thick-paint effect. Alternatively, you can decrease the amount for a more subdued thick-paint effect.
You can set the Thick Paint Amount to 0 to create flat brushstrokes. This can help you take advantage of the superior blending power of Thick Paint brushes while you use them as regular brushes.

If you prefer to customize the Thick Paint amount and use that amount as the new default in your image, you can set it as a Thick Paint layer preference.

**To adjust Thick Paint layer attributes**

1. In the Layers panel, double-click the Thick Paint layer that you want to modify.
2. In the Thick Paint Layer Attributes dialog box, move the Amount slider to increase or decrease the height of the brushstrokes.

You can also

- Name the layer. Type a name in the Name box.
- Adjust the position of the layer. Type values in the Top and Left boxes.
- Add layer notes. Type layer information in the Notes box.

**To set the default amount for Thick Paint layers**

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ▶ Preferences ▶ General.
   - (Windows) Choose Edit ▶ Preferences ▶ General.
2. In the Thick Paint layer area, move the Default amount slider.

**Adjusting Thick Paint lighting**

Corel Painter lets you manipulate the overall lighting in Thick Paint brushstrokes by using ambient lighting, adjusting shadows, and adding directional lights. These controls are global — they affect all Thick Paint brushstrokes on all layers.
**Ambient lightning and shadows**

An ambient light source is available for Thick Paint brushstrokes. You can adjust the brightness of the ambient light to lighten or darken the colors in the lit areas. You can also disable the ambient light source.

![A brushstroke with ambient light (left) and without ambient light (right)](image)

You can control how dark the shadows are in the brushstrokes. When you increase the shadow strength, the colors in the unlit, indented areas of the brushstroke become darker.

![Shadow Strength values: low (left), high (right)](image)

**Setting the position and color of directional lights**

You can adjust surface lighting by using preset (simple) lighting or custom lighting. With simple lighting, you can choose one of eight preset lights. With custom lighting, you can add more light sources, and you can move and delete light sources. The lighting sphere shows all possible surface angles and how the lights illuminate them. The light indicators on the sphere show the position of all light sources.
When you disable the Simple lighting option, the lighting sphere appears with a single light indicator. You can then add more light sources and change their position.

In addition, you can change the color of a light source. For example, you can have multiple colored lights interact with the depth to produce different texture effects. You should keep in mind that each light interacts with all Thick Paint brushstrokes, so be careful not to set up colored lights that clash with the colors in your composition or light sources that create unwanted shadows.

The Thick Paint brushstrokes above use light sources with different colors.

To adjust ambient lighting
1. Choose Canvas ➤ Surface Lighting.
2. In the Ambient Lighting area, make sure that the Ambient light check box is enabled.
3. Move the Brightness slider.

To disable ambient lighting
* In the Surface Lighting dialog box (Canvas ➤ Surface Lighting), disable the Ambient light check box.

To adjust shadows
* In the Surface Lighting dialog box (Canvas ➤ Surface Lighting), move the Shadow Strength slider.

To add, remove, or modify a directional light source
1. Choose Canvas ➤ Surface Lighting.
2. In the Directional Lighting area, perform an action from the following table.
To | Do the following
---|---
Add a preset light source | Enable the **Simple lighting** check box, and click a light indicator on the lighting sphere.
Add a custom light source | Disable the **Simple lighting** check box, and click on the lighting sphere where you want to add a new light source. A new light indicator (small circle) appears where you click.
Delete custom light sources | Move the **Light(s)** slider to the left.
Add custom lights along a circular path | Disable the **Simple lighting** check box, and move the **Light(s)** slider to the right.
Change the position of a custom light source | Drag the light indicator to a new position on the sphere.
Change the light color | Click a light indicator, click the **Light Color** chip, and choose a color.

**To adjust the intensity and brightness of directional light**

1. Choose **Canvas > Surface Lighting**.
2. In the **Directional Lighting** area, adjust any of the following sliders:
   - **Brightness** — controls how much light the light source contributes to the overall lighting color
   - **Concentration** — adjusts the spread of the light over the surface
   - **Exposure** — adjusts the overall lighting amount from darkest to brightest

**Cloning with Thick Paint brushes**

Turn a Thick Paint brush into a cloner by clicking the **Clone Color** button 🎨 in the **Color** panel (Window ➔ Color Panels ➔ Color Panel (Full View)) and start painting. For more information about cloning, see “Image cloning and sampling” on page 181. If you are not satisfied with the appearance of the brushstrokes, try the following:

- Increase the brush size.
- Increase the droplet radius. Select a Thick Paint brush variant. On the property bar, click the **Thick Paint – Media** flyout button 🎨 and click **Thick Paint - Media Panel** 🎨. In the **Droplets** area of the panel, move the **Radius** slider to the right to increase the size of the paint droplets.
- Decrease the brush density. Select a Thick Paint brush variant. Click the **Thick Paint – Brush** flyout button 🎨 on the property bar, and click **Thick Paint - Brush Panel** 🎨. Move the **Brush Density** slider to the left in small amounts (for example, minus 2%) to reduce the number of bristles in the brush.
- Blur the clone source by painting with brushes from the **Blenders** category or by applying a Focus effect (Effects ➔ Focus), such as **Depth of Field**, **Glass Distortion**, **Motion Blur**, **Zoom Blur** or **Woodcut** (Click Effects ➔ Surface Control ➔ Woodcut). Disable the **Output black** check box. Move the **Color edge** slider to the right. To blur the clone source, in the **Clone Source** panel, enable the **Show Source Image** check box. Click in the **Source Image** window, and click **OK**. Blur the source image by using a blender brush or an effect. Once you are done, click the clone document, and enable the **Create New** option in the dialog box that appears.
Liquid Ink

Liquid Ink brushes in Corel Painter create liquid paint effects that simulate traditional ink-based media.

This section contains the following topics:

- “Working with Liquid Ink brushes” (page 553)
- “Adjusting attributes of the Liquid Ink layer” (page 554)
- “Using Liquid Ink controls” (page 554)
- “Adjusting Liquid Ink lighting” (page 555)

Working with Liquid Ink brushes

To work with Liquid Ink brushes, you need to create a Liquid Ink layer. Liquid Ink layers are displayed in the Layers panel.

For a list of sample Liquid Ink brushstrokes, see “Liquid Ink” on page 341.

To create a new Liquid Ink layer

1. Choose Window \ Layers to display the Layers panel.
   
   If the Layers panel is not expanded, double-click the Layers panel tab.

2. In the Layers panel, click the Layers options button and choose New Liquid Ink Layer.

   When you apply a brushstroke to the document window using a Liquid Ink brush, a Liquid Ink layer is automatically created.

To choose a Liquid Ink brush variant

1. In the toolbox, click the Brush tool.

2. Click the Brush Selector on the Brush Selector bar.

3. In the Brush library panel, click the Liquid Ink brush category and click a brush variant.
Adjusting attributes of the Liquid Ink layer

You can experiment with the Liquid Ink layer settings to control the appearance of depth and adjust the threshold of the edges of the ink.

To adjust Liquid Ink layer attributes

1. In the Layers panel, double-click the Liquid Ink layer you want to modify.
2. Click the Layers options button, and choose Layer Options.
3. In the Liquid Ink Layer Attributes dialog box, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name the layer</td>
<td>Type a name in the Name box.</td>
</tr>
<tr>
<td>Adjust the position of the layer</td>
<td>Type values in the Top and Left boxes.</td>
</tr>
<tr>
<td>Add layer notes</td>
<td>Type layer information in the Notes box.</td>
</tr>
<tr>
<td>Increase or decrease the width of the brushstroke</td>
<td>Adjust the Threshold slider.</td>
</tr>
<tr>
<td>Increase or decrease the height, or three-dimensional appearance, of the brushstroke</td>
<td>Adjust the Amount slider.</td>
</tr>
</tbody>
</table>

Using Liquid Ink controls

You can adjust the Liquid Ink controls. For example, you can select Liquid Ink brush type, size, smoothness, and stroke volume. For more information, see “Liquid Ink controls” on page 425.

Size

The Feature slider lets you determine the space between bristles. You can experiment with the Feature slider and its effect on different Liquid Ink brushes; the higher the setting, the farther apart the bristles appear. Lower settings produce more solid strokes. With Liquid Ink brushes, the adhesion of the bristles minimizes the appearance of individual bristles.

Expression

You can use the Expression settings to vary Liquid Ink effects. For example, you can vary the stroke volume by adjusting controllers such as Direction or Velocity. You can also use the Pressure controller to create layered Liquid Ink strokes. For more information, see “Expression settings” on page 373.
Light pressure is used to apply overlapping strokes (left). Increased pressure produces a heavier layering effect (right).

To customize a Liquid Ink brush variant

• Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Liquid Ink.

For more information about each of the Liquid Ink controls, see “Liquid Ink controls” on page 425.

Adjusting Liquid Ink lighting

You can use the Surface Lighting controls to give the appearance of depth to Liquid Ink brushstrokes. These controls are global — they affect all Liquid Ink brushstrokes on all layers.

Surface lighting can include ambient lighting and directional lighting.

Adjusting ambient lighting

You can increase or decrease the ambient lighting in the image. The angle of the light does not change, only the brightness. Ambient lighting can be used in combination with directional light sources.

Setting directional light sources

You can adjust surface lighting by using directional light sources, which illuminate the brushstroke from a certain angle. You can use preset (simple) lighting or custom lighting. With simple lighting, you can choose one of eight preset lights. With custom lighting, you can add more light sources, and you can move and delete light sources.

By adjusting the lighting angle and adding multiple light sources, you can adjust the appearance of depth of Liquid Ink brushstrokes.

The lighting sphere shows all possible surface angles and how the lights illuminate them. The light indicators on the sphere show the position of all light sources.
When you disable the Simple lighting option, the lighting sphere appears with a single light indicator. You can then add more light sources and change their position.

In addition, you can change the color of a light source. For example, you can have multiple colored lights interact with the depth to produce different textural effects. You can also adjust the intensity and brightness of directional light.

To adjust ambient lighting

1. Choose Canvas > Surface Lighting.
2. In the Ambient Lighting area, make sure that the Ambient lighting check box is enabled.
3. Move the Brightness slider.

To remove ambient lighting, disable the Ambient lighting check box.

To add, remove, or modify a directional light source

1. Choose Canvas > Surface Lighting.
2. In the Directional Lighting area, perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a preset light source</td>
<td>Enable the Simple lighting check box, and click a light indicator on the lighting sphere.</td>
</tr>
<tr>
<td>Add a custom light source</td>
<td>Disable the Simple lighting check box, and click on the lighting sphere where you want to add a new light source. A new light indicator (small circle) appears where you click.</td>
</tr>
<tr>
<td>Delete custom light sources</td>
<td>Move the Lights slider to the left.</td>
</tr>
<tr>
<td>Add custom lights along a circular path</td>
<td>Disable the Simple lighting check box, and move the Lights slider.</td>
</tr>
<tr>
<td>Change the position of a custom light source</td>
<td>Drag a light indicator to a new position on the sphere.</td>
</tr>
<tr>
<td>Change the light color</td>
<td>Click a lighting indicator, click the Light Color chip, and choose a color.</td>
</tr>
</tbody>
</table>
If the brushstroke doesn’t have any height, the lighting effects are not visible. To increase the height of the brushstroke, double-click the Liquid Ink layer in the Layers panel, and in the Liquid Ink Layer Attributes dialog box, adjust the Amount slider.

To adjust the intensity and brightness of directional light

1. Choose Canvas ➤ Surface Lighting.
2. In the Directional Lighting area, adjust any of the following sliders:
   • Brightness — controls how much light the light source contributes to the overall lighting color
   • Concentration — adjusts the spread of the light over the surface
   • Exposure — adjusts the overall lighting amount from darkest to brightest

If the brushstroke doesn’t have any height, the lighting effects are not visible. To increase the height of the brushstroke, double-click the Liquid Ink layer in the Layers panel, and in the Liquid Ink Layer Attributes dialog box, adjust the Amount slider.
Impasto

Impasto is a painting technique that involves using a brush or palette knife to apply thick paint on a canvas and retain visible brush or knife marks. This painting method is used to add texture, dimension, and movement to a painting. In Corel Painter, the Impasto brushes allow you to simulate the appearance and texture of traditional impasto. You can also control the impasto effect by manipulating the surface lighting to increase or decrease the perceived depth of the brushstrokes.

This section contains the following topics:

• “Applying, displaying, and clearing impasto” (page 559)
• “Adjusting and creating Impasto brushes” (page 560)
• “Adjusting Impasto lighting and depth” (page 564)
• “Blending impasto with other layers” (page 566)

Applying, displaying, and clearing impasto

Before applying Impasto brushstrokes, you need to set the canvas to display the impasto depth and lighting information. The canvas stores the impasto information for the entire image, which includes the Impasto brushstrokes that you apply to individual layers. If the impasto information is hidden, the brushstrokes appear smooth and flat.

You can choose one of the available Impasto brush variants from the Impasto brush category. You can also transform other brush variants into Impasto brushes. For more information, see “Adjusting and creating Impasto brushes” on page 560.

You can clear the impasto information from the canvas at any time. You can also hide the impasto information before clearing it in order to preview the end result.

To display or hide impasto information

1. Choose Window ➤ Navigator.
In the Navigator panel, click the Open Navigator Settings button and choose Show Impasto.

If you want to deactivate the Impasto view, click the Open Navigator Settings button in the Navigator panel, and choose Hide Impasto.

You can also activate the impasto view by choosing Canvas ➤ Surface Lighting, and enabling the Enable Impasto check box.

To quickly apply an Impasto brushstroke
1. Choose Window ➤ Navigator.
2. In the Navigator panel, click the Open Navigator Settings button and choose Show Impasto.
3. Click the Brush Selector on the Brush Selector bar.
4. In the Brush library panel, click the Impasto brush category, and click an Impasto brush variant.
5. Paint on the canvas or layer.

If you save a file that contains Impasto brushstrokes on multiple layers to the Adobe Photoshop (PSD) format, do not drop the layers to the canvas before saving. If you drop the layers before saving, you may lose some of the impasto information.

To clear the impasto information
• Choose Canvas ➤ Clear Impasto.

Adjusting and creating Impasto brushes
The Impasto brush controls let you modify Impasto brush variants, or transform other brush variants into Impasto brushes. The controls let you set drawing and depth methods, set the amount of depth applied, and modify brush interaction. The impasto settings act identically to other brush settings, in that they’re saved as part of a brush variant or applied to any active brush. For more information, see "Adjusting brushes with brush controls" on page 371.

Setting an impasto drawing method
The impasto drawing methods control the amount of color and depth that the brush applies to the canvas. When you change the drawing method, it affects the next brushstroke that you apply to the canvas.

Setting an impasto depth method
The impasto Depth Method lets you choose a control medium for applying depth. Corel Painter uses the luminance (brightness) information in the control medium to determine how much depth is applied within a stroke. Light areas of the medium receive more depth; dark areas receive less. Black areas appear flat.

For example, when you use Paper as the Depth Method, the bright and dark areas of the paper grain determine where grooves and bumps appear in the brushstroke.
This Impasto brushstroke is produced when Paper is used as the Depth Method.

You can set the impasto Depth method to use the selected texture. For more information about texture painting and Texture brushes, see “Texture painting” on page 483 and “Customizing Texture brushes” on page 487.

The impasto depth method option is not supported by all brush types.

Controlling the depth interaction of a medium

If the brush variant that you chose allows you to select a Depth Method, you can also adjust various settings that alter the way the brushstrokes interact with the canvas and other brushstrokes.

You can invert the depth method to apply the negative of the source in a brushstroke. For example, if you invert the depth using Weaving Luminance, light areas of the weave become dark and vice versa.

You can also apply negative depth, which allows you to use a brushstroke to excavate, or dig into the paint.

![Negative depth option](image)

*The Negative depth option forces impasto to excavate (left). Normally, impasto raises ridges and bumps (right).*

In addition, you can specify how Impasto interacts with previously applied brushstrokes. For example, you can adjust the Plow setting so when a brushstroke with a high Plow value encounters another Impasto brushstroke, it displaces the depth of the existing brushstroke. In essence, the brushstroke “plows” through existing brushstrokes. This technique produces realistic effects.

![Plow settings](image)

*The effects of high (left) and low (right) Plow settings*

You can apply one of the nine depth Expression settings to control the flow of depth based on stylus pressure, velocity, or bearing. You can also invert the depth Expression setting to create a different effect. For example, if you set depth Expression to Pressure and the Invert option is enabled, less depth is applied as you press harder, just as it would if you were using a real brush. For more information, see “Expression settings” on page 373.

You can also adjust the Min setting to specify the range of variability that you want the expression to apply. The Min Depth setting represents a percentage of the Depth setting and it must be linked to an expression to have an effect. For example, if you choose the Pressure expression on the Impasto panel, set the Depth slider to 20%, and then set the Min Depth slider to 50%, the depth will vary from 10% to 20% every time you apply pressure to the stylus.

You can increase the variation of depth that is applied by adjusting the Depth Jitter. You can also use the Smoothness slider to smooth the depth jitter in a brushstroke for a more organic look.
To choose an impasto drawing method

1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Impasto.
2. From the Draw to list box, choose one of the following options:
   - Color and Depth — applies brushstrokes with color and depth
   - Color — applies brushstrokes with color only, depth is disabled
   - Depth — applies grayscale brushstrokes to represent the highlights and shadows created by depth, color is disabled

To control the appearance of depth

1. Choose Window ▶ Brush Control Panels ▶ Brush Media ▶ Impasto.
2. From the Depth Method list box, choose one of the following:
   - Uniform — applies brushstrokes with even depth and little texture
   - Erase — removes depth while applying color, which allows you to remove unwanted Impasto brushstrokes. To erase depth, you must select the Color and Depth option from the Draw To list box. The amount of depth removed depends on the Depth value that is set. If you want to remove all depth, set the Depth slider to 0.
   - Paper — uses the selected paper grain to control the appearance of depth
   - Texture Luminance — uses the texture luminance to control the appearance of depth. For more information about texture painting, see “Texture painting” on page 483.
   - Original Luminance — uses the clone source luminance to control depth. For more information, see “Using clone source or pattern luminance to create texture” on page 680.
   - Weaving Luminance — uses the selected weave pattern to control the appearance of depth
3. Drag the Depth slider to the right to increase depth, or to the left to decrease it.

If you set a high value, you produce brushstrokes that have deeper grooves.

The impasto depth method option is not supported by all brush types.
You can create Impasto brush variants using only dab-based dab types, such as Circular, Static Bristle, and Computed Circular.

When a brushstroke with a high Plow value encounters another Impasto brushstroke, it displaces the depth of the existing brushstroke. In essence, your brushstroke “plows” through existing brushstrokes.

For a realistic effect, try varying Depth inversely with Pressure. Set the Expression list box to Pressure, and enable the Invert option. This lets you apply paint more thickly when you press lightly, but more thinly when you press firmly, just as if you were using real paint.
To control the depth interaction

1. Choose **Window**  ➤  **Brush Control Panels**  ➤  **Brush Media**  ➤  **Impasto**.

2. Perform an action from the following table:

**You can also**

- Invert the appearance of impasto depth: Enable the **Invert** check box.
- Change the direction of impasto depth so you can dig into the paint: Enable the **Negative Depth** check box.
- Link the depth settings to a specific stylus, or mouse, movement: Choose an option from the **Expression** list box.
- Set the percentage of variability that you want the expression to apply: Move the **Min Depth** slider.
- Invert the appearance of the depth expression: Click the **Invert Depth Expression** button.
- Adjust the amount of variation that is applied to Depth: Move the **Depth Jitter** slider.
- Smooth the depth variation: Move the **Smoothness** slider.
- Specify the transitions in the brushstroke texture: Move the **Smoothing** slider to the right to increase the effect, or to the left to decrease it. A high smoothing value produces brushstrokes with less texture.
- Control how much depth a brushstroke displaces when it intersects with other brushstrokes: Move the **Plow** slider to the right to increase the effect, or to the left to decrease it.

When a brushstroke with a high **Plow** value encounters another Impasto brushstroke, it displaces the depth of the existing brushstroke. In essence, your brushstroke “plows” through existing brushstrokes.

For a realistic effect, try varying **Depth** inversely with **Pressure**. Set the **Expression** list box to **Pressure**, and enable the **Invert** option. This lets you apply paint more thickly when you press lightly, but more thinly when you press firmly, just as if you were using real paint.

When adjusting **Depth Jitter**, make sure the **Min Depth** slider is not set to 100%. Setting the **Min Depth** to 100% stops **Depth Jitter** from occurring.
Adjusting Impasto lighting and depth

Corel Painter offers surface lighting controls that let you manipulate the overall depth effect that impasto creates. The changes that you make to the surface lighting can increase or decrease the depth, or perceived thickness, of the brushstroke. These controls are global — they affect all the Impasto brushstrokes on all layers.

In addition, you can use ambient lighting or directional lighting.

You can modify the impasto effect by increasing the appearance of depth.

Adjusting the appearance of depth

You can use surface lighting to adjust the appearance of depth in the brushstrokes. The adjustments that you make to surface lighting affect all Impasto brushstrokes.

To change the depth of individual brushstrokes, you can vary stylus settings or build up media. For more information, see “Blending impasto with other layers” on page 566.

Adjusting ambient lighting

You can increase or decrease the ambient lighting in the image. The angle of the light does not change, only the brightness. Ambient lighting can be used in combination with directional light sources.

Setting directional light sources

You can adjust surface lighting by using directional light sources, which illuminate the brushstroke from a certain angle. You can use preset (simple) lighting or custom lighting. With simple lighting, you can choose one of eight preset lights. With custom lighting, you can add more light sources, and you can move and delete light sources.

The lighting sphere shows all possible surface angles and how the lights illuminate them. The light indicators on the sphere show the position of all light sources.

When you disable the Simple lighting option, the lighting sphere appears with a single light indicator. You can then add more light sources and change their position.

You can change the color of a light source. For example, you can have multiple colored lights interact with the depth to produce different textural effects. You should keep in mind that each light interacts with all the Impasto brushstrokes, so be careful not to set up colored lights that clash with the colors in your composition or light sources that create unwanted shadows.
The image above uses two different colored light sources.

You can also adjust the intensity and brightness of directional light.

To modify surface lighting to adjust depth
1 Choose Canvas ➤ Surface Lighting.
2 In the Appearance of Depth area, adjust any of the following sliders:
   • Amount — increases or decreases the visibility of brush striations in brushstrokes. The highest value displays more striations to create the illusion of more texture and increased depth, whereas the lowest value displays fewer striations to create the illusion of smooth texture without depth.
   • Picture — controls how much color appears in the image. At its lowest value, all color is washed out, leaving only the highlights.
   • Shine — controls how much highlight appears on the surface of brushstrokes. Higher Shine values make the brushstroke look metallic.
   • Reflection — maps a clone source image or pattern onto the texture at a variable percentage. For more information, see “Creating reflection maps” on page 683.

To adjust ambient lighting
1 Choose Canvas ➤ Surface Lighting.
2 In the Ambient Lighting area, make sure that the Ambient lighting check box is enabled.
3 Move the Brightness slider.

To remove ambient lighting, disable the Ambient lighting check box.

To add, remove, or modify a directional light source
1 Choose Canvas ➤ Surface Lighting.
2 Enable the Enable Impasto check box.
3 In the Directional Lighting area, perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a preset light source</td>
<td>Enable the Simple lighting check box, and click a light indicator on the lighting sphere.</td>
</tr>
<tr>
<td>Add a custom light source</td>
<td>Disable the Simple lighting check box, and click on the lighting sphere where you want to add a new light source. A new light indicator (small circle) appears where you click.</td>
</tr>
</tbody>
</table>
To do the following

Delete custom light sources
Move the Lights slider to the left.

Add custom lights along a circular path
Disable the Simple lighting check box, and move the Lights slider.

Change the position of a custom light source
Drag a light indicator to a new position on the sphere.

Change the light color
Click a lighting indicator, click the Light Color chip, and choose a color.

To adjust the intensity and brightness of directional light
1  Choose Canvas ➤ Surface Lighting.
2  In the Directional Lighting area, adjust any of the following sliders:
  • Brightness — controls how much light the light source contributes to the overall lighting color
  • Concentration — adjusts the spread of the light over the surface
  • Exposure — adjusts the overall lighting amount from darkest to brightest

Blending impasto with other layers

You can control how Impasto brushstrokes blend with images on other layers by selecting a Composite Depth method in the Layers panel.

The Composite Depth menu provides the following methods for combining Impasto brushstrokes:
• The Add method, which is the default Composite Depth method, combines depth information between layers. Brushstrokes on different layers build up where they overlap. If the composite depth method is set to Add and you paint with an Impasto brush variant on a layer, the composite depth setting does not change.

An example of the Add composite depth method

• The Subtract method removes depth information between layers. Impasto brushstrokes on top layers create grooves in the image data beneath them. If the composite depth method is set to Subtract and you paint with an Impasto brush variant on a layer, the composite depth method does not change.

An example of the Subtract composite depth method

• The Replace method uses layer masks to replace the depth information from lower layers with information from top layers. Wherever brushstrokes overlap, only the top brushstrokes are visible; the lower brushstrokes are completely covered. If the composite depth method is set to Replace and you paint with an Impasto brush variant on a layer, the composite depth method does not change.
The **Ignore** method prevents Impasto brushstrokes from interacting with image data on different layers. With the **Ignore** method active, the display of depth for the layer is turned off. This makes it possible to disable display of depth for individual layers. If the composite depth method is set to **Ignore** and you paint with an Impasto brush variant on a layer, the method changes back to **Add**.

You can set a different composite depth method for every layer in a document. For more information, see “Blending layers by using composite methods” on page 594.
Layers

Layers provide one of the great advantages of creating images in a digital workspace — the freedom to experiment with different compositions and effects without risking an unwanted, permanent edit. The Corel Painter file format preserves layers when you save a document, so you can easily make changes at a later time.

This section contains the following topics:

Creating layers
• “Getting started with layers” (page 570)
• “Displaying the Layers panel” (page 572)
• “Creating and deleting layers” (page 574)
• “Converting selections into layers or floating objects” (page 575)
• “Naming and adding notes to layers” (page 576)

Selecting, transforming, and manipulating layers
• “Selecting layers” (page 577)
• “Copying and duplicating layers” (page 579)
• “Moving layers” (page 580)
• “Transforming layers” (page 581)
• “Aligning layers” (page 585)
• “Locking layers” (page 586)
• “Showing or hiding layers” (page 586)
• “Changing layer order” (page 586)
• “Viewing layer position” (page 588)
• “Grouping layers” (page 588)
• “Dropping layers with the canvas” (page 590)

Working with layer content
• “Painting on layers” (page 591)
• “Preserving layer transparency” (page 592)
• “Adjusting layer opacity” (page 593)
• “Adding drop shadows to layers” (page 593)
• “Blending layers by using composite methods” (page 594)

Working with layers masks
• “Creating and deleting layer masks” (page 600)
Getting started with layers

A layer is an object that serves as a container for image data. You can use layers to build an image one element at a time. This allows you to modify and manipulate the content of a layer independently of other layers and the canvas. Likewise, you can work on the canvas without interfering with any of the other layers. For example, if you introduced an element to an image by using a layer and you don’t like the result, you don’t have to clear the entire canvas — just modify or remove the affected layer.

When you add content, such as brushstrokes to a layer, the areas of the layer that have no content are transparent. This allows you to see the content of layers below and the canvas. In Corel Painter, you can control the behavior of layer transparency. For more information, see “Preserving layer transparency” on page 592.

Understanding layers and the canvas

To better understand the role of layers in Corel Painter, it’s important to understand the role of the canvas. When creating a new image in Corel Painter, a blank canvas displays in the document window, which serves as the foundation, or background layer, of the image. Although the canvas displays in the Layers panel, you cannot modify the canvas like other layers. For example, you cannot delete, reorder, unlock, transform, or group the canvas. In addition, unlike layers, the canvas is not transparent because it stores the paper color. Therefore, if you convert the canvas to a layer, even areas that appear transparent retain the paper color. For more information, see “To convert the canvas to a layer” on page 576.

Layer categories and types

Corel Painter includes different layer types that are pixel-based, media-based or vector-based. It also includes dynamic and reference layers. The type is determined by the data the layer contains.

The Corel Painter default layer is pixel-based. You can use most brush variants on pixel-based layers, with the following exceptions: Watercolor and Liquid Ink brushes. These brush variants require media-based layers. Pixel-based layers also play a role in more specialized functions, such as building an image hose nozzle, embedding a URL in an image, or creating an animation.
Vector-based layers contain shapes or text. When you create a shape with one of the shape tools (Pen, Quick Curve, Rectangular Shape, or Oval Shape) or text using the Text tool, Corel Painter automatically adds a new layer to the document. Each new shape or text block becomes a separate layer; you can group multiple shapes together or merge them into a single shape.

Some features in Corel Painter can be applied only to default, pixel-based layers. If you want to use these features on shapes, Watercolor layers, Liquid Ink layers, dynamic layers, and so on, you must convert them to default layers.

The following table describes each of the layer types.

<table>
<thead>
<tr>
<th>Layer type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Stores the paint applied by most brush variants. You can also apply effects to pixel-based default layers.</td>
</tr>
<tr>
<td>Floating object</td>
<td>Stores layer selections so you can edit layer content. For more information, see “Converting selections into layers or floating objects” on page 575.</td>
</tr>
<tr>
<td>Watercolor</td>
<td>Stores the paint applied with the Watercolor and Real Watercolor brushes and enables them to mix and flow together. When you apply a Watercolor brush to the canvas, or to a standard layer, a new Watercolor layer is automatically created. For more information, see “Working with the Watercolor layer” on page 462.</td>
</tr>
<tr>
<td>Liquid Ink</td>
<td>Stores the brushstrokes of Liquid Ink brushes. When you apply one of the Liquid Ink brushes to the canvas or to an image layer, a new Liquid Ink layer is automatically created. For more information, see “Working with Liquid Ink brushes” on page 553.</td>
</tr>
<tr>
<td>Reference</td>
<td>Stores low-resolution representations of other layers, which lets you manipulate standard layers more easily. For more information, see “Working with reference layers” on page 605.</td>
</tr>
<tr>
<td>Dynamic</td>
<td>Lets you apply effects to the underlying image. Some dynamic layers, such as Glass Distortion and Equalize, interact with the underlying images in a specific area to produce effects. Other dynamic layers, such as Liquid Metal, interact with the underlying images as you apply brushstrokes. For more information, see “Dynamic Plug-ins” on page 701.</td>
</tr>
<tr>
<td>Shape</td>
<td>Stores any shapes that you create using one of the shape tools. When you create a shape, a new vector-based shape layer is automatically created. For more information, see “Getting started with shapes” on page 786.</td>
</tr>
<tr>
<td>Text</td>
<td>Stores single blocks of text that were inserted with the Text tool. When you add text, a vector-based text layer is automatically created. For more information, see “Aligning text” on page 808.</td>
</tr>
</tbody>
</table>
Displaying the Layers panel

All layers in a document are listed in the Layers panel. The Layers panel allows you to display manage the order of layers. It also includes commands and controls for selecting, hiding, locking, deleting, naming, and grouping layers. You can access the various layer commands and controls by using the buttons at the bottom of the panel.

Layer panel components

1. Composite Method list box
2. Pick Up Underlying Color button
3. Preserve Transparency button
4. Show Layer icon
5. Hide Layer icon
6. Layer Commands
7. Dynamic Plugins
8. New Layer button
9. New Layer Mask button
10. Lock Layer button
11. Layer options button
12. Layer list
13. Canvas
14. Delete Layer button

The Layers panel displays icons that identify layer types and characteristics. The following table lists the icons that appear in the Layers panel.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Canvas" /></td>
<td>Canvas</td>
</tr>
<tr>
<td><img src="image" alt="Pixel-based layer" /></td>
<td>Pixel-based layer</td>
</tr>
<tr>
<td><img src="image" alt="Shape layer" /></td>
<td>Shape layer</td>
</tr>
<tr>
<td><img src="image" alt="Reference layer" /></td>
<td>Reference layer</td>
</tr>
<tr>
<td><img src="image" alt="Dynamic layer" /></td>
<td>Dynamic layer</td>
</tr>
<tr>
<td><img src="image" alt="Watercolor layer" /></td>
<td>Watercolor layer</td>
</tr>
<tr>
<td><img src="image" alt="Liquid Ink layer" /></td>
<td>Liquid Ink layer</td>
</tr>
<tr>
<td><img src="image" alt="Text layer" /></td>
<td>Text layer</td>
</tr>
<tr>
<td><img src="image" alt="Thick Paint layer" /></td>
<td>Thick Paint layer</td>
</tr>
<tr>
<td><img src="image" alt="Layer group" /></td>
<td>Layer group</td>
</tr>
<tr>
<td><img src="image" alt="Expanded group" /></td>
<td>Expanded group</td>
</tr>
<tr>
<td><img src="image" alt="Visible layer" /></td>
<td>Visible layer</td>
</tr>
<tr>
<td><img src="image" alt="Hidden layer" /></td>
<td>Hidden layer</td>
</tr>
<tr>
<td><img src="image" alt="Locked layer" /></td>
<td>Locked layer</td>
</tr>
</tbody>
</table>

In the **Layers** panel, you can also set layer opacity and choose a composite method. For information, see “Adjusting layer opacity” on page 593 and “Blending layers by using composite methods” on page 594.
The Navigator panel displays information about the dimensions and position of layer content. For more information, see “Navigating images and viewing image information” on page 102.

To display the Layers panel

* Choose Window ▸ Layers.

If the panel is not expanded, double-click the Layers panel tab.

To convert to a default layer

* In the Layers panel, select a layer, click the Layer options button ☰, and choose Convert To Default Layer

You can convert Shape, Watercolor, Liquid Ink, and dynamic layers into default layers.

You can also convert a layer to a default layer by right-clicking the layer, and choosing Convert To Default Layer.

Creating and deleting layers

You can add a default layer to an image at any time. When you apply a brush stroke by using a Watercolor and Liquid Ink brush, the appropriate layer is automatically generated. You can also add additional Watercolor or Liquid Ink layers when required. You can delete layers, but you cannot delete the canvas.

When you create a layer, the new layer is placed directly above the selected layer in the Layers panel. If the selected layer belongs to a group, the new layer is added to the group. If a layer group is selected, the layer is placed above the group. You can also change the order in which layers are displayed. For more information, see “Changing layer order” on page 586 and “Grouping layers” on page 588.

To create a new layer

* Perform a task from the following table.

To 

<table>
<thead>
<tr>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a layer</td>
</tr>
<tr>
<td>Create a watercolor layer</td>
</tr>
<tr>
<td>Create a Liquid Ink layer</td>
</tr>
</tbody>
</table>

If you choose a Watercolor, Real Watercolor, or Liquid Ink brush, a new layer for that brush type is automatically created when you apply a brushstroke to the document window.

To delete a layer

1 In the Layers panel, select one layer or multiple layers.
2 Do one of the following:
   • Click the Delete Layer button at the bottom of the Layers panel.
   • Click the Layer options button, and choose Delete Layer.
   • Right-click a layer, and choose Delete Layer.

You can also delete shape layers by selecting the shape and pressing Delete (macOS) or Backspace (Windows).
You cannot delete the canvas layer.

Converting selections into layers or floating objects

In Corel Painter, you can convert a selection that was made on the canvas into a layer. You can also convert a selection that was made on a layer into a floating object. You can convert selections that were made with the Rectangular Selection, Oval Selection, Lasso, or Magic Wand tool. You can also duplicate a selection to convert it to layer or floating object.

Converting a selection to a layer is also a useful way to convert the entire canvas to a layer. For example, you can convert a photo into a layer and then apply effects to it.

Layer-based selections function in the same way as selections on the canvas — you can use them to constrain brushstrokes, to isolate an area of the layer for applying an effect, or to choose an area of the layer to cut or copy. For more information, see “Selections and transformations” on page 619.

When you convert a canvas-based selection to a layer, a new layer appears in the Layers panel. However, when you convert a layer-based selection, a Layer Floating Object appears as an item below the parent layer in the Layers panel.

You can move floating objects around a layer to create new compositions. Each layer in a document can have only one floating object at a time. You can drop a floating object to merge it with the layer, but many operations automatically drop (or merge) the floating object back to its parent layer.

Floating objects are created by making a selection on a pixel-based layer. Shapes cannot be floating objects because they are vector-based. However, you can turn a shape into a pixel-based layer. For more information, see “To convert a shape to a pixel-based layer for painting” on page 800.

When you save a document to RIFF format, Corel Painter preserves all floating objects. However, saving a document in a non-RIFF format automatically drops floating objects onto their parent layers.

To convert a selection to a layer or floating object

1 Create a selection on the canvas or a layer with a selection tool.
2 Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert the selection to a layer or floating object</td>
<td>Choose Select ➤ Float or click the selection with the Layer Adjuster tool.</td>
</tr>
<tr>
<td>Duplicate the selection as a layer or floating object</td>
<td>Hold down Option (macOS) or Alt (Windows), and click the selection with the Layer Adjuster tool.</td>
</tr>
</tbody>
</table>
When you rotate, scale, distort, or flip a selection using the **Transform tool** ![Transform]. the selection is automatically committed to a layer. For more information, see “Preparing selections for transformations” on page 641.

**To convert the canvas to a layer**

1. In the **Layers** panel, select the canvas.
2. Choose Select ▸ **All**.
3. Choose Select ▸ **Float**.

**To reposition or drop a floating object**

1. In the **Layers** panel, select the floating object.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reposition a floating object</td>
<td>In the document window, drag the floating object to the new location with the <strong>Layer Adjuster tool</strong> ![Layer Adjuster]. Then, press the arrow keys to move the floating object one pixel at a time.</td>
</tr>
<tr>
<td>Drop a floating object</td>
<td>Click the <strong>Layer Commands</strong> button ![Layer Commands], and choose <strong>Drop</strong>.</td>
</tr>
</tbody>
</table>

**Naming and adding notes to layers**

As you add more layers and groups to a document, it can become difficult to remember which image data each layer contains. By assigning descriptive names to layers and groups, you can keep track of the separate pieces of an image. You can also assign more descriptive information to a layer by adding notes to it.

Corel Painter assigns each layer or group a default name when you create it. This name references the object’s type and creation order. For example, pixel-based layers are titled Layer 1, Layer 2, and so on. A shape’s title is based on the tool you use to create it — Rect # for the **Rectangular Shape** tool, Oval # for the **Oval Shape** tool, and Shape # for the Pen and Quick Curve tools.

**To name a layer or group**

1. In the **Layers** panel, double-click a layer or group.
2. Type a new name in the text box.

   You can also rename a layer by clicking the Layer options button ![Layer options], choosing **Layer Attributes**, and typing a name in the **Name** box.

   When you collapse layers, the name of the bottom layer is used as the name of the new merged layer.

   You cannot rename the **Canvas** layer.
To add a layer description

1. In the Layers panel, click the Layer options button 🔄, and choose Layer Attributes.
2. Type in the Note box.

You cannot add notes to a layer if you enable the WWW Map Clickable Region check box for image mapping.

You can also add a layer description by right-clicking a layer or group in the Layers panel, choosing Layer Attributes, and typing in the Note box.

You can also add a layer description by selecting a layer or group, choosing Layers ▶ Layer Attributes, and typing in the Note box.

Selecting layers

In Corel Painter, you have different options for selecting individual and multiple layers. You must select layers to make changes such as moving, aligning, and painting. If no layers are selected when making changes, you may make unwanted changes to the canvas.

Layer Adjuster tool and Auto-Select Layer option

You can select layers with the Layer Adjuster tool if the Auto-Select Layer option is enabled.

When you choose the Layer Adjuster tool from the toolbox, the property bar displays layer-related options including the Auto-Select Layer check box. When you enable this option, you can select layers automatically with the Layer Adjuster tool by clicking an area of layer content in the document window.

By default, the Auto-Select Layer option is disabled. This means that the layer selection is “locked in” — the Layer Adjuster tool affects only the selected layer or layers. In other words, without enabling the Auto-Select Layer option, you cannot select a layer by clicking it in the document window; you must select a layer by clicking it in the Layers panel.

Layers panel

You can select a layer, multiple layers, or a layer group from the Layers panel. Because the Layers panel lists all image layers, it’s a useful tool for browsing and selecting layers. For more information, see “Displaying the Layers panel” on page 572.

Displaying layer indicators

You can also display layer indicators, which are handles that display at the corners of a selected layer’s content. The layer indicators provide a visual representation of the layer’s bounding box. For more information, see “Moving layers” on page 580.

To select a layer
To Do the following

Select a single layer
Do one of the following:
- Click a layer in the Layers panel.
- Choose the Layer Adjuster tool from the toolbox, enable the Auto-Select Layer check box on the property bar, and then click anywhere in a layer’s content.

Select multiple layers
Do one of the following:
- In the Layers panel, hold down Command (macOS) or Ctrl (Windows), and click each layer you want to select.
- Choose the Layer Adjuster tool from the toolbox, enable the Auto-Select Layer button on the property bar, hold down Shift, and click the layers you want to select in the document window.

Tip: To select contiguous layers in the Layers panel, click a layer, hold down Shift, and then click the last layer you want to select.

Select all layers in a document
Do one of the following:
- In the Layers panel, click the Layer options button, and choose Select All Layers.
- Press Ctrl + Shift + 1 (Windows) or Command + Shift + 1 (macOS).

You can also press the F key to activate the Layer Adjuster tool.

If you are working with a shape, you can switch to the Shape Selection tool by double-clicking a shape with the Layer Adjuster tool.

To deselect layers
- In the Layers panel, click the Canvas.

You can also deselect a single layer by clicking the Layer options button in the Layers panel, and choosing Deselect Layer.

To show layer indicators
1 In the Layers panel, select a layer.
2 Click the Layer options button, and choose Show Layer Indicators.

To hide the layer indicators, click the Layer options button, and choose Hide Layer Indicators.
Copying and duplicating layers

You can copy individual layers in the same image or between images. You can also duplicate layers in order to quickly replicate image elements. In addition, you can simultaneously copy the contents of multiple layers by using a selection.

To copy and paste a layer

1. Choose the Layer Adjuster tool in the toolbox.
2. Enable the Auto-Select Layer check box on the property bar.
3. In the document window, click the layer that you want to copy.
4. On the property bar, click the Copy button, and perform an action from the following table:

<table>
<thead>
<tr>
<th>To paste a layer</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Directly above the copied layer</td>
<td>Click the Paste in Place button.</td>
</tr>
<tr>
<td>Above another layer</td>
<td>Click the layer in the Layers panel, and then click the Paste in Place button.</td>
</tr>
<tr>
<td>Above the canvas</td>
<td>Select the canvas in the Layers panel, and then click the Paste in Place button.</td>
</tr>
</tbody>
</table>

You can also copy a selected layer by pressing Ctrl + C (Windows) or Command + C (macOS), and then paste it by pressing Ctrl + V (Windows) or Command + V (macOS).

To duplicate a layer

1. Choose the Layer Adjuster tool in the toolbox.
2. Enable the Auto-Select Layer check box on the property bar.
3. Hold down Option (macOS) or Alt (Windows) and click a layer.

A duplicate layer is created on top of the original layer. Drag the new layer to reveal the original layer in the document window.

You can also duplicate a layer by right-clicking the layer in the Layers panel, and choosing Duplicate Layer.

You can also duplicate a selected layer by clicking the Layer options button in the Layers panel, and choosing Duplicate Layer.

You can also duplicate a layer by selecting the layer in the Layers panel, and choosing Layers ➤ Duplicate Layer.
To copy a layer to another document

1. Choose the Layer Adjuster tool from the toolbox.
2. Enable the Auto-Select Layer check box on the property bar.
3. In the document window, click the layer that you want to copy.
4. On the property bar, click the Copy button.
5. Open or create a document.

You can also copy a layer by opening the document where you want to copy the layer, enabling the Auto-Select Layer check box on the property bar, and dragging the layer to the other document.

To copy a selection from multiple layers

1. Make a selection.
   The selection must include elements from multiple layers.
2. Choose Edit > Copy Merged.

You can also copy from multiple layers by pressing Command + Option + C (macOS) or Ctrl + Alt + C (Windows).

Moving layers

When a layer is selected, you can move its content anywhere in the document to create a new image layout.

The pink rose was added to an individual layer. The rose layer (left) was repositioned on top of the white roses (right).

Think of a layer's content as being contained by an invisible bounding box. This bounding box is a rectangle that marks the left, right, top, and bottom edges of the layer's content. When you move or align a layer, you work with the dimensions and position of this bounding box, not with the entire area of the layer. This allows you to easily position the contents of a layer in relation to the canvas.
The layer indicators provide a visual representation of the bounding box. For more information, see “Selecting layers” on page 577.

To move or nudge a layer
1. In the Layers panel, select the layer or group you want to move.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move a layer</td>
<td>Click the Layer Adjuster tool in the toolbox, and drag the selected layer in the document window.</td>
</tr>
<tr>
<td>Move a layer one pixel at a time</td>
<td>Click the Layer Adjuster tool in the toolbox, click the layer in the document window, and press the Arrow keys to move the selected layer one pixel at a time.</td>
</tr>
<tr>
<td>Move a layer to a new document window</td>
<td>With two or more documents open in the application window, click the Layer Adjuster tool in the toolbox, and drag the selected layer to another document window.</td>
</tr>
</tbody>
</table>

To move a layer to a specific location
1. In the Layers panel, select a layer or group.
2. Click the Layer options button, and choose Layer Attributes.
3. In the Position area, type values in the following boxes:
   - Top — defines the distance in pixels from the top edge of the canvas to the top edge of the layer’s content. Increase to move the layer down, or decrease to move the layer up.
   - Left — defines the distance in pixels from the left edge of the canvas to the left edge of the layer’s content. Increase to move the layer to the right, or decrease to move the layer to the left.

If you use negative values, or values larger than the canvas dimensions, the layer is placed partially or wholly outside the canvas.

You can also open the Layer Attributes dialog box by right-clicking a layer or group in the Layers panel, and choosing Layer Attributes.

Transforming layers
You can apply transformations to layers individually or multiple layers simultaneously, which also includes transforming layer groups. For more information about the various methods of transformation, see “Selections and transformations” on page 619.
An example of selecting multiple layers for performing a transformation
To speed up the process of applying transformations to multiple layers or a layer group, you can enable the **Fast Preview Mode**. During the transformation, only a grayscale rendering of the layers displays in the document window, instead of full-color details. You can turn off the **Fast Preview Mode** to reveal the full-color results. For example, you may want to see the transformed layers in full-color before committing the transformation.
Fast Preview Mode displays the selected layers in grayscale to perform the transformation more quickly.

In addition, you can apply a transformation to a selection across multiple layers. For more information, see “Creating path-based selections” on page 627.

Please note that you cannot make transformations to hidden or locked layers.

To transform one or multiple layers

1. In the Layers panel (Window ▸ Layers), do one of the following:
   • Click a layer.
   • Click a layer group.
   • Hold down Command (macOS) or Ctrl (Windows), and click each layer you want to select.

2. In the toolbox, click the Transform tool ▭.
   If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool ▭ to open the flyout, and then choose the Transform tool ▭.

3. On the property bar, click one of the following:
   • Move button ▬
   • Scale button ▬
   • Rotate button ▬
   • Skew button ▬
• Distort button
• Perspective Distortion button

4 Perform the transformation.

5 On the property bar, click the Commit Transformation button.

When applying a transformation to a layer group, the transformation is applied to all layers within a layer group, including hidden layers or layers that do not appear to be selected.

You cannot apply transformations to locked or hidden layers.

To enable or disable Fast Preview of transformations

1 In the toolbox, click the Transform tool.

2 On the property bar, enable or disable the Fast Preview Mode check box.

Aligning layers

You can align layers horizontally or vertically. When aligning layers, Corel Painter calculates the “destination” point for alignment. For example, if you align layers to the left, the destination is the leftmost point of all selected layers. If you align horizontally to the center, the destination is the midpoint between the leftmost edge and the rightmost edge of the selected layers.

Next, Corel Painter aligns the corresponding edge of each selected layer’s bounding box with the destination point. For example, if you align layers to the left, each layer is moved so that the left edge of its bounding box lines up with the destination point. If you align horizontally to the center, each layer is moved so that the horizontal midpoint of its bounding box lines up with the destination point.

To align layers

1 Select the layers or groups that you want to align.

2 Choose the Layer Adjuster tool in the toolbox.

3 On the property bar, click the Align flyout button, and choose any of the following:
   • Left Edges — aligns the left edges of the layers’ content
   • Horizontal Centers — aligns the midpoints of the layers’ content horizontally
   • Right Edges — aligns the right edges of the layers’ content
   • Top Edges — aligns the top edges of the layers’ content
   • Vertical Centers — aligns the midpoints of the layers’ content vertically
   • Bottom Edges — aligns the bottom edges of the layers’ content
Locking layers

You can lock layers and the canvas to avoid accidentally changing them. When the canvas or a layer is locked, you cannot select it with the Layer Adjuster tool in the document window. You can, however, move a locked layer or shape by nudging it.

To lock or unlock a layer or the canvas

1. Select the layer or the canvas in the Layers panel.
2. Do one of the following:
   - In the Layers panel, click the Lock button.
   - Click the Layer options button, and choose Lock or Unlock.

The Locked icon appears next to a locked layer or locked canvas in the Layers panel.

Showing or hiding layers

You can control the view of an image in the document window by changing the layer visibility settings. This is helpful in both compositing an image and applying effects. For example, you can hide one layer to gain better visibility of the layer below it.

In the example on the right, the layer containing the background is hidden; in the example on the left, the layer containing the background is visible.

Layer visibility settings stay active when you print or save documents to certain file formats. In other words, the content of hidden layers does not print and is not saved. However, saving a document in RIFF or PSD format preserves hidden layers as part of the document. For more information, see “Importing and exporting layers” on page 604.

To show or hide a layer or the canvas

- In the Layers panel, click the eye icon next to the layer name or the canvas.

  When the eye is shut, the layer is hidden in the document window. When the eye is open, the layer is visible in the document window.

  You cannot paint on a hidden layer or hidden canvas.

Changing layer order

The layer order determines how the layers in a document interact. When you create a new pixel-based layer, it appears on top of the canvas (when the canvas is selected) or on top of the selected layer. New Watercolor, Liquid Ink, and dynamic layers are always created on top...
of existing layers. Depending on its transparency, masking, and compositing characteristics, the layer will obscure or otherwise affect the underlying layers.

A document’s layer order is reflected in the Layers panel. The bottom layer is always the canvas.

![Image](image.png)

*In this example, the picture of the brush is contained in a layer. The brush layer is displayed in the top position (left) and in the bottom position (right).*

To change the order of layers

1. Choose the Layer Adjuster tool  from the toolbox.
2. In the Layers panel, drag a layer to a new position.

You can also

Move a layer to the bottom

- On the property bar, click the Order flyout button , and choose Move to Bottom .
- Right-click the layer in the Layers panel, and choose Move to Bottom.

Move a layer to the top

- On the property bar, click the Order flyout button , and choose Move to Top .
- Right-click the layer in the Layers panel, and choose Move to Top.

Move a layer down one

On the property bar, click the Order flyout button , and choose Move Down One Layer .

Move a layer up one

On the property bar, click the Order flyout button , and choose Move Up One Layer .

When you have nonoverlapping layers in a document, the Move Up One Layer and Move Down One Layer commands may move the selected layer past multiple layers. This is because nonoverlapping layers are considered to be at the same level. The Move Up One Layer and Move Down One Layer commands move the selected layer (or layers) above or below the next level. To move a layer to a position between nonoverlapping layers, drag it in the Layers panel.
Viewing layer position

You can display information about the size of a layer’s content and its position on the canvas in the Navigator panel. Think of the area of a layer that contains images as being marked by a bounding box. For more information, see “Selecting layers” on page 577. The Navigator panel displays the dimensions and position of the bounding box, not the entire area of the layer. This makes it easy to determine the exact size and location of a layer’s content in the document.

The following table describes the information displayed in the Navigator panel.

<table>
<thead>
<tr>
<th>Position indicator (measured in pixels)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X-coordinate of the pointer on the canvas</td>
</tr>
<tr>
<td>Y</td>
<td>Y-coordinate of the pointer on the canvas</td>
</tr>
<tr>
<td>W</td>
<td>Width of the layer’s content</td>
</tr>
<tr>
<td>H</td>
<td>Height of the layer’s content</td>
</tr>
</tbody>
</table>

In the document window, you can also view indicators that mark the corners of the selected layer’s content. For more information, see “To show layer indicators” on page 578.

To displaying layer position information

• Choose Window ▶ Navigator.

  If the panel is not expanded, double-click the Navigator panel tab.

Grouping layers

Grouping layers enables you to control layers as a unit. A group can contain any combination of layers: pixel-based layers, Watercolor layers, Liquid Ink layers, vector-based shapes, and dynamic layers.

You can move, rename, hide, show, lock, and set options for a group just as you do for a single layer. However, you cannot paint across layers in a group or change the composite method for a group; you must collapse the group into a single layer if you want to paint on it.

To work with individual layers in a group, you must open the group. To regain control of the group as a unit, you must close the group. Collapsing a group reduces its contents to a single layer.

If you select a layer within a group in the Layers panel and then proceed to create a new layer, the new layer is added to the group. If the group is selected, the layer is placed above the group.

To create a group

1. In the Layers panel, select the layers you want to group.
   For more information, see “Selecting layers” on page 577.
2. Do one of the following:
   • Choose the Layer Adjuster tool in the toolbox, and click the Group Layers button on the property bar.
   • Choose Layers ▶ Group Layers.
Right-click the selected layers in the **Layers** panel, and choose **Group Layers**.

The layers are collected under a group item in the **Layers** panel.

If you select nonsequential layers (layers not next to each other in the list), Corel Painter creates the group at the position of the topmost layer. To select nonsequential layers, in the **Layers** panel, hold down Ctrl (Windows) or Command (macOS), and click each layer you want to select.

You can also group layers by using keyboard shortcuts. For more information, see “Layers menu commands” on page 131.

To open or close a group

- In the **Layers** panel, click the arrow to the left of the group.

  When the arrow points down ▼ and you can see the group items, the group is open. When the arrow points to the right ► and the names of the group members are hidden, the group is closed.

To add or remove a layer in a group

1. In the **Layers** panel, open the destination group.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a layer to a group</td>
<td>Drag a layer to the group.</td>
</tr>
<tr>
<td>Remove a layer from a group</td>
<td>Drag the layer out of the group.</td>
</tr>
</tbody>
</table>

You can create a nested group by dragging a closed group to the open destination group.

To ungroup layers

1. In the **Layers** panel, select the group. If the group is open, close the group.
2. Do one of the following:
   - Choose the **Layer Adjuster** tool in the toolbox, and click the **Ungroup Layers** button on the property bar.
   - Choose **Layers** → **Ungroup Layers**.
   - Right-click the selected layers in the **Layers** panel, and choose **Ungroup Layers**.

You can also ungroup layers by using keyboard shortcuts. For more information, see “Layers menu commands” on page 131.

To collapse a group

1. In the **Layers** panel, select the group.
2. Do one of the following:
• Click the **Layer Commands** button and choose **Collapse Layers**.

• Choose the **Layer Adjuster** tool in the toolbox, click the **Merge** flyout button on the property bar, and choose **Collapse Layers**.

If the group contains shapes, **Liquid Ink** layers, or dynamic layers, the **Commit** dialog box is displayed. Click **Commit All** to convert the items to pixel-based layers before collapsing the entire group.

When you collapse layers, the name of the bottom layer is used as the name of the new merged layer.

If you want to collapse a group containing a Watercolor layer, you must first convert the Watercolor layer to a default layer. For more information, see “Blending layers by using composite methods” on page 594.

You can also collapse layers by right-clicking the selected layers in the **Layers** panel, and choosing **Collapse Layers**.

You can also collapse layers by clicking the Layer options button in the **Layers** panel, and choosing **Collapse Layers**.

If you have enabled the **Commit and don’t ask again** check box in the **Commit** dialog box, you can reinstate the display of the **Commit** dialog box when collapsing layers by choosing Corel Painter 2020 menu Preferences (macOS) or Edit Preferences (Windows), then clicking General from the Preferences list of categories, and enabling the **Show Commit dialog when converting to layer** check box.

**Dropping layers with the canvas**

You can drop a layer or layer group to merge its contents with the canvas. Dropping a layer is a permanent change. Once layers are dropped, you can no longer access the layers’ content separately from the canvas. You can drop specific layers or you can drop all layers at once, this also known as flattening an image.

When you drop a layer, you can choose to create a selection based on the layer contents. If the layer has a layer mask, the mask is used to make the selection. For more information, see “Creating and deleting layer masks” on page 600 and “Selections and transformations” on page 619.

**To drop a layer**

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Drop specific layers</strong></td>
<td>In the <strong>Layers</strong> panel, select the layers (or groups) that you want to drop, and do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Click the <strong>Layer Commands</strong> button and choose <strong>Drop</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click the Layer options button and choose <strong>Drop</strong>.</td>
</tr>
<tr>
<td><strong>Drop all layers</strong></td>
<td>In the <strong>Layers</strong> panel, click the Layer options button and choose <strong>Drop All</strong>.</td>
</tr>
<tr>
<td><strong>Make a selection by dropping a layer</strong></td>
<td>In the <strong>Layers</strong> panel, click the Layer options button and choose <strong>Drop and Select</strong>.</td>
</tr>
</tbody>
</table>
When the Layer Adjuster tool is selected in the toolbox, you can also drop layers by clicking the Merge flyout button on the property bar, and choosing the command you want.

Painting on layers

Painting on layers, instead of painting directly on the canvas, allows you build an image gradually and with more control. For example, if you add a series of brushstrokes to a layer and you’re not satisfied with the result, you can delete the layer and start over. You can paint on layers using any of the Corel Painter brushes. The purpose of this section is to provide you with tips and techniques for painting on layers.

Pick up colors from underlying layers

When painting using brush variants that push paint, rather than apply paint, you can choose to pick up colors from underlying layers. For example, if you have red paint on the top layer, and blue paint on the bottom layer, you can blend the red and blue paint. In most cases, brush variants that allow you to blend colors within an individual layer will also support the picking up of colors on underlying layers.

Brush methods and painting on layers

The Natural-Media environment allows brushstrokes on different layers to interact with each other. However, mixing brushstrokes that use the Cover and Buildup methods on the same layer can produce unexpected results. This is caused by a conflict between the brush method and the layer’s composite method.

- Brushes that use the Buildup method — such as those in the Felt Pens or Pencils category — work best on layers that use the Gel composite method. In fact, when you use the Buildup method to paint on a blank layer, Corel Painter automatically sets the layer’s composite method to Gel.
- Brushes that use the Cover method work best on layers that are set to the Default composite method.

For more information, see “Blending layers by using composite methods” on page 594 and “General controls: Methods and subcategories” on page 383.

General tips for painting on layers

The following are tips for painting on layers:

- You can use Watercolor brushes only on Watercolor layers.
- You can use Liquid Ink brushes only on Liquid Ink layers.
- You must collapse a layer group before painting, because you cannot paint on grouped layers. For more information, see “Grouping layers” on page 588.
- You can protect areas of a layer from painting by creating a selection or preserving transparency. For more information, see “Selections and transformations” on page 619 and “Preserving layer transparency” on page 592.
- You can control what parts of a layer are visible and hidden by creating a layer mask. For more information, see “Creating and deleting layer masks” on page 600.
- You cannot paint on hidden or locked layers.

To paint on a layer

1 In the Layers panel, select a layer.
2 Click the Brush selector on the Brush selector bar.
3 In the Brush library panel, click a brush category and brush variant.
4 Paint on the layer in the document window.

The Preserve Transparency button in the Layers panel affects what areas of a layer you can paint on. For more information, see “Preserving layer transparency” on page 592.
To pick up color from underlying layers

- In the Layers panel, click the Pick Up Underlying Color button.

You can also pick up color from underlying layers by choosing Layers ➤ Pick Up Underlying Color or clicking the Layer options button ➔ in the Layers panel, and choosing Pick Up Underlying Color.

Preserving layer transparency

Areas of a layer that don’t contain images are transparent. In Corel Painter, you can preserve these transparent areas of a layer. When you preserve layer transparency, it affects which areas of a layer you can create images on. It also affects the results of erasing or deleting images on a layer.

By default, the Preserve Transparency setting is disabled, which lets you paint anywhere on the layer. When the setting is enabled, the transparent areas are preserved, and you are confined to painting on areas of the layer that already contain images.

The results of painting on a layer with Preserve Transparency disabled (left) and enabled (right)

If you want to paint on a shape, you must first commit the shape to a pixel-based layer. For more information, see “Converting shapes to image layers” on page 800.

A good way to think about preserving transparency is in terms of a layer mask. As described in "Creating and deleting layer masks" on page 600, a layer mask defines the visible areas of a layer.

Preserving transparency provides a powerful selective editing capability to create interesting effects by altering the strokes you’ve already applied. For example, you can enable the setting to fill a set of hand-drawn letters with a pattern, a color gradient, or other brushstrokes.

Preserving transparency also affects the results of cutting or erasing on a layer.

- When Preserve Transparency is disabled, erasing or deleting images restores transparency to the area and reveals the underlying image.
- When Preserve Transparency is enabled, erasing or deleting images reveals the document’s paper color. In effect, erasing or deleting with Preserve Transparency enabled is the same as painting or filling with the document’s paper color.

Erasing part of a layer (the woman’s hair) with Preserve Transparency disabled restores transparency (left). When the option is enabled, erasing reveals the paper color (right).

You can create a layer mask based on the layer’s transparency. A layer mask defines which areas of a layer are visible in the document window. For more information, see “Creating and deleting layer masks” on page 600.
To preserve layer transparency

* In the Layers panel, click the Preserve Transparency button.

You can also preserve a layer’s transparency by choosing Layers ➤ Preserve Transparency or clicking the Layer options button in the Layers panel, and choosing Preserve Transparency.

You can load a layer’s transparency to a selection. In the Layers panel, right-click a layer, and choose Select Layer Content. Click the Layer options button in the Layers panel, and choose Create Layer Mask From Transparency. For more information, see “Selections and transformations” on page 619.

Adjusting layer opacity

You can adjust a layer’s opacity to create different levels of transparency. The Opacity slider covers a range of 0% (completely transparent) to 100% (completely opaque).

To change a layer’s opacity

1. Select the layer you want to change.
2. In the Layers panel, do one of the following:
   * Move the Opacity slider.
   * Type a percentage in the Opacity box, and press Return (macOS) or Enter (Windows).

The example on the left shows the background layers at 100% opacity. The example on the right shows them at 50% opacity.

Adding drop shadows to layers

You can add a drop shadow to a single layer or to a group to enhance the appearance of an image. Drop shadows are also helpful for developing Image Hose nozzles.

When you add a drop shadow, Corel Painter creates a new layer for the shadow and groups it with the original. This enables you to select and modify the drop shadow layer independently from the original layer.

To add a drop shadow

1. Select a layer or group.
2. Choose Effects ➤ Objects ➤ Create Drop Shadow.
3. In the Drop Shadow dialog box, type values in the following boxes:
   * X-Offset and Y-Offset — specifies the distance, in pixels, from the center of the layer image to the shadow
   * Opacity — specifies the degree to which the shadow covers underlying images. Setting Opacity to 100% obscures underlying images; lower values create a more transparent shadow.
• **Radius** — specifies the amount of blur at the edge of the shadow. The radius is half the distance across the blurred region. If you set Radius to zero, you create a sharp-edged shadow.
• **Angle** — specifies the direction of the blur.
• **Thinness** — specifies the amount of blur applied perpendicular to the Angle. If a blur shows streaks, increase Thinness to soften it.

If you want to merge the drop shadow layer with the image layer, enable the **Collapse to one layer** check box.

---

### Blending layers by using composite methods

Composite methods control how layers interact with the underlying image. You can change composite methods to create special effects without changing the actual images that make up a document.

Corel Painter provides two types of composite settings:

- **Composite Method** sets the standard composite method.
- **Composite Depth** controls how a layer’s image data interacts with depth information on the canvas and other layers.

For example, if the canvas contains Impasto brushstrokes, the **Composite Depth** setting determines what happens when these brushstrokes intersect with brushstrokes on the layer. For more information, see “Blending impasto with other layers” on page 566.

You can set a different composite method for every layer in a document. Keep in mind the role of the underlying image in creating an effect — you might achieve an unexpected result if the underlying image is solid black or white.

The best way to understand the different composite methods is by seeing them in action. Quickly cycle through a layer’s composite methods to create new and interesting versions of your image. For a comparison of Corel Painter composite methods and Adobe Photoshop blend modes, see “Importing and exporting layers” on page 604.

The available composite methods are described in the following table:

<table>
<thead>
<tr>
<th>Composite method</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Default</strong></td>
<td><img src="image1.png" alt="Default Example" /></td>
</tr>
<tr>
<td>Allows the layer to cover and hide the underlying image</td>
<td></td>
</tr>
</tbody>
</table>

| **Gel**          | ![Gel Example](image2.png) |
| Tints the underlying image with the layer’s color. For example, a yellow layer gives the underlying image a yellow cast. |
| Corel Painter automatically sets a layer’s composite method to Gel if you paint on it with a brush that uses the **Buildup** method. |
**Composite method**

**GelCover**

Uses a combination of the Default method and the Gel method. The edges of the layer’s content tint the underlying image with their color (the Gel method). The rest of the layer covers the underlying image (Default method).

If you save a file that uses a GelCover composite method layer to the PSD file format, the GelCover information will be lost.

---

**Colorize**

Replaces the hue and saturation of the canvas pixels with the hue and saturation of the layer pixels.

You can use this feature to convert a color image to grayscale, or a grayscale image to color. A black layer turns the underlying color image into a grayscale image. A colored layer adds color to an underlying grayscale image.

---

**Reverse-Out**

Allows the layer to invert the colors beneath it. This method is a great way to remove text. Place a layer over black text to turn it white.

A color’s inverse, also known as its complementary color, is the color on the opposite side of the color wheel.

With Reverse-Out, the colors in the layer are ignored; the layer content becomes transparent and reveals the inverse of the colors beneath it.

---

**Shadow Map**

Blocks light, letting you create shadows without changing the image
Composite method

Magic Combine
Combines the layer with the underlying image based on luminance. The parts of the layer that are lighter than the underlying image are visible. The parts that are darker are replaced by the lighter area of the underlying image.

One way to use this method is to fill text. With a photograph as the top layer and black text as the underlying image, choosing Magic Combine fills the text with the image.

Pseudocolor
Translates the layer’s luminance into hue. You can use this method to turn a grayscale layer into a spectrum of color.

Normal
Works like the Default method; the layer covers the underlying image. The Normal method is the default mode in Photoshop.

Dissolve
Combines the image color with the layer color based on opacity.
**Composite method**

**Multiply**
Combines colors to create a darker color

**Screen**
Combines colors to create a lighter color

**Overlay**
Combines colors while preserving the highlights and shadows of the image color

**Soft Light**
Darkens or lightens colors depending on the luminance of the layer color
Composite method

Example

**Hard Light**
Daily Light Multiplies or screens colors, depending on the luminance of the layer color

![Example Image](image1)

**Darken**
Colors with the image color or the layer color — whichever is darker

![Example Image](image2)

**Lighten**
Colors with the image color or the layer color — whichever is lighter

![Example Image](image3)

**Difference**
Subtracts one color from the other, depending on which color has a greater brightness value

![Example Image](image4)
## Composite method

### Hue
Creates a color by combining the luminance and saturation of the image color with the hue of the layer color.

![Hue example](image)

### Saturation
Creates a color by combining the luminance and hue of the image color with the saturation of the layer color.

![Saturation example](image)

### Color
Creates a new color by combining the luminance of the image color with the hue and saturation of the layer color. This method is the opposite of Luminosity.

![Color example](image)

### Luminosity
Creates a new color from the hue and saturation of the image color and the luminance of the layer color. This method is the opposite of Color.

![Luminosity example](image)
To change a layer’s composite method

1. Select a layer.

2. In the Layers panel, choose a composite method from the Composite Method list box.

You can also choose a composite depth method from the Composite Depth list box. For more information, see “Blending impasto with other layers” on page 566.

Creating and deleting layer masks

You can create a new, blank layer mask, or you can create a layer mask based on the layer’s transparency. A layer mask based on transparency is white wherever the layer has content, and black in other areas. Intermediate levels of gray are partially transparent. For more information, see “Preserving layer transparency” on page 592.

You can delete layer masks you no longer need. You can also clear a layer mask without deleting it, leaving you with a blank mask.

Layer masks let you define what areas of a layer are visible in the document window. Masking originated as a technique for creating color separations, where sheets of masking material were hand-cut to define the color regions in an image. In the Corel Painter digital workspace, the layer mask is a powerful tool for controlling image composition and effects.

Layer masks vs. channels

A layer mask is similar to an alpha channel. Both are grayscale images that you can create and edit. Although the Channels panel provides access to both channels and layer masks, their characteristics and functions are different:

- A layer mask is attached to a layer, but an alpha channel is independent.
- The canvas can have up to 32 alpha channels; each layer can have only one layer mask.
- Channels don’t influence the visibility of the canvas image; a layer mask defines what areas of a layer’s image are visible.
- An alpha channel, when loaded, protects designated areas of an image; a layer mask does not provide protection.
- A channel is enabled by loading it to a selection. A layer mask can be enabled and disabled at any time, and it can also be loaded to a selection.

For more information, see “Creating and copying channels” on page 609.

A layer mask for the butterfly layer is created based on its transparency.
Black areas are transparent; white areas reveal the image.

To create a blank layer mask

1. Select a layer.
2. In the **Layers** panel, click the **New Layer Mask** button.

The blank layer mask icon displays next to the layer name in the **Layers** panel.

The layer mask icon varies in appearance depending on how you’re viewing the layers. If you are displaying layers as **No Thumbnails**, the icon is the same as the **New Layer Mask** button. If you’re viewing layers as any size of thumbnail, a small-scale representation of the mask displays as the icon.

You can also create a layer mask by choosing **Layers ➤ Create Layer Mask**.

**To create a layer mask based on transparency**

- In the **Layers** panel, right-click a layer, and choose **Create Layer Mask From Transparency**.

The layer mask icon displays next to the layer name in the **Layers** panel.

You can create layer masks based on transparency for pixel-based layers only. Other layers must first be converted to default layers by right-clicking the layer in the **Layers** panel, and choosing **Convert To Default Layer**.

Earlier versions of Corel Painter used layer visibility masks. If you have a file with a modified visibility mask that was created with an earlier version of Corel Painter, use this procedure to load the visibility mask to a layer mask.

You can also create a layer mask based on transparency by selecting a layer and choosing **Layers ➤ Create Layer Mask From Transparency**.

**To delete or clear a layer mask**

- Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete a layer mask</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Layers</strong> panel, right-click the layer mask, and choose <strong>Delete Layer Mask</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Choose <strong>Layers ➤ Delete Layer Mask</strong>.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Layers</strong> panel, select the layer mask and click the <strong>Delete</strong> button.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Layers</strong> panel, select the layer mask, click the <strong>Channel options</strong> button, and choose <strong>Delete Layer Mask</strong>.</td>
</tr>
<tr>
<td></td>
<td>• In the <strong>Channels</strong> panel, click the <strong>Channel options</strong> button, and choose <strong>Delete</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click the <strong>Delete</strong> button at the bottom of the <strong>Channels</strong> panel.</td>
</tr>
</tbody>
</table>
To Do the following

Clear a layer mask

In the Channels panel, click the Channel options button and choose Clear.

Applying layer masks

If you like the result of a layer mask, you can apply it. This permanently removes the hidden parts of the layer and deletes the layer mask.

To apply a layer mask

• In the Layers panel, right-click a layer mask, and choose Apply Layer Mask.

You can also apply a layer mask by selecting the layer mask and choosing Layers ➤ Apply Layer Mask.

Loading layer masks to selections

Although a layer mask does not protect areas of a layer from being edited, you can load a layer mask to a selection. The selection provides protection to the hidden parts of the layer. For more information, see “Selections and transformations” on page 619.

To load a layer mask to a selection

1. In the Layers panel, select a layer that has a layer mask.

2. Right-click the layer mask icon, and choose Load Layer Mask To Selection.

Selecting and viewing layer masks

Before you work with a layer mask, you must select it. You can also view a layer mask as a grayscale image. Selecting a layer mask and viewing it are distinct operations — you can select a layer mask without viewing it. You can also hide a layer mask.

To select a layer mask

1. In the Layers panel, choose a layer that has a layer mask.

   The layer mask is displayed in the Channels panel.

2. Do one of the following:

   • In the Channels panel, click the layer mask.

   • In the Layers panel, click the layer mask icon next to the layer name.

To select a transparency mask in the Layers panel

• In the Layers panel, perform an action from the following table:

To Do the following

Select the transparency mask for a layer

Press Command (macOS) or Ctrl (Windows), and click the title or preview icon of a layer or layer group.
To view a layer mask

1. Select a layer with a layer mask.
2. In the Channels panel, click the layer mask.
   In this mode, the RGB image is hidden.

To hide a layer mask

* In the Channels panel, click the eye icon next to the layer mask item, so that the icon changes to a closed eye.

Enabling and disabling layers masks

You can disable a layer mask to view the entire layer, but you can re-enable it at any time.

To enable or disable a layer mask

* Right-click a layer mask in the Layers panel, and click Enable Layer Mask or Disable Layer Mask.

You can also enable a layer mask by selecting the mask, and choosing Layers ▶ Enable Layer Mask.

You can also disable a layer mask by selecting the mask, and choosing Layers ▶ Disable Layer Mask. A red ‘X’ is displayed over the layer mask icon.

Copying layer masks

You can copy a layer mask to an alpha channel or copy a channel to a layer mask. The name of a layer mask in the Channels panel reflects the name of the layer ([Layer Name] [Layer Mask]). Although you cannot change the name of a layer mask, it automatically updates if you change the layer name.

To copy a layer mask to a channel

1. Right-click a layer mask in the Channels panel, and choose Duplicate.
2. In the Duplicate Channel dialog box, enable the New Alpha Channel option.

You can also copy a channel to an existing channel, so that the existing channel is replaced. To do this, enable the Replace Existing Alpha Channel option, and choose the existing channel from the list box.

To copy a channel to a layer mask

1. Select a layer in the Layers panel.
2. Click the New Layer Mask button.
   A blank layer mask is created.
3 In the Channels panel, right-click the channel you want to copy, and choose Duplicate.
4 In the Duplicate Channel dialog box, enable the Replace Existing Alpha Channel option.

Corel Painter copies to the layer mask the portion of the channel that coincides with the layer content.

**Inverting layer masks**

You can invert a layer mask to make dark pixels light, and light pixels dark.

**To invert a layer mask**

1 In the Channels panel, select a layer mask.
2 Click the Channel options button, and choose Invert.

You can also invert a layer mask by right-clicking the layer mask, and choosing Invert.

**Editing layer masks**

When you select a layer mask, you can edit it as you would edit a channel. You can paint in a layer mask; apply effects to it; fill it with a color, pattern, gradient, or weave; and feather it. You do not have to view a layer mask to edit it; you can select the layer mask, make changes to it, and view the resulting image immediately.

When you edit a layer mask, you are making modifications to the mask, not to the layer’s image. You can use shades of gray only; no colors are available. This is because the layer mask is a grayscale image that is separate from the RGB image.

The paint and effects you apply to a layer mask are reflected as follows:

- Applying white removes areas from the mask and reveals more of the layer.
- Applying black adds to the mask, which conceals more of the layer.
- Applying an intermediate gray value makes the mask semitransparent.

**Importing and exporting layers**

You can save your Corel Painter document in the RIFF format with “live” layers — the layers continue to function when you reopen the file. RIFF is the only format that preserves layers in their original state.

If you export a Corel Painter document in PSD (Photoshop) format, all layers convert to standard Photoshop transparent layers. Photoshop does not preserve groups; each layer in a group becomes its own Photoshop layer. For more information, see “Grouping layers” on page 588.

The following table describes how Corel Painter layer composite methods are converted to blend modes in Photoshop:
<table>
<thead>
<tr>
<th>Corel Painter Composite Method</th>
<th>Photoshop Blend Mode</th>
<th>Corel Painter Composite Method</th>
<th>Photoshop Blend Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gel</td>
<td>Darken</td>
<td>Overlay</td>
<td>Overlay</td>
</tr>
<tr>
<td>GelCover</td>
<td>not converted</td>
<td>Soft Light</td>
<td>Soft Light</td>
</tr>
<tr>
<td>Colorize</td>
<td>Color</td>
<td>Hard Light</td>
<td>Hard Light</td>
</tr>
<tr>
<td>Reverse-Out</td>
<td>Normal</td>
<td>Darken</td>
<td>Darken</td>
</tr>
<tr>
<td>Shadow Map</td>
<td>Multiply</td>
<td>Lighten</td>
<td>Lighten</td>
</tr>
<tr>
<td>Magic Combine</td>
<td>Lighten</td>
<td>Difference</td>
<td>Difference</td>
</tr>
<tr>
<td>Pseudocolor</td>
<td>Normal</td>
<td>Hue</td>
<td>Hue</td>
</tr>
<tr>
<td>Normal</td>
<td>Normal</td>
<td>Saturation</td>
<td>Saturation</td>
</tr>
<tr>
<td>Dissolve</td>
<td>Dissolve</td>
<td>Color</td>
<td>Color</td>
</tr>
<tr>
<td>Multiply</td>
<td>Multiply</td>
<td>Luminosity</td>
<td>Luminosity</td>
</tr>
<tr>
<td>Screen</td>
<td>Screen</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For more information, see “Blending layers by using composite methods” on page 594.

If you save a file to a file format other than RIFF or PSD, the layers drop (or merge) into a single background image.

**Working with reference layers**

Reference layers get their image content from an external source — either a pixel-based layer in the current document or a separate file. They provide a low-resolution representation of the original image that you can quickly manipulate in ways that would otherwise require more time. Working with a reference layer allows you to resize, rotate, or slant a layer onscreen by dragging its handles. The changes are immediately displayed in the document window. When you finish making changes, you can commit the reference layer back to a standard layer. Corel Painter examines the source image to restore the original resolution.

You cannot edit the image data in a reference layer. If you try to paint on or apply effects to a reference layer, Corel Painter prompts you to commit it back to a pixel-based layer.

You can create a reference layer by basing it on an existing layer or by placing an image. For more information, see “Opening and placing files” on page 98.

**To create a reference layer**

1. Select a layer.
2. Click the Layer options button in the Layers panel, and choose Convert To Reference Layer.

   The layer’s icon in the Layers panel changes to an eight-handled shape, and an eight-handled box marks the boundary of the layer’s contents in the document window.
You can also create a reference layer by right-clicking a layer in the Layers panel, and choosing Convert To Reference Layer.

You can also create a reference layer by selecting the layer, and choosing Layers ▶ Convert To Reference Layer.

To modify a reference layer

* Select a reference layer.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize a reference layer in one direction</td>
<td>Drag a side handle.</td>
</tr>
<tr>
<td>Resize a reference layer in more than one direction at once</td>
<td>Drag a corner handle. If you want to maintain the layer proportions, hold down Shift as you drag. The pointer changes when you position it over a corner handle.</td>
</tr>
<tr>
<td>Rotate a reference layer</td>
<td>Hold down Command (macOS) or Ctrl (Windows), and drag a corner handle. The pointer changes when you position it over a corner handle.</td>
</tr>
<tr>
<td>Skew a reference layer</td>
<td>Hold down Command (macOS) or Ctrl (Windows), and drag a side handle. The pointer changes when you position it over a side handle.</td>
</tr>
</tbody>
</table>

To commit a reference layer

* In the Layers panel, right-click a reference layer, and click Convert To Default Layer.

The conversion process might take a few seconds, depending on the size and quality of the layer.

Storing layers as images in the Image Portfolio

The Image Portfolio is a convenient place to store layers as images so you can use them again.

You can create your own Image Portfolio libraries to organize images by category. When you’re creating a library, keep in mind that the smaller the library, the easier it will be to see its contents at a glance.

You can also move items between Image Portfolio libraries. For more information, see “Working with libraries” on page 87.

To display the Image Portfolio panel

* Choose Window ▶ Media Panels ▶ Images.
  
  If the Image Portfolio panel is not expanded, double-click the Image Portfolio panel tab.

To add a layer to the Image Portfolio

1. Select a layer.
2. In the toolbox, click the Layer Adjuster tool.
3. In the Image Portfolio panel, click the Image Portfolio options button, and choose Add Image To Portfolio.
The layer is added to the portfolio.

4 In the **Save Image** dialog box, type a name in the **Save As** box.

The **Image Portfolio** holds only pixel-based layers. If you want to add a shape, Watercolor, Liquid Ink, or dynamic layer to the **Image Portfolio**, you must first convert it to a default layer. In the **Layers** panel, right-click the layer, and choose **Convert To Default Layer**.

### To use an image from the Image Portfolio

1 Choose **Window**  ➤ **Media Panels**  ➤ **Images**.

2 Double-click an item in the **Image Portfolio** panel to add it to the document window.

*Corel Painter places the Image Portfolio item on a new layer.*
Alpha Channels

Alpha channels, also referred to simply as channels, let you store and edit path-based and pixel-based selections in an active document. Corel Painter stores only the current selection by default, therefore, when you make a new selection, your previous selection is automatically lost. However, by saving the selection as an alpha channel, you can retain the selection information and load it in the image whenever you need it.

The alpha channel is a grayscale image that stores 8 bits of information per pixel, which means that each pixel can be assigned one of 256 levels of gray — from 0 (black) to 255 (white). White areas of the channel are selected, and black areas of the channel are protected. Intermediate levels of gray are partially protected. For example, areas that are 50% gray will allow 50% of the brushstroke or effect to get through the channel to the image.

This section contains the following topics:
• “Creating and copying channels” (page 609)
• “Generating channels automatically” (page 611)
• “Importing and exporting alpha channels” (page 612)
• “Selecting and viewing channels” (page 612)
• “Setting channel attributes” (page 614)
• “Deleting and clearing channels” (page 615)
• “Editing channels” (page 615)

Creating and copying channels

You can create a channel from a selection, create a blank channel, or create a new channel by copying an existing channel. The channels are saved with the image and remain part of the file. Channels remain inactive (for canvas control) until you load them as selections in the image. For more information, see “To load a selection from an alpha channel” on page 635.

Corel Painter lets you create up to 32 alpha channels. The channels are listed in the Channels panel and are available for selecting, displaying, and modifying.
The Channels panel displays all alpha channels that are stored in the current document.

To create a channel from a selection
1. Click a selection tool in the toolbox and make a selection.
2. Choose Window ➤ Channels.
3. In the Channels panel, click the Save Selection as Channel button 
4. Type a name in the Name box.

To apply an alpha channel as a selection, you must load it as a selection in the document window. For more information, see “To load a selection from an alpha channel” on page 635.

You can also open the Channels panel by pressing Command + 5 (macOS) or Ctrl + 5 (Windows).

To create a blank channel
- In the Channels panel, do one of the following:
  - Click the Channel options button , and choose New.
  - Click the New Channel button 

To copy a channel
1. In the Channels panel, choose a channel from the list.
2. Click the Channel options button , and choose Duplicate.
3. In the Duplicate Channel dialog box, enable the New Alpha Channel option.
You can also copy a channel to an existing channel, so that the existing channel is replaced. To do this, enable the **Replace Existing Alpha Channel** option, and choose the existing channel from the list box.

### Generating channels automatically

Corel Painter can automatically generate a channel based on the light and dark areas of a number of sources, including paper, pattern, and clone source. For example, you can create a channel based on the luminance values of a clone. You can also create a channel based on a range of colors. These methods are similar to automatically generating pixel-based selections. For more information, see “Creating pixel-based selections” on page 629.

![An image (left), the channels created using image luminance (middle), and inverted image luminance (right)](image)

**To generate a channel based on luminance**

1. In the **Channels** panel, do one of the following:
   - To generate a new channel, choose the RGB channel from the list.
   - To replace a channel, choose it from the list.

2. Click the Channel options button 🔄, and choose **New From**.

3. In the **New From** dialog box, choose one of the following options from the list box:
   - **Paper** — uses the current paper texture to create the channel
   - **3D Brush Strokes** — creates a channel based on the difference between the current image and the clone source. If no clone source is selected, Corel Painter uses the current pattern.
   - **Original Selection** — works only when performing offset sampling between documents. It allows you to create a channel in the sampling destination document that is based on a selection made in the sampling source document. For best results, the dimensions of the source and destination documents should match. You must establish a link between an offset sampling source and destination document for this option to be available. For more information, see “Cloning image areas” on page 203.
   - **Image Luminance** — creates a channel based on the current image’s light and dark areas. For **Image Luminance** to be effective, the image must have high contrast. Images with low contrast produce a semisolid channel, without clear delineation between the selected and protected areas.
   - **Original Luminance** — produces a channel based on the clone source's light and dark areas. This option lets you import an image to the channel. If no clone source is selected, Corel Painter uses the current pattern.
   - **Current Color** — creates a channel based on pixels of the current main color. Areas of the current color are protected; the rest of the image is selected. You might want to use the **Dropper** tool to pick a color from the image before using the **Current Color** option.

If you want to invert the channel, enable the **Invert** check box.
Like a grayscale image, a channel can have 256 values in it. Inverting a channel is equivalent to creating the negative of a grayscale image. For example, a pixel with 80% luminance will have 20% luminance when inverted. A pixel with 30% luminance will have 70% luminance when inverted.

To generate a color-based channel

1 In the Channels panel, do one of the following:
   • To generate a new channel, choose the RGB channel from the list.
   • To replace a channel, choose it from the list.
2 Click the Channel options button and choose New From Color Range.
3 With the New Channel from Color Range dialog box open, click in the document window to pick a color.
4 The color you select is the middle of the range of colors used to create the channel.
5 In the New Channel from Color Range dialog box, adjust the Range slider in the Hue, Saturation, and Value areas. These sliders control the selected range. You can drag the limits of the range in either direction.
6 In the New Channel from Color Range dialog box, adjust the Feather slider in the Hue, Saturation, and Value areas. This helps soften the edges of the channel.
   If you want to invert the channel, enable the Inverted check box.

The channel displays as a red overlay on the image in the Preview window of the New Channel from Color Range dialog box. You can drag in the Preview window to display other parts of the image.

Importing and exporting alpha channels

When you save a file to the Corel Painter file format (RIFF), the alpha channels that are stored in the file are retained. They are also retained when exporting Corel Painter files in the Adobe Photoshop (PSD) format. In addition, if you import an Adobe Photoshop file that contains alpha channels in Corel Painter, the alpha channels are supported.

It is important to note that when you open RGB-based Adobe Photoshop files in Corel Painter, anything in the alpha channels (#4 and above) appear as a channel in Corel Painter. Conversely, when you export your Corel Painter file in the Photoshop format, all channels are placed into channels #4 and above.

Selecting and viewing channels

You can select and view all alpha channels that are stored in the active document from the Channels panel. Selecting and viewing a channel are distinct operations — you can view a channel without selecting it, and you can select a channel without viewing it. If you want to edit a particular channel, you must select it.
You can view or hide a channel by clicking the eye icon next to the channel’s thumbnail in the Channels panel. When the eye is open (1), the channel is displayed in the document window. When the eye is closed (2), the channel is hidden.

The Channels panel also lists the RGB color image. In addition, if a layer is selected, and the layer has a layer mask, the Channels panel also lists the layer mask. For more information, see “Creating and deleting layer masks” on page 600.

You can view the RGB image and more than one channel, but your editing applies only to the one item selected in the Channels panel — either the RGB image or a channel.

Corel Painter offers two ways to view a channel — as a colored overlay on the image or in grayscale. Colored overlays are red by default, but you can change the color. For more information, see “To set channel attributes” on page 615.
To display the channels panel

- Choose Window   Channels.

  If the panel is not expanded, double-click the panel tab.

To select a channel

- In the Channels panel, choose a channel from the list.

  When you want to work on the image again, choose RGB from the list.

To view or hide a channel

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>View a channel as a colored overlay</td>
<td>In the Channels panel, click the eye icon  next to the channel’s thumbnail. In this mode, the RGB image is always displayed.</td>
</tr>
<tr>
<td>View a channel as a grayscale image</td>
<td>In the Channels panel, make sure the channel is hidden (eye closed  ) and not selected, and click the channel name. In this mode, the RGB image is hidden.</td>
</tr>
<tr>
<td>Hide a channel</td>
<td>Click the eye icon  next to the channel item to close the eye</td>
</tr>
</tbody>
</table>

A channel protecting the wings and body is displayed in grayscale. The RGB image is hidden.

Setting channel attributes

You can change the appearance of channels by modifying their display attributes, which helps to distinguish one channel from another. These attributes do not affect the function of the channel; they affect only how the channel displays in the document window.

Corel Painter names new channels incrementally: Alpha 1, Alpha 2, and so on. Renaming a channel makes it easier to find a specific channel, especially if you have several in the document.
To set channel attributes

1. In the **Channels** panel, choose a channel from the list.
2. Click the Channel options button  and choose **Channel Attributes**.
3. In the **Channel Attributes** dialog box, move the **Opacity** slider to set the channel display strength.
4. Click the **Color** chip, and choose a display color in the **Color** dialog box. If you want to see the color overlay in grayscale, choose black. A channel is easiest to use as an overlay when its color contrasts strongly with the predominant hue of the RGB image. You might want to use a different color for each channel.
5. Click **OK**.
6. Enable one of the following options to specify where the color overlay displays:
   - **Masked Areas**
   - **Selected Areas**
   If you want to rename the channel, type a name in the **Name** box.

   If you want the channel displayed at its full intensity, move the **Opacity** slider to 100%. Choose a lower value to display the channel more transparently so you can follow the underlying RGB image as you edit the channel.

Deleting and clearing channels

If you’ve finished working with a particular channel you can delete it. You can also clear a channel without deleting it, leaving you with a blank channel.

To delete a channel

1. In the **Channels** panel, choose a channel from the list.
2. Click the **Delete** button at the bottom of the **Channels** panel.

   You can also delete a channel by clicking the Channel options button  and choosing **Delete**.

To clear a channel

1. In the **Channels** panel, choose a channel from the list.
2. Click the Channel options button  and choose **Clear**.

Editing channels

You can edit a channel by modifying the size, shape, or opacity of its protected area, which ultimately becomes the protected area of the selection. The changes that you make to the channel do not directly affect the image until you load it as a selection. For more information, see “To load a selection from an alpha channel” on page 635.

Because the alpha channel is a grayscale image, you edit the channel by applying only white (to remove protected areas), black (to add protected areas), and shades of gray (to create semi-protected areas); no colors are available.

You can apply changes by selecting a brush and painting the changes in the channel.
In this example, the channel has a few stray areas that are unprotected (left). The stray areas were transformed into protected areas by applying black brushstroke (right).

In addition, you can apply effects, such as feathering to soften the transitions between light and dark areas. This introduces a bit of opacity to the channel.

You can also invert a channel to convert a protected area into an unprotected area.

In addition, you can introduce interesting effects by filling a channel with a pattern, gradient, or weave. For more information, see “Working with color fills” on page 260.

**To paint in a channel**

1. In the **Channels** panel, display and select the channel you want to work with. If you want to paint only on a specific area of the channel, make a selection.

2. Choose the **Brush** tool from the toolbox.

3. Click the Brush Selector on the Brush Selector bar.

4. In the Brush library panel, click a brush category, and brush variant. The **Pen** and **Airbrush** brush categories make good choices.

5. In the **Color** panel, choose one of the following:
   - **Black** — adds to the protected area
   - **White** — removes from the protected area
• Grey — applies a semi-protected area

When you paint in the channel, hue is irrelevant. The channel carries 8 bits of information and you need only set a level in that range. The value scale is between black and white.

6 Paint in the document window.

7 In the Channels panel, click the eye icon next to the RGB channel’s thumbnail to display the channel in grayscale.

You can also

Control the brush opacity

Adjust the Opacity slider on the property bar.

Change the brush size

Type a value in the Size box, or adjust the slider.

To apply an effect to a channel

1 In the Channels panel, display and select the channel you want to work with.
   If you want to apply the effect to a specific area of the channel, make a selection.

2 Choose an effect from the Effects menu.

To feather a channel

1 In the Channels panel, display and select the channel you want to work with.

2 Click the Channel options button, and choose Feather.

3 In the Feather dialog box, type a number of pixels.

To invert a channel

1 In the Channels panel, choose a channel from the list.

2 Click the Invert Channel button.

To fill a channel with a pattern

1 In the Channels panel, display and select the channel you want to work with.
   If you want to fill only a specific area of the channel, make a selection.

2 Click Window > Media Panels > Patterns.

3 In the Patterns panel, click a pattern swatch.

4 Choose Edit > Fill.

5 In the Fill dialog box, choose Original Luminance from the Fill with list box.
   If you want to change the opacity, adjust the Opacity slider.

To fill a channel

1 In the Channels panel, display and select the channel you want to work with.

2 Choose the Paint Bucket tool from the toolbox.

3 On the property bar, click the Fill Image button.

4 From the Fill list box on the property bar, choose one of the following:
• **Current Color** — fills with the current color (a shade of gray). For information, see “Working with color fills” on page 260.
• **Gradient** — fills with the selected gradient. For information, see “Applying gradients” on page 737.
• **Source Image** — fills using the current clone source image. If you haven’t defined a clone source, Corel Painter fills with the current pattern. For information, see “Filling an area with a sampled image” on page 213.
• **Weave** — fills with the selected weave. For information, see “Applying weaves” on page 767.

5  Open the Fill selector on the property bar, and click a swatch from the media library panel.

6  Click the area of the channel you want to fill.

   If the result is not what you want, undo the fill, change the settings, and try again.

You can also

Specify the range of grey to be filled

   On the property bar, type a value in the Tolerance box, or adjust the slider.

Specify the fill opacity for pixels outside the tolerance range

   On the property bar, type a value in the Feather box, or adjust the slider.

Soften the edge of the fill

   Enable the Anti-Alias button on the property bar. Anti-aliasing is desirable when Feather is zero or extremely low.

The **Paint Bucket** tool applies a fill only to a visible channel. Make sure the channel’s eye icon is open before using the **Paint Bucket** tool.

You can return to the default **Paint Bucket** tool settings by clicking the **Reset Paint Bucket Tool** button on the property bar.
Selections and transformations

Corel Painter includes various tools for selecting an area of the canvas to mark it for special treatment. You can make selections to change an area, to protect an area from change, or to apply a transformation.

This section contains the following topics:

Creating and saving selections
- “Getting started with selections” (page 620)
- “Selecting areas by painting” (page 622)
- “Creating path-based selections” (page 627)
- “Creating pixel-based selections” (page 629)
- “Creating selections from layers” (page 632)
- “Choosing the protected area of a selection” (page 633)
- “Saving selections as alpha channels” (page 633)

Viewing and modifying selections
- “Working with the Selection Portfolio” (page 636)
- “Viewing selections” (page 636)
- “Inverting selections” (page 637)
- “Softening the edges of selections” (page 637)
- “Stroking selections” (page 638)
- “Modifying the borders of selections” (page 639)
- “Expanding or contracting selections” (page 639)
- “Adding to or subtracting from selections” (page 640)

Transforming selections
- “Preparing selections for transformations” (page 641)
- “Moving selections” (page 642)
- “Transforming a duplicate selection” (page 643)
- “Scaling and rotating path-based selections” (page 643)
- “Skewing and distorting path-based selections” (page 645)
- “Canceling transformations” (page 647)
Getting started with selections

You can use selections to isolate an area of the canvas to apply effects or transformations, while protecting the unselected areas from the changes.

Selection types

Corel Painter supports two types of selections: path-based and pixel-based. The method that you use to create a selection determines its type.

- Path-based selections are defined by a closed path, for example a circle or a square. You can make path-based selections by using the Rectangular Selection, Oval Selection, Lasso tool, or by converting a shape. Path-based selections support many transformations that pixel-based selections do not. In addition, it’s the only type of selection that you can store in the Selection Portfolio.

- Pixel-based selections are defined at the pixel level. You can create a pixel-based selection by using the Magic Wand tool. Corel Painter also includes options for auto-generating selections based on various image or clone characteristics.

You can covert a pixel-based selection to a path-based selection. For more information, see “To convert a pixel-based selection to a path-based selection” on page 629.

Selection methods

The following table describes the various methods for using selections.

<table>
<thead>
<tr>
<th>To</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constrain brushstrokes</td>
<td>Protects the area inside or outside the selection from painting</td>
</tr>
<tr>
<td>Transform</td>
<td>Moves, scales, rotates, skews, or distorts an area</td>
</tr>
<tr>
<td>Apply an image effect</td>
<td>Applies an effect to only an isolated area. You can also set different levels of protection within a selection to create partial intensity of the effect.</td>
</tr>
<tr>
<td>Cut or copy</td>
<td>Removes, moves, or duplicates an area</td>
</tr>
<tr>
<td>Copy to a new layer</td>
<td>Copies or moves an area to a new layer</td>
</tr>
<tr>
<td>Stroke the selection</td>
<td>Applies a brushstroke along a selection’s border</td>
</tr>
<tr>
<td>Create a channel</td>
<td>Saves a selection to a channel</td>
</tr>
</tbody>
</table>

Selection tools

The following table describes all of the available selections tools.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular Selection</td>
<td>Creates rectangular and square selections (path-based). For more information, see “To</td>
</tr>
</tbody>
</table>
Selections and transformations

Oval Selection

Creates oval selections (path-based). For more information, see “To make an oval or a circular selection” on page 628.

Lasso tool

Creates freehand selections (path-based). For more information, see “Make a freehand selection” on page 629.

Polygonal Selection tool

Selects an area based on different points set in an image which are anchored by straight line segments (path-based). For more information, see “Make a freehand selection with straight-edged segments” on page 629.

Magic Wand tool

Selects pixels of similar color by clicking or dragging in an image (pixel-based). For more information, see “To select an area by using the Magic Wand tool” on page 630.

Selection Brush tool

Lets you create a freehand selection by painting. For more information, see “To make a freehand selection by painting” on page 624.

Transform tool

Modifies path-based selections by using different transformation modes.

Selection Adjuster tool

Selects, moves, and manipulates path-based selections.

Selection brushes

Selection brushes let you create freehand selections by painting. Explore the collection of Selection brush variants in Corel Painter to find some useful brushes or create your own custom variants. For more information, see “Selecting areas by painting” on page 622 and “Selection brushes” on page 354.

Selection storage

In Corel Painter, each new selection automatically replaces the current selection, therefore, you need to store a selection in order to reuse it. Corel Painter includes two options for storing the selections that you want to reuse.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha channels</td>
<td>Stores both path-based and pixel-based selections for the current document. You can modify alpha channels by combining them with the current selection.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Selection Portfolio</td>
<td>Stores path-based selections in a library to make them accessible from any document</td>
</tr>
</tbody>
</table>

**Selecting areas by painting**

You can create a freehand selection by painting with the **Selection Brush** tool or any brush variant that uses the **Selection** method. Use Corel Painter’s interactive and dynamic brush shapes to quickly generate new, additive, or subtractive selections.

![Examples of selections created with Selection brush variants using different dab types](image)

You can choose a Selection brush from the preset selection brushes available in Corel Painter or create your own custom brush from any brush that uses the following dab types: Circular, Computed Circular, Captured, Single-Pixel, Static Bristle, Dynamic Speckle Bristle, and Dynamic Speckle Particle types (Flow, Gravity, and Spring). Selection brushes support grain and opacity, and work with all other selection tools.

You can customize Selection brushes by using brush controls. For more information, see “Adjusting brushes with brush controls” on page 371.

As you brush over an image to make a selection, a color overlay appears, to help you distinguish selected areas from protected areas. By default, the overlay is a red-tinted, transparent sheet. However, if your underlying brushstrokes are red, you can change the overlay color so that the overlay can be seen clearly against the image colors. You can adjust the overlay opacity, and you can also choose to display the overlay over selected or protected areas.
By default, the overlay is no longer visible after you complete a selection. Instead, a dashed outline — marquee — appears around the selection to indicate the border separating the selected area from the protected area. If you find it useful to have the color overlay visible at all times, you can easily display it.

When painting with a Selection brush, you can automatically align brushstrokes to a curve. For more information about aligning brushstrokes to paths and shapes, see “Aligning brushstrokes to paths and shapes” on page 158.
When painting with a Selection brush, you can align brushstrokes to perspective guides. For more information about perspective guides, see “Using perspective guides” on page 222.

To make a freehand selection by painting

1. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an area with the <strong>Selection Brush</strong> tool</td>
<td>In the toolbox, click the <strong>Selection Brush</strong> tool 🖋.</td>
</tr>
<tr>
<td>Select an area with a Selection brush</td>
<td>Click the Brush Selector on the Brush Selector bar. In the Brush library panel, click a brush category, and a choose a brush variant that uses the <strong>Selection</strong> method.</td>
</tr>
</tbody>
</table>

2. Paint in the document to select the area you want.
You can also

Choose a brush tip profile
Click the Dab Options button on the property bar, and choose a dab profile.
For more information about dab profiles, see “Changing dab profiles” on page 401.

Set dab opacity
Move the Opacity slider on the property bar.
The lower the opacity, the fewer pixels are selected.

Note: If you are painting with a brush that uses the Add to Selection (Glazing) method, brushstrokes with opacity lower than 50% produce no marks.
For more information about opacity, see “Opacity controls” on page 388.

Set grain
Move the Grain slider on the property bar.
For more information about grain, see “Grain controls” on page 390.

To save a selection, click the Save Selection button on the property bar. For more information about saving selections, see “Saving selections as alpha channels” on page 633.

To replace the active selection, click the New Selection button on the property bar.

You can also add to or subtract from a selection. For information, see “Adding to or subtracting from selections” on page 640.

To customize a Selection brush

1 In the Brush Selector panel (Window ➤ Brush Selector ➤ Panel (Full View)), choose a brush with one of the following dab types: Circular, Computed Circular, Captured, Single-Pixel, Static Bristle, Dynamic Speckle Bristle, and Dynamic Speckle Particle types (Flow, Gravity, and Spring).

2 In the General panel (Window ➤ Brush Control Panels ➤ General), choose Selection from the Method list box.

3 From the Subcategory list box, choose one of the following categories:
• New Selection — creates a new selection
• Add to Selection — As the dab opacity builds up quickly, pixels are added quickly to a selection.
• Add to Selection (Glazing) — The dab opacity never exceeds the maximum value that you have specified, regardless of how many times you brush over the same area in a single brushstroke or how many brushstrokes you apply to the same area. If the opacity is below 50%, no pixels are selected.
• Add to Selection (Alpha Blend) — The opacity builds up very slowly when you brush over the same area in a single brushstroke.
• Subtract from Selection — subtracts from an existing selection
To set selection display options

1. Click the Selection Display Options button on the property bar.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the overlay color</td>
<td>Click the color picker, and choose a color.</td>
</tr>
<tr>
<td>Set the overlay opacity</td>
<td>Move the Opacity slider.</td>
</tr>
<tr>
<td>Overlay a selected area</td>
<td>Choose Selected area from the Overlay list box.</td>
</tr>
<tr>
<td>Overlay a protected area</td>
<td>Choose Masked area from the Overlay list box.</td>
</tr>
</tbody>
</table>
To Do the following

View the overlay after you complete a selection Disable the Hide Overlay check box.

To align a selection brushstroke to a curve
1. Open or create a document.
2. Click the Quick Curve tool \( \bigcirc \) in the toolbox, and drag to create a curve.
   - If you prefer, you can access the Quick Curve tool by pressing \( Q \).
3. In the Brush Selector panel (Window \( \rightarrow \) Brush Selector \( \rightarrow \) Panel (Full View)), click a Selection brush.
4. Click the Stroke Options flyout button \( \bigcirc \) on the property bar, and click the Align to Path button .
5. Paint near the curve.
   - If the brushstrokes are within the tolerance area, they follow the curve; if they are outside the tolerance area, no brushstrokes are applied.

To align a selection brushstroke to perspective guides
1. Open or create a document.
2. In the toolbox, click the Perspective Guides tool \( \bigcirc \).
   - If you prefer, you can access the Perspective Guides tool by pressing the period key.
3. Click the Perspective Guides check box on the property bar.
4. Choose a preset from the Preset drop-down list.
5. In the Brush Selector panel (Window \( \rightarrow \) Brush Selector \( \rightarrow \) Panel (Full View)), click a Selection brush.

To turn off snapping to perspective guides, hold down \( \text{Shift} \) as you paint.

Creating path-based selections

You can create path-based selections that are rectangular or oval. If you need more flexibility, you can create freehand selections by using the Lasso or the Polygonal Selection tools. The Lasso tool creates selections based on freehand segments. The Polygonal Selection tool selects an area with more precision by setting different points on the image and anchoring them using straight-line segments.

You can apply transformations only to path-based selections. However, you can convert any pixel-based selections to path-based selections in order to perform transformations. It’s important to note that when converting a pixel-based selection, the modified selection is reduced to only two levels of protection: the inside or the outside of the selection is protected. For more information, see “Choosing the protected area of a selection” on page 633.

In addition, if you select multiple layers prior to performing a transformation on a path-based selection, the transformation applies to the selected area across any layers that are currently selected. For example, if you select a layer group, the selection and transformation is applied to all layers within that group. Therefore, make sure to select only the desired layers before performing a transformation.

You can also select the entire canvas or create path-based selections by converting shapes or pixel-based selections. Converting a shape to create a path-based selection is useful for selecting an area that is identical to an existing shape or text.
To make an oval or a circular selection

2. In the Layers panel, do one of the following:
   • Click a layer.
   • Click a layer group.
   • Hold down Command + Shift (macOS) or Ctrl + Shift (Windows), and click each layer you want to select.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To select</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>An oval area</td>
<td>Choose the Oval Selection tool  from the toolbox. Drag in the document window to select an area.</td>
</tr>
<tr>
<td>A circular area</td>
<td>Choose the Oval Selection tool  from the toolbox. While dragging the selection in the document window, hold down the Shift key.</td>
</tr>
</tbody>
</table>

Whenever you create a selection, Corel Painter deactivates the previous selection.

To make a rectangular or square selection

2. In the Layers panel, do one of the following:
   • Click a layer.
   • Click a layer group.
   • Hold down Command + Shift (macOS) or Ctrl + Shift (Windows), and click each layer you want to select.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To select</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A rectangular area</td>
<td>Choose the Rectangular Selection tool  from the toolbox. Drag in the document window to select an area.</td>
</tr>
<tr>
<td>A square area</td>
<td>Choose the Rectangular Selection tool  from the toolbox. While dragging the selection in the document window, hold down the Shift key.</td>
</tr>
</tbody>
</table>

To make a freehand selection

2. In the Layers panel, do one of the following:
   • Click a layer.
   • Click a layer group.
• Hold down **Command** + **Shift** (macOS) or **Ctrl** + **Shift** (Windows), and click each layer you want to select.

3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make a freehand selection</td>
<td>Choose the <strong>Lasso</strong> tool from the toolbox. Draw a freehand border around the area that you want to select in the document window.</td>
</tr>
<tr>
<td>Make a freehand selection with straight-edged segments</td>
<td>Choose the <strong>Polygonal Selection</strong> tool from the toolbox. Click where you want to set the anchor points of the polygon selection, and double-click to set the last anchor point.</td>
</tr>
</tbody>
</table>

If you draw an open path with the **Lasso** tool, the endpoints are connected automatically with a straight line before the selection is created.

**To select the entire canvas**

• Choose **Select** ➤ All.

**To convert a shape to a selection**

1 Select the shape that you want to convert.  
The shape must be closed.

2 On the property bar, click the **Convert To Selection** button.

The outline of the shape creates the selection path. Everything within the outline is fully selected.

You can also convert the current selection to a shape. For more information, see “To convert a selection to a shape” on page 801.

**To convert a pixel-based selection to a path-based selection**

1 Create a pixel-based selection.  
For more information, see “Creating pixel-based selections” on page 629.

2 Choose **Select** ➤ **Transform Selection**.

Corel Painter generates paths from the outlines of the pixel-based selection. You can now use the **Transform** tool for transformations.

**Creating pixel-based selections**

Corel Painter offers various methods for making pixel-based selections. The **Magic Wand** tool selects groups of pixels according to color. You can adjust the settings to control the range of colors, and you can also choose to include only adjacent colors (contiguous) or only nonadjacent colors (noncontiguous).
In addition, there are ways to auto-generate pixel-based selections by using various image, clone, and color characteristics. For example, you can create a selection based on the luminance values of a clone.

Pixel-based selections provide 256 levels of protection to the canvas. Each pixel in the selection sets a level of protection for its corresponding color pixel in the RGB image. Opaque areas of the selection provide 100% protection and prevent brushstrokes and effects from marking the canvas. Clear areas of the selection provide no protection and allow brushstrokes and effects to mark the canvas. Brushstrokes and effects are partially applied to areas where the selection is shaded or semitransparent. As a result, you can paint and apply effects with varying levels of intensity within a selection.

You can move pixel-based selections, but you cannot resize or rotate them. To apply transformations to pixel-based selections, convert any pixel-based selections into path-based selections. For more information, see “To convert a pixel-based selection to a path-based selection” on page 629.

To select an area by using the Magic Wand tool

1. In the toolbox, click the Magic Wand tool.
2. On the property bar, adjust the Tolerance slider to control the amount of variance allowed from the selected color with higher values creating a larger range of colors.
3. In the document window, do one of the following:
   - Click to select the color in the middle of the range of colors that you want to use for the selection.
   - Click and drag over an area to define the range of colors that you want to use for the selection.

   It may take a moment for the selection to be calculated and loaded.

You can also

- Create a selection with contiguous pixels
  - On the property bar, click the Contiguous button.
- Create a new selection
  - On the property bar, click the New Selection button and click in the document window.
- Add to the current selection
  - On the property bar, click the Add To Selection button and click the areas you want to add.
- Remove an area from the current selection
  - On the property bar, click the Subtract From Selection button and click the areas you want to add.

The default tolerance for selections is 32. This can be adjusted from 1 to 255.

If you add to the current selection, you add to the range of values that the Magic Wand tool selects rather than create an additional selection with a unique seed color.

You can restrict a selection to a rectangular area by pressing Option + Shift (macOS) or Alt + Shift (Windows), and dragging a bounding rectangle in your image.

You can restore the default settings by clicking the Reset Tool button on the property bar.
To auto-generate a selection based on image characteristics

1. Choose Select  Auto Select.
2. From the Using list box, choose one of the following options:
   - Paper — creates a selection by using the current paper texture
   - Image Luminance — creates a selection based on the light and dark areas of the current image
   - Current Color — creates a selection of pixels based on the current main color. Before using this option, you can pick a color from the image by using the Dropper tool.

   If you want to invert the selection, enable the Invert check box.

To auto-generate a selection based on clone characteristics

1. Open or create an image.
2. In the Clone Source panel (Window  Clone Source), choose Embedded Image from the Source list box. In the Embed Source Image dialog box, do one of the following:
   - To browse for a file, enable the Browse option.
   - To clone a currently open document, enable the Current Document option, and choose a document from the list box.
   - To embed the active texture, enable the Current Texture option.
3. Choose Select  Auto Select.
4. From the Using list box, choose one of the following:
   - 3D Brush Strokes — creates a selection that is based on the difference between the current image and the clone source. If no clone source is selected, the current pattern is used.
   - Original Luminance — produces a selection in the current document based on the light and dark areas of the clone source. If no clone source is selected, the current pattern is used.

   If you want to invert the selection, enable the Invert check box.

To auto-generate a color-based selection

1. Choose Select  Color Select.
2. Click in the document window to pick a color.
3. In the Color Select dialog box, move the Range sliders in the Hue, Saturation, and Value areas. These sliders control the selected range of colors.
4. Move the Feather sliders in the Hue, Saturation, and Value areas. Feathering helps soften the selection edge.
5. The Preview window shows the selected area as a red overlay on the image. Drag in the Preview window to see other parts of the document.
Creating selections from layers

You can create a selection from a layer, multiple layers, or layer group. You can also add the transparency mask of a layer, or layer group, to a previous selection. To modify a layer-based selection, you can subtract or intersect the transparency mask of a layer, or layer group, with a previous selection. Intersecting includes only those parts that are common to all selected layers. For more information, see “Getting started with layers” on page 570.

To create a selection from a layer

- With the Layers panel open, perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select the content of a layer</td>
<td>Choose <strong>Select ➤ Select Layer Content</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can also select the content of a layer from the <strong>Layers</strong> panel, by holding</td>
</tr>
<tr>
<td></td>
<td>down <strong>Command</strong> (macOS) or <strong>Ctrl</strong> (Windows), and clicking the title of the</td>
</tr>
<tr>
<td></td>
<td>layer that you want to select.</td>
</tr>
<tr>
<td>Select the content of a group of layers</td>
<td>Choose <strong>Select ➤ Select Group Content</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can also select the content of a layer group from the <strong>Layers</strong> panel, by</td>
</tr>
<tr>
<td></td>
<td>clicking the group, and then holding down <strong>Command</strong> (macOS) or <strong>Ctrl</strong></td>
</tr>
<tr>
<td></td>
<td>(Windows), and clicking the title of the layer group that you want to select.</td>
</tr>
<tr>
<td>Add the transparency mask of the layer or</td>
<td>In the <strong>Layers</strong> panel, hold down <strong>Shift + Command</strong> (macOS) or **Shift +</td>
</tr>
<tr>
<td>layer group to the previous selection</td>
<td>Ctrl** (Windows), and click the titles of the layers that you want to add.</td>
</tr>
<tr>
<td>Subtract the transparency mask of the layer</td>
<td>In the <strong>Layers</strong> panel, hold down <strong>Option + Command</strong> (macOS) or <strong>Alt + Ctrl</strong></td>
</tr>
<tr>
<td>or layer group from the previous selection</td>
<td>(Windows), and click the title of the layer that you want to subtract.</td>
</tr>
<tr>
<td>Intersect the transparency mask of a layer or</td>
<td>In the <strong>Layers</strong> panel, hold down <strong>Shift + Option + Command</strong> (macOS) or</td>
</tr>
<tr>
<td>layer group with the previous selection</td>
<td><strong>Shift + Alt + Ctrl</strong> (Windows), and click the title of the layer that you want</td>
</tr>
<tr>
<td>Create a selection from a Dynamic, Shape, or</td>
<td>to intersect.</td>
</tr>
<tr>
<td>Text layer</td>
<td></td>
</tr>
</tbody>
</table>

You can also create a selection from a layer by choosing **Load Selection** from the **Select** menu. In the **Load Selection** dialog box, choose the transparency of the selected layer from the **Load From** list box, and enable the **Replace Selection** option.
Choosing the protected area of a selection

The drawing mode determines whether the inside or the outside of a selection is protected when you paint.

To specify the protected area of a selection

1. Choose Window ▶ Navigator.

2. Click the Open Navigator Settings button, choose Drawing Mode, and then choose one of the following options:
   - Draw Anywhere — disables protection by the selection. Brushstrokes are allowed anywhere on the canvas. The selection is active only for applying effects and using the Cut or Copy command.
   - Draw Outside — protects the area inside the selection
   - Draw Inside — protects the area outside selection. This drawing mode is similar to using a stencil in that only the selected region accepts brushstrokes.

Saving selections as alpha channels

You can create alpha channels to store multiple selections in a document. An alpha channel is a temporary storage area for both path-based and pixel-based selections. To reuse a selection in other documents, you can store the selection in the Selection Portfolio. It is important to note that the Selection Portfolio stores only path-based selections. For more information see, "Working with the Selection Portfolio" on page 636.

You can create an alpha channel from the current selection to copy its editable and protected areas. You can also combine a new selection with one that was previously stored in an alpha channel. To reactivate a selection that was previously saved as an alpha channel, simply load it in the image. Loading a selection reactivates it on the canvas, where it controls painting and image effects.

Combining selections when saving or loading alpha channels

When you save or load alpha channels, you can combine the current selection with an existing alpha channel by adding, subtracting, or intersecting with the selection. Adding to a selection combines it with the existing channel. Subtracting a selection cuts it out of the existing channel. When intersecting a selection, you include only those parts that are common to the selection and the existing channel.

In the following set of owl images, the artist created and saved selections for each area that she wanted to work with separately — the eyes, the beak, and the outline. To show the selections clearly in these images, the selections were saved to channels, reloaded, and displayed as red overlays. For more information, see "To view or hide a channel" on page 614.

The following images show the step-by-step creation of a precise “face” selection that excludes the beak and eyes. The purpose of the precise selection of the face is to control the brushstrokes and constrain effects.
The eye and beak channels (saved selections) are loaded and added. The combined selection is saved to the "eyebeak" channel.

The "outline" channel is loaded.

The "eyebeak" channel is loaded and subtracted from the "outline" channel. The resulting selection is saved to the "head" channel.

A "face" selection is drawn roughly by using the Lasso tool. The eyes, the beak, and a portion of the background are included.
The “head” channel (the outline with eyes and beak subtracted) is loaded and intersected with the rough “face” selection. This step removes the eyes, beak, and background portion. The resulting selection is saved to the “face” channel.

To save a selection to a new alpha channel
1. Create a selection.
2. Choose Select ➤ Save Selection.
3. Choose New from the Save To list box.

If you want to specify a name, type a name in the Name box.

Alpha channels are pixel based, therefore, any path-based selections are saved as pixel-based selections.

If you do not specify a name, the new channel is named incrementally with the previous channel: Alpha 1, Alpha 2, and so on.

You can also save a selection to a channel by clicking the Save Selection As Channel button in the Channels panel.

To combine a selection with an existing alpha channel
1. Create a selection.
2. Choose Select ➤ Save Selection.
3. Choose a channel from the Save To list box.
4. In the Operation area, enable one of the following options:
   • Replace Mask — replaces the channel with the current selection
   • Add to Mask — combines the current selection with the chosen channel
   • Subtract From Mask — subtracts the current selection from the chosen channel
   • Intersect With Mask — determines the intersection of the selection and the chosen channel, and saves the intersection to the channel

You can also save a selection to a channel by clicking the Save Selection As Channel button in the Channels panel.

To load a selection from an alpha channel
1. Choose Select ➤ Load Selection.
2. Choose a channel from the Load From list box.
3. In the Operation area, enable one of the following options:
   • Replace Selection — replaces the current selection with the chosen channel

Selections and transformations | 635
• **Add To Selection** — adds the channel to the current selection
• **Subtract From Selection** — subtracts the channel from the current selection. In other words, the channel is “cut away” from the selection.
• **Intersect With Selection** — determines the intersection of the channel and the current selection. This intersection becomes the new selection.

You can also load a selection from an alpha channel by clicking the **Load Channel As Selection** button in the Channels panel.

**Working with the Selection Portfolio**

You can store any of the path-based selections that you want to reuse in the **Selection Portfolio**, which is a library for storing selections. You can add your selections to the default library, or create your own library. For more information, see “Working with libraries” on page 87. You can also browse and use any of the available sample selections in the **Selection Portfolio**.

**To store a selection in the portfolio**

1. Create the path-based selection you want to store.
2. Choose **Window** ➤ **Media Panels** ➤ **Selections**.
3. In the toolbox, click the **Selection Adjuster** tool .
4. In the **Selection Portfolio** panel, click the Selection Portfolio options button , and choose **Add Selection To Portfolio**.
5. In the **Save Selection** dialog box, type a name for the selection.

**To use a selection from the portfolio**

• Double-click a selection in the **Selection Portfolio** panel.

The selection replaces the previous selection and appears in its original position on the canvas, provided that the document dimensions are the same.

**Viewing selections**

You can turn a selection off and reactivate it later. In addition, options are available for controlling the display of the selection marquee, which is the visible border of the selection.

**To turn off a selection**

• Choose **Select** ➤ **None**.

You can also turn off a selection by clicking outside it with the **Oval Selection** tool , the **Rectangular Selection** tool , or the **Lasso** tool .

**To reactivate a selection**

• Choose **Select** ➤ **Reselect**.
This command is available only if you have previously turned off a selection.

**To hide or show the selection marquee**

- From the menu bar, choose one of the following:
  - Select Hide Marquee.
  - Select Show Marquee.

The drawing mode remains in effect even when the marquee is hidden. For more information, see “Choosing the protected area of a selection” on page 633.

**Inverting selections**

You can invert a selection, which deselects the previously selected area and selects the previously unselected area.

![The marquee indicates that the flower is selected (left). After inverting the selection, the marqueses, that surround both the canvas and the flower, indicate that everything but the flower is selected (right).](image)

A pixel-based selection can include 256 values, like a grayscale image. An inverted pixel-based selection is equivalent to the negative of a grayscale image. For example, a pixel that has 80% luminance will have 20% luminance when inverted.

**To invert a selection**

1. In the toolbox, click the Selection Adjuster tool, and then click a selection.

2. On the property bar, click the Invert Selection button.

To produce a unique effect, you can nudge the selection by a few pixels by using the Selection Adjuster tool, clicking the selection, and then pressing an arrow key on your keyboard a few times. This technique works only when the selection is directly on the canvas, it does not work if the selection is on a layer.

**Softening the edges of selections**

You can soften the edges of a path-based selection by anti-aliasing or feathering. Anti-aliasing smooths the edges of a selection by modifying the color transition between the pixels. Feathering, on the other hand, softens the edges by gradually increasing the transparency of the pixels along the edge of the selection.
To apply anti-aliasing to a selection
1  Create a selection by using one of the selection tools.
2  On the property bar, click the Anti-alias button.

To feather the edge of a selection
1  In the toolbox, click the Selection Adjuster tool, and then click a selection.
2  On the property bar, click the Feather button.
3  In the Feather Selection dialog box, specify the number of pixels that you want to feather.

The maximum number of pixels that you can feather is 50.

When the selection marquee is shown, feathering may be difficult to see. It is easier to see the effect of feathering if you save the selection to a channel and view the channel. For more information, see “To view or hide a channel” on page 614.

Stroking selections
You can apply a brushstroke to a path-based selection. Corel Painter uses the current brush variant, brush size, color, and paper texture to apply a stroke along the border of a selection. Stroking selections is an excellent way to make brushstrokes follow specific contours.

Setting the drawing mode controls whether brushstrokes are placed inside, outside, or on both sides of the selection border. For more information, see “Choosing the protected area of a selection” on page 633.

To stroke a selection
1  Create a path-based selection.
2  In the toolbox, click the Brush tool.
3  Click the Brush Selector on the Brush Selector bar.
4  In the Brush library panel, click a brush category, and click a brush variant.
5  Click a color in the Color panel.
6  On the property bar, type a value in the Size box, or adjust the pop-up slider.
7  In the Navigator panel, click the Open Navigator Settings button, choose Drawing Mode, and then choose a drawing mode option.
8  From the menu bar, choose Select → Stroke Selection, and repeat the command to build strokes.

You can use different brushes while building strokes.

To produce a unique effect, you can nudge the selection by a few pixels by using the Selection Adjuster tool, clicking the selection, and then pressing an arrow key on your keyboard a few times. This technique works only when the selection is directly on the canvas, it does not work if the selection is on a layer.
Stroking a selection while using the Draw Anywhere drawing mode lets you apply strokes to both sides of the selection border.

Modifying the borders of selections

You can modify the border width of path-based selections. You can also smooth a selection border by removing sharp edges, rounding corners, and straightening the outline path.

To modify the border of a selection

1. In the toolbox, click the Selection Adjuster tool, and then click a selection.
2. On the property bar, click the Modify flyout button, and click Border.
3. In the Border Selection dialog box, specify the number of pixels for the width of the border.

To smooth a selection

1. In the toolbox, click the Selection Adjuster tool, and then click a selection.
2. On the property bar, click the Modify flyout button, and click Smooth.
3. Repeat the command from the previous step until the path is sufficiently smooth.

Expanding or contracting selections

You can expand or contract a selection by a set number of pixels.
To expand or contract a selection

- Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand a selection</td>
<td>On the property bar, click the Modify flyout button, and click Widen. In the Widen Selection dialog box, specify the number of pixels.</td>
</tr>
<tr>
<td>Contract a selection</td>
<td>On the property bar, click the Modify flyout button, and click Contract. In the Contract Selection dialog box, specify the number of pixels.</td>
</tr>
</tbody>
</table>

Adding to or subtracting from selections

You can adjust the size and shape of a selection by adding or subtracting selection areas.

To add to a selection

1. Create a selection by using one of the selection tools.
2. On the property bar, click the Add To Selection button.
3. Select the area that you want to add.

If you are using the Oval Selection tool or the Rectangular Selection tool, you can select a circular or square area by holding down Shift while dragging.

You can also add to a selection by holding down Shift and selecting the area that you want to add. If you are using the Oval Selection tool or the Rectangular Selection tool and you want to select a circular or square area, you need to release Shift for a moment and then hold down Shift again while dragging.

When making selections, you can use any combination of selection tools, including the Magic Wand tool. If you combine pixel- and path-based selections, the result is a pixel-based selection. For more information about creating pixel-based selections with the Magic Wand tool, see “To select an area by using the Magic Wand tool” on page 630.

Adding to a path-based selection
To subtract from a selection

1 Create a selection by using one of the selection tools.
2 On the property bar, click the Subtract From Selection button.
3 Select the area that you want to subtract.

If you are using the Oval Selection tool or the Rectangular Selection tool, you can select a circular or square selection by holding down Shift while dragging.

You can also subtract from a selection by holding down Option (macOS) or Alt (Windows) and selecting the area you want to subtract. If you are using the Oval Selection tool or the Rectangular Selection tool and you want to select a circular or square area, you need to hold down Option + Shift (macOS) or Alt + Shift (Windows) while dragging.

You can also load selections from the Selection Portfolio, a library of ready-to-use selections. In addition, you can use Boolean operations to combine existing selections with alpha channels.

Preparing selections for transformations

Before attempting to transform a selection, it’s important to determine if it’s path-based or pixel-based because the selection type determines which transformations you can perform. For example, path-based selections support many transformations that pixel-based selections do not. However, you can convert a pixel-based selection to a path-based selection to apply transformations to it. For more information, see “To convert a pixel-based selection to a path-based selection” on page 629.

To prepare a selection for a transformation, you can set the reference point around which the transformation is performed. The reference point is located at the center of the selection by default.

You can also apply transformation simultaneously across multiple layers. For more information, see “Transforming layers” on page 581.

To determine the selection type

• In the toolbox, click the Selection Adjuster tool, and then click a selection.
  • If the selection displays handles, the selection is path-based.
  • If the selection does not have handles, it is pixel-based.

To set the reference point for a transformation

1 For a selection made by using the Selection Adjuster tool, choose the Transform tool from the toolbox.
If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.

2. Point to the center of the selection’s bounding box.

3. Drag the Reference Point to a new location on the canvas.

   You can place the Reference Point outside the selection.

You can reset the Reference Point to its default location by clicking the Reset Reference Point button on the property bar or choosing the Edit > Transform > Reset Reference Point.

Moving selections

You can move both path-based and pixel-based selections to a new location on the canvas.

To move a selection

1. For a selection made by using the Selection Adjuster tool, choose the Transform tool from the toolbox.

   If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.

2. On the property bar, click the Move button.

3. While staying within the bounding box, click the selection, and then drag it to a new position on the canvas.

   To display the layers in full-color before committing the transformation, disable the Fast Preview mode check box on the property bar.

4. On the property bar, click the Commit Transformation button.

   If you prefer, you can apply the transformation by pressing Enter.

You can move a pixel-based selection with the Transform tool; however, if a portion of the selection moves off the canvas, it is subtracted from the selection.
Transforming a duplicate selection

You can transform a copy of a selection or the contents of an active layer.

To transform a duplicate

1. Hold down Option (macOS) or Alt (Windows), and choose the Transform tool from the toolbox.
   - If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.
2. On the property bar, click a transformation mode.
   - The transformation is applied to copied content.
   - You can also transform a duplicate by clicking Command + Shift + Option + T (macOS) or CTRL + Shift + Alt + T (Windows).

Scaling and rotating path-based selections

You can scale or rotate path-based selections. Scaling lets you change the dimensions of a selection. You can also scale an object proportionally by preserving its aspect ratio.

To scale a selection

1. In the toolbox, click the Transform tool.
   - If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, then select the Transform tool.
2. On the property bar, click the Scale button.
3. Perform a task from the following table.
To | Do the following
---|---
Scale a selection in one dimension | Drag a side, top, or bottom handle. On the property bar, click the Commit Transformation button.

Scale a selection in two dimensions | Drag a corner handle. On the property bar, click the Commit Transformation button.

Scale while maintaining the selection’s shape, or “aspect ratio” | Hold down Shift while you drag a corner handle. On the property bar, click the Commit Transformation button.

Scale around the reference point while maintaining the selection’s shape, or “aspect ratio” | Hold down Alt + Shift (Windows) or Option + Shift (macOS), and drag a corner handle. On the property bar, click the Commit Transformation button.

Scale around the reference point | Hold down Alt (Windows) or Option (macOS), and drag a corner handle. On the property bar, click the Commit Transformation button.

You can also scale a selection by choosing Edit ➤ Transform ➤ Scale, and specifying the horizontal and vertical scale percentages in the dialog box.

**To rotate a selection**

1. In the toolbox, click the Transform tool.

   If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.

2. On the property bar, click the Rotate button.

3. Move the pointer outside the border of the selection’s bounding box.

4. Drag a corner handle.
If you want to constrain the rotation by 15-degree increments, hold down Shift while dragging.

5 On the property bar, click the Commit Transformation button ☑.

You can also Rotate a selection by choosing Edit ➤ Transform ➤ Rotate, and specifying the rotation angle in degrees in the dialog box. A positive number rotates clockwise; a negative number rotates counterclockwise.

Skewing and distorting path-based selections

You can skew and distort path-based selections. Skewing slants the vertical and horizontal dimensions of a selection non-proportionally. Distorting a selection lets you move the sides or corners of a selection in different directions. For example, you can crush or stretch the selection. In addition, you can use perspective distortion to give an object the appearance of depth. Skewing distortion allows you to achieve a 3D look.

To skew a selection

1 In the toolbox, click the Transform tool ▶️.

   If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool ▶️.

2 On the property bar, click the Skew button ◄.

3 Move the pointer outside the border of the selection’s bounding box.

4 Drag a side handle.

   If you want to skew only the selected side, hold down Alt (Windows) or Option (macOS) while dragging the side handle.

5 On the property bar, click the Commit Transformation button ☑.
To distort a selection

1. In the toolbox, click the Transform tool.
   - If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.
2. On the property bar, click the Distort button.
3. Drag a corner handle.
   - If you want to constrain the distortion to the horizontal or vertical axis, hold down Shift while dragging a corner handle.
   - If you want to distort the selection relative to the Reference Point, hold down Alt (Windows) or Option (macOS) while dragging a corner handle.
4. On the property bar, click the Commit Transformation button.

To distort perspective in a selection

1. In the toolbox, click the Transform tool.
   - If the Transform tool is not displayed in the toolbox, click and hold the Layer Adjuster tool to open the flyout, and then choose the Transform tool.
2. On the property bar, click the Perspective Distortion button.
3. Drag a corner handle.
   - If you want to constrain the distortion to the horizontal or vertical axis, hold down Shift while dragging a corner handle.
4. On the property bar, click the Commit Transformation button.
Canceling transformations

If you are not satisfied with the transformation, you can cancel it and return the selection to its previous state.

To cancel a transformation

• Click the Cancel Transformation button on the property bar, or press Esc.
Common options for effects

Corel Painter includes a wide array of effects that you can use to alter images. The effects are organized in four main categories:

• Tonal control
• Surface control
• Focus
• Esoterica

To control each of the effects, you need to modify their individual settings. However, the effects do have some options in common.

This section contains the following topics:

• “Fading effects” (page 649)
• “Applying recently used effects” (page 650)
• “Changing effects with open panels” (page 650)
• “Applying effects using source luminance” (page 650)

Fading effects

You use the **Fade** control to undo a percentage of the last effect applied to the image. You can use this feature to control the intensity of an effect.

---

Fade was applied to the image (right) to undo a percentage of the last effect (left).
To fade an effect

1. Choose **Edit ➤ Fade**.
   
   To apply **Fade**, you must have previously applied an effect to the image.

2. In the **Fade** dialog box, move the slider.
   
   If you change your mind, choose **Edit ➤ Undo**.

### Applying recently used effects

At the top of the **Effects** menu, Corel Painter displays the last two effects you applied. This lets you quickly reapply frequently used effects. You can also use keyboard shortcuts to apply the last two effects.

#### To reapply a recently used effect

- Do one of the following:
  - Choose **Effects**, then choose one of the options at the top of the menu.
  - Press **Command + /** (macOS) or **Ctrl + /** (Windows).

You can also apply a shortcut key to the 2nd Last Effect command by clicking **Edit ➤ Preferences ➤ Customize Keys**. Clicking the **Effects** category in the **Application Commands** list, clicking the 2nd Last Effect command to select it, and typing a shortcut key in the **Shortcut** column.

### Changing effects with open panels

To experiment with an effect, you must display all required panels before choosing an effect. For example, the **Color Overlay** effect combines the selected paper texture and main color to define the overlay. If the **Papers** and **Color** panels are open when you choose the effect, you can change paper grains and colors to create different overlays before applying the effect to your image. Any changes in the paper or color appear in the **Preview** window in the **Color Overlay** dialog box. You can move an effect’s dialog box around on your screen, if necessary, for full access to other panels.

### Applying effects using source luminance

With Corel Painter, you can apply some effects to an image by using the luminance values of a specified source, which can include an external source or the luminance of the image itself. The intensity of the effect on the image is based on the light and dark values of the source. A larger degree of change to the light areas of the source, and a smaller degree of change is applied to dark areas. For example, when you choose **Paper** as a source, the effect is applied according to the light and dark areas of the paper selected in the **Papers** panel. You can also choose a pattern or external image (clone source) as a luminance source.

The luminance source options are listed in the **Using** list box and they vary between effects. The luminance options can include:

- **Paper**
- **Image luminance**
- **Original luminance (pattern or clone source)**
- **3D Brushstrokes**
- **Alpha channel** or **layer mask** (Note: This option is available only if your document has a channel or a layer with a layer mask.)

These options are explained in greater detail in the Help for each of the effects. The best way to see how these options affect your images is to try them.
Corel Painter includes Focus effects for sharpening, softening, motion blurring, and distorting image. It also includes a collection of Esoterica effects, which let you transform images in various ways.

This section contains the following topics:

Focus effects
- “Applying Smart Blur” (page 651)
- “Applying Camera Motion Blur” (page 652)
- “Applying Depth of Field” (page 653)
- “Applying Glass Distortion” (page 655)
- “Applying Motion Blur” (page 657)
- “Sharpening focus” (page 658)
- “Softening focus” (page 659)
- “Applying Zoom Blur” (page 660)

Esoterica effects
- “Applying Marbling” (page 660)
- “Automatically cloning an image” (page 662)
- “Applying the Auto Van Gogh effect” (page 663)
- “Applying Blobs” (page 664)
- “Creating custom tiles” (page 665)
- “Applying Grid Paper” (page 668)
- “Applying Growth effects” (page 668)
- “Applying Highpass” (page 669)
- “Applying the Maze effect” (page 670)
- “Placing elements” (page 671)
- “Applying the Pop Art Fill effect” (page 672)

Applying Smart Blur

The Smart Blur effect softens the appearance of an image by smoothing out the colors and sharp details. The effect produces a result that is similar to applying soft brushstrokes. You can use Smart Blur to quickly apply a painterly effect to an image.
To apply Smart Blur
1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects > Focus > Smart Blur.
3. In the Smart Blur dialog box, adjust the Amount slider.

Applying Camera Motion Blur

The Camera Motion Blur effect creates a blur similar to what you’d get in a photograph by jostling the camera during a long exposure. It’s particularly effective with an image showing lights on a dark background.

To apply Camera Motion Blur
1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects > Focus > Camera Motion Blur.
3. In the document window, drag to create the blur motion.
   - The direction and intensity of the blur is determined by your cursor movement. For example, fast movement produces a different blur than slow. A longer drag path increases the amount of blur. Straight, curved, and zigzag movements also produce different effects.
4. In the Camera Motion Blur dialog box, adjust the Bias slider to move the origin of motion along the drag path.
Applying Depth of Field

This effect creates a blur similar to the distance from the plane of camera focus in photography. You can specify the radius of the blurring effect in the image.

![M](image1.png)

The “M” is a floating shape. The blur on the shadow was created by using Depth of Field.

There are five different methods for applying Depth of Field:

- **Uniform Color** — applies the effect uniformly to the image
- **Paper** — applies the effect by using the paper texture luminance (brightness) as a mapping model. More of the effect is applied to the dark areas in the paper grain; less of the effect is applied to the light areas. If you want to experiment with the effect, keep the Papers panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.
- **Image Luminance** — uses the image’s luminance as the model for the effect. More of the effect is applied to dark areas in the original image; less color is applied to light areas.
- **Original Luminance** — uses the luminance of the clone source (or a pattern) as the model for the effect. More of the effect is applied to dark areas in the clone source (or pattern); less color is applied to light areas.
- **Alpha Channel or Layer Mask** — sets the values in the channel or layer mask as the model for the effect. More of the effect is applied to dark areas in the layer mask or channel; less color is applied to light areas. You can use this method only if you have a saved alpha channel or a layer mask in your image.

To apply Depth of Field uniformly

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects ➤ Focus ➤ Depth of Field.
3. Choose Uniform Color from the Using list box.
4. Adjust any of the Depth of Field controls. For information, see “Depth of Field controls” on page 655.

To apply Depth of Field by using paper luminance

1. Do one of the following:
   - On the Brush tool property bar, click the Grain flyout button.
   - Choose Window ➤ Media Panels ➤ Papers to open the Papers panel.
2. Click a paper texture swatch in the Paper Textures area.
3. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
4. Choose Effects ➤ Focus ➤ Depth of Field.
5. Choose Paper from the Using list box.
To apply Depth of Field by using image luminance

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Focus ➤ Depth of Field.

3. Choose Image Luminance from the Using list box.
   Darker regions of the source receive greater blur.

4. Adjust any of the Depth of Field controls. For information, see “Depth of Field controls” on page 655.

To apply Depth of Field by using clone or pattern luminance

1. Perform a task from the following table.

To Do the following

Use a clone source

In the Clone Source panel (Window ➤ Clone Source), choose Embedded Image from the Source list box.

In the Embed Source Image dialog box, do one of the following:
- To browse for a file, enable the Browse option.
- To clone a currently open document, enable the Current Document option, and choose a document from the list box.
- To embed the active texture, enable the Current Texture option.

Click OK.

Use a pattern

Choose Window ➤ Media Panels ➤ Patterns, and click a pattern swatch in the Painter Patterns area.

2. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

3. Choose Effects ➤ Focus ➤ Depth of Field.

4. Adjust any of the Depth of Field controls. For information, see “Depth of Field controls” on page 655.

To apply Depth of Field by using layer mask or channel luminance

1. Do one of the following:
   - To use a layer mask, choose Window ➤ Layers, and click the layer that contains a layer mask in the Layers panel.
   - To use an alpha channel, choose Window ➤ Channels, and click the alpha channel in the Channels panel.

2. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

3. Choose Effects ➤ Focus ➤ Depth of Field.
4 Choose Original Luminance from the Using list box. Darker regions of the source receive greater blur.

5 Adjust any of the Depth of Field controls. For information, see “Depth of Field controls” on page 655.

Depth of Field controls
• Min Size — sets the minimum radius of the blur regions
• Max Size — sets the maximum radius of the blur regions

The maximum size must be greater than the minimum size.

Applying Glass Distortion

The Glass Distortion effect creates the kind of distortions you would see if you were looking at your image through a sheet of glass. You can make your image appear as if it is behind the pebble glass of a shower door, or you can distort your image beyond recognition.

Glass Distortion works by relocating the pixels of the image based on a displacement map. The map is created by combining displacement information from a source with a preset map type.

![Before (left) and after (right) applying Glass Distortion](image)

There are five sources of displacement information:
• Paper uses the information in a paper texture to displace pixels. More displacement is applied to light areas of the texture, and less to dark areas. Paper texture is good for creating the pebbled glass effect. Unless you want frosted glass, you’ll probably want to increase the scale of the paper.
• 3D Brushstrokes uses the difference in luminance between the brushstrokes applied to the clone and the current document
• Image Luminance uses the light and dark areas in the current document to determine the intensity of distortions
• Original Luminance uses the clone source’s luminance. Use a tessellation as the clone source to produce a bumpy glass effect.
• [Alpha channel] or [Layer mask] uses the luminance of a channel or layer mask. More distortion appears in the light areas of the channel. You must have a saved alpha channel or layer mask to use this source.

To create a controlled distortion map, choose an alpha channel or a layer mask as a source. For example, gradations in the channel lead to a progressive distortion effect. Shapes in the channel produce distortions with distinct outlines.

To apply glass distortion by using paper luminance
1 Do one of the following:
   • On the Brush tool property bar, click the Grain flyout button.
   • Choose Window ► Media Panels ► Papers to open the Papers panel.
2 Click a paper texture swatch in the Paper Textures area.
3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
• A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
• A layer — Click a layer in the Layers panel.

4 Choose Effects ➤ Focus ➤ Glass Distortion.
5 Choose Paper from the Using list box.
6 Adjust any of the Glass Distortion controls. For information, see “Glass Distortion controls” on page 657.

To apply glass distortion by using 3D brushstrokes
1 Open an image.
2 Choose File ➤ Clone.
3 Apply brushstrokes to the clone.
4 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
5 Choose Effects ➤ Focus ➤ Glass Distortion.
6 Choose 3D Brush strokes from the Using list box.
7 Adjust any of the Glass Distortion controls. For information, see “Glass Distortion controls” on page 657.

To apply glass distortion by using image luminance
1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
2 Choose Effects ➤ Focus ➤ Glass Distortion.
3 Choose Image Luminance from the Using list box.
4 Adjust any of the Glass Distortion controls. For information, see “Glass Distortion controls” on page 657.

To apply glass distortion by using clone or pattern luminance
1 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Use a clone source | In the Clone Source panel (Window ➤ Clone Source), choose Embedded Image from the Source list box. In the Embed Source Image dialog box, do one of the following: 
• To browse for a file, enable the Browse option.
• To clone a currently open document, enable the Current Document option, and choose a document from the list box.
• To embed the active texture, enable the Current Texture option. Click OK. |
| Use a pattern | Choose Window ➤ Media Panels ➤ Patterns, and click a pattern swatch in the Painter Patterns area. |
• The canvas — Click the Canvas in the Layers panel.
• A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
• A layer — Click a layer in the Layers panel.

3 Choose Effects ▶ Focus ▶ Glass Distortion.

4 Choose Original Luminance from the Using list box.

5 Adjust any of the Glass Distortion controls. For information, see “Glass Distortion controls” on page 657.

To apply glass distortion by using layer mask or channel luminance

1 Do one of the following:
   • To use a layer mask, choose Window ▶ Layers, and click the layer that contains a layer mask in the Layers panel.
   • To use an alpha channel, choose Window ▶ Channels, and click the alpha channel in the Channels panel.

2 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

3 Choose Effects ▶ Focus ▶ Glass Distortion.

4 Choose Original Luminance from the Using list box.

5 Adjust any of the Glass Distortion controls. For information, see “Glass Distortion controls” on page 657.

Glass Distortion controls

• Softness — controls the transitions between displaced colors
  Increasing the Softness setting creates more intermediate steps, which produces a smoother distortion. If you experience aliasing in a glass distortion, try increasing the Softness setting.

• Refraction (Map type) — displaces pixels in the same way that an optical lens bends light. This is the best map type for creating distortions that you’d expect from looking through glass.

• Vector Displacement (Map type) — moves pixels in a specific direction

• Angle Displacement (Map type) — moves pixels in different directions. Increasing the Softness value by a small amount (from 0 to 0.1) with this map type produces dramatic changes in the glass distortion.

• Amount — controls the degree of displacement. Moving the slider to the right increases the distortion.

• Variance — creates multiple variations in the neighborhood of the displacement. The result of increasing variance depends on the type of image and other settings.

• Direction — controls the direction of displacement. The 3 o’clock position corresponds to 0°. The Refraction map type is not dependent on direction.

• Inverted — inverts the selected source

• Quality — changes the quality of the distortion

Applying Motion Blur

This effect makes an image appear as if it has been blurred by movement. You can control the angle, radius, and direction of the blurring effect.
To apply a Motion Blur effect

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Focus ➤ Motion Blur.
   In the Motion Blur dialog box, adjust the following sliders:
   - Radius — sets the amount of blur. Moving the slider to the right makes the image look as though it’s moving faster.
   - Angle — sets the direction in which the image appears to travel. A setting of 0° blurs in the direction of 3 o’clock.
   - Thinness — blurs the image in a direction perpendicular to the angle you choose with the Angle slider.

Sharpening focus

The Sharpen effect heightens contrast by intensifying highlights and shadows. You can create sharper images by using either the Gaussian or Circular aperture options. Gaussian aperture sharpens the red, green, and blue components of color; Circular aperture sharpens an image based on luminance.

To sharpen focus

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Focus ➤ Sharpen.
3 In the **Sharpen** dialog box, enable an aperture option.

4 Use the following guidelines to adjust the sliders:
   - **Amount** — determines how much of the edge of an element is affected
   - **Highlight** — determines the intensity of the bright areas. Move the slider to the right to brighten the highlights.
   - **Shadow** — determines the depth of the shadows. The higher the percentage, the darker the shadows.

If you chose the **Gaussian** aperture option and you want to sharpen only selected colors, enable any combination of the **Red**, **Green**, or **Blue** check boxes.

---

### Softening focus

The **Soften** and **Super Soften** effects increase the transition from one part of an image to another by enhancing the anti-aliasing of the brushstrokes. You can apply the **Soften** effect to images by using either the **Gaussian** or **Circular** aperture options. The **Gaussian** aperture is useful for creating smooth, optical blurs or defocusing; the **Circular** aperture is useful for creating shadow maps cast by a circular light source like the sun.

The **Super Soften** effect lets you soften images by specifying the radius of pixels that you want to soften.

#### To soften focus

1. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects**  **Focus**  **Soften**.

3. In the **Aperture** area, enable one of the following options:
   - **Gaussian**
   - **Circular**

4. Adjust the **Amount** slider.
   - The farther the slider is to the right, the more steps there are between image elements, which creates more blurring.

#### To soften by specifying pixel values

1. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects**  **Focus**  **Super Soften**.

3. Type a pixel value in the **Soften** box.
   - This value determines the radius of pixels that are softened. The lower the value, the more subtle the effect.

You can also

- **Wrap around the effect**
  - Enable the **Wrap Around** check box.

- **Preview the effect**
  - Enable the **Preview** check box.
You can also

Clear the effect  

Click Reset.

Applying Zoom Blur

This effect creates a blur by zooming in on, or out from, an area. The greater the distance from the zoom point, the more the image is blurred. This effect lets you call attention to a particular area of the image.

To apply Zoom Blur

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Focus ➤ Zoom Blur.

3. In the document window, click the image to specify the zoom point.

4. Adjust the Amount slider to determine the amount of blur.
   - If you want to create the blur by zooming in, enable the Zoom In check box. If you want to create the blur by zooming out, disable the Zoom In check box.

Applying Marbling

The Marbling effect creates intricate distortions of an image, following a technique that dates back to the 12th century. Marbling is created by dragging a fork, or rake, across an image, which produces an effect similar to a fork dragging through a mix of chocolate syrup and melted ice cream.
Each time you drag a rake across an image, you create a step. You can create marbling “recipes” that include several steps — each one using a different rake, direction, and waviness. You can save marbling recipes and reuse them.

Marbling works best with patterns or textures. Using the Blobs effect is an excellent way of creating the raw materials for marbling; filling with a pattern is another. For more information, see “Applying Blobs” on page 664.

To create a marbling recipe

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➔ Esoterica ➔ Apply Marbling.

3. Move any of the following sliders:
   - Spacing — adjusts the distance between rake teeth, which controls the number of teeth in the rake. When the slider is all the way to the right, the rake has one tooth.
   - Offset — moves the rake in a perpendicular direction to the path direction, which adjusts the position of the rake lines
   - Waviness — changes the amplitude (height) of the waves. When this slider is set to zero, the path is straight.
   - Wavelength — determines the distance between wave peaks
   - Phase — moves the wave in the rake direction. This lets you set where in the curve (peak, downslope, valley, or upslope) the rake begins in the image.
   - Pull — controls how much the rake distorts the image. Lower values produce thin, short distortions. Higher values create stronger distortions.
   - Quality — lets you control the smoothness in the marbled image. Low settings produce an aliased effect. The marbling looks rough with scattered pixels. Increasing the Quality setting adds anti-aliasing, making color distortions appear smoother and more fluid.

As you move the sliders, the dotted lines in the preview window show the rake path.

4. In the Direction area, enable an option for the rake stroke.

5. Click the Add Step button ➔.

6. Repeat steps 3 to 5 for each rake step you want to create.

The Apply Marbling dialog box displays the current step number and the total number of steps in the recipe. You can move between steps by clicking the forward and backward arrow buttons.

Selections can help you control the marbling when you have a particular effect in mind. For example, the rake path normally begins from the edge of the image. If you want the rake path to begin in the center of a blob, select an area that begins at the blob’s center.

Steps are applied in order, so subsequent steps are based on the result of each previous one.

The final look of the marble largely depends on whether you start horizontally or vertically, and whether you work with a fine comb or a coarse rake.

Each step you add increases the time it takes to apply the recipe.

To save or load a recipe

- Perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear a recipe</td>
<td>In the Apply Marbling dialog box, click Reset. The current recipe is deleted.</td>
</tr>
</tbody>
</table>
To | Do the following
--- | ---
Save a recipe | In the Apply Marbling dialog box, click Save All Steps. In the Save Marbling dialog box, specify a name.
Load a recipe | In the Apply Marbling dialog box, click Load Marbling Steps. In the Marbling Recipes dialog box, choose a recipe.

**Automatically cloning an image**

You can use the Auto Clone effect to automatically apply brush dabs to your image. The types of dabs depend on which brush you select. The color is picked up from the clone source. Unlike most other effects, Auto Clone has no dialog box, using the current brush settings and the clone color instead.

The best way to produce a Natural-Media version of an image is to first clone it and then choose a brush that produces artistic dabs. The Driving Rain variant of the Cloner brush category works well for generating a hand-drawn look. The Seurat variant of the Artists brush category also works well.

![Image of an Artists brush variant used with the Auto Clone effect.](image)

If you apply Auto Clone to a large area, the paint may fill smaller rectangular tiles one at a time. If you click to stop Auto Clone, it won’t automatically finish the final tile of the overall selected area. To fill in non-rectangular areas, you can use Auto Clone with a selection. For more information, see “Getting started with selections” on page 620.

When you use Auto Clone with the Felt Pen Cloner variant, or other tools that turn black as you repeat strokes, areas darken rapidly. You can slow down the color buildup when using Auto Clone by dimming the original image.

Another way to automate cloning is by recording and playing back individual brushstrokes, which is especially useful for filling in backgrounds. For more information, see “Recording and playing back brushstrokes” on page 161 and “Image cloning and sampling” on page 181.

**To automatically fill an area with cloned brushstrokes**

1. Open an image file to use as a clone source.
2. Choose File ➤ Clone.
   
   If you want to apply the effect to only a portion of your image, choose a Selection tool from the toolbox and make a selection.
3. Click the Brush Selector on the Brush Selector bar.
4. In the Brush library panel, click the Cloners brush category, and then choose a brush variant such as Driving Rain Cloner or Impressionist cloner.
   
   Not all Cloners are compatible with Auto Clone. If you choose an incompatible variant, the Auto Clone effect is disabled.
5. Choose Effects ➤ Esoterica ➤ Auto Clone.
Dabs of paint are automatically applied to the selected area.

Click anywhere in the image to turn off Auto Clone.

If you apply Auto Clone to a large area, the paint may fill areas sparsely. When you click to stop Auto Clone, it stops at that point. It won’t continue to fill the selected area. To fill an area completely, you must let the Auto Clone continue.

You can transform a variant into a cloner, so you can use it with Auto Clone, by clicking the Clone Color button in the Color panel.

You can generate more color variety in the dabs by setting the ±H, ±S, and ±V sliders in the Color Variability panel to 15% each. You can open the Color Variability panel by choosing Window  Brush Control Panels  Brush Media  Color Variability.

Applying the Auto Van Gogh effect

You can use the Auto Van Gogh effect to create a Van Gogh–like rendition of an image. To apply Auto Van Gogh, you must first clone the image and then choose the Auto Van Gogh variant from the Artists brush category, which is included in the Painter 2015 brush library.

The effect requires two passes. The first pass determines the angles of the brush dabs. The second pass applies the dabs. The image is then rendered in a set of directional brushstrokes.

To apply Auto Van Gogh to an image

1 Select the image you want to clone.
2 Choose File  Quick Clone.
3 Click the Brush Selector on the Brush Selector bar, and choose Painter 2015 Brushes from the Brush library list box.
4 In the Brush library panel, click the Artists brush category, and then click the Auto Van Gogh brush variant.
5 Choose Effects  Esoterica  Auto Van Gogh.

You can generate more color variety in the dabs by setting the ±H, ±S, and ±V sliders in the Color Variability panel to 15% each. You can open the Color Variability panel by choosing Window  Brush Control Panels  Brush Media  Color Variability.
Applying Blobs

The **Blobs** effect creates a pattern similar to oil floating on water. The effect distorts underlying image as if it were liquid and places blobs that are based on color, clipboard content, or a pattern, on the image.

You can use one of three sources to fill in the blobs. You can produce blobs that look like bubbles by creating a circular selection that’s shaded like a sphere, and then copying it to the Clipboard.

![Before (left) and after (right) applying a Blob effect created from Clipboard contents](image1)

![A Blob effect created from the current color source](image2)

**Blobs** create a nice basis for the **Apply Marbling** effect because they create interesting color patterns. You may want to apply this effect to your original image before **Apply Marbling**. For more information, see “Applying Marbling” on page 660.

To apply a blob effect

1. Perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill blobs with Clipboard contents</td>
<td>Copy an image to the Clipboard. You can copy images outside of Corel Painter.</td>
</tr>
<tr>
<td>Fill blobs with the current color</td>
<td>Choose a color in the <strong>Color</strong> panel.</td>
</tr>
<tr>
<td>Fill blobs with a pattern</td>
<td>Choose a pattern in the <strong>Patterns</strong> panel.</td>
</tr>
</tbody>
</table>

2. Open the image.
3. To apply the effect to:
• The canvas — Click the Canvas in the Layers panel.
• A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
• A layer — Click a layer in the Layers panel.

4 Choose Effects ▶ Esoterica ▶ Blobs.

5 Choose one of the following options from the Using list box:
   • Paste Buffer — fills blobs with the current contents of the Clipboard
   • Current Color — fills blobs with the color currently selected in the Color panel
   • Pattern — fills blobs with the pattern currently selected in the Patterns panel

   Each time you apply the effect, a different seed number is generated in the Seed box.

6 Type a value in the Number of Blobs box.

7 Specify the minimum and maximum sizes of the blobs.

You can also

Set the number of anti-aliasing steps

Create repeating patterns

Change the random pattern of the blobs

Type a value in the Subsample box.

Disable the Random Seed check box, and type a value in the Seed box.

With the Random Seed check box enabled, click the Refresh button next to the Seed box.

Creating custom tiles

Corel Painter transforms images into tiles based on a preset pattern, like bricks or hexagons, or from a paper pattern, clone source, or channel. If you use a preset pattern, the tiles are uniform in size and cover the entire image evenly.

The color of each tile is determined by applying the average color of the image pixels it covers.

![Before (left) and after (right) applying tiles generated from a preset pattern](image)

When you generate tiles from either a paper pattern, clone source, or channel, tiles are based on light and dark concentrations in the selected source. In this case, the shape of the tiles is varied and may not cover an image evenly.
The **Custom Tile** effect functions differently from the **Make Mosaic** and **Make Tessellation** effects. For more information, see “Creating a mosaic” on page 752.

**To apply custom tiles**

1. To apply the effect to:
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects** ➤ **Esoterica** ➤ **Custom Tile**.

3. Choose one of the following patterns from the **Using** list box:
   - Brick
   - Hex
   - Square
   - Triangle
   - Cross
   - 12-6-4
   - 12-6-4 V2

4. Adjust any of the **Custom Tile** controls. For information, see “Custom tile controls” on page 668.

**To apply custom tiles by using clone or pattern luminance**

1. Perform a task from the following table.
To

Do the following

Use a clone source

In the Clone Source panel (Window ➤ Clone Source), choose Embedded Image from the Source list box.

In the Embed Source Image dialog box, do one of the following:
• To browse for a file, enable the Browse option.
• To clone a currently open document, enable the Current Document option, and choose a document from the list box.
• To embed the active texture, enable the Current Texture option.

Click OK.

Use a pattern

Choose Window ➤ Media Panels ➤ Patterns, and click a pattern swatch in the Painter Patterns area.

2 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

3 Choose Effects ➤ Esoterica ➤ Custom Tile.

4 Choose Original Luminance from the Using list box.

5 Adjust any of the Custom Tile controls. For information, see “Custom tile controls” on page 668.

To apply custom tiles by using paper luminance

1 Choose Window ➤ Media Panels ➤ Papers.

2 Choose a paper swatch in the Paper Textures area.

3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

4 Choose Effects ➤ Esoterica ➤ Custom Tile.

5 Choose Paper from the Using list box.

6 Adjust any of the Custom Tile controls. For information, see “Custom tile controls” on page 668.

To apply custom tiles by using layer mask or channel luminance

1 Do one of the following:
   • To use a layer mask, choose Window ➤ Layers, and click the layer that contains a layer mask in the Layers panel.
   • To use an alpha channel, choose Window ➤ Channels, and click the alpha channel in the Channels panel.

2 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

3 Choose Effects ➤ Esoterica ➤ Custom Tile.

4 Choose the channel or layer mask from the Using list box.

5 Adjust any of the Custom Tile controls. For information, see “Custom tile controls” on page 668.
Custom tile controls
- Brick Width and Brick Height — adjusts the size of bricks
- Angle and Scale — adjusts the tile orientation and size of built-in tile shapes
- Blur Radius — sets the sampling radius for blurring the crack or grout color. Increasing the Blur Radius adds more neighboring colors to the crack pixels in each pass.
- Blur Passes — sets the number of times the crack pixels are blurred. More passes mix more tile color into the cracks. Blurring occurs only when Blur Passes is greater than zero.
- Threshold — draws the line between light and dark. Everything above the Threshold value becomes tiles, and everything below becomes grout.
- Use grout — adds grout between the tiles
- Grout Color — sets the grout color
- Grout Thickness — controls the width of the cracks between tiles or the grout lines (if grout is enabled)

Applying Grid Paper

The Grid Paper effect adds a grid of horizontal lines, vertical lines, rectangles, or dots to an image.

Unlike the grid overlay, which is a transparent layer that floats as a reference above an image, Grid Paper becomes part of an image. It is best to apply Grid Paper to a blank canvas and then apply color to the canvas or layers.

To apply Grid paper
2. Choose an option from the Grid Type list box.
3. Set the grid dimensions by entering values in the following boxes:
   - Horizontal Spacing — determines the amount of space between horizontal lines
   - Vertical Spacing — determines the amount of space between vertical lines
   - Line Thickness — sets the width of grid lines
4. Click the Grid Color chip, and choose a color from the color picker to set the grid color.
5. Click the Background chip, and choose a color from the color picker to set the background color.

Applying Growth effects

The Growth Effect generates branchlike designs from a central point and adds them to your image. The designs resemble architectural renderings of trees.

Examples of Growth patterns
Growth patterns are created from the current main color. You have access to the Color panel while the Growth dialog box is open, so you can change the main color at any time.

To create growth patterns
1. In the Color panel, choose a color.
2. Choose Effects ➤ Esoterica ➤ Growth.
3. Enable any of the following check boxes:
   - Hard edges — creates growth patterns with hard edges; disable to create growth patterns with soft, feathery edges
   - Fractal — creates open-ended (fractal) patterns; disable to create nonfractal patterns, which are closed on the outside by a ring
4. Adjust any of the following sliders:
   - Flatness — reshapes the growth pattern like a lens effect. Move the slider to the left for a concave lens effect. Move the slider to the right for a “fish-eye” lens effect.
   - Thinout — affects how the size of the growth pattern is distributed from the center to the outside edges. At settings over 100%, the outside edges become thicker. At settings under 100%, the edges become finer and more delicate.
   - Random — affects how symmetrical the growth patterns appear. Lower values generate straight-line, geometrical designs. Higher values generate distorted, crooked designs.
   - Thickness — uniformly adjusts the weight of the lines within the design. Move the slider to the left for thinner lines, and to the right for thicker lines. The growth pattern cannot be made thinner than one pixel.
   - Branch — determines how many branches come from the center to the outside edge. The range is 1 through 20.
   - Max Level — determines the number of levels or sublevels that appear in the tree. Specifically, Max Level determines how the branches split to the outside edge.
   - Fork — adjusts the overall intricacy of the outermost branches
   - Fork Ratio — is similar to Fork, but it affects only the tips of the outermost branches
5. Without closing the Growth dialog box, drag in the document window to create a growth pattern.
6. Do one of the following:
   - To apply the current growth pattern, click OK.
   - To discard all patterns, click Cancel.

The sliders in the Growth dialog box affect both fractal and nonfractal growth patterns in a similar way, with the exception of Fork and Fork Ratio, which affect only fractal growth patterns.

Applying Highpass

The Highpass effect suppresses low-frequency areas containing gradual or smooth transitions of brightness levels. This leaves high-frequency areas, or just the edges of an image, containing stark shifts between brightness levels.

Highpass uses either the Gaussian or Circular aperture options. Gaussian aperture affects the red, green, and blue components of color; Circular aperture uses image luminance. You can make the highpass more pronounced by using the Equalize effect.
The Highpass effect introduces stark shifts between brightness levels.

To apply a Highpass effect

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects ➔ Esoterica ➔ Highpass.
3. In the Highpass dialog box, choose an aperture option.
4. Move the Amount slider to determine how much to suppress the low-frequency areas.

   This value defines a radius, in pixels, around each pixel in the selected image area. Moving the slider to the left suppresses larger amounts of low-frequency information. Moving the slider to the right suppresses smaller amounts of low-frequency information.

Applying the Maze effect

The Maze effect generates an image of a maze. Typically, you’ll create a maze in a new, blank image. Each maze has one “solution” — that is, an open path from the entrance to the exit.

You can capture a portion of the maze as a pattern or paper texture, or use the maze as a source for other effects. Mazes must be rectangular and cannot be applied to non-rectangular selections.
To apply a Maze effect

2. Click the Maze Color chip, and choose a maze color.
3. Click the Background chip, and choose a background color.
4. Enable any of the following check boxes:
   • Patterned — constrains barriers to the horizontal
   • Display solution — displays the path from the entrance to the exit
5. Type a value in the Seed box to generate a random maze pattern.
6. Type a value in the Thickness box to set the width of barriers and paths.

Placing elements

Place Elements is an effect designed to automate the application of brush dabs. It’s particularly useful when applying it with an Image hose brush variant. For more information, see “Painting with the Image hose” on page 517.

![An example of the Place Elements effect used with the Image hose](image)

The Place Elements effect creates a virtual sphere within the confines of a selection rectangle. When the selection is square, the sphere is perfectly round; when the selection is rectangular, the sphere is elongated or flattened.

A number of points are created at random locations on the sphere. The points are then distanced from each other, and a brush dab is placed at each point. Each dab’s appearance is adjusted according to its location on the sphere.

![An example of the Place Elements effect used with a brush](image)

To place elements

1. Do one of the following:
   • To use an Image hose, choose an Image hose brush variant from the Brush library, and then choose a nozzle from the Nozzle selector on the Media Selector bar.
To apply paint dabs, select a brush from the Brush library. Not all brush variants are supported by Place Elements.

2 Choose Window ➤ Color Panels ➤ Color Panel (Full View).

3 In the Color panel, do one of the following:
   • If using an Image hose brush variant, set the additional color to black.
   • If using another brush variant, set the main color.

If using the Image hose, the effect automatically controls mixing of the additional color with nozzle elements to produce depth shading. Shadows tend toward black, so black is a good color to use.

4 Choose the Rectangular Selection tool from the toolbox.

5 Drag to create a selection.
   This selection determines the location and size of the effect.

6 Choose Effects ➤ Esoterica ➤ Place Elements.

7 Adjust any of the following sliders:
   • Iterations — controls the spacing of iterations. In each iteration, the points distance themselves from each other on the surface of the virtual sphere. The points start at random locations, so if you set zero as the number of iterations, the placement of the points is completely random. Higher numbers of iterations increase the regularity of the spacing.
   • Points — sets the number of points to create on the virtual sphere. Each point correlates to an image element placed.
   • Radius Fraction — determines the size of the virtual spheres created at the second and third levels. The first-level radius is multiplied by the fraction amount to determine the radius of the second-level spheres.

The fraction is used again between the second and third levels. Higher values (above 1.0) increase overlapping of the spheres. Lower values (below 1.0) preclude overlapping (when sufficient iterations are used to distribute the points).

8 In the Levels area, enable one of the following options:
   • 1 — specifies that each point receives only one element
   • 2 — specifies that each point receives an element and then is used as the center for another virtual sphere on which point iteration and element placement repeats
   • 3 — extends sphere creation and element placement once more

   The number of elements increases rapidly with more than one level. For example, if you choose 12 points and three levels, you’ll create $12 + (12 \times 12) + (12 \times 12 \times 12) = 1,884$ elements. Of course, many of these elements will probably be covered by later placements.

   If you choose two or three levels, you can prevent overlapping elements by enabling the Cull Interiors check box. This removes points that occur inside other spheres, before elements are placed. This option increases processing time for the effect.

Applying the Pop Art Fill effect

This effect lets you cover an image with pseudo-halftone dots so you can create a Pop Art image.
To apply a Pop Art Fill

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ▶ Esoterica ▶ Pop Art Fill.

3. Choose Image Luminance from the Using list box.
   If you want to work with an inverted version of the source, enable the Invert colors check box.

4. Adjust the Scale slider to set the dot size.

5. Adjust the Contrast slider to mix in the luminance of the control medium.

6. Click the Dab Color chip, and choose a dot color.

7. Click the Background chip, and choose a background color.
Using lighting and surface texture effects

Corel Painter includes a collection of effects that let you control image lighting and surface texture.

For general information about using effects, see "Common options for effects" on page 649.

This section contains the following topics:

**Lighting effects**
- “Applying preset lighting effects” (page 676)
- “Adding, deleting, and repositioning lights” (page 676)
- “Adjusting light properties” (page 677)

**Surface texture effects**
- “Using paper to create texture” (page 678)
- “Using 3D brushstrokes to create texture” (page 679)
- “Using image luminance to create texture” (page 680)
- “Using clone source or pattern luminance to create texture” (page 680)
- “Creating embossed effects” (page 681)
- “Using channels and layer masks to create texture” (page 682)

**Adjusting surface texture using lighting effects**
- “Creating reflection maps” (page 683)
- “Adjusting texture lighting” (page 684)

**Other surface effects**
- “Applying the Apply Screen effect” (page 686)
- “Applying the Color Overlay effect” (page 687)
- “Applying the Dye Concentration effect” (page 689)
- “Applying the Express Texture effect” (page 691)
- “Applying a warp effect” (page 692)
- “Applying the Woodcut effect” (page 694)
- “Applying the Distress effect” (page 696)
- “Applying the Serigraphy effect” (page 697)
- “Applying the Sketch effect” (page 698)
Applying preset lighting effects

Corel Painter includes a series of preset lighting effects that you can apply to your images. The lighting effects allow you to quickly change the intensity or direction of the image lighting. You can apply a preset lighting environment without making any changes, or you can use it as a starting point for customized lighting. For more information, see “Adding, deleting, and repositioning lights” on page 676 or “Adjusting light properties” on page 677.

Before (left) and after (right) applying a preset lighting effect

To apply preset lighting effects

1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

2 Choose Effects ➤ Surface Control ➤ Apply Lighting.

3 In the Apply Lighting dialog box, choose a preset from the Preset list box.

   The lighting effect displays in the preview window.

   If you apply an effect to a shape, dynamic layer, text layer, or reference layer, you must first commit the layer to an image layer.

Adding, deleting, and repositioning lights

You can add one or more light sources to an image to create unique lighting effects. Adding a light source is similar to hanging your artwork in a gallery and adjusting spotlights to illuminate it. You can also delete and reposition lights.

When you add a light, a new indicator appears in the preview window of the Apply Lighting dialog box. The preview window displays the current position of each light and the angle of its projection. You can use the light indicators to move and direct lights. The large part of the light indicator controls the light source (the point from which the light is shining). The small part of the indicator controls the light direction (the point toward which the light is shining).
The small circle (left) controls the light direction. The large circle (right) controls the light source.

In addition, you can change the light properties, such as intensity and spread. For more information, see “Adjusting light properties” on page 677.

To add, delete, and reposition a light

1 To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2 Choose Effects ➤ Surface Control ➤ Apply Lighting.

3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a light</td>
<td>Click anywhere in the preview window.</td>
</tr>
<tr>
<td>Delete a light</td>
<td>Click an indicator, and press Delete (macOS) or Backspace (Windows).</td>
</tr>
<tr>
<td>Move a light</td>
<td>Drag the large end of the indicator to the point where you want the light to originate.</td>
</tr>
<tr>
<td>Change the direction of a light</td>
<td>Drag the small end of the light indicator until the light is pointing in the desired direction.</td>
</tr>
</tbody>
</table>

Adjusting light properties

You can adjust light properties such as brightness, distance, elevation, and color. Light properties have a cumulative effect. For example, if you turn up a light’s brightness, you might need to adjust exposure.

To adjust the light properties

1 To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2 Choose Effects › Surface Control › Apply Lighting.

3 In the preview window, click an indicator to select it.

4 In the Directional Lighting area, move any of the following sliders:
   • Brightness — controls the light intensity
   • Distance — controls how far the light is from the image. If you move the light source closer, you can compensate for the increased light by adjusting the Exposure slider.
   • Elevation — sets the light’s angle in relation to the canvas. At 90°, the light is shining straight down, and at 1°, it’s nearly horizontal.
   • Spread — sets the angle of the light cone
   To change the light color, click the Color chip, and choose a color.

5 In the Ambient Lighting area, move any of the following sliders:
   • Exposure — controls the image’s brightness, as in photography. Moving the slider to the left decreases exposure and darkens the image; moving it to the right increases exposure and lightens the image.
   • Ambient — controls the surrounding light in an image. If you have no light indicators in the preview window, the ambient lighting controls the overall lightness of the image. Moving the slider to the left darkens the overall lighting; moving it to the right increases the light.
   To change the color of the ambient light, click the Color chip, and choose a color.

Using paper to create texture

You can add texture to an image by incorporating paper texture. This allows you to give the appearance of depth to brushstrokes. Corel Painter uses the paper surface and grain to produce the effect. You can choose a specific paper texture, or Corel Painter applies the currently selected paper texture to the image by default.

If you want to experiment with the effect, keep the Papers panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.

To create surface texture by using paper

1 Choose Window › Media Panels › Papers.

2 Choose a paper swatch in the Paper Textures area.

3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

4 Choose Effects › Surface Control › Apply Surface Texture.

5 Choose Paper from the Using list box.
   If you want to apply an inverted paper texture, enable the Inverted check box.

6 Adjust any of the Apply Surface Texture controls. For more information, see “Apply Surface Texture controls” on page 685.
Using 3D brushstrokes to create texture

You can create the illusion of textured brushstrokes by applying the 3D Brushstrokes effect to an image. To use this effect, you need to clone the image, apply brushstrokes to the clone using cloners, and then apply the effect to the image. Corel Painter then uses the difference in luminance between the clone source and the image to produce the texture.

An example of an image before (left) and after (right) the 3D Brushstrokes method is applied to the image

If you use this method, the look of the brushstrokes on the clone determines how realistic the final 3D brushstrokes appear. So, you may want to set up a more complex brush before painting. For example, you can apply a paper texture to the stroke. Many of the brush variants reveal the paper texture automatically in their brushstrokes.

An example of 3D Brushstrokes with paper texture

You can apply a paper texture when you first create an image, and then paint or draw over it to make a textured canvas for your brushstrokes. However, the texture is erasable, so you might not end up with the same texture across the document surface. As a rule, you add the paper texture as the last step in producing artwork.

You can also use advanced brush settings to make realistic brushstrokes. For example, you can use the Brush Loading option to move underlying colors as you make brushstrokes. For more information, see “Using brush loading” on page 201. You can also apply other settings, like Bleed, or adjust brush size to create complex brushstrokes. For more information, see “Adjusting brushes with brush controls” on page 371.

An example of 3D Brushstrokes with Brush Loading (left) and bleed (right) settings applied
To apply 3D brushstrokes to an image
1. Open an image.
2. Choose File ➤ Quick Clone.
3. Apply brushstrokes to the clone.
4. Choose Effects ➤ Surface Control ➤ Apply Surface Texture.
5. Choose 3D Brushstrokes from the Using list box.
6. Adjust any of the Apply Surface Texture controls. For more information, see “Apply Surface Texture controls” on page 685.

Using image luminance to create texture
You can use the currently selected image’s luminance, or lightness, to produce surface texture. Light parts of the image create dents; whereas darker parts create raised areas. The overall effect gives an embossed look to the image.

![Before (left) and after (right) adding texture based on image luminance](image)

To create surface texture by using image luminance
1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects ➤ Surface Control ➤ Apply Surface Texture.
3. Choose Image Luminance from the Using list box.
4. Adjust any of the Apply Surface Texture controls. For more information, see “Apply Surface Texture controls” on page 685.

Using clone source or pattern luminance to create texture
You can add texture to an image by using the luminance of a clone source or a pattern. The method uses the light and dark areas in the clone source or pattern to produce the illusion of dents and bumps. To experiment with different looks, you can change the clone source or pattern.
The clone source luminance helps produce a textured effect.

Any image effects or brushstrokes that you apply to the clone source result in different textures. For example, you can create raised areas in the clone by darkening the area in the source image.

To create surface texture based on clone source or pattern luminance
1. Open an image.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a clone source</td>
<td>In the Clone Source panel (Window  Clone Source), choose Embedded Image from the Source list box.</td>
</tr>
<tr>
<td></td>
<td>In the Embed Source Image dialog box, do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To browse for a file, enable the Browse option.</td>
</tr>
<tr>
<td></td>
<td>• To clone a currently open document, enable the Current Document option, and choose a document from the list box.</td>
</tr>
<tr>
<td></td>
<td>• To embed the active texture, enable the Current Texture option.</td>
</tr>
<tr>
<td></td>
<td>Click OK.</td>
</tr>
</tbody>
</table>

Use a pattern

Choose Window  Media Panels  Patterns, and click a pattern swatch in the Painter Patterns area.

3. To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
4. Choose Effects  Surface Control  Apply Surface Texture.
5. Choose Original Luminance from the Using list box.
6. Adjust any of the Apply Surface Texture controls. For more information, see “Apply Surface Texture controls” on page 685.

Creating embossed effects

You can generate an image that appears embossed by cloning the image and then using the luminance of the clone source to produce the effect. You can control the height of the texture, as well as the lighting, color, and material properties of the embossing.
Before (left) and after (right) applying the embossed effect

To create an embossed effect

1. Open an image.
2. Choose File ➤ Clone.
3. Choose a color other than black from the Colors or Color Sets panel.
   If you want the embossed image to be white, select all, and then press Delete (macOS) or Backspace (Windows).
4. Choose Edit ➤ Fill.
5. In the Fill dialog box, choose Current Color from the Fill with list box.
6. Adjust the Opacity slider to set the opacity of the fill.
7. Click OK to fill the clone file with color.
8. Choose Effects ➤ Surface Control ➤ Apply Surface Texture.
9. Choose Original Luminance from the Using list box.
   The preview window shows how the embossed image will look.
10. In the Light Controls area, adjust any of the following sliders:
    • Brightness — controls the light intensity
    • Concentration — adjusts the spread of the light’s shine over the surface
    • Exposure — adjusts the overall lighting amount from darkest to brightest
11. Enable the Simple lighting check box, and click a light indicator on the sphere to change the location of highlights and shadows.

   If you want to change the light color, click the Light Color chip, and choose a color from the color picker.

Using channels and layer masks to create texture

Corel Painter lets you produce surface texture based on an alpha channel or a layer mask. You can use this method only if you added an alpha channel, or a layer that contains a layer mask, to the image.

When you apply the texture to a channel, the area that surrounds the edges of the channel appears raised. When you apply texture to a layer mask, the layer mask acts as a boundary for the texture and the texture appears around the edges. For more information, see “Creating and deleting layer masks” on page 600.

Before (left) and after (right) adding texture based on a saved alpha channel
To create surface texture based on a channel or layer mask

1 In the Layers panel, select a layer or the canvas.
   If you want to use a layer mask, you must select the layer to which the layer mask is attached. Make sure that the layer mask is not blank.

2 Choose Effects ➤ Surface Control ➤ Apply Surface Texture.

3 Choose the channel or layer mask from the Using list box.

4 Adjust any of the Apply Surface Texture controls. For more information, see “Apply Surface Texture controls” on page 685.

Creating reflection maps

A reflection map is an image that is mapped onto a texture to produce the illusion that it’s reflecting light from the surrounding environment. You can use either a pattern or a clone source image as a reflection map. Choosing a pattern allows you to quickly apply a realistic reflection. Reflection maps are useful to create the appearance of chrome or polished metal.

You can control how much of the image appears in the texture. If you add a reflection map to a clone, the clone source is mapped onto the texture. Otherwise, Corel Painter uses the current pattern as the reflection map.

You can use the Image Warp effect to approximate the reflection from a curved surface. For more information, see “Applying a warp effect” on page 692.

To create a reflection map from a clone source

1 Open an image or create a new image to use as the reflection.
   If you want to approximate the reflection from a curved surface, apply the Image Warp effect.

2 Choose File ➤ Clone.

3 Click a selection tool from the toolbox, and select the area that you want to be reflective.

4 In the toolbox, click the Selection Adjuster tool.

5 Right-click the selection and choose Layer Via Copy.
A new layer is created.

6 In the Layers panel, click the Canvas, and then select the layer you just created.

7 Click the New Layer Mask button.

Using a layer mask simplifies the process because the layer mask exactly matches the shape of the reflection area. For more information, see “Creating and deleting layer masks” on page 600.

8 Choose Effects ➤ Surface Control ➤ Apply Surface Texture.

9 Choose the layer mask from the Using list box.

10 Move the Reflection slider to adjust the amount of reflection you want.

11 Move the Softness slider to adjust the mapping from the edges of the layer’s image.

Increasing softness gives a rounder, more 3D look to the surface.

Adjusting texture lighting

Lighting determines a large part of the final look of a texture. Bad lighting can obscure details in a pattern or surface. Good lighting, however, can add interesting highlights and enhance reflections.

You can use preset (simple) lighting or custom lighting. With simple lighting, you can choose one of eight preset lights. With custom lighting, you can add more lights, and you can move and delete light sources.

The lighting sphere shows all possible surface angles and how the lights illuminate them. The light indicators on the sphere show the position of all light sources.
You can also change the following light properties: brightness, concentration, and exposure. In addition, you can change a light’s color.

To adjust texture lighting

1. To apply the effect to:
   - Canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects**  **Surface Control**  **Apply Surface Texture**.

3. Do one of the following
   - For preset lighting, enable the **Simple lighting** check box, and click a light indicator on the lighting sphere.
   - For custom lighting, disable the **Simple lighting** check box, and perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a custom light</td>
<td>Click on the lighting sphere where you want to add a new light source.</td>
</tr>
<tr>
<td></td>
<td>A new light indicator (small circle) appears where you click.</td>
</tr>
<tr>
<td>Delete a custom light</td>
<td>Click a light indicator, and press <strong>Delete</strong> (macOS), or <strong>Backspace</strong> (Windows).</td>
</tr>
<tr>
<td>Add custom lights along a circular path</td>
<td>Move the <strong>Lights</strong> slider.</td>
</tr>
<tr>
<td>Move a custom light</td>
<td>Drag a light indicator to a new position on the sphere.</td>
</tr>
<tr>
<td>Change the light color</td>
<td>Click a lighting indicator, click the <strong>Light Color</strong> chip, and then choose a color.</td>
</tr>
</tbody>
</table>

4. Adjust any of the **Apply Surface Texture** controls. For information, see “Apply Surface Texture controls” on page 685.

### Apply Surface Texture controls

- **Using** — lets you choose a method for applying the surface texture. The following methods are available: Paper, 3D Brushstrokes, Image Luminance, and Original Luminance.
- **Softness** — lets you adjust the amount of distortion created by the texture. Increasing softness creates more intermediate steps, which produces a smoother distortion.
- **Inverted** — lets you apply an inverted texture.
Appearance of Depth

- **Amount** — controls how much surface texture is applied to the image. Moving the slider all the way to the right applies the maximum amount.
- **Picture** — controls how much of the color from the original image is applied to the texture. At 100%, the full color of the picture shines through. Moving the slider to the left displays more black, leaving only the shine.
- **Shine** — controls how much highlight appears on the surface of the texture. Higher Shine values make the texture look metallic.
- **Reflection** — maps a clone source image or pattern onto the texture at a variable percentage

Light Controls

- **Brightness** — controls the light intensity
- **Concentration** — adjusts the spread of the light’s shine over the surface
- **Exposure** — adjusts the overall lighting amount from darkest to brightest
- **Light Color** — lets you change the light color
- **Simple lighting** — lets you choose one from eight preset lights
- **Lighting sphere** — lets you add, move, and delete custom lights when the **Simple lighting** check box is disabled.

Applying the Apply Screen effect

You can simulate the appearance of a silk-screened print by using the **Apply Screen** effect. This effect lets you combine image luminance and the three selected colors, to produce a multi-color rendition of the image. When you use this effect, anti-aliasing is automatically applied to the image.

![Before (left) and after (right) using Apply Screen using the image luminance](image)

To apply a screen

1. Open an image.
2. Choose **Effects** ▶ **Surface Control** ▶ **Apply Screen**.
3. Choose **Image Luminance** from the **Using** list box.
4. Choose three colors by clicking each color chip and choosing a color from the color picker.
5. Adjust any of the following sliders:
   - **Threshold 1** — determines how much of the two colors below the slider display in the image
     Moving the slider increases the amount of one color and decreases the amount of the other color.
   - **Threshold 2** — determines how much of the color below the slider displays in the image
     Moving the slider to the left decreases the color amount. Moving it to the right increases the color amount.
You can also apply a screen that is based on paper texture by choosing Paper from the Using list box, and then clicking the Paper Textures chip, and choosing a texture.

Applying the Color Overlay effect

You can simultaneously add color and texture to an image by using the Color Overlay effect. This effect allows you to coat an image with color. You can control the opacity and intensity of the color. To use the Color Overlay effect, you need to choose a color that you want to apply and then choose the method for applying the effect.

There are five different methods for applying color:

- **Uniform Color** — adds a flat tint to the image
- **Paper** — overlays a color using the paper texture as a mapping model. More color is applied to light areas in the paper grain; less color is applied to dark areas. If you want to experiment with the effect, keep the Papers panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.
- **Image Luminance** — uses the image’s brightness as the model for the color overlay. More of the effect is applied to light areas in the original image; less color is applied to dark areas.
- **Original Luminance** — uses the luminance of the clone source (or a pattern) as the model for the color overlay. Light areas in the clone source produce more color in the image.
- **Alpha Channel** or **Layer Mask** — sets the values in the channel or layer mask as the model for the color overlay. More color is applied to the light areas of the channel or mask; less color is applied to dark areas. You can use this method only if you have a saved alpha channel or a layer mask in your image.

Before (left) and after (right) applying the Color Overlay effect using the Paper method

To apply a uniform tint to an image

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2. Choose Effects ➤ Surface Control ➤ Color Overlay.
3. Choose a color from the Use Color chip.
4. Choose Uniform Color from the Using list box.
5. Adjust any of the Color Overlay controls. For information, see “Color Overlay controls” on page 689.

To use image luminance to apply a color overlay

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
• A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
• A layer — Click a layer in the Layers panel.

2 Choose Effects ▶ Surface Control ▶ Color Overlay.
3 Choose a color from the Use Color chip.
4 Choose Image Luminance from the Using list box.
5 Adjust any of the Color Overlay controls. For information, see “Color Overlay controls” on page 689.

To use paper texture to apply a color overlay
1 Choose Window ▶ Media Panels ▶ Papers.
2 Choose a paper swatch in the Paper Textures area.
3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.
4 Choose Effects ▶ Surface Control ▶ Color Overlay.
5 Click the Use Color chip, and choose a color.
6 Choose Paper from the Using list box.
7 Adjust any of the Color Overlay controls. For information, see “Color Overlay controls” on page 689.

To use clone source or pattern luminance to apply a color overlay
1 Open an image.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Use a clone source        | In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.
   | In the Embed Source Image dialog box, do one of the following: |
   | • To browse for a file, enable the Browse option. |
   | • To clone a currently open document, enable the Current Document option, and choose a document from the list box. |
   | • To embed the active texture, enable the Current Texture option. |
   | Click OK.              |                  |

Use a pattern

3 Choose Effects ▶ Surface Control ▶ Color Overlay.
4 Choose a color from the Use Color chip.
5 Choose Original Luminance from the Using list box.

To use a layer mask or channel to apply a color overlay
1 Do one of the following:
   • To use a layer mask, choose Window ▶ Layers, and click the layer that contains a layer mask in the Layers panel.
   • To use an alpha channel, choose Window ▶ Channels, and click the alpha channel in the Channels panel.
2 Choose Window ▶ Color Panels ▶ Color Panel (Full View).
3 Choose a color from the Color panel.
4 Choose Effects ▶ Surface Control ▶ Color Overlay.
5 Choose the layer mask or alpha channel from the Using list box.
6 Adjust any of the Color Overlay controls. For information, see “Color Overlay controls” on page 689.

Color Overlay controls
- Use Color — lets you choose the overlay color
- Opacity — controls how transparent the effect is
- Dye Concentration — allows the paper to absorb the color
- Hiding Power — allows the color to cover what lies beneath it

Applying the Dye Concentration effect
You can adjust the dye concentration in an image to control color intensity and play with surface texture. For example, use this effect to lighten an underexposed photo or to darken an overexposed one. You need to choose a method for applying the effect. Some methods, such as Paper, generate more texture than other methods, such as Uniform Color. There are five different methods for applying dye concentration:
- Uniform Color — allows you to adjust only color density
- Paper — adjusts color by using the paper texture as a mapping model. If you want to experiment with the effect, keep the Papers panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.
- Image Luminance — uses the image's brightness as the model for the color adjustment
- Original Luminance — uses the luminance of the selected pattern or clone source as the model for the adjustment
- Alpha Channel or Layer Mask — sets the values in the alpha channel or layer mask as the model for the dye concentration adjustment. You can use this method only if you have a saved channel or a layer mask in your image.

To uniformly adjust dye concentration
1 To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2 Choose Effects ▶ Surface Control ▶ Dye Concentration.
3 Choose Uniform Color from the Using list box.
4 Adjust any of the Dye Concentration controls. For information, see “Dye Concentration controls” on page 690.

To adjust dye concentration using image luminance
1 To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
2 Choose Effects ▶ Surface Control ▶ Dye Concentration.
3 Choose Image Luminance from the Using list box.
4 Adjust any of the Dye Concentration controls. For information, see “Dye Concentration controls” on page 690.

To adjust dye concentration using paper luminance
1 Choose Window ▶ Media Panels ▶ Papers.
2 Choose a paper swatch in the Paper Textures area.

3 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

4 Choose Effects ▶ Surface Control ▶ Dye Concentration.

5 Choose Paper from the Using list box.

6 Adjust any of the Dye Concentration controls. For information, see “Dye Concentration controls” on page 690.

To adjust dye concentration using clone source or pattern luminance

1 Open an image.

2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a clone source</td>
<td></td>
</tr>
<tr>
<td></td>
<td>In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.</td>
</tr>
<tr>
<td></td>
<td>In the Embed Source Image dialog box, do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To browse for a file, enable the Browse option.</td>
</tr>
<tr>
<td></td>
<td>• To clone a currently open document, enable the Current Document option, and choose a document from the list box.</td>
</tr>
<tr>
<td></td>
<td>• To embed the active texture, enable the Current Texture option.</td>
</tr>
<tr>
<td></td>
<td>Click OK.</td>
</tr>
</tbody>
</table>

Use a pattern

<table>
<thead>
<tr>
<th>Use a pattern</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Choose Window ▶ Media Panels ▶ Patterns, and click a pattern swatch in the Painter Patterns area.</td>
</tr>
</tbody>
</table>

3 Choose Effects ▶ Surface Control ▶ Dye Concentration.

4 Choose Original Luminance from the Using list box.

5 Adjust any of the Dye Concentration controls. For information, see “Dye Concentration controls” on page 690.

To adjust dye concentration using a layer mask or alpha channel

1 Do one of the following:
   • To use a layer mask, choose Window ▶ Layers, and click the layer that contains a layer mask in the Layers panel.
   • To use an alpha channel, choose Window ▶ Channels, and click the alpha channel in the Channels panel.

2 Choose Effects ▶ Surface Control ▶ Dye Concentration.

3 Choose the Layer mask or alpha channel from the Using list box.

4 Adjust any of the Dye Concentration controls. For information, see “Dye Concentration controls” on page 690.

Dye Concentration controls

• Presets — the controls in this area let you choose a preset effect, save the current settings as a preset, and delete a preset
• Maximum — controls the amount of dye on the peaks of the texture

   If you think of texture as peaks and valleys, the Maximum slider controls the amount of dye on the peaks, and the Minimum slider controls the amount of dye in the valleys.

• Minimum — controls the depth of the texture. The lower the values, the higher the contrast between the peaks and valleys. The higher the values, the flatter the image appears.
• **Preview** — enable this check box to preview the effect in the document window
• **Reset** — resets the sliders to their default settings

### Applying the Express Texture effect

You can apply the **Express Texture** to generate a high-contrast version of an image in grayscale, which creates a visual effect similar to a custom halftone screen, like a mezzotint or line screen. When you use this effect, anti-aliasing is automatically applied to the image.

You need to choose a method for applying the effect. There are five different methods for applying **Express Texture**:

- **Paper** — adjusts light intensity by using the paper texture as a mapping model. If you want to experiment with the effect, keep the **Papers** panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.
- **Image Luminance** — uses the image’s brightness as the model for the adjustments
- **Original Luminance** — uses the luminance of the clone source as the model for the adjustment
- **Alpha Channel** or **Layer Mask** — sets the values in the alpha channel or layer mask as the model for the adjustments. You can use this method only if you have a saved channel or a layer mask in your image.

![An image with the Express Texture effect applied](image.jpg)

#### To apply Express Texture using image luminance

1. **To apply the effect to:**
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

2. Choose **Effects** ➤ **Surface Control** ➤ **Express Texture**.

3. Choose **Image Luminance** from the **Using** list box.

4. Adjust any of the **Express Texture** controls. For information, see “Express Texture controls” on page 692.

#### To apply Express Texture using paper texture

1. Choose **Window** ➤ **Media Panels** ➤ **Papers**.

2. Choose a paper swatch in the **Paper Textures** area.

3. **To apply the effect to:**
   - The canvas — Click the **Canvas** in the **Layers** panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the **Layers** panel.

4. Choose **Effects** ➤ **Surface Control** ➤ **Express Texture**.

5. Choose **Paper** from the **Using** list box.

6. Adjust any of the **Express Texture** controls. For information, see “Express Texture controls” on page 692.
To apply Express Texture using clone source or pattern luminance

1. Open an image.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Use a clone source | In the Clone Source panel (Window ▸ Clone Source), choose Embedded Image from the Source list box. 
In the Embed Source Image dialog box, do one of the following:
• To browse for a file, enable the Browse option. 
• To clone a currently open document, enable the Current Document option, and choose a document from the list box. 
• To embed the active texture, enable the Current Texture option. 
Click OK. |
| Use a pattern | Choose Window ▸ Media Panels ▸ Patterns, and click a pattern swatch in the Painter Patterns area. |

3. Choose Effects ▸ Surface Control ▸ Express Texture.
4. Choose Original Luminance from the Using list box.
5. Adjust any of the Express Texture controls. For information, see “Express Texture controls” on page 692.

To apply Express Texture using a layer mask or alpha channel

1. Do one of the following:
   • To use a layer mask, choose Window ▸ Layers, and click the layer that contains a layer mask in the Layers panel. 
   • To use an alpha channel, choose Window ▸ Channels, and click the alpha channel in the Channels panel.
2. Choose Effects ▸ Surface Control ▸ Express Texture.
3. Choose the layer mask or alpha channel from the Using list box.
4. Adjust any of the Express Texture controls. For information, see “Express Texture controls” on page 692.

Express Texture controls

• Gray Threshold — determines where the threshold is, between pure black and pure white
• Grain — determines how deeply the texture penetrates the surface
• Contrast — determines the number of levels of black and white. For example, low contrast generates pure gray, medium contrast produces levels of grayscale, and high contrast produces a black and white screen.

Applying a warp effect

Corel Painter offers different options for warping images. The Image Warp effect lets you distort the surface of an image as if it were a sheet of pliable film. You can make images look as though they’re reflected in a fun house mirror.
You can also use the Quick Warp effect to create some basic distortions, like stretch or bulge. These distortions are useful for preparing images for reflection maps when applying surface texture. For more information, see “Creating reflection maps” on page 683.

Quick Warp lets you create five types of distortions:

- **Sphere** — warps the image spherically, like a reflection on a polished silver ball
  
  ![An example of the Quick Warp effect using Sphere distortion](image)

- **Bump** — warps the center of the image toward you, making it appear convex
  
  ![An example of the Quick Warp effect using Bump distortion](image)

- **Valley** — warps the center of the image away from you, making it appear concave

- **Swirl** — distorts the image in a spiral

- **Ripple** — distorts the image in concentric rings, like the rings created when you drop a stone into a pool of water

You can apply Image Warp and Quick Warp to the canvas, selections, and layers. However, Image Warp allows you to better target areas for warping, which is useful if you need to warp only a small portion of an image.

To warp an image using Image Warp

1. To apply the effect to:
• The canvas — Click the Canvas in the Layers panel.
• A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
• A layer — Click a layer in the Layers panel.

2 Choose Effects  ➤ Surface Control  ➤ Image Warp.

3 In the Image Warp dialog box, enable one of the following options:
   • Linear — pulls the selected area as if you were pulling from the top of a cone
   • Cubic — pulls a flat surface outward
   • Sphere — pulls a surface as if it were a lens

4 Adjust the Size slider.
   This slider controls the size of the area affected by dragging the cursor. The higher the number, the smaller the affected area.

5 In the document window, drag to distort the image.
   A circle displays as you drag, which indicates the area affected.

To warp an image using Quick Warp

1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

2 Choose Effects  ➤ Surface Control  ➤ Quick Warp.

3 In the Quick Warp dialog box, enable one of the following options:
   • Sphere — warps the image spherically, like a reflection on a polished silver ball
   • Bump — warps the center of the image toward you, making it appear convex
   • Valley — warps the center of the image away from you, making it appear concave
   • Swirl — distorts the image in a spiral
   • Ripple — distorts the image in concentric rings, like the rings created when you drop a stone into a pool of water

4 Adjust any of the following sliders:
   • Power — controls the intensity of the Sphere and Ripple effects
   • Angle Factor — controls the appearance of twisting and swirling in all effects

Applying the Woodcut effect

You can apply the Woodcut effect to create an image that appears like a woodcut or linoleum block print. You can specify either black and white or colored Woodcut effects. You can also save preset Woodcut effects to apply to other images.

Before (left) and after (right) applying the Woodcut effect
To apply a black and white Woodcut effect

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Surface Control ➤ Woodcut.

3. Enable the Output Black check box to use the black part of the effect in the final image.

4. Disable the Output Color check box if you want to use black and white only in the final image.

5. Adjust any of the following sliders:
   - Black Edge — determines the detail of the black edge. Larger values produce thick, black edges around objects. Smaller values produce more intricate edges.
   - Erosion Time — determines the number of erosion iterations performed on the black edge. The higher the erosion, the simpler the edge.
   - Erosion Edge — controls the amount of smoothing on the black edge. Larger values produce a rounded appearance of the black edge.
   - Heaviness — determines the amount of black in the final image.

To apply a colored Woodcut effect

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Surface Control ➤ Woodcut.

3. Enable the Output Color check box to use the color part of the effect in the final image.

4. Disable the Output Black check box if you want to use color only in the final image.

5. Enable one of the following options:
   - Auto Color — computes the color set from the original image’s colors automatically.
   - Use Current Color Set — uses a predefined color set. Next, choose a color from the Color Set box.

6. Adjust any of the following sliders:
   - Number of Colors — determines the number of colors used in the effect, ranging from 2 to 256. This control is available only with the Auto Color option.
   - Color Edge — determines the thickness of a colored edge applied to the image boundaries. Moving the slider to the right increases edge thickness, which is measured in pixels. The edge color is selected by choosing a color swatch below the preview window.

You can change the colors in a color set by clicking a color and then clicking a new color in the Change Color chip.

To save a Woodcut effect as a preset

1. Choose Effects ➤ Surface Control ➤ Woodcut.

2. In the Woodcut dialog box, modify any of the settings.

3. Click the Add button.

4. In the Add Preset dialog box, type a name in the Preset Name box.
   - You can choose the saved preset from the Preset list box.
Applying the Distress effect

You can apply the Distress effect to generate a high-contrast, black and white rendering of an image. You can control the edges, smoothness, variability, and threshold of the effect. The effect interacts with either the currently selected paper grain, pattern, clone source, layer mask, or channel.

**To apply the Distress effect using paper luminance**

1. Choose Window ▶ Media Panels ▶ Papers.
2. Choose a paper swatch in the Paper Textures area.
   - If you want to experiment with the effect, keep the Papers panel open while you apply the effect. This way you can switch to different papers and modify the paper controls.
3. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
4. Choose Effects ▶ Surface Control ▶ Distress.
5. Choose Paper from the Using list box.
6. Adjust any of the Distress controls. For information, see “Distress controls” on page 697.

**To apply the Distress effect using clone source or pattern luminance**

1. Open an image.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a clone source</td>
<td>In the Clone Source panel (Window ▶ Clone Source), choose Embedded Image from the Source list box.</td>
</tr>
<tr>
<td></td>
<td>In the Embed Source Image dialog box, do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To browse for a file, enable the Browse option.</td>
</tr>
<tr>
<td></td>
<td>• To clone a currently open document, enable the Current Document option, and choose a document from the list box.</td>
</tr>
</tbody>
</table>
To Do the following

• To embed the active texture, enable the Current Texture option.

Click OK.

Use a pattern

Choose Window ➤ Media Panels ➤ Patterns, and click a pattern swatch in the Painter Patterns area.

3 To apply the effect to:
  • The canvas — Click the Canvas in the Layers panel.
  • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
  • A layer — Click a layer in the Layers panel.

4 Choose Effects ➤ Surface Control ➤ Distress.

5 Choose Original Luminance from the Using list box.

6 Adjust any of the Distress controls. For information, see “Distress controls” on page 697.

To apply the Distress effect using a layer mask or alpha channel luminance

1 Do one of the following:
  • To use a layer mask, choose Window ➤ Layers, and click the layer that contains a layer mask in the Layers panel.
  • To use an alpha channel, choose Window ➤ Channels, and click the alpha channel in the Channels panel.

2 To apply the effect to:
  • The canvas — Click the Canvas in the Layers panel.
  • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
  • A layer — Click a layer in the Layers panel.

3 Choose Effects ➤ Surface Control ➤ Distress.

4 Choose the layer mask or channel from the Using list box.

5 Adjust any of the Distress controls. For information, see “Distress controls” on page 697.

Distress controls

• Edge Size — determines the size of the edge enhancement
• Edge Amount — determines the amount of edge enhancement
• Smoothing — determines the roundness of the edge between black and white
• Variance — determines the amount of grain added to the edge
• Threshold — determines how much black is in the image
• Preview — enable this check box to preview the effect in the document window

Applying the Serigraphy effect

With the Serigraphy effect, you can use photographs to generate images that appear silk-screened or look like woodblock cuts. When applying the effect, Corel Painter saves each color reduction as a separate layer, so you can edit each layer individually.
To apply Serigraphy effects

1 To apply the effect to:
   • The canvas — Click the Canvas in the Layers panel.
   • A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   • A layer — Click a layer in the Layers panel.

2 Choose Effects ➤ Surface Control ➤ Serigraphy.

3 Click the Match to color chip, and choose a color from the color picker.
   This is the center color — the color on which the effect will be based.

4 Click the Fill with color chip, and choose a color from the color picker.
   This color is used on the new layer.

5 In the Serigraphy color dialog box, adjust any of the following sliders:
   • Smoothing — determines the smoothness of the black edge
   • Threshold — determines the total amount of color difference from the center color
   • Distance Weighting — determines the amount of color distance from the center color
   • Hue Weighting — determines how much hue contributes to the effect
   • Sat Weighting — determines how much saturation contributes to the effect
   • Lum Weighting — determines how much luminance contributes to the effect

6 Click Create Serigraphy Layer.

7 Click OK.

You can also specify Match and Fill colors by clicking a color in the image.

Applying the Sketch effect

You can use the Sketch effect to generate a black and white pencil outline of a photograph. You can then use the outline as a guide for applying color, which is a useful technique for starting a painting. For more information, see “Choosing a painting workflow” on page 143.

To store the settings for the effect, you can create a preset. This allows you to quickly apply the settings to another image.
To apply the Sketch effect

1. To apply the effect to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.

2. Choose Effects ➤ Surface Control ➤ Sketch.

3. In the Sketch dialog box, adjust any of the following sliders:
   - Sensitivity — determines sensitivity to detail. Low values detect only the main edges. High values detect the main edges as well as thin lines, such as the lines around a person’s eyes.
   - Smoothing — determines how much noise is filtered out. Higher values result in wider, lighter, and blurrier lines.
   - Grain — determines how much of the paper grain is revealed in the sketch marks. Move this slider to the right to show more of the paper grain.
   - Threshold High and Threshold Low — removes noise after edge detection. Threshold High is used to flag light pixels which may be just noise in the image. Threshold Low is used to test surrounding pixels.

   You can also apply a preset sketch effect by choosing a preset from the Preset list box.

To save a sketch effect as a preset

1. Choose Effects ➤ Surface Control ➤ Sketch.

2. In the Sketch dialog box, modify any of the settings.

3. Click the Add button ➤.

4. In the Add Preset dialog box, type a name in the Preset Name box.

   You can delete a preset sketch effect by choosing it from the Preset list box and clicking the Delete button.
Dynamic Plug-ins

Dynamic plug-ins are a category of floating layers that give you the ability to manipulate, transform, and adjust underlying images non-destructively. In other words, you can apply and modify the dynamic plug-effects any number of times without altering the source image.

This section contains the following topics:

- “Getting started with dynamic plug-ins” (page 702)
- “Modifying and deleting dynamic layers” (page 702)
- “Converting dynamic layers” (page 702)
- “Applying the Brightness and Contrast dynamic plug-in” (page 703)
- “Applying the Burn dynamic plug-in” (page 703)
- “Applying the Tear dynamic plug-in” (page 705)
- “Applying the Bevel World dynamic plug-in” (page 706)
- “Applying the Equalize dynamic plug-in” (page 707)
- “Applying the Glass Distortion dynamic plug-in” (page 708)
- “Applying the Kaleidoscope dynamic plug-in” (page 710)
- “Applying the Liquid Lens dynamic plug-in” (page 711)
- “Applying the Liquid Metal dynamic plug-in” (page 714)
- “Applying the Posterize dynamic plug-in” (page 721)
Getting started with dynamic plug-ins

Dynamic plug-ins allow you to apply effects to images without altering the original image. For example, you can add a burnt effect to the edge of an image or increase the image brightness. The Dynamic plug-ins are accessible from the Layers panel.

When you apply an effect using a dynamic plug-in, a dynamic layer is automatically generated in the document. Like all floating objects, dynamic layers appear in the layer list in the Layers panel, where they are identified by the plug icon 🛡️. You can select, move, group, hide, show, and lock dynamic layers, as well as change their display order, opacity, and composite method, as you would with other layers. For more information, see “Layers” on page 569.

The steps for applying dynamic plug-ins vary slightly depending on which dynamic plug-in you choose. For most dynamic plug-ins, you can apply the effect to:

• a constrained area by making a selection in the document window
• a selected layer
• to the content of the entire canvas

If you apply the effect to a selection, the dynamic layer conforms to the dimensions and location of the selection. If you apply the effect to the canvas, the dynamic layer is the same size as the canvas. For a few dynamic plug-ins, such as Kaleidoscope, you can specify the size of the new layer before you create it. For more information, see “Applying the Kaleidoscope dynamic plug-in” on page 710.

When you save the file in RIFF format, the dynamic layer retains its dynamic nature. Therefore, if you plan on modifying the dynamic layer in the future, you should save the file to RIFF.

To access the dynamic plug-ins

2. In the Layers panel, click the Dynamic Plug-ins button 🛡️ to display a list of dynamic plug-ins.

Modifying and deleting dynamic layers

After creating a dynamic layer, you can change its settings. You can also delete a dynamic layer at any time.

To change a dynamic layer’s settings

1. Select the dynamic layer in the document window or in the Layers panel.
2. Double-click the dynamic layer in the Layers panel.
3. In the dialog box, change any settings.

To delete a dynamic layer

• In the Layers panel, select the dynamic layer, and click the Delete button 🗑.

You can also delete a dynamic layering by choosing Edit ➤ Undo.

Converting dynamic layers

At some point, you may want to finalize the dynamic plug-in effect and convert the result to a default layer. This allows you to work with the image in ways not possible when the effect is held in a dynamic layer.
Converting a dynamic layer captures its current appearance to a pixel-based layer. After a dynamic layer is converted, you can no longer adjust the effect. The following operations automatically generate a prompt to convert a dynamic layer:

- painting on a dynamic layer
- applying an additional effect or dynamic plug-in
- dropping a dynamic layer
- collapsing a group that contains a dynamic layer
- saving to a non-RIFF format

To convert a dynamic layer to a default layer

1. In the Layers panel, choose a dynamic layer.
2. Click the Layer options button 🗂️, and choose Convert To Default Layer.

Applying the Brightness and Contrast dynamic plug-in

The Brightness and Contrast dynamic plug-in creates a layer that lets you adjust the brightness and contrast of the image beneath it.

![Brightness and Contrast dynamic layer]

To create a Brightness and Contrast dynamic layer

1. Do one of the following:
   - In the Layers panel, choose the Canvas.
   - Choose the Rectangular Selection tool 🟢 from the toolbox, and then drag in the document window to select an area.
2. In the Layers panel, click the Dynamic Plug-ins button 🔗, and choose Brightness and Contrast.
3. In the Brightness/Contrast dialog box, drag the sliders to adjust the image contrast and brightness.

Corel Painter automatically creates a new layer when you apply the dynamic plug-in.

- If you don’t like the results, you can click Cancel or you can click Reset to restore the default settings.
- You can also use the Opacity slider 🔍 in the Layers panel to adjust the effect.

Applying the Burn dynamic plug-in

The Burn dynamic plug-in lets you add a burn effect to the edges of a selection or layer. You can adjust the amount and character of the burn.
Different Burn settings produce different results.

To burn a layer or selection

1. Do one of the following:
   - In the **Layers** panel, choose the **Canvas**, and choose **Select ▶ All**.
   - In the **Layers** panel, choose a layer.
   - Choose the **Rectangular Selection** tool from the toolbox, and then drag in the document window to select an area.

2. In the **Layers** panel, click the **Dynamic Plug-ins** button, and choose **Burn**.

3. In the **Burn Options** dialog box, adjust any of the following sliders and controls:
   - **Burn Margin** — specifies the width of the burn effect in relation to the layer’s size
   - **Flame Breadth** — specifies the width of the scorched region. The burn color appears in the scorch.
   - **Flame Strength** — specifies how much of the layer is consumed by the burn. Increasing **Flame Strength** shrinks the layer.
   - **Wind Direction** — changes the burn amount for different sides of the layer
   - **Wind Strength** — determines how much change the **Wind Direction** control imparts
   - **Jaggedness** — specifies the amount of irregularity in the burnt edges

   If you apply the effect a selection, Corel Painter 2020 automatically creates a new layer when you apply the dynamic plug-in.

   If you apply the effect to an existing layer, Corel Painter converts the layer to a dynamic layer.

You can also

- Use the current paper to vary the dye concentration in the scorch region
  - Enable the **Use paper texture** check box.

- Burn the interior edges as well as the exterior edges of the selection
  - Enable the **Burn Interior Edges** check box. Disable this check box to protect the interior edges.

- Change the scorch color
  - Click the **Color** chip, and choose a color from the color picker.

- Restore the default settings
  - Click the **Reset** button.

You can view only the dynamic layer by hiding the canvas in the **Layers** panel.

You can apply a **Burn** to a specific area of the canvas by selecting the area, right-clicking the selection and choosing **Layer via Copy**, then applying the effect to the new layer.

You can use the **Revert to Original** command in the **Layers** panel menu to restore a source image to its original condition. For more information, see “Modifying and deleting dynamic layers” on page 702.
Applying the Tear dynamic plug-in

The Tear dynamic plug-in lets you apply a torn-paper effect to the edge of a selection or layer. You can also control the amount of tearing that the effect produces.

You can tear a little (left) or a lot (right).

To apply the Tear dynamic plug-in

1. Do one of the following:
   - In the Layers panel, choose the Canvas, and choose Select ➤ All.
   - In the Layers panel, choose a layer.
   - Choose the Rectangular Selection tool from the toolbox, and then drag in the document window to select an area.

2. In the Layers panel, click the Dynamic Plug-ins button, and choose Tear.

3. In the Tear Options dialog box, set the following sliders and controls to adjust the tear effect:
   - Margin — specifies the width of the tear effect from the edge of the layer
   - Strength — specifies how much of the layer is torn away
   - Jaggedness — specifies the amount of irregularity in torn edges

   If you apply the effect to a selection, Corel Painter automatically creates a new layer when you apply the dynamic plug-in.

   If you apply the effect to an existing layer, Corel Painter converts the layer to a dynamic layer.

You can also

- Tear the interior edges as well as the exterior edges
  - Enable the Tear interior edges check box. Disable this check box to protect interior edges.

- Change the tear color
  - Click the Color chip, and choose a color from the color picker.

- Restore the default settings
  - Click the Reset button.
You can view only the dynamic layer by hiding the canvas in the Layers panel. Use a rough paper texture to create a better tear by clicking the Paper selector in the toolbox and choosing a paper texture from the list.

You can use the Revert to Original command in the Layers panel menu to restore a source image to its original condition. For more information, see “Modifying and deleting dynamic layers” on page 702.

Applying the Bevel World dynamic plug-in

The Bevel World dynamic plug-in lets you create three-dimensional (3D) objects by adding bevel effects, or angled edges, to selections or layers. You can control both bevel shape and lighting to create unique effects.

![Examples of various bevel profiles](image)

For example, you can even use Bevel World to create a 3D button with text on it. First, create the background button, and then add text to float over the button. You can then group the text and button together and collapse the layer group.

You can also change the 3D appearance of the bevel by adjusting the lighting.

To apply a bevel effect

1. Do one of the following:
   - In the Layers panel, choose a layer.
   - Choose a selection tool from the toolbox, and then drag in the document window to select an area.

2. In the Layers panel, click the Dynamic Plug-ins button and choose Bevel World.

3. In the Bevel area, adjust any of the following sliders:
   - Bevel Width — specifies the width of the bevel in relation to the layer diameter
   - Outside Portion — controls the portion of the bevel that appears outside the layer
   - Rim Slope — specifies the angle of the rim (innermost portion) of the bevel
   - Cliff Portion — specifies the horizontal distance between the base and the rim
   - Cliff Height — specifies the vertical distance between the base level and rim level
   - Cliff Slope — specifies the angle of the cliff (middle portion) of the bevel
   - Base Slope — specifies the angle of the base (outermost portion) of the bevel
   - Smoothing — controls the roundness of the transitions between base, cliff, and rim as well as the sharpness of the resulting ridges

4. In the Light area, adjust any of the following sliders:
   - Light Direction — specifies the angle of the light source
• **Light Height** — specifies the light’s angle in relation to the canvas. At 90°, the light is shining straight down, and at 1°, it’s nearly horizontal. With **Light Height** set to 90%, the **Light Direction** setting has no effect. When set to 90% or less, the light rotates around the center.

• **Brightness** — controls the light’s intensity

• **Scatter** — adjusts the spread of the light’s shine over the surface

• **Shine** — controls the prevalence of highlights

• **Reflection** — controls how much of the source image is visible in the bevel. If you are working with a clone, the clone source is mapped onto the surface at a variable percentage.

You can also

Add beveling on the interior edges of the bevel area
Enable the **Bevel inner edges** check box.

Change the color of the outside portion
Click the **Outside Color** chip, and choose a color from the color picker. This control applies only when **Outside Portion** is greater than zero.

Change the light color
Click the **Light Color** chip, and choose a color from the color picker.

Add a preset light source
In the **Light** area, enable the **Simple lighting** check box, and click a light indicator on the lighting sphere.

Add a custom light source
In the **Light** area, disable the **Simple lighting** check box, and click on the lighting sphere where you want to add a new light source. A new light indicator (small circle) appears where you click.

Delete a custom light source
Click on a light indicator and press **Delete**.

Restore the default settings
Click the **Reset** button.

You can use the **Revert to Original** command in the **Layers** panel menu to restore a source image to its original condition. For more information, see “Modifying and deleting dynamic layers” on page 702.

**Applying the Equalize dynamic plug-in**

The **Equalize** dynamic plug-in creates a layer that lets you adjust the contrast in underlying images. It does this by adjusting black and white points and distributing the brightness levels throughout the entire range of available levels.
The Equalize dynamic layer is applied to a rectangular selection.

The Equalize dynamic plug-in creates a histogram showing the number of pixels for each brightness level value. Equalize allows gamma adjustment, which lightens or darkens an image without changing highlights or shadows.

To create an Equalize dynamic layer

1. Do one of the following:
   - In the Layers panel, choose the Canvas.
   - Choose the Rectangular Selection tool from the toolbox, and then drag in the document window to select an area.

2. In the Layers panel, click the Dynamic Plug-ins button, and choose Equalize.

3. In the Equalize dialog box, adjust the contrast by dragging the small black and white markers under the histogram. Any values in the image located to the right of the white marker become black; any values to the left of the black marker become white.

4. Drag the Gamma slider to adjust only the midtones of an image and leave the white and black areas untouched.

   Corel Painter automatically creates a new layer when you apply the dynamic plug-in.

   If you don’t like the results, click Reset to restore the default settings.

   You can also use the Opacity slider in the Layers panel to adjust the effect.

Applying the Glass Distortion dynamic plug-in

The Glass Distortion dynamic plug-in creates a layer that simulates the appearance of viewing the image through textured glass. You can move the layer in the document to view the distortion over different parts of an image.
To create a Glass Distortion dynamic layer

1. Do one of the following:
   - In the Layers panel, choose the Canvas.
   - Choose a selection tool from the toolbox, and then drag in the document window to select an area.

2. In the Layers panel, click the Dynamic Plug-ins button and choose Glass Distortion.

3. In the Glass Distortion Options dialog box, choose one of the following displacement sources from the Using list box:
   - Paper — uses the selected paper texture. Paper texture is good for creating the pebbled glass effect. Unless you want frosted glass, you’ll probably want to increase the scale of the paper.
   - Current Selection — uses the currently selected area in the document window
   - Image Luminance — uses the current document’s luminance
   - Original Luminance — uses the clone source’s luminance
   Image pixels are displaced, based on the light and dark areas of the source.

4. To modify the distortion effect, adjust any of the following sliders:
   - Softness — controls the transitions between displaced colors. Increasing softness creates more intermediate steps and produces a smoother distortion. If you experience aliasing in a glass distortion, try increasing the softness.
   - Amount — controls the degree of displacement. A higher amount leads to more distortion.
   - Variance — creates multiple variations in the neighborhood of the displacement. The result of increasing variance depends on the type of image and other settings.

Corel Painter automatically creates a new layer when you apply the dynamic plug-in.

You can also

Inverts the selected source

Display changes before applying them to the image

Restore the default settings

You can also use the Opacity slider in the Layers panel to adjust the effect.

You can drag the Glass Distortion layer or selection in the document window to distort other areas of the image.
The Glass Distortion dynamic layer using Paper (left) and Image Luminance (right) displacement sources

Applying the Kaleidoscope dynamic plug-in

The Kaleidoscope dynamic plug-in creates a square layer that produces kaleidoscopic effects from underlying images. The traditional kaleidoscope is a hollow tube with a set of mirrors and colored chips at one end. You peer into the other end and enjoy the highly symmetrical patterns that the mirrors create from the colored chips. When you add a Kaleidoscope dynamic layer, you first specify its size. You can move the layer over different parts of an image to produce different effects.

To create a Kaleidoscope dynamic layer

1. In the Layers panel, click the Dynamic Plug-ins button and choose Kaleidoscope.
2. In the Kaleidoscope dialog box, specify the size of the dynamic layer. Kaleidoscopes must be square, and no bigger than the shorter dimension of the document (width or height).
3. Drag the Kaleidoscope layer to different areas of the image to alter the effect.

Move the Kaleidoscope layer to produce different effects.

To preserve the Kaleidoscope layer, you need to save the image in RIFF format.

To create and capture a Kaleidoscope pattern

1. Drag the Kaleidoscope layer on the canvas until it displays an image that you like.
2. In the Layers panel, select the Kaleidoscope layer.
3. Click the Layers panel menu arrow, and choose Drop and Select to commit the layer.
4 Choose Window ▶ Media Panels ▶ Patterns.

5 In the Patterns panel, click the Capture Pattern button.

For more information, see “Patterns” on page 723.

When you create a pattern from a Kaleidoscope layer, the selection is dropped to the canvas and cut out. If you want to preserve the original image and the Kaleidoscope layer so that you can continue working with the effect, save the image in RIFF format before you choose Drop and Select. As an alternative, you can set the number of Undo levels high enough so that you can back out of the steps to restore the original image.

Applying the Liquid Lens dynamic plug-in

Liquid Lens creates a dynamic layer that lets you distort and smear the underlying image. You can create “fun house” mirror effects, melting images, and more. You can also erase any of the changes that you make.

Liquid Lens tools

You can apply different distortion effects by using any of the following tools:

<table>
<thead>
<tr>
<th>Liquid Lens tool</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circular Distortion tool</td>
<td>Drag in the direction you want the distortion to move. Size and Spacing have no effect on the Circular Distortion tool.</td>
</tr>
</tbody>
</table>

The Circular Distortion tool creates circular rings of distortion. Drag in the direction you want the distortion to move. Size and Spacing have no effect on the Circular Distortion tool.

The Left Twirl tool distorts in counterclockwise spirals.
Liquid Lens tool

The Right Twirl tool distorts in clockwise spirals.

Example

The Bulge tool distorts outward, pushing images out.

The Pinch tool distorts inward, drawing images closer.

The Brush tool distorts in the direction you drag.
To create a Liquid Lens dynamic layer

1. In the Layers panel, choose the Canvas.
2. Click the Dynamic Plug-ins button 📒 and choose Liquid Lens.
3. In the Liquid Lens dialog box, choose a Liquid lens tool.
4. Adjust any of the following sliders:
   - **Size** — changes the diameter of the distortion tool and the size of rain, which scatters distortion droplets in the layer
   - **Spacing** — changes the distance between distortion dabs
   - **Amount** — controls the degree of distortion applied
   - **Smooth** — changes the blending between the distortion stroke and the unaffected images

5. Drag in the document window to create distortion.
   - If you don’t like the distortion, click Clear.

You can also

- Simulate a melting image by scattering distortion droplets downwards in the layer
- In the Liquid Lens dialog box, click Rain, then click anywhere in the image to stop the rain.
You can also

If Smooth and Size settings are very high, the rain might continue for a moment after you click.

Restore the default settings

Click the Reset button.

You cannot use Undo to restore the image to its previous state, however, you can use the Eraser tool in the Liquid Lens dialog box.

You can move the Liquid Lens layer to different regions of the document to distort other images.

To erase Liquid Lens distortion

1  In the Liquid Lens dialog box, choose the Eraser tool.

2  Adjust the Size, Spacing, and Smooth sliders to modify the Eraser tool settings.

   Higher settings on the Smooth slider create softer transitions from the erased area to the remaining distortion.

3  Drag in the document window.

   The original underlying image returns.

Applying the Liquid Metal dynamic plug-in

The Liquid Metal dynamic plug-in lets you paint on a layer with liquid and metal. This text uses the term “metal” to refer to the media applied — even if the settings create an effect more like water.
You can apply droplets of liquid that distort the underlying image through refraction. You can also create globs of shiny metal that flow together and move like mercury. The **Refraction** slider sets the difference between water and metal, which lets you achieve intermediate effects. Negative metal can be used to create holes in metal.

![Image of liquid metal effect](image)

*The Liquid Metal dynamic plug-in creates either liquid metal or translucent, refractive liquid.*

A stroke of metal is made up of a series of discrete droplets. You can select one or several droplets and move them or change their properties.

The “handles” show the droplet’s circle and center point. Showing the handles on the droplets isn’t necessary for selecting them, but it can make your work easier. The droplets applied in the last stroke are automatically selected. Each new stroke deselects the droplets of the previous one.

The **Undo** feature is not available when working with metal; however, you can remove selected metal, the last metal applied, or all metal on the layer.

Metal is highly reflective. You can customize the look by using a clone source or a pattern as a reflection map. For more information, see “Image cloning and sampling” on page 181 and “Patterns” on page 723.

**Liquid metal tools**

You can apply metal with the Brush tool, the Circular Drop tool, or the Rain feature. You can adjust the size of your brush or rain droplets. The Brush is the default applicator. You can use the Brush tool to paint with metal. You can use the Circular Drop tool to create circles of metal. The Rain feature lets you scatter metallic droplets on the layer.

**Liquid Metal tool**

**Example**

You can create strokes of metal by using the Brush tool.
Liquid Metal tool

Example

You can create circles of metal by using the Circular Drop tool.

You can create randomly falling metal raindrops by applying the Rain feature.

To create a Liquid Metal dynamic layer

1. In the Layers panel, choose the Canvas.
2. Click the Dynamic Plug-ins button and choose Liquid Metal.
3. In the Liquid Metal dialog box, choose one of the following tools:
   * Circular Drop tool
   * Brush tool
4. In the Settings area, move any of the following sliders:
   * Size — changes the diameter of the selected droplets that you apply by using the Brush tool or Rain. It does not affect the Circular Drop tool.
   * Spacing — adjusts the spacing between droplets in strokes created with the Brush tool
A stroke with low spacing (left): the droplets flow together. A stroke with high spacing (right): each droplet is distinct.

- **Volume** — adjusts visibility along the perimeter

  Decreasing volume below 100% shrinks the visible portion of the droplet, “drying it up” (left). Increasing volume beyond 100% extends visibility beyond the droplet circle into the perimeter range (right).

- **Smooth** — changes the perimeter range, which determines the droplet’s tendency to “join” its neighbors

  Low settings on the Smooth slider keep droplets distinct (left); higher settings make the droplets flow together (right).

5 In the **Rendering** area, choose one of the following metal types from the **Map** list box:

- Standard Metal
- Chrome 1
- Chrome 2
- Interior
- Clone Source

6 Move any of the following sliders:
• **Amount** — controls the emphasis of the metal effect from the **Refraction** slider and applies to all droplets in the layer. To create water effects, you can set the **Amount** to –0.5 so the droplets magnify the underlying images.

![Reflection and Refraction](image1.jpg)

Reflection and Refraction are inverted when you move the Amount slider to either extreme.

• **Refraction** — controls droplet appearance. The slider represents a scale between reflection and refraction.

![Low refraction](image2.jpg)  ![High refraction](image3.jpg)

Low refraction means high reflection (left). High refraction creates translucent, refractive liquid. As Refraction nears 100%, the metal becomes transparent. The droplets look like a simple liquid — oil or water (right).

7 Drag in the document window to apply the metal.

If you want to clear the effect and start again, click **Clear**.

You can also

- Makes the droplets appear more round and three-dimensional
  
  Enable the **Surface tension** check box.

- Scatter metal droplets in the layer
  
  In the **Liquid Metal** dialog box, click **Rain**, then click anywhere in the image to stop the rain.
  
  If **Smooth** and **Size** settings are very high, the rain might continue for a moment after you click.

- Restore the default settings
  
  Click the **Reset** button.

The **Map** type that you choose applies to the entire layer. You can change the type at any time.

**To create negative metal**

- Press **Option** (macOS) or **Alt** (Windows), and drag with the **Circular Drop** tool or **Brush** tool over existing metal droplets.

  You will create holes in your metal. As you drag through positive pools, the negative metal will divide and separate the existing metal.
To remove metal

To

Remove the last metal applied
Do the following
Press Delete (macOS) or Backspace (Windows).

Remove the selected metal droplets
In the Liquid Metal dialog box, click the Select Drops tool , select the metal, and press Delete (macOS) or Backspace (Windows).

Remove all metal on the layer
In the Liquid Metal dialog box, click Clear.

To show metal droplet handles

• In the Liquid Metal dialog box, enable the Display handles check box.

When you enable the Display Handles check box (right), you can see the droplet circles and center points.

To select metal droplets

1 In the Liquid Metal dialog box, choose the Select Drops tool .
2 Perform an action from the following table.

To

Select a single droplet
Do the following
If the Display Handles check box is enabled, click the center point handle of a droplet. If handles are not displayed, click anywhere on a droplet.

Select a group of droplets
Drag across the droplets you want to select.

Add droplets to a selection
Hold down Shift, and click additional droplets to add to the selection.

Subtract droplets from a selection
Hold down Shift, and click droplets to subtract from the selection.

When a droplet is selected, the center point handle is displayed as a solid.
To move metal droplets

1. In the **Liquid Metal** dialog box, choose the **Select Drops** tool, and select the droplets that you want to move.

2. Choose the **Move Drop** tool, and drag the droplets to a new position.

   Notice how the droplets seek to join other droplets they encounter. You can control this tendency by adjusting the **Smooth** slider.

To adjust the size of the Liquid Metal brush

1. In the **Liquid Metal** dialog box, choose the **Select Drops** tool, and click outside the droplets to deselect all.

2. Move the **Size** slider to the desired value.

3. Click the **Brush** tool and paint, or click **Rain**.

   You can also adjust the size of existing metal by selecting the droplets and moving the **Size** slider.

To apply a clone source or pattern to the Liquid Metal reflection

1. Do one of the following:
   - Choose a pattern by clicking the Pattern selector from the **Media Selector** bar, and clicking a pattern from the list.
   - Set a clone source.

2. In the **Layers** panel, choose the **Canvas**.

3. In the **Layers** panel, click the **Dynamic Plug-ins** button, and choose **Liquid Metal**.

4. In the **Liquid Metal** dialog box, choose **Clone Source** from the **Map** list box.
5 Adjust any settings.

6 With the Circular Drop tool  or Brush tool , drag in the document window to apply the metal.

If you want to clear the effect and start again, click Clear.

If no clone source has been specified, Corel Painter uses the current pattern as the reflection map.

The same piece of metal changes appearance when a pattern is used as the reflection map.

Applying the Posterize dynamic plug-in

The Posterize dynamic plug-in creates a layer that reduces the number of color levels in the images it floats over.

To create a Posterize dynamic layer

1 Do one of the following:
   • In the Layers panel, choose the Canvas.
   • Choose the Rectangular Selection tool from the toolbox, and then drag in the document window to select an area.

2 In the Layers panel, click the Dynamic Plug-ins button and choose Posterize.

3 In the Posterize dialog box, specify the number of color levels you want.
   The maximum number of color levels is 128. The value applies to each color channel — red, green, and blue.
   Corel Painter automatically creates a new layer when you apply the dynamic plug-in.
Patterns

With Corel Painter, you can apply patterns to an image by filling or painting. In addition, you can customize patterns by modifying sample patterns or by creating them from scratch.

All patterns, including both the sample and custom patterns, reside in libraries. You’ll find more libraries, with additional materials, on the Corel website. For more information, see “Working with libraries” on page 87.

This section contains the following topics:
• “Applying pattern fills” (page 723)
• “Painting with patterns” (page 725)
• “Creating and editing patterns” (page 726)
• “Creating seamless patterns” (page 729)
• “Creating fractal patterns” (page 731)

Applying pattern fills

Corel Painter lets you apply preset pattern fills to images. A pattern is a repeating design, and the smallest unit of a pattern is known as a “tile.” When you fill an area with a pattern, the tile, which is rectangular, is repeated across the selected area.

You can adjust the appearance of a pattern in various ways. For example, you can change the tile size, also known as the scale, and offset tiles in a fill. When you offset the tiles, you adjust the horizontal or vertical position of the first tile, relative to the top of the object, which affects the rest of the pattern fill.

Left: A pattern scaled at 20%. Right: The same pattern scaled at 100%.
To apply a pattern as a fill

1. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To apply a pattern to</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The canvas</td>
<td>Click Canvas in the Layers panel.</td>
</tr>
<tr>
<td>A selection</td>
<td>Click a selection tool from the toolbox, and drag in the document window to select an area.</td>
</tr>
<tr>
<td>A layer</td>
<td>Click a layer in the Layers panel.</td>
</tr>
</tbody>
</table>

2. Choose the Paint Bucket tool in the toolbox.

3. Choose Clone Source from the Fill with list box on the property bar, click the Clone Source flyout button and choose Current Pattern from the Source list box.

4. Click a pattern swatch in the Painter Patterns area.

5. In the document window, click the canvas, selection, or layer.

You can also

Specify the range of colors to be filled

On the property bar, type a value in the Tolerance box or move the slider.

Specify the pattern opacity for pixels outside the tolerance range

On the property bar, type a value in the Feather box or move the slider.

Soften the edges of the pattern

On the property bar, click the Anti-Alias button. Anti-aliasing is recommended when the Feather setting is extremely low or set to zero.

The image must be larger than the tile in order for the tiling to be visible in an image.
To adjust the appearance of a pattern

1. Choose Window ➤ Media Panels ➤ Patterns.
2. Click a pattern swatch in the Painter Patterns area.
3. Click one of the following buttons:
   * Rectangular — places the tiles in a rectangular grid for fills. This option disables the Offset slider.
   * Horizontal — offsets the tiles in subsequent rows
   * Vertical — offsets the tiles in subsequent columns
   If applicable, move the Offset slider to control the amount of offset.
4. Move the Scale slider to control the size of each tile in the pattern.
   After you set these options, the pattern is ready to use.

Painting with patterns

Corel Painter lets you paint patterns directly onto an image using a brush that uses the rendered dab type. When painting with a pattern, you can apply the pattern as is, or you can modify its appearance. For example, you can paint a pattern with a mask, which generates a pattern with a transparent background. You can also paint subtle patterns by adjusting the opacity, which produces a translucent effect.

Painted pattern type | Example
--- | ---
Pattern | ![Pattern Example](image)
Pattern with mask | ![Pattern with Mask Example](image)
Pattern with opacity | ![Pattern with Opacity Example](image)

To paint with a pattern

1. In the Brush Selector, choose a brush variant that supports patterns.
   For example, the Pattern Pens brush category supports patterns. If a brush does not support patterns, the Source list box in the General control panel (Window ➤ Brush Control Panels ➤ General) is disabled (appears gray).
2. In the General controls panel, choose a dab type from the Dab Type list box.
   For example, the Projected and Rendered dab types support patterns. If a dab type does not support patterns, the Source list box in the General controls panel is disabled.
3. From the Source list box in the General controls panel, choose one of the following options:
• **Pattern** — paints with a pattern containing no mask information
• **Pattern with Mask** — paints using the mask data contained in the pattern (not all patterns contain mask data)

If you want to change the size of the painted pattern, you should resize the brush instead of scaling the pattern. To achieve the best results, set the **Scale** in the **Patterns** panel to 100%.

4 Click the **Patterns** flyout button on the property bar, and click a pattern.

5 Paint in the image.

You can also paint with a pattern by choosing a brush variant from the **Pattern Pens** category.

- If you have not set a clone source, Corel Painter uses the current pattern in any operation related to clone source colors or luminance. This means you can paint with a pattern by using a **Cloner** brush.
- When painting with a pattern, keep in mind that direction matters. Corel Painter flips the pattern you’re painting when you change directions, so apply strokes in the same direction to achieve a uniform effect.

### To paint with pattern opacity

1 In the Brush Selector, choose a brush variant that supports patterns.
   - For example, the **Pattern Pens** brush category supports patterns. If a brush does not support patterns, the **Source** list box in the **General** control panel (Window > Brush Control Panels > General) is disabled (appears gray).

2 In the **General** controls panel, choose a dab type from the **Dab Type** list box.
   - For example, the **Projected** and **Rendered** dab types support patterns. If a dab type does not support patterns, the **Source** list box in the **General** controls panel is disabled.

3 In the **General** controls panel, choose **Pattern As Opacity** from the **Source** list box.
   - **Pattern As Opacity** is the only computed dab type that responds to methods (**Cover** and **Buildup**), allowing it to respond to **Graininess**.

4 Click the **Patterns** flyout button on the property bar, and click a pattern.

5 Apply a brushstroke to the image.

You can also paint with a pattern by choosing a brush variant from the **Pattern Pens** category.

Corel Painter applies the current color, using luminance in the pattern to control opacity. Light colors in the pattern are rendered as transparent (or as having very low opacity). Dark colors in the pattern are rendered as very dark (or as having high opacity).

### Creating and editing patterns

You can create a pattern from scratch or from an existing image. When creating a pattern from an existing image, you can base the pattern on the entire image or a selected area. You can also create a pattern from a mask, which produces a pattern with a transparent background. The image or selection that you choose is converted into a tile that, when repeated, generates a pattern.
A pattern tile was created by applying brushstrokes to the canvas.

If you want to edit an existing pattern, or if a pattern preview isn’t detailed enough, you can open the pattern tile in its own window so that you can view the pattern closely to modify it. For example, you can manipulate a pattern to be a half-drop design, traditionally used in wallpaper designs.

After creating a pattern tile, you may want to refine it so that it tiles seamlessly. For more information, see “Creating seamless patterns” on page 729.

Images that you turn into patterns are saved in the RIFF format, and they maintain their pattern characteristics even after you save and reopen them. You can switch libraries whenever you want to use a different set of patterns. For more information, see “Working with libraries” on page 87.

Creating patterns on layers

You can use the same techniques to create patterns on layers as you do to create them on the canvas. However, a pattern’s wrap-around features do not apply to layers. This is because the canvas has edges, but layers do not — they are unlimited in size. If you shift a pattern on a layer, the pattern does not wrap around.

To create a pattern from scratch

1. Choose **File ➤ New**.
2. Type values in the **Width** and **Height** boxes.
   - If you want to create a pattern, you should set a small canvas size, such as 400 pixels by 300 pixels at 300 ppi.
3. In the **Patterns** panel (Window ➤ Media Panels ➤ Patterns), click the Pattern options button ☰, and choose **Define Pattern**.
4. Apply brushstrokes to the canvas.
   - If you apply a brushstroke to the edge of the canvas, wrap-around colors are enabled so that you can drag a brushstroke off one edge of an image, while simultaneously applying the brushstroke to the other side of the image.
5. Click the Pattern options button ☰, and choose **Add Image to Library**.
6. In the **Save Image** dialog box, type a name for the pattern.

You can also create a pattern by choosing an existing pattern, modifying it, and then choosing **Define Pattern**.

To create a pattern from an image

1. Open the image file that you want to use in creating a pattern.
2. In the **Patterns** panel (Window ➤ Media Panels ➤ Patterns), click the Pattern options button ☰, and choose **Define Pattern**.
3 Click the Pattern options button and choose Add Image to Library.

4 In the Save Image dialog box, type a name for the pattern.

**To create a pattern from a selection**

1 Open or create an image.

2 Choose the Rectangular Selection tool in the toolbox.

3 Drag in the document window to select the area that you want to save as a pattern tile.

4 In the Patterns panel (Window ➤ Media Panels ➤ Patterns), click the Capture Pattern button.

5 In the Capture Pattern dialog box, enable one of the following options:
   - **Rectangular tile** — places the tile in a rectangular grid for fills. This option disables the Bias slider.
   - **Horizontal shift** — offsets the tiles in subsequent rows
   - **Vertical shift** — offsets the tiles in subsequent columns
   If applicable, move the Bias slider to adjust the amount of offset.

6 Type a name in the Name text box.

7 Click OK to save the pattern tile to the current library.

You can also create a pattern that is based on a 4-point clone source, such as perspective or bilinear. For more information, see “Applying transformations when sampling” on page 205.

**To create a masked pattern**

1 Open the image file that you want to use in creating a pattern.

2 Choose the Lasso tool in the toolbox.

3 In the document window, draw a freehand border around the area that you want to convert to a masked pattern.

4 In the Patterns panel (Window ➤ Media Panels ➤ Patterns), click the Capture Pattern button.

5 In the Capture Pattern dialog box, enable one of the following options:
   - **Rectangular tile** — places the tile in a rectangular grid for fills. This option disables the Bias slider.
   - **Horizontal shift** — offsets the tiles in subsequent rows
   - **Vertical shift** — offsets the tiles in subsequent columns
   If applicable, move the Bias slider to adjust the amount of offset.

6 Type a name in the Name text box.

7 Click OK to save the masked pattern to the current library.

To quickly apply a pattern mask, click the Brush Selector. In the Brush library panel, choose the Pattern Pens category, and then choose the Pattern Pen Masked variant.

You can apply pattern masks by using any brush variant that supports them. For more information, see “Painting with patterns” on page 725.
To edit a pattern

1. In the Patterns panel (Window ➔ Media Panels ➔ Patterns), click a pattern swatch in the Painter Patterns area.

2. Click the Pattern options button ‹, and choose Check Out Pattern.
   The pattern tile appears in a separate document window.

3. On the canvas, modify the pattern tile image.

4. Click the Pattern options button ‹, and choose Add Image to Library.

5. In the Save Image dialog box, click OK to save the pattern to the library.
   If you want to rename the pattern, type a new name in the Save As text box. For example, you may want to modify a default pattern, but keep a copy of the default pattern intact.

   The Check Out Pattern mode supports wrap-around colors. When you drag a brushstroke off one edge of an image, the brushstroke is simultaneously applied to the other side of the image. This allows you to quickly modify the edges of an individual pattern tile.

Creating seamless patterns

Patterns are created by repeating a rectangular image tile across an area. Ideally, the pattern tiles should seamlessly blend into one another so that the eye doesn’t distinguish the tile edges. Corel Painter allows you to generate seamless patterns by modifying the edges of a pattern tile before applying the pattern. However, you can also fix a pattern’s seams by directly modifying the pattern fill.

To achieve seamless tiling, Corel Painter gives documents defined as pattern tiles two special characteristics: wrap-around colors and wrap-around seams.

- The wrap-around colors feature lets you drag a brushstroke off one edge of an image, while simultaneously applying the stroke to the other side of the image. This allows you to quickly modify the edges of an individual pattern tile.
- The wrap-around seams feature lets you shift the edges of pattern tiles to the center of the image, where their tonal differences are more apparent and easier to correct. This allows you to modify a pattern after applying it as a fill.
To ensure a seamless pattern, you can also apply an effect, such as the Glass Distortion effect, the Super Soften effect (with the Wrap Around check box enabled), and most of the Tonal Control effects. Some effects, such as Apply Surface Texture, can result in a noticeable seam. For information, see “Applying Glass Distortion” on page 655.

To create a seamless pattern from a pattern tile
1. In the Patterns panel (Window ➔ Media Panels ➔ Patterns), choose the pattern whose tile you want to fix.
2. Click the Pattern options button ⌁, and choose Check Out Pattern.
   The pattern tile appears in a separate document window.
3. Use any color brush to paint out the edge lines, or use a brush with a Water or Drip method to smear across the lines.
4. Click the Capture Pattern button 📷.
5. In the Capture Pattern dialog box, type a name in the Name box.

To preserve detailed images, set the Straight Cloner brush to clone from somewhere inside the image. For more information, see “Painting in the clone” on page 185.

You can also copy a selection to a layer and move it over the edge. To produce clean transitions, feather the layer, and reduce opacity. Drop the layer when you’re satisfied with the result. For more information, see “Layers” on page 569.

To create a seamless pattern from a pattern fill
1. Create a blank document.
2. In the Patterns panel (Window ➔ Media Panels ➔ Patterns), choose the pattern whose seams you want to modify.
3. Click Canvas in the Layers panel.
4. Choose the Paint Bucket tool 🟪 from the toolbox, and click the canvas in the document window.
5. In the Patterns panel, click the Pattern options button ⌁, and choose Define Pattern.
6. In the toolbox, click the Grabber tool 📷.
7. Hold down the Shift key and drag the image to display the area where the tile’s horizontal and vertical edges meet.
8. Do any of the following:
   • Use any color brush to paint out the edge lines, or use a brush with a Water or Drip method to smear across the lines.
   • Use the Straight Cloner brush to paint out the edge lines to preserve image details. For more information, see “Painting in the clone” on page 185.
You can also copy a selection to a layer and move it over the edge. To produce clean transitions, feather the layer, and reduce opacity. Drop the layer when you’re satisfied with the result. For more information, see “Layers” on page 569.

The changes that you make to a pattern fill are not reflected in the original pattern tile.

Creating fractal patterns

You can create interesting landscapes by using fractal patterns. You can also convert a fractal pattern into a paper texture and save it to the Paper library. For more information, see “Working with paper texture and grain” on page 165.

Using Fractal Pattern controls

When you create fractal patterns, the following controls allow you to fine-tune your creation:

- **Power** controls the intricacy of the pattern’s definition, as if you were “zooming” in and out on a textured surface with a microscope.

  ![Power comparison](image)
  
  *The Power slider determines the degree of detail. The image on the left is set to -200% and the image on the right is set to 0%.*

- **Feature Size** defines the number of prominent features within the tile.

  ![Feature Size comparison](image)
  
  *The Feature Size slider determines the number of repetitions per tile. The image on the left is set to 90% and the image on the right is set to 20%.*

- **Softness** adjusts the edge softness of the pattern.
- **Angle** changes the direction from which you view the fractal.
- **Thinness** emphasizes the direction suggested by the lines of the fractal pattern. Thinner lines produce a more linear look.
- **Size** determines the size of the tile you are creating. If your computer has a lot of memory, you can make a large file with a high resolution. If you do not have a lot of available memory on your computer, some of the size options may not be available.
Low Thinness settings display the fractal as streaks. Use the Angle slider to change the direction of streaking.

Corel Painter uses four channels to store graphic information: Red, Green, Blue, and Alpha. When creating fractal patterns, you can place information other than color values in these channels, which allows you to visualize this information in different ways.

To create fractal patterns
1. In the Patterns panel (Window ➔ Media Panels ➔ Patterns), click the Make Fractal Pattern button.
2. In the Make Fractal Pattern dialog box, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control the intricacy of the pattern</td>
<td>Move the Power slider to the right to zoom out and see many small features, or move it to the left to zoom in and see a few large features.</td>
</tr>
<tr>
<td>Modify the number of prominent features within the tile</td>
<td>Move the Feature Size slider to the right to decrease the repetitions per tile, or move it to the left to increase the number of repetitions per tile.</td>
</tr>
<tr>
<td>Adjust the edge softness of the pattern</td>
<td>Move the Softness slider to the left to decrease the softness, or move it to the right to increase the softness.</td>
</tr>
<tr>
<td>Change the direction from which you view the fractal</td>
<td>Move the Angle slider to the left to decrease the angle, or move it to the right to increase the angle.</td>
</tr>
<tr>
<td>Create a more linear pattern by emphasizing the direction suggested by the lines of the fractal pattern</td>
<td>Move the Thinness slider to the left to increase the appearance of lines, or move it to the right to decrease the appearance of lines.</td>
</tr>
</tbody>
</table>

3. In the Size area, enable the option that corresponds to the size of the tile that you want to create.
4. From the Channel list box, choose one of the following options:
   - Height as Luminance — displays pseudo-height information as luminance. White areas are represented as peaks, and dark areas become depressions. Images generated with this option can be used with the Apply Surface Texture effect.
   - Gradient Bearing — uses the Red channel to display the bearing of the down angle of a height field.
   - Surface Normal — uses the Green and Blue channels to represent the X and Y components of the surface normal (angle perpendicular to the surface at a given point) of the height field (Green=X, Blue=Y).
5. Click OK. Creating the new pattern may take some time. When the pattern file is ready, it appears in a new document window.
6. In the Patterns panel, click the Capture Pattern button.
7. In the Capture Pattern dialog box, type a name in the Name box.
The Gradient Bearing and Surface Normal options for viewing a fractal texture are offered for purely aesthetic reasons. One way to take advantage of them is to create color variations of the texture with the Adjust Colors feature.

To colorize a fractal pattern, you can replace the grayscale tones with colors from a gradient fill by using the Express in Image feature. For information, see “To replace image colors with gradient colors” on page 749.

To convert a fractal pattern into a paper texture
1. In the Patterns panel (Window ➤ Media Panels ➤ Patterns), choose a pattern.
2. Click the Pattern options button, and choose Check Out Pattern. The fractal pattern is displayed in a new image window.
3. Choose Effects ➤ Tonal Control, and adjust image elements such as brightness, contrast, and luminance. For more information, see “Equalizing images” on page 287.
4. Choose Select ➤ All.
5. In the Papers panel (Window ➤ Media Panels ➤ Papers), click the Capture Paper button.
6. In the Capture Paper dialog box, set the crossfade to 0.
7. Type a name in the Save As box.
Gradients

A gradient is a type of fill that gradually changes from one color to the next, along a linear, radial, circular, or spiral path. Gradient fills are also known as blends or fountain fills.

Gradients were used in this artwork by Aaron Rutten.

You can use gradients to add depth, texture, and realism to your paintings and illustrations.
A gradient is used to add background depth and lighting in this artwork by Manuel Sanz (left), and to add a vignette in this artwork by Eric Holmen (right).

In comic, manga, or anime art, gradients can help artists to quickly color sketches and add visual interest.

A gradient is applied to quickly color the girl’s hair. Artwork by Tricia Flohr.

Corel Painter lets you apply a wide variety of painting styles to gradients to achieve interesting artistic and painterly effects.

Start a painting by filling the background with a gradient and experimenting with different preset styles.

Corel Painter offers a wide selection of preset gradients, but you can also create gradients.

This section contains the following topics:

- “Applying gradients” (page 737)
- “Editing gradients” (page 740)
Applying gradients

Corel Painter allows you to apply a gradient to an image by filling an area, such as the canvas, a selection, layer, or channel. For more information, see “Selections and transformations” on page 619, “Layers” on page 569, and “Alpha Channels” on page 609.

Before you apply a gradient, you can specify the gradient type, padding, opacity, size, and the direction of the gradient color blend by using the controls on the property bar.

You can also use merge modes to create a wide range of colorful effects. Merge modes let you specify how a gradient blends with the underlying image. For detailed information about merge modes, see “Blending layers by using composite methods” on page 594.

After you draw a gradient, you can modify its appearance interactively in the image window. For more information, see “Editing gradients” on page 740.
You can edit a gradient preset before you apply it. For more information, see “To edit a gradient preset” on page 742.

You can also paint with a gradient by using a brush and dab type that support gradient painting. For more information, see “General controls: Dab types” on page 378. Painting with gradients does not support gradient node transparency.

To apply a gradient

1. Click the **Interactive Gradient** tool in the toolbox.
2. Click the **Preset** flyout button on the property bar, and click a gradient fill thumbnail in the **Painter Gradients** area.
   - Tip: You can load alternate libraries of gradients to increase your choices. For more information about working with libraries, see “Working with libraries” on page 87.
3. Choose settings from the property bar. For more information, see “To set gradient options” on page 738.
4. Perform a task from the following table:

To apply a gradient to

<table>
<thead>
<tr>
<th>The canvas</th>
<th>Do the following to set the gradient scale and direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>A selection</td>
<td>Click and drag inside the selection.</td>
</tr>
<tr>
<td>A layer</td>
<td>Select a layer in the <strong>Layers</strong> panel. Click and drag on the layer.</td>
</tr>
<tr>
<td>A channel</td>
<td>Select a channel in the <strong>Channels</strong> panel. Click and drag on the channel.</td>
</tr>
</tbody>
</table>

   - Tip: To snap the gradient line to the horizontal, vertical, or diagonal axis, hold down **Shift** key while you drag.
5. Double-click anywhere outside the gradient.
   - If the **Edit nodes** option on the property bar is not enabled, the gradient is applied automatically when you lift the stylus or release the mouse button.
   - If the **Edit nodes** option on the property bar is enabled, the gradient is applied only after you double-click outside the gradient or click the **Commit Gradient** button on the property bar.

Once you commit a gradient, it can no longer be edited.

To discard a gradient before you have committed it, click the **Discard Gradient** button on the property bar.

To remove a gradient from your document after you have committed the gradient, click **Edit ➤ Undo Gradient Fill**.

You can also choose a gradient by choosing **Window ➤ Media Panels ➤ Gradients**, and clicking a gradient in the **Painter Gradients** area.

You can also apply a gradient by choosing the **Paint Bucket** tool in the toolbox, choosing **Gradient** from the Fill list box on the property bar, and then clicking the selected area, layer, or channel.

To set gradient options

- Perform a task from the following table.
To

Choose a gradient type

Do the following

Click one of the following buttons on the property bar:

• Linear Gradient
• Radial Gradient
• Circular Gradient
• Spiral Gradient

Tip: You can also set the gradient type by choosing Window ➤ Media Panels ➤ Gradients, clicking a gradient in the Painter Gradients area, and choosing a gradient type.

Set the gradient padding

Click the Padding flyout button on the property bar, and choose one of the following options:

• Extend — lets you fill the document or selection by extending the color of the start and end nodes
• Mirror — lets you fill the document or selection by mirroring a gradient on either side of the start and end nodes (applies only to liner gradients)
• Repeat — lets you fill the document or selection by repeating a gradient on either side of the start and end nodes

Set the gradient opacity

On the property bar, move the Opacity slider, or type a percentage in the Opacity box.

Set the direction of a gradient

Click the Preset flyout button on the property bar, and click Gradients panel. Click one of the gradient order buttons:

• Left to Right Gradient
• Right to Left Gradient

Tip: You can also reverse the order of colors in the gradient by clicking the Reverse Gradient Direction button on the property bar.

Specify how a gradient blends with the underlying image

Choose a merge mode from the Merge Mode list box on the property bar. For a detailed explanation of merge modes, see “Blending layers by using composite methods” on page 594.

To paint with a gradient

1 Click Window ➤ Media Panels ➤ Gradients.
2 In the Painter Gradients area, click a gradient fill thumbnail.
3 Click the Brush Selector on the Brush Selector bar.
4 In the Brush library panel, click a brush category, and a brush variant that supports gradients.
If the Source pop-up menu in the General controls panel is not available (appears gray), the selected brush category or variant does not support gradients. For example, the Pattern Pens brush category supports gradients.

5 In the General controls panel, choose a dab type from the Dab Type pop-up menu. If the Source pop-up menu in the General controls panel is not available (appears gray), the selected dab type does not support gradients. For example, the Line Airbrush, Projected, and Rendered dab types support gradients.

6 From the Source pop-up menu in the General controls panel, choose one of the following options:
   • Gradient — applies the current gradient across the width of the stroke
   • Gradient Repeat — repeats the current gradient along the length of the stroke

7 Paint in the document window.

![Painting with a gradient by using Gradient (left) and Gradient Repeat (right)](image)

Brushes using gradients ignore gradient node transparency.

When painting with a gradient, only the Linear gradient type is supported.

Direction matters when you paint with a gradient. Corel Painter flips the gradient when you change direction. To achieve a uniform effect, apply strokes in the same direction.

**Editing gradients**

After you draw a gradient with the Interactive Gradient tool, you can edit it in the document window. An interactive gradient control appears, which marks the transition from one color to another. The direction and size of the gradient depend on where you first click in the document window, the distance that you drag, and the direction in which you drag. Each color in the gradient fill is represented by a square node on the interactive gradient control. You can modify the gradient appearance by repositioning nodes, adding and removing nodes, and changing the color of nodes.

![Change a color, add a new color, or adjust the position and direction of a gradient by editing nodes interactively.](image)

You can edit gradient attributes such as the gradient size, the direction of a gradient’s color blend, the gradient colors, and the gradient’s angle.

You can also edit existing gradient presets or custom gradients before you apply them or save them for future use.
To edit a gradient interactively

1. Click the Interactive Gradient tool in the toolbox.
2. Click the Preset flyout button on the property bar, and click a gradient fill thumbnail.
   Make sure the Edit nodes option on the property bar is enabled.
3. Draw a gradient.
4. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the size of a gradient</td>
<td>Drag the start or end node on the interactive gradient control.</td>
</tr>
<tr>
<td>Adjust the position of a gradient</td>
<td>To set where you want the gradient to start, drag the start handle. To set where you want the gradient to end, drag the end handle. Tip: To snap the gradient line to the horizontal, vertical, or diagonal axis, hold down Shift key while you drag.</td>
</tr>
<tr>
<td>Change the direction of a gradient fill</td>
<td>Drag the end node in the opposite direction. Tip: You can also reverse the order of colors in the gradient by clicking the Reverse Gradient Direction button on the property bar.</td>
</tr>
<tr>
<td>Adjust the angle of a gradient</td>
<td>Drag the end node.</td>
</tr>
<tr>
<td>Change a color</td>
<td>Click a node, click the Color chip, and choose a color in the color picker. Tip: You can also change the color by clicking a node, clicking the Gradient Node panel toggle button on the property bar, clicking the Color Selector in the Gradient Node panel, and choosing a color.</td>
</tr>
<tr>
<td>Add a color</td>
<td>Click anywhere along the interactive gradient control, click the Color chip, and choose a color in the color picker. Tip: You can also add a color by clicking anywhere along the interactive gradient control, clicking the Gradient Node panel toggle button on the property bar, clicking the Color Selector in the Gradient Node panel, and choosing a color.</td>
</tr>
<tr>
<td>Delete a color</td>
<td>Click a node. Click the Gradient Node panel toggle button on the property bar. In the Gradient Node panel, click Delete Node. Note: You cannot delete an end node.</td>
</tr>
</tbody>
</table>
To Do the following

Set the transparency of a color

Click a node. Click the Gradient Node panel toggle button on the property bar. In the Gradient Node panel, move the Opacity slider or enter a value in the box.

Specify the position of an intermediate node relative to the first and the last nodes

Click a node. Click the Gradient Node panel toggle button on the property bar. In the Gradient Node panel, move the Position slider or enter a value in the box.

To edit a gradient preset

1 In the Gradient Libraries panel (Window ➤ Media Panels ➤ Gradients), choose a preset.
2 Click the Edit Gradient button.
3 In the Edit Gradient dialog box, perform a task from the following table.

To Do the following

Add a color

Click in the color ramp bar where you want to add a color, click the Color chip, and choose a color in the color picker.

![New color node](image)

_A new color was added to the gradient by adding a node to the color ramp bar._

Delete a color

Click a node in the color ramp bar, and click Delete Node.

![Nodes](image)

Modify the color transition

Drag a node in the color ramp bar.

Set the transparency of a color

Click a node in the color ramp bar and move the Opacity slider.

Blend the gradient colors

Disable the Linear check box and drag the Color Spread slider to control the color smoothness at each node.
To specify how colors blend between two nodes

Do the following

Click a square box above the color ramp bar.

Select one of the following options in the Color Blend Method area:

- **RGB** — blends the red, green, and blue components of the two colors
- **Clockwise around the color wheel** — blends the end node colors along a clockwise path around the color wheel
- **Counterclockwise around the color wheel** — blends the end node colors along a counterclockwise path around the color wheel

Tip: To understand this concept better, refer to the standard display of the Color panel (Hue Ring and Saturation/Value Triangle), and note the order of the colors on the Hue Ring.

Create a node that is set to the current color

Press Option + click (macOS) or Alt + click (Windows) in the color ramp bar.

4 In the Gradients panel (Window ➤ Media Panels ➤ Gradients), click the Gradient options button and choose Save Gradient.

5 In the Save Gradient dialog box, enter a name for the gradient.

You can also

Modify the appearance of a spiral gradient

Click the Preset flyout button on the property bar, and click Gradients Panel to display the Gradients panel. Click the Spiral Gradient button in the Type area, and do any of the following:

- Drag the Spiral Rate slider to the right or left to increase or decrease the spiral tension.
- Enable the Invert Spiral check box.
Adjust the angle of a gradient

Drag the **Ramp Angle** slider or type an angle in the corresponding numeric value box.

**Applying paint effects to gradients**

You can apply different paint styles to gradients created with the **Interactive Gradient** tool.
Different paint styles were applied to the gradients used in these images. (Top) Artwork by Fiona Sansom. (Bottom) Artwork by Greg Newman.

You can preview a paint effect before committing a gradient. If you have experimented with the preset gradient auto-painting styles and you know which style you want to apply, you can quickly draw and commit the gradient without previewing the paint effect.

To apply a paint effect to a gradient

1. Click the Interactive Gradient tool in the toolbox.
2. Click the Preset flyout button on the property bar, and choose a gradient.
3. Choose settings from the property bar.
Make sure the **Edit nodes** option on the property bar is enabled.

4 Perform a task from the following table:

<table>
<thead>
<tr>
<th>To apply a gradient to</th>
<th>Do the following to set the gradient scale and direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>The canvas</td>
<td>Click and drag on the canvas.</td>
</tr>
<tr>
<td>A selection</td>
<td>Click and drag inside the selection.</td>
</tr>
<tr>
<td>A layer</td>
<td>Select a layer in the <strong>Layers</strong> panel. Click and drag on the layer.</td>
</tr>
<tr>
<td>A channel</td>
<td>Select a channel in the <strong>Channels</strong> panel. Click and drag on the channel.</td>
</tr>
</tbody>
</table>

5 Click the **Express Paint** button on the property bar and choose an auto-painting style.
   To preview the paint effect in the image window, enable the **Preview Effect** option.
   To change the size of the brushstrokes that the paint effect will apply, move the **Size** slider.
   To set the number of the brushstrokes that the paint effect will apply, move the **Amount** slider. The smaller the size, the more brushstrokes you need to render the entire gradient.

6 Click the **Commit Gradient** button on the property bar.

If you choose a very small size and amount, the brushstrokes may cover only part of the gradient, especially on a very large canvas. When you apply a paint effect to a small selection, you may need to lower the size and amount of brushstrokes to achieve the result you want.
   The smaller the brushstroke size, the longer it takes to apply the paint effect.
   You can apply a paint effect only to a gradient that you draw with the **Interactive Gradient** tool.

To stop the auto-painting at any time, click in the document window.

To quickly draw and commit a gradient without previewing a paint effect, click the **Interactive Gradient** tool in the toolbox, click the **Preset** flyout button on the property bar, and choose a gradient. Disable the **Edit nodes** option on the property bar, click the **Express Paint** button on the property bar, choose an auto-painting style, and then draw the gradient. The paint effect will be applied automatically as you lift the stylus to commit the gradient.

**Creating gradients**

Although Corel Painter comes with preset gradients, you can create custom gradients.

You can create from very simple to very complex gradients. For a simple two-point gradient, you choose a main and an additional color, and then Corel Painter generates the gradient colors between them.
You can also create a new gradient by editing an existing gradient. For information, see “To edit a gradient preset” on page 742.

You can use any existing image as a source for creating new gradients. For example, you can capture the colors in a photo of a sunset, or paint your own range of colors as the content of a gradient.

To create a perfect blend between a series of colors, it is better to work with a row of single pixels than a large piece of an image.

You can save your custom gradients in the Gradient Library so you can use them in future projects. When you save a gradient, it is stored in a library. For more information about working with libraries, see ”Working with libraries” on page 87.
All gradients are stored in the Painter Gradients library, which is accessible from the Media Selector bar.

To create a two-point gradient

1. In the **Color** panel (Window ➔ Color Panels ➔ Color Panel (Full View)), click the **Main Color** (front) swatch, and choose a main color.

2. Click the **Additional Color** (back) swatch, and choose an additional color.

3. In the **Gradients** panel (Window ➔ Media Panels ➔ Gradients), choose **Main to Additional Color** in the Painter Gradients area.

4. Click the Gradient options button, and choose **Save Gradient**.

5. In the **Save Gradient** dialog box, type a name for the gradient in the **Save as** box.

To create a gradient from an image

1. Click the **Rectangular Selection** tool in the toolbox.

2. Drag in the document window to select a horizontal or vertical area, making the selection as narrow as possible. If the selection is horizontal, Corel Painter creates the gradient from the first row of pixels starting at the upper left. If the selection is vertical, Corel Painter creates the gradient from the first column of pixels, starting at the upper left.

3. In the **Gradients** panel (Window ➔ Media Panels ➔ Gradients), click the Gradient options button, and choose **Capture Gradient**.

4. In the **Capture Gradient** dialog box, type a name for the gradient in the **Save as** box. The new gradient is saved in the current library. In the future, you can choose it by name from the **Gradients** panel.

   After a gradient is captured, it can no longer be edited. To change a captured gradient, change the artwork from which it was captured, and then recapture the gradient.
Replacing image colors with gradient colors

You can replace an image’s colors with those of a gradient. This effect applies gradient colors to the pixels of the image, based on their luminance values. For more information, see “Using image luminance to create texture” on page 680.

You can choose an image (left) and replace its colors with the colors of a selected gradient (right).

To replace image colors with gradient colors

1. Open the image that you want to use.
   - Select part of the image, or use the entire image.
2. In the Gradients panel (Window ➤ Media Panels ➤ Gradients), choose a gradient in the Painter Gradients area.
3. Click the Gradient options button ✦, and choose Express In Image.
4. In the Express In Image dialog box, adjust the Bias slider to define how the gradient is mapped.
   - Corel Painter replaces the colors in the image with the colors in the gradient, based on matching luminance.
Mosaics and tessellations

Mosaic is a decorative art technique that involves creating images by assembling colored tiles and setting them on a surface by using grout. A tessellation is also a form of mosaic that involves repeating a geometric shape, without overlaps, to create an image. In Corel Painter, you create images by using mosaic or tessellation effects.

When you create a mosaic in Corel Painter, it’s similar to applying color by using brushstrokes, however, instead of applying paint to the canvas, you’re laying down tiles. You can create a mosaic from scratch or from an existing photo by using a clone source. You can also integrate mosaic effects in an existing image.

You can erase and/or reshape tiles to create the perfect mosaic design.

You can apply tiles to the canvas to create a mosaic.

You can use the tessellation technique to generate a mosaic that resembles stained glass. Tessellating divides your image into polygonal shapes and then converts the shapes into tiles.
You can use the tessellation technique to create a stained-glass effect.

You can alter the appearance of mosaics and tessellations in many ways. For example, you can give a three-dimensional (3D) appearance to mosaics or add points to tessellations to increase the number of shapes.

This section contains the following topics:
- “Creating a mosaic” (page 752)
- “Selecting and removing tiles” (page 754)
- “Specifying tile and grout color” (page 755)
- “Adjusting mosaic tile dimensions and randomness” (page 756)
- “Filling an area with tiles” (page 759)
- “Creating 3D tiles” (page 760)
- “Re-rendering mosaic tiles” (page 761)
- “Stroking and filling a selection with mosaic tiles” (page 761)
- “Adding mosaic effects to an image” (page 762)
- “Creating tessellations” (page 763)

Creating a mosaic

You can create a mosaic from scratch or from a clone source. When you create a mosaic, it is applied directly to the canvas. You cannot apply mosaic tiles inside a layer.

After you exit the Mosaic and Tessellation dialog box, you can treat this rendered image just like any photograph or painting. You can paint it, apply effects to it, select portions of it, or increase the canvas size. You can also integrate mosaic effects into an existing image. For information, see “Adding mosaic effects to an image” on page 762.

After you apply tiles to a mosaic, you can select, deselect, or remove tiles to change their color or apply effects to them. For information, see “Selecting and removing tiles” on page 754 and “Specifying tile and grout color” on page 755.

When creating mosaics from scratch, you can follow these helpful guidelines:
- Use your first few courses of mosaic tiles to delineate the most important contours of your subject — just as if you were drawing with a pencil. Describe the most important lines of your scene first. Additional courses of tiles should follow the initial contours.
To create a mosaic from scratch

2. Choose Effects ➤ Esoterica ➤ Make Mosaic and Tessellation.
3. Click the Grout color chip, and choose a color.
4. Click the Tile color chip, and choose a color.
5. Drag in the document window to apply tiles.
6. If you want to continue working on the mosaic, keep the Mosaic and Tessellation dialog box open.
For more information about changing the grout and tile color, see "Specifying tile and grout color" on page 755.

You can also change tile dimensions and shape. For more information, see "Adjusting mosaic tile dimensions and randomness" on page 756.

You can also specify that Corel Painter automatically fill an area with tiles by choosing Stroke/Fill Selection from the Action list box in the Mosaic and Tessellation dialog box. For more information, see "Stroking and filling a selection with mosaic tiles" on page 761.

To create a mosaic from a clone source

1. Choose File ▶ Open, and locate the file that you want to clone.
2. Choose File ▶ Quick Clone.
3. Choose Effects ▶ Esoterica ▶ Make Mosaic and Tessellation.
4. In the Mosaic and Tessellation dialog box, choose Apply Tiles from the Action list box.
   - If you don’t want to work with tracing paper, disable the Use tracing paper check box.
5. Enable the Clone color check box.
6. Drag in the document window to apply tiles.
   - If you want to continue working on the mosaic, keep the Mosaic and Tessellation dialog box open.

You can monitor the progress of the clone-based mosaic by viewing the image with the Use tracing paper check box enabled. This lets you see a faded out version of the clone source.

Selecting and removing tiles

You can select and deselect tiles so you can add or modify them. You can also remove individual tiles, a selection of tiles, or remove all tiles from the document at once. If you remove all tiles from the document, Corel Painter clears the canvas, leaving only the grout color.

Similar to working with real ceramic tiles, you cannot merge or overlap Corel Painter mosaic tiles. You can place them close to each other, but you can’t make them occupy the same space. Corel Painter adjusts the shape of the tiles to fit them close to one another while maintaining the grout line spacing. So, when you want to re-lay the tiles in an area, you must remove the existing tiles.

To select tiles

1. In the Mosaic and Tessellation dialog box, choose Select Tiles from the Action list box.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select tiles</td>
<td>Drag across the tiles you want to select. Red borders appear on selected tiles.</td>
</tr>
<tr>
<td>Select contiguous tiles of the same color (no variability allowed)</td>
<td>Press Command + Control (macOS), or Ctrl (Windows), and drag across part of a line of tiles, so that the whole line of tiles is selected. A magic wand appears as you select the tiles.</td>
</tr>
</tbody>
</table>
To

Select all tiles

Do the following

Click Select All Tiles, or press the A key.

To deselect tiles

1. In the Mosaic and Tessellation dialog box, choose Select Tiles from the Action list box.
2. Perform a task from the following table.

To

Deselect an individual tile

Do the following

Click on a tile that is already selected to deselect it.

Deselect all tiles

Click Deselect All Tiles, or press the D key.

To remove tiles

To

Remove specific tiles

Do the following

In the Mosaic and Tessellation dialog box, choose Remove Tiles from the Action list box. Click or drag across the tiles you want to remove.

Remove all tiles

In the Mosaic and Tessellation dialog box, click Clear.

Specifying tile and grout color

When creating a mosaic from scratch, you can adjust the tile color by adjusting the value, hue, or randomize color variability to build visual interest. You can adjust the color for individual tiles or for larger areas across the mosaic. The tile color is determined by the main color selected in the Colors panel.

If you’re creating a mosaic from a clone source, the tiles are based on the clone source colors. For more information, see “To create a mosaic from a clone source” on page 754.

Normally, each tile is given a single color. If you want more options for coloring tiles, render the tiles to a channel. You can then convert the channel to a selection to paint directly on the tiles, apply effects, or fill them with a pattern, weave, gradient, or image. For more information, see “Creating 3D tiles” on page 760.

In a mosaic, any area that is not covered by tiles is considered grout. A default grout color is assigned to the mosaic background when you begin working, but you can change the color.

To change the color of selected tiles

1. Choose Effects ➤ Esoterica ➤ Make Mosaic and Tessellation.
2. In the Mosaic and Tessellation dialog box, choose Select Tiles from the Action list box.
3. Click or drag across the tiles you want to select.
4. Red borders appear on selected tiles.
5. Choose a color from the Color panel.
6. Press one of the following keys to apply the described color change to the selected tiles:
• C (Color) — changes the tiles to the current main color
• T (Tint) — applies a small amount (10%) of the current main color. Repeat to accentuate.
• V (Vary) — adds color variability, based the settings in Brush Controls Panels ➤ Color Variability

To change tile color individually
1 In the Mosaic and Tessellation dialog box, choose Change Tile Color from the Action list box.
2 Enable one of the following color adjustment options:
   • Color — changes the tiles to the current main color. You can click the Color chip and choose another color.
   • Darken — applies a small amount of black
   • Lighten — applies a small amount of white
   • Tint — applies a small amount (10%) of the current main color
   • Vary — adds color variability based on the settings in Brush Controls Panels ➤ Color Variability.
3 Click individual tiles that you want to change or drag across a group of tiles.

To apply color variability to tiles
1 In the Mosaic and Tessellation dialog box, choose Change Tile Color from the Action list box.
2 In the Color Adjustments area, enable the V (Vary) option.
3 Click Color Variability to display the Color Variability panel.
4 In the Color Variability panel, move the sliders or type values in the boxes to adjust the color variability settings.

To change the grout color
1 In the Mosaic and Tessellation dialog box, choose Apply Tiles from the Action list box.
2 Click the Grout Color chip.
3 Choose a color on the Color panel or the Painter Colors panel that appear.

Changing the grout color automatically re-renders the mosaic, which erases any part of the image that is not a tile or grout.

Adjusting mosaic tile dimensions and randomness
You can change the shape of mosaic tiles by adjusting the tile dimensions and spacing. You can also control the variability of tile shapes by setting the degree of randomness. Increasing randomness makes the shapes more erratic, each different from the last. For example, if the length dimension is 10 pixels, a length randomness of 25% creates tiles that are randomly given a length in the range of 7.5 to 12.5 pixels.

To adjust tile dimensions
1 Choose Effects ➤ Esoterica ➤ Make Mosaic and Tessellation.
2 Choose the Dimensions option from Settings list box.
3 Adjust any of the following dimension sliders:

<table>
<thead>
<tr>
<th>Dimension control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>Sets the width of the tiles in pixels.</td>
</tr>
<tr>
<td></td>
<td>In this example, the width is set to 3.5 pixels (top) and 30.4 pixels (bottom).</td>
</tr>
</tbody>
</table>
Dimension control

Length
Sets the length of the tiles in pixels.
In this example, the length is set to 4.1 pixels (top) and 24.2 pixels (bottom).

Pressure
Determines how tile dimensions are affected by stylus pressure, which allows you to control the width variance under differently weighted strokes.

With the Pressure slider set to zero, a light stroke produces narrow tiles, and a heavier stroke creates wider tiles.

Increasing the Pressure slider also increases the effect of pressure on the width of the tiles and prevents the creation of narrow tiles in response to a light stroke. Setting Pressure to 100% creates uniformly wide tiles, regardless of the pressure.

In this example, the Pressure slider is set to 0% (top) and 100% (bottom).

Grout
Sets the spacing between tiles in pixels.
In this example, the spacing between tiles is 0% (top) and 15% (bottom).
To adjust tile variability

1. Choose Effects ➤ Esoterica ➤ Make Mosaic and Tessellation.
2. Choose the Randomness option from Settings list box.
3. Adjust any of the following dimension controls:

<table>
<thead>
<tr>
<th>Dimension control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width</strong></td>
<td>Allows the tile width to vary by a set percentage. The lowest setting, 0%, produces no variability and the highest setting, 100%, produces the most variability. In this example, Width randomness is set to 92%.</td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>Allows the length of a tile to vary by a set percentage. The lowest setting, 0%, produces no variability and the highest setting, 100%, produces the most variability. In this example, the Length slider is set to 98%.</td>
</tr>
<tr>
<td><strong>Pressure Cut</strong></td>
<td>Controls the variability of the angle of the tile ends. The lowest setting, 0%, produces no variability and the highest setting, 100%, produces the most variability. In this example, the Cut slider is set to 90°.</td>
</tr>
<tr>
<td>Randomness control</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Grout</td>
<td>Controls the variability of the length of space found between tiles. The lowest setting, 0%, produces no variability and the highest setting, 100%, produces the most variability. In this example, the Grout randomness is set to 100%.</td>
</tr>
</tbody>
</table>

**Filling an area with tiles**

You can use different modes to fill an area of a mosaic with tiles. You can use the **Start with triangle** mode to fill a wedge-shaped area by applying a brushstroke that starts with a triangular shaped tile.

*The Start with triangle mode creates a perfect wedge in the "V."

You can use the **Respect edge of image** mode to automatically insert a space at the perimeter of the image so that the tiles you insert at the edge of the image do not pass the edge.
To choose a method for filling an area with tiles

1. Choose Effects ▶ Esoterica ▶ Make Mosaic and Tessellation.
2. In the Options area, enable one or both of the following check boxes:
   - Start with triangle
   - Respect edge of image
3. Drag in the document window to apply tiles.

Creating 3D tiles

You can create mosaics with a 3D appearance by rendering tiles into a mask. This technique places the tile shapes in a new channel named Mosaic Mask (in the Channels panel), which allows you to add depth to the tiles by using surface texture to create a 3D appearance.

With the tiles in a channel, you can also load the mosaic pattern as a selection or you can invert the channel to use the grout as a selection. The result can be particularly interesting when you work with a tessellated mosaic.

To give mosaic tiles a 3D look

1. Choose Effects ▶ Esoterica ▶ Make Mosaic and Tessellation.
2. Drag in the document window to apply tiles.
   When the mosaic is complete, you can proceed to step 3.
3. Choose Render To Mask from the Action list box.
4. Click Render To Mask, and then click OK.
   This action uses tile data to create a new channel in the Channels panel (Window ▶ Channels).
5. Choose Effects ▶ Surface Control ▶ Apply Surface Texture.
6. In the Apply Surface Texture dialog box, choose Mosaic Mask from the Using list box.
Adjust the Amount or Softness sliders to achieve the level of relief that you want. In most cases, the best results are obtained with the Picture slider set at 100%. For more information, see “Using 3D brushstrokes to create texture” on page 679.

Because Corel Painter uses the tile shapes from the channel, the resulting surface texture gives the tiles a realistic 3D appearance.

Re-rendering mosaic tiles

If you increase the dimensions of a document that contains a mosaic, you need to re-render the mosaic to ensure the mosaic resolution matches that of the document. This command re-creates the mosaic from the grout color and the tile object information. Re-rendering fills the image with the grout color and then re-renders the mosaic tiles at the resolution of the document. It is important to note that the re-rendering process erases any image that is not a tile or grout.

To re-render tiles

1. Open an image that is the size you want.
2. Choose Effects ▶ Esoterica ▶ Make Mosaic and Tessellation.
3. Create a mosaic, and click OK.
4. Choose Canvas ▶ Resize.
5. In the Resize dialog box, disable the Constrain File Size check box, and type a higher value in the Width or Height box.

When Corel Painter finishes resizing, you’ll notice that the tiles have blurred. You can correct this problem by re-rendering the mosaic.
7. Click Rebuild.
8. Click OK.

Corel Painter replaces the resized, blurry tiles with tiles rendered at the higher resolution.

After you click Rebuild, Corel Painter erases any part of the image that is not a tile or grout.

Stroking and filling a selection with mosaic tiles

You can stroke or fill path-based selections that were created with the Rectangular Selection, Oval Selection, and Lasso tools with mosaic tiles. If you want to stroke or fill a channel-based selection with mosaic tiles, you need to use the Transform Selection command to convert a channel-based selection to a path-based selection. For more information, see “Getting started with selections” on page 620.

Stroking and filling a selection are appropriate only when you change a parameter between operations — for example, if you change the tile color or dimensions. The Stroke Selection command applies a single row of tiles as an outline along the selection path. To fill an entire selection with tiles, you can make the selection using the Lasso tool. To fill an oval or rectangular selection, you must first use the Stroke Selection command to apply tiles to the selection path, and then use the Fill Selection command to fill the rest of the selection.
To fill an oval or rectangular selection, you must first use the Stroke Selection command to apply tiles to the selection path (left), and then use the Fill Selection command to fill the rest of the selection (right).

To create a mosaic in a selection
1. Set up the area you want to tile as an active selection.
2. Choose Effects ➤ Esoterica ➤ Make Mosaic and Tessellation.
3. In the Mosaic and Tessellation dialog box, choose Dimensions or Randomness from the Settings list box.
4. Choose the color for the tile and the grout.
5. From the Action list box, choose Stroke/Fill Selection.
6. Click one of the following buttons:
   - Stroke Selection — creates one row of tiles along each selection path
   - Fill Selection — applies multiple rows of tiles, working in from the path until the selected area is filled with tiles

The Fill Selection command works with selections made by using the Lasso tool 📐. To fill an oval selection, you must first choose the Stroke Selection command, and then choose the Fill Selection command.

In some cases, Corel Painter might not put a tile in every space. You can fill openings by choosing Apply Tiles from the Action list box and applying the tiles.

If you want to change the tiling of an area, you can use the Remove Tiles action to clear it. Then you can reapply tiles.

Adding mosaic effects to an image

You can add mosaic effects to an image that already contains brushstrokes, layers, or objects. However, because mosaics are applied directly to the canvas, you need to incorporate mosaic effects carefully or you could lose some of the existing content.

When you create a mosaic, the entire canvas is automatically covered with the grout color. This obliterates images that are currently on the canvas, but leaves objects that hover above the canvas, such as layers and shapes. These objects are not deleted, but they do cover up the mosaic that you’re working on.

If you want to incorporate a mosaic with another image, you have several options:
- Using selections — You can add the mosaic effect to a portion of an image by filling a selection with a mosaic effect. For information, see “Stroking and filling a selection with mosaic tiles” on page 761.
- Using multiple documents — You can create the mosaic in its own document. When you’re satisfied with the result, float and copy the mosaic to the document where you want to composite it. For more information, see “Converting selections into layers or floating objects” on page 575.
- Using layers — You cannot add a mosaic to a layer. However, you can float the non-mosaic portion of the image using a layer. Create the mosaic on the canvas and when you’re satisfied with the mosaic, you can drop the layers.
Creating tessellations

A tessellation is a type of mosaic that is made up of nonrectangular tiles. With Corel Painter, you can create a tessellation from scratch or from a clone source. A tessellation that is based on a clone source is a powerful option. The tessellation points are distributed according to the luminance of the clone source. Lighter regions receive a greater density of points, so the shapes are smaller.

You can create a tessellation from a clone source.

A finished tessellation resembles stained glass.

When creating a tessellation, Corel Painter divides the canvas into shapes, such as triangles, cracks, or pieces, which become the mosaic tiles. The shapes themselves are sets of points, connected by line segments. You can control the type of shape, the number of points, and their distribution.

You can base your Tessellation on Triangles, Cracks or Pieces.

You can also add points to a specified area to create a different effect.
Adding points in the shape of a letter. The letters appear as a swath of smaller polygons.

After creating a tessellation, the shapes appear as mosaic tiles that are given the main color and are surrounded by grout lines. You can change the color of the tiles.

To create a tessellation

1. Choose Effects ▶ Esoterica ▶ Make Mosaic and Tessellation.
2. Choose Dimensions from the Settings list box.
3. Move the Grout slider to set the grout line thickness.
4. Click the Grout Color chip, and select a color.
5. Choose Make Tessellation from the Action list box.
6. Choose one of the following tile shapes from the Tile Shape list box.
   - Triangles
   - Cracks
   - Pieces
7. Choose one of the following from the Spacing list box:
• **Even** — generates a tessellation by using evenly-spaced points
• **Random** — generates a tessellation by using random points

Corel Painter forms polygons by connecting the points according to the spacing type.

8 Do one of the following:
• Click **Add 500 Points**, and repeat if necessary.
• Click or drag in the image.

9 Click **Apply**.

If you want to modify the tessellation, choose an action from the **Action** list box.

If you want to clear all tessellation points, click **Clear**.

**To create a tessellation from a clone source**

1 Choose **File ➤ Open**, and locate the file that you want to clone.

2 Choose **File ➤ Quick Clone**.

3 Click the **Clone Color** button 🎨 in the **Color** panel.

   Enabling the **Clone Color** option disables the **Color** panel. This is a reminder that the color information is pulled from the clone source.

4 Choose **Effects ➤ Esoterica ➤ Make Mosaic and Tessellation**.

5 Choose **Make Tessellation** from the **Action** list box.

6 Choose one of the following tile shapes from the **Tile Shape** list box:
   • Triangles
   • Cracks
   • Pieces

7 Choose one of the following from the **Spacing** list box:
   • **Clone** — generates a tessellation by using the clone source. Darker image areas produce a greater density of points.
   • **Inverted Clone** — generates a tessellation by using the clone source. Lighter image areas produce a greater density of points.

8 Do one of the following:
• Click **Add 500 Points**, and repeat if necessary. The points accumulate and the total number of points appears below the **Action** list box.
• Click or drag in the image. You can add higher concentrations of polygons in very specific areas to create specific patterns or shapes.

   If you want to specify the grout thickness, you must do so before creating the tessellation. First, choose **Apply Tiles** from the **Action** list box, and move the **Grout** slider.

   It is possible to create a huge number of points. More points mean more polygons, which increase the time it takes to convert to a mosaic. Keep this in mind to avoid overwhelming your system.

**To color tessellations**

1 In the **Mosaic and Tessellation** dialog box, choose **Change Tile Color** from the **Action** list box.

2 In the **Color Adjustments** area, enable the **Color** option.

3 Click the color chip, and choose a bright main color.
4 Drag to create a stroke in the document, or click individual tiles.

Colored, tessellated tiles appear beneath your stroke.

You can also base the color on the color in a clone source if you enable **Clone Color** in the **Colors** panel.
Weaves

Corel Painter includes an assortment of weave samples that you can apply as fills. On Windows, you can also edit a weave sample to make it your own. In addition, Corel Painter includes a powerful programming language that allows you to draft custom weave patterns from scratch.

Weaves reside in default libraries. You’ll find more libraries, with additional materials, on the Corel Painter DVD and on the Corel Web site. For more information, see “Working with libraries” on page 87.

This section contains the following topics:
- “Applying weaves” (page 767)
- “Editing and saving weaves” (page 768)
- “Creating weave patterns” (page 770)
- “Using the Edit Weave dialog box” (page 770)
- “Defining warp and weft expressions” (page 771)
- “Defining warp and weft color expressions” (page 773)
- “Designing the tie-up” (page 774)
- “Reference: Expression operators” (page 776)

Applying weaves

You can choose a weave from the Weaves panel, or from one of the Weave libraries that are included with Corel Painter, and apply it as a fill. For more information, see “Working with libraries” on page 87.
The Weave Library is accessible from the Media Selector bar.

You can also display a weave as two-dimensional or show the interwoven threads three-dimensionally, complete with shadows.

To apply a weave as a fill

1. Choose Window ➤ Media Panels ➤ Weaves Control Panel.
2. Click the Weave selector, and click a weave in the Painter Weaves library panel.
3. Click one of the following buttons:
   - Two-Dimensional Weave — produces a weave that looks like blocks
   - Three-Dimensional Weave — produces a weave that looks like textured fabric
4. To apply a weave to:
   - The canvas — Click the Canvas in the Layers panel.
   - A selection — Click a selection tool from the toolbox, and drag in the document window to select an area.
   - A layer — Click a layer in the Layers panel.
5. Choose the Paint Bucket tool from the toolbox.
6. In the document window, click the canvas, selection, or layer.

Editing and saving weaves

You can edit a sample weave from the Weaves panel to make it your own. For example, you can scale the weave or modify the thickness of the threads.
After altering the scale, thickness, or color of a weave, you can save the changes as a new weave to the Weaves library for future use. For more information, see “Working with libraries” on page 87.

To adjust weave scaling and thickness

1. Choose Window ➤ Media Panels ➤ Weaves Control Panel.
2. Click the Weave selector, and click a weave in the Painter Weaves library panel.
   The weave appears in the Weave Preview Window.
3. Click the Three-Dimensional Weave button .
   For most weaves, the preview does not change until you adjust the scale and thickness values.
4. Move the Horizontal Scale slider and Vertical Scale slider to the right to increase the scale or to the left to decrease the scale.
5. Move the Horizontal Thickness slider and Vertical Thickness slider to the right to increase the thickness or to the left to decrease the thickness.

   Thickness sliders affect only the three-dimensional display. When you select a two-dimensional display, the thickness sliders have no effect.

To edit weave colors

1. Choose Window ➤ Color Panels ➤ Color Sets.
2. In the Weaves panel (Window ➤ Media Panels ➤ Weaves Control Panel), click the Weave selector, and click a weave on the Painter Weaves library panel.
3. Click the Weave Options button , and choose Get Color Set.
   The color set for the selected weave appears in the Color Set Libraries panel.
4. Click a color on the Color panel.
5. Hold down Command (macOS) or Ctrl (Windows), and then click the color swatch that you want to replace on the Color Set Libraries panel.
6. In the Weaves panel, click the Weave Options button , and choose Put Color Set.
   If you fill an image with the modified weave colors, Corel Painter applies the new color set.

To save a weave

1. In the Weaves panel (Window ➤ Media Panels ➤ Weaves Control Panel), click the Weave options button , and choose Save Weave.
2. In the Save Weave dialog box, type a name for the weave.

   If you want to preserve the default weave, type a new name for the modified weave. If you don’t type a new name, Corel Painter saves the modified weave using the default weave’s name.

   The new weave pattern appears in the current Painter Weaves library.
Creating weave patterns

(Windows only)

Corel Painter lets you create weave patterns to simulate fabrics, such as wallpaper, carpet, clothing, and furniture, using the Edit Weave dialog box combined with the Corel Painter weaving language.

In this section, actual weaving terminology is used so that weavers can become familiar with these techniques more easily.

Introduction to weaving

A weave consists of vertical threads (warp) and horizontal threads (weft) that are interlaced on a loom to form a fabric. Each warp thread is connected to exactly one harness in the loom. The harnesses are connected in a pattern to treadles. Pressing a treadle raises a set of harnesses, lifting the associated warp threads. A weft thread is then passed horizontally through the loom. The particular set of harnesses that are raised determines which warp threads are in front of the weft thread and which are behind. For the next weft thread, a different treadle is pressed, raising a different set of harnesses and, hence, a different set of warp threads.

An example of a simple weave using 1) grey horizontal weft threads and 2) black vertical warp threads

In traditional weaving, you need to follow a draft to create a weave. A draft is a set of instructions for setting up a loom to produce a weave. The draft contains the following details:

• warp threading definition — describes how to set up the loom for threading the vertical threads (number of threads, sequence, and color)
• weft threading definition — describes how to set up the loom for treadling the horizontal threads (number of threads, sequence, and color)
• tie-up — instructs the weaver which of the warp rows to use when weaving a given weft thread

In Corel Painter, the Edit Weave dialog box allows you to draft a weave pattern. For information, see “Using the Edit Weave dialog box” on page 770.

Using the Edit Weave dialog box

(Windows only)

You can draft a weave using the Edit Weave dialog box, which is intended for an 8-harness, 8-treadle loom.
Edit Weave dialog box: The numbers above correspond to the numbers in the following table, which describes the main components of the dialog box.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Warp</td>
<td>The values in the <strong>Warp</strong> area specify the threading sequence of the vertical threads in the weave.</td>
</tr>
<tr>
<td>2. Warp Colors</td>
<td>The values that appear in the <strong>Warp Colors</strong> area control the color and number of vertical threads in the weave.</td>
</tr>
<tr>
<td>3. Weft</td>
<td>The values in the <strong>Weft</strong> area specify the treadling sequence of the horizontal threads in the weave.</td>
</tr>
<tr>
<td>4. Weft Colors</td>
<td>The values that appear in the <strong>Weft Colors</strong> area control the color and number of horizontal threads in the weave.</td>
</tr>
<tr>
<td>5. Tromp as Writ</td>
<td>The <strong>Tromp as Writ</strong> button allows you to copy the warp values and apply them to the weft threads.</td>
</tr>
<tr>
<td>6. Tieup</td>
<td>The <strong>Tieup</strong> area allows you to control the interlacing of the threads by determining which warp rows to use when weaving a weft thread.</td>
</tr>
</tbody>
</table>

To access the Edit Weave dialog box

- In the **Weaves** panel (**Window** ➤ **Media Panels** ➤ **Weaves Control Panel**), click the Weave options button 
  and choose **Edit Weave**.

Defining warp and weft expressions

(Windows only)
The warp and weft expressions use the information in the tie-up to extend and evolve the weave into larger, more complex patterns. For more information, see “Designing the tie-up” on page 774.

Warp and weft expressions in traditional weaving

In traditional weaving, the warp expression represents the threading sequence, in other words, it describes which warp threads are connected to which harnesses. The weft expression is the treadling sequence that determines which treadle is pressed (and therefore which harnesses are raised) for each successive weft thread.

The following table describes which warp threads are connected to which harnesses for the warp sequence 234123:

<table>
<thead>
<tr>
<th>Connect warp thread</th>
<th>To harness</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1</td>
<td>#2</td>
</tr>
<tr>
<td>#2</td>
<td>#3</td>
</tr>
<tr>
<td>#3</td>
<td>#4</td>
</tr>
<tr>
<td>#4</td>
<td>#1</td>
</tr>
<tr>
<td>#5</td>
<td>#2</td>
</tr>
<tr>
<td>#6</td>
<td>#3</td>
</tr>
</tbody>
</table>

The sequence repeats for subsequent threads.

<table>
<thead>
<tr>
<th>Connect warp thread</th>
<th>To harness</th>
</tr>
</thead>
<tbody>
<tr>
<td>#7</td>
<td>#2</td>
</tr>
<tr>
<td>#8</td>
<td>#3</td>
</tr>
<tr>
<td>#9</td>
<td>#4</td>
</tr>
</tbody>
</table>

The threading sequence above, 234123, has a length of 6, which indicates that the pattern runs for 6 threads before repeating.

The following table describes which treadle is pressed (and therefore which harnesses are raised) for each successive weft thread for the weft sequence 654:

<table>
<thead>
<tr>
<th>Press treadle</th>
<th>For weft thread</th>
</tr>
</thead>
<tbody>
<tr>
<td>#6</td>
<td>#1</td>
</tr>
<tr>
<td>#5</td>
<td>#2</td>
</tr>
<tr>
<td>#4</td>
<td>#3</td>
</tr>
</tbody>
</table>

The sequence repeats for subsequent threads.
For weft thread

Press treadle

#6

#5

#4

Warp and weft expressions in Corel Painter

In Corel Painter, you need to use the weave pattern expression language to generate a weave. You may find working with the pattern expression language more logical than working with very complex expanded sequences. For more information see, “Reference: Expression operators” on page 776.

The following table includes an example of a traditional pattern expression expressed in the Corel Painter pattern language.

<table>
<thead>
<tr>
<th>Traditional expression</th>
<th>Pattern language expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>122334444333221</td>
<td>(1-4-1)(1-4-1)</td>
</tr>
</tbody>
</table>

To define a warp or weft expression

- In the Edit Weave dialog box, type an expression in the Warp box.

  As you type a warp or weft sequence, the “Expands to n” message above the panel displays the length n (number of digits) of the expression. This describes the number of threads in the sequence.

  If Corel Painter cannot resolve the expression, the expansion length message displays “!” (error).

If you want to copy the Warp expression to the Weft expression, click the Tromp as Writ (pattern) button.

Defining warp and weft color expressions

(Windows only)

You can use one color for all the warp threads and another for all the weft threads, or you can set up a sequence of colors for each.

When defining thread color sequences using the pattern expression language, you must identify the colors alphabetically. Therefore, you are limited to 26 colors of thread in the weaving.

Using the warp and weft color panels, you can create expressions that describe the color sequences that you want. You can also use any letters that you like and then change the associated color later by modifying the color set. For more information, see “To edit weave colors” on page 769.

The following table includes an example of a simple color sequence expressed in the Corel Painter pattern language.

<table>
<thead>
<tr>
<th>Thread color sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[B 8 D 4]</td>
<td>Use color B for 8 threads, use color D for 4 threads.</td>
</tr>
</tbody>
</table>
To define a warp or weft color expression
• In the Edit Weave dialog box, type an expression in the Warp Colors box.

To display the weave color set
• In the Weaves panel, click the Weave options button, and choose Get Color Set.
  The color set for the selected weave appears in the Color Set Libraries panel in its own color set library.

To display the letter associated with a color set color
1 In the Weaves panel, click the Weave options button, and choose Get Color Set.
2 In the Color Set Libraries panel, click the Color Sets options button, choose Color Set Library View → List.
   Scroll to the newly created color set to view the letters associated with the weave colors.

Designing the tie-up
(Windows only)
The purpose of the tie-up is to describe which of the warp rows to use when weaving a given weft thread. It works in conjunction with the warp and weft expressions to generate the weave pattern.

![Tie-up grid](image)

*The tie-up describes which threads are in front at which point in the weaving process.*

In the Edit Weave dialog box, the tie-up is a grid that measures 8 threads wide by 8 threads high. A black cell indicates that the warp thread should be placed in front of the weft. A white cell indicates that the weft thread should be placed in front of the warp.
In this tie-up, the white cells instruct the weft thread (black) to be placed in front of the warp thread (white) in the weave pattern. Notice that the white cells that are positioned in the fourth row and column cause the weft thread (black) to be more prominent in the weave pattern.

In this tie-up, alternate black cells that are positioned in the fourth row and column instruct the warp thread (white) to be placed in front of the weft thread (black). Notice that the addition of the black cells in the fourth row and column produces a checkerboard effect.

To modify the tie-up
- In the Edit Weave dialog box, click a cell in the grid.
  If you click a white cell, the cell changes to black, which places the warp thread in front of the weft.
  If you click a black cell, the cell changes to white, which places the weft thread in front of the warp.
Reference: Expression operators

You need to learn how to use the weaving pattern language expression operators to effectively draft a weave pattern.

The Weaving Pattern Expression Language is designed around a group of values, called the domain of the pattern. For the warp or weft sequences, the domain is made up of the numbers 1 through 8, which correspond to the harnesses and treadles in the tie-up.

Patterns wrap around on their domain so the number one higher than 8 is actually 1, and the number one lower than 1 is actually 8. This is called modular arithmetic. For example, some are found in the sequences 5678123 or 3218765.

The following table defines a few commonly used terms.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operands</td>
<td>In all examples, the operands used for the operators are numeric sequences. However, the operands may be other patterns created from other operators. In this case, use parentheses to distinguish operands.</td>
</tr>
<tr>
<td>Expansion</td>
<td>Refers to the actual warp or weft numeric sequence created when the expression is translated from the shorthand pattern language.</td>
</tr>
<tr>
<td>Length</td>
<td>Describes the number of elements in the expanded sequence. For example, (1-4-1)(1-4-1) expands to 1223334444333221, which has a length of 16.</td>
</tr>
</tbody>
</table>

**BLOCK**

Operator usage

<pattern> block <count>  

[[]]

The left operand is a sequence of any length. The right operand is a pattern of digit characters for specifying block lengths from 0 to 9.

If either operand is shorter than the other, it is extended (via repeating) to exactly the length of the other operand.

Then, with equal length operands, each element of the left operand is repeated individually by the value of the corresponding digit in the right operand.

The length of the expansion is the sum of the digits in the (possibly lengthened) right operand.

Individual elements of the right operand (lengths) can be replaced by {number} for counts from 1 to 127.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1234 [] 2</td>
<td>11223344</td>
</tr>
<tr>
<td>34512 [23]</td>
<td>334445511122</td>
</tr>
<tr>
<td>12345678 [87654321]</td>
<td>1111111122222233333444445555666778</td>
</tr>
</tbody>
</table>
Example | Expansion
---|---
12 | 123494321
123 | 1{12}3

Block Expressions
Block expressions may be used in an interleaved format. This is particularly useful for color sequences like those used in the Scottish tartan plaids. For example, one of the Drummond color sequences is expressed as follows:

\[ \text{[G \, R \, G \, B \, G \, B \, G \, B \, G \, R \, G \, R \, G \, 8 \, R \, G \, R \, 2 \, G \, 2 \, R \, 5 \, G \, 1 \, 6 \, B \, 2 \, G \, 2 \, B \, 2 \, G \, 3 \, 6 \, R \, 2 \, G \, 2 \, R \, 8 \, |]} \]

**REPEAT**

Operator usage | Short form
---|---
<pattern> repeat <count> | rep, *

The left operand is a pattern of any length. The right operand is an integer count. The expansion is the <pattern> repeated <count> times.

Example | Expansion
---|---
1234567 repeat 3 | 123456712345671234567

**EXTEND**

Operator usage | Short form
---|---
<pattern> extend <count> | ext, ->

The left operand is a pattern of any length. The right operand is an integer that is interpreted as a length. The left operand is reshaped to be the length as specified by the right operand. If the left operand is shorter than the desired length, it is repeated out to the right length. If the left operand is shorter, it is merely trimmed.

Example | Expansion
---|---
123 -> 8 | 12312312
123456787654321 -> 10 | 1234567876

**CAT**

Operator usage | Short form
---|---
<pattern> concat <pattern> | ,

The left and right operands are both patterns of any length. The result is the left operand concatenated with the right operand. Note that when a pattern is spelled out (e.g. 1234), the concat operation is implicit between each of its members (i.e. 1234 is equivalent to 1,2,3,4). The concat operator is used only when needed — for example, to separate parenthetical operands.
**INTERLEAVE**

**Operator usage**

\(<\text{pattern}>\) interleave \(<\text{pattern}>\)

**Short form**

```
int, ~
```

The left and right operands are both patterns of any length. If either operand is shorter than the other, it is extended (via repeating) to exactly the length of the other operand. Then, the operands are interleaved. Interleaving alternates the elements of the left operand with the elements of the right (like lacing your fingers together). The expansion contains the first element of the left, the first element of the right, the second element of the left, the second element of the right, and so on.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>(1-4</td>
<td>), (4-1</td>
</tr>
<tr>
<td>1-8, (1-8 [ ] 2)</td>
<td>123456781122334455667788</td>
</tr>
</tbody>
</table>

**UPTO**

**Operator usage**

\(<\text{pattern}>\) upto \(<\text{pattern}>\)

**Short form**

```
<, -
```

The"-" may be used as an upto operator only when the last element of the left operand is strictly less than the first element of the right operand.

The left and right operands are both patterns of any length.

The expansion is the left operand concatenated with the sequence between the last element of the left operand and the first element of the right operand, concatenated with the rest of the right operand.

Upto wraps around on the domain. For example, 7 upto 2 expands to 7812.

The upto operator may be followed immediately (with no intervening characters) by any number of tick marks (` ' ). A tick mark indicates to cycle through the domain before running up to the right operand. The number of tick marks sets the number of cycles.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-8</td>
<td>12345678</td>
</tr>
<tr>
<td>1-''5</td>
<td>123456781234567812345</td>
</tr>
</tbody>
</table>
**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>123-765</td>
<td>123456765</td>
</tr>
<tr>
<td>2&lt;1</td>
<td>23456781</td>
</tr>
<tr>
<td>13 upto' 5812</td>
<td>13456781234567812345812</td>
</tr>
</tbody>
</table>

**DOWNTO**

**Operator usage**

<pattern> extend <count>

**Short form**

ext, ->

**Operator usage:** <pattern> downto <pattern>  **Short form:** >, -

The “..” may be used as a downto operator only when the last element of the left operand is strictly greater than the first element of the right operand.

The left and right operands are both patterns of any length.

The expansion is the left operand concatenated with the descending sequence between the last element of the left operand and the first element of the right operand, concatenated with the rest of the right operand.

Downto wraps around on the domain. For example, 2 downto 7 expands to 2187.

The downto operator may be followed immediately (with no intervening characters) by any number of tick marks (‘`). A tick mark indicates to cycle through the domain before running down to the right operand. The number of tick marks sets the number of cycles.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>8-1</td>
<td>87654321</td>
</tr>
<tr>
<td>1-8-1</td>
<td>123456787654321</td>
</tr>
<tr>
<td>5``1</td>
<td>543218765432187654321</td>
</tr>
<tr>
<td>567-321</td>
<td>567654321</td>
</tr>
<tr>
<td>2&gt;1</td>
<td>21</td>
</tr>
<tr>
<td>13 downto`` 5812</td>
<td>132187654321876543218765812</td>
</tr>
</tbody>
</table>

**TEMPLATE**

**Operator usage**

<pattern> template <pattern>

**Short form**

temp, :

The right and left operands are patterns of any length.
Template allows texturing (sub-articulation) of a master pattern (the left operand) with a texture pattern (the right operand).

The first element of the template is taken as the root. All other elements in the template sequence are considered with respect to their difference from the root. For example, if 342 is the template pattern, the first element (3) is the root (r). The second element (4) is r+1, and the third element (2) is r-1. The template is then r, r+1, r-1.

This template is then applied to each element in the left operand, with the element’s value replacing the root.

Remember that the values wrap around on the domain.

<table>
<thead>
<tr>
<th>Example</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-8 temp 121</td>
<td>121232343454565676787818</td>
</tr>
<tr>
<td>1-8 : 12121</td>
<td>121212323434545656767878781818</td>
</tr>
<tr>
<td>12321 temp 878</td>
<td>878181212181878</td>
</tr>
<tr>
<td>12321 : 3</td>
<td>34543</td>
</tr>
</tbody>
</table>

PALINDROME

Operator usage

<pattern> palindrom e

This operator takes only one operand, the left operand. That operand can be a pattern of any length. The resultant expansion is the left operand concatenated with itself backwards. However, the center element is not repeated, and the last element of the result is dropped automatically. This is essential when the palindromed sequence is repeated and helps to remove flaws from a weaving draft.

A palindrome word is the same, spelled backwards or forwards, like “madam.”

<table>
<thead>
<tr>
<th>Example</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-8</td>
<td>12345678765432</td>
</tr>
<tr>
<td>1223334444555</td>
<td>122333444455555444433322</td>
</tr>
</tbody>
</table>

PERMUTE

Operator usage

<pattern> permute <permutation>

The left operand is a pattern of any length. The right operand is a permutation vector.

The left operand is extended to a length that is an integer multiple of the right operand’s length.

Then the left operand is permuted in chunks of the right operand’s length. The organization of the permutation pattern is used to reorganize the elements in each chunk of the pattern.
For example, a permutation of 312 puts “the third element first, the first element second and the second element third.”

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>123456787654321 permute 312</td>
<td>312645778465132</td>
</tr>
<tr>
<td>1-8 perm 1324</td>
<td>13245768</td>
</tr>
</tbody>
</table>

**PBOX**

**Operator usage**

\(<\text{pattern}\> \text{ pbox } <\text{permutation}>\)

The left operand is a pattern of any length. The right operand is a permutation vector. Its length will be adjusted, if necessary, (by trimming or repeating) to equal the length of the left operand.

Then, the organization of the permutation pattern is used to reorganize the elements of the pattern.

Pbox maintains the length of the left operand pattern.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>123456787654321 pbox 21436587</td>
<td>214365878563412</td>
</tr>
<tr>
<td>1-8 pbox 4-18-5</td>
<td>4321876543218765</td>
</tr>
</tbody>
</table>

**UPDOWN**

**Operator usage**

\(<\text{pattern}\> \text{ updown } <\text{pattern}>\)

The left and right operands are both patterns of any length. If either operand is shorter than the other, it is extended (via repeating) to exactly the length of the other operand.

Then, UPDOWN generates alternating ascending and descending runs. An odd number of runs is always generated. The expansion contains the ascending run from the first element of the left operand to the first element of the right operand, followed by the descending run from there to the second element of the first operand, etc. The operation is complete with the ascending run from the last element of the left operand to the last element of the right operand.

The updown operator may be followed immediately (with no intervening characters) by any number of tick marks (‘’). A tick mark indicates to cycle through the domain before completing the up and down runs. The number of tick marks sets the number of cycles.

**Example**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Expansion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1234 updown 5678</td>
<td>12345432345654345676545678</td>
</tr>
<tr>
<td>12 ‘’’ 567</td>
<td>123456781234543218765432345678123456543218765432123456781234567</td>
</tr>
</tbody>
</table>
DOWNUP

Operator usage

Short form

<pattern> downup <pattern>  
> <

The left and right operands are both patterns of any length. If either operand is shorter than the other, it is extended (via repeating) to exactly the length of the other operand.

Then, DOWNUP generates alternating descending and ascending runs. An odd number of runs is always generated. The expansion contains the descending run from the first element of the left operand to the first element of the right operand, followed by the ascending run from there to the second element of the first operand, etc. The operation is complete with the descending run from the last element of the left operand to the last element of the right operand.

The downup operator may be followed immediately (with no intervening characters) by any number of tick marks ('). A tick mark indicates to cycle through the domain before completing the up and down runs. The number of tick marks sets the number of cycles.

Example

Expansion

1234 downup 5678  
18765678121876781232187812343218

12 >< 567  
18765432187656781234567812187654321876781234567818765432187

ROTATE

Operator usage

Short form

<pattern> rotate <number>  
rot, #

The left operand is a pattern of any length. The right operand is an integer (which may be negative) that is interpreted as a length. Rotate takes the set of elements specified by <number> from the start of the pattern and moves them to the end. A negative number takes a set of elements from the end of the pattern and moves them to the beginning.

Example

Expansion

12345678 rotate 3  
45678123

1-4-1 rotate -3  
3211234

REVERSE

Operator usage

Short form

<pattern> reverse  
rev,`

This operator takes only one operand, the left operand. That operand may be a pattern of any length. The resulting expansion is the left operand written backwards.
Example | Expansion
---|---
1-8 reverse | 87654321
1223334444555 | 5554444333222

**Precedence Ordering**

When several operators are used in an expression, they are evaluated in order of precedence. That is, some operations are performed before others. The precedence levels for the pattern language are shown in the following:

- upto, downto, concat
- downup, updown
- repeat, extend, template, interleave,
- permute, pbox
- palindrome

When two operators have the same precedence, left to right ordering is followed.

Example | Interpreted as
---|---
1-4-2 | (((1 upto 4) downto 2))
1234[,]4321 | (((1234 block 4321) palindrome))
1-4 block 4-1 | (((1 upto 4) block (4 upto 1)))
(1-4,),4-1 | (((((1 upto 4) palindrome) concat ((4 upto 1) palindrome)) palindrome))

- If precedence does the wrong thing, or if it is unclear, use parentheses to bring out the intended order of evaluation.
Shapes

Shapes are vector-based objects that you can draw, modify, and fill. They can be open shapes, such as lines and curves, or closed shapes, such as circles and squares. You can create and edit shapes with the precision of a drawing program and integrate them with the Natural-Media environment in Corel Painter.

For information about printing shapes, see “Printing shapes” on page 842.

This section contains the following topics:

Creating shapes
• “Getting started with shapes” (page 786)
• “Drawing shapes” (page 786)
• “Drawing lines and curves” (page 788)
• “Setting preferences for drawing shapes” (page 791)

Selecting and modifying shapes
• “Selecting a shape” (page 793)
• “Modifying shape outlines and fills” (page 793)
• “Adding, deleting, and moving anchor points” (page 795)
• “Adjusting curvature” (page 797)
• “Cutting and joining shape segments” (page 798)

Converting shapes
• “Converting shapes to image layers” (page 800)
• “Converting selections to shapes” (page 800)
Transforming shapes
- “Resizing, rotating, skewing, and flipping shapes” (page 801)
- “Duplicating shapes” (page 803)
- “Combining shapes” (page 803)
- “Blending shapes” (page 804)
- “Saving a shape outline as a selection” (page 806)

Sharing shapes
- “Exporting Adobe Illustrator shapes” (page 806)

Getting started with shapes
In Corel Painter, you work mainly with bitmaps, also known as raster images. Shapes, however, are vector objects. You can work with them in Corel Painter in much the same way you work with vector objects in drawing programs like CorelDRAW® and Adobe Illustrator. For more information, see “Exporting Adobe Illustrator shapes” on page 806. Vector graphics are made up of lines, curves, objects, and fills that are all calculated mathematically.

Corel Painter draws shapes in an anti-aliased fashion. This anti-aliasing gives objects a smooth edge, as opposed to the jagged edges apparent in some drawing programs. Some clipart objects actually look like photographic elements when they are imported into Corel Painter and displayed with anti-aliasing.

Anti-aliased shapes are typically slower to appear on the screen in Corel Painter than are aliased objects in drawing programs, so you may want to use your drawing program for most of your object creation. You can then import the vector artwork into Corel Painter, tweak it with the drawing tools, and add some Natural-Media effects.

When you create a shape in Corel Painter, the shape appears on a special shape layer. To maintain all of the editing properties of a shape, the shape must remain on the shape layer. However, you convert the shape to a pixel-based default image layer, so you can apply effects, transformations, or use painting tools. For more information, see “Converting shapes to image layers” on page 800.

You can also convert shapes to selections and vice versa. The tools for adjusting shapes allow precise control over the outline path, so you may want to use shapes to create some of your selection paths. For more information, see “Converting selections to shapes” on page 800.

When you save a file that contains a shape in the RIFF format, Corel Painter maintains shapes as vector objects on separate layers. In other formats, shapes merge with the canvas. In the Photoshop (PSD) format, shapes are converted to bitmaps and are assigned to appropriate layers.

Drawing shapes
You can draw shapes by using the Rectangular Shape or Oval Shape tools.

As you create shapes, Corel Painter gives them default attributes for stroke and fill. However, you can change the default settings for shapes. For more information, see “Setting preferences for drawing shapes” on page 791.
To draw a rectangle or square

1. Choose the **Rectangular Shape** tool from the toolbox.
2. On the property bar, enable the **Stroke** check box, click the **Stroke Color** flyout button, and choose an outline color.
3. On the property bar, enable the **Fill** check box, click the **Fill Color** flyout button, and choose a fill color.
4. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To draw</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A rectangle</td>
<td>Drag in the document window to draw the shape.</td>
</tr>
<tr>
<td>A square</td>
<td>While dragging in the document window, hold down the <strong>Shift</strong> key.</td>
</tr>
</tbody>
</table>

The property bar and the **Navigator** panel display information about the shape. To display the **Navigator** panel, choose **Window** ➤ **Navigator**.

You can toggle between the **Shape Selection** tool and any of the shape design and editing tools by holding down **Command** (macOS) or **Ctrl** (Windows). Toggling makes it convenient to quickly select a wing handle or anchor point before editing it.

To draw an oval or circle

1. Choose the **Oval Shape** tool from the toolbox.
2. On the property bar, enable the **Stroke** check box, click the **Stroke Color** flyout button, and choose an outline color.
3. On the property bar, enable the **Fill** check box, click the **Fill Color** flyout button, and choose a fill color.
4. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To draw</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>An oval</td>
<td>Drag in the document window to draw the shape.</td>
</tr>
<tr>
<td>A circle</td>
<td>While dragging the in the document window, hold down the <strong>Shift</strong> key.</td>
</tr>
</tbody>
</table>
The property bar and the **Navigator** panel display information about the shape. To display the **Navigator** panel, choose **Window**  **Navigator**.

You can toggle between the **Shape Selection** tool and any of the shape design and editing tools by holding down **Command** (macOS) or **Ctrl** (Windows). Toggling makes it convenient to quickly select a wing handle or anchor point before editing it.

**Drawing lines and curves**

You can draw straight lines or smooth, flowing curves by drawing freehand. You can combine the lines and curves to create shapes. The lines and curves that you draw are known as Bézier lines.

**Shapes created with straight line segments**

**Shapes created with curved line segments**

**Working with Bézier lines**

Bézier Lines can be straight or curved, and they consist of anchor points connected by line segments (or paths). When the path is a curve, “wings” extend from the anchor points. The wings are represented by a straight line and are tangent to the curve. The wings have control “handles” on them. By dragging the wing handle, you can change the curvature of the line segment.

**Shapes can be open (with endpoints) or closed (without endpoints).**
Shapes | 789

Open paths contain endpoints; closed paths do not.

Anchor points can be either smooth or corner points. A smooth point allows you to manipulate the segments on both sides of an anchor point by dragging a handle. A corner point restricts the manipulation of the segments to the one side of the anchor point that has a handle. You can also convert between smooth and corner points. For more information, see “To convert a smooth or corner point” on page 798.

An anchor point can be a smooth point (top) or a corner point (bottom).

You can easily adjust shapes after you create them. For more information, see “Adding, deleting, and moving anchor points” on page 795.

Clicking creates anchor points connected by straight line segments.

Dragging curves the segments between points.

**To draw a line segment**

1. Choose the Pen tool 🎨 in the toolbox.

2. On the property bar, enable the Stroke check box, click the Stroke Color flyout button, and choose a color.

3. Perform an action from the following table:
To Do the following

Draw a straight line segment
Click where you want to start the line segment, and then click where you want to end it. Corel Painter draws a straight line between the two points.

Draw a curved line segment
Draw a straight line segment, and then drag the first endpoint to create a curve. The angle and length of the wing determine the curvature of the path. The farther you drag, the longer the wing and the deeper the curve.

4 Repeat step 3 as often as necessary, combining straight and curved segments until you have the shape you want.

5 Finish the shape by doing one of the following:
  • Close the shape by clicking or dragging the first anchor point.
  • Close the shape by clicking the Edit flyout button on the property bar, and choosing Close Shape.
  • Hold down Command (macOS) or Ctrl (Windows) to temporarily access the Shape Selection tool, and click outside the shape to deselect it.

You can constrain the placement of the points by snapping to the grid. For more information, see “Using the grid” on page 233.

Each click or drag adds to the path. If you unintentionally add to the path, press Delete (macOS) or Backspace (Windows) to remove the last anchor point.

To add to an open shape path

1 Click an endpoint with the Pen tool.

2 Click or drag where you want to add an anchor point.

You can add to a path from an endpoint only. You cannot add to a closed path, or to the middle of an open path.

You can also select an endpoint by holding down Command (macOS) or Ctrl (Windows) and clicking the endpoint or dragging a marquee over it.

To draw a freehand shape

1 Choose the Quick Curve tool in the toolbox.

2 On the property bar, click the Stroke Color flyout button, and choose a color.

3 Click where you want to start the shape or line, and drag.
As you drag, a dotted line appears. When you stop dragging, the Quick Curve shape appears.

If you want to close the shape, finish at the same point where you began or right-click the shape and choose Close.

You can add to either endpoint of a Quick Curve shape by selecting the endpoint and dragging out from it. To select an endpoint, hold down Command (macOS) or Ctrl (Windows), and click the endpoint or drag over it.
### Setting preferences for drawing shapes

You can set the default appearance for all new shapes that you draw by modifying the shape preferences. For example, you can set the color for the shape outline and fill. You can also modify the appearance of Bezier handles and various elements such as outlines and wings, to make it easier for drawing.

**To set preferences for drawing shape outlines**

1. Choose a shape tool from the toolbox.
2. On the property bar, perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply an outline to a shape</td>
<td>Enable the Stroke check box.</td>
</tr>
<tr>
<td>Remove an outline from a shape</td>
<td>Disable the Stroke check box.</td>
</tr>
<tr>
<td>Change the outline color</td>
<td>Click the Stroke Color flyout button, and choose a color from the color selector.</td>
</tr>
<tr>
<td>Adjust the outline opacity</td>
<td>Click the Shape Attributes flyout button, and move the Opacity slider in the Stroke area.</td>
</tr>
<tr>
<td>Adjust the outline width</td>
<td>Move the Stroke Width slider.</td>
</tr>
<tr>
<td>Modify the appearance of endpoints of open shapes</td>
<td>Click the Shape Attributes flyout button, and click one of the following Endcap buttons: Projecting, Round, or Butt</td>
</tr>
<tr>
<td>Modify the appearance of corners where two line segments connect</td>
<td>Click the Shape Attributes flyout button, and click one of the following Miter buttons: Miter, Round, or Bevel</td>
</tr>
<tr>
<td>Set the miter limit to smooth out the sharpness of lines that join at a sharp angle</td>
<td>Click the Shape Attributes flyout button, and move the Miter Limit slider.</td>
</tr>
</tbody>
</table>
You can also set preferences for filling shapes in the Shape Attributes panel (Window ➤ Shape Attributes).

**To set preferences for filling shapes**

1. Choose a shape tool from the toolbox.
2. On the property bar, perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a fill</td>
<td>Enable the Fill check box.</td>
</tr>
<tr>
<td>Remove a fill</td>
<td>Disable the Fill check box.</td>
</tr>
<tr>
<td>Change the fill color</td>
<td>Click the Fill Color flyout button, and choose a color in the color selector.</td>
</tr>
<tr>
<td>Fill overlapping areas of multiple shapes</td>
<td>Click the Shape Attributes flyout button, and click the Fill Overlaps button.</td>
</tr>
<tr>
<td>Leave overlapping areas unfilled</td>
<td>Click the Shape Attributes flyout button, and click the Don’t Fill Overlaps button. Multiple overlaps alternate between filled and not filled.</td>
</tr>
<tr>
<td>Adjust the fill opacity</td>
<td>Click the Shape Attributes flyout button, and move the Opacity slider in the Fill area.</td>
</tr>
</tbody>
</table>

You can also adjust shape flatness by adjusting the Flatness slider.

**To set preferences for shape tools**

1. Do one of the following:
   - (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Shapes.
   - (Windows) Choose Edit ➤ Preferences ➤ Shapes.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control the size of the anchor points</td>
<td>In the Drawing Options area, enable the Big Handles check box. This can make them easier to grab and drag. If you want big points, enable this option.</td>
</tr>
</tbody>
</table>
To Do the following

Set the color of the wings, Bezier, and handles
In the Colors area, click Wing/Bezier Handle, and choose a color.

Set the color of the selected anchor points
In the Colors area, click Selected Point/Anchor, and choose a color. The unselected anchor points appear “hollow.”

Selecting a shape
You need to select a shape before moving or modifying it. When a shape is selected, you can see the shape’s outline path and anchor points. You can also select a shape layer to modify it. For more information, see “Selecting layers” on page 577.

To select shapes

To Do the following

Select a shape
Choose the Shape Selection tool from the toolbox, and click a shape.

Select multiple shapes
Hold down Shift, and click the shapes with the Shape Selection tool.

If you are using the Layer Adjuster tool, you can switch to the Shape Selection tool by double-clicking a shape.

Modifying shape outlines and fills
You can choose the color, opacity, and width of the path outlining the shape, which is also known as a stroke. You can also control the way line ends are drawn and joined. In addition, you can apply a fill to a shape by choosing the color and opacity of the fill.

Stroke and fill attributes apply to both open and closed shapes. Before filling an open shape, Corel Painter closes the shape by connecting the endpoints with a straight line.

The Flatness slider controls how many straight lines the program uses to approximate a curve when printing. PostScript output devices create curved lines by linking a series of short, straight lines that progress in angle. The smaller the flatness setting, the greater the number of straight lines, and the more accurate the curve.

You can also change the default shape attributes. For more information, see “Setting preferences for drawing shapes” on page 791. In addition, you can paint a shape after the shape has been committed to a pixel-based image layer. For information, see “Converting shapes to image layers” on page 800.

To modify a shape’s outline attributes

1 Choose the Shape Selection tool from the toolbox, and click a shape.

You can select multiple shapes by holding down Shift while clicking the shapes.

2 On the property bar, perform an action from the following table:
To Do the following

Apply an outline to a shape
Enable the Stroke check box.

Remove an outline from a shape
Disable the Stroke check box.

Change the outline color
Click the Stroke Color flyout button, and choose a color in the color selector.

Adjust the outline opacity
Click the Shape Attributes flyout button, and move the Opacity slider in the Stroke area.

Adjust the outline width
Move the Stroke Width slider.

Modify the appearance of endpoints of open shapes
Click the Shape Attributes flyout button, and click one of the following Endcap buttons: Projecting, Round, or Butt.

Modify the appearance of corners where two line segments connect
On the property bar, click the Shape Attributes flyout button, and click one of the following Miter buttons: Miter, Round, or Bevel.

Set the miter limit to smooth out the sharpness of lines that join at a sharp angle
On the property bar, click the Shape Attributes flyout button, and move the Miter Limit slider.

You can also set shape outline attributes in the Shape Attributes panel (Window ➔ Shape Attributes).

To set shape fill attributes

1 Choose the Shape Selection tool from the toolbox, and click a shape.
   You can select multiple shapes by holding down Shift while clicking the shapes.
2 On the property bar, perform an action from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a fill</td>
<td>Enable the Fill check box.</td>
</tr>
<tr>
<td>Remove a fill</td>
<td>Disable the Fill check box.</td>
</tr>
</tbody>
</table>
To

Change the fill color

Do the following

Click the Fill Color flyout button, and choose a color in the color selector.

Adjust the fill opacity

Click the Shape Attributes flyout button, and move the Opacity slider in the Fill area.

Fill overlapping areas of multiple shapes

Click the Shape Attributes flyout button, and click the Fill Overlaps button.

Leave overlapping areas unfilled

Click the Shape Attributes flyout button, and click the Don’t Fill Overlaps button. Multiple overlaps alternate between filled and not filled.

You can also fill a shape by choosing Edit ➤ Fill command or the Paint Bucket tool . Because these methods apply pixel data to the region, Corel Painter first converts the shape to a pixel-based layer. For more information, see “Applying a color as a fill” on page 261. After you commit the shape, you cannot re-access the shape-specific controls.

You can also set shape fill attributes in the Shape Attributes panel (Window ➤ Shape Attributes).

To set shape flatness

1 Choose the Shape Selection tool from the toolbox, and click a shape.

You can select multiple shapes by holding down Shift while clicking the shapes.

2 On the property bar, click the Shape Attributes flyout button, and adjust the Flatness slider.

Usually, it is not necessary to change the flatness setting. You may want to change it to adjust for a particular high resolution printer or to avoid a PostScript limit check error. Check with your output service to find out if they have a recommended flatness setting.

A change in flatness appears only in your output, not on your screen.

Adding, deleting, and moving anchor points

You can add anchor points to create new vertices or curves. You can also delete anchor points to change the shape of the path or to smooth a contour that has unnecessary points. This might occur when you draw with the Quick Curve tool or create a shape from a selection.

Shapes | 795
Use the Add Point tool to add anchor points to the path.

Use the Remove Point tool to delete anchor points.

You can also move one or several points by averaging, which moves two or more anchor points with respect to each other. Averaging is useful when you need to join the endpoint of one curve to the endpoint of another. Averaging the endpoints in both directions brings them precisely on top of each other. Now, when you join the endpoints, Corel Painter merges them to a single point, through which the path continues. If you don’t average points that are near each other, Corel Painter joins them with a segment.

To add or delete an anchor point

* With the Shape Selection tool \(\text{Shape Selection tool} \), select a shape.

To

Do the following

Add an anchor point

Choose the Add Point tool \(\text{Add Point tool} \) on the property bar, and click where you want to add the point.

Delete an anchor point

Choose the Remove Point tool \(\text{Remove Point tool} \) on the property bar, and click the anchor point you want to delete.

The anchor point is deleted, but the path remains connected.

You can quickly switch to Shape Selection tool \(\text{Shape Selection tool} \) by holding down Command (macOS) or Ctrl (Windows).

To move anchor points

1. Choose the Shape Selection tool \(\text{Shape Selection tool} \) from the toolbox.

2. Click an anchor point to select it, or marquee select a point by dragging over it.
   - If you want to select several points, marquee select them by dragging over them. All anchor points within the marquee are selected, including those from other shapes.
   - If you want to add to the selection, hold down Shift and select more points.
3 Drag the point to a new location.

If you have selected several points, dragging one moves them all.

![Drag an anchor point to move it.]

To average anchor points

1 With the Shape Selection tool , select the anchor points you want to average.

   It is often easiest to drag a marquee around the points you want.

2 Choose Shapes > Average Points.

3 In the Average Points dialog box, enable an option to determine the axis for the averaging.

Adjusting curvature

The angle and length of the wing determine the curvature of the segments on either side of the anchor point. The longer the wing, the deeper the curve.

The result of moving a wing depends on whether the anchor point is defined as a smooth point or a corner point. Two connecting curves (or straight lines) share one anchor point, which can be a smooth or corner point. The wings on smooth and corner points behave differently.

When you drag the handle on one wing of a smooth point, the curves on both sides of the point change. With a smooth point, you adjust the angle of the wings concurrently.

![A corner point is converted to a smooth point.]

When you drag the handle on one wing of a corner point, only the curve on that side of the point changes. With a corner point, you can adjust the angle of the wings independently.

To adjust a curve

1 Choose the Shape Selection tool from the toolbox.

2 Click a shape to select it.

   If an anchor point’s wings are not displayed, drag over the anchor point to display them.

3 Drag a wing handle to set the curve you want.
You can also adjust a curve by dragging a line segment with the Shape Selection tool.

Use the Shape Selection tool to drag a wing handle.

To convert a smooth or corner point

1. With the Shape Selection tool, select an anchor point.
   
   If the anchor point’s wings are not displayed, drag over the anchor point to display them.

2. Choose the Convert Point tool on the property bar.

3. Click one of the anchor point’s wing handles.

After converting a point, you must use the Shape Selection tool for further adjustments. If you try to adjust an anchor point with the Convert Point tool, the anchor point will be converted again.

Cutting and joining shape segments

You may want to open a shape so that you can add new curves or connect to another open shape. You can do this with the Scissors tool. You can also connect any two endpoints — of the same shape or of different shapes. This lets you close an open shape or attach one shape to another.

To cut a shape

1. Choose the Scissors tool from the toolbox.

2. Click where you want to split the shape (you cannot click an endpoint).
   
   The hot spot of the Scissors tool is where the blades cross. Position the cross on the line.

   The scissors snap closed momentarily, and two new anchor points are created.
Choose the **Shape Selection** tool on the property bar, and drag the new anchor points or segments. The new anchor points are on top of each other, and both are selected. If you try to drag one of the new anchor points with the **Shape Selection** tool and both move, deselect them, then drag one point away.

To join endpoints

1. Choose the **Shape Selection** tool from the toolbox.
2. Select the two anchor points you want to join. You can do this either by marquee selecting both points, or by clicking the first point and then holding down **Shift** and clicking the second point.
3. On the property bar, click the **Edit** flyout button, and choose **Join Endpoints**.
   A straight line is created between the two points.
Use the Join Endpoints command to connect two endpoints.

Converting shapes to image layers

In Corel Painter, the shapes that you create are added to shape layers. If you want to alter a shape by painting, applying effects, or transforming, you must convert the shape to a pixel-based image layer. You can convert an individual shape or a group of shapes to an image layer.

Shape layers vs. image layers

Some of the options and controls for working with pixel-based image layers also apply to shapes. For example, you can move shapes in the same way you move image layers, and you can change the composite method to control how the shape interacts with the underlying image. Shapes also follow the same layering rules as pixel-based image layers, and you can manipulate them in many of the same ways. However, shapes differ from pixel-based image layers by the type of data they contain. Shapes are vector objects; pixel-based image layers are constructed of pixels. If you want to apply brushstrokes, transformations (using the Transform tool), or effects to a shape, you must convert the shape to a pixel-based layer. Moreover, if you attempt to perform any of these actions with a shape selected, Corel Painter automatically displays a warning message to instruct you to commit the shape to an image layer. After you commit the shape to an image layer, you cannot re-access the shape-specific controls.

For more information, "Layers" on page 569.

To convert a shape to a pixel-based layer for painting

- Right-click (Windows) or Control-click (macOS) a shape in the Layers panel, and choose Convert To Default Layer.

If you want to confine the painting to only the shape, enable the Preserve Transparency button \( \) in the Layers panel.

You cannot paint on a shape using Watercolor brushes or Liquid Ink brushes because they automatically create their own special layers.

In some cases, Corel Painter will prompt you to convert a shape. For example, if you attempt to apply an effect to a shape, Corel Painter asks if you want to commit the shape to an image layer.

You can also convert a shape to a pixel-based layer by clicking the shape in the Layers panel, clicking the Layer options button \( \), and choosing Convert To Default Layer.

You can also convert a shape to an image layer by choosing Shapes \( \) Convert To Layer.

Converting selections to shapes

You can convert a selection to a shape to edit its contour. When you are satisfied with the contour, you can convert the shape outline back to a selection. For more information, see “To convert a shape to a selection” on page 629.
If you are scaling, rotating, or skewing a selection path, use the **Selection Adjuster** tool. If you must edit the profile of the curve, convert the selection to a shape.

Working from a selection path also lets you create shapes based on regions of the image. For example, if you used the **Magic Wand** tool to select a region of common color, you could convert the Magic Wand selection path to a shape. When the selection is pixel-based, Corel Painter may create multiple shapes.

![You can convert a selection to a shape.](image)

**To convert a selection to a shape**

1. Choose a selection tool from the toolbox and create a selection in the image.
2. On the property bar, click the **Convert To Shape** button.

Corel Painter converts the selection to a shape, giving it the default shape attributes. The new shape appears in the **Layers** panel.

For best results, the selection should be path-based. If the selection is pixel-based, from the menu bar choose **Select > Transform Selection** to convert it to a path-based selection.

**Resizing, rotating, skewing, and flipping shapes**

Corel Painter lets you resize, rotate, flip, or skew an individual shape, or a group of shapes. Before you can work with a shape, you must select it.
To resize a shape

1. Choose the Layer Adjuster tool  from the toolbox.
2. Select the shape or group you want to resize.
   A selection rectangle appears around the shapes. The rectangle has a handle on each corner and side.
3. Drag one of the handles to resize the selected shape.
   To resize in one dimension, drag one of the side handles. To resize in both dimensions, drag one of the corner handles.
   You can maintain the proportions by holding down Shift as you drag.

To rotate a shape

1. Choose the Layer Adjuster tool  from the toolbox.
2. Select the shape or group you want to rotate.
   A selection rectangle appears around the shapes. The rectangle has a handle on each corner and side.
3. Hold down Command (macOS) or Ctrl (Windows) and drag a corner handle.
   This command works for both shapes and pixel-based layers.

To skew a shape

1. Choose the Layer Adjuster tool  from the toolbox.
2. Select the shape or group you want to skew.
3. Hold down Command (macOS) or Ctrl (Windows), and drag a middle handle.

To flip a shape

1. Choose the Shape Selection tool  from the toolbox, and click a shape.
2. On the property bar, click the Edit flyout button , and choose one of the following options:
   * Flip Horizontally
   * Flip Vertically
   You can also flip a shape by first selecting it with the Layer Adjuster tool . Then, to flip horizontally, drag a top or bottom handle past the opposite handle. To flip vertically, drag a side handle past the opposite handle.
Duplicating shapes

Duplicating creates an identical copy of the selected shape. Corel Painter also lets you duplicate shapes by using compound transformations. Transformed duplicates are created according to the options you set.

To duplicate a shape

1. Choose the **Shape Selection** tool from the toolbox, and click a shape.
2. Choose **Shapes > Duplicate**.

To change duplication settings

1. Choose **Shapes > Set Duplicate Transform**.
2. In the **Set Duplicate Transform** dialog box, specify any of the following settings:
   - **Translation** — controls where Corel Painter creates duplicate shapes in relation to the original. The offset values are in pixels. When **H. Offset** and **V. Offset** are both zero, the duplicate is created precisely on top of the original. If both values are 100, the duplicate appears 100 pixels lower and 100 pixels to the right. Negative values offset the duplicate up and to the left, respectively.
   - **Scaling** — controls the size of duplicates in relation to the original. The scale values are percentages.
   - **Constrain Aspect Ratio** — maintains the aspect ratio of the shape. If you want to create distorted duplicates, disable this option and specify different percentages for horizontal and vertical scaling.
   - **Rotation** — lets you specify a number of degrees to rotate duplicates. Positive values rotate counterclockwise, and negative values rotate clockwise.
   - **Slant** — controls the degree of slant applied to duplicates. Positive values slant duplicates to the right. Negative values slant them to the left. Slant accepts values between –90° and 90°. However, as values approach the extremes, the duplicate shape becomes a streak.

To create a transformed duplicate

1. Select the shape you want to transform.
2. Choose **Shapes > Duplicate**.

Corel Painter creates a duplicate shape according to the specifications you’ve set.

This duplicate is now the selected shape. You can choose the **Duplicate** command again, or press **Command + ]** (macOS) or **Ctrl + ]** (Windows), to repeat the transformation on the new shape.

The oval shape was duplicated by using rotation only (left). The number 5 shape was duplicated by using translation, scaling, and rotation (right).

Combining shapes

You can combine shapes in various ways to achieve particular results. You can compound two or more shapes to create a single shape. The resulting shape takes on the attributes of the shape on the topmost layer. If the shape is filled, any overlapping areas are not filled. Compound shapes can be used to cut a void in one shape using another shape. You can release a compound shape, which reverts it to the original shapes.
The rectangle and the oval are combined to create a compound shape.

You can also compound shapes to create a shape group, which allows you to manipulate multiple shapes as a single unit.

**To create a compound shape**

1. Choose the **Shape Selection** tool, hold down **Shift** and select both shapes, or drag over the shapes to marquee select them.

2. On the property bar, click the **Edit** flyout button, and choose **Make Compound**.

You can combine a shape with a compound shape to create a nested compound shape.

The resulting compound shape can itself be used again to create another compound shape.

**To release a compound shape**

1. Select a compound shape.

2. On the property bar, click the **Edit** flyout button, and choose **Release Compound**.

**Blending shapes**

You can blend single shapes, or groups of shapes, so that they appear to be one shape morphing into another. Blending creates intermediate shapes between two or more selected shapes. It is also used to simulate shading on irregular shapes. Blending applies to stroke and fill attributes as well as to the shape size.

You can blend a shape group with another group, but you can’t blend a single shape with a group.

Blending groups with other groups offers interesting effects, especially if the groups are blends themselves.
To blend shapes

1. Position the shapes you want to blend.
   You can arrange the shape layers in the Layers panel. Blends will progress from lower to higher layers.

2. Choose the Shape Selection tool from the toolbox.

3. Hold down Shift, and select the shapes you want to blend.

4. Choose Shapes → Blend.

5. In the Blend dialog box, type a value in the Number of Steps box to control how many intermediate shapes are created.

6. In the Spacing area, enable one of the following options:
   • Equal — blends shapes with equal spacing
   • Decrease toward end — starts blending with wide spacing and decreases toward the end of the blend
   • Increase toward end — starts blending with small spacing and increases toward the end of the blend
   • Increase toward/from middle — widens spacing in the middle and decreases toward both ends

7. In the Color area, choose one of the following options:
   • RGB — progresses color directly over the course of the blend
   • Hue CW — progresses color clockwise in the color wheel to reach the destination color
   • Hue CCW — progresses color counterclockwise in the color wheel to reach the destination color

8. Type a value between 0.01 and 100 in the Perspective Factor box to control the spacing of intermediate shapes.
   With a Perspective Factor of 1.0, the shapes are spaced evenly. With a Perspective Factor of less than 1.0, shapes are closer at the beginning of the blend and farther apart at the end of the blend. With a Perspective Factor greater than 1.0, shapes are farther apart at the beginning of the blend and closer at the end of the blend.

9. Enable any of the following check boxes:
   • Arc Length Matching — blends shapes containing a different number of anchor points
   • Align Shape Start Points — bases the orientation of intermediate shapes on the orientation of the start and end shapes. When disabled, Corel Painter bases the orientation of intermediate shapes on the starting point (first anchor point) of the start and end shapes. This can create a “tumbling” appearance in the intermediate shapes.
Saving a shape outline as a selection

You can save the outline of a shape as a selection. Corel Painter doesn’t have a shapes library. However, because of the close relationship between shape outlines and selection paths, you can save shape outlines as selections in the Selection Portfolio. Then, you can easily convert the saved selection to a shape. For more information, see “Working with the Selection Portfolio” on page 636. For information about converting selections to shapes, see “To convert a selection to a shape” on page 801.

To save a shape outline as a selection

1 Choose Window ➤ Media Panels ➤ Selections.
2 Choose the Shape Selection tool from the toolbox, and click a shape.
3 On the property bar, click the Convert To Selection button ．
4 In the Selection Portfolio panel, click the Selection options button  ， and choose Add Selection to Portfolio.
5 In the Save Selection dialog box, type a name in the Save As box.

Exporting Adobe Illustrator shapes

Corel Painter lets you export shape data to the Adobe Illustrator (AI) format. Exporting to the AI format saves only the shapes, not the canvas or any other layers in the document. Transparency and compositing methods are lost when shape data is exported to the AI format.

If both Corel Painter and Adobe Illustrator are running on your computer, you can copy content from Adobe Illustrator and paste it in Corel Painter.

To export shapes to Adobe Illustrator

1 Choose File ➤ Export ➤ Adobe Illustrator File.
2 In the Export as Illustrator File dialog box, specify a location and filename, and click Save.
Adding text

Corel Painter lets you position and manipulate editable text on your image.

This section contains the following topics:

• “Adding text to images” (page 807)
• “Aligning text” (page 808)
• “Adjusting text kerning and leading” (page 809)
• “Stretching, rotating, and skewing text” (page 809)
• “Adding drop shadows to text” (page 810)
• “Applying effects to text” (page 810)
• “Applying curves to text” (page 811)
• “Converting text layers” (page 813)
• “Dropping text” (page 813)

Adding text to images

You can add text to an image by using the Text tool  . The text that you add is then stored in a text layer, which is automatically created for you as soon as you place the text cursor on the canvas. Each text layer holds a single text block. The text layer is visible in the Layers panel, and is represented by a T icon .

The text layer lets you work with your image without changing any text attributes. However, you can select the text layer and edit it at any time. The text remains fully editable until you drop it onto the canvas. For more information, see “Dropping text” on page 813.

To add text to an image

1 Choose the Text tool  from the toolbox.

2 Click anywhere in the document window, and type.
You can also format text by choosing options from the property bar.

You can also format text by clicking the **Show or hide the Text panel** button \( T \) on the property bar, and choosing options from the Text panel.

---

**Formatting text**

You can format text by changing the font, point size, and color. You can also perform these tasks from the property bar or from the Text panel (Window → Text), where you’ll find additional text controls. The changes that you make are applied to all of the text in the text layer.

**To change the font, point size, and color of text**

1. Choose the **Text tool** \( T \) from the toolbox.
2. In the **Layers** panel, select a text layer.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a font</td>
<td>On the property bar, choose a font from the <strong>Font</strong> list box.</td>
</tr>
<tr>
<td>Choose a point size</td>
<td>On the property bar, choose or type a point size in the <strong>Point Size</strong> box ( T ).</td>
</tr>
<tr>
<td>Choose a color</td>
<td>On the property bar, click the <strong>Color</strong> picker, and choose a color.</td>
</tr>
</tbody>
</table>

---

**Aligning text**

You can align a text block to the left, right, or center. The text baseline origin is used as the reference point for the text alignment.

**To align text**

1. Choose the **Text tool** \( T \) from the toolbox.
2. In the **Layers** panel, select a text layer.
3. On the property bar, enable one of the following buttons:
   - Align Left
   - Align Center
   - Align Right
You can also align text by clicking the Show or hide the Text panel button \( T \) on the property bar, and clicking one of the alignment buttons in the Text panel.

**Adjusting text kerning and leading**

You can fine-tune the spacing between letters by adjusting the kerning. You can also adjust the amount of space between lines of text by adjusting the leading. You may want to change the leading from the default setting which is set at 100%.

**To kern text**

1. Choose the Text tool \( T \) from the toolbox.
2. In the Layers panel, select a text layer.
3. Click the Show or hide the Text panel button \( T \) on the property bar, and adjust the Tracking slider \( \alpha \) in the Text panel.

**To adjust leading**

1. Choose the Text tool \( T \) from the toolbox.
2. In the Layers panel, select a text layer.
3. Click the Show or hide the Text panel button \( T \) on the property bar, and adjust the Leading slider \( \gamma \) in the Text panel.

**Stretching, rotating, and skewing text**

You can change the appearance of text by stretching, rotating, or skewing the text. Stretching text affects both the horizontal and vertical size. As you stretch vertically, the text appears thinner and taller. As you stretch horizontally, the text appears flatter and shorter.

Rotating pivots the text from the end point of the text block. Depending on the alignment of the text, it pivots from the lower-left corner, lower-right corner, or center. You can also skew the text by slanting the text to the right or left.

**To stretch, rotate, or skew text**

1. Select text using the Layer Adjuster tool \( \text{Layer Adjuster} \).
2. Choose a task from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stretch text</td>
<td>Drag a handle in the direction you want to stretch the text.</td>
</tr>
</tbody>
</table>
To Do the following

Rotate text
Hold down Command (macOS) or Ctrl (Windows), and drag one of the corner handles.

Skew text
Hold down Command (macOS) or Ctrl (Windows), and drag one of the center handles on either side of the text.

If the bounding box is not shown, click the Layer options button and choose Show Layer Indicators.

Adding drop shadows to text
You can apply a drop shadow to text. You can choose between two drop shadow styles: external, which places the shadow behind the text, or internal, which places the shadow inside the text.

You can also change the composite method for text or the drop shadow of text. For more information, see “Blending layers by using composite methods” on page 594.

To add a drop shadow to text
1. Choose the Text tool from the toolbox.
2. In the Layers panel, select a text layer.
3. On the property bar, enable one of the following buttons:
   - External Shadow — makes your letters look as though they’re casting a shadow onto a sheet of paper held beneath them
   - Internal Shadow — makes your letters look like cutouts held above a sheet of paper that is the same color as the text
   - No Shadow — removes a shadow

You can also add a shadow by clicking the Show or hide the Text panel button on the property bar, and choosing one of the shadow buttons in the Text panel.

Applying effects to text
You can alter the appearance of text or text drop shadows by applying different effects. You can apply a composite method to text, as you would with other types of layers, to control how the text interacts with the underlying image.

You can also adjust opacity, which controls the transparency of text or shadows. Your text’s shadow should be semitransparent. You can also use opacity to fade the color of text.

In addition, you can add either a focus blur or a directional blur to text and shadows. Focus blurs make text fuzzy. You can use the focus blur to soften the edges of text characters. With directional blurs, you can specify the direction in which the blur occurs.

To apply a composite method to text
1. Choose the Text tool from the toolbox.
2 In the Layers panel, select a text layer.

3 On the property bar, click on the following buttons:
   • Text Attributes
   • Shadow Attributes

4 Choose an option from the Composite Method list box.

To adjust text opacity
1 On the property bar, click on the following buttons:
   • Text Attributes
   • Shadow Attributes

2 Move the Opacity slider to the left to increase transparency or to the right to increase opacity.

To blur text
1 In the Layers panel, select the Text layer or the Shadow layer.

2 On the property bar, click on the following buttons:
   • Text Attributes
   • Shadow Attributes

3 Click the Show or hide the Text panel button on the property bar, and adjust the Blur slider in the Text panel.

   If you want to apply a directional blur, enable the Directional Blur check box, and adjust the Directional Blur slider.

   The first half of the slider adds a left-to-right blur on the text; the second half adds an up-and-down blur.

Applying curves to text

You can apply a curve style and modify the path (baseline) along which your text will flow. The baseline created by a curve style is a Bézier curve, meaning that the shape can be controlled by using control handles and anchor points. For more information, see “Drawing lines and curves” on page 788.

There are four curve styles to choose from:

<table>
<thead>
<tr>
<th>Curve Style</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Curve Flat</td>
<td>The Curve Flat style flows along a straight line.</td>
</tr>
</tbody>
</table>
Curve Style

The **Curve Ribbon** style flows the text along a curve and keeps the letters in an upright position. When you apply the **Curve Ribbon** style, you can use the **Shift** key and the **Rotate** tool to control how the text moves around the baseline.

The **Curve Perpendicular** style places the text along the curve, with each letter perpendicular to the curve.

The **Curve Stretch** style actually changes the shape of the letters to fill in the space that would be left when the curve bends. For example, if text is set on a circular path, Corel Painter makes the tops of the letters heavier and thicker to fill in space.

You can control how the text is centered on the baseline. You can also move the center point by dragging on the slider or by changing the alignment. Dragging the **Centering** slider also changes where the text starts and stops on a line. The **Centering** slider has no effect on the **Curve Flat** style. After you apply a curve style, you can change the curve of the path.

**To set a curve style and change centering**

1. Choose the **Text** tool T from the toolbox.
2. In the **Layers** panel, select a text layer.
3. Click the **Show or hide the Text panel** button T on the property bar, and click a curve style icon in the **Text** panel:
   - **Curve Flat** 📀
   - **Curve Ribbon** 📀
   - **Curve Perpendicular** 📀
   - **Curve Stretch** 📀
4. Drag the **Centering** slider T to the right or left.
   The text moves along the curve.
You can also change the alignment of text on a path by clicking a text layer in the Layers panel and clicking an alignment button in the Text panel. For more information, see “To align text” on page 808.

To change the text path
1 In the Layers panel, select a text layer.
2 Choose the Shape Selection tool from the toolbox.
3 Click an end point on the path.
   Drag the handles to change the shape of the path.

Converting text layers
You can convert a text layer into a standard layer so that you can apply effects such as gradations, blends, or surface textures. For example, you can also apply surface control textures to give the text a three-dimensional appearance. For more information, see “Adjusting light properties” on page 677.

You can also convert a text layer to shapes, which allows you to move and edit individual characters. For more information, see “Shapes” on page 785.

To convert a text layer to a standard layer
1 In the Layers panel, choose a text layer.
2 Click the Layer options button, and choose Convert To Default Layer.

If the text has an outside or an inside shadow, then two layers — one for the text and one for the shadow — are created within a group.

To convert a text layer to shapes
1 In the Layers panel, choose a text layer.
2 Click the Layer options button, and choose Convert Text To Shapes.
   The text layer is replaced by a group of shape layers.

Text shadows and blurring effects are not converted when you use this command.

Dropping text
While you are working with text, it resides on a layer and is not yet a part of the image. When a text layer is dropped, it integrates with the canvas and can no longer be edited.

To drop a text layer onto the canvas
1 In the Layers panel, select a text layer.
If you want to select more than one text layer, highlight several layers and group them.

2. Click the **Layer Commands** button 📋 at the bottom of the **Layers** panel, and choose **Drop**.
Working with animation and digital videos

Corel Painter lets you create animations frame-by-frame from scratch, as well as open existing digital videos (QuickTime or AVI) for editing frames on Windows. Whichever workflow you choose, you can use Corel Painter’s Natural Media brushes and effects to create or modify animation frames. You can also use features such as onion skinning or cloning in the creation of animations.

This section contains the following topics:

- “Choosing an animation workflow” (page 815)
- “Creating frame-by-frame animation” (page 817)
- “Opening a Corel Painter movie” (page 818)
- “Importing QuickTime and AVI files” (page 819)
- “Selecting movie frames” (page 819)
- “Editing frame content” (page 819)
- “Applying effects to a single frame” (page 820)
- “Previewing animations” (page 820)
- “Using onion skinning” (page 821)
- “Animating with layers” (page 821)
- “Adding, deleting, and erasing frames” (page 822)
- “Repeating frames” (page 822)
- “Inserting movies” (page 823)
- “Rotoscoping” (page 824)
- “Applying scripts to movies” (page 824)
- “Exporting movies as QuickTime” (page 825)
- “Exporting movies as AVI” (page 826)
- “Importing and exporting numbered files” (page 827)
- “Exporting animated GIFs” (page 828)

Choosing an animation workflow

Corel Painter offers different animation workflows:

- Create animation frames from scratch
- Edit digital video frames
- Create animations by cloning
• Create animations by tracing
• Create animations from layers

Customizing an animation-specific color set

You can customize a color set for the animation to better control the use of color. For example, using a particular color set prevents the colors of your characters from shifting between frames. You might want to set up an image of each character with annotations to specify which colors to use in which areas.

Not all colors are suitable for video.

You can’t display different sections of a movie at different rates. What you can do is create sections separately at different rates and then modulate them to the same rate before joining them. This is the kind of work you’ll do in your video-editing application.

For more information, see “To set the preview rate” on page 821.

Frame Stacks panel

In Corel Painter, digital video and animation files are known as movies or frame stacks. Whether you’re working with an imported digital video or building an animation from scratch, you can select and navigate frames from the Frame Stacks panel.

The Frame Stacks panel appears whenever you open or create a movie file and it must stay open while you work with a movie.

You work in one frame at a time — the one appearing in the document window. The Frame Stacks panel helps you navigate the frames in the stack and choose which frame to modify.

Each frame in a frame stack can have one layer. For example, if you add an item from the image portfolio onto a frame, Corel Painter places the image on a layer. You can move the image around the layer. However, when you move between frames or close the file, Corel Painter drops all layers — the layer is deleted, and the layer’s content is flattened onto the background canvas. For more information about working with layers, see “Layers” on page 569.

The Frame Stacks panel displays thumbnails of several frames. The frame numbers appear under the thumbnails. The current frame is shown with a red triangle over it.

The number of thumbnails is determined by the layers of onion skin you’ve chosen. By default, QuickTime and AVI files are opened with two layers of onion skin. For more information about onion skinning, see “Using onion skinning” on page 821.

Setting movie file sizes

Keep in mind that video and animation can produce huge files. When planning a project, be careful not to overestimate your available disk space. For an idea of disk requirements, consider this example: Each 640 by 480-pixel, 24-bit color frame is 1.2 MB. At this size, a 12-fps, 30-second animation would consume more than 400 MB of disk space.

To calculate the disk space required for a frame stack

1 Using pixels as the unit of measurement for width and height, calculate the number of bytes required to save the frame stack with the following formula:

\[(\text{Frame Width}) \times (\text{Frame Height}) \times (\text{Bytes per Pixel}) \times (\text{Number of Frames})\]

2 Divide the product of the formula in step 1 by 1,024 to convert to kilobytes.
Bytes per pixel are determined by the storage type. For example, 24-bit color with an 8-bit alpha channel uses 4 bytes per pixel. For more information about storage types, see “Creating frame-by-frame animation” on page 817.

When you save a movie as QuickTime or AVI, the file size can be reduced by compression. For more information about compression, see “Exporting movies as QuickTime” on page 825 and “Exporting movies as AVI” on page 826.

Creating frame-by-frame animation

In Corel Painter, you can build animations one frame at a time. Then, when you complete a series of frames, also known as a frame stack, you can preview them as a movie.

The first step in creating a new animation is to create a movie. You can specify options such as the number of frames and the frame size. You can also choose how many onion skin layers you want to display. Onion skinning allows you to see multiple frames at the same time. You can view up to five frames at a time: the current frame and four other frames adjacent to it. This will help you determine where the next frame of motion should be drawn. For more information, see “Using onion skinning” on page 821.

Once you create a movie file, a blank frame appears in the document window so you can begin adding content by using brushes and other tools. After you complete a frame, you can use the navigation tools in the Frame Stacks panel to display the next frame in the sequence, or whichever frame you want to work on next. You can play back the animation as you create it, to make sure that you have the correct flow of movement. The Frame Stacks panel must stay open when you create or edit movies. For more information, see “Editing frame content” on page 819.

In Corel Painter, movies are saved to the Painter Framestack file format (FRM), which stores a series of images equal in size and resolution.

To create a new movie

1. Choose Movie ➤ New Movie.
2. Type a filename in the Movie Name text box.
3. In the Canvas Settings area, type values in the Width and Height boxes. The standard digital video frame is 640 by 480 pixels, which is a 4:3 aspect ratio. Many people work at sizes consistent with this aspect ratio.
4. Type a value in the Resolution box.
5. In the Movie Settings area, type a value in the Number of Frames box. You can also add or remove frames at a later time.
6. From the Layers of Onion Skin options, choose the number of onion skin layers that you want. The number of onion skin layers determines the number of frames displayed in the Frame Stacks panel. For more information, see “Using onion skinning” on page 821.
7. From the Storage Type list box, choose one of the following options:
   - 8-bit gray — displays 256 levels of gray
   - 8-bit System Palette — displays the system palette for 256 colors
   - 15-bit color with 1-bit alpha — displays 32,768 colors and a layer for a channel
   - 24-bit color with 8-bit alpha — displays 16.7 million colors and a layer for an anti-aliased channel
8. In the Enter Movie Name dialog box, specify a location to save the file.
9. Click Save.

The movie file is saved to the Painter Framestack (FRM) format.

When the movie opens, the Frame Stacks panel appears, and the document window displays the first frame of the movie.
You can also

Choose a paper color  
Click the Color chip, and choose a color from the color picker.

Choose a paper texture  
Click the Paper chip, and choose a paper texture from the Papers Textures panel.

The storage type lets you specify the color depth for saving each frame. This applies to the saved frame stack, not to your work in the current frame. For example, choosing 256 colors as the storage type still allows you to work with a selection and 24-bit tools in the document window for the current frame. As soon as you change frames, however, the image is saved in the 256-color format, and the selection is lost. If you want to maintain selections in saved frames, you must choose the 15-bit or 24-bit storage type. These storage types allow you to take advantage of compositing options that require a selection layer.

To create frame-by-frame animation

1  With the Frame Stacks panel open in the document window, navigate to frame 1.
2  In the toolbox, click the Brush tool.
3  Click the Brush Selector on the Brush Selector bar.
4  In the Brush library panel, click a brush category, and click a brush variant.
5  Paint the animation frame in the document window.
6  In the Frame Stacks panel, click the Step Forward button.  
   Changing frames automatically saves the frame. You cannot undo changes after the frame has been saved.

   Repeat steps 5 and 6 until you complete all frames.

You can view previous and future frames while working in the current frame with the onion skin view. You can enable the onion skin view by clicking Movie Show Onion Skin Layers.

You can also step forward one frame by pressing Page Up or step back one frame by pressing Page Down. For more information about keyboard shortcuts for animation, see “Animation” on page 139.

Opening a Corel Painter movie

You can open movies (frame stacks) that were previously created in Corel Painter so you can edit them.

To open a Corel Painter movie

1  Choose File Open.
2  In the Open dialog box, locate the FRM file, and click Open.
3  In the Open Frame Stack dialog box, choose the number of onion skin layers you want to appear in the Frame Stacks panel.
   The number you choose determines the number of thumbnails visible in the Frame Stacks panel.
4  Click OK.

   The Frame Stacks panel appears and the document window displays the first frame in the stack.
**Importing QuickTime and AVI files**

You can import QuickTime or AVI digital videos so you can edit them using any of the Corel Painter brushes, textures, and effects. When you import a QuickTime or AVI file, Corel Painter automatically converts it into a frame stack. A frame stack is a series of images equal in size and resolution.

Corel Painter does not provide features for working with audio.

When you're finished editing the digital video in Corel Painter, you can save it as a QuickTime, AVI, or animated GIF file. You can then open the QuickTime or AVI file in a video-editing application to add sound effects and other finishing touches.

For efficiency, import only the video frames that you plan to edit. For example, if you have a two-minute video clip and you want to paint on the first 10 seconds, don’t import the entire clip in Corel Painter. Instead, separate the first 10 seconds in a video-editing application and import only those frames. After finishing that clip in Corel Painter, you can open the frames in the video-editing application and join them to the other frames.

You can also import movies that are saved as a series of numbered files. For more information, see "Importing and exporting numbered files" on page 827.

---

**To open a QuickTime or AVI movie**

1. Choose File ➤ Open.
2. In the Open dialog box, locate the movie, and click Open.
3. In the Enter Movie Name dialog box, type a name in the File Name box, and click Save.
   
   The Frame Stacks panel appears, and the document window displays the first frame of the movie.

   > When you open a QuickTime or AVI movie, Corel Painter makes a frame stack copy of the movie. This ensures that the original file does not change.

   Frame stacks are uncompressed, so you need an adequate amount of disk space to create them. For example, a 1MB QuickTime or AVI movie can become a 20MB frame stack.

---

**Selecting movie frames**

You can select a frame by clicking its thumbnail in the Frame Stacks panel. You can also easily jump to any frame in a movie.

**To select a frame**

- Do one of the following
  - In the Frame Stacks panel, click the frame’s thumbnail.
  - Choose Movie ➤ Go to Frame, and type the frame number in the Go to Frame dialog box.

---

**Editing frame content**

Frames can be added to, or deleted from, a movie. You can also erase the contents of a frame while leaving the frame in the movie. These changes cannot be undone, so it’s best that you create your animation in segments and combine them when you are finished.
Applying effects to a single frame

You can paint on, or apply effects to, any frame in a movie. You can do anything in a frame that you can do in a single image: paint with a brush, add layers, or apply an effect to a selection or to the entire image. Frames are automatically saved when you select another frame, and the changes cannot be undone.

To paint on or apply an effect to a single frame

1. In the Frame Stacks panel, click the thumbnail of the frame that you want to work in, or click the Step Forward button to advance to the frame. The selected frame appears in the document window.
2. Modify the image in the document window.
3. When you’re ready to work on the next frame, click the Step Forward button. Changing frames automatically saves the frame. You cannot undo changes after the frame is saved.

Previewing animations

The Frame Stacks panel provides the tools that you need to preview and navigate animations. For example, you can navigate to various frames in the stack for editing purposes or play the animation to preview how the frames link together. You can also set the preview frame rate to control how many frames are displayed per second.

To preview an animation

- In the Frame Stacks panel, perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Play the frame stack</td>
<td>Click the Play button</td>
<td>Ctrl + .</td>
</tr>
<tr>
<td>Stop playing the frame stack</td>
<td>Click the Stop button</td>
<td>Home</td>
</tr>
<tr>
<td>Return to the first frame in a stack</td>
<td>Click the Rewind button</td>
<td>Page Down</td>
</tr>
<tr>
<td>Move back one frame</td>
<td>Click the Step Reverse button</td>
<td>Page Up</td>
</tr>
<tr>
<td>Advance to the next frame</td>
<td>Click the Step Forward button</td>
<td></td>
</tr>
<tr>
<td>Advance to the last frame in the stack</td>
<td>Click the Fast Forward button</td>
<td></td>
</tr>
</tbody>
</table>
To set the preview rate

- In the Frame Stacks panel, move the Playback slider.

Using onion skinning

Onion skinning is a feature animators use to view previous and future frames while working in the current frame. Traditional animators work on an onion skin paper that allows them to see a sequence of frames through transparent layers. They then draw successive frames, using the previous frames for reference. Seeing several images superimposed helps increment the action evenly.

Scrolling a background is another example of a cycled action. Commonly, a subject remains in one place while the background slides by.

Corel Painter lets you work with two to five onion skin layers. You can specify the number of onion skin layers when you first open a frame stack or create a movie. To change the number of onion skin layers, you must close the file and reopen it.

The Frame Stacks panel displays a linear view of the onion skin layers. Each thumbnail represents one onion skin layer, and the thumbnail of the current frame has a red triangle above it.

You can change the current frame by clicking any thumbnail in the Frame Stacks panel. This lets you view a frame in any position of the onion skin sequence. For example, if you want to display the reference frames before the current frame, set the current frame to the far-right position in the panel. If you want to display the frames before and after the current frame, set the current frame to the middle thumbnail in the panel.

To show onion skin layers

- Choose Movie ➤ Show Onion Skin Layers.

  In the document window, the current frame appears darkest. Each frame moving away is progressively fainter.

Animating with layers

One of the simplest ways to create animation in Corel Painter is to add an item from the Image Portfolio panel across a series of frames. This is the most basic example of animating with layers. Adding multiple layers allows you to make more complex animations.

You can also group layers and move them simultaneously, but be careful. When you leave a frame, Corel Painter drops the layers in that frame. When a layer is dropped, its contents are merged with the canvas and can no longer be accessed separately. For this reason, you may want to work from the background forward; start by animating what’s farthest from your point of view. For more information, see “Dropping layers with the canvas” on page 590.

You can also rotate a layer. Rotating a layer can degrade its on-screen image quality, but this does not affect its printed quality.
To create motion with layers

1. Choose Movie ➤ New Movie.
2. Type 1 in the Number of Frames box.
3. Enable one of the Layers of Onion Skin options, and click OK.
4. In the Enter Movie Name dialog box, choose a location, type a name for the file, and click Save.
5. Choose Window ➤ Media Panels ➤ Images.
6. Double-click an item in the Image Portfolio panel to add it to the document window. A new layer is created.
7. Position the layer to the far left of the document window.
8. Click the Step Forward button in the Frame Stacks panel. A new frame is added and becomes the current frame. The layer in the previous frame is merged with the canvas. In the new, current frame, the layer is active.
9. On the keyboard, press the arrow keys to move the portfolio image.
10. Repeat steps 8 and 9 for as many frames as you want to add.
11. In the last frame, click the Layer options button in the Layers panel, and choose Drop.
12. Click the Play button in the Frame Stacks panel. The portfolio image moves across the screen.

Adding, deleting, and erasing frames

You can add frames at the end or beginning of a movie, or in between any frames in the stack. You can also delete frames from a movie and all subsequent frames are renumbered as necessary. In addition, you can clear the frame contents, but retain the paper color. You cannot undo the actions of deleting and erasing frames, so it’s best to create animations in small segments and then combine them when you are finished. For more information, see “Inserting movies” on page 823.

To add frames

1. Choose Movie ➤ Add Frames.
2. In the Add Frames dialog box, type the number of frames in the Add box.
3. Enable an option for frame placement.
   For example, to add six blank frames before frame 10, type 6 in the Add box, enable the Before option, and type 10 in the Frame box.

To delete frames

1. Choose Movie ➤ Delete Frames.
2. In the Delete Frames dialog box, enter the range of frames to delete.

To erase frames

1. Choose Movie ➤ Erase Frames.
2. In the Erase Frames dialog box, enter the range of frames to erase.

Repeating frames

You can repeat actions to create an animated cycle. You can also repeat the last frame at the end of the stack.
Take, for example, a blinking eye. For this type of action, draw the cycle once, and repeat it as many times as needed.

![Blinking Eye Animation](image)

*This example shows a blinking eye as an animated cycle. You draw the frames once, and then repeat them.*

To create a clean cycle, the beginning and ending images must be the same. For example, in an animation of a blinking eye, the eye would be open at the beginning and at the end. That way, when the end of one cycle is “hooked up” to the beginning of the next, the action continues smoothly.

**To repeat the last frame**

1. In the Frame Stacks panel, click the Fast Forward button 🔁.
2. Choose Movie ➤ Clear New Frames to disable this command. The check mark beside the Clear New Frames command is removed.
3. Click the Step Forward button ▶️ in the Frame Stacks panel.

You can add blank frames at the end of a movie with the Step Forward button ▶️ when the Clear New Frames command is enabled.

**Inserting movies**

You can combine movies by inserting the frames of one movie into another. You can insert a movie before or after a specific frame, at the start of a movie, or at the end of a movie.

You can insert only Corel Painter movie (FRM) files. You cannot insert frames from QuickTime, AVI, or numbered files. However, if you open a QuickTime or AVI file in Corel Painter, you can save it to the FRM format in order to insert it into another Corel Painter movie.

**To insert a movie**

1. Choose Movie ➤ Insert Movie.
2. Enable an option in the Insert Movie area.
3. In the Select Movie dialog box, locate the movie that you want to insert.
4. Click Open.

The movie you insert must have the same frame size (width and height) as the current movie. You will also get better results if both movies use the same frame rate.
Rotoscoping

Rotoscoping is the process of painting on a movie, applying effects to a movie, or compositing a portion of the images from one movie with the images of another. This is often done to make the action of a person filmed in one place appear on a background filmed in another. You can also use rotoscoping to remove an element from a video clip, as shown below in the frames from a short movie of an owl on a roost. After the video was captured digitally, it was imported into Corel Painter, and the roost was removed frame by frame by using the masking tools.

Rotoscoping is also useful for adding a background to an animation. The process is the same whether you work with digitized video or painted animation cells.

Applying scripts to movies

The Script feature lets you repeat the same actions for each frame in a movie. For example, you might want to apply an effect like Glass Distortion to a video clip. You can record a script that applies the Glass Distortion effect to a single image and then, with a single command, apply that script to the entire movie. A script can contain almost any action — a single command, a series of commands, or the many steps in creating an original drawing. You’ll devise scripts based on the needs of your project.

You cannot undo changes after applying a script to a movie. Before applying the script, you should become familiar with scripting and experiment with a separate sample image. You might want to work with a copy of the movie, or you might apply the script to a short sample movie to test it. For complete information on working with scripts, see “Using scripts to automate tasks” on page 831.

Using scripts to set grain position

You can use a script to apply a surface texture (paper grain) to an entire movie. In this case, you have several options for the position of the grain in each frame. You can put the grain in exactly the same position, move the grain randomly, or move it linearly by a set number of pixels.

Using scripts to apply brushstrokes

You can apply a recorded brushstroke to a movie. Corel Painter divides the stroke into as many segments as there are frames and places the segments in successive frames. This feature is most useful when used with the Image Hose. When you apply a brushstroke to a movie using the Image Hose brush, one or more Nozzle images are deposited on each frame. If the Nozzle file is an animated sequence — for example, a person walking — Corel Painter can drop successive images on successive frames. Play the movie back, and the person walks across the document window. For this to work, you must set up the Nozzle file appropriately and have the right Image Hose brush size. For more information, see “Painting with the Image hose” on page 517.

To create a script for a movie

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Script options button in the upper-right corner, and choose Record Script.
Perform the actions you want included in the script, and click the Stop button \( \text{Stop} \) in the Scripts panel.

In the Script Name dialog box, type a name for the script in the Save as box.

To apply a script to a movie

1. Open the movie to which you want to apply the script.
2. Choose Window \( \rightarrow \) Scripts.
3. In the Scripts panel, click the Script options button \( \text{Script options} \), and choose Apply Script To Movie.
4. In the Apply Script To Movie dialog box, double-click a script.

Corel Painter applies that script to each frame in the stack. If you have a few small frames in your movie, and the script is not a complicated one, the script can be applied quickly. If the movie has several large frames, a complicated script could take a long time.

You can apply only scripts that do not create new images.

To set grain position with a script

1. Record a script that applies surface texture or dye concentration to an entire image.
2. Choose Movie \( \rightarrow \) Set Grain Position.
3. In the Set Grain Position dialog box, enable one of the following options:
   - Grain Stays Still — allows the grain to remain in the same position throughout the movie
   - Grain Moves Randomly — moves the grain as the movie plays. To use this option, you must disable the Record Initial State option when recording your script. In the Scripts panel, click the Script options button \( \text{Script options} \), and choose Script Options. In the Script Options dialog box, disable the Record Initial State check box.
   - Grain Moves Linearly — increments the grain movement. Specify the number of pixels you want the grain to move horizontally and vertically from one frame to the next.
4. Click OK.
5. Choose Window \( \rightarrow \) Scripts.
6. In the Scripts panel, click the Script options button \( \text{Script options} \), and choose Apply Script To Movie to apply the grain script. Each frame is textured according to your selected method.

To apply a brushstroke script

1. Choose Brushes \( \rightarrow \) Record Stroke.
2. Create a brushstroke in the document window.
3. Open a movie file.
4. Choose Movie \( \rightarrow \) Apply Brush Stroke To Movie.

Exporting movies as QuickTime

You can export a movie as a QuickTime movie on the Windows platform.

QuickTime supports several compression schemes. The following descriptions should help you choose one; however, you’ll probably want to experiment with different compressors and settings to identify the best settings for your work. You may also have additional compression methods available.

- The Animation method works well with areas of continuous tone. If you set the Quality in the Compression Settings dialog box to Best and make every frame a key frame, this compressor is lossless. For most Corel Painter animations, this compressor is a good choice.
• The Cinepak method produces acceptable motion and image quality at remarkably small file sizes. It is the preferred format for CD delivery and transfer across the Internet. Cinepak can take a long time to compress, and it can be difficult to find the best compression settings for certain image types and frame rates.

• The Graphics method is limited to 256 colors. It compresses the file at a greater ratio than the Animation compressor, but does not play as quickly.

• The None option uses no compression, so the images retain all of their quality. With a large frame size, some computers might not be fast enough to play at a high frame rate.

• The Photo-JPEG method allows high compression ratios while maintaining excellent image quality. However, it does not play at high rates. JPEG is an international standard for image compression.

• The Video method is designed for recording and playing back digitized video at high rates. Because of the spatial compression method it uses, the Video compressor does not provide optimal results for images with large areas of continuous tone, such as those in most animations.

The compression ratio is inversely proportional to image quality. The Quality slider allows you to set an optimum level between the amount of compression and image quality. For most work in Corel Painter, it is best to set the Quality slider to High.

You can specify the number of frames you want displayed per second and, with some compression methods, the frequency of key frames. Key frames are used in temporal compression methods. Each key frame is stored in its entirety. The next set of frames, up to the next key, are saved only as changes.

With some compression methods, you can also limit the speed of data transmission with the Limit Data Rate option. The data rate limit overrides the Quality setting, if necessary, to keep the compressed movie within the set limit.

To export a Corel Painter movie as a QuickTime movie

1. Choose File ➔ Save As.
2. In the Save Movie dialog box, enable the Save Movie As QuickTime option.
3. In the Enter Movie Name dialog box, choose a location, enter a name for the file, and click Save.
4. In the Compression Settings dialog box, choose a compression method from the list box.
5. Specify the options you want.

Exporting movies as AVI

The AVI format supports several compression schemes. The following descriptions should help you choose one; however, you'll probably want to experiment with different compressors and settings to identify the best settings for your work. You may also have different compression methods available.

• The Cinepak method produces acceptable motion and image quality at remarkably small file sizes. It is the preferred format for CD delivery and transfer across the Internet. Cinepak takes a long time to compress, and it can be difficult to find the best compression settings for certain image types and frame rates.

• The Microsoft Video 1 method is designed for recording and playing back digitized video at high rates.

• The Full Frames (Uncompressed) method uses no compression, so the images retain all of their quality. With a large frame size, some computers might not be fast enough to play at a high frame rate. This is the preferred format for transferring Corel Painter movies to AVI-editing applications.

The compression ratio is inversely proportional to image quality. In the Video Compression dialog box, the Compression Quality slider allows you to set an optimum level between the amount of compression and image quality.

Key frames are used in temporal compression methods. Each key frame is stored in its entirety. The next set of frames, up to the next key, are saved only as changes. With some compression methods, you can specify the frequency of key frames with the Key Frame Every [Number] Frames option.

With some compression methods, you can also limit the speed of data transmission with the Data Rate option. The data rate limit overrides the Quality slider setting, if necessary, to keep the compressed movie within the set limit.
Understanding frame rate

Frame rate describes the number of image frames displayed per second (fps). The frame rate can determine not only how big a file your animation is, but also how smooth the motion appears.

When you save a movie as an AVI file, you can specify the rate of display. This doesn’t necessarily mean that what you specify is what you’ll experience. Factors like frame size, compression method, and computer speed can prevent some movies from achieving their set rate. If your animations will be viewed on the computer only, frame rates of 8, 10, and 12 fps are good choices. If your animations will be viewed elsewhere, you should consider the following frame rates:

- The frame rate of film is 24 fps.
- The frame rate of National Television System Committee (NTSC) video is 30 fps (29.97 fps in broadcast video). NTSC is the video standard used in the United States.
- The frame rate of Phase Alternating Line (PAL) video is 25 fps.

These frame rates are sufficient to produce smooth, continuous motion with filmed or video-recorded subjects.

Animation drawings contain far less detail than live-action images. The difference in the level of detail allows animations to be produced at frame rates significantly lower than those designed for live action. Because of the smoothness of color fills and continuity between images, animations can look quite nice at rates between 10 and 15 fps.

You must consider frame rates to know how many drawings are needed to make actions smooth, natural, and consistent throughout the project.

The computer can display frames at any reasonable rate. The Frame Stacks panel provides control over frame display rates. You can preview an animation at a rate of 1 to 40 fps.

To export a Corel Painter movie as an AVI movie

1. Choose File ➤ Save As.
2. In the Save Movie dialog box, enable the Save Movie As AVI option, and specify the number of frames per second.
3. In the Enter Movie Name dialog box, choose a location, enter a name for the file, and click Save.
4. In the Video Compression dialog box, choose a compression method from the Compressor list box.
5. Specify the options you want.

   For some compression methods, you can click Configure to specify additional options.

Importing and exporting numbered files

Corel Painter supports importing and exporting numbered files. Numbered files are any series of files that are the same size and resolution, and named following a specific style, which includes a number at the beginning or end of each file name. For example, the first frame might be called “Movie01,” the second frame “Movie02,” and so on.

When you export a movie as numbered files, you can import the numbered files into an application that may not support other movie formats. When exporting, you specify the filename for the first file. You must include zeros so that all numbered files have the same number of digits. For example, to create numbered files from 1 to 24, include “01” in the filename. To create numbered files from 89 to 110, include “089” in the filename.

Importing numbered files is an excellent method of bringing an animation from another 3D or animation program into Corel Painter. The file format of the numbered files you are importing must be supported by Corel Painter, and the number of digits in each filename must be the same. When you import numbered files, you create a new frame stack, and you are prompted to choose a number of onion skin layers and a storage type. For more information, see “Creating frame-by-frame animation” on page 817.

To export a movie as numbered files

1. Choose File ➤ Save As.
In the **Save Movie** dialog box, enable the **Save Movie As Numbered Files** option, and click **OK**.

In the **Save Numbered File As** dialog box, choose a location and file format, enter a name for the first file, and click **Save**.

You must begin or end the filename with a number — for example, “01Movie” or “Animation14.”

To import numbered files

1. Choose **File > Open**.
2. Enable the **Open Numbered Files** check box in the **Open** dialog box.
3. Select the first numbered file, and click **Open**. Then, select the last numbered file, and click **Open**.
4. In the **Enter Movie Name** dialog box, choose a location to save the imported movie, enter a filename, and click **Save**.
5. In the **Open Frame Stack** dialog box, choose a number of onion skin layers and a storage type, and click **OK**.

Corel Painter sequences the images into the frames of a new frame stack.

Exporting animated GIFs

Corel Painter lets you export a frame stack as an animated GIF file. The animated GIF format is ideal for displaying simple animations on the web.

You can use a GIF as a link anchor or as an image map. However, you cannot use it as a background.

There are many options available when you save images to a GIF file.

You can apply transparency to the animation and choose a background option. However, you must set up a selection for each frame. For more information, see “Getting started with selections” on page 620.

The **Disposal Method** options let you specify what happens to an image after it has been displayed (and its frame delay has passed), and before the next image is displayed. The disposal method is significant only when you use transparency that differs between frames.

The **Loop** option lets you play the animation repeatedly in the client browser. The animation appears in the browser one frame at a time, at the speed at which it is downloaded. In most cases, this is significantly slower than the intended display rate. With the **Loop** option enabled, the browser will loop the animation after all frames have been downloaded, with the specified delay between frames. Because the animation plays from the browser’s cache, it’s much faster.

If your movie is intended for the web, you should consider reducing its file size so the movie is small enough to download within a reasonable amount of time. You can minimize file size by doing any of the following:

- Reduce the frame size. You choose the frame size when you create a new movie. If you import an existing animation or video, you cannot resize the frames.
- Limit the number of frames because each frame increases the file size.
- Limit the number of colors. When you reduce the number colors in the image, you are also reducing the size of the color palette, which leads to smaller files.

To export a frame stack as an animated GIF

1. With the frame stack open, choose **File > Save As**.
2. In the **Save Movie** dialog box, enable the **Save Movie As GIF Animation** option.
3. In the **Enter Movie Name** dialog box, choose a location, type a filename, and click **Save**.

   The **Save as GIF Options** dialog box appears.
4. Enable an option in the **Number of Colors** area.
5. In the **Imaging Method** area, enable one of the following options:
   - **Quantize to Nearest Color** — reduces the number of similar colors in the image without affecting the overall image. This is useful for images with broad areas of a single color.
   - **Dither Colors** — simulates a greater number of colors when only a limited number of colors are available.
In the **Animation Options** area, type a value in the **Frame Delay** box to specify a pause (in 100ths of a second) between frames.

In the **Disposal Method** area, choose one of the following options:

- **Default** — uses the client browser’s default disposal method
- **Background** — Restores to the background color the region covered by the image
- **None** — leaves the image on-screen while rendering the next frame over it
- **Previous** — displays the imagery of the previous frame to the region covered by the image

You can now use your browser to open the file and view the animation. You can place the animation on a web page using the same HTML image tag you’d use for a simple GIF file.

You can also

Gradually display images in the web browser as they load  
In the **Misc Options** area, enable the **Interlaced** option.

Enable server-side image map  
In the **Map Options** area, enable the **NCSA Map File** or **CERN Map File** option.

Enable client-side image maps  
In the **Map Options** area, enable the **Client Side Map File** option.

Apply transparency  
In the **Transparency** area, enable the **Output Transparency** option, and then enable a background option. Move the **Threshold** slider to specify the selection mask value at which the image becomes transparent.

Repeat the animation  
Enable the **Loop** check box, and type the number of times to repeat the animation. If you want it to repeat indefinitely, type 0.

If you do not set a frame delay, the frames appear as quickly as the system can load and display them. The display of each image (especially with larger frames) varies between computer systems, so the actual animation display rate may be lower. You can use frame delay to approximate a particular frame rate. For example, you capture some one-quarter size video at 8 frames per second (fps). You want 8 frames to appear in one second, so you divide one second (100 hundredths of a second) by 8. The result is 100/8 = 12.5. Discard the decimal portion and enter 12 as the frame delay. Discarding the decimal is the only allowance for the time required to display each image. For a large frame size, you might want to allow more time for display.

If the animation in the browser window stops playing, it’s probably finished the set number of loops. In some browsers, you can get it started again by resizing the window. In all browsers, you can get it started again by reloading the page.
Using scripts to automate tasks

You can use scripts to speed up repetitive tasks, combine multiple or complex actions, or make an option more easily accessible.

This section contains the following topics:

Working with scripts
- “Getting started with scripts” (page 831)
- “Displaying the Scripts panel” (page 832)
- “Recording and playing scripts” (page 832)
- “Enabling and playing background scripts” (page 834)
- “Creating resolution-independent scripts” (page 834)
- “Editing, renaming, and deleting scripts” (page 835)
- “Converting scripts to movies” (page 836)
- “Importing and exporting scripts” (page 837)

Managing script libraries
- “Importing and exporting script libraries” (page 837)
- “Creating and deleting script libraries” (page 838)

Getting started with scripts

Using a script is similar to using the speed-dialing feature on a phone. On many phones, you can set a frequently dialed number to a speed-dial button; then, the next time you need to dial that number, you can save time by pressing its speed-dial button. Similarly, a script lets you set the actions that you want to repeat; then, the next time you need to repeat those actions, you can save time by playing the script.

You can record anything in a script — from a single edit command to an entire work session.

There are a number of ways to take advantage of scripting:
- You can record a script to replace repetitive tasks.
- You can use background scripts to back up your work, which gives you the ability to revert to any stage in the project by playing the script and stopping it at the stage you want. This technique is similar to using multiple levels of undo. For more information, see “Enabling and playing background scripts” on page 834.
- You can play back a script at a different resolution. You can record at a low resolution, then automatically produce the same results at a higher resolution. For information, see “Creating resolution-independent scripts” on page 834.
• You can record a script that plays back using the current art materials. For example, you can record a script of a pencil drawing, then open a new document, choose a different paper texture, color, and brush, and play back the script. Then, you can watch Corel Painter repeat your drawing with the selected art materials. For more information, see “Recording and playing scripts” on page 832.

• (Windows only) You can record a script to use as a tutorial so you can show someone the step-by-step process used to create an image. It’s like looking over the artist’s shoulder. You can then convert the script to an .avi movie to share techniques with others. Every action you take becomes a frame in the movie. For more information, “Converting scripts to movies” on page 836.

• (Windows only) You can use scripts with movies. When you have an operation that you want to apply to each frame in a movie, record the set of commands in a script. You can then apply the script to the entire movie as one command. For more information, see “Applying scripts to movies” on page 824.

Displaying the Scripts panel

The Scripts panel supplies the basic tools for recording, playing, and editing scripts. It also gives you access to the Scripts library viewer, which is used for storing and managing the scripts and script libraries that you create.

To show or hide the Scripts panel

• Choose Window ➔ Scripts.

Recording and playing scripts

Scripts allow you to record every action you make so you can repeat all actions with only one click of a button. For example, if you need to apply color adjustments to a collection of images, you can record a script while performing the process for the first image, and then play the script to apply the changes to the other images in the collection. From the Scripts panel, you can access the basic functions for recording and playing scripts.
When recording scripts, you have the option of recording the initial state of the application. This includes the tools and art materials that you use during the session, including brushes, colors, and paper textures. Corel Painter plays the session using the materials that you recorded. If you disable this option, Corel Painter uses the tools and art materials selected at the time you play back the script. For example, you can use a different brush, color, and paper texture each time you play the script to produce different results.

To prepare for a script recording session, you may find it useful to write down the individual steps that you want to perform so you don’t forget any steps while recording. However, you can edit or delete a script if you’re not satisfied with the result. For more information, see “Editing, renaming, and deleting scripts” on page 835.

To record a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Record button •.
3. Perform the actions that you want to record.
4. Click the Stop button ■.
5. In the Script Name dialog box, type a name in the Save As box.

Corel Painter automatically adds an icon for the script in the Scripts library viewer.

You can record a script that enables you to change art materials on playback by clicking the Script options button ●, choosing Script Options, and disabling the Record Initial State option.

When you create a new script, it is automatically saved to the currently selected library. You can move a script from the library panel by dragging a resource from one library to another.

To play a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, choose a script from the Scripts library viewer.
3. Click the Play button ➤.

You can also

Stop the script

Click the Stop ■ button.

Temporarily interrupt the script

Click the Pause button ⅛.

You can also use Command + . (macOS) or Ctrl + . (Windows) to stop a script from playing.
If the script requires brushes, papers, patterns, or other materials that are stored in alternate libraries, these libraries must be open during playback.

Enabling and playing background scripts

You can enable Corel Painter to automatically record background scripts. The background script starts recording all of the operations that you perform from the moment you open the application until you close the application. Background scripts are saved in the Scripts panel with a timestamp, along with the other scripts that you create. You can specify how long Corel Painter saves background scripts before deleting them.

You can play background scripts; however, unlike custom scripts, you cannot edit background scripts.

To enable background scripts

1. Do one of the following:
   * (macOS) Choose Corel Painter menu ➤ Preferences ➤ General.
   * (Windows) Choose Edit ➤ Preferences ➤ General.
2. Enable the Auto-record script check box.
3. Specify the number of days for which you want Corel Painter to store background scripts in the Auto-save scripts for box.

Because Corel Painter always saves your script data, the data can build up in your Corel Painter Script Data file.

To play a background script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, choose a background script from the Scripts library viewer.
   Background scripts are listed by the date and time they were created.
3. Click the Play button ➤.

Creating resolution-independent scripts

You can create a resolution-independent script that allows you to record a script that automatically adjusts to the resolution of the image in which you’re playing the script. When you’re creating the script, you can get smoother, more responsive performance by working at low resolution. Then, when you play back the script at a higher resolution, you get the benefit of a higher quality image.

The record-to-playback scaling ratio is limited. A factor of 4 is probably too much. For best results, you may need to experiment.

To record a resolution-independent script

1. Before you start recording, open a new document at the resolution in which you want to work.
2. Choose Window ➤ Scripts.
3. Before painting or drawing, choose Select ➤ All, or press Command + A (macOS) or Ctrl + A (Windows).
   This action creates a reference rectangle that is part of the recording. The rectangle must be recorded to play a session back into a higher resolution file later.
4. In the Scripts panel, click the Record button ●.
Deselect the reference rectangle by doing one of the following:

• Choose Select ▶ None.
• Draw inside the selected area.
• Press Command + D (macOS) or Ctrl + D (Windows).

Proceed with recording the script.

To play a script at a different resolution

1 Create a new document with the resolution at which you want to play the script.
   If you want the resulting image to be a higher resolution than the original, create a document with proportionally larger dimensions. For example, if the original document is 500 X 500 pixels, make the new document 1000 X 1000 pixels to double the size.
   If the destination document has a different aspect ratio from the original, the image created by the script will be proportionally distorted.

2 In the Scripts panel, click the resolution-independent script you recorded in the Scripts library viewer.

3 Before playing the script, choose Select ▶ All, or press Command + A (macOS) or Ctrl + A (Windows) in the new document.
   The rectangle recorded at the outset of the original script is referenced to the selected rectangle in this document.

4 Click Play.
   The original script replays into the new document. All brushes, paper textures, and related functions are appropriately scaled for the new resolution.

Editing, renaming, and deleting scripts

Corel Painter lets you modify scripts in different ways. You can edit script instructions in order to change a recorded action sequence. You can also rename and delete scripts.

You can edit a script by opening it as a series of instructions that contain parameters, most of which are editable. You can also edit a script by exporting the script (.txt file) and then opening the file in a text editor. For more information, see “Importing and exporting scripts” on page 837.

To edit script parameters

1 Choose Window ▶ Scripts.

2 In the Scripts panel, click the script that you want to edit from the Scripts library viewer.

3 Click the Scripts options button ▶, and choose Edit Script.
   Corel Painter displays a list of the script's instructions in the Edit Script dialog box.

4 Double-click the instruction line that you want to edit.

5 Double-click a parameter within the instruction.

6 In the parameter’s dialog box, make the necessary changes.

7 Close the dialog box.

8 In the Edit Script dialog box, click Done to save the changes to the script.

The open script becomes the current script and is displayed in the Scripts library viewer. If you choose another script from the Scripts library viewer, the open script does not change.

You can also edit a script by exporting the script and then opening the script file in a text editor. You can export a script by clicking the Scripts options button ▶ in the Scripts panel, and then choosing Export Script.
To rename a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, choose a script from the Scripts library viewer.
3. Click the Script options button, and choose Script Library View ➤ Rename Script.
4. Type a new name in the Save As box.

To delete a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, choose a script from the Scripts library viewer.
3. Click the Delete button.

Converting scripts to movies

(Windows only)

You can convert a script into a Corel Painter movie, which you can save as a QuickTime or AVI file. Every action you perform in the script becomes a frame in the movie. For more information, see “Exporting movies as AVI” on page 826 and “Exporting movies as QuickTime” on page 825.

If the script is resolution-independent, you can replay the session into a movie using different dimensions. For more information, see “Creating resolution-independent scripts” on page 834. However, if the script is resolution-dependent and the new image window is larger, the script plays back in the upper-left corner of the movie. If the new image is smaller than the script dimensions, only the upper-left portion of the scripted session appears in the movie.

You can also apply a script to a movie. For example, you can record a script that applies the Motion Blur effect to a single image. Then, with a single command, you can apply the script to each frame of a movie. You can also use a script to set grain position in a movie. For more information, see “Applying scripts to movies” on page 824.

To convert a script into a movie

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click a script in the Scripts library viewer.
3. Open a new image at the size you want the movie to be.
4. In the Scripts panel, click the Script options button, and choose Script Options.
5. In the Script Options dialog box, enable the Save Frames on Playback check box. This option creates a movie on playback.
6. Type the number of tenths of a second that you want between frames.
   The lower the number, the more frequently a frame is created and the more fluid the movie is. More frames, however, use more disk space.
7. In the Scripts panel, click Play.
8. In the Enter Movie Name dialog box, type a name in the File name box, choose a destination folder, and click Save.
9. In the Open Frame Stack dialog box, enable an option in the Layers of Onion Skin area.
10. In the Storage Type area, enable an option for storing color.

   Corel Painter plays the script into the Frame Stacks dialog box.
Not all actions can be converted into a movie. For example, a script that contains a File ➤ New command will not be converted.

### Importing and exporting scripts

You can import and export scripts. For example, you can import a script that was created by someone else, or export a script to share it with others. Corel Painter scripts are exported as .txt files. In addition, you can import or export script libraries. For more information, see “Importing and exporting script libraries” on page 837.

#### To import a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Import a script button 📄.
3. Choose the drive and folder where the script is stored.
4. Click the script file.
5. Click Open.

#### To export a script

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Export the currently selected script button 📄.
3. In the Export script dialog box, choose the drive and folder where you want to store the script.
4. Click Save.

### Importing and exporting script libraries

You can import multiple scripts at once if they are stored in a script library. This includes script libraries that were created in a previous version of Corel Painter. You can also export script libraries. In the Script library viewer, you can open and view multiple libraries at once.

#### To import a script library

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Script options button ☰, and choose Import Script Library.
3. Choose the drive and folder where the library is stored.
4. Choose the library.
5. Click Open.

The imported library is displayed at the bottom of the panel window.

#### To import a script created in a previous version of Corel Painter

1. Choose Window ➤ Scripts.
2. In the Scripts panel, click the Script options button ☰, and choose Import Legacy Script Library.
3. Choose the drive and folder where the library is stored.
4. Choose the library.
To export a script library
1. Choose Window  Scripts.
2. In the Scripts panel, click the Script options button ..., and choose Export Script Library.
3. In the Choose Library dialog box, choose the library that you want to export from the Library list box, and click OK.
4. Choose the drive and folder where you want to store the library.
5. Click Save.

Creating and deleting script libraries
You can store and organize scripts to make it easier to locate and access them. When you create a new script, it is automatically saved to the currently selected script library. However, you can move a script to a new library. If you no longer need a script library, you can delete it.

To create a script library
1. Choose Window  Scripts.
2. In the Scripts panel, click the Script options button ..., and choose New Script Library.
3. In the New Library dialog box, type a name in the Save As box, and click OK.
   A header bar for the new library appears at the bottom of the library panel and its title appears in the list of available libraries. The new library contains one script by default.

To delete a script library
1. Choose Window  Scripts.
2. In the Scripts panel, click the Script options button ..., and choose Remove Script Library.
3. In the Choose Library dialog box, choose a library from the Library list box, and click OK.
4. Click Yes.
Printing images

Corel Painter provides extensive options for printing your work.

This section contains the following topics:

• “Printing basics” (page 839)
• “Printing images” (page 840)
• “Saving files in EPS format for printing” (page 841)
• “Printing composite images” (page 842)
• “Printing shapes” (page 842)

Printing basics

Whether you are planning to print your artwork to your desktop printer or send it to a print service provider, keep the following considerations in mind to ensure that the finished image appears as intended.

Image size, resolution, and print quality

The size and resolution of an image affect its print quality. For best results, set the image resolution and size when you create your document. Choose image dimensions and resolution that match your print intent. For information about image resolution, see “Resolution and print quality” on page 98. For information about image dimensions, see “Canvas size and aspect ratio” on page 96.

Printing colors accurately

Corel Painter allows you to manage colors when printing to ensure accurate color reproduction. Color management is not enabled by default. If you want to use color management while working on or printing a document, you must first set up color management for your system. For more information, see “Color management” on page 265.

Proofing and soft-proofing documents

Soft-proofing lets you look at the final result without committing ink to paper. You can verify whether the color profile of the document is suitable for a specific printer or monitor and avoid unwanted results. For more information, see “What is soft-proofing?” on page 268.

If you’re sending your images to a print service provider for printing, it is recommended that you first obtain proofs. You can use proofs from a black-and-white printer to check page size and image placement. Proofs from a color printer provide a general impression of what your final image will look like. Keep in mind that the proof is not an accurate representation of a final print produced by an offset printing process. The final output is affected by a combination of the print process, inks, and paper types used.
Printing images

Before printing an image, you can specify printer properties, including paper size and device options. For example, you can specify printer features such as duplexing stapling. The preferences that you choose depend on several factors: the type of output device to be used, whether the printed output will be in color or in black and white, and whether you are printing separations. You can print Corel Painter images on a wide variety of printers, including PostScript, Windows Graphics Device Interface (GDI), and QuickDraw, and high-resolution imagesetters.

You can manually adjust the page size, orientation, and margin settings to match the standard paper settings for printing. You can also print an image that is larger than a selected page size by automatically resizing the image to fit the page. For example, you can automatically resize a 12-by-12-inch image to fit on an 8.5-by-11-inch page.

You can also print an image to a file, so you can send the file to a print service provider for printing. Some of these options are available only on the Windows operating system.

To set printer properties
1. Choose File  Print.
2. Do one of the following:
   • (macOS) Click the Show Details button, and choose an option from the list box (such as Page Attributes, Layout, Color Matching, or Paper Feed).
   • (Windows) On the General page, click Preferences.
3. Set any properties in the dialog box.

To print an image
1. Choose File  Print.
2. Do one of the following:
   • (macOS) Choose a printer from the Printer list box, choose an option from the Pages list box, and type a value in the Copies box.
   • (Windows) On the General page, choose a printer from the Select Printer area, enable an option in the Page Range area, and type a value in the Number of copies box.
3. Click Print.

You can also

Print a grayscale version of the image
Do one of the following:
• (macOS) Click the Show Details button, choose Corel Painter 2020 from the list box, and enable the Print Grayscale check box.
• (Windows) Choose the Painter 2020 tab, and enable the Print Grayscale check box.

Print to a non-PostScript printer (Windows only)
Choose the Painter 2020 tab, and enable the GDI Printing option.

Print an image to a color PostScript device (Windows only)
Choose the Painter 2020 tab, and enable the Color PostScript option.

Print separations (Windows only)
Choose the Painter 2020 tab, and enable the Separations option.
You can also

The output consists of four pages, one each for cyan, magenta, yellow, and black. You can print separations from Corel Painter with PostScript devices, including high-resolution imagesetters. Corel Painter places a color bar, registration marks, and the color name on each of the four separated plates.

Print an image to a black-and-white PostScript laser printer (Windows only)

Choose the Painter 2020 tab, and enable the B & W PostScript option.

To manually adjust page layout for printing

1  Do one of the following:
   • (macOS) Choose File ➤ Print, click the Show Details button, and choose Page Attributes from the list box.
   • (Windows) Choose File ➤ Page Setup.
2  Choose a preset page size from the Paper Size list box (macOS) or the Size list box (Windows).
3  In the Orientation area, choose one of the following options:
   • Portrait — sets the page’s height to be greater than its width
   • Landscape — sets the page’s width to be greater than its height
4  Do one of the following:
   • (macOS) Choose Margins and Layout from the list box, and choose any margins and layout options you want.
   • (Windows) In the Margins area, specify values in the Left, Right, Top, and Bottom boxes.

To automatically resize an image to fit the page

1  Choose File ➤ Print.
2  Do one of the following:
   • (macOS) Click the Show Details button, choose Corel Painter 2020 from the list box, and enable the Fit to page check box.
   • (Windows) Click the Painter 2020 tab, and enable the Size to Fit Page check box.

You must enable this option to print images larger than the page size.

To print to a file (Windows only)

1  Choose File ➤ Print.
2  On the General page, enable the Print to file check box.
3  Click Print.
4  In the Save Print Output As dialog box, type a filename in the File name box.

Saving files in EPS format for printing

You can save files in EPS-DCS format for printing. It is important to note that you cannot reopen EPS-DCS files in Corel Painter. Therefore, you should also save a copy in another format first so that you can reopen it in Corel Painter.

When saving to EPS-DCS, you can enable an output preview, such as color preview. Corel Painter uses the loaded ICC profiles to control separation. If the output preview is disabled, Corel Painter uses the default separation tables. For more information, see “Understanding color management” on page 265.
The images that you save as encapsulated PostScript (EPS) files conform to the Desktop Color Separation (EPS-DCS) format.

To save a file in EPS format for printing

1. Choose File ➤ Save As.
2. In the Save Image As dialog box, choose PostScript EPSF from the Format (macOS) or Save as type (Windows) list box, and click Save.
3. In the EPS Save Options dialog box, enable the Hex (ASCII) picture data check box to change the data format. Enabling this check box allows another method of storing PostScript information, but it approximately doubles the size of the saved file. Some programs require this option to be enabled.
4. Enable one of the following output preview options:
   - No preview
   - Black and white preview
   - Color preview
   You may need to enable the Black and white preview option to print EPS files on some laser printers. Although the preview or display is in black and white, the color information remains intact.

   If you are creating a document that is destined for printing as well as online viewing (for example, a PDF file), enable the Color preview option.

   Corel Painter uses the device’s default screening information to produce high-quality color separations. If the No preview option is enabled when you save a file in EPS format, Corel Painter uses the Color Studio separation tables with your device’s default screening.

Printing composite images

Printing a composite image that contains many layers and shapes can be time-consuming. You can print a single-layer version of the image much more quickly.

Instead of flattening a composite image by dropping each layer to the canvas, you can clone the file to produce a flattened image, which you can then print. This method lets you preserve the layers in the saved RIFF file in case you want to change them later. For more information, see “To clone an image by using Quick Clone” on page 188.

Printing shapes

In Corel Painter, you can interleave shapes with layers in the Layers panel, which can affect how your document is printed. Shapes are vector objects, as opposed to pixel-based objects, which makes them resolution-independent. Corel Painter attempts to preserve shapes as vector paths in order to print at the full native resolution of PostScript printers.

When printing to PostScript devices, Painter will rasterize shapes that use effects such as transparency and certain composite methods.
Any object in a lower position in the **Layers** list “touched” by a rasterized shape must also be rasterized to preserve the effect. For example, if you have a shape with transparency on top of a number of other shapes, all shapes below it must be rasterized to preserve the transparency on the canvas even if the overlap area is small. Similarly, if part of an image from a layer is placed over a shape, the shape must be rasterized to be correctly printed.

If you want to print shapes at the full resolution of your printer, ensure that the shapes are not transparent, that their composite method is set to **Default**, and that they are not under any other transparent layers or objects.

For more information about shapes, see “Shapes” on page 785.
Notes for users of Adobe Photoshop

If you have previously worked with Adobe Photoshop, you may notice the differences in the tools and terminology of Corel Painter. This section describes these differences and provides additional tips to help you move smoothly between these applications.

This section contains the following topics:

- “Comparing terminology in Corel Painter and Adobe Photoshop” (page 845)
- “Comparing tools in Corel Painter and Adobe Photoshop” (page 846)
- “Frequently asked questions from users of Adobe Photoshop” (page 847)

Comparing terminology in Corel Painter and Adobe Photoshop

Certain terms and concepts in Corel Painter differ from those of similar features in Adobe Photoshop. The following table lists some common terms in Photoshop with their equivalent terms in Corel Painter.

<table>
<thead>
<tr>
<th>Adobe Photoshop term</th>
<th>Corel Painter term</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>Script</td>
</tr>
<tr>
<td>Adjustment layer</td>
<td>Layer</td>
</tr>
<tr>
<td>Animation</td>
<td>Movie</td>
</tr>
<tr>
<td>Blending mode</td>
<td>Composite method</td>
</tr>
<tr>
<td>Indexed color mode</td>
<td>Web-safe color palette</td>
</tr>
<tr>
<td>Smart Object</td>
<td>Reference layer</td>
</tr>
<tr>
<td>Layer effect</td>
<td>Dynamic plug-ins</td>
</tr>
</tbody>
</table>
Comparing tools in Corel Painter and Adobe Photoshop

The following table lists Adobe Photoshop tools and the corresponding Corel Painter tools. Many of these tools create similar results but operate slightly differently. For that reason, we also provided a link to a corresponding help topic that describes the Corel Painter tool.

<table>
<thead>
<tr>
<th>Adobe Photoshop term</th>
<th>Corel Painter term</th>
<th>For more information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions palette</td>
<td>Scripts panel</td>
<td>See “Displaying the Scripts panel” on page 832.</td>
</tr>
<tr>
<td>Blur tool</td>
<td>Focus effect</td>
<td>See “Using focus and esoterica effects” on page 651.</td>
</tr>
<tr>
<td>Burn tool</td>
<td>Burn tool</td>
<td>See “Dodging and burning” on page 290.</td>
</tr>
<tr>
<td>Clone Stamp tool</td>
<td>Rubber Stamp tool</td>
<td>See “Cloning image areas” on page 203.</td>
</tr>
<tr>
<td>Crop tool</td>
<td>Crop tool</td>
<td>See “Cropping images” on page 110.</td>
</tr>
<tr>
<td>Dodge tool</td>
<td>Dodge tool</td>
<td>See “Dodging and burning” on page 290.</td>
</tr>
<tr>
<td>Drop shadow</td>
<td>Drop shadow</td>
<td>See “Adding drop shadows to layers” on page 593.</td>
</tr>
<tr>
<td>Elliptical Marquee tool</td>
<td>Oval Selection tool</td>
<td>See “Creating pixel-based selections” on page 629.</td>
</tr>
<tr>
<td>Eyedropper tool</td>
<td>Dropper tool</td>
<td>See “Sampling colors from images” on page 244.</td>
</tr>
<tr>
<td>Filter Gallery</td>
<td>Effects menu</td>
<td>See “Common options for effects” on page 649.</td>
</tr>
<tr>
<td>Adobe Photoshop tool</td>
<td>Corel Painter tool</td>
<td>For more information</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------------------------------</td>
<td>------------------------------------------------------------</td>
</tr>
<tr>
<td>Freeform Pen tool</td>
<td>Quick Curve tool</td>
<td>See “Drawing lines and curves” on page 788.</td>
</tr>
<tr>
<td>Gradient tool</td>
<td>Interactive Gradient tool</td>
<td>See “Applying gradients” on page 737.</td>
</tr>
<tr>
<td>Hand tool</td>
<td>Grabber tool</td>
<td>See “Repositioning images” on page 110.</td>
</tr>
<tr>
<td>Lasso tool</td>
<td>Lasso tool</td>
<td>See “Creating path-based selections” on page 627.</td>
</tr>
<tr>
<td>Move tool</td>
<td>Move mode of Transform tool</td>
<td>See “Moving selections” on page 642.</td>
</tr>
<tr>
<td>Paint Bucket tool</td>
<td>Paint Bucket tool</td>
<td>See “Exploring painting media” on page 149.</td>
</tr>
<tr>
<td>Path Selection tools</td>
<td>Shape Selection tool</td>
<td>See “Selecting a shape” on page 793.</td>
</tr>
<tr>
<td>Pen tool</td>
<td>Pen tool</td>
<td>See “Drawing lines and curves” on page 788.</td>
</tr>
<tr>
<td>Polygon Lasso tool</td>
<td>Polygonal Selection tool</td>
<td>See “To make a freehand selection” on page 628.</td>
</tr>
<tr>
<td>Rectangular Marquee tool</td>
<td>Rectangular Selection tool</td>
<td>See “Creating path-based selections” on page 627.</td>
</tr>
<tr>
<td>Type tool</td>
<td>Text tool</td>
<td>See “Adding text to images” on page 807.</td>
</tr>
</tbody>
</table>

Frequently asked questions from users of Adobe Photoshop

When I open Photoshop (PSD) files, which elements are preserved and which are lost or modified?

The following table lets you know what changes to expect when you open a PSD file in Corel Painter.
### Adobe Photoshop element

<table>
<thead>
<tr>
<th>Corel Painter element</th>
<th>When the PSD file is opened in Corel Painter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha channels</td>
<td>Alpha channels are preserved.</td>
</tr>
<tr>
<td>Blending modes</td>
<td>Most blending modes are preserved as composite methods. If no equivalent composite method exists for a particular blending mode, the blending mode is converted to the Default composite method.</td>
</tr>
<tr>
<td>Color</td>
<td>If the file does not use the RGB color model, you are prompted to convert the file to the default RGB color profile in Corel Painter. To avoid this step, you may want to convert your files to the RGB color model in Photoshop before opening them in Corel Painter. For more information, see “Color management” on page 265.</td>
</tr>
<tr>
<td>Layers</td>
<td>Layers and layer masks are preserved.</td>
</tr>
<tr>
<td></td>
<td>Layer effects and adjustment layers are not supported. To preserve the results of using these elements, you may want to merge or flatten them in Photoshop before opening the file in Corel Painter.</td>
</tr>
<tr>
<td></td>
<td>Shape layers, layer clipping paths, and clipping groups are not preserved.</td>
</tr>
</tbody>
</table>

### When I save files to the PSD file format, which elements are preserved and which are lost or modified?

The following table lets you know what changes to expect when you save a file to the PSD file format.

<table>
<thead>
<tr>
<th>Corel Painter element</th>
<th>When saved to PSD file format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>RGB options are available when you save to the PSD file format.</td>
</tr>
<tr>
<td>Impasto</td>
<td>Most Impasto brushstrokes are preserved if you save the individual layers in the PSD file. If you drop the layers before saving, you may lose some of the Impasto information.</td>
</tr>
<tr>
<td>Layers</td>
<td>All layers are converted to standard Photoshop transparent layers.</td>
</tr>
<tr>
<td></td>
<td>All Corel Painter layer composite methods are converted to Photoshop blend modes. For information about comparing Corel Painter composite methods with Photoshop blending modes, see “Importing and exporting layers” on page 604.</td>
</tr>
<tr>
<td>Masks</td>
<td>Layer masks are preserved in the PSD file.</td>
</tr>
<tr>
<td>Shapes</td>
<td>Shapes are converted to bitmaps and assigned to appropriate layers.</td>
</tr>
<tr>
<td>Text</td>
<td>Text is converted to a bitmap and assigned to the appropriate layer.</td>
</tr>
</tbody>
</table>
Setting preferences

Corel Painter preferences allow you to customize the program to complement your work style and to achieve optimal performance. The purpose of this section is to describe all Corel Painter preferences and, when applicable, provide references to more detailed information.

This section contains the following topics:
- “General preferences” (page 849)
- “Brush cursor preferences” (page 851)
- “Interface preferences” (page 852)
- “Performance preferences” (page 854)
- “Shapes preferences” (page 855)
- “Cloning preferences” (page 856)
- “Tablet preferences” (page 857)
- “Connections preferences” (page 857)

You can also find set preferences for setting up the drawing cursor, brush tracking and customizing keyboard shortcuts. For more information, see “Setting up the drawing cursor” on page 151, “Brush tracking and calibration” on page 146, and “Customizing keys” on page 124.

General preferences

The general preferences affect various aspects of Corel Painter. For example, you can specify preferences for saving documents, controlling brushes, and saving. The following tables categorize, list, and describe all general preferences.

<table>
<thead>
<tr>
<th>Brush preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align constrained brushstroke to canvas</td>
<td>Matches the brush rotation angle to the canvas rotation angle.</td>
</tr>
<tr>
<td>Disable feature scaling when resizing brush</td>
<td>Disables the Scale feature with brush size option in all areas of the application.</td>
</tr>
<tr>
<td>Simplified brush resizing control (Legacy-style)</td>
<td>Removes the green highlight from the onscreen brush resizing control</td>
</tr>
<tr>
<td>Description</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Brush size increment</strong></td>
<td>Lets you set the brush size increment value in pixels. For more information, see “Setting basic brush attributes” on page 303.</td>
</tr>
<tr>
<td><strong>Align Brush to Path tolerance</strong></td>
<td>Determines how close the brushstroke must be to the path or shape for automatic alignment to occur. For more information, see “Aligning brushstrokes to paths and shapes” on page 158.</td>
</tr>
<tr>
<td><strong>Paint hidden shape</strong></td>
<td>Aligns a brushstroke with a hidden shape or path.</td>
</tr>
<tr>
<td><strong>Show Using Audio Expression dialog box</strong></td>
<td>Displays the Using Audio Expression dialog box every time you use Audio Expression. Enable this check box if you previously enabled the Do not show this again check box in the Using Audio Expression dialog box.</td>
</tr>
<tr>
<td><strong>Show dialog box when entering Presentation Mode</strong></td>
<td>Displays the Presentation Mode dialog box every time you use Presentation Mode. Enable this check box if you previously enabled the Do not show this again check box in the Presentation Mode dialog box.</td>
</tr>
<tr>
<td><strong>Layer preference</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Show Commit dialog when converting to layer</strong></td>
<td>Displays a dialog box every time you need to commit content to a layer. Enable this check box if you previously enabled the Commit and don’t ask again check box in the Commit dialog box. For more information, see “Grouping layers” on page 588.</td>
</tr>
<tr>
<td><strong>Saving preference</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Create backup on Save</strong></td>
<td>Creates a backup file every time you save a document. For more information, see “Saving and backing up files” on page 113.</td>
</tr>
<tr>
<td><strong>Auto-record script</strong></td>
<td>Enables the automatic saving of Corel Painter background scripts.</td>
</tr>
<tr>
<td><strong>Auto-save scripts for</strong></td>
<td>Controls how long Corel Painter saves background scripts before deleting them. For more information, see “Enabling and playing background scripts” on page 834.</td>
</tr>
<tr>
<td><strong>Product update preference</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Notify me of available product updates</strong></td>
<td>Notifies you automatically when a product update is available for Corel Painter 2020.</td>
</tr>
<tr>
<td><strong>Tooltips preference</strong></td>
<td>Displays tooltips with accompanying illustrations (if available).</td>
</tr>
<tr>
<td><strong>Text and images</strong></td>
<td></td>
</tr>
</tbody>
</table>
Text only

Hides illustrations from tooltips, displaying only text.

Thick Paint layer preference

Description

Default amount

Lets you specify the default amount of Thick Paint layers. This amount sets the height of the brushstrokes.

To access the general preferences

• Do one of the following:
  • (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ General.
  • (Windows) Choose Edit ➤ Preferences ➤ General.

Brush cursor preferences

By default, when you paint, the drawing cursor appears as an icon; when you hover over the canvas, the Enhanced brush ghost shows a representation of the brush variant onscreen and gives information about the tilt, bearing, and rotation of your pen.

The Enhanced brush ghost gives visual feedback about your pen in relation to the tablet. The outer ring indicates the brush size, and the line indicates the tilt and bearing of the pen. If you have a flat-tip Intuos Art Pen that supports 360-degree rotation, a dot appears along the outer ring to indicate the pen rotation.

Corel Painter provides a range of options to customize the appearance of the drawing cursor. You can change the cursor type; for example, you can choose a brush ghost that shows the brush shape and size, or you can use a single pixel when painting with brushes from the Pen and Pencils category.

The Brush ghost (left) gives you information about the size of your brush variant. The Enhanced brush ghost (right) gives you information about the tilt, bearing, and rotation of your pen.

You can also specify a number of icon settings, such as the icon shape, color, and orientation.

To set drawing cursor options

1 Choose Corel Painter 2020 menu ➤ Preferences ➤ Brush Cursor (macOS) or Edit ➤ Preferences ➤ Brush Cursor (Windows).
In the **Cursor Type** area, choose a cursor type:

- **Enhanced brush ghost** — provides visual feedback about the brush shape and size as well as the tilt, bearing, and rotation of the pen. If you want to see the Enhanced brush ghost when painting, disable the **Show icon when painting** check box.
- **Brush ghost** — When you paint, the cursor appears as an icon; when you hover over the canvas, it provides visual feedback about the shape and size of the selected brush.
- **Icon** — displays the drawing cursor as an icon both when you paint and when you hover over the canvas
- **Single pixel** — displays the drawing cursor as a single pixel both when you paint and when you hover over the canvas

You can also

---

### Choose a drawing cursor icon

Choose an icon from the **Shape** list box:

- Default
- Brush
- Cross
- Small cross
- Torus
- Triangle
- Hollow triangle
- Gray triangle

### Change the icon color

Click the **Color** button, and click a color in the **Colors** dialog box.

### Change the icon orientation

Drag the **Angle** slider.

---

### Interface preferences

Corel Painter lets you modify a variety of settings that affect the look and feel of your application. You can choose a theme, change the background color of the document, specify the default document view, and set the orientation and layout of the toolbox, command bar, and Media Selector bar, so that the program looks the way you want. Some user interface elements, such as the document window border color and the color of the document title bar are controlled by the theme of your operating system. To change the appearance of these user interface elements, explore the personalization options of your operating system.

The following table describes the Corel Painter preferences for modifying the display of the application interface.

<table>
<thead>
<tr>
<th>Color Theme</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color Theme</td>
<td>Lets you choose a color theme for your workspace. The default color theme is Dark Gray. To make the workspace lighter or darker, you can choose one of the following themes: Medium Gray, Light Gray, Frost, Sepia.</td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>Workspace Options preferences</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units</td>
<td>Lets you choose the unit of measurement used by the application's various sliders and other measurement options</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Background Color</strong></td>
<td>Sets the background color of the document window</td>
</tr>
<tr>
<td><strong>Brush Icons in Custom Palettes preference</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Stroke (wide icons)</strong></td>
<td>Lets you add wide custom icons that display the brushstrokes to a custom palette</td>
</tr>
<tr>
<td><strong>Category</strong></td>
<td>Lets you add regular-width custom icons that display the brush category to a custom palette</td>
</tr>
<tr>
<td><strong>Default View Mode preferences</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Multi-document View</strong></td>
<td>Sets the default workspace view to display all standard tools in the workspace and all open documents</td>
</tr>
<tr>
<td><strong>Single Document View</strong></td>
<td>Sets the default workspace view to hide your computer’s desktop and view the document window without scroll bars</td>
</tr>
<tr>
<td><strong>Toolbox Layout</strong></td>
<td>Sets the orientation and layout of the toolbox in the document window</td>
</tr>
<tr>
<td><strong>Media Layout</strong></td>
<td>Sets the orientation and layout of the Media Selector bar in the document window</td>
</tr>
<tr>
<td><strong>Command Bar Layout</strong></td>
<td>Sets the orientation of the command bar in the document window</td>
</tr>
<tr>
<td><strong>Property Bar preferences</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Tall (with group labels)</strong></td>
<td>Lets you display group labels</td>
</tr>
<tr>
<td><strong>Short (without group labels)</strong></td>
<td>Lets you hide group labels</td>
</tr>
<tr>
<td><strong>Brush Selector Bar Height preferences</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Same as Property Bar with Group Labels</strong></td>
<td>Sets the height of the Brush Selector bar to match the height of the property bar when group labels are displayed</td>
</tr>
<tr>
<td><strong>Same as Property Bar without Group Labels</strong></td>
<td>Sets the height of the Brush Selector bar to match the height of the property bar when group labels are not displayed</td>
</tr>
<tr>
<td><strong>Display preference</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Area Averaging: Increases performance by using pixel averaging below 50% zoom</strong></td>
<td>Increases the speed at which the screen is drawn when you are viewing an image at less than 50% magnification. Enabling this option may decrease accuracy.</td>
</tr>
</tbody>
</table>
To access the interface preferences
• Do one of the following:
  • (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Interface.
  • (Windows) Choose Edit ➤ Preferences ➤ Interface.

Performance preferences

You can set various performance preferences to optimize Corel Painter. For example, you can change memory options such as the amount of memory (RAM) used by the application, choose processor (CPU) or graphics processor (GPU) settings, or specify the volume name (macOS) or drive (Windows) that you want to assign as a scratch disk.

In addition, you can optimize performance by disabling or hiding certain features that you don’t need. For more information, see “What settings do I use to ensure the optimal performance of Corel Painter?” on page 872.

You can also run the Brush Accelerator utility to evaluate your system’s GPU, CPU, and memory. The test results indicate whether your system’s GPU, CPU, and memory meet, exceed or are below the recommended specifications.

The performance preferences are described in the following table.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
| Processor (CPU) preference                      | **Thread Allocation**
|                                                | Allows you to specify the number of cores that you want Corel Painter to use. If you use all of the computer’s available cores, it may impact the performance of any applications that you have running in the background. You must restart Corel Painter for this change to take effect. |
| Graphics Processor (GPU) preference            | **Use the Graphics Processor (GPU) to accelerate brush performance**
|                                                | Allows you to enable or disable your system’s graphic processor (GPU). You must restart Corel Painter for this change to take effect.       |
| Configure                                      | **Configure**
|                                                | Allows you to select which graphics processor (GPU) Painter uses to accelerate brush performance.                                          |
| Memory (RAM) preferences                        | **Allocate to Painter**
|                                                | Changes the percentage of RAM memory used by Corel Painter, which is set to 80% by default. You can dedicate as much as 100% of the memory to Corel Painter. The lowest percentage you can choose is 5%. You must restart Corel Painter for this change to take effect. |
|                                                | **Undo Levels**
|                                                | Allows you to undo and redo up to 256 levels of changes. The number of Undo levels applies across all open documents. For example, if you set 5 undo levels and have two open documents, |
undoing three operations on the first document leaves you with only two undo operations on the second document.

In addition, setting multiple undo levels uses a significant amount of disk space. If you perform multiple operations on the entire image, the whole image must be saved for each undo.

**Scratch Drive**

Allows you to specify the volume name (macOS) or drive (Windows) that has free memory to allow Corel Painter to perform an operation if your computer runs out of RAM.

To ensure the optimal performance of scratch disks, consider the following:

- Choose a drive that does not contain the files that you are currently working on.
- Choose a different drive than the one used by the operating system’s virtual memory.
- Defragment the scratch disk drive on a regular basis.

<table>
<thead>
<tr>
<th>Display preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>High Quality Display</strong></td>
<td>Applies smoothing to the current view to minimize pixelation when zooming. Disabling this check box increases performance when working on high-resolution paintings.</td>
</tr>
</tbody>
</table>

**Brush Accelerator preferences**

<table>
<thead>
<tr>
<th>Brush Accelerator preferences</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Run Brush Accelerator Now</strong></td>
<td>Runs the Brush Accelerator test to evaluate your system’s processor (CPU), graphics processor (GPU), and memory (RAM). The test typically takes a few minutes. It is recommended to save and close all open documents and to not run any unnecessary applications during the test.</td>
</tr>
<tr>
<td><strong>View Report</strong></td>
<td>Displays a report of the Brush Accelerator test results in the Welcome Screen.</td>
</tr>
<tr>
<td><strong>Help with Performance Settings</strong></td>
<td>Displays the Help for Performance preferences.</td>
</tr>
</tbody>
</table>

**To specify performance preferences**

- Do one of the following:
  - (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Performance.
  - (Windows) Choose Edit ➤ Preferences ➤ Performance.

**Shapes preferences**

The shapes preferences allow you to set the default fill and stroke for creating new shapes. You can also change the appearance of the Bézier handles when drawing or the wing, point, path, outline, and anchor colors.
### Shape preference

<table>
<thead>
<tr>
<th>Description</th>
<th>Shape preference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fills both open and closed shapes with the currently selected color when</td>
<td>On Draw - Fill with current color</td>
</tr>
<tr>
<td>drawing.</td>
<td></td>
</tr>
<tr>
<td>Outlines both open and closed shapes with the currently selected color</td>
<td>On Draw - Stroke in current color</td>
</tr>
<tr>
<td>when drawing.</td>
<td></td>
</tr>
<tr>
<td>Fills the shape with the currently selected color when the shape paths are</td>
<td>On Close - Fill with current color</td>
</tr>
<tr>
<td>closed.</td>
<td></td>
</tr>
<tr>
<td>Outlines the shapes with the currently selected color when the shape paths</td>
<td>On Close - Stroke in current color</td>
</tr>
<tr>
<td>are closed.</td>
<td></td>
</tr>
<tr>
<td>Controls the size of the anchor points and the direction of the wing handles</td>
<td>Big handles</td>
</tr>
<tr>
<td>to help you grab and drag them easily. If you want big points, enable this</td>
<td></td>
</tr>
<tr>
<td>option.</td>
<td></td>
</tr>
<tr>
<td>Sets the color of the wings, Bézier, and handles.</td>
<td>Colors - Wing/Bézier/Handle</td>
</tr>
<tr>
<td>Sets the color of the shape outline paths.</td>
<td>Colors - Outline/Path</td>
</tr>
<tr>
<td>Sets the color of the selected anchor points. The unselected anchor points</td>
<td>Colors - Selected Point/Anchor</td>
</tr>
<tr>
<td>appear “hollow.”</td>
<td></td>
</tr>
</tbody>
</table>

#### To change shape preferences

- Do one of the following:
  - (macOS) Choose Corel Painter 2020 menu Preferences Shapes.
  - (Windows) Choose Edit Preferences Shapes.

If you set default preferences for the shape outline and fill color by using the Set Default Shape Attributes dialog box, the settings in the Preferences dialog box are ignored.

### Cloning preferences

The Cloning preferences let you customize the cloning and Quick Clone behavior. For example, you can choose to always use the last selected cloner brush variant or automatically open the Clone Source panel. For more information, see “To clone an image by using Quick Clone” on page 188.

#### Quick Clone preferences

<table>
<thead>
<tr>
<th>Description</th>
<th>Close source image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closes the clone source image automatically when the image is cloned.</td>
<td>Closes the clone source image automatically when the image is cloned. The clone source is embedded in the clone document, but the original image is closed.</td>
</tr>
</tbody>
</table>
Open Clone Source panel
Displays the Clone Source panel automatically when Quick Clone is used.

Clear Canvas
Lets you start cloning with a blank canvas.

Turn on Tracing Paper
Activates Tracing Paper.

Switch to cloner brushes
Activates the last Cloner brush variant.

Clone color
Uses the current brush variant to clone the underlying color.
To enable the Clone Color check box, you must disable the Switch to cloner brushes check box.

Cloning preferences

Show Edit Source Image dialog box
Displays a dialog box every time you switch to the Source Image window from the clone document window. The dialog box warns you that any source image editing needs to be updated, saved, exported, or discarded.

To change Cloning preferences
• Do one of the following:
  • (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Cloning.
  • (Windows) Choose Edit ➤ Preferences ➤ Cloning.

Tablet preferences
The Tablet preferences let you choose a suitable option for the tablet and other devices that you use to paint with the application. Before setting these options, make sure your devices are connected and have the latest driver software installed.
In addition, you can access multi-touch options for both macOS and Windows. For more information about multi-touch options, see “Multi-touch support” on page 117.

To specify tablet preferences
• Choose (macOS) Corel Painter 2020 menu ➤ Preferences ➤ Tablet or (Windows) Edit ➤ Preferences ➤ Tablet.

To choose an input device (Windows)
1 In the Tablet settings area, choose an input device.
  • Wacom-compatible device (Wintab) — configures Painter to use Wacom tablets and Wacom-compatible devices
  • RTS-compatible device (Real-Time Stylus) — configures Painter to use a tablet or device that has the RTS feature
2 Restart Corel Painter.

Connections preferences
The Connections preferences allow you to connect Corel Painter to companion applications.
<table>
<thead>
<tr>
<th>Connections preferences</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow companion applications to connect to Painter</td>
<td>Allows you to connect Corel Painter to companion applications</td>
</tr>
<tr>
<td>Service Name</td>
<td>Gives your copy of Corel Painter a unique name</td>
</tr>
<tr>
<td>Authentication Code</td>
<td>Ensures that only a legitimate user can access your copy of Corel Painter from a remote application</td>
</tr>
</tbody>
</table>

**To change Connections preferences**

- Do one of the following:
  - (macOS) Choose Corel Painter 2020 menu ➤ Preferences ➤ Connections.
  - (Windows) Choose Edit ➤ Preferences ➤ Connections.
Corel Painter includes various options for creating images for the web.

This section contains the following topics:

- “Choosing web-safe colors” (page 859)
- “Posterizing using color sets” (page 859)
- “Choosing web-friendly brushes” (page 860)
- “Creating transparent GIFs” (page 861)
- “Reducing the number of colors in GIF files” (page 862)
- “Creating image maps” (page 863)
- “Creating server-side image maps” (page 865)
- “Creating web page backgrounds” (page 865)
- “Creating web buttons” (page 867)

Choosing web-safe colors

Using a web-safe color table becomes important when you expect to deliver your web page to viewers who use monitors displaying 256 or fewer colors. On such a monitor, web browsers dither colors that aren’t found in the web-safe palette. So, depending on your audience, making sure that some or all of your image conforms to the web-safe palette can make good sense.

To select a web-safe color palette

1. Click the **Options** button in the **Color Set Libraries** panel, and choose **Import Color Set**.
2. In the **Select Color Set** dialog box, select the **Hexadecimal** folder within the **Color Sets** folder.
3. Choose a hex file from the list, and click **Open**.

   The selected color palette is displayed in the **Color Set Libraries** panel.

Posterizing using color sets

You can use the **Posterize Using Color Set** option to force your image to use the default color set. **Posterize Using Color Set** can help make the colors in your image ready for delivery to the web — without a lot of dithering or shifting of colors.
Posterizing means adjusting the number of color levels an image contains. Corel Painter can automatically constrain all colors in your image to a web-safe, 216-color palette. Although the Posterize Using Color Set option is not designed to be a highly sophisticated method of reducing color (it offers you no control over exactly how color reduction is performed), it can be a real time-saver.

In addition, you can constrain the colors you use to the default or another Corel Painter web-safe palette, utilize web-safe single-color brushes, and keep the number of colors in your image to a minimum.

It’s important to note that exporting to GIF format can compromise the color set values used when Posterize Using Color Set has been performed. For best results in those cases, do the following:

- First, save your reduced-color image in a 24-bit format, such as Windows Bitmap, TIFF, or PICT. This maintains the benefits of defining web-safe colors in Corel Painter.
- Next, open the image in a tool that supports indexed color to save the GIF — one that offers “constrain to color set” features.
- Finally, save the image to GIF format. The web-safe colors from Corel Painter are maintained and your image is ready to go on the web.

To posterize using a color set
1. Select an area of your image you want affected or select nothing if you want the entire image affected.
2. Make sure the proper color set is active.

Choosing web-friendly brushes

Web artists are pulled between the desire for beautiful images and the need for small image file sizes, with faster download times. Corel Painter includes brushes that are designed for creating images for the web, making it easier to create smaller files without compromising image quality.

Bitmapped images can be roughly divided into two general types — images with areas of flat color and continuous-tone images. Continuous-tone images (which most of the normal features in Corel Painter produce) are best saved as JPEG images. Images with flat areas of color are best saved as GIF images. The more regions of flat color there are in an image, the more compressed (smaller) the resulting GIF file is.

The strength of Corel Painter is its Natural-Media brushes; however, Corel Painter is also versatile in the creation of flat color suitable for GIF images on the web.

One-color brushes

You can set the brush controls to create areas of flat color, while keeping all the feeling and nuance of a Natural-Media brush. These brush edges are aliased, meaning they have jagged edges. For example, if a brush color is black, there are no intermediate gray pixels at the brush’s edge. There is either black or the background color. In addition to a flat color, this brush type responds to paper texture.

Magnified detail of the stroke is shown to the left of each W-stroke. In this image, the same brushstroke is applied using a different paper texture.
To make a brush with a flat-edged appearance, change the method to Cover and the subcategory to Grainy Edge Flat Cover. If you have created some of your own brush variants in Corel Painter, you can convert them to web-friendly brushes, too.

Web brushes are also included with the extra content in Corel Painter, which is available online.

To change the brush method and subcategory

2. From the Method list box, choose Cover.
3. From the Subcategory list box, choose Grainy Edge Flat Cover.
4. Save your creation as a variant.

The result is the current brush with a web-friendly hard edge.

For more information, see “Saving and deleting brush variants” on page 309 and “Creating and deleting brush categories” on page 311.

Brushes that require a particular method, such as Wet, Eraser, or Plug-in, will not work as well with the Cover method. If you use another brush method, you will not be working with a one-color brush.

To load Corel Painter web-friendly brushes into a library

1. Click the Brush Selector.
2. In the Brush library panel, click the Brush library options button ▼, and choose Import ▶ Brush Library.
3. In the Import Brush Library dialog box, locate a web brushes library that you have downloaded or created.
4. Click Open.

Creating transparent GIFs

Corel Painter lets you create web-ready transparent GIFs. If designed correctly, GIFs with transparent areas are very effective when displayed over background colors or tiles.

A GIF with a transparent background (the airplane) is displayed over a blue background image.

In Corel Painter, the method of defining transparency during GIF export is to define the transparent areas based on the content of the selected layers. The edges of the floating elements on the layers help define the transparent areas. For more information, see “Layers” on page 569.

When saving to the GIF file format, you can reduce the number of colors, which translates into smaller files.
To create a transparent GIF from a layer or group of layers

1. From the Layers panel, select a layer or group of layers. To output transparency in a GIF, you need an active selection.

2. Choose Select ➢ Select Layer Content.

3. Choose File ➢ Save As.

4. Choose GIF from the Save As Type list box.

5. Specify a location and filename, and click Save.

6. In the Save As GIF Options dialog box, enable the Output Transparency check box to make the selected area the only part of the canvas displayed on your web page.

7. Enable one of the following options:
   - Background is WWW Gray — sets the transparent color to 75% gray
   - Background is BG Color — sets the transparent color using the additional color specified in the Color panel. Note that this setting does not refer to the background color of the HTML page.

8. In the Preview window, verify that the selected area is correctly masked and that the transparent area is correctly positioned. Transparent areas appear as a grid.
   - If necessary, drag in the Preview window to view all parts of the image.

9. Choose one of the following imaging methods:
   - Quantize to Nearest Color — causes Corel Painter to look at each pixel and pick the nearest color. This is useful when the image you are saving has broad areas of a single color.
   - Dither Colors — causes Corel Painter to apply a stippled effect to the chosen colors to generate a more accurate, less banded result. Dither Colors can reduce the effectiveness of GIF file compression.

The RIFF format contains image data that is lost when saving to GIF or JPEG. To edit the file later, save a RIFF copy before saving to the GIF or JPEG file format.

Reducing the number of colors in GIF files

Web designers are always seeking a careful balance when creating graphics for the web. Artwork and images must be as rich and vibrant as possible while remaining small and easily downloadable.

One way of keeping the file size small is to reduce the number of colors used to create the image. Reducing the number of colors reduces file size and, therefore, download time.

A web artist may end up saving multiple versions of the same graphic element, varying the number of colors used. These versions must then be placed on a web page to determine if the quantity of colors used is acceptable. This whole process can be time-consuming.

In Corel Painter, you can make this decision during the process of saving the image to GIF format, by using the Preview window on the Save As GIF Options dialog box.

To reduce the number of colors in a GIF

1. Choose File ➢ Save As and name your image file.

2. Choose the GIF file format, and click Save.
   - Click OK to dismiss the layer warning, if displayed.

3. In the Save As GIF Options dialog box, in the Number of Colors area, enable the 256 Colors option.
   - In the preview window, the image appears in 256 colors.

4. Enable the 128 Colors option.
   - In the preview window, the image appears in 128 colors.
Continue reducing the number of colors in the image until you find the minimum number of colors necessary for adequate display on your web page.

Choose one of the following imaging methods:

- **Quantize to Nearest Color** — causes Corel Painter to look at each pixel and pick the nearest color. This is useful when the image you are saving has broad areas of a single color.
- **Dither Colors** — causes Corel Painter to apply a stippled effect to the chosen colors to generate a more accurate, less banded result.

The RIFF format contains data about your image that is lost when you convert it to GIF. If you want to edit the file later, save a RIFF copy before you generate a GIF version.

**Creating image maps**

An image map is a web feature that lets you jump to different locations by clicking specific areas within an image.

There are two types of image maps:

- **Client-side image maps** store image map information right in your HTML document. URL information appears at the bottom of the browser window when a pointer is moved over the mapped areas.
- **Server-side image maps** store image map information in a separate file that is stored on a server and accessed by a Common Gateway Interface (CGI) script. Coordinate information, not URL information, is displayed at the bottom of the browser window when a pointer is moved over a mapped area.

Client-side image maps are faster and more efficient because all the image information is present in the HTML code for the page. A server-side image map, in contrast, requires an extra round trip of information between the browser and the web server. However, client-side image maps are not supported by very old browsers.

![Image maps example](image)

*When a hotspot is clicked (left), the browser jumps to the page referenced by that link (right).*

**Client-side image mapping**

A client-side image map is an image that has “hotspots” directly associated with URL information. When a hotspot is clicked, the browser jumps to the page referenced by that link.

A client-side image map recognizes circular and rectangular “hotspots.” Therefore, Corel Painter treats a circular area as a circle and a rectangle as a rectangle. Oval areas are exported as rectangles.

Image maps are created using layers. The size of the layer determines the clickable area. For more information, see “Layers” on page 569.
The size of the layer determines the size of the clickable area, or hotspot.

Server-side image mapping handles circles and ovals differently. With server-side mapping, you can export ovals. For more information on server-side image maps, see “Creating server-side image maps” on page 865.

To define a client-side image map
1. Select or create a layer or shape in the exact place in your image where you want a link created.
   
   If you can’t see the layer’s marquee, click the Layer options button in the Layers panel, and choose Show Layer Indicators.

2. Click the Layer options button \( \equiv \), and choose Layer Attributes.

3. In the Layer Attributes dialog box, specify a name for the layer.

4. Enable the WWW Map Clickable Region check box.

5. In the URL box, specify a URL to associate with this portion of your image (for example, http://www.painterartist.com).

6. Click OK to return to the image.

7. Deselect the layer, and then define the next area of your image map.
   
   If there are two or more overlapping areas in an image map, the topmost one takes priority.

8. Export your image to the GIF or JPEG file format. In the Save As GIF Options or Save as JPEG Options dialog box, enable the Client Side Map File check box to indicate that Corel Painter should export an HTML file containing the image map definition.

   The RIFF format contains data about your image that is lost when you convert it to GIF or JPEG. If you want to edit the file later, save a RIFF copy before you generate a GIF or JPEG version.

   When a client-side image map is exported, Corel Painter exports both the image and an HTML file. You can then open the HTML file in a text or HTML editor and copy the code into another web page.

To define a default URL for an image map
1. To define a default, or base, URL to use when a user clicks outside the defined hotspot areas in an image map, choose File \( \Rightarrow \) Get Info when no layers, shapes, or plug-ins are selected.

2. In the File Information dialog box, enable the WWW Map Default URL check box.

3. Enter a URL address.

4. Click OK.

   If you don’t provide a default URL, clicking outside the defined hotspot areas has no effect.
Creating server-side image maps

In Corel Painter, you can define a layer as a clickable region. Corel Painter saves this image map information within a separate text file, which you can upload to your web server. It can then be accessed by a CGI script.

Because server-side image mapping is becoming obsolete, be sure to read the previous section on client-side image mapping support.

To create a server-side image map

1. Select or create a layer or shape in the exact place in your image where you want a link created.
2. In the Layers panel, select a layer.
3. Click the Layer options button, and choose Layer Attributes.
4. In the Layer Attributes dialog box, specify a name for the layer.
5. Enable the WWW Map Clickable Region check box.
6. In the URL box, specify a URL to associate with this portion of your image (for example, http://www.painterartist.com).
7. Click OK to return to the image.
8. Deselect the layer, then select the next hotspot in your image map. Try to avoid overlapping hotspot areas within an image map.
   You can set a default URL to use if the user clicks outside of your defined hotspot areas. For more information, see “To define a default URL for an image map” on page 864.
9. Export your image to the GIF or JPEG file format. In the Save As GIF Options or Save As JPEG Options dialog box, enable either the NCSA Map File check box or the CERN Map File check box, depending on which format is recommended by your Internet Service Provider.
   When you save the image, Corel Painter creates an additional text file that describes the clickable regions and their associated URLs.
10. Store both files (the image file and its associated image map definition file) on your web server, as directed in the documentation for your image mapping CGI script/program. Both files must be present for the server-side image map to work.

The RIFF format contains data about your image that is lost when you convert it to GIF or JPEG. If you want to edit the file later, save a RIFF copy before you generate a GIF or JPEG version.

Creating web page backgrounds

Corel Painter offers tools for creating web page backgrounds.

An effective web page background should be subtle and unobtrusive. This is particularly important if the background is used behind text. You can lighten patterns by using the Edit ➤ Fade command, to make them more suitable for displaying behind text.
Controlling background color

Using a background color closely matched to your background image takes no additional download time and creates a pleasing transition. For example, suppose your page loads a dark green seamless background tile. The tile takes a little time to download. While it’s loading, the browser displays the page, using the page background color (which, if not explicitly defined, is usually gray or white). This can cause a jarring visual transition. Depending on the text color used, it can even make a page impossible to read until the background image has finished loading.

Using HTML, you can specify a solid background color for a page, table, or Cascading Style Sheet (CSS) element. Although Corel Painter can’t assist you with actually setting the background color in your HTML code, you can use Corel Painter to determine the hexadecimal format of a color, which is used in HTML.

Using tiled backgrounds

When a background image is smaller than the boundaries of the display area for a page, table, or Cascading Style Sheet (CSS) layer, web browsers automatically repeat the image, effectively creating a tiled pattern. Corel Painter makes it easy to create tiling background images for use in web pages.

The CSS features in modern browsers let you apply background tiles to more elements than ever before. In the past, you could apply them only to the page itself, or possibly to a table. Now, with CSS, layers or block-level elements — anything you can display on its own line in traditional HTML layout — can have a background image. Since authors are no longer limited to using tiled backgrounds for just pages, possibilities open up for the creative use of tiles behind such elements as borders, call-out boxes, or sidebars.

You can use any image or selection to define a pattern. An image designed for use as part of a pattern is normally created so that it tiles seamlessly. That is, the eye should not be able to distinguish the edges between tile repetitions. Corel Painter has features that can help you create seamless tiles, which you can then use as interesting web backgrounds. For information about creating, editing, saving, and filling with patterns, see "Patterns" on page 723.

The Glass Distortion effect, the Super Soften effect (with the Wrap Around check box enabled), and most of the Tonal Control effects preserve the seamless quality of the pattern. Some effects, such as Apply Surface Texture, can result in a noticeable seam, so experiment.
A way to partially avoid seams that occur with effects such as **Apply Surface Texture** is to apply the effect several times at lower strengths (by moving the *Amount* slider). Shift the pattern a little (using *Shift + Spacebar*) between applications. This tends to “distribute” the seams and make them less noticeable.

Tile dimensions should be as small as practical, but in most cases should not go below 20 x 20 pixels. If a tile is too small, it takes the browser longer to render it over a large area.

When you’ve finished creating your tile, save the image in RIFF format, in case you must work with it later in Corel Painter. Then, save it in either JPEG or GIF format for use on the web.

Web backgrounds should, ideally, be saved as GIFs, with as few colors as possible, to reduce file size. You can also use JPEGs, but they often have larger file sizes. As a rule of thumb, any background tile over 20 KB is probably too large. For more information about saving an image in GIF or JPEG format, see “Saving and backing up files” on page 113.

**Creating tiles with fractal patterns**

Another easy way to design seamless tiles is to take advantage of the effects you can create with the **Make Fractal Pattern** command. **Make Fractal Pattern** is a pattern generator that creates organic patterns, which can make interesting background tiles. The patterns it generates can be filled with color and even enhanced with a paper texture. For more information, see “Creating fractal patterns” on page 731.

**Color Overlay**, the **Watercolor** brushes, and **Cloning** are other options you can apply to a pattern. Beautiful, complex effects can also be achieved by applying **Glass Distortion** to a pattern created with **Make Fractal Pattern**.

**Creating web buttons**

Corel Painter has a wide array of features that help you create web buttons. You can apply textures and effects to your web buttons.

**Using shapes and selections**

You can create web buttons using shapes or by choosing a selection from the Selection Portfolio. For more information, see “Drawing shapes” on page 786. For information about using selections, see “To use a selection from the portfolio” on page 636.

**Using 3D techniques**

You may want to use one or more of the texturing options in Corel Painter to create 3D effects. The following sections describe several powerful ways to quickly add 3D effects to the buttons you create.

After you’ve added a desired 3D effect, try altering the light source to create a second image that represents the button in a different state, or try using the **Hue Shift** slider in the **Effects ➤ Tonal Control ➤ Adjust Colors** dialog box.

**Adding shadows**

Shadows lend a definite 3D flare to a web page. You can quickly add drop shadows to text, buttons, shapes, and layers. When you apply a drop shadow to a shape, the shape loses its vector quality and becomes a pixel-based layer. For more information about creating drop shadows, see “Adding drop shadows to layers” on page 593.
Applying surface texture

Leading the array of Corel Painter web-friendly tools, the **Apply Surface Texture** feature could easily become a web designer’s best friend. You can use **Apply Surface Texture** to apply 3D effects to web buttons, bars, or other elements.

You can use the **Reflection** slider to create an effect you would expect to see in objects made of glass or polished metal, like a chrome bumper on a classic car. The **Image Luminance** option in the **Using** list box gives your buttons an embossed look. For more information about applying surface texture, see “Using paper to create texture” on page 678.

Using the Impasto technique

The Impasto feature lets you create the illusion of depth by applying thick paint to the canvas. You can use the Impasto technique to add a 3D appearance to all or discrete areas of your image. For more information, see “Impasto” on page 559.

Using Bevel World

No discussion of creating web buttons would be complete without mentioning Bevel World. Bevel World is a dynamic plug-in that can add 3D angled edges to your shapes and selections.

Bevel World has controls that affect the 3D bevel shape being applied, as well as controls to adjust lighting. Try experimenting with lighting controls. By changing the lighting on a bevelled surface, you can easily create different states for your web buttons.

For more information about Bevel World, see “Applying the Bevel World dynamic plug-in” on page 706.

You can decide later to change the settings, as long as you have not committed the layer. To understand more about committing a layer, see “Converting dynamic layers” on page 702.
Troubleshooting tips

This section provides troubleshooting tips and offers answers to frequently asked questions. If your problem or question is not included in the following list, visit the Corel Knowledge Base.

Installation

- “I am trying to install/reinstall Corel Painter but I get a warning that my serial number is invalid. What do I do?” (page 870)
- “How do I repair my Corel Painter installation (Windows)?” (page 870)
- “How do I uninstall Corel Painter properly (Windows)?” (page 870)
- “How can I get the thumbnails of my Painter files to show in Windows Explorer?” (page 870)

Brushes and tablets

- “My brushes stopped working.” (page 870)
- “My blending and smearing brushes paint with white or don’t interact with underlying colors.” (page 871)
- “My brush doesn’t use the color I chose or doesn’t work as expected.” (page 871)
- “Where do I find my previously purchased brushes after reinstalling Corel Painter or installing it on another computer?” (page 871)
- “My tablet doesn’t work as expected with Corel Painter. What do I do?” (page 871)

Workspaces, user files, and layouts

- “What’s the difference between user files and a workspace?” (page 871)
- “What’s the difference between a layout and a workspace?” (page 871)
- “I was given a custom workspace, but I can’t use it.” (page 872)
- “Some palettes in the workspace I just imported appear cutoff (Windows).” (page 872)

Performance

- “Lately Corel Painter has been taking longer to start. Can I do something to shorten its startup time?” (page 872)
- “What settings do I use to ensure the optimal performance of Corel Painter?” (page 872)
- “I was using Corel Painter without any problems for a while, and now it no longer works as expected. What do I do?” (page 872)
- “I know that restoring Corel Painter to its default settings may help with unexpected performance problems, but I don’t want to lose my custom brushes and palettes. How do I keep my custom items?” (page 873)
- “I have read that renaming my application data folder (Windows) or application library folder (macOS) may help improve the performance of Corel Painter. How do I rename this folder?” (page 873)
- “Corel Painter stops responding on startup (macOS)? What do I do?” (page 873)
Installation

I am trying to install/reinstall Corel Painter but I get a warning that my serial number is invalid. What do I do?

Make sure you have pasted or typed the correct serial number, and that you are using a serial number provided by Corel. It may help to paste your serial number into a basic text editor, such as Notepad (Windows) or TextEdit (macOS). Next, copy the serial number from the text editor, and paste it into the Serial Number box.

If you have uninstalled or reinstalled Corel Painter several times, you may have reached the maximum number of times you can use the serial number to activate the product. Contact Corel Customer Service for help.

How do I repair my Corel Painter installation (Windows)?

If you suspect that your installation of Corel Painter is corrupt, you may need to repair it. To do this, close all applications, and click Uninstall a program on the Windows Control Panel. Double-click the product name on the Uninstall or change a program page. In the Installation wizard, enable the Repair option, and follow the instructions.

How do I uninstall Corel Painter properly (Windows)?

Always use the Corel Painter Installation wizard to uninstall Corel Painter. Close all applications, and click Uninstall a program on the Windows Control Panel. Double-click the product name on the Uninstall or change a program page. In the Installation wizard, enable the Remove option and the Remove User Files check box, and follow the instructions.

The Corel Painter installation includes Corel Painter Thumbnail Previewer, which lets you view the contents of Corel Painter (RIFF) files in Windows Explorer by generating thumbnail images. This utility must be uninstalled separately. To do so, double-click Corel Painter Thumbnail Previewer on the Uninstall or change a program page.

How can I get the thumbnails of my Painter files to show in Windows Explorer?

• Upgrade to the latest version of Corel Painter. It comes with Corel Painter Thumbnail Previewer, which lets you view the contents of Corel Painter (RIFF) files in Windows Explorer by generating thumbnail images.
• If you change the Corel Painter file association, thumbnails may become unavailable. To fix the issue, you must uninstall Corel Painter together with Corel Painter Thumbnail Previewer, and then reinstall the application.

Brushes and tablets

My brushes stopped working.

• Check the Layers palette to make sure that the Preserve Transparency button is disabled.
• Make sure the active layer is visible. If the eye icon next to the layer name in the Layers palette is shut, click the icon to make the layer visible.
• Sometimes the brush marks don’t show because the brush opacity is set to 0. Increase the opacity in the Opacity box on the property bar.
• You may be painting underneath a layer that is hiding your brushstrokes. Check the Layers palette, and make sure you are painting on the layer you want. If there are layers blocking the active layer, hide these layers by clicking the eye icon.
• There may be a small selection in the image, and brushes cannot paint outside selections. Choose the Select menu, and click None (if it is not already grayed out) to remove the selection.
• You may be trying to paint on a white canvas with a brush that uses the Glow technology. Glow brushes don’t leave a mark on white or very light backgrounds. To make sure you are indeed using a glow brush, check if there is an enabled Glow control on the property bar, or if the brush uses the Glow subcategory.
• Click the Reset Tool button on the property bar to restore the brush to its default settings.
• Some composite methods can make the paint appear invisible. For example, if the layer’s composite method is set to Multiply or Gel and you are painting on black, you won’t be able to see your brushstrokes. In general, if you are having difficulty seeing your brushstrokes, try changing the layer’s composite method to Default.
• Blender brushes do not add color; they blend existing colors.
My blending and smearing brushes paint with white or don’t interact with underlying colors.

• In the Layers panel, click the Pick Up Underlying Color button to enable it. If the brush still doesn't work as expected on the active layer, choose the canvas in the Layers palette and try painting over existing colors. If it works, consider painting on the canvas - some brushes use methods that don’t work on layers.
• For brushstrokes without white fringes, take advantage of enhanced blending, which is supported by many brushes. Choose Window ➤ Brush Control Panels ➤ Brush Media ➤ Blending, and enable the Enhanced Layer Blending check box (if available for the selected brush).

My brush doesn’t use the color I chose or doesn’t work as expected.

• In the Colors palette, check if the Additional Color swatch appears selected. If so, click the Main Color swatch so that your brush uses the main color.

• In the Layers panel, check the composite method assigned to the active layer in the Composite Method list box, and make sure it is set to Default, not Gel, Multiply, Overlay, or another method that changes the appearance of the main color when it interacts with underlying colors.
• Make sure that the Hue ring and Saturation/Value triangle in the Color palette do not appear grayed out. If they are, then the Clone Color option is enabled, which means that the brush is using a color or pattern from a clone source. In the Color palette, click the Clone Color control to disable it.
• Sometimes your brush may be customized beyond recognition. In the Brush library panel, click the Brush library options button and choose Restore Default Variant.

Where do I find my previously purchased brushes after reinstalling Corel Painter or installing it on another computer?

Click Help menu ➤ Restore Purchases, and follow the instructions to download and install your previously purchased items. This method can help you restore only brush packs that you purchased from within Corel Painter. For more detailed information, see “To restore your purchases” on page 303.

My tablet doesn’t work as expected with Corel Painter. What do I do?

Start by making sure that your tablet preferences are set properly - Wacom-compatible device (Wintab) or RTS-compatible device (Real-Time Stylus). For more information, see “Support for tablets and other devices” on page 117.
Make sure the tablet and the tablet driver are supported by the operating system, and that you have the latest version of the tablet driver installed. After installing the latest driver, you may find that tablet performance has become worse. In such cases, you may want to go back to the previous version of the driver. Remember to restart your computer each time you install or uninstall device drivers.
Unplug the tablet, and try to connect it to your computer by using another USB port.

User files, workspaces, and layouts

What’s the difference between user files and a workspace?

User files are created when you customize content (such as a brush, paper or texture) or reposition a workspace element in Corel Painter. For example, when you change the settings of a brush or add a new item to a library, your new settings are saved to user files.

A workspace lets you create a customized version of Corel Painter to suit your workflow needs. A workspace can include custom brush libraries, paper libraries, texture libraries, nozzles, portfolios, and more. In addition, you can easily create multiple workspaces, each with different libraries and portfolios. You can switch workspaces from the Window ➤ Workspace menu. For more information about workspaces, see “Creating, importing, exporting, and deleting workspaces” on page 88.

What’s the difference between a layout and a workspace?

A layout (also known as “palette arrangement”) displays, hides, and positions workspace elements such as palettes and panels to suit a specific workflow. For example, the New to Painter layout displays only the most essential controls together with the Hints panel to help you get started quickly with Corel Painter. You can switch layouts while working in the same workspace by clicking Window ➤ Layout.
A layout arranges the elements of a workspace in a specific way; a workspace includes specific content such as brushes, textures, papers, and more.
You can arrange palettes and panels and save the arrangement as a custom layout. For more information, see “To save an arrangement of palettes as a workspace layout” on page 80. When you restore Corel Painter to its default settings, you can choose to keep custom brushes, papers, textures, and other assets, but all your custom layouts will be lost.

I was given a custom workspace, but I can’t use it.

Workspace files have a .pws extension. To use a custom workspace that was shared with you, you must import it by choosing Window ➤ Workspace ➤ Import Workspace.

You can double-click a workspace file to import it on the macOS, but not on Windows. If you double-clicked the workspace file on Windows, and then tried to import it unsuccessfully, you need to download the file again.

Some palettes in the workspace I just imported appear cutoff (Windows).

The location of palettes is saved with the custom workspace. If the imported custom workspace is too wide, some of its palettes may appear cutoff or be completely hidden. Try decreasing the UI scaling value in Windows, and then move the palettes to the left. Next, set the UI scaling to your preferred value.

Performance

Lately Corel Painter has been taking longer to start. Can I do something to shorten its startup time?

Before closing Corel Painter, make sure to close all panels and palettes that you rarely use.

What settings do I use to ensure the optimal performance of Corel Painter?

• Set performance options in the Preferences dialog box. For more information, see “Performance preferences” on page 854.

• (Windows) Optimize the settings of your device, be it a Microsoft Surface Pro laptop, Cintiq Companion, or a desktop computer. Change the power settings of your device from Power Save mode to High performance (Control Panel ➤ Hardware and Sound ➤ Power Options). You can also disable programs that are running in the background, turn off search indexing, clean the registry, disable visual effects, and more. For detailed information, see https://www.computerworld.com/article/3029168/microsoft-windows/windows-10-quick-tips-8-ways-to-speed-up-your-pc.html.

• Set the rotation of the canvas to 0°, especially when using impasto.

• If you are using impasto but you don’t need to see the impasto effect while painting, choose Canvas ➤ Hide Impasto to improve performance.

• Hide the Navigator panel (Window ➤ Navigator) if you don’t need it.

• Adjust the following brush settings:
  • Move the Boost slider on the Spacing panel (Window ➤ Brush Control Panels ➤ Brush Shape ➤ Spacing) to optimize the performance of brushstrokes. Start with low boost values (under 10%) to significantly increase brush performance. Note that high boost values may produce less accurate brushstrokes. This setting applies only to specific brush dab types, such as Flat and Camel hair.
  • Check if the selected brush uses Brush Loading by choosing Window ➤ Brush Control Panels ➤ Brush Media ➤ Blending, and disable it to improve performance. For more information about this control, see “Blending controls” on page 431.

I was using Corel Painter without any problems for a while, and now it no longer works as expected. What do I do?

We recommend that you follow these troubleshooting tips in the order they are listed.

• Restart Corel Painter. This may improve application performance.

• Sometimes, silent hardware and operating system (OS) updates may cause Corel Painter to slow down. Its performance should be improved after the updates are installed. In general, we recommend that you restart your computer after installing any hardware, OS, or Corel Painter updates.

• Start Corel Painter by holding down Shift. This action will restore Corel Painter to its default settings and may solve unexpected problems. For more information, see “Restoring the default Corel Painter settings” on page 89.

• If restoring Corel Painter to its default settings did not improve performance, the problem may be some custom items such as brushes, papers, or custom palettes that you created earlier and decided to keep. Start Corel Painter while holding down Shift again, and try disabling one or more items under the Keep some customizations option.
• Another fix to try on Windows is to rename the Corel Painter folder in your User folder. For more information, see “I have read that renaming my application data folder (Windows) or application library folder (macOS) may help improve the performance of Corel Painter? How do I rename this folder?” on page 873.

• If you are still having problems using the application and suspect that the installation has become corrupt, you may need to repair the installation. For more information, see “How do I repair my Corel Painter installation (Windows)?” on page 870.

• If nothing else seems to work, you may need to uninstall and re-install Corel Painter. Before you uninstall the application, make sure you have your Corel Painter serial number handy. For information about how to uninstall Corel Painter on Windows, see “How do I uninstall Corel Painter properly (Windows)?” on page 870.

I know that restoring Corel Painter to its default settings may help with unexpected performance problems, but I don’t want to lose my custom brushes and palettes. How do I keep my custom items?

• When you restore the application to its default settings by holding down Shift and starting it, choose the Keep some customizations option in the dialog box that comes up. You can choose to keep your custom brushes, custom palettes, and customized libraries (papers, patterns, scripts, textures, and more).

• You can also export custom content or custom palettes before restoring Corel Painter to its default settings.

I have read that renaming my application data folder (Windows) or application library folder (macOS) may help improve the performance of Corel Painter? How do I rename this folder?

(Windows) Press the Windows key + R, type %appdata% in the Run dialog box, and press Enter. Next, browse to the Corel/Painter [XX] folder, where XX is the version number of the product, and rename the folder to Painter XX_old. Start Corel Painter.

(macOS) Start Finder. Choose Go ➤ Go to Folder, type ~/library in the Go to folder box, and click Go. Next, browse to the Corel/Painter [XX] folder, where XX is the version number of the product, and rename the folder to Painter XX_old. Start Corel Painter.

Corel Painter stops responding on startup (macOS)? What do I do?

For troubleshooting tips, check out this article on the Corel Knowledge Base.