Get started...........................................................................................................................................................................................21

Install CorelDRAW Graphics Suite..........................................................................................................................................................23

System requirements..............................................................................................................................................................................23

Prepare for installation.......................................................................................................................................................................23

Install CorelDRAW Graphics Suite applications................................................................................................................................24

Installation options.........................................................................................................................................................................24

Modify and repair installations.......................................................................................................................................................25

Uninstall CorelDRAW Graphics Suite...............................................................................................................................................26

FAQ................................................................................................................................................................................................26

Corel accounts and services..................................................................................................................................................................29

Authenticate CorelDRAW Graphics Suite.........................................................................................................................................29

Account settings.............................................................................................................................................................................30

Updates..........................................................................................................................................................................................30

Change user credentials..................................................................................................................................................................30

Your privacy and profile..................................................................................................................................................................31

Corel Support Services....................................................................................................................................................................32

Submit feedback.............................................................................................................................................................................32

Error logging and reporting...........................................................................................................................................................32

What’s new in CorelDRAW Graphics Suite?..........................................................................................................................................33

CorelDRAW Graphics Suite September 2023 release.......................................................................................................................33

CorelDRAW Graphics Suite March 2023 release.............................................................................................................................35

CorelDRAW Graphics Suite September 2022 Subscriber Update.....................................................................................................36

CorelDRAW Graphics Suite March 2022 Subscriber Update............................................................................................................37

CorelDRAW Graphics Suite 2021.5.................................................................................................................................................42

CorelDRAW Graphics Suite 2021....................................................................................................................................................44

Learning resources................................................................................................................................................................................51

Get help.........................................................................................................................................................................................51

Learn docker...................................................................................................................................................................................53

Help and tooltips.............................................................................................................................................................................54

Hints................................................................................................................................................................................................55
Welcome screen.................................................................................................................................................................................. 55
Quick Start Guide.................................................................................................................................................................................. 56
Practice projects..................................................................................................................................................................................... 56
Video resources..................................................................................................................................................................................... 57
Developers’ website............................................................................................................................................................................... 57
Network deployment guide......................................................................................................................................................................... 57
Web-based resources.................................................................................................................................................................................. 57
Start and set up......................................................................................................................................................................................... 59
  Start and quit CorelDRAW................................................................................................................................................................. 59
  Change the language............................................................................................................................................................................ 59
  Startup settings................................................................................................................................................................................... 60
CorelDRAW basics.................................................................................................................................................................................... 61
  Vector graphics and bitmaps............................................................................................................................................................... 61
  Start and open drawings.................................................................................................................................................................. 62
  Scan images....................................................................................................................................................................................... 67
  Work with multiple drawings.......................................................................................................................................................... 67
  Undo, redo, and repeat actions...................................................................................................................................................... 68
  Zoom, pan, and scroll....................................................................................................................................................................... 69
  Preview drawings............................................................................................................................................................................... 73
  Viewing modes.................................................................................................................................................................................. 74
  Views.............................................................................................................................................................................................. 75
  Save drawings.................................................................................................................................................................................. 76
  Locked files....................................................................................................................................................................................... 78
  Back up and recover files............................................................................................................................................................. 78
  Add and access drawing information........................................................................................................................................ 79
  Close drawings................................................................................................................................................................................ 80
  Explore basic tasks.......................................................................................................................................................................... 80
  Disable warning messages............................................................................................................................................................ 81
  View system information............................................................................................................................................................... 81
  Edit while printing, saving, and exporting documents........................................................................................................... 81
CorelDRAW workspace tour................................................................................................................................................................. 83
View documents and document properties ........................................................................................................................................................................152

Lines, shapes, and outlines ..........................................................................................................................................................................................153

Lines, outlines, and brushstrokes ..............................................................................................................................................................................155

Lines .......................................................................................................................................................................................................................155
Parallel drawing.............................................................................................................................................................................................................164
Calligraphic and preset lines..............................................................................................................................................................................166
LiveSketch...............................................................................................................................................................................................................168
Format lines and outlines....................................................................................................................................................................................174
Add arrowheads to lines and curves...............................................................................................................................................................179
Variable outlines......................................................................................................................................................................................................181
Copy, convert, remove, and replace outlines..................................................................................................................................................183
Brushstrokes..............................................................................................................................................................................................................186
Brushstrokes and stylus input...............................................................................................................................................................................187
Spray objects along a line....................................................................................................................................................................................188
Connector and callout lines................................................................................................................................................................................191
Dimension lines........................................................................................................................................................................................................194
Pressure-sensitive pens and devices.................................................................................................................................................................197

Shapes..........................................................................................................................................................................................................................201
Rectangles and squares.......................................................................................................................................................................................201
Ellipses, circles, arcs, and pie shapes.................................................................................................................................................................204
Polygons and stars.........................................................................................................................................................................................................206
Spirals..............................................................................................................................................................................................................................208
Grids............................................................................................................................................................................................................................208
Predefined shapes......................................................................................................................................................................................................209
Use shape recognition................................................................................................................................................................................................210

Shape objects.................................................................................................................................................................................................................213
Curve objects......................................................................................................................................................................................................................214
Select and move nodes..................................................................................................................................................................................................215
Align and distribute nodes................................................................................................................................................................................................216
Manipulate segments....................................................................................................................................................................................................223
Join curves.....................................................................................................................................................................................................................225
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Objects, symbols, and layers</td>
<td>299</td>
</tr>
<tr>
<td>Perspective drawing</td>
<td>285</td>
</tr>
<tr>
<td>Symmetrical drawing</td>
<td>273</td>
</tr>
<tr>
<td>PowerClip objects</td>
<td>263</td>
</tr>
<tr>
<td>Fillet, scallop, and chamfer corners</td>
<td>260</td>
</tr>
<tr>
<td>Trim objects</td>
<td>258</td>
</tr>
<tr>
<td>Fillet, scallop, and chamfer corners</td>
<td>260</td>
</tr>
<tr>
<td>Weld and intersect objects</td>
<td>262</td>
</tr>
<tr>
<td>Options for nodes, handles, and previews</td>
<td>269</td>
</tr>
<tr>
<td>Symmetrical drawing</td>
<td>273</td>
</tr>
<tr>
<td>Create symmetry</td>
<td>274</td>
</tr>
<tr>
<td>Edit symmetry</td>
<td>276</td>
</tr>
<tr>
<td>Fuse curves in symmetry groups</td>
<td>281</td>
</tr>
<tr>
<td>Remove symmetry and break symmetry links</td>
<td>282</td>
</tr>
<tr>
<td>Perspective drawing</td>
<td>285</td>
</tr>
<tr>
<td>Draw in perspective</td>
<td>286</td>
</tr>
<tr>
<td>Edit perspective groups</td>
<td>291</td>
</tr>
<tr>
<td>Break perspective groups apart</td>
<td>296</td>
</tr>
<tr>
<td>Copy and cut segments</td>
<td>226</td>
</tr>
<tr>
<td>Add, remove, and join nodes</td>
<td>227</td>
</tr>
<tr>
<td>Node types</td>
<td>228</td>
</tr>
<tr>
<td>Transform nodes</td>
<td>229</td>
</tr>
<tr>
<td>Break the path of curve objects</td>
<td>230</td>
</tr>
<tr>
<td>Mirror changes in curve objects</td>
<td>231</td>
</tr>
<tr>
<td>Skew and stretch objects</td>
<td>232</td>
</tr>
<tr>
<td>Smudge and smear objects</td>
<td>233</td>
</tr>
<tr>
<td>Roughen objects</td>
<td>236</td>
</tr>
<tr>
<td>Smooth objects</td>
<td>237</td>
</tr>
<tr>
<td>Attract or push away nodes to shape</td>
<td>239</td>
</tr>
<tr>
<td>Apply distortion effects</td>
<td>240</td>
</tr>
<tr>
<td>Add twirl effects</td>
<td>242</td>
</tr>
<tr>
<td>Shape objects by using envelopes</td>
<td>243</td>
</tr>
<tr>
<td>Crop and erase objects</td>
<td>251</td>
</tr>
<tr>
<td>Split objects</td>
<td>256</td>
</tr>
<tr>
<td>Trim objects</td>
<td>258</td>
</tr>
<tr>
<td>Fillet, scallop, and chamfer corners</td>
<td>260</td>
</tr>
<tr>
<td>Weld and intersect objects</td>
<td>262</td>
</tr>
<tr>
<td>PowerClip objects</td>
<td>263</td>
</tr>
<tr>
<td>Options for nodes, handles, and previews</td>
<td>269</td>
</tr>
</tbody>
</table>
Objects.................................................................................................................................................................................................301
Select objects............................................................................................................................................................................................................302
Edit objects in Focus mode.............................................................................................................................................................................305
Transform objects........................................................................................................................................................................................................308
Copy, duplicate, and delete objects.............................................................................................................................................................311
Create objects from enclosed areas..............................................................................................................................................................314
Create a boundary around objects.............................................................................................................................................................314
Feather object edges..................................................................................................................................................................................................315
Use object coordinates to draw and modify objects................................................................................................................................316
Copy object properties, transformations, and effects................................................................................................................................324
Clone objects..............................................................................................................................................................................................................326
Position objects........................................................................................................................................................................................................327
Align and distribute objects........................................................................................................................................................................329
Apply object hinting..................................................................................................................................................................................................333
Snap objects..............................................................................................................................................................................................................333
Dynamic guides.......................................................................................................................................................................................................337
Alignment guides........................................................................................................................................................................................................340
Change the order of objects........................................................................................................................................................................345
Size and scale objects..................................................................................................................................................................................................346
Rotate and mirror objects...........................................................................................................................................................................348
Modify objects with the Properties docker...........................................................................................................................................350
Fit objects to a path...................................................................................................................................................................................................351
Group objects..............................................................................................................................................................................................................355
Combine objects........................................................................................................................................................................................................357
Lock objects..............................................................................................................................................................................................................358
Find and replace objects...........................................................................................................................................................................359
Hide and show objects..................................................................................................................................................................................................361
Constrain objects.........................................................................................................................................................................................................362
Export objects..............................................................................................................................................................................................................363
Bar codes.................................................................................................................................................................................................................363
Link and embed objects................................................................................................................................................................................365
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About color management</td>
<td>465</td>
</tr>
<tr>
<td>Get started with color management</td>
<td>469</td>
</tr>
<tr>
<td>Install, load, and embed color profiles</td>
<td>472</td>
</tr>
<tr>
<td>Assign color profiles</td>
<td>473</td>
</tr>
<tr>
<td>Convert colors to other color profiles</td>
<td>474</td>
</tr>
<tr>
<td>Color-conversion settings</td>
<td>474</td>
</tr>
<tr>
<td>Soft proofing</td>
<td>475</td>
</tr>
<tr>
<td>Save fills and transparencies</td>
<td>463</td>
</tr>
<tr>
<td>Manage fills and transparencies</td>
<td>462</td>
</tr>
<tr>
<td>Find and view fills and transparencies</td>
<td>459</td>
</tr>
<tr>
<td>Find, manage, and save fills and transparencies</td>
<td>459</td>
</tr>
<tr>
<td>Copy, freeze, and remove transparencies</td>
<td>455</td>
</tr>
<tr>
<td>Merge modes</td>
<td>456</td>
</tr>
<tr>
<td>Pattern transparency</td>
<td>451</td>
</tr>
<tr>
<td>Texture transparency</td>
<td>454</td>
</tr>
<tr>
<td>Fountain transparency</td>
<td>449</td>
</tr>
<tr>
<td>Uniform transparency</td>
<td>448</td>
</tr>
<tr>
<td>Work with fills</td>
<td>444</td>
</tr>
<tr>
<td>Apply fills to areas</td>
<td>443</td>
</tr>
<tr>
<td>Two-color bitmap pattern fills</td>
<td>431</td>
</tr>
<tr>
<td>Texture fills</td>
<td>437</td>
</tr>
<tr>
<td>PostScript fills</td>
<td>439</td>
</tr>
<tr>
<td>Mesh fills</td>
<td>439</td>
</tr>
<tr>
<td>Fountain fills</td>
<td>426</td>
</tr>
<tr>
<td>Uniform fills</td>
<td>425</td>
</tr>
<tr>
<td>Fills</td>
<td>425</td>
</tr>
<tr>
<td>Show or hide color palettes</td>
<td>421</td>
</tr>
<tr>
<td>Set color palette properties</td>
<td>423</td>
</tr>
<tr>
<td>Object transparency</td>
<td>447</td>
</tr>
<tr>
<td>Pattern transparency</td>
<td>451</td>
</tr>
<tr>
<td>Texture transparency</td>
<td>454</td>
</tr>
<tr>
<td>Copy, freeze, and remove transparencies</td>
<td>455</td>
</tr>
<tr>
<td>Merge modes</td>
<td>456</td>
</tr>
<tr>
<td>Find, manage, and save fills and transparencies</td>
<td>459</td>
</tr>
<tr>
<td>Find and view fills and transparencies</td>
<td>459</td>
</tr>
<tr>
<td>Manage fills and transparencies</td>
<td>462</td>
</tr>
<tr>
<td>Save fills and transparencies</td>
<td>463</td>
</tr>
<tr>
<td>Color management</td>
<td>465</td>
</tr>
<tr>
<td>About color management</td>
<td>465</td>
</tr>
<tr>
<td>Get started with color management</td>
<td>469</td>
</tr>
<tr>
<td>Install, load, and embed color profiles</td>
<td>472</td>
</tr>
<tr>
<td>Assign color profiles</td>
<td>473</td>
</tr>
<tr>
<td>Convert colors to other color profiles</td>
<td>474</td>
</tr>
<tr>
<td>Color-conversion settings</td>
<td>474</td>
</tr>
<tr>
<td>Soft proofing</td>
<td>475</td>
</tr>
</tbody>
</table>
Special effects....................................................................................................................................................................................483
Vector and bitmap effects....................................................................................................................................................................485
  Bitmap effects...........................................................................................................................................................................485
  Vector effects.........................................................................................................................................................................489
  Apply bitmap effects......................................................................................................................................................491
Special effects categories...........................................................................................................................................................499
  3-D........................................................................................................................................................................................504
  Art strokes.................................................................................................................................................................................504
  Blur........................................................................................................................................................................................510
  Camera....................................................................................................................................................................................515
  Color transform...................................................................................................................................................................519
  Contour..................................................................................................................................................................................521
  Correction..............................................................................................................................................................................522
  Creative................................................................................................................................................................................523
  Custom................................................................................................................................................................................529
  Distort....................................................................................................................................................................................530
  Noise....................................................................................................................................................................................535
  Sharpen................................................................................................................................................................................538
  Texture................................................................................................................................................................................540
Lenses........................................................................................................................................................................................................547
  Apply lenses..........................................................547
  Edit lenses........................................................................................................................................................................549
Add 3D effects................................................................................................................................................................................551
  Contour objects..............................................................................................................................................................551
Apply perspective...........................................................................................................................................................................555
Create extrusions.............................................................................................................................................................................558
Create bevel effects........................................................................................................................................................................562
Add drop shadows and inner shadows..........................................................................................................................................564
Add block shadows........................................................................................................................................................................569
Blend objects................................................................................................................................................................................573
Mosaics.............................................................................................................................................................................................. 579
Vector mosaics (Pointillizer effect).................................................................................................................................................. 579
Bitmap mosaics (PhotoCocktail effect)........................................................................................................................................ 582
Add movement and focus...............................................................................................................................................................587
Impact effects................................................................................................................................................................................587
Text.................................................................................................................................................................................................595
Add and manipulate text................................................................................................................................................................. 597
Import and paste text....................................................................................................................................................................... 597
Artistic text.................................................................................................................................................................................... 599
Paragraph text................................................................................................................................................................................599
Add columns to text frames............................................................................................................................................................603
Combine and link paragraph text frames........................................................................................................................................604
Align text to the baseline grid...........................................................................................................................................................606
Select text....................................................................................................................................................................................... 607
Find, edit, and convert text...............................................................................................................................................................608
Shift, rotate, mirror, and flip text....................................................................................................................................................611
Move text...........................................................................................................................................................................................612
Wrap text........................................................................................................................................................................................... 613
Fit text to a path................................................................................................................................................................................614
Special characters, symbols, and glyphs.........................................................................................................................................616
Embed graphics................................................................................................................................................................................621
Legacy text....................................................................................................................................................................................... 621
Format text....................................................................................................................................................................................... 623
Choose typefaces and fonts.............................................................................................................................................................623
Format characters............................................................................................................................................................................ 626
Change text color......................................................................................................................................................................................... 627
Kern a range of characters.................................................................................................................................................................................. 629
Change text case and capitalization............................................................................................................................................................... 629
OpenType features....................................................................................................................................................................................... 631
Variable fonts.............................................................................................................................................................................................. 635
Adjust character and word spacing............................................................................................................................................................ 637
Adjust line and paragraph spacing............................................................................................................................................................. 639
Create bulleted and numbered lists.......................................................................................................................................................... 640
Drop caps....................................................................................................................................................................................................... 644
Change character position and angle.......................................................................................................................................................... 645
Align text................................................................................................................................................................................................. 646
Add tabs and indents................................................................................................................................................................................. 648
Text styles..................................................................................................................................................................................................... 649
Hyphenate text......................................................................................................................................................................................... 650
Formatting codes..................................................................................................................................................................................... 652
Nonprinting characters........................................................................................................................................................................... 653
Work with text in different languages....................................................................................................................................................... 655
Format Asian text.................................................................................................................................................................................... 655
Line-breaking rules for Asian text............................................................................................................................................................ 656
OpenType support for Asian text.............................................................................................................................................................. 657
Format multilingual text.......................................................................................................................................................................... 657
Display text correctly in any language.................................................................................................................................................... 659
Manage fonts................................................................................................................................................................................................... 661
Change the default font............................................................................................................................................................................. 661
Substitute fonts......................................................................................................................................................................................... 662
Embed fonts............................................................................................................................................................................................. 663
View fonts............................................................................................................................................................................................... 664
Filter fonts............................................................................................................................................................................................. 665
Search for fonts..................................................................................................................................................................................... 667
Acquire more fonts.................................................................................................................................................................................. 668
Choose fonts.......................................................................................................................................................................................... 668
Merge and split tables and cells.................................................................761
Manipulate tables as objects..................................................................762
Add images, graphics, and backgrounds to tables.................................763
Import tables......................................................................................763

**Bitmaps**...........................................................................................765

Work with bitmaps........................................................................767
Convert vector graphics to bitmaps......................................................767
Import bitmaps................................................................................769
Crop bitmaps..................................................................................769
Bitmap dimensions and resolution......................................................769
Straighten bitmaps........................................................................773
Correct perspective distortions...........................................................776
Remove artifacts and noise from JPEG images.....................................777
Remove dust and scratch marks from bitmaps.......................................777
Sharpen images..............................................................................777
Change and mask colors in bitmaps......................................................779
Image Adjustment Lab.....................................................................780
Adjust color and tone..................................................................785
Tone Curve filter...........................................................................792
Transform color and tone.................................................................795
Edit bitmaps with Corel PHOTO-PAINT............................................796

**Bitmap color modes**........................................................................797
Change the color mode of bitmaps......................................................797
Change bitmaps to black-and-white....................................................798
Change bitmaps to duotones...............................................................799
Change bitmaps to the paletted color mode.......................................800

**Trace**.............................................................................................803
Trace bitmaps................................................................................803
PowerTRACE controls......................................................................806
Preview traced results.....................................................................808
Fine-tune traced results................................................................808
Contents | 15

Printing .............................................................................................................................................................................................. 823

Prepare files for print service providers ............................................................................................................................................... 851

Print basics......................................................................................................................................................................................... 825

Print your work.................................................................................................................................................................................. 825

Lay out print jobs............................................................................................................................................................................... 826

Preview print jobs............................................................................................................................................................................... 827

Print styles...................................................................................................................................................................................... 828

Fine-tune print jobs......................................................................................................................................................................... 829

Print colors accurately................................................................................................................................................................... 830

Print to a PostScript printer............................................................................................................................................................. 832

Preflight summaries.......................................................................................................................................................................... 834

Print merge.................................................................................................................................................................................... 835

Prepare a data source file.............................................................................................................................................................. 836

Create a form document............................................................................................................................................................... 843

Merge data..................................................................................................................................................................................... 850

Prepare files for print service providers....................................................................................................................................... 851

Prepare for a print service provider............................................................................................................................................ 851

Imposition layouts........................................................................................................................................................................... 852

Printers’ marks................................................................................................................................................................................ 854

Maintain OPI links........................................................................................................................................................................... 856

Color separations........................................................................................................................................................................... 857

Color trapping and overprinting................................................................................................................................................... 858

In-RIP trapping settings............................................................................................................................................................... 861

RAW camera files............................................................................................................................................................................... 815

Use RAW camera files.................................................................................................................................................................... 815

Import RAW camera files in CorelDRAW..................................................................................................................................... 816

Adjust the color and tone of RAW camera files.......................................................................................................................... 818

Sharpen RAW camera files and reduce noise............................................................................................................................... 821

Preview RAW camera files and obtain image information......................................................................................................... 822

Contents | 15
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print to film</td>
<td>863</td>
</tr>
<tr>
<td>Prepare banners for printing</td>
<td>864</td>
</tr>
<tr>
<td>Work with a print service provider</td>
<td>866</td>
</tr>
<tr>
<td>Web graphics</td>
<td>867</td>
</tr>
<tr>
<td>Create objects for the web</td>
<td>869</td>
</tr>
<tr>
<td>Create pixel-perfect graphics for the web</td>
<td>869</td>
</tr>
<tr>
<td>Export bitmaps for the web</td>
<td>870</td>
</tr>
<tr>
<td>Export and upload bitmaps to WordPress</td>
<td>875</td>
</tr>
<tr>
<td>Save and apply web presets</td>
<td>876</td>
</tr>
<tr>
<td>Export objects with transparent colors and backgrounds</td>
<td>876</td>
</tr>
<tr>
<td>Web-compatible text</td>
<td>877</td>
</tr>
<tr>
<td>Rollovers</td>
<td>878</td>
</tr>
<tr>
<td>Bookmarks and hyperlinks</td>
<td>879</td>
</tr>
<tr>
<td>Add hotspots and alternate text to objects</td>
<td>880</td>
</tr>
<tr>
<td>Import and export</td>
<td>883</td>
</tr>
<tr>
<td>Import and export files and assets</td>
<td>885</td>
</tr>
<tr>
<td>Import files</td>
<td>885</td>
</tr>
<tr>
<td>Export files</td>
<td>889</td>
</tr>
<tr>
<td>Export objects and pages</td>
<td>891</td>
</tr>
<tr>
<td>Export to PDF</td>
<td>895</td>
</tr>
<tr>
<td>Export to PDF</td>
<td>895</td>
</tr>
<tr>
<td>PDF hyperlinks, bookmarks, and thumbnails</td>
<td>898</td>
</tr>
<tr>
<td>Comments in PDF files</td>
<td>898</td>
</tr>
<tr>
<td>Reduce PDF file size</td>
<td>898</td>
</tr>
<tr>
<td>Text and fonts in PDF files</td>
<td>900</td>
</tr>
<tr>
<td>Encode PDF files</td>
<td>901</td>
</tr>
<tr>
<td>View options for EPS files</td>
<td>902</td>
</tr>
<tr>
<td>PDF color management options</td>
<td>902</td>
</tr>
<tr>
<td>PDF security options</td>
<td>903</td>
</tr>
<tr>
<td>Optimize PDF files</td>
<td>905</td>
</tr>
</tbody>
</table>
Supported file formats

- Adobe Portable Document Format (PDF)
- PaintBrush (PCX)
- PICT (PCT)
- Kodak Photo CD Image (PCD)
- JPEG 2000 (JP2)
- JPEG (JPG)
- High Efficiency Image File Format (HEIF)
- GIF
- PostScript (PS or PRN)
- Encapsulated PostScript (EPS)
- AutoCAD Drawing Database (DWG) and AutoCAD Drawing Interchange Format (DXF)
- Adobe Type 1 Font (PFB)
- Adobe Illustrator (AI)
- Windows Bitmap (BMP)
- OS/2 Bitmap (BMP)
- Computer Graphics Metafile (CGM)
- PostScript (PS or PRN)
- Corel DESIGNER (DES, DSF, DS4, or DRW)
- Microsoft Publisher (PUB)
- Corel PHOTO-PAINT (CPT)
- Corel Symbol Library (CSL)
- Cursor Resource (CUR)
- CorelDRAW (CDR)
- Corel Presentation Exchange (CMX)
- Microsoft Word (DOC, DOCX, or RTF)
- Adobe Type 1 Font (PFB)
- Adobe Illustrator (AI)
- Computer Graphics Metafile (CGM)
- OS/2 Bitmap (BMP)
- Windows Bitmap (BMP)
- Encapsulated PostScript (EPS)
- AutoCAD Drawing Database (DWG) and AutoCAD Drawing Interchange Format (DXF)
- Adobe Type 1 Font (PFB)
- Adobe Illustrator (AI)
- PaintBrush (PCX)
- Adobe Portable Document Format (PDF)
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize the toolbox</td>
<td>969</td>
</tr>
<tr>
<td>Customize the property bar</td>
<td>969</td>
</tr>
<tr>
<td>Customize the status bar</td>
<td>971</td>
</tr>
<tr>
<td>Customize filters</td>
<td>972</td>
</tr>
<tr>
<td>Use macros and scripts to automate tasks</td>
<td>973</td>
</tr>
<tr>
<td>Macros</td>
<td>973</td>
</tr>
<tr>
<td>JavaScript scripts</td>
<td>980</td>
</tr>
<tr>
<td>Reference</td>
<td>983</td>
</tr>
<tr>
<td>CorelDRAW for Adobe Illustrator users</td>
<td>985</td>
</tr>
<tr>
<td>Compare terminology</td>
<td>985</td>
</tr>
<tr>
<td>Compare tools</td>
<td>986</td>
</tr>
<tr>
<td>Using the Adobe Illustrator workspace</td>
<td>989</td>
</tr>
<tr>
<td>Glossary</td>
<td>991</td>
</tr>
</tbody>
</table>
Get started

- Install CorelDRAW Graphics Suite ................................................................. 23
- Corel accounts and services ............................................................................. 29
- What's new in CorelDRAW Graphics Suite? ...................................................... 33
- Learning resources ............................................................................................ 51
- Start and set up .................................................................................................. 59
- CorelDRAW basics ............................................................................................ 61
- CorelDRAW workspace tour .............................................................................. 83
- Creative tools and content .................................................................................. 107
- Touchscreen and wheel devices ......................................................................... 127
- Collaborate ........................................................................................................ 135
- Use a document management system with CorelDRAW Graphics Suite .......... 149
Install CorelDRAW Graphics Suite

This section contains the following topics:
• “System requirements” (page 23)
• “Prepare for installation” (page 23)
• “Install CorelDRAW Graphics Suite applications” (page 24)
• “Installation options” (page 24)
• “Modify and repair installations” (page 25)
• “Uninstall CorelDRAW Graphics Suite” (page 26)
• “FAQ” (page 26)

System requirements

The following list includes the minimum system requirements. Note that for optimum performance, you need more RAM and hard disk space than indicated in the list.
• Windows 11, Windows 10, in 64-bit, all with the latest updates and service packs. CorelDRAW® Graphics Suite supports Windows 10, versions 21H1 and 21H2 as well as later versions that may be released during the life cycle of the suite.
• Intel Core i3/5/7/9 or AMD Ryzen 3/5/7/9, Threadripper, EPYC
• OpenCL 1.2-enabled video card with 3+GB VRAM
• 4 GB RAM (8+ GB or more recommended)
• 4.3 GB hard disk space for application files and installation files
• Multi-touch screen, mouse, or tablet
• Display resolution: 1280 x 720 screen resolution at 100% (96 dpi)
• DVD drive optional (for box installation); installation from DVD requires a download of up to 700 MB
• Internet connection is required to install and authenticate CorelDRAW Graphics Suite, and access some of the included software components, online features, and content.

Prepare for installation

• Make sure that your system’s date and time are set correctly.
• Make sure that your system has the latest updates installed.
• Close all applications, including all virus detection programs and applications that are open in the system tray or on the Windows taskbar. Not doing so may increase the installation time and interfere with the installation.
• Log in as a user with administrative privileges.
Install CorelDRAW Graphics Suite applications

The installation wizard makes it easy to install CorelDRAW Graphics Suite applications and components. You can choose a typical installation to quickly install the suite, or you can customize the installation by choosing different options.

To install CorelDRAW Graphics Suite applications

1. Close all applications, including all virus detection programs.
   For smooth installation, we recommend that you restart Windows. This action will ensure that no restart is required by the latest system updates, and there are no memory issues.
2. Download the product from the link provided on your order confirmation.
3. In the installation wizard, follow the instructions for installing the software.

Installation options

You can choose between the following types of installations:

- **Typical installation** — automatically installs the main programs and utilities of the suite to a default location in the Program Files folder. If later you need a component that is not installed, you can modify your installation.
- **Custom installation** — lets you choose additional features, exclude components that you don’t need, and specify where to install the suite. If you have purchased a multilingual version of the suite, you can also choose which language packs to install.
- **Deployment** — available only for multiseat purchases. This option lets you create a server image for installing the software to individual workstations. For more information, see the CorelDRAW Graphics Suite Deployment Guide.

Programs

The following table lists the programs that are installed by default. To exclude a program from the installation, you must choose Custom installation.

<table>
<thead>
<tr>
<th>Program</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CorelDRAW®</td>
<td>An intuitive and versatile graphics application for creating high-quality vector illustrations, logo designs, and page layouts</td>
</tr>
<tr>
<td>Corel PHOTO-PAINT™</td>
<td>A complete image-editing application that lets you retouch and enhance photos as well as create original bitmap illustrations and paintings</td>
</tr>
<tr>
<td>CAPTURE ™</td>
<td>An easy-to-use application for capturing images from your computer screen</td>
</tr>
<tr>
<td>Corel® Font Manager</td>
<td>An application for finding, organizing, and managing fonts</td>
</tr>
<tr>
<td>Corel® BARCODE WIZARD</td>
<td>An application for generating bar codes in a wide range of industry-standard formats</td>
</tr>
</tbody>
</table>
Program features and utilities

The following table lists the program features that you can install. Not all components are available in all versions of the software.

<table>
<thead>
<tr>
<th>Feature or utility</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Visual Basic for Applications 7.1</td>
<td>A subset of the Microsoft Visual Basic (VB) programming environment, which is suitable for beginners.</td>
<td>You can use VBA to create basic macros for personal use, but you can also use it to create more advanced macro projects.</td>
</tr>
<tr>
<td>Microsoft Visual Studio Tools for Applications (VSTA)</td>
<td>A built-in program environment that allows developers and other programming experts to use VSTA for creating the most advanced macro projects</td>
<td>To use VSTA with CorelDRAW Graphics Suite, you must have your own copy of Microsoft Visual Studio 2019 installed. If you install Microsoft Visual Studio after installing CorelDRAW Graphics Suite, you must re-install the VSTA feature by modifying your CorelDRAW Graphics Suite installation. For more information, see “To modify or repair a CorelDRAW Graphics Suite installation” on page 26.</td>
</tr>
<tr>
<td>Windows Shell Extension</td>
<td>Lets you view thumbnails of native Corel files such as CorelDRAW (CDR), Corel PHOTO-PAINT (CPT), pattern fill (FILL), and other native file.</td>
<td>If you have installed CorelDRAW Graphics Suite or CorelDRAW Technical Suite before, this option does not appear in the installation wizard.</td>
</tr>
<tr>
<td>GPL Ghostscript</td>
<td>Highly recommended if you import EPS and PDF files in your documents. This feature lets you isolate and use individual elements of imported EPS files rather than only header images. It also improves the import of PDF files generated by third-party applications.</td>
<td>Included with the Typical installation</td>
</tr>
<tr>
<td>Product languages</td>
<td>Let you use the programs and Help in two or more languages</td>
<td>This option is included only with multilingual versions of the software and requires Custom installation.</td>
</tr>
<tr>
<td>Install desktop shortcuts</td>
<td>Adds product icons to your desktop for easy access</td>
<td>Included with the Typical installation</td>
</tr>
<tr>
<td>Copy installation files</td>
<td>Lets you maintain and update the software without using the installation disc</td>
<td>Included with the Typical installation</td>
</tr>
</tbody>
</table>

Modify and repair installations

You can also use the installation wizard to do the following:
• modify the current installation by adding or deleting components such as programs or product languages
• repair the current installation by fixing errors such as missing or corrupt files as well as inaccurate shortcuts and registry entries

Repairing an installation is helpful when you encounter problems in using the application, or when you suspect that the installation is corrupt.

Before repairing an installation, try resetting the current workspace to the default settings by holding down F8 while starting the application. Note that when you reset the workspace, all workspace preferences are reset.

To modify or repair a CorelDRAW Graphics Suite installation
1 Close all applications.
2 On the Windows Control Panel, click Uninstall a program.
3 Double-click the suite’s name on the Uninstall or change a program page.
4 Enable the Modify option or the Repair option in the wizard that appears, and follow the instructions.
   Product languages can be selected on the last page of the wizard.

Program features and utilities that are already installed may not appear in the wizard, or their check boxes may appear disabled.
   Certain features, such as Copy installation files, cannot be added by modifying your installation.

Uninstall CorelDRAW Graphics Suite
You can uninstall CorelDRAW Graphics Suite from the Control Panel. If you want to uninstall the product and then reinstall it with the same serial number on another computer, make sure to uninstall while being connected to the Internet. This will restore by one the number of computers on which you can legitimately install the product.

To uninstall CorelDRAW Graphics Suite
1 On the Windows Control Panel, click Uninstall a program.
2 Double-click the suite’s name on the Uninstall or change a program page.
3 Enable the Remove option in the wizard that appears, and follow the instructions.
   To completely uninstall the product by removing user files, such as workspaces, presets, user-created fills, and customized files, enable the Remove user files check box.

Any additional components and applications that you installed with the suite, such as the Corel Graphics - Windows Shell Extension, GPL Ghostscript, or Microsoft Visual Studio Tools for Applications (VSTA), must be uninstalled separately.

FAQ
If your question is not included in the list of frequently asked questions (FAQ) below, visit Corel® Support Services, and search the Corel® Knowledge Base.
• “I am upgrading my version of the software. Do I need to uninstall the previous version?” (page 27)
• “What is the difference between an upgrade and an update?” (page 27)
• “What if I lost my serial number and need to reinstall the software?” (page 27)
• “What is the difference between Typical and Custom installation? Which type of installation is suitable for me?” (page 27)
• “Why do you ask me to update my operating system with the latest service packs and critical updates?” (page 27)
• “How do I deploy CorelDRAW Graphics Suite to my organization’s network?” (page 27)
• “How do I change the language of the user interface and Help?” (page 27)

I am upgrading my version of the software. Do I need to uninstall the previous version?

No, you don’t need to uninstall the previous version. By default, the new version is installed to a separate folder, which ensures that you can work with both versions. Do not change the installation folder to install the upgrade and the previous version to the same folder.

What is the difference between an upgrade and an update?

An upgrade lets you install the latest major version of the software. After a major version is released, updates usually follow to offer defect fixes, and performance and stability improvements. Updates have the name of the major version with a number appended — for example, .1. Often, the application installs silently the necessary updates, but you can also check for updates by clicking Help ➤ Updates.

What if I lost my serial number and need to reinstall the software?

Do one of the following:

• For download versions, check the email you received from Corel when you purchased the product.
• Sign in on corel.com to access Your Account page.
• If you purchased a box, check the cover of the installation disk.

What is the difference between Typical and Custom installation? Which type of installation is suitable for me?

See “Installation options” on page 24.

Why do you ask me to update my operating system with the latest service packs and critical updates?

We ask you to install the latest service packs and critical updates in order to:

• protect your computer from malicious software
• resolve Windows issues and defects
• ensure smooth operation of the operating system and your Corel software
• help meet the minimum system requirements
• help speed up the installation process
• reduce the likelihood of needing to restart your operating system
• ensure that system drivers are up-to-date and optimized for the suite.

How do I deploy CorelDRAW Graphics Suite to my organization’s network?

If you purchased multiple licenses of CorelDRAW Graphics Suite, you have the option of deploying the applications to your organization’s network.

The CorelDRAW Graphics Suite Deployment Guide provides more information about network installations. To purchase a volume license of the software, please contact Corel® Support Services.

How do I change the language of the user interface and Help?

You can change the language of the user interface and Help only if you have purchased and installed a multilingual version of the suite. For more information, see “To change the language of the user interface and Help” on page 59.
Corel accounts and services

This section contains the following topics:

• “Authenticate CorelDRAW Graphics Suite” (page 29)
• “Account settings” (page 30)
• “Updates” (page 30)
• “Change user credentials” (page 30)
• “Your privacy and profile” (page 31)
• “Corel Support Services” (page 32)
• “Submit feedback” (page 32)
• “Error logging and reporting” (page 32)

Authenticate CorelDRAW Graphics Suite

Authentication lets you access online features and content that are included with your software. You can authenticate CorelDRAW Graphics Suite after the suite installation, before starting an application, or while using an application.

To authenticate CorelDRAW Graphics Suite, you must sign in with your Corel.com account. This action associates your product with your account. If you don’t have a Corel.com account or you want to associate your product with a new account, you need to create an account before signing in.

After you install and authenticate CorelDRAW Graphics Suite, the product appears in Your Account page on corel.com. If you want to associate the product with a different account, you must change your user credentials. For more information, see “Change user credentials” on page 30.

To authenticate CorelDRAW Graphics Suite

1. Click the Sign-in button in the upper-right corner of the application window.

2. In the dialog box that appears, do one of the following:
   • Sign in by entering the email address and the password associated with your Corel.com account.
   • Follow the instructions to create an account, and sign in.
You can now access online features provided you have Internet connection.

**Account settings**

You can check your account settings by accessing Your Account page from within the application. On Your Account page, you can find out more about the products associated with your account, and you can access support and set your communication preferences.

In those rare cases when your account settings may not reflect your latest transaction, you can refresh your account from within the application.

**To check your corel.com account**

- Click Help ➤ Account Settings.

**Updates**

Product updates, formerly known as service packs, include performance and stability improvements that enhance your product experience. By default, you are automatically notified when product updates and news become available. You can customize the update and message settings. For example, you can choose how often to receive updates and offers as tray notifications: daily, weekly, monthly, or not at all.

To view information about product updates, click Help ➤ Updates.

To customize update and message settings, click Help ➤ Message Settings.

**Change user credentials**

As a user and owner of CorelDRAW Graphics Suite, you must know your user credentials:

- your product serial number — lets you install and reinstall your product. The serial number is the unique identifier of your product license.
- the email address associated with your Corel.com account. For each Corel.com account, a unique email address and password are required. When you authenticate your product to access online features and content, you sign in with a specific Corel.com account, associating the product with that account and its email address.

This topic describes two typical cases in which you need to change your account settings and then update your user credentials in the installed product to match the new account settings. Updating your user credentials ensures that you don’t need to uninstall and reinstall the product.

You want to merge two product subscriptions that you purchased with the same Corel.com account at a different time so that the subscriptions have the same renewal date.

In this case, each subscription is associated with a different serial number. You must first go to Your Account page, and then associate both subscriptions with one of the serial numbers. Second, you must edit the user credentials in the product that now has an obsolete serial number.

Step 1: Go to Your Account page by signing in on corel.com, and then click Merge in the Product Status area. On the Subscriptions page, select the subscriptions that you want to merge. Proceed to the Confirm selection page, and choose the serial number that you want to keep.

Step 2: Start the version of CorelDRAW or Corel PHOTO-PAINT that now has an obsolete serial number. Click Tools ➤ Options ➤ Global. In the left pane of the dialog box, click UserID. Next, click Edit Credentials, and in the dialog box, type the serial number that you chose in step 1.
You have two Corel.com accounts associated with different email addresses, and you want to merge the two accounts.

First, you must call Corel Support Services to merge the accounts for you, and then you must update your email address through the product.

Step 1: Contact Corel Support Services with a request to merge the two accounts for you. You will be asked to provide an active email address for your merged account. If you have subscriptions or Upgrade Programs in each account, they are associated with different serial numbers so you need to choose one of the serial numbers.

Step 2: Start the version of CorelDRAW or Corel PHOTO-PAINT that is now associated with an obsolete account and email address. Click Tools ➤ Options ➤ Global. In the left pane of the dialog box, click User ID. Click Edit Credentials, and in the dialog box that appears, type the email address that you chose for your merged account. Type your password. If necessary, type the serial number that you chose in step 1.

Your privacy and profile

Corel tracks which features you are using to improve the application. Also, when you search for learning materials from within the Learn docker, Corel tracks your searches and uses this information to improve the available learning materials and create new tutorials. You can adjust your privacy settings to opt out of feature and search term tracking at any time.

Once you complete your profile, we can recommend learning materials based on the information you provided in the survey, such as your familiarity with the product and the projects you create. If you don’t want to receive any recommendations, you can reset your profile to the default state. You can also edit your profile at any time by changing your responses and providing answers to newly added questions. An up-to-date profile helps us improve our recommendations for you.

To manage privacy settings

1. Click Tools ➤ Options ➤ Global.
2. In the left pane of the Options dialog box, click Privacy.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow or prevent Corel from tracking what features you use</td>
<td>Enable or disable the Share feature usage check box.</td>
</tr>
</tbody>
</table>
| Allow or prevent Corel from collecting information about your searches in the Explore tab of the Learn docker | Enable or disable the Share search terms check box.  
  Note: Searching for learning materials in the Explore tab of the Learn docker is an application feature, so if you disable the Share feature usage check box, the Share search terms check box is disabled and grayed out by default. |

To manage your profile

1. Click Tools ➤ Options ➤ Global.
2. In the left pane of the Options dialog box, click Privacy.
3. Click one of the following buttons:
   - Reset Profile — reverts your profile to the default state, letting you opt out of recommendations in the Welcome Screen and Learn docker
   - Edit Profile — opens the latest version of the profile survey, letting you update your responses and answer any new questions that may have been added
Corel Support Services

Corel Support Services can provide you with prompt and accurate information about product features, specifications, pricing, availability, services, and technical support. For the most current information on support services available for your Corel product, please visit www.corel.com/support.

Submit feedback

You can submit comments or suggestions about CorelDRAW Graphics Suite to an online portal where other users can review and evaluate them. You can also vote and comment on feedback from other users. To submit, vote, or comment on feedback, you must log in to your CorelDRAW Graphics Suite Ideas Portal account. The portal is available only in English.

To share ideas and give feedback about the application

1. Do one of the following:
   • Click Help ➤ Submit Ideas and Feedback.
   • Click Help ➤ Welcome Screen, then click Ideas & Feedback.
   • Click Help ➤ Learn, then click Share your ideas and suggestions.
2. On the CorelDRAW Graphics Suite Ideas Portal, click Log In/Sign Up, and enter your credentials.
   If you don’t have a CorelDRAW Graphics Suite Ideas Portal account, you can create one now.
3. Click Add A New Idea.
4. On the New Idea page, type a one-sentence summary of the idea in the Your Idea box.
   Any similar ideas will appear here when you start typing. Consider voting for them before you create a new idea. You can search existing ideas by typing in the Search all ideas box. If you find ideas you agree with, click the corresponding Vote button.
5. In the Please add more details box, type more information about your idea.
6. Click Add Idea.

Error logging and reporting

If an application in CorelDRAW Graphics Suite quits unexpectedly, an error report will appear the next time you launch the application. To help improve the application, provide any steps necessary to reproduce the problem, and send the error report to Corel. You can also disable error logging and reporting.

To enable or disable error logging and reporting

1. Click Tools ➤ Options ➤ Global.
2. In the left pane of the Options dialog box, click Privacy.
3. Enable or disable the Show Crash Report dialog box check box.
   When the check box is disabled, you will not be prompted to send reports if the application stops responding.
What’s new in CorelDRAW Graphics Suite?

The new and enhanced features of CorelDRAW® Graphics Suite are described in the following topics:

- “CorelDRAW Graphics Suite September 2023 release” (page 33)
- “CorelDRAW Graphics Suite March 2023 release” (page 35)
- “CorelDRAW Graphics Suite September 2022 Subscriber Update” (page 36)
- “CorelDRAW Graphics Suite March 2022 Subscriber Update” (page 37)
- “CorelDRAW Graphics Suite 2021.5” (page 42)
- “CorelDRAW Graphics Suite 2021” (page 44)

CorelDRAW Graphics Suite September 2023 release

New! Focus mode

When working on complex documents in CorelDRAW, Focus mode simplifies selecting and editing objects within groups. It allows you to isolate design elements while still being able to see them within context of the whole drawing. You can focus on a range of design elements, including PowerClip objects, symmetry groups, objects with effects applied, bitmaps, and more.

When you bring an object or a group of objects into Focus mode, it is brought to the top of the stacking order. A transparent overlay covers all other design elements that cannot be edited or selected. This makes it easier to work with a particular object, group of objects, or overlapping objects. You can adjust the opacity of the overlay.

When you activate Focus mode, a floating toolbar appears in the top-left corner of the drawing window displaying the focused object’s place in the hierarchy of the design. Using the breadcrumb controls on the floating toolbar, easily navigate through object groups without needing the Objects docker, freeing up screen space.

For more information, see “Edit objects in Focus mode” on page 305.

Enhanced! Export options

A range of enhancements to the Export docker in CorelDRAW make it easier than ever to output objects and pages to even more file formats, now including CDR, WEBP, CGM, PSD, and BMP. A redesigned workflow simplifies exporting the current page, all pages, or selected objects.

When working with multipage documents, you can export each page to a separate file. You can also export a specific page or a range of pages. In addition, a page in one document can be duplicated and exported to a new CorelDRAW file in couple of clicks. And now page sizes are retained in the individual output files when exporting to GIF, JPG, PNG, or EPS.
For more information, see “Export objects and pages” on page 891 and “To duplicate and export a page to a new document” on page 728.

New and enhanced! Assets docker

CorelDRAW Graphics Suite September 2023 Subscriber Update introduces a range of features and enhancements to the Assets docker to improve your workflow. In response to user feedback, the redesigned docker incorporates a tree folder structure, providing a familiar and intuitive method for browsing files. It allows you to view folder hierarchy, navigate through folders, and locate content within the broader context of your files.

The Assets docker now has two panes, Folders pane and Content pane, so you can browse and preview content with ease. The Folders pane lets you browse content and filter out search results by selected folder. You can browse and search the contents of one or more folders, or explore all locations in the folder list. Furthermore, CorelDRAW enables you to add folders to or remove folders from the content locations list, giving you the flexibility to work with content from local folders and shared network locations. You can rename items in the folder list and give them more descriptive or meaningful names, facilitating better organization and seamless file navigation. You can expand and collapse folders to optimize screen space and focus on relevant content. Plus, you can navigate the tree folder structure in the Folders pane by using the arrow keys, which offers efficiency, accessibility, and contributes to a smoother workflow. The Content pane displays assets thumbnails. You can resize the Folders and Content panes to adjust the layout of the Assets docker according to your preferences and needs.

We have streamlined the user interface to enhance accessibility and convenience. Sorting options are now conveniently located in a drop-down list at your fingertips. Plus, progress bars appear during the loading and synchronization of content, providing visual feedback on the status of these tasks while you work uninterrupted in the application. In addition, performance improvements deliver faster syncing, filtering, and searching of content.

For more information, see “Find clipart and other local and network assets” on page 110.

New and enhanced! Print Merge

Introducing a range of user-inspired enhancements, the Print Merge feature in CorelDRAW offers increased versatility and ease of use.

Expanding the range of compatible file types, CorelDRAW now provides support for Excel Workbook (XLSX) data source files. Yet another significant improvement in the import functionality is the ability to choose specific worksheets and columns when importing data from spreadsheets with multiple tabs and columns. For more information about importing data source files, see “To import a data source file” on page 842.

The latest update includes two new variable data types, images and QR codes, enabling you to integrate diverse data into your projects and produce richer outputs with ease. In addition to columns holding text and numeric values, you can now create path columns and specify file paths. This allows you to seamlessly incorporate image assets such as logos, icons, or photographs into your merged documents. For more information about image fields, see “Image fields” on page 844. By merging unique QR codes for each record, you can supply customized experiences for your audience. For more information about QR code fields, see “QR code fields” on page 846. Enhanced alignment and scaling options for images and QR codes give you complete control over the position and size of the visuals in the final output.

Another essential feature is the ability to synchronize a linked file with its source and incorporate the latest changes. For more information about importing and syncing with data source files, see “Import and sync with data source files” on page 838. Furthermore, alongside importing a data source file, you can now selectively import data from columns, which makes it easier to combine data from diverse sources, expanding your possibilities. For more information about importing a column, see “To import a column from a data source file” on page 842.

CorelDRAW introduces a number of time-saving features that streamline the data management process, maximizing your efficiency and productivity. You can select and deselect all records with the click of a button. Plus, you can quickly clear all merge data without having to manually delete each individual record and column. Updating print merge fields in your document is now quick and easy, giving you the flexibility to adapt and modify the content as needed. For more information about updating data fields, see “To edit a merge field” on page 849.

The application offers multiple methods for identifying and locating print merge objects, enhancing your ability to navigate and work with documents. When you select merge fields on the drawing page, blue handles visually differentiate them from regular objects. In addition, you can conveniently find information about merge fields on the Status bar and in the Summary section of the Properties docker.
complex files with numerous objects and data fields, the **Find and Replace** docker is highly effective for quickly locating merge fields. For more information about finding and selecting merge fields, see “To find and select merge fields” on page 849.

**Enhanced! PDF Import**

Enhanced PDF import capabilities, such as improved text flow, enhanced text editability, accurate recognition of language order, retention of OpenType features and stylistic sets, and preservation of formatting and column layout, ensure a fast and seamless transition of your PDF content into CorelDRAW. Paragraphs are intelligently converted into Artistic and Paragraph text objects based on line length and spacial proximity, ensuring an accurate representation of the original text structure and organization. Paragraph alignment, line spacing, drop caps, superscript and subscript characters, bulleted and numbered lists, and other formatting elements are precisely identified and maintained, preserving the intended visual appeal and integrity of your document. Optimized paragraph handling, accurate recognition of formatting details, and smoother transitions for multi-column layouts streamline your editing workflow, making it easier and more efficient to work with imported PDF content.

**Enhanced! Ghostscript 10.01.2**

The application removes the previously installed GPL Ghostscript 8.64 included with the CorelDRAW product and offers the latest version 10.01.2 as an optional module. For more information, see “Installation options” on page 24.

**Note**: If the CorelDRAW Graphics Suite September 2023 Subscriber Update hasn't been applied, it is recommended that you verify the Ghostscript version installed on your system, uninstall any outdated versions of the module, and install version 10.01.2 to address vulnerabilities in Ghostscript 10.01.1 and earlier. For detailed instructions on updating Ghostscript, see How to uninstall Ghostscript (8.64) or exclude it from the installation of CorelDRAW Graphics Suite.

**CorelDRAW Graphics Suite March 2023 release**

**New! Online templates**

In CorelDRAW, you can now start a project from an online template on the **Templates** tab of the **Create a New Document** dialog box. For more information, see “To start a document from a template” on page 692. The new online library gives you instant access to more templates than ever before. Complete your profile survey, so you can filter templates and display the ones that are best suited for you.

**Enhanced! Practice project recommendations**

You can now access practice projects that match your skill level, needs, and interests on the last page of the profile survey. For more information, see “Practice projects” on page 56.

**Enhanced! Document-creation controls**

Now you can set bleed limits on the **Document Settings** tab of the **Create a New Document** dialog box. This setting is saved with the document's presets and offers more flexibility when creating new documents in CorelDRAW. For more information, see “Start and open drawings” on page 62.

**Enhanced! Document-preset thumbnails**

Improved thumbnails of presets in the **Create a New Document** dialog box make it easier to view and browse the wide selection of print, web, device-specific, and social media presets available in the app. Page size information has been streamlined to reduce visual clutter. Now icons give a better indication of the page type and can help you quickly locate the exact preset you need.

**Enhanced! Crash reporting**

If an application in CorelDRAW Graphics Suite quits unexpectedly, an error report dialog box appears the next time the application is launched. Now if you don't want to send an error report, you can disable the crash report dialog in the **Global Privacy** settings. For more information, see “Error logging and reporting” on page 32.
New! Variable Outline tool

The Variable Outline tool lets you create object outlines of varying widths in CorelDRAW. You can specify where the width variance starts and ends to create dynamic, organic-looking lines and shapes. In addition, you can modify an outline without affecting its variable outline properties. For more information, see “Variable outlines” on page 181.

You can apply an outline of varying widths using the Variable Outline tool.

CorelDRAW Graphics Suite September 2022 Subscriber Update

New and enhanced! Support for the Google Web Picture (*.webp) file format

CorelDRAW and Corel PHOTO-PAINT now offer support for the Google Web Picture (*.webp) file format. This open standard format developed by Google provides lossless and lossy compression for images designed for use on the web. WEBP lossless images are smaller than PNGs, and WEBP lossy images are smaller than JPEG images. You can import WEBP files as you would any other supported files. When you export a file to the WEBP format, you can choose from several presets to suit your needs, or create a new preset and save it for future use. Advanced settings, such as quality and compression ratio give you flexibility and control over the compression factor for RGB channels and the ratio between encoding speed, file size, and quality, respectively. Image transparency is maintained on both import and export. For more information, see “Google Web Picture (WEBP)” on page 946.

New and enhanced! Practice projects

Practice projects are collections of CorelDRAW (CDR) and Corel PHOTO-PAINT (CPT) files that you can download to use for learning, training, or demos. You can take advantage of these new in-app tutorials to practice basic concepts and refine your skills. In addition to the completed version of the project that you can consult for reference, each CorelDRAW tutorial comes with a partially completed version enriched with step-by-step instructions to make the experience interactive and help you complete the project successfully. You can access and browse practice projects on the Explore tab of the Learn docker. Complete the user profile survey to get recommendations for practice projects that match your needs. For more information, see “Practice projects” on page 56.

New and enhanced! Create a New Document dialog box

The Create a New Document dialog box in CorelDRAW has been redesigned to provide a central location for starting drawings. The dialog box now has two tabs, Document Settings and Templates, so you can switch between views with ease.

On the Document Settings tab (File ➤ New), you can start a blank drawing by specifying document settings or choosing a preset. CorelDRAW lets you search and browse a wide selection of print, web, device-specific, and social media presets. Presets include predefined settings for page size and orientation, primary color mode, units of measurement, and resolution. For example, the LinkedIn Cover preset from the Social category uses pixels instead of inches, landscape orientation, RGB color and has the dimensions required for a LinkedIn cover image. To find presets more easily, CorelDRAW lets you filter them by category and page type and sort them by name, date, and page size. For more information, see “Start and open drawings” on page 62.
On the Templates tab (File ▶ New from Template), you can start a drawing from a template. The interfaces for filtering and sorting templates and accessing local and network folders have been reorganized to help you quickly find the templates you need. For more information, see “Find templates” on page 692.

New and enhanced! Scale tools

CorelDRAW lets you easily scale a portion of an object or image to a specific size. The time-saving Scale portion tool lets you resize a portion of an object to fit a desired dimension. For example, if you need a door to be seven feet tall, you simply specify that value and then drag vertically along the door to scale it. You can also use the interactive Fit to Reference tool, which offers greater accuracy when resizing an object to fit into another object. For example, this handy new tool lets you simultaneously scale and move a screw to fit perfectly into a specific nut. For more information, see “Size and scale objects” on page 346.

New and enhanced! Cropping artwork to page boundaries on export

Now when you export files to the PNG, JPEG, and GIF formats in CorelDRAW, you can crop your artwork to the boundaries of the drawing page to remove unwanted objects and reduce file size.

Enhanced! Export docker

CorelDRAW Graphics Suite September 2022 Subscriber Update introduces a range of features and enhancements to the Export docker to improve your workflow. Assets and pages can now be exported to three additional formats: Adobe Illustrator (AI), AutoCAD Drawing Database (DWG), and AutoCAD Drawing Interchange Format (DXF). For your convenience, assets and pages can be renamed directly in the Export docker. Plus, the Export button is grayed out when there are no items selected.

New! Updated user interface on Windows 11

To better align with the updated Windows 11 user interface, the CorelDRAW Graphics Suite September 2022 Subscriber Update features rounded corners on the application window and dialog boxes, dialog box shadows, a new application title bar, and snap layouts.

CorelDRAW Graphics Suite March 2022 Subscriber Update

New! Adjustment presets

In CorelDRAW Graphics Suite March 2022 Subscriber Update, adjustment presets have been completely rebuilt. You can now create multi-filter adjustment presets non-destructively in Corel PHOTO-PAINT™, and apply these presets in both CorelDRAW and Corel PHOTO-PAINT. When you achieve a favorite image-editing result, you can easily combine and save the adjustment filter settings for quick and easy reuse in other projects.

You can also organize your presets into custom categories or simply assign them to default categories. In addition, you can jump-start your editing process by choosing from a collection of carefully curated and tested preset styles, which include Black & White, Color, and Tone categories.
In CorelDRAW, you can apply adjustment presets from the FX tab in the Properties docker.

**New and enhanced! Adjust menu**

When you choose a filter from the restructured Adjust menu in Corel PHOTO-PAINT, the Adjustments docker automatically opens the tools and settings for your chosen filter. All adjustments are now non-destructive, so you can experiment endlessly. And you can reset or flatten your adjustments with a single click. In addition, there are new shortcuts and commands designed to save you time, and you can instantly copy and paste adjustments with a menu command.

**New and enhanced! Adjustments docker**

The Adjustments docker in Corel PHOTO-PAINT has been reorganized to make it your one-stop shop for adjustment filters. Four additional filters have been added, and existing filters introduce new interface elements and editing options that make it easier for you to achieve your desired result.

The Black & White filter provides a new creative option that gives you greater control when converting a color image to grayscale. You can now isolate the shadows and highlights of your image and adjust the hue and saturation of each image characteristic separately, which is very effective for tinting.

There are also updated controls for Color Balance, Equalize, and Sample & Target filters, and a new Levels filter that makes it easier to adjust image contrast. With the Color Balance filter, a new color sampling tool lets you set a neutral gray with a single click. The Histogram interfaces have been enhanced, and to give you a better visual representation as you make adjustments, we’ve added color to the sliders for the following filters — Hue, Saturation, and Lightness, Black & White, Replace Colors, Channel Mixer, and Color Balance.
Enhanced! Adjustments docker performance

With Corel PHOTO-PAINT, you will experience an impressive boost in image-editing speed when using the Adjustments docker. The improved display caching system means that adjustment filters will be fluid and responsive, particularly when zooming in on smaller image details and areas. In addition, support for multi-core processing in both CorelDRAW and Corel PHOTO-PAINT makes applying adjustments in either application a breeze.

New and enhanced! General improvements

CorelDRAW Graphics Suite March 2022 Subscriber Update offers an array of general improvements inspired by frequent user requests. CorelDRAW provides five new adjustment filters and 19 effects for working with bitmaps, all accessible from the Effects menu.

In Corel PHOTO-PAINT, the Objects docker now provides an opacity slider with live results, making it easier to adjust and assess changes to object opacity. You can also now apply non-destructive effects to selections that include multiple objects, even when using a mask.

As you save your work with non-destructive effects in Corel PHOTO-PAINT, you’ll likely notice reduced file sizes, often by as much as two times smaller thanks to new use of ZIP compression on effect data. There’s also a new Edge Transparency option in the Mask menu that lets you control the falloff of transparency on mask edges. In addition, the cursor for several masking tools has been updated to provide better indication of whether you’re in a creation or transformation state.

New and enhanced! Learn docker

Search for learning resources and tools in the new Explore section of the Learn docker, known as the Hints docker in earlier versions. Access and browse an extensive library of online resources from within the application to get familiar with product features quickly. Get our recommendations for videos and written tutorials that match your experience level and needs by completing your profile. Plus, you can view only the type of learning resources you prefer by applying a filter; and sort search results by relevance, date, or best match. For more information, see “Learn docker” on page 53.
New! Personalization settings

Our personalized recommendations for learning resources are based on the answers you provided in the profile survey. When you update your profile, we revise our suggestions for learning materials to better suit your needs. You can also opt out of recommendations by resetting your profile to the default state. For more information, see “Your privacy and profile” on page 31.

Enhanced! Pages docker

Improved thumbnail previews in the Pages docker in CorelDRAW simplify working with pages. Plus, you can now quickly insert pages after the active page, without having to rearrange pages manually.

Enhanced! Multipage view

Resize pages interactively in multipage view as if they were standard rectangle objects. To resize pages from the center, simply hold down Shift when dragging a handle.
Switching to multipage view automatically zooms to show all pages; switching to single page view zooms to fit the active page in the drawing window.

**Enhanced! Facing pages**

The new Show Spreads command in the Pages docker in CorelDRAW makes it easy to toggle between showing spreads of facing pages and single page thumbnails. When you view spreads as single page thumbnails, you can move any facing page by dragging it within the Pages docker or moving its page tab in the document navigator. For more information, see “To move a facing page” on page 734.

Plus, the improved tabs in the document navigator clearly show spreads of facing pages for easier page navigation.

---

**Enhanced! Multi-asset export**

The Export docker features expanded file support, letting you export assets to the TIFF and EPS file formats. Plus, you can select all assets with a single click, which makes it easier to export all assets at once or remove all items from the export list.

**Enhanced! Assets docker**

The new default list view and improved thumbnails of Cloud assets make it easier to view and use your content. Syncing assets from the Cloud is faster and more reliable. Plus, when using linked symbol libraries, you can restore broken links and regain access to the symbols in the libraries with ease.
New! Share ideas and provide feedback

Make suggestions about CorelDRAW Graphics Suite directly from within the applications, and then other users can evaluate and give feedback on your ideas. You can also review and vote on recommendations from others. For more information, see “Submit feedback” on page 32.

CorelDRAW Graphics Suite 2021.5

Available exclusively to subscribers, CorelDRAW Graphics Suite 2021.5 features improved asset management, a streamlined collaboration workflow, direct access to online fonts from within Corel® Font Manager™, and more.

New and enhanced! Manage, share, and sync assets

Access all your local, shared, and Cloud content from the Assets docker (formerly known as CONNECT Content docker) in CorelDRAW. Renamed and enhanced, the Assets docker gives you quick access to all symbol libraries and other files saved and shared to your Cloud folder. Plus, you can view linked symbol libraries, and you can sync them with their source, whether local or online, so that their symbols are always up-to-date.
Enhanced! Performance of Cloud files
It is now faster and easier to work with Cloud files. Whether you are saving documents to the Cloud, or opening or sharing Cloud documents, you’ll notice improved speed and performance.

Enhanced! Collaboration
A streamlined log-in process lets you sign in to the Cloud and the Comments docker simultaneously by using your Corel account. Any comments you add to a document after sign-in are now identified by your email address in addition to your name. Plus, you can bypass providing credentials altogether to add anonymous comments.

New! Access to online fonts
Access more than 1000 font families from the Google Fonts library directly from Corel Font Manager to use in your designs. Browse, search, and preview those online fonts with ease without having to install them. Download or install the fonts you like to access them from the Font list box in CorelDRAW and Corel PHOTO-PAINT.
New! Adjust variable font properties in Corel Font Manager

View and adjust the properties of variable fonts with Corel Font Manager.

Enhanced! File support in the Sources docker

Assemble complex projects with ease thanks to the enhanced file support in the Sources docker in CorelDRAW. Add externally linked CorelDRAW files to your drawings. You can even import Excel Workbook (XLS and XLSX) or Comma-separated values (CSV) files to add linked tables that contain project information. Plus, you can sync the linked files with their source at any time to update them with the latest changes.

CorelDRAW Graphics Suite 2021

You can count on CorelDRAW Graphics Suite 2021 to streamline your design journey. Whether you’re creating for web or print, get the job done with progressive image editing, next-generation collaboration that accelerates productivity, and new advanced-illustration tools that push the boundaries of your creativity.
New! Multipage View

CorelDRAW® 2021 helps accelerate the design workflow with Multipage View. It lets you see all pages in a document simultaneously, so you don't have to click tabs to navigate to another part of your drawing. For more information, see “Page views” on page 723.

View, manage, and edit all of your project’s digital assets in one view

New! Live Comments

This new feature lets everyone involved in a project work in real time, where stakeholders can comment on and annotate a document in CorelDRAW.app™ with all feedback instantly appearing in the working file in CorelDRAW 2021. For more information, see “Review and provide feedback” on page 137.

A new dashboard in both CorelDRAW 2021 and CorelDRAW.app™ acts as your collaboration hub. It contains all your Cloud drawings and in a click displays a preview, the number of comments and team members, and project status. The dashboard also lets you share designs directly from CorelDRAW 2021 without having to open each file. For more information, see “CorelDRAW.app, CorelDRAW, and Cloud” on page 135.

A project dashboard helps you store, view, organize, and share files saved to the Cloud.

New! Perspective Drawing

In CorelDRAW 2021, it's easier than ever to draw objects or scenes in perspective. This new feature is based on the principles of perspective projection and boosts productivity by eliminating the need to first set up complex grids.
To get you started, there are presets for four types of perspective drawing, which are easily customizable by adjusting any part of the perspective field. The possibilities are limitless thanks to the ability to create multiple perspective groups each with their own unique perspective field within the same page or document.

Whether you want to produce textures and patterns for your illustrations, deliver distinctive sketches of product ideas, or generate proof of concept designs that have the illusion of depth and distance, perspective drawing can help accomplish the task at hand with ease. For information, see “Perspective drawing” on page 285.

Draw objects or illustrated scenes in perspective, faster and easier than ever.

New! Multi-asset Export

CorelDRAW® 2021 lets you create a customized list of assets to export with one click. The new Export docker has a range of flexible, time-saving options for outputting pages and objects.

In a couple of clicks, you can send pages or objects to multiple industry-standard formats, including PDF. The same design element can be simultaneously exported with different settings by duplicating it in the Export docker and modifying the output options. Or you can export several items at the same time using identical preferences. For more information, see “Export objects and pages” on page 891.

Export a list of pages and objects to a range of formats in a single click.

Enhanced! Image Adjustment

Corel PHOTO-PAINT 2021 introduces a range of features and enhancements to deliver more efficient, accurate image editing. The new Adjustments docker gives instant access to the most critical and frequently used filters, letting you quickly work non-destructively, in real time, and in context. What’s more, the brand new Local Adjustment Mode simplifies targeting a filter to a specific image area.
The **Replace Colors** filter has been rebuilt from the ground up. Improved color pickers and eyedropper tools allow for more precise editing, and a new interactive control makes fine-tuning hue and saturation ranges more intuitive. CorelDRAW 2021 has also added a slider to help ensure smoother color transitions between selected and unselected pixels. For more information, see “To replace colors” on page 791.

**New! HEIF Support**

CorelDRAW Graphics Suite 2021 lets you take advantage of photos captured on mobile phones with High Efficiency Image File (HEIF) support. Many devices use HEIF as the default capture format because it delivers smaller file sizes without sacrificing picture quality. You can import or open the key image from HEIF files in Corel PHOTO-PAINT or import it into a drawing in CorelDRAW. For more information, see “High Efficiency Image File Format (HEIF)” on page 929.
New! Pages docker

CorelDRAW 2021 simplifies working with multipage documents thanks to the new **Pages** docker. It lists all pages in a design so you can easily manage them and quickly navigate a project. Each page has a scalable thumbnail preview that reflects its size and content. Reordering pages is as easy as dragging them in the docker. What’s more, you can add, delete, and rename pages in one spot, saving you time and effort. And in a click, you can switch display modes to either focus on a single page or use the new Multipage View. For more information, see “Pages” on page 719.

Manage pages in your drawings with ease and navigate projects faster than ever.

New! Autofit Page

Another time-saver in CorelDRAW 2021 is the **Autofit Page** feature. In just a click, you can resize a page to fit its content. You can also quickly customize the margin by specifying the space between design elements and the edge of the page. For more information, see “To autofit a page” on page 734.

Enhanced! Guidelines

When working with guidelines, you can quickly switch views from world scale to page dimensions. In addition, it’s easier to manage custom guidelines, so you can set up the framework for a design faster than ever.
Enhanced! Pan and Zoom

CorelDRAW Graphics Suite 2021 is optimized to better leverage your system’s graphics processing unit (GPU) and deliver significantly smoother panning and zooming. Whether you’re using a mouse or trackpad, you can navigate a document with perfect fluidity.

User-inspired enhancements

New! Export or import font collections

Corel Font Manager 2021 offers a new feature that helps ensure that you can preserve your font collections. You can now import and export font databases so that you can use them in another version of the software or share with them others.

Enhanced! Find and Replace

Finding and replacing objects is easier in CorelDRAW 2021 thanks to new indicators that highlight objects included in a search when you’ve limited the range to selected items.

New! Snap to self

When working in complex designs, a new setting allows you to prevent objects from snapping to their own snap points so you can move and transform design elements with ease and precision.
Learning resources

You can learn to use the product in various ways: by reading the Quick Start Guide; by accessing the Help, Hints, and tooltips, and by exploring the resources on the Corel website (www.corel.com). You can also check the Readme file (readme.html), which is installed with the software.

This section contains the following topics:
- “Get help” (page 51)
- “Learn docker” (page 53)
- “Help and tooltips” (page 54)
- “Hints” (page 55)
- “Welcome screen” (page 55)
- “Quick Start Guide” (page 56)
- “Practice projects” (page 56)
- “Video resources” (page 57)
- “Developers’ website” (page 57)
- “Network deployment guide” (page 57)
- “Web-based resources” (page 57)

Get help

Various learning resources are available. The following table can help you decide what learning resources to consult when you need assistance. You can access more information about some resources by clicking the corresponding links.

<table>
<thead>
<tr>
<th>To</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start learning the applications</td>
<td>“Video resources” on page 57</td>
</tr>
<tr>
<td></td>
<td>“Quick Start Guide” on page 56</td>
</tr>
<tr>
<td></td>
<td>“Practice projects” on page 56</td>
</tr>
<tr>
<td>Get recommendations for tools and learning resources to help you with the task at hand</td>
<td>“Learn docker” on page 53</td>
</tr>
</tbody>
</table>
To

Learn about new and enhanced features

Obtain additional information about product tools and features

Advance your knowledge of the suite by learning from graphics design experts

Learn to automate tasks by using macros and scripts

Find information about deploying the suite on a network

Find specific information about the latest version of the suite

See

“Video resources” on page 57

“Help and tooltips” on page 54

“Hints” on page 55

“Web-based resources” on page 57

Insights from the Experts, a series of tutorials by graphic design professionals who use CorelDRAW Graphics Suite in their everyday work. You can access these online tutorials as individual PDF files directly from the Corel website.

“Web-based resources” on page 57

Community website for developers

CorelDRAW Graphics Suite Deployment Guide

Readme file (readme.html), which is installed with the software. To find it, navigate to the folder where the product is installed, open the Languages folder, and open the language folder you want.

Documentation conventions

The following table describes important conventions used in the documentation.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu ▶ Menu command</td>
<td>A menu item and menu command that you need to click in sequence</td>
<td>Click File ▶ Open.</td>
</tr>
</tbody>
</table>
Learn docker

The Learn docker lets you search and access various online learning resources such as practice projects, videos, Help topics, and written tutorials that can help you with your projects. To find the resources you need more easily, you can filter and sort your search results.

Complete your profile by answering questions about your experience with the product and the type of projects you create so that we can recommend learning resources that match your skill level, needs, and interests. You can access the profile survey when you start the application for the first time or from the Explore tab of the Learn docker.

In addition, you can search local resources such as Hints and tooltips from within the Learn docker. For information about how to access and use Hints, see “Hints” on page 55. For more information about tooltips, see “Help and tooltips” on page 54.

You can also give feedback and share ideas about the application from the Learn docker. For more information, see “Submit feedback” on page 32.

To find learning resources

1. Click Help ▶ Learn.
2. In the Learn docker, click the Explore button 🌍.
   If you haven’t completed your profile, click the Personalize results button ✨ and answer the questions in the survey.
3. In the Search box, type a search term, and press Enter.
   To delete the search term, click the Clear search button (X).

You can also

Filter search results

Click the Filter button, and disable any of the following filters: Tool Hints, Practice Projects, Written Tutorials, Videos, and Help Topics.

Sort search results

From the Sort list box, choose one of the following options:
• Most Recent — sorts learning materials by the date they were created, starting with the most recent one
• Recommended for you — sorts learning materials based on your profile, starting with the ones that best match your needs, interests, and skill level
• Most Relevant — sorts learning materials based on their relevance to the search term you typed
You must be signed in to access the Explore tab. For more information, see “To authenticate CorelDRAW Graphics Suite” on page 29.

You can also access the profile survey from the Privacy page of the Options dialog box. For more information, see “Your privacy and profile” on page 31.

Help and tooltips

The Help provides comprehensive information about product features from within the application.

An active Internet connection is required to access the help. The Help is also available online as a user guide in a print-friendly PDF format. If you often work offline, you can download the CorelDRAW User Guide.

You can browse through the entire list of topics or search for specific words. You can also access the Corel Knowledge Base on the Corel website and other online resources, such as videos, from the Help window.

Tooltips provide helpful information about application controls when you position the pointer over icons, buttons, and other user interface elements. You can hide all tooltips, and you can display them again when you need them.

To use the Help

1. Click Help ▶ Product Help.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse through topics in the Help</td>
<td>Click a topic heading in the left pane.</td>
</tr>
<tr>
<td>Search the full text of the Help for a particular word or phrase</td>
<td>Type a word or phrase in the search box. For example, if you are looking for information about the RGB color mode, you can type RGB to display a list of relevant topics. Choose a topic from the list that appears. Tip: If your search results do not include any relevant topics, check whether you spelled the search word or phrase correctly. Note that the English Help uses American spelling (for example, “color,” “favorite,” “center,” and “rasterize”), so searching for British spellings (“colour,” “favourite,” “centre,” and “rasterise”) produces no results.</td>
</tr>
</tbody>
</table>

You can also access the Help by pressing F1.

View context-sensitive Help from within a dialog box by clicking the Help button in the dialog box.
To access the CorelDRAW User Guide
• Click Help ▶ User Guide.

An active Internet connection is required to access the User Guide. If you often work offline, download the User Guide from product.corel.com.

To hide and show tooltips
1 Click Tools ▶ Options ▶ CorelDRAW.
2 Click Display.
3 In the Other controls area, disable or enable the Show tooltips check box.

Hints
Hints provide information about tools in the toolbox from within the application. When you click a tool, a hint appears on the Hints tab of the Learn docker on the right side of the application window, telling you how to use the tool. If you need additional information about a tool, you can access relevant learning resources such as a Help topic, video, or written tutorial. You can hide the Hints at any time.

To use Hints

To

Display or hide Hints

Do the following

Click Help ▶ Learn, and click the Hints button in the Learn docker.

When the Learn command is enabled, the Learn docker appears and provides information about the active tool in the toolbox.

Display information about a tool

Click the tool, or perform an action with a tool that is already active.

Get additional information about the active tool

In the Learn more section, click a link to a relevant Help topic, video, or a written tutorial.

Navigate to previously viewed topics

Click the Back and Forward buttons at the bottom of the Learn docker.

You can also give feedback and share ideas about the application from any Hint in the Learn docker. For more information, see “Submit feedback” on page 32.

Welcome screen

The Welcome Screen appears when you start the application. With the Welcome Screen, you can quickly start or open a document, choose a workspace that suits your needs, access online learning videos and other learning resources, and get inspired by a gallery of original artwork created with CorelDRAW. Plus, discovery files can help you get started quickly with the application.
To access the Welcome screen
• Click Help ➤ Welcome screen.

You can close the Welcome screen by clicking the X button on the Welcome screen button on the tab bar.

You can also access the Welcome screen by clicking the Welcome screen button on the tab bar.

If you don’t want to see the Welcome screen each time you start the application, click Tools ➤ Options ➤ CorelDRAW, and choose a different option from the On CorelDRAW start-up list box on the General page.

You can also give feedback and share ideas about the application from the Welcome Screen. For more information, see “Submit feedback” on page 32.

Quick Start Guide

The Quick Start Guide, available in PDF format, can help you get started quickly with the suite by introducing you to useful tools and features.

To access the Quick Start Guide
• Click Help ➤ Quick Start Guide.

An active Internet connection is required to access the Quick Start Guide. If you often work offline, download the Quick Start Guide from product.corel.com.

Practice projects

Practice projects are collections of CorelDRAW (CDR) and Corel PHOTO-PAINT (CPT) files that you can download to use for learning, training, and demos. Take advantage of these short, in-app tutorials to practice basic concepts or refine your skills. In addition to the completed version of the project that you can consult for reference, each CorelDRAW tutorial comes with a partially completed version enriched with step-by-step instructions and hands-on tasks to make the experience interactive, reinforce your knowledge, and help you complete the project successfully. You can access the practice projects in the Learn docker. For more information about the Learn docker, see “Learn docker” on page 53. Search for a feature that you would like to explore and discover what tutorials in our collection meet your needs.

When you click a practice file in the list of search results, it is downloaded to the %AppData%Roaming\Corel\CorelDRAW Graphics Suite 2022\{APP\}\Discovery\{LANGUAGE\} folder where {APP} stands for the application, and {LANGUAGE} stands for the language of the user interface; for example, if you have installed the application in English, the practice projects you download are stored in the %AppData%Roaming\Corel\CorelDRAW Graphics Suite 2022\Draw\Discovery\EN folder. After a tutorial is downloaded to the default folder, it automatically opens in the application.

To access a practice project
1 In the Learn docker (Help ➤ Learn), click the Explore button.

To get recommendations for practice projects that match your needs, click the Personalize results button, and answer the questions in the survey to complete your profile.

2 In the Search box, type a search term, and press Enter.

To show only practice projects, Click the Filter button, and disable all filters except for Practice Projects.

3 In the list of search results, click the thumbnail of the practice project that you want to do.

When the file is downloaded to your machine, it automatically opens in the application.
After you complete a tutorial, you can save it. For more information about saving drawings, see “Save drawings” on page 76.

If you have already downloaded a practice project, the next time you click on the thumbnail image for this tutorial in the Learn docker, the application will open your local version as a new document.

**Video resources**

You can access video learning resources from the Welcome screen, from the Learn docker as well as from the Help menu.

The video tutorials show you how to complete basic tasks such as drawing, shaping, and coloring objects in CorelDRAW, or masking and cropping in Corel PHOTO-PAINT and help you get the most out of features such as symmetry, font management, fills and transparencies, alignment tools, QR codes, bitmap and vector effects, and more. Some videos don't have sound but include captions that provide useful tips and help you understand the features that are shown. Whether you are a new or long-time user, you will find useful demos and tips to boost your productivity and expand your experience.

**To access a video**

- Click **Help ▶ Video tutorials**.

**Developers’ website**

Whether you are automating tasks by using macros or scripts, creating custom tools, or developing commercial solutions that integrate with CorelDRAW Graphics Suite; the developer community website can help you with its wealth of useful resources: a programming guide, detailed Object Model reference documentation with code samples, and in-depth programming articles.

You can use either Microsoft Visual Basic for Applications (VBA) or Microsoft Visual Studio Tools for Applications (VSTA) to create macros and customized solutions for CorelDRAW and Corel PHOTO-PAINT.

**Network deployment guide**

The CorelDRAW Graphics Suite Deployment Guide is a step-by-step resource for deploying CorelDRAW Graphics Suite to a network. This guide is provided to customers who purchase a volume (“multi-seat”) license of CorelDRAW Graphics Suite for their organization. To purchase a volume license of the software and obtain its deployment guide, please contact Corel Support Services.

**Web-based resources**

The following web-based resources can help you get the most out of CorelDRAW Graphics Suite:

- **Corel Knowledge Base** — articles written by the Corel Technical Support Services Team in response to questions by users
- **Community.CorelDRAW.com** — an online environment to share your experience with the product, ask questions, give feedback and share ideas about the application, and receive help and suggestions from other users
- **Tutorials on the Corel website** — in-depth tutorials in which CorelDRAW Graphics Suite experts share their knowledge and techniques

An active Internet connection is required to access web-based resources.
Start and set up

This section contains the following topics:

• “Start and quit CorelDRAW” (page 59)
• “Change the language” (page 59)
• “Startup settings” (page 60)

Start and quit CorelDRAW

You can start CorelDRAW from the Windows taskbar and end a CorelDRAW session from the application window.

To start and quit CorelDRAW

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start CorelDRAW</td>
<td>From the Windows taskbar, click <strong>Start ➤ CorelDRAW Graphics Suite ➤ CorelDRAW</strong>.</td>
</tr>
<tr>
<td>Quit CorelDRAW</td>
<td>Click <strong>File ➤ Exit</strong>.</td>
</tr>
</tbody>
</table>

Change the language

If an application has been installed in more than one language, you can change the language of the user interface and Help at any time.

To change the language of the user interface and Help

1. Click **Tools ➤ Options ➤ Global**.
2. Click **General**.
3. Choose a language from the **User interface language** list box.
If you want to change the language of the user interface and Help when you start the application, enable the **Ask me the next time the application starts** check box.

4 Restart the application.

If there is only one language available in the **User interface language** list box, you must first install the additional languages that you want. For more information, see “To modify or repair a CorelDRAW Graphics Suite installation” on page 26.

### Startup settings

You can specify the startup settings for CorelDRAW, which control how the application appears when it’s opened. For example, you can start the application with the Welcome screen open or a new blank document.

**To change startup settings**

1 Click **Tools ➤ Options ➤ CorelDRAW**.
2 Click **General**.
3 In the **Getting started** area, choose an option from the **On CorelDRAW start-up** list box.
   - If you want to hide the **Create a new document** dialog box when starting documents, disable the **Show New Document dialog box** check box.
CorelDRAW basics

CorelDRAW lets you create and edit drawings. In this section, you can find information about commonly performed tasks.

This section contains the following topics:
- “Vector graphics and bitmaps” (page 61)
- “Start and open drawings” (page 62)
- “Scan images” (page 67)
- “Work with multiple drawings” (page 67)
- “Undo, redo, and repeat actions” (page 68)
- “Zoom, pan, and scroll” (page 69)
- “Preview drawings” (page 73)
- “Viewing modes” (page 74)
- “Views” (page 75)
- “Save drawings” (page 76)
- “Locked files” (page 78)
- “Back up and recover files” (page 78)
- “Add and access drawing information” (page 79)
- “Close drawings” (page 80)
- “Explore basic tasks” (page 80)
- “Disable warning messages” (page 81)
- “View system information” (page 81)
- “Edit while printing, saving, and exporting documents” (page 81)

Vector graphics and bitmaps

The two main types of computer graphics are vector graphics and bitmaps. Vector graphics are made of lines and curves, and they are generated from mathematical descriptions that determine the position, length, and direction in which lines are drawn. Bitmaps, also known as raster images, are composed of small squares called pixels; each pixel is mapped to a location in an image and has numerical color values.

Vector graphics are ideal for logos and illustrations because they are resolution-independent and can be scaled to any size, or printed and displayed at any resolution, without losing detail and quality. In addition, you can produce sharp and crisp outlines with vector graphics.
Bitmaps are excellent for photographs and digital paintings because they reproduce color gradations well. Bitmaps are resolution-dependent — that is, they represent a fixed number of pixels. They look good at their actual size, but they can appear jagged or lose image quality when scaled, or when displayed or printed at a resolution higher than their original resolution.

You can create vector graphics in CorelDRAW. You can also import bitmaps (such as JPEG and TIFF files) into CorelDRAW and add them to your drawings. For information about working with bitmaps, see “Work with bitmaps” on page 767.

![Top: A vector graphic consists of lines and fills. Bottom: A bitmap is made up of pixels.](image)

**Start and open drawings**

CorelDRAW lets you start a new drawing from a blank page, a template, or an existing drawing. A blank page gives you the freedom to specify every aspect of a drawing. A template provides you with a starting point and leaves the amount of customization up to you. The Create a New Document dialog box (File ➤ New or File ➤ New from Template) provides a central location for starting new drawings. On the Document Settings tab, you can start a blank drawing by specifying document settings or choosing a preset. On the Templates tab, you can start a drawing from a template.

For information about starting a drawing from a template, see “To start a document from a template” on page 692. For more information about creating and using templates, see “Templates” on page 691.

**Notes for starting new drawings**

When starting a new drawing from a blank page, CorelDRAW lets you specify page, document, and color management settings or choose a preset. Presets include predefined settings for page size and orientation, primary color mode, units of measurement, and resolution. For example, the LinkedIn Cover preset from the Social category uses pixels instead of inches, landscape orientation, RGB color and has the dimensions required for a LinkedIn cover image. CorelDRAW offers a wide selection of print, web, device-specific, and social media presets. You can browse and search presets. To find presets more easily, you can filter them by category and page type and sort them by name, date, and page size. If none of the presets are suitable for the drawing that you want to create, you can customize the settings and save them for future use.

**Notes for opening existing drawings**

Basing a new drawing on an existing drawing lets you reuse objects and page settings. CorelDRAW lets you open existing drawings saved to the CorelDRAW (CDR) format as well as drawings and projects saved to various file formats such as Corel DESIGNER™ (DSF or DES), Adobe Illustrator (AI), Adobe Portable Document Format (PDF), Encapsulated PostScript (EPS), and Computer Graphics Metafile (CGM). However, you may not be able to open certain files, depending on their file type and contents. In such cases, you can try importing the files as objects.
in an open drawing. For information about the file formats that you can import into CorelDRAW, see “Supported file formats” on page 911.

If the drawing you are opening is from an earlier version of CorelDRAW and contains text in a language different from the language of your operating system, you can choose code page settings to ensure that text is properly converted according to the Unicode Standard. Code page settings help you correctly display text such as keywords, file names, and text entries outside the drawing window — for example, in the Objects and Object Data dockers. To display text correctly in the drawing window, you must use encoding settings. For more information, see “Display text correctly in any language” on page 659.

If the drawing you are opening contains an embedded International Color Consortium (ICC) profile, the embedded color profile remains the document’s color profile. For more information, see “About color management” on page 465.

You can search for drawings by different criteria, such as filename, title, subject, author, keyword, comment, text within the file, and other properties attached to the file. For more information about searching for files, see the Windows Help. For more information about browsing and searching for content, see “Find clipart and other local and network assets” on page 110.

You can also display previous versions of a drawing.

To start a drawing

1. Do one of the following:
   - On the Welcome screen, click Get started ➤ New document.
   - In the application window, click File ➤ New.
   - On the standard toolbar, click the New button.

2. Type a filename in the Name text box.

3. Do one of the following:
   - To start a drawing from a preset, click a preset thumbnail in the viewing pane.
   - To start a drawing by specifying document settings, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the number of pages</td>
<td>Type a value in the Number of pages box.</td>
</tr>
</tbody>
</table>
| Set the default color mode for the document | In the Primary color mode area, enable one of the following options:  
   - CMYK  
   - RGB |
| Set the unit of measurement for the page | Choose a unit of measurement from the Drawing units list box. |
| Set the page size | Choose a page size for the drawing from the Size list box or type values in the Width and Height boxes. |
| Set the page orientation | Click one of the following page orientation buttons:  
   - Portrait  
   - Landscape |
| Set the resolution for effects that will likely be rasterized, such as transparency, drop shadow, and bevel effects | Choose a rendering resolution from the Resolution list box. |
To do the following

Choose a preset page size

4 Click OK.

You can also

Choose a page viewing mode for the drawing

Click one of the following buttons:

- Single Page View - to view one page at a time
- Multipage View - to view all pages

Tip:

- To set the default page viewing mode for new drawings, click Tools ▶ Options ▶ CorelDRAW ▶ Document, click the Page View mode you want, click Save as Default, and click OK.

Set a bleed limit

In the Layout area, enable the Bleed check box, and type a value in the Bleed limit box.

Choose an RGB profile for the drawing

In the Colors area, choose a default RGB profile from the RGB profile list box.

Choose a CMYK profile for the drawing

Choose a default CMYK profile from the CMYK profile list box.

Choose a Grayscale profile for the drawing

Choose a default Grayscale profile from the Grayscale profile list box.

Choose a default method for out-of-gamut colors to be mapped into gamut

Choose an option from the Rendering intent list box.

When you choose a color mode from the Primary color mode list box, it becomes the default color mode for the document. The default color mode affects how colors work together in effects such as blends and transparencies. It does not restrict the type of colors that you can apply to a drawing. For example, if you set the color mode to RGB, you can still apply colors from a CMYK color palette to the document.

The primary color mode also specifies the default color mode for exporting documents. For example, if you choose the RGB color mode and export a document as a JPEG, the color mode is automatically set to RGB.

The settings that are displayed in the Colors area of the Create a new document dialog box are based on the settings that are specified in the Default color management settings dialog box.

If you do not want to show the Create a new document dialog box and prefer to use the last used settings to create new documents, enable the Do not show this dialog again check box.

You can restore the Create a new document dialog box when starting drawings by clicking Tools ▶ Options ▶ CorelDRAW, clicking General, and enabling the Show New Document dialog box check box.
To find, filter, and sort presets

* On the **Document Settings** tab of the **Create a New Document** dialog box (File ▶ New), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find presets</td>
<td>Type a word in the <strong>Search</strong> box, and press <strong>Enter</strong>.</td>
</tr>
<tr>
<td>Tip:</td>
<td>To clear the search, delete the search term. Optionally, press <strong>Enter</strong> to see the default list of presets.</td>
</tr>
<tr>
<td>Filter presets</td>
<td>Choose one of the following options from the <strong>Filter document presets based on page type</strong> list box:</td>
</tr>
<tr>
<td>* All page sizes</td>
<td>shows all presets</td>
</tr>
<tr>
<td>* Custom</td>
<td>shows the custom presets that you have created</td>
</tr>
<tr>
<td>* Print</td>
<td>shows presets for graphics that are destined for commercial printing</td>
</tr>
<tr>
<td>* Web</td>
<td>shows presets for graphics that are destined for the Internet</td>
</tr>
<tr>
<td>* Devices</td>
<td>shows device-specific presets</td>
</tr>
<tr>
<td>* Social</td>
<td>shows social media presets</td>
</tr>
<tr>
<td>Sort presets</td>
<td>Choose one of the following options from the <strong>Sort document presets by page type, name, date, or size</strong> list box:</td>
</tr>
<tr>
<td>* Page type</td>
<td>lists all default presets and presets based on page size in the following fixed order: print, web, device-specific, and social media presets</td>
</tr>
<tr>
<td>* Name</td>
<td>sorts presets by file name, in alphanumeric order</td>
</tr>
<tr>
<td>* Most recently used</td>
<td>sort presets by the date you used them, starting with the last used preset</td>
</tr>
<tr>
<td>* Largest page size</td>
<td>sort presets by page size, starting with the one with the largest page size</td>
</tr>
<tr>
<td>* Smallest page size</td>
<td>sort presets by page size, starting with the one with the smallest page size</td>
</tr>
</tbody>
</table>

**Note:** The **Custom** presets are always listed as the first item by design.

To create a custom preset

1. On the **Document Settings** tab of the **Create a New Document** dialog box (File ▶ New), choose the settings that you want to save as a preset.
2. Click the **Save Preset** button .
3. In the **Add preset** dialog box, type a name for the new preset.

You can delete a preset by choosing the preset name from the **Preset** list box, and clicking the **Delete Preset** button .
To open a drawing

1 Click File ➤ Open.
2 Locate the folder where the drawing is stored.
3 Click a filename.
4 Click Open.

You can also

- Extract an embedded International Color Consortium (ICC) profile to the color folder in which the application is installed: Enable the Extract embedded ICC profile check box. This option is not available for all file formats.
- Maintain layers and pages when you open files: Enable the Maintain layers and pages check box. If you disable the check box, all layers are combined in a single layer. This option is not available for all file formats.
- View thumbnail of a drawing: Click the arrow button next to the Views button, and click Extra large icons, Large icons, Medium icons, or Small icons.
- Choose a code page: Choose a code page from the Select code page list box. This option is not available for all file formats.
- Search for a drawing: Type a word or phrase in the search box. The search box looks for files only in the current folder and subfolders. To search for a drawing in another location, you must first navigate to the folder where the drawing is stored.
- Access a previous version of a file: Right-click a file, and click Restore previous versions. You can access a previous version of a file only if System Protection is turned on. For detailed information about accessing previous versions of files, see the Windows Help.

You can view file information, such as version number and compression ratio. For example, a compression ratio of 80 percent means that the file size was reduced by 80 percent after the file was saved. You can also see in what application and language the drawing was last saved, and you can view keywords and notes associated with a drawing.
To open a file you have recently worked on, click **File** ➤ **Open Recent**, and click the filename. To clear the list of recently opened files, click **File** ➤ **Open Recent** ➤ **Clear Menu**.

If you have multiple files open, you can navigate between them by clicking **Window**, and then clicking the name of the file that you want to display in the drawing window.

**Scan images**

You can scan images in CorelDRAW by using a compatible TWAIN driver. CorelDRAW supports scanners that use Microsoft Windows Image Acquisition (WIA), which provides a standard interface for scanning images.

If your scanner does not support WIA, but has a compatible TWAIN driver, you may be able to use this driver for scanning images in CorelDRAW. TWAIN is supported by both the 32-bit and 64-bit versions of CorelDRAW. However, note that there are few 64-bit TWAIN drivers available.

The software interfaces and options vary. For information about using the software associated with your scanner, see the manufacturer's documentation.

**To scan images**

1. Click **File** ➤ **Acquire Image**, and click one of the following commands:
   - **Select WIA source** — for a scanner that uses a WIA driver
   - **Select TWAIN source** — for a scanner that uses a TWAIN driver
     A command appears disabled if a compatible WIA or TWAIN scanner driver is not installed.
2. Choose a scanner from the dialog box that appears.
3. Click **Select**.
4. Click **File** ➤ **Acquire Image** ➤ **Acquire**.
5. Preview the image, and select the area that you want to scan.
   WIA, in combination with some scanners, supports scanning of multiple areas to separate files.
6. Click **Scan**.
   On your scanner’s interface, this button may have a different name, such as **OK** or **Send**.

   To scan additional images during the same session, click **File** ➤ **Acquire Image** ➤ **Acquire**.

**Work with multiple drawings**

Multiple drawings can be opened in a single drawing window, making it easy to handle many drawings simultaneously. You can access each open drawing from its tab at the top of the drawing window, and you can start new drawings.

Open drawings appear docked, but you can undock any drawing you want and drag it inside or outside the application window.

You can also arrange drawings in overlapping (cascading) windows, side by side, or stacked vertically.
### To work with multiple drawings

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to another open drawing</td>
<td>At the top of the drawing window, click the tab that has the filename you want. An asterisk after the filename shows that the file has unsaved changes.</td>
</tr>
<tr>
<td>Start another drawing</td>
<td>Click the <strong>New</strong> button to the right of the last tab in the drawing window.</td>
</tr>
<tr>
<td>Undock a drawing</td>
<td>Drag the tab to a new position inside or outside the application window.</td>
</tr>
</tbody>
</table>

### To arrange multiple drawing windows

- Click **Window**, and click one of the following commands:
  - **Cascade** — arranges drawings so that they overlap and the title bars are visible
  - **Tile Horizontally** — arranges drawings side by side
  - **Tile Vertically** — stacks drawings vertically

### Undo, redo, and repeat actions

You can undo the actions that you perform in a drawing, starting with the most recent action. If you don't like the result of undoing an action, you can redo it. Reverting to the last saved version of a drawing also lets you remove one or more actions. Certain actions applied to objects, such as stretching, filling, moving, and rotating, can be repeated to create a stronger visual effect.

Customizing the **Undo** settings lets you increase or decrease the number of actions that you can undo or redo.

### To undo, redo, and repeat actions

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo an action</td>
<td>Click <strong>Edit</strong> ➔ <strong>Undo [Last Action]</strong>.</td>
</tr>
<tr>
<td>Redo an action</td>
<td>Click <strong>Edit</strong> ➔ <strong>Redo</strong>.</td>
</tr>
<tr>
<td>Undo or redo a series of actions</td>
<td>Click <strong>Window</strong> ➔ <strong>Dockers</strong> ➔ <strong>History</strong>. In the <strong>History</strong> docker, click the action that precedes all the actions that you want to undo, or click the last undone action that you want to redo.</td>
</tr>
<tr>
<td>Revert to the last saved version of a drawing</td>
<td>Click <strong>File</strong> ➔ <strong>Revert</strong>.</td>
</tr>
<tr>
<td>Repeat an action</td>
<td>Click <strong>Edit</strong> ➔ <strong>Repeat</strong>.</td>
</tr>
</tbody>
</table>
When you undo a series of actions in the History docker, all actions listed below the action that you click are undone.

When you redo a series of actions in the History docker, the action that you click and all preceding undone actions are redone.

You can repeat an action on another object or group of objects by selecting the object or objects and clicking Edit ➤ Repeat. You can also undo or redo a series of actions by clicking the arrow button next to the Undo button ⬅️ or Redo button ➡️, on the standard toolbar and choosing an action from the list.

To specify the Undo settings

1. Click Tools ➤ Options ➤ CorelDRAW.
2. Click General in the left pane of the dialog box that appears.
3. In the Undo levels area, type a value in the Regular box to specify the number of actions that can be reversed when you use the Undo command with vector objects.

The value that you specify is limited only by your computer’s memory resources. The higher the value you specify, the greater the demand on memory resources.

Zoom, pan, and scroll

You can change the view of a drawing by zooming in to get a closer look or by zooming out to see more of the drawing. You can experiment with a variety of zoom options to determine the amount of detail you want.

You can also zoom in and out in preset increments by using common keyboard shortcuts, supported by web browsers and other applications.

Panning and scrolling are two additional ways to view specific areas of a drawing. When you work at high magnification levels or with large drawings, you may not be able to see the whole drawing. Panning and scrolling let you move the page around in the drawing window to view previously hidden areas.

You can use the Pan tool to pan around a large image and view particular areas.

You can also use the Quick Pan mode to switch from any active tool to the Pan tool. This feature lets you pan without having to change tools.
You can zoom in and out while you are panning, and you can pan while you are zooming. In this way, you can avoid having to alternate between the two tools. You can also specify default zooming and panning settings.

If you use a mouse wheel, the wheel zooms in and zooms out by default. You can set custom zoom increments for zooming with the mouse wheel. You can also use the mouse wheel to scroll.

By default, when zooming with a mouse and panning with the Pan tool, you are viewing the document at high resolution. However, you can show a low-resolution document preview for any device or method you are using to zoom and pan. You can also hide the low-resolution document preview for any device and method.

You can scroll a drawing by using the scroll bars that border the drawing window. You can show or hide the scroll bars.

To zoom
1. In the toolbox, click the Zoom tool.
2. On the property bar, click one of the following:
   - Zoom in — lets you increase the magnification level
   - Zoom out — lets you decrease the magnification level
   - Zoom to selected — adjusts the magnification level to fit the selected objects on the active page or the selected pages in multipage view
   - Zoom to all objects — adjusts the magnification level to fit all objects on the active page
   - Zoom to all pages — adjusts the magnification level to fit all pages in multipage view
   - Zoom to page — adjusts the magnification level to fit the active page
   - Zoom to page width — adjusts the magnification level to fit the width of the active page
   - Zoom to page height — adjusts the magnification level to fit the height of the active page

The Zoom to all pages button is available only in multipage view. For more information about multipage view, see “Page views” on page 723.

The Zoom to selected button is available only if objects or pages are selected before you click the Zoom tool.

You can also zoom in, zoom out, and zoom to all objects by using the Zoom In, Zoom Out, and Zoom to Fit commands in the View menu.

When you are not editing text, you can also access the Zoom tool by pressing Z.

Using the Zoom tool, you can also zoom in by clicking anywhere in the drawing window or dragging to select a specific area to magnify. To zoom out, right-click in the drawing window, or drag with the right mouse button to select a specific area.

You can also zoom in by using the Pan tool and double-clicking in the drawing window. To zoom out, right-click in the drawing window.

To zoom using keyboard shortcuts
- Do one of the following:
  - To zoom in, press Ctrl+(+).
  - To zoom out, press Ctrl+-.
  - To zoom to all objects, press F4.
  - To zoom to selected object, press Shift+F2.
  - To zoom to page, press Shift+F4.
You can use these keyboard shortcuts to adjust the zoom level in the document window as well as in dialog boxes and labs that feature preview windows such as the Print Preview dialog box, PowerTRACE™, Image Adjustment Lab, and more.

To pan in the drawing window
1. In the toolbox, click the Pan tool.
2. Drag in the drawing window until the area you want to view appears.

When you are not editing text, you can also access the Pan tool by pressing the H key.

To pan in the drawing window while zoomed in on the drawing, click the Navigator button in the lower-right corner of the drawing window. To access the Navigator button, the scroll bars must be displayed. For more information, see “To hide or display the scroll bars” on page 72.

You can quickly center the page in the drawing window by double-clicking the Pan tool in the toolbox.

To switch to the Quick Pan mode
1. Click any selection, drawing, or shaping tool, and start using it.
2. Hold down the middle mouse button or wheel, and drag in the drawing window.

To specify default zoom settings
1. Click Tools ➤ Options ➤ Tools.
2. In the left pane of the dialog box that appears, click Zoom/Pan.
3. To specify the action of the Zoom or Pan tool when you right-click in the drawing window, enable one of the following options:
   - Zoom out — zooms out by a factor of 2
   - Context menu — displays a menu of commands that let you zoom to a specific level
4. To specify how the page appears when the zoom is set to 100%, enable or disable the Zoom relative to 1:1 check box.
   - When the option is enabled, a 100% zoom displays real-world dimensions.
   - When the option is disabled, a 100% zoom displays the full page, regardless of real-world dimensions.
5. To specify how the page appears when you zoom in and out using the mouse wheel, enable or disable the Center mouse when zooming with the mouse wheel check box.
• When the option is enabled, the area where the mouse pointer is located moves to the center of the screen as you zoom in and out using the mouse wheel.
• When the option is disabled, the area where the mouse pointer is located stays in the same position as you zoom in and out using the mouse wheel.

To choose default settings for the mouse wheel

1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the dialog box that appears, click Display.
3 To specify the default action of the mouse wheel, choose Zoom or Scroll from the Default action for mouse wheel list box.

You can also

Set the increments for zooming with the mouse wheel
Move the Zoom rate slider.

Set the increments for zooming with the mouse wheel while holding down Ctrl + Shift (Alternate Zoom)
Move the Alternate Zoom (Ctrl + Shift) rate slider.
By default, Alternate Zoom is faster than regular zooming, but you can customize it to be at a slower speed.

Restore the default increments for zooming with the mouse wheel
Click the Reset button next to the Zoom rate and Alternate Zoom (Ctrl + Shift) rate sliders.

4 In the left pane of the Options dialog box, click Display.

To hide or display a low-resolution preview while zooming and panning

1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the Options dialog box, click Display.
3 In the Navigation area, choose one of the following from the Low-resolution preview for responsive zooming and panning box:
   • Hide for mouse — shows the document at high resolution when you zoom with a mouse and pan with the Pan tool, but enables a low-resolution preview for other methods such as touch
   • Always show — shows a low-resolution preview of the document for all methods and devices used to zoom and pan
   • Never show — always hides the low-resolution preview and shows the document at high resolution

To scroll by using a mouse wheel

• Do one of the following:
  • To scroll vertically, move the wheel.
  • To scroll horizontally, press Shift while you move the wheel.

The mouse wheel can be used for scrolling when the Scroll option for the mouse is enabled. For more information, see “To choose default settings for the mouse wheel” on page 72.

If the Zoom option for the mouse is enabled, you can scroll vertically by holding down Alt while you move the mouse wheel.

To hide or display the scroll bars

• Click View ▶ Scroll Bars.
A check mark beside the **Scroll Bars** command indicates that the scroll bars are displayed.

**Preview drawings**

You can preview a drawing to see how it will look when printed or exported. When you preview a drawing, only the objects on the drawing page and in the immediate area of the drawing window are displayed, and you can see all layers that are set to print in the **Objects** docker. If you want a closer look at specific objects in a drawing, you can select and preview them. When you preview selected objects, the rest of the drawing is hidden.

Before you preview a drawing, you can specify the preview mode. The preview mode affects the speed with which your preview appears as well as the amount of detail displayed in the drawing window.

By default, the borders of a page are displayed in the drawing window, but you can hide them at any time. If a drawing is intended for print, you can display the area that will actually print as well as the bleed, the part of the drawing that extends beyond the page border. Bleeds are useful when a drawing contains a color page background or objects that are positioned on the page border. Bleeds ensure that no white space appears between the edges of a drawing and the edge of the paper after the printer cuts, binds, and trims the document.

**To preview a drawing**

- Click **View** > **Full-screen Preview**.

  Click anywhere on the screen, or press any key, to return to the application window.

  You can press **Page up** and **Page down** to preview pages in a multipage drawing.

**To preview selected objects**

1. Select the objects.
2. Click **View** > **Preview Selected Only**.

  Click anywhere on the screen, or press any key, to return to the application window.

  If **Preview selected only** mode is enabled and no objects are selected, **Full-screen preview** displays a blank screen.

**To choose a full-screen preview mode**

1. Click **Tools** > **Options** > **CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Display**.
3. In the **Full-screen preview** area, enable one of the following options:
   - **Use normal view** — Drawings appear without PostScript fills or high-resolution bitmaps, and no anti-aliasing is used.
   - **Use enhanced view** — Drawings appear with PostScript fills, and anti-aliasing is used to sharpen the display of the drawings.

**To set the page display**

1. Click **Layout** > **Document Options**.
2. In the left pane of the dialog box that appears, click **Page Size**.
3. Enable or disable the following check boxes:
   - **Show page border** — shows or hides page borders
   - **Show bleed area** — shows or hides the area of the drawing extending beyond the page border. To change the bleed area, type a value in the **Bleed** box.
When preparing a drawing for commercial printing, you may also need to set a bleed limit. For more information, see “To set a bleed limit” on page 855.

You can also click View ▶ Page ▶ Page border, or View ▶ Page ▶ Bleed.

You can display the printable area of a drawing by clicking View ▶ Page ▶ Printable area. The printable area is usually indicated by two dotted lines inside or around the page, depending on the current printer settings. One outline indicates the area that can be printed on the current printer; the other outline indicates the paper size that your printer is set to use.

**Viewing modes**

As you work, CorelDRAW lets you display a drawing in any of the following modes:

- **Wireframe** — displays an outline of the drawing by hiding fills, extrusions, contours, and drop shadows; also displays the bitmaps in monochrome. This mode lets you quickly preview basic elements in a drawing.
- **Normal** — displays a drawing without PostScript fills or high-resolution bitmaps. This mode refreshes and opens slightly faster than the Enhanced mode.
- **Enhanced** — displays a drawing with PostScript fills, high-resolution bitmaps, and anti-aliased vector graphics.
- **Pixels** — displays a pixel-based rendition of the drawing, which allows you to zoom in on an area of an object, and then position and size the object more precisely. This view also lets you see what the drawing will look like when it is exported to a bitmap file format.
- **Simulate overprints** — simulates the color of areas where overlapping objects were set to overprint and displays PostScript fills, high-resolution bitmaps, and anti-aliased vector graphics. For information about overprinting objects, see “To overprint selected color separations” on page 859.
- **Rasterize complex effects** — rasterizes the display of complex effects, such as transparencies, bevels, and drop shadows when in Enhanced view. This option is useful for previewing how the complex effects will be printed. To ensure the successful printing of complex effects, most printers require complex effects to be rasterized.

The viewing mode you choose affects the amount of time it takes for a drawing to open or be displayed on the monitor. For example, a drawing displayed in Wireframe view takes less time to refresh or open than does a drawing displayed in Simulate Overprints view.

![Wireframe viewing mode (left); Enhanced viewing mode (center), and Simulate overprints viewing mode (right). The fill for the gray diamond shape and the cup’s shadow are set to overprint.](image)

**To choose a viewing mode**

- Click View, and click one of the following modes:
  - Wireframe
If you are overprinting, it is important to preview the objects in the Simulate overprints mode before printing. The type of objects you are overprinting and the type of colors you are mixing determine how overprinted colors are combined. For more information about overprinting, see "Color trapping and overprinting" on page 858.

To set the default viewing mode, click Layout ➤ Document Options, click General, and choose an option from the View mode list box.

You can quickly switch between the selected viewing mode and the previous viewing mode by pressing Shift + F9.

Views

You can save a view of any part of a drawing. For example, you can save a view of an object at 230% magnification and then return to this specific view at any time.

To save a view

1. Click Window ➤ Dockers ➤ Views.
2. Click the Add current view button.

You can also

Rename a view

Double-click a view name, and type a new name.

Delete a saved view

Click a view, and click the Delete current view button.

You can also save the current view by clicking the Zoom or Pan tool in the toolbox, clicking in the Zoom levels list box on the standard toolbar, typing a name, and pressing Enter.

To switch to a saved view

1. Click Window ➤ Dockers ➤ Views.
2. Click a view in the Views docker.

You can also switch to a saved view by selecting it from the Zoom levels list box on the standard toolbar.
Save drawings

By default, drawings are saved to the CorelDRAW file format (CDR) and are compatible with the latest version of the application. You can also save a drawing that is compatible with an earlier version of CorelDRAW Graphics Suite and specify save options. Such options are useful when the file contains new text, fill, outline, and transparency features that are not supported in earlier versions.

You can save a drawing to other vector file formats as well. If you want to use a drawing in another application, you must save it to a file format that is supported by that application. For information about saving files to other formats, see “Export files” on page 889.

The application makes it easy to tell if a drawing has unsaved changes by adding an asterisk after its filename. The asterisk is added in different locations where the filename appears such as the Windows menu, the title bar, and the document tab.

When saving a drawing, you can embed the used fonts to facilitate file sharing. By default, CorelDRAW embeds all used fonts, with the exception of Asian fonts and fonts that do not have embedding permissions. For more information, see “Manage fonts” on page 661.

When you save a drawing, CorelDRAW lets you add reference information so that you can easily find and organize drawings later on. You can attach tags (also known as properties) such as title, subject, and rating.

You can also save selected objects in a drawing. For large drawings, saving only the selected objects reduces the file size, which can decrease the time it takes to load the drawing.

When saving a file, you can use advanced options to control how bitmaps, textures, and vector effects, such as blends and extrusions, are saved with the drawing.

You can also save a drawing as a template, which lets you create other drawings with the same properties. For information about saving a drawing as a template, see “Templates” on page 691.

To save a drawing

1. Click File ➤ Save as.
2. Type a filename in the File name box.
3. Locate the folder where you want to save the file.

   If you want to save the drawing to a vector file format other than CorelDRAW (CDR), choose a file format from the Save as type list box.

You can also

- Save only selected objects
- Enable the Selected only check box.
- This option is available only if there are selected objects in the drawing.

- Embed fonts
- Enable the Embed fonts check box.
- This check box is unavailable when you save a drawing to an earlier version of CorelDRAW.

- Add reference information
- Do any of the following:
You can also

• Type a title and subject in the corresponding box.
• Assign a rating to the file.

If you are using an expired trial version of CorelDRAW, you will not be able to save drawings.
Saving a drawing to a previous version of CorelDRAW may result in loss of certain effects that were not available in the previous version of the application.

You can also save a drawing by clicking File ➤ Save.
You can also save a drawing by clicking the Save button on the Standard toolbar.

To use advanced options when saving
1 Click File ➤ Save as.
2 Click Advanced.
3 Enable any of the following check boxes:
   • Save in Corel Presentation Exchange (CMX) format — saves a drawing as a Corel® Presentations™ Exchange (CMX) file so that you can open and edit it in other Corel applications, such as WordPerfect™
   • Use bitmap compression — reduces the file size by compressing bitmap effects, such as bitmap extrusions, transparencies, and drop shadows
   • Use graphic object compression — reduces the file size by compressing vector objects, such as polygons, rectangles, ellipses, and perfect shapes
Using compression increases the time required for opening and saving a drawing.
4 If a drawing contains texture fills, enable one of the following options:
   • Save texture fills with the file — saves custom texture fills with the file
   • Rebuild texture fills when opening the file — re-creates texture fills when you open the saved drawing
5 If a drawing contains blends and extrusions, enable one of the following options:
   • Save blends and extrusions with the file — saves all blends and extrusions included in a drawing
   • Rebuild blends and extrusions when opening the file — re-creates blends and extrusions when you open the saved drawing

Choosing to save textures, blends, and extrusions with the file increases the file size but lets you open and save a drawing more quickly. Conversely, choosing to rebuild textures, blends, and extrusions when a saved drawing is opened decreases the file size but increases the time required for saving or opening a drawing.

To save a drawing that is compatible with an older version of CorelDRAW
1 Click File ➤ Save as.
2 Type a filename in the File name box.
3 Locate the folder where you want to save the file.
4 Choose a version from the Version list box.
5 Click Save.
   If the drawing includes new features; enable one of the following options in the Save to a previous version dialog box:
   • Keep appearance — preserves the appearance of text, fills, outlines and transparencies when the file is opened in a previous version of CorelDRAW. However, this option may limit editing.
• Keep editable — preserves the file editable. However, this option may change the appearance of text, outlines, fills, and transparencies when the file is opened in a previous version of CorelDRAW.

You can also

Specify save settings
Click Tools ▶ Options ▶ CorelDRAW. Click Save, and enable one of the following options:
• Keep appearance (suitable for limited edits)
• Keep editable (may change appearance)

Disable the prompt that appears when saving to an earlier version
Click Tools ▶ Options ▶ CorelDRAW. Click Save, and disable the Ask when saving check box.

Locked files
In a corporate environment you may open a locked file that is already being edited by another user. You can save changes that you make to a locked file in one of the following ways:
• If the other user has modified the file or still has the file open, you must save the file with a new name by clicking File ▶ Save As.
• If the other user has closed the file without modifying it, you can save the changes by clicking File ▶ Save.

Back up and recover files
CorelDRAW can save backup copies of drawings and prompt you to recover them in the event of a system error. The back-up feature creates a copy of the drawing when you save a drawing. This backup copy does not contain the changes that you made since you last opened the file. The backup copy is named backup_of_filename, and by default is stored in the same folder as the original drawing. You can change the location where backup files are created.

The auto-backup feature saves drawings that you have opened and modified. Auto-backup files are named auto_backup_of_filename. During any working session with CorelDRAW, you can set the time interval for automatically backing up files and specify whether you want the files to be saved in your temporary folder (the default location) or in a folder of your choice. You can recover the backup files from the temporary or specified folder when you restart CorelDRAW after a system error. If you choose not to recover the backup file, it is automatically erased when you quit the application.

To specify backup and auto-backup settings
1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the dialog box that appears, click Save.
3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a backup file before saving</td>
<td>Enable the Back up original file before saving check box.</td>
</tr>
<tr>
<td>Change the location where backup files are created</td>
<td>In the Back up to area, enable the Choose location option. Click Browse, and navigate to the folder you want.</td>
</tr>
<tr>
<td>Specify auto-backup settings</td>
<td>To set how often to back up the file automatically, enable the Back up every check box, and choose a value from the Minutes list box.</td>
</tr>
</tbody>
</table>
To choose the location for auto-backup files, in the Back up to area, enable one of the following options:

- **Temporary folder** — lets you save auto-backup files in the temporary folder
- **Choose location** — lets you specify the folder for auto-backup files

Disable the auto-backup feature

Choose *Never* from the *Minutes* list box.

All open or modified files that are not in the CorelDRAW (CDR) file format are backed up as CorelDRAW files.

You can cancel the creation of an auto-backup file by pressing *Esc* while a file is being saved.

To recover a backup file

1. Restart CorelDRAW.
2. Click *OK* in the file recovery dialog box that appears.
   The file recovery dialog box appears upon startup after a system error.
3. Save and rename the file in the specified folder.

If you click *Cancel*, CorelDRAW ignores the backup file and deletes it when you quit the application.

**Add and access drawing information**

CorelDRAW lets you add reference information, such as language, title, author, subject, keywords, rating, and other notes to a drawing. Although adding document information is optional, doing so makes it easier to organize and locate drawings later on.

The application also lets you access other important document information, such as the number of pages and layers, fonts, object and text statistics, and the types of objects the drawing contains. You can also view color information such as the color profiles that are used to define document colors as well as the primary color mode and rendering intent.

To add and access drawing information

1. Click *File* ➤ *Document Properties*.
2. In the *Document Properties* dialog box, type text in any of the following boxes:
   - Language
   - Title
   - Subject
   - Author
   - Copyright
   - Keywords
   - Notes
3. To specify a rating, choose a rating from the *Rating* list box.
4. Click *OK*. 
You can modify the drawing information at any time.

Close drawings

You can close one drawing, or multiple drawings, at any time before quitting CorelDRAW.

To close drawings

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close one drawing</td>
<td>Click File ➤ Close.</td>
</tr>
<tr>
<td>Close all drawings</td>
<td>Click File ➤ Close All.</td>
</tr>
</tbody>
</table>

If you are unable to close a document, you may have a task, such as printing or saving, in progress or a task that has failed. Please refer to the status bar to view the status of a task.

Explore basic tasks

CorelDRAW has a virtually unlimited number of tools and capabilities to help you create drawings. The following table provides you with the basic features of CorelDRAW to help you get started.

For information about                      See

- Drawing lines                          “Format lines and outlines” on page 174
- Drawing shapes                         “Shapes” on page 201
- Creating and manipulating objects      “Transform objects” on page 308
- Adding color to objects                “Fills” on page 425
- Adding text to a drawing               “Add and manipulate text” on page 597
- Creating drawings for use on the web   “Export bitmaps for the web” on page 870
- Printing drawings                      “Print basics” on page 825
Disable warning messages

You may encounter warning messages while working in the application. Warning messages explain the consequences of an action you are about to perform, and inform you of permanent changes that might result from that action. Although the warnings are helpful, you can disable them so you don’t have to view them after you become familiar with the software. Avoid disabling warning messages until you are comfortable with the application and familiar with the results of the commands you use.

To disable warning messages
1. Click Tools ➤ Options ➤ CorelDRAW.
2. Click Warnings.
3. Disable one or more of the check boxes.

View system information

You can view information about your computer as well as information about the application itself. For example, you can view details about your computer’s setup. You can view detailed information about your system, display and printing properties, Corel applications and DLL files, and system DLL files. You can use this feature, for instance, to find out how much space you have on the drive to which you want to save a file.

To view system information
1. Click Help ➤ About CorelDRAW.
2. Click System info.
3. Choose a category from the Choose a category list box.

💡 Click the Save button to store system information for printing.

Edit while printing, saving, and exporting documents

If you want to continue with your editing tasks while printing, saving, or exporting a document, you can enable background tasks. This setting lets you use one core of the computer CPU (Central Processing Unit) for editing, and another core for printing, saving, and exporting.

To enable background tasks
1. Click Tools ➤ Options ➤ Global.
2. Click General.
3. Enable the Enable background tasks check box.
CorelDRAW workspace tour

Becoming familiar with the terminology and workspace of CorelDRAW will help you follow the concepts and procedures in the user guide and in the Help.

In this section, you’ll learn about

- “CorelDRAW terms” (page 83)
- “Application window” (page 84)
- “Standard toolbar” (page 86)
- “Toolbox” (page 89)
- “Property bar” (page 102)
- “Dockers” (page 103)
- “Status bar” (page 105)
- “Document navigator” (page 105)
- “Choose a workspace” (page 105)

CorelDRAW terms

Before you get started with CorelDRAW, you should be familiar with the following terms.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td>An element in a drawing such as an image, shape, line, text, curve, symbol, or layer</td>
</tr>
<tr>
<td>Drawing</td>
<td>The work you create in CorelDRAW; for example, custom artwork, logos, posters, and newsletters</td>
</tr>
<tr>
<td>Vector graphic</td>
<td>An image generated from mathematical descriptions that determine the position, length, and direction in which lines are drawn</td>
</tr>
<tr>
<td>Bitmap</td>
<td>An image composed of grids of pixels or dots</td>
</tr>
</tbody>
</table>

...
<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Docker</td>
<td>A window that contains commands and settings relevant to a specific tool or task</td>
</tr>
<tr>
<td>Flyout</td>
<td>A group of related tools or menu items</td>
</tr>
<tr>
<td>List box</td>
<td>A list of options that drops down when a user clicks the down arrow button</td>
</tr>
<tr>
<td>Artistic text</td>
<td>A type of text to which you can apply special effects, such as shadows</td>
</tr>
<tr>
<td>Paragraph text</td>
<td>A type of text to which you can apply formatting options, and which can be edited in large blocks</td>
</tr>
</tbody>
</table>

**Application window**

The CorelDRAW application window appears below.
Circled numbers correspond to the numbers in the following table, which describes the main components of the application window. Artwork by Firman Hatibu.

<table>
<thead>
<tr>
<th>Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Toolbox</td>
<td>Provides tools for creating and modifying objects in the drawing</td>
</tr>
<tr>
<td>2. Document tab</td>
<td>Lets you quickly move between open documents</td>
</tr>
<tr>
<td>3. Title bar</td>
<td>Displays the title of the currently selected drawing</td>
</tr>
<tr>
<td>4. Menu bar</td>
<td>Contains pull-down menu options</td>
</tr>
<tr>
<td>5. Toolbar</td>
<td>Contains shortcuts to menu and other commands</td>
</tr>
<tr>
<td>6. Drawing window</td>
<td>The area outside the drawing page bordered by the scroll bars and application controls</td>
</tr>
<tr>
<td>Part</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>7. Property bar</td>
<td>A detachable bar with commands that relate to the active tool or object. For example, when the Text tool is active, the text property bar displays commands for creating and editing text.</td>
</tr>
<tr>
<td>8. Docker</td>
<td>Displays task- and tool-related controls, such as command buttons, options, and list boxes for modifying drawings</td>
</tr>
<tr>
<td>9. Rulers</td>
<td>Horizontal or vertical bars marked off in units and used to determine the size and position of objects</td>
</tr>
<tr>
<td>10. Document palette</td>
<td>A detachable bar that contains color swatches for the current document</td>
</tr>
<tr>
<td>11. Document navigator</td>
<td>Provides controls for managing pages</td>
</tr>
<tr>
<td>12. Drawing page</td>
<td>The printable area inside the drawing window</td>
</tr>
<tr>
<td>13. Status bar</td>
<td>Displays object position and properties, such as type, size, color, fill, and resolution</td>
</tr>
<tr>
<td>14. Navigator</td>
<td>A button that opens a smaller display to help you move around a drawing</td>
</tr>
<tr>
<td>15. Color palette</td>
<td>A detachable bar that contains color swatches</td>
</tr>
</tbody>
</table>

To toggle between displaying and hiding the rulers, see “To hide or display the rulers” on page 740.

You can customize the appearance of the application workspace by setting a scaling level, choosing a theme, and changing the color of the desktop and the window borders. For more information, see “Customize workspace appearance” on page 961.

**Standard toolbar**

The standard toolbar, which appears by default, contains buttons and controls that are shortcuts to many of the menu commands. For information about customizing the contents and appearance of the toolbar, see “Customize toolbars and other command bars” on page 966.

Click this button

To

- ![Folder icon](image) Start a new drawing
- ![Folder icon](image) Open a drawing
Click this button

To

Save a drawing

Choose and open a document from the Cloud.

Save and upload a document to the Cloud.

Print a drawing

Cut selected objects to the Clipboard

Copy selected objects to the Clipboard

Paste the Clipboard contents into a drawing

Undo an action

Restore an action that was undone

Import a drawing

Export a drawing

Publish to PDF

Set a zoom level
Click this button

![Display Full-screen preview]

To

Display Full-screen preview

![Show or hide rulers]

Show or hide rulers

![Show or hide grid]

Show or hide grid

![Show or hide guidelines]

Show or hide guidelines

![Disable all snapping. Click again to restore the selected snapping options.]

Disable all snapping. Click again to restore the selected snapping options.

![Enable or disable automatic alignment for the pixels, document grid, baseline grid, guidelines, objects, and page]

Enable or disable automatic alignment for the pixels, document grid, baseline grid, guidelines, objects, and page

![Open the CorelDRAW Options dialog box]

Open the CorelDRAW Options dialog box

![Start Corel applications and plug-ins, or access the Get More dialog box to download other creative tools]

Start Corel applications and plug-ins, or access the Get More dialog box to download other creative tools

More about toolbars

In addition to the standard toolbar, CorelDRAW has toolbars for specific tasks. For example, the Text toolbar contains commands relevant to using the Text tool. If you use a toolbar frequently, you can display it in the workspace at all times.

For information about customizing the position, contents, and appearance of toolbars, see "Customize toolbars and other command bars" on page 966.

The following table describes toolbars other than the standard toolbar.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td>Contains commands for zooming in and out of a drawing page by specifying percentage of original view, clicking the Zoom tool, and selecting a page view</td>
</tr>
<tr>
<td>Text</td>
<td>Contains commands for formatting and aligning text</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Layout</td>
<td>Contains commands for converting objects to PowerClip frames and text frames, displaying alignment guides as well as setting columns and margins</td>
</tr>
<tr>
<td>Transform</td>
<td>Contains commands for skewing, rotating, and mirroring objects</td>
</tr>
<tr>
<td>Macros</td>
<td>Contains commands for editing, testing, and running macros</td>
</tr>
<tr>
<td>Internet</td>
<td>Contains commands for web-related tools for creating rollovers and publishing to the Internet</td>
</tr>
<tr>
<td>Project Timer</td>
<td>Contains controls that let you track the time spent on project tasks</td>
</tr>
</tbody>
</table>

To toggle between displaying and hiding a toolbar, click **Window ➔ Toolbars**, and click the command with the toolbar name.

To lock all toolbars so that you don’t inadvertently change their position, click **Window ➔ Toolbars ➔ Lock toolbars**.

**Toolbox**

The toolbox contains tools for drawing and editing images. Some of the tools are visible by default, while others are grouped in flyouts. Flyouts open to display a set of related CorelDRAW tools. A small flyout arrow in the lower-right corner of a toolbox button indicates a flyout. You can access the tools in a flyout by clicking the flyout arrow. After you open a flyout, you can easily scan the contents of other flyouts by hovering over any of the toolbox buttons which have flyout arrows.

![Flyout arrow](image)

In the default workspace, clicking the flyout arrow on the Shape tool opens the Edit Shape Tools flyout.

Some tools in the toolbox are not visible by default. You can choose which tools to display in the toolbox.

**Locate tools**

The following illustration shows all flyouts in the default CorelDRAW toolbox and can help you locate tools more easily.
To toggle between displaying and hiding the toolbox, click Window  Toolbars  Toolbox.

To hide or display tools in the toolbox, click the Quick customize button and enable or disable the corresponding check boxes.

For more information, see “Customize the toolbox” on page 969.

The following table provides descriptions of the tools in the CorelDRAW toolbox.

### Pick tools

The Pick tool lets you select, size, skew, and rotate objects.
The **Freehand pick** tool lets you select objects by using a freehand selection marquee.

The **Free transform** tool lets you transform an object by using the **Free rotation**, **Free angle reflection**, **Free scale**, and **Free skew** tools.

**Edit shape tools**

The **Shape** tool lets you edit the shape of objects.

The **Smooth** tool lets you smooth curved objects to remove jagged edges and reduce the number of nodes.

The **Smear** tool lets you shape an object by pulling extensions or making indents along its outline.
The **Twirl** tool lets you create swirl effects by dragging along the edge of objects.

The **Attract and Repel** tool lets you shape objects by attracting nodes to the cursor or pushing nodes away from the cursor.

The **Smudge** tool lets you distort a vector object by dragging along its outline.

The **Roughen** tool lets you distort the outline of a vector object by dragging along the outline.

**Crop tools**

The **Crop** tool lets you remove unwanted areas in objects.
The **Knife** tool lets you slice objects, groups of objects, and bitmaps along any path you specify.

The **Virtual segment delete** tool lets you delete portions of objects that are between intersections.

The **Eraser** tool lets you remove areas of your drawing.

**Zoom tools**

The **Zoom** tool lets you change the magnification level in the drawing window.

The **Pan** tool lets you control which part of the drawing is visible in the drawing window.
Curve tools

The **Freehand** tool lets you draw single line segments and curves.

The **2-point line** tool lets you draw a straight two-point line segment.

The **Bézier** tool lets you draw curves one segment at a time.

The **Pen** tool lets you draw curves one segment at a time.

The **B-spline** tool lets you draw curved lines by setting control points that shape the curve without breaking it into segments.

The **Polyline** tool lets you draw lines and curves in preview mode.
The **3-point curve** tool lets you draw a curve by defining the start, end, and center points.

**Drawing tools**

The **Artistic media** tool provides access to the **Preset**, **Brush**, **Sprayer**, **Calligraphic**, and **Expression** tools.

The **Smart drawing** tool converts your freehand strokes to basic shapes and smoothed curves.

The **LiveSketch™** tool lets you sketch naturally with intelligent stroke adjustment.

**Rectangle tools**

The **Rectangle** tool lets you draw rectangles and squares.
The 3-point rectangle tool lets you draw rectangles at an angle.

Ellipse tools

The Ellipse tool lets you draw ellipses and circles.

The 3-point ellipse tool lets you draw ellipses at an angle.

Shape tools

The Polygon tool lets you draw symmetrical polygons and stars.

The Star tool lets you draw perfect stars.
The **Spiral** tool lets you draw symmetrical and logarithmic spirals.

The **Common shapes** tool lets you choose from a full set of shapes, including hexagram, a smiley face, and a right-angle triangle.

The **Impact** tool lets you create graphic effects in a style inspired by comic books and contemporary illustrations.

The **Graph paper** tool lets you draw a grid of lines similar to that on graph paper.

**Text tools**

The **Text** tool lets you type words directly on the screen as artistic or paragraph text.
The **Table** tool lets you draw and edit tables.

**Dimension tools**

The **Parallel dimension** tool lets you draw slanted dimension lines.

The **Horizontal or vertical dimension** tool lets you draw horizontal or vertical dimension lines.

The **Angular dimension** tool lets you draw angular dimension lines.

The **Segment dimension** tool lets you display the distance between end nodes in single or multiple segments.
The 2-leg callout tool lets you draw a callout with a two-segment leader line.

Connector tools

The Connector tool lets you draw straight, right-angle, and rounded right-angle connector lines.

The Anchor editing tool lets you modify connector line anchor points.

Effect tools

The Drop shadow tool lets you apply a drop shadow behind or below an object.

The Inner shadow tool lets you apply a shadow inside an object.
The **Contour** tool lets you apply a contour to an object.

The **Blend** tool lets you blend two objects.

The **Distort** tool lets you apply a Push or Pull distortion, a Zipper distortion, or a Twister distortion to an object.

The **Envelope** tool lets you shape an object by dragging the nodes of the envelope.

The **Extrude** tool lets you apply the illusion of depth to objects.

The **Block shadow** tool lets you add solid vector shadows to objects and text.
Transparency tool

The *Transparency* tool lets you apply transparencies to objects.

Eyedropper tools

The *Color eyedropper* tool lets you select and copy a color from an object on the drawing window or the desktop.

The *Attributes eyedropper* tool lets you select and copy object properties, such as line thickness, size and effects, from an object on the drawing window.

Fill tools

The *Interactive fill* tool lets you apply various fills.

The *Smart fill* tool lets you create objects from enclosed areas and then apply a fill to those objects.
The **Mesh fill** tool lets you apply a mesh grid to an object.

The **Variable Outline** tool lets you apply an outline of variable widths to an object.

The **Outline** tool opens a flyout that gives you quick access to items such as the **Outline pen** dialog box and **Outline color** dialog box. This tool is not displayed by default in the toolbox. For information about how to display it, see “To customize the toolbox” on page 969.

**Property bar**

The property bar displays the most commonly used functions that are relevant to the active tool or to the task you’re performing. Although it looks like a toolbar, the property bar content changes depending on the tool or task.

For example, when you click the **Text** tool in the toolbox, the property bar displays text-related commands. In the example below, the property bar displays text formatting, alignment, and editing tools.

You can customize the contents and position of the property bar to suit your needs. For more information, see “Customize the property bar” on page 969.
To toggle between displaying and hiding the property bar, click Window ▶ Toolbars ▶ Property bar.

To hide or display controls on the property bar, click the Quick customize button and enable or disable the corresponding check boxes.

Dockers

Dockers display the same types of controls as a dialog box, such as command buttons, options, and list boxes. Unlike most dialog boxes, you can keep dockers open while working on a document, so you can readily access the commands to experiment with different effects. Dockers have features similar to palettes in other graphics programs.

Dockers can be either docked or floating. A docked docker is attached to the edge of the application window, a toolbar, or a palette. A floating docker is not attached to a workspace element. If you open several dockers, they usually appear nested, with only one docker fully displayed. You can display a docker hidden from view by clicking the docker’s tab.

You can move dockers, and you can collapse dockers to save screen space.

An example of a docker. When you open the Properties docker and click an object in the drawing window, you can access various options for modifying object properties.
In this example, the Properties and the Objects dockers are docked and nested. The Transform docker is floating.

To open a docker
• Click Window ➤ Dockers, and click a docker.

💡 To open or close dockers, you can also click the Quick customize button on the right side of a docker, and enable or disable the corresponding check boxes.

You can also close a docker by clicking the X button on its title bar. Clicking the X button on the title bar closes all nested dockers in a group. To close only a specific docker, click the X button on the docker tab.

To move dockers

To move
Do the following
A docker Drag the docker tab to a new location.

Multiple nested dockers Drag the title bar of the active docker to a new location.

To dock a floating docker
• Drag the docker’s title bar or tab to an edge of the drawing window and position the pointer along the edge. When a gray preview of the docker’s position appears, release the mouse button.

To collapse a docker
• Click the Collapse docker button on the docker’s title bar.
To expand a collapsed docker, click its tab.

**Status bar**

The status bar displays information about selected objects (such as color, fill type, outline, cursor position, and relevant commands). It also displays document color information, such as the document color profile and color proofing status.

You can edit the fill and outline of selected objects by clicking the Fill and Outline icons on the status bar. See “Customize the status bar” on page 971 for information about customizing the contents and appearance of the status bar.

**To hide the status bar**

- To hide the status bar, click **Window  Toolbars  Status Bar**.

**Document navigator**

The document navigator is located below the drawing window and provides controls for managing pages. It is displayed by default, but you can hide it.

**To hide or display the document navigator**

- Click **View  Document Navigator**.
  
  A check mark beside the **Document Navigator** command indicates that the document navigator is displayed.

**Choose a workspace**

CorelDRAW includes a collection of workspaces that are designed to help you increase your productivity. A workspace is a configuration of settings that specifies how the various command bars, commands, and buttons are arranged when you open the application. You can choose a workspace from the **Welcome Screen**, or you can switch to a different workspace from within the application.

The specialized workspaces in CorelDRAW are configured according to specific workflows or tasks, such as page layout work or illustrating. Their purpose is to make more accessible the tools that you use most often.

The following table describes the available workspaces.

<table>
<thead>
<tr>
<th>Workspace</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lite</td>
<td>This workspace makes CorelDRAW's most commonly used tools and features more accessible. If you are new to CorelDRAW, the Lite workspace is ideal for getting started.</td>
</tr>
<tr>
<td>Default</td>
<td>This workspace has been redesigned to provide a more intuitive placement of tools and controls. This workspace is ideal for users who have experience with other vector graphics software, as well as users who are familiar with CorelDRAW.</td>
</tr>
<tr>
<td>Workspace</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Default</td>
<td>Help topics are based on the Default workspace.</td>
</tr>
<tr>
<td>Touch</td>
<td>Optimized for touch-enabled devices, the Touch workspace is ideal for field work and sketching. Complete your tasks by using touch, dial, or a stylus, without needing a mouse or keyboard.</td>
</tr>
<tr>
<td>Illustration</td>
<td>This workspace is designed to make the process of creating book cover designs, magazine ads, storyboards, and other types of illustrations more intuitive and efficient.</td>
</tr>
<tr>
<td>Page layout</td>
<td>This workspace is optimized for arranging graphics and text objects so you can create compelling layouts for business cards, branding materials, product packaging, or multipage documents such as brochures and newsletters.</td>
</tr>
<tr>
<td>Adobe Illustrator</td>
<td>Simulates the Adobe Illustrator workspace by positioning the CorelDRAW features where you would find the equivalent feature in Adobe Illustrator. This workspace is useful if you recently switched from Adobe Illustrator to CorelDRAW and you are not familiar with the CorelDRAW workspace.</td>
</tr>
</tbody>
</table>

If you have a unique workflow, you can create a custom workspace that is optimized for your specific needs. For more information, see “Create workspaces” on page 959.

**To choose a workspace**

- Click **Window ➤ Workspace**, and choose one of the available workspaces.

You can also choose a workspace from the Welcome Screen or from the **Options** dialog box (**Tools ➤ Options ➤ Workspaces**).
Creative tools and content

You can search and manage content and assets, such as vector and bitmap (raster) images and symbol libraries saved to local, network, or Cloud folders and on portable devices. When you find the content that you need, you can insert it into your document or open it in its associated application.

You can expand your collection of creative tools by downloading free tools and content, and purchasing apps, plug-ins, and content packs.

This section contains the following topics:
- “Content types” (page 107)
- “View content with the Assets docker” (page 108)
- “Find clipart and other local and network assets” (page 110)
- “Use and manage images with the Assets docker” (page 117)
- “Work with Cloud assets” (page 118)
- “Work with linked assets” (page 120)
- “Manage content with the Tray docker” (page 122)
- “Acquire applications, plug-ins, and content” (page 123)
- “Change content locations” (page 125)

Content types

Content types include images (clipart and photos), fills (fountain, bitmap patterns, and vector patterns), fonts, image lists, palettes, symbol libraries, photo frames, and templates. Some content is included with the suite to get you started. Additional content is available for download. For more information, see “To access the Get More dialog box” on page 124.

For information about fills, see "Find and view fills and transparencies" on page 459. For information about templates, see "Find templates" on page 692. For information about fonts, see the Corel Font Manager Help or "Acquire more fonts” on page 668.

Sample vector images
Sample bitmap images

Sample vector patterns

Sample bitmap patterns

Sample photo frames

Sample image lists

View content with the Assets docker

The Assets docker provides three views to help you work with your content. The Local and network assets view shows vector and bitmap images and other assets that are stored in local or network folders. The Cloud assets view shows the files in your Cloud folder, including symbol library files that are shared with you. The Linked assets view shows the symbol libraries linked to the active document.

The Assets docker replaces the CONNECT Content docker from earlier versions.
You can view the full name and location of an asset in any view.

Assets can be displayed as a list of titles (or filenames if titles are not available) accompanied by thumbnails (default view) or as a grid of thumbnails. Also, you can increase and decrease the size of asset thumbnails.

The user interface controls vary based on the selected view. For detailed information about the controls in each view, see “Find clipart and other local and network assets” on page 110, “Work with Cloud assets” on page 118, and “Work with linked assets” on page 120.

To switch between views

- In the Assets docker (Window ➤ Dockers ➤ Assets), perform a task from the following table.

<table>
<thead>
<tr>
<th>To show only</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assets saved to local and network folders</td>
<td>Click the Local and network assets button</td>
</tr>
<tr>
<td>Files saved or shared to your Cloud folder</td>
<td>Click the Cloud assets button</td>
</tr>
<tr>
<td>Linked symbol libraries</td>
<td>Click the Linked assets button</td>
</tr>
</tbody>
</table>

To view the filename and location of an asset

- Hold the pointer over a thumbnail.

To switch between list and grid view

- Click the Thumbnail preview button ( 或 ) located at the bottom of the Assets docker.
To adjust the size of asset thumbnails

- Move the Thumbnail size slider.

Find clipart and other local and network assets

The Assets docker (Window ▶ Dockers ▶ Assets) provides a central location where you can search and browse vector and bitmap images in local or network folders and on portable devices.

Explore the Assets docker

The image below shows the main components of the Assets docker in Local and network assets view.
<table>
<thead>
<tr>
<th>Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. <strong>Content pane</strong></td>
<td>Lets you view thumbnails of content files</td>
</tr>
<tr>
<td>2. Resizing bar</td>
<td>Lets you resize the <strong>Content</strong> and <strong>Folders</strong> panes</td>
</tr>
<tr>
<td>3. <strong>Folders</strong> pane</td>
<td>Displays content in a hierarchical tree-like folder structure</td>
</tr>
<tr>
<td>4. <strong>Show All</strong></td>
<td>Lets you explore the content in all folders including default libraries, as well as user-added folders and sub folders</td>
</tr>
<tr>
<td>5. <strong>Filter content</strong></td>
<td>Lets you filter content by category</td>
</tr>
<tr>
<td>6. <strong>Sort content</strong></td>
<td>Lets you sort content by name and date as well as view your favorite images</td>
</tr>
<tr>
<td>7. <strong>Search</strong> box</td>
<td>Lets you search for files by using search terms</td>
</tr>
<tr>
<td>8. <strong>Local and network assets</strong></td>
<td>Lets you access vector and bitmap images and other assets that are stored in local or network folders</td>
</tr>
<tr>
<td>9. <strong>Cloud assets</strong></td>
<td>Lets you access files in your Cloud folder, including symbol library files that are shared with you</td>
</tr>
<tr>
<td>10. <strong>Linked assets</strong></td>
<td>Lets you access symbol libraries linked to the active document</td>
</tr>
<tr>
<td>11. <strong>Get More</strong></td>
<td>Lets you access the <strong>Get More</strong> dialog box that allows you to download apps and plug-ins as well as content such as fill packs, image packs (clipart and photos), and font packs from within CorelDRAW</td>
</tr>
<tr>
<td>12. <strong>Options</strong></td>
<td>Lets you access the following menu commands:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Single-Folder Selection Mode</strong> — lets you toggle between selecting a single folder and selecting multiple folders in the <strong>Folders</strong> pane</td>
</tr>
<tr>
<td></td>
<td>• <strong>Browse Recursively</strong> — lets you browse or search all items in the selected folder and subfolders</td>
</tr>
<tr>
<td></td>
<td>• <strong>Add Folder</strong> — lets you add a location to the <strong>Folders</strong> pane</td>
</tr>
<tr>
<td></td>
<td>• <strong>Browse</strong> — lets you change the location of a folder</td>
</tr>
<tr>
<td></td>
<td>• <strong>Open Folder Location</strong> — lets you quickly open a folder location in File Explorer without the need to manually navigate to it</td>
</tr>
<tr>
<td></td>
<td>• <strong>Reindex Folder</strong> — lets you index a folder for faster viewing, browsing, and searching</td>
</tr>
<tr>
<td></td>
<td>• <strong>Rename</strong> — lets you rename a folder in the <strong>Folders</strong> pane</td>
</tr>
<tr>
<td></td>
<td>• <strong>Remove from List</strong> — lets you remove a location from the <strong>Folders</strong> pane</td>
</tr>
<tr>
<td></td>
<td>• <strong>Help</strong> — lets you access the help topic on asset management</td>
</tr>
<tr>
<td>Part</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>13. <strong>Browse folders</strong></td>
<td>Lets you toggle between displaying and hiding the <strong>Folders</strong> pane when viewing local and network assets</td>
</tr>
<tr>
<td>14. <strong>Show raster images</strong></td>
<td>Lets you hide or show clipart and vector graphics in the <strong>Content</strong> pane</td>
</tr>
<tr>
<td>15. <strong>Show vector images</strong></td>
<td>Lets you hide or show photos and other bitmaps in the <strong>Content</strong> pane</td>
</tr>
<tr>
<td>16. <strong>Thumbnail size slider</strong></td>
<td>Lets you adjust the size of thumbnails in the <strong>Content</strong> pane</td>
</tr>
<tr>
<td>17. <strong>Thumbnail preview</strong></td>
<td>Lets you switch between list and grid view in the <strong>Content</strong> pane</td>
</tr>
<tr>
<td>18. <strong>Edit</strong></td>
<td>Lets you open and edit an image</td>
</tr>
<tr>
<td>19. <strong>Properties</strong></td>
<td>Lets you tag, delete, and edit the properties of a local or network asset</td>
</tr>
<tr>
<td>20. <strong>Open Folder Location</strong></td>
<td>Lets you open a folder location in File Explorer</td>
</tr>
<tr>
<td>21. <strong>Import</strong></td>
<td>Lets you import content in the active document</td>
</tr>
</tbody>
</table>

The **Assets** docker in **Local and network assets** view has two panes, the **Folders** and **Content** pane.

The **Folders** pane lets you browse content and filter out search results by selected folder. It allows you to view folder hierarchy, navigate through folders, and quickly locate content within the broader context of your files. When no search term is entered, clicking one or more folders displays all content in the selected folder or folders. The **Folders** pane is hidden by default.

The **Content** pane displays thumbnails of assets along with their names (or titles.) If no title is available, then the filename is displayed instead. For more information about adding titles to images, see “To tag, delete, and edit the properties of a local or network asset” on page 117. When you hover over a thumbnail, you can view the filename and location of an asset. You can also switch between grid and list view, and adjust the size of thumbnails. For more information, see “To switch between list and grid view” on page 109 and “To adjust the size of asset thumbnails” on page 110.

You can resize the panes to adjust the layout of the docker according to your preferences and needs.

**Browse and search for content**

You can browse for content, or you can search for content by using keywords.

To get you started, Corel provides local content that is stored in your **Documents\Corel\Corel Content\Images** folder. If you are looking to expand your image collection, you can download additional image packs from within the **Get More** dialog box. After you download and install a pack, the content is saved to the **Documents\Corel\Corel Content\Images** folder and appears in the **Corel Image Library** listed at the top of the **Folders** pane. To access content in local folders or shared network locations, you can add them to the folder list. If you add a folder from a USB flash drive or portable hard drive, it is important to note that the content will not be accessible when the secondary storage device gets disconnected from your machine. To ensure uninterrupted access, first copy the content to a folder on your computer, and then add that location to the content list. The application keeps the content in the docker in sync with the content in the
source location. Additions of folders or assets in File Explorer are quickly reflected in the **Assets** docker. If you are unable to view the images in an existing content list location immediately after adding them to a folder in File Explorer, you can initiate a folder reindexing process. You can also delete folders from the content list and change the location of folders. Changing folder location eliminates the need for a two-step process of deleting an unnecessary folder and adding a new one. Instead, you can update the folder’s location with a single action. For example, when you rename a folder or move it to a different location in File Explorer, in the **Assets** docker, you can restore the link by browsing to the folder.

You can browse and search the contents of one or more folders, or explore all locations in the folder list. Not only can you explore multiple folders, but you can also selectively choose the folders you want to view. Selecting specific folders lets you quickly view the assets in these folders without the need to navigate through the entire tree structure repeatedly. It simplifies the process of accessing content from multiple folders simultaneously. You can expand and collapse folders to optimize screen space and focus on relevant content. Additionally, if you need to quickly navigate through content within the panes, you can scroll with the mouse. Plus you can use the arrow keys to navigate through the tree structure in the **Folders** pane, which offers efficiency, accessibility, and contributes to a smoother and uninterrupted workflow.

You can rename items in the folder list and give them more descriptive or meaningful names, facilitating better organization and seamless navigation. While working in the docker, you can quickly access and explore a location in your computer’s file management system without the need to manually navigate to it.

You can search assets by the filename, title, or tags. For example, if you type “tree” in the text field, the application automatically filters out all files that do not match, and you see only the files that have the word “tree” in the filename, title, or tags.

You can narrow the search results by choosing the content source (for example, a specific folder location) and category (for example, Nature). You can also view the list of your favorite or most recently used images, and you can sort images by the name and the date they were created or modified.

After you find the image or asset you need, you can add it to your project. For more information, see “Use and manage images with the **Assets** docker” on page 117.

**To access local and network assets**
1. Click **Window** ‹ Dockers ‹ **Assets**.
2. In the **Assets** docker, click the **Local and network assets** button.

**To browse for local and network assets**
1. In the **Assets** docker, click the **Local and network assets** button, and then click the **Browse folders to choose a content source** button.
2. Click a location in the **Folders** pane.
   - To select multiple folders, click the **Options** button, uncheck the **Single-Folder Selection Mode** toggle menu to switch to multi-folder selection, and then enable the check boxes of the folders that you want to explore in the **Folders** pane.

**You can also**

**Expand a folder**
- Click the arrow button to the left of a folder to expand it.
- To collapse an expanded folder, click its arrow button.

**Tip:** You can also expand and collapse a selected folder by pressing the **Right** or **Left arrow** key, respectively.

**Navigate folders**
- Press the **Up** or **Down arrow** key to move up or down the folder structure, respectively.
Notes:
• When folders are expanded, using the Up or Down arrow keys allows you to navigate through all folders and subfolders in the order they appear in the tree structure. When folders are collapsed, using the Up or Down arrow keys lets you navigate specifically through the top-level folders.
• You can also navigate up and down the folder structure by using the Left or Right arrow key, respectively. However, when a folder has subfolders, pressing the Left or Right arrow key once navigates up or down the folder structure, and pressing it a second time collapses or expands the folder structure.

Explore all locations in the folder list
Click Show All at the top of the content list in the Folders pane. Click the Options button and make sure the Browse Recursively command is enabled.

Resize the Folders and Content pane
Drag the resizing bar up or down.

Reindex a folder
Click the Options button and click Reindex Folder.

_enabled by default, recursive browsing (Options button ➤ Browse Recursively) lets you explore a directory and its subdirectories. When you disable recursive browsing, you can browse only the content in the top-level directory.

The Single-Folder Selection Mode toggle menu (Options button ➤ Single-Folder Selection Mode) lets you switch between single-folder and multi-folder selection. By default, multi-folder selection is disabled.

To manage folders in the Folders pane
1 In the Assets docker, click the Local and network assets button ➠, and then click the Browse folders to choose a content source button ➠.
2 Perform a task from the following table.

To
Add a folder

Do the following
Click the Options button ➤ and click Add Folder. In the Select Folder dialog box, browse to the drive and folder where your content is stored, click a location, and click Select Folder.

The new folder is added to the list and becomes the active folder.

Notes:
• The Corel Image Library always appears at the top of the content list. All other folders are sorted alphanumerically according to their names.
• When the selected folder contains subfolders that have already been added to the list, the folder will be added as a parent folder.
• If you are unable to view the images in an existing content list location immediately after adding them to a folder in File
To Do the following

Explorer, click the Options button and click Reindex Folder.

- If you have added a folder from a USB flash drive or portable hard drive to the content list, the content will not be accessible if the secondary storage device gets disconnected from your machine. To ensure uninterrupted access, it is recommended to first copy the content to a folder on your computer and then add that folder to the content list in the docker.

Remove a folder

Right-click a folder in the Folders pane, and click Remove from List.

Tip: You can also remove a folder by selecting the folder in the Folders pane, clicking the Options button, and clicking Remove from List.

Rename a folder

Right-click a folder in the Folders pane, and click Rename. In the Rename dialog box, type a name in the Name box.

Tip: You can also rename a folder by clicking the folder in the Folders pane, clicking the Options button, clicking Rename, and typing a name in the Name box of the Rename dialog box.

Change folder location

Click a folder in the Folders pane. Click the Options button, click Browse, and navigate to the folder you want.

To find local and network assets

1 In the Assets docker, click the Local and network assets button, and then click the Browse folders to choose a content source button.

2 Perform a task from the following table to choose a location.

To search

A folder

Click a folder in the Folders pane.

Multiple folders

Click the Options button, uncheck the Single-Folder Selection Mode toggle menu to switch to multi-folder selection, and then enable the check boxes of the folders that you want to explore in the Folders pane.

All available content

Click Show All at the top of the content list in the Folders pane.

Tip: To search across all subfolders of selected folders, click the Options button, and make sure the Browse Recursively command is enabled.

3 Type a word in the Search box, and press Enter.

Thumbnails that match the search term appear in the Content pane.
To filter and sort local and network assets

1. In the **Assets** docker, click the **Local and network assets** button.

2. Browse or search for content.

3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter images</strong></td>
<td>Choose a category from the <strong>Filter content</strong> list box.</td>
</tr>
<tr>
<td></td>
<td>To hide or show clipart and vector graphics, click the <strong>Show vector images</strong> button.</td>
</tr>
<tr>
<td></td>
<td>To hide or show photos and other bitmaps, click the <strong>Show raster images</strong> button.</td>
</tr>
<tr>
<td><strong>View the most recently used images</strong></td>
<td>From the <strong>Sort assets by name or date</strong> list box, choose <strong>Recent</strong>.</td>
</tr>
<tr>
<td><strong>View your favorite images</strong></td>
<td>From the <strong>Sort assets by name or date</strong> list box, choose <strong>Favorites</strong>. For information about how to mark content as favorite, see &quot;To tag, delete, and edit the properties of a local or network asset&quot; on page 117.</td>
</tr>
<tr>
<td><strong>Sort images</strong></td>
<td>From the <strong>Sort assets by name or date</strong> list box, choose one of the following options:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Name</strong> — sorts assets by title (or name), in alphanumeric order. If titles are not available, assets are sorted by filenames.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Date Created</strong> — sorts images by the date they were created, starting with the last created image</td>
</tr>
<tr>
<td></td>
<td>- <strong>Date Modified</strong> — sorts images by the date they were modified, starting with the last modified image</td>
</tr>
<tr>
<td></td>
<td>Images in your <strong>Favorites</strong> list are sorted by name.</td>
</tr>
<tr>
<td></td>
<td>Images in your <strong>Recent</strong> list are sorted by name.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: When sorting by name, assets are arranged alphanumerically based on their titles (if available). For more information about adding titles, see &quot;To tag, delete, and edit the properties of a local or network asset&quot; on page 117.</td>
</tr>
</tbody>
</table>
To download and add a new image pack
1 In the Assets docker, click the Get More button.
2 In the Get More dialog box, click the image pack you want.
3 Do one of the following:
   • Click Buy Now, and follow the onscreen instructions to purchase the item.
   • Click Download if the item is included in your product or subscription.

Use and manage images with the Assets docker

After you find the image you need in a local, network, or Cloud folder, you can place it into your project as an embedded or linked object. When inserting a vector graphic, you can place it at the original position where it was created relative to the page.

You can open an image and edit it in its associated application. To find the images you like quickly, you can tag them as favorites. In addition, you can view and change the properties of an image. For example, you can change its title, add new tags, and delete existing tags. When you no longer need an image, you can delete it.

To insert content in the active document
1 In the Assets docker, click a thumbnail.
2 Click the Import button and choose one of the following commands:
   • Import and link — inserts a bitmap image as a linked object
   • Import at original position — lets you place a vector graphic at the original position where it was created relative to the page. The graphic is placed as an embedded object.
   • Import — inserts the file as an embedded object
3 Follow the onscreen instructions.

You can also insert a file into an active document as an embedded object by dragging the file from the viewing pane to the active document.
You can also insert a file into an active document by right-clicking the file in the viewing pane and choosing an Import command.
You can also insert a file into an active document from the Tray docker.
To open and edit an image

1. In the Assets docker, click a thumbnail.
2. Click the Edit button.

The file opens in its associated application.

💡 You can’t edit files that have been shared with you on the Cloud.

To tag, delete, and edit the properties of a local or network asset

- In the Assets docker (Window ▶ Dockers ▶ Assets), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag an image as favorite</td>
<td>Right-click a thumbnail, and click Favorite.</td>
</tr>
<tr>
<td>Edit image properties</td>
<td>Right-click a thumbnail, and click Properties. In the Properties dialog box, do any of the following:</td>
</tr>
<tr>
<td></td>
<td>• Choose a language from the Language list box.</td>
</tr>
<tr>
<td></td>
<td>• Type a new name in the Title box.</td>
</tr>
<tr>
<td></td>
<td>• Choose a category from the Category list box to categorize the image.</td>
</tr>
<tr>
<td></td>
<td>• To assign a custom category, choose New category from the Category list box, and type the category name in the box.</td>
</tr>
<tr>
<td></td>
<td>• Add or delete tags in the Tags box.</td>
</tr>
</tbody>
</table>

Delete a file from your local library

Right-click a thumbnail, and click Delete.

Work with Cloud assets

The Assets docker lets you view and search all your Cloud assets, such as CorelDRAW (CDR) files, Corel DESIGNER (DES) files, and symbol libraries, including symbol libraries that are shared with you in your Cloud folder. After finding a Cloud asset, you can add it to the active document the way you would add any asset from a local or a network folder. For more information, see “To insert content in the active document” on page 117.
You can open your own Cloud assets for editing, but not Cloud assets that are shared with you. You can also refresh the list of Cloud assets so it is in sync with the contents of your Cloud folder.

Symbol libraries can be saved to the Cloud and shared with others. For more information, see “To save a symbol library to the Cloud” on page 388. Whether it is your own library file or a shared one, you can link it your active document from the Cloud. Linked symbol libraries can be synced from the Cloud when they are updated. For more information about linking symbol libraries, see “To link a symbol library to the active document” on page 121.
To find and edit Cloud assets

1. In the Assets docker (Window ➤ Dockers ➤ Assets), click the Cloud assets button.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find a Cloud asset</td>
<td>Type a keyword in the Search box.</td>
</tr>
<tr>
<td>Open a Cloud asset for editing</td>
<td>Right-click a thumbnail, and click Edit.</td>
</tr>
<tr>
<td></td>
<td>Note: You can’t edit symbol libraries that are shared with you.</td>
</tr>
</tbody>
</table>

To refresh the list of Cloud assets

- In the Assets docker (Window ➤ Dockers ➤ Assets), click the Cloud assets button and click the Refresh list button.

Work with linked assets

When you find the symbol library you need, you can link it to the document so that it is available for use. The Linked assets view in the Assets docker lets you access the symbol libraries that are linked to the active document. If the symbol libraries are linked from the Cloud, you can refresh the file list to sync it with your Cloud folder.

You can open your linked symbol libraries for editing, but not linked libraries that are shared with you. You can also sync linked libraries with the source so that their symbols are always up-to-date.

In some cases, the link between a document and a symbol library may be broken. For example, renaming or moving a linked symbol library breaks its link to the document. An icon beside the linked library name shows that the link is broken. You can restore the link to the symbols library to regain access to the symbols in the library.
The Symbols docker lets you access the symbols in a linked library from the Linked Symbols section so you can use them in your projects. For more information, see “Use symbols in drawings” on page 385.

To link a symbol library to the active document

1. In the Assets docker (Window ➤ Dockers ➤ Assets), do one of the following:
   • Click the Local and network assets button.

Linked assets view. Two symbol libraries are linked to the document. The link of the first symbol library is broken and needs to be restored.
• Click the Cloud assets button.

2 Click a symbol library.

3 Click the Import button, and click Link to document.

💡 You can also right-click a symbol library, and click Link to document.

To work with linked symbol libraries

1 In the Assets docker (Window ➤ Dockers ➤ Assets), click the Linked assets button.

2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh the list of libraries linked from the Cloud</td>
<td>Click the Refresh List button.</td>
</tr>
</tbody>
</table>
| Edit a linked symbol library | Right-click a library, and click Edit.  
**Note:** The Edit command is not available for symbol libraries that are shared with you. |
| Sync a linked symbol library | Right-click a library, and click Sync linked assets.  
**Note:** The Sync linked asset command is only available when the source file has been updated. |
| Break the link of a linked symbol library | Right-click a library, and click Break link.  
**Note:** The linked asset is removed from the document. |
| Restore the broken link of a symbol library | Right-click a symbol library with a broken link, and click Restore link. If you are restoring the link to a local symbol library that was moved or renamed, the Restore dialog box appears, letting you browse to the symbol library.  
**Note:** You can’t restore the link to a shared symbol library if the file owner has unshared the file. However, you can remove the symbol library from the list by right-clicking the file, and clicking Break link. |

Manage content with the Tray docker

You can organize your content by using trays. A tray is useful for gathering content from various folders. While the files are referenced in the tray, they actually remain in their original location. You can add and remove content from the tray. The tray is shared between CorelDRAW and Corel PHOTO-PAINT.

You can create trays, and you can rename them using meaningful names. In addition, you can load a tray file that is not listed among the available trays. You can delete a tray at any time.
The Tray docker also lets you add content to the active document. For more information about adding content to the active document, see “To insert content in the active document” on page 117.

To add content to a tray
1 In the Assets docker (Window ➤ Dockers ➤ Assets), search or browse for content.
2 Right-click a thumbnail, and click Add to [Tray Name].

You can also drag content from a folder on your computer to the Tray docker.

To remove content from a tray
1 Click Window ➤ Dockers ➤ Tray.
2 Select a thumbnail in the tray, and click the Remove from tray button.

To work with trays
1 Click Window ➤ Dockers ➤ Tray.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a tray</td>
<td>Choose a tray from the list box.</td>
</tr>
<tr>
<td>Create a tray</td>
<td>Click the Tray management button and click Add new tray. By default, trays are saved to your Documents/Corel/Corel Content \Trays folder.</td>
</tr>
<tr>
<td>Rename a tray</td>
<td>Click the Tray management button and click Rename tray. Type a name in the Rename dialog box.</td>
</tr>
<tr>
<td>Load a tray file</td>
<td>Click the Tray management button and click Open tray file. Navigate to the tray file.</td>
</tr>
<tr>
<td>Delete a tray</td>
<td>Click the Tray management button and click Delete tray.</td>
</tr>
</tbody>
</table>

Acquire applications, plug-ins, and content

The Get More dialog box lets you download apps and plug-ins as well as content such as fill packs, image packs (clipart and photos), and font packs from within CorelDRAW. The selection is updated with new offerings as they become available. Some items are free whereas other items are available for purchase.

Both applications and plug-ins require installation.
To uninstall an application or a plug-in, go to the Control Panel of the operating system.

**AfterShot 3 HDR**

Corel® AfterShot™ 3 HDR lets you make easy corrections and enhancements to your RAW or JPEG photos, and apply adjustments to thousands of photos at once with batch-processing tools. Plus, you can create high dynamic range (HDR) images with the HDR module, included in AfterShot 3 HDR. Download Corel AfterShot 3 HDR for free from within CorelDRAW, and quickly learn professional-grade photo editing. To access even more powerful photo-management and photo-editing features, upgrade to the latest version of AfterShot Pro from within the Get More dialog box.

**Restore purchases**

After you purchase creative tools, check marks appear beside their names. If you reinstall the suite or install it on another computer, you can restore your purchases. The items that you have purchased will appear in the Get More dialog box, so that you can download them and reinstall them.

**To access the Get More dialog box**

- Click the Launch button on the standard toolbar, and click Get More.

The Get More dialog box lets you download clipart, photos, fonts, applications, and more.

**To download AfterShot 3 HDR**

- Click the Launch button on the standard toolbar, and click AfterShot 3 HDR.
After downloading AfterShot 3 HDR, you can start it from the Launch button on the standard toolbar. For detailed information about how to use AfterShot 3 HDR, start the application and access the Help by pressing F1.

To access an application or a plug-in
• Click the Launch button on the standard toolbar, and click the application or plug-in that you want to use.

To restore your purchases
1 Click Help ▶ Restore Purchases.
2 In the dialog box that appears, type the email address that was used to make the purchases, and click Continue. A list of your purchases is displayed.
3 Click Close.
   The list of offerings in the Get More dialog box is updated to show which items you have already purchased.
4 Download the items you want.

Change content locations
Images, fills, fonts, image lists, photo frames, trays, and templates are saved to your Documents\Corel\Corel Content\[Content Type] folders. You can change the location of some or all these content files by browsing to different folders. For example, you can choose to save templates and fonts to a new location, but leave other content files in your Documents\Corel\Corel Content folder.

When you change a content location, you can choose to move the content files from the old location to the new location.

You can reset individual or multiple content locations to their default folders from the Options dialog box. Alternatively, you can reset all content locations when you reset the application to its default settings by holding down F8 during startup. With this method, all files saved to custom locations remain in place. To restore your custom content locations, you must browse again to the respective folders.

To change a content location
1 Click Tools ▶ Options ▶ Global.
2 Click File Locations.
3 Click the location that you want to change, and click Edit.
4 In the Select Folder dialog box, navigate to the folder you want.
   If you want to move the content files saved to the old location to the new folder, click Yes in the Move Content dialog box.

You can also

Reset the location of a single content type
   Click the content type name, and click Reset.

Reset the locations of multiple content types
   Holding down Ctrl, click the content types you want, and click Reset.
Touchscreen and wheel devices

This section includes the following topics:
- “Touch” (page 127)
- “Wheel devices” (page 129)

For information about using a pen and stylus with CorelDRAW, see “Pressure-sensitive pens and devices” on page 197.

Touch

CorelDRAW provides touch gesture support, a Touch workspace, and automatic workspace switching to help you make the most of your touch-enabled device.

Gestures

You can use common gestures on your touchscreen device to scroll, zoom, and pan in a document as well as access tools grouped in flyouts. The following table describes how to complete common tasks using touch gestures.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll in a document</td>
<td>Tap the screen with two fingers and drag in the direction you want to scroll.</td>
</tr>
<tr>
<td>Zoom in and out</td>
<td>Using two fingers, pinch outwards to zoom in and pinch inwards to zoom out.</td>
</tr>
<tr>
<td>Zoom and pan simultaneously</td>
<td>Using two fingers, pinch outwards or inwards while dragging in the direction you want.</td>
</tr>
<tr>
<td>Choose a tool located in a flyout</td>
<td>In the toolbox, tap a flyout button, and tap the tool you want.</td>
</tr>
</tbody>
</table>

Touch workspace

Optimized for touch-enabled devices, the Touch workspace is ideal for field work and sketching. It allows you to complete your tasks by using touch, dial, and a stylus, without needing a mouse or keyboard.
The Touch workspace has streamlined user interface (UI) that shows you only the tools and commands that you are most likely to use when using a tablet. In comparison to the other available workspaces, the Touch workspace features the following changes:

- Buttons and other UI elements are bigger to be touch-friendly.
- The toolbox is modified to include only tools you are likely to use often.
- The toolbox lets you access Undo and Redo commands as well as Copy, Paste, and Delete.
- The menu bar is no longer at the top of the main window. You can access menu commands by clicking the Menu button in the lower-left corner of the status bar.
- The status bar lets you quickly change the zoom level as well as access commonly used commands and dockers.

Switch between Touch and Desktop workspaces

Tablet mode is a Windows feature that optimizes the UI for touch-enabled devices. Usually, Tablet mode is activated when you detach a tablet from its base. When a tablet is attached to its base, it is in Desktop mode. On Windows 10, CorelDRAW automatically switches to the Touch workspace when Tablet mode is enabled. When Tablet mode is disabled, the application switches to a desktop workspace. You can choose which workspace to use in Desktop mode and which workspace to use in Tablet mode. You can also turn off automatic workspace switching.

In addition, you can show and hide the rulers for Desktop mode and Tablet mode independently to suit your workflow. For more information, see “To show or hide the rulers for Desktop and Tablet mode” on page 741.

Similarly to other workspaces, the Touch workspace can be selected from the Window ➤ Workspace menu.

To set options for switching between Tablet mode and Desktop mode

1. Click Tools ➤ Options ➤ CorelDRAW.
2. In the left pane of the dialog box that appears, click Tablet Mode.
Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn on or off automatic workspace switching when changing between Desktop and Tablet mode</td>
<td>Enable or disable the Auto-switch between Tablet and Desktop workspaces check box.</td>
</tr>
<tr>
<td>Set the workspace for Tablet mode</td>
<td>Choose a workspace from the Tablet mode list box.</td>
</tr>
<tr>
<td>Set the workspace for Desktop mode</td>
<td>Choose a workspace from the Desktop mode list box.</td>
</tr>
</tbody>
</table>

To choose the Touch workspace

- Click Window ➔ Workspace ➔ Touch ➔ Touch.

Wheel devices

With CorelDRAW Graphics Suite, you can take advantage of Microsoft Surface Dial and other wheel devices so that you can focus on your creative tasks. Especially useful in combination with a stylus, a wheel device helps you draw and create naturally and ergonomically. You can easily transition between tools and tasks by using your nondominant hand while you are sketching or designing with your stylus.

Your wheel device can be used in two modes: off-screen (placed on your desk) and on-screen (placed directly on the screen).

For information about setting up your wheel device, see the manufacturer’s instructions.

Off-screen mode

When the wheel device is off the screen, its on-screen interface lets you zoom in and out as well as undo and redo actions. In addition, you can now navigate the pages of your document, and you can change the object order by moving selected objects to the front or back of other objects. Plus, your wheel device can help you use the LiveSketch tool more efficiently. For more information, see "Wheel devices and the LiveSketch tool" on page 131.

![The on-screen UI of surface dial when used in off-screen mode in CorelDRAW.](image)

On-screen mode

In on-screen mode (when you place the wheel device on the screen), the on-screen UI is designed to simulate an artist’s palette, giving you quick access to tools and controls through the Tool and Property panels. To select a tool or control on the on-screen UI, you need to use your stylus, or you can simply tap on a touch-screen enabled device.
The default Tool panel lets you switch between the following tools: Pick, Eraser, Rectangle, Ellipse, Text, Pen, and Bézier. You can also access commonly used commands such as Delete, Convert to curves, and Weld.

From the Property panel, you can adjust document, tool, and object settings. For example, you can change the document dimensions and orientation as well as the unit of measurement.

The Tool panel (1) and the Property panel (2) appear when you place the wheel device in the drawing window.

The Property panel is similar to the property bar. It includes controls that are relevant to the selected tool and object. Each time you switch tools on the Tool panel, the Property panel is updated to allow you to edit tool and object properties on the fly. For example, if you have an object selected in the drawing window, you can use the Property panel to quickly adjust object width, height, and outline width; and you can mirror and rotate the object. In addition, if you need to adjust property values, the wheel device can help you fine-tune them with precision.
The Property panel displays controls that let you edit the selected object, a rectangle in this example.

To tailor the Tool panel to your workflow and have a non-cluttered yet complete collection of tools at your fingertips, you can remove, add, and rearrange tools.

Wheel devices and the LiveSketch tool

Your wheel device can be especially helpful when you are sketching with the LiveSketch tool. In off-screen mode, you can use the wheel device to easily undo and redo your strokes. In on-screen mode, you can fine-tune the time it takes to adjust strokes, and set other tool and stroke properties. Plus, you won’t need to use a keyboard to reset the timer and have your strokes adjusted instantly in both modes of the wheel device.
To use a wheel device in off-screen mode

1. Press down the wheel device to show the on-screen menu, and then release.
2. Rotate the wheel device to select one of the following commands on the on-screen menu, and click.
   - **Zoom** — lets you zoom in and out
   - **Undo** — lets you undo and redo actions
   - **LiveSketch** — lets you undo and instantly adjust strokes when using the LiveSketch tool. For more information, see “To use the LiveSketch tool with a wheel device in off-screen mode” on page 134.
   - **Object Order** — lets you move the selected object up or down in the stacking order
   - **Page** — lets you navigate the pages of your document
3. Rotate the wheel device clockwise or counterclockwise to complete your task.

To choose tools and adjust properties using a wheel device in on-screen mode

1. Place the wheel device on the screen with your nondominant hand.
   The Tool and Property panels appear beside the wheel device.
2. Perform a task from the following table by using a stylus or mouse.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust document properties</td>
<td>Make sure that no object is selected in the drawing window. Select the Pick tool on the Tool panel. On the Property panel, select a control. To adjust values, rotate the wheel device clockwise or counterclockwise.</td>
</tr>
<tr>
<td>Choose a tool</td>
<td>Select a tool on the Tool panel.</td>
</tr>
</tbody>
</table>
To do the following

**Adjust tool and object properties**
Select the control you want on the **Property** panel. To adjust values, rotate the wheel device clockwise or counterclockwise.

---

### To delete, convert or weld objects using a wheel device in on-screen mode

1. Place the wheel device on the screen. The **Tool** and **Property** panels appear beside the wheel device.
2. Perform a task from the following table using a stylus or mouse.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete a selected object</td>
<td>Select the <strong>Delete</strong> button on the <strong>Tool</strong> panel.</td>
</tr>
<tr>
<td>Convert selected objects to curves</td>
<td>Select the <strong>Convert to curves</strong> button on the <strong>Tool</strong> panel.</td>
</tr>
<tr>
<td>Weld selected objects</td>
<td>Select the <strong>Weld</strong> button on the <strong>Tool</strong> panel.</td>
</tr>
</tbody>
</table>

---

### To customize the **Tool** panel

1. Place the wheel device on the screen. The **Tool** and **Property** panels appear beside the wheel device.
2. Using your stylus or mouse, select **Edit** on the **Tool** panel. The **Customization** panel opens.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a tool</td>
<td>Drag the tool from the <strong>Customization</strong> panel to the <strong>Tool</strong> panel.</td>
</tr>
<tr>
<td>Delete a tool</td>
<td>Drag the tool out of the <strong>Tool</strong> panel.</td>
</tr>
<tr>
<td>Reposition a tool</td>
<td>Drag the tool to a new position in the <strong>Tool</strong> panel.</td>
</tr>
</tbody>
</table>
To use the LiveSketch tool with a wheel device in off-screen mode

1. In CorelDRAW, tap the **LiveSketch** tool in the toolbox.
2. Press down the wheel device to show the on-screen menu, rotate the wheel device to select **LiveSketch**, and click.
3. Start sketching, and do any of the following:
   - To undo or redo strokes, rotate the wheel device counterclockwise or clockwise.
   - To adjust a stroke instantly before the delay time has elapsed, click.

To use the LiveSketch tool with a wheel device in on-screen mode

1. In CorelDRAW, tap the **LiveSketch** tool in the toolbox.
2. Place the wheel device on the screen to show the on-screen menu.
3. Perform any of the tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust LiveSketch settings</td>
<td>Using a stylus or a mouse, select the control you want on the <strong>Property</strong> panel. To adjust values, rotate the wheel device clockwise or counterclockwise.</td>
</tr>
<tr>
<td>Reset the timer and adjust strokes instantly</td>
<td>As you are sketching with the <strong>LiveSketch</strong> tool, click the wheel device when you want to finalize the stroke before the delay time has elapsed. Without a wheel device, you can reset the time and adjust the strokes instantly by pressing <strong>Enter</strong>.</td>
</tr>
</tbody>
</table>
Collaborate

Using CorelDRAW in conjunction with CorelDRAW.app, you can collaborate on design projects with others, on any device.

This section includes the following topics:
• “Collaboration workflow” (page 135)
• “CorelDRAW.app, CorelDRAW, and Cloud” (page 135)
• “Review and provide feedback” (page 137)
• “Collaborate on text” (page 145)

Collaboration workflow

CorelDRAW offers a workflow that lets you collaborate with colleagues and clients with ease.

Step 1: Upload your design created in CorelDRAW to the Cloud, Google Drive, or Microsoft 365; or capture your design ideas on the fly in CorelDRAW.app. Next, share a link with the stakeholders for review. For more information, see “CorelDRAW.app, CorelDRAW, and Cloud” on page 135.

Step 2: Reviewers open the design in CorelDRAW.app to add comments and annotations. You are notified when changes are made to the design. You can receive feedback in real time (live comments) as you are working on a design that is being reviewed. Any comments and markup added in CorelDRAW.app appear instantly in the file you have open in CorelDRAW.

Reviewers can also add their comments and suggestions to the file in CorelDRAW.

Step 3: Open the reviewed file in CorelDRAW and edit the file based on the reviewers’ comments. With the help of the Comments docker, you can reply to comments to ask for clarification, resolve comments as well as add, hide, and delete them.

Step 4: Upload your revised design for further review or final approval.

CorelDRAW.app, CorelDRAW, and Cloud

Available exclusively to CorelDRAW Graphics Suite and CorelDRAW Technical Suite users, CorelDRAW.app is a web-based application for creating vector graphics. Access it from any device to capture your ideas into designs instantly or share your designs with customers.

CorelDRAW.app is integrated with CorelDRAW. You can save files created in CorelDRAW.app or CorelDRAW to the Cloud, an online storage, and then open these files in either one of the applications. For example, you can create a design in CorelDRAW.app, save it to the Cloud, and later edit the design in CorelDRAW, taking advantage of its wide array of editing tools. After you finish editing, you can save and upload the
file to the Cloud directly from CorelDRAW. The edited file can be opened in CorelDRAW.app for annotation, but not for editing, and then saved to the Cloud. If you need to edit the file, you can open it in CorelDRAW.

A project dashboard helps you store, view, organize, and share files saved to the Cloud. You can share a file by copying and sending a link to its location. Everybody who receives the link will have the access privileges that you choose. You can also share a file with specific people by specifying their email addresses and access privileges.

CorelDRAW.app and CorelDRAW share some features, but they also differ. For information about saving, editing, and opening files with CorelDRAW.app, view a tutorial from within the app by clicking Help ▶ Learning ▶ Tutorial.

Important notes!
• To open files created in CorelDRAW.app in CorelDRAW and vice versa, you must save them as CorelDRAW (CDR) files.
• The first time you access the Cloud from CorelDRAW, you will be prompted to sign in with the password associated with your Corel account. You need to sign in only once a year.
• An Internet connection is required to open files from and save files to the Cloud.

If you need to sign in with different credentials, you must first sign out of the Cloud (Help ▶ Sign out of Cloud).

To access CorelDRAW.app
2. In the Sign in to Cloud dialog box, type the email address and password associated with your Corel.com account.

If you are a corporate user of CorelDRAW Graphics Suite, you can also sign in to CorelDRAW.app Enterprise with your corporate Microsoft 365 or Google Workspace account.

To open a CorelDRAW (CDR) file saved to the Cloud
1. In CorelDRAW, click File ▶ Open from Cloud.
2. On the project dashboard, double-click the file you want to open.

You can also open a CDR file from the Cloud by clicking the Open from Cloud button on the standard toolbar.

To save a CorelDRAW (CDR) file to the Cloud
1. In CorelDRAW, click File ▶ Save to Cloud.
2. On the project dashboard, choose the folder where you want to save the file, and type a file name.
3. Click Save to save the file and upload it to the Cloud.

You can also

Save the file to the Corel DESIGNER (DES) file format, or to an earlier version of CorelDRAW

Choose the file format and version from the File format and version box.

Break the link between a file saved to the Cloud and its locally saved version

In CorelDRAW, click File ▶ Save As, and save the file to the local folder you want.
A file saved to the Cloud can be identified by the cloud icon beside its name.

You can also save a CorelDRAW file to the Cloud by clicking the **Save to Cloud** button on the standard toolbar.

**To find, organize, and view files saved to the Cloud**

1. Click **File > Save to Cloud** or **File > Open from Cloud** to show the project dashboard.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find a file</td>
<td>Start typing the file name in the <strong>Search</strong> box.</td>
</tr>
<tr>
<td>Create a new folder to organize your files</td>
<td>Click <strong>New folder</strong>, and specify the folder name.</td>
</tr>
<tr>
<td>View files as large thumbnails or a list</td>
<td>Click the <strong>Card view</strong> button or the <strong>List view</strong> button in the upper-right corner of the project dashboard.</td>
</tr>
<tr>
<td>Sort files</td>
<td>Click the <strong>Sorting</strong> button and click a command.</td>
</tr>
</tbody>
</table>

**To share a file saved to the Cloud**

1. Click **File > Open from Cloud** to show the project dashboard.
2. Click the file.
   - A pane showing the file thumbnail is displayed to the right.
3. Click **Share This File** at the bottom of the file thumbnail.
4. In the **Share File** dialog box, do one of the following:
   - Click **Copy** to copy the link. From the **Everybody with the link** box, choose the access privileges of all people who will receive the link: **Viewer**, **Reviewer**, or **Approver**.
   - In the **Private Sharing** section, type the email addresses of the people you want to share the file with, and specify the access privileges for each person.

**To sign out of Cloud**

- In CorelDRAW, click **Help > Sign out of Cloud**.

**Review and provide feedback**

Using the **Comments** docker, you can view and address any comments added to a document in context, and you can provide in-context feedback.

**Identify comments**

You can sign in with your Corel account to have all your comments identified with your name and email address. With multiseat corporate installations, you must sign in with your Google Workspace or Microsoft 365 corporate account to have your comments authenticated.
Alternatively, you can choose not to sign in and add anonymous comments. This feature is useful when you want to add comments to a local file, without using Cloud collaboration features. Any anonymous comments can be edited and deleted by other users.

**Respond to and add comments**

After signing in, you can select, respond to, and resolve comments as well as reopen resolved comments. You can add a note icon, and then type a comment in the **Comments** docker, or you can mark up the document with arrows, rectangles, ellipses as well as straight and free-form lines. To draw attention to a specific area in a document, you can highlight it as if you were using a highlighter on paper. You can add a comment to clarify each mark that you draw.

To customize the shapes and lines used as marks, you can choose their color, line thickness, or outline width before or after you draw them. Plus, you can move and resize them.

Also, you can edit the comments that you added, and you can resolve all comments with a single click. You can copy a comment if you need to reuse it.

**Live comments**

You can collaborate with reviewers in real time as they are reviewing your document in CorelDRAW.app. Any comments and markup added in CorelDRAW.app appear instantly in the same document that is open in CorelDRAW, and vice versa. Such comments are known as live comments because of their dynamic nature. You can respond to live comments or ask for clarification and receive feedback right away. Live comments behave as other comments, however, to use them, you must first save and share the document to the Cloud, and then open the document from the Cloud. Also, live comments cannot be exchanged between different installations of CorelDRAW.

**Find, hide, and delete comments**

You can search for comments by typing a word or a reviewer’s name so that you can quickly find specific comments.

To work on your editing tasks with ease, you can hide all comment marks at any time. All resolved comments are hidden by default, letting you focus on comments that need to be addressed. You can choose to show resolved comments.

When a comment or a thread of comments is no longer needed, you can delete it to reduce clutter. You can also delete all markup and comments at once, which is useful when preparing the final version of a design.
When exporting a document that contains comments to a PDF file, you can include or exclude the comments. For more information, see “Comments in PDF files” on page 898.

Save and share

After you have addressed the feedback in the file, you can save it to the Cloud, and then share it with others through CorelDRAW.app for further review or final approval.

Collaborate on text

You can also co-author and co-edit text. For more information, see “Collaborate on text” on page 145.

To sign in to the Comments docker

1. Click Window ➤ Dockers ➤ Comments.

   The Sign-in page appears when you access the Comments docker for the first time. If you have already signed in but you want to switch accounts, click the Sign in or out button in the Comments docker.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sign in with your Corel account (available only to subscribers)</td>
<td>Click Sign in with Corel Account, and provide the required credentials.</td>
</tr>
<tr>
<td>Add anonymous comments</td>
<td>Click Continue to Comments.</td>
</tr>
<tr>
<td>Tip: If you have already signed in to the Comments docker, you must first sign out before you can add anonymous comments.</td>
<td></td>
</tr>
<tr>
<td>Sign in with a Google Workspace account (available only for multiseat installations)</td>
<td>Click Sign in with Google Workspace, and provide the required credentials.</td>
</tr>
<tr>
<td>Sign in with a Microsoft 365 account (available only for multiseat installations)</td>
<td>Click Sign in with Microsoft 365, and provide the required credentials.</td>
</tr>
</tbody>
</table>
**To view, select, and move comments**

1. Open a document that has comments and markup.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>View a comment</td>
<td>Using the <strong>Pick</strong> tool, point to the comment mark in the drawing window. A tooltip is displayed, showing the author, the comment, and the number of replies to the comment.</td>
</tr>
<tr>
<td>Select a comment</td>
<td>Using the <strong>Pick</strong> tool, click the comment mark in the drawing window.</td>
</tr>
<tr>
<td>Select multiple comments</td>
<td>Holding down <strong>Ctrl</strong>, click the comments in the <strong>Comments</strong> docker, or click the comment marks in the drawing window with the <strong>Pick</strong> tool.</td>
</tr>
<tr>
<td>Move a comment mark</td>
<td>Using the <strong>Pick</strong> tool, click the comment mark and drag it to a new position in the drawing window.</td>
</tr>
</tbody>
</table>

**To respond to comments**

1. In CorelDRAW, click **File** ➤ **Open from Cloud**, and double-click the file you want to open. If the file is saved to another location, find it and open it from there.
2. Click **Window** ➤ **Dockers** ➤ **Comments**.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reply to a comment</td>
<td>Click the comment, type a reply in the box that appears below the comment, and press <strong>Enter</strong>.</td>
</tr>
<tr>
<td>Resolve a comment</td>
<td>Click the <strong>Resolve</strong> button in the upper-right corner of the comment box.</td>
</tr>
</tbody>
</table>

**Note:** If you haven’t changed the default display settings for resolved comments, the comment mark and the comment disappear as soon as you resolve the comment. For information about showing and hiding resolved comments, see "To hide and show comments" on page 144.

**Tip:** You can also click the **Actions** button, and click **Resolve**.
To Do the following

Resolve all comments

Click the **Options** button and click **Resolve All**.

Reopen a resolved comment

Click the **Options** button and click **Show Resolved** to show all resolved comments. Click the **Actions** button to the right of the comment, and click **Re-open**.

To use live comments, you must first save and share the document to the Cloud, and then open the document from the Cloud. Live comments can be exchanged between CorelDRAW.app and CorelDRAW and vice versa, but not between two installations of CorelDRAW.

To add a note associated with a comment

1. In the **Comments** docker, click the **Note** tool.
2. Click where you want to add the note icon in the drawing window.
3. Type a comment in the **Comments** docker, and press **Enter**.

To add the same note on all document pages, you must first select the **Master Page** in the **Objects** docker, and then click the **Desktop** layer.

You can cancel the comment you are typing by pressing **Esc**.

To use drawing markup tools

1. In the **Comments** docker, perform a task from the following table:

To

Do the following

Draw an arrow or a straight line

Click the **Arrow Markup** tool. In the drawing window, drag to draw the arrow. To add an arrowhead at the start point, enable the **Start arrow** check box.

To draw a straight line, disable the **Start arrow** check box and the **End arrow** check box. Point to where you want to start the line, and drag to draw the line.

You can choose the color of arrows and lines from the **Line color** picker.

You can specify the width of arrows and lines by typing a value in the **Line width** box.

Add a highlight

Click the **Highlighter** tool, and drag across the area you want to highlight.
To Do the following

You can choose the color of highlights from the Highlight color picker.

You can specify the width of highlights in the Highlight width box.

Draw a free-form line or shape

Click the Freehand Markup tool, point to where you want to start, and drag in the drawing window.

You can choose the color of lines from the Line color picker.

You can specify the width of lines in the Line width box.

Draw a rectangle

Click the Rectangle Markup tool and drag in the drawing window.

You can choose the color of the outline from the Outline color picker.

You can specify the width of the outline in the Outline width box.

Draw an ellipse

Click the Ellipse Markup tool and drag in the drawing window.

You can choose the color of the outline from the Outline color picker.

You can specify the width of the outline in the Outline width box.

Draw filled rectangles or ellipses

Select the Rectangle Markup tool or Ellipse Markup tool, choose a fill color from the Fill color picker, and then drag in the drawing window.

2 Type a comment in the Comments docker, and press Enter.
50% transparency is applied to the colors of the markup.

You can also customize a comment mark after it is added in the drawing window. Using the **Pick** tool, click the comment mark in the drawing window, and then set the color and line properties you want in the **Comments** docker.

**To resize comment marks**

1. Using the **Pick** tool, click a comment mark such as a line, highlight, rectangle, an arrow or an ellipse in the drawing window.

2. Drag a selection handle.

The rectangle was resized to focus on a specific area of the design.

You cannot resize comment marks drawn by other users.

Notes cannot be resized.
To edit your comments
1. In the Comments docker, click a comment that you have added.
2. Click the Actions button , and then click Edit.
3. Edit the comment, and press Enter.

You can edit only your own comments.

To copy a comment
1. In the Comments docker, click a comment.
2. Click the Actions button , and then click Copy Text.

To search for comments
• In the Comments docker, start typing a word or a reviewer’s name in the Search box. The search results are updated dynamically as you type.

CorelDRAW searches all document pages, not only the active page.

To clear the Search box, delete the words you typed.

To hide and show comments
1. Click the Pick tool .
2. In the Comments docker, click the Options button and perform a task from the following table.

To Do the following
Hide or show all comment marks Click Show Annotations to disable or enable the command.
Hide or show resolved comments and their marks Click Show Resolved to disable or enable the command.

To delete comments
• In the Comments docker, perform a task from the following table.

To Do the following
Delete a comment Click the comment, and press Delete.
Tip: You can also click the Actions button , and click Delete.

Delete all comments Click the Options button and click Delete All.
Delete actions can’t be undone.

To delete a comment, you can also select the comment mark in the drawing window by using the Pick tool, and press Delete.

To save and share a file
1. In the Comments docker, click the Save and share button.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save and share a file that has already been saved before</td>
<td>In the Share File dialog box, specify the access privileges you want.</td>
</tr>
<tr>
<td></td>
<td>Note: The file is saved in its current state before the Share File dialog box appears.</td>
</tr>
<tr>
<td></td>
<td>Tip: For information about the Share File dialog box, see “To share a file saved to the Cloud” on page 137.</td>
</tr>
<tr>
<td>Save and share a file that hasn’t been saved before</td>
<td>In the project dashboard, type a file name, and click Save. In the Share File dialog box, specify the access privileges you want.</td>
</tr>
</tbody>
</table>

Collaborate on text

You can involve contributors and clients in co-authoring or co-editing text in a document. To enable text collaboration, you first insert placeholder text that shows the font, size, and location of a text element; and then mark this text for editing. Next, you add a comment in the Comments docker to capture any instructions or notes you have for the reviewers. After you save and share the file, reviewers can edit the text content and adjust text formatting in CorelDRAW.app.
Text elements in a design are marked for editing.

When you open the file that includes edited text, check the text for errors, make sure it fits in the text frame, and make the necessary adjustments. You can then resolve the comment associated with the text.

Comments related to text behave like any other comments in the Comments docker: They can be resolved, edited, deleted, and hidden. For more information, see “Review and provide feedback” on page 137.

To mark text for editing

1 Add placeholder text to your design, and specify the font size and basic formatting.
2 Click Window ➤ Dockers ➤ Comments.
3 In the Comments docker, click the Collaborative Text tool button.
4 In the drawing window, click the placeholder text you want to mark for review.
   A frame is added around the text. The frame is blue by default, but you can choose another color from the Frame color picker in the Comments docker before you mark the text for editing.
5 In the Comments docker, add instructions for reviewers in the empty comment box that appears.
   To save and share the file, click the Save and share button. For more information, see “To save and share a file” on page 145.

You can select, hide, and delete comments related to text editing the same way as you would other comments. For more information, see “To view, select, and move comments” on page 140, “To hide and show comments” on page 144, and “To delete comments” on page 144.

To review edited text

1 Open the file that contains the edited text.
2 Check the text for errors, and make adjustments as needed.
3 To resolve the comment, click the Resolve button in the upper-right corner of the comment box in the Comments docker.
You can respond to and reopen comments related to text the same way as you would other comments. For more information, see “To respond to comments” on page 140.
Use a document management system with CorelDRAW Graphics Suite

CorelDRAW gives you direct access to your organization’s document management system (DMS), such as Microsoft SharePoint, to quickly retrieve and store documents from within CorelDRAW.

In this section, you’ll find the following topics:
- “About document management systems” (page 149)
- “Get started with Microsoft SharePoint” (page 149)
- “Check documents in and out of a document library” (page 151)
- “View documents and document properties” (page 152)

About document management systems

A document management system is a server-based computer system that lets organizations store and track their electronic documents. In other words, a document management system is a secure central location, or virtual filing cabinet, for electronic documents. It lets you easily search for and retrieve electronic documents and make them available to others.

A document management system can also include tools that make it easy for a group of people to collaborate on the same documents. For example, some document management systems can track and store multiple versions of documents, so that you can track changes and retrieve previous versions.

Understanding document libraries

In some document management systems, the term “document library” is used to refer to the component that lets you access, store, and retrieve your documents. To access documents, you must know where the document library is located on the server. You can obtain this information from your network administrator, who can provide you with the Web address, or URL, of the document library. The URL has the following format: http://[ServerName]/[Site]/[Name].

Get started with Microsoft SharePoint

CorelDRAW gives you direct access to your organization’s Microsoft SharePoint document management system (DMS).
The Document Management feature is available only if your organization has licensed CorelSure Maintenance.

To use your organization’s DMS with CorelDRAW, you must log in to SharePoint by using your SharePoint credentials, not your Corel.com account credentials.

**Saving documents to a document library**

You can share CorelDRAW (CDR) documents with others by saving them to your organization’s document library. After you save a document to the document library, others can view the document, or check it out, provided they have the permission to do so.

**Using the working folder**

By default, CorelDRAW places a folder called “Working Files” in My Documents, so the location of the default working folder is as follows:

`Users\<Your name>\Documents\Working Files`

The file you check out is copied to the working folder, and you can modify the file in CorelDRAW from that location. When you are ready to check in the changes, the file is copied from the working folder back into the SharePoint document library. For information about checking out files, see “Check documents in and out of a document library” on page 151.

You can change the working folder, although you should never need to do so.

You must check in all checked-out files before changing the working folder. If you change the working folder while files are checked out; you will not be able check them in from within CorelDRAW.

**To save a document to a document library for the first time**

1. Click **File ➤ Document Management ➤ Save.**
2. In the **Save** dialog box, type the document library URL in the **Look in** text box, and then press **Enter**. The URL must have the proper format: `http://[ServerName]/[Site]/[Name].`
   The document library page appears.
3. Browse to the location where you want to save the file.
4. Type a name for the document in the **File name** box.
5. Click **Save**.

You can save only CorelDRAW (CDR) documents.

To save the document to a local folder, click **File ➤ Save As**.

**To change the working folder**

1. Check in all checked-out files.
2. Click **Tools ➤ Options ➤ Global.**
3. In the **Options** dialog box, click **File Locations**.
4. Click **Documents**, and click the **Browse** button located to the right of the file path.
5. In the **Browse for Folder** dialog box, navigate to the folder you want.
   If you want to move the documents saved to the old location to the new folder, click **Yes** in the **Move Content** dialog box.
You can also

Reset the location of the working folder

Click Documents, and click Reset.

To display the Document Management toolbar

• Click View » Toolbars » Document Management.

Check documents in and out of a document library

The checkout process lets you collaborate with others on the same set of documents. It provides a method for controlling and tracking the changes that are made to the documents. You can check out a document if it is not already checked out by someone else. By checking out a document, you can temporarily prevent others from making changes to it.

You can make changes to a document after checking it out. When you are ready for others to view the changes that you made, you can check in your version of the document to the document library. After the document is checked in, your version of the document can be checked out by someone else.

If your organization’s document management system supports version tracking, you may have the option of adding a version description or choosing a version type, such as a major or minor version. Major versions (1.0, 2.0 and so on) can be used for making important changes in your drawing, whereas minor versions (1.1, 1.2, 1.3 and so on) can be used for making light edits. In addition, depending on how the permissions are set up in your document library, a minor version might be treated as a draft document that only certain users can access.

When you check out a document, a copy of the document is saved to your working folder. You can modify this copy of the document and save the changes locally, without sharing them with others. You can also keep working on the copy of the document when you are offline. You can repeatedly close and reopen the copy without affecting the checkout status and then check in the document when you are online again.

Undoing document checkouts

You can undo a checkout at any time. Undoing a checkout lets you discard all changes that you made to the document since you checked it out. If you choose to keep the document open after undoing a checkout, the working copy becomes a read-only version.

To check a document out of a document library

1  Click File » Document Management » Open.
   The document library Web page appears.
2  Browse to the location of the file that you want to check out.
3  Click the filename.
4  Click Open.
   The file appears as read-only.
   The checkout status of the file appears on the Document Management toolbar. The file is ready to be checked out if it is described as Checked in.
5  Click the Check out document button on the Document Management toolbar (View » Toolbars » Document management).

When you check out a document, a copy of the document is saved to a working folder on your computer.

To check a document in to a document library

1  Click the Check in document button on the Document Management toolbar.
In the **Check in document** dialog box, type a description of the changes that you made to the document in the **Description of changes** text box.

If minor versions are available, by default the document is checked in as a minor version. To check in the document as a major version, disable the **Increment minor version** check box.

If you want to check in the changes but keep working on the document, enable the **Keep document checked out after checking in this version** check box.

If you copy a file to another location and make changes to the file, you will not be able to check in the changes from within CorelDRAW. Instead, you must either check in the file directly in SharePoint or copy the file to the working folder and then check the file in from within CorelDRAW.

The availability of major and minor versions depends on the settings of your organization’s document management system.

**To undo a document checkout**

- Click the **Undo checkout** button on the **Document Management** toolbar.

  Undoing a checkout discards all the changes you made to the document. If you want to save a copy of the document that has your changes to a local folder, click **File** > **Save As**.

**View documents and document properties**

You can view a document stored on SharePoint by opening it as a read-only file. In addition, you can view document information, such as the document title, name, creation date, percentage of completion, and version description. The document properties that are displayed may vary depending on the document library settings.

**To view and edit document properties**

1. Open the document by clicking **File** > **Document Management** > **Open**.

2. Click the **Document properties** button on the **Document Management** toolbar (View > Toolbars > Document Management).

   You can modify any available editable properties in the **Document Properties** dialog box.
Lines, shapes, and outlines

Lines, outlines, and brushstrokes ......................................................................................................................................................... 155
Shapes ................................................................................................................................................................................................. 201
Shape objects ...................................................................................................................................................................................... 213
Symmetrical drawing ........................................................................................................................................................................... 273
Perspective drawing ........................................................................................................................................................................... 285
Lines, outlines, and brushstrokes

CorelDRAW lets you add lines and brushstrokes by using a variety of techniques and tools. After you draw lines or apply brushstrokes to lines, you can format them. You can also format the outlines that surround objects.

CorelDRAW provides preset objects that you can spray along a line. You can also create flow and dimension lines in drawings.

This section contains the following topics:
- “Lines” (page 155)
- “Parallel drawing” (page 164)
- “Calligraphic and preset lines” (page 166)
- “LiveSketch” (page 168)
- “Format lines and outlines” (page 174)
- “Add arrowheads to lines and curves” (page 179)
- “Variable outlines” (page 181)
- “Copy, convert, remove, and replace outlines” (page 183)
- “Brushstrokes” (page 186)
- “Brushstrokes and stylus input” (page 187)
- “Spray objects along a line” (page 188)
- “Connector and callout lines” (page 191)
- “Dimension lines” (page 194)
- “Pressure-sensitive pens and devices” (page 197)

You can draw lines by using shape recognition. For more information, see “Use shape recognition” on page 210.

You can also draw lines with precision by using object coordinates. For more information, see “Use object coordinates to draw and modify objects” on page 316.

Lines

A line is a path between two points. Lines can consist of multiple segments, and the line segments can be curved or straight. The line segments are connected by nodes, which are depicted as small squares. CorelDRAW provides various drawing tools that let you draw curved and straight lines, and lines containing both curved and straight segments.
Freehand and Polyline tools

The Freehand and Polyline tools let you draw freehand lines as if you were sketching on a sketchpad. If you make a mistake while drawing freehand curves, you can erase the unwanted part immediately and continue drawing. When drawing straight lines or segments, you can constrain them to straight vertical or horizontal lines.

The Freehand tool lets you control the smoothness of the curved line you are drawing as well as add segments to an existing line. However, the Polyline tool is easier to use for quickly drawing a complex line that consists of alternating curved and straight segments.

In addition to drawing freehand lines and straight segments, you can use the Polyline tool to draw circular arcs.

You can choose settings to control how the Freehand and Polyline tools behave. For example, you can change the default smoothness of a curved line that you’ve created with these tools.

2-point line tool

You can draw straight lines by using the 2-point line tool. This tool also allows you to create straight lines that are perpendicular or tangent to objects.

Bézier and Pen tools

The Bézier and Pen tools let you draw lines one segment at a time by placing each node with precision and controlling the shape of each curved segment. When using the Pen tool, you can preview the line segments you are drawing.

You can draw lines with multiple segments by using the Bézier tool and clicking each time you want the line to change direction.

You can draw curves by using the Bézier tool and dragging the control handles at the ends of the Bézier curve.

B-spline tool

By using control points, you can easily shape a curved line and draw B-splines, which are typically smooth, continuous curved lines. B-splines touch the first and last control points and are pulled by the points in between. However, unlike the nodes on Bézier curves, control points don’t let you specify the points through which a curve passes when you want to align a curve with other drawing elements.
The control points that touch the line are referred to as “clamped.” Clamped control points function as anchors. The control points that pull the line but do not touch it are referred to as “floating.” The first and last control points are always clamped on open-ended B-splines. The points in between float by default, but you can clamp points if you want to create cusps or straight lines within the B-spline. You can edit completed B-splines by using the control points.

The path of a B-spline curve is determined by the control points you set.

3-point curve tool
The 3-point curve tool lets you draw simple curved lines by specifying their width and height. Use this tool to create arc shapes quickly without manipulating nodes.

You can draw a curved line by specifying its width (left), and then specifying its height and clicking the page (right).

Smart drawing tool
The Smart drawing tool lets you use shape recognition to draw straight and curved lines. For more information, see “Use shape recognition” on page 210.

Nodes and control handles
Some lines have nodes and control handles that you can manipulate to shape lines as you draw. For information about node types, see “Curve objects” on page 214.

Hide the bounding box
When drawing lines by using the curve tools, you can hide the bounding box that is displayed around the lines once they are drawn. The curve tools include the Freehand tool, the 2-point line tool, the Bézier tool, the Artistic media tool, the Pen tool, the B-Spline tool, the Polyline tool, and the 3-point curve tool.
To draw a line by using the Freehand tool

1. In the toolbox, click the Freehand tool.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw a curved line</td>
<td>Click where you want to start the curved line, and drag.</td>
</tr>
<tr>
<td>Draw a straight line</td>
<td>Click where you want to start the line, and then click where you want the line to end.</td>
</tr>
<tr>
<td>Control the smoothness of a curved line</td>
<td>Type a value in the Freehand smoothing box on the property bar. Higher values produce smoother curves.</td>
</tr>
<tr>
<td>Reposition a line while drawing</td>
<td>Hold down both the left and right mouse buttons, and drag the line to a new position.</td>
</tr>
<tr>
<td>Add line segments to an existing line</td>
<td>Click the end node of a selected line, and click where you want the new segment to end.</td>
</tr>
<tr>
<td>Create a closed shape from two or more connected lines</td>
<td>In a line that contains two segments, click the end node, and then click the start node.</td>
</tr>
</tbody>
</table>

You can constrain a line created with the Freehand tool to a predefined angle, called a constrain angle, by holding down Ctrl while you drag. This feature is useful for drawing straight vertical and horizontal lines. For information about changing the constrain angle, see “To change the constrain angle” on page 363.

You can erase a portion of a curved freehand line by holding down Shift and dragging backward over the line before releasing the mouse button.

To draw a line by using the Polyline tool

1. In the toolbox, click the Polyline tool.
2 Do one of the following:
   • To draw a straight segment, click where you want to start the line segment, and then click where you want to end it.
   • To draw a curved segment, click where you want to start the segment, and drag across the drawing page.
      You can add as many segments as you want and alternate between curved and straight segments.

3 Double-click to end the line.

You can also

Reposition a line while drawing
   Hold down both the left and right mouse buttons, and drag the line to a new position.

Place a copy of a line in the drawing
   Hold the right mouse button, and drag the line to a new position.
      Click Copy here.

Before you create a curved segment, click the Auto-close curve button on the property bar to automatically close an open object.

To draw an arc by using the Polyline tool
1 In the toolbox, click the Polyline tool.
2 Click in the drawing window, and then release the mouse button.
3 Hold down Alt, and move the pointer to create an arc.
4 Do one of the following:
   • Click to finish the arc, and release Alt to return to freehand drawing.
   • Click to finish the arc, and, without releasing Alt, move the pointer to draw another arc.
5 Double-click to end the line.

You can hold down Ctrl in conjunction with Alt to constrain the arc to 15-degree increments or another predefined angle, called a constrain angle. For information about changing the constrain angle, see “Constrain objects” on page 362.

To draw a straight line by using the 2-point line tool
1 In the toolbox, click the 2-point line tool.
2 Point to where you want to start the line, and drag to draw the line.
   As you drag, the length and angle of the segment appears in the status bar if the Object Details option is selected. If you're adding to a line, the total length for all segments also appears. For information about how to display object details on the status bar, see “To change the information the status bar displays” on page 971.

To draw a perpendicular line
1 In the toolbox, click the 2-point line tool.
2 On the property bar, click the Perpendicular 2-point line button.
3 Click the edge of an object, and drag to where you want the line to end.
If you want to draw a line that is perpendicular to two objects, drag to the edge of the second object, and release the mouse button when the perpendicular snap point appears.

To extend the line beyond the second object, hold down Ctrl when the perpendicular snap point appears, and drag to where you want the line to end.

This procedure cannot be used for drawing a line that is perpendicular to the baseline of a text object.

You can also drag from an existing curve to draw a perpendicular line.

**Drawing perpendicular lines**

To draw a tangent line

1. In the toolbox, click the 2-point line tool.
2. On the property bar, click the Tangential 2-point line button.
3. Click the edge of a curved segment in an object, and drag to where you want the tangent line to end.

If you want to draw a line that is tangent to two objects, drag to the edge of the second object, and release the mouse button when the tangent snap point appears. When the quadrant snap point coincides with tangent snap point, the quadrant snap point appears.

To extend the line beyond the second object, hold down Ctrl when the tangent snap point appears, and drag to where you want the line to end.

The Tangential 2-point line mode can be used for drawing the sides of the cylinder.

**Drawing tangent lines**
To draw a line by using the Bézier tool

1 In the toolbox, click the Bézier tool.

2 Do one of the following:
   • To draw a curved segment, click where you want to place the first node, and drag the control handle to where you want to place the next node. Release the mouse button, and drag the control handle to create the curve.
   • To draw a straight segment, click where you want to start the line segment, and click where you want to end it.
   You can add as many segments as you want.

3 Press the Spacebar to finish the line.

You can also

Draw a curved segment followed by a straight segment
Draw a curved segment, double-click the end node, and click where you want the straight segment to end.

Draw a straight segment followed by a curved segment
Draw a straight segment. Click the endpoint of the segment, drag to where you want, and release the mouse button. Drag to draw a curve.

Change curve angle to preset increments as you draw
While holding down Ctrl, drag a control handle.

To draw a line by using the Pen tool

1 In the toolbox, click the Pen tool.

2 Do one of the following:
   • To draw a curved segment, click where you want to place the first node, and drag the control handle to where you want to place the next node. Release the mouse button, and drag the control handle to create the curve you want.
   • To draw a straight segment, click where you want to start the line segment, and click where you want to end it.
   You can add as many segments as you want and alternate between curved and straight segments. For more information about alternating curved and straight segments, see “To draw a line by using the Bézier tool” on page 161.

3 Double-click to finish the line.

You can also

Preview a line while drawing
Enable the Preview mode button in the property bar. Click on the drawing page, and release the mouse button. Move the mouse, and click to finish the line.

Add a node to a line
Enable the Automatically add or delete nodes button on the property bar. Point to where in the line you want to add a node, and click when the pointer changes to the Add nodes state.

Delete a node from a line
Point to a node, and click when the pointer changes to the Delete nodes state.
To draw a B-spline

1. In the toolbox, click the B-spline tool.
2. Click where you want to start the line.
3. Click to set as many control points as you need to shape your line.
   Control points float by default, but you can clamp control points to the line by pressing V while clicking.
4. Double-click to finish the line.

You can also

- Reshape the line by using control points
  Select the line by using the Shape tool, and reposition the control points to reshape the line.

- Float a control point
  Select the line by using the Shape tool, click a clamped control point, and click the Float control point button on the property bar.

- Clamp a control point
  Select the line by using the Shape tool, click a floating control point, and click the Clamp control point button on the property bar.

- Add a control point
  Select the line by using the Shape tool, and double-click along a control line.

- Delete a control point
  Select the line by using the Shape tool, and double-click the control point that you want to delete.

- Select multiple control points
  Select the line by using the Shape tool, and hold down Shift while you click on the control points that you want to select.

If you add to a B-spline by selecting the first or last control point, the clamped control point automatically changes to a floating control point as you draw the new portion of the line.

You can also add control points while you draw a B-spline by pressing Spacebar instead of clicking.

To draw a curve by using the 3-point curve tool

1. In the toolbox, click the 3-point curve tool.
2. Click where you want to start the curve, and drag to where you want the curve to end.
3. Release the mouse button, and click where you want the center of the curve to be.
You can also

Draw a circular curve
  Hold down Ctrl while dragging.

Draw a symmetrical curve
  Hold down Shift while dragging.

Curve samples from left to right: Free-form, circular, symmetrical.

To set options for the Freehand and Bézier tools
1. Click Tools ➤ Options ➤ Tools.
2. In the left pane of the dialog box that appears, click Freehand/Bézier.
3. Move the Freehand smoothing slider to set the default smoothness for curved lines.
   Higher values produce smoother curves.
4. Specify a value in any of the following boxes:
   • Corner threshold — to set the value at which a corner node changes from cusp to smooth
   • Straight line threshold — to set the amount by which a line can deviate from a straight path and still be treated as a straight line
   • Auto-join — to set how close two end nodes must be to join automatically, forming a closed curve

   Double-click the Freehand tool to display the Freehand/Bézier page in the Options dialog box.

To hide the bounding box when using curve tools
1. In the toolbox, click one of the following curve tools:
   • Freehand
   • 2-point line
   • Bézier
   • Artistic Media
   • Pen
   • B-Spline
   • Polyline
   • 3-point curve
2. Click the Bounding box button on the property bar.

   When you hide the bounding box while working with one curve tool, the bounding box remains hidden for all curve tools. For example, if you hide the bounding box when using the Freehand tool, it remains hidden when you switch to the Bézier tool.
You can also hide the bounding box by clicking **Tools** ▶ **Options** ▶ **CorelDRAW**, clicking **Display** and then enabling the **Hide bounding box for curve tools** check box.

**Parallel drawing**

The Parallel Drawing mode allows you to simultaneously draw multiple parallel curves while controlling the distance between them. In addition, you can set the distance between the original line and the parallel line by specifying a value or dragging in the document.

CorelDRAW lets you create single or multiple parallel lines and preview them as you draw. You can hide the preview if you want to focus on the original line. You can also add parallel lines to an existing line.

*From left to right: Parallel drawing with the 2-point Line tool, 3-Point Curve tool, and Pen tool*

*You can draw parallel curves simultaneously.*

The Parallel Drawing mode is available for the following tools:

- 2-Point Line
- Polyline
- 3-Point Curve
- Pen
- Bézier
- Freehand
- B-Spline
To draw parallel lines
1. Click a curve tool.
2. On the property bar, click the **Parallel Drawing** button.
3. On the **Parallel Drawing** toolbar, click the **Parallel lines** button.
   
   If you want to specify the number of parallel lines to be added, type a value in the **Number of lines** box.
4. Draw a line.

You can also

Add a parallel line to the left of the original line

On the toolbar, click the **Parallel lines on left** button.

Add a parallel line to the right of the original line

Click the **Parallel lines on right** button.

Specify the distance between the original line and the parallel line

Type a value in the **Distance** box.

You can also set the distance by clicking the **Set distance interactively** button, and dragging in the drawing window.

Hide the preview of parallel lines while drawing

Click the **Preview lines** button.

You can also display the **Parallel Drawing** toolbar by clicking **Window**  **Toolbars**  **Parallel Drawing**.

To add parallel lines to an existing line
1. Using the **Pick** tool, click a line.
2. On the property bar, click the **Parallel Drawing** button.
3. On the **Parallel Drawing** toolbar, specify the settings you want.
4. Click the **Create from selected** button.
Adding parallel curves to a selected curve

Parallel lines cannot be added to closed curves.

Calligraphic and preset lines

CorelDRAW lets you simulate the effect of a calligraphic pen when you draw lines. Calligraphic lines vary in thickness according to the direction of the line and the angle of the pen nib. By default, calligraphic lines appear as closed shapes drawn with a pencil. You can control the thickness of a calligraphic line by changing the angle of the line you draw in relation to the calligraphic angle you choose. For example, when the line you draw is perpendicular to the calligraphic angle, the line is at the maximum thickness specified by the pen width. Lines drawn at the calligraphic angle, however, have little or no thickness.

A calligraphic pen allows you to draw lines of various thicknesses.

CorelDRAW lets you create pressure-sensitive lines which vary in thickness. For more information, see “Brushstrokes and stylus input” on page 187.
A flower drawn by using three different artistic media lines: calligraphic lines (left), pressure-sensitive lines of variable thickness (center), and flat preset lines (right).

CorelDRAW provides preset lines that let you create thick strokes in a variety of shapes. After you draw a calligraphic or preset line, you can apply a fill to it as you would to any other object. For information about applying fills, see "Fills" on page 425.

To draw a calligraphic line
1. In the toolbox, click the Artistic media tool  
2. Click the Calligraphic button  on the property bar.
3. Type a value in the Calligraphic angle box on the property bar.
4. Drag until the line is the shape you want.

You can also
- Set the width of the line: Type a value in the Stroke width box on the property bar.
- Smooth the edges of the line: Type a value in the Freehand smoothing box on the property bar.
- Apply transformations to line thickness when scaling: Click the Scale stroke with object button on the property bar.

The width you set is the maximum line width. The angle of the line you draw in relation to the calligraphic angle determines the line's actual width.

To draw a preset line
1. In the toolbox, click the Artistic media tool  
2. Click the Preset button  on the property bar.
3. Choose a preset line from the Preset stroke list box.
4. Drag until the line is the shape you want.
You can also

Set the width of the line

Type a value in the **Stroke width** box on the property bar.

Smooth the edges of the line

Type a value in the **Freehand smoothing** box on the property bar.

Apply transformations to line thickness when scaling

Click the **Scale stroke with object** button on the property bar.

💡

You can also choose preset lines from the **Artistic Media** docker. You can open the **Artistic Media** docker by clicking **Effects > Artistic Media**.

**LiveSketch**

The **LiveSketch** tool offers the simplicity and speed of freehand sketching combined with intelligent stroke adjustment and vector drawing. As you sketch, CorelDRAW analyses the properties, temporal order, and spacial proximity of your **input strokes**, adjusts them, and converts them into Bézier curves.

Perfect for quick sketches and drawings, the **LiveSketch** tool speeds up your workflow and allows you to focus on the creation process. Instead of being preoccupied with nodes and handles and switching between tools, you can let your creativity flow and achieve the desired result quickly and effectively. There is no need to scan your sketches and trace them any more. You can sketch out your design concepts and ideas using vector curves right from the get-go.

![LiveSketch example](image)

*Whether you have great sketching skills or you are just learning to sketch, CorelDRAW can adjust your strokes and help you quickly move your ideas from imagination to reality. Artwork by Andrew Stacey.*

CorelDRAW supports the most common drawing styles: discrete overlapping strokes, folded strokes (scribbling back and forth across the surface, with lines doubling back on each other), chicken scratch (drawing short lines rapidly one after the other to build long lines and large forms).
To make the most of the **LiveSketch** tool, use a stylus and customize CorelDRAW to fit your sketching style.

You can specify the time it takes to activate stroke adjustment after you draw one or more strokes. For example, if you set the timer to one second and make a few strokes, stroke enhancement will take effect one second after you finish drawing the strokes. The timer creates a temporal window within which the discrete strokes that you make are analyzed and converted into curves. Experiment with the timer to find a setting that best matches your sketching speed and style. If you use multiple small strokes to build up a bigger line, set a short delay time to create your curves right away and develop a sketching cadence. Alternatively, increase the delay time to 5 seconds and take advantage of the live preview to see your input strokes and build upon them. Setting a longer delay period also gives you more time to manipulate your lines.

You can reset the timer and adjust the strokes before the specified time has elapsed. You can also delete strokes before they have been adjusted.

As your composition progresses, you may want to re-draw existing lines to change their position and shape or simply to refine them. CorelDRAW lets you modify existing curves by including them into your sketch as new input strokes. You can specify the width of the
editable area around previously drawn curves. When you sketch within this area, the existing curves are processed along with the other input strokes and are readjusted; when you sketch outside the specified distance, your input strokes are added as new objects.

An existing stroke (left); A new stroke (in blue) is created close to the existing curve (middle); The existing stroke is extended and readjusted (right.)

When you move the pointer inside the editable area of an existing curve, the curve is highlighted to indicate that you can modify it.

If you need to sketch very close to existing lines or draw over strokes to reinforce them, you can disable proximity-based stroke adjustment temporarily or permanently so that strokes are added as separate objects.

Disable proximity-based stroke grouping to keep your strokes as separate objects.

When you include an existing curve into a sketch, the resulting curve inherits the properties of the existing curve.
At times, you may need to define the entire extent of a shape or an object with a single curve. It can be difficult, however, to maintain smooth lines for a long distance or over a long curve without lifting the stylus off the tablet or releasing the mouse button. CorelDRAW can help you work with continuous lines by creating a seamless curve from strokes that you draw within the specified time interval.

Note that CorelDRAW processes only the input strokes that are within the specified delay time, so you may have to adjust the timer depending on your sketching speed.

As more and more of your sketch is laid down, and you start to improve the accuracy and appearance of the lines, you may need to erase existing curves or portions of curves. You can easily switch to erase mode by flipping the stylus (provided your stylus or pen has an eraser end) and then switch back to sketching mode by flipping the stylus again. Note that if a curve is selected, you erase only portions of that curve. If you want to erase any part of your drawing, make sure you deselect all objects before you use the stylus eraser. For information about deselecting objects, see “To deselect objects” on page 304. When your stylus doesn’t have an eraser end or you work with a mouse, you can erase curves with the **Eraser** tool. For more information about erasing Bézier curves, see “To erase an image area” on page 253.

By default, CorelDRAW shows a representation of the adjusted stroke while you are drawing. If you find the live preview too distracting, you can hide it.
In preview mode, CorelDRAW displays the adjusted stroke (in black) before the delay time has elapsed and the input strokes (in blue) have been processed.

You can control the amount of smoothing applied to curves.

To sketch with the LiveSketch tool
1 In the toolbox, click the LiveSketch tool.
2 Adjust any of the settings on the property bar.
3 Sketch in the document window.

You can also access the LiveSketch tool by pressing S on your keyboard.

To set a delay before input strokes are adjusted
• Move the Timer slider.

By default, the delay is 1000 milliseconds or 1 second. The minimum delay is 0 milliseconds; the maximum is 5 seconds. Clicking a different tool before the specified delay time has elapsed implements stroke adjustment.

Press Enter to reset the timer and adjust the strokes before the delay time has elapsed. Press Esc to delete an input stroke before it has been adjusted.

Setting a longer delay period gives you more time to manipulate your lines.

To readjust an existing curve
1 Click the Include curves toggle button on the property bar to enable it.
2 Move the Distance from curve slider to set the distance at which existing curves are included into a sketch as new input strokes.
3 Sketch over an existing stroke to modify it.

To disable proximity-based stroke adjustment temporarily, hold down Shift and make one or more strokes.
To disable proximity-based stroke enhancement permanently, click the Include curves button on the property bar.

By default, the distance threshold is 5 pixels. The minimum value is 0 pixels; the maximum is 40 pixels.

To create a single curve from strokes
1 Click the Create single curve button on the property bar to allow input strokes to be converted into one continuous line.
2 Sketch in the document window.

For best results, set a longer delay time. CorelDRAW processes only strokes that are within the specified delay time.

To erase a curve
1 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Erase an area in a drawing</td>
<td>Deselect all objects on the drawing page.</td>
</tr>
<tr>
<td>Erase portions of a curve</td>
<td>Select the curve.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: The last curve that you draw before you lift the stylus off the tablet is automatically selected by default.</td>
</tr>
</tbody>
</table>

2 Flip the stylus to automatically switch to erase mode, and stroke over the unwanted areas.

To erase a curve or portions of a curve when your stylus doesn’t have an eraser end or when using a mouse, select the curve, click the Eraser tool in the toolbox, and drag where you want to erase.

You can change the size and shape of the eraser nib. For information, see “To erase an image area” on page 253.

To show or hide a preview of the resulting curve
• Click the Preview mode button on the property bar.

To control curve smoothness
• Type a value in the Curve smoothing box on the property bar.

Higher values produce smoother curves.
Format lines and outlines

Lines are treated the same way as outlines of closed shapes, such as ellipses and polygons. In some programs, outlines are known as strokes or thick lines.

You can change the appearance of both lines and outlines by using the controls in the Outline section of the Properties docker, the Outline pen dialog box, and the property bar. For example, you can specify the color, width, and style of lines and outlines. The preset line styles available in CorelDRAW are solid or dashed.

Corners and ends

You can choose a corner style to control the corner shape in lines and a line cap style to change the appearance of a line’s endpoints.

With dashed lines and outlines, the Default dashes option applies the dashes along the line and outline without any adjustments in the corners and endpoints. However, you can control the appearance of dashes in the end and corner areas by using two additional options. The Align dashes option aligns dashes with the end and corner points so that there is no empty space in the corners and at the start and end of a line or outline. The Fixed dashes options creates dashes of fixed length in the end and corner points.

Miter limit

You can set the miter limit to determine the corner shape in objects containing lines that meet at sharp angles. Corners with angles above the miter limit are pointed (mitered); corners with angles below the miter limit are beveled (squared off).

Behind fill, Scale with object, and Overprint outline settings

By default, an outline is applied on top of an object’s fill, but you can apply it behind the fill, with the fill overlapping the outline. You can also link the outline thickness to an object’s size so that the outline increases when you increase the object’s size and decreases when you decrease the object’s size. In addition, you can set the outline to print on top of underlying colors, without removing them during printing.

Outline position

You can specify the position of the outline by placing it outside or inside the object, or centering it so that it overlaps equally the outside and the inside of an object. The effect of outline position options are more obvious with thick outlines.
Line styles and calligraphic outlines

You can create custom line styles, and you can edit the available preset line styles.

In addition, you can create calligraphic outlines. A calligraphic outline varies in thickness, creating the effect of a hand-made drawing.

Default line and outline properties

The default line and outline properties for each new object that you draw are as follows:

- black color
- solid line
- square corner and line cap styles
- centered outline
- no arrowheads applied
- outline applied on top of an object’s fill
- outline not linked to an object’s size.

However, you can change any of these default line and outline properties at any time.

Cuttable outlines

To create a cuttable outline for devices such as plotters, vinyl cutters and Print-Cut devices, you need to assign the appropriate predefined color name (usually CutContour) that is specified by the device manufacturer.

Note that cuttable outlines do not print when identified by the RIP or Print-Cut device. If you want to make the outlines printable, you can use the Object ▶ Shaping ▶ Boundary command. For more information, see “To create a boundary around selected objects” on page 315.

To change the color of a line or an outline

1. Select a line or an object that has an outline.
2. Right-click a color on the onscreen color palette.

To specify line and outline settings

1. Select an object.
2. Click Window ▶ Dockers ▶ Properties.
3. In the Outline section, type a value in the Width box.
   If the Outline section is not displayed, click Outline.
If you want to change the color, open the color picker, and click a color.

4  Choose a line style from the **Style** box.

**You can also**

Change the units of measurement for the outline width

Choose a unit of measurement from the **Outline units** box.

**Tip:** To save the units of measurement for the outline width as the defaults for new documents, click **Tools** ➤ **Save Settings as Default**, enable the **General** check box under **Document Preferences** in the **Save as New Document Defaults** dialog box, and click **Save**.

Set the shape of corners

Click one of the following buttons:

- **Mitered corners** — creates pointed corners
- **Round corners** — creates rounded corners
- **Beveled corners** — creates squared off corners

*Corners from left to right: Mitered, rounded, and beveled.*

Set the appearance of endpoints in open paths

Click one of the following buttons:

- **Square cap** — creates square end shapes
- **Round cap** — creates rounded end shapes
- **Extended square cap** — creates square end shapes that extend the length of the line

*Line caps from left to right: Square cap, Extended square cap, and Round cap.*

Control the corners and end points of dashed lines and outlines

Click one of the following buttons:

- **Align dashes** button — aligns the dashes with the end and corner points of lines and outlines
You can also

- **Fixed dashes** button — creates dashes of fixed length in the corners and ends. These dashes are half the length of the first dash in the dashed line pattern.

Tip: The **Default dashes** button, which is enabled by default, spreads evenly dashes along the line or outline without making any adjustments.

Dashed line options from top to bottom: Default dashes, Align dashes, and Fixed dashes.

Set the miter limit for lines that meet at sharp angles

Type a value in the **Miter limit** box.

Lines meet at the same sharp angle. Left: The angle exceeds the miter limit, creating a pointed corner. Right: The angle is below the miter limit, creating a beveled corner.

Specify the outline position

Click one of the following buttons:

- **Outside outline** — places the outline outside the object
- **Centered outline** — centers the outline along the object edge
- **Inside outline** — places the outline inside the object

Apply an outline behind an object’s fill

Enable the **Behind fill** check box.

If this check box is not displayed, click the arrow button at the bottom of the **Outline** section.
You can also

Apply an outline behind an object’s fill

Link the outline thickness to an object’s size

Enable the Scale with object check box.

If this check box is not displayed, click the arrow button at the bottom of the Outline section.

Set the outline to print on top of underlying colors during printing

Enable the Overprint outline check box.

If this check box is not displayed, click the arrow button at the bottom of the Outline section.

You can also specify line and outline settings in the Outline pen dialog box. To access the Outline pen dialog box, double-click the Outline icon on the status bar or press F12.

You can also change the outline width of a selected object by typing a value in the Outline width box on the property bar.

To create or edit a line style

1 Select an object.

2 In the Outline section of the Properties docker (Window  Dockers  Properties), perform a task from the following table.

To

Create a line style

Do the following

Click the Settings button and move the slider in the Edit line style dialog box. By clicking the boxes to the left of the slider, you
To do the following

- can specify the placement and frequency of the dots in the new line style you create. Click Add.

Choose a line style from the **Style** list box, and click the **Settings** button. Create a line style in the **Edit line style** dialog box, and click **Replace**.

---

**Edit a line style**

- **To create a calligraphic outline**
  1. Select an object.
  2. Click **Window** ➤ **Dockers** ➤ **Properties**.
  3. In the **Outline** section, click one of the following buttons to set the shape of corners:
     - Mitered corners
     - Round corners
     - Beveled corners
     
     If the **Outline** section is not displayed, click **Outline**.
  4. Type a value in the **Stretch** box to change the width of the pen’s nib.
     
     If the **Stretch** box is not displayed, click the arrow button at the bottom of the **Outline** section.
     
     The value range is from 1 to 100, with 100 as the default setting. Reducing the value makes square nibs rectangular and round nibs oval, creating a more pronounced calligraphic effect.
  5. Type a value in the **Tilt nib** box to change the orientation of the pen in relation to the drawing surface.
     
     To reset the **Stretch** and **Tilt nib** values to their original values, click the **Default** button.

- **To set the line and outline properties for new objects**
  1. Using the Pick tool, click on an empty space in the drawing window to deselect all objects.
  2. Double-click the **Outline** icon on the status bar.
  3. In the **Change document defaults** dialog box, enable the check boxes for the objects and text whose default settings you want to change, and click OK.
  4. Specify the settings you want in the **Outline pen** dialog box.

- **Add arrowheads to lines and curves**

  Arrowheads let you enhance the starting points and endpoints of lines and curves. You can specify the attributes of an arrowhead with precision. For example, you can define the exact size of an arrowhead as well as offset or rotate the arrowhead by a precise amount. You can also flip arrowheads vertically and horizontally. You can save your specified attributes as arrowhead presets for later use.
You can edit existing arrowhead presets, and you can create an arrowhead preset based on an existing one. You can also create an arrowhead preset based on an object such as a curve or a closed shape. When you no longer need an arrowhead preset, you can delete it.

To add an arrowhead
1 Select a line or curve.
2 Open the **Start arrowhead** picker on the property bar, and click a line-ending shape.
3 Open the **End arrowhead** picker, and click a line-ending shape.

You can remove an arrowhead by choosing the **No arrowhead** preset from the **Start arrowhead** or **End arrowhead** picker.

You can also add arrowheads from the **Outline pen** dialog box or the **Outline** section of the **Properties** docker.

To specify the arrowhead attributes of a line or curve
1 Using the **Pick tool**, select a line or curve that has an arrowhead.
2 Click **Window ➤ Dockers ➤ Properties**.
3 In the **Outline** section, click the **Arrowhead settings** button next to the **Start arrowhead** picker or the **End arrowhead** picker, and click **Attributes**.
   If the **Outline** section is not displayed, click **Outline**. If the **Arrowhead settings** button is not displayed, click the arrow at the bottom of the **Outline** section.
   If you want starting and ending arrowheads to have the same size, offset, rotation angle, and orientation, enable the **Share attributes** check box.
4 In the **Arrowhead attributes** dialog box, perform any of the tasks in the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the size of an arrowhead</td>
<td>In the <strong>Size</strong> area, type a value in the <strong>Length</strong> or <strong>Width</strong> box.</td>
</tr>
<tr>
<td></td>
<td>If you want to create a nonproportional arrowhead, disable the <strong>Proportional</strong> check box.</td>
</tr>
<tr>
<td>Offset an arrowhead</td>
<td>In the <strong>Offset</strong> area, type values in the <strong>X</strong> and <strong>Y</strong> boxes.</td>
</tr>
</tbody>
</table>
To

Mirror an arrowhead

In the Mirror area, enable the Horizontally or Vertically check box.

Rotate an arrowhead

Specify an angle in the Rotation box.

Save custom arrowhead attributes as an arrowhead preset

Enable the Save as arrowhead preset check box.

You can access the new arrowhead preset from the Start arrowhead and End arrowhead pickers on the property bar.

You can switch arrowheads from one end of a line or curve to another by clicking the Arrowhead settings button, and clicking Swap.

You can remove an arrowhead from a line or curve by clicking the Arrowhead settings button and clicking None.

To edit an arrowhead preset

1. Using the Pick tool, select an object that has an arrowhead.
2. Click Window ➤ Dockers ➤ Properties.
3. In the Outline section, click the Arrowhead settings button next to the Start arrowhead picker or the End arrowhead picker, and click Edit.
   If the Outline section is not displayed, click Outline. If the Start arrowhead picker is not displayed, click the arrow at the bottom of the Outline section.
4. In the Arrowhead attributes dialog box, specify the attributes you want.

You can create an arrowhead preset that is based on an existing preset. Click Arrowhead settings button, and click New. Then, specify the attributes you want in the Arrowhead attributes dialog box, and type a preset name in the Save arrowhead area.

To delete an arrowhead preset, select the preset from the Start or End arrowhead picker, click the Arrowhead settings button, and click Delete.

To create an arrowhead preset from an object

1. Select an object to use as an arrowhead.
2. Click Object ➤ Create ➤ Arrowhead.
3. In the Create arrowhead dialog box, type a value in the Length box or Width box.
   If you want to create a nonproportional arrowhead, disable the Proportional check box, and type values in both the Length and Width boxes.

Variable outlines

You can vary the width of object outlines to create dynamic, organic-looking lines and shapes.
You can apply an outline of varying widths using the Variable Outline tool.

First you add a variable outline node to an outline. Next you select the variable outline node, and a selection handle with arrowhead ends displays perpendicularly to the dashed line, which represents the outline, to help you manipulate the width. Then you can adjust outline width by dragging an arrowhead on either side of the handle. You can modify outline width symmetrically or asymmetrically.

You can copy variable outline properties from one object to another. You can also modify an outline without affecting its variable outline properties.

To vary the width of an outline
1 In the toolbox, click the Variable Outline tool.
2 Click an object.
   A dashed line appears along the outline.
3 Double-click the dashed line where you want the width variance to start.
   A variable outline node with arrowheads is added to the outline.
4 Do one of the following:
   • Drag an arrowhead on either side of the node to adjust the outline width symmetrically.
   • Hold down **Shift** and drag an arrowhead to adjust the outline width asymmetrically.

You can also

**Adjust outline width precisely**
Select a variable outline node, and type values in the **Side 1** and **Side 2** boxes on the property bar. To adjust width symmetrically, click the **Lock Ratio** button on the property bar.

The maximum outline width on a side is 450 points. The total width of the variable outline is displayed in the **Total** box on the property bar.

**Adjust multiple nodes simultaneously**
Hold down **Ctrl**, click the variable outline nodes you want to adjust, and drag any arrowhead.

To select consecutive nodes, hold down **Shift**, click the first node, and then click the last node that you want to select.
You can also

Copy variable outline properties from one object to another
Using the Variable Outline tool, click the object to which you want to apply a variable outline. Click the Copy Variable Outline button on the property bar, and click the object whose properties you want to copy.

Reposition a node on an outline
Drag the node to a new position on the dashed line.

Note: A variable outline node cannot be dragged over another variable outline node.

Tips:
- You can reposition a variable outline node by dragging the node in the Variable Outline slider on the Properties docker (Window ➔ Dockers ➔ Properties).
- You can also reposition a variable outline node by entering a percentage in the Position box on the Properties docker. Node position is relative to the start of a line (from left to right) or a closed curve (clockwise).

Scale a variable outline when scaling an object’s outline
Click the Scale width with Stroke button on the property bar.

Delete a variable outline node
Double-click the variable outline node.

Remove all variable outline nodes from an outline
Select the outline with the Variable Outline tool, and click Clear Nodes on the property bar.

When a drawing containing a variable outline is opened in a version of CorelDRAW earlier than 24.3, the variable outline is treated like a filled object.

The colors of the dashed line are based on the main and secondary colors used for nodes and handles. For information about changing these colors, see “To create a custom color scheme for nodes, handles, and previews” on page 271.

You can also access the Variable Outline tool by pressing V on your keyboard.

You can also access variable outline settings in the Outline pen dialog box. To access the Outline pen dialog box, double-click the Outline icon on the status bar or press F12.

You can also add a variable outline node by clicking an outline with the Variable Outline tool where you want to add the node and clicking the Add node button on the property bar. To remove a node, select it and click the Remove node button on the property bar.

Copy, convert, remove, and replace outlines
CorelDRAW lets you copy outline properties to other objects.
You can also convert an outline to an object, and you can remove an outline. Converting an outline to an object creates an unfilled closed object with the outline’s shape. You can apply fills and special effects to the new object. You can search for objects based on their outline width and color and replace those properties.

To copy outline properties to another object

1. Using the Pick tool, select the object that has the outline you want to copy.

2. With the right mouse button, drag the source object over the target object, to which you want to apply the outline. A blue outline of the original object follows the pointer to the new object.

3. When the pointer changes to a crosshair pointer, release the mouse button, and choose Copy outline here from the context menu.

You can also use the Attributes eyedropper tool to copy outline properties. For more information, see “To copy fill, outline, or text properties from one object to another” on page 324.

You can also sample the color of an existing object and apply the sampled color to the outline of another object. For more information, see “To sample a color” on page 411.

To convert an outline to an object

1. Select an object.

2. Click Object > Convert outline to object.

The outline becomes an unfilled closed object independent of the original object’s fill. If you want to apply a fill to the new object, the fill is applied to the area, which was the original object’s outline.

A star with an outline applied (left); the outline has been converted to an object independent of the original fill (center); a fountain fill was applied to the new closed object.

You can also convert an outline to an object by pressing Ctrl + Shift + Q.

To remove the outline of an object

1. Select an object.

2. On the property bar, choose None from the Outline width list box.
You can also remove an object’s outline by selecting the object and right-clicking the No color swatch on the color palette.

To find and replace outline widths
1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3. Enable the Outline properties option.
4. Enable the Outline width check box in the Find area.
5. Specify the outline width to find.
6. Enable the Outline width check box in the Replace area, and specify the replacement outline width.
7. Click Find, and click any of the following:
   - Find Next > or Find Previous < to scroll through objects that meet the outline-search criteria.
   - Find All or Find All on Page to select all objects on the active page that meet the outline-search criteria.
   - Replace to replace the outline of the selected object.
   - Replace All to replace all outlines that meet the outline-search criteria.

You can also

Find and replace outline-scaling settings
- Enable the Scale outline with image check box in the Find area, and specify the setting to find. Then, enable the Scale outline with image check box in the Replace area, and specify the replacement setting.

Find and replace outline-overprint settings
- Enable the Outline overprint check box in the Find area, and specify the setting to find. Then, enable the Outline overprint check box in the Replace area, and specify the replacement setting.

To find and replace outline colors
1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3. Enable the Color option.
4. In the Find area, choose the color to find from the color picker.
5. In the Replace area, choose the replacement color from the color picker.
6. In the Apply to area, enable the Outlines check box.
7. Click Find, and click any of the following:
   - Find Next > or Find Previous < to scroll through objects that meet the outline-search criteria.
   - Find All or Find All on Page to select all objects on the active page that meet the outline-search criteria.
   - Replace to replace the outline color of the selected object.
   - Replace All to replace the color of all outlines that meet the outline-search criteria.
Brushstrokes

CorelDRAW lets you apply a variety of preset brushstrokes, ranging from strokes with arrowheads to ones that are filled with rainbow patterns. When you draw a preset brushstroke, you can specify some of its attributes. For example, you can change the width of a brushstroke and specify its smoothness.

You can also create custom brushstrokes by using an object or a group of vector objects. When you create a custom brushstroke, you can save it as a preset.

To apply a preset brushstroke
1  In the toolbox, click the Artistic media tool.
2  Click the Brush button on the property bar.
3  Choose a brush category from the Category list box.
4  Choose a brushstroke from the Brushstroke list box.
5  Drag until the stroke is the shape you want.

You can also

Set the width of the brushstroke  
Type a value in the Stroke width box on the property bar.

Smooth the edges of the brushstroke  
Type a value in the Freehand smoothing box on the property bar.

Apply transformations to brushstroke thickness when scaling  
Click the Scale stroke with object button on the property bar.

If you have access to a brushstroke that isn’t listed in the Brushstroke list box, you can apply it by clicking the Browse button on the property bar and locating the brushstroke file.

You can also choose brushstrokes from the Artistic Media docker. You can open the Artistic Media docker by clicking Effects Artistic Media.

To create a custom brushstroke
1  Select an object or a set of grouped objects.
2 In the toolbox, click the Artistic media tool.
3 Click the Brush button on the property bar.
4 Click the object or grouped objects.
5 Click the Save artistic media stroke button on the property bar.
6 Type a filename for the brushstroke.
7 Click Save.

Custom brushstrokes can be accessed from the property bar by choosing Custom from the Category list box. The custom brushstrokes display in the Brushstroke list box.

To delete a custom brushstroke, choose Custom from the Category list box on the property bar, choose the brushstroke from the Brushstroke list box, and click the Delete button.

Brushstrokes and stylus input

You can apply brushstrokes that respond to pen pressure, tilt, and bearing provided your stylus or pen supports these features. Pen pressure lets you vary the size of the brush nib. Pen tilt lets you vary the flatness of the brush nib, and pen bearing lets you vary the rotation of the brush nib.

You can use pen pressure, tilt, and bearing at the same time, or you can use only one or two of these features. For example, you can use pen pressure to vary the size of the brush nib, but disable pen tilt so that the flatness of the brush nib does not change. You can set a fixed value for pen tilt to flatten the nib. Disabling pen pressure lets you set a fixed nib size. Disabling pen bearing lets you use a nib of fixed rotation.

To apply a brushstroke that responds to pen pressure, tilt, and bearing
1 In the toolbox, click the Artistic media tool.
2 Click the Expression button on the property bar.
3 Make sure the following buttons on the property bar are enabled:
   • Pen pressure — lets you vary the size of the brush nib. If you are using the mouse, press the Up arrow or Down arrow to simulate changes in pen pressure and change the width of the stroke.
• **Pen tilt** — lets you vary the flatness of the nib

• **Pen bearing** — lets you vary the rotation of the brush nib

4 Drag until the stroke is the shape you want.

You can also

**Change the width of the stroke**
Type a value in the **Stroke width** box on the property bar.

**Change the stroke width when scaling the object**
Click the **Scale stroke with object** button on the property bar.

---

The width you set represents the stroke’s maximum width. The amount of pressure you apply determines the actual size of the brush nib.

You can use pen tilt and pen bearing to vary brushstrokes only if your stylus or pen supports these features.

**To use a brush nib of fixed width, flatness, or rotation**

1 In the toolbox, click the **Artistic media** tool.

2 Click the **Expression** button on the property bar.

3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the size of the brush nib</td>
<td>Click the <strong>Pen pressure</strong> button on the property bar to disable it. Type a value in the <strong>Stroke width</strong> box.</td>
</tr>
<tr>
<td>Flatten the brush nib by using a fixed value for pen tilt</td>
<td>Click the <strong>Pen tilt</strong> button on the property bar to disable it. Type a value in the <strong>Tilt angle</strong> box. Use a value between 15 and 90 degrees.</td>
</tr>
<tr>
<td>Rotate the brush nib by using a fixed value for pen bearing</td>
<td>Click the <strong>Pen bearing</strong> button on the property bar to disable it. Type a value in the <strong>Bearing angle</strong> box.</td>
</tr>
</tbody>
</table>

**Spray objects along a line**

CorelDRAW lets you spray a series of objects in a line. Besides graphic and text objects, you can import bitmaps and **symbols** to spray along a line.

You can control how a sprayed line appears by adjusting the spacing between objects, so they are closer or farther apart from each other. You can also vary the order of objects in the line. For example, if you are spraying a series of objects that includes a star, a triangle, and a square, you can change the spray order so that the square appears first, followed by the triangle and then the star. CorelDRAW also lets you shift the position of objects in a sprayed line by rotating them along the path or offsetting them in one of four different directions: alternating, left, random, or right. For example, you can choose a left offset direction to align the objects you spray to the left of the path.
You can also create a new spray pattern with objects of your own.

Objects sprayed along a curved line (left). The objects and line were edited after the objects were sprayed (right).

To spray a pattern

1. In the toolbox, click the Artistic media tool.
2. Click the Sprayer button on the property bar.
3. Choose a spray pattern category from the Category list box on the property bar.
4. Choose a spray pattern from the Spray pattern list box on the property bar.
5. Drag to draw the line.

You can also

- Adjust the number of objects sprayed at each spacing point. Type a number in the top box of the Images per dab and image spacing box on the property bar.
- Adjust the spacing between dabs. Type a number in the bottom box of the Images per dab and image spacing box on the property bar.
- Set the spray order. Choose a spray order from the Spray order list box on the property bar.
- Adjust the size of spray objects. Type a number in the top box of the Size of sprayed objects box on the property bar.
- Increase or decrease the size of the spray objects as they progress along the line. Type a number in the bottom box of the Size of sprayed objects box on the property bar.
- Apply transformations to spray line thickness when scaling. Click the Scale stroke with object button on the property bar.
Increasing the value for the size of spray objects along the line causes objects to become larger as they are distributed along the path. Spray patterns that have more complex objects use more system resources. CorelDRAW requires more time to produce lines when complex objects are used, and these objects increase the file size. Using symbols for each group in the list can help reduce file size and ease the demands on your system. For more information about creating symbols, see “Symbols” on page 383.

You can also choose spray patterns from the Artistic Media docker. You can open the Artistic Media docker by clicking Effects → Artistic Media.

To rotate the lines that you spray
1. Select the spray pattern that you want to adjust.
2. Click the Rotation button on the property bar.
3. Type a value between 0 and 360 in the Angle box on the property bar.
   If you want each object in the spray to rotate incrementally, enable the Use Increment check box and type a value in the Increment box.
4. Enable one of the following options:
   • Relative to path — rotates objects in relation to the line
   • Relative to page — rotates objects in relation to the page
5. Press Enter.

To offset the lines that you spray
1. Select a spray pattern.
2. Click the Offset button on the property bar.
3. Enable the Use offset check box to offset objects from the path of the line sprayed.
   If you want to adjust the offset distance, type a new value in the Offset box.
4. Choose an offset direction from the Offset direction list box.
   If you want to alternate between the left and right of the line, choose Alternating.

To create a new spray pattern
1. Click Effects → Artistic Media.
2. Select an object, a set of grouped objects, or a symbol.
3. Click the Save button on the Artistic Media docker.
4. Enable Object sprayer.
5. Click OK.
6. Type a filename in the File name box.
7. Click Save.

Spray patterns are saved as CorelDRAW (CDR) files and can be accessed by choosing Custom from the Category list box on the Artistic media property bar, and choosing a spray pattern from the Spray pattern list box.
To delete a custom spray pattern, select the spray pattern from the Spray pattern list box on the property bar, and click the Delete button.

Connector and callout lines

You can draw connector lines between objects. Objects stay connected by these lines even when you move one or both objects. Connector lines, which are also known as “flow lines”, are used in technical drawings such as diagrams, flowcharts, and schematics. For information about drawing flowchart shapes, see “Predefined shapes” on page 209.

There are three types of connector lines that you can draw. You can draw a straight connector line. You can also draw right-angle connector lines with a sharp corner or a rounded corner. You can edit connector lines by moving, adding, or deleting segments.

Using the controls on the property bar, you can modify the width and style of a connector line as well as apply arrowheads. For more information, see “Format lines and outlines” on page 174. You can also change the color of connector lines.

You can choose default settings for connector lines such as snapping points and distance from the objects they are connecting.

When you move objects, their connector lines remain attached.

You can draw callout lines that label and draw attention to objects.

To use connector and callout lines with precision, you need to snap them to specific nodes in objects. For more information about snapping and snapping modes, see “Snap objects” on page 333.

Connector lines and objects attached to connector lines cannot be brought into Focus mode. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.
To draw a connector line between two or more objects
1. In the toolbox, click the Connector tool button, and then on the property bar click one of the following:
   - Straight-line connector tool — to create a straight connector line at any angle
   - Right-angle connector tool — to create a connector line containing vertical and horizontal segments at right angles
   - Rounded right-angle connector tool — to create a connector line containing vertical and horizontal elements at rounded right angles
2. Drag from a node on one object to a node on another object.

You can also

Move a horizontal segment in an angled connector line
Using the Shape tool, select a connector line, and drag the middle node on the segment that you want to move.

Move an end point of an angled connector line
Using the Shape tool, drag an end node along the edge of the object.

Add a segment in an angled connector line
Using the Shape tool, drag a corner node.

Delete a segment in an angled connector line
Using the Shape tool, drag a corner node over the closest corner node.

To change the direction of a connection line
1. In the toolbox, click the Anchor editing tool.
2. Click the anchor point from which you want to change the connector line direction.
3. On the property bar, click the Adjust anchor direction button.
4. In the Adjust anchor direction box, type one of the following values:
   - 0 — directs the connector line to the right
   - 90 — directs the connector line straight up
   - 180 — directs the connector line to the left
   - 270 — directs the connector line straight down

You can change the direction of only right-angle connector lines.

To add an anchor point to an object
1. In the toolbox, click the Anchor editing tool.
2. Double-click anywhere on an object to add the anchor point.
By default, anchor points that you add to an object are not available as snap points for a connector line when the object is moved around in the drawing. To make an anchor point available as a snap point, select it with the Anchor editing tool, and click the Auto anchor button on the property bar.

By default, the position of the anchor point is calculated relative to its position on the page. You can set the anchor point position relative to the object that it is attached to, which is useful if you want to set anchor points in the same relative position in multiple objects. To set the anchor point position relative to the object, select the anchor point with the Anchor editing tool. On the property bar, click the Relative to object button, and type the coordinates in the Anchor position box.

To move or delete an anchor point

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the anchor anywhere along the perimeter of an object</td>
<td>Using the Anchor editing tool, drag the anchor point to another point on the perimeter.</td>
</tr>
<tr>
<td>Move the anchor to the middle of an object</td>
<td>Drag the anchor point to any point inside the object.</td>
</tr>
<tr>
<td>Delete an anchor</td>
<td>On the property bar, click the Delete anchor button.</td>
</tr>
</tbody>
</table>

To set a connector line to flow around objects

1. Using the Pick tool, select the object to which the connector line is attached.
2. Click Window → Dockers → Properties.
3. In the Properties docker, click Summary to display additional options.
4. Enable the Wrap connector line check box.

To flow around an object, a connector line must be attached to the object by at least one end.

To add a text label to a connector line

1. In the toolbox, click the Connector tool button, and then on the property bar click one of the following:
   - Straight-line connector tool
   - Right-angle connector tool
   - Rounded right-angle connector tool
2. Double-click the connector line.
   A text cursor appears.
3. Type the text.

As you move the connector line, the text label remains attached to it.
To choose default settings for connector lines

1. Click Tools ➤ Options ➤ Tools.
2. In the left pane of the dialog box that appears, click Connector.
3. To limit snapping and attaching connector lines to only anchor points in objects, disable the Use geometric anchor points as snapping points check box. When this check box is enabled, you can snap and attach connector lines to edge nodes, center nodes and other geometric points in an object.
4. To increase or decrease the distance between connector lines and objects, type a higher or lower value in the Route distance from object box. This setting doesn’t apply to straight connector lines.

To draw a callout

1. In the toolbox, click the 2-Leg callout tool.
   The 2-Leg callout tool is located on the Dimension tools flyout.
2. Click where you want the first callout segment to start, and drag to where you want the first segment to end.
3. Click where you want the second segment to end.
   A text cursor is displayed at the end of the callout line, indicating where to type a label for the object.
4. Type the callout text.

You can also

- Change the callout shape
  Choose a shape from the Callout shape box on the property bar.
- Change the distance between the text and the callout shape
  Type a value in the Gap box.

💡 If you want to edit the callout line and callout text independently of each other, as a line and a text object, you must first separate the callout line from the callout text by clicking Object ➤ Break callout apart.

Dimension lines

You can draw dimension lines to indicate the distance between two points in a drawing or the size of objects. You can add several types of dimension lines:
- **Parallel dimension lines** measure the actual distance between two nodes.
- **Vertical or horizontal dimension lines** measure the vertical (y-axis) or horizontal (x-axis) distance between any two nodes.
- **Angular dimension lines** measure angles.
- **Segment dimension lines** measure the linear distance between the end nodes of a segment, or the linear distance between the two most distant nodes in multiple segments. Segment dimension lines can also measure selected successive segments.
You can set how dimension text and lines are displayed. For example, you can choose the unit of measurement, specify the position and font of the dimension units, and add a prefix or suffix to dimension text. You can also set default values for all new dimension lines that you create.

You can customize the extension lines on which dimension lines rest. You can specify the distance between the extension lines and the object that is measured, and the length of the extension overhang. Extension overhang is the portion of the extension line that falls beyond the dimension arrows.

By default, dimension text is dynamic. If you resize the object to which a dimension line is attached, the dimension text is updated automatically to display the new size. You can make the dimension text static, however, if necessary.

To be able to use dimension lines with precision, you need to snap them to specific nodes in objects. For more information about snapping and snapping modes, see “Snap objects” on page 333.

Dimension lines cannot be brought into Focus mode, but you can bring dimension text into focus. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To draw a vertical, horizontal, or parallel dimension line

1 Do one of the following:
   • To draw a parallel dimension line, click the Parallel dimension tool in the toolbox.
   • To draw a vertical or horizontal dimension line, click the Horizontal or vertical dimension tool.

2 Click to place the starting point, and drag to where you want to place the endpoint of the dimension line.
3 Move the pointer to position the dimension line, and click to place the dimension text.
   By default, dimension text is centered on the dimension line.

To draw an angular dimension line
1 In the toolbox, click the Angular dimension tool △.
2 Click where you want the two lines that measure the angle to intersect, and drag to where you want the first line to end.
3 Click where you want the second line to end.
4 Click where you want the angle label to appear.

To draw a segment dimension line
1 In the toolbox, click the Segment dimension tool □.
2 Click the segment that you want to measure.
3 Move the pointer to where you want to position the dimension line, and click where you want to place the dimension text.

You can also

Measure the distance between the two most distant nodes in multiple segments

Using the Segment dimension tool □, marquee select the segments, drag to position the dimension line, and click where you want to place the dimension text.

Measure successive segments automatically

Click the Automatic successive dimensioning button △ on the property bar, and marquee select the segments that you want to measure. Drag to position the dimension line, and click where you want to place the dimension text.

Segment dimension lines can be applied automatically to selected successive segments.

To set the display of dimension units
1 Select a dimension line.
2 On the property bar, choose options from the following list boxes:
   • Dimension style — lets you choose fractional, decimal or standard dimension units
   • Dimension precision — lets you choose a level of precision for the measurements
   • Dimension units — lets you choose the unit of measurement
You can also

Hide dimension units
Click the Display units button  on the property bar.

Specify the position of dimension units
Click the Text position button  on the property bar, and click a text position.

Change the point size and font of dimension units
Select the dimension text by using the Pick tool . On the property bar, choose a font style from the Font list box, and type a value in the Font size box.

Specify a prefix or suffix for dimension text
Type a prefix or suffix in the Prefix or Suffix box on the property bar.

Hide or show a leading zero with a dimension value
Click the Leading zero button  on the property bar. (The leading zero appears in dimension lines by default.)

Make dimension text static
Click the Dynamic dimensioning button .

Most dimension line controls on the property bar become unavailable. If you change the size of the object to which the dimension line is attached, the dimension line text is not updated.

To set default properties for new dimension lines
1 Click Tools Options Tools.
2 In the left pane of the dialog box that appears, click one of the following:
   • Angular Dimension - to set default properties for angular dimension lines
   • Dimension - to set default properties for all other dimension lines
3 Specify the dimension style, precision, and units, prefix, and suffix.
The dimension style control is not available for angular dimension lines.

To customize extension lines
1 Select a dimension line.
2 On the property bar, click the Extension lines options button .
3 To specify the distance between the extension lines and the object, enable the Distance from object check box, and type a value in the Distance box.
4 To specify the length of the extension overhang, enable the Extension overhang check box, and type a value in the Distance box.

Pressure-sensitive pens and devices
The following tools in CorelDRAW let you use the pressure of your pressure-sensitive pen, stylus, or other device: Artistic Media (Expression mode), Eraser, Smear, Twirl, Attract and Repel, Roughen, and Smudge.

In addition, you can vary brushstrokes by using pen tilt and pen bearing with the Artistic Media (Expression mode) tool, Eraser, Roughen and Smudge tools. Note that pen tilt and pen bearing can be used only if your pen or stylus supports these features.
Pressure and pen settings

When you use a pressure-sensitive stylus or pen tablet with CorelDRAW, the amount of pressure that you apply controls the width of your strokes. Each person uses a different strength or pressure level in a stroke, and you can set the application to match your stroke strength by specifying pen settings. Proper pen settings are particularly useful if you have a light touch. If a light stroke leaves no trace, adjusting pen settings can increase sensitivity for specific tools. Abrupt changes in the width your brushstrokes shows that you need to adjust your pen settings on the Pen Settings page in the Options dialog box. Pen settings can be saved as presets to use later.

Tilt and bearing

Pen tilt lets you vary the flatness of the nib. If you do not want nib flatness to vary, you can disable pen tilt, and specify a fixed value for tilt angle to determine the nib flatness. Pen bearing lets you use the direction in which the stylus is tilted to vary nib rotation. You can disable pen bearing, and set a fixed value for the bearing angle to rotate the nib.

To adjust pen settings

1. Click Tools ▶ Options ▶ CorelDRAW.
2. In the left pane of the dialog box that appears, click Pen Settings.
3. Using your stylus or digital pen, apply at least three strokes, building from the lowest to the highest pressure.
   To save the settings as a preset, click Save.

To choose a pen tablet interface

1. Click Tools ▶ Options ▶ CorelDRAW.
2. In the left pane of the dialog box that appears, click Pen Settings.
Choose one of the following tablet options:

- **WinTab** — recommended for Wacom-compatible pen tablets or devices
- **Real-Time Stylus** — recommended for pen tablets or devices that use the RTS interface
Shapes

CorelDRAW lets you draw basic shapes, which you can modify by using special effects and reshaping tools.

In this section, you’ll learn about

• “Rectangles and squares” (page 201)
• “Ellipses, circles, arcs, and pie shapes” (page 204)
• “Polygons and stars” (page 206)
• “Spirals” (page 208)
• “Grids” (page 208)
• “Predefined shapes” (page 209)
• “Use shape recognition” (page 210)

You can also draw shapes with precision by using object coordinates. For more information, see “Use object coordinates to draw and modify objects” on page 316.

Rectangles and squares

CorelDRAW lets you draw rectangles and squares. You can draw a rectangle or square by dragging diagonally with the Rectangle tool or by specifying the width and height with the 3-point rectangle tool. The 3-point rectangle tool lets you quickly draw rectangles at an angle.

You can create a 3-point rectangle by first drawing its baseline and then drawing its height. The resulting rectangle is angled.

You can also draw a rectangle or square with rounded, scalloped or chamfered corners. You can modify each corner individually or apply the changes to all corners. In addition, you can specify that all corners scale relative to the object. You can also specify the default corner size for drawing rectangles and squares.
Understanding rounded, scalloped, and chamfered corners

Rounding produces a curved corner, scalloping replaces the corner with an edge that has a curved notch, and chamfering replaces the corner with a straight edge, also known as a bevel.

From left to right, you can see standard corners with no changes, rounded corners, scalloped corners, and chamfered corners.

To draw rectangles or squares with rounded, scalloped, or chamfered corners, you need to specify the corner size. For rounding or scalloping a corner, the corner size determines the corner radius. The radius is measured from the curve’s center to its perimeter. Higher corner size values produce more rounded corners or deep scalloped corners.

From left to right, you can see the radius of a rounded corner and the radius of a scalloped corner.

The size value for chamfering a corner represents the distance to set where the chamfer will begin in relation to the original corner. Higher corner size values produce a longer chamfered edge.

For more information about modifying the corners of curve objects, such as lines, text, or bitmaps, see “Fillet, scallop, and chamfer corners” on page 260.

To draw a rectangle or square by dragging diagonally

To | Do the following
---|---
Draw a rectangle | In the toolbox, click the Rectangle tool \( \text{Rectangle} \) \( \text{Rect} \). Drag in the drawing window until the rectangle is the size you want.

Draw a square | In the toolbox, click the Rectangle tool \( \text{Rectangle} \) \( \text{Rect} \). Hold down Ctrl, and drag in the drawing window until the square is the size you want.
You can draw a rectangle from its center outward by holding down Shift as you drag. You can also draw a square from its center outward by holding down Shift + Ctrl as you drag.

You can draw a rectangle that covers the drawing page by double-clicking the Rectangle tool.

To draw a rectangle by specifying height and width
1 In the toolbox, click the 3-point rectangle tool.
2 In the drawing window, point to where you want to start the rectangle, drag to draw the width, and release the mouse button.
3 Move the pointer to draw the height, and click.

To adjust the size of the rectangle, type values in the Object size boxes on the property bar.

To constrain the angle of the baseline to a preset increment, known as constrain angle, hold down Ctrl as you drag. For information about changing the constrain angle, see “To change the constrain angle” on page 363.

To draw a rectangle or square with rounded, scalloped, or chamfered corners
1 Click a rectangle or square.
2 Click one of the following buttons on the property bar:
   - Round corner — produces a curved corner
   - Scalloped corner — replaces a corner with an edge that has a curved notch
   - Chamfered corner — replaces a corner with a flat edge
3 Type values in the Corner radius areas on the property bar.
4 Click Apply.

You can also

Apply the same changes to all corners
Click the Edit corners together button on the property bar.

Disable the scaling of corners relative to the object
Click the Relative corner scaling button on the property bar.

You can also modify the corners of a selected rectangle or square by clicking the Shape tool, clicking a corner option button on the property bar, then dragging a corner node toward the shape’s center. If you prefer to modify only one corner, hold down Ctrl, then drag a corner node toward the shape’s center.

To specify the default corner shape and size for drawing rectangles and squares
1 Click Tools ► Options ► Tools.
2 In the left pane of the dialog box that appears, click Rectangle.
3 To specify the default corner shape (round, scalloped, or chamfered), click one of the buttons at the top of the right pane.
4 In the Corners area, type values in the boxes.
You can also

Apply the same changes to all corners

Click the Edit corners together button.

Scale corners relative to the object size

Enable the Scale corners check box.

Ellipses, circles, arcs, and pie shapes

You can draw an ellipse or circle by dragging diagonally with the Ellipse tool, or you can draw an ellipse by using the 3-point ellipse tool to specify its width and height. The 3-point ellipse tool lets you quickly create an ellipse at an angle, eliminating the need to rotate the ellipse.

Using the Ellipse tool, you can draw a new arc or pie shape, or you can draw an ellipse or circle and then change it to an arc or a pie shape. You can also change the default properties of new objects that are drawn with the Ellipse tool. For example, you can set the default properties so that all new shapes you draw are arcs or pie shapes.

To draw an ellipse or a circle by dragging diagonally

To

Draw an ellipse

In the toolbox, click the Ellipse tool. Drag in the drawing window until the ellipse is the shape you want.

Draw a circle

In the toolbox, click the Ellipse tool. Hold down Ctrl, and drag in the drawing window until the circle is the size you want.

You can draw an ellipse or a circle from its center outward by holding down Shift as you drag.

To draw an ellipse by specifying width and height

1 In the toolbox, click the 3-point ellipse tool.

2 In the drawing window, drag to draw the centerline of the ellipse at the angle you want. The centerline runs through the center of the ellipse and determines its width.

3 Move the pointer to define the height of the ellipse, and click.
To draw an arc or a pie shape

To

Draw an arc

Do the following

In the toolbox, click the Ellipse tool. Click the Arc button on the property bar. Drag in the drawing window until the arc is the shape you want.

Draw a pie shape

In the toolbox, click the Ellipse tool. Click the Pie button on the property bar. Drag in the drawing window until the pie is the shape you want.

To draw an arc, the ellipse or circle must have an outline.

You can change the direction of a selected arc or pie shape by clicking the Change direction button on the property bar.

You can constrain the movement of the node to 15-degree increments by holding down Ctrl as you drag.

To change the default properties for new objects drawn with the Ellipse tool

1. Click Tools ➔ Options ➔ Tools.
2. In the left pane of the dialog box that appears, click Ellipse.
3. To change the shape of new objects to arcs or pie shapes, enable one of the following options:
   • Pie
   • Arc
4. Type values in the Starting angle and Ending angle boxes.
5. To set the direction of all new arcs or pie shapes, enable one of the following options:
   • Clockwise
   • Counterclockwise

To use the Shape tool to create a pie shape, drag the node of the ellipse (left) to the inside of the ellipse (center). To create an arc, drag the node to the outside of the ellipse (right).
Polygons and stars

CorelDRAW lets you draw polygons and two types of stars: perfect and complex. Perfect stars are traditional-looking stars and can have a fill applied to the entire star shape. Complex stars have intersecting sides and produce original results with a fill applied.

Left to right: Polygon, perfect star, and complex star, each with a fountain fill applied

You can modify polygons and stars. For example, you can change the number of sides on a polygon or the number of points on a star, and you can sharpen the points of a star. You can also use the Shape tool to reshape polygons and complex stars, just as you would with any other curve object. For more information about working with curve objects, see “Curve objects” on page 214. Perfect stars can also be reshaped, but with some restrictions.

To draw a polygon

- In the toolbox, click the Polygon tool and drag in the drawing window until the polygon is the size you want.

💡

You can draw a polygon from its center by holding down Shift as you drag.

💡

You can draw a symmetrical polygon by holding down Ctrl as you drag.

To draw a star

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw a perfect star</td>
<td>In the toolbox, click the Star tool and drag in the drawing window until the star is the size you want.</td>
</tr>
<tr>
<td>Draw a complex star</td>
<td>In the toolbox, click the Star tool Click the Complex star tool on the property bar, and drag in the drawing window until the star is the size you want.</td>
</tr>
</tbody>
</table>

💡

You can draw a star from its center by holding down Shift as you drag.

💡

You can draw a symmetrical star by holding down Ctrl as you drag.
To modify a polygon

To Change the number of sides of a polygon
Do the following
Select a polygon, type a value in the Points or sides box on the property bar, and press Enter.

Reshape a polygon into a star
Do the following
Select a polygon, click the Shape tool, and drag a node on the polygon until the star is the shape you want.

Left to right: The Shape tool was used to change a polygon into a star that can be shaped as a curve object. The line segments of the star were then converted to curves and adjusted to produce the starfish shape.

To modify a star

To Change the number of points on a star
Do the following
Select a star, type a value in the Points or sides box on the property bar, and press Enter.

Sharpen a star’s points
Do the following
Select a star, and type a value in the Sharpness box on the property bar.

Reshape a star
Do the following
Select a star, click the Shape tool, and drag a node on the star.

When you use the Shape tool to reshape a perfect star, the node movement is constrained. Also, on perfect stars, you cannot add or delete nodes, nor can you convert line segments to curves.
Spirals
You can draw two types of spirals: symmetrical and logarithmic. Symmetrical spirals expand evenly so that the distance between each revolution is equal. Logarithmic spirals expand with increasingly larger distances between revolutions. You can set the rate by which a logarithmic spiral expands outward.

You can change the default settings of the Spiral tool so that all new spirals you draw have the properties you want.

To draw a spiral
1. In the toolbox, click the Spiral tool.
2. Type a value in the Spiral revolutions box on the property bar.
3. On the property bar, click one of the following buttons:
   • Symmetrical spiral
   • Logarithmic spiral
   If you want to change the amount by which the spiral expands as it moves outward, move the Spiral expansion factor slider.
4. Drag diagonally in the drawing window until the spiral is the required size.

💡
You can draw a spiral from its center outward by holding down Shift as you drag.
You can also draw a spiral with even horizontal and vertical dimensions by holding down Ctrl as you drag.

To choose default settings for the Spiral tool
1. Click Tools > Options > Tools.
2. In the left pane of the dialog box that appears, click Spiral.
3. Change the settings you want.

Grids
You can draw a grid and set the number of rows and columns. A grid is a grouped set of rectangles that you can break apart.

You can change the default settings of the Graph Paper tool to specify the number of rows and columns for new grids.

To draw a grid
1. In the toolbox, click the Graph paper tool.
2 Type values in the top and bottom portions of the **Columns and rows** box on the property bar.

The value you type in the top portion specifies the number of columns; the value you type in the bottom portion specifies the number of rows.

3 Point to where you want the grid to appear.
4 Drag diagonally to draw the grid.

If you want to draw the grid from its center point outward, hold down **Shift** as you drag; if you want to draw a grid with square cells, hold down **Ctrl** as you drag.

**To ungroup a grid**

1 Select a grid by using the **Pick** tool.
2 Click **Object** ➤ **Group** ➤ **Ungroup**.

You can also break apart a grid by clicking the **Ungroup** button on the property bar.

**To choose default settings for the Graph Paper tool**

1 Click **Tools** ➤ **Options** ➤ **Tools**.
2 In the left pane of the dialog box that appears, click **Graph Paper**.
3 Type values in the **Number of columns** and **Number of rows** boxes.

**Predefined shapes**

Using the Common Shapes collection, you can draw predefined shapes. Certain shapes — specifically basic shapes, arrow shapes, banner shapes, and callout shapes — contain diamond-shaped handles that are called **glyphs**. You can drag a glyph to modify the appearance of a shape.

![Glyph](image)

*Using the Shape tool, you can drag a glyph to alter a shape.*

You can add text to the inside or outside of the shape. For example, you might want to put a label inside a flowchart symbol or a callout.

**To draw a predefined shape**

1 In the toolbox, click the **Common Shapes** tool.
2. Open the **Common shapes** picker on the property bar, and click a shape.

3. Drag in the drawing window until the shape is the size you want.

   Like other shapes, shapes that are drawn from the Common Shapes picker can be modified.

**To modify a predefined shape**

1. Select a shape that contains a *glyph*.
2. Drag a glyph until you achieve the shape you want.

   The right-angle, heart, lightning bolt, explosion, and flowchart shapes do not contain glyphs.

**To add text to a predefined shape**

1. Click the **Text** tool.
2. Position the cursor inside the shape's outline until it changes to a text cursor.
3. Type inside the shape, choose a font, and format the text.

**Use shape recognition**

You can use the **Smart drawing** tool to draw freehand strokes that can be recognized and converted to basic shapes. Rectangles and ellipses are translated to native CorelDRAW objects; trapezoids and parallelograms are translated to Perfect Shapes objects; lines, triangles, squares, diamonds, circles, and arrows are translated to curve objects. If an object is not converted to a shape, it is smoothed. Objects and curves drawn with shape recognition are editable. You can set the level at which CorelDRAW recognizes shapes and converts them to objects. You can also specify the amount of smoothing applied to curves.

You can set the amount of time to elapse between making a pen stroke and the implementation of shape recognition. For example, if the timer is set to one second and you draw a circle, shape recognition takes effect one second after you draw the circle.

You can make corrections as you draw. You can also change the thickness and line style of a shape that was drawn by using shape recognition.

---

Shapes created with the Smart drawing tool are recognized and smoothed.

**To draw a shape or line by using shape recognition**

1. In the toolbox, click the **Smart drawing** tool.
2. Choose a recognition level from the **Shape recognition level** list box on the property bar.
3 Choose a smoothing level from the Smart smoothing level list box on the property bar.
4 Draw a shape or line in the drawing window.

The Smart drawing tool property bar is displayed only when the Smart drawing tool is selected.

To set shape recognition delay
1 Click Tools ➤ Options ➤ Tools.
2 In the left pane of the dialog box that appears, click Smart Drawing.
3 Move the Drawing assistance delay slider.

The minimum delay is 10 milliseconds; the maximum is 2 seconds.

To make a correction while using shape recognition
- Before the delay recognition period has elapsed, hold down Shift, and drag over the area you want to correct.
  You must start erasing the shape or line from the last point drawn.

  If you are drawing a freehand shape consisting of several curves, you can delete the last curve drawn by pressing Esc.

To change the outline thickness of an object drawn with shape recognition
1 In the toolbox, click the Smart drawing tool .
2 Click the shape.
3 From the Outline width list box on the property bar, choose an outline thickness.

The Smart drawing tool property bar is displayed only when the Smart drawing tool is selected.

When you overlap lines drawn with the Smart drawing tool, the outline thickness is determined by the average.

You can change the line style of a shape drawn with shape recognition. For more information, see “To specify line and outline settings” on page 175.
CorelDRAW lets you shape objects in various ways.

This section contains the following topics:

- “Curve objects” (page 214)
- “Select and move nodes” (page 215)
- “Align and distribute nodes” (page 216)
- “Manipulate segments” (page 223)
- “Join curves” (page 225)
- “Copy and cut segments” (page 226)
- “Add, remove, and join nodes” (page 227)
- “Node types” (page 228)
- “Transform nodes” (page 229)
- “Break the path of curve objects” (page 230)
- “Mirror changes in curve objects” (page 231)
- “Skew and stretch objects” (page 232)
- “Smudge and smear objects” (page 233)
- “Roughen objects” (page 236)
- “Smooth objects” (page 237)
- “Attract or push away nodes to shape” (page 239)
- “Apply distortion effects” (page 240)
- “Add twirl effects” (page 242)
- “Shape objects by using envelopes” (page 243)
- “Crop and erase objects” (page 251)
- “Split objects” (page 256)
- “Trim objects” (page 258)
- “Fillet, scallop, and chamfer corners” (page 260)
- “Weld and intersect objects” (page 262)
- “PowerClip objects” (page 263)
- “Options for nodes, handles, and previews” (page 269)
Curve objects

A curve object has nodes and control handles, which you can use to change the object’s shape. A curve object can be any shape, including a straight or curved line. An object’s nodes are the small shapes that appear along the object’s outline. The line between two nodes is called a segment. Segments can be curved or straight. Each node has a control handle for each curved segment connected to it. Control handles help you adjust the curve of a segment.

![Components of a curve: control handles, segments, and nodes]

Curve objects created in CorelDRAW follow a path that gives them their defining shape. A path can be open (for example, a line) or closed (for example, an ellipse) and can sometimes include subpaths. For more information about paths and subpaths, see “Break the path of curve objects” on page 230.

Most objects that are added to a drawing are not curve objects, with the exception of spirals, freehand lines, and Bézier lines. Therefore, if you want to customize the shape of an object or text object, it is recommended that you convert it to a curve object.

You can view the properties of a curve object in the **Properties** docker.

**To convert objects to curve objects**

1. Select the object.
2. Click **Object ➤ Convert to curves**.

   You can convert artistic text to curves so that you can shape individual characters.

   Bitmaps cannot be converted to curve objects.

**To view curve properties**

1. Select the curve object.
2. Click **Object ➤ Properties**.
3. At the top of the **Properties** docker, click the **Curve** button 🌿.

   You can also convert an object to a curve object by selecting the object and clicking the **Convert to curves** button 🌿 on the property bar.
Select and move nodes

You can select individual, multiple, or all of the object's nodes. Selecting multiple nodes lets you shape different parts of an object simultaneously. You can marquee select nodes by enclosing them with a rectangular marquee box, or by enclosing them with an irregularly shaped marquee box. Freehand marquee selection is useful when you want to select specific nodes in complex curves.

When a node is selected on curved segments, control handles are displayed. You can adjust the shape of the curved segments by moving the nodes and control handles.

![Image showing control handles](image)

Usually, a control handle is displayed as a solid blue arrowhead (left). When a control handle overlaps with a node, it is displayed as an unfilled blue arrowhead beside the node (right).

You can reposition a node by specifying its coordinates.

The **Shape** tool is the standard tool for moving nodes. You can also set an option to use the **Pick** and **Bézier** tools for selecting and moving nodes.

**To select a node**

1. In the toolbox, click the Shape tool.
2. Select a curve object.
3. Click a node.

You can also

- **Marquee select multiple nodes**
  - On the property bar, choose **Rectangular** from the **Selection mode** list box, and drag around the nodes that you want to select.

- **Freehand marquee select multiple nodes**
  - On the property bar, choose **Freehand** from the **Selection mode** list box, and drag around the nodes you want to select.

- **Select multiple nodes**
  - Hold down **Ctrl**, and click each node.

- **Select all nodes on a selected curved object**
  - Click **Edit** ➤ **Select all** ➤ **Nodes**.

- **Select consecutive nodes**
  - Holding down **Shift**, click the first node, and then the last node that you want to select.
  - To change the direction in which the nodes are selected, click while holding down **Shift**.
You can also

Select the node that follows or precedes a selected node
Press Tab or Shift + Tab.

Deselect a node
Hold down Ctrl, and click a selected node.

Deselect multiple nodes
Hold down Ctrl, and click each selected node.

Deselect all nodes
Click an unused space in the drawing window.

You can also select a node by using the Pick, Freehand, Bézier, or Polyline tool. To do this, first click Tools ➤ Options ➤ CorelDRAW. Click Nodes and Handles, and enable the Enable node tracking check box. Click a curve object, move the pointer over a node until the tool’s shape state cursor appears, and click the node. Note that when the Enable node tracking check box is enabled, you can no longer select and move an object by clicking and dragging any of its nodes.

To select all nodes on a selected curve, double-click the Shape tool.

To move a node
1. Select an object by using the Shape tool.
2. Drag the node until you achieve the desired shape.

You can also move a node by using the Pick, Freehand, Bézier, or Polyline tool. To do this, first click Tools ➤ Options ➤ CorelDRAW. Click Nodes and Handles, and make sure that the Enable node tracking check box is enabled. Click a curve object, move the pointer over a node until the tool’s shape state cursor appears, and drag the node.

To specify a node’s coordinate values
1. Click the Shape tool.
2. Select a node on a curve object.
3. Click Window ➤ Dockers ➤ Coordinates.
4. Click the Multi-point curve button.
5. Type values in the X and Y boxes to specify the exact position of the point along the x and y rulers.
6. Click one of the following:
   • Create object — adds a new curve object to the drawing window
   • Replace object — replaces the selected curve object with a new one

Align and distribute nodes
CorelDRAW lets you quickly align and distribute nodes in one or more curves.
First, you need to choose a reference point. The reference point can be the bounding box of the selection, the page edge or center, the closest grid line, or a specified point.

The nodes in a curve (1) are left-aligned relative to the bounding box of all active nodes (2), the page edge (3) or center (4), the closest grid line (5), or a specified point (6).

After you set a reference point, you can choose an alignment option. You can align nodes to the left, right, top, or bottom, or along a horizontal or vertical axis.
The active nodes in a curve (top left) are aligned to the left (1), right (3), top (4), bottom (6), and along a vertical (2) and horizontal (5) axis relative to the bounding box of the selection.

You can align nodes from different curves.
When you align nodes in a selection, the alignment is based on the average of the bounding area of the active nodes. CorelDRAW aligns nodes based on the order in which they appear along a curve rather than on the order in which you select them because it can be time-consuming to select nodes one at a time in complex objects with hundreds of nodes. You can change the order of the nodes by reversing the direction of the curve object.

Distributing nodes adds equal spacing between them horizontally or vertically. You can distribute nodes within the bounding box that contains them or over the drawing page.
Nodes are distributed horizontally (1 and 3) and vertically (2 and 4) within the bounding box that surrounds them (1 and 2) and over the entire page (3 and 4).

CorelDRAW distributes nodes based on the order in which they appear along a curve.
From top to bottom: The nodes in a curve (top left and top right) are distributed horizontally (middle) or vertically (bottom) based on the order in which the nodes appear along the curve.

To prevent blurry edges in curve objects designed for web use, you can align the object nodes with the pixel grid. This feature realigns object nodes to position them correctly on the pixel grid.

Align nodes with the pixel grid to prevent blurry edges.
To align nodes

1. Select the nodes with the Shape tool.

2. In the Align and Distribute docker (Window ▶ Dockers ▶ Align and Distribute), choose a reference point by performing a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align nodes relative to the bounding box of the active nodes</td>
<td>Click the Active nodes button in the Align nodes to area.</td>
</tr>
<tr>
<td></td>
<td>Note: When you select nodes along a curve, the nodes are aligned based on the order in which they appear along the curve. To change the direction of a curve, click the Reverse direction button on the Shape tool property bar.</td>
</tr>
<tr>
<td>Align nodes with the page edge</td>
<td>Click the Page edge button in the Align nodes to area.</td>
</tr>
<tr>
<td>Align nodes with the page center</td>
<td>Click the Page center button in the Align nodes to area.</td>
</tr>
<tr>
<td></td>
<td>Tip: To align nodes with the page center, make sure that the Align horizontally button and Align vertically button in the Align area are enabled.</td>
</tr>
</tbody>
</table>

3. In the Align area of the docker, click one of the following buttons:
   - Align left — to align nodes to the left
   - Align horizontally — to align nodes along a vertical axis
   - Align right — to align nodes to the right
   - Align top — to align nodes to the top
   - Align vertically — to align nodes along a horizontal axis
   - Align bottom — to align nodes to the bottom

You can also

- Align a node with the closest grid line
  - Click the Grid button in the Align nodes to area.

- Align a node with a specified point
  - Click the Specified point button in the Align nodes to area, and type values in the Specify coordinates boxes.
  - Tip: You can also specify a point interactively by clicking the Specify point button and clicking in the document window.
You can also align nodes within the active selection, vertically and horizontally, by clicking the **Align nodes** button on the property bar, and enabling one or more alignment options in the **Node align** dialog box.

To distribute nodes

1. Select the nodes with the **Shape** tool.
2. In the **Align and Distribute** docker (Window ➔ Dockers ➔ Align and Distribute), click one of the following buttons in the **Distribute nodes to** area to choose the area over which the nodes are distributed:
   - **To selected** — distributes the nodes over the area of the bounding box that contains them
   - **To page** — distributes the nodes over the drawing page
3. To distribute nodes horizontally, click any of the horizontal distribution buttons.
4. To distribute nodes vertically, click any of the vertical distribution buttons.

Since nodes have no real width or height, clicking any horizontal or vertical distribution button places equal space between the nodes along a horizontal or vertical axis, respectively.

To distribute nodes by a specified distance

1. Select the nodes with the **Shape** tool.
2. Click **Object ➔ Align and Distribute ➔ Align and Distribute**.
3. In the **Distribute to** area, click the **By object spacing** button.
4. Type values in the H and V boxes to set the distance between objects horizontally and vertically.
5. To distribute nodes horizontally, click any of the horizontal distribution buttons.
6. To distribute nodes vertically, click any of the vertical distribution buttons.

To align nodes with the pixel grid

1. Select a curve.
   - To view the results, click **View ➔ Pixels**, and adjust the zoom level to 800% or higher.
2. Click **Object ➔ Align and Distribute ➔ Align and Distribute**.
3. Click **Align with Pixel Grid**.

**Manipulate segments**

You can move curved segments to change an object’s shape. You can also control the smoothness of curved segments.
You can change the direction of a curve object by reversing the position of its start and end nodes. The effect is apparent only when the ends of a curve object are different. For example, when an arrowhead is applied to the end node of a curve object, changing the direction results in moving the arrowhead to the start node.

![Changing the direction of a curve](image)

To manipulate the segments of a curve object

1. In the toolbox, click the **Shape** tool.
2. Click a curve object.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape a segment by using the control handles without affecting the placement of the node</td>
<td>Click a node, then drag one of the control handles.</td>
</tr>
<tr>
<td>Shape a segment by using the control handles while moving a node</td>
<td>Click a node. Hold down <strong>Alt</strong>, and drag one of the control handles.</td>
</tr>
</tbody>
</table>

You can also

- **Straighten a curve segment**: Click a curve segment, and click the **Convert to line** button on the property bar.
- **Curve a straight segment**: Click a straight segment, and click the **Convert to curve** button on the property bar.
- **Smooth a segment**: Click a node, and move the **Curve smoothness** slider on the property bar. To smooth all segments in a curve object, select all of the object’s nodes before moving the **Curve smoothness** slider.
- **Change the direction of a curve object**: Click a segment, and click the **Reverse direction** button on the property bar.
Join curves

You can join curves and line segments to create more complex curves as well as closed objects. The shape of the connecting lines is determined by the mode that you choose: Extend, Chamfer, Fillet, or Bézier Curve.

The lines in the upper-left corner were joined by using different modes. Modes from left to right: Extend, Chamfer, Fillet, and Bézier Curve.

You can also set the gap tolerance, which is the maximum distance between endpoints that can be joined. If the endpoints are further apart than the gap tolerance, they cannot be joined.

When you join curves, the resulting curve takes on the properties of the last object that was selected.

To join curves

1. Hold down Shift, and select each object using the Pick tool.
2. Click Object » Join Curves.
3. In the Join Curves docker, choose one of the following modes from the list box:
   - Extend
   - Chamfer
   - Fillet
   - Bézier Curve
4. Click Apply.
   If the curves are not joined, you must increase the gap tolerance.
You can also

Set the gap tolerance

Type a value in the Gap tolerance box.

Specify the radius

Type a value in the Radius box.

This control is available only for the Fillet mode.

You cannot join interior points, only endpoints.

If endpoints to be joined do not share coordinates, the endpoints are extended to their intersection.

You can also connect the subpaths in a group of objects.

You can also select lines by marquee selecting. If the lines are marquee selected, the properties from the bottom object on a layer are used. To see which object is the bottom one, open the Objects docker by clicking Window ▸ Dockers ▸ Objects.

Copy and cut segments

You can copy and cut curve segments, and then paste them as objects, making it easy to extract subpaths or create adjacent shapes with similar contours.

To copy or cut a curve segment

1. Select the curve object.
2. Using the Shape tool †‡, select the nodes on a curve segment, and then press one of the following:
   • Ctrl + C to copy the curve segment
   • Ctrl + X to cut the curve segment
   • Ctrl + D to duplicate the curve segment at a specified offset distance

To paste the curve segment, press Ctrl + V.
Add, remove, and join nodes

When you add nodes, you increase the number of segments and, therefore, the amount of control you have over the shape of the object. You can delete selected nodes to simplify an object’s shape.

When curve objects contain many nodes, it is difficult to edit and output them to devices such as vinyl cutters, plotters, and rotary engravers. You can have the number of nodes in a curve object reduced automatically. Reducing the number of nodes removes overlapping nodes and can smooth a curve object. This feature is especially useful for reducing the number of nodes in objects imported from other applications.

You can join the start and end nodes of an open path such as a line to create a closed object. This feature is useful for filling an object with color because you can apply fills only to the inside of closed objects. For information about applying fills, see “Fills” on page 425.

You can align the nodes of a curve object horizontally or vertically.

To add or delete a node

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a node</td>
<td>In the toolbox, click the Shape tool, select a curve object, and double-click where you want to add a node.</td>
</tr>
<tr>
<td>Delete a node</td>
<td>In the toolbox, click the Shape tool, select a curve object, and double-click a node.</td>
</tr>
</tbody>
</table>
To reduce the number of nodes in a curve object
1. In the toolbox, click the Shape tool.
2. Click a curve object, and do one of the following:
   - To reduce the number of nodes in the entire object, click the Select all nodes button on the property bar.
   - To reduce the number of nodes in a part of a curve object, marquee select the part you want to change.
3. Do one of the following:
   - Click Reduce nodes on the property bar to have overlapping and redundant nodes automatically removed.
   - Move the Curve smoothness slider to control the number of nodes that are removed. Removing many nodes can reshape the curve object.

To join the end nodes of a single subpath
1. In the toolbox, click the Shape tool.
2. Click a subpath.
3. Click the Close curve button on the property bar.

You can close multiple subpaths in an object by clicking Object \(\rightarrow\) Join curves and choosing settings in the Join curves docker. For more information, see “Join curves” on page 225.

To join the nodes of multiple subpaths
1. In the toolbox, click the Shape tool.
2. Hold down Shift, and click a node from each subpath.
3. Click the Extend curve to close button on the property bar.

If you want to join nodes from separate curve objects, you must first combine them into a single curve object, and then join the end nodes of the new subpaths. For information about combining objects, see “Combine objects” on page 357.

Node types
You can change the nodes on a curve object to one of three types: cusp, smooth, and symmetrical. The control handles of each node type behave differently.

Cusp nodes let you create sharp transitions, such as corners or sharp angles, in a curve object. You can move the control handles in a cusp node independently of one another, changing only the line on one side of the node.

With smooth nodes, the lines passing through the node take on the shape of a curve, producing smooth transitions between line segments. The control handles of a smooth node are always directly opposite one another, but they may be at different distances from the node.

Symmetrical nodes are similar to smooth nodes. They create a smooth transition between line segments, but they also let you give lines on both sides of a node the same curve appearance. The control handles of symmetrical nodes are directly opposite each other and at an equal distance from the node.
Each node type appears with a different shape - smooth nodes as circles, cusp nodes as squares, and symmetrical nodes as diamonds.

To shape a curve object by using cusp, smooth, or symmetrical nodes
1. In the toolbox, click the Shape tool.
2. Click a node.
3. On the property bar, click one of the following buttons:
   - Cusp node
   - Smooth node
   - Symmetrical node
4. Drag the node’s control handles.

You can also change an existing node from one type to another by using shortcut keys. To change a smooth node to a cusp node or a cusp node to a smooth node, click the node using the Shape tool, and press C. To change a symmetrical node to a smooth node or a smooth node to a symmetrical node, click the node with the Shape tool, and press S.

Transform nodes
You can shape objects by stretching, scaling, rotating, and skewing their nodes. For example, you can scale the corner nodes of a curve object to enlarge the curve object proportionally. Also, a curve object or parts of a curve object can be rotated in a counterclockwise or clockwise direction.
To stretch, scale, rotate, or skew nodes

1. In the toolbox, click the Shape tool.
2. Select a curve object.
3. Select the nodes along the curve that you want to transform.
4. On the property bar, click one of the following buttons:
   - Stretch or scale nodes
   - Rotate or skew nodes
5. Drag a set of handles to transform the nodes.

Break the path of curve objects

You can break the path of a curve object.

Paths

Paths outline an object’s shape and are often visible as one or more line or curve segments. You can disconnect line segments from one another to create subpaths. Even though they are not connected, subpaths are still part of the defining path of the original object; however, you can extract a subpath to create two separate objects: the extracted subpath and the object it was extracted from.

Subpaths

Subpaths are the basic curves and shapes from which a single curve object is constructed. For example, a single curve object with subpaths is often created when text is converted to curves. The letter “O,” for instance, is composed of two ellipses: the outside ellipse that defines the letter’s shape and the inside ellipse that defines the “hole.” The ellipses are subpaths that compose the single curve object, “O.” One of the basic reasons for creating an object with subpaths is that you can produce objects with holes in them. In the following example, you can see objects underneath the center of the letter “O.”

To break a path

To Break a path

Do the following

In the toolbox, click the Shape tool. Select a node on the path, and click the Break curve button on the property bar.
To

Extract a broken path from an object

Do the following

In the toolbox, click the Shape tool. Right-click a path, and click Break apart. Select a segment, node, or group of nodes that represents the portion of the path you want to extract, and click the Extract subpath button on the property bar.

When you break a path in a curve object, the resulting subpaths remain part of the same object. When you extract a path from an object, you create two separate objects.

Mirror changes in curve objects

When you mirror changes in curve objects by using Reflect Nodes mode, you edit nodes and have the same edits take place in reverse on corresponding nodes. For example, you can move a node to the right, and its corresponding node moves the same distance to the left. This feature is useful when you want to shape a curve object and mirror the changes across the object’s left and right side or top and bottom side.

To mirror changes, you must select two curve objects one of which was created by mirroring the other, or a symmetrical object. For information about mirroring objects, see "Rotate and mirror objects" on page 348. Next, you need to choose whether to mirror changes horizontally (along a vertical line of symmetry) or vertically (along a horizontal line of symmetry). Finally, you need to select the appropriate corresponding nodes so that editing changes are mirrored across the selected objects.

To mirror changes in curve objects

1. Using the Pick tool, select mirrored curve objects or a symmetrical curve object.
2. Click the Shape tool.
3. On the property bar, click one of the following:
   - Reflect nodes horizontally button — lets you edit corresponding nodes in objects that have been mirrored horizontally
   - Reflect nodes vertically button — lets you edit corresponding nodes in objects that have been mirrored vertically
4. Hold down Shift, and select corresponding nodes on the left and right, or top and bottom.
5 Edit the nodes on one side.
    The changes occur in reverse on corresponding nodes on the other side.

💡 To shape multiple objects by using Reflect Nodes mode, click the first object, and drag to select nodes; or hold down Shift, and click each node on the first object. Then hold down Shift, click the second object, and drag to select nodes, or hold down Shift and click each node on the second object.

Skew and stretch objects

You can skew and stretch objects in CorelDRAW. When you skew an object, you specify the degree by which you want to slant the object. Stretching changes an object’s vertical and horizontal dimensions non proportionally.

CorelDRAW also lets you change the skew and sizing anchor point of an object from its default center position.

![Skewing an object horizontally](image)

![Stretching an object horizontally](image)

To skew an object

1 Select an object.
2 In the toolbox, click the Free transform tool.
3 Click the Free skew button on the property bar.
4 Type values in the **Skew angle** boxes on the property bar to specify the number of degrees by which you want to skew the object horizontally or vertically.

If you want to apply the scaling according to the object's position rather than the x and y coordinates, click the **Relative to object** button on the property bar.

You can also skew an object interactively by dragging one of its skew handles. If the skew handles are not displayed, click the selected object again, and point to the middle handles.

You can also access skewing options from the **Transform** docker.

### To stretch an object

1. Select an **object**.
2. Click **Window ➤ Dockers ➤ Transform**.
3. In the **Transform** docker, click the **Size** button.
4. Disable the **Proportional** check box.
5. Type a value in the following boxes:
   - **W** — lets you specify the width of a selected object
   - **H** — lets you specify the height of a selected object
6. Click **Apply**.

The new values that you enter to stretch an object are the basis for a new ratio of the horizontal and vertical dimensions of the object. When you enable the **Proportional** check box, any resizing of the object is based on this new ratio. To revert the object to its original one-to-one proportions before transforming it again, you must enable the **Proportional** check box, and then retype the original values.

You can change object dimensions proportionally by enabling the **Proportional** check box, typing a value in either the **H** or **W** box, and pressing **Enter**.

You can also stretch an object from its center by pressing **Shift** and dragging a corner selection handle.

You can also stretch an object in increments of 100% by pressing **Ctrl**, and dragging a corner selection handle.

### Smudge and smear objects

Smudging and smearing let you shape an **object** by pulling extensions or making indents along its outline. With smudging, the extensions and indents resemble streaks that vary little in width as you drag with the **Smudge** tool. With smearing, the extensions and indents have a more fluid shape that decreases in width as you drag with the **Smear** tool.

#### Smudge objects

When applying smudging to an object, you can control the extent and shape of the distortion whether you activate the controls for the graphics tablet stylus or use the settings that apply to a mouse.

The smudging effect responds to both the angle of rotation — or bearing — and the tilt angle of a graphics tablet stylus. Rotating the stylus changes the angle of the smudging effect and tilting the stylus flattens the brush tip and changes the shape of the smudging. If you are using a mouse, you can simulate the bearing and tilt of the stylus by specifying values. Increasing the bearing angle from 0° - 359° changes the angle of the brushstroke. As you decrease the tilt angle from 90° - 15°, you change the smudging shape by flattening the brush tip.
Smudging can respond to the pressure of a stylus on a tablet where the smudging widens with more pressure and narrows with less. If you are using a mouse or want to override stylus pressure, you can enter real values to simulate the pressure of a stylus on a graphics tablet. Negative values to -10 create a narrowing distortion, 0 maintains an even stroke width, and positive values to 10 create an expanding distortion.

The sun’s rays and blades of grass have been created by dragging outwards with the Smudge tool and the clouds by dragging inwards.

Whether you are using a stylus or a mouse, you can specify the nib size. The nib size determines the width of the smudging applied to an object.

**Smear objects**

To control the smearing effect, you can set the size of the brush nib and the amount of effect to apply, and you can use the pressure of your digital pen. You can use smooth curves or curves with sharp corners when smearing objects.

**Smearing an object**

To smudge an object

1. Select an object using the Pick tool.
2. In the toolbox, click the Smudge tool.
3. Do one of the following:
   - To smudge the inside of an object, click outside an object, and drag inwards.
   - To smudge the outside of an object, click inside an object, and drag outwards.
Shape objects | 235

You can also

Change the size of the brush nib

You can also

Type a value in the **Nib size** box on the property bar.

Change the size of the brush nib when using the graphics stylus

Click the **Pen pressure** button on the property bar and apply pressure to the stylus.

Widen or narrow the smudging

Type a value between -10 and 10 in the **Dryout** box on the property bar.

Specify the shape of the smudging

Type a value between 15 and 90 in the **Pen tilt** box on the property bar.

Change the shape of the smudging when using the graphics stylus

Click the **Use pen tilt** button on the property bar.

Specify the angle of the nib shape for smudging

Type a value between 0 and 359 in the **Pen bearing** box on the property bar.

Change the angle of the nib shape for smudging when using the graphics stylus

Click the **Use pen bearing** button on the property bar.

You cannot apply smudging to Internet or embedded objects, linked images, grids, masks, mesh-filled objects, or objects with blend and contour effects.

To get the minimum and maximum values for the smudging controls, right-click the control on the property bar, and click **Settings**.

To smear an object

1. Select an object by using the **Pick** tool.
2. In the toolbox, click the **Smear** tool.
3. Do one of the following:
   - To smear the outside of an object, click outside an object, close to its edge, and drag outwards.
   - To smear the inside of an object, click inside an object, close to its edge, and drag inwards.

You can also

Change the size of the brush nib

Type a value in the **Nib size** box on the property bar.

Set the amount of smearing

Type a value in the **Pressure** box.
You can also

Use the pressure of a digital pen to control the amount of smearing
   Click the **Pen pressure** button on the property bar.

Use smooth curves when smearing
   Click the **Smooth smear** button.

Use curves with sharp corners when smearing
   Click the **Pointy smear** button.

The difference between a smooth smear and pointy smear is noticeable only with higher Pressure values.

Roughen objects

The roughening effect lets you apply a jagged or spiked edge to objects, including lines, curves, and text. You can control the size, angle, direction, and number of the indentations whether you activate the graphics tablet stylus or apply settings to a mouse.

The roughening effect is determined either by movements of a graphics tablet stylus, by fixed settings, or by automatically applying perpendicular spikes to the line. Tilting the stylus toward and away from the tablet’s surface increases and decreases the size of the spikes. If you are using a mouse, you can specify the tilt angle from 0 - 90°. You can determine the direction of the spikes by changing the angle of rotation (or bearing) of the stylus as you apply the roughening effect to an object. When you are using a mouse, you can set the bearing angle from 0 - 359°. You can also increase or decrease the number of spikes that are applied as you drag.

The roughening effect also responds to the pressure of the stylus on the tablet. The more pressure you apply, the more spikes are created in the roughened area. If you are using a mouse, you can specify values to simulate the stylus pressure.

You can also change the brush nib size.

To roughen an object

1. Select an object using the **Pick** tool.
2. In the toolbox, click the **Roughen** tool.
3. Point to the area on the outline you want to roughen, and drag the outline to distort it.
You can also

Specify the size of the roughening spikes
Type a value from 0.01 to 2.0 in the Nib size box on the property bar.

Change the number of spikes in a roughened area
Type a value between 1 and 10 in the Frequency of spikes box on the property bar.

Change the number of spikes in a roughened area when using a graphics stylus
Click the Pen pressure button on the property bar.

Specify the height of the roughening spikes
Type a value between 0 and 90 in the Pen tilt box on the property bar.

Increase the number of roughening spikes as you drag
Type a value between -10 and 10 in the Dryout box on the property bar.

Change the height of the roughening spikes when using a graphics stylus
Click the Use pen tilt button on the property bar.

Specify the direction of the roughening spikes
Choose Fixed direction from the Spike direction list box. Type a value between 0 and 359 in the Bearing box on the property bar.

Change the direction of the roughening spikes when using a graphics stylus
Choose Stylus setting from the Spike direction list box on the property bar.

Create roughening spikes perpendicular to the path or outline
Choose Auto from the Spike direction list box on the property bar.

Objects with distortions, envelopes, and perspective applied to them are converted to curve objects before the roughening effect is applied.

To make the tilt angle and bearing angle responsive to the graphics tablet stylus, right-click the roughened object, and select a command from the submenu.
To get the minimum and maximum values for the roughening controls, right-click the control on the property bar, and click Settings.

Smooth objects

You can smooth curved objects to remove jagged edges and reduce the number of nodes. Alternatively, you can smooth shapes, such as rectangles or polygons, to give them an organic, hand-drawn look.

To control the smoothing effect, you can vary the size of the brush nib and the speed at which the effect is applied, and you can use the pressure of your digital pen.
Text converted to curves (top) and the same text smoothed with the Smooth tool (bottom)

To smooth an object

1. Select an object by using the Pick tool.
2. In the toolbox, click the Smooth tool.
3. Drag along the edge of the object.

You can also

Set the size of the brush nib

Type a value in the Nib size box on the property bar.

To change the size of the brush nib, you can also drag in the document window while holding down Shift. Drag towards the nib’s center to decrease the size, and away from the nib’s center to increase it.

Set the speed of the smoothing effect

Type a value in the Rate box.

You can also hold down Alt and drag to display an onscreen slider that lets you set the speed of the smoothing effect interactively.

Use the pressure of a digital pen to control the effect

Click the Pen pressure button on the property bar.
Attract or push away nodes to shape

The Attract and Repel tool lets you shape objects by attracting nodes or pushing nodes away. To control the shaping effect, you can vary the size of the brush nib and the speed at which the nodes are attracted or pushed away, and you can use the pressure of your digital pen.

To shape an object by attracting and pushing away nodes

1. Select an object by using the Pick tool.
2. In the toolbox, click the Attract and Repel tool.
3. Do one of the following:
   • To attract nodes to the cursor, click the Attract tool on the property bar.
   • To push nodes away from the cursor, click the Repel tool.
4. Click inside or outside the object, close to its edge, and hold down the mouse button to reshape the edge. For a more pronounced effect, drag while holding down the mouse button.
You can also

Set the size of the brush nib  
Type a value in the **Nib size** box on the property bar.

To change the size of the brush nib, you can also drag in the document window while holding down **Shift**. Drag towards the nib’s center to decrease the radius, and away from the nib’s center to increase it.

Set the speed at which nodes are attracted or pushed away  
Type a value in the **Rate** box.

Use the pressure of a digital pen to control the effect  
Click the **Pen pressure** button on the property bar.

**Apply distortion effects**

You can apply three types of distortion effects to shape objects.

<table>
<thead>
<tr>
<th>Distortion effect</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Push and pull</td>
<td>Lets you push the edges of an object in or pull the edges of an object out.</td>
</tr>
<tr>
<td>Zipper</td>
<td>Lets you apply a saw tooth effect to the edges of the object. You can adjust the amplitude and frequency of the effect.</td>
</tr>
<tr>
<td>Twister</td>
<td>Lets you rotate an object to create a swirl effect. You can choose the direction of the swirl, as well as the degree and amount of rotation.</td>
</tr>
</tbody>
</table>

*From left to right: Original image; Zipper and Twister distortions applied; Pull distortion applied*

After you distort an object, you can change the effect by altering the center of distortion. This point is identified by a diamond-shaped handle, around which a distortion appears. It is similar to a mathematical compass, where the pencil moves around a stationary point. You can place the center of distortion anywhere in the drawing window, or choose to center it in the middle of an object so that the distortion is distributed evenly and the shape of the object changes in relation to its center.

You can create an even more dramatic effect by applying a new distortion to an already distorted object. You don’t lose the effect of the original distortion if, for example, you apply a zipper distortion on top of a twister distortion. The CorelDRAW application also lets you remove and copy distortion effects.
When an object with a distortion effect is brought into Focus mode, the object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To distort an object

1. In the toolbox, click the Distort tool.

2. On the property bar, click one of the following buttons, and specify the settings you want:
   - Push and pull distortion
   - Zipper distortion
   - Twister distortion

3. Point to where you want to place the center of distortion, and drag until the object is the shape you want.

You can also

- Change the center of distortion
  Drag the diamond-shaped position handle to a new location.

- Adjust the number of points on a zipper distortion
  Move the slider on the center of the distortion handle.

- Apply a preset distortion
  Choose a distortion preset from the Preset list box on the property bar.

- Apply more than one distortion to an object
  Click another distortion type on the property bar, click an object, and drag.

You can reapply the effects to distorted objects.

You can center a distortion by clicking the Center distortion button on the property bar.
You can use the interactive vector controls to edit a distortion effect. Upper left: Zipper effect applied to circle. Upper right: Zipper effects with higher frequency (more spikes) applied. Bottom: Results of applying zipper effects.

To remove a distortion
1. Select a distorted object.
2. Click Object ➤ Clear Distortion.

Removing a distortion this way clears the most recent distortion you’ve applied.

You can also remove a distortion from a selected object by clicking Clear Distortion on the property bar.

To copy a distortion
1. Select the object to which you want to copy a distortion.
2. Click Object ➤ Copy effect ➤ Distortion from.
3. Click a distorted object.

You can also use the Eyedropper tool to copy the effect. For more information, see “To copy effects from one object to another” on page 325.

Add twirl effects
You can add twirl effects to objects. You can set the radius, speed, and direction of the twirl effects, and you can use the pressure of your digital pen to change the intensity of the twirl effect.
To add a twirl effect to an object
1. Select an object by using the Pick tool.
2. In the toolbox, click the Twirl tool.
3. Click the edge of the object, and hold down the mouse button until the twirl is the size you want.
   To position and reshape the twirl, you can drag while holding down the mouse button.

You can also
- Set the radius of the twirl effect: Type a value in the Nib size box on the property bar.
- Set the rate at which the twirl effect is applied: Type a value between 1 and 100 in the Rate box on the property bar.
- Set the direction of the twirl effect: Click the Counterclockwise twirl button or the Clockwise twirl button.
- Use the pressure of a digital pen to control the intensity of the twirl effect: Click the Pen pressure button on the property bar.

Shape objects by using envelopes
CorelDRAW lets you shape objects, including lines, artistic text, paragraph text frames, and bitmaps by applying envelopes. Envelopes are made of multiple nodes that you can move to shape the envelope and, as a result, change the shape of the object.
The original bitmap (left) with an envelope (right). The envelope is applied nondestructively, so you can edit it or remove it and revert to the original image at any point.

You can apply a basic envelope that conforms to the shape of an object, or you can also apply a preset envelope.

A preset envelope has been applied to a group of bitmaps.

If none of the presets fits your needs, you can create a custom envelope and save it for future use. Envelope presets are saved as Preset (.PST) files and are stored in the \AppData\Roaming\Corel\CorelDRAW Graphics Suite 2022\Draw\Presets\Envelope folder.
A custom envelope (3) is created from the shape of a vector object (1) and applied to a bitmap (2).

CorelDRAW also lets you copy and remove envelopes.

After you apply an envelope, you can edit it or add a new envelope to continue changing the object’s shape. You edit an envelope by adding and positioning its nodes. Adding nodes gives you more control over the shape of the object contained in the envelope. CorelDRAW also lets you delete nodes, move multiple nodes simultaneously, change nodes from one type to another, and change a segment of an envelope to a line or curve. For more information about the different types of nodes, see “Curve objects” on page 214.

You can also change the mapping mode of an envelope to specify how the object fits to the envelope. For example, you can stretch an object to fit the basic dimensions of the envelope, and then apply the horizontal mapping mode to compress it horizontally so that it fits the shape of the envelope.

To apply an envelope
1. Select an object.
2. In the toolbox, click the Envelope tool.
3. On the property bar, click one of the following buttons:
• **Straight line mode** — creates envelopes based on straight lines, adding perspective to objects

• **Single-arc mode** — creates envelopes with an arc shape on one side, giving objects a concave or convex appearance

• **Double-arc mode** — creates envelopes with an S shape on one or more sides

• **Unconstrained mode** — creates freeform envelopes that let you change the properties of the nodes, and add and delete the nodes

4 Click the object.

5 Drag the nodes to shape the envelope.

If you want to reset the envelope, press **Esc** before releasing the mouse.

You can also

Apply a preset envelope

Click the Preset list list box on the property bar, and click an envelope shape.

Apply an envelope to an object with an envelope

Click the Add new envelope button on the property bar, and drag the nodes to change the shape of the envelope.

Remove an envelope

Click Effects ▸ Clear envelope.

Applying an envelope to paragraph text allows you to modify only the shape of the text frame. To shape the text inside the frame, consider converting the frame to a curve after you finish editing and formatting the content. For information about converting objects to curves, see “To convert objects to curve objects” on page 214. Note that once you convert the frame to a curve, you can no longer edit the text. To shape individual characters with an envelope, use artistic text.

You cannot apply an envelope to a bitmap with an envelope.

You can also apply an envelope by using the Envelope docker (Effects ▸ Envelope).

You can prevent the straight lines of a vector object from being converted to curves by enabling the Keep lines button on the property bar.

**To create an envelope based on the shape of another object**

1 Select an object to which you want to apply an envelope.

2 In the toolbox, click the Envelope tool.

3 Click the Create envelope from button on the property bar.

4 Click the object from which you want to create an envelope.

The envelope is applied to the object that you selected in step 1.

To save the envelope for future use, click the Add preset button on the property bar, type a filename in the File name list box, and click Save.

You can create an envelope only from a closed curve.
To copy an envelope

1  Select an object to which you want to apply an envelope.
2  Click Object  Copy effect  Envelope from.
3  Select the object from which you want to copy the envelope.

💡 You can also copy an envelope by selecting an object, clicking the Copy envelope properties button on the property bar, and selecting an object with the envelope you want to copy.

💡 You can also use the Attributes Eyedropper tool to copy an envelope. For more information, see “To copy effects from one object to another” on page 325.

To edit the nodes and segments of an envelope

1  In the toolbox, click the Envelope tool.
2  Select an object with an envelope.
3  Double-click the envelope to add a node or double-click a node to delete it.

You can also

Move several envelope nodes at once  Click the Unconstrained mode button on the property bar, marquee select the nodes you want to move, and drag any node to a new position.

Marquee select multiple nodes  On the property bar, choose Rectangular from the Selection mode list box, and drag around the nodes that you want to select.

Freehand marquee select multiple nodes  On the property bar, choose Freehand from the Selection mode list box, and drag around the nodes you want to select.

Move two opposing nodes an equal distance in the same direction  Click the Straight line mode, Single-arc mode, or Double-arc mode button on the property bar so that it appears raised, press Ctrl, and drag a node to a new position.
You can also

Move two opposing nodes an equal distance in the same direction

Move two opposing nodes an equal distance in the opposite direction

Note: This feature applies only to some preset envelopes with symmetrical nodes.

Click the Straight line mode, Single-arc mode or Double-arc mode button on the property bar so that it appears raised, press Shift, and drag a node to a new position.
You can also

Move two opposing nodes an equal distance in the opposite direction

Move all opposing nodes symmetrically to or away from a central point

Click the **Straight line mode** , **Single-arc mode** or **Double-arc mode** button on the property bar so that it appears raised, press Ctrl + Shift, and drag a node to a new position.

**Note:** This feature applies only to some preset envelopes with symmetrical nodes.
You can also

Move all opposing nodes symmetrically to or away from a central point.

Moving all corner nodes stretches the envelope horizontally or vertically.

Moving all middle nodes lets you push the edges of the envelope in or pull the edges of the envelope out.

Note: This feature applies only to some preset envelopes with symmetrical nodes.
You can also

**Change an envelope node type**

Click the **Unconstrained mode** button on the property bar so that it appears pressed, and click either the **Cusp node** button, the **Smooth node** button, or the **Symmetrical node** button.

**Change an envelope segment to a straight line or curve**

Click the **Unconstrained mode** button on the property bar so that it appears pressed, click a line segment, and click the **Convert to line** button or the **Convert to curve** button.

*Note:* Both the **Convert to line** and **Convert to curve** buttons are disabled when you apply an envelope to a bitmap.

If you split, crop, or erase portions of an object with an envelope, you can no longer edit the envelope.

If you edit a bitmap with an envelope in Corel PHOTO-PAINT, or if you copy a bitmap with an envelope and paste it into Corel PHOTO-PAINT or into an earlier version of CorelDRAW, the envelope is no longer editable.

**To change the mapping mode**

1. In the toolbox, click the **Envelope** tool.
2. Click an **object** with an **envelope**.
3. On the property bar, choose one of the following from the **Mapping mode** list box:
   - **Horizontal** — stretches the object to fit the basic dimensions of the envelope and then compresses the object horizontally to fit the shape of the envelope
   - **Original** — maps the corner handles of the object’s selection box to the envelope’s corner nodes. The other nodes are mapped linearly along the edge of the object’s selection box.
   - **Putty** — maps the corner handles of the object’s selection box to the envelope corner nodes
   - **Vertical** — stretches the object to fit the basic dimensions of the envelope and then compresses the object vertically to fit the shape of the envelope
4. Drag the nodes or the control handles.

*The mapping mode of paragraph text frames cannot be changed after an envelope is applied.*

**Crop and erase objects**

You can crop and erase portions of objects.

**Crop**

Cropping lets you quickly remove unwanted areas in objects and imported photos, eliminating the need to ungroup objects, break linked groups apart, or convert objects to curves. You can crop vector objects and bitmaps.
Cropping objects

When cropping objects, you define a rectangular area (cropping area) that you want to keep. Object portions outside the cropping area are removed. You can specify the exact position and size of the cropping area, and you can rotate and resize it. You can also remove the cropping area.

You can crop only selected objects without affecting other objects in a drawing, or you can crop all objects on the drawing page. In either case, the affected text and shape objects are automatically converted to curves.

Erase

CorelDRAW lets you erase unwanted portions of bitmaps and vector objects. The Eraser tool works just like a pencil eraser, removing any part of the image over which you click and drag. If you want to erase only portions of a specific object, you have to select it. When no object is selected, the Eraser tool removes any part of the drawing over which you drag. For information about selecting objects, see “Select objects” on page 302. Erasing automatically closes any affected paths and converts the object to curves. If you erase connecting lines, CorelDRAW creates subpaths rather than individual objects. You cannot erase objects with contours, blends, drop shadows, block shadows, and extrusions.

When working with a pen or stylus, you can use pressure to vary the size of the eraser nib. If your pen or stylus supports tilt and bearing, you can use these features to vary the flatness and rotation of the eraser nib. You can also set fixed values for the tilt angle and bearing angle so that the flatness and rotation of the nib remain the same.

You can use your stylus to vary the size and flatness of the eraser nib.

You can also choose default settings for the Eraser tool such as the default size of the eraser nib. Objects created as a result of erasing have their nodes automatically reduced; however you can choose to disable this setting.

Delete

You can also delete virtual line segments, which are portions of objects that overlap each other. For example, you can delete a loop in a line that crosses over itself, or loops in line segments in which two or more objects overlap.
To crop an object or imported photo

1. Select the object or imported photo that you want to crop.
   - You can select one or more objects. If no objects on the drawing page are selected, all objects in the drawing will be cropped.
2. In the toolbox, click the Crop tool.
3. Drag to define a cropping area.
4. Double-click inside the cropping area.

You can also

- Specify the exact position of the cropping area: Type values in the Crop position boxes on the property bar, and press Enter.
- Specify the exact size of the cropping area: Type values in the Crop size boxes on the property bar, and press Enter.
- Rotate the cropping area: Type values in the Angle of rotation box.
- Remove the cropping area: Click Clear.

Objects on locked, hidden, Grid, or Guides layers cannot be cropped. Also, you cannot crop OLE and Internet objects, rollovers, or the content of PowerClip objects.

During cropping, affected linked groups, such as contours, blends, and extrusions, are automatically broken apart.

You can move, rotate, and size the cropping area interactively as you would any object. To move the cropping area, drag it to a new position. To size the cropping area, drag any of its handles. To rotate the cropping area, click inside, and drag a rotation handle.

You can remove the cropping area by pressing Esc.

To erase an image area

1. Perform a task from the following table.
To Do the following

Erase an area in a drawing Deselect all objects.

Erase portions of an object Select the object.

2 Do one of the following:
   • When using a mouse, click the Eraser tool in the toolbox.
   • When using a stylus, flip the stylus to automatically switch to erase mode.

3 Drag over the area that you want to erase.

You can also

Change the size of the eraser nib Type a value in the Eraser thickness box on the property bar, and press Enter.

Change the shape of the eraser nib Click the Round nib or the Square nib button on the property bar.

Vary the width of the eraser nib Click the Pen pressure button on the property bar to enable it.

The maximum width of the nib is determined by the value specified in the Eraser thickness box.

If you are using the mouse, press the Up arrow or Down arrow to simulate changes in pen pressure and change the width of the eraser nib.

Vary the flatness of the eraser nib Click the Pen tilt button on the property bar to enable it.

Flatten the eraser nib by setting a fixed value for pen tilt Click the Pen tilt button on the property bar to disable it, and type a value in the Tilt angle box.

You can specify a value between 15 and 90. The lower the value, the flatter the nib.

Vary the rotation of the eraser nib Click the Pen bearing button on the property bar to enable it.

Rotate the eraser nib by setting a fixed value for pen bearing Click the Pen bearing button on the property bar to disable it, and type a value in the Bearing angle box.

You can specify a value between 0 and 359.

Maintain all the nodes of the area being erased Disable the Reduce nodes button on the property bar.
When you erase portions of objects, any affected **paths** are automatically closed.

You can erase straight lines by clicking where you want to start erasing, and then clicking where you want to finish erasing. Press **Ctrl** if you want to constrain the line’s angle.

You can also erase an area of a selected object by double-clicking the area with the **Eraser** tool.

**To choose default Eraser settings**
1. Click **Tools** ➤ **Options** ➤ **Tools**.
2. Click **Eraser** in the left pane of the dialog box that appears.
3. Type a thickness value in the **Thickness** box to set the size of the eraser nib.
4. Enable or disable the **Auto-reduce nodes of resulting objects** check box.

**To delete a virtual line segment**
1. In the toolbox, click the **Virtual segment delete** tool.
2. Move the pointer to the line segment you want to delete.
   The **Virtual segment delete** tool snaps upright when positioned properly.
3. Click the line segment.

You can also

- **Delete multiple line segments at one time**
  Drag a marquee to enclose or intersect all target segments.

- **Delete a virtual line segment that intersects with a curve**
  Hold down **Alt**, and drag to draw a curve.

- **Weld line segments**
  Hold down **Shift**, click the two overlapping end points. You can also hold down **Alt + Shift**, and drag to marquee select the overlapping nodes.

![](Deleting multiple virtual line segments)
Split objects

You can split vector objects, text, and bitmaps. You can split single objects or groups of objects along straight, freehand, or Bézier lines.

(From top to bottom) Three modes for splitting objects are available: Bézier, 2-Point Line, and Freehand.

In addition, you can create a gap between the new objects resulting from the splitting action, or you can make the new objects overlap.

This bitmap was split into two along a freehand line. The gap value was specified before cutting the bitmap.

When you split an object by using the Knife tool, CorelDRAW lets you choose whether to convert outlines to curve objects or keep them as outlines. By default, the application automatically chooses the option that best preserves outline appearance.

When splitting objects that have dashed lines, arrowheads or end caps, the Convert to objects option preserves the outline appearance better. When you choose the Automatic option for such objects, CorelDRAW converts the outlines to objects.
To split an object

1. In the toolbox, click the Knife tool.

2. On the property bar, click one of the following buttons:
   - **2-point line mode** — to split the object along a straight line. To constrain the line by 15-degree increments, hold down Shift + Ctrl.
   - **Freehand mode** — to split the object along a freehand line

3. Drag across the object or group of objects that you want to split.

You can also

**Split an object along a Bézier line**

Click the Bézier mode button on the property bar. Click where you want to start cutting an object, drag the control handle to where you want to position the next node, and click. Continue clicking to add more straight segments to the line. To add a curved segment, point to where you want to place the node and drag to shape the curve. To constrain the line by 15-degree increments, hold down Shift + Ctrl.

**Create a gap or an overlap between the new objects**

On the property bar, choose Gap or Overlap from the Cut span list box. Type a value in the Width box.

**Choose outline options**

On the property bar, choose an option from the Outline options list box.

**Switch from one mode to another**

Click the Knife tool, and press A. The cursor changes to show the currently selected mode — 2-point line, Freehand, or Bézier.

Note: You cannot switch modes while dragging with the Knife tool.
When you split an object by using the **Knife** tool, the new objects become **curve objects**.

**Trim objects**

Trimming creates irregularly shaped **objects** by removing object areas that overlap. You can trim almost any object, including clones, objects on different layers, and single objects with intersecting lines. However, you cannot trim **paragraph text**, dimension lines, or masters of clones.

Before you trim objects, you must decide which object you want to trim (the **target object**) and which object you want to use to perform the trimming (the **source object**). For example, if you want to create a star-shaped cut out of a square object, the star is the source object because you are using it to trim the square. The square is the target object because it’s the object you want to trim. The source object trims the part of the target object it overlaps.

The target object retains its fill and outline attributes. For example, if you trim a rectangle that is overlapped by a circle, the area of the rectangle that was covered by the circle is removed, creating an irregular shape.

CorelDRAW lets you trim objects in different ways. You can use a front object as the source object to trim an object behind it, as well as use the back object to trim a front object. You can also remove hidden areas of overlapping objects, so that only the visible areas remain in the drawing. Removing the hidden areas can reduce file size when you convert vector graphics to bitmaps.

Trimming can be used to reduce the number of objects in a drawing. Instead of adding eyes and spots to the bug, areas (shown on the left in gray) are trimmed to reveal the black background (right).

The letter “A” is the front object used to trim the back object. A partial silhouette of the letter is created in the logo (right).
The circle is used to trim the rectangle.

To trim an object
1. Select the source objects.
2. Hold down Shift, and click the target object.
3. Click Object ➤ Shaping ➤ Trim.

If you marquee select the objects, CorelDRAW trims the bottom-most selected object. If you select multiple objects individually, the last object selected is trimmed.

You can also trim objects by marquee-selecting the source and target objects and clicking the Trim button on the property bar.

To trim front or back objects
1. Marquee select the source and target objects.
2. Click Object ➤ Shaping, and click one of the following:
   • Front minus back — removes the back object from the front one
   • Back minus front — removes the front object from the back one

You can trim the control object of a PowerClip object so that the object inside the PowerClip object will assume the new shape of the PowerClip container. For information about PowerClip objects, see “PowerClip objects” on page 263.

Linked objects such as drop shadows, text on a path, blends, contours, and extrusions are converted to curve objects before they are trimmed.

To trim overlapping areas in objects
1. Marquee select the objects you want to trim.
2. Click Object ➤ Shaping ➤ Simplify.
You can trim the control object of a PowerClip object, so that the object inside the PowerClip object assumes the new shape.

Linked objects, such as drop shadows, text on a path, blends, contours, and extrusions, are converted to curve objects before they are trimmed.

Fillet, scallop, and chamfer corners

You can fillet, scallop, or chamfer the corners of any curve object, whether it originates from a shape, lines, text, or a bitmap. Filleting produces a rounded corner, scalloping rounds and inverts the corner to create a notch, and chamfering bevels a corner so that it appears flat. CorelDRAW also lets you preview the corners before you apply the changes to them. For information about modifying the corners of squares and rectangles, see “Rectangles and squares” on page 201.

If you modify the corners of a non-curve shape, the shape is automatically converted to curves for you. The changes are applied to all corners unless you select individual nodes. However, you must convert an object to curves manually by using the Convert to curves command before you can select individual nodes. You cannot fillet, scallop, or chamfer a smooth or symmetrical curve; the corner must be created by two straight or curve segments that intersect at an angle of less than 180 degrees.

The operation is not applied to the corners when the fillet, scallop, or chamfer value is too high. This occurs when the line segments aren’t long enough to apply the radius or chamfer distance. When setting values for these operations, consider that, although the line segments may appear long enough at the beginning of the operation, they shorten as the radius or chamfer values are applied across the object.

In this example, the circles represent fillet radius settings. The top row shows the proposed fillets on the left and the filleted results on the right. The bottom row shows the proposed fillets on the left, but in the results on the right, not all corners are filleted. After the first fillet is applied, the next corner cannot be filleted because the line segment is not long enough. This corner is skipped, and the final corner is filleted.
To round object corners by filleting
1  Do one of the following:
   • Select a curve object using the Pick tool.
   • Select individual nodes on a curve object using the Shape tool.
2  Click Window ➤ Dockers ➤ Corners.
3  In the Corners docker, enable the Fillet option.
4  Type a value in the Radius box.
   The radius is used to create a circular arc whose center is equidistant from either side of a corner. Higher values produce more rounded corners.
5  Click Apply.

The Apply button is disabled if no valid objects or nodes are selected.

If you have a square or rectangle, you can also round all corners at once by dragging a corner node toward the center of the object while the Shape tool is active. The shape is not converted to curves if you use this method.

To scallop object corners
1  Do one of the following:
   • Select a curve object using the Pick tool.
   • Select individual nodes on a curve object using the Shape tool.
2  Click Window ➤ Dockers ➤ Corners.
3  In the Corners docker, enable the Scallop option.
4  Type a value in the Radius box.
   The radius value is measured from the original corner point to create a scalloping arc.
5  Click Apply.

The Apply button is disabled if no valid objects or nodes are selected.

To bevel object corners by chamfering
1  Using the Pick tool, select the object.
2  Click Window ➤ Dockers ➤ Corners.
3  In the Corners docker, enable the Chamfer option.
4 In the Chamfer distance area, type a value in the A box to set where the chamfer will begin in relation to the original corner. If you do not want the ends of the chamfer to be equidistant from the original corner, click the Lock button, and type a different value in the B box. A and B values are applied according to the direction in which the line is drawn.

5 Click Apply.

To select individual nodes using the Shape tool, you must first convert the object to curves manually by using the Convert to curves command.

Weld and intersect objects

You can create irregular shapes by welding and intersecting objects. You can weld or intersect almost any object, including clones, objects on different layers, and single objects with intersecting lines. However, you cannot weld or intersect paragraph text, dimension lines, or masters of clones.

You can weld objects to create one object with a single outline. The new object uses the welded objects' perimeter as its outline and adopts the fill and outline properties of the target object. All intersecting lines disappear.

You can weld objects regardless of whether they overlap each other. If you weld objects that do not overlap, they form a weld group that acts as a single object. In both cases, the welded object takes on the fill and outline attributes of the target object.

You can weld single objects with intersecting lines so that the object breaks into several subpaths, but its appearance remains the same.

Intersecting creates an object from the area where two or more objects overlap. The shape of this new object can be simple or complex, depending on the shapes you intersect. The new object’s fill and outline attributes depend on the object you define as the target object.

To weld objects

1 Select the source object or objects.
2 Hold down Shift, and click the target object.
3 Click Object ➤ Shaping ➤ Weld.

The new object has the fill and outline properties of the target object.
You can also weld objects by marquee-selecting the source and target objects and clicking the **Weld** button on the property bar.

**To intersect objects**

1. Select the source object or objects.
2. Hold down **Shift**, and select the target object.
3. Click **Object** ➤ **Shaping** ➤ **Intersect**.

The new object, which is created from the overlapping parts of the source and target object, has the fill and outline properties of the target object.

You can also intersect objects by selecting the source and target objects and clicking the **Intersect** button on the property bar.

**To intersect multiple objects**

1. Marquee select the source object or objects.
2. Hold down **Shift**, and click each target object.
3. Click **Object** ➤ **Shaping** ➤ **Intersect**.

You can also intersect objects by marquee-selecting the source and target objects and clicking the **Intersect** button on the property bar.

**PowerClip objects**

CorelDRAW lets you place vector objects and bitmaps, such as photos, inside other objects, or frames. A frame can be any object, for example artistic text or a rectangle. When the object is larger than the frame, the object, called the contents, is cropped to fit the form of the frame. This creates a PowerClip object.

![Objects before becoming a PowerClip object: artistic text and a bitmap](image)
In the PowerClip object, the artistic text is the frame, and the bitmap forms the contents. The bitmap is shaped to the letters of the artistic text.

The rectangle is used as a frame, and the tree is placed inside to create a PowerClip object.

You can create more complex PowerClip objects by placing one PowerClip object inside another PowerClip object to produce a nested PowerClip object. You can also copy the contents of one PowerClip object to another PowerClip object.

You can create an empty PowerClip frame from an object, or convert a PowerClip frame back to an object. Creating empty PowerClip frames or text frames is useful when you want to define the layout of your document before adding the content. For more information about text frames, see “Paragraph text” on page 599. After you create an empty PowerClip frame, you can add contents to it. You can also add contents to a PowerClip frame that already contains another object.

Creating empty PowerClip frames and text frames is useful when you want to visualize your page layout before adding the contents.

After you create a PowerClip object, you can select or edit its contents, or reposition the contents inside the frame. Whenever a PowerClip object is selected, a floating toolbar appears.

The PowerClip toolbar lets you edit, select, extract, lock, or reposition the contents inside the frame. The toolbar appears whenever a PowerClip object is selected.
You can lock the PowerClip contents, so that when you move the frame, the content moves with it. If you want to delete the contents of a PowerClip object or modify it without affecting the frame, you can extract the contents.

You can set the default behavior for dragging content to PowerClip frames, centering new content, and marking empty PowerClip frames.

To create a PowerClip object
1. Select the object that you want to use as the PowerClip contents.
2. Click Object ➤ PowerClip ➤ Place inside frame.
3. Click the object that you want to use as a frame.

If you want to create a nested PowerClip object, drag the PowerClip object inside another PowerClip object, and hold down the W key as you release the mouse button to place the object inside the frame.

You can also right-click an object or a group of objects, click PowerClip inside, and then click the object that you want to use as a container.

If the content is placed so that it falls outside the frame in its current position, it is automatically centered inside the frame to make it visible. To change this setting, click Tools ➤ Options ➤ CorelDRAW, choose PowerClip in the left pane, and set the options you want in the Auto-center new content area.

To create an empty PowerClip frame
1. Select an object that you want to use as a frame.
2. Click Object ➤ PowerClip ➤ Create empty PowerClip frame.

You can also right-click the object, choose Frame type, and click Create empty PowerClip frame.

You can also click the PowerClip frame button on the Layout toolbar. To open the Layout toolbar, click Window ➤ Toolbars ➤ Layout.

To add content to a PowerClip frame
1. Drag an object to the PowerClip frame.
   When the object approaches the frame, the frame is highlighted.
2. Do one of the following:
   • To add the object to an empty PowerClip frame, release the mouse button.
   • To add the object to a full PowerClip frame, hold down the W key as you release the mouse button.

You can also drag content to the PowerClip frame directly from the Assets docker.

If the content is placed so that it falls outside the frame in its current position, it is automatically centered inside the frame to make it visible. To change this setting, click Tools ➤ Options ➤ CorelDRAW, choose PowerClip in the left pane, and set the options you want in the Auto-center new content area.

To convert a PowerClip frame back to an object
• Right-click the PowerClip frame, choose Frame type, and click Remove Frame.
If the frame contains content, the content is deleted when the frame reverts to a regular object. To avoid losing the content, you can first extract it from the PowerClip object.

You can also click the No frame button on the Layout toolbar. To open the Layout toolbar, click Window ▶ Toolbars ▶ Layout.

To select the contents of a PowerClip object
1. Select the PowerClip object.
   The PowerClip toolbar appears.
2. Click the Select contents button on the PowerClip toolbar.

To position the contents inside a PowerClip frame
1. Select a PowerClip object.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center the contents inside the PowerClip frame</td>
<td>Click Object ▶ PowerClip ▶ Center.</td>
</tr>
</tbody>
</table>
| Fit the contents proportionally inside the PowerClip frame | Click Object ▶ PowerClip ▶ Fit Proportionally. 
   The content is resized so that its longest dimension fits inside the frame. The content is not distorted, and its aspect ratio is preserved. The whole content is visible, but there may be empty areas in the frame. |
| Fill the PowerClip frame proportionally | Click Object ▶ PowerClip ▶ Fill Proportionally. 
   The content is resized so that it fills the frame without being distorted. The content’s aspect ratio is preserved. The frame is full, but there may be parts of the content that fall outside the frame and are not visible. |
| Fill the PowerClip frame by stretching the contents | Click Object ▶ PowerClip ▶ Stretch to Fill. 
   The content is resized and distorted so that it fills the frame. The content’s aspect ratio is not preserved. The frame is full, and all of the content is visible. |

The Fit Proportionally, Fill Proportionally, and the Stretch to Fill commands modify the PowerClip contents. The content remains modified even if you extract it from the frame.

You can also position the contents by clicking the arrow button on the PowerClip toolbar and clicking a command.
Examples of PowerClip contents positioned by using the following commands: Center contents (top left), Fit contents proportionally (top right), Fill frame proportionally (bottom left), and Stretch contents to fill frame (bottom right).

To copy the contents of a PowerClip object
1. Select an object.
2. Click **Object** ➤ **PowerClip** ➤ **Copy PowerClip From**.
3. Click a PowerClip object.

To edit the contents of a PowerClip object
1. Select a PowerClip object.
2. Click **Object** ➤ **PowerClip** ➤ **Edit PowerClip**.
3. Edit the contents of the PowerClip object.
4. Click **Object** ➤ **PowerClip** ➤ **Finish Editing PowerClip**.

While you edit the contents, the frame appears in Wireframe mode and cannot be selected or edited.

You can also double-click the PowerClip object to enable it for editing, or select the PowerClip object and click the **Edit** button on the PowerClip toolbar. When you have finished editing the contents, click the **Finish** button.

To lock or unlock the contents of a PowerClip object
1. Select a PowerClip object.
2. Click **Object** ➤ **PowerClip** ➤ **Lock Contents to PowerClip**.

If you move the frame while the content is unlocked, the content remains stationary and is not visible until you move the frame over it.
You can also right-click a PowerClip object and click **Lock Contents to PowerClip**, or you can select the PowerClip object and click the **Lock Contents** button on the PowerClip toolbar.

### To extract the contents of a PowerClip object

1. Select a PowerClip object.
2. Click **Object ➤ PowerClip ➤ Extract Contents**.

   The content remains in the same location, but it is separated from the frame. The PowerClip frame remains as an empty PowerClip frame.

You must extract the contents of each level in a nested PowerClip separately.

You can also select the PowerClip object and click the **Extract Contents** button on the PowerClip toolbar.

### To set default options for PowerClip frames

1. Click **Tools ➤ Options ➤ CorelDRAW**.
2. In the left pane of the dialog box that appears, click **PowerClip**.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Set the default behavior for dragging content to a PowerClip frame | From the **Drag content inside PowerClip** list box, choose **PowerClip with content** or **Empty PowerClip**, and then choose one of the following options:  
  - **Ignore PowerClip frame** — places the content on top of the PowerClip frame instead of inside  
  - **Add content to PowerClip frame**  
  - **Replace existing content** (available only for PowerClip frames with content) |
| Set the default behavior for centering new content in a PowerClip frame | In the **Auto-center new content** area, choose one of the following options:  
  - **When content is completely outside frame** — centers content only if it is beyond the boundaries of the PowerClip frame and will not be visible otherwise  
  - **Always** — always centers new content  
  - **Never** — turns off auto-centering |
| Mark empty PowerClip frames | Enable the **Show lines in empty PowerClip frames** check box, and choose one of the following options:  
  - **Always (including print and export)** — displays lines in empty PowerClip frames on screen and in printed or exported documents  
  - **On screen only** — displays lines in empty PowerClip frames only on screen |
Options for nodes, handles, and previews

The Nodes and Handles page of the CorelDRAW Options dialog box lets you customize the appearance of nodes, handles, and vector previews to match your preferences, making it easier to edit nodes and apply vector effects and transformations.

General settings

You can change the size and shape of nodes, and you can choose to hide or show the curve direction when editing. Three preset sizes are available for nodes and handles: small, medium, and large.

By default, each of the three node types has a different shape. Cusp nodes appear as squares, smooth nodes as circles, and symmetrical nodes as diamonds. You can change the shape of any node type, choosing from shapes such as triangles, diamonds, circles, and polygons. For information about the different type of nodes, see “Node types” on page 228.

The Shape tool is usually used to select and move nodes. You can enable node tracking to select and move nodes by using the Pick, Freehand, Polyline, or Bézier tool.

Color settings

The Default color scheme uses blue as the main color and red as the secondary color for displaying nodes, control handles, and previews while you are editing. The main color is used in the first curve you select. When you select additional curves with the Shape tool, they are displayed in red, the secondary color. In addition, the Default color scheme applies a white highlight to improve visibility. This white highlight color is also used to fill unselected nodes and to make vector previews stand out. You can also choose to show unselected nodes without a fill.
When nodes and handles become hard to see against more complex backgrounds, you can use a keyboard shortcut (Ctrl+Shift+I) to replace the main color with the secondary color and vice versa. You can also switch between showing unselected nodes with and without a fill by using a keyboard shortcut (Ctrl+Shift+G).

You can create a custom color scheme by changing the main and the secondary colors. In addition, you can hide the highlight from previews. To distinguish nodes types more easily, you can set the application to display each node type in a different color.

**To set general options for nodes, handles, and previews**

1. Click **Tools ➤ Options ➤ CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Nodes and Handles**.
3. Perform any of the tasks in the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the node size</td>
<td>Choose a size from the <strong>Node size</strong> list box.</td>
</tr>
<tr>
<td>Change the shapes of nodes</td>
<td>From the <strong>Node shape</strong> list boxes, choose a shape for each node type: cusp, smooth, and symmetrical.</td>
</tr>
<tr>
<td>Revert to the default node shapes</td>
<td>Next to the <strong>Nodes shape</strong> list boxes, click <strong>Reset</strong>.</td>
</tr>
</tbody>
</table>

With the Default color scheme, the main color for nodes, handles, and previews is blue (right). The secondary color, red, is used for the additional curve selected with the Shape tool (left). Unselected nodes are filled with white, the highlight color.

Unselected nodes are shown with a fill (left) and without a fill (right).
To show or hide the direction of selected curves

Do the following

Enable or disable the **Show curve direction when editing** check box.

Select and move nodes by using the Pick, Freehand, Polyline, or Bézier tool

Do the following

Enable the **Enable node tracking** check box.

Show unselected nodes without a fill

Do the following

Disable the **Show unselected nodes with fill** check box.

To switch color settings for nodes, handles, and previews by using keyboard shortcuts

1. Select the nodes you want with the **Shape** tool.
2. Perform a task from the following table.

Replace the main color with the secondary color and vice versa

Press **Ctrl+Shift+I**.

Switch between showing unselected nodes with a fill and without a fill

Press **Ctrl+Shift+G**.

To choose a color scheme

1. Click **Tools ▶ Options ▶ CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Nodes and Handles**.
3. In the **Colors** area, choose one of the following color schemes from the **Color scheme** list box:
   - Default
   - Custom

   The controls below the **Color scheme** list box become available only after you choose **Custom** from the **Color scheme** list box.

To create a custom color scheme for nodes, handles, and previews

1. Click **Tools ▶ Options ▶ CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Nodes and Handles**.
3. In the **Colors** area, choose **Custom** from the **Color scheme** list box.
4. Open the following color pickers, and choose a color:
   - **Main color** — used in nodes and handles when an object is selected for editing. When you select multiple objects for editing, the main color is used for the nodes and handles of the first selected object
   - **Secondary color** — used in nodes and handles when additional objects are selected for editing with the **Shape** tool or when you are editing vector effects such as extrusions

You can also

Hide the highlight color from vector previews

Disable the **Show highlight** check box.
You can also

Display each node type in a different color

Revert to the default main and secondary colors

Enable the Show node types in different colors check box.

Click Reset next to the Main color and the Secondary color picker.

The Reset button is available only for custom color schemes.
Symmetrical drawing

CorelDRAW lets you create symmetrical objects and designs in real time, making you more productive by automating what is usually a very time-consuming workflow. Whether you want to create simple symmetrical objects or a complex kaleidoscopic design, the Symmetry drawing mode provides you with the controls you need to accomplish your task.

You can include both vector and bitmap objects in your symmetrical designs.

Examples of a simple and a more complex symmetrical design using vector objects
Create symmetry

To create symmetry, you can convert an existing object to a symmetry group, or you can start from scratch by drawing objects in symmetry mode. The objects that you convert or draw are known as primary objects; the objects generated by the symmetry are known as object copies.

CorelDRAW offers mirror symmetry, which lets you create identical shapes and curves that are mirrored or reflected on a set of planes. In the default mirror symmetry mode, primary objects are reflected along a single symmetry line. If you want to create a more complex design, you can add more symmetry lines.

When creating a symmetry group from scratch, you can start by setting up the planes of symmetry. You can add more symmetry lines to create more object copies. In addition, you can reposition and rotate the symmetry lines by dragging them in the drawing window or by specifying values on the property bar. Each symmetry group has a center of symmetry, which is shown by a circular cursor when the
symmetry lines are selected. With multi-line symmetry, the intersection point of the symmetry lines is the center of symmetry. Symmetry lines are rotated about the center of symmetry. You can move the center of symmetry by dragging it, or you can specify its exact location by using x and y coordinates.

For information about how to edit symmetry groups, see “Edit symmetry” on page 276.

To create a symmetry group from objects
1 Select or draw a curve or a shape.
2 Click Object ➤ Symmetry ➤ Create New Symmetry.
   A symmetry line appears in the drawing window, and the primary object is duplicated and mirrored.
   Edit the primary object or add more objects.
3 Click Object ➤ Symmetry ➤ Finish Editing Symmetry.

   To accurately mirror an object that has a calligraphic outline, you must first link the outline thickness to the object’s size. To do this, select the object, double-click the Outline icon on the status bar, and in the Outline Pen dialog box, enable the Scale with object check box.

   You can also create a symmetry group from an object by right-clicking the object and clicking Create New Symmetry.
   You can create a symmetry group from multiple shapes and curves.

To create a mirror symmetry group from scratch
1 Click Object ➤ Symmetry ➤ Create New Symmetry.
   To add more symmetry lines for a more complex symmetry group, type a number in the Mirror lines box on the property bar. You can use up to 12 lines of symmetry.
   You can also adjust the symmetry lines. For more information, see “To set up the planes of symmetry” on page 275.
2 Draw a curve or a shape.

To set up the planes of symmetry
1 Click Object ➤ Symmetry ➤ Create New Symmetry.
   If you want to change the planes of symmetry in an existing symmetry group, click Object ➤ Symmetry ➤ Edit Symmetry.
2 Perform a task from the following table.
To | Do the following
--- | ---
Specify the number of symmetry lines | Type a number in the **Mirror lines** box on the property bar. You can add up to 12 symmetry lines.
Reposition a symmetry line | Using the **Pick tool**, drag the symmetry line in the drawing window.
Rotate a symmetry line | Using the **Pick tool**, click the symmetry line twice, and drag a rotation handle. Tip: You can also rotate a symmetry line by typing a value in the **Angle of rotation** box on the property bar.
Specify the center of symmetry | Type values in the X and Y boxes. This action repositions the symmetry lines.

**Edit symmetry**

You can edit symmetry groups in any of the following ways: by editing the objects in the symmetry group; by adding, repositioning, and rotating symmetry lines; and by editing the symmetry group as a single entity.

When editing a symmetry group, you can preview only the outline of object copies for faster rendering. This view makes it easy to identify the primary objects. You can also preview the object copies as full objects with the same fills, outlines, and effects that are applied to the primary objects. You can toggle quickly between the two preview modes. To evaluate the results more easily, you can also hide the symmetry lines.

You can use the **Pick tool** and **Shape tool** to modify the objects in a symmetry group. When you reshape the primary objects with the **Shape tool**, the vector previews appear in the default main color, and the object copy outlines appear in the default secondary color. For information about these preview colors and how to change them, see “Options for nodes, handles, and previews” on page 269.
You can apply fills, effects, and transparencies to the primary objects. Any changes you make to the primary objects are reflected in the object copies. You can add objects to the symmetry group, and you can delete objects you no longer need. In addition, you can drag objects into a symmetry group even if the group is not in Edit symmetry mode.

Modifying the symmetry lines affects how the elements in the symmetry group are positioned and oriented. You can add more symmetry lines for more object copies. In addition, you can move the symmetry lines to increase or decrease the distance between the primary objects and object copies; and you can rotate the symmetry lines. For more information, see “To set up the planes of symmetry” on page 275.
Move the symmetry line to change the distance between primary objects and object copies.

Rotating the symmetry line

As with any group of objects, you can move, rotate, and scale the symmetry as a single entity, preserving the spatial relationship between its elements. You can also apply fills and transparencies to the entire symmetry group, and you can modify the outline properties.

The symmetry group on the left is scaled (middle) and then rotated (right) with the Pick tool.

When you are editing a symmetry group, it is easy to snap objects to the symmetry line because the View ➤ Snap to ➤ Symmetry Lines command is enabled by default. This feature helps you fuse open curves and create closed shapes in your symmetrical design. If you don’t want the objects you edit to snap to the symmetry line, you can disable snapping to symmetry lines.

To edit the objects of a symmetry group
1. Select a symmetry group.
   A floating toolbar appears below the property bar.
2 Click Edit on the toolbar.
3 Edit the primary objects in the group by using the Shape tool and the Pick tool. You can also apply fills and transparencies, and you can apply effects such as contours, envelopes, blends, and distortions.
4 Add and delete objects as needed.
5 Click the Finish on the toolbar.

You can also

Display object copies as outlines or full objects
Click the Show full preview button on the property bar to disable or enable it.

Show or hide symmetry lines
Click the Show symmetry lines button on the property bar to disable or enable it.

You can start editing a symmetry group by double-clicking it or by clicking Object ▶ Symmetry ▶ Edit Symmetry. You can also enter the Edit Symmetry mode by clicking a selected symmetry group while holding down Ctrl.

You can also finish editing a symmetry group by clicking Object ▶ Symmetry ▶ Finish Editing Symmetry.

To drag an object into a symmetry group that contains objects
• Drag the object over the symmetry group, hold down W, and release the mouse button.

To drag an object into an empty symmetry group
• Drag the object over the symmetry group, and release the mouse button.

To edit a symmetry group as a single entity
1 Using the Pick tool, click the symmetry group.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the symmetry group</td>
<td>Drag it to a new location in the drawing window.</td>
</tr>
<tr>
<td>Scale the symmetry group</td>
<td>Drag a corner selection handle.</td>
</tr>
<tr>
<td>Rotate the symmetry group</td>
<td>Click the symmetry group again to display the rotation handles, and drag a rotation handle.</td>
</tr>
<tr>
<td>Apply a fill to the symmetry group</td>
<td>Click the Interactive fill tool and drag across the symmetry group. For more information about fills, see “Fills” on page 425.</td>
</tr>
</tbody>
</table>
To Do the following

Applying a fill to a symmetry group changes the fill of each object in the symmetry group. Bitmap and vector pattern fills are not reflected.

![Applying a fill to a symmetry group](image)

Apply a transparency to the symmetry group

Click the Transparency tool and choose transparency settings from the property bar. For more information about transparencies, see “Object transparency” on page 447.

![Applying a uniform transparency to a symmetry group](image)

The transparency replaces any transparencies that may have been applied to individual objects in the group.

Bitmap and vector pattern transparencies are not reflected.

Add an outline to a symmetry group

Double-click the Outline icon on the status bar, and set the outline properties you want in the Outline Pen dialog box. For more information about outlines, see “Format lines and outlines” on page 174.

Adding an outline to a symmetry group changes the outline of each object in the symmetry group.
To preserve the symmetry, skewing and stretching a symmetry group are not allowed.

You can move, scale, and rotate a symmetry group with precision by using the controls on the property bar.

**To disable snapping to symmetry lines**
- In Edit symmetry mode, click View ▶ Snap to ▶ Symmetry Lines.

Disabling snapping to symmetry lines makes it difficult to fuse curves in symmetry groups.
For more information about snapping options, see “Snap objects” on page 333.

**Fuse curves in symmetry groups**

If you want to apply a fill to an open curve and its mirrored copy, you need to fuse them into a single curve. For successful fusion to take place, the end points of the curves must be snapped to the symmetry line.

![From left to right: Creating an open curve; snapping the end points to the symmetry line; filling the fused curve.](image)

When two curves are fused, the fill of the primary curve is applied to the reflected curve. However, nodes appear only on the primary curve of the fused object. You can adjust the shape of the fused object by manipulating the nodes of the primary curve.

**To fuse open curves in a symmetry group**

1. Click Object ▶ Symmetry ▶ Edit Symmetry.
2. Click the open curve that you want to fuse with its mirrored copy.
   - If the curve end points do not meet on the symmetry line, drag them with the Shape tool until they snap to the symmetry line. If it is difficult to snap the end points of the primary curve to the symmetry line, make sure that the Snap to Symmetry Lines command is enabled (View ▶ Snap to ▶ Symmetry Lines).
3. On the property bar, click the Fuse open curves button.
Only the selected curve set is fused into a single object. Unselected open curves are not affected.

You can undo the fusion by clicking the **Fuse open curves** button on the property bar to disable it.

### Remove symmetry and break symmetry links

If you want to delete all object copies from a symmetry group and keep only the primary objects, you can remove the symmetry.

![Symmetry examples](image)

*Left to right: Symmetry group in Edit mode; the symmetry group in normal state; the symmetry is removed, leaving only the primary objects.*

After completing a symmetry group, you may want to make some of its elements non-symmetrical. To do this, you need to break the symmetry link of the symmetry group, turning it into a regular group of objects. You can then edit individual objects in the group.

![Symmetry examples](image)

*The symmetry link is broken in the symmetry group on the left. Then, some objects are resized, and other objects are deleted (right).*

### To remove the symmetry from a symmetry group

1. Select a symmetry group.
2 Click **Remove** on the floating toolbar that appears below the property bar. All object copies are deleted.

You can also remove the symmetry link by clicking **Object ▶ Symmetry ▶ Remove Symmetry**.

You can also right-click a symmetry group, and click **Remove Symmetry**.

**To break the symmetry link of a symmetry group**

1 Select a symmetry group.

2 Click **Break Link** on the floating toolbar that appears below the property bar. After the symmetry link is broken, the symmetry group becomes a regular group of objects.

You can also break the symmetry link by clicking **Object ▶ Symmetry ▶ Break Symmetry Link**.

You can also right-click a symmetry group, and click **Break Symmetry Link**.
Perspective drawing

CorelDRAW lets you draw in perspective so that you can add depth and dimension to your 2D designs and illustrations. Perspective drawing is especially useful for creating complex compositions that have many components sharing the same perspective, such as scenery.

Perspective drawing was used to create this illustration.

This section contains the following topics:

- “Draw in perspective” (page 286)
- “Edit perspective groups” (page 291)
- “Break perspective groups apart” (page 296)

To create the illusion of distance and depth, you can also apply a perspective effect to existing objects. For more information, see “Apply perspective” on page 555.
Draw in perspective

Using perspective drawing (Object ▶ Perspective ▶ Draw in Perspective), you can draw complex sketches, patterns, and designs, creating the illusion of distance and depth.

When you draw in perspective, CorelDRAW automatically creates a perspective field and lets you add lines and shapes that align with the perspective lines. The result is a perspective group comprising of the perspective field and the objects you added. A drawing can contain multiple perspective groups with unique perspective fields.

A perspective group consists of a perspective field and one or more objects.

The perspective field includes a grid of perspective lines that converge towards one, two or three vanishing points. The visible part of the perspective field is called viewport.

Elements of a perspective field: Perspective grid (1), horizon (2), vanishing point (3), viewport (4)

CorelDRAW provides presets for three types of perspective: one-point, two-point and three-point perspective.

- **One-point** — creates a perspective field where all lines recede from view towards one vanishing point
- **Two-point** — creates a perspective field where all lines recede from view towards two vanishing points
• **Three-point (worm’s-eye view)** — creates a perspective field where all lines recede from view towards one of three vanishing points. This preset helps you create views as seen from below.

• **Three-point (bird’s-eye view)** — creates a perspective field where all lines recede from view towards one of three vanishing points. This preset helps you create views as seen from above.

Before you start drawing in the perspective field, you can choose the plane you want to draw on. You can choose to draw on an orthographic plane, which is a flat plane without perspective, on the top perspective plane or on one of the side perspective planes.

Perspective types: (1) one-point, (2) two-point, (3) three-point (worm’s-eye view), (4) three-point (bird’s-eye view)

Before you start drawing in the perspective field, you can choose the plane you want to draw on. You can choose to draw on an orthographic plane, which is a flat plane without perspective, on the top perspective plane or on one of the side perspective planes.

Perspective drawing assumes that the viewer or the camera is at a certain distance from objects. All objects are scaled relative to the viewer. In CorelDRAW, the position of the viewer is indicated by camera lines, which you can use as a drawing aide to place objects. Camera lines are linked to the active perspective plane and are hidden by default. After displaying a camera line, you can move it to increase or decrease the distance between the viewer and the depicted objects. Moving a camera line doesn’t change existing objects, but impacts how an object
appears when it is moved to the active plane. If an object side aligns with the camera line, that side appears at 100% - it is not shortened or lengthened. Object sides or objects that appear at a distance from the camera line will appear smaller than their actual size.

![Perspective example](image)

The red rectangle is further away from the camera line so it appears smaller than the blue rectangle.

You can customize the perspective drawing presets by adjusting the perspective field. For example, you can move vanishing points, horizon lines, and camera lines. You can also resize the viewport.

For information about how to edit perspective groups, see “Edit perspective groups” on page 291.

When you save a drawing that contains perspective groups to a CorelDRAW version earlier than 23.0 (2021), the perspective groups keep their appearance, but they are saved as regular groups of objects.

To draw in perspective

1. Using the **Pick** tool, click an empty space in the drawing window to make sure no objects are selected.

2. Click **Object ▶ Perspective ▶ Draw in Perspective**.

3. Choose a perspective type from the **Type** list box.
   - One-point
   - Two-point
   - Three-point (worm’s-eye view)
   - Three-point (bird’s-eye view)

4. Do one of the following:
   - Drag in the drawing window to set the perspective field.
   - Press **Enter** to fill the page with a perspective field.

   If you want to reset the perspective field, click **Edit ▶ Undo**, and draw the perspective field again.

5. To choose the plane you want to draw on, click one of the following buttons:
   - **Orthographic** — to draw on a flat plane, without perspective
• **Top**  — to draw on the top perspective plane
• **Side**  — to draw on the side perspective plane. This button is available only for one-point perspective.
• **Left**  — to draw on the left perspective plane
• **Right**  — to draw on the right perspective plane

6 Click a line or a shape tool, and draw one or more objects.
7 Click **Finish** on the floating toolbar.

You can’t change the perspective type after drawing the perspective field.
The application prevents you from drawing in perspective in certain areas so that you don’t get unexpected results. For example, you can’t draw an object over a vanishing point on a perspective plane.
You cannot draw in perspective when in Focus mode. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

You can modify the appearance of the perspective field to suit your needs. For example, you can increase the number of the perspective lines for greater drawing precision. For information, see “To modify the appearance of the perspective field” on page 295.
You can also draw objects on the orthographic plane, without perspective, and then move (project) them to another plane. For more information, see “Move an object to another plane” on page 294.
You can also add an existing object to the perspective group. For more information, see "Add an object to the perspective group" on page 294.

**To adjust the perspective field**

1 Click **Object**  **Perspective**  **Draw in Perspective**.
2 Choose a perspective type from the **Type** list box on the floating toolbar, and choose a plane to draw on.
3 Using the **Pick** tool , perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the vanishing point</td>
<td>Drag a vanishing point to a new position.</td>
</tr>
</tbody>
</table>
To Do the following

Move the vanishing point

Move a horizon line
Point to a horizon line, and when the cursor changes to a double-sided arrow, drag the horizon line to a new position.

Resize the viewport
Click the viewport frame to display its handles. Drag a middle handle to adjust the width or height of the viewport. Drag a corner handle to resize the viewport proportionally.

Move a camera line
Click the Show camera lines button on the floating toolbar to display the camera line. Drag the camera line to a new position.

Note: A camera line on the orthographic plane cannot be moved.

Tip: You can also drag a camera line by one of its diamond-shaped handles.

Two identical rectangles are added to the left plane with the camera line at a different position. Their right sides remain the same, at 100% of their size, because they are aligned with the camera line.
For best results, adjust the perspective field before drawing or adding objects in perspective.

Each time you move a vanishing point, horizon line, or camera line, the perspective field is redrawn. Existing objects remain unchanged but each new object you draw reflects the new position of the vanishing point, horizon line or camera line.

If you can’t move a vanishing point, horizon line or camera line, click the Lock perspective field button on the floating toolbar to allow changes to the perspective field.

To prevent accidental changes to the perspective field, click the Lock perspective field button again after you finish editing.

Edit perspective groups

You can edit perspective groups by moving and editing the objects in the group, and by adding objects.

You can move, rotate, and scale objects within a perspective group. Also, you can move an object in a perspective group from one plane to another to change its view. For example, you can place the object on the orthographic plane to remove the perspective, or you can move an object from the top plane to a side plane, and vice versa. You can also move objects from the orthographic plane to any available perspective plane.

The objects are moved from the orthogonal plane (left) to the left plane (right).

While you are in Edit mode, you can add existing objects, such as vector shapes, text and bitmaps, to the perspective group by moving them to a plane. Text added to perspective groups isn’t converted to curves, so you can edit and reformat it.
A rectangle, a text object, and a bitmap (left) were moved to the right plane (right) and are now included in the perspective group.

You can also shape and edit the objects in a perspective group by using the **Shape** tool. When you draw and edit objects in a perspective group, snapping to perspective lines (View ▶ Snap To ▶ Perspective Lines) is enabled by default. If you want to snap objects only to guidelines, you can disable snapping to perspective lines. For more information about using guidelines to help with object placement, see "Set up guidelines" on page 744.

You can move and scale proportionally perspective groups as you would any other groups. However, perspective groups can’t be resized nonproportionally, rotated, or skewed.

In addition, you can modify the appearance of the perspective field in each perspective group. For example, you can hide and show horizon and perspective lines, and you can customize the color of the lines and adjust their opacity. Adjusting the line color and opacity can help you focus on the objects you draw; conversely, it can make the lines and handles stand out so that you can adjust the perspective field more easily.

Depending on the drawing precision you want, you can adjust the density of the perspective field by adding or removing perspective lines.
The perspective field is customized by changing the color of the horizon line and viewport, and increasing the number and opacity of the perspective lines.

To edit a perspective group
1. Select a perspective group.
2. Click **Edit** in the upper-left corner of the drawing window. A floating toolbar appears.

To

Do the following

Select an object in the perspective group

Click the object using the **Pick** tool.

**Tip:** You can also marquee-select the object.

Move an object along the plane it was drawn

Using the **Pick** tool, drag the object to a new position. The object maintains its perspective but is redrawn to reflect its new position in relation to the vanishing point.

**Tips:**
- You can also use the arrow keys to nudge the object.
- You can specify x and y coordinates on the property bar.

Scale an object

Drag a corner handle.

**Tip:** To resize the object non-proportionally, drag a middle handle.

Rotate an object

Click the object to display the rotation handles, and drag a rotation handle.
To move an object to another plane

Do the following

Right-click the object, click Move to Plane, and then click one of the following commands:

- Move to Orthogonal Plane — to place the object on a flat plane, removing the perspective
- Move to Top Plane — to place the object on the top perspective plane
- Move to Left Plane — to place the object on the left perspective plane
- Move to Right Plane — to place the object on the right perspective plane
- Move to Side Plane — to place the object on the side perspective plane

Note: Only commands relevant for the selected object are displayed.

To add an object to the perspective group

3 Click Finish on the floating toolbar.

Perspective groups cannot be edited when Focus mode is activated. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

You can start editing a selected perspective group by clicking Object ➤ Perspective ➤ Edit Perspective Group. You can also right-click a perspective group, and click Edit Perspective Group.

To reshape an object placed on a perspective plane

1 Select a perspective group.
2 Click Edit in the upper-left corner of the drawing window.
3 Using the Shape tool , click the object you want to edit.
   The object is temporarily moved to the orthographic plane.
4 Edit the object to achieve the shape you want.
5 Click the Pick tool .
   The edited object is automatically projected on the perspective plane where it resided before it was edited.
To edit text placed on a perspective plane
1. Select a perspective group.
2. Click Edit in the upper-left corner of the drawing window.
3. Using the Text tool, click the text.
4. Edit and format the text in the Edit Text dialog box.

To move or scale a perspective group
1. Using the Pick tool, select a perspective group.
2. Do any of the following:
   • Drag the group to a new position in the drawing window.
   • Drag a handle to scale the group.

Perspective groups can’t be resized nonproportionally, rotated, or skewed. To apply any of these transformations to a perspective group, you must break it apart first. For more information, see “Break perspective groups apart” on page 296.

To modify the appearance of the perspective field
1. Select a perspective group.
2. Click Edit in the upper-left corner of the drawing window.
3. Using the controls on the toolbar that appears, perform a task from the following table.
To

Show or hide the camera lines

Click the Show camera lines button.

Show or hide the horizon lines

Click the Show horizon button.

Change the opacity of horizon lines

Move the Horizon opacity slider.

Change the color of horizon lines

Choose a color from the Horizon color picker.

Show or hide perspective lines

Click the Show perspective lines button.

Adjust the density of the perspective field

Move the Density slider to add or remove perspective lines.

Change the opacity of perspective lines

Move the Line opacity slider.

Change the color of perspective lines

Choose a color from the Line color picker.

4 Click Finish on the floating toolbar.

Break perspective groups apart

Breaking a perspective group apart removes the perspective field while preserving the appearance of the objects in a perspective group. The perspective group becomes a regular group that can be manipulated and edited as you would any other group; each object in the group keeps its perspective effect. However, you will no longer be able to edit the objects in perspective.

The perspective group (left) was broken apart and then rotated (right).

To break a perspective group apart

1 Select a perspective group.

2 Click Object ➤ Break Perspective Group Apart.
You can also right-click a perspective group, and click Break Perspective Group Apart.
Objects, symbols, and layers

Objects................................................................................................................................................................................................ 301
Link and embed objects...................................................................................................................................................................... 365
QR codes............................................................................................................................................................................................. 367
Layers...................................................................................................................................................................................................373
Symbols............................................................................................................................................................................................... 383
Manage and track projects..................................................................................................................................................................393
Objects

Working with objects is an essential part of creating drawings.

This section contains the following topics:

- “Select objects” (page 302)
- “Edit objects in Focus mode” (page 305)
- “Transform objects” (page 308)
- “Copy, duplicate, and delete objects” (page 311)
- “Create objects from enclosed areas” (page 314)
- “Create a boundary around objects” (page 314)
- “Feather object edges” (page 315)
- “Use object coordinates to draw and modify objects” (page 316)
- “Copy object properties, transformations, and effects” (page 324)
- “Clone objects” (page 326)
- “Position objects” (page 327)
- “Align and distribute objects” (page 329)
- “Apply object hinting” (page 333)
- “Snap objects” (page 333)
- “Dynamic guides” (page 337)
- “Alignment guides” (page 340)
- “Change the order of objects” (page 345)
- “Size and scale objects” (page 346)
- “Rotate and mirror objects” (page 348)
- “Modify objects with the Properties docker” (page 350)
- “Fit objects to a path” (page 351)
- “Group objects” (page 355)
- “Combine objects” (page 357)
- “Lock objects” (page 358)
- “Find and replace objects” (page 359)
- “Hide and show objects” (page 361)
- “Constrain objects” (page 362)
- “Export objects” (page 363)
- “Bar codes” (page 363)
Select objects

Before you can change an object, you must select it. You can select visible objects, objects that are hidden from view by other objects, and a single object in a group or a nested group. In addition, you can select objects in the order in which they were created, select all objects at once, and deselect objects.

A bounding box appears around a selected object, and an “X” appears at its center.

You can select a single object from a group.

You can marquee select objects by enclosing them with a selection area of rectangular or irregular shape.

Marquee selecting objects using a rectangular selection area (top) and a selection area of irregular shape (bottom)

You can create selection groups that let you select specific objects simultaneously without grouping them. Selection groups are associated with numbers from 0 to 9 and are saved with the document. When you press the number associated with a selection group, all objects
in this group are selected. You can also select and zoom into all objects in a selection group at the same time. You can add objects to a selection group.

Usually, you select objects by using the Pick tool. By default, all objects are treated as filled so that you can select any unfilled object by clicking on its outline or the area surrounded by the outline. However, you can change this default behavior so that you can select unfilled objects only by clicking on their outlines. Changing the default behavior is useful when you work with line drawings and often need to select objects that appear beneath other objects.

To select objects

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select an object</strong></td>
<td>Click the Pick tool , and then click an object.</td>
</tr>
<tr>
<td><strong>Select multiple objects</strong></td>
<td>Click the Pick tool , hold down Shift, and click each object that you want to select.</td>
</tr>
<tr>
<td><strong>Marquee select objects by using a rectangular selection area</strong></td>
<td>Click the Pick tool , and drag around the objects that you want to select. To constrain the selection area to a square, hold down Ctrl while dragging.</td>
</tr>
<tr>
<td><strong>Marquee select objects by using a selection area of irregular shape</strong></td>
<td>Click the Freehand pick tool , and drag around the objects that you want to select. Objects that are only partially enclosed by the selection area are not selected. To select objects that are only partially enclosed by the selection area, hold down Alt while dragging. To constrain the selection area to a rectangular shape, hold down Ctrl while dragging.</td>
</tr>
<tr>
<td><strong>Select an object while reviewing objects in the order of their creation, starting with the first object created</strong></td>
<td>Click the Pick tool , and then press Shift + Tab one or more times, until a selection box appears around the object that you want to select.</td>
</tr>
<tr>
<td><strong>Select an object while reviewing objects in the order of their creation, starting with the last object created</strong></td>
<td>Click the Pick tool , and then press Tab one or more times, until a selection box appears around the object that you want to select.</td>
</tr>
<tr>
<td><strong>Select all objects</strong></td>
<td>Click Edit → Select All → Objects.</td>
</tr>
<tr>
<td><strong>Select an object in a group</strong></td>
<td>Hold down Ctrl, click the Pick tool , and then click an object in a group.</td>
</tr>
<tr>
<td>To</td>
<td>Do the following</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Select an object in a nested group</td>
<td>Hold down \textit{Ctrl}, click the \textbf{Pick tool}, and then click an object one or more times, until a selection box appears around it.</td>
</tr>
<tr>
<td>Select an object hidden from view by other objects</td>
<td>Hold down \textit{Alt}, click the \textbf{Pick tool} or the \textbf{Freehand pick tool}, and then click the topmost object one or more times, until a selection box appears around the hidden object.</td>
</tr>
<tr>
<td>Select multiple hidden objects</td>
<td>Hold down \textit{Shift} + \textit{Alt}, click the \textbf{Pick tool} or the \textbf{Freehand pick tool}, and then click the topmost object one or more times, until a selection box appears around the hidden objects.</td>
</tr>
<tr>
<td>Select a hidden object in a group</td>
<td>Hold down \textit{Ctrl} + \textit{Alt}, click the \textbf{Pick tool}, and then click the topmost object one or more times, until a selection box appears around the hidden object.</td>
</tr>
</tbody>
</table>

The status bar displays a description of each hidden object as you select it.

**To create a selection group**

1. Click the \textbf{Pick tool}, hold down \textit{Shift}, and click each object that you want to include in the selection group.

2. Press \textit{Ctrl} + a number from 0 to 9.
   
   The number you pressed is associated with the new selection group.

\textbf{You can also}

Select all objects in a selection group

Select and zoom in on all objects in a selection group

Add an object to a selection group

Select the object, and press \textit{Alt} + the number associated with the selection group.

**To deselect objects**

To

Deselect all objects

Click the \textbf{Pick tool}, and click a blank space in the drawing window.
To do the following

Deselect a single object among multiple selected objects

Hold down Shift, click the Pick tool , and then click the object.

To change how unfilled objects are selected

1. Click Tools ➤ Options ➤ Tools.
2. In the left pane of the dialog box that appears, click Pick.
3. Enable or disable the Treat all objects as filled check box.

Enabling the check box lets you select an unfilled object by clicking on its outline or the area enclosed by the outline; disabling the check box lets you select an unfilled object by clicking only on its outline.

Using the Pick tool, you can also click the Treat all objects as filled button on the property bar when no objects are selected.

Edit objects in Focus mode

Focus mode enables you to isolate design elements, such as objects and bitmaps, within the context of your drawing. This facilitates the selection and editing of specific objects, including groups within groups, overlapping elements, and more. When you bring an object into focus, it is temporarily brought to the front of the stacking order. A transparent overlay covers all other design elements that cannot be edited or selected. You can adjust the opacity of the overlay.

When you bring an object into focus, with the exception of an object group, it is placed in temporary container called a Focus group. The in-focus object appears with the name Focus Group in the Objects docker.

When you activate Focus mode, a floating toolbar appears in the top-left corner of the drawing window displaying the focused object’s place in the hierarchy of the design. Using the breadcrumb controls on the floating toolbar, you can shift focus to other parts of the design without opening the Objects docker.

When you exit Focus mode, all changes that you have made to objects or object groups are retained, and the object’s name and place in the design hierarchy are restored in the Objects docker.
The Focus mode toolbar appears when you bring a design element into focus. It displays the position of the in-focus object within the design hierarchy, allows you to shift focus to other design elements, and lets you exit Focus mode.

You can focus on objects, grouped objects, PowerClip objects, symmetry groups, bitmaps, and more.

Some object types can’t be brought into Focus mode. Others can be brought into Focus mode, but with limited functionality.

**Unsupported objects**

<table>
<thead>
<tr>
<th>Object type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple objects (ungrouped)</td>
<td></td>
</tr>
<tr>
<td>Symbols in master symbol edit mode</td>
<td>Symbols not already in edit mode can be brought into focus. For more information about editing symbols, see &quot;To edit a symbol&quot; on page 384.</td>
</tr>
<tr>
<td>Rollover objects in edit mode</td>
<td>Rollover objects not already in edit mode can be brought into focus. Entire rollover objects can be brought into focus, but not individual rollover state objects. For more information about editing rollovers, see &quot;To modify an object’s rollover state&quot; on page 878.</td>
</tr>
<tr>
<td>Perspective groups or perspective drawing</td>
<td></td>
</tr>
<tr>
<td>Borders and grommets</td>
<td></td>
</tr>
<tr>
<td>Dimension lines</td>
<td>Dimension text can be brought into Focus mode.</td>
</tr>
<tr>
<td>Impact effects</td>
<td></td>
</tr>
<tr>
<td>Tables</td>
<td></td>
</tr>
<tr>
<td>Connector lines</td>
<td>Connector lines and objects attached to connector lines cannot be brought into Focus mode.</td>
</tr>
</tbody>
</table>

**Limited support design elements**

<table>
<thead>
<tr>
<th>Object type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text objects (artistic text, paragraph text, text on a path)</td>
<td>Text objects cannot be brought into Focus mode by double-clicking.</td>
</tr>
</tbody>
</table>
Object type

Text objects (artistic text, paragraph text, text on a path)

Notes

Text objects on a path are brought into focus together. Once in Focus mode, you can select and edit the text and the path separately.

Lens objects

Notes

The object and lens are brought into focus together. Once in Focus mode, you can select and edit the object and the lens separately if the lens is frozen. When the lens is not frozen, only the shape of the lens can be edited.

Objects with effects applied by any Effects tool (Shadow tool, Contour tool, Blend tool, Distort tool, Envelope tool, Extrude tool, Block Shadow tool)

Notes

The object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately.

Bitmaps with effects applied

Notes

The bitmap and effect are brought into focus together. Once in Focus mode, you can modify the bitmap and any changes to the bitmap are reflected in the effect.

PowerClip objects

Notes

PowerClip objects cannot be brought into Focus mode by double-clicking.

To bring an object into Focus mode

1. Select an object.
2. Click Edit ➤ Bring into Focus.

When Focus mode is active and you sample color from an object that is out-of-focus, the Color Eyedropper tool captures color values as if there were no overlay present.

When in Focus mode, any new object you create is automatically grouped with the object or object group in focus.

You can also bring an object into Focus mode by double-clicking it with the Pick tool or by right-clicking it in the Objects docker and clicking Bring into Focus.

To shift focus

To

Do the following

Shift focus to another object

Click the name of the object on the Focus mode toolbar.

Shift focus to the object one level higher

Press Esc.

If a single object or the top level of an object group is in focus, Focus mode is closed.
To exit Focus mode

• Click Edit ➤ Exit Focus Mode.

You can also exit Focus mode by double-clicking anywhere in the drawing window off the object in focus, by clicking the Exit Focus Mode button on the floating toolbar, or by pressing Shift + Esc.

To adjust the visibility of inactive objects

1 Click Tools ➤ Options ➤ CorelDRAW.
2 In the left pane of the Options dialog box, click Edit.
3 Adjust the Visibility of inactive objects slider.
   Move the slider to the left to increase the opacity of the overlay; move the slider to the right to increase the transparency of the overlay.

Transform objects

You can change the appearance of objects in the drawing window by using the following transformations.

<table>
<thead>
<tr>
<th>Transformation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sizing</td>
<td>[Image of flower before and after sizing]</td>
</tr>
<tr>
<td>Scaling</td>
<td>[Image of flower before and after scaling]</td>
</tr>
<tr>
<td>Skewing</td>
<td>[Image of flower before and after skewing]</td>
</tr>
</tbody>
</table>

Transformations:
- **Sizing** lets you change the width and height of an object.
- **Scaling** lets you size an object to a percentage of its original size.
- **Skewing** lets you slant an object to one side.
### Transformation

<table>
<thead>
<tr>
<th>Transformation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Stretching</strong></td>
<td>lets you change the height and width of an object nonproportionally.</td>
</tr>
<tr>
<td><strong>Rotating</strong></td>
<td>lets you turn an object around its center axis or a point relative to its position.</td>
</tr>
<tr>
<td><strong>Mirroring</strong></td>
<td>lets you create a horizontal or vertical mirror image of an object.</td>
</tr>
</tbody>
</table>

### Transform objects interactively

You can transform an object interactively by using the mouse and the **Pick** tool. This method is the quickest, but it is not recommended if you want to transform an object with precision.

### Other methods for transforming objects

You can transform an object in any of the following ways:

- For more precise results, you can select an object with the **Pick** tool and adjust settings on the property bar. For example, you can specify a precise rotation angle or specify the size of an object.
- The **Transform** docker lets you transform objects with precision and apply the transformation to the duplicate of an object, which is created automatically. This feature lets you experiment with transformations without affecting the original object. You can access the **Transform** docker by clicking **Window** > **Dockers** > **Transform**.
- The **Transform** toolbar also lets you transform objects with precision. You can access the **Transform** toolbar by clicking **Window** > **Toolbars** > **Transform**.

Each of these methods lets you apply transformations to a single object or to multiple objects simultaneously.

### Clear and redo transformations

All transformations can be simultaneously cleared at any time.
For more information about

Sizing and scaling  
See “Size and scale objects” on page 346

Skewing and stretching  
See “Skew and stretch objects” on page 232

Rotating and mirroring  
See “Rotate and mirror objects” on page 348

To transform an object interactively

1. Select an object by using the Pick tool .
   The bounding box of the object appears. The bounding box includes eight selection handles that you can use to size, stretch, and mirror the object. If you click the object again, new handles appear. You can use these handles to rotate and skew the object.

   ![Diagram of handle types: selection (1), rotation (2), and skew (3)]

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size or scale an object</td>
<td>Drag a corner selection handle.</td>
</tr>
<tr>
<td>Stretch an object</td>
<td>Drag a middle selection handle.</td>
</tr>
<tr>
<td>Skew an object</td>
<td>Click the object to display the skew handles, and drag a skew handle.</td>
</tr>
<tr>
<td>Rotate an object</td>
<td>Click the object to display the rotation handles, and drag a rotation handle.</td>
</tr>
<tr>
<td>Mirror an object</td>
<td>Hold down Ctrl, and drag a selection handle to the opposite side of the object.</td>
</tr>
</tbody>
</table>

💡 If you want to leave the original object unchanged and apply the transformation to copies that are created, type a number in the Copies box in the Transform docker.
To clear all transformations applied to an object
1 Select an object.
2 Click Object ➤ Clear Transformations.

You can undo the Clear Transformations command by clicking Edit ➤ Undo Clear Transformations.

Copy, duplicate, and delete objects
CorelDRAW provides you with several ways to copy objects. When you no longer need an object, you can delete it.

You can cut or copy an object to place it on the Clipboard and paste it into a drawing or another application. Cutting an object places it on the Clipboard and removes it from the drawing. Copying an object places it on the Clipboard but keeps the original in the drawing.

Duplicating an object places a copy directly in the drawing window and does not use the Clipboard. Duplicating is faster than copying and pasting. When an object is duplicated, there is a distance between the duplicate and the original object along the x and y axes. This distance, known as duplicate offset, can be changed in the Options dialog box.

You can apply a transformation, such as rotating, sizing, or skewing, to the duplicate of an object while keeping the original object intact. If you decide that you want to keep the original object, you can delete the duplicate.

You can create multiple copies of objects simultaneously, while specifying their position, without using the Clipboard. For example, you can distribute object copies horizontally, to the left or right of the original object; or you can distribute copies of objects vertically, below or above the original object. You can specify the spacing between copies of objects, or you can specify the offset at which copies of objects are created in relation to each other.

You can use other methods to create copies of objects quickly, without using the Clipboard. You can use the plus sign (+) on the numeric keypad to place a copy of an object on top of the original object, or you can create copies instantly by pressing the Spacebar or right-clicking while dragging an object.

To cut or copy an object
1 Select an object.
2 Click Edit, and click one of the following:
   • Cut
   • Copy
You can also cut or copy an object by right-clicking the object and clicking **Cut** or **Copy**.

**To paste an object into a drawing**

- Click **Edit**  **Paste**.

You can use this procedure to paste an object from another application.

To paste an object from an unsupported file format, or to specify options for the pasted object, click **Edit**  **Paste Special**. For more information about pasting objects from other applications, see "Link and embed objects" on page 365.

**To duplicate an object**

1. Select an object.
2. Click **Edit**  **Duplicate**.

Duplicating an object is useful for creating cuttable drop shadows for devices such as vinyl cutters and plotters.

You can also duplicate a selected object by pressing **Ctrl + D**.

To change the default duplicate offset, click **Layout**  **Document Options**. On the **General** page, type values in the **Horizontal** and **Vertical** boxes.

- Offset values of 0 place the duplicate on top of the original.
- Positive offset values place the duplicate up and to the right of the original.
- Negative offset values place the duplicate down and to the left of the original.

**To create copies of an object at a specified position**

1. Select an object.
2. Click **Edit**  **Step and Repeat**.
3. In the **Step and Repeat** docker, type a value in the **Number of copies** box, and click **Apply**.

**To**

**Do the following**

**Distribute copies of objects horizontally**

In the **Vertical settings** area, choose **No offset** from the **Mode** list box. In the **Horizontal settings** area, choose **Spacing between objects** from the **Mode** list box. To specify the spacing between object copies, type a value in the **Distance** box. To place the object copies to the right or left of the original, choose **Right** or **Left** from the **Direction** list box.

**Distribute copies of objects vertically**

In the **Horizontal settings** area, choose **No offset** from the **Mode** list box. In the **Vertical settings** area, choose **Spacing between objects** from the **Mode** list box. To specify the spacing between
To offset all copies of objects by a specified distance:

Do the following:

- Type a value in the **Distance** box.
- Choose **Up** or **Down** from the **Direction** list box.

In the **Horizontal settings** and **Vertical settings** areas, choose **Offset** from the **Mode** list box, and type values in the **Distance** boxes.

Multiple copies of an object are offset by a specified distance.

You can access the **Step and Repeat** docker by pressing **Ctrl + Shift + D**.

**To create copies of objects quickly**

1. Select an object by using the **Pick tool**.
2. Press the **Spacebar** while rotating or transforming the object.

You can also:

- Place a copy of an object on top of the original by pressing the plus sign (+) on the numeric keypad.
- Create a single copy by using a mouse or stylus. While moving, rotating, or transforming the object, right-click and then release both mouse buttons.

**To transform the duplicate of an object**

1. Select an object.
2. Click **Window ➤ Dockers ➤ Transform**.
3. Choose the settings you want in the **Transform** docker.
4. Type **1** in the **Copies** box.
5. Click **Apply**.
You can clear a transformation by selecting an object and clicking Object ▶ Clear Transformations.

To delete an object
1. Select an object.
2. Click Edit ▶ Delete.

To retrieve a deleted object, you must use the Undo command. For more information, see “Undo, redo, and repeat actions” on page 68.

You can also delete an object by selecting it and pressing Delete.

Create objects from enclosed areas
You can create objects from areas enclosed by other objects. For example, if you draw a freehand line that crosses over itself to create loops, you can create an object from the loop shape. You can create an object in the shape of the area if the area is completely enclosed, regardless of the number of surrounding shapes and lines.

For more information about creating objects from enclosed areas, see “Apply fills to areas” on page 443.

Create a boundary around objects
You can automatically create a path around selected objects on a layer to create a boundary. This boundary can be used for various purposes, such as to produce keylines or cut lines.

The boundary is created by a closed path that follows the shape of the selected objects. The default fill and outline properties apply to the object created by the boundary.
You can create a boundary around selected objects (left). The boundary is created as a new object (middle) that can be used as a cut line or keyline for a finished logo (right).

To create a boundary around selected objects
1. Select the objects that you want to surround with a boundary.
2. Click Object ➔ Shaping ➔ Boundary.

Feather object edges
You can feather the edges of vector and bitmap objects. Feathering gradually increases the transparency along the edges of objects making objects blend perfectly into the background.

Feather the edges of a bitmap to make it blend seamlessly into your composition.
Soften the edges of vector objects by using the Feather effect.

You can specify the width of the feathered section of the object and the transparency gradient you want to use.

**To feather the edges of an object**

1. Select an object.
2. Click Effects ➤ Blur ➤ Feather.
3. Type a value in the **Width** box.
4. Enable one of the following options to specify the transparency gradient you want to use:
   - **Linear** — changes the edge transparency in even increments from the beginning to the end of the feathered section
   - **Curved** — results in small transparency increments at the beginning of the feathered edge, larger transparency increments in the middle, and small transparency increments at the end
   - **Gaussian** — blurs object edges outward according to Gaussian distribution, using bell-shaped curves

To preview your design while adjusting the effect settings, enable the **Preview** check box.

**Use object coordinates to draw and modify objects**

You can use the **Coordinates** docker to draw and modify shapes and lines with precision. The live preview in the drawing window lets you see the effects of your adjustments.

You can type coordinate values to specify the exact position, dimensions, and angle of rotation of an object. You can also set object attributes interactively by dragging in the drawing window.

**Rectangles and squares**

To draw a rectangle with precision, you can specify an origin point, which is one of nine points in the rectangle (four corner points, four midpoints, and one center point). If you rotate the rectangle, the origin point is used as the center of rotation. You can also specify the angle of rotation, and the width and height of a rectangle.

If the angle of rotation is 0, you can specify the position of the lower-left and upper-right corners of the rectangle.

To draw a square, you can specify the origin point, the length of a side, and an angle of rotation.
The origin point of a rectangle appears as a blue node in the live preview. You can select the center point, or any corner or midpoint, as the origin point.

Ellipses and circles

To draw an ellipse with precision, you can specify an origin point, which is one of nine points in the bounding box that can be drawn around the ellipse. The origin point is used as the center of rotation.

You can also specify the ellipse diameters, which are the width and height of the bounding box around the ellipse, and the angle of rotation. If the angle of rotation is 0, you can specify the exact position of the lower-left and upper-right corners of the bounding box around the ellipse.

To draw a circle, you can specify the origin point, diameter, and angle of rotation.

Polygons

To draw a polygon, you can specify the number of sides, the angle of rotation, or the center and diameters of the bounding ellipse that can be drawn around the polygon. The center of the bounding ellipse, also known as the “polygon center,” is used as the center of rotation.

You can also draw regular polygons with precision. All sides of a regular polygon are of equal length. You can specify the side length and angle of rotation, or the center and diameter of the bounding circle that can be drawn around the regular polygon.
You can specify the diameters of the bounding ellipse that can be drawn around the polygon.

**Lines**

You can draw a straight line by using one of two methods. With the first method, you specify the start point and endpoint of the line. With the second method, you specify the start point and length of the line, plus an angle of rotation.

You can create complex lines by specifying the coordinates of multiple points. You can delete points, and you can modify the coordinates of existing points. After adding all the points you want, you can close the curved line by connecting its start point to its endpoint.

![Straight and multipoint lines](image)

**Stars**

You can also use coordinates to draw stars and complex stars.

**Modify existing objects**

You can use the **Coordinates** docker to modify existing objects with precision. Note that when you modify an existing object, it is replaced with a new object. As a result, the following transformations and effects applied to the original objects are lost: envelope effects, rotations, and skew effects. In addition, any changes that were previously applied to the nodes on a polygon are lost.

**To draw or modify a rectangle by using object coordinates**

1. Click **Window** ➤ **Dockers** ➤ **Coordinates**. If you want to modify an existing rectangle, select the rectangle.
2. Click the **Rectangle** flyout, and choose **Rectangle**.
3. Make any of the following adjustments:
   - To set the origin point of the rectangle, click a point in the **Origin** area.
   - To specify the exact position of the origin point, type values in the **x** and **y** boxes.
   - To specify the width and height of the rectangle, type values in the **W** and **H** boxes.
• To specify only the height or width of the rectangle and have the other dimensions automatically adjusted in proportion, enable the **Set proportional** check box.
• To rotate the rectangle at a specified angle, type a value in the **Angle of rotation** box. The origin point of the rectangle is used as the center of rotation.

4 Click one of the following:
• **Create object** — adds a new rectangle to the drawing window
• **Replace object** — replaces the selected rectangle with a new one

You can also

Draw a rectangle by specifying the exact position of its lower-left and upper-right corners

Set the lower-left and upper-right corners of a rectangle directly in the drawing window

Set the origin point directly in the drawing window

Specify the dimensions of the rectangle directly in the drawing window

Set the angle of rotation directly in the drawing window

To draw or modify a square by using object coordinates

1 Click **Window**  **Dockers**  **Coordinates**.
   If you want to replace an existing square, select the square.
2 Click **Rectangle**  flyout, and choose **Square**.
3 Make any of the following adjustments:
   • To set the origin point of the square, click a point in the **Origin** area.
   • To specify the exact position of the origin point, type values in the x and y boxes.
   • To specify the length of a side, type a value in the **Object size** box.
   • To rotate the square at a specified angle, type a value in the **Angle of rotation** box. The origin point of the rectangle is used as the center of rotation.
4 Click one of the following:
   • **Create object** — adds a new square to the drawing window
   • **Replace object** — replaces the selected square with a new one
You can also

Set the origin point directly in the drawing window

Click the Set origin point interactively button, and click in the drawing window.

Specify the length of a square side directly in the drawing window

Click the Set dimensions interactively button, and drag in the drawing window.

Set the angle of rotation directly in the drawing window

Click the Set angle interactively button, and drag in the drawing window.

To draw or modify an ellipse by using object coordinates

1 Click Window Dockers Coordinates.
   If you want to modify an existing ellipse, select the ellipse.
2 Click the Ellipse flyout, and choose Ellipse.
3 Make any of the following adjustments:
   • To set the origin point of the ellipse, click a point in the Origin area.
   • To specify the exact position of the origin point, type values in the x and y boxes.
   • To specify the diameters (width and height) of the ellipse, type values in the W and H boxes.
   • To specify only one of the diameters and have the other diameter automatically adjusted in proportion, enable the Set proportional check box.
   • To rotate the ellipse at a specified angle, type a value in the Angle of rotation box. The origin point of the ellipse is used as the center of rotation.
4 Click one of the following:
   • Create object — adds a new ellipse to the drawing window
   • Replace object — replaces the selected ellipse with a new one

You can also

Draw an ellipse by specifying the lower-left and upper-right corners of the bounding box around an ellipse

In the Bounding box area, type values in the X and Y boxes under the Lower-left corner or Upper-right corner label.
This method for drawing ellipses is available only when no rotation is applied to the ellipse.

Set the lower-left and upper-right corners of an ellipse's bounding box directly in the drawing window

In the Bounding box area, click the Set lower-left corner interactively or Set upper-right corner interactively button, and click in the drawing window.

Set the origin point directly in the drawing window

Click the Set origin point interactively button, and click in the drawing window.

Specify the dimensions of the ellipse directly in the drawing window

Click either of the Set diameter interactively buttons, and drag in the drawing window.
You can also

Set the angle of rotation directly in the drawing window
Click the **Set angle interactively** button  and drag in the drawing window.

To draw or modify a circle by using object coordinates

1. Click **Window**  Dockers  Coordinates.
   If you want to replace an existing circle, select the circle.
2. Click the **Ellipse**  flyout, and choose **Circle**.
3. Make any of the following adjustments:
   - To set the origin point of the square, click a point in the **Origin** area.
   - To specify the exact position of the origin point, type values in the **x** and **y** boxes.
   - To specify the diameter of a circle, type a value in the **Object size** box.
   - To rotate the circle at a specified angle, type a value in the **Angle of rotation** box. The origin point of the circle is used as the center of rotation.
4. Click one of the following:
   - **Create object** — adds a new circle to the drawing window
   - **Replace object** — replaces the selected circle with a new one

You can also

Set the origin point directly in the drawing window
Click the **Set origin point interactively** button  and click in the drawing window.

Specify the diameter of a circle directly in the drawing window
Click the **Set diameter interactively** button  and drag in the drawing window.

Set the angle of rotation directly in the drawing window
Click the **Set angle interactively** button  and drag in the drawing window.

To draw or modify a polygon by using object coordinates

1. Click **Window**  Dockers  Coordinates.
   If you want to modify an existing polygon, select the polygon.
2. Click the **Polygon**  flyout, and choose **Polygon**.
3. In the **Polygon** area, type a value in the **Points or sides** box.
4. Make any of the following adjustments:
   - To rotate the polygon at a specified angle, type a value in the **Angle of rotation** box.
   - To specify the polygon center, type values in the **X** and **Y** boxes in the **Bounding box** area. The polygon center is the center of the bounding ellipse that can be drawn around the polygon. The polygon center is used as the center of rotation.
   - To specify the diameters of the bounding ellipse around the polygon, type values in the **W** and **H** boxes in the **Bounding box** area.
   - To specify only one diameter and have the other diameter automatically adjusted in proportion, enable the **Set proportional** check box.
5 Click one of the following:
• Create object — adds a new polygon to the drawing window
• Replace object — replaces the selected polygon with a new one

You can also

Set the angle of rotation directly in the drawing window
Click the **Set angle interactively** button and drag in the drawing window.

Set the polygon center directly in the drawing window
Click the **Set polygon center interactively** button and click in the drawing window.

Specify the diameters of the bounding ellipse directly in the drawing window
Click either of the **Set diameter interactively** buttons and drag in the drawing window.

To draw or modify a regular polygon by using object coordinates

1 Click Window » Dockers » Coordinates.
   If you want to modify an existing polygon, select the polygon.
2 Click Polygon flyout, and choose **Regular polygon**.
3 In the Regular Polygon area, type a value in the **Points or sides** box.
4 Type a value in the **Side length** box.
5 Make any of the following adjustments:
   • To rotate the polygon at a specified angle, type a value in the **Angle of rotation** box.
   • To specify the polygon center, type values in the **X** and **Y** boxes in the **Bounding box** area.
   • To specify the diameter of the bounding circle around the polygon, type a value in the **Object size** box.
6 Click one of the following:
   • Create object — adds a new polygon to the drawing window
   • Replace object — replaces the selected polygon with a new one

You can also

Set the side length directly in the drawing window
Click the **Set dimensions interactively** button and drag in the drawing window.

Set the angle of rotation directly in the drawing window
Click the **Set angle interactively** button and drag in the drawing window.

Set the polygon center directly in the drawing window
Click the **Set polygon center interactively** button and click in the drawing window.

Specify the diameter of the bounding circle directly in the drawing window
Click the **Set diameter interactively** button and drag in the drawing window.
To draw or modify a straight line by using object coordinates

1. Click Window  Dockers  Coordinates.
   If you want to modify an existing line, select the line.
2. Click the 2-point line button.
3. To specify the start point and endpoint along the x and y rulers, type values in the X and Y boxes in the End point and Start point areas.
   In the live preview, the start point is highlighted.
4. Click one of the following:
   • Create object — adds a new line to the drawing window
   • Replace object — replaces the selected line with a new one

You can also

Draw a straight line by specifying its start point, length, and angle of rotation
   Type values in the Start point X and Y boxes. In the Object size area, type a value in the Line length box. Then, type a value in the Angle of rotation box.

Set the start point or endpoint of a line directly in the drawing window
   Click one of the Set point interactively buttons, and click in the drawing window.

Set the line length directly in the drawing window
   In the Object size area, click the Set line length interactively button, and drag in the drawing window.

Set the angle of rotation directly in the drawing window
   In the Object size area, click the Set angle interactively button, and drag in the drawing window.

To draw or modify a multi-point line by using object coordinates

1. Click Window  Dockers  Coordinates.
   If you want to replace an existing line with a new one, select the line.
2. Click the Multi-point curve button.
3. Click the Add point button.
4. Make either of the following adjustments:
   • To specify the exact position of the point along the x and y rulers, type values in the X and Y boxes.
   • To add another point, click the Add point button, and type values in the X and Y boxes.
5. After specifying all the points you need, click one of the following:
   • Create object — adds a new line to the drawing window
   • Replace object — replaces the selected line with a new one

You can also

Specify the position of a point directly in the drawing window
   Click a point in the Coordinates docker. Click the Set point interactively button, and click in the drawing window.
You can also

Delete a point

Click a point in the Coordinates docker, and click the Delete point button.

Connect the start point with the endpoint of a line

Click the Auto-close/open curve button.

Use the following keyboard shortcuts to create a multi-point line quickly:

- To add a point, click in the Points area, and press Insert.
- To delete a selected point, press Delete.
- To activate the X or Y box of a selected point, press F2.
- To navigate through the X and Y boxes of the available points, select a box and press Tab repeatedly.
- To navigate backward through the X or Y boxes of the available points, select a box and press Shift + Tab repeatedly.
- To activate the Set point interactively button, double-click a point in the docker.

To draw or modify a star or complex star by using object coordinates

1 Click Window ➤ Dockers ➤ Coordinates.
2 Click the Star or the Complex star button.
3 Specify the settings you want.
4 Click one of the following:
   • Create object — adds a new star to the drawing window
   • Replace object — replaces the selected star with a new one

Copy object properties, transformations, and effects

CorelDRAW lets you copy attributes from one object to another. You can copy object properties such as outline, fill, and text properties. You can copy object transformations such as sizing, rotating, and positioning. You can also copy effects applied to an object.

To copy fill, outline, or text properties from one object to another

1 In the toolbox, click the Attributes Eyedropper tool.
2 Click the Properties flyout on the property bar, and enable any of the following check boxes:
   • Outline
   • Fill
   • Text
3 Click the object whose properties you want to copy.
   The Attribute Eyedropper tool automatically switches to the Apply object attributes mode.
4 Click the object to which you want to apply the copied properties.
Options that are enabled in the Transformations and Effects flyouts on the property bar are also applied when you copy properties.

You can also copy fill or outline properties, or both, by right-clicking an object with the Pick tool, dragging over another object, releasing the mouse button, and choosing Copy fill here, Copy outline here, or Copy all properties.

To copy size, position, or rotation from one object to another
1 In the toolbox, click the Attributes Eyedropper tool.
2 Click the Transformations flyout on the property bar, and enable any of the following check boxes:
   - Size
   - Rotation
   - Position
3 Click the object whose transformations you want to copy.
   The Attributes Eyedropper tool automatically switches to the Apply object attributes mode.
4 Click the object to which you want to apply the copied transformations.

Options that are enabled in the Properties and Effects flyouts on the property bar are also applied when you copy properties.

To copy effects from one object to another
1 In the toolbox, click the Attributes Eyedropper tool.
2 Click the Effects flyout on the property bar, and enable any of the following check boxes:
   - Perspective
   - Envelope
   - Blend
   - Extrude
   - Contour
   - Lens
   - PowerClip
   - Shadow
   - Distortion
   - Bitmap effects
3 Click the object whose effects you want to copy.
   The Attributes Eyedropper tool automatically switches to the Apply object attributes mode.
4 Click the object to which you want to apply the copied effects.

Options that are enabled in the Properties and Transformations flyouts on the property bar are also applied when you copy properties.
Clone objects

When you clone an object, you create a copy of an object that is linked to the original. Any changes you make to the original object are reflected automatically in the clone. Changes you make to the clone are not automatically reflected in the original, however. You can remove changes made to the clone by reverting to the original.

Cloning lets you modify multiple copies of an object simultaneously by changing the master object. This type of modification is especially useful if you want the clone and master objects to differ by certain properties, such as fill and outline color, but want the master object to control other properties, such as shape.

If you simply want to use the same object in a drawing multiple times, consider using symbols, instead of clones, to keep the file size manageable. For more information about symbols, see “Symbols” on page 383.

The object on the left was cloned twice. Different fill and outline properties were applied to the clones. The clone on the right was also reshaped.

To clone an object

1. Select an object.
2. Click Edit ▶ Clone.

You can also

Select the master object of a clone
Right-click the clone, and click Select Master.

Select the clone objects of a master
Right-click the master, and click Select Clones.

You can clone a master object multiple times, but you cannot clone a clone.

To revert to the master object of a clone

1. Right-click a modified clone, and click Revert to Master.
2. Enable any of the following check boxes:
   • Clone Fill — restores the master fill attributes
   • Clone Outline — restores the master outline attributes
   • Clone Path Shape — restores the master shape attributes
   • Clone Transformations — restores the master shape and size attributes
   • Clone Bitmap Color Mask — restores the master color settings
Only the clone properties that are different from the master object are available in the Revert to Master dialog box.

Position objects

You can position objects by dragging them to a new location, by nudging, or by specifying their horizontal and vertical coordinates.

Nudging lets you move an object in increments by pressing the Arrow keys. The increment value is known as “nudge distance.” Micro-nudging lets you move an object by a fraction of the nudge distance. Super-nudging lets you move an object by a multiple of the nudge distance. By default, you can nudge objects in 0.1-inch increments, but you can change this increment value to suit your needs. You can also change micro-nudge and super-nudge values.

To position an object, you can set horizontal and vertical coordinates that are relative to the center anchor point, or other anchor point, of the object.

You can also move an object to another page.

To move an object

1. Select an object.
2. Point to the center of the bounding box.
3. When the position cursor appears, drag the object to a new position in the drawing.

You can move an object to another page by dragging the object over a page number tab at the bottom of the document window and then dragging the object into the document window.

To move an object while drawing

1. Start drawing a shape such as a rectangle, ellipse, or polygon.
2. Hold down the right mouse button without releasing the left mouse button, and drag the unfinished object to its new position.
3. Release the right mouse button, and continue drawing.
To nudge an object

<table>
<thead>
<tr>
<th>Do the following</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Press an Arrow key.</td>
<td>Nudge a selected object by the nudge distance</td>
</tr>
<tr>
<td>Hold down Ctrl, and press an Arrow key.</td>
<td>Nudge a selected object by a fraction of the nudge distance (micronudge)</td>
</tr>
<tr>
<td>Hold down Shift, and press an Arrow key.</td>
<td>Nudge a selected object by a multiple of the nudge distance (supernudge)</td>
</tr>
</tbody>
</table>

To set nudge distances

1. Click **Layout** ➤ **Document Options**.
2. In the left pane of the dialog box, click **Rulers**.
3. Type a value in any of the following boxes:
   - Nudge
   - Super nudge
   - Micro nudge

You can also set the nudge distance by deselecting all objects and typing a value in the **Nudge distance** box on the property bar.

To save the new nudge distances to use in new drawings, click **Tools** ➤ **Save Settings as Default**.

To position an object by x and y coordinates

1. Select an object.
   - If you want to change the object origin, click a point on the **Object Origin** button on the property bar.
2. Type values in the following boxes:
   - **x** — lets you position the object on the x-axis
   - **y** — lets you position the object on the y-axis
   The x and y values specify the exact position of the object origin.
3. Press **Enter**.

The object origin, also known as “anchor point” or “reference point,” can be the center of an object or any one of the object’s selection handles. The object origin remains stationary when an object is positioned by typing values in the x and y boxes on the property bar.

To position an object by changing the anchor point

1. Select an object.
2. Click **Window** ➤ **Dockers** ➤ **Transform**.
3. Click the **Position** button.
4. Disable the **Relative position** check box in the **Transform** docker.
5. Type values in the following boxes:
   - **X** — lets you specify a value for the position of an object along the horizontal axis
   - **Y** — lets you specify a value for the position of an object along the vertical axis
Enable the check box that corresponds to the anchor point that you want to set.

Click Apply.

By default, the point of origin (0,0) is at the lower-left corner of the drawing page.

When you enable the **Relative position** check box on the **Transform** docker, the position of the center anchor point is identified as 0,0 in the X and Y boxes. When you specify a different position in the X and Y boxes, the values represent a change from the current position as measured from the center anchor point of the object.

### Align and distribute objects

CorelDRAW lets you precisely align and distribute objects in a drawing.

You can align objects with each other and with parts of the drawing page, such as the center, edges, and the closest grid line. You can also align objects with a specified point by entering its exact x and y coordinates. You can align objects by their edges (left, right, top or bottom) or by their centers.

Distributing objects automatically adds spacing between them based on their width, height, and center points. You can distribute objects so that their center points or selected edges (for example, top or right) appear at equal intervals. You can also distribute objects so that there is equal space between them. You can distribute objects over the extent of the bounding box surrounding them or over the entire drawing page. In addition, you can distribute objects by specifying the distance between them.

Scattered objects (left) are vertically aligned and equally distributed (right).

To prevent blurry edges in objects designed for web use, you can align the objects with the pixel grid. This feature realigns the nodes or edges of the object to position them correctly on the pixel grid.
To align objects with the pixel grid to prevent blurry edges.

1. Select the objects.
2. Click Object ➤ Align and Distribute ➤ Align and Distribute.
3. In the Align and Distribute docker, choose a reference point by performing a task from the following table:

| To                                             | Do the following                                                                 smashed-alignments
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Align an object with a specific object</td>
<td>Click the Selected objects button. If you select the objects one at a time, the last object selected is the reference point for aligning the other objects. If you marquee select the objects, the object that is positioned in the upper-left corner of the selection is used as a reference point.</td>
</tr>
</tbody>
</table>
| Align an object with the page edge              | Click the Page edge button.                                                     smashed-alignments
| Align an object with the page center             | Click the Page center button.                                                   smashed-alignments
| To align the center of the object with the page center, make sure that the Align center horizontally button and Align center vertically button in the Align area are enabled. | smashed-alignments
| Align an object with the closest grid line      | Click the Grid button.                                                          smashed-alignments
To align an object with a specified point

Do the following

Click the **Specified point** button and type values in the X and Y boxes.

You can also specify a point interactively by clicking the **Specify point** button, and clicking in the document window.

4 In the **Align** area of the docker, click one of the following buttons to use an object edge or center for aligning.

- **Align left** — to align the left edges of objects
- **Align center horizontally** — to align object centers along a vertical axis
- **Align right** — to align the right edges of objects
- **Align top** — to align the top edges of objects
- **Align center vertically** — to align object centers along a horizontal axis
- **Align bottom** — to align the bottom edges of objects

To align objects from their outlines, enable the **Use object outline** check box.

You can also

Set an alignment option for text objects

Before clicking one of the alignment buttons described in the previous step, click one of the following buttons in the **Text** area:

- **First line baseline** — aligns and distributes text by the baseline of the first line
- **Last line baseline** — aligns and distributes text by the baseline of the last line
- **Bounding box** — aligns and distributes text by its bounding box

You can also align objects with another object quickly, without using the **Align and Distribute** docker, by clicking **Object** ▶ **Align and Distribute** and clicking any of the first six alignment commands. The letter next to a command name indicates the keyboard shortcut that you can use to align objects. For example, the letter **L** next to the **Align Left** command shows that you can press **L** to align objects with the leftmost point of the object that is used as a reference point.

You can also align all objects with the page center, vertically and horizontally, by pressing **P**.

To distribute objects

1 Select the objects.

2 Click **Object** ▶ **Align and Distribute** ▶ **Align and Distribute**.

3 To choose the area over which the objects are distributed, click one of the following buttons in the **Distribute to** area of the **Align and Distribute** docker:

- **Selected objects** — distributes the objects over the area of the bounding box surrounding them
- **Page edge** — distributes the objects over the entire drawing page

4 To distribute objects horizontally, click one of the following buttons:

- **Distribute left** — evenly spaces the left edges of the objects
- **Distribute center horizontally** — evenly spaces the center points of the objects along a horizontal axis
To distribute objects by a specified distance
1 Select the objects.
2 Click Object ➤ Align and Distribute ➤ Align and Distribute.
3 In the Distribute to area of the Align and Distribute docker, click the Object spacing button.
4 Type values in the H and V boxes.
5 To distribute objects horizontally, click any of the horizontal distribution buttons.
6 To distribute objects vertically, click any of the vertical distribution buttons.

To align an object with the pixel grid
1 Select an object.
   To view the results, click View ➤ Pixels, and adjust the zoom level to 800% or higher.
2 Click Object ➤ Align and Distribute ➤ Align and Distribute.
3 In the Align and Distribute docker, click Align with Pixel Grid.
   The object bounding box is aligned with the pixel grid.
The **Align with Pixel Grid** feature works with basic curves and shapes. It is unavailable for complex objects and effects such as symbols, text, symmetry groups, vector effects, and PowerClip objects.

**Apply object hinting**

Object hinting allows you to improve object rendering by adjusting the display of an object so that it lines up with the pixel grid. For example, if you’re creating a button for the web, you can enable object hinting to ensure the object appears clean and sharp when exporting it as a bitmap.

![The Pixel view of a square (left) with a 1-pixel line width that was created without object hinting. A copy of the square (right) displayed with object hinting applied.](image)

**To apply object hinting**

1. Select an object.
2. Click **Object ➤ Object Hinting**.

**Snap objects**

When you move or draw an object, you can snap it to another object in a drawing. You can snap an object to various snap points on the target object. When you move the pointer close to a snap point, the snap point becomes highlighted, which identifies it as the pointer’s snapping target.

You can snap objects to other objects, to page elements (such as the center of the page), to the document grid, pixel grid, baseline grid, and guidelines. When you edit or draw in perspective, you can snap objects to perspective lines. When editing symmetry groups, you can also snap objects to symmetry lines. All these snapping options can be turned on or off from the **View** menu and from the **Snap to** button on the standard toolbar.

When you need to turn off the selected snapping options temporarily, you can disable all snapping from the **Snap off** button on the standard toolbar or the **View** menu. To restore the selected snapping options, you can enable snapping by using the same controls.

To snap an object to another object with greater precision, you can first snap the pointer to a snap point in the object, and then snap the object to a snap point in the target object. For example, you can snap the pointer to the center of a rectangle, drag the rectangle by the center, and then snap the rectangle to the center of another rectangle.
The pointer was snapped to an end node of the leaf (top), and then the leaf was dragged to snap to the end node of the branch (bottom).

Snapping modes determine which snap points you can use in an object. The table below includes descriptions of all available snapping modes.

<table>
<thead>
<tr>
<th>Snapping mode</th>
<th>Description</th>
<th>Snapping mode indicator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
<td>Lets you snap to a node on an object</td>
<td></td>
</tr>
<tr>
<td>Intersection</td>
<td>Lets you snap to a geometric intersection of objects</td>
<td></td>
</tr>
<tr>
<td>Midpoint</td>
<td>Lets you snap to a line segment midpoint</td>
<td></td>
</tr>
<tr>
<td>Quadrant</td>
<td>Lets you snap to points that are at 0°, 90°, 180°, and 270° on a circle, ellipse, or arc</td>
<td></td>
</tr>
<tr>
<td>Tangent</td>
<td>Lets you snap to a point on the outside edge of an arc, circle, or ellipse where a line touches, but does not intersect, the object</td>
<td></td>
</tr>
<tr>
<td>Perpendicular</td>
<td>Lets you snap to a point on the outside edge of a segment where a line is perpendicular to the object</td>
<td></td>
</tr>
<tr>
<td>Edge</td>
<td>Lets you snap to a point that touches the edge of an object</td>
<td></td>
</tr>
<tr>
<td>Center</td>
<td>Lets you snap to the center of the closest object (arc, regular polygon, or curve centroid)</td>
<td></td>
</tr>
<tr>
<td>Text baseline</td>
<td>Lets you snap to a point on the baseline of artistic or paragraph text</td>
<td></td>
</tr>
</tbody>
</table>

You can adjust a number of snapping settings. For example, you can disable some or all snapping modes to make the application run faster. You can also set a snapping threshold, which specifies the distance from the pointer at which a snap point becomes active.
When you move or transform an object, the pointer may snap to a snap point in the object itself. You can disable snapping of objects to their own snap points, which is useful for moving and transforming complex objects.

To turn snapping on or off
- Perform one or more tasks from the following table:

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable snapping for all objects</td>
<td>Click View ➤ Snap To ➤ Objects.</td>
</tr>
<tr>
<td>Enable snapping objects to page elements (edges, edge midpoints, and page center)</td>
<td>Click View ➤ Snap To ➤ Page.</td>
</tr>
</tbody>
</table>
| Enable snapping objects to the pixel grid | Click View ➤ Snap To ➤ Pixels.  
This option is available only when pixel view is enabled. For more information, see “Viewing modes” on page 74. |
| Enable snapping objects to the document grid | Click View ➤ Snap To ➤ Document Grid.  
For more information, see “Document grid and pixel grid” on page 741. |
| Enable snapping objects to the baseline grid | Click View ➤ Snap To ➤ Baseline Grid.  
For more information, see “Baseline grid” on page 743. |
| Enable snapping objects to guidelines | Click View ➤ Snap To ➤ Guidelines.  
For more information, see “Set up guidelines” on page 744. |
| Enable or disable snapping objects to perspective lines | Click View ➤ Snap To ➤ Perspective Lines.  
Perspective lines include horizon and viewport lines.  
This option is available only when you draw or edit perspective groups. For more information, see “Edit perspective groups” on page 291. |
| Enable snapping objects to symmetry lines | Click View ➤ Snap To ➤ Symmetry Lines.  
This option is available only in symmetry mode. For more information, see “Edit symmetry” on page 276. |
A check mark next to the snap command indicates that snapping is turned on.

You can also press \texttt{Alt + Z} to toggle snapping to objects on and off, or press \texttt{Alt + Y} to toggle snapping to the document grid on and off.

You can also turn snapping modes on or off from the \textit{Snap To} button on the standard toolbar.

**To disable and enable snapping**

- Click \textit{View} \& \textit{Snap Off}.

  When there is a check mark beside the command, all snapping is off. The \textit{View} \& \textit{Snap To} menu commands and the \textit{Snap to} button on the standard toolbar become grayed out. Clicking the \textit{View} \& \textit{Snap Off} command again enables all snapping and restores all selected snapping options.

You can also disable and enable all selected snapping options by pressing \texttt{Alt + Q} or by clicking the \textit{Snap Off} button on the standard toolbar.

To temporarily disable snapping as you are moving an object, hold down \texttt{Q}.

**To snap objects**

1. Select the object that you want to snap to the target object.
2. Move the pointer over the object until the snap point becomes highlighted.
3. Drag the object close to the target object until the snap point on the target object becomes highlighted.

   To snap an object as you draw it, drag in the drawing window until the snap point in the target object becomes highlighted.

**To adjust snapping settings**

1. Click \textit{Tools} \& \textit{Options} \& \textit{CorelDRAW}.
2. In the left pane of the dialog box that appears, click \textit{Snapping}.
3. To enable snapping objects to page elements (edges and page center), enable the \textit{Snap to page} check box.
4. Enable one or more of the check boxes in the \textit{Modes} area.
   - To enable all snapping modes, click \textit{Select All}.
   - To disable all snapping modes without turning off snapping, click \textit{Deselect All}.
5. Type a value in the \textit{Snapping radius} box to set the radius, in pixels, of the snapping field around the pointer.

You can also

- Prevent objects from snapping to their own snap points. Disable the \textit{Snap objects to themselves} check box.
  - Tip: You can turn snapping objects to themselves on and off by pressing \texttt{Ctrl + Shift + H}.

- Display or hide snapping mode indicators. Enable or disable the \textit{Show Snap location marks} check box.
You can also

Display or hide screen tips
Enable or disable the Show snapping mode in screen tip check box.

Dynamic guides

You can display dynamic guides to help you precisely move, align, and draw objects in relation to other objects. Dynamic guides are temporary guidelines that you can pull from the following snap points in objects — center, node, quadrant, and text baseline. For more information about snap points and snapping modes, see “Snap objects” on page 333.

As you drag an object along a dynamic guide, you can view the distance of the object from the snap point that was used to create the dynamic guide, which helps you position the object precisely. You can use dynamic guides to place objects in relation to other objects as you draw them. You can also display intersecting dynamic guides and then place an object at the intersection.

A dynamic guide was pulled from a node in the object on the left. The screen tip next to the node displays the angle of the dynamic guide (0º) and the distance between the node and the pointer (1.5 inches.) The object on the right was dragged along the dynamic guide and positioned precisely 1.5 inches away from the node that was used to generate the dynamic guide.

Dynamic guides contain invisible divisions, called ticks, to which your pointer gravitates. Ticks let you move objects with precision along a dynamic guide. You can adjust tick spacing to suit your needs, and you can disable snapping to ticks. You can set other options for dynamic guides. For example, you can choose to display dynamic guides at one or more preset angles, or at custom angles that you specify. You can preview the angle settings. You can also customize the color and line style of dynamic guides. When you no longer need a dynamic guide at a certain angle, you can delete the angle settings. You can also display dynamic guides that are extensions of line segments.

This dynamic guide is an extension of a line segment.

You can turn off dynamic guides at any time.

To enable or disable dynamic guides
• Click View ➤ Dynamic Guides.
A check mark beside the **Dynamic Guides** command indicates that dynamic guides are enabled.

You can toggle dynamic guides on and off by pressing **Shift + Alt + D**.

**To display dynamic guides**
1. With dynamic guides enabled, click a drawing tool.
2. Move the pointer over, and then off, an eligible snap point of an object.
3. Repeat step 2 with other objects to display other dynamic guides.

   The snap points that you point to are registered in a queue and are used to create dynamic guides.

The eligible snap points — the node, center, quadrant, and text baseline snap points — appear only when the corresponding snapping modes are activated. For more information about snap points and snapping modes, see “Snap objects” on page 333.

To avoid displaying too many dynamic guides, you can clear the queue of points at any time by clicking in the drawing window or pressing **Esc**.

You can use the snap points you registered to display intersecting dynamic guides. To do this, display a dynamic guide, and then move the pointer along the dynamic guide to where an intersecting dynamic guide would appear from a registered snap point.

**To place an object in relation to another object**
1. With dynamic guides enabled, select an object.

   If you want to move the object by a specific snap point, move the pointer over the snap point until the snap point becomes highlighted.
2. Drag the object to an eligible snap point of the target object.
3. When the snap point of the target object becomes highlighted, drag the object along the dynamic guide to position it.

The eligible snap points — the node, center, quadrant, and text baseline snap points — appear only when the corresponding snapping modes are activated. For more information about snap points and snapping modes, see “Snap objects” on page 333.

**To draw an object in relation to another object**
1. With dynamic guides enabled, click a drawing tool.
2. Move the pointer over an eligible snap point of an object.
3. When the snap point becomes highlighted, move the pointer to display a dynamic guide.
4. Move the pointer along the dynamic guide to the point where you want to draw, and drag to draw an object.

The eligible snap points — the node, center, quadrant, and text baseline snap points — appear only when the corresponding snapping modes are activated. For more information about snap points and snapping modes, see “Snap objects” on page 333.

**To place an object at the intersection of dynamic guides**
1. With dynamic guides enabled, select an object.
If you want to use a specific snap point to move the object, move the pointer over the snap point until the snap point becomes highlighted.

2 Drag the object to an eligible snap point of another object, drag to display a dynamic guide, and continue to hold down the mouse button.

3 Drag the object to another eligible snap point. When the snap point becomes highlighted, drag to display another dynamic guide where the two dynamic guides would intersect.

4 When the intersecting point appears, release the mouse button.

In the following example, intersecting dynamic guides are used to position an ellipse.

First, the ellipse was dragged by its center snap point (left) to the edge of the other carton, and then to the right to display a dynamic guide (right).

Next, the ellipse was dragged to the edge of the carton, and then down to display another dynamic guide (left). Finally, the ellipse was positioned at the intersection of the dynamic guides (right).

The eligible snap points — the node, center, quadrant, and text baseline snap points — appear only when the corresponding snapping modes are activated. For more information about snap points and snapping modes, see “Snap objects” on page 333.

To set options for dynamic guides

1 Click Window ▶ Dockers ▶ Live Guides.

2 In the Live Guides docker, click the Dynamic guides button.

3 Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable or disable dynamic guides</td>
<td>Enable or disable the check box in the top-right corner of the Dynamic guides section of the docker.</td>
</tr>
</tbody>
</table>
To

Do the following

Change the line style of dynamic guides
Open the Line style picker, and choose a line style.

Change the color of dynamic guides
Open the Line color picker, and choose a color.

Display or hide the angle of dynamic guides and the distance from the snap point used to create the dynamic guide
Click the Display screen tips button.

Display dynamic guides that are extensions of line segments
Click the Extend along segment button.

Snap to specified invisible divisions along the dynamic guide
Click the Snap to tick spacing button, and type a value in the Tick spacing box.

Choose the angles at which to display the dynamic guides
Enable or disable the angle check boxes.

When you enable an angle check box, a preview of the dynamic guide appears in the Guides preview window.

Add a custom dynamic guide angle
Type a value in the Custom angle box, and click the Add custom angle button.

Delete a custom dynamic guide angle
Select a dynamic guide in the list, and click the Delete custom angle button.

Display dynamic guides at all available angles
Click the Select all button.

Disable dynamic guides at all available angles
Click the Deselect all button

Alignment guides
You can align objects interactively on the drawing page by using alignment guides. Alignment guides are temporary guidelines that appear when you create, resize, or move objects in relation to other nearby objects. While dynamic guides provide precise measurements for creating technical illustrations, alignment guides are useful in page layout to align text or graphic elements quickly and accurately.

Alignment guides help you align the center of an object with the center of another object (center to center) or the edge of an object with the edge of another object (edge to edge). In addition, you can align the edge of an object with the center of another object (edge to center).
If you want to align an object at a set distance from the edge of another object, you can set margins for the alignment guides. After you specify the margins, you can choose how the edge guides appear: they can follow either the margins, or both the margins and the edges of the object.

Margin alignment guides let you use offset margins, inset margins, or both. There are separate controls for horizontal and vertical margin alignment guides, so you can modify settings for one without affecting the other.

Alignment guides are turned off by default. You can easily enable or disable alignment guides, or modify their default settings, including the color and line style. You can choose whether alignment guides appear for individual objects in a group, or for the bounding box of the group as a whole.

The Intelligent Spacing feature lets you precisely arrange and position an object in relation to other onscreen objects, and the Intelligent Dimensioning feature lets you intuitively scale and rotate an object in relation to other onscreen objects.
Intelligent Dimensioning displays indicators when an object is rotated to the same angle (top) or scaled to same size as the closest object (bottom).

Intelligent Spacing displays indicators when an object is equidistant between two other objects (left) or has the same spacing as the closest onscreen objects (right).

To enable or disable alignment guides

• Click View ➤ Alignment Guides.

A check mark beside the Alignment Guides command indicates that alignment guides are enabled.

You can also enable or disable alignment guides by clicking the Alignment guides button on the Layout toolbar. To open the Layout toolbar, click Window ➤ Toolbars ➤ Layout.

You can also enable alignment guides by pressing Shift + Alt + A.
To modify alignment guide settings
1. Click Window ➤ Dockers ➤ Live Guides.
2. In the Live Guides docker, click the Alignment guides button.
3. Perform any of the following tasks.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable or disable alignment guides</td>
<td>Enable or disable the check box in the top-right corner of the Alignment guides section.</td>
</tr>
<tr>
<td>Change the color of alignment guides</td>
<td>Open the Line color picker, and choose a color.</td>
</tr>
<tr>
<td>Change the line style of alignment guides</td>
<td>Open the Line style picker, and choose a line style.</td>
</tr>
<tr>
<td>Set guides to align the edge of an object with the edge of another object</td>
<td>Click the Object edges button.</td>
</tr>
<tr>
<td>Set guides to align the edge of an object with the center of another object</td>
<td>Click the Object centers button.</td>
</tr>
<tr>
<td>Set guides to align to individual objects in a group</td>
<td>Click the Individual objects in a group button.</td>
</tr>
<tr>
<td>Distribute objects using the same spacing as the closest onscreen objects</td>
<td>Ensure that the Intelligent spacing button is enabled, and drag the object until indicator arrows appear.</td>
</tr>
<tr>
<td>Position an object equidistantly between two other objects</td>
<td>Ensure that the Intelligent spacing button is enabled, and drag the object between two other objects until indicator arrows appear.</td>
</tr>
<tr>
<td>Scale objects to the same dimensions as other onscreen objects</td>
<td>Ensure that the Intelligent dimensioning button is enabled, and scale the object until indicator arrows appear.</td>
</tr>
<tr>
<td>Rotate objects to the same angle as other rotated onscreen objects</td>
<td>Ensure that the Intelligent dimensioning button is enabled, and rotate the object until rotation indicators appear.</td>
</tr>
</tbody>
</table>

You can access most alignment guide controls on the Layout toolbar by clicking the Layout toolbar button.

To add margin alignment guides
1. Click Window ➤ Dockers ➤ Live Guides.
2. In the Live Guides docker, click the Alignment guides button.
3. Perform any of the following tasks.
To Do the following

Add margin alignment guides
Enable the **Margins** check box. If the **Margins** check box is not displayed, click the arrow button located at the bottom of the **Alignment guides** section.

Change the line color of margins
Open the **Margin line color** picker, and choose a color.

Change the line style of margins
Open the **Margin line style** picker, and choose a line style.

Set horizontal margins
Type a value in the **Horizontal margin** box, click the **Horizontal margin** button, and choose one of the following options:
- **Offset horizontally** — creates a margin of the specified distance around an object
- **Inset horizontally** — creates a margin of the specified distance within an object
- **Offset and inset horizontally** — creates margins of the specified distance around and within an object

Set vertical margins
Type a value in the **Vertical margin** box, click the **Vertical margin** button, and choose one of the following options:
- **Offset vertically** — creates a margin of the specified distance around an object
- **Inset vertically** — creates a margin of the specified distance within an object
- **Offset and inset vertically** — creates a margin of the specified distance around and within an object

Lock the ratio between vertical and horizontal margins
Click the **Lock ratio** button.

View only margin alignment guides
Disable the **Object edges** button, the **Object centers** button, the **Intelligent spacing** button, and the **Intelligent dimensioning** button.

Disable horizontal margins
Click the **Horizontal margin** button, and choose **No horizontal margin**.

Disable vertical margins
Click the **Vertical margin** button, and choose **No vertical margin**.
Change the order of objects

You can change the stacking order of objects on a layer or a page by sending objects to the front or back of other objects. You can also position objects precisely in the stacking order, as well as reverse the stacking order of multiple objects.

The four objects (left) are ordered from top to bottom to create the final image (right).

To move an object in the stacking order

1. Select an object.
2. Click **Object ➤ Order**, and then click one of the following commands:
   - **To Front of Page** — moves the selected object in front of all other objects on the page
   - **To Back of Page** — moves the selected object behind all other objects on the page
   - **To Front of Layer** — moves the selected object in front of all other objects on the active layer
   - **To Back of Layer** — moves the selected object behind all other objects on the active layer
   - **Forward One** — moves the selected object forward one position. If the selected object is in front of all other objects on the active layer, it is moved to the layer above.
   - **Back One** — moves the selected object behind one position. If the selected object is behind all other objects on the selected layer, it is moved to the layer below.
   - **In Front Of** — moves the selected object in front of the object that you click in the drawing window
   - **Behind** — moves the selected object behind the object that you click in the drawing window

An object cannot be moved to a locked (non-editable) layer; instead, it is moved to the closest editable layer. For example, when you apply the **To Front of Page** command, and the topmost layer is locked, the object is moved to the topmost editable layer. Any objects on the locked layer remain in front of the object.

By default, all objects on the master page appear on top of the objects on other pages. For information about reordering content on master page layers, see “To move a layer” on page 381.

An **Order** command is unavailable if the selected object is already positioned in the specified stacking order. For example, the **To Front of Page** command is unavailable if the object is already in front of all the other objects on the page.

To reverse the order of multiple objects

1. Select the objects.
2. Click **Object ➤ Order ➤ Reverse Order**.
Size and scale objects

CorelDRAW lets you size and scale objects. In both cases, you change the dimensions of an object proportionally by preserving its aspect ratio. You can change the dimensions of an object by specifying precise values or by changing the object interactively. When you scale an object, you change its dimensions by a specified percentage.

You can also scale an object by specifying the dimension for a portion of the object, and you can interactively set a portion dimension and origin point to scale an object.

To size an object

To

Do the following

Size a selected object

Drag any of the corner selection handles.

Set a precise size

Type values in the Object size boxes on the property bar.

Size a selected object from its center

Hold down Shift, and drag one of the corner selection handles.

Size a selected object to a multiple of its original size

Hold down Ctrl, and drag one of the corner selection handles.

Stretch and size a selected object simultaneously

Hold down Alt, and drag one of the corner selection handles.

The anchor point of an object, also known as "object origin," remains stationary when you resize the object by typing values in the Object size boxes on the property bar. If you want to change the object origin, click a point on the Object Origin button on the property bar.

You can also size an object by clicking Window ▶ Dockers ▶ Transform, clicking the Size button and then typing values in the Transform docker.

To scale an object

1 Select an object.

2 In the toolbox, click the Free Transform tool .

3 Click the Free scale button on the property bar. If you want to change the object origin, click a point on the Object Origin button on the property bar.

4 Type a percentage by which you want to scale the object in the Scale factor boxes on the property bar.

You can also

Apply the scaling according to the object’s position rather than the x and y coordinates Click the Relative to object button on the property bar.
You can also

Scale an object using the Transform docker

Click Window ▶ Dockers ▶ Transform. Click the Scale and mirror button, type values in the X and Y boxes, and click Apply.

Leave the original object unchanged and apply the transformation to a copy

Click the Apply to duplicate button on the property bar, or type a number in the Copies box in the Transform docker.

The object origin, also known as “anchor point” or “reference point,” can be the center of an object or any one of the object’s selection handles. The object origin remains stationary when an object is scaled by typing values in the Scale factor boxes on the property bar.

You can also scale an object by dragging a corner selection handle.

You can also scale an object by using the Transform toolbar. To open the toolbar, click Window ▶ Toolbars ▶ Transform.

To scale an object by portion

1. Select an object.
2. Click Window ▶ Dockers ▶ Transform.
3. In the Transform docker, click the Size button and enable the Scale portion option.
4. Type a value in the Scale portion box, and then click Apply.
5. Drag along the portion of the object that you want to scale.
   Hold down Shift to constrain to a straight line.
   Press ESC to cancel.

You can also

Leave the original object unchanged and apply the transformation to a copy

In the Transform docker, type a number in the Copies box.

To scale an object by portion interactively

1. Select an object.
2. Click Window ▶ Dockers ▶ Transform.
3. In the Transform docker, click the Size button, enable the Scale portion option, and then click the Fit to Reference button.
4. Drag to set the dimension and object origin, and then click Apply.
   The origin point is set with your first click.
5. Drag along the portion of the object that you want to scale.
   Hold down Shift to constrain to a straight line.
   Press ESC to cancel.
You can also

Leave the original object unchanged and apply the transformation to a copy. In the Transform docker, type a number in the Copies box.

Rotate and mirror objects

CorelDRAW lets you rotate and create mirror images of objects. You can rotate an object by specifying horizontal and vertical coordinates. You can move the center of rotation to a specific ruler coordinate or to a point that is relative to the current position of the object.

Rotating objects around a single point

Mirroring an object flips it from left to right or top to bottom. By default, the mirror anchor point is in the center of the object.

To rotate an object

1 Select an object.
2 In the toolbox, click the Free Transform tool.
3 Click the Free rotation button on the property bar.
4 Type a value in the Angle of rotation box on the property bar.
5 Press Enter.
You can also

Apply the rotation according to the object’s position rather than the x and y coordinates  
Click the Relative to object button on the property bar.

Use rotation handles to rotate an object  
Using the Pick tool, click the object twice to display the rotation handles. Drag a rotation handle clockwise or counterclockwise.

Rotate an object using the Transform docker  
Click Window Dockers Transform. Click the Rotate button

You can also view and set the relative center of an object by clicking the object to display the rotation handles and dragging the relative center handle (circle with a dot in the middle) to a new position.
You can set the relative center of an object to its original position by enabling the Relative Center check box in the Transform docker.
You can also rotate an object by using the Transform toolbar. To open the toolbar, click Window Toolbars Transform.

To rotate an object around a ruler coordinate
1 Select an object.
2 Click Window Dockers Transform.
3 Click the Rotate button
4 Disable the Relative Center check box.
5 Type a value in the Angle of Rotation box.
6 Type values in any of the following Center boxes:
   • X — lets you specify the point on the horizontal ruler around which the object rotates
   • Y — lets you specify the point on the vertical ruler around which the object rotates
7 Click Apply.

To mirror an object
1 Select an object.
2 Click Window Dockers Transform.
3 Click the Scale and mirror button.
4 In the Transform docker, click one of the following buttons:
   • Mirror horizontally — lets you flip the object from left to right
   • Mirror vertically — lets you flip the object from top to bottom
   If you want to flip the object on a specific anchor point, enable the check box that corresponds to the anchor point you want to set.
5 Click Apply.

You can also mirror a selected object by holding down Ctrl and dragging a selection handle to the opposite side of the object.
You can also mirror a selected object by clicking the Mirror horizontally or the Mirror vertically button on the property bar.
Modify objects with the Properties docker

The Properties docker presents object-dependent formatting options and properties, letting you modify object settings from one location. For example, if you create a rectangle, the Properties docker automatically presents outline, fill, transparency, and corner formatting options, as well as the rectangle’s properties. If you create a text frame, the docker instantly displays character, paragraph, and frame formatting options, as well as the text frame’s properties.

You can navigate quickly to the properties that you want to modify by using the controls at the top of the Properties docker. In addition, two view modes are available: Scroll and Tab. Scroll mode displays all relevant object properties, letting you scroll to the options you want. Tab mode displays only one group of object properties at a time, hiding the other options. For example, you can view only fill options, and then click the Outline button to view only outline options.
If objects have outline, fill, or other styles applied to them, style indicators appear beside the property in the **Properties** docker. You can hide the style indicators to save space.

**To use the Properties docker**

1. Select an object.
   - If the **Properties** docker is not open, click *Window ➤ Dockers ➤ Properties*.
2. Perform any of the following tasks.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the object properties that you want to modify</td>
<td>Click the corresponding button at the top of the docker.</td>
</tr>
<tr>
<td>Switch between Scroll and Tab mode</td>
<td>Click the <em>Scroll/Tab mode</em> button.</td>
</tr>
<tr>
<td>Display or hide the style indicators</td>
<td>Click the <em>Style indicators</em> button.</td>
</tr>
</tbody>
</table>

**Fit objects to a path**

The **Fit Objects to Path** feature lets you fit any type and number of objects to a path of your choice. Smart distribution and rotation settings help you customize the placement of objects on the path.

You can distribute objects along a path by placing equal gaps between them and you can distribute objects by spacing evenly their reference points such as center of rotation or object origin. Objects can be rotated to follow the path. Moreover, you can use additional options such as different rotation styles and spin angles to create unique effects.

![Fitting objects to a path](image)

**To fit objects to a path**

1. Using the **Pick** tool, select the objects that you want to fit to a path.
2. Holding down **Shift**, click the path.
   - If you do not select a path, the last object you selected in step 1 is used as a path.
3. Click **Objects ➤ Fit Objects to Path**.
4. In the **Fit Objects to Path** docker, choose any settings you want.
5. Click **Apply**.
Objects that can be used as paths include curves, rectangles, ellipses, polygons, artistic text, and groups of objects. If a group contains an object that cannot be used as a path, this invalid object is excluded — selected objects are fit to the path of the remaining objects in the group.

The stacking order of the objects and path depends on the order of creation. If you draw the path first, it will appear behind the objects. If you draw the path last, it will appear on top of the objects.

Fitting linked groups, such as drop shadows, artistic media groups, and blends, to a path may produce unexpected results. To use B-splines and connector lines as paths, you must convert them to curves first.

You can also access the Fit Objects to Path docker from the Window Dockers menu, or you can access it by clicking the Quick Customize button of any docker and enabling the Fit Objects to Path check box.

To fit a blend to a path, we recommend that you use an alternative method. Click the Blend tool, click the Path properties button on the property bar, choose New Path, and then click a path.

To choose Fit Objects to Path settings

Use the controls in the Fit Objects to Path docker (Objects Fit Objects to Path) to customize how objects are placed on the path and create unique effects.

Objects

Keep originals: Enable this check box to fit copies of the objects to the selected path and keep the original objects in place.

Duplicates: Fit Objects to Path can automatically create extra copies of the selected objects and place them on the path. Specify the number of additional copies to be fit to the path in the Duplicates box.

Group all objects: Enable this check box if you want the objects to be grouped after they are placed on the path. The path is not included in the group so that you can move it or delete it easily.

Path

Treat as contiguous: This option has an effect when you want to fit objects to closed paths or to paths that consist of open subpaths.

Object positioning

Order: This list box lets you choose the order in which the selected objects appear on the path. The objects can be placed in the order in which they were selected or in reverse order. You can also place them based on their size, width, or height.

This effect was created by fitting a rectangle and 350 rectangle copies to the path of a text object.
Distribution: This list box lets you choose a distribution method. You can distribute objects by inserting equal space between them (Uniform object spacing). You can also distribute objects by spacing evenly the reference points that you select.

Reference points: An object is anchored (fit) to the path by its reference point. The Reference list box lets you choose the center of rotation of each object or the object origin as a reference point. The object origin, also known as “anchor point”, can be the center of an object or any one of eight other points on the object’s bounding box. To change the origin point, simply click another point on the Origin control.
Rotation options

Ignore initial rotation: This control lets you clear all previous rotations applied to the objects before they were placed on the path.

The following controls let you enhance object rotation along the path.

Style: Choose from several rotation styles to create various rotation effects. The Uniform style lets you add the same rotation to each object along the path by specifying a value in the Start angle box. The Progressive style works together with the Start angle and Spin angle boxes to add a rotation that changes along the path. If you want to create a more organic rotation effect with angles of rotation varying randomly, you can choose Jitter or Progressive jitter. You can specify the range of the random rotations.

Direction: By default, added rotation is applied counterclockwise. To change the direction, enable the Clockwise check box.

Start angle: Add an angle of rotation to each object.

Spin angle: This control works together with the Progressive and Progressive jitter styles. It allows you to add an angle of rotation to each object, ranging from $0^\circ$ to the specified value. Suppose that you want to fit an object and three duplicates to a path, and you specify a spin angle of $180^\circ$. This spin angle applies an additional rotation of $0^\circ$ to the first object, $60^\circ$ to the second object, $120^\circ$ to the third object, and $180^\circ$ to the last object.
Progressive rotation style with a start angle of 5º and a spin angle of 180º

**Revolutions:** An alternative way of adding rotation to the objects on the path progressively. One revolution equals 360º.

**Range:** This control is available when the Jitter and Progressive jitter styles are selected. Specify a value range for random rotations used to create jitter. For example, with a value of 15º, the angles of rotation vary between 15º and -15º.

Examples of Jitter (top) and Progressive jitter (bottom) rotation styles with range of 30º

**Group objects**

When you group two or more objects, they are treated as a single unit but retain their individual attributes. Grouping lets you apply the same formatting, properties, and other changes to all the objects within the group at the same time. In addition, grouping helps prevent accidental changes to the position of an object in relation to other objects. You can also create nested groups by grouping together existing groups.

Individual objects retain their attributes when they are grouped.
You can add objects to or remove objects from a group, and you can delete objects that are members of a group. You can also select and edit a single object in a group without ungrouping the objects. For information on selecting objects in groups, see “Select an object in a group” on page 303. If you want to edit multiple objects in a group at the same time, you must first ungroup the objects. If a group contains nested groups, you can ungroup all objects in the nested groups simultaneously.

**To group objects**

1. Select the objects.
2. Click **Object ▸ Group ▸ Group**.

The status bar indicates that a group of objects is selected.

You can select objects from different layers and group them; however, after objects are grouped, they reside on the same layer and are stacked on top of one another.

You can create a nested group by selecting two or more groups of objects and clicking **Object ▸ Group ▸ Group**. You can also group objects by dragging an object in the **Objects** docker over another object. If the **Objects** docker is not open, click **Window ▸ Dockers ▸ Objects**.

You can also group objects by clicking the **Group objects** button on the property bar.

**To add an object to a group**

- In the **Objects** docker, drag the object to the group.

  If the **Objects** docker is not open, click **Window ▸ Dockers ▸ Objects**.

**To remove an object from a group**

- In the **Objects** docker, drag an object outside the group.

  If the **Objects** docker is not open, click **Window ▸ Dockers ▸ Objects**.

You can also remove an object from a group by clicking the **Pick tool** holding down Ctrl, clicking the object in the drawing window, and then pressing **Delete**.

To delete an object in a group, select the object in the object list, and click **Edit ▸ Delete**.

**To edit an object in a group**

1. Click the **Pick tool**.
2. Hold down Ctrl, and click an object in a group to select it.
3. Edit the object.

You can also select an object in a group by clicking the object in the **Objects** docker. If the **Objects** docker is not open, click **Window ▸ Dockers ▸ Objects**.
You can use Focus mode to facilitate the selection and editing of a specific object within an object group. When you bring an object into focus, it is temporarily brought to the front of the stacking order. For more information, see “Edit objects in Focus mode” on page 305.

To ungroup objects

1. Select one or more groups.
2. Click Object ➤ Group, and click one of the following commands:
   - Ungroup — breaks a group into individual objects, or a nested group into multiple groups
   - Ungroup All — breaks one or more groups into individual objects, including objects within nested groups

Choosing Ungroup All also ungroups all nested groups. To preserve nested groups, select Ungroup.

You can also ungroup objects by clicking the Ungroup button on the property bar.

You can also ungroup all nested groups within a group by clicking the Ungroup all button on the property bar.

Combine objects

Combining two or more objects creates a single object with common fill and outline attributes. You can combine rectangles, ellipses, polygons, stars, spirals, graphs, or text so that they are converted to a single curve object. If you need to modify the attributes of an object that has been combined from separate objects, you can break apart the combined object. You can extract a subpath from a combined object to create two separate objects. You can also weld two or more objects to create a single object. For information about welding objects, see “Weld and intersect objects” on page 262.

To combine objects

1. Select the objects to be combined.
2. Click Object ➤ Combine.
Combined text objects become larger blocks of text.

You can also combine selected objects by clicking the Combine button on the property bar.

You can close open lines in a combined object by clicking Object > Join Curves and choosing settings in the Join Curves docker.

To break apart a combined object
1 Select a combined object.
2 Click Object > Break Curve Apart.

If you break apart a combined object that contains artistic text, the text breaks apart into lines first, and then into words. Paragraph text breaks into separate paragraphs.

To extract a subpath from a combined object
1 Click the Shape tool, and select a segment, node, or group of nodes on a combined object.
2 Click the Extract subpath button on the property bar.

After you extract the subpath, the fill and outline properties of the path are removed from the combined object.

Lock objects
Locking an object prevents you from accidentally moving, sizing, transforming, filling, or otherwise changing it. You can lock single, multiple, or grouped objects. To change a locked object, you need to unlock it first. You can unlock one object at a time, or all locked objects at the same time.

To lock an object
• Select an object, and click Object > Lock > Lock.

You cannot lock linked objects, such as blends, contours, or text inside an object. You also cannot lock objects within groups or linked groups.

You can also lock an object by right-clicking it and then clicking Lock.
You can also lock an object by clicking the lock icon beside the object name in the Objects docker.

To unlock objects
1 Select a locked object or group of objects.
2 Click Object > Lock, and then click one of the following:
• Unlock
• Unlock All
You can also unlock an object by right-clicking it and then clicking **Unlock**. You can also unlock multiple locked objects by dragging in the second column in the **Objects** docker.

**Find and replace objects**

You can find objects so that you can quickly replace them or select them for editing.

The search criteria you use can include object type and its related properties, fill and outline properties, vector effects applied to objects, or the name of an object or style. For example, you can search for and select all rectangles with rounded corners and without fill. You can also search for objects that contain the same properties as a selected object. You can change the search criteria in the middle of a search. You can also save search criteria for later use.

You can find objects that contain the properties you specify and then replace those properties with others. For example, you can replace all object fills of a certain color with fills of a different color. You can also replace color models and palettes, outline properties, and text attributes, such as font and font size.

You can also search for specific words and replace them with other words. For more information, see “To find and replace text” on page 609.

By default, the application searches only the current page. When working with multipage documents, you can expand the search range to find and replace objects on all document pages, a range of pages, or specific pages. Conversely, you can limit the search range to only currently selected objects.

**To find and select objects**

1. Click **Edit ➤ Find and Replace**.
2. In the **Find and Replace** docker, choose **Find Objects** from the list box at the top of the docker.
3. Enable the **Properties** option.
4. Click **Add Query**, and then in the dialog box that appears, do any of the following:
   - Under **Object Types**, enable check boxes corresponding to object types to include in the search. You can narrow the search by specifying object properties. To include all objects in a search, enable the **Object Types** check box.
   - Under **Fills**, enable check boxes corresponding to fill types to include in the search. You can narrow the search by specifying fill properties. To include all fill types in a search, enable the **Fills** check box. For more information about fill types and their properties, see “Fills” on page 425.
   - Under **Outlines**, enable check boxes corresponding to outline types to include in the search. You can narrow the search by specifying outline properties. To include all outline types in a search, enable the **Outlines** check box. For more information about outlines and their properties, see “Format lines and outlines” on page 174.
   - Under **Special Effects**, enable check boxes corresponding to special effects to include in the search. You can narrow the search by specifying special effect properties. To include all effects listed under **Special Effects** in a search, enable the **Special Effects** check box. For more information about special effects and their properties, see “Add 3D effects” on page 551.
5. Click **OK**.
6. In the **Find and Replace** docker, click any of the following buttons:
   - **Find Next >** or **Find Previous <** to scroll through objects that meet the search criteria.
   - **Find All** or **Find All on Page** to select all objects on the active page that meet the search criteria.
   - **Edit Query** to modify the search criteria.
You can also

Search for objects by name
In the Find and Replace docker, enable the Names or Styles option, enable the Object name check box, and type the object name.

Search for objects by style
In the Find and Replace docker, enable the Names or Styles option, enable the Style check box, and then either enable the Name option and choose the style name or enable the Type option and choose the style type.

Save object-search criteria
Click the Save button, type a name in the File name box, and then click Save. The search criteria is saved to a FIN file.

Reuse object-search criteria
Click the Load button, navigate to the folder where the FIN file is stored, and click Open.

You can also initiate an object search by pressing Ctrl + F.

To find objects with similar properties
1 Select an object.
2 Click Edit ➤ Find and Replace.
3 In the Find and Replace docker, choose Find Objects from the list box at the top of the docker.
4 Enable the Properties option.
5 Click From Selection.
   The Search query area displays all the properties of the selected object.
6 Click any of the following buttons:
   • Find Next > or Find Previous < to scroll through objects that meet the search criteria.
   • Find All or Find All on Page to select all objects on the active page that meet the search criteria.
   • Edit Query to modify the search criteria.

The application can find and replace objects on multiple pages at once; however, it can select only objects on the active page.

To replace object properties
1 Click Edit ➤ Find and Replace.
2 In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3 To specify the properties you want to replace, enable one of the following options: Color, Color model or palette, Outline properties, or Text properties.
4 Choose the settings you want in the Find and Replace areas.
5 Click one of the following buttons:
   • Replace to replace the properties of the selected objects.
   • Replace All to modify all objects that meet the search criteria.
For more information about replacing colors, see “To find and replace colors” on page 414.
For more information about replacing outline colors, see “To find and replace outline colors” on page 185.
For more information about replacing outline widths, see “To find and replace outline widths” on page 185.
For more information about replacing text properties, see “To find and replace text properties” on page 609.

To set the search range
1  Click Edit ➤ Find and Replace.
2  In the Find and Replace docker, expand the Search range section.
3  Enable any of the following options:
   • Selection — to search only the currently selected objects
   • Current page — to search the page you are working on
   • All pages — to search all document pages
   • Pages — to set the page range or identify specific document pages you want to search

The application can find and replace objects on multiple pages at once; however, it can select only objects on the active page.

Hide and show objects

CorelDRAW allows you to hide objects and groups of objects, helping you edit objects in complex projects and experiment with your designs more easily.

To hide an object
1  Select the object that you want to hide.
2. Click Object  Hide  Hide.

When an object is hidden in the Objects docker, an eye icon is displayed beside its name.

You can also access the Hide command by right-clicking an object.

To display hidden objects
- Click Object  Hide, and click one of the following commands:
  - Show
  - Show All

You can also show a hidden object by clicking the eye icon beside the object name in the Objects docker.

Constrain objects

You can restrict how objects are drawn and edited by using a constrain key while you draw. For example, you can press a constrain key to constrain a rectangle to a square, an ellipse to a circle, or a straight line to a perfectly horizontal or vertical line. By default, the application uses the Ctrl key to constrain the shape or angle of objects, and the Shift key to draw shapes outward from their center of origin. However, you can change the default constrain key to Shift at any time.

You can use a control key to draw or rotate an object, or the nodes and control handles of an object, at a preset increment. This increment is known as the constrain angle. By default, the constrain angle is 15 degrees, but you can change it to suit your needs.

To constrain objects while drawing or editing

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constrain a shape to equal width and height</td>
<td>While holding down Ctrl, draw diagonally.</td>
</tr>
<tr>
<td>Use a preset increment (the constrain angle) to draw or rotate an object</td>
<td>While holding down Ctrl, move the pointer to draw or rotate the object.</td>
</tr>
</tbody>
</table>

A rectangle is constrained to a square, an ellipse to a circle, and a polygon to a shape with sides of equal length.

To change the constrain key
1. Click Tools  Options  Tools.
2. In the left pane of the dialog box that appears, click Pick.
3. In the Ctrl and Shift keys area, enable one of the following options:
   - CorelDRAW defaults — lets you use the Ctrl key as the constrain key and the Shift key to draw shapes outward from their center of origin
   - Windows standard — lets you use the Shift key as the constrain key and the Ctrl key to apply transformations to the duplicate of an object while leaving the original intact
To change the constrain angle
1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the dialog box that appears, click Edit.
3 Type a value in the Constrain angle box.

Export objects
CorelDRAW lets you export one or more objects, or a group of objects to the GIF, JPEG, PNG, and PDF formats. For more information, see “Export objects and pages” on page 891.

Bar codes
The Barcode wizard in CorelDRAW lets you add bar codes to drawings. A bar code is a group of bars, spaces, and sometimes numbers that is designed to be scanned and read into computer memory. Bar codes are most commonly used to identify merchandise, inventory, and documents.

The Barcode wizard guides you through the process of inserting a bar code. If you need additional information at any step, you can consult the Help in the Barcode wizard.

You can also insert QR codes. For more information, see “Insert QR codes” on page 367.

To insert a bar code
1 Click Object ▶ Insert ▶ Barcode.
2 Follow the instructions in the Barcode wizard.
   If you need help with choosing options, click Help in the Barcode wizard.

A bar code is inserted into a drawing as an object.
Link and embed objects

Object linking and embedding (OLE) is a method of exchanging information between applications. Using OLE, you can take selected objects or entire files from one application, called the source application, and place them into another application, called the destination application.

You can freely move objects and files between applications as long as all the applications involved support OLE. CorelDRAW lets you create and edit OLE objects, as well as insert objects and files created in other applications.

Linking results in a larger file size but is useful when you want to use an object or file in multiple files. To change every instance of the object or the file, you only need to change the object in the source application. Linking is also useful when the destination application does not directly support files created in the source application. Embedding is useful when you want to include all objects in one file. Embedded objects are not linked to the source file, and result in a smaller file size in the destination application.

This section contains the following topics:
  • “Insert linked or embedded objects” (page 365)
  • “Edit linked or embedded objects” (page 366)

Insert linked or embedded objects

CorelDRAW lets you insert CorelDRAW files as linked or embedded objects in other applications. You can also insert a linked or embedded object in CorelDRAW. A linked object remains connected to its source file; whereas an embedded object is not linked to its source file but is integrated into the active document.

To insert a linked object
1. In CorelDRAW, select an object.
   Make sure that the file is saved first.
2. Click Edit ➤ Copy.
3. Click Edit ➤ Paste special in the destination application.
4. Enable the Paste link option.

To insert a linked object into the active drawing from another application, click Object ➤ Insert ➤ Object. In the Insert new object dialog box, enable the Create from file option, browse to the file you want to insert, and enable the Link check box.
To insert an embedded object

1. In the destination application, click **Object ▶ Insert ▶ Object**.
2. Enable the **Create from file** option.
3. Click the **Browse** button.
4. Click a filename.

You can also create an embedded object by enabling the **Create new** option, and choosing the application in which you want to create the object from the **Object type** list box.

You can also insert an embedded object by selecting an object in the source application, and dragging it to the window of the target application.

Edit linked or embedded objects

You can edit a linked or embedded object. You can edit a linked object by editing its source file. Any changes you make to the source file are automatically applied to the linked object.

To edit a linked or embedded object

1. Double-click the linked or embedded object to start the source application.
2. Edit the object in the source application.
3. Save the changes in the source application.
4. Close the source application.
5. Return to the active application window to review the edits.

In most cases, you can edit OLE objects only in the source application. If you try to change an OLE object using CorelDRAW, note the following limitations. Depending on the source of the OLE object, you might not be able to rotate, skew, clone, trim, weld, intersect, use as symbols, or combine OLE objects. Also, you might not be able to apply any of the effects in the **Effects** menu to OLE objects, except for PowerClip objects. You can only size, move, copy OLE objects and place them into PowerClip containers.

You can also edit linked or embedded objects by starting the source application and opening the file directly.
A Quick Response (QR) code is a type of barcode that represents information in two dimensions. Typically, QR codes consist of dots (also called “pixels”) arranged in a square pattern and displayed against a contrasting background. QR codes are known for their fast readability and can store information such as website addresses, phone numbers, and messages.

With the widespread use of smartphones, QR codes have become popular in consumer advertising and packaging. By scanning a QR code on your smartphone, you can quickly access the brand’s website for more information about a product.

To insert, edit, and validate QR codes, you must sign in to your account and be connected to the Internet.

This section contains the following topics:
- “Insert QR codes” (page 367)
- “Edit QR codes” (page 368)
- “Validate QR codes” (page 370)

Insert QR codes

CorelDRAW lets you insert QR codes with embedded information such as a web address, email address, phone number, text message, geo location, or plain text. After you insert a QR code, you can edit and validate it. For more information, see “Edit QR codes” on page 368 and “Validate QR codes” on page 370.

To insert a QR code

1. Click Object ➤ Insert ➤ QR Code.
2. In the Properties docker, choose one of the following options from the QR code type list box:
• **URL** — lets you specify a URL for a website
• **Email address** — lets you specify an email address if you want to use the QR code to generate a blank email
• **Phone number** — lets you specify a phone number for the QR code. Depending on the QR reader that you use, scanning the code can initiate, with your permission, dialing the phone number on smartphones.
• **SMS** — lets you include a Short Message Service (SMS) message by typing a phone number and message text. With your permission, the QR reader can initiate sending the SMS message to the specified phone number.
• **Contact** — lets you specify contact information in vCard or meCard format. From the Contact card type list box, choose vCard or meCard, and type the contact information in the appropriate boxes. With your permission, this contact information can be automatically added to the address book on your phone.
• **Calendar event** — lets you schedule an event by specifying a name, location, start date/time, and end date/time for the event. With your permission, the event can be added to your calendar.
• **Geo location** — lets you show a geographic location by specifying latitude and longitude values
• **Plain text** — lets you include plain (unformatted) text

To insert, edit, and validate QR codes, you must sign in to your account and be connected to the Internet.

**Edit QR codes**

After you insert a QR code, you can use the Properties docker to customize the pixel fill, the background fill, the pixel outline, as well as the pixel shape and corner roundness. When you customize the shape of the pixels, the markers (the three larger squares in the corners, as well as one or more smaller squares in the interior of the code pattern) remain unchanged to maintain the readability of the code. You can also specify the margin around the QR code or weld the pixels together.

![A QR code with customized pixel shapes and added text. The markers remain unchanged.](image)

*From left to right: Custom pixel fill color, custom pixel fill and background color, custom pixel fill and outline color as well as custom pixel outline width*
Error correction

Visual effects, logos, or text added to a QR code can give it an artistic look but may be considered errors by scanners. You can use the error correction settings to minimize the possibility of error when scanning the QR code. For example, if part of the pixel pattern is covered by a graphic or text, the error correction duplicates some of the hidden data so that this data can be recovered. Four levels of error correction are available.

You can move, resize, scale, and align the QR code like any other object. For more information, see “Transform objects” on page 308.

With QR codes, you can use styles to control the appearance of the fill, outline, and other properties. For more information, see “Styles and style sets” on page 697. You can also change the default look of QR codes by modifying the default object properties. For more information, see “Manage and apply default object properties” on page 702.

To edit a QR code

1. Double-click the QR code.
2. In the Properties docker, perform any of the following tasks.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a fill to the pixels of the QR code</td>
<td>Choose a fill type from the <strong>Pixel fill type</strong> list box, and then choose a fill from the <strong>Pixel fill color</strong> picker. If you want to customize the fill, click the <strong>Pixel fill settings</strong> button next to the pixel color picker, and specify the fill settings.</td>
</tr>
<tr>
<td>Apply a fill to the background</td>
<td>Choose a fill type from the <strong>Background fill type</strong> list box, and then choose a fill from the <strong>Background fill color</strong> picker. If you want to customize the fill, click the <strong>Background fill settings</strong> button next to the background color picker, and specify the fill settings.</td>
</tr>
<tr>
<td>Specify the pixel outline width and color</td>
<td>Type a value in the <strong>Pixel outline width</strong> box, and then choose a color from the <strong>Pixel outline color</strong> picker. If you want to customize the outline, click the <strong>Pixel outline settings</strong> button next to the outline color picker, and specify the outline settings.</td>
</tr>
<tr>
<td>Specify the margin around the QR code</td>
<td>Type a value in the <strong>Margin</strong> box.</td>
</tr>
<tr>
<td>To</td>
<td>Do the following</td>
</tr>
<tr>
<td>----</td>
<td>------------------</td>
</tr>
<tr>
<td>Choose a pixel shape</td>
<td>Choose a shape from the <strong>Pixel shape</strong> picker. To set the percentage of fill on the pixels, type a value in the <strong>Pixel fill factor</strong> box.</td>
</tr>
<tr>
<td>Weld pixels</td>
<td>Click the arrow button ( \Downarrow ) at the bottom of the <strong>QR code</strong> section to expand it, and enable the <strong>Weld pixels</strong> check box.</td>
</tr>
<tr>
<td>Set the corner roundness of the pixels</td>
<td>Click the arrow button ( \Downarrow ) at the bottom of the <strong>QR code</strong> section to expand it, and type a value in the <strong>Pixel roundness</strong> box.</td>
</tr>
</tbody>
</table>

When editing the fill, make sure that there is high contrast between the pixels and the background to avoid errors in scanning the code.

To insert, edit, and validate QR codes, you must sign in to your account and be connected to the Internet.

### To add a text or graphic object to a QR code

1. Select the text or graphic object that you want to add.
2. Move the object and place it in the QR code. If the object is behind the QR code, change the stacking order by using the **Object** \( \rightarrow \) **Order** command.

### To set the error correction level

1. Double-click a QR code.
2. In the **Properties** docker, click the arrow button \( \Downarrow \) at the bottom of the **QR code** section to expand it, and choose an option from the **Error correction level** list box.
   - **Low** — restores 7% of the information
   - **Medium** — restores 15% of the information
   - **Quartile** — restores 25% of the information
   - **High** — restores 30% of the information

Higher correction levels duplicate a higher percentage of the information, which may limit the amount of new information a QR code can store. This may be a problem for QR codes that are approaching, or already contain, the maximum amount of information before high error correction is applied. In that case, you are prompted to reduce either the correction level or the amount of data in the QR code.

### Validate QR codes

After inserting and formatting a QR code, you can validate it to make sure that it can be read by QR code readers and scanners.

### To validate a QR code

1. Double-click the QR code.
2. In the **Properties** docker, click **Validate**.
To insert, edit, and validate QR codes, you must sign in to your account and be connected to the Internet.

To validate a QR code that was not created in CorelDRAW, click **Object ➤ Insert ➤ Validate Bar Code**, and marquee-select the QR code.
Layers

Layers help you organize and arrange objects in complex illustrations.

This section contains the following topics:
- “Create layers” (page 373)
- “View layers, pages, and objects” (page 376)
- “Change layer properties” (page 378)
- “Find, move, and copy layers and objects” (page 381)

Create layers

All CorelDRAW drawings consist of stacked objects. The vertical order of these objects — the stacking order — contributes to the appearance of the drawing. An effective way to organize these objects is by using invisible planes called layers.

Layering gives you added flexibility when you organize and edit the objects in complex drawings. You can divide a drawing into multiple layers, each containing a portion of the drawing’s contents. For example, you can use layers to organize an architectural plan for a building. You can organize the building’s various components (for example, plumbing, electrical, structural) by placing them on separate layers.
Local layers and master layers

All content is placed on layers. Content that applies to a specific page is placed on a local layer. Content that applies to all pages in a document can be placed on a global layer called a master layer. Master layers are stored on a virtual page called the Master Page.

The Objects docker displays the default layer structure. The names of the active page and layer appear at the top.

You can create master layers for all pages, for even pages, or for odd pages. For example, placing content on an even master layer means that the content will appear on all even pages but not on the odd pages.

Each new file is created with a default page (Page 1) and a Master Page. The default page contains the following layers:

- **Guides** — stores page-specific (local) guidelines. All objects placed on the Guides layer appear as outlines only, and the outlines act as guidelines.
- **Layer 1** — represents the default local layer. When you draw objects on the page, the objects are added to this layer unless you choose a different layer.

The Master Page is a virtual page that contains the information that applies to all pages in a document. You can add one or more layers to a master page to hold content such as headers, footers, or a static background. By default, a master page contains the following layers:
• **Guides (all pages)** — contains the guidelines that are used for all pages of the document. All objects placed on the Guides layer appear as outlines only, and the outlines act as guidelines.

• **Desktop** — contains objects that are outside the borders of the drawing page. This layer lets you store objects that you may want to include in the drawing at a later time.

• **Document grid** — contains the document grid that is used for all pages of the document. The document grid is always the bottom layer.

The default layers on the master page cannot be deleted or copied.

To add content to a layer, you must make it the active layer.

You can delete selected local layers. If a document contains layers that do not contain any content, you can delete them all at once to reduce clutter.

**To create a layer**

1. If the **Objects** docker is not open, click **Objects» Objects**.
2. Click the **Options** button 
   and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a local layer</td>
<td>Click <strong>Layer » New Layer</strong>.</td>
</tr>
<tr>
<td>Create a master layer for all pages</td>
<td>Click <strong>Layer » New Master Layer (all pages)</strong>.</td>
</tr>
<tr>
<td>Create a master layer for odd pages</td>
<td>Click <strong>Layer » New Master Layer (odd pages)</strong>. This command is available only when the active page is an odd page.</td>
</tr>
<tr>
<td>Create a master layer for even pages</td>
<td>Click <strong>Layer » New Master Layer (even pages)</strong>. This command is available only when the active page is an even page.</td>
</tr>
</tbody>
</table>

To use a layer in the drawing, you must first make the layer active by clicking the layer name in the **Objects** docker. When you start a drawing, the default layer (Layer 1) is the active layer.

Master layers are always added to the master page. Content added to these layers is visible on all pages of the document, all odd pages, or all even pages, depending on the type of master layer that you have chosen.

Master layers for odd and even pages cannot be created in Facing Pages view. If you have created odd and even master pages before switching to Facing Pages view, the odd and even master layers will be converted to all-page master layers. For more information about facing pages, see “To view facing pages” on page 727.

You can also add a layer by clicking the **New Layer** button in the **Objects** docker.

You can also create new master layers by opening the flyout at the bottom of the **Objects** docker and clicking the respective button: **New Master Layer (all pages)**, **New Master Layer (odd pages)**, or **New Master Layer (even pages)**.

You can make any layer a master layer by right-clicking the layer name, clicking **Change Layer To**, and choosing **Master Layer (all pages)**, **Master Layer (odd pages)**, or **Master Layer (even pages)**.
To make a layer active

1. If the Objects docker is not open, click Object ➤ Objects.
2. In the Objects docker, do one of the following:
   • Click the layer name.
   • Click an object residing on the layer you want to make active.

By default, the active layer is Layer 1.

The name of the active layer and the type of the currently selected object appear on the status bar at the bottom of the application window. The names of the active page and layer also appear at the top of the Objects docker.

If you don’t want to activate layers by selecting objects that reside on them, click the Options button, and click Select Object to Activate Layer to disable the command.

To delete a layer

1. If the Objects docker is not open, click Object ➤ Objects.
2. Click the name of a layer.
3. Click the Delete button.

When you delete a layer, you also delete all the objects on it. To preserve an object, move it to a different layer before you delete the current layer.

You can delete any unlocked layer except the following default layers: Document grid, Desktop, Guides, and Guides (all pages). For more information about locking and unlocking layers, see “To set the editing properties of a layer” on page 380.

You can also delete a layer by right-clicking the layer name in the Objects docker and choosing Delete.

To delete all empty layers

• In the Objects docker, click the Options button, and click Layer ➤ Delete Empty Layers.

View layers, pages, and objects

The views in the Objects docker let you display the components of your document in different ways. The view you choose depends on the complexity of your document and the task you are performing. For example, in a long multipage document, you can choose to view only pages so that you can navigate the document more easily and view only one page at a time. The Layers and Objects view lets you view and reorder all the layers that affect the selected page.
You can expand layers, pages, and groups, including any nested groups residing on them, with a single click.

You can also switch the view of a layer from a color viewing mode such as Normal or Enhanced to Wireframe. Useful for complex projects, this feature lets you control the viewing mode of each layer as opposed to the View → Wireframe command that applies to all layers in a project. Also, you can change the color of the wireframe lines.

The Objects docker shows thumbnail previews of objects so that you can identify them more easily. You can increase and decrease the size of the object thumbnails.

For information about how facing page views affect layers, see “To view facing pages” on page 727.

For information about how layers are affected when you save a file to an earlier version of CorelDRAW, see “To save a drawing” on page 76.

To display pages, layers, and objects in the Objects docker

1. If the Objects docker is not open, click Object → Objects.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Display all layers and objects for a page | Click the View Layers and Objects button  
Choose a page from the Choose Page list box. |
| Display all layers and objects across all pages | Click the View Pages, Layers, and Objects button |
To Do the following

Display selected objects in the Objects docker
Click the Options button \(\textbullet\) and then click Expand to Show Selection.

Display master layers under each page in the Objects docker
Click the Options button \(\textbullet\) and then click Show Master Layers on Pages.
This feature is useful for hiding the master layer content or changing the layer stacking order on a specific page. For more information about changing layer properties, see “Change layer properties” on page 378.

The name of the active layer and the type of the currently selected object appear on the status bar at the bottom of the application window. The names of the active page and layer also appear at the top of the Objects docker.

If you want to view a document that has facing pages, see “To view facing pages” on page 727.

To expand fully layers, pages, and groups
• In the Objects docker, Ctrl +click the arrow to the left of the layer, page, or group name.
To collapse an expanded layer, page or group, click its arrow button \(\nabla\).

To switch the view of a layer
• In the Objects docker, right-click a layer, and click Switch to Wireframe View or Switch to Color View.

This feature lets you control the viewing mode of each layer as opposed to the View \(\textbullet\) Wireframe and other view commands that apply to all layers in a project.

You can also point to the right of the layer name and Ctrl +click the layer color icon.

To change the color of the wireframe lines
• In the Objects docker, click the layer color bar that appears to the right of the layer name, and choose a color.

Objects on the layer are displayed with the layer color when you use Wireframe view (View \(\textbullet\) Wireframe).

To change the size of object thumbnails
• Move the Resize list slider at the bottom of the Objects docker.

Change layer properties
For each new layer that you create, the display, editing, and printing and exporting properties are enabled by default. You can change these properties at any time. You can also turn a local layer into a master layer, or a master layer into a local layer. For information about master layers, see “Create layers” on page 373.
You can choose to show or hide layers in a drawing. Hiding a layer lets you identify and edit the objects on other layers. It also reduces the time required for your drawing to refresh when you edit it.

You can set printing and exporting properties for a layer to control whether a layer is displayed in the printed or exported drawing. Note that hidden layers are displayed in the final output if the printing and exporting properties are enabled. The **Document grid** layer cannot be printed or exported.

You can allow editing of the objects on all layers or restrict editing so that you can only edit objects on the active layer. You can also lock a layer to prevent accidental changes to the objects it contains. When you lock a layer, you cannot select or edit the objects on that layer.

You can rename layers to indicate their contents, their position in the stacking order, or their relationship with other layers.

You can change the layer color so that objects on the layer are displayed with the layer color when you use Wireframe view. For example, if you place various components of an architectural plan (plumbing, electrical, structural) on separate layers, you can use layer color to quickly identify to which component the objects belong. For more information about Wireframe view, see "Viewing modes" on page 74.
To hide or show a layer

1. If the Objects docker is not open, click Object ▶ Objects.
2. Point to the layer name, and click the eye icon 🕵️.

To show the layer, click the eye icon.

Objects on a hidden layer are displayed in the printed or exported drawing unless the layer’s printing and exporting properties are disabled. For more information, see “To enable or disable printing and exporting of a layer” on page 380.

You can also show or hide a layer by right-clicking the layer in the Objects docker and then clicking Show orHide.

To enable or disable printing and exporting of a layer

1. If the Objects docker is not open, click Object ▶ Objects.
2. Click the printer icon 🗽 beside the layer name.

Disabling the printing and exporting of a layer prevents its contents from appearing in the printed or exported drawing, or in full-screen previews. For information about full-screen previews, see “Preview drawings” on page 73.

You can also enable or disable the printing and exporting of a layer by right-clicking the layer in the Objects docker and clicking Enable Print and Export or Disable Print and Export.

To set the editing properties of a layer

1. If the Objects docker is not open, click Object ▶ Objects.
2. In the Objects docker, click the name of the layer that you want to edit.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock or unlock a layer</td>
<td>Right-click the layer name, and click Lock. To unlock a layer, click the lock icon 🗝 beside the layer name.</td>
</tr>
<tr>
<td>Allow editing on all layers</td>
<td>Click the Options button 🧩 and then click Edit Across Layers to enable the command.</td>
</tr>
<tr>
<td>Allow editing on the active layer only</td>
<td>Click the Options button 🧩 and then click Edit Across Layers to disable the command.</td>
</tr>
</tbody>
</table>
If you disable editing across layers, you can work only on the active layer and the Desktop layer. You cannot select or edit objects on inactive layers. For example, if you use the Pick tool to marquee-select multiple objects on the drawing page, only the objects on the active layer are selected.

You cannot lock or unlock the Document grid layer.

You can also unlock a layer by right-clicking the layer in the Objects docker and then clicking Unlock.

To rename a layer
1. If the Objects docker is not open, click Object ▶ Objects.
2. Right-click the layer name, and click Rename.

Layer names may not be preserved when you save a CorelDRAW Graphics Suite file to a previous version.

Find, move, and copy layers and objects

When working with complex projects, you can find layers and objects quickly by using the Objects docker.

You can move or copy layers on a single page or between pages. You can also move or copy selected objects to new layers, including layers on the master page.

Moving and copying layers affects the stacking order. Moving or copying an object to a layer below its current layer causes the object to become the top object on its new layer. Similarly, moving or copying an object to a layer above its current layer causes the object to become the bottom object on its new layer.

When you add a new page, objects that reside on the desktop are kept on the layer where they were created and do not appear on the new page. You can have such objects moved to the Desktop layer automatically so that they appear on all document pages.

To find an object or a layer
• In the Objects docker, type the name of an object or a layer in the Search box.

To move a layer
1. If the Objects docker is not open, click Object ▶ Objects.
2. In the layers list, drag a layer name to a new position.

To copy a layer
1. If the Objects docker is not open, click Object ▶ Objects.
2. In the layer list, right-click the layer that you want to copy, and click Copy.
3. Right-click the layer above which you want to place the copied layer, and click Paste.

The layer and the objects it contains are pasted above the selected layer.

To move or copy an object to another layer
1. If the Objects docker is not open, click Object ▶ Objects.
2 Click an object in the Objects docker.

3 Click the Options button \(\text{Gear} \) and click one of the following:
   - Move to Layer
   - Copy to Layer

4 Click the destination layer.

When you move objects to or from a layer, the layer must be unlocked.

You can move and copy an object to another layer by dragging the object to a new layer in the Objects docker.

You can also move an object to another layer by using an Order command. For more information, see “To move an object in the stacking order” on page 345.

To move objects on the desktop to the Desktop layer when adding new pages
   - In the Objects docker, click the Options button \(\text{Gear} \) and disable the Keep Desktop Objects on Layer command.
Symbols

CorelDRAW lets you create objects and save them as symbols. Symbols are defined once and can be referenced many times in a drawing. Each time you insert a symbol into a drawing, you create an instance of the symbol. Symbol definitions, as well as information about instances, are stored in a symbol manager, which is part of the CorelDRAW (CDR) file. Using symbols for objects that appear many times in a drawing helps to reduce file size.

In this section, you’ll learn about

- “Create, edit, and delete symbols” (page 383)
- “Use symbols in drawings” (page 385)
- “Share symbols between drawings” (page 387)
- “Symbol collections and libraries” (page 388)

For information about modifying symbol instances and about unsupported object types, see “Reference: Symbols” on page 389.

For information about working with special characters in text, see “Embed graphics” on page 621.

Create, edit, and delete symbols

Symbols are objects that are defined once and can be referenced many times in a drawing. You can have multiple instances of a symbol in a drawing with little impact on file size. Symbols make editing a drawing quicker and easier, as changes made to a symbol are automatically inherited by all instances.
Symbols are created from objects. When you convert an object to a symbol, the new symbol is added to the Symbols docker, and the selected object becomes an instance. You can also create a symbol from multiple objects. Most objects in CorelDRAW can be converted to symbols, with some exceptions. For more information, see “Unsupported object types” on page 390.

The symbols that you create in a drawing are saved with the CorelDRAW (CDR) file. In addition, you can create symbol libraries, which contain symbols that can be shared between drawings. For more information, see “Symbol collections and libraries” on page 388.

You can edit a symbol; any changes you make affect all instances in the drawing. The selection handles for symbols differ from those for objects. Selection handles for symbols are blue; selection handles for objects are black. When you insert a symbol from an external library, a copy of the symbol is added to the active drawing, but it remains linked to the source symbol. You can edit a linked symbol or you can decide to break the link to the external library and make the symbol internal. When the link is broken, the local copy of the symbol remains in the drawing as an internal symbol, and it can be edited independently from the symbol in the external library.

You can also delete a symbol. When you delete a symbol that is used in a document, all instances of the symbol are removed from the document. You can also delete all symbols that are stored in the document library but are not used in the document.

To create a symbol

1. Select an object or multiple objects.
2. Click Object ➤ Symbol ➤ Create new symbol.
3. Type a name for the symbol in the Create new symbol dialog box.

Symbols cannot span layers. If you convert objects on different layers to a symbol, the objects are combined on the topmost object’s layer. For more information about layers, see “Layers” on page 373.

Not all objects can be converted to symbols. For more information, see “Unsupported object types” on page 390.

You can also convert an existing object or objects to a symbol by dragging the object or objects to the Symbols docker. To open the docker, click Object ➤ Symbol ➤ Symbols.

To edit a symbol

1. In the Symbols docker, choose a symbol from the list.
2. Click the Edit symbol button.
3 Modify the objects on the drawing page.
4 Click Finish in the top-left corner of the drawing window.

Changes made to a symbol are automatically made to all instances in the active drawing.
While working in symbol edit mode, you cannot add layers or save a drawing.
Symbols in master symbol edit mode cannot be brought into Focus mode, but symbols not already in edit mode can be brought into focus. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

You can also edit a symbol by selecting an instance in the drawing window and clicking the Edit symbol button on the property bar, or holding down Ctrl and clicking a symbol instance.
To edit a linked symbol, click File  Open. Choose the drive and folder of the library that contains the symbol that you want to modify. Click a library (.csl) filename, and click Open. The symbol appears in the Symbols docker, and it can be selected and edited like any other symbol. You may need permission to change files on the network.
To rename a symbol, double-click the symbol’s name in the Symbols docker, and type a new name.
While editing a symbol, you can insert an instance of another symbol, which creates a nested symbol. You cannot, however, insert an instance of the same symbol.

To make a linked symbol internal
1 Select a symbol in the drawing window.
2 Click Object  Symbol  Break link.
If there are other instances of the symbol in the drawing, you are given the choice to break the link to all instances. If you do, the internal symbol will then apply to all the instances.

You can also make a linked symbol internal by right-clicking a symbol and choosing Break link.

To delete a symbol
1 In the Symbols docker, choose a symbol from the list.
2 Click the Delete symbol button.
When you delete a symbol, all instances of the symbol are removed from the drawing.

To delete unused symbols
1 In the Symbols docker, click the name of the active document.
2 Click the Options button, and choose Delete unused symbols.

Use symbols in drawings
You can find symbols by searching or by browsing the list of available symbols. After finding the symbol you need, you can insert it into the drawing, which creates a symbol instance. You can modify certain properties of a symbol instance, such as size and position, without
affecting the symbol definition stored in the library. For a full list of the properties that you can modify, see “Modify symbol instances” on page 389. You can convert a symbol instance back to an object while preserving its properties.

You can also delete a symbol instance.

**To search for symbols**

1. Open the Symbols docker by clicking Object ➤ Symbol ➤ Symbols.
2. In the Symbols docker, click the drawing or the folder you want to search.
3. Type a keyword in the Search box.
   You can search by symbol name or description.

   To clear the Search box, delete the words you typed.

**To insert a symbol instance**

1. Open the Symbols docker by clicking Object ➤ Symbol ➤ Symbols.
   If you want the symbol scaled automatically to match the current drawing scale, click the Options button and ensure that Scale to world units is enabled.
2. Right-click a symbol from the list, and click Insert symbol button.

   For information about working with special characters in text, see “Embed graphics” on page 621.

   You can also insert a symbol instance by dragging a symbol from the Symbols docker to the drawing window.

**To modify a symbol instance**

1. Select a symbol instance.
2. Make any changes.

Not all properties of a symbol instance can be modified. For a list of properties that can be modified, see “Modify symbol instances” on page 389. To modify other properties, you can revert the symbol instance to an object, or modify the symbol itself.

If a symbol contains multiple objects, all objects in the symbol instance are treated as if they were a group. You cannot modify individual objects in a symbol instance.

When a symbol instance is selected, you can modify many object properties on the property bar.

**To convert a symbol instance to an object or objects**

1. Select a symbol instance.
2. Click Object ➤ Symbol ➤ Revert to objects.

   The symbol remains in the Symbols docker.
You can also revert a symbol instance to an object by right-clicking the symbol instance and clicking **Revert to objects**.

**To delete a symbol instance**

1. Select a symbol instance.
2. Press **Delete**.

The symbol remains in the **Symbols** docker.

**Share symbols between drawings**

You can share symbols between drawings by adding the symbols of a CorelDRAW (CDR) or Corel DESIGNER (DES) drawing to your local or network symbols, by copying and pasting, or by using library files.

Copying symbols to the Clipboard leaves the originals in the library. You can also copy and paste instances of a symbol to and from the Clipboard. Pasting a symbol instance places the symbol in the library and also places an instance of the symbol in the drawing. Subsequent pasting will place another instance of the symbol in the drawing without adding it to the library. If a modified symbol instance is pasted into a drawing, the new instance maintains the properties of the original instance, and the new symbol definition in the library maintains the properties of the original symbol. Symbol instances are copied and pasted in the same way other objects are. For more information, see “Copy, duplicate, and delete objects” on page 311.

For information about how to use libraries to share symbols, see “Symbol collections and libraries” on page 388.

**To add the symbols of a drawing to your Local or Network Symbols**

1. In the folder tree of the **Symbols** docker, click **Local Symbols** or **Network Symbols**.
2. Click the **Options** button, and click **Import Library**.
3. Locate and choose the drawing that contains the symbols you want to use.
4. Click **OK**.

The file name of the drawing appears under **Local Symbols** or **Network Symbols** in the **Symbols** docker. To show the symbols, click the file name.

The symbols you added are linked and can’t be renamed, edited, or deleted.

If the drawing you are importing doesn’t contain symbols, its file name doesn’t appear under **Local Symbols** or **Network Symbols**.

**To copy and paste symbols between drawings**

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy symbols to the Clipboard</td>
<td>Open the source document. In the <strong>Symbols</strong> docker, choose the symbol or symbols from the list, right-click, and click <strong>Copy</strong>.</td>
</tr>
</tbody>
</table>
To Do the following

Paste symbols from the Clipboard

Open the target document. In the Symbols docker, right-click, and click Paste.

Tip: This method can’t be used if there are no symbols in the target document. To paste symbols in a document that has no symbols, click Edit ➤ Paste.

The first pasted symbol is named “Symbol1,” and an increment number is appended to the names of subsequent copies: “Symbol2,” “Symbol3,” and so on.

Symbol collections and libraries

The symbols that you create in a drawing are saved with the CorelDRAW file. If you want to use the symbols in other drawings or share them with other users, you can save or export them to the Corel Symbol Library (CSL) format, creating a symbol library. When you save a drawing to the Corel Symbol Library (CSL) format, all symbol instances are saved with the document. When you export a library, only the symbols are saved with the document.

You can also save your document symbols to the Cloud as a Corel Symbol Library (CSL) file to share them with others and link the .csl file to the document. The linked symbol library appears under Linked Symbols. Symbols from a linked symbol library are updated when the .csl file on the Cloud is updated.

The Symbols docker displays the libraries that are in the local Symbols folder. The Symbols folder is the default location for custom symbol libraries that have been exported from CorelDRAW and imported libraries that are copied locally. You can add libraries and collections (groups of library files) to your drawing. You can also delete libraries and collections, and you can add symbols to an existing library.

To create a symbol library

1. Create the symbols you want.
2. Click File ➤ Save as.
3. Choose the drive and folder where you want to store the library.
4. Choose CSL - Corel Symbol Library from the Save as type list box.
5. Type a filename in the File name box.
6. Click Save.

All symbols and symbol instances are saved with the document.

You can also click the name of the active document in the Symbols docker, click the Options button, and then click Export library. When you export a library, only the symbols are saved with the document.

To save a symbol library to the Cloud

1. In the Symbols docker(Object ➤ Symbol ➤ Symbols), click the document file name.
2. Click the Options button, and choose Save to Cloud.

When you access the Cloud for the first time, you will be asked to sign in with your Corel.com account.
3. Type a filename and choose the folder where you want to save the .csl file.
4. Click Save.
To add a collection or library to a drawing
1. In the folder tree of the Symbols docker, click Local symbols or Network symbols.
2. Click the Options button and click Import Library.
3. Locate and choose a collection or library.
4. Click OK.

By default, library files are referenced from their original location. If you want to copy a library to your Symbols folder, enable the Copy libraries locally check box.

If you are adding a collection, you can enable the Recursive check box to include subfolders.

To delete a collection or library
1. In the Symbols docker, click a collection or library.
2. Press Delete.

The collection or library is removed from the folder tree in the Symbols docker, but files are not deleted.

To add a symbol to an existing library
1. In the Symbols docker, right-click a symbol, and click Copy.
2. Click File ➤ Open.
3. Choose the drive and folder where the library is stored.
4. Choose CSL - Corel Symbol Library from the Files of type list box.
5. Choose the library file where you want to add a symbol.
6. Right-click in the drawing window, and click Paste.
7. Save the library file.

Reference: Symbols

Modify symbol instances
The following object properties can be modified for symbol instances. If a symbol contains multiple objects, all objects in the symbol instance are treated collectively as a single object, just as if they were grouped.

<table>
<thead>
<tr>
<th>Property</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>Can be modified on the property bar. For more information, see “Position objects” on page 327.</td>
</tr>
<tr>
<td>Size</td>
<td>Can be modified on the property bar. For more information, see “Size and scale objects” on page 346.</td>
</tr>
</tbody>
</table>
## Property

<table>
<thead>
<tr>
<th>Property</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale</td>
<td>Percentage is relative to the symbol definition. Can be modified on the property bar. For more information, see “Size and scale objects” on page 346.</td>
</tr>
<tr>
<td>Skew</td>
<td>For more information, see “Skew and stretch objects” on page 232.</td>
</tr>
<tr>
<td>Rotation angle</td>
<td>Can be modified on the property bar. For more information, see “Rotate and mirror objects” on page 348.</td>
</tr>
<tr>
<td>Transparency</td>
<td>Uniform transparency only. Can be modified in the Symbol section of the Properties docker.</td>
</tr>
<tr>
<td>Mirror</td>
<td>Can be modified on the property bar. For more information, see “Rotate and mirror objects” on page 348.</td>
</tr>
<tr>
<td>Wrap text</td>
<td>Can be modified in the Summary section of the Properties docker. Can also be modified on the property bar. For more information, see “To wrap paragraph text around an object, artistic text, or a text frame” on page 613.</td>
</tr>
<tr>
<td>Order</td>
<td>Can be modified on the property bar. For more information, see “Change the order of objects” on page 345.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of an instance is displayed in the Symbols docker. Click twice to change it.</td>
</tr>
</tbody>
</table>

## Unsupported object types
Most objects in CorelDRAW can be converted to symbols, with the following exceptions.

<table>
<thead>
<tr>
<th>Unsupported object type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linked or embedded objects</td>
<td>Includes bar codes</td>
</tr>
<tr>
<td>Objects with lenses that are not frozen</td>
<td>Lenses must be frozen.</td>
</tr>
<tr>
<td>Control objects in link groups (such as drop shadows, contours, blends, bevels, and extrusions)</td>
<td>All related objects in the link group must be included in the symbol. For example, if an object has a drop shadow, you cannot convert the object without the drop shadow. Alternatively, you can break the group apart.</td>
</tr>
<tr>
<td>Objects with Artistic Media effects applied</td>
<td>Spray effects must be broken apart into curve objects. Other Artistic Media effects must be either broken apart, or converted as a link group. Spray effects that contain transparencies cannot be converted to symbols.</td>
</tr>
<tr>
<td>Unsupported object type</td>
<td>Notes</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------</td>
</tr>
<tr>
<td>Print merge fields</td>
<td></td>
</tr>
<tr>
<td>Linked bitmaps</td>
<td></td>
</tr>
<tr>
<td>Placed PDF or EPS files</td>
<td></td>
</tr>
<tr>
<td>Locked object</td>
<td>Object must be unlocked.</td>
</tr>
<tr>
<td>Paragraph text</td>
<td></td>
</tr>
<tr>
<td>Connector and dimension lines</td>
<td>Must be broken apart or included with the linked object or objects</td>
</tr>
<tr>
<td>Guidelines</td>
<td></td>
</tr>
<tr>
<td>Rollovers</td>
<td>You cannot convert a rollover to a symbol; however, you can include a symbol instance in a rollover state.</td>
</tr>
<tr>
<td>Objects with transparency or transparency effects applied</td>
<td>Transparency effects must be converted to a bitmap.</td>
</tr>
</tbody>
</table>
Manage and track projects

The **Object Data** docker is an advanced feature that is particularly useful as a project management tool when you create or supervise a large project. You can enter many types of project data about individual objects or groups of objects such as costs, project notes, object details and more.

**Project Timer** offers a quick, automated, and non-intrusive way to track the time spent on a project.

This section contains the following topics:

- “Set up the project database” (page 393)
- ”Assign and copy object data” (page 394)
- “View and print object data” (page 395)
- ”Track project time” (page 396)

**Set up the project database**

Before you assign project data to objects in a drawing, you need to know what information you want to display. By default, CorelDRAW creates four data fields: **Name**, **Cost**, **Comments**, and **CDRStaticID**. The first three fields can be edited or deleted as required. The **CDRStaticID** field is hidden; it is used by CorelDRAW to identify objects, and it can’t be edited or deleted.

You can create and assign as many data fields as you want, as long as they use permitted format variables. For more information about assigning data fields, see ”Assign and copy object data” on page 394.

At any time, you can change the setting, such as the name or format, of a data field. If you require custom fields, you can define their formats using four basic field formats: **General**, **Date/time**, **Linear/angular**, and **Numeric**. Each of these formats provides a series of common settings. If the preset formats in CorelDRAW don’t provide the information you want in your data summary, you can create your own custom formats using the variables available for the format type you’re using. The field format you select is used for all objects in the active drawing.

You can also delete any data field except **Name** and **CDRStaticID**. When you delete a field, you also delete all data entered for that field in the active document.

**To add a data field**

1. Click **Window  Dockers  Object Data**.
2. In the **Object Data** docker, click the **Open field editor** button 📊.
3. In the **Object data field editor** dialog box, click **New field**.
4 To change the name of the field you created, double-click the field, type a new name, and press Enter.

5 In the Add field to area, enable one or both of the following check boxes:
   - Document defaults — stores the new field in the current document
   - Application defaults — stores the new field in the application

You can also use this procedure to change the settings of an existing data field.

You can also

Change the format of a data field

Select the data field, and click Change in the Format area. In the Format definition dialog box, enable the option beside the format type that you want to use, and choose a format from the list.

Create a custom format for a data field

Select the data field, and click Change in the Format area. In the Format definition dialog box, enable the option beside the format type that you want to create. Type the format in the Create box, and press Enter.

Delete a data field

Choose the name of the data field from the list, and click Delete Field(s). To choose multiple fields, hold down Ctrl, and click the names in the list.

Assign and copy object data

After creating all the data fields you want for a drawing, you can create a database. The Object Data docker and the Object Data Manager (a spreadsheet launched from the Object Data docker) provide all the commands and features that you need to add and edit object information.

The Object Data docker is best for entering data for single objects. It lets you add, edit, and delete object data. The Object Data Manager, in contrast, is best for entering and editing data for multiple objects. It provides many of the editing features available in popular spreadsheet applications.

You can use one object’s data entries to update another object’s data entries. This function does not replace an object’s data entries; rather, it appends fields and data where appropriate.

To add or edit data for an object

1 Select the object using the Pick tool.

2 Click Window ➤ Dockers ➤ Object Data.

3 Select a data field. Type text in the Value column for the field, and press Enter.

4 Repeat step 3 to add data to other fields.

You can also

Clear all fields

Click the Clear all fields button.
To add or edit data for multiple objects
1 Select the objects using the Pick tool.
2 Click Window  Dockers  Object Data.
3 In the Object data docker, click the Open spreadsheet button.
4 In the Object Data Manager window, click a cell, and type the appropriate data. Press Enter to assign the entry to the cell, the fields, and the objects.

To copy data from one object to another
1 Using the Pick tool, select the object to which you want to copy data.
2 Click Window  Dockers  Object Data.
3 In the Object data docker, click the Copy data from button.
4 Click the object from which you want to copy data.

View and print object data
The Object Data Manager, which is accessible from the Object Data docker, provides the commands and functions you need to view the data you’ve assigned to one or multiple objects in a drawing. While the Object Data Manager can be used to view and edit data associated with a single object, its main purpose is to help you view and manage large amounts of data associated with multiple objects contained in various groups.

You can change how object data is displayed:
- You can set the number of nested group levels to show.
- You can display individual group subtotals for fields shared by multiple groups. Use this command when more than one group of objects is displayed in a data sheet. This command applies only to fields with numeric formats.
- To create a visible distinction between groups in a column, you can place a two-space indent before data relating to objects in groups.
- You can have the Object Data Manager automatically total the values in the selected column. The total is displayed at the bottom of the column.

The Object Data Manager gives you access to all of the application’s printing capabilities, so you can print quickly or print using specific settings.

To view and print an object data summary
1 Select the object or objects using the Pick tool.
   If you want to view the object data summary for the entire document, click Edit  Select all  Objects.
2 In the Object Data docker (Window  Dockers  Object Data), click the Open spreadsheet button.
   The object data summary is displayed in the Object Data Manager window.
3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the number of nested group levels to display</td>
<td>Type a value in the Show levels box.</td>
</tr>
<tr>
<td>Display or hide group subtotals</td>
<td>Right-click the column title, and click Summarize Groups.</td>
</tr>
</tbody>
</table>
To Do the following

A check mark beside the **Summarize Groups** command indicates that the group subtotals are displayed.

To Indent or align groups in a column

Right-click the column title, and click **Show Hierarchy**.

A check mark beside the **Show Hierarchy** command indicates that the nested groups in a column are indented.

To Display or hide the sum of values in a column

Right-click the column title, and click **Show Totals**.

A check mark beside the **Show Totals** command indicates that the sum of the values in a column are displayed.

To Print the object data summary

Click the **Print** button  
Choose a printer from the **Printer** list box. Type a number in the **Number of copies** box. For more information about the printing capabilities of CorelDRAW, see “Print basics” on page 825.

**Tip:** To set page margins and exclude gridlines, column headers, or row headers, click the **Page Setup** button, and choose the settings you want in the **Page Setup** dialog box.

### Track project time

The **Project Timer feature** (Windows ➤ **Toolbars ➤ Project Timer**) lets you track the time spent on a project with ease. To fine-tune the tracking records, you can add tasks and track the time spent on each task. You can give a task a meaningful name, and you can edit a task log by resetting the counter or specifying the task duration and start and finish date.

Tracking information is saved with the document and is easily accessible. In addition, you can save the tracking records as Comma-Separated Values (CSV) or text (TXT) files that can be opened and formatted in a spreadsheet application to create time sheet reports.

Additional settings are available to help you customize Project Timer to match your workflow. You can set automation preferences, specify whether and how to track inactivity, and simplify the Project Timer toolbar even more by hiding UI elements.

---

*The Project Timer toolbar appears below the standard toolbar.*
To track time spent on a project

1. Open or start the project that you want to track.
2. Click the **Track/Pause/Off** button on the **Project Timer** toolbar.
   - If the **Project Timer** toolbar is not displayed, click **Windows ▶ Toolbars ▶ Project Timer**.
3. Start working on the project.
   - The **Track/Pause/Off** button on the toolbar shows you if a task is being tracked. This button has the following states:
     - ![Off](image)
       - shows that tracking is off
     - ![On](image)
       - shows that the active task is being tracked
     - ![Suspended](image)
       - shows that tracking for the active task has been suspended temporarily, and Project Timer is not recording the time at present.
   - Depending on Project Timer settings, this may happen when the Project Timer panel is open, or another document is in focus. For more information about settings, see “To adjust Project Timer settings” on page 399.

To add, activate, delete, modify, or move a task

- Click the drop-down arrow on the **Project Timer** toolbar, and in the **Project Timer** panel, perform any of the tasks from the following table. When you are finished, click outside the **Project Timer** panel to hide it.
To                     Do the following

Add a task

Click New.

Change the task that is being tracked

Choose the task that you want to track from the task list, and click Activate.

The task list shows the task as Active to indicate that this is now the task that you are tracking.

You can also double-click a task to activate it.

Delete a task

Select the task, and click Delete.

You can also delete the selected task by pressing the Delete key.

Rename a task

Click the task name twice in the task list, and type a new name.

Change the task duration

Click the Recorded time field twice, and specify the amount of time you want.

Notes: From the task list, you can modify only the duration of a task that is not active (not being tracked). To modify the active task, you must use the Edit Active Task dialog box. For more information, see “To edit the active task” on page 398.

Changing the task duration does not update the start and finish time and dates.

Change the start and finish time and dates

Click twice the Dates field of the task, and specify the start and finish time and dates you want.

Notes: From the task list, you can modify only the start and finish time and date of a task that is not active. To modify the active task, you must use the Edit Active Task dialog box.

Changing the task start and finish time and dates does not update the task duration.

Move the selected task up or down the list

Select a task, and click the Up ▲ or Down ▼ button.

To edit the active task

You can reset the timer for the active task. You can also change the task start or finish time and date, or you can change the task duration.

1 Click the drop-down arrow on the Project Timer toolbar.
2 Click Edit, and perform a task from the following table.
To

Reset the timer for the active task to 0

Modify task information

Do the following

Click Reset counter.

Click Edit task, and do any of the following:

• Type a new task name in the Name box.
• Type values in the Recorded time boxes to specify the total time spent on the task. The first box shows hours, the second one — minutes, and the third one — seconds.
• Specify the task start and finish time and date in the Start and Finish boxes.

The recorded time for task duration is not linked to the start and finish time and dates. Changing the value in the Recorded time box does not update the Start and Finish boxes, and vice versa.

To create a time sheet report

You can save the tracking information as a CSV or TXT file, and you can then open and format the file in Microsoft Excel or other spreadsheet applications.

1. Click the drop-down arrow on the Project Timer toolbar.
2. Click the Export options button, and click one of the following commands:
   • Export to CSV — to save the time sheet as a CSV file. CSV files preserve the information in a table-structured format similar to spreadsheets. Unlike spreadsheets, they can contain only one sheet and do not support formatting options and formulas. The CSV files exported from Project Timer use commas as field separators.
   • Export to TXT (Comma separated) — to save the time sheet as a TXT file that uses commas as field separators
3. In the Save As dialog box, locate the folder where you want to save the file, and type a filename.
4. Open and format the file in a spreadsheet application.

To adjust Project Timer settings

With the help of the Project Timer Settings dialog box, you can set Project Timer to start or pause tracking automatically in response to specific actions or changes. In addition, inactivity settings help you decide how to treat periods of time when the project is open but there are no recorded document changes. For example, you can set Project Timer to display a prompt or pause tracking after a specified time of inactivity. You can also customize the Project Timer toolbar by displaying and hiding controls.

1. Click the drop-down arrow on the Project Timer toolbar to show the Project Timer panel.
2. Click the Project Timer options button, and click Settings. The Project Timer Settings dialog box appears.
3. In the Project Timer Settings dialog box, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Project Timer to start tracking automatically upon performing a specific action</td>
<td>In the Automation area, enable any of the following check boxes below Start recording when:  &lt;br&gt;  • Document is opened  &lt;br&gt;  • New document is created  &lt;br&gt;  • Task is activated</td>
</tr>
<tr>
<td>Set inactivity preferences</td>
<td>In the Inactivity detection area, choose one of the following options from the On inactivity list box:  &lt;br&gt;  • Prompt — to display a prompt after a specified time of inactivity</td>
</tr>
</tbody>
</table>
To

Do the following

• Pause timer — to pause recording after the specified time of inactivity and resume tracking when you continue working on the document
• Always track — to ignore inactivity and record all time as work

Specify how long after inactivity to pause the timer or display a prompt

In the Inactivity tolerance box, type a value.

Pause tracking automatically in certain circumstances

Enable any of the following check boxes below Pause recording when:

• CorelDRAW is minimized and out of focus
• Another document is in focus
• Project Timer panel is open

Recording resumes when you continue working on the document.

Customize the Project Timer toolbar

Enable or disable any of the following check boxes in the Toolbar appearance area:

• Track/Pause/Off button — to show or hide the Track/Pause/Off button
• Task name — to show or hide the name of the task that is being tracked
• Timer — to show or hide the timer displaying the current task duration

To respond to the Inactivity prompt

If no changes are made to the document for some time, by default Project Timer prompts you to decide how to track this time of inactivity. The prompt is displayed as soon as the inactivity tolerance time elapses.

• In the Inactivity Detected dialog box, click one of the following buttons:
  • Discard — to delete the entire period of inactivity from the tracking record
  • Track as work — to record the period of inactivity as work time. This option is useful to track time spent on tasks related to the project but not performed in CorelDRAW. For example, you may have done research on the project or discussed it at length with a client over the phone. Hence, you want to track this time even though you did not make any changes to the project itself.
  • Custom — to log a custom amount of time. In the Custom Activity Log dialog box, specify the amount of time (in minutes) that you want to be tracked as work. For example, you may have been away from your desk for an hour. If you worked for 20 minutes during that hour on project-related tasks, you can choose to log only 20 minutes. The remaining 40 minutes will be discarded.

If you want Project Timer to remember your choice and apply it all future inactivity, enable the Remember and don’t ask again check box before clicking a button in the dialog box. This action suppresses all inactivity prompts. To start displaying prompts again, you must change the inactivity preferences in the Project Timer Settings dialog box. In the Inactivity detection area, choose Prompt from the On inactivity list box.
The Custom Activity Log dialog box
Color, fills, and transparencies

Color..............................................................................................................................................................................405
Fills..................................................................................................................................................................................425
Object transparency..........................................................................................................................................................447
Find, manage, and save fills and transparencies........................................................................................................459
Color management..........................................................................................................................................................465
CorelDRAW lets you choose and create colors by using a wide variety of industry-standard color palettes, color mixers, and color models. You can store frequently used colors for future use by using the Document palette, or creating and editing custom color palettes.

You can customize how a color palette appears on your screen by changing the size of swatches, the number of rows, and other properties.

You can also create color styles. For more information, see “Color styles” on page 707.

This section contains the following topics:

- “Color models” (page 405)
- “Color depth” (page 407)
- “Choose colors” (page 408)
- “Find and replace colors” (page 413)
- “Document palette” (page 415)
- “Create and edit color palettes” (page 417)
- “Organize and show color palettes” (page 420)
- “Show or hide color palettes” (page 421)
- “Set color palette properties” (page 423)

Color models

Color models provide a precise method for defining colors, each model defining colors through the use of specific color components. There is a range of color models to choose from when creating graphics.

CMYK color model

The CMYK color model, which is used in printing, uses the components cyan (C), magenta (M), yellow (Y), and black (K) to define color. Values for these components range from 0 to 100 and represent percentages.

In subtractive color models, such as CMYK, color (that is, ink) is added to a surface, such as white paper. The color then “subtracts” brightness from the surface. When the value of each color component (C,M,Y) is 100, the resulting color is black. When the value of each component is 0, no color is added to the surface, so the surface itself is revealed — in this case, the white paper. Black (K) is included in the color model for printing purposes because black ink is more neutral and darker than blending equal amounts of cyan, magenta, and yellow. Black ink produces sharper results, especially for printed text. In addition, black ink is usually less expensive than using colored ink.
Black is the result of combining the three CMY colors at their highest intensities.

RGB color model

The RGB color model uses the components red (R), green (G), and blue (B) to define the amounts of red, green, and blue light in a given color. In a 24-bit image, each component is expressed as a number from 0 to 255. In an image with a higher bit rate, such as a 48-bit image, the value range is greater. The combination of these components defines a single color.

In additive color models, such as RGB, color is produced from transmitted light. RGB is therefore used on monitors, where red, blue, and green lights are blended in various ways to reproduce a wide range of colors. When red, blue, and green lights are combined at their maximum intensities, the eye perceives the resulting color as white. In theory, the colors are still red, green, and blue, but the pixels on a monitor are too close together for the eye to differentiate the three colors. When the value of each component is 0, which signifies an absence of light, the eye perceives the color as black.

White is the result of combining the three RGB colors at their maximum intensities.

RGB is the most commonly used color model, because it allows a broad range of colors to be stored and displayed.

HSB color model

The HSB color model uses hue (H), saturation (S), and brightness (B) as components for defining color. HSB is also known as HSV (with the components hue, saturation, and value). Hue describes the pigment of a color and is expressed in degrees to represent the location on the standard color wheel. For example, red is 0 degrees, yellow is 60 degrees, green is 120 degrees, cyan is 180 degrees, blue is 240 degrees, and magenta is 300 degrees.

Saturation describes the vividness or dullness of a color. Values of saturation range from 0 to 100 and represent percentages (the higher the value, the more vivid the color). Brightness describes the amount of white in the color. Like saturation values, brightness values range from 0 to 100 and represent percentages (the higher the value, the brighter the color).
Grayscale color model

The grayscale color model defines color by using only one component, lightness, which is measured in values ranging from 0 to 255. Each grayscale color has equal values of the red, green, and blue components of the RGB color model. Changing a color photo to grayscale creates a black-and-white photo.

Color depth

Color depth refers to the maximum number of colors an image can contain. Color depth is determined by the bit depth of an image (the number of binary bits that define the shade or color of each pixel in a bitmap). For example, a pixel with a bit depth of 1 can have two values: black and white. The greater the bit depth, the more colors an image can contain, and the more accurate the color representation is. For example, an 8-bit GIF image can contain up to 256 colors, but a 24-bit JPEG image can contain approximately 16 million colors.

Usually, RGB, grayscale, and CMYK images contain 8 bits of data per color channel. That is why an RGB image is often referred to as 24-bit RGB (8 bits x 3 channels), a grayscale image is referred to as 8-bit grayscale (8 bits x channel), and a CMYK image is referred to as 32-bit CMYK (8 bits x 4 channels).

Regardless of how many colors an image contains, the image displayed onscreen is limited to the highest number of colors supported by the monitor on which it is viewed. For example, an 8-bit monitor can display only up to 256 colors in a 24-bit image.
Choose colors

You can choose fill and outline colors by selecting a color from the Document palette, custom color palettes, palettes from the Palette libraries, or color viewers. When you want to use a color that already exists in an object or document, you can sample the color by using the Color eyedropper tool to achieve an exact match.

For information about applying the colors you choose, see “Uniform fills” on page 425 and “Format lines and outlines” on page 174. For information about saving colors for future use, see “Color styles” on page 707.

Default color palette

A color palette is a collection of color swatches. In some programs, color palettes are known as "swatch palettes."

In CorelDRAW, the default color palette is based on the primary color mode of the document. For example, if the document’s primary color model is RGB, the default color palette is also RGB. For more information, see “Color models” on page 405. You choose the default color model when you create a new drawing. You can open and use additional color palettes at any time.

You can choose both fill and outline colors by using the default color palette. The selected fill and outline colors appear in the color swatches on the status bar.

Document palette

When you create a new drawing, the application automatically generates an empty palette, called the Document palette. It helps you keep track of the colors that you use by storing them with your document for future use. For more information, see “Document palette” on page 415.

Palette libraries and custom color palettes

The color palettes that are found in the Palette libraries cannot be edited directly. Some of them are provided by third-party manufacturers, for example PANTONE, HKS Colors, and TRUMATCH. It may be useful to have on hand a manufacturer’s swatch book, which is a collection of color samples that shows exactly what each color looks like when printed.

The PANTONE solid coated palette is an example of a color palette from the Palette libraries.

Some palettes found in the Palette libraries — PANTONE, HKS Colors, TOYO, DIC, Focoltone, and SpectraMaster — are collections of spot colors. If you create color separations when you print, each spot color requires a separate printing plate, which can significantly affect the cost of the printing job. If you want to use color separations but would like to avoid using spot colors, you can convert the spot colors to process colors when printing. For more information, see “Color separations” on page 857.

Custom color palettes can include colors from any color model, including palettes from the Palette libraries, such as a spot color palette. You can save a custom color palette for future use. For more information about working with custom color palettes, see “Create and edit color palettes” on page 417 and “Organize and show color palettes” on page 420.

Sampling colors

When you want to use a color that already exists in a drawing, palette, or on your desktop, you can sample the color to achieve an exact match. By default, you sample a single pixel from the drawing window.
Color viewers

Color viewers provide a representation of a range of colors by using either one-dimensional or three-dimensional shapes. The default color viewer is based on the HSB color model, but you can use this viewer to choose CMYK, CMY, or RGB colors. For information about color models, see “Color models” on page 405.

An example of a color viewer

Choosing web colors

You can use web colors when you design documents that will be published to the web. With CorelDRAW, you can define web colors by using RGB hexadecimal values (for example, #aa003f).

Out-of-gamut colors

If you choose a color that is out of the printer’s gamut, CorelDRAW allows you to replace it with a similar color that is in the printer’s gamut.

To choose a color by using the default color palette

To | Do the following
---|---
Choose a fill color for a selected object | Click a color swatch.
Choose an outline color for a selected object | Right-click a color swatch.
Choose from different shades of a color | Click and hold a color swatch to display a pop-up color picker, and then click a color.
View more colors on the default color palette | Click the scroll arrows at the top and bottom of the color palette.

You can display color values by pointing to a swatch.

To display color names instead of color values, click the Options flyout button at the top of the default palette, and click Show color names. This action undocks the default color palette and displays the color names.
To choose a color by using a color palette

1. Select an object.
2. Double-click the Fill button on the status bar. In the Edit fill dialog box, click the Uniform fill button.
3. Enable the Color palettes option.
4. Choose a color palette from the Palette list box.
5. Move the color slider to set the range of colors displayed in the color selection area.
6. Click a color in the color selection area.

You can also

Display or hide the names of colors Enable or disable the Show color names check box.

Swap the reference color (original color of the selected object) with the new color Click the Swap colors button.

Choose an outline color Double-click the Outline button on the status bar. In the Outline pen dialog box, open the Color picker, and choose a color.

Each spot color swatch on a color palette is marked with a small white square.

If you choose a color that is out of the printer’s gamut, CorelDRAW allows you to replace it with a similar color that is in the printer’s gamut. For more information, see “To replace an out-of-gamut color with a reproducible color” on page 413. For information about color correction, see “Color management” on page 465.

You should use the same color model for all colors in a drawing; the colors will be consistent and you will be able to predict the colors of the final output more accurately. For more information about reproducing colors accurately, see “Color management” on page 465.

You can also access color palettes in the Color docker by clicking the Show color palettes button, and choosing a palette from the list box. If the Color docker is not open, click Window > Dockers > Color.

To choose a fill color by using a color viewer

1. Select an object.
2 Double-click the Fill button on the status bar.

3 In the Edit fill dialog box, click the Uniform fill button.

4 Enable the Color viewers option.

5 Choose a color model from the Color model list box.

6 Choose a color viewer from the Color viewers list box.

7 Move the color slider.

8 Click a color in the color selection area.

You can also

Sample a color from the drawing or desktop

Click the Eyedropper button, and click the drawing or desktop.

Swap the reference color (original color of the selected object) with the new color

Click the Swap colors button.

If you choose a color that is out of the printer’s gamut, CorelDRAW allows you to replace it with a similar color that is in the printer’s gamut. For more information, see “To replace an out-of-gamut color with a reproducible color” on page 413. For information about color correction, see “Color management” on page 465.

You should use the same color model for all colors in a drawing; the colors will be consistent and you will be able to predict the colors of the final output more accurately. It is preferable to use the same color model in your drawing that you will be using for the final output.

You can swap the Old color (the current main or secondary color) and the New color (which has been chosen in the color selection area) by clicking the More color options button and choosing Swap colors.

You can also access color models in the Color docker by clicking the Show color viewers button and choosing a color model from the list box. If the Color docker is not open, click Window ➤ Dockers ➤ Color.

To sample a color

1 In the toolbox, click the Color eyedropper tool.

2 On the property bar, click one of the following buttons:
   • 1×1 — lets you choose the color of the pixel you click
   • 2×2 — lets you choose the average color in a sample area of 2 × 2 pixels. The pixel you click is in the middle of the sample area.
   • 5×5 — lets you choose the average color in a sample area of 5 × 5 pixels

   If you want to sample a color outside the drawing window, click Select from desktop on the property bar, and click a color on the desktop.

3 Click the color that you want to sample.

   The Color eyedropper tool automatically switches to the Apply color mode.

4 Perform a task from the following table.
To Do the following

Fill an object with a sampled color
Hover over an object. When the Apply color pointer changes to a solid color swatch, click to apply the sampled color.

Fill an object’s outline color with the sampled color
Hover over an object’s outline. When the Apply color pointer changes to an outline shape, click to apply the sampled color.

Add the sampled color to the Document palette
On the property bar, click the arrow next to Add to palette, and choose Document palette.

Sample an additional color
On the property bar, click the Select color button, and then click the color that you want to sample.

You can also

Drag a sampled color from one object to another
Drag the color to another object.

Apply a sampled color from the Selected color swatch on the property bar
Drag the sampled color from the Selected color swatch to the object.

Apply a sampled color from the Uniform fill swatch in the lower-right corner of the drawing window
Drag a color from the Uniform fill swatch to the object.

Add the sampled color to the Document palette
Drag the sampled color from the Selected color swatch or the Uniform fill swatch to the Document palette.

In some cases, the sampled color may be an RGB or CMYK color that is the closest equivalent to the original color, rather than being a complete match.

To choose a web color

1. Select an object.
2. Click Window ➤ Dockers ➤ Color.
3. In the Color docker, click the Show color viewers button, and choose RGB from the list box.
4. Type or paste a value in the Hex value box.
   Whether you use a three-digit (fff) or six-digit format (ffffff), the final value is presented in the six-digit format.
5. Click one of the following buttons:
   • Fill — fills the selected object with the new color
   • Outline — applies the color to the outline of the object
You can specify hexadecimal color values only when working with RGB colors. If you type an invalid hexadecimal value, the color does not change.

You can view hexadecimal color values on the status bar.

You can also choose web colors from the Outline Pen dialog box (on the status bar, double-click the Outline pen button) and the Edit Fill dialog box (on the status bar, double-click the Fill button, and click the Uniform fill button), which let you view and copy the hexadecimal equivalents of non-hexadecimal color values.

To replace an out-of-gamut color with a reproducible color
1. Select an object.
2. Double-click the Fill button on the status bar.
3. In the Edit fill dialog box, click the Uniform fill button.
4. Choose a color.
5. If the color is out of gamut, the Bring color in gamut button appears, showing a color similar to the newly selected color but in the printer's gamut. Click the button.
   The new color is replaced, and the Bring color in gamut button disappears.

Find and replace colors
You can find a color in a drawing and replace it with another color. The color replacement can be applied to all outlines, uniform fills, fountain fills, 2-color fills, mesh fills, and monochrome bitmaps in the active document. Conversely, you can replace the color only in outlines or a specific type of fill. For example, you can replace the color only in uniform fills, and leave the color untouched in other fills and object outlines.
You can also find and replace the color model or color palette of fills and outlines.

In addition, you can expand the search range to find and replace colors on multiple pages, or you can limit the search to only currently selected objects. For more information, see “To set the search range” on page 361.

To find and replace colors

1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3. Enable the Color option.
4. In the Find area, click the Color picker, and choose a color. You can use the Color eyedropper tool to sample a color from the drawing or from an element that is outside the application window.
5. In the Replace area, click the Color picker, and choose a replacement color.
6. In the Apply to area, enable any of the following check boxes to specify where to apply the color replacement:
   - Outlines
   - Uniform fills
   - Fountain fills
   - 2-color fills
   - Mesh fills
   - Monochrome bitmaps
7. Click any of the following buttons:
   - Find Next ➤ or Find Previous ➤ to scroll through objects that meet the search criteria.
   - Find All or Find All on Page to select all objects on the active page that meet the search criteria.
   - Replace to replace the color in the selected object.
   - Replace All to replace the color of all fills or outlines that meet the search criteria.
To find and replace the color model or color palette of fills and outlines

1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3. Enable the Color model or palette option.
4. Do one of the following:
   - Enable the Specific color model option in the Find area, and choose a color model from the list box. Choose a replacement color model from the Replace with list box.
   - Enable the Specific color palette option in the Find area, and choose a color palette from the list box. Choose a replacement color palette from the Replace with list box.
5. In the Apply to area, enable any of the check boxes to specify where to apply the color replacement.
6. Click the find or replace button you want.

Document palette

When you start a new drawing, an empty color palette, called the Document palette, appears docked in the lower-left corner of the drawing window. Every time you use a color in your drawing, it’s automatically added to the Document palette. However, if you prefer to control which colors are added to the Document palette, you can disable the automatic updates and add colors manually.

When adding colors manually, you can choose colors from a color palette, an external image, or a color picker. In addition, you can add colors from an imported image or object. You can also add all colors from an existing drawing to the Document palette.

Drag a bitmap to the Document palette to add colors.

When you open documents that were created in CorelDRAW X4 or an earlier version of the program, only custom spot colors and a maximum of 100 legacy color styles are added to the Document palette. The legacy styles are added to the palette as regular colors.

You can clear the Document palette of any unwanted or unused colors by removing colors individually or refreshing the palette to remove all unused colors at once.
The Document palette is automatically saved with the document. If you rename the .cdr file to .zip, the Document color palette (DocumentPalette.xml) is included in the .zip package.

To show or hide the Document palette

- Click Window ➤ Color Palettes ➤ Document palette.

Hiding the Document palette does not disable the automatic adding of colors.

To disable the automatic adding of colors to the Document palette

- On the Document palette, click the flyout button ➤, and then click Palette ➤ Auto-Add Colors.

By default, the Document palette is docked above the status bar at the bottom of the application window.

You can also disable the automatic adding of color by clicking Tools ➤ Options ➤ Customization, clicking Color Palette in the left pane of the dialog box that appears, and disabling the Automatically update the document palette check box.

To manually add colors to the Document palette

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a color from another color palette</td>
<td>Drag a color from an open color palette to the Document palette.</td>
</tr>
<tr>
<td>Add a color from a bitmap image</td>
<td>On the Document palette, click the Eyedropper button ➤, and click a color in the image.</td>
</tr>
<tr>
<td>Add multiple colors from an image</td>
<td>On the Document palette, click the Eyedropper button ➤, hold down Ctrl, and then click the image until you add the colors that you want.</td>
</tr>
<tr>
<td>Add multiple colors from an image or object by dragging</td>
<td>Drag an image or object from the drawing window to the Document palette.</td>
</tr>
<tr>
<td>Add colors from a selection</td>
<td>Select an object or multiple objects. On the Document palette, click the flyout button ➤, and then click Palette ➤ Add from Selection.</td>
</tr>
<tr>
<td>Move a color swatch</td>
<td>Drag a color swatch to a new position on the Document palette.</td>
</tr>
</tbody>
</table>

When dragging most vector objects to the palette, you add all object colors to the palette. When dragging a bitmap, you can specify the number of colors that you want to be added to the palette. If an object includes a fountain fill, texture fill, or pattern fill, only colors that are defined during the fill creation are supported. Colors from PostScript fills are not supported.

By default, the Document palette is docked above the status bar at the bottom of the application window.
To add colors from an existing drawing to the Document palette
1. Open a drawing.
2. On the Document palette, click the flyout button ➤, and then click Palette ➤ Add from Document.

By default, the Document palette is docked above the status bar at the bottom of the application window.

If the drawing was created in a previous version of CorelDRAW and it includes custom spot colors, they appear in the Document palette.

If you have a document with both vector and bitmap images, and you want to add only the colors from the vector images to the Document palette, specify 0 in the Add colors from bitmap dialog box.

To remove colors from the Document palette
1. Click a color swatch on the Document palette.
2. On the Document palette, click the flyout button ➤, and click Delete Color.

By default, the Document palette is docked above the status bar at the bottom of the application window.

You can also remove all colors that are no longer used from the Document palette by clicking the flyout button ➤, and clicking Palette ➤ Refresh.

Create and edit color palettes
Custom color palettes are collections of colors or color styles that you save. They can include colors or color styles from any color model, including spot colors, or any color palette found in the Palette libraries. You can create a custom palette to store all colors or color styles that you need in a current, or future, project.

It's easy to share color palettes with others. The custom palettes are accessible from the My palettes folder in the Palettes docker.

You can create a custom color palette by choosing individual colors or color styles, or by using the colors in a selected object or an entire document. You can also edit, rename, and delete custom color palettes.

Custom color palettes are saved as XML files and are stored in your Documents\Corel\Corel Content\Palettes folder.

To create a custom color palette from scratch
1. Click Window ➤ Dockers ➤ Palettes.
2. Click the + at the bottom of the docker, and choose New empty color palette ➤.
3. Type a filename in the File name box.
4. Click Save.
5. In the Palettes docker, choose the custom palette that you created under My palettes.
6. Click the Options button, and choose Edit palette.
7. In the Palette editor dialog box, click Add color.
8. In the Select color dialog box, choose a color, and click OK.

You can also

Treat the color as a spot color
In the Selected color area of the Palette editor dialog box, choose Spot from the Treat as list.

Treat the color as a process color
In the Selected color area of the Palette editor dialog box, choose Process from the Treat as list.

Rename a color
In the Palette editor dialog box, click a color in the color selection area, and type a name in the Name box.

To add a color to a custom color palette
1. Open a custom color palette.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a color from another color palette</td>
<td>Drag a color from an open color palette to the custom palette.</td>
</tr>
<tr>
<td>Add a color from an image</td>
<td>On the custom palette, click the Eyedropper button, and click the color that you want to add.</td>
</tr>
<tr>
<td>Add multiple colors from an image</td>
<td>On the custom palette, click the Eyedropper button, hold down Ctrl, and click the image until you add the colors that you want.</td>
</tr>
<tr>
<td>Add multiple colors from an image or object</td>
<td>Drag an image or object from the drawing window to the custom palette.</td>
</tr>
<tr>
<td>Add a color from a color-related dialog box</td>
<td>In the dialog box, click a color swatch, click the arrow next to Add to palette, choose the name of your custom palette from the list, and then click Add to palette.</td>
</tr>
<tr>
<td>Add colors from a selection</td>
<td>Select an object or multiple objects. On the custom palette, click the flyout button, and click Add from selection.</td>
</tr>
<tr>
<td>Move a color swatch</td>
<td>Drag a color swatch to a new position on the palette.</td>
</tr>
</tbody>
</table>
When dragging most vector objects to the palette, you add all object colors to the palette. When dragging a bitmap, you can specify the number of colors that you want to be added to the palette. If an object includes a fountain fill, texture fill, or pattern fill, only colors that are defined during the fill creation are supported. Colors from PostScript fills are not supported.

To create a color palette from an object
1 Select an object.
2 Click Window → Color Palettes → Create Palette from Selection.
3 Type a filename in the File name box.
4 Click Save.

To create a color palette from a document
1 Click Window → Color Palettes → Create Palette from Document.
2 Type a filename in the File name box.
3 Click Save.

To edit a custom color palette
1 Click Window → Color palettes → Palette Editor.
2 Choose a palette from the list box.
3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a color</td>
<td>Click Add color. In the Select color dialog box, click the Models tab, click a color in the color selection area, and click Add to palette.</td>
</tr>
<tr>
<td>Treat a color as a spot color</td>
<td>In the Selected color area of the Palette editor dialog box, choose Spot from the Treat as list.</td>
</tr>
<tr>
<td>Treat a color as a process color</td>
<td>In the Selected color area of the Palette editor dialog box, choose Process from the Treat as list.</td>
</tr>
<tr>
<td>Change a color</td>
<td>In the color selection area, click a color, and click Edit color. In the Select color dialog box, click a new color in the color selection area.</td>
</tr>
<tr>
<td>Delete a color</td>
<td>In the color selection area, click a color, and click Delete color.</td>
</tr>
<tr>
<td>Sort colors</td>
<td>Click Sort colors, and choose a color sorting method.</td>
</tr>
<tr>
<td>Move a color</td>
<td>Drag a color swatch to a new position.</td>
</tr>
</tbody>
</table>
**To** | **Do the following**
--- | ---
Rename a color | Click a color in the color selection area, and type a name in the Name box.

You can delete multiple colors by holding down **Shift** or **Ctrl**, clicking the colors that you want to delete, and clicking **Delete color**.

If you add a process color to the palette, but treat it as a spot color, the color is changed to spot and the color name is preserved. However, if you choose a spot color with a trademarked name, for example a PANTONE color, and convert it to a process color, the trademarked name is substituted with the color components for that color.

To rename a custom color palette
1. Click **Window** ➤ **Dockers** ➤ **Palettes**.
2. From the **My Palettes** folder, click a custom palette twice.
3. Type a new name, and press **Enter**.

To delete a custom color palette
1. Click **Window** ➤ **Dockers** ➤ **Palettes**.
2. From the **My Palettes** folder, right-click a custom palette, and click **Delete**.

### Organize and show color palettes

The **Palettes** docker lets you quickly access the available color palettes, including the Document palette and the Color Styles palette, and create custom color palettes. The color palettes in the **Palettes** docker are divided into two main folders: **My palettes** and **Palette libraries**.

You can use the **My palettes** folder to store all the custom color palettes that you create. You can add folders to store and organize your color palettes for different projects. You can also copy a color palette or move it to a different folder. You can open and control the display of all color palettes.

The **Palette libraries** folder of the **Palettes** docker contains collections of preset color palettes from which you can choose colors. You cannot edit any of the color palettes that are found in the Palette libraries. However, you can create a custom color palette by copying a color palette from the **Palette libraries** folder. For more information, see “Show or hide color palettes” on page 421.

To open the **Palettes** docker
- Click **Window** ➤ **Dockers** ➤ **Palettes**.

To display or hide a custom color palette
1. Open the **Palettes** docker.
2. In the **My palettes** folder, enable the check box beside the custom palette name.

   If you want to set a custom color palette as the default palette, click the custom palette flyout button ➤, and click **Set as default**.

To open a custom color palette
1. Open the **Palettes** docker.
2 Click the **Opens a palette** button.

3 Choose the drive and folder where the custom color palette is stored.
   If you want to open a color palette (.cpl file) that was created in a previous version of CorelDRAW, select **Legacy custom palette (*.cpl)** from the **Files of type** list box.

4 Click the custom palette.

5 Click **Open**.

When you open a legacy custom palette (.cpl) file, it is automatically converted to the XML format (.xml). The XML version is stored in your **Documents\Corel\Corel Content\Palettes** folder, and also appears in the **My palettes** folder in the **Palettes** docker.

If the custom color palette (.xml) was saved to the **My palettes** folder, you can open it by clicking **Window** ➤ **Color palettes** and choosing the custom palette from the list.

**To create a folder for storing custom color palettes**

1 Open the **Palettes** docker.

2 Click the **Create a new folder** button. The new folder appears in the **My Palettes** folder.

3 Type a new name, and press **Enter**.
   If you want to move a custom color palette, drag it to the new folder.

**To cut or copy a custom color palette**

1 Open the **Palettes** docker.

2 In the **My palettes** folder, right-click a custom palette, and click one of the following:
   - Cut
   - Copy
   If you want to paste the custom palette to a different folder, right-click the folder, and click **Paste**.

**To copy a palette from the Palette libraries for editing**

- Open the **Palettes** docker, drag a palette from the **Palette libraries** folder to the **My palettes** folder.
  An editable copy of the color palette appears in the **My palettes** folder.

**Show or hide color palettes**

The Palette libraries contain a collection of color palettes. You can control the display of the default color palettes, such as the default RGB and default CMYK color palettes. The main Palette libraries that are included are Process color and Spot color.

The Process color library contains the default RGB, CMYK, and Grayscale color palettes. In addition, you can find preset color palettes that have a specific theme, such as nature. The Spot color library contains color palettes that are provided by third-party manufacturers, such as HKS Colors, PANTONE, Focoltone, and TOYO. These color palettes can be very useful when you need specific company-approved colors for your printed projects. The color palette libraries are locked, which means that you cannot edit them.
To display a color palette in the Palette libraries
1  Open the Palettes docker.
2  In the Palette libraries folder, enable the check box beside the color palette name.

To display spot or process color palettes
1  Open the Palettes docker.
2  In the Palette libraries folder, double-click one of the following folders:
   • Spot
   • Process
3  Enable the check box beside the color palette name.
Set color palette properties

You can customize color palettes.

Color palettes can be either docked or floating. Docking a color palette attaches it to the edge of the application window. Undocking a color palette pulls it away from the edge of the application window, so it floats and can be easily moved around.

With color swatches, you can set the right mouse button either to display a context menu or to set the outline color. You can also adjust the color swatch border and size, and you can hide or display the No color well.

To dock or undock a color palette

- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dock a color palette</td>
<td>Click the top of the color palette border, and drag the color palette to any edge of the application window until a thin black toolbar outline appears.</td>
</tr>
<tr>
<td>Undock a color palette</td>
<td>Click the dotted border of the color palette, and drag the color palette away from the edge of the application window.</td>
</tr>
<tr>
<td>Change the number of rows on a docked color palette</td>
<td>On the palette, click the flyout button ▶, click Rows, and choose an option from the list.</td>
</tr>
</tbody>
</table>

You can also change the number of rows on a docked color palette by clicking Tools ▶ Options ▶ Customization, clicking Color Palette in the left pane of the dialog box that appears, and typing a value in the Maximum palette rows when docked box. You can set a maximum of seven rows on a color palette.

To set the action of the right mouse button for color swatches

1. Click Tools ▶ Options ▶ Customization.
2. In the left pane of the dialog box that appears, click Color Palette.
3. Enable one of the following check boxes:
   - Context menu
   - Set outline color

If you enable the Set outline color option, you can still display the context menu by holding down the right mouse button for at least one second anywhere on the color palette.

To customize color swatches

1. Click Tools ▶ Options ▶ Customization.
2. In the left pane of the dialog box that appears, click Color Palette.
3. Enable any of the following check boxes:
• Wide borders
• Large swatches
• Show “No Color” well

💡 You can also display color names in the color swatches by clicking the flyout button on a color palette and clicking Show color names.
Fills

You can add colored, patterned, textured, and other fills to the inside of objects or other enclosed areas. You can customize a fill and set it as a default, so that each object you draw has the same fill.

Fill samples: Uniform, linear fountain, elliptical fountain, vector pattern, bitmap pattern, two-color, texture, and PostScript

This section contains the following topics:
- “Uniform fills” (page 425)
- “Fountain fills” (page 426)
- “Vector and bitmap pattern fills” (page 431)
- “Two-color pattern fills” (page 436)
- ”Texture fills” (page 437)
- “PostScript fills” (page 439)
- “Mesh fills” (page 439)
- ”Apply fills to areas” (page 443)
- ”Work with fills” (page 444)

Uniform fills

You can apply a uniform fill to objects. Uniform fills are solid colors you can choose or create using color models and color palettes. For information about creating colors, see “Color” on page 405.
**To apply a uniform fill**

1. Select an object.
2. Click a color on the color palette.

   If you want to mix colors in a uniform fill, press **Ctrl**, and click another color on the color palette.

   ![Uniform fill button](image)

   You can also choose a uniform fill by clicking

   - the **Uniform fill** button in the Fill section of the Properties docker
   - the **Interactive fill** tool in the toolbox, and then clicking the **Uniform fill** button on the property bar

**Fountain fills**

A fountain fill is a smooth progression of two or more colors that adds depth to an object. Fountain fills are also known as gradient fills.

There are four types of fountain fills: linear, elliptical, conical, and rectangular. A linear fountain fill flows in a straight line across the object, a conical fountain fill creates the illusion of light hitting a cone, an elliptical fountain fill is dispersed in concentric ellipses from the center of the object, and a rectangular fountain fill is dispersed in concentric rectangles from the center of the object.

![Four types of fountain fills](image)

There are four types of fountain fills (left to right): linear, elliptical, conical, and rectangular.

The application provides a collection of fountain fills that you can access. You can browse the available fountain fills, search by keywords, mark fills as favorites, and sort fills. You can also download additional fill packs. For more information, see “Find and view fills and transparencies” on page 459.

Any fountain fill can be modified to suit your needs, and you can create your own fills from scratch. Fountain fills can contain two or more colors, which you can position anywhere in the fill’s progression. You can specify fill attributes such as the direction of a fill’s color blend, the fill’s angle, center point, and midpoint. You can also set the width and height of the fill as a percentage of the object’s width and height. Plus, you can smooth, skew, rotate, repeat, and mirror a fill.
You can edit fill properties from the Properties docker.

Left to right: An object with a linear fountain fill applied. Another color is added to the fill. The fill is resized to 50% of the object’s width and height, and then repeated and mirrored. Last, the fill is rotated 45 degrees.

After you create a fountain fill, you can save it for future use. For more information, see “Save fills and transparencies” on page 463.
You can adjust the print and display quality of the fountain fill by specifying the number of fountain steps. By default, the fountain steps setting is locked so that the print quality of the fountain fill is determined by the value specified in the print settings and the display quality is determined by the default value you set. However, you can unlock the fountain steps setting and specify a value that applies to both the print and view quality of the fill. For information about setting fountain fill steps for printing, see “Fine-tune print jobs” on page 829.

To apply a fountain fill
1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click the Fountain fill button on the property bar.
3. Open the Fill picker on the property bar, and double-click a fill thumbnail.

For information about how to find fills in the Fill picker, see “To find, filter, and sort fills and transparencies” on page 460.

You can also apply a fill by clicking a fill thumbnail in the Fill picker. This action applies the fill without closing the Fill picker.

You can add a color to a fountain fill by clicking the Interactive fill tool in the toolbox, clicking the Fountain fill button on the property bar, and dragging a color from the color palette to an object’s interactive vector handle.

To create a fountain fill
1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click the Fountain fill button on the property bar.
3. Click one of the following buttons to choose a fountain fill type:
   • Linear fountain fill
   • Elliptical fountain fill
   • Conical fountain fill
   • Rectangular fountain fill
4. Click the start node, open the Node color picker on the property bar, and choose a color.
5. Click the end node, open the Node color picker on the property bar, and choose a color.
6. Move the midpoint slider to set the midpoint between the two colors.
7. In the Properties docker, click the Save as new button to save the fill, or continue editing the fill by performing a task from the following table.
To

Change the transparency of a color

Add an intermediate color

Change the position of an intermediate color

Delete an intermediate color

Revert, mirror, repeat, or reverse the fill

Specify how quickly the fountain fill blends from one color to another

Create smoother color transitions between fountain fill nodes

Specify the way the colors blend between two nodes

Do the following

Select the corresponding node, and type a value in the **Node transparency** box.

Double-click the color band where you want to add a node. With the new node selected, open the **Node color** picker, and choose a color.

Drag the corresponding node to a new location above the color band, or type a value in the **Node position** box in the **Properties** docker.

Double-click the corresponding node.

Click the **Arrangement** button on the property bar, and click one of the following buttons:

- Default fountain fill
- Repeat and mirror
- Repeat

Click the **Reverse fill** button on the property bar.

*The effect of repeating and mirroring can be seen only if the fill is smaller than the object. The following illustration shows a default fill (1), the same fill resized and then repeated and mirrored (2), the fill resized and repeated (3), and the fill reversed (4).*

Type a value in the **Acceleration** box on the property bar.

Select either the two nodes or the midpoint between them, and in the **Fill** area of the **Properties** docker, and choose a blend direction option:

- **Linear color blend** — blends the colors along a straight line, beginning at the start color and continuing across the color wheel to the end color
- **Clockwise color blend** — blends the colors along a clockwise path around the color wheel
- **Counterclockwise color blend** — blends the colors along a counterclockwise path around the color wheel
To

Specify the way the colors blend between two nodes

Do the following

The following color blend options are illustrated below from left to right: Linear color blend, Clockwise color blend, Counterclockwise color blend.

Set the width and height of the fill as a percentage of the object’s width and height

In the Properties docker, click the arrow button at the bottom of the Fill section to display more fill options, and then type values in the W and H boxes.

Move the center of the fill up, down, left, or right

Type values in the X and Y boxes.

Slant the fill at a specified angle

Type a value in the Skew box.

In this example, the fill is skewed at 15 degrees.

Rotate the color progression clockwise or counterclockwise

Type a value in the Rotate box.

Allow the fill to be skewed or stretched disproportionately

Enable the Free scale and skew check box.

Apply the selected fill to the intersecting area of combined objects

Enable the Fill winding check box.

For more information, see “Combine objects” on page 357.

Let the fill print on top of the underlying colors.

Enable the Overprint fill check box.

💡 You can also apply a custom fountain fill by clicking the Interactive fill tool in the toolbox and dragging colors from the color palette in the document window onto the object’s interactive vector handles. You can mix colors by selecting one of the interactive vector handles, pressing Ctrl, and clicking a color on the color palette.
To change the fountain fill print and display quality

1. Select an object that has a fountain fill applied to it.
2. In the Properties docker, click the arrow button at the bottom of the Fill section to display more fill options.
3. Disable the Steps check box to unlock the fountain steps, and type a value in the Steps box.
   Higher numbers create a smoother transition between colors.

When the Fountain steps box is locked, the number of steps in the printed fountain fill is determined by the value specified in the Print dialog box. For information about setting fountain fill steps for printing, see “Fine-tune print jobs” on page 829.

To set the display quality for fountain fills

1. Click Tools ➔ Options ➔ CorelDRAW.
2. In the left pane of the dialog box that appears, click Display.
3. Type a value in the Preview fountain steps box.

Vector and bitmap pattern fills

You can fill objects with vector or bitmap pattern fills, as well as two-color fills. A vector pattern fill is a more complex vector graphic composed of lines and fills. A vector fill can have color or transparent background. A bitmap pattern fill is a bitmap image whose complexity is determined by its size, image resolution, and bit depth. For information about two-color fills, see “Two-color pattern fills” on page 436.

CorelDRAW provides a collection of vector and bitmap patterns that you can access. You can browse the available pattern fills, search by keyword, mark fills as favorites, and sort fills. You can also download additional fill packs. For more information, see “Find and view fills and transparencies” on page 459.
Modifying pattern fills

You can modify pattern fills to suit your needs. For example, you can change the size of the pattern fill, or move the center of the pattern left or right and up or down. CorelDRAW also lets you offset tiles in a fill.

You can mirror the fill so that alternating tiles are reflections of each other. If you want a pattern fill to change according to actions you perform on the filled object, you can set the fill to transform with the object. For example, if you enlarge the object, the pattern becomes larger while the number of tiles remains the same.

The brightness and the contrast of bitmap patterns can be adjusted. You can also create a radial or linear seamless blend between the bitmap pattern tiles, and you can smooth the color transition between tiles by matching their edges. You can also adjust pattern parameters such as the brightness, luminance, and color contrast of the pattern.

Creating pattern fills

You can also create your own patterns. Vector and bitmap patterns are made up of smaller units called tiles. Depending on the size of the object, the pattern fill may consist of one or more tiles. The pattern is created by repeating the tile to fill up the object. You can create a new pattern by selecting an area of the workspace to use as a tile, or by using an imported image as a tile source.

After you create a new pattern, you can save it for future use. For more information, see “Save fills and transparencies” on page 463.

To apply a vector or bitmap pattern fill

1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click one of the following buttons on the property bar:
   - Vector pattern fill

Examples of bitmap pattern fills

From left to right: Original vector pattern fill. The center of the pattern tile is moved to the right (middle). The center of the tile is moved down (right).

After you create a new pattern, you can save it for future use. For more information, see “Save fills and transparencies” on page 463.
• Bitmap pattern fill

3 Open the Fill picker, and double-click a pattern thumbnail.

For information about how to find fills in the Fill picker, see “To find, filter, and sort fills and transparencies” on page 460.

You can also apply a fill by clicking a fill thumbnail in the Fill picker. This action applies the fill without closing the Fill picker.

To create a vector or bitmap pattern from the workspace

1 Select an object.
2 Click the Interactive fill tool in the toolbox, and then click one of the following buttons on the property bar:
   • Vector pattern fill
   • Bitmap pattern fill
3 In the Fill area of the Properties docker, click the New source button below the Fill picker, and choose New source from document.
4 Select an area of the workspace that you want to use as a pattern. The area can include any objects or parts of objects that you have drawn.
5 Click Accept.
   To save the pattern, click the Save as new button.

Vector patterns can have transparent or color background.

You can also click the New source from workspace button and select an area of the document to use as a tile source. In this case, the current settings in the Transformations area of the Properties docker will apply to the new pattern.

To create a vector or bitmap pattern from an imported image

1 Select an object.
2 Click the Interactive fill tool in the toolbox, and then click one of the following buttons on the property bar:
   • Vector pattern fill
   • Bitmap pattern fill
3 In the Fill area of the Properties docker, click the New source button below the Fill picker, and choose New source from file.
4 In the Import dialog box, locate the image that you want to use, and double-click the filename.

To modify a vector or bitmap pattern fill

1 Select an object.
2 Click the Interactive fill tool in the toolbox, and then click one of the following buttons on the property bar:
   • Vector pattern fill
- Bitmap pattern fill

3 In the Fill area of the Properties docker, click the arrow \( \uparrow \) button at the bottom to display more pattern fill options.

4 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrange the tiles so that alternating tiles are reflections of each other</td>
<td>Click the Mirror tiles horizontally ( \overset{\frown}{\frown} ) or the Mirror tiles vertically ( \overset{\frown}{\frown} ) button.</td>
</tr>
<tr>
<td>Set the width and height of the pattern tiles</td>
<td>Type values in the Fill width and Fill height boxes.</td>
</tr>
<tr>
<td>Move the center of the pattern fill up, down, left, or right</td>
<td>Type values in the ( X ) and ( Y ) boxes.</td>
</tr>
<tr>
<td>Slant or rotate the pattern at a specified angle</td>
<td>Type a value in the Skew box or the Rotate box.</td>
</tr>
<tr>
<td>Specify row or column offset as a percentage of the tile’s height or width</td>
<td>Click the Row offset ( \overset{\frown}{\frown} ) or the Column offset button ( \overset{\frown}{\frown} ) and type a value in the % of tile box.</td>
</tr>
</tbody>
</table>
To specify row or column offset as a percentage of the tile’s height or width

Apply object transformations to the pattern fill

Apply the selected fill to the intersecting area of combined objects

Adjust additional properties of a bitmap pattern fill

You can also skew or rotate tiles by clicking the Interactive fill tool in the toolbox, selecting an object, and dragging the skewing or rotation handles to change the appearance of the pattern.

To adjust the color transitions, brightness, and contrast of a bitmap pattern fill

1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click one of the following buttons on the property bar:
   - Vector pattern fill
   - Bitmap pattern fill
3. In the Fill area of the Properties docker, click the arrow button at the bottom to display more pattern fill options.
4. Perform a task from the following table.

### To adjust the color transitions, brightness, and contrast of a bitmap pattern fill

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a radial or linear seamless blend</td>
<td>Click the Radial blend button, or click the Linear blend button and move the slider.</td>
</tr>
<tr>
<td>Smooth the color transition of the pattern tile edges with their opposite edge</td>
<td>Enable the Edge match check box, and type a value in the box.</td>
</tr>
<tr>
<td>Increase or decrease the brightness of the pattern</td>
<td>Enable the Brightness check box, and type a value in the box.</td>
</tr>
<tr>
<td>Increase or decrease the grayscale contrast of the pattern</td>
<td>Enable the Luminance check box, and type a value in the box.</td>
</tr>
</tbody>
</table>
To Do the following

Increase or decrease the color contrast of the pattern
Enable the Color check box, and type a value in the box.

Two-color pattern fills
A two-color pattern fill is composed only of the two colors that you choose. In addition to specifying the colors, you can mirror the fill tiles vertically or horizontally, and you can set the size of the fill tiles. You can also skew and rotate the fill, and you can move its center.

You can create your own pattern fill from objects in the drawing window by using the Object ▶ Create ▶ Pattern Fill command.

To apply a two-color pattern fill
1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click the Two-color pattern fill button on the property bar.
3. Choose a fill from the First fill color or pattern picker.
4. Open the Front color picker, and click a color.
5. Open the Back color picker, and click a color.
   You can use the Properties docker to edit the attributes of the two-color fill by clicking the arrow button at the bottom of the Fill section, and performing a task from the following table.
To | Do the following
---|---
Arrange the tiles so that alternating tiles are reflections of each other | Click the Mirror tiles horizontally or the Mirror tiles vertically button.
Set the width and height of the pattern tiles | Type values in the Fill width and Fill height boxes.
Move the center of the pattern fill up, down, left, or right | Type values in the X and Y boxes.
Rotate the pattern at a specified angle | Type a value in the Rotate box.
Slant the pattern at a specified angle | Type a value in the Skew box.
Specify row or column offset as a percentage of the tile’s height or width | Click the Row offset or the Column offset button and type a value in the % of tile box.
Apply object changes to the pattern fill | Enable the Transform with object check box.
Apply the selected fill to the intersecting area of combined objects | Enable the Fill winding check box.

You can also mix colors in a two-color pattern fill by pressing Ctrl and clicking a color on the color palette. You can also drag colors from the color palette to the interactive handles to change the colors of the fill. You can mix colors by holding down Ctrl while dragging a color to the interactive handles.

**To create a two-color pattern fill**
1 Click Object ➤ Create ➤ Pattern Fill.
2 In the Create pattern dialog box, enable the Two color option, and click OK.
3 In the drawing window, select the pattern or area that you want to use for the fill, and then double-click the selection.
4 In the dialog box that appears, choose a resolution, and then click OK.
The new two-color pattern fill can be accessed from the Fill picker.

**Texture fills**
A texture fill is a randomly generated fill that you can use to give your objects a natural appearance. You can use existing texture fills, such as water, minerals, and clouds. You can change the colors of a texture fill. Texture fills can hold only RGB colors; however, other color models and palettes can be used as a reference to select colors. For information about color models, see “Color models” on page 405.

You can change the tile size of texture fills. Increasing the resolution of a texture tile increases the accuracy of the fill. You can also specify exactly where these fills begin by setting the tile origin. CorelDRAW also lets you offset tiles in a fill. Adjusting the horizontal or vertical position of the first tile, relative to the top of the object, affects the rest of the fill.
You can also rotate or skew the fill, adjust the tile size, and change the center of the texture.

If you want a texture fill to change according to the actions you perform on the filled object, you can set the fill to transform with the object. For example, if you enlarge the filled object, the texture becomes larger while the number of tiles remains the same.

Texture fills can enhance a drawing. However, they also increase the size of a file and the time it takes to print, so you may want to use them in moderation.

**Examples of texture fills**

**To apply a texture fill**

1. Select an object.
2. Click the **Interactive fill tool** in the toolbox, and then click the **Texture fill button** on the property bar.
3. Choose a texture library from the **Texture library list box**.
4. Choose a texture from the **Fill picker**.

   If you want to edit the texture, click the **Edit fill button**. In the **Edit fill dialog box**, perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrange the tiles so that alternating tiles are reflections of each other</td>
<td>Click <strong>Transformations</strong>, and click the <strong>Mirror tiles horizontally</strong> or the <strong>Mirror tiles vertically button</strong>.</td>
</tr>
<tr>
<td>Change the size of the fill</td>
<td>Click <strong>Transformations</strong>, and type values in the <strong>Fill width</strong> and <strong>Fill height</strong> boxes.</td>
</tr>
<tr>
<td>Move the center of the fill up, down, left, or right</td>
<td>Click <strong>Transformations</strong>, and type values in the <strong>X</strong> and <strong>Y</strong> boxes.</td>
</tr>
<tr>
<td>Rotate the fill at a specified angle</td>
<td>Click <strong>Transformations</strong>, and type a value in the <strong>Rotate</strong> box.</td>
</tr>
<tr>
<td>Slant the fill at a specified angle</td>
<td>Click <strong>Transformations</strong>, and type a value in the <strong>Skew</strong> box.</td>
</tr>
<tr>
<td>Specify a row or column offset as a percentage of the tile's width or height</td>
<td>Click <strong>Transformations</strong>, and click the <strong>Row offset</strong> or the <strong>Column offset button</strong>. Type a value in the % of tile box.</td>
</tr>
</tbody>
</table>
To | Do the following
---|---
Apply object changes to the texture fill | Click Transformations, and enable the Transform with object check box.
Specify the bitmap resolution of the texture fill | Click Texture resolution and size, and type a value in the Bitmap resolution box.
Apply the selected fill to the intersecting area of combined objects | Enable the Fill winding check box.
For more information, see “Combine objects” on page 357.

PostScript fills
You can apply PostScript texture fills to objects. A PostScript texture fill is created in the PostScript language. Some textures are very complex, and large objects that contain PostScript texture fills may take time to print or to be updated on the screen. Depending on the view mode you are using, the letters “PS” — rather than the fill — may appear. For more information about displaying PostScript fills, see “Views” on page 75.

When you apply a PostScript texture fill, you can change several properties, such as the size, line width, and the amount of gray that appears in the texture’s foreground and background.

![Examples of PostScript fills](image)

To apply a PostScript fill
1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click the PostScript fill button on the property bar.
3. Choose a fill from the PostScript fill textures list box.
   
   If you want to change the fill properties, click the Edit fill button, and specify the settings you want.

Mesh fills
When you fill an object with a mesh fill, you can create unique effects. For example, you can create smooth color transitions in any direction without having to create blends or contours. When you apply a mesh fill, you specify the number of columns and rows in the grid, and you specify the grid’s intersecting points.
After you have created a mesh object, you can edit the mesh fill grid by adding and removing nodes or intersections. You can also remove the mesh.

A mesh fill is applied to the vase.

The Mesh tool can be used to create smooth color transitions.

A mesh fill can be applied only to closed objects or a single path. If you want to apply a mesh fill to a complex object, you must first create a mesh-filled object and combine it with the complex object to form a PowerClip object. For more information about working with PowerClip objects, see “PowerClip objects” on page 263.

You can add color to a patch of a mesh fill and to the individual intersection nodes. You can also choose to mix colors for a more blended appearance.
In addition, you can smooth the color in a mesh fill to reduce the appearance of hard edges. You can also reveal objects underneath a selected area by applying transparency to the mesh fill.

You can set the default properties of all new mesh fills by specifying the number of rows and columns in the mesh grid.

**To apply a mesh to an object**

1. Select an object.
2. In the toolbox, click the **Mesh fill** tool.
3. Type the number of columns in the top portion of the **Grid size** box on the property bar.
4. Type the number of rows in the bottom portion of the **Grid size** box on the property bar, and press **Enter**.
5. Adjust the grid nodes on the object.
You can also

Add a node or an intersection
Click once within a grid, and click the Add intersection button on the property bar.

You can also add a node or an intersection by double-clicking within a grid.

Remove a node or an intersection
Click a node, and click the Delete nodes button on the property bar.

Shape the mesh fill
Drag a node to a new location.

Remove the mesh fill
Click the Clear mesh button on the property bar.

If the mesh object contains color, adjusting the intersection nodes of the mesh affects how the colors blend together.

You can also marquee select or freehand marquee select nodes to shape an entire area of the mesh. To marquee select nodes, choose Rectangular from the Selection mode list box on the property bar, and drag around the nodes that you want to select. To freehand select nodes, choose Freehand from the Selection mode list box, and drag around the nodes that you want to select. Holding down Alt while dragging lets you toggle between the Rectangular and Freehand selection modes.

You can add an intersection or a node by double-clicking in a space, or you can add a single line by double-clicking a line.

To fill a mesh with color
1 Select a mesh-filled object.
2 In the toolbox, click the Mesh fill tool.
3 Drag a color from the color palette to a patch in the object.

You can also

Color a node in a mesh fill
Click a node, and click a color on the color palette.

You can also drag a color from the color palette to a node.

Mix a color in a mesh fill
Select part of the mesh, press Ctrl, and click a color on the color palette.

You can also marquee select or freehand marquee select nodes to apply a color to an entire area of the mesh. To marquee select nodes, choose Rectangular from the Selection mode list box on the property bar, and drag around the nodes that you want to select. To freehand select nodes, choose Freehand from the Selection mode list box on the property bar, and drag around the nodes that you want to select. Holding down Alt while dragging lets you toggle between the Rectangular and Freehand selection modes.
To smooth color transitions in a mesh fill
1. Select a mesh-filled object.
2. In the toolbox, click the Mesh fill tool.
3. Make sure that the Smooth mesh color button on the property bar is enabled.

To apply transparency to a mesh fill
1. Select a mesh-filled object.
2. In the toolbox, click the Mesh fill tool.
3. Click a node to select part of the mesh.
4. On the property bar, type a value in the Transparency box slider.
   Higher values increase the transparency of the selected area.

To set the default properties of mesh fills
1. Click Tools > Options > Tools.
2. In the left pane of the dialog that appears, click Mesh Fill.
3. Type values in the Number of columns and Number of rows boxes.

Apply fills to areas
You can apply fills to any enclosed area by using the Smart fill tool. Unlike other fill tools, which fill only objects, the Smart fill tool detects the edges of an area and creates a closed path so that the area can be filled. For example, if you draw a freehand line that crosses over itself to create loops, the Smart fill tool can detect the edges of the loops and fill them.

In the example above, the original spiral object is duplicated and offset, resulting in enclosed areas that can be filled by using the Smart fill tool.

Using the Smart fill tool to fill enclosed areas
Because the Smart fill tool creates a path around the area, it essentially creates a new object that can be filled, moved, copied, or edited. This means that the tool can be used in one of two ways: to fill an area or to create a new object from an area.
Although primarily used to fill areas, the Smart fill tool can also be used to create new objects. In the example above, the original objects — the two spirals (left) — are deleted (right), but the fill remains because each filled area is actually an object.

You can apply the default fill and outline to the area, use the property bar to specify a specific fill color and outline, or create an outline with no fill.

When you use the Smart fill tool on areas that already have fills applied to them, remember the following:

- An object with transparency applied to it is considered completely transparent — paths under any area of the object are detected, regardless of whether the specific area appears opaque.
- PostScript fills are considered transparent — paths under any area of a PostScript fill are detected.
- All fills other than PostScript fills are considered opaque — paths under these fills are not detected.

To apply a fill to an enclosed area

1. In the toolbox, click the Smart fill tool.
2. On the property bar, choose one of the following options from the Fill Options list box:
   - Use default — lets you apply the default fill settings
   - Specify — lets you fill the area with a solid color by choosing a color from the Fill color picker on the property bar
   - No fill — applies no fill to the area
3. From the Outline list box, choose one of the following options:
   - Use default — lets you apply the default outline settings
   - Specify — lets you choose a line width from the Outline width box and a line color from the Outline color picker
   - No outline — applies no outline to the area
4. Click inside the enclosed area that you want to fill.

A new object is created from the enclosed area, and the selected fill and outline options on the property bar are applied to it. The new object appears on top of the existing objects in the layer.

If you click outside an enclosed area, a new object is created from all objects on the page, and the selected fill and outline options on the property bar are applied to the new object.

The outline width is centered on an object’s path. Because the Smart fill tool detects paths, not outlines, thick outlines appear partially covered by the new object. You can uncover the original outlines by changing the stacking order of the objects. For information about changing the stacking order of objects, see “To move an object in the stacking order” on page 345.

Work with fills

There are a number of tasks that are common to all types of fills. You can choose a default fill color so that every object that you add to a drawing has the same fill. You can also remove a fill, copy it to another object, or use it to fill an area surrounded by an open curve.

If you want to apply the same fill to other objects or simultaneously modify the fill attributes of multiple objects in a drawing, you can save the fill settings as a style. For more information about styles, see “Styles and style sets” on page 697. You can search for objects based on their fill and replace the existing fill with a new one. For more information, see “Find and replace colors” on page 413.
To choose a default fill color
1. Click a blank area on the drawing page to deselect all objects.
2. On the status bar, double-click the Fill icon.
3. In the Edit fill dialog box, choose a fill type, choose a fill color, and click OK.
4. In the Change document defaults dialog box, enable the check boxes for the types of objects whose default fill you want to change.

You can also change the default fill color by editing the default style sets in the Object Styles docker. For more information, see “Manage and apply default object properties” on page 702.

To remove a fill
1. Select an object.
2. Click the Interactive fill tool in the toolbox, and then click the No fill button on the property bar.

You cannot remove mesh fills by following this procedure. To remove a mesh fill from an object, select the object by using the Mesh fill tool, and click Clear Mesh on the property bar.

To copy a fill to another object
1. Using the Pick tool, select the object from which you want to copy the fill.
2. With the right mouse button, drag the object over the destination object to which you want to apply the fill. A blue outline of the first object follows the pointer to the destination object.
3. When the pointer changes to a crosshair pointer, release the mouse button, and choose Copy fill here from the context menu.

You can also click the Interactive fill tool, select the object to which you want to copy a fill, click the Copy fill button on the property bar, and click the object from which you want to copy the fill.
You can also use the Attributes eyedropper tool to copy a fill. For more information, see “To copy fill, outline, or text properties from one object to another” on page 324.
You can also sample the color of an existing object and apply the sampled color to another object as a uniform fill. For more information, see “To sample a color” on page 411.

To show fills in open curves
1. Click Layout ➤ Document Options.
2. In the left pane of the dialog box that appears, click General.
3. Enable the Fill open curves check box.
Object transparency

When you apply a transparency to an object, you make the objects beneath it partially visible. You can apply transparencies by using the same kind of fills you apply to objects; that is, uniform, fountain, hatch, texture, and pattern. For more information about these fills, see “Fills” on page 425.

Examples of different types of transparencies, including uniform, fountain, and pattern.
Uniform transparency

Uniform transparency alters the transparency values of all pixels in the object or editable area by an equal amount.

To apply a uniform transparency

1. Select an object.
2. Click Object ▶ Properties.
3. In the Transparency area of the Properties docker, click the Uniform transparency button.
4. Move the Transparency slider to increase or decrease the transparency.
You can click a color on the color palette to apply a color to the transparency. To apply the transparency only to the fill or the outline of the object, click the Fill button \(\text{Fill button}\) or the Outline button \(\text{Outline button}\).

You can also click the Transparency tool \(\text{Transparency tool}\) in the toolbox and use the controls on the property bar.

Fountain transparency

Fountain transparency makes the object fade from one transparency value to another. The fountain transparency can be linear, elliptical, conical, or rectangular.

![Fountain transparency examples](image)

From left to right: Original object with a linear, elliptical, conical, and rectangular transparency applied.

The application provides a collection of fountain transparencies that you can access. You can browse the available transparencies, search by keyword, mark transparencies as favorites, and sort them. You can also download additional fill packs, which can be used as transparencies. For more information, see “Find and view fills and transparencies” on page 459.

You can create a fountain transparency by adding and removing nodes, and specifying a transparency value for each node. You can also reverse, mirror, resize, or skew a fountain transparency, or apply other transformations.

After you create a fountain transparency, you can save it for future use or share. For more information, see “Save fills and transparencies” on page 463.

To apply a fountain transparency

1. Select an object.
2. Click Object ➔ Properties.
3. In the Transparency area of the Properties docker, click the Fountain transparency button \(\text{Fountain transparency button}\) to display fountain transparency options.
4. Open the Transparency picker, and double-click a thumbnail.

You can also

Apply the transparency only to the fill or the outline of the object

Click the Fill button \(\text{Fill button}\) or the Outline button \(\text{Outline button}\) in the Transparency area of the Properties docker.

Modify the transparency

Click the Edit transparency button \(\text{Edit transparency button}\) in the Properties docker, and specify the settings you want.
You can also click the Transparency tool in the toolbox, and use the controls on the property bar to apply a fountain transparency.
For information about how to find transparencies in the Transparency picker, see “To find, filter, and sort fills and transparencies” on page 460.

To create a fountain transparency

1. Select an object.
2. Click Object ➤ Properties.
3. In the Transparency area of the Properties docker, click the Fountain transparency button to display fountain transparency options.
4. Click one of the following buttons to choose a fountain transparency type:
   • Linear fountain transparency
   • Elliptical fountain transparency
   • Conical fountain transparency
   • Rectangular fountain transparency
5. Click the first node below the grayscale band, and type a value in the Opacity box.
6. Click the last node below the grayscale band, and type a value in the Opacity box.
7. Move the midpoint slider above the grayscale band to set the midpoint of the transparency.
   To save the transparency, click the click the Save as new button in the Transparency area of the Properties docker.

You can also

You can also change the transparency of the midpoint

Select the midpoint node, and type a value in the Opacity box.

Add an intermediate transparency

Double-click the grayscale band where you want to add a node. With the new node selected, type a value in the Opacity box.

Change the position of an intermediate transparency

Drag the corresponding node to a new location below the grayscale band, or type a value in the Position box.

Delete an intermediate transparency

Click the Transparency tool and double-click the node on the interactive vector handles that appear on the object.

Allow the transparency to be skewed or stretched disproportionately

Enable the Free scale and skew check box.

Mirror, repeat, or reverse the transparency

Click the Edit transparency button, and click one of the following buttons:
   • Repeat and mirror
   • Repeat
   • Reverse transparency
You can also

Specify the number of steps used to display or print the fountain transparency

Click the Edit transparency button, enable the Steps check box, and then type a value in the Steps box.

Specify how quickly the fountain transparency blends from one level of opacity to another

Click the Edit transparency button, enable the Steps check box, and move the Acceleration slider.

Create smoother color transitions between fountain fill nodes

Click the Edit transparency button, enable the Smooth transition check box.

Set the width and height of the transparency as a percentage of the object’s width and height

Click the Edit transparency button, and type values in the Transparency width and Transparency height boxes.

Move the transparency center up, down, left, or right

Click the Edit transparency button, and type values in the X and Y boxes.

Slant the transparency at a specified angle

Click the Edit transparency button, and type a value in the Skew box.

Rotate the transparency at a specified angle

Click the Edit transparency button, and type a value in the Rotate box.

To apply the transparency only to the fill or the outline of the object, click the Fill button or the Outline button.

You can also click the Transparency tool in the toolbox. To adjust the transparency, use the controls on the property bar or the interactive vector handles that appear on the object.

You can also drag colors, which are converted to grayscale, from the color palette onto the transparency nodes. Alternatively, if the Transparency tool is selected, you can drag the colors onto the object’s interactive vector handles.

Pattern transparency

There are three types of pattern transparency: vector pattern, bitmap pattern, and two-color pattern.

Vector pattern transparencies are pictures composed of lines and fills, instead of dots of color like bitmaps. These vector graphics are smoother and more complex than bitmap images and are easier to manipulate.

Bitmap pattern transparencies are color pictures composed of patterns of light and dark or differently colored pixels in a rectangular array.

Two-color pattern transparencies are simple pictures composed of “on” and “off” pixels. The only shades included in the picture are the two that you assign.
You can choose pattern transparencies from a personal or shared library. You can browse the available transparency patterns, search by keyword, mark patterns as favorites, and sort patterns. You can also download additional fill packs, which can be used as transparency patterns. For more information, see “Find and view fills and transparencies” on page 459.

You can modify pattern transparencies to suit your needs. For example, you can create seamless patterns and adjust the pattern parameters, such as the pixel configuration along the edge of the tile and the brightness, luminance, and color contrast of the pattern.

You can also create your own patterns. For example, you can create patterns from areas of the workspace or images that you import. Vector and bitmap patterns are made up of smaller units called tiles. Depending on the size of the object, the transparency may consist of one or more tiles. The pattern is created by repeating the tile to fill up the object.

After you modify or create a pattern transparency, you can save it for future use. For more information, see “Save fills and transparencies” on page 463.

To apply a vector or bitmap pattern transparency

1. Select an object.
2. Click **Object ▶ Properties**.
3. In the **Transparency** area of the **Properties** docker, click one of the following buttons:
   - Vector pattern transparency
   - Bitmap pattern transparency
4. Open the **Transparency** picker, and double-click a thumbnail.

For information about how to find transparencies in the **Transparency** picker, see “To find, filter, and sort fills and transparencies” on page 460.

To apply the transparency only to the fill or the outline of the object, click the **Fill** button or the **Outline** button.

You can also click the **Transparency** tool in the toolbox and use the controls on the property bar.

To modify a vector or bitmap transparency

1. Select an object.
2. Click **Object ▶ Properties**.
3. In the **Transparency** area of the **Properties** docker, click one of the following buttons:
   - Vector pattern transparency
• Bitmap pattern transparency

4  Click the Edit transparency button.

5  Perform a task from the following table.

To  

Arrange the tiles so that alternating tiles are reflections of each other  

Click the Mirror tiles horizontally or the Mirror tiles vertically button.

Create a radial or linear seamless blend  

Click the Radial blend button, or click the Linear blend button and move the slider.

This setting applies only to bitmap pattern transparency.

Smooth the color transition of the pattern tile edges with their opposite edge  

Enable the Edge match check box, and type a value in the box.

This setting applies only to bitmap pattern transparency.

Increase or decrease the brightness of the pattern  

Enable the Brightness check box, and type a value in the box.

This setting applies only to bitmap pattern transparency.

Increase or decrease the grayscale contrast of the pattern.  

Enable the Luminance check box, and type a value in the box.

This setting applies only to bitmap pattern transparency.

Increase or decrease the color contrast of the pattern  

Enable the Color check box, and type a value in the box.

This setting applies only to bitmap pattern transparency.

Set the width and height of the transparency as a percentage of the object’s width and height  

Type values in the Transparency width and Transparency height boxes.

Move the center of the transparency up, down, left, or right  

Type values in the X and Y boxes.

Rotate the transparency at a specified angle  

Type a value in the Rotate box.

Slant the transparency at a specified angle  

Type a value in the Skew box.

Specify row or column offset as a percentage of the tile’s height or width  

Click the Row offset or the Column offset button and type a value in the % of tile box.

Apply object changes to the transparency  

Enable the Transform with object check box.
To save the edited transparency, click the **Save as new** button.

You can also click the **Transparency** tool in the toolbox and use the controls on the property bar.

You can also skew or rotate tiles by clicking the **Transparency** tool in the toolbox, selecting an object, and dragging the skewing or rotation handles to change the appearance of the pattern.

To apply a two-color pattern transparency

1. Select an object.
2. Click **Object ▶ Properties**.
3. In the **Transparency** area of the **Properties** docker, click the **Two-color pattern transparency** button.
4. Choose a pattern from the **Transparency** picker.
5. Type values in the **Foreground transparency** and **Background transparency** boxes.

To apply the transparency only to the fill or the outline of the object, click the **Fill** button or the **Outline** button.

To modify the pattern, click the **Edit transparency** button, and specify the settings you want.

You can also click the **Transparency** tool in the toolbox and use the controls on the property bar.

Texture transparency

You can use textures to create transparency effects. You can use existing textures, such as water, minerals, and clouds, or you can edit a texture to create your own texture transparency.

![Texture transparency example](image)

A texture transparency is applied to the object filled with light green.

When you edit a texture, you can modify its parameters, such as softness, density, brightness, and colors. Parameters vary for each texture. You can also apply other transformations, such as mirror, resize, or offset the texture tiles. After you have edited a texture, you can save it for future use.

To apply a texture transparency

1. Select an object.
2. Click **Object ▶ Properties**.
3 In the Transparency area of the Properties docker, click the flyout arrow on the Two-color pattern transparency button and click the Texture transparency button to display texture transparency options.

4 Choose a collection of textures from the Texture library list.

5 Choose a texture from the Transparency picker.

To apply the transparency only to the fill or the outline of the object, click the Fill button or the Outline button. To modify the texture, click the Edit transparency button and specify the settings you want.

You can also click the Transparency tool in the toolbox and use the controls on the property bar.

Copy, freeze, and remove transparencies

You can copy a transparency from one object to another. If you want to apply the same transparency to other objects or simultaneously modify the transparency attributes of multiple objects in a drawing, you can save the transparency settings as a style. For more information about styles, see “Styles and style sets” on page 697.

When you position a transparency over an object, you can freeze it, making the view of the object move with the transparency.

You can also remove the transparency from an object.

To copy a transparency from another object
1 In the toolbox, click the Transparency tool
2 Select the object to which you want to copy the transparency.
3 Click the Copy transparency button on the property bar.
4 Click the object from which you want to copy the transparency.

To freeze the contents of a transparency
1 In the toolbox, click the Transparency tool
2 Select an object to which a transparency has been applied.
3 Click the Freeze transparency button on the property bar.
The view of the object beneath the transparency moves with it; however, the actual object remains unchanged.

**To remove a transparency**

1. Select an object to which a transparency has been applied.
2. In the **Transparency** area of the **Properties** docker, click the **No transparency** button.

**Merge modes**

You can apply a merge mode to a transparency to specify how the color of a transparency is combined with the color of the object behind it. The following merge modes available for transparencies can also be applied to drop shadows.

<table>
<thead>
<tr>
<th>Merge mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Applies the transparency color on top of the base color</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the values of the transparency color and the base color</td>
</tr>
<tr>
<td>Subtract</td>
<td>Adds the values of the transparency color and the base color together, and then subtracts 255</td>
</tr>
<tr>
<td>Difference</td>
<td>Subtracts the transparency color from the base color and multiplies by 255. If the transparency color value is 0, the result will always be 255.</td>
</tr>
<tr>
<td>Multiply</td>
<td>Multiplies the base color by the transparency color, and then divides by 255. This has a darkening effect, unless you are applying color to white. Multiplying black with any color results in black. Multiplying white with any color leaves the color unchanged.</td>
</tr>
<tr>
<td>Divide</td>
<td>Divides the base color by the transparency color, or conversely, divides the transparency color by the base color, depending on which color has the higher value</td>
</tr>
<tr>
<td>If lighter</td>
<td>Replaces any base color pixels that are a darker color with the transparency color. Base color pixels that are lighter than the transparency color are not affected.</td>
</tr>
<tr>
<td>If darker</td>
<td>Replaces any base color pixels that are a lighter color with the transparency color. Base color pixels that are darker than the transparency color are not affected.</td>
</tr>
<tr>
<td>Texturize</td>
<td>Converts the transparency color to grayscale, and then multiplies the grayscale value by the base color</td>
</tr>
<tr>
<td>Merge mode</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Color</td>
<td>Uses the hue and saturation values of the source color and the lightness value of the base color to create a result. This merge mode is the opposite of the Lightness merge mode.</td>
</tr>
<tr>
<td>Hue</td>
<td>Uses the hue of the transparency color, as well as the saturation and lightness of the base color. If you are adding color to a grayscale image, there will be no change because the colors are desaturated.</td>
</tr>
<tr>
<td>Saturation</td>
<td>Uses the lightness and hue of the base color and the saturation of the transparency color</td>
</tr>
<tr>
<td>Lightness</td>
<td>Uses the hue and saturation of the base color and the lightness of the transparency color</td>
</tr>
<tr>
<td>Invert</td>
<td>Uses the transparency color’s complementary color. If a transparency color value is 127, there will be no change because the color value falls in the center of the color wheel.</td>
</tr>
<tr>
<td>Logical AND</td>
<td>Converts the transparency and base colors to binary values, and then applies the Boolean algebraic formula AND to these values</td>
</tr>
<tr>
<td>Logical OR</td>
<td>Converts the transparency and base colors to binary values, and then applies the Boolean algebraic formula OR to these values</td>
</tr>
<tr>
<td>Logical XOR</td>
<td>Converts the transparency and base colors to binary values, and then applies the Boolean algebraic formula XOR to these values</td>
</tr>
<tr>
<td>Behind</td>
<td>Applies the source color to those areas of the image that are transparent. The effect is similar to looking through the clear, silver-free areas on a 35-mm negative.</td>
</tr>
<tr>
<td>Screen</td>
<td>Inverts the source and base color values, multiplies them, and then inverts the result. The result color is always lighter than the base color.</td>
</tr>
<tr>
<td>Overlay</td>
<td>Multiplies or screens the source color according to the value of the base color</td>
</tr>
<tr>
<td>Soft light</td>
<td>Applies a soft, diffused light to the base color</td>
</tr>
<tr>
<td>Hard light</td>
<td>Applies a hard, direct spotlight to the base color</td>
</tr>
<tr>
<td>Color dodge</td>
<td>Simulates the photographic technique called dodging, which lightens image areas by decreasing the exposure</td>
</tr>
<tr>
<td>Merge mode</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Color burn</td>
<td>Simulates the photographic technique called burning, which darkens image areas by increasing the exposure</td>
</tr>
<tr>
<td>Exclusion</td>
<td>Excludes the transparency color from the base color. This mode is similar to the Difference mode.</td>
</tr>
<tr>
<td>Red</td>
<td>Applies the transparency color to the red channel of RGB objects</td>
</tr>
<tr>
<td>Green</td>
<td>Applies the transparency color to the green channel of RGB objects</td>
</tr>
<tr>
<td>Blue</td>
<td>Applies the transparency color to the blue channel of RGB objects</td>
</tr>
</tbody>
</table>

**To apply a merge mode to a transparency**

1. Select an object.
2. In the Properties docker, choose a merge mode from the Merge mode list box in the Transparency area.

![Transparency tool](image)

You can also click the Transparency tool in the toolbox and choose a merge mode from the Merge mode list box on the property bar.
Find, manage, and save fills and transparencies

When working with vector patterns, bitmap patterns, or fountain fills and transparencies, you can access your personal local library as well as shared and local folders to browse, search, and save fills and transparency patterns.

This section contains the following topics:
- “Find and view fills and transparencies” (page 459)
- “Manage fills and transparencies” (page 462)
- “Save fills and transparencies” (page 463)

Find and view fills and transparencies

CorelDRAW lets you use, browse, and search vector patterns, bitmap patterns, and fountain fills that are available locally on your computer, on portable media devices, and in network folders. Any of these fills can also be used as transparency patterns. For more information, see “Object transparency” on page 447.

To get you started, Corel provides local fills that are listed under All content in the Fill and Transparency pickers. These fills are stored in your Documents\Corel\Corel Content\Fills folder. If you are looking to expand your fill collection, you can download additional fill packs from within the Get More dialog box.

To access fills and patterns that are saved to local folders outside your Documents\Corel\Corel Content\Fills folder, you can create links to these folders in the Fill and Transparency pickers. Such links are known as aliases. In addition, aliases can be used to access fills saved to shared network locations as well as secondary storage devices such as USB flash drives, and portable hard drives.

You can also view the list of your favorite or most recently used fills and transparencies.

You can search and browse one pack, folder or list at a time. You can also browse and search your entire All content library by enabling the Browse recursively option.

When you copy a folder that contains many fills to your computer, it may take some time for Windows to index the folder. To view, browse, and search fills in such a folder right away, you may need to reindex the folder.

To find fills and transparencies more easily, you can filter them based on categories such Abstract, Animals, Floral, Nature, and more. You can also sort local fills and transparencies by name and the date they were created or modified.
The Fill picker lets you search, browse, and manage local and shared fills.

Fills and transparencies appear as thumbnail images. By positioning your pointer over a thumbnail, you can view the filename and file location. You can adjust the size of the thumbnails for easier and faster preview of fills and transparencies. In addition, you can resize the Fill picker or the Transparency picker to view more thumbnails at a glance.

For more information about fills, see “Fills” on page 425.

To find, filter, and sort fills and transparencies
1 Select an object.
2 Click Object  Properties.
3 In the Properties docker, click one of the following buttons in the Fill or Transparency section:
   • Fountain fill or Fountain transparency
   • Vector pattern fill or Vector pattern transparency
   • Bitmap pattern fill or Bitmap pattern transparency
4 Open the Fill picker or the Transparency picker.
5 From the Choose content source list box, choose the local pack, folder, network location or list you want to search or browse. The items under All content show the fill packs provided by Corel and any fill packs and fills added by you.
   To search, type a keyword in the Search box, and press Enter.

You can also

Browse or search all items in your All content library
From the Choose content source list box, choose All content.
Click the Options button and click Browse recursively.

Reindex a folder
From the Choose content source list box, choose All content or an alias. Click the Options button and click Reindex folder.

View the last 25 most recently used fills and patterns
From the Choose content source list box, choose Recent.

View your favorite fills and transparencies
From the Choose content source list box, choose Favorites. For information about how to mark a fill as favorite, see “To manage fills and transparencies” on page 463.
You can also

Filter fills and transparencies

From the Choose content source list box, choose a pack under All content or an alias. Choose a category from the Filter list box.

Sort fills and transparencies

From the Choose content source list box, choose a pack under All content or an alias. Click the Options button, and choose one of the following:

- **Sort by name** sorts fills and transparencies by the fill name, in alphabetical order.
- **Sort by date created** sorts fills and transparencies by the date they were created, starting with the last created fill.
- **Sort by last modified** sorts fills and transparencies by the date they were modified, starting with the last modified fill.

Fills and transparencies in your Favorites list are automatically sorted by the date you marked them as favorites, starting with the last fill and transparency added to Favorites.

Fills and transparencies in your Recent list are automatically sorted by the date you used them, starting with the last used fill or transparency.

This procedure applies only to vector patterns, bitmap patterns, and fountain fills and transparencies.

**To download and add a new fill and transparency pack**

1. Open the Fill picker or the Transparency picker in the Fill or Transparency section of the Properties docker.
2. Open the Choose content source list box, and click Add new.
3. Click Get More.
4. In the Get More dialog box, click the fill pack you want.
5. Do one of the following:
   - Click Buy, and follow the onscreen instructions to purchase the item.
   - Click Download if the item is included in your product or subscription.

**To add an alias to a location that contains fills and transparencies**

1. Open the Fill picker or the Transparency picker in the Fill or Transparency section of the Properties docker.
2. Open the Choose content source list box, and click Add new.
3. Click Create alias.
4. In the Locate fills library dialog box, browse to the folder or location you want.
5. Click Select Folder.

**To view the filename and location of a fill or transparency**

- In the Fill picker or the Transparency picker, point to a thumbnail.

**To adjust the size of fill or transparency thumbnails**

- In the Fill picker or the Transparency picker, move the Thumbnail size slider.
To resize the Fill picker or the Transparency picker

- Drag the lower-right corner of the Fill picker or the Transparency picker.
  You can increase the width of the picker by dragging its right side, and you can increase the height of the picker by dragging its bottom side.

Manage fills and transparencies

The Fill and Transparency pickers let you manage the list of your local packs and aliases (links to local folders, network locations, and secondary storage devices). For example, you can rename the local packs or aliases, and you can remove aliases from the list. If an alias no longer works because the fill folder has been moved, you can browse to the new location to restore the link.

To find the fills and transparencies you like with ease, you can mark them as favorites. In addition, you can view and change the properties of a fill or transparency. For example, you can change its name and language; and you can add new tags and delete existing tags. When you no longer need a fill or transparency, you can delete it.

To update the list of fill packs in the Fill and Transparency pickers

1. Open the Fill picker or the Transparency picker from the property bar or the Fill or Transparency section of the Properties docker.
2. Choose a fill pack from the Choose content source list box under All content.
3. Click the Options button, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rename a fill pack</td>
<td>Click Rename, and in the Rename dialog box, type a name in the Name box.</td>
</tr>
<tr>
<td>Open the fill pack in Windows Explorer</td>
<td>Click Open folder location.</td>
</tr>
<tr>
<td>Delete a fill pack</td>
<td>Click Open folder location. Select the folder that contains the pack in Windows Explorer, right-click it, and click Delete. This action deletes the fill pack and removes it from the list in the Fill and Transparency pickers.</td>
</tr>
</tbody>
</table>

To update the list of aliases in the Fill and Transparency pickers

1. Open the Fill picker or the Transparency picker from the property bar or the Fill or Transparency section of the Properties docker.
2. Choose an alias from Choose content source list box.
3. Click the Options button, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse to a folder that has been moved or renamed</td>
<td>Click Browse, and navigate to the folder that contains the fills.</td>
</tr>
</tbody>
</table>
To

Do the following

Rename the alias
Click Rename, and in the Rename dialog box, type a name in the Name box.

Remove the alias from the list
Click Remove.

Open the folder in Windows Explorer
Click Open folder location.

To manage fills and transparencies

1 Select an object.
2 Click Object ➤ Properties.
3 In the Properties docker, click one of the following buttons in the Fill or Transparency section:
   • Fountain fill or Fountain transparency
   • Vector pattern fill or Vector pattern transparency
   • Bitmap pattern fill or Bitmap pattern transparency
4 Open the Fill picker or the Transparency picker.
5 Perform an action from the following table.

To
Do the following

Mark a fill or pattern as a favorite
Right-click a thumbnail, and click Favorite.

Change the name of a fill or pattern in your local library, or the tags associated with it
Right-click a thumbnail, and click Properties. In the Properties dialog box, do any of the following:
• Choose a language from the Language list box.
• Type a new name in the Title box.
• Choose a category from the Category list box to categorize the fill or pattern.
• Add to or delete tags from the Tags box.

Delete a fill or pattern from your local library
Right-click a thumbnail, and click Delete.

This procedure applies only to vector patterns, bitmap patterns, and fountain fills and transparencies.

Save fills and transparencies

After you create or modify a fill or transparency pattern, you can save it and add metadata such as name and tags in the language of your choice. Fills and patterns are saved in a special file format with a .fill extension, which preserves information about the transformations applied to the fill or pattern.

To save a custom fill or transparency
1 In the Fill or Transparency section of the Properties docker, click the Save as new button.
This button is available for fountain, vector pattern, and bitmap pattern fills and transparencies, but not for two-color pattern, texture, and PostScript fills and transparencies. For information about saving a two-color pattern fill, see “To create a two-color pattern fill” on page 437.

2 In the **Create Custom [Fill Type]** dialog box, choose a language from the list box, type a name for the fill or pattern, and type any tags that you want to associate with it.

Fills and patterns in your personal library are saved by default in your `Documents\Corel\Corel Content\Fills` folder. You can change the default location to which fills and patterns are saved. For more information, see “Change content locations” on page 125.

You can also save a fill or transparency by clicking the **Save custom fill** button + in the **Fill** or **Transparency** picker. The fill or transparency is saved to the location selected in the **Choose content source** list box in the **Fill** or **Transparency** picker. If you have selected **Recent** from the **Choose content source** list box, the fill or transparency is saved to your `Documents\Corel\Corel Content\Fills` folder.
Color management

Color management helps ensure colors appear consistent when you work with files from various sources and output these files on different devices.

This section contains the following topics:

• “About color management” (page 465)
• “Get started with color management” (page 469)
• “Install, load, and embed color profiles” (page 472)
• “Assign color profiles” (page 473)
• “Convert colors to other color profiles” (page 474)
• “Color-conversion settings” (page 474)
• “Soft proofing” (page 475)
• “Color management presets” (page 478)
• “Color management policies” (page 479)
• “Manage colors when opening documents” (page 480)
• “Manage colors when importing and pasting files” (page 481)
• “Manage colors for print” (page 481)
• “Use a safe CMYK workflow” (page 482)
• “Manage colors for online viewing” (page 482)

About color management

This section provides answers to the following commonly asked questions about color management:

• “Why don’t colors match?” (page 466)
• “What is color management?” (page 466)
• “Why do I need color management?” (page 466)
• “How do I get started with color management?” (page 467)
• “Is my monitor displaying the correct colors?” (page 467)
• “Should I assign a color profile or convert colors to a color profile?” (page 467)
• “What is a rendering intent?” (page 467)
Why don’t colors match?

Different tools are used during the process of creating and sharing a document. For example, you may start with a file that was created in another application or import an image that was captured by a digital camera or scanner. After completing the document, you may print it or email it to a colleague for review. Each of the tools that you use in your workflow has a different way of interpreting color. In addition, each tool has its own range of available colors, called a color space, which is a set of numbers that define how each color is represented.

In other words, when defining and interpreting color, each tool speaks a unique language. Consider a color in the color space of your digital camera: a vivid blue RGB color with the values Red = 0, Green = 0, and Blue = 255. This color may appear as a different color in the color space of your monitor. In addition, the color space of your printer may not contain a match for this color. As a result, when your document moves through the workflow, this vivid blue color gets lost in the translation and is not accurately reproduced. A color management system is designed to improve the communication of color in the workflow so that the color of the output matches your intended color.

What is color management?

Color management is a process that lets you predict and control color reproduction, regardless of the source or destination of the document. It ensures a more accurate color representation when a document is viewed, modified, shared, exported to another format, or printed.

A color management system, also known as a color engine, uses color profiles to translate the color values from one source to another. For example, it translates the colors that are displayed on the monitor into the colors that a printer can reproduce. Color profiles define the color space of monitors, scanners, digital cameras, printers, and the applications that you use to create or edit documents.

Why do I need color management?

If your document requires accurate color representation, you may want to learn more about color management. The complexity of your workflow and the ultimate destination of your documents are also important considerations. If your documents are destined only for online viewing, color management may not be as important. However, if you plan to open documents in another application or if you are creating documents for print or multiple types of output, then proper color management is essential.
Color management lets you do the following:

- reproduce colors consistently across your workflow, especially when opening documents that were created in other applications
- reproduce colors consistently when sharing files with others
- preview (or “soft-proof”) colors before they are sent to their final destination, such as a printing press, a desktop printer, or the web
- reduce the need to adjust and correct documents when sending them to different destinations

A color management system does not offer identical color matching, but it greatly improves color accuracy.

**How do I get started with color management?**

Here are some suggestions for adding color management to your workflow:

- Make sure that your monitor is displaying the correct colors. For more information, see “Is my monitor displaying the correct colors?” on page 467.
- Install color profiles for any input or output devices that you are planning to use. For more information, see “Install, load, and embed color profiles” on page 472.
- Become familiar with the color management features of CorelDRAW. The default settings for color management produce good color results, but you can change these default settings so that they suit your specific workflow. For more information, see “Get started with color management” on page 469.
- Soft-proof documents to preview final results on-screen. For more information, see “Soft proofing” on page 475.
- Embed color profiles when saving and exporting files. In this way, you help ensure color consistency when the files are viewed, modified, or reproduced. For more information, see “Install, load, and embed color profiles” on page 472.

**Is my monitor displaying the correct colors?**

Calibrating and profiling the monitor are essential steps for ensuring color accuracy. When you calibrate a monitor, you set it to display colors according to an established standard of accuracy. After calibration, you can create a color profile of the monitor, which describes how the monitor interprets colors. This custom color profile is usually installed in your operating system by the profiling software, so it can be shared with other devices and applications. Calibration and profiling work together to achieve color accuracy: If a monitor is incorrectly calibrated, its color profile is not useful.

Calibration and profiling are complex and usually require third-party calibration devices, such as colorimeters and specialized software. Furthermore, improper calibration may do more harm than good. You can learn more about monitor calibration and custom color profiles by researching color management techniques and products. You can also refer to the documentation that was provided with your operating system or monitor.

How you perceive the color that your monitor displays is also important for managing color consistency. Your perception is influenced by the environment in which you are viewing the documents. Here are some ways to create a suitable viewing environment:

- Ensure that your room has a consistent flow of light. For example, if the room is filled with sunlight, use a shade, or if possible, work in a room without windows.
- Set the monitor background to a neutral color, such as gray, or apply a grayscale image. Avoid using colorful wallpapers and screensavers.
- Don’t wear bright clothing that can clash with the display of colors on the monitor. For example, wearing a white shirt reflects onto the monitor and alters your perception of color.

**Should I assign a color profile or convert colors to a color profile?**

When you assign a color profile, the color values, or numbers, in the document do not change. Instead, the application uses the color profile to interpret the document colors. However, when you convert colors to another color profile, the color values in the document change.

The best practice is to choose a suitable color space when you create a document and to use the same color profile throughout your workflow. You should avoid assigning color profiles and converting colors to other color profiles while working on a document. For more information, see “Assign color profiles” on page 473 and “Convert colors to other color profiles” on page 474.

**What is a rendering intent?**

A color management system can perform effective translation of document colors to multiple devices. However, when converting colors from one color space to another, a color management system may be unable to match certain colors. This translation failure occurs because some colors in the source may not fit within the range (or gamut) of the destination color space. For example, the bright red
and blue colors that you see on your monitor are often outside the gamut of colors that your printer can produce. These “out-of-gamut” colors can dramatically change the look of the document, depending on how they are interpreted by the color management system. Each color management system has four methods of interpreting out-of-gamut colors and mapping them into the gamut of the destination color space. These methods are known as “rendering intents.” The choice of a rendering intent depends on the graphical content of the document.

Many colors in an sRGB document may be out of gamut for the U.S. Web Coated (SWOP) v2 color space. The out-of-gamut colors are mapped into gamut according to the rendering intent.

The following rendering intents are available:

- The **Relative colorimetric** rendering intent is suitable for logos or other graphics that contain only a few out-of-gamut colors. It matches the out-of-gamut source colors with the closest in-gamut colors at the destination. This rendering intent causes the white point to shift. If you print on white paper, the whiteness of the paper is used to reproduce the white areas of the document. Therefore, this rendering intent is a good option if your document will be printed.

- The **Absolute colorimetric** rendering intent is suitable for logos, or other graphics, that require very precise colors. If no match is found for the source colors, then the closest possible match is used. The Absolute colorimetric and Relative colorimetric rendering intents are similar, but the Absolute colorimetric rendering intent preserves the white point through the conversion and does not adjust for the whiteness of the paper. This rendering intent is used mainly for proofing.
• The **Perceptual** rendering intent is suitable for photographs and bitmaps that contain many out-of-gamut colors. The overall color appearance is preserved by changing all the colors, including the in-gamut colors, to fit within the range of colors at the destination. This rendering intent maintains the relationships between colors to produce the best results.

• The **Saturation** rendering intent produces more concentrated solid colors in business graphics, such as charts and graphs. Colors may be less accurate than those produced by other rendering intents.

The number of out-of-gamut colors (indicated by the green overlay) may influence your choice of a rendering intent.

Left: The Relative colorimetric rendering intent is suitable for this photo, which contains only a few out-of-gamut colors.
Right: The Perceptual rendering intent is a good choice for this photo, which contains many out-of-gamut colors.

Get started with color management

CorelDRAW has two types of color management settings: default settings for color management and document color settings. The default settings for color management control the colors of new documents and any documents that do not contain color profiles (also known as “untagged documents”). Documents that were created in earlier versions of CorelDRAW are treated as untagged. Document color settings affect only the colors of the active document.

**Default settings for color management**

The default settings for color management are essential for producing consistent colors.

• **Preset** — If you are new to color management and create designs for a specific output, you can choose a preset to help you get started with the right color management settings such as default color profiles and color-conversion settings. Examples are the North America Prepress preset, which is suitable for projects to be printed by North American print service providers, and the Europe Web preset, which is suitable for web projects that are created in Europe. For more information about color management presets, see “Color management presets” on page 478.

• **Default color profiles** — define the RGB, CMYK, and grayscale colors in new and untagged documents. You can change these settings so that all new documents use the color profiles that you specify. In some applications, default color profiles are called “working space profiles.”

• **Primary color mode** — determines the document color palette that is displayed when you open or start a document as well as the default color mode of a document that is exported as a bitmap. The primary color mode is set for all new and untagged documents, but you can change this setting for the active document on the Document tab of the Color management settings dialog box. Note that the primary color mode does not limit colors in a CorelDRAW document to a single color mode.

• **Rendering intent** — lets you choose a method for mapping out-of-gamut colors in new and untagged documents. If the default rendering intent is not suitable for the active document, you can change it on the Document tab of the Color Management settings dialog box. For information about choosing the right rendering intent for your projects, see “What is a rendering intent?” on page 467.
• **Color conversion** — controls how colors are matched when you are converting colors from one color profile to another. For example, you can change the color engine or specify options for converting pure black colors in RGB, CMYK, Lab, or Grayscale documents. For more information, see “Color-conversion settings” on page 474.

• **Open policy** — manages colors in files that you open. For more information about color management policies, see “Color management policies” on page 479.

• **Import and Paste policy** — manages colors in files that you import or paste in an active document. For more information about color management policies, see “Color management policies” on page 479.

• **Spot color definition** — lets you display spot colors by using their Lab, CMYK, or RGB color values. These alternative color values are also used when spot colors are converted to process colors.

![Default tab of the Color Management Settings dialog box.](image)

**Document color settings**

You can view and edit the color settings of the active document, without affecting new and untagged documents. You can see what color profiles are assigned to the document, which determines the document color space for RGB, CMYK, and grayscale colors.

You can also assign different color profiles to the active document. For information about assigning color profiles, see “Assign color profiles” on page 473. For information about converting document colors to other color profiles, see “Convert colors to other color profiles” on page 474.
In addition, you can change the primary color mode and rendering intent for the active document.

To access default settings for color management
1 Click Tools ➤ Color Management.
2 Click the Default tab.

To change the default color profiles
1 Click Tools ➤ Color Management.
2 Click the Default tab.
3 Choose a color profile from the following list boxes:
   • RGB profile — describes RGB colors in new and untagged documents
   • CMYK profile — describes CMYK colors in new and untagged documents
   • Grayscale profile — describes grayscale colors in new and untagged documents

You can also

Change the primary color mode
Choose a color mode from the Primary color mode list box.
Changing the primary color mode on the Default tab of the Color management settings dialog box does not affect the active document.

Change the rendering intent
Choose a rendering intent from the Rendering intent list box.
To access document color settings
1. Click Tools ▶ Color Management.
2. Click the Document tab.

To display the color profiles that are used in the active document on the status bar, click the flyout button on the status bar, and choose Document Color Settings.

Install, load, and embed color profiles

To ensure color accuracy, a color management system needs ICC-compliant profiles for monitors, input devices, external monitors, output devices, and documents.

- Monitor color profiles — define the color space that is used by your monitor to display document colors. CorelDRAW uses the primary monitor profile that is assigned by the operating system. The monitor profile is very important for color accuracy. For more information, see “Is my monitor displaying the correct colors?” on page 467.
- Input device color profiles — used by input devices such as scanners and digital cameras. These color profiles define which colors can be captured by specific input devices.
- Display color profiles — include monitor profiles that are not associated with your monitor in the operating system. These color profiles are especially useful for soft-proofing documents for monitors that are not connected to your computer.
- Output device color profiles — define the color space of output devices such as desktop printers and printing presses. The color management system uses these profiles to map accurately document colors to the colors of the output device.
- Document color profiles — define the RGB, CMYK, and grayscale colors of a document. Documents that contain color profiles are known as “tagged.”

Finding color profiles

Many color profiles are installed with your application or can be generated with profiling software. Manufacturers of monitors, scanners, digital cameras, and printers also provide color profiles. In addition, you can access color profiles from websites such as:

- [http://www.color.org/findprofile.xalter](http://www.color.org/findprofile.xalter) — This website of the International Color Consortium (ICC) can help you find commonly used standard color profiles.
- [http://www.eci.org/doku.php?id=en:downloads](http://www.eci.org/doku.php?id=en:downloads) — This website of the European Color Initiative (ECI) provides standard ISO profiles as well as profiles that are specific to Europe
- [http://www.tftcentral.co.uk/articles/icc_profiles.htm](http://www.tftcentral.co.uk/articles/icc_profiles.htm) — This website provides ICC profiles for many different types of LCD (Liquid Crystal Display) monitors to help you display consistent colors. However, if color accuracy is essential for your workflow, you should calibrate and profile your monitor instead of relying on readily available monitor profiles. For more information, see “Is my monitor displaying the correct colors?” on page 467.

Installing and loading color profiles

If you don’t have the necessary color profile, you can install it, or you can load it within the application. Installing a color profile adds it to the Color folder of the operating system; loading a color profile adds it to the Color folder of the application. CorelDRAW Graphics Suite can access color profiles from both Color folders.

Embedding color profiles

When you save or export a document to a file format that supports color profiles, the color profiles are embedded in the file by default. Embedding a color profile attaches the color profile to the document to ensure that the same colors you used are shared with anyone who views or prints the document.

To install a color profile

- In Windows Explorer, right-click a color profile, and click Install profile.
To load a color profile
1 Click Tools ▶ Color Management.
2 Click the Default tab.
3 Choose Load color profiles from the RGB profile, CMYK profile, or Grayscale profile list boxes.
4 In the Open dialog box, navigate to the color profile.

After you load a color profile, you can also access it from the Color Proofing docker, Print dialog box, and Document tab of the Color Management settings dialog box.

Note that you can load a color profile of any color mode from any list box: RGB profile, CMYK profile, or Grayscale profile. However, after you load the profile, you can access it only from the list box of the respective color mode. For example, you can load an RGB color profile from the CMYK profile list box, but you can access the profile only from the RGB profile list box.

You can also load a color profile from the Document tab of the Color Management settings dialog box.

To embed a color profile
1 Click File, and then click one of the following commands:
   - Save as
   - Export
   - Export For ▶ Web
2 In the dialog box that appears, enable the Embed color profiles check box.

When you save or export a file to the CorelDRAW (CDR) or Adobe Portable Document Format (PDF) file format, you can embed up to three color profiles.

Embedding a color profile increases the file size of a document. To avoid increasing the file size unnecessarily, CorelDRAW embeds only color profiles for colors that are used in the document. For example, if your document contains only RGB objects, only the RGB color profile will be embedded.

Assign color profiles

When you open or import a document that is missing a color profile, by default the application automatically assigns a color profile to the document. If the document has a color profile that is not suitable for the required destination, you can assign a different color profile to the document. For example, if the document is intended to be displayed on the web or to be printed on a desktop printer, you should make sure that sRGB is the document RGB profile. If the document is destined for print production, the Adobe RGB (1998) profile is a better choice, because it has a larger gamut and produces good results when RGB colors are converted to a CMYK color space.

When you assign a different color profile to a document, the colors may appear different, although the color values do not change.
To assign color profiles to a document

1. Click **Tools** ➤ **Color Management**.
2. Click the **Document** tab.
3. Enable the **Assign new (preserves color values)** option.
4. Choose color profiles from the **RGB**, **CMYK**, and **Grayscale** list boxes.

**Convert colors to other color profiles**

When you convert document colors from one color profile to another, the color values in the document are changed according to the rendering intent, but the appearance of colors is preserved. The main purpose of converting colors is to match the appearance of colors in the source color space as closely as possible to colors in the destination color space.

Because multiple color conversions deteriorate accuracy, it is recommended that you convert colors only once. Wait until the document is ready and you are sure of the color profile that will be used for the final output. For example, if you designed a document in the Adobe RGB (1998) color space, and the document will be posted on the web, you can convert document colors to the sRGB color space.

You can choose the color management engine that is used for converting colors. For more information, see "Color-conversion settings" on page 474.

To convert colors to other color profiles

1. Click **Tools** ➤ **Color Management**.
2. Click the **Document** tab.
3. Enable the **Convert (preserve color appearance)** option.
4. Choose a color profile from the **RGB**, **CMYK**, and **Grayscale** list box.
5. Choose a suitable rendering intent from the **Rendering intent** list box. For information about the available rendering intents, see "What is a rendering intent?" on page 467.

**Color-conversion settings**

When you choose color profiles, colors are matched between devices as closely as possible by the color management module (CMM) of the Microsoft Image Color Management (ICM), which is the default CMM. Color management modules are also known as “color engines.”

You can also use the Adobe CMM if it is installed on your computer.
Handling pure black and grayscale colors

You can preserve pure black color in the destination color space during color conversion. For example, if you are converting an RGB document to a CMYK color space, pure RGB black (R=0, G=0, B=0) can be mapped to pure black CMYK colors (K=100). This option is recommended for grayscale documents or documents that contain mostly text. Note that preserving pure black during color conversion may create solid edges of black in effects and gradient fills that contain black.

By default, grayscale colors are converted to the CMYK black (K) channel. This process ensures that all grayscale colors print as shades of black, and no cyan, magenta, and yellow inks are wasted during printing.

To choose color-conversion settings

1. Click Tools ➤ Color Management.
2. Click the Default tab.
3. In the Color conversion area, choose a color engine from the Color engine list box.

You can also

Do the following

Keep pure black in the source color space as pure black in the destination color space

Enable the Preserve pure black check box.

Map grayscale colors to CMYK black during conversion

Enable the Map gray to CMYK black check box.

Soft proofing

Soft proofing provides an on-screen preview of a document as it will appear when it is reproduced by a specific printer or displayed on a specific monitor. Unlike the “hard-proofing” technique that is used in a traditional printing workflow, soft proofing lets you look at the final result without committing ink to paper. You can verify whether the color profile of the document is suitable for a specific printer or monitor and avoid unwanted results.

To simulate the output colors that are produced by a device, you need to choose the color profile of the device. Because the color spaces of the document and device are different, some document colors may not have matches in the gamut of the device color space. You can enable the gamut warning, which lets you preview the on-screen colors that cannot be reproduced accurately by the device. When the gamut warning is enabled, an overlay highlights all the out-of-gamut colors for the device that you are simulating. You can change the color of the out-of-gamut overlay, and you can also make it more transparent to see the underlying colors.
The gamut warning highlights colors that a printer or monitor cannot reproduce accurately.

You can change how out-of-gamut colors are brought into the gamut of the proof profile by changing the rendering intent. For more information, see “What is a rendering intent?” on page 467.

You can preserve the RGB, CMYK, or grayscale color values of the document when soft-proofing. For example, if you are soft-proofing a document to be printed to a printing press, you can keep the original document CMYK color values in the soft proof. In this case, all colors will be updated on-screen, but only the RGB and grayscale color values of the document will be changed in the soft proof. Preserving the CMYK color values can help you prevent unwanted color conversions in the final output.

If you often need to soft-proof documents for a specific output, you can create and save custom proof presets. You can delete the presets that you no longer need at any time.

You can save soft proofs by exporting them to the JPEG, TIFF, Adobe Portable Document Format (PDF), or Corel PHOTO-PAINT (CPT) file format. You can also print proofs.

By default, soft proofing is disabled when you start a new document or when you open a document. However, you can make sure that soft proofing is turned on by default at all times.

**To turn soft proofing on or off**

- Click View ➔ Proof Colors.

When you turn soft proofing on, colors in the document window, color palettes, and preview windows of dialog boxes appear different.

Simulating printer output may cause on-screen colors to appear dull because all colors are brought into a CMYK color space, which has a smaller gamut than an RGB color space.

You can also enable or disable soft proofing by clicking the **Proof colors** button on the status bar.

**To specify soft-proof settings**

1. Click Window ➔ Dockers ➔ Color Proofing.
2. Perform any of the following tasks.
To 

Do the following

Simulate the output of a specific device

From the Simulate environment list box, choose the color profile of the device.

Keep specific color values unchanged

Enable the Preserve numbers check box.

Depending on the color profile in the Simulate environment box, the check box lets you preserve CMYK, RGB, or grayscale color values.

Change the rendering intent

Choose a rendering intent from the Rendering intent list box.

Enable the gamut warning

Enable the Proof colors check box, then in the Gamut warning area, enable the Out-of-gamut colors check box.

Change the color of the out-of-gamut overlay

In the Gamut warning area, choose a color from the color picker.

Change the transparency of the out-of-gamut overlay

In the Gamut warning area, type a value in the Transparency box. The value should be between 1 and 100.

Save a custom proof preset

Choose the settings that you want, click the Save button, and then type a name in the Save preset as box. Out-of-gamut settings are not included in the proof preset.

Choose a proof preset

From the Proof preset list box, choose a preset.

Delete a proof preset

Click the Delete button.

The accuracy of the simulation depends on factors such as the quality of your monitor, the color profile of the monitor and the output device, and the ambient lighting in your work area.

To export a soft proof

1  Click Window  Dockers  Color Proofing.
2  In the Color Proofing docker, click the Export soft proof button.
3  Type a filename in the File name box.
4  From the Save as type list box, choose one of the following options:
   • JPG - JPEG Bitmaps
   • PDF - Adobe Portable Document Format
   • TIF - TIFF Bitmap
   • CPT - Corel PHOTO-PAINT image
5  Choose any settings in the dialog box that appears.
To print a proof
1. Click **Window** ➔ **Dockers** ➔ **Color Proofing**.
2. In the **Color Proofing** docker, click the **Print proof** button.

To turn soft proofing on by default
1. Click **Tools** ➔ **Options** ➔ **CorelDRAW**.
2. In the list of categories, click **Display**.
3. Enable the **Proof colors** check box.

**Color management presets**

The application provides color management presets, which are default color settings that are applied to new and untagged documents. You can choose a color management preset that is suitable for the geographic region where a document is created or for the location of its final output.

You can also create your own presets, which allows you to retain your selections on the **Default** tab of the **Color management settings** dialog box and reuse them in other documents. If you no longer need a preset, you can delete it.

**To choose a color management preset for new documents**
1. Click **Tools** ➔ **Color Management**.
2. Click the **Default** tab.
3. Choose one of the following color management presets from the **Preset** list box:
   - **North America General Purpose** — suitable for designs that will be used in multiple types of output in North America
   - **Europe General Purpose** — suitable for designs that will be used in multiple types of output in Europe
   - **Europe Prepress** — suitable for designs that will be printed by print service providers in Europe
   - **Europe Web** — suitable for web designs that are created in Europe
   - **Japan General Purpose** — suitable for designs that will be used in multiple types of output in Japan
   - **Japan Prepress** — suitable for designs that will be printed by print service providers in Japan
   - **Japan Web** — suitable for web designs that are created in Japan
   - **Minimal Color Management** — preserves the original RGB, CMYK, and Grayscale color values when opening, importing, or pasting documents
   - **North America Prepress** — suitable for designs that will be printed by print service providers in North America
   - **North America Web** — suitable for web designs that are created in North America
   - **Simulate Color Management Off** — produces the color-conversion results of the **Color Management Off** preset that is available in earlier versions of CorelDRAW
   - **Simulate CorelDRAW Graphics Suite X4** — displays colors as they appear in CorelDRAW Graphics Suite X4

**To add a color management preset**
1. Click **Tools** ➔ **Color Management**.
2. Click the **Default** tab.
3. Change any default color settings.
4. Click the **Save** button ➔ next to the **Preset** list box.
5. In the **Save color management style** dialog box, type a name in the **Save style as** box.
To delete a color management preset

1. Click **Tools ▶ Color Management**.
2. Click the **Default** tab.
3. Choose a preset from the **Preset** list box.
4. Click the **Delete** button.

Color management policies

Color management policies determine how colors are managed in documents that you open and work with in an application. In CorelDRAW, you can set one color-management policy for opening documents and another for importing and pasting files and objects in the active document.

The color management policy for opening files determines what RGB, CMYK, and Grayscale color profiles are used in each file you want to open. By default, the application uses the color profiles embedded in the file. You can also choose to assign the default color profiles to the file or convert colors in the file to the default color profiles.

By default, the color management policy for importing and pasting files converts the RGB and Grayscale colors of the files to the document color profiles, and assigns the document CMYK color profile to files in the CMYK mode. You can also choose to assign the document color profiles to the file, or convert the colors of the active document to the color profiles that are embedded in the file.

The files that you are opening or importing may be missing color profiles, or may contain color profiles that do not match the default color profiles. By default, the application does not warn you about missing or mismatched color profiles but makes color management choices that produce good results. However, you can activate warning messages if you want to have full control over the colors in your documents.

To set a color management policy for opening documents

1. Click **Tools ▶ Color Management**.
2. Click the **Default** tab.
3. In the **Open policy** area, choose one of the following options from the **RGB** list box:
   - **Use embedded color profile** — preserves the RGB color profile that is embedded in the file. This option is recommended, because it preserves the original RGB color appearance and RGB color values of the document.
   - **Assign default color profile** — uses the default RGB color profile to define document colors. RGB color values are preserved, but the appearance of RGB colors may change.
   - **Convert to default color profile** — converts colors to the default RGB color profile. The appearance of RGB colors in documents is preserved, but the color values may change.
4. From the **CMYK** list box in the **Open policy** area, choose an option for managing CMYK colors in documents. The options are the same as the options that are available for RGB colors.
5. From the **Grayscale** list box in the **Open policy** area, choose an option for managing the grayscale colors in documents. The options are the same as the options that are available for RGB colors.

To set a color management policy for importing and pasting files

1. Click **Tools ▶ Color Management**.
2. Click the **Default** tab.
3. In the **Import and Paste policy** area, choose one of the following options from the **RGB** list box:
   - **Convert to document color profile** — converts the RGB colors of the imported or pasted file to the RGB color profile of the active document. This option is used when the imported file contains a color profile that does not match the color profile of the document.
   - **Assign document color profile** — assigns the RGB color profile of the document to the imported or pasted file. The RGB color values of the file are preserved but the color appearance may change.
• **Use embedded color profile** — uses the RGB color profile that is embedded in the file, preserving the RGB color values and appearance of the imported or pasted file. This option converts document colors to the color profile that is embedded in the imported or pasted file.

4 From the CMYK list box in the **Import and Paste policy** area, choose an option for managing CMYK colors in imported and pasted files. The options are the same as the options that are available for RGB colors.

5 From the Grayscale list box in the **Import and Paste policy** area, choose an option for managing the grayscale colors in imported and pasted files. The options are the same as the options that are available for RGB colors.

**To activate warning messages for missing and mismatched color profiles**

1 Click **Tools** ➤ **Color Management**.

2 Click the **Default** tab.

3 Enable any of the following check boxes in the **Open policy** and **Import and paste policy** areas:
   • Warn on color profile mismatch
   • Warn on missing color profile

**Manage colors when opening documents**

The default color management policy for opening documents preserves colors in all tagged documents that you open and assigns the default color profiles to untagged documents.

If a document that you open is missing a color profile or contains color profiles that do not match the default color profiles of the application, CorelDRAW makes color-management choices based on the color management policy. If you are comfortable with color management, you can view warnings about missing and mismatched color profiles and choose different color management options. For more information about how to activate warnings, see “To activate warning messages for missing and mismatched color profiles” on page 480.

**Opening documents with missing color profiles**

The document you are opening may support one or multiple color modes and therefore be missing one or more color profiles. For example, a CorelDRAW (CDR) or PDF document may contain three types of objects: RGB, CMYK, and Grayscale, so up to three color profiles may be missing from such a document.

The following options are available when you are opening a document with a missing color profile and have activated warnings for missing color profiles.

• **Assign color profile** — lets you assign a color profile to the document. This option preserves color values, but may change the appearance of colors. For example, if the RGB color profile is missing from the document, the default RGB color profile of the application is assigned by default. The RGB color values are preserved but the RGB colors may not appear as originally designed. You can also choose to assign a color profile that is different from the default color profile of the application. This option is recommended only if you know the original color space of the document and have the associated color profile installed.

• **Convert to default color profile** — Used in conjunction with the **Assign color profile** control, this option converts colors from the assigned color profile to the default color profile. Colors will appear as they would in the assigned color space, but the color values may change.

**Opening documents with mismatched color profiles**

When a document contains a color profile that does not match the default color profile, you can choose one of the following options:

• **Use embedded color profile** — This option ensures that the color values are preserved and colors are displayed as originally intended.

• **Ignore embedded color profile, and use default color profile** — Assigning the default color profile will preserve the color values but may change the appearance of colors.

• **Convert from embedded color profile to default color profile** — This option converts colors from the embedded color profile to the default color profile. The appearance of colors will be preserved, but the color values may change. This option is recommended if you have already set color management options suitable for your workflow. For example, you may be creating graphics for the web, and you may have chosen sRGB as the application default color space. Enabling this option ensures that the document uses the sRGB color space, and document colors are consistent and suitable for the web.
Opening documents with missing and mismatched color profiles

Documents that support multiple color modes can be missing color profiles and contain mismatched color profiles at the same time. For example, a document that contains RGB, Grayscale, and CMYK objects may be missing an RGB profile and may have a mismatched CMYK color profile. In such cases, you are presented with warning dialog boxes that include options for missing and mismatched color profiles.

Manage colors when importing and pasting files

The default color policy for importing and pasting files converts the colors of imported and pasted files to the color profile of the active document. If the color profile of the imported or pasted file matches the color profile of the active document, no color conversion is performed. For more information about color management policies, see “Color management policies” on page 479.

However, you can choose to view warnings about missing and mismatched profiles and set other color management options. For more information about how to view warnings, see “To activate warning messages for missing and mismatched color profiles” on page 480.

Importing and pasting files with missing color profiles

If color profiles are missing from a file, you can choose to assign specific color profiles to the file, and then convert its colors to the document color profiles. The color values of the file will change.

Importing and pasting files with mismatched color profiles

If a file contains color profiles that do not match the document color profile, the following options are available:

- **Ignore embedded color profile, and assign the document color profile** — Color values are preserved, but the appearance of colors may change.
- **Convert from embedded color profile to the document color profile** (default option) — The color of the imported file are converted from the embedded color space to the document color space. The appearance of colors is preserved, but the color values may change.
- **Convert document colors to embedded color profile** — Document colors are converted to the color profile embedded in the imported file. The appearance and color values of the imported or pasted file are preserved.

Importing and pasting files with missing and mismatched color profiles

Some files can be missing color profiles and contain mismatched color profiles at the same time. In such cases, you are presented with dialog boxes that include options for missing and mismatched color profiles.

Manage colors for print

By default, CorelDRAW does not perform color conversions when a document is sent to the printer. The printer receives the color values and interprets the colors. However, if there is a color profile associated with the printer in the operating system, CorelDRAW detects the color profile and uses it to convert document colors to the color space of the printer.

If you have a PostScript printer, you can let CorelDRAW or the PostScript printer perform any necessary color conversion. When CorelDRAW manages the color conversion, document colors are converted from the assigned color space to the color space of the PostScript printer. Note that you must disable color management in the printer driver. Otherwise, both application and printer manage colors during printing, and document colors are corrected twice, which causes unwanted color shifts.

When the PostScript printer converts document colors, the color management feature must be enabled in the printer driver. Only PostScript printers and RIP engines that support printer color conversions can be used in this advanced method. Although it increases the file size, this method has the advantage of ensuring consistent colors when you send the same print job to different print service providers.

For more information about reproducing colors for print, see “Print colors accurately” on page 830.

You can also manage colors in PDF files that you create for commercial printing. For more information, see “PDF color management options” on page 902.
Use a safe CMYK workflow

Often, you may use specific CMYK color values in your projects. To ensure reliable color reproduction, you may obtain these CMYK color values from a color swatch book. By preserving these CMYK color values throughout the printing process, you can help prevent unwanted color conversions and ensure that colors are reproduced as they appeared in the original design. A workflow that preserves the CMYK color values is known as a “safe” CMYK workflow.

CorelDRAW supports a safe CMYK workflow. By default, CMYK color values are preserved in any document that you open, import, or paste. Also, CMYK color values are preserved by default when you print documents.

In some cases, you may want to bypass the safe CMYK workflow and preserve the appearance of CMYK colors when you open, import, or paste documents. This option is useful when you want to see the original colors of a design on-screen, or view a copy that is printed to a desktop printer. To preserve the appearance of CMYK colors, you can set color management policies that convert CMYK colors in documents that you open, import, or paste. In addition, when printing to a PostScript printer, you can convert CMYK colors to the printer color profile by disabling the Preserve CMYK numbers check box on the Color page of the Print dialog box.

Manage colors for online viewing

Managing colors for online viewing can be even more complex than managing colors for print. Documents and images on the web are displayed on a great variety of monitors, which are often uncalibrated. In addition, most web browsers do not support color management and ignore the color profiles that are embedded in files.

When you design documents for exclusive web use, it is recommended that you use the sRGB color profile as your document RGB color profile and choose RGB colors. If a document contains a different color profile, you should convert document colors to sRGB before saving the document for use on the web.

When you create a PDF file for online viewing, you can embed color profiles in the file to reproduce colors consistently in Adobe Reader and Adobe Acrobat. For more information, see “To specify color management options for exporting PDF files” on page 902.

When you start a new document that is destined for online viewing, you can choose a preset that can help you achieve good color results. For more information, see “To start a drawing” on page 63. In addition, CorelDRAW offers color management presets for web documents. For information about how to choose a color management preset, see “To choose a color management preset for new documents” on page 478.
Special effects

Vector and bitmap effects................................................................................................................................................................... 485
Special effects categories..................................................................................................................................................................... 499
Lenses..................................................................................................................................................................................................547
Add 3D effects.................................................................................................................................................................................... 551
Mosaics................................................................................................................................................................................................579
Add movement and focus................................................................................................................................................................... 587
Vector and bitmap effects

CorelDRAW includes a wide range of effects that you can apply to objects, object groups, or image areas. Effects are applied nondestructively, so you can add, edit, remove, show or hide them, and revert to the original object or image at any point.

This section includes the following topics:
- “Bitmap effects” (page 485)
- “Vector effects” (page 489)
- “Apply bitmap effects” (page 491)

Bitmap effects

Bitmap effects are pixel-based. You can apply bitmap effects both to vector and bitmap objects. In the application user interface (UI), bitmap effects are listed in the top part of the Effects menu.
Bitmap effects are organized into the following categories.

<table>
<thead>
<tr>
<th>Category</th>
<th>Apply to</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust</td>
<td>Bitmap objects</td>
<td>Lets you adjust the color and tone of bitmaps. For more information about the effects in this category, see “Adjust color and tone” on page 785, “Tone Curve”</td>
</tr>
<tr>
<td>Category</td>
<td>Apply to</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Color Transform</td>
<td>Vector and bitmap objects</td>
<td>Lets you create photographic illusions by using color reduction and replacements. Effects include “Bit planes” on page 519, “Halftone” on page 519, “Psychedelic” on page 520, and “Solarize” on page 520.</td>
</tr>
<tr>
<td>Category</td>
<td>Apply to</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contour</td>
<td>Vector and bitmap objects</td>
<td>Lets you highlight and enhance the edges of an image. Effects include “Edge detect” on page 521, “Find edges” on page 521, “Trace contour” on page 521, and “Local Equalization” on page 522.</td>
</tr>
<tr>
<td>Correction</td>
<td>Bitmap objects</td>
<td>Lets you remove small imperfections and sharpen images. Effects include “Remove dust and scratch marks from bitmaps” on page 777, and “Sharpen images” on page 777.</td>
</tr>
<tr>
<td>Custom</td>
<td>Vector and bitmap objects</td>
<td>Lets you apply a wide range of effects to your image. For example, you can add texture and patterns to an image (Bump-map effect). Effects include “Band pass” on page 529, “Bump map” on page 529, and “User defined” on page 529.</td>
</tr>
<tr>
<td>Category</td>
<td>Apply to</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Sharpen</td>
<td>Vector and bitmap objects</td>
<td>Lets you add a sharpening effect to focus on and enhance edges. Effects include “Adaptive unsharp” on page 538, “Directional sharpen” on page 539, “High pass” on page 539, “Sharpen” on page 540, and “Unsharp mask” on page 540.</td>
</tr>
<tr>
<td>Texture</td>
<td>Vector and bitmap objects</td>
<td>Lets you add texture to an image by simulating a variety of surfaces, such as cobblestone, elephant skin, plastic, and relief sculpture. Effects include “Brick wall” on page 540, “Bubbles” on page 541, “Canvas” on page 541, “Cobblestone” on page 542, “Elephant skin” on page 542, “Etching” on page 542, “Plastic” on page 543, “Plaster wall” on page 543, “Relief sculpture” on page 544, “Screen door” on page 544, “Stone” on page 544, and “Underpainting” on page 545.</td>
</tr>
<tr>
<td>Transform</td>
<td>Bitmap objects</td>
<td>Lets you transform the color and tone of an image. Effects include Deinterlace, Invert colors, and Posterize. For more information, see “Transform color and tone” on page 795.</td>
</tr>
<tr>
<td>Plug-ins</td>
<td>Vector and bitmap objects</td>
<td>Lets you use a third-party filter to apply effects to bitmaps in CorelDRAW. An installed plug-in appears at the bottom of the Bitmaps menu.</td>
</tr>
</tbody>
</table>

To browse the bitmap effects that are available in the application, see “Special effects categories” on page 499.

For more information on working with bitmap effects, see “Apply bitmap effects” on page 491.

**Vector effects**

There are two types of vector effects: effects, such as bevels, blends, contours, and extrusions, which can be applied only to vector objects; and effects, such as envelopes, drop shadows, inner shadows, block shadows, lenses, perspective, and mosaics, which can be applied to both vector and bitmap objects.
A vector effect (drop shadow) is applied to a bitmap (left) and vector object (right).

The following table provides a quick reference of vector effects.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Apply to</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bevel</td>
<td>Vector objects</td>
<td>Lets you add 3D depth to a graphic or text object by making its edges appear sloped (cut at an angle)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, see “Create bevel effects” on page 562.</td>
</tr>
<tr>
<td>Blend</td>
<td>Vector objects</td>
<td>Lets you create a progression in shape and size from one object to another. Blends are often used for creating realistic shadows and highlights</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in objects.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, see “Blend objects” on page 573.</td>
</tr>
<tr>
<td>Block shadow</td>
<td>Vector and bitmap objects</td>
<td>Lets you add solid shadows to objects and text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, see “Add block shadows” on page 569.</td>
</tr>
<tr>
<td>Contour</td>
<td>Vector objects</td>
<td>Lets you create 3D effects and cuttable outlines for outputting to devices such as plotters, engraving machines and vinyl cutters</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, see “Contour objects” on page 551.</td>
</tr>
<tr>
<td>Drop shadow and inner shadow</td>
<td>Vector and bitmap objects</td>
<td>Lets you add solid shadows to objects and text</td>
</tr>
<tr>
<td>Effect</td>
<td>Apply to</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Envelope</td>
<td>Vector and bitmap objects</td>
<td>Lets you shape objects. For more information, see “Shape objects by using envelopes” on page 243.</td>
</tr>
<tr>
<td>Extrusion</td>
<td>Vector objects</td>
<td>Lets you make objects appear three-dimensional. For more information, see “Create extrusions” on page 558.</td>
</tr>
<tr>
<td>Impact</td>
<td>n/a</td>
<td>Lets you add perspective or bring focus to a design element. For more information, see “Impact effects” on page 587.</td>
</tr>
<tr>
<td>Lens</td>
<td>Vector and bitmap objects</td>
<td>Lets you change how an object area beneath the lens appears, not the actual properties and attributes of objects. For more information, see “Apply lenses” on page 547.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Vector and bitmap objects</td>
<td>Lets you create the illusion of distance and depth. For more information, see “Apply perspective” on page 555.</td>
</tr>
<tr>
<td>PhotoCocktail™</td>
<td>Vector and bitmap objects</td>
<td>Lets you turn your photos and vector art into mosaics composed of images. For more information, see “Bitmap mosaics (PhotoCocktail effect)” on page 582.</td>
</tr>
<tr>
<td>Pointillizer™</td>
<td>Vector and bitmap objects</td>
<td>Lets you create vector mosaics from vector or bitmap objects. For more information, see “Vector mosaics (Pointillizer effect)” on page 579.</td>
</tr>
</tbody>
</table>

**Apply bitmap effects**

You can choose bitmap effects by using the Effects menus and the FX tab in the Properties docker. To browse the effects that are available in the application, see “Special effects categories” on page 499.
Before you apply an effect, you can customize it. All dialog boxes of bitmap effects have a preview window that allows you to preview your designs in real-time as you adjust the effect settings. You can pan to a new area, zoom in or out, and choose how to display the artwork in the preview window, so you can evaluate the adjustments you make. By default, the application also shows a live preview of the image in the drawing window as you modify the effect settings.

The before and after full (top) and split (bottom) previews are particularly useful to keep track of edits and understand how different settings affect the image.

You can apply a bitmap effect to one or more objects, a group of objects, or an image area.
To apply a bitmap effect to an image area, choose a drawing tool, draw a closed shape to select the area you want, convert the shape to a lens, and then apply an effect to the lens. For more information about using lenses, see “Lenses” on page 547.

Once you apply a bitmap effect, it appears in the Properties docker. The FX tab in the Properties docker is the hub for non-destructive editing, allowing for quick adjustments and unlimited experimentation. You can show and hide special effects, edit applied effects, and apply multiple special effects to the same object. Plus, you can change the order of the applied special effects, and you can delete a special effect. Effects are cumulative; each time you apply an effect, it's stacked on top of the previous effect. On the FX tab, the effects appear in the order in which you apply them, with the most recently added effect at the top of the list. You can also flatten effects to apply changes permanently.

When you apply a bitmap effect to a bitmap object, CorelDRAW automatically adds a border around the bitmap so that the effect covers the entire image. Disabling the automatic inflate option cuts off the effect at the edges of the image. For example, if you apply the Gaussian Blur effect to a rectangle, the corners are cut off.
If you want to use a custom border size, disable automatic inflation, and manually specify the dimensions of the inflated bitmap.

CorelDRAW lets you track, record, and automate special-effects operations. For more information, see “Use macros and scripts to automate tasks” on page 973.

Adding plug-in filters to CorelDRAW provides additional features and effects that you can use to edit images. You can add plug-in filters, and you can remove them when you no longer need them.

To apply a bitmap effect to an object
1. Select a vector or bitmap object.
2. Click Effects, choose an effect category, and click an effect.
3. Adjust any settings.
   To preview your design while adjusting the effect settings, click the Preview button and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan to another area of the image</td>
<td>Using the Pan tool drag the image until the area you want to see is visible.</td>
</tr>
<tr>
<td>Zoom in and out</td>
<td>Using the Zoom in tool or the Zoom out tool, click in the preview window.</td>
</tr>
</tbody>
</table>
To

<table>
<thead>
<tr>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit the image in the preview window</td>
</tr>
<tr>
<td>Click the <strong>Zoom to fit</strong> button 🕵️.</td>
</tr>
<tr>
<td>View the resulting image in a single pane</td>
</tr>
<tr>
<td>Click the <strong>Full preview</strong> button 📀.</td>
</tr>
<tr>
<td>View the original and resulting image in separate panes</td>
</tr>
<tr>
<td>Click the <strong>Before and after full preview</strong> button 📄.</td>
</tr>
<tr>
<td>View the original and resulting image in a single pane</td>
</tr>
<tr>
<td>Click the <strong>Before and after split preview</strong> button 📄 and drag the split view divider in the center of the window to the left or right.</td>
</tr>
</tbody>
</table>

Some effects support only RGB images. If an image is in a color mode that is not supported, the application converts the image to the RGB (24-bit) mode.

To browse the bitmap effects that are available in the application, see “Special effects categories” on page 499.

By default, as you modify the effect settings, the application shows a representation of the adjusted image in the drawing window. To disable the live preview, disable the **Preview** check box.

You can copy effects applied to an object. For more information, see “To copy effects from one object to another” on page 325.

You can change the visibility of the effects applied to an object. For more information, see “To work with bitmap effects” on page 496.

You can also apply an effect to a selected object by doing one of the following:

- Click the **FX** tab of the **Properties** docker (Window ➔ Dockers ➔ Properties), click the **Add effect** button ➔, choose an effect category, and click an effect.
- Click the **Add Effect** button ➔ in the **Objects** docker (Window ➔ Dockers ➔ Objects), choose an effect category, and click an effect.

### To apply a bitmap effect to an image area

1. In the toolbox, click a drawing, rectangle, or ellipse tool.
2. In the document window, draw a closed shape to select an area.
3. Click **Effects ➔ Lens**, and choose **Bitmap Effect** from the list box in the **Lens** docker.
4. Click **Effects**, choose an effect category, and click an effect.

   The effect is applied to the content on all the layers that are beneath the lens.

You can adjust the shape of a lens by using any of the **Edit Shape** and **Curve** tools. For more information about shaping objects, see “Shape objects” on page 213.

   Feather the edges of a lens to make it blend seamlessly into your composition. For more information about feathering, see “Feather object edges” on page 315.

   You can apply multiple effects to a lens. Click the **Add effect** button ➔ on the **FX** tab of the **Properties** docker, and choose an effect from the menu. Repeat this step for each effect that you want to add. On the **FX** tab, the effects appear in the order in which you apply them, with the most recently added effect at the top of the list.
By default, each new object that you create with a drawing, rectangle, or ellipse tool has a black outline. You can remove the outline if you don't need it. For more information, see “To remove the outline of an object” on page 184.

When you convert a vector object to a lens, a lens icon appears in the Objects docker to the right of the object.

To work with bitmap effects
1. Select a vector or bitmap object that has a bitmap effect applied.
2. Open the Properties docker (Window ▶ Dockers ▶ Properties), click the FX tab, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide an effect</td>
<td>Click the Show/Hide icon for the effect you want to show or hide.</td>
</tr>
<tr>
<td>Apply additional effects</td>
<td>Click the Add effect button and choose an effect from the menu.</td>
</tr>
<tr>
<td>Edit an applied effect</td>
<td>Select an effect, and click the Edit icon.</td>
</tr>
<tr>
<td>Change the order of applied effects</td>
<td>Click an effect, and drag it to a new position in the list.</td>
</tr>
<tr>
<td>Delete an effect</td>
<td>Select an effect, and click the Delete button.</td>
</tr>
</tbody>
</table>

Clicking the Show/Hide icon on the FX tab of the Properties docker changes the visibility of individual effects, whereas clicking the Show/Hide Effects icon in the Objects docker changes the visibility of all effects applied to an object and overrides the visibility settings for individual effects that you may have set on the FX tab of the Properties docker.

You can also hide and show effects by clicking the Show/Hide Effects toggle icon in the Objects docker (Window ▶ Dockers ▶ Objects). To hide or show the effects of multiple objects, select the objects, and click the Show/Hide Effects toggle icon.

To flatten effects
* Click Effects ▶ Flatten Effects.

To inflate a bitmap manually
1. Select a bitmap.
2. Click Bitmaps ▶ Inflate Bitmap ▶ Manually Inflate Bitmap.
3. In the Width and Height areas, do one of the following:
   * In the Inflate to boxes, type the number of pixels that should make up the dimensions of the inflated bitmap.
• In the Inflate by boxes, type the percentages by which to inflate the original bitmap.

To inflate the bitmap proportionally, enable the Maintain aspect ratio check box.

To automatically inflate the bitmap to cover the entire image, click Bitmaps ▶ Inflate Bitmap ▶ Auto Inflate Bitmap.

**To choose default bitmap inflation settings**

1. Click Layout ▶ Document Options.
2. Click General.
3. Enable or disable the Auto inflate bitmaps for effects check box.

**To add a plug-in filter**

1. Click Tools ▶ Options ▶ CorelDRAW.
2. Click Plug-ins.
3. Click Add.
4. Choose a folder containing a plug-in.
5. Restart the application.

   The plug-in appears in the Bitmaps ▶ Plug-ins menu.

To remove a plug-in filter, click a plug-in folder from the Plug-in folders list, and click Remove.
Special effects categories

In this chapter, you will find descriptions of the special effects that are available in the application as well as sample images that illustrate each effect. The special effects are organized into the following categories:

- “3-D” (page 499)
- “Art strokes” (page 504)
- “Blur” (page 510)
- “Camera” (page 515)
- “Color transform” (page 519)
- “Contour” (page 521)
- “Correction” (page 522)
- “Creative” (page 523)
- “Custom” (page 529)
- “Distort” (page 530)
- “Noise” (page 535)
- “Sharpen” (page 538)
- “Texture” (page 540)

For information about applying special effects, see “Vector and bitmap effects” on page 485.

3-D

You can apply three-dimensional special effects to an image to create the illusion of depth.

To apply the effects that are labeled with ‘Corel PHOTO-PAINT’, you need to edit the bitmap in Corel PHOTO-PAINT. To send a bitmap to Corel PHOTO-PAINT, you can click the Edit bitmap button on the property bar, or you can use the Edit bitmap command from the Bitmaps menu. You can also enable an option that lets you access Corel PHOTO-PAINT by double-clicking a bitmap. For more information, see “Edit bitmaps with Corel PHOTO-PAINT” on page 796.
3-D rotate

The 3-D rotate effect (Effects  3D Effects  3D Rotate) lets you rotate an image by adjusting an interactive, three-dimensional model. Click and drag the interactive, three-dimensional model in the 3D Rotate dialog box to rotate and position the image. Enable the Best fit check box to ensure that the image stays within the boundaries of the image window.

Bevel effect (Corel PHOTO-PAINT)

The Bevel effect (Effects  3D Effects  Bevel effect) lets you create the appearance of a raised surface.

Cylinder

The Cylinder effect (Effects  3D Effects  Cylinder) shapes an image into a cylinder.
Emboss

The Emboss effect (Effects ➤ 3D Effects ➤ Emboss) transforms an image into a relief, with details appearing as ridges and crevices on a flat surface. You can choose the embossing color or depth, as well as the direction of the light source. The effect works best on images with medium to high contrast. Depth sets the depth of the ridges and indentations in the relief. Level sets the intensity of the effect. The Direction dial lets you specify the direction of the light source. Original color embosses the image using its original colors. Gray embosses the image in gray with moderate, embossed highlights. Black embosses the image in black with high-contrast, embossed highlights. Other embosses the image using a color that you choose from the Other color picker.

Glass (Corel PHOTO-PAINT)

The Glass effect places a three-dimensional, glass-like surface over an editable area. You can specify the width of the bevel, the area that is slanted to produce the three-dimensional look, the sharpness of the bevel’s edges, and the angle at which the light is bent at the edges. You can also specify the brightness, direction, and angle of the light that strikes the bevel. The Glass effect lets you apply preset styles and create custom preset styles.
Page curl

The Page curl effect (Effects ➤ 3D Effects ➤ Page curl) makes one of the corners of an image roll in on itself. You can specify a corner and set the curl orientation, transparency, and size. You can also choose a color for the curl and the background that is exposed where the image curls away from the paper. Click a thumbnail to specify the position of the page curl. Choose a vertical or horizontal direction for the page curl. The Opaque option creates a curl using a solid color, the Transparent option displays the underlying image through the curl. The Curl color picker lets you choose the curl color. The Background color picker let you choose a color for the background that is exposed where the image curls away from the paper. The Width% and Height% sliders let you set the curl size.

Pinch/punch

The Pinch/punch effect (Effects ➤ 3D Effects ➤ Pinch/punch) warps an image by pinching it toward you or punching it away from you. You can position the effect by setting a center point.
Sphere

The Sphere effect (Effects ➤ 3D Effects ➤ Sphere) wraps an image around the inside or outside of a sphere. You can set a center point around which an image wraps, and you can control the wrapping. Positive values expand the central pixels toward the edges of an image resulting in a convex shape. Negative values compress pixels toward the center of an image resulting in a concave shape.

The Boss (Corel PHOTO-PAINT)

The Boss effect (Effects ➤ 3D Effects ➤ The Boss) raises the area of the image that falls along the edges of a mask. You can specify the width, height, and smoothness of the raised edge, as well as the brightness, sharpness, direction, and angle of the light sources. The Boss effect lets you apply preset styles and create custom preset styles.

Zig zag

The Zig zag effect (Effects ➤ 3D Effects ➤ Zig zag) creates waves of straight lines and angles that twist an image outward from an adjustable center point. You can choose the type of waves and specify their number and strength.
Art strokes

The art strokes special effects give images a hand-painted look. You can use these effects to make images look like pastel drawings, sponge paintings, and watercolors, or to create textured backgrounds.

Charcoal

The Charcoal effect (Effects ▶ Art strokes ▶ Charcoal) makes an image look like a black-and-white charcoal drawing.

Conte crayon

The Conte crayon effect (Effects ▶ Art strokes ▶ Conte crayon) simulates textures produced with a conté crayon. You can select multiple crayon colors and set the crayon pressure and the granularity of the texture.
Crayon

The Crayon effect (Effects  Art strokes  Crayon) makes an image look like a wax crayon drawing. You can specify the crayon pressure and create dark outlines around elements in the image.

Cubist

The Cubist effect (Effects  Art strokes  Cubist) groups similarly colored pixels into squares to produce an image that resembles a cubist painting. You can specify the square size, the amount of light, and the paper color.
Dabble

The Dabble effect (Effects ➤ Art strokes ➤ Dabble) makes image pixels look like dabs of paint. You can choose from a variety of brushstrokes and specify the brushstroke size.

Impressionist

The Impressionist effect (Effects ➤ Art strokes ➤ Impressionist) makes an image look like an impressionist painting. You can customize the dabs of color or the brushstrokes and specify the amount of light in the image.

Palette knife

The Palette knife effect (Effects ➤ Art strokes ➤ Palette knife) creates the impression that an image was created by spreading paint on a canvas with a palette knife. You can specify the amount of smudging and the size and direction of the brushstrokes.
Pastels

The Pastels effect (Effects  ▶  Art strokes  ▶  Pastels) makes an image look like a pastel drawing. You can specify the size and color variation of the brushstrokes.

Pen and ink

The Pen and ink effect (Effects  ▶  Art strokes  ▶  Pen & ink) makes an image look like a pen-and-ink drawing created with a cross-hatching or stipple technique.
Pointillist

The **Pointillist** effect (Effects ➤ Art strokes ➤ Pointillist) analyzes the main colors of an image and converts them to small dots. You can specify the size of the dots and the amount of light in the image.

![Original](image1.png) ![Pointillist](image2.png)

Scraperboard

The **Scraperboard** effect (Effects ➤ Art strokes ➤ Scraperboard) scrapes away a black surface to reveal white or another color, making an image look like a sketchy drawing. You can specify the density of the paint and the brushstroke size.

![Original](image3.png) ![Scraperboard](image4.png)

Sketch pad

The **Sketch pad** effect (Effects ➤ Art strokes ➤ Sketch pad) makes an image look like a pencil sketch.
Watercolor

The **Watercolor** effect (Effects ▶ Art strokes ▶ Watercolor) makes an image look like a watercolor painting. You can specify the brush size, granulation level, and image brightness. You can also specify the intensity of the colors and determine the degree to which the colors blend.

Water marker

The **Water marker** effect (Effects ▶ Art strokes ▶ Water marker) makes an image look like an abstract sketch created with color markers. You can change the brushstrokes by selecting different modes. You can also specify the size and color variation of the brushstrokes.
Wave paper

The Wave paper effect (Effects ▶ Art strokes ▶ Wave paper) makes an image look like a painting created on textured wave paper. You can create a black-and-white painting, or you can preserve the original color of the image.

Blur

The blur special effects change the pixels of an image to soften them, smooth their edges, blend them, or create motion effects.

To apply the effects that are labeled with 'Corel PHOTO-PAINT’, you need to edit the bitmap in Corel PHOTO-PAINT. To send a bitmap to Corel PHOTO-PAINT, you can click the Edit bitmap button on the property bar, or you can use the Edit bitmap command from the Bitmaps menu. You can also enable an option that lets you access Corel PHOTO-PAINT by double-clicking a bitmap. For more information, see “Edit bitmaps with Corel PHOTO-PAINT” on page 796.

Tune blur

The Tune blur effect (Effects ▶ Blur ▶ Tune blur) lets you apply any of four blurring effects, which are represented by thumbnails, to an image. You can adjust the blur effect and preview the image with softer or sharper focus while you are editing it. The Tune blur filter lets you improve image quality or create exciting visual effects.
Directional smooth

The **Directional smooth** effect (Effects ▶ Blur ▶ Directional smooth) smooths the regions of gradual change in an image while preserving edge detail and texture. You can use this filter to subtly blur the edges and surfaces of images without distorting the focus.

![Original vs Directional smooth](image)

Feather

The **Feather** effect (Effects ▶ Blur ▶ Feather) gradually increases the transparency along the edges of objects making objects blend perfectly into the background. You can specify the width of the feathered section of the object and the transparency gradient you want to use. The edge transparency can change in even increments from the beginning to the end of the feathered section (Linear edges) or in small increments at the beginning of the feathered edge, larger transparency increments in the middle, and small transparency increments at the end (Curved edges).

![Original vs Feather](image)

Gaussian blur

The **Gaussian blur** (Effects ▶ Blur ▶ Gaussian blur) effect produces a hazy effect, blurring the focus of an image according to Gaussian distribution, which spreads the pixel information outward using bell-shaped curves. The effect can improve the quality of bitmaps with sharp edges. Move the **Radius** slider to adjust the intensity of the effect. The **Gaussian Blur** effect supports all color modes except Paletted and Black-and-White.
Jaggy despeckle

The **Jaggy despeckle** effect (Effects  ➤  Blur  ➤  Jaggy despeckle) scatters colors in an image, creating a soft, blurred effect with minimal distortion. It is most effective for removing the jagged edges that can appear in line art or high-contrast images. The **Jaggy despeckle** effect is also a preset lens type.

Low pass

The **Low pass** effect (Effects  ➤  Blur  ➤  Low pass) removes sharp edges and detail from an image, leaving smooth gradients and low-frequency areas. The higher the settings you specify, the more image detail is erased.
Motion blur

The Motion blur effect (Effects ➔ Blur ➔ Motion blur) creates the illusion of movement in an image. You can specify the direction of movement.

Original  Motion blur

Radial blur

The Radial blur effect (Effects ➔ Blur ➔ Radial blur) creates a blurring effect in an image that spins around or radiates outward from a center point that you specify.

Original  Radial blur

Bokeh blur (Corel PHOTO-PAINT)

The Bokeh blur effect (Effects ➔ Blur ➔ Bokeh blur) lets you control the amount of blur applied to the outside of an editable area and adjust the transition between the area in focus and the blurred area. For more information, see the Corel PHOTO-PAINT Help.
Smart blur

The **Smart blur** effect (Effects ➔ Blur ➔ Smart blur) removes unwanted artifacts and noise from images.

Smooth

The **Smooth** effect (Effects ➔ Blur ➔ Smooth) mutes the differences between adjacent pixels to smooth an image without losing detail. It is especially useful for removing the **dithering** that is created when you convert an image from the **paletted** mode to the **RGB** mode. The **Smooth** effect produces a more pronounced effect than the **Soften** effect. The **Smooth** effect is also a preset lens type.
Soften

The **Soften** effect (Effects ▶ Blur ▶ Soften) smooths and tones down the harsh edges in an image without losing important image detail. The difference between the **Smooth** and **Soften** effects is subtle but is often apparent when images are viewed at high resolution. The **Soften** effect is also a preset lens type.

![Original](image1) ![Soften](image2)

Zoom

The **Zoom** effect (Effects ▶ Blur ▶ Zoom) blurs image pixels outward from a center point. The pixels closest to the center point are the least blurry.

![Original](image3) ![Zoom](image4)

Camera

The Camera special effects let you simulate the effect produced by photographic filters, such as spot filters and diffusion filters. You can also add lighting effects, such as sun flares or spot lights.

Colorize

The **Colorize** effect (Effects ▶ Camera ▶ Colorize) lets you replace all colors in an image with a single color (or hue) to create a duotone image. You can then adjust the saturation or vividness of the color. A color with 100% saturation contains no white. A color with 0% saturation corresponds to a shade of gray. With this effect, you can create various single-color images. For example, a brownish hue can create a sepia effect, simulating the color of old photographs.
Diffuse

The Diffuse effect (Effects ➤ Camera ➤ Diffuse) softens images by distributing image pixels to fill in blank spaces and remove noise. The result simulates the soft focus of a photographer’s diffusion filter. You can make this effect smooth or blurry.

Lens flare

The Lens flare (Effects ➤ Camera ➤ Lens flare) effect produces rings of light on an RGB image, simulating the flare that appears on a photograph when the camera is aimed towards a direct, bright light.
Lighting effects

The Lighting effects (Effects ▶ Camera ▶ Lighting effects) let you add light sources to an RGB or grayscale image to create the illusion of spotlights, floodlights, or sunlight. You can also apply a texture to create embossed reliefs. You can use a preset light or texture style, or customize a preset style and save it in the preset list.

Photo filter

The Photo filter effect (Effects ▶ Camera ▶ Photo filter) lets you simulate the effect of placing a colored filter in front of a camera lens. You can choose the color of the filter and then adjust the color density and luminosity.

Sepia toning

The Sepia toning effect (Effects ▶ Camera ▶ Sepia toning) simulates the look created when you take a photo with sepia film. Sepia-toned images are similar to black-and-white photos (also known as grayscale photos), except the tones are brown instead of gray.
Spot filter

The Spot filter effect (Effects ➤ Camera ➤ Spot filter) lets you control the focus area in an image and de-emphasize the surrounding area by applying a Gaussian blur to imitate a photographer's use of depth of field. You can set the position and radius of the area in focus, control the edges and degree of the blur, and decrease light in the surrounding areas. You can use a preset style or customize a preset style and save it in the preset list.

Time machine

The Time machine effect (Effects ➤ Camera ➤ Time machine) lets you walk your image back through history to recreate some popular photographic styles from the past. You can choose from seven styles, which range from the year 1839 to the 1960s.
Color transform

The color transform special effects let you create dramatic effects by changing the color of an image.

Bit planes

The Bit planes effect (Effects ▸ Color transform ▸ Bit planes) reduces an image to basic RGB color components and displays tonal changes using solid colors. You can adjust the tonal values of each color component individually or as a group.

Halftone

The Halftone effect (Effects ▸ Color transform ▸ Halftone) gives an image the appearance of a color halftone. A color halftone is an image that has been converted from a continuous tone image to a series of dots of various sizes that represent different tones. You can specify the size of the biggest dot and vary the color pattern. Move the Max dot radius slider to set the maximum radius of a halftone dot. The Cyan, Magenta, Yellow, and Black sliders specify the angles of the cyan, magenta, yellow, and black color screens.
Psychedelic

The Psychedelic effect (Effects ▶ Color transform ▶ Psychedelic) changes the colors in an image to bright, electric colors, such as orange, hot pink, cyan, and lime green. The Psychedelic effect is also a preset lens type.

Solarize

The Solarize effect (Effects ▶ Color transform ▶ Solarize) transforms colors in an image by reversing image tones. The Solarize effect is also a preset lens type.
Contour

The contour special effects detect and accentuate the edges of objects. You can adjust the level of edge detection, the type of edges that are detected, as well as the color of the edges that are detected.

Edge detect

The Edge detect effect (Effects ➤ Contour ➤ Edge detect) detects the edges in an image and converts them to lines on a single-color background. You can customize this effect by specifying the intensity of the outline and the background color. The White, Black, or Other button allow you to choose a white, black, or other color for the background, respectively. The Sensitivity slider lets you adjust the intensity of the effect.

Find edges

The Find edges effect (Effects ➤ Contour ➤ Find edges) locates edges in an image and lets you convert these edges to soft or solid lines. When you convert edges to soft lines you create a smooth blurred outline. Converting edges to solid lines creates a sharper outline. The Find edges filter is particularly useful for high-contrast images, such as images that contain text.

Trace contour

The Trace contour effect (Effects ➤ Contour ➤ Trace contour) highlights the edges of image elements using a 16-color palette. Trace contour lets you specify which edge pixels are highlighted.
Local Equalization

The Local Equalization effect (Effects ➤ Contour ➤ Local Equalization) lets you enhance the contrast near image edges and reveals details in both light and dark regions. The filter uses neighboring pixels to create a stylized effect.

Correction

The correction special effects let you remove dust and scratch marks from images and sharpen images by increasing contrast, enhancing images edges, or reducing shading.

Dust and Scratch

The Dust and Scratch effect (Effects ➤ Correction ➤ Dust and Scratch) improves the appearance of an image that has small dust and scratch marks. The filter works by eliminating the contrast between pixels that exceed the contrast threshold you set. You can set a radius to determine how many pixels are affected by the changes. For more information, see “Remove dust and scratch marks from bitmaps” on page 777.

Tune Sharpen

The Tune Sharpen effect (Effects ➤ Correction ➤ Tune Sharpen) sharpens images by accentuating edge detail, focusing blurred areas, or increasing contrast. The filter lets you choose a percentage of sharpening to apply to the image and set a threshold of pixels changed by the effect. For more information, see “Sharpen images” on page 777.
You can also sharpen images by using individual **Sharpen** effects. For more information, see "Sharpen" on page 538.

**Creative**

The creative special effects use a variety of shapes and textures to transform an image into abstract art. They use crystals, fabric, glass, frames, or whirlpools as the foundation for creating something new.

**Art Style**

The **Art Style** effects (Effects ➔ Creative ➔ Art Style) use neural net techniques to transfer the style of one image to the content of another. Based on the analysis of a variety of source style images, including textures, patterns, colorful mosaics, and paintings by well-known artists, the artificial intelligence presets take the semantic content of your image, apply a style transfer to it, and create a styled image that simulates the textures, colors, visual patterns, and aesthetics of the reference image. Experiment with the presets to best appreciate the collection of styles and media available in the application. You can vary the intensity of an effect to adjust its strength. The higher the intensity, the more pronounced the effect. You can also control the level of detail. High values sharpen the edges and bring up more image details but increase the file size and processing time. Choose the detail level depending on the selected style preset and your artistic intent.

![Original](image1)
![Smooth Acrylic](image2)
![Grainy](image3)
![Graphite](image4)
![Pink Pastel](image5)
![Sienna](image6)
Pastel Mosaic  Post-Impressionist  Soft Pastels
Neon  Bold Edges  Saturated Acrylic
Waves  Sunset  Lava Lamp
Wood Blocks  Warm Texture  Woodcut
Crystalize

The Crystalize effect (Effects ▶ Creative ▶ Crystalize) makes an image look as though it was created with crystals. You can control the effect by specifying the dimensions of the crystals. Lower values produce smaller crystals, causing less distortion. Higher values produce larger crystals and create a more abstract effect.

Fabric

The Fabric effect (Effects ▶ Creative ▶ Fabric) makes an image look as though it was created with textiles, such as needlepoint, rug hooking, quilts, strings, ribbons, and tissue collage. You can specify the size and angle of the textile, as well as the brightness.

Frame

The Frame effect (Effects ▶ Creative ▶ Frame) lets you frame an image with a preset or custom frame. You can change the color, opacity, orientation, and alignment of a frame, and you can save customized settings as preset styles. You can also update, load, and delete preset frame settings. To customize a frame, click the Modify tab. Opacity sets the opacity of the frame. Blur/Feather blurs or feathers the edge of the frame with the contents. Horizontal and Vertical set the horizontal and vertical frame size. The Rotate dial lets you specify the degree to which you want to rotate a frame. Flip horizontal and Flip vertical mirror the frame horizontally and vertically, respectively. Align lets you choose a center point for the frame from the bitmap. Re-center centers the frame on the bitmap. The Save preset button lets you save customized frame settings as a preset.
Glass block

The Glass block effect (Effects ▶ Creative ▶ Glass block) makes an image look as though it is being viewed through thick glass blocks. You can control the effect by specifying the dimensions of the glass blocks.

Mosaic

The Mosaic effect (Effects ▶ Creative ▶ Mosaic) breaks an image into unequal elliptical pieces to form the appearance of a mosaic. You can specify the size of the pieces and the background color. You can also frame the mosaic.
Scatter

The Scatter effect (Effects ▶ Creative ▶ Scatter) distorts an image by scattering pixels. You can specify the direction of the scattering. The Scatter effect is also a preset lens type.

Smoked glass

The Smoked glass effect (Effects ▶ Creative ▶ Smoked glass) applies a transparent colored tint to images. You can specify the color of the smoked glass, the opacity of the tint, and the amount of blurring.

Stained glass

The Stained glass effect (Effects ▶ Creative ▶ Stained glass) transforms images into stained-glass artwork. You can adjust the size of the glass pieces and create solder between them.
Vignette

The Vignette effect (Effects ▸ Creative ▸ Vignette) lets you add an elliptical, circular, rectangular, or square frame around an image. You can specify the color and fade rate of the effect. Move the Fade slider to set the transition between the frame and the bitmap. The offset is the distance from the center of the image to the inner border of the frame. The higher the offset (that is, the higher the distance from the center of the image), the thinner the frame.

Vortex

The Vortex effect (Effects ▸ Creative ▸ Vortex) produces a swirl around a center point that you specify in an image. You can specify the direction of the swirl’s inner and outer pixels.
Custom

The custom special effects offer you a wide range of effects to transform an image. You can create an artistic media painting, overlay an image with a customized image, or use a variety of blur, sharpen, and edge detect effects.

Band pass

The Band pass effect (Effects ▶ Custom ▶ Band pass) adjusts the sharp and smooth areas on images. Sharp areas are areas where abrupt changes take place (for example, colors, edges, noise). Smooth areas are areas where gradual changes take place.

Bump map

The Bump map (Effects ▶ Custom ▶ Bump-map) effect adds texture and patterns to an image by embedding its surface with a relief based on the pixel values of a bump map image. The pixel values of the bump map image represent surface elevation. You can use a preset bump map or load a custom bump map image. You can specify the surface and lighting properties of the effect.

User defined

These User defined effects (Effects ▶ Custom ▶ User defined) let you create blur, sharpen, or edge detect special effects by defining a new color value for each pixel based on the color values of adjacent pixels. You define the value of the selected pixel numerically, by typing values in a grid. The central box in the grid represents the selected pixel, and the boxes around it represent the adjacent pixels. The number you type in the central box of the grid is multiplied by the original color value of the selected pixel. The resulting number (the new color value of
the selected pixel) can be further modified by choosing how much it is influenced by the values of the adjacent pixels, which can be added to or subtracted from the value of the selected pixel. For example, if you type 0 in all the boxes surrounding the central pixel, the pixel’s value is not influenced by the adjacent pixels, but only by the number you type in the central box. All numbers you type in the grid are multiplied by the corresponding pixel values and added together to create a new value for the pixel. The new pixel value is then divided by a divisor value you choose. If the divisor is the same as the number you type in the central box, then they will cancel each other out, and the new pixel value will depend only on the values of the adjacent pixels. The result of all numerical operations in the grid represents the final color value (1 to 255) of the pixel.

**Distort**

The distort special effects transform the appearance of images without adding depth.

**Blocks**

The Blocks effect (Effects ▶ Distort ▶ Blocks) breaks down the image into scrambled block pieces. You can specify the size of the blocks, the distance between the blocks, and the color of the background (exposed when the effect is applied).

**Displace**

The Displace effect (Effects ▶ Distort ▶ Displace) shifts an active image according to the values of a secondary image known as a displacement map. Values from the displacement map display as forms, colors, and warp patterns in the image.
Mesh warp

The Mesh warp effect (Effects ▸ Distort ▸ Mesh warp) lets you distort an image by repositioning the nodes on a superimposed grid. You can increase the number of nodes on the grid by increasing the number of gridlines to a maximum of 10. Increasing the number of nodes on the grid provides finer control over small details in the image. You can use any of the preset mesh warp styles, and you can create and save custom mesh warp styles.

Offset

The Offset effect (Effects ▸ Distort ▸ Offset) changes an image’s position by shifting it according to the parameters you specify. When an image is offset, empty areas display where the image was previously positioned. You can fill the empty areas by tiling or stretching the image, or by applying color.
The **Pixelate** effect (Effects ➤ Distort ➤ Pixelate) breaks an image into square, rectangular, or circular cells. The **Pixelate** effect is also a preset lens type.

The **Ripple** effect (Effects ➤ Distort ➤ Ripple) distorts an image with one or more waves. You can specify the strength of the primary wave to set the warping of the image or add an additional perpendicular wave to increase the distortion.
Shear

The Shear effect (Effects  ▶ Distort  ▶ Shear) maps the shape of an image to the shape of a line segment.

Original

Shear

Swirl

The Swirl effect (Effects  ▶ Distort  ▶ Swirl) creates a swirl across an image according to the direction, number of whole rotations, and angle that you specify.

Original

Swirl

Tile

The Tile effect (Effects  ▶ Distort  ▶ Tile) reduces the image’s dimensions and reproduces it as a series of tiles on a grid. You can use this effect in combination with a flood fill to create a background or to create a wallpaper effect for a webpage.
Wet paint

The **Wet paint** effect (**Effects** ➔ **Distort** ➔ **Wet paint**) creates the illusion of wet paint on images. You can specify the size of the drips and the range of colors that are affected in the image.

Whirlpool

The **Whirlpool** effect (**Effects** ➔ **Distort** ➔ **Whirlpool**) applies a fluid, swirling pattern across an image. You can use a preset whirlpool style, or you can create a custom style by setting the smear length, spacing, twist, and streak detail of the effect. You can also save custom whirlpool styles.
Wind

The Wind effect (Effects ➔ Distort ➔ Wind) blurs an image in a specific direction, creating the effect of wind blowing across the image. You can specify the strength and direction of the blur, as well as the transparency of the effect.

Noise

In bitmap editing, noise is defined as the random pixels that display across an image, which resemble static on television screens. The noise special effects let you create, control, or eliminate noise.

Add noise

The Add noise effect (Effects ➔ Noise ➔ Add noise) creates a granular effect that adds texture to a flat or overly blended image. You can specify the type and amount of noise that is added to the image.

3-D stereo noise

The 3-D stereo noise effect (Effects ➔ Noise ➔ 3-D stereo noise) creates a dithered noise pattern giving an image the appearance of three-dimensional depth when viewed a certain way. This effect is particularly suited to high-contrast line art and grayscale images. This effect may be very difficult to perceive.
Maximum

The Maximum effect (Effects ➤ Noise ➤ Maximum) removes noise by adjusting the color value of a pixel based on the maximum color values of its neighboring pixels. This effect also produces a mild blurring effect when applied more than once.

Median

The Median effect (Effects ➤ Noise ➤ Median) removes noise and detail by adjusting the color value of a pixel according to the median color value of the surrounding pixels.
Minimum

This effect (Effects  ▶ Noise ▶ Minimum) removes noise by adjusting the color value of a pixel, based on the minimum color values of its neighboring pixels.

![Original](image1) ![Minimum](image2)

Tune noise

The Tune noise effect (Effects  ▶ Noise ▶ Tune noise) lets you apply any of nine noise effects. Each effect is represented by a thumbnail which lets you preview the image as you apply an effect.

![Original](image3) ![Tune noise](image4)

Remove Moire

The Remove Moire effect (Effects  ▶ Noise ▶ Remove Moire) lets you remove moiré from images. Moiré is the wave pattern produced when halftone screens of two different frequencies are superimposed on the same image.

![Original](image5) ![Tune noise](image6)
Remove Noise

The Remove Noise effect (Effects ➤ Noise ➤ Remove Noise) lets you remove noise from scanned images. Noise is the speckled effect produced by scanning or video-capturing.

Sharpen

You can sharpen images to increase contrast, enhance image edges, or reduce shading. Sharpening is usually done after adjusting the color and tone of an image and after resampling or resizing. For more information about sharpening images, see the Corel PHOTO-PAINT help.

Adaptive unsharp

The Adaptive unsharp effect (Effects ➤ Sharpen ➤ Adaptive unsharp) lets you accentuate edge detail by analyzing the values of neighboring pixels. This filter preserves most image detail, but its effect is most apparent in high-resolution images.
Directional sharpen

The **Directional sharpen** effect (Effects ▶ Sharpen ▶ Directional sharpen) lets you enhance the edges of an image without creating a grainy effect.

High pass

The **High pass** effect (Effects ▶ Sharpen ▶ High pass) lets you remove image detail and shading to give an image a glowing quality by emphasizing its highlights and luminous areas. However, it can also affect the color and tone of the image.
Sharpen

The **Sharpen** effect (Effects  ▶ Sharpen ▶ Sharpen) lets you accentuate the edges of the image by focusing blurred areas and increasing the contrast between neighboring pixels. Move the **Edge level(%)** slider to set the degree to which edge detail is accentuated. **Threshold** specifies how far apart adjacent tonal values have to be before the effect is applied. This is important to prevent smooth areas from becoming speckled. Low values produce a more exaggerated sharpening effect because fewer areas are excluded. Higher threshold values exclude areas of lower contrast. To prevent dramatic shifts in hue, enable **Preserve colors**.

Unsharp mask

The **Unsharp mask** effect (Effects  ▶ Sharpen ▶ Unsharp mask) lets you accentuate edge detail and focus blurred areas in the image without removing low-frequency areas. **Percentage** sets the intensity of the sharpening effect. **Radius** sets the amount of pixels that are evaluated at once. **Threshold** sets how many pixels are affected.

Texture

The texture special effects let you add texture to an image using a variety of shapes and surfaces. You can use bricks, bubbles, canvas, elephant skin, plastic, and stone; or you can create etchings and underpaintings. You can also use these effects to make an image look as though it is painted on a plaster wall or as though you are viewing it through a screen door.

Brick wall

The **Brick wall** effect (Effects  ▶ Texture ▶ Brick wall) groups pixels into a series of interlocking cells to make an image look like a painting on a brick wall. You can specify the brick size and the density of the brick pattern.
Bubbles

The Bubbles effect (Effects ➔ Texture ➔ Bubbles) creates a bubbling foam on an image. You can specify the size of the bubbles and the amount of the image that is covered.

Canvas

The Canvas effect (Effects ➔ Texture ➔ Canvas) applies a textured surface to an image by letting you use another image as a canvas. You can choose a preset canvas map, or you can load any image as a canvas map. For best results, choose images that have high to medium contrast.
Cobblestone

The Cobblestone effect (Effects ▶ Texture ▶ Cobblestone) makes an image look as though it was created with cobblestones. You can specify the size, spacing, and granularity of the cobblestones.

Elephant skin

The Elephant skin effect (Effects ▶ Texture ▶ Elephant skin) gives an image a wrinkled look by creating an overlay of wavy lines. You can specify the age of the elephant skin (up to 100 years) as well as the skin color.

Etching

The Etching effect (Effects ▶ Texture ▶ Etching) transforms an image into an etching. You can control the depth of the etching, the amount of detail, the direction of the light, and the color of the metal surface.
Plastic

The Plastic effect (Effects > Texture > Plastic) makes an image look as though it is made of plastic. You can specify the image depth, as well as the color and angle of light shining on the plastic. You can also customize the angle of the light. Highlight sets the brightness of the image accents. Depth sets the depth of the plastic shading. Smoothness sets the amount of image detail. The Light direction dial lets you set the direction of the light. The color picker lets you choose a color for the light.

Plaster wall

The Plaster wall effect (Effects > Texture > Plaster wall) redistributes pixels so that an image looks as though it was painted on a plaster wall.
Relief sculpture

The Relief sculpture effect (Effects ▶ Texture ▶ Relief sculpture) transforms an image into a relief sculpture. You can set the smoothness of the relief, the amount of detail it contains, the direction of the light, and the surface color.

Original

Relief sculpture

Screen door

The Screen door effect (Effects ▶ Texture ▶ Screen door) makes an image look as though it is being viewed through a screen door. You can specify the mesh detail and brightness, the softness within the image, as well as whether the image is color or black-and-white.

Original

Screen door

Stone

The Stone effect (Effects ▶ Texture ▶ Stone) gives an image a stone texture. You can specify the amount of detail, the density of the pattern, and the angle of the light hitting an image. You can apply a preset stone style or create and save a custom stone style as a preset.
Underpainting

The **Underpainting** effect (Effects ➤ Texture ➤ Underpainting) makes an image look like a painting created on a canvas that is subsequently covered with layers of paint. You can specify the degree to which the original image is painted over and adjust the brightness of the image.
Lenses

Lenses contain creative effects that let you change the appearance of an object without actually changing the object.

This section contains the following topics:

- “Apply lenses” (page 547)
- “Edit lenses” (page 549)

Apply lenses

Lenses change how the object area beneath the lens appears, not the actual properties and attributes of the objects. You can apply lenses to any vector object, such as a rectangle, ellipse, closed path, or polygon. You can also change the appearance of artistic text and bitmaps. When you apply a lens over a vector object, the lens itself becomes a vector image. Likewise, if the lens is placed over a bitmap, the lens also becomes a bitmap. You can use a lens to apply bitmap effects to image areas. For more information, see “To apply a bitmap effect to an image area” on page 495.

After you apply a lens, you can copy it and use it with another object.

The lens types applied to the original (far left): (left to right) Heat map, Magnify, and Custom color map

The following are the types of lenses that you can apply to objects.
<table>
<thead>
<tr>
<th>Lens</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitmap effect</td>
<td>Lets you apply special effects to image areas</td>
</tr>
<tr>
<td>Brighten</td>
<td>Lets you brighten and darken object areas and set the rate of the brightness and darkness</td>
</tr>
<tr>
<td>Color add</td>
<td>Lets you simulate an additive light model. The colors of the objects beneath the lens are added to the color of the lens as if you were mixing colors of light. You can choose the color and the amount of color you want to add.</td>
</tr>
<tr>
<td>Color limit</td>
<td>Lets you view an object area with only black and the lens color showing through. For example, if you place a green color limit lens over a bitmap, all colors except green and black are filtered out in the lens area.</td>
</tr>
<tr>
<td>Custom color map</td>
<td>Lets you change all the colors of the object area beneath the lens to a color ranging between two colors you specify. You can choose the range’s start and end colors and the progression between the two colors. The progression can follow a direct, forward, or reverse route through the color spectrum.</td>
</tr>
<tr>
<td>Fish eye</td>
<td>Lets you distort, magnify, or shrink the objects beneath the lens, according to the percentage value you specify</td>
</tr>
<tr>
<td>Heat map</td>
<td>Lets you create the effect of an infrared image by mimicking the heat levels of colors in object areas beneath the lens</td>
</tr>
<tr>
<td>Invert</td>
<td>Lets you change the colors beneath the lens to their complementary CMYK colors. Complementary colors are colors that are opposite each other on the color wheel.</td>
</tr>
<tr>
<td>Magnify</td>
<td>Lets you magnify an area on an object by an amount that you specify. The magnify lens overrides the original object’s fill, making the object look transparent.</td>
</tr>
<tr>
<td>Tinted grayscale</td>
<td>Lets you change the colors of object areas beneath the lens to their grayscale equivalents. Tinted grayscale lenses are particularly effective for creating sepia-tone effects.</td>
</tr>
<tr>
<td>Transparency</td>
<td>Lets you make an object look like a piece of tinted film or colored glass</td>
</tr>
<tr>
<td>Wireframe</td>
<td>Lets you display the object area beneath the lens with the outline or fill color of your choice. For example, if you set red for the outline and blue for the fill, all areas beneath the lens appear to have red outlines and blue fills.</td>
</tr>
</tbody>
</table>
To apply a lens
1. Select an object.
2. Click Effects ▶ Lens.
3. Choose a lens type from the list box in the Lens docker.
4. Specify the settings you want.

You cannot apply the lens effect directly to linked groups such as contoured objects, beveled objects, extruded objects, drop shadows, paragraph text, or objects created with the Artistic media tool.

To copy a lens
1. Select the object to which you want to copy the lens.
2. Click Object ▶ Copy effect ▶ Lens from.
3. Click the object from which you want to copy the lens.

Edit lenses
After you create a lens, you can edit it. For example, you can adjust the shape of a lens by using any of the Edit Shape and Curve tools. For more information about shaping objects, see “Shape objects” on page 213. You can also adjust the settings of Bitmap effect lenses. For more information, see “To work with bitmap effects” on page 496.

You can specify how a lens affects the area beneath it. For example, you can change the viewpoint of a lens, indicated by an X in the drawing window, to display any part of a drawing. The viewpoint represents the center point of what is being viewed through the lens. You can position the lens anywhere in the drawing window, but it always shows the area around its viewpoint marker. For example, you can use the viewpoint marker on the Magnify lens to enlarge part of a map.

You can also display a lens only where it overlaps other objects or the background. As a result, the lens effect is not seen where the lens covers blank space (white space) in the drawing window.

Freezing the current view of a lens lets you move the lens without changing what’s displayed through it. In addition, changes you make to the areas beneath the lens have no effect on the view.

You can feather the edges of lens objects to blend them perfectly into the background. For more information, see “Feather object edges” on page 315.

To edit lens properties
1. Select a lens object.
2. In the Lens docker (Effects ▶ Lens), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the viewpoint of a lens</td>
<td>Enable the Viewpoint check box. Type values in the x and y boxes to specify the coordinates of the center point that is viewed through the lens, and press Enter.</td>
</tr>
<tr>
<td>Display a lens only where it overlaps objects or the background</td>
<td>Enable the Remove face check box.</td>
</tr>
</tbody>
</table>
To | Do the following

Freeze the current view of a lens | Enable the Frozen check box.

The Remove face check box is not available for the Fish Eye and Magnify lenses.

When a lens object is brought into Focus mode, the object and lens are brought into focus together. Once in Focus mode, you can select and edit the object and the lens separately if the lens is frozen. When the lens is not frozen, only the shape of the lens can be edited. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.
Add 3D effects

You can create the illusion of three-dimensional (3D) depth in objects by adding contour, perspective, extrusion, bevel, or shadow effects.

This section contains the following topics:
- “Contour objects” (page 551)
- “Apply perspective” (page 555)
- “Create extrusions” (page 558)
- “Create bevel effects” (page 562)
- “Add drop shadows and inner shadows” (page 564)
- “Add block shadows” (page 569)
- “Blend objects” (page 573)

Contour objects

You can contour an object to create a series of concentric lines that progress to the inside or outside of the object. CorelDRAW also lets you set the number of the contour lines and the distance between them.

In addition to creating interesting 3D effects as well as shading in complex illustrations, you can use contours to create cuttable outlines for output to devices such as plotters, engraving machines, and vinyl cutters.

After contouring an object, you can copy or clone its contour settings to another object. You can also change the colors of the fill between the contour lines and the contour outlines themselves. You can set a color progression in the contour effect, where one color blends into another. The color progression can follow a straight, clockwise, or counterclockwise path through the color range of your choice.

You can also choose how contour corners appear. For example, you can use pointed or rounded corners, or you can bevel (square off) sharp contour corners.

You can separate an object from its contour lines.
A center contour has been applied to the above object. The number of contour lines, as well as the distance between lines, can be changed.

An outside contour has been applied to the above object. Note that an outside contour projects from the outside edge of the object.

When an object with a contour effect is brought into Focus mode, the object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To contour an object

1. In the toolbox, click the **Contour** tool.
2. Click an object or a set of grouped objects, and drag the start handle toward the center to create an inside contour or away from the center to create an outside contour.
3. Move the object slider to change the number of contour steps.

You can also

- Add contour lines to the center of the selected object
- Click the **To center** button

A center contour has been applied to the above object. The number of contour lines, as well as the distance between lines, can be changed.

An outside contour has been applied to the above object. Note that an outside contour projects from the outside edge of the object.
You can also

Specify the number of contour lines

Click the Inside contour or Outside contour button on the property bar, and type a value in the Contour steps box on the property bar.

Specify the distance between contour lines

Type a value in the Contour offset box on the property bar.

Accelerate contour line progression (changes contour shapes)

Click the Object and color acceleration button on the property bar, and move the Object slider.

Choose the shape of contour corners

Click the Contour corners button on the property bar, and choose one of the following commands:

- Mitered corners (for pointed contour corners)
- Round corners
- Bevel corners

You can create contours by clicking Effects ➤ Contour (the second Contour command in the Effects menu) and specifying the settings you want in the Contour docker.

To copy or clone a contour

1. Select the object to which you want to apply the contour effect.
2. Click Object, and click one of the following:
   - Copy Effect ➤ Contour From
   - Clone Effect ➤ Contour From
3. Click the object whose contour effect you want to copy or clone.
You can also use the Attributes eyedropper tool to copy a contour. For more information, see “To copy effects from one object to another” on page 325.

To set the fill color for a contour object
1 In the toolbox, click the Contour tool.
2 Select a contour object.
3 Open the Fill color picker on the property bar, and click a color.
   If you cannot apply the fill color, make sure that the Fill color option is enabled on the status bar.
   If the original object has a fountain fill, a second color picker appears.

You can accelerate the fill color progression by clicking the Object and color acceleration button on the property bar and moving a slider.

You can change the contour center’s color by dragging a color from the color palette to the end fill handle.

To specify an outline color for the contour object
1 In the toolbox, click the Contour tool.
2 Select a contour object.
3 Open the Outline color picker on the property bar, and click a color.

To set the fill progression
1 In the toolbox, click the Contour tool.
2 Select a contour object.
3 Click the Contour colors button on the property bar, and then click any of the following buttons:
   • Linear contour colors
   • Clockwise contour colors
   • Counterclockwise contour colors

Fill progression from left to right: Linear, clockwise, counterclockwise
To separate an object from its contour lines
1. Using the Pick tool, select a contoured object.
2. Click Object ➤ Break Contour Apart.

Apply perspective
Adding perspective to objects creates the illusion of distance and depth. You can create a perspective effect by shortening one or two sides of an object. This effect gives an object the appearance of receding in one or two directions, thereby creating a one-point perspective or a two-point perspective.

The original graphic (left) with one-point (middle) and two-point (right) perspective applied to it.

CorelDRAW lets you use perspective with both vector and bitmap objects. You add perspective to a bitmap interactively in the drawing window.
Two-point perspective (bottom left) is applied to a bitmap (top left).

The perspective effect is applied nondestructively, so you can edit it or remove it and revert to the original image at any point. After you add perspective to bitmaps, you can transform and manipulate them as you would any other vector objects. For information about transforming objects, see “Transform objects” on page 308.

Perspective effects can be added to objects or grouped objects.
You can also add a perspective effect to linked groups, such as contours, blends, and extrusions. You can’t add perspective effects to paragraph text or symbols.

You can adjust perspective by moving the nodes on the perspective grid or the vanishing points. Moving a node lets you edit a two-point perspective; moving a vanishing point lets you edit a one-point perspective.

After you apply a perspective effect, you can copy it to other objects in a drawing, adjust it, or remove it from the object.

To apply a perspective

To

Apply a one-point perspective

Apply a two-point perspective

Do the following

Click Object ➤ Add perspective. Press Ctrl, and drag a node.

Click Object ➤ Add perspective. Drag the nodes on the outside of the grid to apply the effect you want.

Pressing Ctrl constrains the node’s movement to the horizontal or vertical axis to create a one-point perspective effect.

Press Ctrl + Shift as you drag to move two adjacent nodes symmetrically towards or away from a central point. This is useful when you want to distort an image symmetrically.

To copy an object’s perspective effect

1 Select an object to which you want to apply a perspective effect.
2 Click **Object ▶ Copy Effect ▶ Perspective From**.

3 Select an object whose perspective effect you want to copy.

You can also use the **Attributes eyedropper** tool to copy a perspective effect. For more information, see “To copy effects from one object to another” on page 325.

**To adjust the perspective**

1 In the toolbox, click the **Shape** tool.

2 Select an object that has a perspective effect.

3 Drag a node to a new position.

Pressing **Ctrl** constrains a node’s movement to the horizontal or vertical axis to create a one-point perspective effect.

Splitting, cropping, or erasing portions of an object with perspective flattens the perspective effect, so you can no longer edit it.

You can also adjust one-point perspective by dragging a **vanishing point**.

Press **Ctrl** + **Shift** as you drag to move adjacent nodes closer together or further apart along a horizontal or vertical axis. This is useful when you want to achieve a symmetrical perspective effect.

**To remove a perspective effect from an object**

1 Select an object that has a perspective effect.

2 Click **Object ▶ Clear Perspective**.

**Create extrusions**

You can make objects appear three-dimensional by creating extrusions. You can create extrusions by projecting points from an object and joining them to create an illusion of three dimensions. CorelDRAW also lets you apply a vector extrusion to an object in a group.

After you create an extrusion, you can copy or **clone** its attributes to a selected object. Cloning and copying transfer the extrusion attributes of an extruded object to another. However, the cloned extrusion settings cannot be edited independently from the **master**.

You can change an extruded form by rotating it and rounding its corners.

CorelDRAW also lets you remove a vector extrusion.

**Bevels**

Another way in which you can give an object a three-dimensional appearance is by applying a beveled edge to an extrusion. A bevel creates the illusion that an object’s extruded edges are cut on an angle. You can specify the angle and depth values of the bevel to control the effect.

You can create a bevel effect without extruding an object. For more information, see “Create bevel effects” on page 562.

**Extruded fills**

You can apply fills to an entire extrusion or only to the extruded surfaces. You can cover each surface individually with the fill, or you can drape the fill so that it blankets the entire object with no breaks to the pattern or texture.
Lighting

You can enhance extrusions by applying light sources. You can add up to three light sources to project toward the extruded object with varying intensity. When you no longer need light sources, you can remove them.

Vanishing points

You can create a vector extrusion in which the lines of the extrusion converge at a vanishing point. The vanishing point of a vector extrusion can be copied to another object so that both objects appear to recede toward the same point.

You can also give extrusions different vanishing points.

When an object with an extrusion effect is brought into Focus mode, the object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To create an extrusion

1. Select an object using the Pick tool.
2 In the toolbox, click the **Extrude** tool.
3 Choose a preset from the **Presets** list box on the property bar.
4 Choose an extrusion type from the **Extrusion type** list box on the property bar.

You can edit the extrusion by using the **Extrude** docker (Effects ➤ Extrude).

**To copy or clone an extrusion**

1 Select the object you want to extrude.
2 Click **Object** and click one of the following:
   - Copy Effect ➤ Extrude From
   - Clone Effect ➤ Extrude From
3 Click an object whose extrusion properties you want to copy.

You can also use the **Attributes eyedropper** tool to copy an extrusion. For more information, see “To copy effects from one object to another” on page 325.

**To change the form of a vector extrusion**

<table>
<thead>
<tr>
<th><strong>To</strong></th>
<th><strong>Do the following</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rotate an extrusion</strong></td>
<td>Select an extruded object. Click the <strong>Extrude rotation</strong> button on the property bar. Drag the extrusion in the direction you want.</td>
</tr>
<tr>
<td><strong>Change the direction of an extrusion</strong></td>
<td>Using the <strong>Extrude</strong> tool, click an extrusion. Click the vanishing point, and drag in the direction you want.</td>
</tr>
<tr>
<td><strong>Change the depth of an extrusion</strong></td>
<td>Using the <strong>Extrude</strong> tool, click an extrusion. Drag the slider between the interactive vector handles.</td>
</tr>
<tr>
<td><strong>Round the corners of an extruded rectangle or square</strong></td>
<td>In the toolbox, click the <strong>Shape</strong> tool. Drag a corner node along the outline of the rectangle or square.</td>
</tr>
</tbody>
</table>

**To remove a vector extrusion**

1 Select an extruded object.
2 Click **Effects ➤ Clear Extrusion**.

You can also remove a vector extrusion by clicking **Clear Extrusion** on the property bar.
To apply a fill to an extrusion
1. Select an extruded object with the **Extrude** tool.
2. Click the **Extrusion color** button on the property bar.
3. Click one of the following buttons:
   - **Use object fill** — applies the object’s fill to the extrusion
   - **Use solid color** — applies a solid color to the extrusion
   - **Use color shading** — applies a gradient fill to the extrusion

   You can apply an unbroken pattern or texture fill to an object by enabling the **Drape fills** check box before you click the **Use object fill** button.

To apply beveled edges to an extrusion
1. In the toolbox, click the **Extrude** tool.
2. Select an extruded object.
3. Click the **Extrusion bevels** button on the property bar.
4. Enable the **Use bevel** check box.
5. Type a value in the **Bevel depth** box.
6. Type a value in the **Bevel angle** box.

   You can also set the bevel depth and angle by using the **Bevel interactive display box** below the **Use bevel** check box.

   You can show only the bevel and hide the extrusion by enabling the **Show bevel only** check box.

To add light to an extrusion
1. Select an extruded object.
2. Click the **Extrusion lighting** button on the property bar.
3. Enable any of the three numbered check boxes.
   The lights appear as numbered circles in the preview window.
4. Drag the numbered circles in the **Light intensity preview** window to position the lights.

   You can also
   - Adjust the intensity of a light source (Move the **Intensity** slider next to the numbered check box.)
   - Remove a light source (Disable a numbered check box.)
To change the vanishing point of an extrusion

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock a vanishing point</td>
<td>Double-click an extruded object. Choose VP locked to object or VP locked to page from the Vanishing point properties list box on the property bar.</td>
</tr>
<tr>
<td>Copy a vanishing point</td>
<td>Double-click an extruded object whose vanishing point you want to change. From the Vanishing point properties list box on the property bar, choose Copy VP from. Select the extruded object that has the vanishing point you want to copy.</td>
</tr>
<tr>
<td>Set one vanishing point for two extrusions</td>
<td>Double-click an extruded object. Choose Shared vanishing point from the Vanishing point properties list box on the property bar. Select the extruded object that has the vanishing point you want to share.</td>
</tr>
</tbody>
</table>

Create bevel effects

A bevel effect adds 3D depth to a graphic or text object by making its edges appear sloped (cut at an angle). Bevel effects can contain both spot and process (CMYK) colors, so they are ideal for printing.

You can remove a bevel effect at any time.

Bevel effects can be applied only to vector objects and artistic text, not to bitmaps.

Bevel styles

You can choose from the following bevel styles:

- Soft edge — creates beveled surfaces that appear shaded in some areas
- Emboss — makes an object appear as a relief

Beveled surfaces

You can control the intensity of the bevel effect by specifying the width of the beveled surface.

Light and color

An object with a bevel effect appears lit by white ambient (surrounding) light and a spotlight. The ambient light is of low intensity and cannot be changed. The spotlight is also white by default, but you can change its color, intensity, and location. Changing the spotlight color...
affects the color of the beveled surfaces. Changing the spotlight’s intensity lightens or darkens the beveled surfaces. Changing the location of the spotlight determines which beveled surfaces appear lit.

You can change the location of the spotlight by specifying its direction and altitude. Direction determines where the light source is located in the plane of the object (for example, to the left or right of an object). Altitude determines how high the spotlight is located in relation to the object’s plane. For example, you can place the spotlight flush with the horizon (altitude of 0°) or directly above the object (altitude of 90°).

In addition, you can change the color of the beveled surfaces that are in shadow by specifying a shadow color.

When an object with a bevel effect is brought into Focus mode, the object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To create a Soft Edge bevel effect

1. Select an object that is closed and has a fill applied to it.
2. Click Effects ▸ Bevel.
3. In the Bevel docker, enable the Soft edge option.
4. Enable one of the following Bevel offset options:
   • To center — lets you create beveled surfaces that meet in the middle of the object
   • Distance — lets you specify the width of the beveled surfaces. Type a value in the Distance box.
5. Click Apply.

You can also

Change the color of beveled surfaces in shadow
Choose a color from the Shadow color picker.
Beveled surfaces change to a shade of the specified shadow color.

Choose a spotlight color
Choose a color from the Light color picker.

Change the intensity of the spotlight
Move the Intensity slider.

Specify the position of the spotlight
Move either of the following sliders:
   • Direction
   • Altitude

Direction values range from 0° to 360°; altitude values range from 0° to 90°.

Bevel effects can be applied only to artistic text. You can convert paragraph text to artistic text by selecting the text using the Pick tool and then clicking Text ▸ Convert to artistic text.

The lowest altitude value (0°) places the spotlight on the plane of the object; the highest altitude value (90°) places the spotlight directly above the object.

The effect of the shadow color is most apparent when the spotlight is located close to the object’s plane (low altitude value).
Using a given altitude value, you can change the spotlight’s location by changing the direction value. For example, at an altitude of 45°, the following direction values change the spotlight location as noted:

- 45° places the spotlight on the upper right.
- 135° places the spotlight on the upper left.
- 225° places the spotlight on the lower left.
- 315° places the spotlight on the lower right.

To create an Emboss effect

1. Select an object that is closed and has a fill applied to it.
2. Click **Effects ➤ Bevel**.
3. In the **Bevel** docker, enable the **Emboss** option.
4. In the **Distance** box, type a low value.
5. To change the intensity of the spotlight, move the **Intensity** slider.
6. To specify the direction of the spotlight, move the **Direction** slider.
7. Click **Apply**.

   If you want to create a more pronounced bevel effect, type a higher value in the **Distance** box, and reapply the effect.

You can also

Choose a shadow color

Choose a color from the **Shadow** color picker.

Choose a spotlight color

Choose a color from the **Light** color picker.

Remember:

The Emboss bevel effect is achieved by creating two duplicates of the object. The duplicates are offset in opposite directions: one toward the light source and the other away from the light source. The color of the duplicate placed toward the spotlight is a blend of the spotlight and object colors and depends on the light intensity. The color of the duplicate placed away from the spotlight is a 50 percent blend of the shadow and object colors.

The **Altitude** slider is disabled for the Emboss bevel style.

To remove a bevel effect

1. Select an object with a bevel effect applied.
2. Click **Object ➤ Clear Effect**.

Add drop shadows and inner shadows

Drop shadows and inner shadows simulate light falling on objects, adding 3D depth for a more realistic appearance. Drop shadows appear behind or below objects; inner shadows appear inside objects.

You can add drop shadows and inner shadows to most objects or groups of objects, including text and bitmaps.

You can add drop shadows and inner shadows interactively or by using presets. After you add a shadow, you can edit it. For example, you can adjust attributes such as color, **opacity**, offset, and **feathering**. You can edit shadows interactively by using the vector control or by using controls on the property bar.
A drop shadow applied to an object. The feathered effect softens the edges of the drop shadow on the right.

An inner shadow applied to an object

By changing the settings of the inner shadow, you can change the object appearance. The same text object with different inner shadow settings.

After you create a shadow, you can copy it or clone it to a selected object. When you copy a shadow, the original and copy have no connection and can be edited independently. With cloning, the master object’s shadow attributes are automatically applied to its clone.

By separating a shadow from its object, you gain more control over the shadow itself. For example, you can edit the shadow as you would edit a transparency. For information about editing a transparency, see “Object transparency” on page 447. In addition, you can separate a shadow from its object so that you can apply both an inner shadow and a drop shadow to an object.

As with transparencies, you can apply a merge mode to a shadow to control how the color of the shadow blends with the color of the object underneath. For more information about merge modes, see “Merge modes” on page 456.
You can remove drop shadows and inner shadows.

When an object with a shadow effect is brought into Focus mode, the object and the effect are brought into focus together. Once in Focus mode, you can select and edit the object and the effect separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

Drop shadows and extrusions created in CorelDRAW are ideal for printed outputs, but are not appropriate for output to devices such as vinyl cutters and plotters. Cuttable shadows are needed for such projects. To add a cuttable shadow to an object, you must use a block shadow. For more information about block shadows, see “Add block shadows” on page 569.

You can also create a cuttable shadow by duplicating the object, filling the duplicate with a dark color, and then placing it behind the original object.

You can also use extrusions to create shadows.

To add a drop shadow or an inner shadow

1 In the toolbox, click the Shadow tool.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a drop shadow</td>
<td>On the property bar, click the Drop shadow tool. Drag from the center of the object to position the drop shadow. To add a perspective drop shadow, drag from the object edge.</td>
</tr>
<tr>
<td>Add an inner shadow</td>
<td>On the property bar, click the Inner shadow tool. Drag from the center of the object until the inner shadow is the size you want. The closer to the edge you drag the end handle, the narrower the inner shadow becomes. Tip: To offset the inner shadow, drag beyond the edges and the bounding box of the object.</td>
</tr>
</tbody>
</table>

A flat drop shadow (left), and a perspective drop shadow (right)
Shadows cannot be added to linked groups, such as blended objects, contoured objects, beveled objects, extruded objects, objects created with the Artistic media tool or other shadows.

You cannot add shadows to a bitmap which has been shaped by an envelope or to objects that have bitmap effects applied to them.

You can apply only one shadow to an object — a drop shadow or an inner shadow, not both. However, you can use grouping to apply both shadows to the same object. For example, you can apply an inner shadow to an object, create a group from that object, and then apply a drop shadow to the group.

You can also add a shadow by choosing a preset from the Preset list box on the property bar.

To edit a drop shadow or an inner shadow
1 In the toolbox, click the Shadow tool.
2 Click an object with a shadow.
3 Use any of the following controls on the property bar to specify the shadow attributes:
   - **Shadow color** — to choose the shadow color
   - **Merge mode** — to choose how the color of the shadow blends with the color of the underlying object. The default merge mode Multiply produces natural-looking shadows.
   - **Shadow opacity** — to adjust the transparency of the shadow
   - **Shadow feathering** — to sharpen or soften the edges of the shadow
   - **Feathering direction** — to soften the shadow’s edges towards the inside of the shadow, the outside of the shadow, or in both directions. Shadows look more realistic when they use Gaussian Blur feathering, which is the default option. The Inside and Average options are not available for inner shadows.
   - **Feather edge** — to choose a feathering type. This control is not available for Gaussian Blur feathering.
   - **Inner shadow width** — to set the width of an inner shadow that is not offset
   - **Shadow offset** — to change the distance between shadow and the object edge. With drop shadows, changing the offset makes the object appear closer or further away from the background.

You can also

Edit a perspective drop shadow

Use any of the following controls:
   - **Shadow angle** — to set the direction of the drop shadow
   - **Shadow stretch** — to set the length of the drop shadow
   - **Shadow fade** — to adjust the fading of the drop shadow
You can also

Edit a perspective drop shadow

Note: These controls are not available for inner shadows and flat drop shadows.

Save the custom settings as a preset

Click the Add preset button and type a name for the shadow preset.

Shadow presets are saved to your Documents\Corel\Corel Content\CorelDRAW\Presets\Shadow folder.

Delete a custom shadow preset

Choose a custom preset from the Preset list box, and click the Delete preset

To copy or clone a drop shadow or an inner shadow

1 Select the object to which you want to copy or clone a shadow.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy a drop shadow</td>
<td>Click Object ▶ Copy Effect ▶ Shadow From, and click the drop shadow of an object.</td>
</tr>
<tr>
<td>Copy an inner shadow</td>
<td>Click Object ▶ Copy Effect ▶ Shadow From, and click the inner shadow of an object.</td>
</tr>
<tr>
<td>Clone a drop shadow</td>
<td>Click Object ▶ Clone Effect ▶ Shadow From, and click the drop shadow of an object.</td>
</tr>
<tr>
<td>Clone an inner shadow</td>
<td>Click Object ▶ Clone Effect ▶ Shadow From, and click the inner shadow of an object.</td>
</tr>
</tbody>
</table>
You can also use the Attributes eyedropper tool to copy a drop shadow or an inner shadow. For more information, see “To copy effects from one object to another” on page 325.

You can also copy a shadow from one object to another by using the Copy shadow properties button on the property bar.

To separate a drop shadow or inner shadow from an object

1. Using the Pick tool, select an object’s drop shadow or inner shadow.
2. Do one of the following:
   * Click Object > Break Drop Shadow Apart.
   * Click Object > Break Inner Shadow Apart.
3. Click a blank space in the drawing window to deselect the object and the shadow, and then drag the shadow.

Separating an inner shadow from an object

You can use this procedure to apply both an inner shadow and a drop shadow to an object. For example, you can apply a drop shadow to an object, break the drop shadow apart, and then apply an inner shadow to the object.

To remove a drop shadow or an inner shadow

1. Select an object’s shadow.
2. Click Object > Clear Shadow.

You can also remove a shadow from an object by selecting the shadow and clicking Clear Shadow on the property bar.

Add block shadows

The Block Shadow tool in CorelDRAW lets you add solid shadows to objects and text. Unlike drop shadows and extrusions, block shadows consist of simple lines, which makes them ideal for screen printing and sign making.
You can adjust the depth and direction of a block shadow, and you can change its color. A block shadow may contain holes, but you can remove them to create a solid curve object.

By default, a block shadow is generated from the object outline. You can also choose to ignore the outline and start the block shadow from the object edge. The effect of this option is more obvious when an object has a thick outline. In addition, you can expand a block shadow that is generated from the object outline.

If you are planning to print or export your document, you can specify block shadow settings to suit your needs. For example, you can set a block shadow to overprint, that is to print on top of underlying objects. Also, overlapping areas between the object and its block shadow can be removed when the document is exported or printed.

You can remove block shadows from objects at any time.
When an object with a block shadow is brought into Focus mode, the object and the block shadow are brought into focus together. Once in Focus mode, you can select and edit the object and the block shadow separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To add a block shadow

1. In the toolbox, click the Block Shadow tool.
2. Click the object, and drag in the direction you want until the block shadow is the size you want.

You can’t add a block shadow to a bitmap which has been shaped by an envelope.

To edit a block shadow

1. Using the Block Shadow tool, click the object.
2. Perform any of the tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the depth of a block shadow</td>
<td>Type a value in the Depth box. Tip: You can also adjust the depth by dragging the vector handle in the drawing window.</td>
</tr>
<tr>
<td>Set the direction of a block shadow</td>
<td>Type a value in the Direction box. This value specifies the angle of the block shadow in relation to the object. Tip: You can also change the direction of a block shadow by dragging the handle in the drawing window.</td>
</tr>
<tr>
<td>Change the color of a block shadow</td>
<td>Choose a color from the Block shadow color picker on the property bar. Tip: You can also change the color by dragging a color from the color palette to the vector handle in the drawing window.</td>
</tr>
</tbody>
</table>
To Do the following

Remove the holes from a block shadow

Click the **Remove holes** button on the property bar to enable it.

Expand a block shadow that is generated from the outline

On the property bar, click the **Generate from object outline** button to enable it. Type a value in the **Expand block shadow** box on the property bar.

Ignore the outline when generating a block shadow

On the property bar, click the **Generate from object outline** button to disable it.

To set printing and exporting options for block shadows

1. Using the **Block Shadow** tool, click the object.
2. Perform any of the tasks from the following table.

To Do the following

Set a block shadow to print on top of underlying objects

Click the **Overprint block shadow** button.

Trim overlapping areas between the object and its block shadow

Click the **Simplify** button.
To

Trim overlapping areas between the object and its block shadow

Do the following

To remove a block shadow

1. Using the Block Shadow tool, click the block shadow.
2. Click the Clear block shadow button on the property bar.

Blend objects

CorelDRAW lets you create blends, such as straight-line blends, blends along a path, and compound blends. Blends are often used for creating realistic shadows and highlights in objects.

A straight-line blend shows a progression in shape and size from one object to another. The outline and fill colors of the intermediate objects progress along a straight-line path across the color spectrum. The outlines of intermediate objects show a gradual progression in thickness and shape.

After you create a blend, you can copy or clone its settings to other objects. When you copy a blend, the object takes on all the blend-related settings, except for the outline and fill attributes. When you clone a blend, changes you make to the original blend (also called the master) are applied to the clone.
Straight-line blends can be used to create graphics with a glass-like appearance. The rollover button (left) contains a blend of tightly overlapped blended objects.

You can fit objects along part or all of a path’s shape, and you can add one or more objects to a blend to create a compound blend.

You can change the appearance of a blend by adjusting the number and spacing of its intermediate objects, the blend’s color progression, the nodes the blends map to, the blend’s path, and the start and end objects. You can fuse the components of a split or compound blend to create a single object.

You can also split and remove a blend.
By mapping nodes, you can control the appearance of a blend. Two nodes on the polygon are mapped to two nodes of a star shape, showing a more gradual transition (bottom).

When blended objects are brought into Focus mode, the objects and the blend are brought into focus together. Once in Focus mode, you can select and edit the objects and the blend separately. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

To blend objects

To

Do the following

Blend along a straight line

In the toolbox, click the Blend tool. Select the first object, and drag over the second object.

Blend an object along a freehand path

In the toolbox, click the Blend tool. Select the first object. Hold down Alt, and drag to draw a line to the second object.

Fit a blend to a path

In the toolbox, click the Blend tool. Click the Path properties button on the property bar. Click New path. Using the curved arrow, click the path to which you want to fit the blend.

Stretch the blend over an entire path

Select a blend that is already fitted on a path. Click the More blend options button on the property bar, and click Blend along full path.

Create a compound blend

Using the Blend tool, drag from an object to the start or end object of another blend.

You can also blend objects by using the Blend docker (Effects > Blend).
To copy or clone a blend

1. Select the two objects that you want to blend.
2. Click Object, and click one of the following:
   • Copy Effect ➤ Blend from
   • Clone Effect ➤ Blend from
3. Select the blend whose attributes you want to copy or clone.

You can’t copy or clone a compound blend.

You can also use the Attributes eyedropper tool to copy a blend. For more information, see “To copy effects from one object to another” on page 325.

To set the number of intermediate objects in a blend

1. Select a blend.
2. Type a value in the Blend objects box on the property bar.
3. Press Enter.

You can set object and color acceleration rates by clicking the Object and color acceleration button on the property bar and moving the corresponding slider.

To set the distance between objects in a blend that is fit to a path

1. Select a blend that is fit to a path.
2. Click the Blend spacing button on the property bar.
3. Type a value in the Blend objects box on the property bar.
4. Press Enter.

If you have used the Blend along full path command, the Blend spacing button is unavailable.

You can set object and color acceleration rates by clicking the Object and color acceleration button on the property bar and moving the corresponding slider.
To set the color progression in a blend
1 Select a blend.
2 On the property bar, click one of the following:
   • Direct blend
   • Clockwise blend
   • Counterclockwise blend

You can’t create color progressions by using blended objects filled with bitmaps, texture, pattern, or PostScript fills.

You can set how fast the object’s colors transform from the first to the last object by clicking the Object and color acceleration button on the property bar and moving the corresponding sliders.

To map the nodes of a blend
1 Select a blend.
2 Click the More blend options button on the property bar, and click Map nodes.
3 Click a node on the start object and on the end object.

To work with the start or end objects in a blend

To

Do the following

Select the start or end object
Select a blend, click the Starting and ending objects button on the property bar, and click Show start or Show end.

Change the start or end object of a blend
Select a blend, click the Starting and ending objects button on the property bar, and click New start or New end. Click an object outside the blend that you want to use as the start or end of the blend.

Fuse the start or end object in a split or compound blend
Hold down Ctrl, click a middle object in a blend, and then click a start or end object. Click the More blend options button on the property bar. If you have selected the start object, click the Fuse start button. If you have selected the end object, click the Fuse end button.

You can reverse the direction of the blend by clicking Object ▶ Order ▶ Reverse order.

To change the blend path
1 Select a blend.
2 Click the Path properties button on the property bar, and click New path.
3 Click the path you want to use for the blend.
You can also

Detach a blend from a path
Click the Path properties button on the property bar, and click Detach from path.

Change the path of a selected freehand blend
Click the blend path with the Shape tool, and drag a path’s node.

To select the blend path, click the Path properties button, and click Show path.

To split a blend
1 Select a blend.
2 Click the More blend options button on the property bar.
3 Click the Split button.
4 Click the intermediate object at the point at where you want to split the blend.

You can’t split a blend at the intermediate object that is immediately adjacent to the start or end object.

To remove a blend
1 Select a blend.
2 Click Effects Clear blend.

You can also remove a selected blend by clicking Clear Blend on the property bar.
Mosaics

The Pointillizer and PhotoCocktail effects let you create mosaics from objects and images.

This section contains the following topics:
- “Vector mosaics (Pointillizer effect)” (page 579)
- “Bitmap mosaics (PhotoCocktail effect)” (page 582)

Vector mosaics (Pointillizer effect)

The Pointillizer effect lets you create high-quality vector mosaics from any number of selected vector or bitmap objects. Whether you are looking to create precise halftone patterns or artistic effects that resemble pointillistic art, this effect will give you the inspiration and tools you need to create striking designs.

Vector mosaics created with Pointillizer are ideal for vehicle wraps and window decor projects. You can fine-tune your designs to perfection by using an array of controls.

To create a vector mosaic

1. Select a vector object or bitmap.
   You can also select multiple objects or groups of objects.
2 Click Effects ➤ Pointillizer.
3 In the Pointillizer docker, adjust any settings you want.
4 Click Apply.
   If you want to cancel the rendering process, press Esc.

To fine-tune a vector mosaic

Use any of the controls in the Pointillizer docker to customize and fine-tune your vector mosaic.

Density: This control lets you adjust the number of tiles per square inch.

Scale: This control lets you adjust the size of all tiles by scaling them up or down. Values higher than the default value of 1 increase the tile size; values lower than 1 decrease the size.

Screen angle: Use this control to rotate each row of tiles about the horizontal axis by the angle you specify. Positive values rotate the rows counterclockwise.
**Keep original source:** When you enable the *Keep original* check box, the source graphic is preserved, and the vector mosaic (output) is placed on top. Disable the check box to have the source deleted automatically after the mosaic is created.

**Limit colors:** Enable this check box to control the number of colors that are used for rendering the mosaic. To specify the maximum number of colors in the output, type a value in the *Number* box.

---

**Tracking options**

Choose from a selection of tracking algorithms to customize the mosaic.

**Method** lets you choose a technique for interpreting the source graphic. Three tracking methods are available — *Uniform* (white matte), *Size modulation 1* (opacity), and *Size modulation 2* (luminosity).

- **Uniform (white matte)** uses tiles of the same size to generate the mosaic. Transparencies are flattened against a white background.
- **Size modulation 1 (opacity)** interprets the source as a series of tiles that vary in size based sampled opacity values. The more opaque (less transparent) the areas are, the bigger the tiles are.
- **Size modulation 2 (luminosity)** interprets the source graphic based on its brightness values. Brighter areas in the source are rendered as smaller tiles; darker areas are rendered as bigger tiles.

**Merge adjacent** lets you specify the maximum number of tiles of similar color to be combined into a single tile. This setting has effect only if there is enough space available.
Weld adjacent overlap lets you weld together overlapping tiles. Enable this check box to render the output in clusters of color; disable the check box to preserve more details.

Shape

The Shape list box lets you pick one of the preset tile shapes such as a circle or square. To use a custom tile shape, do the following:

1 Choose Custom from the Shape list box.
2 Click Select at the bottom of the Preview area.
3 Click a closed curve in the drawing window.
   The Preview area shows the selected tile shape.

Bitmap mosaics (PhotoCocktail effect)

The PhotoCocktail effect lets you turn your photos and vector art into unique mosaics composed of selected images.
You can customize your mosaic by adjusting the number of tiles and the extent to which your photo or vector art blends with the mosaic tiles. You can create the mosaic as a single bitmap or as an array of bitmap tiles that are easy to edit. Several methods are available to help you control the quality of the mosaic.

**To create a mosaic from bitmap or vector objects**

1. Select the reference image (bitmap, vector object, or group of objects) that you want to recreate as a mosaic.
2. Click **Effects ➤ PhotoCocktail**.
3. In the **PhotoCocktail** docker, click **Browse** in the **Library** area, and browse to the image library, which is the folder that contains the images to be used as tiles. Click **Select folder**.
4. PhotoCocktail indexes the images and shows how many of them can be used as tiles. The **Path** control shows the location of the selected image library.
5. Choose any settings you want.
6. Click **Apply**.

**PhotoCocktail settings**

Additional controls are available in the **PhotoCocktail** docker to help you customize the effect.

**Reference**

**Keep original source**: Enable this check box if you want to keep the reference image or objects after applying the effect. Disable the check box to delete the reference image and leave only the mosaic.

**Grid**

**Columns**: This box lets you specify how many columns of tiles to include in the mosaic. The bigger the number, the more detail in the mosaic.

**Rows**: Shows the number of rows to be included in the mosaic. The number is automatically calculated based on the value in the **Columns** box.
Optimization
You can recreate the reference image more accurately by applying a blending effect. Blending lets you superimpose the reference image over the mosaic tiles.

**Blending:** This box lets you specify to what extent to blend the reference colors with the tile colors. Higher values increase the likeness of the mosaic to the reference image.

Duplicates
You can use duplicate tiles in the final mosaic.

**Duplicates:** Enable this check box to repeat tiles in the final mosaic. You can specify the minimum number of tiles that surround duplicate tiles in the **Tiles** box.

Output
Output controls let you define the composition and quality of the final mosaic.

**Composition:** This list box lets you choose one of the following options:
- **Single bitmap** renders the mosaic as a single rasterized image, with the blending effect incorporated in the image.
- **Bitmap stack** produces a single rasterized image with the blending effect layered on top as a single object.
- **Bitmap array** creates a group of bitmap tiles, with the blending effect layered on top as a single object.
**Edges**: This list box lets you choose a method for treating incomplete tiles around the edges. For example, incomplete tiles around the edges can be removed from the final mosaic, or the output can be stretched to match the reference image. Stretching the output results in mosaic tiles that are rectangular rather than square.

![Left: Tiles are stretched to match the dimensions of the reference image; Right: Partial tiles along the bottom edge are removed.](image)

**Priority**: This list box lets you choose one of the following methods for adjusting the output quality:

- The **Match document DPI** method automatically generates a mosaic that has the same DPI (dots per inch) as the active document.
- The **Custom DPI** method lets you specify the dpi of the final mosaic in the DPI box.
- The **Custom tile dimensions** method lets you specify the width of each tile in the first Tile box. The tile height is automatically calculated. Tile dimensions are shown in pixels.
- The **Custom output dimensions** method lets you specify the width of the final mosaic in the first Artwork box. The height is automatically calculated. The maximum dimensions of a mosaic are 15,000 x 15,000 pixels.

The mosaic DPI is influenced by the grid density and the dimensions of the mosaic.

The tile size is a good indicator of output quality. The higher the tile size, the better the quality. Dividing the mosaic size in pixels by the grid density gives you the tile size in pixels.
Add movement and focus

The Impact tool lets you create graphic effects in a style inspired by comic books and contemporary illustrations. Such effects are perfect for adding impact, movement, or focus to designs or illustrations.

Effects created by using the Impact tool

This section contains the topic “Impact effects” on page 587.

Impact effects

Two impact effect styles are available: Radial and Parallel. Radial effects can be used to add perspective or bring focus to a design element. Parallel effects can be used to add energy or signify motion.
Impact effects: Parallel (left) and Radial (right)

You can shape the impact effect by adding inner and outer boundaries. To customize the effect, you can rotate the effect lines and change the line width and spacing as well as the shape of each stroke. You can also randomize line settings for a more natural look. For example, lines can start and end randomly within the boundaries of an effect.

The effects are vector objects and can be edited with other tools in CorelDRAW. For example, you can distort or reshape the effect lines, and you can change the effect color.

To add an impact effect

1. Click the **Impact** tool in the toolbox.

2. On the property bar, choose **Radial** or **Parallel** from the **Effect style** list box.

3. Drag in the drawing window.
   - To resize the effect, drag the blue node along its edge.

4. Adjust any settings on the property bar.
   - For information about adding boundaries, see “To add and remove effect boundaries” on page 588.
   - For information about line and line spacing settings, see “To adjust additional settings” on page 590.

To add and remove effect boundaries

You can constrain the effect within inner and outer boundaries by using other objects as reference shapes. The reference objects are not connected to the effect and can be moved, hidden, or deleted without changing the effect appearance.

1. Select the effect.

2. Position the effect behind the reference objects, exactly where you want the effect to appear.
   - To place the effect behind the objects, you can use an appropriate command from the **Object** ➤ **Order** menu (for example, **To Back of Layer**).

3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an inner boundary</td>
<td>Click the <strong>Inner boundary</strong> button on the property bar, and click the reference object in the drawing window. This action shapes the inner edge of the effect, creating a gap with the shape of the selected object. If you no longer need the reference object, you can delete it.</td>
</tr>
</tbody>
</table>
To Do the following

Remove the inner boundary
Click the Remove inner boundary button [X].

The gap is removed from the effect, but the reference object used as an inner boundary is not deleted.

Add an outer boundary
Click the Outer boundary button [X] and click the reference object in the drawing window.

This action constrains the effect inside the bounding box of the reference object.

If you no longer need the reference object, you can delete it.

Remove the outer boundary
Click the Remove outer boundary button [X] to restore the effect to its original shape.

This action restores the effect to its original shape but does not delete the reference object that was used to define the outer boundary.

The following objects cannot be used to define boundaries: symbols, objects in text frames, grouped objects, the impact effect itself, and other impact effects.

Reshaping the reference objects after you use them as effect boundaries does not reshape the boundaries. If you need to reshape the boundaries, you must remove them and then add them again.
In this example, the red rectangle is used to define the outer boundary of the effect (left). The outer boundary is then removed, and the effect is restored to its original shape (right).

To adjust additional settings

The controls on the property bar let you customize the lines and line spacing in the effect.

**Angle of rotation**: Type a value to specify the angle of the lines in the effect (parallel style) or rotate the lines around the inner edge (radial style). Note that rotation can be applied to radial effects only if there is an inner boundary to rotate the lines against.

**Start and end points** This button lets you start and end lines randomly within the boundaries of the effect. Click the button, and enable any of the following check boxes: **Random start points** and **Random end points**. When these check boxes are disabled, all effect lines start and end at the boundary edges.
Add movement and focus | 591

From left to right: Before and after randomizing the start and end points of an effect

**Line width**: Type values in the **Min** and the **Max** box to set the minimum and maximum width for the lines in the effect. The minimum value cannot exceed the maximum value.

**Width steps**: Set the number of steps between the minimum and maximum width. When the value is 0, there are only two types of lines in the effect: of maximum width and of minimum width. Higher numbers add lines of increasing width between the thinnest and the thickest lines. For example, a value of 2 adds two lines between each line of minimum and maximum width.

Randomize width order: Click this button to randomize the order of lines in the effect. Lines will no longer appear in a repeating pattern from thinnest to thickest.
Line spacing: Type values in the Min and Max box to set the minimum and maximum amount of space between the lines in the effect. The minimum value cannot exceed the maximum value.

Spacing steps: Set the number of steps between the minimum and maximum line spacing. With a value of 0, there are only two types of spacing between lines: maximum and minimum. Values of 1 and higher create additional types of line spacing.

Randomize spacing order: Enable this check box to randomize the order of the additional spacing between the minimum and maximum line spacing.

Line style: This list box lets you choose a line shape.
The same impact effect with four different line styles applied

Widest point: Available for line styles that have varying width, this box lets you set the position of the widest line point. The higher the value, the closer the widest points are to the end points of the lines.

From left to right: A high and a low value of the Widest point setting

To edit an impact effect as a vector object

You can resize, transform, and move an effect the way you would resize, transform, and move any other object in CorelDRAW. You can also use the Shape tool to edit individual lines in the effect. In addition, you can change the line and outline color of the effects.

1. Select the effect by using the Pick tool.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transform an effect</td>
<td>Drag the selection handles on the bounding box to size, stretch, and mirror the effect.</td>
</tr>
<tr>
<td></td>
<td>Click the effect again to display a new set of handles, and drag a handle to rotate or skew the effect.</td>
</tr>
</tbody>
</table>
To Do the following

Edit lines by using the Shape tool

Click Object ▶ Break Impact Shape Apart. Next, ungroup the lines by pressing Object ▶ Group ▶ Ungroup. Click the Shape tool and edit the lines by adding, removing, and manipulating nodes.

Change the effect color

To change the line color, click a color on the onscreen color palette. To add an outline color to the effect lines, right-click a color on the onscreen color palette.

Each time you adjust a setting on the property bar of the Impact tool, the effect is redrawn, and some of the changes you made with the vector-editing tools may be lost. That is why we recommend that you make additional changes only after you finish adjusting the settings of the impact effect.

Impact effects cannot be brought into Focus mode. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.
Text

Add and manipulate text.....................................................................................................................................................................597
Format text..................................................................................................................................................................................623
Work with text in different languages........................................................................................................................................655
Manage fonts..............................................................................................................................................................................661
Writing tools..............................................................................................................................................................................671
Add and manipulate text

CorelDRAW provides multiple ways to add and manipulate text (also known as ‘type’). You can create two types of text objects: artistic text and paragraph text. Artistic text is useful for adding a single word or a short line of text. Paragraph text is suitable for creating text-intensive documents, such as newsletters or brochures.

You can change the position and appearance of text. For example, you can fit text to a path, wrap text around objects, or rotate text. You can also format the appearance of characters and paragraphs. For more information, see “Format text” on page 623.

This section contains the following topics:

• “Import and paste text” (page 597)
• “Artistic text” (page 599)
• “Paragraph text” (page 599)
• “Add columns to text frames” (page 603)
• “Combine and link paragraph text frames” (page 604)
• “Align text to the baseline grid” (page 606)
• “Select text” (page 607)
• “Find, edit, and convert text” (page 608)
• “Shift, rotate, mirror, and flip text” (page 611)
• “Move text” (page 612)
• “Wrap text” (page 613)
• “Fit text to a path” (page 614)
• “Special characters, symbols, and glyphs” (page 616)
• “Embed graphics” (page 621)
• “Legacy text” (page 621)

Import and paste text

You can import text in a new or existing document. This allows you to author text in a word processor and then add it to a CorelDRAW document. CorelDRAW supports the following text file formats:

• ANSI Text (TXT)
• Microsoft Word Document (DOC) files
• Microsoft Word Open XML Document (DOCX) files
• WordPerfect® file (WPD)
• Rich Text Format (RTF) files
When importing or pasting text, you can choose to keep or discard fonts and formatting. Maintaining fonts ensures that imported or pasted text retains its original font. Maintaining formatting preserves information such as bullets and columns. If you choose to discard fonts and formatting, the properties of the selected text are applied to the imported or pasted text. If no text is selected, the default font and formatting properties are applied to the imported or pasted text. For more information about importing files, see “Import files” on page 885. For more information about pasting, see “To paste an object into a drawing” on page 312.

The text import cursor lets you place text on the drawing page.

You can import text in a selected text frame, or, if you did not select a text frame, the imported text is automatically inserted in a new text frame in the document window. By default, the size of text frames remains static, regardless of how much text you add to them. Any text that does not fit the frame is hidden and the frame appears red until you enlarge it or link it to another text frame. You can adjust the text size so that the text fits perfectly in the frame. For more information, see “Combine and link paragraph text frames” on page 604.

To import text in a document
1 Using the Text tool A, position the cursor in the text frame where you want to import the text.
   If you do not have a text frame in the document, skip step 1 and proceed to step 2.
2 Click File → Import.
3 Choose the drive and folder where the file is stored.
4 Click the filename.
5 Click Import.
6 In the Importing/Pasting Text dialog box, choose one of the following options:
   • Maintain Fonts and Formatting
   • Maintain Formatting Only
   • Discard Fonts and Formatting
   If you want to apply CMYK black to the imported black text, enable the Force CMYK Black check box. This check box is available when you choose an option that maintains text formatting.
7 Do one of the following:
   • Position the import cursor in the drawing page, and click.
   • Click and drag on the drawing page to define the size of the text frame.
   • Press the Spacebar to place the imported text in the default location.

   For more information about importing a specific file format, see “Supported file formats” on page 911.

To paste text in a document
1 Copy or cut text.
2 Click Edit → Paste.
3 In the Importing/Pasting Text dialog box, choose one of the following options:
• Maintain Fonts and Formatting
• Maintain Formatting Only
• Discard Fonts and Formatting

If you want to apply CMYK black to the imported black text, enable the Force CMYK black check box. This check box is available when you choose an option that maintains text formatting.

If you choose to maintain fonts, but the text that you import requires a font that is not installed on your computer, the PANOSE font matching system substitutes the font for you. For more information, see “Substitute fonts” on page 662.

You can also set hyphenation options for imported text. For more information about hyphenation options, see “Hyphenate text” on page 650.

If you want to use the same formatting options whenever you import or paste text, enable the Don’t show this warning again check box. To reactivate the warning, click Tools ▸ Options ▸ CorelDRAW, click Warnings in the left pane of the dialog box that appears, and enable the Pasting and importing text check box.

Artistic text

Artistic text is useful for adding single words or short lines of text, such as headlines, to a document. You can then apply a wide range of effects to the artistic text, such as drop shadows or a contour.

Lorem ipsum dolor sit amet

Artistic text appears in a bounding box in the document window

You can add artistic text along an open or closed path or fit existing artistic to a path. For more information, see “Fit text to a path” on page 614.

In addition, you can assign hyperlinks to text. For more information, see “To assign a hyperlink to objects and text” on page 880.

To add artistic text
• Using the Text tool A, click anywhere on the drawing page, and type.

You can convert artistic text to paragraph text by selecting the artistic text using the Pick tool and then clicking Text ▸ Convert to paragraph text.

Paragraph text

You add paragraph text in a document by using text frames. Paragraph text, also known as “block text,” is generally reserved for larger bodies of text that have greater formatting requirements. For example, you can use paragraph text when creating brochures, newsletters, catalogs, or other text-intensive documents.

You can insert a text frame directly in the drawing window. You can also place text inside a graphic object, which increases the number of different shapes that you can use as text frames. You can create a text frame from a closed object and then type text inside the frame. You
can separate the frame from the object at any time, so that you can modify them independently. You can convert a text frame back to an object.

If you want to see the layout of your document before you add the final content, you can fill the text frames with temporary placeholder text. You can also use custom placeholder text.

By default, text frames have a fixed size, regardless of how much text you add to them. You can increase or decrease the frame size, so that the text fits in the frame. If you add more text than a frame allows, the text continues past the lower-right border of the text frame, but remains hidden. The color of the frame turns red to alert you that there’s additional text. You can fix the overflow manually by increasing the frame size, adjusting the text size, adjusting the column width, or linking the frame to another text frame. For more information, see “Combine and link paragraph text frames” on page 604.

You can also choose to automatically adjust the point size of text so that it fits neatly inside a frame. If the text overflows, CorelDRAW automatically decreases the point size; if you have little text, the application expands it to fill the frame.
You can also change the formatting of selected paragraph text frames and any frames to which they are linked. For information, see “To specify formatting preferences for text frames” on page 606. You can also align text inside a text frame by using the baseline grid. For more information, see “Align text to the baseline grid” on page 606.

In addition, you can assign hyperlinks to paragraph text. For more information, see “To assign a hyperlink to objects and text” on page 880. You can also change the text orientation for Asian text. For more information, see “To choose a text orientation for Asian text” on page 655.

**To add paragraph text**

1. Click the **Text tool**.
2. Drag in the drawing window to size the paragraph text frame.
3. Type in the text frame.

You can also

- **Set text frame column width to adjust automatically to fit the text**
  - Click **Window > Dockers > Properties**. In the Properties docker, click the **Frame** button to display the frame-related options.
  - In the **Frame** area, click the **Columns** button. In the Column settings dialog box, enable the **Automatically adjust frame width** option.

- **Apply a background color to a text frame**
  - Open the **Background color picker** in the **Frame** area of the Properties docker, and click a color.

A red text frame indicates text overflow. You can fix the overflow manually by increasing the frame size, adjusting the text size, or linking the frame to another text frame. For more information, see “Combine and link paragraph text frames” on page 604. You can also fix the overflow automatically by clicking **Text > Paragraph Text Frame > Fit Text to Frame**.

You can use the **Pick tool** to adjust the size of a paragraph text frame. Click the text frame, and drag any selection handle.

**To create a frame from an object**

1. Do one of the following:
   - **Using the Pick tool**, click the object in which you want to insert a text frame.
   - Using a drawing tool, draw a closed shape.
2. Select the object, and click **Text > Paragraph Text Frame > Create Empty Text Frame**.

You can also

- **Create a text frame from an object by using the Text tool**
  - Click the **Text tool**. Move the pointer over the outline of the object, and click the object when the pointer changes to an **Insert in object** pointer. Type inside the text frame.
You can also

Create a text frame from an object from the context menu
Right-click the object, and click Frame Type ➤ Create Empty Text Frame.

Create a text frame from an object by using the Layout toolbar
Click Window ➤ Toolbars ➤ Layout. Using the Pick tool , click the object in which you want to insert a text frame. Click the Text frame button .

To convert a text frame back to an object
• Right-click the text frame, choose Frame Type, and click Remove Frame.

If the frame contains content, the content is deleted when the frame reverts to a regular object.

You can also click the Remove frame button on the Layout toolbar. To open the Layout toolbar, click Window ➤ Toolbars ➤ Layout.

To separate a text frame from an object
1 Click the Pick tool .
2 Select the object that includes the text frame.
3 Click Object ➤ Break Paragraph Text inside a Path Apart.

The text frame and the object can now be moved or edited separately.

When you separate a text frame from some objects, such as ellipses or stars, the text does not retain the shape of the object. Alternatively, the text is contained in a standard rectangular text frame.

To insert placeholder text
1 Select an empty text frame.
2 Click Text ➤ Paragraph Text Frame ➤ Insert Placeholder Text.

You can customize the placeholder text by creating text in a word processor or text application and saving the document as placeholder.rtf. You then need to store the file in the following Users folder: Documents\Corel\Corel Content. The next time that you launch the application, the customized placeholder text is inserted in the text frame. However, if you save the file using an incorrect file name or in the wrong folder, the default Lorem ipsum placeholder text is inserted in the text frame.
You can insert placeholder text in multiple frames by clicking Pick tool , selecting the text frames while holding down Shift, and then clicking Text ➤ Paragraph Text Frame ➤ Insert Placeholder Text.

You can also select the empty text frame, right-click, and choose Insert Placeholder Text.

When you insert placeholder text in the first frame in linked frames, the placeholder text fills all frames.

You can undo inserting placeholder text by clicking Edit ➤ Undo Insert Placeholder Text.

To adjust text to fill the text frame

1. Select a text frame.
2. Click Text ➤ Paragraph Text Frame ➤ Fit Text to Frame.

If you choose to fit text to a frame that is linked to other frames, the application adjusts the size of text in all linked text frames. For more information about linking text frames, see “Combine and link paragraph text frames” on page 604.

Add columns to text frames

You can lay out text in columns. Columns are useful for designing text-intensive projects, such as newsletters, magazines, and newspapers.

You can create columns of equal or varying widths and gutters. You can also apply right-to-left text flow to the columns for bidirectional (bidi) text, such as Arabic and Hebrew (Note that this option is available only for certain languages).

The text in the frame (left) was laid out in two columns (right).

To add columns to a text frame

1. Select a paragraph text frame.
2. Click Window ➤ Dockers ➤ Properties.
3. In the Properties docker, click the Frame button to display the frame-related options.
4. Type a value in the Number of columns box.

To resize text frame columns

1. Click the Text tool A and select a text frame with columns.
2. Perform a task from the following table.
To manually adjust column and gutter width

Do the following

Click the Text tool A. Drag a column side selection handle.

To set a specific column and gutter width

Do the following

In the Properties docker, click the Frame button to display the frame-related options. Click the Columns button and type values in the Width or Gutter boxes.

To automatically create columns of equal width

Do the following

In the Properties docker, click the Frame button to display the frame-related options. Click the Columns button and enable the Equal column width check box.

To change the flow of bidirectional text in columns

1. Select a paragraph text frame.
2. Click Window Dockers Properties.
3. In the Properties docker, click the Frame button to display the frame-related options.
4. Click the Columns button.
5. In the Column Settings dialog box, enable the Right-to-left columns check box.

The Right-to-left columns option is available only for bidirectional languages, such as Hebrew and Arabic. The proper keyboard must also be installed.

Combine and link paragraph text frames

You can combine text frames. You can also break text frames apart into subcomponents — columns, paragraphs, bullets, lines, words, and characters. Every time you break apart a text frame, the subcomponents are placed into separate text frames.

Linking text frames directs the overflow text of one text frame to another. If you resize a linked frame, or change the size of the text, the amount of text in the next frame is automatically adjusted. You can link text frames before or after you type text.

You cannot link artistic text. However, you can link a paragraph frame to an open or closed object. When you link a frame to an open object, such as a line, the text flows along the path of the line. Linking a text frame to a closed object, such as a rectangle, inserts a text frame and directs the flow of text inside the object. If text exceeds the open or closed path, you can link the text to another frame or object. You can also link to existing frames and objects across pages or create a linked frame in the same location on another page.

After linking text frames, you can redirect the flow from one object or text frame to another. When you select the text frame or object, a blue arrow indicates the direction of the text flow. You can hide or display these arrows.
You can make text flow between text frames and objects by linking the text. You can remove links between multiple frames, and between frames and objects. When you have only two linked frames and you remove the link, the overflow text remains in the second frame. Deleting a frame that is part of a series of linked frames redirects the text flow into the next frame or object.

By default, paragraph formatting, such as columns, drop caps, and bullets, is applied to the selected text frames only. However, you can change your settings so that formatting is applied to all linked text frames, or to all selected and subsequently linked text frames. For example, if you apply columns to the text in one frame, you can choose whether to apply columns to the text in all the linked frames.

To combine or break apart paragraph text frames

1. Select a text frame.
   If you are combining text frames, hold down **Shift**, and use the **Pick tool** to select subsequent text frames.

2. Click **Object**, and click one of the following:
   - **Combine**
   - **Break Apart**

   Text frames with envelopes, text fitted to a path, and linked text frames cannot be combined.

   If you first select a text frame with columns, the combined text frame will have columns.

To link paragraph text frames and objects

1. Using the **Text tool**, select the starting text frame.

2. Click the **Text flow** tab at the bottom of the text frame or object.
   If the text frame cannot hold all the text, the tab contains an arrow and the text frame becomes red.

3. When the pointer changes to a **Link to** pointer, do one of the following:
   - To link to a frame or object on the same page, click the text frame or object into which you want to continue the text flow.
   - To link to an existing frame or object on a different page, click the corresponding **Page** tab on the document navigator, and then click the text frame or object.
   - To create a new linked frame on another page, click the corresponding **Page** tab on the document navigator, and hover over the area of the drawing page that corresponds to the position of the first frame. When a preview of the frame appears, click to create the linked frame. The new frame has the same size and position as the original frame. If you click elsewhere on the page, the text frame that is created is the size of the entire page.
If a text frame is linked, the Text flow tab changes, and a blue arrow indicates the direction of text flow. If the linked text is on another page, the page number and a dashed blue line are displayed. To hide or display these indicators, see “To specify formatting preferences for text frames” on page 606.

To link text frames successfully, you have to make sure that the automatic sizing of frames is disabled. For more information, see “To add paragraph text” on page 601.

To redirect text flow to a different text frame or object
1 Using the Pick tool, click the Text flow tab at the bottom of the frame or object that contains the text flow that you want to modify.
2 Select the new frame or object into which you want the text flow to continue.

To remove links between text frames or objects
1 Using the Pick tool, select the linked frames or objects.
2 Click Text ➤ Paragraph Text Frame ➤ Unlink.

You can disconnect linked frames on different pages only if they are on facing pages.

You can also remove links by clicking a text frame, and then clicking Object ➤ Break text apart.

To specify formatting preferences for text frames
1 Click Tools ➤ Options ➤ CorelDRAW.
2 In the left pane of the dialog box that appears, click Text, and click Paragraph Text.
   If you want to hide or display the text flow indicators, disable or enable the Show linking of text frames check box.
3 In the When editing, apply paragraph frames formatting to area, enable one of the following options:
   • All linked frames — applies paragraph formatting to selected text frames and all text frames that are linked to them
   • Selected frames only — applies paragraph formatting to the selected text frames only
   • Selected and subsequent frames — applies paragraph formatting to selected text frames and any text frames that are later linked to them.

You can also

Display and hide text frames
   Enable the Show text frames check box.

Enable automatic expanding and shrinking of frames to fit text
   Enable the Expand and shrink paragraph text frames to fit text check box.

Align text to the baseline grid
You can align text within a frame or in different frames by using the baseline grid. This is useful, for example, when you want to align two or more text frames that contain different fonts, font sizes, and spacing.
All objects can snap to the baseline grid; only text frames can align to the baseline grid. Snapping is turned on or off for all objects (it’s a grid setting). Alignment is turned on or off for individual frames (it’s a text frame setting). For information about displaying or hiding the baseline grid, turning snapping on or off, changing the grid color, and setting the line spacing, see “Baseline grid” on page 743.

---

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vestibulum pulvinar, enim tristique egestas volutpat, erat elit adipiscing purus, a vehicula elit nulla vestibulum pulvinar.

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vestibulum pulvinar, enim tristique egestas volutpat, erat elit adipiscing purus, a vehicula elit nulla vestibulum pulvinar.

You can set one or more text frames to align to the baseline grid. When this option is enabled, the text in the text frame is aligned to the baseline grid when part or all of the text frame overlaps with the drawing page. If the text frame is moved completely outside the drawing page, the text is no longer aligned to the baseline grid.

If you align a text frame to the baseline grid and then link it to another frame, both frames are aligned to the baseline grid. If you align one of several already linked frames to the baseline grid, only the selected frame is aligned. For more information about linking text frames, see “Combine and link paragraph text frames” on page 604.

To align paragraph text to the baseline grid
1. Click View ➤ Grid ➤ Baseline Grid.
2. Select a text frame.
3. Click Text ➤ Align to Baseline Grid.

You can also right-click the text frame and choose Align to Baseline Grid.

You can align multiple selected frames at the same time.

Select text
CorelDRAW lets you select text to edit specific characters or modify it as an object. For example, you can select specific characters to change the font or select a text object, such as a text frame, so you can move, resize, or rotate it.
To select a text object

To Do the following

Select artistic text Using the Pick tool , click the artistic text.

Select a text frame Using the Pick tool , click the text frame.

You can use the Pick tool to select multiple text objects. Hold down Shift, and click each text object.

To select text for editing

To Do the following

Select specific characters of artistic or paragraph text for editing Using the Text tool , drag across the text.

Select a text frame for editing Using the Text tool , click the text frame.

Find, edit, and convert text

You can find text in a document and replace it automatically. You can also find and replace the properties of text objects. You can find special characters, such as an em dash or optional hyphen. You can edit text directly in the drawing window or in a dialog box.

Additional formatting options are available for paragraph text. To apply these formatting options to artistic text, you first need to convert the artistic text to paragraph text. Likewise, you can apply special effects to paragraph text by converting the text to artistic text. Converting text may result in the loss of any formatting.

You can also convert both paragraph and artistic text to curves. By transforming characters into lines or curve objects, you can add, delete, or move the nodes of individual characters to alter their shape. For more information, see "Curve objects" on page 214.

When you convert text to curves, the appearance of the text is preserved, including font, style, character position and rotation, spacing, and any other text settings and effects. Any linked text objects are also converted to curves. If you convert paragraph text in a fixed-sized text frame to curves, any text that overflows the text frame is deleted. For information about fitting text to a text frame, see "Format text" on page 623.

To find text

1 Click Edit Find and Replace.

2 In the Find and Replace docker, choose Find and Replace Text from the list box at the top of the docker.

3 Type the text that you want to find in the Find box.
   If you want to find the exact case of the text that you specified, enable the Match case check box.
   If you want to find whole words only, enable the Find whole words only check box.

4 Click Find Next.
You can also find special characters by clicking the right arrowhead next to the Find box, choosing a special character, and clicking Find Next.

You can also expand the search range to find text on all document pages, a range of pages, or specific pages. Conversely, you can limit the search to only currently selected objects. For more information, see “To set the search range” on page 361.

**To find and replace text**

1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Find and Replace Text from the list box at the top of the docker.
3. Enable the Replace option.
4. Type the text that you want to find in the Find box.
   - If you want to find the exact case of the text that you specified, enable the Match case check box.
   - If you want to find only whole words, enable the Find whole words only check box.
5. Type the replacement text in the Replace box.
6. Click one of the following buttons:
   - Find Next ➤ to scroll through occurrences of the text that is specified in the Find box
   - Replace — replaces the selected occurrence of the text that is specified in the Find box. If no occurrence is selected, Replace finds the next occurrence.
   - Replace All — replaces every occurrence of the text that is specified in the Find box

You can also expand the search range to find text on all document pages, a range of pages, or specific pages. Conversely, you can limit the search to only currently selected objects. For more information, see “To set the search range” on page 361.

**To find and replace text properties**

1. Click Edit ➤ Find and Replace.
2. In the Find and Replace docker, choose Replace Objects from the list box at the top of the docker.
3. Enable the Text properties option.
4. In the Find area, do any of following:
   - Enable the Font check box and choose the font to find.
   - Enable the Weight check box, and choose the text weight to find.
   - Enable the Size check box, and choose the text size to find.
5. In the Replace area, do any of following:
   - Enable the Font check box and choose a replacement font.
   - Enable the Weight check box, and choose a replacement text weight.
   - Enable the Size check box, and choose a replacement text size.
6. Click Find, and click any of the following:
   - Find Next ➤ or Find Previous < to scroll through text objects that meet the search criteria.
   - Find All to select all text objects that meet the search criteria.
   - Replace to replace the properties of the selected text object.
   - Replace All to replace the color of all text objects that meet the search criteria.
You can also expand the search range to find text on all document pages, a range of pages, or specific pages. Conversely, you can limit the search to only currently selected objects. For more information, see “To set the search range” on page 361.

To edit text

1. Click the **Text** tool  

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit artistic text</td>
<td>Click in the artistic text.</td>
</tr>
<tr>
<td>Edit paragraph text</td>
<td>Click in the text frame.</td>
</tr>
</tbody>
</table>

Text that has been converted to curves cannot be edited.

You can also edit text by clicking **Text**  → **Edit Text**, and making changes to the text in the **Edit Text** dialog box.

To convert text

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert paragraph text to artistic text</td>
<td>Using the <strong>Pick</strong> tool  → select the text and click <strong>Text</strong>  → <strong>Convert to Artistic Text</strong>.</td>
</tr>
<tr>
<td>Convert artistic text to paragraph text</td>
<td>Using the <strong>Pick</strong> tool  → select the text and click <strong>Text</strong>  → <strong>Convert to Paragraph Text</strong>.</td>
</tr>
<tr>
<td>Convert artistic or paragraph text to curves</td>
<td>Using the <strong>Pick</strong> tool  → select the text and click <strong>Object</strong>  → <strong>Convert to Curves</strong>.</td>
</tr>
</tbody>
</table>

Paragraph text cannot be converted to artistic text when it’s in a linked frame, has text overflow, or has special effects applied to it.

You can also convert text to curves by clicking the **Pick** tool  → right-clicking the text and clicking **Convert to Curves**.
Shift, rotate, mirror, and flip text

You can shift the characters of artistic and paragraph text vertically or horizontally or rotate them to create interesting effects. You can straighten characters into their original position, and you can return vertically shifted characters to the baseline. You can also mirror or flip artistic and paragraph text characters.

If you want to adjust the position of an entire text object that is fitted to a path, such as a circle or a freehand line, see “To adjust the position of text that is fitted to a path” on page 615.

To shift or rotate a character

1. Using the Text tool A, select the character or characters.
2. In the Properties docker, click the Character button A to display the character-related options.
   - To display the Properties docker, click Window ➔ Dockers ➔ Properties.
3. Click the arrow button at the bottom of the Character area to display additional options.
4. Type a value in one of the following boxes:
   - Horizontal character offset — A positive number moves characters to the right, and a negative number moves characters to the left.
   - Vertical character offset — A positive number moves characters up, and a negative number moves characters down.
   - Character angle — A positive number rotates characters counterclockwise, and a negative number rotates characters clockwise.

   You can also use the Shape tool to shift or rotate characters. Select the character node or nodes, and then type values in the Horizontal character offset box, Vertical character offset box, or Character angle box on the property bar.

To straighten a shifted or rotated character

1. Using the Text tool A, select one or more characters.
2. Click Text ➔ Straighten text.

To return a vertically shifted character to the baseline

1. In the toolbox, open the Shape tool flyout.
2. Click the Shape tool .

Rotated characters
3 Select the text object, and select the node to the left of the shifted character.

4 Click Text ▶ Align to Baseline.

To mirror text
1 Using the Pick tool, select a text object.
2 On the property bar, click one of the following buttons.
   • Mirror horizontally — flips the text characters from left to right
   • Mirror vertically — flips the text characters from top to bottom

You can also mirror text by holding down Ctrl and dragging a selection handle to the opposite side of the object.
You can also mirror text fitted to a path. For more information, see “To mirror text that is fitted to a path” on page 616.

To flip text by dragging diagonally
1 Using the Text tool A, select the artistic text or the paragraph text frame.
2 Drag a middle selection handle across the text and past the corner handle on the opposite side.

Move text
CorelDRAW offers different methods for moving text. If you select text as an object, such as a block of artistic text or a text frame, you can move it to a new position, as you would any other object.
You can also move a selection of paragraph text between text frames or move artistic text between artistic text objects. Conversely, you can move paragraph text to an artistic text object, or artistic text to a paragraph text frame.

To move a text object
1 Click the Pick tool .
2 Drag the text object to a new position in the drawing window.

To move a text selection
1 Click the Text tool A.
2 Select the text that you want to move.
3 Perform a task from the following table.
To Do the following

Move text within the same text object Drag the text to a new position within the text object. The text cursor appears to indicate the insertion point.

Move the text to another text object. Drag the text to another text object. The text cursor appears to indicate the insertion point.

Move or copy selected text to a new text object With the right mouse button, drag the text to a new position, release the mouse button, and click Copy here or Move here.

Move an individual character freely in the drawing window Click the Shape tool , select the text object, and drag a character’s selection handle in the lower-left corner of the character.

Wrap text

You can change the shape of text by wrapping paragraph text around an object, artistic text, or a text frame. You can wrap text by using contour or square wrapping styles. The contour wrapping styles follow the curve of the object. The square wrapping styles follow the bounding box of the object. You can also adjust the amount of space between paragraph text and the object or text, and you can remove any previously applied wrapping style.

To wrap paragraph text around an object, artistic text, or a text frame

1 Select the object or text around which you want to wrap text.
2 Click Window ➤ Dockers ➤ Properties.
3 In the Properties docker, click the Summary button to display the wrap options.
4 Choose a wrapping style from the Wrap paragraph text list box. If you want to change the amount of space between wrapped text and the object or text, change the value in the Text wrap offset box.
5 Click the Text tool and drag over the object or text to create a paragraph text frame.
6 Type text in the text frame.

You can wrap existing paragraph text around a selected object by applying a wrapping style to the object and dragging the text frame over the object.
To remove a wrapping style
1 Select the wrapped text or the object it wraps.
2 Click Window ➤ Dockers ➤ Properties.
3 In the Properties docker, click the Summary button to display the wrap options.
4 Choose None from the Wrap text list box.

Fit text to a path
You can add artistic text along the path of an open object (for example, a line) or a closed object (for example, a square). You can also fit existing text to a path. Paragraph text in a text frame can be fitted to open paths only.

After you fit text to a path, you can adjust the text position relative to that path. For example, you can mirror the text horizontally, vertically, or both. Using tick spacing, you can specify an exact distance between the text and the path.

CorelDRAW treats text fitted to a path as one object; however, you can separate the text from the object if you no longer want it to be part of the path. When you separate text from a curved or closed path, the text retains the shape of the object to which it was fitted. You can also modify the text and path properties independently.

The text reverts to its original appearance when you straighten it.

To add text along a path
1 Using the Pick tool, select a path.
2 Click Text ➤ Fit Text to Path.
   The text cursor is inserted on the path. If the path is open, the text cursor is inserted at the beginning of the path. If the path is closed, the text cursor is inserted at the center of the path.
3 Type along the path.
Text cannot be added to the path of another text object.

You can also fit text to a path by clicking the Text tool A and pointing to a path. When the pointer changes to the Fit Text to Path pointer →, click where you want the text to begin, and type.

To fit text to a path
1. Using the Pick tool , select a text object.
2. Click Text ➤ Fit Text to Path.
   The pointer changes to the Fit Text to Path pointer →. By moving the pointer over the path, you can preview where the text will be fitted.
3. Click a path.
   If the text is fitted to a closed path, the text is centered along the path. If the text is fitted to an open path, the text flows from the point of insertion.

Artistic text can be fitted to open or closed paths. Paragraph text can be fitted to open paths only.

Text cannot be fitted to the path of another text object.

To adjust the position of text that is fitted to a path
1. Using the Pick tool , select the text that is fitted to a path.
2. Choose a setting from any of the following list boxes on the property bar:
   • Text orientation — specifies how the text bends to follow the path
   • Distance from path — distance between the text and the path
   • Offset — horizontal position of the text along the path

You can also

Use tick spacing to increase the distance between the path and the text in specified increments

Select the text. On the property bar, click Tick snapping, enable the Tick snapping on option, and type a value in the Tick spacing box.

When you move the text from the path, it moves in the increment you specified in the Tick spacing box. When you move the text, the distance from the path is displayed below the original text.

Change the horizontal position of fitted text

Using the Shape tool , select the text, and drag the character nodes that you want to reposition.
You can also

Move fitted text along or off the path
Using the Pick tool , drag the red glyph that appears next to the text.

When you drag the glyph along the path, a preview of the text is displayed. When you drag the glyph off the path, the distance between the text preview and the path is displayed.

To mirror text that is fitted to a path
1 Using the Pick tool , click the text that is fitted to a path.
2 On the property bar, click one of the following buttons:
   • Mirror text horizontally — flips the text characters from left to right
   • Mirror text vertically — flips the text characters upside down

You can apply a 180-degree rotation to text that is fitted to a path by clicking both the Mirror text horizontally and the Mirror text vertically buttons.

You can also mirror artistic text and paragraph text frames. For more information, see “To mirror text” on page 612.

To separate text from a path
1 Using the Pick tool , select the path and the fitted text.
2 Click Object Break Text Apart.

To straighten text
1 Using the Pick tool , select the path and the fitted text.
2 Click Object Break Text Apart.
3 Using the Pick tool, select the text.
4 Click Text Straighten Text.

Special characters, symbols, and glyphs
Using the Glyphs docker, you can find and insert special characters, symbols, and glyphs (variations of individual characters or character combinations) of OpenType fonts.

Filtering
All characters, symbols, and glyphs included in a font are displayed by default, but you can filter character subsets to display only the characters you want. For example, you can display only currency symbols or numbers, or you can display only Cyrillic characters and symbols.

Characters included in a font are organized in the following categories:
• Common — includes arrows, currency, mathematical symbols, numbers, punctuation marks, and separators as well as CJK symbols and punctuation marks (used in Asian scripts)
• Scripts — includes the scripts that the selected font supports, such as Latin, Greek, Cyrillic, Hiragana and Katakana, Han, Arabic, or Hebrew scripts
• OpenType — includes the OpenType features provided by the selected font such as standard ligatures, discretionary ligatures, fraction, alternate annotation forms, and more. For more information about OpenType features, see “OpenType features” on page 631.
OpenType fonts

The Glyphs docker is ideal for viewing and applying the OpenType features provided by OpenType fonts. The default view shows a list of characters in which the glyphs for individual characters appear grouped. Alternatively, you can display a longer list that shows available glyphs at a glance.

Viewing character position

Each selected character appears against a set of blue lines that let you preview its position in relation to the text baseline.

1) Text baseline
2) Ascender line
3) Font x-height
4) Descender line

Most recently used special characters

You can use the list of most recently used special characters to copy characters that you use often. The list retains the font attributes of most recently used characters and any OpenType features that were applied. You can manage the list by removing characters that you no longer need.

Glyphs without Unicode numbers

Glyphs that have no Unicode mapping can be accessed only in specific circumstances and with specific sets of OpenType features. Such glyphs cannot be inserted by using keystrokes, but you can still add them to your document from the Glyphs docker.

Glyphs without Unicode numbers are inserted as glyphs not characters; therefore, you cannot change their font. For example, if you change the font of text that contains a glyph without Unicode mapping from Gabriola to Impact, the glyph will remain a Gabriola glyph as shown in the following example.

Left: A glyph without a Unicode number. Top: Text that starts with this glyph. Bottom: The font is changed, but the glyph remains the same.

It is easy to tell glyphs without Unicode mapping apart from other glyphs because they are displayed against a gray background in the Glyphs docker.
To add a special character, symbol, or glyph
1. Using the Text tool ☐, click where you want to add the special character.

2. Click Text ➔ Glyphs.

3. In the Glyphs docker, choose a font from the Font list box.

4. Double-click a character in the Character and glyph list.
   If you cannot find the character you want, open the Character filter list box, and enable the Entire font check box.

You can also

Drag a character
Using the Pick tool ☐, drag a character to the document window.

Copy a character
Click a character in the Character and glyph list, and click Copy.

View information about a selected character
Click the arrow button ▼ at the bottom of the Character and glyph list to view any of the following attributes that are applicable: character name, ID, Unicode number, keyboard shortcut for inserting the character, the OpenType feature name, and the language for glyphs that can be displayed properly only in a specific language.

Zoom in and out
Move the Zoom slider.

To zoom in and out in preset increments, click the zoom buttons to the right and left of the Zoom slider.
You can also

Navigate to a special character by using an Alt code

Click in the **Character and glyph** list, hold down **Alt**, and type the Alt code for the character you want.

Navigate to a character

Press the corresponding key on the keyboard.

To filter special characters, symbols, and glyphs

1. Click **Text** ➤ **Glyphs**.
2. In the **Glyphs** docker, choose a font from the **Font** list box.
3. Open the **Character filter** list box, and enable the check boxes for the character subsets that you want to display.
4. Click **Close**.

To view glyphs of OpenType features

1. Click **Text** ➤ **Glyphs**.
2. In the **Glyphs** docker, choose an OpenType font from the **Font** list box.
3. Open the **Character filter** list box, and in the **OpenType** area, enable any of the check boxes for the available OpenType features.
4. Do one of the following:
   - To display a list that includes grouped glyphs, make sure that the **Show all glyphs** button does not appear pressed. To view all glyphs in a group, click a character, and then click the OpenType feature indicator. Click a glyph to display it in the **Character and glyph** list.
   - To display a list that includes all available glyphs, click the **Show all glyphs** button.
Left: The OpenType feature indicators below individual characters show that more glyphs are available.
Right: When the Show all glyphs button (1) is pressed, you can see available glyphs at a glance.

Viewing grouped glyphs

The **Show all glyphs** button is not available for fonts that do not support OpenType features.

Some glyphs provided by OpenType features vary depending on the context in which they appear and cannot be shown in the **Glyphs** docker. You can view and insert such glyphs in the document window by using the onscreen OpenType feature indicator. For more information, see "To enable the onscreen OpenType feature indicator" on page 635.

**To use the list of most recently used special characters**

1. Click **Text** ▶ **Glyphs**.
2. In the list of most recently used special characters (glyphs), perform a task from the following table.
To view the font and OpenType attributes of a character, you must point to the character.

To copy a character from the list, you must right-click the character and click **Copy**.

To remove characters from the list, you must right-click a character and click **Remove** or **Remove all**.

### Embed graphics

You can embed a graphic **object** or **bitmap** in text. The graphic object or bitmap is treated as a text character. As a result, you can apply formatting options according to the type of text in which you embed the graphic object. You can also remove an embedded object from text, after which the object returns to its original state.

### To embed a graphic object in text

1. Select a graphic **object**.
2. Click **Edit**, and click one of the following:
   - **Cut**
   - **Copy**
3. Using the **Text** tool \( A \), click where you want to embed the graphic object.
4. Click **Edit** ➔ **Paste**.

### To remove an embedded object from text

1. Using the **Text** tool \( A \), select an embedded **object**.
2. Click **Edit** ➔ **Cut**.
3. Click the **Pick** tool \( \vec { } \), and click outside the text object.
4. Click **Edit** ➔ **Paste**.

### Legacy text

If a document contains text and was created in a previous version of CorelDRAW, such as CorelDRAW X5, you must update the legacy text before you can use new text features such as OpenType options and aligning text with the **baseline** grid. For more information, see “OpenType features” on page 631 and “Align text to the baseline grid” on page 606.

### To update legacy text

1. Open the document with legacy text. An **Update** toolbar appears at the top of the drawing window.
2. Click **Update**. To undo the update, click **Undo** on the **Update** toolbar. However, once you make changes to the updated text, this option is no longer available.
When legacy text is updated, its flow and layout may change.

You can also update legacy text by clicking the **Update** button in the **Character area** of the **Properties** docker.
CorelDRAW offers many tools and controls for formatting individual characters, entire paragraphs, and text in frames.

This section contains the following topics:
- “Choose typefaces and fonts” (page 623)
- “Format characters” (page 626)
- “Change text color” (page 627)
- “Kern a range of characters” (page 629)
- “Change text case and capitalization” (page 629)
- “OpenType features” (page 631)
- “Variable fonts” (page 635)
- “Adjust character and word spacing” (page 637)
- “Adjust line and paragraph spacing” (page 639)
- “Create bulleted and numbered lists” (page 640)
- “Drop caps” (page 644)
- “Change character position and angle” (page 645)
- “Align text” (page 646)
- “Add tabs and indents” (page 648)
- “Text styles” (page 649)
- “Hyphenate text” (page 650)
- “Formatting codes” (page 652)
- “Nonprinting characters” (page 653)

Choose typefaces and fonts

Text is an important element in the design and layout of documents. In CorelDRAW, you can choose the typeface that is best suited to your project. You can specify the font size and style. In addition, you can use an OpenType font to achieve a unique and distinctive style. For more information, see “OpenType features” on page 631. The default unit of measure for text is points; however, you can change the unit of measure for the active drawing and all subsequent drawings. For information about previewing fonts, see “View fonts” on page 664.

Fonts vs. typefaces

“Font” and “typeface” are two typography terms that are often used interchangeably, but they do not have the same meaning. A font is a collection of characters that includes letters, numbers, and symbols of one variation of a typeface, such as bold or italic. A typeface, which is also known as a font family, is made up of several fonts that share similar design characteristics. In other words, a font is the mechanism
that allows you to render the characters onscreen or in print, whereas the typeface, which embodies the style and visual distinctiveness of the characters, refers to the design and style of the type.

The following table lists a few examples of typefaces and fonts.

<table>
<thead>
<tr>
<th>Typeface (Font family)</th>
<th>Font</th>
</tr>
</thead>
<tbody>
<tr>
<td>Helvetica</td>
<td>Helvetica Bold-Italic</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Normal</td>
</tr>
<tr>
<td>Verdana</td>
<td>Verdana Bold-Italic</td>
</tr>
</tbody>
</table>

**Choosing a typeface**

Typefaces come in different shapes and sizes and have unique characteristics and expressive qualities. Choosing the right typeface is an important design consideration because it can set the tone of the project. Moreover, it can help, or hinder, effective communication. For example, if you design a poster with a typeface that is difficult to read, or sets the wrong tone, your message may not effectively reach your intended audience.

Here are a few basic tips for choosing the right typeface:

- Choose a typeface that best suits the tone of your design.
- Choose a typeface that is appropriate for the final output of your design (e.g. web or print).
- Use less typefaces in your document. The general rule is not to exceed three or four typefaces in a document.
- Make sure the typeface characters are easy to read and recognize.
- Choose a typeface that is appropriate for the age of your target audience.
- Make sure the typeface of headings stands out and looks good when displayed at larger sizes.
- Make sure the typeface of body text enhances readability.
- Choose a typeface that supports multiple languages if you’re working on multilingual documents.

**To change the font**

1. Using the **Text** tool, select a character or a block of text.
   - If the **Properties** docker is not open, click **Window** → **Dockers** → **Properties**.
2. In the **Properties** docker, click the **Character** button to display the character-related options.
3. In the **Character** area of the **Properties** docker, perform one or more tasks from the following table.

**To** | **Do the following**
---|---
Choose a typeface | Choose a typeface from the **Font** list box.

For information about finding fonts more easily, see “Filter fonts” on page 665 and “Search for fonts” on page 667.
To Do the following

Set font size
Type a value in the Font size box.

Change the font style
Choose a style from the Font style list box.

💡 You can also change the font and font size from the property bar.
You can also change the font style of selected text by clicking the Bold button B, Italic button I, or Underline button U on the property bar.

To resize text
1 Using the Text tool A, select a character or a block of text.
2 On the property bar, choose a size from the Font size list box.

💡 You can also

Resize artistic text using the Pick tool
Click the Pick tool , and drag one of the corner handles.

Resize paragraph text using the Pick tool
Click the Pick tool , press Alt, and then drag one of the corner handles.

Increase the size of text
Press Num Lock to activate the number pad on your keyboard, and use the Text tool A to select the text. Then, hold down Ctrl, and press 8 on the number pad.

Decrease the size of text
Using the Text tool A, select the text. Then, hold down Ctrl, and press 2 on the number pad.

Set an increment for resizing text
Click Tools ▶ Options ▶ CorelDRAW. In the left pane of the dialog box that appears, click Text, and type a value in the Keyboard text increment box on the Display page.

Change the default unit of measure
Click Tools ▶ Options ▶ CorelDRAW. In the left pane of the dialog box that appears, click Text, and choose a unit from the Default text units list box on the Display page.

💡 You can also resize the text from the Character area of the Properties docker, by choosing a size from the Font size list box.
Format characters

You can change the position and appearance of characters by displaying them as subscript or superscript, which is useful in drawings with scientific notations. If you select an OpenType font that supports subscript and superscript, you can apply the OpenType feature. However, if you select a font, including an OpenType font, that does not support subscript and superscript, you can apply a synthesized version of the character, which CorelDRAW produces by altering the characteristics of the default font character. For more information, see “OpenType features” on page 631.

You can also add underlines, strikethrough lines, and overlines to selected characters.

To insert superscript or subscript text

1 Using the Text tool A, select a character or a block of text.
   If the Properties docker is not open, click Window Dockers Properties.
2 In the Properties docker, click the Character button A to display the character-related options, and click the arrow for more options.
3 In the Character area of the Properties docker, click the Position button, and choose one of the following options.
   • None — turns off all the features in the list
   • Superscript (auto) — applies the OpenType feature if the font supports it, or applies a synthesized version if the font does not support superscript
   • Subscript (auto) — applies the OpenType feature if the font supports it, or applies a synthesized version if the font does not support subscript
• **Superscript (synthesized)** — applies a synthesized version of the superscript feature, which looks the same as in previous versions of CorelDRAW

• **Subscript (synthesized)** — applies a synthesized version of the subscript feature, which looks the same as in previous versions of CorelDRAW

Some OpenType fonts may appear to support features that are unsupported. For example, Superscript and Subscript options may appear available, but are not. If you apply one of these OpenType fonts, CorelDRAW cannot provide a synthesized version of Superscript and Subscript.

**To underline, overline, or strikethrough text**

1. Using the **Text** tool A, select a character or a block of text.
   
   If the **Properties** docker is not open, click **Window** Dockers Properties.

2. In the **Properties** docker, click the **Character** button A to display the character-related options.

3. In the **Character** area of the **Properties** docker, click the arrow button located at the bottom of **Character** area to display the additional character options.

4. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Underline text</td>
<td>Click the <strong>Underline</strong> button U and choose a style from the list box.</td>
</tr>
<tr>
<td>Apply a line through the selected text</td>
<td>Choose a style from the <strong>Character strikethrough</strong> list box.</td>
</tr>
<tr>
<td>Apply a line above the selected text.</td>
<td>Choose a style from the <strong>Character overline</strong> list box.</td>
</tr>
</tbody>
</table>

**Change text color**

You can quickly change both the fill and outline color of text. You can change the fill, outline, and background color of text. You can change the color of individual characters, a block of text, or all characters in a text object.
To quickly change the color of a text object
1 Using the Pick tool, click a text object to select it.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>To fill characters in a text object with one color</td>
<td>Click any color swatch on the default color palette or drag a color swatch to the text object.</td>
</tr>
<tr>
<td>To apply an outline color to all characters in a text object</td>
<td>Right-click any color swatch on the default color palette or drag a color swatch to the edge of a character in the text object.</td>
</tr>
</tbody>
</table>

To change the color of a text selection
1 Using the Text tool, select a character or a block of text.
   If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.
2 In the Properties docker, click the Character button to display the character-related options.
3 In the Character area of the Properties docker, perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a fill</td>
<td>In the text color area, choose a fill type from the Fill type list box, open the Fill picker, and then click a color or a fill.</td>
</tr>
<tr>
<td>Modify fill settings</td>
<td>In the text color area, click the Fill settings button and modify the settings in the dialog box.</td>
</tr>
<tr>
<td>Choose a background fill</td>
<td>In the text background color area, choose a fill type from the Background fill type list box, open the Fill picker, and then click a color or a fill.</td>
</tr>
<tr>
<td>Modify background fill settings</td>
<td>In the text background color area, click the Fill settings button and modify the settings in the dialog box.</td>
</tr>
<tr>
<td>Choose an outline width</td>
<td>In the text outline color area, click the Outline width list box, and choose an option from the list.</td>
</tr>
<tr>
<td>Choose an outline color</td>
<td>In the text outline color area, click the Outline color picker, and click a color.</td>
</tr>
<tr>
<td>Modify line outline settings</td>
<td>In the text outline color area, click the Outline settings button and modify the settings in the Outline pen dialog box.</td>
</tr>
</tbody>
</table>
Kern a range of characters

You can kern pairs of selected characters. Kerning refers to the repositioning of two characters to balance the optical space between them. For example, kerning is often used to decrease the space in character pairs such as AW, WA, VA, or TA. Such character pairs are known as “kerning pairs.” Kerning increases readability and makes letters appear balanced and proportional, especially at larger font sizes.

To kern text

1. Using the **Text** tool, select the characters that you want to kern. The selected characters appear highlighted.
   - If the **Properties** docker is not open, click **Window**  **Dockers**  **Properties**.

2. In the **Properties** docker, click the **Character** button to display the character-related options.

3. In the **Character** area of the **Properties** docker, type a value in the **Range kerning** box.
   - Negative values decrease the spacing between characters; positive values increase the spacing between characters.

Change text case and capitalization

You can control the case of words, sentences, or paragraphs of selected text. For example, you can apply title case to selected text to capitalize the initial letter of every word. This is a useful formatting technique for headings, such as book or chapter titles.

You can automatically convert text to lowercase or uppercase without deleting or retyping letters. For example, you can quickly make a label or header in your document stand out by converting it to all caps (uppercase).

**Lorem ipsum dolor sit amet**

**LOREM IPSUM DOLOR SIT AMET**

(From top to bottom) The following text case options are applied to an artistic text object: **Sentence case**, **lowercase**, **UPPERCASE**, **Title case**, and **tOGGLE case**.
CorelDRAW lets you change the capitalization of artistic and paragraph text. For example, you can apply small caps to acronyms so they visually blend with the text. If you apply default capitalization, the text stands out too much and impacts the readability. In the following example, the acronym “A.M.” is shown with both the default uppercase and small caps applied.

**Default uppercase**

The class begins at 9:00 A.M. in room 132.

**Small caps**

The class begins at 9:00 a.m. in room 132.

With uppercase text, you can adjust the spacing between capital characters to improve readability provided the font supports capital spacing.

**To change the text case**

1. Using the **Pick** tool, click a text object to select it.
2. Click **Text** > **Change Case**.
3. In the **Change Case** dialog box, enable one of the following options:
   - **Sentence case** — capitalizes the first letter in the first word in artistic text or the first letter in the first word in each sentence in paragraph text
   - **lowercase** — substitutes uppercase characters with lowercase equivalents
   - **UPPERCASE** — substitutes lowercase characters with uppercase equivalents
   - **Title case** — capitalizes the first letter in each word
   - **tOGGLE case** — reverses the case of all characters, making lowercase characters uppercase and uppercase characters lowercase

**To change the capitalization of characters**

1. Using the **Text** tool, select a character or a block of text.
   - If the **Properties** docker is not open, click **Window** > **Dockers** > **Properties**.
2. In the **Properties** docker, click the **Character** button to display the character-related options.
3. In the **Character** area of the **Properties** docker, click the **Caps** button, and click one of the following options:
   - **None** — turns off all of the features in the list
   - **All Caps** — substitutes lowercase characters with upper case equivalents
   - **Titling Caps** — applies the OpenType version of the feature if the font supports it
   - **Small Caps (auto)** — applies the OpenType version of the feature if the font supports it
   - **All Small Caps** — substitutes characters with a scaled-down version of the upper case characters
   - **Small Caps from Caps** — applies the OpenType version of the feature if the font supports it
   - **Small Caps (synthesized)** — applies a synthesized version of **Small caps**, which appears the same as in previous versions of CorelDRAW

If the font supports capital spacing, you can click the **Capital spacing** button to increase the spacing between capital characters and improve readability.

If you choose a non-OpenType font that supports Caps styles, CorelDRAW provides a synthesized version of the Small caps and All small caps styles.

Some OpenType fonts may appear to support features that are unsupported.
OpenType features

CorelDRAW supports OpenType fonts so you can take advantage of their advanced typographic features. OpenType features allow you to choose an alternate appearance for an individual character (also referred to as a glyph) or a sequence of characters. For example, you can choose alternate glyphs for numbers, fractions, or ligature sets.

You can access OpenType commands and options in the Character area of the Properties docker. You can also let CorelDRAW prompt you which OpenType features you can apply by enabling the Interactive OpenType option. When you select text, an indicator arrow appears below the text if an OpenType feature is available. You can click the indicator to access a list of the most popular OpenType features that are available for the selected text.

The OpenType font specification was created jointly by Adobe and Microsoft. Based on Unicode, OpenType fonts extend the capabilities of older font technologies. The most notable advantages of OpenType are:

- cross-platform support (Windows and macOS)
- extended character sets that offer better language support and advanced typographic features
- coexistence with Type 1 (PostScript) and TrueType fonts
- support for a larger glyph limit (64k)

OpenType features

The following table describes the OpenType features that you can apply in CorelDRAW provided that the feature is included in the font.

In addition, CorelDRAW also provides synthesized versions of some Caps and Position OpenType features. For example, if a font does not support a feature, such as Small Caps, CorelDRAW produces its own version of the glyph by scaling the font.

<table>
<thead>
<tr>
<th>OpenType feature</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caps</td>
<td>Changes the case of text, which is useful for inserting titles and acronyms</td>
<td>Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet.</td>
</tr>
</tbody>
</table>

Clicking the Interactive OpenType indicator arrow expands a list of the most popular OpenType features that are available for the selected text.
<table>
<thead>
<tr>
<th>OpenType feature</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>Displays characters as superscript or subscript, which is useful for inserting footnotes or mathematical symbols. If you select an OpenType font that does not support subscript and superscript, or a non-OpenType font, you can apply a synthesized glyph.</td>
<td>Lorem&lt;sup&gt;m&lt;/sup&gt;</td>
</tr>
<tr>
<td>Number styles</td>
<td>Includes features for controlling the appearance of numbers</td>
<td>See examples below</td>
</tr>
<tr>
<td>Number styles — Proportional lining</td>
<td>Displays numbers of varying width, which is best suited for inserting numbers in body text. However, the numbers have a fixed height, which generally matches the height of capital letters.</td>
<td>123</td>
</tr>
<tr>
<td>Number styles — Tabular lining</td>
<td>Displays numbers of equal width, spacing, and height, which is useful for aligning text and displaying text in a table.</td>
<td>123</td>
</tr>
<tr>
<td>Number styles — Proportional Oldstyle</td>
<td>Displays numbers of varying width and height. The style is best suited for blending numbers with mixed text case.</td>
<td>123</td>
</tr>
<tr>
<td>Number styles — Tabular Oldstyle</td>
<td>Displays numbers of equal width, but varying height</td>
<td>123</td>
</tr>
<tr>
<td>Fraction</td>
<td>Displays numbers separated by a slash as fractions. The number of available fractions vary from font to font. Apply this feature only to the numbers that you want to display as a fraction.</td>
<td>See examples below</td>
</tr>
<tr>
<td>Fraction — Numerator</td>
<td>Displays a numerator, such as 456/, as a fraction glyph. This is useful for displaying a non-standard fraction, such as 456/789, as a fraction. Use the Numerator feature in conjunction with the Denominator feature to display non-standard fractions as fractions.</td>
<td>99/100</td>
</tr>
</tbody>
</table>
### OpenType feature

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fraction — Denominator</td>
<td>Displays a denominator, such as /789, as a fraction glyph. This is useful for displaying a non-standard fraction, such as 456/789, as a fraction. Use the Denominator feature in conjunction with the Numerator feature to display non-standard fractions as fractions.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Fraction — Fraction</td>
<td>Displays standard fractions as fraction glyphs</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Fraction — Alternative fraction</td>
<td>Displays a fraction by using a horizontal dividing line instead of a slant or slash</td>
<td>Not available</td>
</tr>
<tr>
<td>Ordinals</td>
<td>Displays ordinals by using a number and a suffix in superscript. For example, you can display “first” as 1&lt;sup&gt;st&lt;/sup&gt; or “second” as 2&lt;sup&gt;nd&lt;/sup&gt;. Apply this feature only to the text that you want to display as an ordinal.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Slashed zero</td>
<td>Displays zeros with a diagonal slash, which makes them easy to distinguish from the letter O. This feature is useful for displaying numbers in financial reports.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Ornaments</td>
<td>Substitutes a character with an ornament that was created by the font designer to match the font’s motif</td>
<td>Not available</td>
</tr>
<tr>
<td>Stylistic alternates</td>
<td>Applies an alternate design to characters</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Stylistic sets</td>
<td>Applies an alternate design to a text selection</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Swash Variants</td>
<td>Inserts calligraphic-type decorative characters</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td><strong>OpenType feature</strong></td>
<td><strong>Description</strong></td>
<td><strong>Example</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------</td>
<td>------------</td>
</tr>
<tr>
<td>Contextual alternates</td>
<td>Lets you fine-tune text by applying an alternate design to a single character, or a sequence of characters, based on its surrounding characters. For example, you can apply this feature to script-based text so that it flows more naturally.</td>
<td>Not available</td>
</tr>
<tr>
<td>Case-sensitive forms</td>
<td>Shifts the position of punctuation marks so they align with capitalized text or lining numbers</td>
<td>Not available</td>
</tr>
<tr>
<td>Standard Ligatures</td>
<td>Replaces a letter pair (or a sequence of letters) with one glyph, which is called a ligature. Many OpenType fonts include standard ligatures for fi, fl, ff, ffi, and ffl. Their purpose is to improve text readability.</td>
<td><img src="image" alt="ff ff" /></td>
</tr>
<tr>
<td>Discretionary Ligatures</td>
<td>Replaces a non-standard letter combination with a ligature. Discretionary ligatures designed to be decorative and are not supported by the majority of OpenType fonts.</td>
<td><img src="image" alt="st st" /></td>
</tr>
<tr>
<td>Contextual ligatures</td>
<td>Inserts a glyph that best suits the surrounding characters. Contextual ligatures are designed to increase readability by improving the joining behavior between the characters of a ligature.</td>
<td>Not available</td>
</tr>
<tr>
<td>Historical ligatures</td>
<td>Substitutes a letter pair, or a letter sequence, with a ligature that is based on historical usages. Historical ligatures are designed to be ornamental and are not supported by the majority of OpenType fonts. The most commonly-used historical ligatures are the letter s combined with another character, such as sh si sl ss, and st.</td>
<td>Not available</td>
</tr>
<tr>
<td>Historical forms</td>
<td>Substitutes modern characters with characters that were commonly used in historical documents. Historical forms are useful for recreating historical text.</td>
<td>Not available</td>
</tr>
</tbody>
</table>

**To apply an OpenType feature to text**

1. Using the **Text** tool, a single character or a sequence of characters.
2. If the **Properties** docker is not open, click **Window** ➔ **Dockers** ➔ **Properties**.
2. In the Properties docker, click the Character button A to display the character-related options.

3. In the Character area of the Properties docker, click an OpenType feature button, and, if applicable, choose a feature from the list.

Some OpenType fonts may appear to support features that are not supported.

**To enable the onscreen OpenType feature indicator**

- Click the Text tool A and then click the Interactive OpenType button O on the property bar.

  If an OpenType feature is available for the selected text, an arrow ▼ appears below the text.

**You can also**

<table>
<thead>
<tr>
<th>View a list of the most popular OpenType features onscreen</th>
<th>Click the down arrow ▼ below the text in the document window.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply an OpenType feature to a text selection</td>
<td>In the OpenType feature list, click a feature.</td>
</tr>
</tbody>
</table>

**Variable fonts**

CorelDRAW supports variable OpenType fonts. A variable font can include an entire font family in a single font file, giving you access to an array of weights, widths, and styles.

A property of a variable font that varies is known as an axis of variation. You can change a variable font along one or more axes of variation such as width, weight, and slant; or along custom axes specified by the font designer. The named design variations along an axis are known as instances. Named instances are similar to presets. For example, the Gingham variable font changes along two axes: weight and width. This font has several named instances featuring different weights and widths such as Light, Light Condensed Regular, Bold, Condensed Bold, Condensed Light, Condensed Regular, Wide Bold, and more. On the weight axis, Light and Bold are at the opposite ends of the axis; on the width axis, Condensed and Wide are at the opposite ends.

This illustration shows several instances of the Gingham variable font.

To achieve a wider range of style variations, you can adjust the available properties (axes) of a variable font instance. If you want to save a style variation for later use, you can save it to a text or paragraph style. For more information about saving object properties to a style, see “To create a style from an object” on page 698.
Variable fonts are identified by an icon. To find variable fonts quickly, you can use a filter. For more information, see “To filter fonts” on page 666.

Variable fonts can be identified by their icon.

Variable fonts are OpenType version 1.8 fonts that use OpenType Font Variations mechanisms. You can use variable fonts to format text for optimum readability. For example, you can format headings of different size in different weights, or data-dense text in narrow widths. When used on web pages, variable fonts can often help reduce the size of font data, thus decreasing the page load times.

The continuous range of style variations can also help with responsive design.

To adjust variable font properties
1. With the Text tool, select a character or a block of text that uses a variable font.
2. Click the Variable fonts button on the property bar, and adjust any available font properties.
Adjusting a variable font along two axes: width (left to right) and weight (top to bottom).

💡 You can also access the **Variable fonts** button from the **Properties** docker and the **Text** docker.

**Adjust character and word spacing**

You can improve text readability by adjusting the character and word spacing. When letters or words are too close together, or too far apart, they become difficult to read. CorelDRAW offers you different tools for controlling text spacing.

**Character spacing**

You can change the spacing between characters (also known as “letter spacing”) in a block of text. For example, fully justifying a block of text may insert too much space between characters, which creates a visual imbalance. To improve readability, you can decrease the character spacing.

```
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus
scelerisque enim et est ullamcorper a fringilla
lectus dictum.
```

*Increased character spacing (left) makes it difficult to read the text. Decreased character spacing (right) improves readability.*

If you want to change the spacing between several characters, you need to adjust the kerning. For more information, see “Kern a range of characters” on page 629.
Word spacing
You can also adjust the spacing between words.

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus scelerisque enim metus ullamcorper a fringilla lectus dictum.

Decreased word spacing makes it difficult to discern the individual words in a paragraph (left). Increased word spacing (right) makes easier to read the paragraph.

To adjust character spacing
1. Do one of the following:
   • Using the Text tool, position the cursor in a block of text.
   • Using the Pick tool, click an artistic text object or a text frame.
   
   If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.
2. In the Properties docker, click the Paragraph button to display the paragraph-related options.
3. In the Paragraph area of the Properties docker, type a value in the Character spacing box.
   
   If you don’t see the Character spacing box, click the arrow to display more paragraph-related options.

Values for adjusting spacing represent a percentage of the space character. The Character values range from -100 to 2000 percent. All other values range from 0 to 2000 percent.

You can also change the character spacing proportionally by clicking the Shape tool, selecting the text object, and dragging the Interactive horizontal spacing arrow in the lower-right corner of the text object.

You can increase the character spacing in uppercase text by using capital spacing. For more information, see “To change the capitalization of characters” on page 630.

To adjust word spacing
1. Do one of the following:
   • Using the Text tool, position the cursor in a block of text.
   • Using the Pick tool, click an artistic text object or a text frame.
   
   If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.
2. In the Properties docker, click the Paragraph button to display the paragraph-related options.
3. In the Paragraph area of the Properties docker, type a value in the Word spacing box.
   
   If you don’t see the Word spacing box, click the arrow to display more paragraph-related options.
You can also change the word spacing proportionally by clicking the Shape tool, holding down Shift, selecting the text object, and dragging the Interactive horizontal spacing arrow in the lower-right corner of the text object.

Adjust line and paragraph spacing

You can change the spacing between lines of text, which is also known as “leading” or “interline spacing.”

Well-balanced line spacing (1) can improve the readability of text. Insufficient line spacing can reduce readability by causing letters to overlap (2).

In CorelDRAW, you can also adjust line spacing of a text object by using the Shape tool.

Adjusting line spacing proportionally by using the Shape tool

You can change the spacing between paragraphs, which is useful for copyfitting text. If a paragraph is positioned at the top or bottom of a frame, the spacing does not apply to the space between the paragraph text and the frame.

To adjust interline spacing

1. Using the Text tool, select the paragraph text.
2. If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.
2 In the Properties docker, click the Paragraph button to display the paragraph-related options.

3 In the Paragraph area of the Properties docker, choose one of the following units of measurement from the Vertical spacing units list box:
   • % of Char height — lets you use a percentage value that is relative to the character height
   • Points — lets you use points
   • % of Pt.size — lets you use a percentage value that is relative to the character point size

4 Type a value in the Line spacing box.

You can also change the spacing between lines proportionally by clicking the Shape tool, selecting the text object, and dragging the Interactive vertical spacing arrow in the lower-left corner of the text object.

To adjust the spacing between paragraphs
1 Using the Text tool, select the paragraph text.
   If the Properties docker is not open, click Window Dockers Properties.
2 In the Properties docker, click the Paragraph button to display the paragraph-related options.
3 In the Paragraph area of the Properties docker, choose a unit of measurement for line spacing from the Vertical spacing units list box.
4 Type a value in one of the following boxes:
   • Before paragraph spacing — lets you specify the amount of space to insert above the paragraph text
   • After paragraph spacing — lets you specify the amount of space to insert below the paragraph text

You can also use this procedure to adjust the spacing between items in a bulleted list.

Create bulleted and numbered lists
You can use bulleted and numbered lists to format paragraph text, and you can create lists inside lists (multilevel lists).

Lorem ipsum dolor sit amet.
- Erat tempor consetetur dolor facer no molestie kasd.
- Dolores ex ea ipsum labore est.
- Et quod sed dolores adipiscing no diam.

Lorem ipsum dolor sit amet.
1) Erat tempor consetetur dolor facer no molestie kasd.
2) Dolores ex ea ipsum labore est.
3) Et quod sed dolores adipiscing no diam. molestie.

Three paragraphs were converted into a bulleted list (left) and a numbered list (right).

In addition, you can customize lists, and you can customize one or more levels in multilevel lists. CorelDRAW lets you edit bullets and numbers by changing their size, position, and distance from the text and text frame. By default, the first level in lists inherits the font
properties of the paragraph text. However, you can change the font of bullets and numbers, and you can choose from a wide array of glyphs to use as bullets. To customize the number formatting, you can choose from numerous preset styles, and you can specify a suffix and a prefix for the numbers.

A customized bulleted list (left) and numbered list (right)

To reuse custom lists, you can save them as a paragraph style. You can remove the bulleted-list and numbered-list formatting at any time.

You can also change the spacing between items in a list. For more information, see “To adjust interline spacing” on page 639.

To create a bulleted or numbered list
1. Using the Text tool, drag across the paragraph text that you want to format as a bulleted or numbered list.
2. Click one of the following buttons on the property bar:
   • Bulleted list
   • Numbered list

You can also

Create a multilevel list

To indent a list item, click the item with the Text tool, and click the Increase indent button on the property bar.

To decrease the indentation of a list item, click the Decrease indent button.

To change the indentation of multiple list items simultaneously, drag across them with the Text tool, and click an indent button.

A multilevel numbered list
You can also

Change the color of a bullet or number in a list

Select the bullet or number with the Text tool A, and click a color on the color palette.

You can also access the Bulleted list and Numbered list buttons from the Paragraph section in the Properties docker, Text docker, and the Edit Text dialog box.

You can also start a bulleted or numbered list from scratch by creating a paragraph text frame and clicking the Bulleted list or Numbered list button on the property bar.

To customize a bulleted or numbered list

1. Using the Text tool A, select the bulleted or numbered list you want to customize.
2. Click Text ▸ Bullets and Numbering.
   The Level box in the Bullets and Numbering dialog box shows the list level you are about to edit. The top-most level of a list is 1. To customize two or more list levels at the same time, hold down Ctrl, and click the levels in the Level box to select them.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a font for the bullets or numbers</td>
<td>Disable the Use paragraph font check box, and choose a font from the Font list box.</td>
</tr>
<tr>
<td>Choose the glyph to be used as a bullet</td>
<td>Open the Glyph picker, and click a glyph.</td>
</tr>
<tr>
<td>Choose the number formatting</td>
<td>Choose a preset numbering style from the Style list.</td>
</tr>
</tbody>
</table>

To add a character before the number, type a prefix in the Prefix box. To add a character after the number, type a prefix in the Suffix box.

Examples of number styles. A prefix and a suffix were added to the numbers of the third list.
To Do the following

Set the bullet or number size

Specify a value in the Size box.

Note: This control is not available when the Use paragraph font check box is enabled. In this case, the bullet or number matches the font and size of the paragraph text.

Adjust the bullet or number position in relation to the text baseline

Specify a value in the Baseline shift box.

Set the distance between the bullet or number and the text

Specify a value in the Glyph to list text box.

Align all lines in a list item to the first line

Enable the Align lines in a list item check box.

Set the distance between the bullets or numbers and the text frame

Specify a value in the Text frame to list box, which is located in the upper-right corner of the dialog box.

Preview the list in the drawing window

Make sure the Preview check box is enabled.

Switch the list type

Enable the Bullets or Numbers option.

Bullets or numbers are inserted at the beginning of each new line that is preceded by a return.
You can also create a custom list from paragraph text that has not been formatted as a list yet. Select the paragraph text, enable the **List** check box in the **Bullets and Numbering** dialog box, and then enable the **Bullets** or **Numbers** option. Perform any of the steps from the preceding table.

You can adjust the spacing in between bullets by increasing or decreasing the space before and after a paragraph. For more information, see "To adjust the spacing between paragraphs" on page 640.

**To save a list as a paragraph style**

1. Using the **Text** tool, drag across an item in a bulleted or numbered list to select it.
2. Right-click, and click **Object Styles** ➔ **New Style From** ➔ **Paragraph**.
3. In the dialog box that appears, type a style name in the **New Style Name** box.

**To remove bulleted-list or numbered-list formatting**

1. Using the **Text** tool, drag across a bulleted or numbered list to select it.
2. Click one of the following buttons on the property bar:
   - Bulleted list
   - Numbered list

**Drop caps**

Applying drop caps, also known as initial caps, to paragraphs enlarges the initial letter and insets it into the body of text. You can customize a drop cap by changing different settings. For example, you can change the distance between the drop cap and the body of text, or specify the number of lines of text that you want to appear next to the drop cap. You can remove the drop cap at any point without deleting the letter.

You can add a drop cap (left) or a hanging indent drop cap (right).

You can preview a drop cap before you add it to a drawing. The changes you make are temporarily applied to the text in the drawing window, so you can see how the drop cap will look when you add it.

**To add a drop cap**

1. Using the **Text** tool, select the paragraph text.
2. If the **Properties** docker is not open, click **Window** ➔ **Dockers** ➔ **Properties**.
3. In the **Properties** docker, click the **Paragraph** button to display the paragraph-related options.
4. In the **Paragraph** area of the **Properties** docker, click the **Options** button, and choose **Drop Cap**.
5. In the **Drop Cap** dialog box, enable the **Use drop cap** check box, and then perform a task from the following table.
To

Specify the number of lines next to a drop cap

Set the distance between the drop cap and the body of text

Preview a drop cap

Offset the drop cap from the body of text

Remove drop caps

Do

In the Appearance area, type a value in the Number of lines dropped box.

In the Appearance area, type a value in the Space after drop cap box.

This sets the space to the right of the drop cap.

Enable the Preview check box.

Enable the Use hanging indent style for drop cap check box.

Disable the Use drop cap check box, or click the Drop cap button in the Paragraph area of Properties docker.

Change character position and angle

You can modify the appearance of text by shifting the characters vertically or horizontally, which changes the position of the selected characters relative to the surrounding characters.

You can also rotate characters by specifying an angle of rotation.

To shift a character

1. Using the Text tool A, select a character or a block of text.

   If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.

2. In the Properties docker, click the Character button A to display the character-related options.

3. In the Character area of the Properties docker, click the arrow button located at the bottom of Character area to display additional options.

4. Perform one or more tasks from the following table.
To do the following

Shift characters horizontally
Type a value in the Horizontal character offset box.

Shift characters vertically
Type a value in the Vertical character offset box.

To rotate a character
1. Using the Text tool \( \text{A} \), select a character or a block of text.
   
   If the Properties docker is not open, click Window \( \rightarrow \) Dockers \( \rightarrow \) Properties.

2. In the Properties docker, click the Character button \( \text{A} \) to display the character-related options.

3. In the Character area of the Properties docker, click the arrow button located at the bottom of Character area to display additional options.

4. Type a value in the Character angle box.

Align text

CorelDRAW lets you align text in various ways. You can align paragraph text horizontally and vertically in relation to its text frame. You can align paragraph text with the baseline grid. For more information, see “Align text to the baseline grid” on page 606. You can also align text to a selected object.

You can align a text object with other objects by using the baseline of the first line, the baseline of the last line, or the edge of the text frame.

Artistic text can be aligned horizontally, but not vertically. When you align artistic text, the entire text object is aligned in relation to the bounding box. If characters have not been shifted horizontally, applying no alignment produces the same result as applying left alignment.
Artistic text is aligned within the bounding box, which is indicated by eight selection handles (black squares). The text at the top is left-aligned, the text at the bottom is right-aligned.

To align text horizontally
1 Do one of the following:
   • Using the Text tool, select the text that you want to align.
   • Using the Pick tool, click an artistic text object or a text frame whose content you want to align.
   If the Properties docker is not open, click Window ▶ Dockers ▶ Properties.
2 In the Properties docker, click the Paragraph button to display the paragraph-related options.
3 In the Paragraph area of the Properties docker, click one of the following buttons:
   • No horizontal alignment — applies the default alignment setting
   • Align left — aligns text with the left side of the text frame or the bounding box of artistic text
   • Center — centers text within the text frame
   • Align right — aligns text with the right side of the text frame and the bounding box of artistic text
   • Full justify — aligns text, with the exception of the last line, with the left and right sides of the text frame
   • Force justify — aligns text, including the last line, with the left and right sides of the text frame

   You can also align text horizontally by clicking the Horizontal alignment button on the property bar and choosing an alignment style from the list box. The property bar displays an icon that corresponds to the current alignment style.

   You can align multiple paragraphs in a text frame by selecting them with the Text tool and choosing an alignment style.

To align paragraph text vertically
1 Using the Pick tool, click a text frame.
   If the Properties docker is not open, click Window ▶ Dockers ▶ Properties.
2 In the Properties docker, click the Frame button to display the frame-related options.
3 In the Frame area of the Properties docker, choose an alignment option from the Vertical alignment list box.

To align text with an object
1 Using the Pick tool, hold down Shift, click the text object, and then click the object.
2 Click Object ▶ Align and Distribute ▶ Align and Distribute.
3 In the Text area, click one of the following buttons:
• First line baseline — uses the baseline of the first line of text to align the objects
• Last line baseline — uses the baseline of the last line of text to align the objects
• Bounding box — aligns text with its bounding box

4 In the Align objects to area, click the Active objects button

5 In the Align area, click one of the following buttons to use an object edge or center for aligning.
   • Align left — to align the left edges of objects
   • Align center horizontally — to align object centers along a vertical axis
   • Align right — to align the right edges of objects
   • Align top — to align the top edges of objects
   • Align center vertically — to align object centers along a horizontal axis
   • Align bottom — to align the bottom edges of objects

To align objects from their outlines, click the Outline button.

If you select the text objects one at a time, the last object selected is the reference point for aligning the other objects. If you marquee select the objects before you align them, the object that is positioned in the upper-left corner of the selection is used.

Add tabs and indents

You can modify existing tab stops by changing their alignment. You can also add trailing leader characters, so that dots, or other characters, automatically precede the tab stops. In addition, you can add new tab stops and remove existing tab stops.

Indenting changes the space between a text frame and the text that it contains. You can add and remove indents without deleting or retyping text. You can indent an entire paragraph, the first line of a paragraph, or all lines of a paragraph except the first line (a hanging indent). You can also indent from the right side of the text frame.

To modify a tab stop

1 Click Window Docker Properties.
2 In the Properties docker, click the Paragraph button to display the paragraph-related options.
3 In the Paragraph area of the Properties docker, click the arrow button located at the bottom of Paragraph area to display additional options.
4 Click the Tab settings button.
5 In the Tab Settings dialog box, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the alignment of tab stops</td>
<td>Click the cell in the Alignment column, and choose an alignment option from the list box.</td>
</tr>
<tr>
<td>Set tab stops with trailing leader characters</td>
<td>Click the cell in the Leaders column, and choose On from the list box.</td>
</tr>
</tbody>
</table>
To Delete a tab stop

Do the following

Click the cell, and click Remove.

Change the default leader character

Click Leader Options, open the Character picker, and click a character.

Change the default leader spacing

Click Leader Options, and type a value in the Spacing box.

You can also add, move, or delete tab stops on the horizontal ruler at the top of the drawing window. Click to add a tab stop, drag a tab marker to move it, and drag a tab marker off the ruler to delete it. For information about rulers, see “Rulers” on page 739.

To add a tab stop

1 Using the Text tool ☐, select the paragraph text.

2 Click Window ▶ Dockers ▶ Properties.

3 In the Properties docker, click the Paragraph button ☑ to display the paragraph-related options.

4 In the Paragraph area of the Properties docker, click the arrow button ▼ located at the bottom of Paragraph area to display additional options.

5 Click the Tab settings button ☐

6 Click Add.

7 Click the new cell in the Tabs column, and type a value.

To indent paragraph text

1 Using the Text tool ☐, select the paragraph text.

2 Click Window ▶ Dockers ▶ Properties.

3 In the Properties docker, click the Paragraph button ☑ to display the paragraph-related options.

4 In the Paragraph area of the Properties docker, type values in the following boxes:
   • First line indent — indents the first line of text relative to the left side of the frame
   • Left line indent — creates a hanging indent relative to the left side of the text frame; all lines, except the first line, are indented
   • Right line indent — indents the text relative to the right side of the frame

You can remove indents by typing 0 in the First line indent, Left line indent, and Right line indent boxes.

You can indent an entire paragraph by typing the same value in both the First line indent and the Left line indent boxes.

Text styles

CorelDRAW provides advanced style capabilities that allow you to format document text with speed, ease, and consistency. A style is a collection of formatting attributes defining object properties, such as artistic and paragraph text properties. For example, to define a character style, you can specify font type, font style and size, text color and background color, character position, caps, and more. You can create styles and style sets for text. You can also change the default text style, so that the same properties are applied to all new artistic or
paragraph text. For example, you can change the font type and size, or change the text to bold or italic. For more information, see “Styles and style sets” on page 697.

Hyphenate text

Hyphenation can be used to break a word if the entire word does not fit at the end of a line. You can hyphenate automatically by using a preset hyphenation definition in combination with your own hyphenation settings. You can set the minimum number of characters before and after a hyphen. You can also specify the number of characters in the “hot zone,” which is the area at the end of a line where hyphenation can occur.

You can insert an optional hyphen in a word to produce a specific word break at the end of a line. You can also create custom definitions that specify the location of optional hyphens in specific words whenever you type, paste, or import the words in the application.

To hyphenate paragraph text automatically

1 Using the Text tool A, select the text frame or paragraph text.
2 If the Properties docker is not open, click Window ➔ Dockers ➔ Properties.
3 In the Paragraph area of the Properties docker, click the Options button ç and choose Hyphenation settings.
4 In the Hyphenation dialog box, enable the Automatically hyphenate paragraph text check box.
5 To modify the hyphenation settings, perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hyphenate capitalized words</td>
<td>Enable the Break capitalized words check box.</td>
</tr>
<tr>
<td>Hyphenate words that contain all uppercase letters</td>
<td>Enable the Break words using ALL CAPS check box.</td>
</tr>
<tr>
<td>Set a minimum word length for automatic hyphenation</td>
<td>In the Hyphenation criteria area, type a value in the Minimum word length box. This value represents the minimum number of characters that hyphenated words must contain.</td>
</tr>
<tr>
<td>Set the minimum number of characters to precede a hyphen</td>
<td>In the Hyphenation criteria area, type a value in the Minimum characters before box.</td>
</tr>
<tr>
<td>Set the minimum number of characters to follow a hyphen</td>
<td>In the Hyphenation criteria area, type a value in the Minimum characters after box.</td>
</tr>
<tr>
<td>Set the “hot zone”</td>
<td>In the Hyphenation criteria area, type a value in the Distance from right margin box. This value represents the number of characters in the hot zone. A word that does not fit within this zone is hyphenated or moved to the next line.</td>
</tr>
</tbody>
</table>
Hyphenation can be used for any languages that have corresponding writing tools installed with the application. For more information about language modules, see “Work with languages” on page 676.

If you do not see any hyphenated words in the paragraph after applying hyphenation, you may need to modify the hyphenation settings.

To insert an optional hyphen

1 Using the Text tool A, click in a word where you want to place an optional hyphen.
2 Click Text ▶ Insert Formatting Code ▶ Optional Hyphen.

You can insert an optional hyphen by pressing Ctrl + -.

To create a custom definition for optional hyphenation

1 Click Text ▶ Insert Formatting Code ▶ Custom Optional Hyphens.
2 In the Word box, type the word for which you want to create the hyphenation definition. When you type in the Word box, the same text is entered in the Hyphenated word box.
3 In the Hyphenated Word box, click where you want the optional hyphen inserted, and press the Hyphen key (-).
4 Click Add Definition.

You can also

Create a custom hyphen definition for a specific language keyboard  
Enable the Show all languages check box, and choose a language option from the Language list box.

Automatically insert custom optional hyphens when typing  
Enable the When typing check box.

Automatically insert custom optional hyphens when typing, pasting, or importing text  
Enable the When pasting and importing text check box.

Delete a custom optional hyphen definition  
Click Remove Definition.

The custom hyphenation definition is defined only for the language specified in the Language list box. You can choose another language without affecting your keyboard.

You can create a custom optional hyphen definition by selecting a word in the document. The word appears in the Word box of the Custom optional hyphens dialog box. After you insert the optional hyphen in the Hyphenated word box, you can apply it by clicking Apply to Selection.

You can find and replace optional hyphens. For more information, see “To find text” on page 608 and “To find and replace text” on page 609.
## Formatting codes

You can insert formatting codes, such as em dashes and nonbreaking spaces. In some programs, formatting codes are also known as “symbols.” The following table lists the available formatting codes and their corresponding keyboard shortcuts.

<table>
<thead>
<tr>
<th>Formatting code</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Em space</td>
<td>Ctrl + Shift + M</td>
</tr>
<tr>
<td>En space</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>1/4 em space</td>
<td>Ctrl + Alt + Space</td>
</tr>
<tr>
<td>Nonbreaking space</td>
<td>Ctrl + Shift + Space</td>
</tr>
<tr>
<td>Tab</td>
<td>Tab</td>
</tr>
<tr>
<td>Column break or text-frame break</td>
<td>Ctrl + Enter</td>
</tr>
<tr>
<td>Em dash</td>
<td>Alt + _</td>
</tr>
<tr>
<td>En dash</td>
<td>Alt + -</td>
</tr>
<tr>
<td>Nonbreaking hyphen</td>
<td>Ctrl + Shift + -</td>
</tr>
<tr>
<td>Optional hyphen</td>
<td>Ctrl + -</td>
</tr>
</tbody>
</table>

All shortcut keys for formatting codes are customizable. For information about customizing these shortcut keys, see the Text commands category in “To assign a keyboard shortcut to a command” on page 963.

You can find and replace formatting codes. For more information, see “To find text” on page 608 and “To find and replace text” on page 609.

### To insert a formatting code

1. Using the Text tool, click to place the cursor where you want to insert a character or space.
2. Click Text ➤ Insert Formatting Code, and choose a formatting code from the menu.

   - The Insert Formatting Code menu is unavailable when the Text tool is not active.

   - You can insert a character not listed in the Insert Formatting Code menu by clicking Text ➤ Glyphs and clicking the character in the Glyphs docker.
Nonprinting characters

You can display nonprinting characters, such as spaces, tabs, and formatting codes. For example, when you display nonprinting characters, a space appears as a tiny black dot, a nonbreaking space appears as a circle, and an em space appears as a line. When enabled, nonprinting characters are displayed only when you add or edit text.

To display nonprinting characters
• Click Text ➤ Show Non-Printing Characters.
Work with text in different languages

In CorelDRAW, you can work with text in different languages. For example, if you are running CorelDRAW on an Asian operating system, or if you have Asian language support installed on another operating system, you can take advantage of the Asian text formatting capabilities available with CorelDRAW.

This section contains the following topics:
• “Format Asian text” (page 655)
• “Line-breaking rules for Asian text” (page 656)
• “OpenType support for Asian text” (page 657)
• “Format multilingual text” (page 657)
• “Display text correctly in any language” (page 659)

Format Asian text

Asian character input is supported in CorelDRAW only when using an appropriate operating system or when language support is installed on a non-Asian operating system. You can choose a default font and text orientation (either horizontal or vertical) when typing text. When you type artistic or paragraph text, the program uses a default artistic or paragraph text style.

When you insert Asian or Middle Eastern text in existing Latin text, the application automatically matches the font of the Latin text if the font is available in the corresponding language. However, you can disable the font matching option so that the inserted text has the default font specified for Asian or Middle Eastern languages. For more information, see “To disable font matching in multilingual text” on page 658.

To choose a default font for Asian text

1 Click the Text tool.
2 Press Esc to ensure that no objects are selected.
3 Choose an input method from the Input Method Editor (IME) on the Windows status bar. If the Windows Language bar is displayed, you can choose an input method from the Language bar.
4 Choose a font from the Font list box on the property bar.
5 Choose a font style from the Font style list box.

To choose a text orientation for Asian text

1 Using the Pick tool, select the frame that contains the text whose orientation you want to change.
2 Click Window  Dockers  Properties.
3 In the Properties docker, click the Frame button [ ] to display the frame-related controls.
4 Choose one of the following orientation options from the Text orientation list box:
   • Horizontal
   • Vertical

   The default orientation for Asian text is horizontal.
   When you change the text orientation from horizontal to vertical, underlines become left lines and overlines become right lines.
   The text orientation setting applies to the entire text object. You cannot have text with different orientations in one text object.

   If you have Asian text support installed with your operating system, you can also change text orientation by clicking the Vertical text orientation [ ] or Horizontal text orientation [ ] buttons on the property bar when the Text tool [ ] is active.

Line-breaking rules for Asian text

CorelDRAW includes line-breaking rules for use with Asian text when you have an Asian operating system. For most Asian languages, a line of text can break between any two characters, with a few exceptions. Some characters cannot appear at the beginning of a line. These characters are referred to as “leading characters.” Other characters — referred to as “following characters” — cannot appear at the end of a line. The line breaks either after the following character or before the character that precedes the following character. Still others — referred to as “overflow characters” — are not wrapped but are, instead, allowed to extend beyond the right or bottom margin.

To enforce one or more of the line-breaking rules, you can enable any of the rules. To customize the rules, you can add or remove characters. You can also reset the rules to the default.

To disable or enable line-breaking rules

1 Click Text  Line-Breaking Rules.
2 In the Asian line-breaking rules dialog box, enable any of the following check boxes:
   • Leading characters — ensures that a line does not break before any of the characters in the list
   • Following characters — ensures that a line does not break after any of the characters in the list
   • Overflow characters — ensures that the characters in the list are allowed to extend beyond the margin of the line

   You must have Asian text support installed on your operating system to view the Line-Breaking Rules menu item.

To add or remove characters to a line-breaking rule

1 Click Text  Line-Breaking Rules.
2 Type or remove the characters in the appropriate box.

   You must have Asian text support installed on your operating system to view the Line-Breaking Rules menu item.
To reset a line-breaking rule to the default

1. Click **Text ▶ Line-Breaking Rules**.
2. Click the **Reset** button beside a rule.

You must have Asian text support installed on your operating system to view the **Line-Breaking Rules** menu item.

**OpenType support for Asian text**

You can apply advanced OpenType typography features to Asian text. OpenType features can be accessed from the **Character** area in the **Text** docker (**Text ▶ Text**). The following table lists the OpenType features that you can use with Asian text provided the features are included in the font.

<table>
<thead>
<tr>
<th>OpenType feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asian widths</td>
<td>Changes the width by spacing or replacing the glyphs</td>
</tr>
<tr>
<td></td>
<td>The Centered CJK punctuation feature centers punctuation marks horizontally and vertically.</td>
</tr>
<tr>
<td>Asian forms</td>
<td>Replaces the selected characters with a different glyph form. Forms cannot be combined.</td>
</tr>
<tr>
<td>Asian vertical metrics</td>
<td>The Alternate vertical metrics feature centers shorter characters vertically relative to full-height characters. This feature also applies to full-width Latin glyphs.</td>
</tr>
<tr>
<td></td>
<td>The Alternate vertical half metrics feature centers characters vertically relative to half-height characters.</td>
</tr>
<tr>
<td>Horizontal Kana alternates</td>
<td>Substitutes the standard kana glyph with a horizontal kana glyph</td>
</tr>
<tr>
<td>Vertical Kana alternates</td>
<td>Substitutes the standard kana glyph with a vertical kana glyph</td>
</tr>
<tr>
<td>Vertical alternates and rotation</td>
<td>Substitutes characters with forms suitable for vertical text, often rotating them at 90 degrees</td>
</tr>
<tr>
<td>Alternate annotation forms</td>
<td>Applies an annotation form to the selected characters. This OpenType feature applies to both Latin and Asian text.</td>
</tr>
</tbody>
</table>

**Format multilingual text**

When you insert Asian or Middle Eastern text in existing Latin text, the application automatically matches the font of the Latin text if the font is available in the corresponding language. However, you can disable the font matching option so that the inserted text has the default font specified for Asian or Middle Eastern languages.
CorelDRAW includes controls that let you format text in different languages. You can limit any font, style, and size changes to only Latin, Asian, or Middle Eastern text by choosing the script type. For example, if you want to change the font size of Japanese text in a document that includes both English and Japanese text, you can choose the Asian script type, and then change the font size. This applies the new font size only to the Japanese text, the English text font size is unaffected. You can also enable right-to-left text flow when working with bidirectional languages, such as Middle Eastern languages. In addition, you can mix Latin text with Asian or Middle Eastern in one text object and set the spacing between the two words.

To disable font matching in multilingual text

1. Click **Tools** ➤ **Options** ➤ **CorelDRAW**.
2. In the **Options** dialog box, click **Text** in the left pane, and then click the **Display** tab.
3. Disable the **Match font when inserting text in another language** check box.

To limit font property changes to multilingual text

1. Using the **Text** tool (A), select the text.
   - If the **Properties** docker is not open, click **Window** ➤ **Dockers** ➤ **Properties**.
2. In the **Properties** docker, click the **Character** button (A) to display the character-related options.
3. In the **Character** area of the **Properties** docker, choose one of the following language options from the **Script** list box:
   - All scripts
   - Latin
   - Asian
   - Middle Eastern
4. Change any font properties.

   The **Script** list box is available only when using an Asian or Middle Eastern operating system or when language support is installed on the operating system.

To set right-to-left text flow in text

1. Do one of the following:
   - Using the **Text** tool (A), position the cursor in a block of text.
   - Using the **Pick** tool ( ), click an artistic text object or a text frame.
   - If the **Properties** docker is not open, click **Window** ➤ **Dockers** ➤ **Properties**.
2. In the **Properties** docker, click the **Paragraph** button ( ) to display the paragraph-related options.
3. In the **Paragraph** area of the **Properties** docker, choose an option from the **Text direction** list box.

   The **Text direction** option is available, and visible, only when you use a Middle Eastern operating system or when language support is installed on a non-Middle Eastern operating system.

   You can also change the direction of text flow in columns. For more information, see “To change the flow of bidirectional text in columns” on page 604.

To specify spacing between Latin and Asian words

1. Using the **Text** tool (A), select the paragraph that combines both the Latin and Asian text.
2 In the Properties docker, click the Paragraph button to display the paragraph-related properties.

3 In the Paragraph area of the Properties docker, type values in the Language spacing box.

The language spacing value is based on the percentage of a standard space. For example, two spaces are represented by typing a value of 200.

**Display text correctly in any language**

In CorelDRAW, all text that is added to a document is encoded using the Unicode character set. When you open or import a drawing that contains text, CorelDRAW converts the encoding system that was used in the file to Unicode. For example, if you import an older document that includes 8-bit ANSI text that uses a specific code page (e.g. 949 ANSI/OEM - Korean), CorelDRAW converts code page 949 to Unicode.

If the code page is not specified when you open a document, CorelDRAW uses a default code page to convert the text. Therefore, this may cause some text to display incorrectly in CorelDRAW. However, you can display the text correctly by selecting it and converting it back to Unicode by using the appropriate code page.

Encoding settings do not affect the display of text outside the drawing window, such as keywords, filenames, and text entries in the Objects docker and Object Data docker. For these types of text, you must use code page settings in the Open or Import dialog boxes to set the proper characters. For information about using code page settings, see “Start and open drawings” on page 62.

**To display text correctly in any language**

1 Using the Text tool, select the text object that is displaying incorrectly.

2 Click Text > Encode.

3 In the Text encoding dialog box, choose the Other encoding option.

4 From the Other encoding list, choose an encoding setting that makes the text readable.

The preview window displays the text with the selected encoding setting.

Changing the encoding allows you to use Unicode fonts, even if your original text was using non-Unicode fonts.
Manage fonts

CorelDRAW allows you to manage and preview fonts.

This section contains the following topics:

- “Change the default font” (page 661)
- “Substitute fonts” (page 662)
- “Embed fonts” (page 663)
- “View fonts” (page 664)
- “Filter fonts” (page 665)
- “Search for fonts” (page 667)
- “Acquire more fonts” (page 668)
- “Choose fonts” (page 668)
- “Corel Font Manager” (page 670)

Change the default font

You can change the default font that is used for artistic, callout, dimension, and paragraph text.

To change the default font

1. Click the Text tool and without clicking anywhere in the document window, choose a font from the Font list box on the property bar.

2. In the Change Document Defaults dialog box, enable any of the following check boxes to change the default font for the corresponding text types:
   - Artistic text
   - Callout
   - Dimension
   - Paragraph text

This step changes the default font for the active document. If you want to change the default font for all new documents that you create, click Tools ▶ Save Settings as Default.
You can also change the default font from the **Object Styles** docker. For more information, see “To edit default object properties” on page 703.

**Substitute fonts**

You can use **PANOSE font matching** to access a list of fonts that can be used as substitutes for fonts used in a document but not found on your computer.

You can set options for font matching. You can use font matching in text only or in both text and text styles. You can also turn off font matching. When you substitute fonts without PANOSE font matching, you can accept the default substitute font, or you can choose any available font as a substitute.

You can apply the substitution temporarily or permanently.

You can build a list of exceptions to font substitutions. Exceptions override the font substitutions recommended by the PANOSE font-matching feature. A list of exceptions can be useful when you share drawings and documents across platforms, because sometimes the same font is spelled differently on each platform.

**To set options for font matching**

1. Click **Tools ▶ Options ▶ CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Text**.
3. Click **Fonts**.
4. Click **PANOSE font matching**.
5. In the **PANOSE font matching preferences** dialog box, enable one of the following options:
   - **Text** — lets you choose font substitutions for text in the document and applies default font substitutions for text styles
   - **Text and styles** — lets you choose font substitutions for text in the document and for text styles
   - **Never show** — applies default font substitutions for text in the document and for text styles

**To use PANOSE font matching**

1. Open or import a document.
   - If the document contains missing fonts, the **Substitute missing fonts** dialog box opens. This dialog box also appears when you have a document font installed, but the version of the installed font is different from the version of the document font (for example, Arial-Normal Version 6.98 and Arial-Normal Version 7.00).
   - The name of the missing font appears in the **Missing font** list, and the recommended substitute appears in the **Substituted font** list.
2. Enable the **Use the PANOSE suggested match** option.
3. Enable one of the following options:
   - **Permanent** — permanently replaces the missing font with the substitution. When you save and reopen the file, the new font is used.
   - **Temporary** — replaces the missing font with the substitution in the current session of the document

**To substitute a missing font**

1. Open or import a document.
   - If the document contains missing fonts, the **Font matching results** dialog box opens.
2. Choose a missing font from the **Missing font** list.
3. Enable the **Substitute font with** option.
4. Choose a font from the **Substitute font with** list box.
   - To change the selection of available fonts, you can enable one of the following options:
     - **Show fonts in the same code page as missing font** — displays only fonts that support the code page of the active document
• Show all fonts — displays all available fonts you can choose from

5 Enable one of the following options:
  • Permanent — permanently replaces the missing font with the substitution. When you save and reopen the file, the new font is used.
  • Temporary — replaces the missing font with the substitution in the current session of the document

You can save font substitutions by enabling the Save this exception for future font matching check box.

You can substitute multiple missing fonts with a single font by holding down Shift and selecting the fonts in the Missing font list first.

To build a list of exceptions to font substitutions
1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the dialog box that appears, click Text.
3 Click Fonts.
4 Click PANOSE font matching.
5 In the PANOSE font matching preferences dialog box, click Exceptions.
6 In the PANOSE font matching exceptions dialog box, type the name of the missing font in the Missing font box.
7 Choose a font that is installed on your computer from the Substituted font list box.
8 Click Add Exception.

Embed fonts

Font embedding can help you share drawings so that others can view, print, and even edit them without having to install or substitute fonts. By default, CorelDRAW embeds the fonts that are used in a drawing when the file is saved, but you can choose to disable font embedding for that particular drawing. For more information, see “To save a drawing” on page 76. You can change the default option for embedding fonts in drawings.

Note that CorelDRAW respects the embedding permissions of each font. Some fonts allow embedding for print and preview purposes, but not for text editing; other fonts may not allow embedding. The following font embedding permissions are respected by CorelDRAW:
• Editable — allows fonts to be embedded in electronic documents and used by the recipients of the documents to edit the text.
• Installable — similar to Editable. In addition, this permission allows fonts to be permanently installed on a recipient’s computer and used to create new documents.
• No Embedding — does not allow fonts to be embedded in electronic documents
• Preview and Print — allows fonts to be embedded in an electronic document strictly for previewing and printing purposes. Such fonts cannot be installed and used to edit the document on other computers.

If a drawing contains fonts that cannot be embedded, a warning is displayed. You can disable this warning.

You can import files that contain embedded fonts. If an embedded font does not allow editing, a visual indicator appears next to the font name in the Objects docker. When you try to edit text that uses this font, you are prompted to choose a font substitution. For more information, see “Substitute fonts” on page 662.

To change the default option for embedding fonts
1 Click Tools ▶ Options ▶ CorelDRAW.
2 In the left pane of the dialog box that appears, click Save.
3 Enable or disable the Embed fonts when saving files check box.
To enable or disable the warning for fonts that cannot be embedded

1. Click **Tools** ➤ **Options** ➤ **CorelDRAW**.
2. In the left pane of the dialog box that appears, click **Warnings**.
3. In the **Show warnings when** box, enable or disable the **Fonts cannot be embedded** check box.

💡 The warning lists a maximum of 7 fonts that cannot be embedded. If a document contains more than 7 fonts that cannot be embedded, an ellipsis is displayed at the bottom of the list.

View fonts

You can customize the font list, from within the **Font list** box, to make it easier to find fonts. For example, you can change the size of the font names displayed in the **Font list** box. You can display fonts grouped by family or as a flat list. If you have non-Latin fonts installed, you can show their names in Latin or in their native language. In addition, you can show recently used fonts at the top of the font list, or hide them, and you can specify the number of recently used fonts to display.

By default, font names use the corresponding fonts, but you can display all font names by using the same font.

CorelDRAW lets you preview fonts in the **Preview** area at the bottom of the Font list box or in the drawing window. You can also preview a font in all available styles, such as bold and italic.

You can resize the **Font list** area by adjusting its height and width or by hiding the preview area.

To customize the font list

1. Click the **Text** tool in the toolbox, and open the **Font list** box on the property bar.
2. To change the size of the font names, move the **Resize** slider.
3. Click the **Font Options** button, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the font list grouped by family or as a flat list</td>
<td>Click <strong>Group by family</strong> to enable or disable the command.</td>
</tr>
<tr>
<td>Show the names of non-Latin fonts in Latin or in the native language</td>
<td>Click <strong>Show Latin names</strong> to enable or disable the command. This option is useful when you work with Cyrillic, Arabic, and Asian fonts.</td>
</tr>
<tr>
<td>Display font names by using the same font</td>
<td>Click <strong>Use font to display the font name</strong> to disable the command.</td>
</tr>
<tr>
<td>Display or hide recently used fonts</td>
<td>Click <strong>Show recently used fonts</strong> to enable or disable the command.</td>
</tr>
<tr>
<td>Specify the number of recently used fonts to display</td>
<td>Click <strong>Font List Options</strong>, and on the <strong>Fonts</strong> page of the dialog box that appears, type a value in the <strong>Number of most recently used fonts displayed</strong> box. The maximum number of recently used fonts that you can display is 20.</td>
</tr>
</tbody>
</table>
To preview a font
1. Click the Text tool in the toolbox.
   If you want to preview a font in the drawing window, select the text you want.
2. On the property bar, click the Font list box.
   The font name appears in the given font.
   To preview the selected text with a specific font applied, point to the font name in the Font list box.

   The names of symbol fonts are displayed in the default user interface font, with examples of the symbol font appearing to the right of the symbol font name and in the Preview area.

   If a font has other styles, such as bold or italic, you can preview them by pointing to the flyout arrow next to the font name.

To resize the Font list area
1. Click the Text tool in the toolbox, and open the Font list box on the property bar.
2. Do any of the following:
   - To hide the preview area, click the Hide preview button.
   - To adjust the width of the Font list area, point to the vertical grab area (right edge) and drag when the double-sided arrow appears.
   - To adjust the height, point to the horizontal grab area (below the Resize slider), and drag when the double-sided arrow appears.

Filter fonts
Filtering helps you view only the fonts that meet specific requirements. For example, you can display only the fonts used in the document or only symbol fonts. You can filter fonts based on the font technology, weight, width, style, supported language(s), OpenType features, and more; and you can apply one or more filters at the same time.

The following table lists available font filter categories and filters.

<table>
<thead>
<tr>
<th>Font filter category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Fonts</td>
<td>Lets you display only the fonts used in the document</td>
</tr>
<tr>
<td>Font Status</td>
<td>Lets you filter fonts based on their status such as Installed, Not installed, and Protected System Fonts.</td>
</tr>
<tr>
<td>Embedding Rights</td>
<td>Lets you filter fonts based on embedding permissions such as whether fonts can be embedded, installed, and previewed. Available filters include: Editable, Installable, No Embedding, and Preview and Print. For information about embedding permissions, see “Embed fonts” on page 663. If fonts with a specific permission are not available, the corresponding filter is not displayed. For example, if all your fonts can be embedded in a document, the No Embedding filter is not displayed.</td>
</tr>
<tr>
<td>Font filter category</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Font Technology</td>
<td>Lets you filter fonts based on the font technology such as OpenType - TrueType, OpenType - PostScript, TrueType, Type1, and Variable Fonts (OpenType Font Variations) If a font technology is not available on your computer, it does not appear in the list of filters.</td>
</tr>
<tr>
<td>Weight</td>
<td>Lets you display fonts based on their weight such as Light, Normal, or Bold</td>
</tr>
<tr>
<td>Width</td>
<td>Lets you display fonts based on their width such as Condensed, Normal, and Expanded</td>
</tr>
<tr>
<td>Style</td>
<td>Lets you display fonts based on their style such as Decorative, Display, Monospaced, Sans Serif, Script, Serif, and Symbol</td>
</tr>
<tr>
<td>Character Range</td>
<td>Lets you filter fonts based on their language or script. Filters in this group include Arabic, Chinese Simplified, Chinese Traditional, Cyrillic, Devanagari, Greek, Hebrew, Japanese, Korean, Latin, and Turkish</td>
</tr>
<tr>
<td>OpenType</td>
<td>Lets you display fonts that have specific OpenType features such as Capital Spacing, Case-Sensitive forms, and more</td>
</tr>
</tbody>
</table>

**To filter fonts**

1. Click the **Text** tool in the toolbox.

2. Open the **Font** list box on the property bar, and click the **Show filters** button.

3. Enable any of the filter check boxes.

**You can also**

- **Clear all filters**
  - Click **Clear filters**.

- **Close the filter list**
  - Click the **Hide filters** button.
You can filter only fonts that are installed on your computer.

You can also filter fonts from the **Font list** box in the **Properties** docker, **Text** docker, **Font Sampler** docker, and **Glyphs** docker.

**Search for fonts**

You can use keywords to search for local fonts from within the **Font list** box. These keywords include font names, font technology, and other metadata included in the fonts.

When you start typing a font name or another keyword, a relevant list of fonts is displayed. This list is automatically updated as you type.

To refine your search, you can type two or more keywords. For example, to find all available Arial fonts that have bold weight, you can type **Arial bold** in the **Font list** box.

**To search for fonts by using keywords**

1. Click the **Text** tool in the toolbox.
2. Open the **Font list** box on the property bar, and type a keyword such as a font name or font technology.
3. To refine your search, press the space bar after typing the first keyword, and type another keyword.

The following table lists the search keywords that you can use organized by categories.

<table>
<thead>
<tr>
<th>Category</th>
<th>Keywords</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Fonts</td>
<td>Document Fonts</td>
</tr>
<tr>
<td>Font Technology</td>
<td>OpenType - TrueType, OpenType - PostScript, TrueType, Type1</td>
</tr>
<tr>
<td>Weight</td>
<td>Thin, Extra Light, Light, Regular, Medium, Semi Bold, Bold, Extra Bold, Black</td>
</tr>
<tr>
<td>Width</td>
<td>Ultra Condensed, Extra Condensed, Condensed, Semi Condensed, Normal, Semi Expanded, Expanded, Extra Expanded, Ultra Expanded</td>
</tr>
<tr>
<td>Style</td>
<td>Decorative, Display, Monospaced, Sans Serif, Script, Serif, Symbol</td>
</tr>
<tr>
<td>Character Range</td>
<td>Arabic, Armenian, Chinese Simplified, Chinese Traditional, Coptic, Cyrillic, Devanagari, Dhivehi, Georgian, Greek, Gujarati, Hebrew, Hiragana, Japanese, Kannada, Katakana, Korean, Latin, Russian, Syria, Tamil, Telugu, Thai, Turkish, Vietnamese</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Ale/Paul, Bitstream, Cultivated/Mind, DynaComware, Font Fabric, Fontlab, Fontgrapher, ITC, Linotype, Mark Simonson, Monotype, Typodermic, RW++</td>
</tr>
</tbody>
</table>
Acquire more fonts

You can download additional fonts from within the Font list box in CorelDRAW and Corel Font Manager. These fonts are usually grouped in font packs. Some font packs are free whereas others are available for purchase. You can access information about the font packs and the fonts they include as well as view font samples.

You can change the default location to which fonts are saved. For more information, see “Change content locations” on page 125.

To acquire a font pack

1. Click the Text tool  in the toolbox.
2. Open the Font list box on the property bar.
3. Click the Get More button.
4. In the Get More dialog box, click a font pack.
5. Do one of the following:
   • Click Buy, and follow the onscreen instructions to purchase the font pack.
   • Click Download if the font pack is free.

The downloaded font pack can be accessed from the Font list box. It also appears in the Filters list under My Collections.

Choose fonts

Font Sampler lets you view the same sample text in different fonts and sizes to help you choose fonts for your project.

You can preview preset text samples, or you can type or paste text. In addition, you can view samples as single lines of text or multiline text, and you can view a text sample as single lines of text in increasing font sizes.

When a text sample uses an OpenType font, you can view available OpenType features and apply them to the text sample.
With text samples using OpenType fonts, you can select text to display the OpenType feature indicator and apply an OpenType feature. In this example, a stylistic set was applied to the selected text.

To view a text sample in context, you can paste it where you want in the drawing window.

**To preview fonts with Font Sampler**

1. Click Window ➤ Dockers ➤ Font Sampler.
2. To change the font of a sample, click the sample, and choose a font from the Font list box.
   - If you want to change the text in all samples, double-click a sample, press Ctrl+A to select the text, and then type the new text.
3 To choose a view option, click any of the following buttons:
   • Single line — shows the samples as single lines of text
   • Multiline — shows the samples as multiline text
   • Waterfall — shows the selected sample as single lines of text in increasing sizes
4 To change the size of sample text, move the Zoom slider.
   If you want to change the text size in preset increments, click the Zoom buttons next to the Zoom slider.

You can also

Add a text sample

Paste a text sample in a document
   Click a text sample, and click Copy. Using the Text tool, Right-click where you want to place the text sample, and click Paste. You can also drag a text sample to the document window.

Delete a text sample

Paste text in a text sample
   Click a text sample, and then press Ctrl+V.

Change the order of text samples
   Drag a text sample to a new position in the list.

Corel Font Manager

Corel Font Manager is a standalone font management application included with CorelDRAW Graphics Suite. Corel Font Manager lets you easily handle, organize, and explore your typeface and font collections by giving you tools to control every aspect of your typography workflow. You can find and preview local fonts, install and uninstall fonts, and delete fonts that you no longer need. For more information, see the Help in Corel Font Manager.

To start Corel Font Manager
   • Click the Application launcher button on the standard toolbar, and then click Corel Font Manager.

To access the Corel Font Manager Help
   • In Corel Font Manager, click the Help button on the title bar.
Writing tools

You can use writing tools to correct errors in spelling and grammar, correct mistakes automatically, and refine your writing style.

This section contains the following topics:
- “QuickCorrect” (page 671)
- “Spell Check and Grammatik” (page 673)
- “Thesaurus” (page 675)
- “Work with languages” (page 676)
- “Customize the writing tools” (page 676)
- “Checking styles” (page 678)
- “Word lists” (page 678)
- “Check statistics” (page 678)

Writing tools are installed with the suite, but not all writing tools are available for all languages. For information about supported languages, see “Reference: Writing tools” on page 681.

QuickCorrect

QuickCorrect automatically corrects misspelled words and capitalization errors. You can customize QuickCorrect by specifying which types of errors you want to correct automatically.

In CorelDRAW, the quotation marks that are applied to text vary according to the language that you have selected. You can further customize the quotation marks for different languages by using QuickCorrect. For example, you can change the style of double, single, and straight quotation marks for a language.

Adding words to QuickCorrect lets you replace words and abbreviations that you often mistype. The next time you type the misspelled word, QuickCorrect corrects the word automatically. You can use this feature to create shortcuts to frequently used words and phrases. For example, you can store the phrase “for your information” under the abbreviation “FYI” so that each time you type “FYI” followed by a space, it is replaced with the phrase.

You can have QuickCorrect add corrections made with the spelling checker to its word list so that the next time you misspell the word the same way, it is automatically corrected.

You can also undo a QuickCorrect correction.
To customize QuickCorrect

1. Click Text ➤ Writing tools ➤ QuickCorrect.
2. Enable any of the following check boxes:
   - Capitalize first letter of sentences
   - Correct two initial, consecutive capitals
   - Capitalize names of days
   - Automatically create hyperlinks when typing web addresses

The Correct two initial, consecutive capitals option doesn’t make a change when a capital letter is followed by a space or period, or if a word contains other capital letters.

Instead of enabling the Capitalize first letter of sentences check box, you can change the text case to sentence case. For more information, see “To change the capitalization of characters” on page 630.

To customize quotation marks for different languages

1. Click Text ➤ Writing tools ➤ QuickCorrect.
2. Choose a language from the Language list box.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change straight quotation marks to typographic (“curly”) quotation marks</td>
<td>Enable the Change straight quotes to typographic quotes check box.</td>
</tr>
<tr>
<td>Insert straight quotation marks when the quotation mark follows a number</td>
<td>Enable the Use straight quotation marks after numbers check box.</td>
</tr>
<tr>
<td>Change the appearance of single quotation marks</td>
<td>Choose a quotation mark style from the Open and Close list boxes located below Single quotes, or type a character in each of the boxes.</td>
</tr>
<tr>
<td>Change the appearance of double quotation marks</td>
<td>Choose a quotation mark style from the Open and Close list boxes located below Double quotes, or type a character in each of the boxes.</td>
</tr>
</tbody>
</table>

Straight quotation marks are sometimes used to represent feet (‘) and inches (”).

To add words to QuickCorrect

1. Click Text ➤ Writing tools ➤ QuickCorrect.
2. In the Replacement text area, enable the Replace text while typing check box.
3. In the Replace box, type the text to be replaced.
4. Type the replacement text in the With box.
5. Click Add.
You can use this feature to create shortcuts to frequently used words and phrases. Type the abbreviation in the Replace box, and the word or phrase in the With box.

**To add spelling corrections to QuickCorrect**

1. Click Text  Writing Tools  Settings.
2. Enable the Add corrections to QuickCorrect check box.

**To undo a QuickCorrect correction**

- Click Edit  Undo QuickCorrect.

**Spell Check and Grammatik**

By using the spelling checker and Grammatik, you can check the spelling and grammar in an entire drawing, part of a drawing, or only selected text. You can also check the spelling or grammar of dates, time, currency symbols, text or look up a word in a different language.

You can manually edit text and then resume checking the drawing.

The spelling checker and Grammatik replace words or phrases in two ways: you can choose a word, or define an automatic replacement for a word. Defining automatic replacement words is useful for words that are regularly misspelled. Automatic replacement words are stored in a user word-list file. For more information about user word-list files, see “Word lists” on page 678.

You can skip a writing error once but flag subsequent occurrences of the problem, or you can skip the error throughout the entire proofreading session.

**To check the spelling or grammar in an entire drawing**

1. Click Text  Writing tools, and click one of the following:
   - Spell check
   - Grammatik
2. Choose Document from the Check list box.

   To check the spelling or grammar in a different language, click Options  Language, and select a language.

   By default, the Auto start command is enabled for the spelling checker and Grammatik. If you disable the Auto start command (Options  Auto start), you must click the Start button in the Writing tools dialog box to check a drawing.

**To check the spelling or grammar in part of a drawing**

1. Click the Text tool A and click in a text frame.
2. Click Text  Writing tools, and click one of the following:
   - Spell check
   - Grammatik
3. From the Check list box, choose one of the following:
   - Paragraph
   - Selected text
   - Sentence
   - Word

   To check the spelling or grammar in a different language, click Options  Language, and select a language.
By default, the Auto start command is enabled for the spelling checker and Grammatik. If you disable the Auto start command (Options ➤ Auto start), you must click the Start button in the Writing tools dialog box to check a drawing.

The options available in the Check list box vary according to the type of drawing that you are checking.

To check the spelling or grammar of selected text
1 Select the text you want to check.
2 Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
To check the spelling or grammar in a different language, click Options ➤ Language, and select a language.
By default, the Auto start command is enabled for the spelling checker and Grammatik. If you disable the Auto start command (Options ➤ Auto start), you must click the Start button in the Writing tools dialog box to check a drawing.

To edit text manually
1 Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
2 When the spelling or grammar checker stops on a word or phrase, click in the Replace with box, and edit the text.

To replace a word or phrase
1 Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
2 When the spelling or grammar checker stops, choose a word or phrase from the Replacements list.
3 Click Replace.

If the spelling checker does not offer replacement words, you can edit text manually in the Replace with box.

To define automatic text replacements
1 Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
2 When the spelling or grammar checker stops on a word, click Auto replace.

To skip a spelling or grammar error
1 Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
2 When the spelling or grammar checker stops, click one of the following:
   • Skip once — to skip an error once
   • Skip all — to skip all occurrences of an error
You can also skip all occurrences of a word for all proofreading sessions by adding it to a user word list. For more information about user word-list files, see “Word lists” on page 678.

**Thesaurus**

You can use the thesaurus to refine your writing style. The thesaurus lets you look up options such as synonyms, antonyms, and related words.

You can replace a word by using the thesaurus. When you look up a word, the thesaurus provides a short definition and a list of the lookup options selected. The thesaurus does not specify word forms for verbs that appear the same in both the present and past tense and words used as multiple parts of speech words used as multiple parts of speech. The thesaurus lets you choose the correct word form to insert or replace in a document. The thesaurus also maintains a history list of the words that you have looked up. Each time you start the thesaurus, it begins a new history list.

You can also insert words with the thesaurus.

**Disclaimer:** The expanded thesaurus file and the dictionary contain words that may be offensive to some people. These words are included in the file to enable relational searches. It is not our intention to offend nor to promote the use of these terms.

**To replace a word**

1. Select a word.
2. Click **Text ▶ Writing tools ▶ Thesaurus**.
3. In the list of lookup options, double-click a definition to access the list of its synonyms, antonyms, and related words.
4. Click a word, and click **Replace**.

**You can also**

- **Look up words suggested by the thesaurus**
  - Double-click a word.
  - The definitions of the word appear in the bottom pane.

- **Look up any word**
  - Type a word in the list box at the top of the Thesaurus page and press **Enter**.

- **Look up recently checked words**
  - Choose a word from the list box at the top of the Thesaurus page.

In some instances, you are prompted to select the correct form of the word that you want to insert. This prompt appears when the word that you want to replace is spelled the same in both the present and past tenses (for example, “read”), or when the word can be used as more than one part of speech (for example, “wonder,” which can be used as either a noun or a verb).

Click the up and down arrows to scroll up and down through the word lists.

**To insert a word**

1. In the drawing, click where you want to insert the word.
2 Click Text ➤ Writing tools ➤ Thesaurus.
3 Type a word in the box at the top of the Thesaurus page and press Enter.
4 Choose a word from the list box.
5 Click Insert.

In some instances, you are prompted to select the correct form of the word that you want to insert. This prompt appears when the word that you want to replace is spelled the same in both the present and past tenses (for example, “read”), or when the word can be used as more than one part of speech (for example, “wonder,” which can be used as either a noun or a verb).

Work with languages

A drawing can contain text that alternates between different languages. For example, if English is the default language of your computer’s operating system, and you also have a French language module installed, you can use the writing tools to check the spelling or grammar of both French and English text. When you run the spelling checker, Grammatik, or the thesaurus, CorelDRAW checks words, phrases, and sentences according to their assigned language. This prevents foreign words from being marked as misspellings. You can use the writing tools the same way you would if the text were all in one language. You can check the spelling or grammar of dates, time, currency symbols, text or look up a word in a different language.

If multiple language modules are available, you can choose from the list and set a default Writing Tools language.

You can check for the formatting conventions of another language. For example, the spelling checker can format all dates in a drawing according to French conventions (such as “12 avril 2005”).

Many of the languages support hyphenation. Hyphenation lets you reduce the raggedness of text along the right margin by dividing a word that falls at the end of a line, instead of forcing the entire word to the next line.

You can also specify which quotation marks to use for different languages. For more information, see “To customize quotation marks for different languages” on page 672.

To assign a language to text

1 Select the text.
2 Click Text ➤ Writing tools ➤ Language.
3 In the Text language dialog box, choose a language from the list.

You can assign a language to selected words, sentences, or paragraphs.

To use the writing tools for the language you select in the Text language dialog box, the module for that language must be installed.

You can check which language has been assigned to text by selecting the text and viewing the three-letter language code that appears in the status bar.

Customize the writing tools

You can customize how the spelling is checked in a drawing. For example, you can choose how the spelling checker starts and whether it searches for misspelled words, irregular capitalization, duplicate words, or words with numbers.

You can customize how Grammatik checks grammar in a drawing. For example, you can customize Grammatik to start automatically, to prompt you before it automatically replaces words, and to show spelling suggestions for misspelled words.
You can customize the thesaurus to look up words or close automatically. The thesaurus can also be customized to suggest spelling suggestions for misspelled words and to display different types of word lists, such as synonyms, antonyms, and related words.

To set spelling checker options
1 Click Text ➤ Writing tools ➤ Spell check.
2 Click Options, and then click one of the following:
   • Auto start
   • Beep on misspelled
   • Recheck all text
   • Check words with numbers
   • Check duplicate words
   • Check irregular capitalization
   • Prompt before auto replacement
   • Show phonetic suggestions

The options you click are applied the next time you open the spelling checker.

To set Grammatik options
1 Click Text ➤ Writing tools ➤ Grammatik.
2 Click Options, and click one of the following:
   • Auto start
   • Prompt before auto replacement
   • Suggest spelling replacements

The options you click are applied the next time you open Grammatik.

To set thesaurus options
1 Click Text ➤ Writing tools ➤ Thesaurus.
2 Click Options, and click one of the following:
   • Auto look up
   • Auto close
   • Spelling assist
   • Synonym
   • Antonym
   • Related words
   • Is a type of
   • Has types
   • Is a part of
   • Has parts
   • Example

The options you click are applied the next time you open the thesaurus.
Checking styles

A checking style consists of preset writing style rules. Using a checking style lets you check a drawing that has a specific type of writing. For example, you can choose an advertising checking style to check advertising copy or marketing materials.

To select a checking style

1. Click Text ➤ Writing tools ➤ Grammatik.
2. Click Options ➤ Checking styles, and choose one of the following:
   - Spelling plus
   - Quick check
   - Very strict
   - Formal memo or letter
   - Informal memo or letter
   - Technical or scientific
   - Documentation or speech
   - Student composition
   - Advertising
   - Fiction
   - Grammar As-You-Go

A checking style remains in effect until you choose another one.

Word lists

A word list is a list of words or phrases scanned when you proof text by using the writing tools. Writing tools scan two types of word lists: user word lists and main word lists. Each language comes with a default user word list. You can customize user word lists by adding, deleting, or replacing words. Main word lists are lists of specialized words used by the spelling checker for a particular language, field or company.

You can add a user word list to help proof a text. You can have up to 10 user word lists active simultaneously. For example, if you want the spelling checker to scan both the US English and the Canadian English user word lists, add both lists. If you work in the medical profession, you can select a third-party medical word list that runs with the writing tools. Each language supported by the spelling checker has a default main word list. The active user word lists are scanned first; if the word or phrase is not found there, the active main word lists are scanned. You can also remove word lists.

You can add a word to a user word list so that the word is not flagged as an error. You can also add replacement words to a user word list, which lets you choose a replacement when the spelling checker or Grammatik stops on a word.

You can edit or delete words in a user word list at any time.

To add a user word list

1. Click Text ➤ Writing tools, and click one of the following:
   - Spell check
   - Grammatik
2. Click Options ➤ User word lists.
3. Click Add list.
In the Add user word list dialog box, choose a user word list.

Click Open.

The filename extension for a user list is .uwl.

When you check a drawing, the user word lists are scanned in the order of their appearance in the User word lists dialog box.

**To remove a user word list**

1. Click Text ➤ Writing tools ➤ Spell check.
2. Click Options ➤ User word lists.
3. Choose a user word list.
4. Click Remove list.

You cannot remove the default language word list.

**To add a word to a user word list**

1. Click Text ➤ Writing tools, and click one of the following:
   - Spell check
   - Grammatik
2. Click Options ➤ User word lists.
3. In the User word lists dialog box, choose a user word list.
4. Type a word in the Word/phrase box.
   - If you want to add a replacement word, type it in the Replace with box.
5. Click Add entry.
6. Click Close.

In the spelling checker, replacement words appear in the Replacements box.

Click Add from the Spell checker or Grammatik pages to add a word to the current user word list.

You can also add short phrases to a user word list.

**To edit a word or phrase in a user word list**

1. Click Text ➤ Writing tools, and click one of the following:
   - Spell check
   - Grammatik
2. Click Options ➤ User word lists.
3. Choose the user word list that contains the word or phrase you want to edit.
4. Choose the word or phrase you want to edit.
5. Edit the word or phrase in the Replace with box.
6. Click Replace entry.
If the word list you want to edit does not appear in the User word lists dialog box, click Add list to open the list.

To delete a word or phrase from a user word list

1. Click Text ➤ Writing tools, and click one of the following:
   • Spell check
   • Grammatik
2. Click Options ➤ User word lists.
3. Choose the word list you want to edit.
4. Choose the word or phrase you want to delete.
5. Click Delete entry.

To choose, add, or remove a main word list

1. Click Text ➤ Writing tools, and click Spell check.
2. Click Options ➤ Main word lists.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a main word list</td>
<td>Enable the check box that corresponds to the main word list that you want to use.</td>
</tr>
<tr>
<td>Add a main word list</td>
<td>Click Add list. In the Main word list editor dialog box, choose a main word list. Click Open.</td>
</tr>
<tr>
<td>Remove a main word list</td>
<td>Choose a main word list. Click Remove list.</td>
</tr>
</tbody>
</table>

Check statistics

You can check text statistics to count text elements, including the number of lines, words, characters, and the names of the fonts and styles used. You can display statistics either for selected text objects or for the entire drawing. If no text is selected, all text elements in the drawing, including tab and space characters, are counted.

To count text elements

1. Do one of the following:
   • To count text elements for an entire drawing, click a blank space in the drawing window.
   • To count text elements for selected text, select a block of text.
2. Click Text ➤ Text statistics.

You can also

Display information about the styles used

Enable the Show style statistics check box.
Reference: Writing tools

Languages and supported lookup options

The following table lists the languages and the thesaurus options they support.

<table>
<thead>
<tr>
<th>Language</th>
<th>Synonym</th>
<th>Antonym</th>
<th>Related Words</th>
<th>Related Information</th>
<th>Cross References</th>
<th>Hypernym</th>
<th>Hyponym</th>
<th>Phrases</th>
</tr>
</thead>
<tbody>
<tr>
<td>Danish</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dutch</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>EnglishUS</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EnglishUK</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EnglishCE</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EnglishOZ</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FrenchNational</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>FrenchCanada</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GermanNational</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td>GermanSwiss</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td>Italian</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Norwegian</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PortugueseNational</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td>PortugueseBrazilian</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
<td></td>
</tr>
<tr>
<td>SpanishNational</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
</tr>
<tr>
<td>SpanishLatin American</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td></td>
<td></td>
<td></td>
<td>✔️</td>
</tr>
</tbody>
</table>
Languages and available writing tools

The following table lists languages, codes, and which writing tools they are available for.

<table>
<thead>
<tr>
<th>Language</th>
<th>Code</th>
<th>Spelling checker</th>
<th>Grammatik</th>
<th>Thesaurus</th>
<th>Dictionary</th>
<th>Hyphenation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Afrikaans</td>
<td>AF</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Catalan</td>
<td>CA</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Czech</td>
<td>CZ</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Danish</td>
<td>DK</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Dutch</td>
<td>NL</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>English U.S.</td>
<td>US</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>English U.K.</td>
<td>UK</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>English Canada</td>
<td>CE</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>English Australia</td>
<td>OZ</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Finnish</td>
<td>SU</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>French Canada</td>
<td>CF</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>French National</td>
<td>FR</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Galician</td>
<td>GA</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>German National</td>
<td>DE</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>German Swiss</td>
<td>SD</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Greek</td>
<td>GR</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Icelandic</td>
<td>IS</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Italian</td>
<td>IT</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Language</td>
<td>Code</td>
<td>Spelling checker</td>
<td>Grammatik</td>
<td>Thesaurus</td>
<td>Dictionary</td>
<td>Hyphenation</td>
</tr>
<tr>
<td>----------------------</td>
<td>------</td>
<td>------------------</td>
<td>-----------</td>
<td>-----------</td>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Norwegian</td>
<td>NO</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Polish</td>
<td>PL</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>PortugueseBrazil</td>
<td>BR</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>PortuguesePortugal</td>
<td>PO</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Russian</td>
<td>RU</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Slovak</td>
<td>SL</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Sotho</td>
<td>ST</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>SpanishAmerica</td>
<td>EA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>SpanishNational</td>
<td>ES</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Swedish</td>
<td>SV</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Tswana</td>
<td>TN</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Turkish</td>
<td>TR</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Xhosa</td>
<td>XH</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Zulu</td>
<td>ZU</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Grammatik**

Grammatik uses the following notations to identify parts of speech or parts of a sentence.

<table>
<thead>
<tr>
<th>Notation in Grammatik</th>
<th>Grammatical term</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>3v</td>
<td>third-person present verb</td>
<td>The following sentences use the third-person present-tense verb form:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“He waits.”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“She brushes her hair.”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>“Does it sing?”</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>punctuation</td>
<td>Punctuation clarifies the meaning of a phrase or statement. Examples:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• period (.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• comma (,)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• question mark (?)</td>
</tr>
<tr>
<td>Notation in Grammatik</td>
<td>Grammatical term</td>
<td>Explanation</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>abrv</td>
<td>abbreviation</td>
<td>An abbreviation is a shortened version of a word. For example, “etc.” is an abbreviation of “etcetera.”</td>
</tr>
<tr>
<td>adj</td>
<td>adjective</td>
<td>An adjective modifies a noun. Example: a “good” book.</td>
</tr>
</tbody>
</table>
| adv                  | adverb           | An adverb modifies a verb or an adjective. Examples: 
  • go “quickly” 
  • a “very” good book |
| aux                  | auxiliary verb   | An auxiliary verb is a form of “be,” “have,” or “do.” Examples: 
  • “is” coming 
  • “had” not run 
  • “did” he say |
| bv                   | base verb        | A base verb is the form of a verb that comes after “to” in an infinitive, or after a modal (such as “would”). |
| c/s                  | comparative/superlative | The comparative and superlative forms of adjectives or adverbs indicate a degree of comparison. Examples: 
  • happier 
  • slowest |
| cj                   | conjunction      | A conjunction joins words, phrases, or clauses. Examples: 
  • the book “and” the pen 
  • I want to leave “because” it is late. |
| det                  | determiner       | A determiner is a type of adjective. Examples: 
  • a 
  • an 
  • the 
  • some 
  • these 
  • any |
| direct object        | direct object    | A direct object receives the action. Example: Bob opened “the box.” |
| ij                   | interjection     | An interjection is an exclamation. Examples: 
  • Hi! 
  • Oh! 
  • Hey! |
<table>
<thead>
<tr>
<th>Notation in Grammatik</th>
<th>Grammatical term</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| indirect object       | indirect object        | An indirect object tells “to whom” or “for whom” the action of the sentence occurs. Examples:  
|                       |                        | • Bob gave “her” an apple.  
|                       |                        | • I sent “him” a postcard. |
| inf                   | split infinitive       | A split infinitive is a verb in its infinitive form (to be, to run) that is split by intervening modifiers. For example, in the split infinitive “to boldly go,” the adverb “boldly” splits the infinitive “to go.” |
| main clause           | main clause            | A main clause is complete in meaning without any other sentence component. Examples:  
|                       |                        | • Let’s have the picnic today unless it rains. (Main clause: “Let’s have the picnic today”)  
|                       |                        | • When not in school, children play. (Main clause: “children play”) |
| mod                   | modal                  | A modal is a type of auxiliary verb. Examples:  
|                       |                        | • will  
|                       |                        | • must  
|                       |                        | • can  
|                       |                        | • should  
|                       |                        | • might |
| num                   | number                 | A number expresses a quantity. Examples:  
|                       |                        | • “three” boys  
|                       |                        | • “497” days  
|                       |                        | • “62” percent |
| phrasal               | phrasal preposition    | A phrasal preposition is a preposition that belongs to, but is separated from, a verb phrase. Example: put the book “down.” |
| pn                    | plural noun            | A plural noun is the plural form of a noun. Examples:  
|                       |                        | • books  
|                       |                        | • children |
| poss                  | possessive noun        | A possessive noun shows ownership. It is used as an adjective to modify another noun. Examples:  
|                       |                        | • “dog’s” leg  
|                       |                        | • “students’” cars  
<p>|                       |                        | • “Joe’s” son |</p>
<table>
<thead>
<tr>
<th>Notation in Grammatik</th>
<th>Grammatical term</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ppt</td>
<td>past participle</td>
<td>A past participle is a past-tense verb form. Example: The note was “written” in ink.</td>
</tr>
<tr>
<td>prep phr</td>
<td>prepositional phrase</td>
<td>A prepositional phrase consists of a preposition and its object, plus any modifiers. Prepositional phrases function as adjectives, adverbs, or nouns. Example: We came back “for the second show.”</td>
</tr>
</tbody>
</table>
| pres-p                | present participle          | A present participle is a verb form that can function as part of a verb phrase or as an adjective. It is usually created by adding “ing” to the base verb. Examples:  
  • He is “writing” a book.  
  • She is “going” to bed.  
  • The lawyers presented “closing” arguments. |
| prn                   | pronoun                     | A pronoun takes the place of a noun. Examples:  
  • I  
  • me  
  • you  
  • mine  
  • yourself  
  • these  
  • who  
  • which |
| pv                    | past tense                  | The past tense expresses actions that have already occurred. Examples:  
  • He “wrote” the book.  
  • We “went” to the store. |
<p>| relative clause       | relative clause             | A relative clause is a type of subordinate clause that acts like an adjective, describing the noun or pronoun that precedes it. A relative clause usually begins with a relative pronoun, such as “who,” “whom,” or “what.” Example: The employees “who worked diligently” were rewarded. |
| rel prn               | relative pronoun            | A relative pronoun introduces a subordinate clause and links it with an independent clause. Examples: The noise “that” scared you was made by the boy “who” lives next door. |</p>
<table>
<thead>
<tr>
<th>Notation in Grammatik</th>
<th>Grammatical term</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| sn                    | singular noun   | A singular noun is the name of one person, place, thing, or idea. Examples:  
  • Tom  
  • Canada  
  • pen  
  • health |
| subject               | subject         | The subject of a clause performs an action.  
  A subject can be one word or several. Examples:  
  • “John” ran.  
  • “The cats” meowed.  
  • “All the children and their mothers” took naps. |
| subordinate clause    | subordinate clause | A subordinate clause, which is also called a dependent clause cannot stand alone. It depends on another clause to complete its meaning. Example: We will have the meeting today, “because everyone is here.” |
| that clause           | that-clause      | A that-clause is a specialized subordinate clause starting with “that.” Example: We were sure “that you would pay us.” |
| verb or verb phrase   | verb or verb phrase | A verb or verb phrase shows action. Verbs can contain one word or several words, but Grammatik uses “verb phrase” when the verb consists of more than one word. Examples:  
  • John “ran.”  
  • He “has gone.” |
| wh-clause             | wh-clause        | A wh-clause is a specialized subordinate clause starting with “when,” “how,” “why,” or “where.” A wh-clause can serve as a noun, an adverb, or an adjective. Examples:  
  • We knew “where she would go.”  
  • I will tell you “when I go.” |
Templates and styles

Templates.............................................................................................................................................................................................691

Styles and style sets.............................................................................................................................................................................697

Color styles..........................................................................................................................................................................................707
Templates

A template is a collection of styles and page layout settings that govern the layout and appearance of a drawing. Templates are sometimes referred to as “templets.”

Use templates

When you start a document from a template by using the File > New from Template command, CorelDRAW formats the page according to the page layout settings in the template and then loads all objects and template’s styles into the new document. With this method, you can search and browse for templates.

If you want to use only the styles from a template, you can create a blank document by using the File > Open command.
You can also import styles from a template into a document at any time.

To start a document from a template

1 Click File  New from Template.
2 Click one of the following buttons:
   • Corel online templates — shows templates in the Corel online library
   • Local templates — shows local and network templates
3 Search or browse for templates.
4 Choose a template by clicking a thumbnail in the preview pane.
5 Click Open.

For information about searching for templates, see “To find, filter, and sort templates” on page 693.

You can also start a drawing from a template by clicking File  New, clicking the Templates tab, and choosing a template.

You can also start a document from a template by clicking File  Open, locating the template, double-clicking it, and enabling the New from template option in the Open dialog box. If you want to use only the template’s styles, disable the With contents check box.

To import styles from a template into a document

1 Click Window  Dockers  Object Styles.
2 In the Object Styles docker, open the Import, export, or save defaults flyout, and then click the Import style sheet button.
3 Locate the folder where the template is stored.
4 Click the template that contains the styles that you want to load.
5 Click Import.
6 In the Import Styles dialog box, enable the check boxes for the settings you’d like to import into the document.

Only the template styles are imported. Page layout settings and objects saved with the template are ignored. The attributes of existing objects are maintained.

Find templates

CorelDRAW provides an easy way of finding templates.

You can search by the file name, title, or keywords associated with a template. For example, if you type “certificate” in the text field, the application automatically filters out all files that do not match, and you see only the files that have the word “certificate” in the file name or keywords. You can cancel a search at any time.

You can narrow the search results by using the template source (for example, only templates created by you) and category (for example, Brochures, Flyers, or Letterheads & Letters). You can also view the list of your favorite or most recently used templates and sort templates by the name and the date they were created or modified.

You can browse and search either the entire local library (local templates included with CorelDRAW and provided by third-party designers, as well as templates that you have created) or online library (online templates provided by CorelDRAW) or one pack, folder or list at a time within those libraries.
Add templates

To get you started, Corel provides templates from the Corel online library and local templates (stored in your Documents\Corel\Corel Content\Templates folder) that appear by default on the Templates tab of the Create a New Document dialog box. If you are looking to expand your template collection, you can download additional template packs from within the Get More dialog box.

To access templates that are saved to local folders outside your Documents\Corel\Corel Content\Templates folder, you can create links (also known as aliases) to these folders. In addition, aliases can be used to access templates saved to shared network locations as well as secondary storage devices such as USB flash drives, and portable hard drives.

When you copy a folder that contains many templates to your computer, it may take some time for your operating system to index the folder. To view, browse, and search templates in such a folder right away, you may need to reindex the folder.

View template and template information

You can increase the size of thumbnails to recognize a particular template easier and faster, and you can decrease thumbnail size to view more search results at a glance. When you select a template in the viewing area, additional information is displayed about the template’s category, style, pagination, and fold options.

To find, filter, and sort templates

1 Click File ➤ New from Template.
2 Click the Options button ➤ Choose content source, and choose an option.
   If you want to search or browse all templates provided by Corel and any templates added by you, choose All folders.
3 Perform a task from the following table.

You can also

Find templates

Type a word in the Search box, and press Enter.

Templates that match the search term appear in the preview window.

Tip: To clear the search, delete the search term. Optionally, press Enter to see the default list of templates.

Filter templates

From the Filter templates based on categories list box, choose a category.

Sort templates

From the Sort templates by name or date list box, choose one of the following options:

* Favorites — shows your favorite templates. Templates in your Favorites list are sorted by name. For information about marking templates as favorite, see “To tag, rename, and delete templates” on page 695.
* Recent — shows the most recently used templates. Templates in your Recent list are sorted by name.
* Name — sorts templates by file name, in alphanumeric order
* Date Created — sorts templates by the date they were created, starting with the last created template
* Date Modified — sorts templates by the date they were modified, starting with the last modified template
You can also

Browse or search all items in your library

From the Filter templates based on categories list box, choose All categories. Click the Options button , and click Browse recursively.

Reindex a folder

Click the Options button and click Reindex folder.

When you choose My templates as the content source, you can browse all templates located in the root of your Documents\Corel \Corel Content\Templates folder.

If the CorelDRAW shell integration components are not installed (that is, if you have disabled the Windows Shell Extension option under Utilities in the Setup wizard during a custom installation), you can search for templates only by filename, not by name or keywords.

To download and add a new template pack

1. Click File New from Template.
2. Click the Get More button.
3. In the Get More dialog box, click the template pack you want.
4. Do one of the following:
   • Click Buy Now, and follow the onscreen instructions to purchase the item.
   • Click Download if the item is included in your product or subscription.

To add an alias to a location that contains templates

1. Click File New from Template.
2. Click the Options button Choose content source Add new.
3. Click Create alias.
4. In the Locate template library dialog box, browse to the folder or location you want.
5. Click Select Folder.

To view templates and template information

1. Click File New from Template.
2. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increase or decrease the size of thumbnails</td>
<td>Move the Thumbnail size slider.</td>
</tr>
<tr>
<td>View template details</td>
<td>Click a thumbnail in the left pane. The template details are displayed in the right pane. To hide the right pane where template details are displayed, disable the Show template details check box.</td>
</tr>
</tbody>
</table>
Manage templates

You can manage the list of your local template packs and aliases (links to local folders, network locations, and secondary storage devices). For example, you can rename the local packs or aliases, and you can remove aliases from the list. If an alias no longer works because the template folder has been moved, you can browse to the new location to restore the link.

To find the templates you like, you can mark them as favorites. In addition, you can view and change the properties of a template. For example, you can change its title and language, add new tags, and delete existing tags. You can change the template category, or you can assign a custom category to a template. When you no longer need a template, you can delete it.

To update the list of template packs and aliases

1. Click File ➤ New from Template.
2. Click the Options button ➤ Choose content source, and choose a template pack or an alias.
3. Click the Options button ➤ , and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rename a template pack or alias</td>
<td>Click Rename, and in the Rename dialog box, type a name in the Name box.</td>
</tr>
<tr>
<td>Browse to a folder that has been moved or renamed</td>
<td>Click Browse, and navigate to the folder that contains the templates.</td>
</tr>
<tr>
<td>Remove the alias from the list</td>
<td>Click Remove.</td>
</tr>
<tr>
<td>Open the template pack or alias in Windows Explorer</td>
<td>Click Open folder location.</td>
</tr>
</tbody>
</table>

To tag, rename, and delete templates

1. Click File ➤ New from Template.
2. Perform an action from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag a template as favorite</td>
<td>Right-click a thumbnail, and click Favorite.</td>
</tr>
<tr>
<td>Change the name of a template in your local library, or the tags associated with it</td>
<td>Right-click a thumbnail, and click Properties. In the Properties dialog box, do any of the following: • Choose a language from the Language list box. • Type a new name in the Title box. • Add or delete tags in the Tags box. • Choose a category from the Category list box to categorize the template. • To assign a custom category, choose New category from the Category list box, and type the category name in the box.</td>
</tr>
</tbody>
</table>
To Do the following

Delete a template from your local library Right-click a thumbnail, and click Delete.

Create templates

If the preset templates do not meet your needs, you can create your own templates, based on documents that you often use. For example, if you regularly put together a newsletter, you can save the page layout settings and styles to a template.

When you save a template, CorelDRAW allows you to add reference information, such as pagination, folds, and category. Although adding template information is optional, doing so makes it easier to organize and locate templates later on.

You can change the default location to which templates are saved. For more information, see “Change content locations” on page 125.

To create a template

1. Click File ➤ Save as Template.
2. Type a name in the File name list box.
3. Locate the folder where you want to save the template.
4. Click Save.
5. In the Template properties dialog box, specify the options you want:
   - Title — Assign a name to your template. This name will appear with the thumbnail in the Templates pane.
   - Tags — Type keywords that you want to associate with the template. You can use these words to search for the template on the Templates tab of the Create a New Document dialog box.
   - Sided — Choose a pagination option.
   - Folds — Choose a fold from the list.
   - Category — Choose a category to assign to the template. To assign a custom category, choose New category from the Category list box, and type the category name in the box.

   If you click Cancel, you close the Template properties dialog box without saving the template.

   If you don’t want to add reference information, click Save without specifying any of the options.

Edit templates

You can edit a template by making changes to the styles, page layout settings, or objects. For example, if you like a template but want to make it more versatile, you can add styles that you’ve created or that you’ve taken from another template. For information about editing styles, see “Edit styles and style sets” on page 701. For information about setting page layout options, see “Page layout” on page 719.

To edit a template

1. Click File ➤ Open.
2. Locate the folder where the template is stored.
3. Double-click a template filename.
4. In the Open dialog box, enable the Open for Editing option.
CorelDRAW provides advanced style capabilities that allow you to format your documents with speed, ease, and consistency. You can create and apply styles and style sets to different types of objects: graphic objects, artistic and paragraph text, callout and dimension objects, and any objects created with the Artistic Media tools.

Styles and style sets are groups of attributes that determine the appearance of objects. When you apply a style or style set to an object, all the attributes defined in that style are applied to the object in one step. That is how you can format simultaneously many different objects and significantly reduce your set-up and production time. What is more, when you edit a style or style set, all the objects defined by that style are automatically updated.

You can also export styles and style sets as style sheets for use in other documents, or import them from previously saved style sheets.

This section includes the following topics:

- “Create styles and style sets” (page 698)
- “Apply styles and style sets” (page 700)
- “Edit styles and style sets” (page 701)
- “Manage and apply default object properties” (page 702)
- “Export and import style sheets” (page 704)
Create styles and style sets

A style is a group of formatting attributes that defines an object property, such as outline or fill. For example, to define an outline style, you can specify attributes such as outline width, color, and type of line. To define a character style, you can specify the font type, font style and size, text color and background color, character position, caps, and more. CorelDRAW lets you create and apply outline, fill, paragraph, character, and text frame styles.

CorelDRAW lets you group styles into style sets. A style set is a collection of styles that helps you define the appearance of an object. For example, you can create a style set containing a fill style and an outline style that you can apply to graphic objects such as rectangles, ellipses, and curves.

There are two options for creating styles. You can create a style or style set based on the formatting of an object that you like, or you can create a style or style set from scratch by setting the object attributes in the Object Styles docker.

In CorelDRAW, styles can contain other styles. A style that contains another style is called a parent; a style that is contained within another style is called a child. Properties are automatically inherited from the parent; however, you can override inherited properties for a child and set its own specific properties. When you modify the parent style, the child style is updated automatically. If you set child-specific attributes, the attributes are no longer related to the parent, so if you modify the parent, the child-specific attributes will not be modified. The parent-child relationship applies to style sets as well.

You can use child and parent styles in documents where you want objects to share some, but not all, attributes, and you need to make global changes on a regular basis. For example, if you are working on a long document and you want to have headings and subheadings with similar formatting, you can create a parent character style for the headings and a child character style for the subheadings. The parent and the child styles can share the same color and font type but differ in size. If you choose a different color or font type for the parent, both the headings and the subheadings will be updated automatically. The subheadings, however, will still appear smaller than the headings.

To create a style from an object

1. Using the Pick tool , right-click an object.
2. Choose Object Styles, choose New Style From, and point to a style type. A preview shows you what object attributes will be included in the new style.
3. Click a style type.
4. In the New Style From dialog box, type a name in the New Style Name box.

If the Object Styles docker is not open, enable the Open Object Styles docker check box in the New Style From dialog box.

You can also create a style from an object by right-clicking the Styles folder in the Object Styles docker, choosing New from Selected, and then choosing a style type.

To create a style set from an object

1. Using the Pick tool , right-click an object.
2. Choose Object Styles, and point to New Style Set From.
A preview shows you what object attributes will be included in the new style set.

3 Click **New Style Set From**.

4 In the **New Style Set From** dialog box, type a name in the **New Style Set Name** box.

   If the **Object Styles** docker is not open, enable the **Open Object Styles docker** check box in the **New Style Set From** dialog box.

   You can also create a style set from a selected object (or multiple selected objects) by clicking **From Selection** in the **Object Styles** docker. The new style set is added under **Style Sets** in the **Object Styles** docker. If the selected object uses styles that match an existing style set, no new style set is added. CorelDRAW selects the matching style set in the **Object Styles** docker.

   You can also create a style set from an object by dragging the object to the **Style Sets** folder in the **Object Styles** docker. If you drag the object over an existing style set in the **Style Sets** folder, the attributes of the object replace the attributes of the style set, and all objects to which the style set has been applied are automatically updated.

To define a style

1 Click **Window** ➤ **Dockers** ➤ **Object Styles**.

2 In the **Object Styles** docker, click the **New style** button, and choose a style type.

   The style appears in the **Styles** folder with a name assigned by the application, for example “Fill 1.”

3 Specify the style attributes that you want.

   You can also

   Rename a style Right-click a style, click **Rename**, type a new name, and press **Enter**.

   Delete a style Do one of the following:

   • Select a style in the **Styles** folder, and click the **Delete style** button.
   • Right-click a style, and click **Delete**.

   Duplicate a style Right-click a style, and click **Duplicate**.

   Create a child style Do one of the following:

   • Select a style in the **Styles** folder, and click the **New Child Style** button.
   • Right-click a style, and click **New Child Style**.

To define a style set

1 Click **Window** ➤ **Dockers** ➤ **Object Styles**.

2 In the **Object Styles** docker, click the **New style set** button to create an empty style set to which you can add styles.

   The style set appears in the **Style Sets** folder with a name assigned by the application, for example “Style Set 1.”

3 Do one of the following:
• Click the **Add or remove style** button next to the style set, and select the style types that you want to add to the style set. Then, set the properties of each style.

• From the **Styles** folder, drag existing styles to the new style set.

**You can also**

**Rename a style set**
Right-click a style set in the **Style Sets** folder, click **Rename**, type a new name, and press **Enter**.

**Delete a style set**
Do one of the following:
- Select a style set in the **Style Sets** folder, and click the **Delete style set** button.
- Right-click a style set, and click **Delete**.

**Duplicate a style set**
Right-click a style set, and click **Duplicate**.

**Create a child style set**
Do one of the following:
- Select a style set in the **Style Sets** folder, and click the **New Child Style Set** button.
- Right-click a style set, and click **New Child Style Set**.

**Apply styles and style sets**

When you apply a style or a style set to an object, the object takes on only the attributes that are defined by the style or style set. For example, if you apply an outline style, the object outline changes while its other attributes stay the same.

You can apply styles and styles sets by using the **Object Styles** docker and the **Properties** docker.

In the **Properties** docker, attributes which are defined by a style appear with a source indicator that is green and has a vertical line in the middle. (The source indicator is the little square next to the attribute name.) If there is no style applied, the source indicator appears blank. If there is an override of the applied style, the source indicator color is orange with a horizontal line in the middle.
Styles simplify the task of formatting objects by saving time and ensuring a consistent look.

To apply a style or style set to an object

1. Using the **Pick tool**, select an object.
2. Click **Window** ➔ **Dockers** ➔ **Object Styles**.
3. In the **Object Styles** docker, select a style or style set, and click **Apply to Selection**.

To see a preview of the style or style set before applying it, point to it in the **Object Styles** docker.

You can also apply a style by clicking a source indicator next to an object property (outline, fill, character, paragraph, or frame) in the **Properties** docker and choosing a style from the list of styles.

You can also apply a style or style set to a selected object by using any of the following methods:

- In the **Object Styles** docker, double-click a style or style set.
- Right-click the object, choose **Styles**, choose **Apply Style**, and then choose a style or style set from the list.
- In the **Object Styles** docker, right-click a style or style set, and choose **Apply Style** or **Apply Style Set**.
- In the **Object Styles** docker, select a style or style set, and drag it to the object.

**Edit styles and style sets**

You can edit a style or style set either by changing its attributes in the **Object Styles** docker, or by changing the attributes of an object linked to the style or style set, and then applying these changes to the style or style set.

You can also edit a style or style set by copying attributes from an object to the style or style set.

You can override style attributes. When you override an attribute, it is no longer related to the style definition, and changes to the style do not affect the object until you remove the override.

To edit a style

1. Click **Window** ➔ **Dockers** ➔ **Object Styles**.
2. In the **Object Styles** docker, open the **Styles** folder, and select a style.
3. In the style properties area of the **Object Styles** docker, modify the attributes you want.
To edit a style set
1. Click Window  Dockers  Object Styles.
2. In the Object Styles docker, open the Style Sets folder, and select a style set.
3. Click the Add or remove style button next to the style set, and click the style type that you want to add or remove from the style set.
   Check marks appear next to the style types that are included in the style set.
   In the style properties area of the Object Styles docker, you can edit the styles that are included in the style set.

To edit a style or style set by editing an object
1. Using the Pick tool , select an object that has a style or style set applied to it.
2. Click Object  Properties.
3. In the Properties docker, edit the object properties.
4. In the document window, right-click the object, choose Object Styles from the context menu, and choose Apply to Style.
   The new attributes of the object replace the attributes of the styles or style sets associated with this object.

To edit a style or style set by copying properties from an object
1. Click Window  Dockers  Object Styles.
2. Drag an object from the document window over a style or style set name in the Object Styles docker.
   You can also copy the properties of an object to a style or style set by right-clicking the style or style set in the Object Styles docker, choosing Copy Properties From, and then clicking an object in the document window.

To override a style attribute
1. Using the Pick tool , select an object that has a style applied to it.
2. Click Object  Properties.
3. In the Properties docker, edit an object attribute defined by a style.
   The source indicator next to the attribute changes from green with a vertical line to orange with a horizontal line, showing that the object attribute is no longer defined by the style.

To remove a style override, do one of the following:
• Click the orange source indicator, and choose Revert.
• In the document window, right-click the object by using the Pick tool, choose Object Styles from the context menu, and choose Revert to Style.

Manage and apply default object properties
The default object properties in CorelDRAW control the appearance of text and graphic objects in the active document. For example, when you install CorelDRAW for the first time, each new graphic object has a black outline and no fill by default.
Using the **Object Styles** docker or the **Change Document Defaults** dialog box, you can modify the default properties of the following types of objects:

- **Artistic Media** — brushstrokes created with the Artistic Media tool
- **Artistic Text** — single words or short lines of text that are entered without text frames
- **Callout** — callout lines and text
- **Dimension** — dimension lines and text
- **Graphic** — lines, rectangles, ellipses, polygons, common shapes as well as grids drawn with the Graph Paper tool
- **Paragraph Text** — block text inserted in text frames
- **QR Code** — barcode objects that represent information in two dimensions

The **Change Document Defaults** dialog box comes up each time you choose a control that lets you change fill, outline, or text properties when there are no objects selected in the drawing window. If you don’t want to change any default object properties, click **Cancel**.

When you modify the defaults, CorelDRAW automatically saves these changes to the current document. If you want to use the custom settings in subsequent documents that you create, you can set them as the new document defaults.

You can specify which object styles, style sets, color styles, or default object properties in the active drawing are set as the new document defaults.

You can apply the default object properties to edited or imported objects.

**To edit default object properties**

1. Click **Window ➔ Dockers ➔ Object Styles**.
2. In the **Object Styles** docker, open the **Default Object Properties** folder, and choose one of the following object types:
   - **Artistic Media**
   - **Artistic Text**
   - **Callout**
   - **Dimension**
   - **Graphic**
   - **Paragraph Text**
   - **QR Code**
3. Modify the attributes you want in the **Object Styles** docker.
   
   Any changes you make are applied to all new objects in the active document and are automatically saved with the document.

You can also

- **Undo changes by reverting selected default properties to the default factory settings for new documents**
  
  Do one of the following:
  - Click the **Revert to new document default** button next to the object type.
  - Right-click the object type, and choose **Revert to new document default**.

- **Undo changes to the default object properties for all object types by reverting to the default factory settings for new documents**
  
  Do one of the following:
  - Click the **Revert all to new document default** button next to the **Default Object Properties** folder.
  - Right-click the **Default Object Properties** folder, and click **Revert all to new document default**.
You can also set selected object properties as the default settings for new documents.

Do one of the following:

- Click the `Set as new document default` button next to the object type.
- Right-click the object type, and click `Set as new document default`.

You can also edit the default object properties by deselecting all objects in the document window, clicking a color or a color style on a palette, or choosing a control that lets you change fill, outline, or text properties, and then enabling the respective check boxes in the `Change Document Defaults` dialog box.

You can also modify the default object properties while editing any object in the document window. Right-click the `Default Object Properties` folder in the `Object Styles` docker, and choose `Update Default Properties When Editing Objects`. Any change you make to an object becomes the default setting for new objects.

To set the current style settings as the new document defaults

1. Click `Window` ➤ `Dockers` ➤ `Object Styles`.
2. In the `Object Styles` docker, click the `Import, export, or save defaults` button, and click `Set as New Document Defaults`.
3. Enable the check boxes for the settings that you’d like to save as the default settings for new documents.

You can also save settings as the default settings for new documents by using the `Options` dialog box. For more information, see “Save and restore defaults” on page 959.

To apply the default object properties to an edited or imported object

1. Using the `Pick` tool, select an object.
2. Click `Window` ➤ `Dockers` ➤ `Object Styles`.
3. In the `Object Styles` docker, open the `Default Object Properties` folder, and double-click the relevant object type from the following list:
   - Artistic Media
   - Artistic Text
   - Callout
   - Dimension
   - Graphic
   - Paragraph Text
   - QR Code

Export and import style sheets

You can make styles and style sets available for use in other documents by exporting them to a CorelDRAW style sheet (.cdss) file. A style sheet contains all the object styles, style sets, color styles, and default object properties in the active document. You can also use styles and style sets from other documents by importing the style sheet to which they were saved.

To export a style sheet

1. Click `Window` ➤ `Dockers` ➤ `Object Styles`. 
2 In the **Object Styles** docker, click the **Import, export, or save defaults** button, and click **Export Style Sheet**.

3 In the **Export Style Sheet** dialog box, choose the folder where you want to save the style sheet.

4 Type a file name in the **File name** box.

5 Click **Export**.

6 Enable the check boxes for the settings you’d like to export from the document.

**To import a style sheet**

1 Click **Window** ➤ **Dockers** ➤ **Object Styles**.

2 In the **Object Styles** docker, click the **Import, export, or save defaults** button, and click **Import Style Sheet**.

3 In the **Import Style Sheet** dialog box, choose the folder where the style sheet is stored.

4 Select the file name, and click **Import**.

5 Enable the check boxes for the settings you’d like to import into the document.

You can also import styles and style sets from an existing CorelDRAW file by selecting the file in the **Import Style Sheet** dialog box and clicking **Import**.

**Assign keyboard shortcuts to styles or style sets**

You can assign a keyboard shortcut to a style or style set. When you press the keyboard shortcut, CorelDRAW applies the style or style set to the selected object. A keyboard shortcut can use up to four different keystrokes.

If a keyboard shortcut is already assigned to another command, you can override the existing setting.

For more information about working with keyboard shortcuts, see “Customize keyboard shortcuts” on page 963.

**To assign a keyboard shortcut to a style or style set**

1 Click **Window** ➤ **Dockers** ➤ **Object Styles**.

2 In the **Object Styles** docker, right-click a style or style set, and click **Assign Keyboard Shortcut**.

   The **Options** dialog box opens with the **Shortcut keys** tab of the **Commands** page displayed and **Apply styles** in the top list box selected.

3 Select the style or style set to which you want to assign a shortcut.

   If you have already assigned a keyboard shortcut to the selected style, the shortcut is displayed in the **Current shortcut keys** box.

4 Click in the **New shortcut key** box, and press a key combination.

   If the key combination is already assigned to another command, that command is listed in the **Currently assigned to** box.

5 Click **Assign**.

   If the same keyboard shortcut is already assigned to another command, the second assignment overwrites the first. By enabling the **Navigate to conflict on assign** check box, you can automatically navigate to the command whose shortcut you reassigned and assign a new shortcut.

**Find objects that use a specific style or style set**

CorelDRAW allows you to find objects with a specific style or style set in the active drawing. For example, you can find all text objects that use a specific heading style.
To find objects that use a specific style or style set
1 Click Window ➤ Dockers ➤ Object Styles.
2 In the Object Styles docker, open the styles or styles sets folder that contains a specific style or style set.
3 Right-click the style or style set, and choose Select Objects Using Style.

Break the link between objects and styles or style sets
You can break the link between an object and the style or style set applied to it. When you break the link, the object retains its current appearance. Subsequent changes to the style or style set will not affect the object attributes.

To break the link between an object and a style or style set
• In the document window, right-click an object by using the Pick tool, choose Object Styles from the context menu, and click Break Link to Style.

If the Break Link to Style command is not available, there are no styles or style sets applied to this object.

You can also break the link between an object and a style by clicking the source indicator next to the styled property (outline, fill, paragraph, character, or frame) in the Properties docker and choosing Not Styled.
Color styles

A color style is a color you save and apply to objects in a document. Any time you update a color style, you also update all objects using that color style. Color styles allow you to apply custom colors with ease and consistency.

This section contains the following topics:

• “Create and apply color styles” (page 707)
• “Edit color styles” (page 710)
• “View color styles” (page 714)
• “Export and import color styles” (page 715)
• “Break the link between a color style and an object” (page 715)

Create and apply color styles

You can create color styles from the colors of an existing object or from scratch. When you create a color style, the new color style is saved to the active document and to the Color styles palette.

After you create a color style, you can apply it to objects in the document. CorelDRAW lets you access available color styles through various controls: the Color Styles docker, the Object Styles docker, the Properties docker, the Color styles palette, and the Document palette. (A color style is automatically added to the Document palette when you apply it to an object.)

Color styles can be combined into groups called harmonies. A harmony allows you to link color styles into hue-based relationships and modify them together as a set. By editing color styles in a harmony, you can quickly create a variety of alternate color schemes by shifting the colors together, or you can alter the color composition of your artwork in one step.

CorelDRAW allows you to create a special type of color harmony called a gradient. A gradient consists of a master color style and a number of shades of that color style. For most of the available color models and palettes, the derivative color styles share the same hue as the master color style but have different saturation and brightness levels. With the PANTONE MATCHING SYSTEM and Custom spot color palettes, the master color style and the derivative color styles are linked to one another but have different tint levels.

You can create a harmony from the colors of an existing object or from scratch.

CorelDRAW also lets you select all color styles that are not used in the document or merge unwanted color styles into others. It also lets you convert color styles to different color modes or to spot colors to prepare your document for production printing.

To create a color style or harmony from a selected object

1 Select an object by using the Pick tool.
2 Click Window  Dockers  Color Styles.

3 In the Color Styles docker, click the New color style button and choose New from selected.

4 In the Create color styles dialog box, enable one of the following options in the Create color styles from area:
   • Object fill — creates a color style from the color of the object fill
   • Object outline — creates a color style from the color of the object outline
   • Both fill and outline — creates color styles from the object fill and outline colors

5 To group the new color styles based on hues of similar saturation and value, enable the Group color styles into harmonies check box, and specify the number of harmonies in the box.

To convert the color styles to a different color mode, enable the Convert all color styles to check box, and choose a color mode from the list box.

You can also create color styles or color harmonies from a selected object by using any of the following methods:

• Drag the selected object to the top part of the gray area in the Color Styles docker to create independent color styles, or drag the selected object to the bottom part of the gray area to create color styles grouped into harmonies. Then, specify the settings you want in the Create color styles dialog box.

• Right-click the object in the document window, and choose Color styles  New from Selected. Then, specify the settings you want in the Create color styles dialog box.

To create a color style

1 Click Window  Dockers  Color Styles.

2 Drag a swatch from any open palette to the top part of the gray area in the Color Styles docker.

You can also create a color style by clicking the New color style button, choosing New color style, and choosing a color in the Color editor. The Color editor provides a variety of options to choose the right color: Eyedropper tool, color viewers, sliders, and palettes. For more information about choosing colors, see “Color” on page 405.

If you want to create color styles from all the colors in your document, do one of the following:

• In the Color Styles docker, click the New color style button and choose New from document.

• In the document window, right-click an object using the Pick tool , and choose Color styles  New from document.

To create a color harmony

1 Click Window  Dockers  Color Styles.

2 In the Color Styles docker, click the New color harmony button and choose New color harmony.

A folder icon for the color harmony appears in the bottom part of the gray area.

3 Drag any color swatches or color style swatches to the harmony folder.

You can also duplicate a harmony by selecting its folder in the Color Styles docker, clicking the New color harmony button and choosing Duplicate harmony.

You can resize the Color harmonies area so that you can view available color harmonies without scrolling by pointing to the grab area, and when the cursor changes to a two-directional arrow, dragging the edge of the pane.
To create a gradient

1. Click **Window** ➤ **Dockers** ➤ **Color Styles**.
2. In the **Color Styles** docker, select a color style as the master color for the gradient.
3. Click the **New color harmony** button and choose **New gradient**.
4. In the **New gradient** dialog box, specify the number of shades in the **Number of colors** box.
5. Adjust the **Shade similarity** slider.
   - Move the slider to the left to create very different shades; move the slider to the right to create very similar shades.
6. Enable one of the following options:
   - **Lighter shades** — creates shades that are lighter than the master color
   - **Darker shades** — creates shades that are darker than the master color
   - **Both** — creates an equal number of light and dark shades

To apply a color style

1. Click **Window** ➤ **Dockers** ➤ **Color Styles**.
2. Select an object by using the **Pick** tool.
3. In the **Color Styles** docker, do one of the following:
   - Double-click a color style to apply a fill.
   - Right-click a color style to apply an outline.

You can also

- **Delete a color style**
  - Select the color style, and click the **Delete** button.
- **Merge selected color styles with the last selected color style**
  - Click the **Merge** button.
- **Swap color styles**
  - Select two color styles in the **Color Styles** docker, and click the **Swap color styles** button. The fill color style becomes the object outline, and the outline color style becomes the object fill.
- **Select all color styles which are not used in the document**
  - Click the **Select unused** button.

You can also apply a color style to a selected object by using any of the following methods:

- On the **Color styles** palette or the **Document** palette, click a color style to apply a fill or right-click a color style to apply an outline. To open the **Color styles** palette, click **Window** ➤ **Color palettes** ➤ **Color styles palette**.
- Drag a color style from a palette or the **Color Styles** docker to the object.
- In the **Outline** or **Fill** section of the **Properties** docker, click the source indicator next to the color picker, and choose from the list of previously created color styles.
You can also use the **Object Styles** docker to apply a color style, if the object style that is assigned to an object contains a color attribute, such as a fill or outline. In the style properties area of the **Object Styles** docker, click the source indicator next to a color picker, and choose from the list of previously saved color styles.

**Edit color styles**

You can edit an individual color style or a color style in a harmony.

When you edit a harmony, you can edit color styles simultaneously by preserving the relationship between them, or you can modify individual color styles within the harmony.

When you change the hue of the master color style in a gradient, all its derivative shades are updated based on the new hue and the original saturation and brightness value.

**Harmony rules**

You can apply a rule to a color harmony to shift all colors according to predetermined logic and create various color schemes (combinations). The selected color in the color harmony is considered to be the base color and is used as reference to position the remaining colors on the color wheel.

You can also use a harmony rule to create a color harmony from scratch. The resulting color harmony contains five colors that are created randomly based on the chosen rule, and its base color is the selected color in the harmony swatch list.

The following harmony rules are available.

- **Analogous** — includes colors that are next to each other on the color wheel, creating clear and smooth color schemes
- **Analogous - Accented** — similar to the Analogous rule, but includes a complementary (contrasting) color in addition to the adjacent colors
- **Complementary** (also known as “contrast”) — balances the base color with the opposite color on the color wheel. Warm and cold colors are created for vibrant and energetic color schemes.
- **Monochromatic** — includes variations of a single color, creating soothing color schemes
- **Tetrad** — based on a pair of colors and their complements on the color wheel. This rule usually creates bold color harmonies and requires careful planning when used.
- **Triad** — balances the base color with colors that are situated close to the opposite end of the color wheel, forming a triangle. This harmony rule usually creates color schemes of soft contrast.
Examples of color harmonies created from scratch by using the following harmony rules: (top) Analogous - Accented, Analogous, Complimentary; (bottom) Monochromatic, Tetrad, Triad.

The icons on the harmony folders show that the color harmonies are based on different harmony rules. From top to bottom: Analogous - Accented, Analogous, Complementary, Monochromatic, Tetrad, and Triad.

Editing color harmonies

You can edit color harmonies in various ways: by removing a previously applied harmony rule, by substituting the base color with the opposite color on the color wheel, by moving colors to different arms on the color wheel, and by dragging the color harmony on the color wheel.

You can select colors from multiple color harmonies and edit them simultaneously. This feature lets you edit multiple rule-based color harmonies at the same time without removing the rules.

In addition, you can convert a color style to the Grayscale color mode from within the Color Styles docker.
To edit a color style

1 Click Window > Dockers > Color Styles.
2 In the Color Styles docker, select an individual color style or a color style in a harmony.
3 In the Color editor or Harmony editor, edit the color style by using any of the available controls: Eyedropper tool, color viewers, sliders, and palettes.

   For more information about choosing colors, see “Color” on page 405.

You can also

- Rename a color style
  Select the color style in the Color Styles docker, and type a new name in the name box at the top of the docker.

- Convert a color style to a different color mode
  Click the Convert button, and choose a color mode from the flyout.

- Convert a color style to a spot color
  Click the Convert button, and choose Convert to Spot.

To edit a color harmony

1 Click Window > Dockers > Color Styles.
2 In the Color Styles docker, click a harmony folder.
3 Do any of the following:
   - In the Harmony editor, click a selector ring and drag to edit the color styles in the harmony. To constrain the movement of the selector ring, hold down Ctrl while dragging the selector ring to preserve the original saturation, or hold down Shift to preserve the original hue.
   - In the Color editor, choose a color by using any of the available controls: Eyedropper tool, color viewers, sliders, and palettes. For more information about choosing colors, see “Color” on page 405.
4 In the Harmony editor, move the Brightness slider to change the tint of the color.

   If you want to specify the exact tint, type a value in the Brightness box.

   To edit an individual color style in the harmony, select the style by clicking its swatch in the harmony folder, or by clicking its respective selector ring or swatch in the Harmony editor.

   You can resize the Color harmonies area so that you can view available color harmonies without scrolling by pointing to the grab area, and when the cursor changes to a two-directional arrow, dragging the edge of the pane.

   You can reorder color harmonies by dragging a color swatch.

To apply a rule to a color harmony

1 Click Window > Dockers > Color Styles.
2 In the Color Styles docker, click a harmony folder.
3 Choose a rule from the Harmony rule list box.
You can also

Create a rule-based color harmony from scratch
Make sure that no color styles are selected, and choose a rule from the Harmony rule list box.

Distribute colors evenly when changing a harmony rule
Make sure the Distribute colors button is enabled, and choose a harmony rule from the Harmony rule list box.
Colors will be distributed evenly along the arms on the color wheel, which can result in radical color changes.
When the Distribute colors button is disabled, color relationships in the color harmony are maintained.

You can choose Custom from the Harmony rule list box to remove a previously applied rule or start a new harmony folder.

To edit a color harmony
1 Click Window  Dockers  Color Styles.
2 In the Color Styles docker, click a color style in a color harmony.
3 In the Harmony editor, perform any of the following tasks.

To Do the following
Remove a rule from a color harmony Click the Remove harmony rule button.
Change to the opposite color on the color wheel Click the Switch to opposite color button.
Move a color to another arm Holding down Alt, drag a selector ring to another arm.
This feature is available for color harmonies that are based on the Complementary, Tetrad, or Triad harmony rule as well as custom color harmonies.
Edit multiple color harmonies simultaneously Click the color styles you want while holding down Ctrl, and drag a selector ring in the Harmony editor.
Convert a color style to the Grayscale color mode Click the Convert button, and click Convert to grayscale.

You can also convert a color style or a color harmony to the Grayscale color mode in the Create Color Styles docker when you are creating a color style or a color harmony from a selected object. For information about how to access the Create Color Styles docker, see “To create a color style or harmony from a selected object” on page 707.
View color styles

Several view options are available in the Color Styles docker to help your work with color styles more easily.

Hint view shows what objects are associated with color styles. When you point to a color style in the Color Styles docker, an indicator marks the object that uses the color style in the document window.

In addition, you can show larger color swatches, and you can view empty arms in color harmonies in the Harmony editor.

To use Hint view

1. Click Window ➤ Dockers ➤ Color Styles.
2. In the Color Styles docker, click the View options button , and click Hint view.
3. Point to a color style that was applied to an object.
   A small indicator appears in the center of the object that uses the color style.
To show larger color swatches

1. Click **Window ➤ Dockers ➤ Color Styles**.
2. In the **Color Styles** docker, click the **View options** button 🔄, and click **Use large swatches**.

To show empty arms in a color harmony

1. Click **Window ➤ Dockers ➤ Color Styles**.
2. In the **Color Styles** docker, click the **View options** button 🔄, and click **Show empty arms**.

Export and import color styles

You can reuse color styles by adding them to custom palettes, saving them as the new document defaults, or exporting them to a style sheet. You can also import color styles from other documents. For more information, see “Create and edit color palettes” on page 417, “Manage and apply default object properties” on page 702, and “Export and import style sheets” on page 704.

Break the link between a color style and an object

When you break the link between a color style and an object, the object no longer derives its color properties from the color style; you can update the color style without modifying the object.

To break the link between a color style and an object

1. Right-click an object by using the **Pick tool** 🖋, and choose **Color styles ➤ Break link to color styles**.

💡 You can also break the link to a color style in the **Properties** docker. Click the source indicator next to the color picker in the **Outline** or **Fill** sections of the **Properties** docker, and choose **Break link to color style**.
Pages and layout

Pages...................................................................................................................................................................................................719
Layout tools.........................................................................................................................................................................................739
Tables...................................................................................................................................................................................................749
Pages

CorelDRAW lets you specify the size, orientation, unit of scale, and background of the drawing page. You can choose to view one page or multiple pages at a time. You can add pages to drawings and duplicate existing pages. CorelDRAW provides options to change the width and height of pages. You can also reposition pages onscreen and reorder pages in a document. To resize or move a page to a different location in multipage view, you must select it. To delete a page, you need to make it active. You can specify custom names for pages and search for pages in the Pages docker. If a page contains a design that you would like to share with a customer, you can export the page as a separate file.

This section contains the following topics:
• “Page layout” (page 719)
• “Page background” (page 722)
• “Page views” (page 723)
• “Add, duplicate, and delete pages” (page 727)
• “Select and activate pages” (page 729)
• “Resize pages” (page 731)
• “Position and order pages” (page 734)
• “Rename pages” (page 735)
• “Find pages” (page 735)
• “Export pages” (page 735)
• “Insert page numbers” (page 736)

Page layout

You can begin working on a drawing by specifying settings for the size, orientation, and layout style of the page. The options you choose when specifying the page layout can be used as a default for all new drawings you create. You can also adjust the page size and orientation settings to match the standard paper settings for printing.

Page size

There are two options for specifying a page size: choosing a preset page size and creating your own. You can choose from many preset page sizes, ranging from legal-size paper and envelopes to posters and web pages. If a preset page size does not meet your needs, you can create a custom page size by specifying a drawing’s dimensions.

You can save custom page sizes as presets for later use, and you can delete any custom preset page sizes that you no longer need.
Page orientation

The orientation of the page can be landscape or portrait. In landscape orientation, the drawing’s width is greater than its height, and in portrait orientation, the drawing’s height is greater than its width. Any pages you add to a drawing have the current orientation; however, you can change the orientation of individual pages at any time.

Layout styles

When you use the default layout style (Full Page), each page in a document is considered a single page and prints on one sheet. You can choose layout styles for multipage publications, such as booklets and brochures. The multipage layout styles — Book, Booklet, Tent Card, Side-fold Card, Top-fold Card, and Tri-fold Brochure — split the page size into two or more equal parts. Each part is considered a separate page. The advantage of working with separate parts is that you can edit each page in upright orientation, and in sequential order in the drawing window, regardless of the layout required to print your document. When you are ready to print, the application automatically arranges the pages in the order required for printing and binding.

Label styles

You can choose from more than 800 preset label formats from different label manufacturers. You can preview the dimensions of labels and see how they fit on a printed page. If CorelDRAW does not provide a label style that meets your requirements, you can modify an existing style or create and save your own original style.

To set the page size and orientation

1. Click Layout ▶ Page Size.
2. Enable the Page size option.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a preset page size</td>
<td>Choose a page size from the Size list box.</td>
</tr>
<tr>
<td>Match the page size and orientation to the printer settings</td>
<td>Click the Get page size from printer button.</td>
</tr>
<tr>
<td>Specify a custom page size</td>
<td>Type values in the Width and Height boxes.</td>
</tr>
<tr>
<td>Set the page orientation</td>
<td>Click the Landscape or the Portrait button.</td>
</tr>
<tr>
<td>Set the page size and orientation for an individual page in a multipage document</td>
<td>Make sure that the page you want to change is displayed in the drawing window, choose a page size and orientation, and enable the Apply size to current page only check box.</td>
</tr>
<tr>
<td>Display the page border</td>
<td>Enable the Show page border check box.</td>
</tr>
<tr>
<td>Add a frame around the page</td>
<td>Click Add page frame.</td>
</tr>
<tr>
<td>Choose a rendering resolution for the document</td>
<td>Choose a resolution from the Rendering resolution list box.</td>
</tr>
<tr>
<td>Set a bleed limit</td>
<td>Enable the Show bleed area check box, and type a value in the Bleed box.</td>
</tr>
</tbody>
</table>
You can also open the **Options** dialog box with the **Page size** page displayed by double-clicking the shadow of the drawing page. You can change the page orientation by clicking **Layout**  **Switch Page Orientation**.

To change the page orientation in multipage view (**View**  **Multipage View**), right-click the page name label, and click **Switch Page Orientation**.

**To add or delete custom preset page sizes**

1. Click **Layout**  **Page Size**.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a custom preset page size</td>
<td>Specify a custom page size in the <strong>Width</strong> and <strong>Height</strong> boxes, click the <strong>Save</strong> button , and type a name for the custom page in the <strong>Save custom page type as</strong> box. The custom preset page size appears in the <strong>Size</strong> list box.</td>
</tr>
<tr>
<td>Delete a preset page size</td>
<td>Choose a page size from the <strong>Size</strong> list box, and click the <strong>Delete</strong> button</td>
</tr>
</tbody>
</table>

With the **Pick** tool active and no objects selected, you can also add or delete custom preset page sizes by clicking **Edit this list** at the bottom of the **Page size** list box on the property bar.

**To choose a layout style**

1. Click **Layout**  **Page Layout**.
2. Choose a layout style from the **Layout** list box.

   Each layout style is accompanied by a short description and illustration.

**To use a label style**

1. Click **Layout**  **Page Size**.
2. Enable the **Label presets** option.
3. Double click a manufacturer name from the list, and then choose a label style.

   If you want to customize the label style, click **Customize**, and adjust the label size, margins, gutters, and the number of labels appearing on each sheet.

   If you want to save the custom label style you created, click the **Add** button  in the **Save Settings** dialog box, type a name for the new label style in the **Save as** box.

   You cannot use label styles if a drawing contains multiple pages.
For best results, choose **Letter** paper size and **Portrait** orientation before applying a label style.

**To save the current page layout as the default**

1. Click **Layout ➤ Document Options**.
2. Click **Save as Default**.
3. Enable the **Page size** and **Layout** check boxes.

**Page background**

You can choose the color and type of background for a drawing. For example, you can use a solid color if you want a uniform background. If you want a more intricate or dynamic background, you can use a bitmap. Some examples of bitmaps include textured designs, photographs, and clipart.

When you choose a bitmap as the background, it is embedded in the drawing by default. This option is recommended. However, you can also link the bitmap to the drawing so that if you later edit the source image, the change is automatically reflected in the drawing. If you send a drawing with a linked image to someone else, you must also send the linked image.

You can make a background bitmap printable and exportable, or you can save computer resources by exporting and printing a drawing without the background bitmap.

If you no longer need a background, you can remove it.

**To use a solid color as the background**

1. Click **Layout ➤ Page Background**.
2. Enable the **Solid** option.
3. Open the color picker, and click a color.

When you export files to a bitmap format, the background color is used for anti-aliasing edges. If the bitmaps are of irregular shape and will be placed against a background different from white, it is recommended that you select a matching page background color. For example, if you are planning to place the exported bitmap against a blue background, you may want to choose a similar blue color for the page background.

**To use a bitmap as the background**

1. Click **Layout ➤ Page Background**.
2. Enable the **Bitmap** option.
3. Click **Browse**.
4. Locate the folder in which the file is stored.
5. Double-click the filename.
6. Enable one of the following options:
   - **Linked** — links the bitmap to the drawing so that changes made to the source file are reflected in the bitmap background
   - **Embedded** — embeds the bitmap in the drawing so that changes made to the source file are not reflected in the bitmap background

   If you want the background to be printed and exported with the drawing, enable the **Print and export background** check box.

7. Enable one of the following options:
   - **Default size** — lets you use the bitmap’s current size
• **Custom size** — lets you specify the dimensions of the bitmap by typing values in the H and V boxes.

If you want to specify nonproportional height and width values, disable the **Maintain aspect ratio** check box.

If the bitmap is smaller than the drawing page, it is **tiled** across the drawing page. If it is larger than the drawing page, it is **cropped** to fit the drawing page.

A background bitmap is not an object and cannot be edited.

To remove a background

1. Click **Layout › Page Background**.
2. Enable the **No background** option.

Page views

CorelDRAW offers different modes of viewing pages in documents. You can view one page or multiple pages at a time. You can choose a page view mode when you create a new document. For more information, see “To start a drawing” on page 63. You can also set the default page view mode for new documents. You can switch between page view modes at any time.

By default, documents are displayed in single page view.

In single page view, only one page is displayed at a time; to navigate between pages, you click the appropriate page tab (1) in the document navigator or the page name (2) in the Pages docker.

In multipage view, you view all document pages at once without having to constantly click back and forth between tabs. CorelDRAW provides options to display pages in document order or free-form mode. When designing and reviewing proofs for printed materials, such as brochures, books, and magazines, where pages have a fixed sequence, you can choose to arrange pages in a column, row, or grid. Custom mode, which allows for a free-form, non-sequential layout, is great for working with documents in which different assets for a project are placed on separate pages.
Branding and marketing assets for a bakery business have been arranged on different pages in a document: (page 1) bag; (page 2 and 3) business card; (page 4) gift certificate; (page 5, 6-7, and 8) menu; (9) packaging.

In all modes, you can create designs, as well as add, delete, duplicate, and resize pages interactively in the drawing window. The only difference between the modes is that in custom mode, you can rearrange pages and move them anywhere onscreen, whereas in grid, column, or row layout, pages have fixed positions and cannot be moved in the drawing window.
In grid, column, or row layout, you reorder pages by using the Pages docker or the document navigator. For more information, see “To reorder pages” on page 734.

In multipage view, you can zoom and pan to change the magnification level or move to a different page, respectively. For detailed information about zooming and panning, see “Zoom, pan, and scroll” on page 69.

Both in single and multipage view, you can use the Pages docker to quickly add, delete, rename, reorder, and browse through pages. CorelDRAW lets you change the size of items in the Pages docker as well as display them as thumbnails or in a list.

When you are laying out books, magazines, or other double-sided documents, you can also view document pages in spreads (also known as facing pages).

**To switch between page viewing modes**

- Click View ➤ Multipage View.

  A check mark next to the Multipage View command indicates that multipage view is turned on.

You can also switch between page viewing modes by clicking the Single page view ➤ or Multipage view ➤ buttons in the Pages docker (Window ➤ Dockers ➤ Pages).
To set the default page viewing mode for new documents

1. Click Layout ➤ Document Options.
2. In the Options dialog box, click General.
3. Click the Page View mode you want, click Save as Default, and click OK.

To arrange pages in multipage view

- In the Pages docker (Window ➤ Dockers ➤ Pages), click the Multipage View Settings button, and perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
</table>
| Show pages in document order | Choose one of the following Layout options:  
  • Grid – to arrange the pages in a grid  
  • Vertical – to arrange the pages in a single column  
  • Horizontal – to arrange the pages in a row  
  
Tips:  
  • To specify the number of columns in Grid layout, type a number in the Columns box.  
  • To set the spacing between the pages, type a value in the Spacing box.  
  • To reorder pages in Grid, Vertical, and Horizontal layout, in the Pages docker, drag a page to a new location in the page list. For more information about ordering pages, see “To reorder pages” on page 734. |
| Show pages in free-form mode | Click Custom |

To fit all pages in view, click the Zoom tool in the toolbox, and click the Zoom to all pages button on the property bar.

To zoom to selected pages, click the Pick tool in the toolbox, hold down Shift, click the page name label of a page that you want to select, and then click the other pages that you want to add to the selection. On the standard toolbar, click the Zoom levels list box, and click Zoom to selected.

To activate and zoom to a page, double-click the page thumbnail in the Pages docker (Window ➤ Dockers ➤ Pages).

You can use the Navigator to pan to a page in a complex multipage document. Hold down the Navigator button in the lower-right corner of the drawing window, and when a rectangle appears above the page thumbnails, drag the rectangle until the page that you want is in focus. For more information about panning, see “Zoom, pan, and scroll” on page 69.

To modify the display of items in the Pages docker

- In the Pages docker (Window ➤ Dockers ➤ Pages), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch the thumbnail preview between list view and grid view</td>
<td>Click the Thumbnail preview list or grid button.</td>
</tr>
</tbody>
</table>
To

Do the following

Change the size of items
Drag the Resize list slider until the items are the size you want.

To view facing pages

1. Click Layout ➤ Page Layout.
2. Enable the Facing pages check box.
3. Choose one of the following settings from the Start on list box:
   • Left side — starts the document on a left-hand page
   • Right side — starts the document on a right-hand page

You cannot view facing pages if the document uses a Tent Card or Top-fold Card layout style, or if it contains multiple page orientations. The Left side option is available only for the Full Page and Book layout styles.

In multipage view, facing pages display in Vertical layout by default, and the side of the start page is reflected in the page arrangement.

When you enable the Facing pages check box, the content on the facing pages is merged on one page. The layer structure for the merged page is based on the left-hand page. The layers from the right-hand page are inserted above the layers on the left-hand page. This rule also applies if you reorder the pages. If you disable the Facing pages check box, the layers and content are redistributed across separate pages. Objects that cross both pages are assigned to a page according to where the center of the object is found.

It is recommended that you avoid switching back and forth between individual pages and facing pages within the same document.

Add, duplicate, and delete pages

CorelDRAW lets you add pages to a drawing or duplicate existing pages. When you duplicate a page, you can choose to copy only the layer structure of the page or to copy the layers and all the objects they contain. For more information about layers, see “Layers” on page 373.

You can also duplicate and export a page to a new document.

To add a page

1. In the Pages docker (Window ➤ Dockers ➤ Pages), right-click a page name, and click Insert Page.
2. In the Pages area, type the number of pages you want to add in the Number of pages box.
3. To place the new page before or after the current page, enable one of the following options:
   • Before
   • After

   If you want to insert a page before or after a page other than the current page, type the page number in the Existing page box.

You can also

Specify the page size
Choose a page size from the Size list box.

Specify a custom page size
Type values in the Width and Height boxes.

Set the page orientation
Click the Landscape or the Portrait button.
To quickly insert a page before or after a page, right-click the page name in the **Pages** docker, and click **Insert Page After** or **Insert Page Before**. You can also add a page by clicking the **New Page** button in the **Pages** docker. The page is added after the last page in the document and becomes the active page.

To insert a page before or after a page in multipage view (**View**    **Multipage View**), right-click the page label, and click **Insert Page After** or **Insert Page Before**.

You can also insert a page after the current page by clicking the **Add page** button in the document navigator.

You can also add a page by right-clicking a page tab in the document navigator and clicking **Insert page after** or **Insert page before**.

To duplicate a page

1. In the **Pages** docker (**Window**    **Dockers**    **Pages**), right-click a page name, and click **Duplicate Page**.
2. In the **Insert new page** area of the **Duplicate page** dialog box, choose one of the following options:
   - **Before selected page**
   - **After selected page**
3. At the bottom of the dialog box, choose one of the following options:
   - **Copy layer(s) only** — lets you duplicate the layer structure without copying the contents of the layers
   - **Copy layer(s) and their contents** — lets you duplicate the layers and all their contents

You can also duplicate an active page by clicking **Layout**    **Duplicate Page** and specifying the options you want in the **Duplicate Page** dialog box.

You can also duplicate a page by right-clicking a page tab in the document navigator and specifying the options you want in the **Duplicate Page** dialog box.

You can also duplicate a page in multipage view (**View**    **Multipage View**) by right-clicking the page name label and specifying the options you want in the **Duplicate Page** dialog box.

You can also duplicate a page by right-clicking a page name in the **Objects** docker, choosing **Duplicate page**, and specifying the options you want in the **Duplicate Page** dialog box.

To duplicate and export a page to a new document

1. In the **Pages** docker (**Window**    **Dockers**    **Pages**), right-click a page name, and click **Duplicate Page**.
2. In the **Insert new page** area of the **Duplicate page** dialog box, choose the **To new document** option.
   - A new document opens with the same name as the duplicated page.

You can also duplicate and add the active page to a new document by clicking **Layout**    **Duplicate Page** and choosing the **To new document** option in the **Duplicate Page** dialog box.

You can also duplicate and add a page to a new document by right-clicking a page tab in the document navigator and choosing the **To new document** option in the **Duplicate Page** dialog box.

You can also duplicate and add a page to a new document in multipage view (**View**    **Multipage View**) by right-clicking the page name label and choosing the **To new document option** in the **Duplicate Page** dialog box.

You can also duplicate and add a page to a new document by right-clicking a page name in the **Objects** docker, choosing **Duplicate page**, and choosing the **To new document option** in the **Duplicate Page** dialog box.
To delete a page

• In the Pages docker (Window ➤ Dockers ➤ Pages), perform a task from the following table.

<table>
<thead>
<tr>
<th>To delete</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A page</td>
<td>Right-click a page name, and click Delete.</td>
</tr>
<tr>
<td>Multiple nonconsecutive pages</td>
<td>Hold down Ctrl, click the pages you want to delete, right-click any of the selected pages in the docker, and click Delete.</td>
</tr>
<tr>
<td>Multiple consecutive pages</td>
<td>Click the first page in the range of pages you want to delete, hold down Shift, click the last page in the range, right-click the selected pages in the docker, and click Delete.</td>
</tr>
</tbody>
</table>

You can also delete a page in multipage view (View ➤ Multipage View) by right-clicking the page name label, and clicking Delete Page.

You can also delete a page by selecting the page and clicking the Delete button in the Pages docker.

You can also delete an active page by clicking Layout ➤ Delete Page, and typing the number of the page that you want to delete. To delete a range of pages, enable the Through to page check box, and type the number of the last page to delete in the Through to page box.

You can also delete a page by right-clicking the page tab in the document navigator, and clicking Delete Page.

Select and activate pages

You can select multiple pages, but only one page is active at a time. You select and activate pages in the drawing window, Pages docker, and document navigator. Selecting the page name label with the Pick tool lets you resize the page. In the Custom layout of multipage view, selecting the page name label with the Pick tool also lets you reposition a page in the drawing window. For more information about multipage view modes, see “To arrange pages in multipage view” on page 726. Selecting a page in the Pages docker or a tab in the document navigator lets you delete, duplicate, or move a page to a different position in the document order.
A color outline around a page in multipage view indicates that the page is active. The color of the outline depends on your UI theme.

Control handles around a page in multipage view indicate that the page is selected.

**To select a page**

- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To select a page in</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single page view</td>
<td>Click the page name in the Pages docker (Window → Dockers → Pages).</td>
</tr>
<tr>
<td>Multipage view</td>
<td>Click the Pick tool in the toolbox and click the page name label in the drawing window.</td>
</tr>
</tbody>
</table>
You can also select a page by clicking a page tab in the document navigator.
To select multiple pages in multipage view, click the Pick tool in the toolbox, hold down Shift, click the page name label of a page that you want to select, and then click the other pages that you want to add to the selection.
You can also select multiple nonconsecutive pages in the Pages docker (Window ➤ Dockers ➤ Pages) by holding down Ctrl and clicking the pages you want.
You can also select multiple consecutive pages in the Pages docker by clicking the first page in the range of pages you want to select, holding down Shift, and clicking the last page in the range.

To make a page active
• Do one of the following:
  • With any tool, click anywhere on a page.
  • Click a page in the Objects docker (Object ➤ Objects).
  • Click a page in the Pages docker (Window ➤ Dockers ➤ Pages).
  • In single page view, click a page tab.
  • In multipage view, select a page.
  • In multipage view, double-click a page thumbnail in the Pages docker (Window ➤ Dockers ➤ Pages).

By design, the Zoom, Pan, and Eyedropper tools do not activate pages.
Any new objects that you create in multipage view, including objects that span two pages or objects that extend beyond the page border, are added to the active page.
When a page is active, its name is highlighted and appears bold in the Objects docker.
If you switch pages by clicking a page tab when Focus mode is active, you exit Focus mode. You can return to the object in Focus by pressing Ctrl + Z. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

Resize pages
CorelDRAW provides multiple ways to change the width and height of a page. When working in single page view, you can resize a page by specifying new dimensions or choosing a different preset. When working in multipage view, you can also resize pages interactively in the drawing window as you resize rectangles. To resize a page along a single axis, drag a middle handle. To resize a page along two axes and maintain the page proportions, drag a corner handle. The aspect ratio of width and height is constrained by default.
Dragging the top or bottom middle handle lets you scale a page vertically (left). Dragging the left or right middle handle lets you scale a page horizontally (right).

Dragging a corner handle lets you scale the page by maintaining the page proportions (left). Hold down Shift while dragging the handle to size the page evenly from the center (right).

The maximum page size is 1800 by 1800 inches. In multipage view, the dimensions of all pages combined cannot exceed the maximum viewport size.

You can also resize pages to accommodate content on local layers without having to manually change the page width and height using the Autofit Page button on the property bar. Optionally, you can set the distance between the page edges and your artwork.
To remove excess padding around an object on a page (left), the page is resized to the bounds of the object with a 1-inch margin (middle) and with no margin (right).

To specify the width and height of a page

1. Select a page.
2. Enter values in the Page dimensions boxes on the property bar, and press Enter.

The maximum page size is 1800 by 1800 inches.

You can also specify the page dimensions with precision by selecting a page and choosing a preset from the Presets list box on the property bar.

To resize a page interactively

1. In multipage view (View ➤ Multipage View), select a page by clicking the page name label in the drawing window with the Pick tool.
2. Do one of the following:
   - To resize a page along the vertical axis, drag the top or bottom middle handle.
   - To resize a page along the horizontal axis, drag the left or right middle handle.
   - To resize a page along the vertical and horizontal axes by maintaining the page proportions, drag a corner handle.
   - To resize a page evenly from the center, hold down Shift while dragging a handle.

By default, facing pages are resized evenly from the center.

You can also resize multiple pages by selecting the pages and dragging the control handles in the drawing window.
To autofit a page
1 Select the page that you want to resize.
2 Click the **Autofit Page** button on the property bar.
   To specify the distance between the page edges and your artwork, enter a value in the Margin box.
3 Click **Autofit Page**.

   Content on master layers is ignored.
   The **Autofit Page** button is disabled if there are no objects on local layers.

Position and order pages

You can position pages by dragging them to a new location in the drawing window. This option is available only in the Custom layout of multipage view. For more information about multipage view modes, see "To arrange pages in multipage view" on page 726. Moving pages in the drawing window does not affect the order of the pages in the document.

You can reorder pages in a document, including facing pages. Note, however, that moving only one of the facing pages in a spread may change the document structure and affect even the appearance of pages that you are not trying to move.

To position a page
1 In multipage view (View ➤ Multipage View), click the Multipage View Settings button in the Pages docker (Window ➤ Dockers ➤ Pages), and click Custom.
2 Click the Pick tool in the toolbox.
3 In the drawing window, click the page name label of the page that you want to move, and when the pointer changes to a position cursor, drag the page to a new position.

   The position of pages is maintained from one session to the next.
   When you move a page in multipage view, you can snap it to another page just like you snap objects to page elements. To enable snapping pages to page elements (edges, edge midpoints, and page center), click View ➤ Snap To ➤ Page.

To reorder pages

• Do one of the following:
  • In the Pages docker (Window ➤ Dockers ➤ Pages), drag a page to a new location in the page list.
  • In the document navigator, drag a page tab to a new location.

   By default, items in the Pages docker are displayed in a list. If you prefer to work with large thumbnails, drag the Resize list slider to the right until the thumbnails are the size you want.

To move a facing page
1 In the Pages docker (Window ➤ Dockers ➤ Pages), click the Options button, and click Show Spreads to disable the command.
2 Drag a facing page to a new location in the page list.
You can also move a facing page by dragging its page tab to a new location in the document navigator.

To move both facing pages in a spread at once, you must first enable the Show Spreads command.

**Rename pages**

You can specify custom names for pages.

**To rename a page**

- In the Pages docker (Window ▶ Dockers ▶ Pages), double-click the page name and type a new name.

  You can also rename an active page by clicking Layout ▶ Rename Page, and typing a name in the Page Name box.

  You can also rename an active page by right-clicking the page in the Pages docker, clicking Rename, and typing a name.

  You can also rename a page in multipage view (View ▶ Multipage View) by right-clicking the page name label, clicking Rename Page, and typing a name.

  You can also rename a page in the Objects docker (Object ▶ Objects) by double-clicking the page name and typing a new name.

**Find pages**

You can search pages by name in the Pages docker, or if you know the number of a page, you can quickly jump to it.

**To find a page**

- In the Pages docker (Window ▶ Dockers ▶ Pages), type the name of a page in the Search box.

**To go to a page**

1. Click Layout ▶ Go to Page.
2. Enter a page number, and click OK.

  You can also jump to a page by double-clicking the page counter in the document navigator, and entering a page number in the Go to Page box.

**Export pages**

If a page contains a design that you would like to share with a customer, you can quickly export it to commonly used formats, such as PDF, JPEG, PNG, SVG, EPS, TIFF, GIF, BMP, CGM, PSD, WEBP, CDR, AI, DWG, and DXF by using the Export docker. For more information about exporting pages, see “Export objects and pages” on page 891.

You can also duplicate a page and export it to a new document. For more information, see “To duplicate and export a page to a new document” on page 728.
insert page numbers

You can insert page numbers on the current page, all pages, all odd pages, or all even pages. When you insert page numbers on multiple pages, a new master layer is automatically created, and the page number is placed on it. The master layer can be an all-page master layer, an odd-page master layer, or an even-page master layer. For more information about master layers, see “Create layers” on page 373.

Page numbers are automatically updated when you add or delete pages in your document.

You can also insert a page number inside existing artistic or paragraph text. If the text is located on a local layer, the page number is inserted on the current page only. If the text is located on a master layer, the page number becomes part of the master layer and appears on all pages where the master layer is visible. For more information about artistic and paragraph text, see “Add and manipulate text” on page 597.

If the page numbers are on a master layer, you can hide the page number on a specific page.

You can change the default page number settings before or after you insert page numbers in your document. For example, you can start the page count at a specific number other than 1. This is particularly useful if you want to create multiple CorelDRAW files that will be put together as one publication.

You can also specify whether to start page numbering on the first page or on another page. For example, if you choose to start page numbering on page 3, page 3 displays the number 1. If you insert a new page between 1 and 2, it becomes the new page 2, whereas the old page 2 becomes page 3 — the page where the first page number is displayed.

You can also choose from a variety of commonly used page number styles.

When you save to CorelDRAW X5 or earlier version, page numbers are preserved as editable artistic text. However, if you add or delete a page, the page count will not be updated.

Manipulating page numbers as objects

Page numbers are artistic text objects (unless you insert them in paragraph text) that can be modified and manipulated like any other artistic text object. For example, you can resize, scale, or rotate a page number, change its color, or apply effects such as texture fill or a drop shadow.

When the page number is on a master layer, applying transformations to it affects all page numbers.

The following table lists various ways to manipulate page numbers as objects.

<table>
<thead>
<tr>
<th>You can</th>
<th>For more information see</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize and scale a page number</td>
<td>“Transform objects” on page 308</td>
</tr>
<tr>
<td>Rotate a page number</td>
<td>“Transform objects” on page 308</td>
</tr>
<tr>
<td>Mirror a page number</td>
<td>“Transform objects” on page 308</td>
</tr>
<tr>
<td>Change the color of a page number</td>
<td>“Choose colors” on page 408</td>
</tr>
<tr>
<td>Apply texture to a page number</td>
<td>“Texture fills” on page 437</td>
</tr>
<tr>
<td>Apply a drop shadow to a page number</td>
<td>“Add drop shadows and inner shadows” on page 564</td>
</tr>
</tbody>
</table>
To insert a page number

- Click Layout ➤ Insert Page Number, and choose one of the following options:
  - On active layer — lets you insert a page number on the layer that is currently selected in the Objects docker. If the active layer is a master layer, page numbers are inserted on all pages of the document where the master layer is visible. If the active layer is a local layer, the page number is inserted on the current page only.
  - On all pages — lets you insert page numbers on all pages. The page number is inserted on a new all-page master layer.
  - On all odd pages — lets you insert page numbers on all odd pages. The page number is inserted on a new odd-page master layer.
  - On all even pages — lets you insert page numbers on all even pages. The page number is inserted on a new even-page master layer.

By default, the page number is centered at the bottom of the page.

In the Objects docker, the page number appears as an artistic text object with the name “Page Number.”

You can insert page numbers on odd pages only if the current page is an odd page, and you can insert page numbers on even pages only if the current page is an even page.

You can move the page number anywhere on the page by selecting it with the Pick tool and dragging it to a new location. If you move a page number outside the drawing page, the page number turns into the generic number sign (#). If you then place it on another page, it displays the correct number of the page.

You can also insert a page number inside an existing text object. Using the Text tool, type artistic or paragraph text. With the cursor inside the text object, click Layout ➤ Insert page number ➤ On active layer. The page number is added as part of the existing text, and it will not appear as a separate object in the Objects docker.

To hide the page number on a single page

1. Select the page in the Objects docker.
   - If the Objects docker is not open, click Object ➤ Objects.
2. In Pages, Layers, and Objects view, select the page.
3. Click the Options button ➔, and click Show Master Layers on Pages.
4. Under the selected page, point to the master layer that has the page numbering, and click the Show or hide icon.

   The application hides the page number of the current page, but the page is still included in the page count. All other pages continue to display their page numbers.

To modify page number settings

1. Click Layout ➤ Page Number Settings.
2. In the Page number settings dialog box, choose any of the following options.
   - Start at number — lets you start the page count at a specific number
   - Start on page — lets you specify the page on which to start page numbering
   - Style — lets you choose from commonly used page number styles
Layout tools

You can customize and display page grids and guidelines to help you organize objects and place them exactly where you want. For example, if you are designing a newsletter, you can set the dimensions of the pages and create guidelines for positioning columns and heading text. When you are laying out an advertisement, you can align graphics and text along guidelines and arrange graphic elements within a grid. Rulers can help you position grids, guidelines, and objects along a scale that uses units of your choice. Also, you can add and delete pages.

Page layout settings and tools are fully customizable and can be used as defaults for other drawings.

This section contains the following topics:

- “Rulers” (page 739)
- “Calibrate the rulers” (page 741)
- “Document grid and pixel grid” (page 741)
- “Baseline grid” (page 743)
- “Set up guidelines” (page 744)
- “Modify guidelines” (page 747)
- “Drawing scale” (page 748)

Rulers

You can display rulers in the drawing window to help you draw, size, and align objects precisely. You can hide the rulers or move them to another position in the drawing window. You can also customize the ruler settings to suit your needs. For example, you can set the ruler origin, choose a unit of measure, and specify how many marks or ticks appear within each full unit mark.

You can show and hide rulers for Desktop mode and Tablet mode independently to suit your workflow. By default, rulers are displayed in Desktop mode and hidden when you switch to Tablet mode.
The rulers are usually displayed in Desktop mode.

By default, CorelDRAW applies the units used for the rulers to the duplicate and nudge distances. You can change the default and specify different units for these and other settings. For information about nudging, see “Position objects” on page 327.

To hide or display the rulers

- Click View ➤ Rulers.
  
  A check mark beside the Rulers command indicates that the rulers are displayed.

To customize ruler settings

1. Click Layout ➤ Document Options.
2. Click Rulers.
3. In the Units area, choose a unit of measure from the Horizontal list box.
   
   If you want to use a different unit of measure for the vertical ruler, disable the Same units for horizontal and vertical rulers check box, and choose a unit of measure from the Vertical list box.
4. In the Origin area, type values in the following boxes:
   - Horizontal
   - Vertical
5. Type a value in the Amount box in the Tick divisions area.

If you change the unit of measure for rulers, the unit of measure for nudge distances automatically changes as well, unless you first disable the Same units for nudge distance check box in the Nudge area.
You can access ruler settings directly by double-clicking a ruler.

You can specify nudge settings by typing values in the Nudge, Super nudge, and Micro nudge boxes in the Nudge area.

To show or hide the rulers for Desktop and Tablet mode
1. Click Layout ➤ Document Options.
2. Click Rulers.
3. On the Rulers page, enable or disable the following check boxes:
   • Show rulers in Desktop mode
   • Show rulers in Tablet mode

Calibrate the rulers
You can have one inch on your screen equal one inch of “real” distance. This lets you work with real-world distances as opposed to relative distances that depend on screen resolution. This tool is particularly useful when you work with signs or draw in 1:1 zoom mode.

Before you can perform this procedure, you must have a clear plastic ruler for comparing real-world and on-screen distances. This ruler should use the same unit of measure that you set for the CorelDRAW rulers. For information about ruler settings, see “Rulers” on page 739.

To calibrate the rulers to real-world distance
1. Click Tools ➤ Options ➤ Tools.
2. Click Zoom/Pan.
3. Click Calibrate rulers.
4. Place a clear plastic ruler under the on-screen horizontal ruler.
5. Click the up or down arrows on the Horizontal box to match one unit of measure on the on-screen ruler with one unit of measure on the actual ruler.
6. Place the ruler beside the on-screen vertical ruler.
7. Click the up or down arrows on the Vertical box to match one unit of measure on the on-screen ruler with one unit of measure on the actual ruler.

Document grid and pixel grid
The document grid is a series of non-printing intersecting lines that you can display in the drawing window. You can use the document grid to precisely align and position objects.

You can customize the look of the document grid by changing the grid display and grid spacing. The grid display lets you view the document grid as lines or as dots. The spacing lets you set the distance between the grid lines. The spacing options are based on the unit of measure for the ruler. For example, if the ruler unit of measure is set to inches, the spacing options are based on inches.

If the ruler unit of measure is set to pixels, or if you enabled the Pixels view, you can specify the color and opacity of the pixel grid. The pixel grid is a series of intersecting lines that show you individual pixels in a document. For more information about the Pixels view, see “Viewing modes” on page 74. By default, the lower-left corner of the document page is aligned with pixel grid to help you create pixel-perfect objects for the web.

You can also have objects snap to the document grid or the pixel grid, so that when you move the objects, they align with the grid lines.
To display or hide the document grid

- Click View ➤ Grid ➤ Document Grid.

A check mark beside the Document Grid command indicates that the document grid is displayed.

To set the document grid display and spacing

1. Click Layout ➤ Document Options.
2. In the left pane of the dialog box that appears, click Grid.
3. Enable the Show grid as check box, and enable one of the following options:
   - Lines
   - Dots
4. In the Document grid area, type a value in the Horizontal box.
   If you want to change the grid spacing intervals or the number of lines displayed per unit of measure, choose an option from the list box. The options are based on the unit of measure used for the ruler.
5. Type a value in the Vertical box.

The unit of measure used for grid spacing is the same as that used for rulers. For information about ruler settings, see “To customize ruler settings” on page 740.

To change the settings of the pixel grid

1. Click Layout ➤ Document Options.
2. Click Grid.
3. In the Pixel grid area, open the Color picker, and click a color.
4. Move the Opacity slider to the right to increase the opacity of the grid.

You can also

Enable or disable object snapping to pixels
Enable or disable the Snap to pixel check box.
You can also

Show or hide the pixel grid (when zoomed in at 800% or higher)

Align page center with the pixel grid (useful when saving files to earlier versions of CorelDRAW)

Enable or disable the Show grid at 800% or higher zoom check box.

To see the effect, switch to pixel view (View ➤ Pixels) and zoom to 800% or higher.

Disable the Align page with pixel grid check box.

The Align page with pixel grid setting aligns the lower-left corner of the page with the pixel grid to help you create pixel-perfect designs on export. Disable this check box only when you plan to save the file to an earlier version of CorelDRAW.

To set objects to snap to the document grid

1. Click View ➤ Snap To ➤ Document Grid.
2. Move the objects with the Pick tool.

To set objects to snap to the pixel grid

1. Click View ➤ Snap To ➤ Pixels.
2. Move the objects with the Pick tool.

This option is available only when pixel view is enabled. For more information, see “Viewing modes” on page 74.

Baseline grid

The guides of the baseline grid run across the drawing page and follow the pattern of a ruled notebook. You can display or hide the baseline grid, turn snapping on or off, change the grid color, and set the line spacing. By default, the line spacing is 14 pt. All objects can snap to the baseline grid; only text frames can align to baseline grid. For more information, see “Align text to the baseline grid” on page 606.

To display or hide the baseline grid

• Click View ➤ Grid ➤ Baseline Grid.

A check mark beside the Baseline grid command indicates that the baseline grid is displayed.

To set baseline grid spacing and color

1. Click Layout ➤ Document Options.
2. In the left pane of the dialog box that appears, click Grid.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set spacing</td>
<td>In the Baseline grid area, type a value in the Spacing box.</td>
</tr>
</tbody>
</table>
To

Set distance from top

Do the following

Type a value in the Start from top box.

Setting this value to 0 makes the first line of the baseline grid overlap with the top edge of the drawing page.

Set color

Open the Color picker, and choose a color.

To turn baseline grid snapping on or off

• Click View ➤ Snap To ➤ Baseline Grid.

A check mark beside the Baseline grid command indicates that snapping is turned on.

💡

You can also click Layout ➤ Document Options, click Grid, and enable or disable the Snap to grid check box in the Baseline grid area.

Set up guidelines

Guidelines are lines that can be placed anywhere in the drawing window to aid in object placement. In some applications, guidelines are known as guides.

There are three types of guidelines: horizontal, vertical, and angled. By default, the application displays guidelines that you add to the drawing window, but you can hide them at any time. You can also use objects as guides.

You can set guidelines for individual pages or you can set guidelines for the entire document. For more information about local and master guidelines, see “Local layers and master layers” on page 374.

You can add a guideline wherever you need one; however, you can also choose to add preset guidelines. There are two types of preset guidelines: Corel presets and user-defined presets. Examples of Corel presets include guidelines that appear at 1-inch margins and guidelines that appear at newsletter column borders. User-defined presets are guidelines whose location you specify. For example, you can add preset guidelines that display margins at a distance you specify or that define a column layout or grid. You can remove guidelines at any time.

You can have objects snap to the guidelines, so that when an object is moved near a guideline, it can only be centered on the guideline or lined up on either side of the guideline.

Guidelines use the unit of measure specified for the rulers. For information about ruler settings, see “To customize ruler settings” on page 740. By default, all guidelines are shown at the drawing scale specified in the Edit Scale dialog box. You can choose not to display guideline coordinates at scale, but rather to show the actual position of a guideline on the page.
To display or hide the guidelines

- Click View ➤ Guidelines.

A check mark beside the Guidelines command indicates that the guidelines are displayed.

💡 You can also display or hide the guidelines by clicking Window ➤ Dockers ➤ Guidelines and clicking the Show or hide guidelines button.

You can also access additional guideline options by clicking Layout ➤ Document Options, and then clicking Guidelines in the left pane of the dialog box that appears.

To add a horizontal or vertical guideline

1. Click Window ➤ Dockers ➤ Guidelines.
2. Choose one of the following options from the Guideline type list box:
   - Horizontal
   - Vertical
3. Specify the location of the guideline in the x or y box.
4. Click Add.

💡 You can also add a guideline by dragging from the horizontal or vertical ruler to the drawing window.

To add an angled guideline

1. Click Window ➤ Dockers ➤ Guidelines.
2. Choose Angled from the Guideline type list box.
3. Specify the location of the guideline in the x and y boxes.
4. Type a value in Angle of rotation box.
5. Click Add.

💡 You can also add an angled guideline by dragging from the horizontal or vertical ruler in the drawing window, and typing a value in the Angle of rotation box on the property bar.
To use an object as a guide
1 In the **Objects** docker, click the **Guides** layer on the page you want.
   If the **Objects** docker is not open, click **Object** ➤ **Objects**.
2 Draw and position the object you want to use as a guide.

   The object appears as a custom guide in the **Guidelines** docker.
   Custom guides cannot be edited in the **Guidelines** docker.

To set guidelines for the entire document
1 In the **Objects** docker, click **Guides (all pages)** on the **Master page**.
   If the **Objects** docker is not open, click **Object** ➤ **Objects**.
2 In the drawing window, add the guidelines you want.

   The guidelines that you set on the **Guides (all pages)** layer of the **Master page** appear on all pages of the document. These guidelines appear in addition to any guidelines that you set for individual pages.

To add preset guidelines
1 Click **Layout** ➤ **Document Options**.
2 In the left pane of the dialog box that appears, click **Guidelines**.
3 Click Presets.
4 Choose one of the following options from the **Preset type** list box:
   • Corel presets
   • User-defined presets
5 Specify guideline settings by enabling the corresponding check boxes.
   If you enable the **User-defined presets** option, specify values in the **Margins, Columns**, or **Grid** area.

To remove a guideline
1 Click **Window** ➤ **Dockers** ➤ **Guidelines**.
2 Choose a **guideline** from the list.
   You can choose multiple guidelines by holding down **Ctrl** as you click.
3 Click the **Delete** button CCS

   You can also remove individual guidelines by dragging them off the document window, or clicking a guideline with the **Pick** tool and pressing **Delete**.

   To delete a preset guideline, click **Layout** ➤ **Document Options**. In the left pane of the dialog box that appears, click **Guidelines**, and then click **Presets**. Disable the check box beside the preset guideline that you want to delete.
To have objects snap to the guidelines
1. Click View ▸ Snap To ▸ Guidelines.
2. Drag the object to the guideline.

To snap the center of an object to a guideline, select the object, and drag it by its center over the guideline until the center snaps to the guideline.

You can also set objects and editable areas to snap to a guideline by clicking Window ▸ Dockers ▸ Guidelines and clicking the Snap to guidelines button.

To display the actual position of a guideline on the page
1. Click Window ▸ Dockers ▸ Guidelines.
2. Click the Options button, and click Show at scale to disable the command.

The guideline coordinate no longer matches the value on the property bar and the rulers. For example, if the drawing scale is 1:100, a guideline positioned at 100 mm at scale appears at 1.000 mm when the Show at scale command is disabled.

Modify guidelines
After you add a guideline, you can select it, move it, rotate it, or lock it in place. You can also change the line style and color of guidelines.

To select a guideline

To

Select a single guideline

Select all guidelines on a page

To move or rotate a guideline
1. Click Window ▸ Dockers ▸ Guidelines.
2. Select the guideline.
3. Perform any of the following tasks.

To

Move a guideline

Do the following

Click the guideline with the Pick tool.

Click Edit ▸ Select ▸ Guidelines. The local guidelines and master guidelines are selected.

Specify the new location of the guideline in the x and y boxes, and click Modify.

You can also drag a guideline to a new position in the drawing window.
To rotate a guideline

Do the following

Choose **Angled** from the **Guideline type** list box, type a value in the **Angle of rotation** box, and click **Modify**.

You can also use the **Pick** tool to click the guideline twice and then rotate the guideline when skewing handles appear.

To lock or unlock a guideline

• Right-click the guideline, and click **Lock** or **Unlock**.

You can also click **Window  Dockers  Guidelines** and click the **Lock guideline** button.

To set the line style and color of a guideline

1. Click **Window  Dockers  Guidelines**.
2. Open the **Guideline color** picker, and choose a guideline color.
3. Open the **Guideline style** picker, and choose a line style.

**Drawing scale**

You can choose a preset or custom drawing scale so that distances in a drawing are proportionate to real-world distances. For example, you can specify that 1 inch in the drawing corresponds to 1 meter in the physical world. A preset drawing scale lets you set a typical scale, such as 1:2 or 1:10. A custom drawing scale lets you set any distance on the page to correspond to a real-world distance. For example, you can set a more precise scale that includes decimal numbers, such as 4.5 to 10.6.

Drawing scales are particularly useful if you are creating a technical or architectural drawing with dimension lines. For information about dimension lines, see “Connector and callout lines” on page 191.

To choose a drawing scale

1. Click **Layout  Document Options**.
2. In the **Options** dialog box, click **Rulers** in the left pane.
3. Click **Edit Scale** in the right pane.
4. In the **Drawing Scale** dialog box, choose a drawing scale from the **Typical scales** list box.
   To create a custom drawing scale, choose **Custom** from the **Typical scales** list box, and specify the settings you want.

The **Edit Scale** button does not appear if the ruler’s unit of measure is **pixels**.

If the drawing scale is set to anything other than 1:1, the units on the vertical ruler are the same as the units on the horizontal ruler.
Tables

A table provides a structured layout that lets you present text or images within a drawing. You can draw a table, or you can create a table from paragraph text. You can easily change the look of a table by modifying the table properties and formatting. In addition, because tables are objects, you can manipulate them in various ways. You can also import existing tables from a text file or a spreadsheet.

This section contains the following topics:
• “Add tables” (page 749)
• “Select, move, and navigate table components” (page 751)
• “Insert and delete table rows and columns” (page 753)
• “Resize table cells, rows, and columns” (page 755)
• “Format tables and cells” (page 756)
• “Text in tables” (page 759)
• “Convert tables to text” (page 760)
• “Merge and split tables and cells” (page 761)
• “Manipulate tables as objects” (page 762)
• “Add images, graphics, and backgrounds to tables” (page 763)
• “Import tables” (page 763)

Add tables

With CorelDRAW, you can add a table to a drawing to create a structured layout for text and images. You can draw a table, or you can create a table from existing text.
To add a table to a drawing

1  Click the **Table** tool.

2  Type values in the **Rows and columns** boxes on the property bar.

   The value that you type in the top portion specifies the number of rows; the value that you type in the bottom portion specifies the number of columns.

3  Drag diagonally to draw the table.

You can also create a table by clicking **Table ➤ Create new table**, and then typing values in the **Number of rows**, **Number of columns**, **Height**, and **Width** boxes.
To create a table from text
1. Click the Pick tool.
2. Select the text that you want to convert to a table.
3. Click Table ➤ Convert text to table.
4. In the Create columns based on the following separator area, choose one of the following options:
   • Commas — creates a column where a comma appears and a row where a paragraph marker appears
   • Tabs — creates a column where a tab appears and a row where a paragraph marker appears
   • Paragraphs — creates a column where a paragraph marker appears
   • User defined — creates a column where a specified marker appears and a row where a paragraph marker appears

   If you enable the User defined option, you must type a character in the User defined box.

   If you do not type a character in the User defined box, only one column is created, and each paragraph of text creates a table row.
   You can also convert a table to text. For more information, see “To convert a table to text” on page 760.

Select, move, and navigate table components
You must select a table, table rows, table columns, or table cells before you insert rows or columns, change the table border properties, add a background fill color, or edit other table properties. You can move selected rows and columns to a new location in a table. You can also copy or cut a row or column from one table and paste it in another table. In addition, you can move from one table cell to another when editing the table cell text, and you can set the direction in which the Tab key lets you move around a table.

To select a table, row, or column
1. Click the Table tool, and then click a table.
2. Perform one of the following tasks.

To
Select a table
Select a row
Select a column
Select all table contents
Use a keyboard shortcut to select a table
Do the following
Click Table ➤ Select ➤ Table.
Click in a row, and click Table ➤ Select ➤ Row.
Click in a column, and click Table ➤ Select ➤ Column.
Position the Table tool pointer over the upper-left corner of the table until a diagonal arrow appears , and click.
With the Table tool pointer inserted in an empty cell, press Ctrl + A + A.
To select a row interactively

To do the following

Position the Table tool pointer over the table border to the left of the row that you want to select. When a horizontal arrow appears ➔, click the border to select the row.

To select a column interactively

To do the following

Position the Table tool pointer over the top border of the column that you want to select. When a vertical arrow appears ↓, click the border to select the column.

To select table cells

To do the following

Select a table cell

Click the Table tool, click a table, and click a cell. Then, click Table ➤ Select ➤ Cell.

Select adjacent table cells

Using the Table tool, click inside the first cell that you want to select, and drag over the adjacent cells that you want to select.

Select nonadjacent table cells

Using the Table tool, click a table. Then, hold down Ctrl, and click each table cell that you want to select.

💡 You can also select a cell by inserting the Table tool pointer in an empty cell and pressing Ctrl + A.

💡 You can also use the Shape tool to select a single cell by clicking it, or to select adjacent cells by dragging over them.

To move a table row or column

1 Select the row or column that you want to move.
2 Drag the row or column to another location in the table.

To move a table row to another table

1 Select the table row that you want to move.
2 Click Edit ➤ Cut.
3 Select a row in the other table.
4 Click Edit ➤ Paste.
5 Choose one of the following options:
   • Replace selected row
   • Insert above selected row
   • Insert below selected row

To move a table column to another table

1 Select the table column that you want to move.
2 Click Edit  ➤ Cut.
3 Select a column in the other table.
4 Click Edit  ➤ Paste.
5 Choose one of the following options:
   • Replace selected column
   • Insert left of the selected column
   • Insert right of the selected column

To move to the next table cell
• With the Table tool inserted in a cell, press Tab.

If you are pressing Tab in a table for the first time, you must choose a tab order option from the Tab order list box.

You can use the Tab key to move to the next cell only if the Move to the next cell option is enabled in the Tab key options dialog box.

To change the navigational direction of the Tab key
1 Click Tools  ➤ Options  ➤ Tools.
2 In left pane of the dialog box that appears, click Table.
3 Enable the Move to the next cell option.
4 From the Tab order list box, choose one of the following options:
   • Left to right, top to bottom
   • Right to left, top to bottom

You can program the Tab key to insert a tab character in the table text by enabling the Insert a tab character in the current cell option.

Insert and delete table rows and columns
You can insert and delete the rows and columns in a table.

To insert a table row
1 Select a row in the table.
2 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a row above the selected row</td>
<td>Click Table ➤ Insert ➤ Row above.</td>
</tr>
<tr>
<td>Insert a row below the selected row</td>
<td>Click Table ➤ Insert ➤ Row below.</td>
</tr>
<tr>
<td>Insert multiple rows above the selected row</td>
<td>Click Table ➤ Insert ➤ Insert rows, type a value in the Number of rows box, and enable the Above the selection option.</td>
</tr>
</tbody>
</table>
To insert multiple rows below the selected row

Do the following

Click `Table` ➤ `Insert` ➤ `Insert rows`, type a value in the `Number of rows` box, and enable the `Below the selection` option.

When you use either the **Row above** command or the **Row below** command from the `Table` ➤ `Insert` menu, the number of rows that are inserted depends on how many rows you have selected. For example, if you have selected two rows, then two rows are inserted in the table.

### To insert a table column

1. Select a column.
2. Perform a task from the following table.

#### To
#### Insert a column to the left of the selected column

Do the following

Click `Table` ➤ `Insert` ➤ `Column left`.

#### Insert a column to the right of the selected column

Click `Table` ➤ `Insert` ➤ `Column right`.

#### Insert multiple columns to the left of the selected column

Click `Table` ➤ `Insert` ➤ `Insert columns`, type a value in the `Number of columns` box, and enable the `Left of the selection` option.

#### Insert multiple columns to the right of the selected column

Click `Table` ➤ `Insert` ➤ `Insert columns`, type a value in the `Number of columns` box, and enable the `Right of the selection` option.

When you use the **Column left** command or the **Column right** command from the `Table` ➤ `Insert` menu, the number of columns that are inserted depends on how many columns you have selected. For example, if you have selected two columns, then two columns are inserted in the table.

### To delete a row or column from a table

1. Select the row or column that you want to delete.
2. Perform a task from the following table.

#### To
#### Delete a row

Do the following

Click `Table` ➤ `Delete` ➤ `Row`.

#### Delete a column

Click `Table` ➤ `Delete` ➤ `Column`.
If you select a row but choose the option to delete a column, or if you select a column but choose the option to delete a row, the whole table is deleted.

**Resize table cells, rows, and columns**

You can resize table cells, rows, and columns. In addition, if you previously changed the sizes of some rows or columns, you can redistribute all rows or all columns so that they are the same size.

If table rows are different sizes (left), you can distribute them so that they are the same size (right).

Table rows and columns of different sizes (left) are distributed evenly (right).

**To resize a table cell, row, or column**

1. Click the Table tool and then click the table.
2. Select the cell, row, or column that you want to resize.
3. On the property bar, type values in the Table cell width and height boxes.

**To distribute table rows and columns**

1. Select the table cells that you want to distribute.
2. Perform a task from the following table.
To

Make the height of all selected rows the same

Make the width of all selected columns the same

Do the following

Click Table ▶ Distribute ▶ Rows evenly.

Click Table ▶ Distribute ▶ Columns evenly.

Format tables and cells

You can change the look of a table by modifying both table and cell borders. For example, you can change the table border width or color.

You can modify both table and table cell borders.

Thin table and cell borders (left) are made thicker (right).

In addition, you can change the table cell margins and cell border spacing. The cell margins let you increase the space between the cell borders and the text in the cell. By default, table cell borders overlap to form a grid. However, you can increase the cell border spacing to move the borders away from each other. As a result, the cells do not form a grid, but appear as individual boxes (also known as “separated borders”).
You can modify an existing table (left) by applying separated borders (right).

Separated borders applied to a table.
To modify table borders and cell borders

1. Select the table or table area that you want to modify.
   A table area can include a cell, a group of cells, rows, columns, or the entire table.

2. Click the **Border selection** button on the property bar, and choose the borders that you want to modify.

3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify the border thickness</td>
<td>Choose a border width from the <strong>Outline width</strong> list box on the property bar.</td>
</tr>
<tr>
<td>Modify the border color</td>
<td>Click the <strong>Outline color</strong> picker on the property bar, and then click a color on the color palette.</td>
</tr>
<tr>
<td>Modify the border line style and outline width</td>
<td>In the <strong>Outline</strong> area of the <strong>Properties</strong> docker, choose a line style from the <strong>Line style</strong> picker, and type a value in the <strong>Outline width</strong> box.</td>
</tr>
<tr>
<td></td>
<td>If the <strong>Properties</strong> docker is not open, click <strong>Window ▶ Dockers ▶ Properties</strong>.</td>
</tr>
</tbody>
</table>

To modify cell margins in tables

1. Click the **Table** tool, and then click the table.

2. Select the cells that you want to modify.

3. Click **Margins** on the property bar.

4. Type a value in the **Top margin** box.
   By default, the value in the top margin box is applied to all margins, so that equal margins are created.
   If you want to apply different values for the margins, click the **Lock margins** button to unlock the margin boxes, and type values in the **Top margin**, **Bottom margin**, **Left margin**, and **Right margin** boxes.

5. Press **Enter**.
To modify cell border spacing in tables

1. Click the Table tool, and then click the table.
2. Click Options on the property bar.
3. Enable the Separated cell borders check box.
4. Type a value in the Horizontal cell spacing box.
   
   By default, the vertical cell spacing is equal to the horizontal cell spacing.
   If you do not want equal cell spacing, click the Lock cell spacing button to unlock the Vertical cell spacing box, and then type values in both the Horizontal cell spacing and Vertical cell spacing boxes.
5. Press Enter.

Text in tables

You can easily add text to table cells, and you can modify this text as you would any other paragraph text. For example, you can change the font, add bullets, or add indents to table text. You can change the text properties of a single table cell, or of multiple table cells simultaneously. In addition, you can add tab stops to table cells so that text is shifted away from the cell margins.

When you type text in a new table, you can choose to automatically adjust the size of table cells.

To type text in a table cell

1. Click the Table tool.
2. Click a cell.
3. Type text in the cell.

💡

You can select text in a cell by pressing Ctrl + A.

To change the properties of text in table cells

1. Using the Table tool, click a table.
2. Hold down Ctrl, and click the table cells that contain text to be formatted.
3. Click Text ➤ Text, and specify the settings you want in the Text docker.
For more information about formatting text, see “Format text” on page 623.

To change the text properties for an entire row, column, or table simultaneously, you must first select the table component or table. For more information, see “To select a table, row, or column” on page 751.

To insert a tab stop in a table cell
• With the Table tool pointer inserted in a cell, click Text ➤ Insert formatting code ➤ Tab.

Another way to insert a tab stop is by pressing the Tab key. To use this method, you must set the Tab key to insert tab stops. For information about changing the Tab key options, see “To change the navigational direction of the Tab key” on page 753.

To automatically resize table cells when you type
1. Click the Pick tool and then click the table.
2. Click Options on the property bar, and enable the Automatically resize cells while typing check box.

This option can be applied to new tables that do not yet have text or other content.
If a table already contains text, only cells to which new text is added will be resized.

Convert tables to text
If you no longer want table text to appear in a table, you can convert the table text to paragraph text. For more information about converting text to a table, see “To create a table from text” on page 751.

To convert a table to text
1. Click the Table tool, and then click the table.
2. Click Table ➤ Convert table to text.
3. In the Separate cell text with area, choose one of the following options:
   • Commas — replaces each column with a comma and replaces each row with a paragraph marker
   • Tabs — replaces each column with a tab and replaces each row with a paragraph marker
   • Paragraphs — replaces each column with a paragraph marker
   • User defined — replaces each column with a specified character and replaces each row with a paragraph marker

   If you enable the User defined option, you must type a character in the User defined box.
If you do not type a character in the **User defined** box, each of the table rows is converted into a paragraph, and the table columns are ignored.

### Merge and split tables and cells

You can change how a table is configured by merging adjacent cells, rows, and columns. If you merge table cells, the formatting of the upper-left cell is applied to all merged cells. Alternatively, you can unmerge cells that were previously merged.

![Merging table cells](image1)

*You can change the look of a table (left) by merging adjacent table cells (right).*

![Splitting table cells](image2)

*The two cells at the bottom of the table (left) have been merged into a single cell (right).*

You can also split table cells, rows, or columns. Splitting lets you create new cells, rows, or columns without changing the size of the table.
To merge table cells
1 Select the cells to be merged.
   The selected cells must be contiguous.
2 Click Table ➤ Merge cells.

To unmerge table cells
1 Select the cell that you want to unmerge.
2 Click Table ➤ Unmerge cells.

To split table cells, rows, or columns
1 Click the Table tool.
2 Select the cell, row, or column that you want to divide.
3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split a selection horizontally</td>
<td>Click Table ➤ Split into rows, and type a value in the Number of rows box.</td>
</tr>
<tr>
<td>Split a selection vertically</td>
<td>Click Table ➤ Split into columns, and type a value in the Number of columns box.</td>
</tr>
</tbody>
</table>

Manipulate tables as objects
You can manipulate tables as you would other objects.
The following table lists the various ways to manipulate a table as an object.

<table>
<thead>
<tr>
<th>You can</th>
<th>For more information see</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize and scale a table</td>
<td>“Transform objects” on page 308</td>
</tr>
</tbody>
</table>
You can

Rotate a table
Mirror a table
Lock a table
Convert a table to a bitmap
Break a table apart

For more information see

“Transform objects” on page 308
“Transform objects” on page 308
“Lock objects” on page 358
“Convert vector graphics to bitmaps” on page 767
“To convert objects to curve objects” on page 214

Tables cannot be brought into Focus mode. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

Add images, graphics, and backgrounds to tables

If you want to arrange bitmap images or vector graphics in a structured layout, you can add them to tables. You can also change the look of a table by adding a background color.

To insert an image or a graphic in a table cell
1 Copy an image or a graphic.
2 Click the Table tool, and select the cell where you want to insert the image or graphic.
3 Click Edit ➤ Paste.

You can also insert a graphic or an image by holding down the right mouse button over the image, dragging the image to a cell, releasing the right mouse button, and then clicking Place inside cell.

To add a background color to a table
1 Click the Table tool and then click the table.
2 Click the Background color picker, and then click a color on the color palette.

You can also modify the background color of specific cells, rows, or columns by selecting the cells, clicking the Background color picker on the property bar, and then clicking a color on the color palette.

Import tables

With CorelDRAW, you can create tables by importing content from Quattro Pro™ (.qpw) and Microsoft Excel (.xls) spreadsheets. You can also import tables created in a word-processing application, such as WordPerfect® or Microsoft Word.
To import a table from Quattro Pro or Excel

1. Click File ▸ Import.
2. Choose the drive and folder where the spreadsheet is stored.
3. Click the file to select it.
4. Click Import.
   The Import/Paste dialog box appears.
5. From the Import tables as list box, choose Tables.
6. Choose one of the following options:
   - Maintain fonts and formatting — imports all fonts and formatting that are applied to the text
   - Maintain formatting only — imports all formatting that is applied to the text
   - Discard fonts and formatting — ignores all fonts and formatting that are applied to the text

To import a table from a word-processing document

1. Click File ▸ Import.
2. Choose the drive and folder where the text file is stored.
3. Click the file.
4. Click Import.
5. From the Import tables as list box, choose Tables.
6. Choose one of the following options:
   - Maintain fonts and formatting — imports all fonts and formatting that are applied to the text
   - Maintain formatting only — imports all formatting that is applied to the text
   - Discard fonts and formatting — ignores all fonts and formatting that are applied to the text
Bitmaps

Work with bitmaps..............................................................................................................................................................................767
Bitmap color modes............................................................................................................................................................................ 797
Trace.................................................................................................................................................................................................... 803
RAW camera files................................................................................................................................................................................ 815
Work with bitmaps

You can convert a vector graphic to a bitmap. You can also import and crop bitmaps.

You can add perspective, shape bitmaps with envelopes, apply color masks, watermarks, and special effects, and change the color and tone of the images. For information about applying perspective to bitmaps, see “Apply perspective” on page 555. For information about shaping bitmaps with envelopes, see “Shape objects by using envelopes” on page 243. For information about applying effects to bitmaps, see “Bitmap effects” on page 485.

This section contains the following topics:

• “Convert vector graphics to bitmaps” (page 767)
• “Crop bitmaps” (page 769)
• “Bitmap dimensions and resolution” (page 769)
• “Straighten bitmaps” (page 773)
• “Remove artifacts and noise from JPEG images” (page 777)
• “Remove dust and scratch marks from bitmaps” (page 777)
• “Sharpen images” (page 777)
• “Change and mask colors in bitmaps” (page 779)
• “Image Adjustment Lab” (page 780)
• “Adjust color and tone” (page 785)
• “Tone Curve filter” (page 792)
• “Transform color and tone” (page 795)
• “Edit bitmaps with Corel PHOTO-PAINT” (page 796)

Convert vector graphics to bitmaps

Converting a vector graphic or object to a bitmap lets you apply special effects to the object with CorelDRAW. The process of converting a vector graphic to a bitmap is also known as “rasterizing.”

When you convert the vector graphic, you can select the color mode of the bitmap. A color mode determines the number and kind of colors that make up the bitmap, so the file size is also affected. For more information about color modes, see “Change the color mode of bitmaps” on page 797.

You can also specify settings for such controls as dithering, anti-aliasing, overprinting black, and background transparency.
When you export a file to a bitmap file format, such as TIFF, JPEG, CPT, or PSD, the same bitmap conversion options are available. For more information about exporting, see “Export files” on page 889.

To convert a vector graphic to a bitmap

1. Select an object.
2. Click Bitmaps ➤ Convert to bitmap.
3. Choose a resolution from the Resolution list box.
4. Choose a color mode from the Color mode list box.
5. Enable any of the following check boxes:
   - Dithered — simulates a greater number of colors than those available. This option is available for images that use 256 or fewer colors.
   - Always overprint black — overprints black when black is the top color. Enabling this option prevents gaps from appearing between black objects and underlying objects when you print bitmaps.
   - Anti-aliasing — smooths the edges of the bitmap
   - Transparent background — makes the background of the bitmap transparent

You can change the black threshold for the Always overprint black option. For information about setting the black threshold, see “To set the overprint black threshold” on page 860.

If you export a vector file to a bitmap format, such as GIF, you are prompted to set the bitmap conversion options described in the procedure above before you export the file.

Making the background of a bitmap transparent lets you see images or a background otherwise obscured by the bitmap background.

To convert a vector graphic to a bitmap when exporting

1. Click File ➤ Export.
2. Choose the folder where you want to save the file.
3. Choose a bitmap file format from the Save as type list box, and type a filename in the File name list box.
4. Set the options you want, and click Export.
5. In the Convert to bitmap dialog box, type values in one of the following pairs of boxes:
   - Width and Height — let you specify the image dimensions
   - Width % and Height % — let you resize the image to a percentage of its original size
6. To specify the resolution, type a value in the Resolution box.
7. Choose a color mode from the Color mode list box.
8. Enable any of the following check boxes:
   - Dithered — simulates a greater number of colors than those available. This option is available for images that use 256 or fewer colors.
   - Always overprint black — overprints black when black is the top color. Enabling this option when you print bitmaps prevents gaps from appearing between black objects and underlying objects.
9. Enable any of the following:
   - Anti-aliasing — smooths the edges of the bitmap
   - Maintain layers — preserves layers
   - Transparent background — makes the background of the bitmap transparent
You can change the black threshold for the Always overprint black option. For information about setting the black threshold, see “To set the overprint black threshold” on page 860.

Not all options in the Convert to bitmap dialog box are available for all bitmap file formats.

Making the background of a bitmap transparent lets you see images or a background otherwise obscured by the bitmap background.

Import bitmaps

You can import a bitmap into a drawing either directly or by linking it to an external file. When you link to an external file, edits to the original file are automatically updated in the imported file. After you import a bitmap, the status bar provides information about its color mode, size, and resolution. For more information about importing bitmaps, see “Import files” on page 885. For more information about managing externally linked bitmaps, see “Bookmarks and hyperlinks” on page 879.

You can also resample or crop a bitmap while importing. For more information, see “To resample a bitmap while importing” on page 887 and “To crop a bitmap while importing” on page 888.

Crop bitmaps

Cropping removes unwanted areas of a bitmap. To crop a bitmap into a rectangular shape, you can use the Crop tool. For more information, see “To crop an object or imported photo” on page 253. To crop a bitmap into an irregular shape, you can use the Shape tool and the Crop bitmap command.

To crop a bitmap

1. In the toolbox, click the Shape tool.
2. Select a bitmap.
3. Drag the corner nodes to reshape the bitmap.
   - If you want to add a node, double-click the node boundary (dotted line) by using the Shape tool where you want the node to appear.
4. Click Bitmaps > Crop bitmap.

You cannot crop a bitmap comprised of more than one object.

You can also quickly crop a bitmap into a rectangular shape by using the Crop tool. For information about the Crop tool, see “To crop an object or imported photo” on page 253.

You can also crop a selected bitmap after you drag the corner nodes by clicking the Pick tool, then clicking the Crop bitmap button on the property bar.

Bitmap dimensions and resolution

After you add a bitmap to a drawing, you can change its dimensions and resolution.
You can change the resolution and size of a bitmap at the same time. Left to right: downsampled image, original image, upsampled image.

**Bitmap dimensions**

You can change the physical dimensions of a bitmap by increasing or decreasing its height and width. When choosing a unit of measure, you may find the following tips helpful:

- If you plan to print the image, set the width and height in inches, centimeters, points, or picas at the dots-per-inch (dpi) setting specific to your printer.
- If you plan to use the image on the web, choose pixels.

**Bitmap resolution**

**Resolution** is the amount of detail that an image file contains, or that an input, output, or display device is capable of producing. Resolution is measured in dpi (dots per inch) or ppi (pixels per inch). Low resolutions can result in a grainy appearance; high resolutions can produce higher quality images but result in larger file sizes. The size and resolution of an image affect its print quality. Choose image dimensions and resolution that match your print intent. Whether you are planning to print your artwork to your desktop printer or use it on the web, keep the following considerations in mind to ensure that the finished image appears as intended.

- Typically, bitmaps created only for display on computer monitors are 96 or 72 dpi, and bitmaps created for the web are 72 dpi.
- Bitmaps created for printing on desktop printers are generally 150 dpi, while professionally printed bitmaps are usually 300 dpi, or higher.

The size of a bitmap onscreen depends on the pixel height and width of the bitmap, on the zoom level, and on your monitor settings. As a result, the size of the bitmap may appear different on your screen and in print.

**Resampling bitmaps**

Resampling is changing the amount of image detail as you change the resolution and pixel dimensions of a bitmap. You can downsample and upsample images.

Downsampling decreases the total number of pixels in an image. Best results are usually achieved when downsampling is done after color and tone corrections but before sharpening.
Upsampling adds more pixels to an image. CorelDRAW lets you enlarge images without losing quality and detail. You can choose from several upsampling modes to suit your needs. The Bicubic method adds new pixels between existing pixels and interpolates them based on the colors of neighboring pixels. This method produces smooth tonal gradations. The Nearest neighbor method replaces every pixel with the nearest pixel in the upsampled image, which results in multiple pixels of the same color. This method preserves sharp details, however, it can also produce jagged edges instead of smooth lines and curves. In addition, the application uses advanced machine learning techniques to upscale images by preserving clean edges, sharpness, and fine details. Based on the analysis of a large number of artistic images and photographs, the two artificial intelligence methods, Illustration and Photorealistic, use neural network algorithms to reduce noise and pixelation and maintain color. With its low-level blurring and sharpening techniques that create cartoon-like effects, the Illustration method is great for images such as logos, drawings, illustrations, and paintings created in graphic design software. The Photorealistic method works well for resizing photos.

Depending on your system hardware configuration, upsampling an image with the Illustration and Photorealistic methods can take from a couple of seconds to several minutes. When the estimated time to complete the operation exceeds 3 seconds, a progress bar appears to show the remaining time. The estimated time does not take into account any processes or applications that you may initiate after you start upsampling and that may affect performance. You can cancel the upsampling process at any time.

Upsampling increases the file size of an image; downsampling decreases it. Resampling with fixed resolution lets you maintain the resolution of the image by adding or subtracting pixels while varying the file size. Resampling with variable resolution keeps the image size in inches, millimeters, or centimeters unchanged while changing the pixel size, resulting in lower or higher resolution than that of the original image.
To change the dimensions of a bitmap

1. Select a bitmap.
2. Click Bitmaps ▶ Resample.
3. Choose a unit of measure from the list box next to the Width and Height boxes.
4. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Downsample a bitmap</strong></td>
<td>Decrease the dimensions of the image by entering values in the Width and Height boxes or choosing a scale factor smaller than 100%. In the Mode area, choose a downsampling method to determine how pixels are removed.</td>
</tr>
<tr>
<td>• Bicubic — uses bicubic interpolation that produces smooth tonal gradations</td>
<td></td>
</tr>
<tr>
<td>• Nearest neighbor — preserves sharp details but may produce jagged edges instead of smooth lines and curves</td>
<td></td>
</tr>
<tr>
<td><strong>Upsample a bitmap</strong></td>
<td>Increase the dimensions of the image by entering values in the Width and Height boxes or choosing a scale factor greater than 100%. In the Mode area, choose an upsampling method to determine how pixels are added.</td>
</tr>
<tr>
<td>• Bicubic — uses bicubic interpolation that produces smooth tonal gradations. The new pixels, which are added between existing pixels, are interpolated based on the colors of neighboring pixels.</td>
<td></td>
</tr>
<tr>
<td>• Nearest neighbor — replaces every pixel with the nearest pixel in the upscaled image, which results in multiple pixels of the same color. This method preserves sharp details, however, it can also produce jagged edges instead of smooth lines and curves.</td>
<td></td>
</tr>
<tr>
<td>• Illustration — uses low-level blurring and sharpening techniques that create a more artistic effect. This method works well with images such as drawings, logos, and illustrations created in graphic design software.</td>
<td></td>
</tr>
<tr>
<td>• Photorealistic — maintains sharp edges, areas with continuous color, textures, and fine details. This method is great for resizing photos.</td>
<td></td>
</tr>
</tbody>
</table>

Set the noise reduction level by moving the Noise reduction slider.

**Note:** The Noise reduction option is available only for the Illustration and Photorealistic methods.

You can also

**Maintain the width to height ratio**

Enable the Maintain aspect ratio check box.

**Change the dimensions of a bitmap without changing the pixel count (no resampling)**

Enable the Maintain original file size check box.

As you change the width and height of the bitmap, the resolution
You can also

Change the dimensions of a bitmap without changing the pixel count (no resampling)

Notes:

• This option can be useful if you want to downsize an image to increase its resolution.
• When this check box is enabled, the pixels option in the Unit of measurement list box is grayed out because the total number of pixels in the image remains constant.

When you change the dimensions of a bitmap by specifying values on the property bar or by dragging the selection handles in the drawing window, CorelDRAW adjusts automatically the resolution without changing the amount of pixel data.

By default, the graphics processing unit (GPU) of your computer is used to upsample images. However, if your system’s GPU does not support CUDA or OpenCL (1.2 or higher) and is incompatible with CorelDRAW, you can set the application to use the central processing unit (CPU) instead by clicking Tools ⬤ Options ⬤ Global, clicking General, and disabling the Use GPU to accelerate upsampling option. For information about the CorelDRAW system requirements, see “System requirements” on page 23.

The Photorealistic and Illustration upsampling methods are supported only in the 64-bit version of CorelDRAW Graphics Suite.

To change the resolution of a bitmap

1 Select a bitmap.
2 Click Bitmaps ⬤ Resample.
3 In the Resolution area, type values in any of the following boxes:
   • Horizontal
   • Vertical

You can also

Maintain the width to height ratio of the bitmap

Enable the Maintain aspect ratio check box.

Maintain the file size

Enable the Maintain original file size check box.

As you change the resolution, the height and width of the bitmap are adjusted automatically, however, the total number of pixels in the file remain constant.

You can also resample a selected bitmap by clicking the Resample button on the property bar.

Straighten bitmaps

The Straighten Image dialog box lets you correct lens distortions and straighten bitmap images quickly. This feature is useful for straightening photos that were taken or scanned at an angle or contain lens distortions.
Correct camera lens distortions

With photos that contain camera lens distortions, it is recommended that you start with correcting the lens distortion. You can correct two types of lens distortions, which make straight lines in photos appear curved: barrel and pincushion. Barrel distortions make photos appear pushed out at the center. Pincushion distortions make photos appear pushed in at the center.

Rotate and preview

The Straighten image dialog box lets you rotate an image by moving a slider, typing a rotation angle, or using the arrow keys. You can specify a custom rotation angle from -15 to 15 degrees.

You can use the preview window to dynamically preview the adjustments that you are making. If you want to change the orientation of the image before straightening it, you can start by rotating the image 90 degrees clockwise and 90 degrees counterclockwise.

A grid is displayed in the preview window to help you straighten the image. You can make more precise adjustments by controlling the cell size of the grid. To heighten the contrast of the grid against the colors of the image, you can change the grid’s color. You can also hide the grid if you want to preview the final result without the gridlines. In addition, you can zoom in and out, and pan the image in the preview window to evaluate the results.

Crop

By default, the straightened image is cropped to the cropping area that is displayed in the preview window. The final image has the same aspect ratio as the original image, but it has smaller dimensions. However, you can preserve the original width and height of the image by cropping and resampling the image.

You can also produce an image at an angle by disabling cropping and then using the Crop tool to crop the image in the drawing window.

Restore default settings

By default, the last settings you used are preserved. However, you can choose to revert to the default settings each time you open an image in the Straighten Image dialog box.
To straighten an image

1. Select an image.
2. Click Bitmaps ➤ Straighten Image.
   If the image has a lens distortion, move the Correct lens distortion slider to the left to correct a barrel distortion or to the right to correct a pincushion distortion.
3. Move the Rotate image slider, or type a value between 15 and -15 in the Rotate image box.
4. If necessary, move the Grid slider to adjust the size of the grid cells.
5. To crop and straighten the image, enable the Crop image check box.
   The image is cropped to preserve the aspect ratio of the original image, which means that the final image is smaller than the original image.
   If you want to preserve the width and height of the original image, enable the Crop and resample to original size check box. The final image is resampled.

You can also

- Change the grid color
  Choose a color from the Grid color picker.

- Align an image area with a gridline
  Using the Pan tool ✏️ drag the image until the area is aligned with the gridline.
  You can use the Pan tool only after you zoom in on the image.

- Rotate the image 90 degrees in either direction
  Click the Rotate counterclockwise button or the Rotate clockwise button ⌁.

- Hide or display the grid
  Disable or enable the Grid check box.

- Adjust the rotation angle by 0.1-degree increments
  Click in the Rotate image box, and press the Up arrow or Down arrow key.

- Reset the image to its original orientation
  Click Reset.

- Zoom in or out
  Using the Zoom in ➤ or Zoom out ➤ tool, click in the preview window.

- Fit an image in the preview window
  Click the Zoom to fit button.

- Display an image at its actual size
  Click the 100% button.

- Restore the default settings each time you open an image
  Disable the Remember settings check box.
Correct perspective distortions

You can correct perspective distortions in photos that have straight lines and flat surfaces such as architectural photos and photos of buildings.

Perspective distortions usually occur when you take pictures of tall or wide objects, and the camera sensor is at an angle to the objects. As a result, the photographed objects may appear to be leaning or to be at an angle. Adjusting the vertical perspective helps straighten leaning objects; adjusting the horizontal perspective helps with angled objects. Often, you may need to adjust both the vertical and horizontal perspectives for best results.

![Correcting perspective distortions](image)

To correct perspective distortions in photos

1. Select an image.
2. Click Bitmaps ➤ Straighten image.
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Correct the vertical perspective</td>
<td>Move the <strong>Vertical perspective</strong> slider. If the photo object appears to be leaning backwards, move the slider to the left. Tall buildings in photos usually appear to be leaning back when the picture is taken from the ground.</td>
</tr>
<tr>
<td>Correct the horizontal perspective</td>
<td>Move the <strong>Horizontal perspective</strong> slider. If the photo was taken with the camera to the right of the object, move the slider to the left.</td>
</tr>
<tr>
<td>Crop and resample the corrected image to its original size</td>
<td>Enable the <strong>Crop image</strong> check box, and then enable the <strong>Crop and resample to original size</strong> check box.</td>
</tr>
</tbody>
</table>
Remove artifacts and noise from JPEG images

JPEG compression artifacts, which are caused by different processes involved in the capturing or saving of images, reduce image quality and degrade color. CorelDRAW uses advanced machine learning technology to help you reduce JPEG compression artifacts and restore detail in images.

To remove JPEG compression artifacts
1. Select a bitmap.
2. Click **Bitmaps** ➤ **Remove JPEG Artifacts**.

Remove dust and scratch marks from bitmaps

You can quickly improve the appearance of a bitmap by removing dust and scratch marks. The dust and scratch filter works by eliminating the contrast between pixels that exceed the contrast threshold you set. You can set a radius to determine how many pixels are affected by the changes. The settings you choose depend on the size of the blemish and the area surrounding it. For example, to remove a white scratch that is 1 or 2 pixels wide on a dark background, you can set a radius of 2 or 3 pixels and set the contrast threshold higher than you would for a similar scratch on a light background.

To remove dust and scratch marks from a bitmap
1. Click **Effects** ➤ **Correction** ➤ **Dust and scratch**.
2. Move the following sliders:
   - **Radius** — sets the range of pixels used to produce the effect. To retain image detail, choose a setting as low as possible.
   - **Threshold** — sets the amount of noise reduction. To retain image detail, choose a setting as high as possible.

Sharpen images

You can sharpen images to increase contrast, enhance image edges, or reduce shading. To sharpen an image, or an editable area of an image, you can use filters. Sharpening is usually done after adjusting the color and tone of an image and after resampling or resizing.
You can reveal more image detail by sharpening an image.

To sharpen an image by applying a filter
1. Click Effects ➤ Correction ➤ Tune Sharpen.
2. Move the Percentage slider to set the amount of sharpening that is applied each time you click a thumbnail button.
3. Click any of the following thumbnail buttons:
   - **Unsharp Mask** — lets you accentuate edge detail and focus blurred areas in the image without removing low-frequency areas.
   - **Adaptive Unsharp** — lets you accentuate edge detail by analyzing the values of neighboring pixels. This filter preserves most image detail, but its effect is most apparent in high-resolution images.
   - **Sharpen** — lets you accentuate the edges of the image by focusing blurred areas and increasing the contrast between neighboring pixels. Move the Background slider to set the threshold for the effect. Lower values increase the number of pixels changed by the sharpening effect.
   - **Directional Sharpen** — lets you enhance the edges of an image without creating a grainy effect.

You can also

**Remove shading**

Click Effects ➤ Sharpen ➤ High Pass. The High pass filter removes image detail and shading to give an image a glowing quality by emphasizing its highlights and luminous areas. However, it can also affect the color and tone of the image.

The **Unsharp Mask** filter provides best results for most photographs.

Most sharpen filters support all color modes except 48-bit RGB, 16-bit grayscale, paletted, and black-and-white. The **Sharpen** filter supports all color modes except paletted and black-and-white.

You can access each of the sharpen filters individually by clicking Effects ➤ Sharpen, and clicking a filter.

You can use this procedure to sharpen an editable area of an image.
Change and mask colors in bitmaps

CorelDRAW lets you change colors in monochrome images, apply PostScript halftone screens to optimize color and black-and-white bitmaps for printing, hide and show colors, and mask colors. Monochrome bitmaps have two colors: black and white. You can replace the black and white pixels with any color on a color palette.

If you plan to print to a PostScript printer, you can optimize color or black-and-white printing by applying a halftone screen to an image. Halftone screens break down an image into small dots or lines for clearer printing, continuous tones, and special effects. However, you can see the effect of the screen on the bitmap only after you print it on a PostScript printer. For information about making changes to halftone screens, see “To customize a halftone screen” on page 857.

You can hide and display selected colors by masking them. Hiding colors in a bitmap lets objects or backgrounds show through the image. Hiding a color can also alter the apparent shape of a bitmap. For example, if a bitmap shows a person on a black background, you can hide the background so that the bitmap appears to take on the shape of the person rather than a rectangular shape. Also, hiding colors in bitmaps can increase the speed at which objects are rendered on the screen. You can also display certain colors in a bitmap to change the appearance of the image or to see where a particular color has been applied. You can mask as many as 10 colors in a bitmap.

Color masking also lets you change selected colors without altering the other colors in an image. You can also save a bitmap color mask to a file and open the file for future use.

To color a monochrome bitmap
1. Select a bitmap by using the Pick tool.
2. Right-click a color on the color palette to change the color of the foreground (black) pixels.
3. Click a color on the color palette to change the color of the background (white) pixels.

To apply a screen to a bitmap
1. Select a bitmap by using the Pick tool.
2. In the toolbox, click the Interactive fill tool.
3. On the property bar, click the Uniform fill button, and then click the Edit fill button.
4. In the Edit fill dialog box, enable the Color palettes option.
5. Choose a spot color palette from the Palette list box.
6. Click PostScript options.
7. In the PostScript options dialog box, choose an option (other than Default) from the Type list to set the dot shape or line type.
8. Type a value in the Frequency box to set the number of dots or lines that appear in each inch of the screen.
9. Type a value in the Angle box to set the angle of the dots or lines that appear on the screen.

To hide or display a color in a bitmap
1. Select the bitmap by using the Pick tool.
2. Click Bitmaps ⟵ Bitmap Mask.
3. In the Bitmap Mask docker, click the Color selector button, and click a color in the bitmap.
4. Enable the check box next to the channel that you want to hide or display.
5. Move the Tolerance slider to set the color tolerance for the color.
6. Enable one of the following options:
   - Hide selected
   - Show selected
7 Click Apply.

Higher tolerance levels target a broader range of colors around the color you select. For example, if you select baby blue and increase the tolerance, CorelDRAW hides or displays such colors as pastel blue or electric blue.

To open a bitmap color mask
1 Click Bitmaps ➤ Bitmap Mask.
2 Click the Open mask button.
3 Choose the folder where the color mask file is stored.
4 Double-click the file.

Files containing bitmap color mask have the filename extension *.ini*.

To change a masked color
1 Click Bitmaps ➤ Bitmap Mask.
2 Choose a color from the list of masked colors.
3 Click the Edit color button.
4 Use the controls in the Select color dialog box to edit the color.

You can also change a masked color by clicking the Color selector button, selecting another color from the bitmap, and clicking Apply.

Image Adjustment Lab

The Image Adjustment Lab lets you correct the color and tone of most photos quickly and easily.
The Image Adjustment Lab consists of automatic and manual controls, which are organized in a logical order for image correction. By starting in the upper-right corner and working your way down, you can select only the controls you need to correct the problems specific to your image. It is best to crop or retouch any areas of the image before beginning the color and tone corrections.

When you work in the Image Adjustment Lab, you can take advantage of the following features:

- **Create snapshot** — You can capture the corrected version of an image in a “snapshot” at any time. Thumbnails of the snapshots appear in a window below the image. Snapshots make it easy to compare different corrected versions of the image so you can choose the best one.

- **Undo, Redo, and Reset** — Image correction can be a trial-and-error process, so the ability to undo and redo corrections is important. The Reset command lets you clear all corrections so that you can start again.

- **Remember settings** — Enabled by default, this check box lets you use the current settings on other images. Disable the check box if you want to restore the default settings each time you open an image in the Image Adjustment Lab.

**Using automatic controls**

You can begin by using the automatic correction controls:

- **Auto adjust** — automatically corrects the contrast and color in an image by detecting the lightest and darkest areas and adjusting the tonal range for each color channel. In some cases, this control may be all you need to improve an image. In other cases, you can undo the changes and proceed with more precise controls.
• **Select white point** tool — automatically adjusts the contrast in an image according to the white point that you set. For example, you can brighten an image that is too dark by using the **Select white point** tool.

• **Select black point** tool — automatically adjusts the contrast in an image according to the black point that you set. For example, you can darken an image that is too light by using the **Select black point** tool.

**Using color correction controls**

After using the automatic controls, you can correct color casts in your image. Color casts are typically caused by the lighting conditions when a photo is taken, and they can be influenced by the processor in your digital camera or scanner.

• **Temperature** slider — lets you correct color casts by “warming” or “cooling” the color in an image to compensate for the lighting conditions at the time the photo was taken. For example, to correct a yellow color cast caused by taking a photo indoors in dim incandescent lighting, you can move the slider toward the blue end to increase the temperature values (based on degrees Kelvin). Lower values correspond to low lighting conditions, such as candlelight or light from an incandescent light bulb; these conditions cause an orange cast. Higher values correspond to intense lighting conditions, such as sunlight; these conditions cause a blue cast.

• **Tint** slider — lets you correct color casts by adjusting the green or magenta in an image. You can add green by moving the slider to the right; you can add magenta by moving the slider to the left. Moving the **Tint** slider after using the **Temperature** slider lets you fine-tune an image.

• **Saturation** slider — lets you adjust the vividness of colors. For example, by moving the slider to the right, you can increase the vividness of a blue sky in an image. By moving the slider to the left, you can reduce the vividness of colors. You can create a black-and-white photo effect by moving the slider all the way to the left, so that all color in the image is removed.

![Correction of a color cast. The image on the right is the corrected version.](image)

**Adjusting brightness and contrast across an entire image**

You can brighten, darken, or improve the contrast in an entire image by using the following controls:

• **Brightness** slider — lets you brighten or darken an entire image. This control can correct exposure problems caused by too much light (overexposure) or too little light (underexposure) at the time the photo was taken. If you want to lighten or darken specific areas of an image, you can use the **Highlights**, **Shadows**, and **Midtones** sliders. Adjustment made by the **Brightness** slider is nonlinear, so the current white point and black point values are not affected.

• **Contrast** slider — increases or decreases the difference in tone between the dark and light areas of an image. Moving the slider to the right makes the light areas lighter and the dark areas darker. For example, if the image has a dull, gray tone, you can sharpen the detail by increasing the contrast.

![Adjusting the brightness and contrast of an image can reveal more image detail.](image)

**Adjusting highlights, shadows, and midtones**

You can brighten or darken specific areas of an image. In many cases, the position or strength of the lighting at the time a photo is taken causes some areas to appear too dark and other areas to appear too light.

• **Highlights** slider — lets you adjust brightness in the lightest areas of an image. For example, if you take a photo with a flash, and the flash washes out the foreground subjects, you can move the **Highlights** slider to the left to darken the washed-out areas of the image. You can use the **Highlights** slider in conjunction with the **Shadows** and **Midtones** sliders to balance the lighting.
• **Shadows** slider — lets you adjust the brightness in the darkest areas of an image. For example, a bright light behind a photo subject (backlighting) at the time a photo is taken can cause the subject to appear in shadow. You can correct the photo by moving the **Shadow** slider to the right to lighten the dark areas and reveal more detail. You can use the **Shadows** slider in conjunction with the **Highlights** and **Midtones** sliders to balance the lighting.

• **Midtones** slider — lets you adjust the brightness of the midrange tones in an image. After adjusting the highlights and shadows, you can use the **Midtones** slider to fine-tune the image.

![Image showing the effect of adjusting shadows and midtones](image)

**Using the histogram**

The histogram lets you view the tonal range of an image to evaluate and adjust the color and tone. For example, a histogram can help you detect hidden detail in a photo that is too dark because of underexposure (a photo taken with insufficient light).

The histogram plots the brightness values of the pixels in an image on a scale of 0 (dark) to 255 (light). The left part of the histogram represents the shadows, the middle part represents the midtones, and the right part represents the highlights. The height of the spikes indicates how many pixels are at each brightness level. For example, a higher number of pixels on the left side of the histogram indicates the presence of image detail in the dark areas of the image.

![Image showing underexposed photo and its histogram](image)

**Viewing images in the Image Adjustment Lab**

The tools in the Image Adjustment Lab let you view images in various ways, so that you can evaluate the color and tone adjustments you make. For example, you can rotate images, pan to a new area, zoom in or out, and choose how to display the corrected image in the preview window.

**Using other adjustment filters**

Although the Image Adjustment Lab lets you correct the color and tone of most images, a specialized adjustment filter is sometimes required. Using the powerful adjustment filters in the application, you can make precise adjustments to images. For example, you can adjust images by using a tone curve. For more information about adjustment filters, see “Adjust color and tone” on page 785.

**To correct color and tone in the Image Adjustment Lab**

1. Click **Effects** ➔ **Adjust** ➔ **Image Adjustment Lab**.
2. Click **Auto adjust**.
   - **Auto adjust** automatically adjusts color and contrast by setting the **white point** and **black point** for an image.
   
   If you want to control the white point and black point setting more precisely, click the **Select white point** tool, and click the lightest area of your image. Then click the **Select black point** tool, and click the darkest area of your image.
3. Perform one or more tasks from the following table.
<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Correct color in the image</td>
<td>Adjust the <strong>Temperature</strong> slider to warm or cool the colors, and then fine-tune the color correction by adjusting the <strong>Tint</strong> slider.</td>
</tr>
<tr>
<td>Make colors more vivid or less vivid</td>
<td>Move the <strong>Saturation</strong> slider to the right to increase the amount of color in the image; move the slider to the left to decrease the amount of color in the image.</td>
</tr>
<tr>
<td>Brighten or darken an image</td>
<td>Move the <strong>Brightness</strong> slider to the right to lighten the image; move the slider to the left to darken the image.</td>
</tr>
<tr>
<td>Improve image sharpness by adjusting tone</td>
<td>Move the <strong>Contrast</strong> slider to the right to make the light areas lighter and the dark areas darker.</td>
</tr>
<tr>
<td>Brighten or darken specific areas</td>
<td>Move the <strong>Highlights</strong> slider to brighten or darken the lightest areas of the image. Then, move the <strong>Shadows</strong> slider to lighten or darken the darkest areas of the image. Finally, move the <strong>Midtones</strong> slider to fine-tune the midrange tones in the image.</td>
</tr>
</tbody>
</table>

*The Image Adjustment Lab is not available for CMYK images. For CMYK images, you can access the **Auto adjust** filter and other adjustment filters from the **Effects** menu.*

*You can capture the current version of your image by clicking the **Create snapshot** button. Thumbnails of the snapshots appear in a window below your image. Each snapshot is numbered sequentially and can be deleted by clicking the **Close** button in the upper-right corner of the snapshot title bar.*

*You can undo or redo the last correction you made by clicking the **Undo** button or the **Redo** button. To undo all corrections, click the **Reset to original** button.*

**To view images in the Image Adjustment Lab**
1. Click **Effects** ➔ **Adjust** ➔ **Image Adjustment Lab**.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the image</td>
<td>Click the <strong>Rotate left</strong> button or the <strong>Rotate right</strong> button.</td>
</tr>
<tr>
<td>Pan to another area of an image</td>
<td>Using the <strong>Pan</strong> tool drag the image until the area you want to see is visible.</td>
</tr>
<tr>
<td>Zoom in and out</td>
<td>Using the <strong>Zoom in</strong> tool or the <strong>Zoom out</strong> tool, click in the preview window.</td>
</tr>
</tbody>
</table>
To

Fit an image in the preview window

Display an image at its actual size

View the corrected image in a single preview window

View the corrected image in one window and the original image in another window

View the image in one window with a divider between the original and corrected versions

Do the following

Click the Zoom to fit button.

Click the 100% button.

Click the Full preview button.

Click the Before and after full preview button.

Click the Before and after split preview button. Move your pointer over the dashed divider line, and drag to move the divider to another area of the image.

Adjust color and tone

CorelDRAW lets you adjust the color and tone of bitmaps. For example, you can replace colors and adjust the brightness, lightness, and intensity of colors.

By adjusting tone and color, you can restore detail lost in shadows or highlights, remove color casts, correct underexposure or overexposure, and generally improve the quality of the bitmaps. You can also correct color and tone quickly by using the Image Adjustment Lab. For more information, see “Image Adjustment Lab” on page 780.

You can adjust the color and tone of bitmaps automatically by using the Auto Adjust command or by using the following filters.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Levels</td>
<td>Lets you adjust the tone, color, and contrast of a bitmap while preserving shadow and highlight detail. An interactive histogram lets you shift or compress brightness values to printable limits. The histogram can also be adjusted by sampling values from the bitmap.</td>
</tr>
<tr>
<td>Equalize</td>
<td>Lets you view the tonal range of an image and redistribute the balance of shadows, midtones, and highlights in the composite channel or in individual color channels according to a preset histogram model.</td>
</tr>
<tr>
<td>Sample &amp; Target</td>
<td>Lets you adjust color values in a bitmap with sample colors taken from the image. You can choose sample colors from the dark, midtone, and light ranges of an image and apply target colors to each of the sample colors. For example, you can increase the contrast in a bitmap by choosing the darkest and lightest tones and mapping them to black and white respectively. After you choose sample colors from the dark, midtone, and light ranges of the image and assign a target color to each sample color, the pixels with the same color as the sample colors adjust to display the corresponding target color.</td>
</tr>
<tr>
<td>Effect</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tone curve</td>
<td>Lets you perform color corrections precisely, by controlling individual pixel values. By changing pixel brightness values, you can make changes to shadows, midtones, and highlights. For more information, see “Tone Curve filter” on page 792.</td>
</tr>
<tr>
<td>Light</td>
<td>Lets you adjust the brightness of all colors and the difference between light and dark areas.</td>
</tr>
<tr>
<td>Color balance</td>
<td>Lets you add cyan or red, magenta or green, and yellow or blue to selected tones in a bitmap. For example, if you want to tone down the blue color in a photo, you can shift the color values from blue to yellow.</td>
</tr>
<tr>
<td>Gamma</td>
<td>Gamma is a method of tonal correction that takes the human eye's perception of neighboring pixels into account. For example, if you were to place a 10 percent gray circle on a black background and an identical gray circle on a white background, the circle surrounded by black appears lighter to the human eye than the circle surrounded by white even though the brightness values are identical. The Gamma effect lets you pick up detail in a low contrast image without significantly affecting the shadows or highlights. It affects the values in the image but it is curve-based so that the changes are weighted toward the midtones.</td>
</tr>
<tr>
<td>White Balance</td>
<td>Lets you achieve accurate colors in your photos by correcting color casts in your image. Color casts are typically caused by the lighting conditions when a photo is taken, and they can be influenced by the processor in your camera or scanner.</td>
</tr>
<tr>
<td>Hue/saturation/lightness</td>
<td>Lets you adjust the color channels in a bitmap and change the position of colors in the spectrum. This effect allows you to change colors and their richness, as well as the percentage of white in an image. Hue represents the dominant color (red, green, blue, yellow, and so on), saturation is the amount or richness of this color, and lightness represents the overall percentage of white in an image.</td>
</tr>
<tr>
<td>Black &amp; White</td>
<td>Lets you produce a black and white image without changing the color mode. It also allows you to adjust individual colors for conversion, which modifies the intensity of the gray tones in the image when it’s converted. In addition, you can tint the image by modifying the hue and saturation. For example, you can add a tint to an image to produce a Sepia effect.</td>
</tr>
<tr>
<td>Vibrance</td>
<td>Lets you increase the saturation in an RGB image without causing clipping or “blowing out” the image. Clipping occurs when an area of an image is too bright and the color details in the area are lost,</td>
</tr>
<tr>
<td>Effect</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Vibrance</td>
<td>which can occur when you increase the saturation in an image indiscriminately. The Vibrance filter adjusts saturation proportionally by increasing the saturation of the less-saturated colors more than that of the saturated colors. This filter is useful for adjusting the saturation of images that include a person in front of a detailed background. For example, it allows you to boost the saturation of the background details without adversely affecting the skin tone of the person in the image.</td>
</tr>
<tr>
<td>Selective color</td>
<td>Lets you change color by changing the percentage of spectrum CMYK process colors from the red, yellow, green, cyan, blue, and magenta color spectrum in a bitmap. This filter also lets you add process color to the grayscale tonal component of an image. Selective color modifications increase and decrease the percentage of cyan, magenta, yellow, and black pixels that make up each primary color in the color spectrum. For example, decreasing the percentage of magenta in the reds spectrum results in a color shift toward yellow. Conversely, increasing the percentage of magenta in the reds spectrum causes a color shift toward magenta and an overall increase in red. The extent of color modification depends on the adjustment percentage method you choose.</td>
</tr>
<tr>
<td>Replace colors</td>
<td>Lets you replace one or more colors in an image, selection, or object. When you select the color you want to replace, the application automatically selects a range of similar colors to be replaced. You can select the original and replacement colors from the image or from a color picker. To add or remove colors from the selection, you can adjust the hue and saturation range. You can also select and replace a single color. To prevent abrupt color changes, you can smooth the transition between selected and unselected pixels. You can also set the hue, saturation, and lightness for the new color.</td>
</tr>
<tr>
<td>Desaturate</td>
<td>Lets you reduce the saturation of each color in a bitmap to zero, remove the hue component, and convert each color to its grayscale equivalent. This creates a grayscale black-and-white photo effect without changing the color model.</td>
</tr>
<tr>
<td>Channel mixer</td>
<td>Lets you mix color channels to balance the colors of a bitmap. For example, if a bitmap has too much red, you can adjust the red channel in an RGB bitmap to improve image quality.</td>
</tr>
</tbody>
</table>

By default, the application shows a live preview of the image in the document window as you change the settings in the filter dialog box. However, if you zoom in on the image in the document window to get a closer look at a specific area, but you still want to be able to evaluate the changes in the entire image, you can preview the image in the dialog box. For more information about previewing images in the dialog boxes of bitmap effects, see “To apply a bitmap effect to an image area” on page 495.
To adjust color and tone automatically
1. Select a bitmap.
2. Click Effects \ Adjust \ Auto adjust.

To apply the Sample & Target effect
1. Select a bitmap.
2. Click Effects \ Adjust \ Sample & Target.
3. Choose a color channel from the Channel list box.
   - The color channels that appear in the Channel list box depend on the color mode of the bitmap. There is one composite channel and one channel for each color component. If you want to adjust all color channels, even when viewing only one channel, enable the Adjust all channels check box.
4. Enable the Shadows, Midtones, and Highlights check boxes.
5. Click the eyedropper tool in the Sample area, and click in the image to choose a dark area, midtone area, and light area, respectively.
6. Open the Target color picker for the shadows, midtones, or highlights, and choose a new color.

The shadows, midtones, and highlights in the image have been adjusted by mapping a sample color in the bitmap to a target color.

To apply the Light effect
1. Select a bitmap.
2. Click Effects \ Adjust \ Light (or press Ctrl + B).
3. Move the Brightness, Contrast, Intensity, Highlights, Shadows, or Midtones sliders to adjust each aspect of your image, respectively.

Adjusting the brightness, contrast, intensity, highlights, shadows, or midtones lets you improve the clarity and quality of the image.
Brightness shifts all pixel values up or down the tonal range, lightening or darkening all colors equally.
Contrast adjusts the difference between light and dark colors.
Intensity brightens the light areas of the drawing or darkens the dark areas.
Contrast and intensity usually go hand-in-hand because an increase in contrast sometimes washes out detail in shadows and highlights, and an increase in intensity can bring it back.
Highlights adjusts the brightness in the lightest areas.
Shadows adjusts the brightness in the darkest areas.
Midtones adjusts the brightness in the midrange tones.

To adjust the color balance
1. Select a bitmap.
2. Click Effects ➔ Adjust ➔ Color balance (or press Ctrl + Shift + B).
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color correct the shadow, midtone, and highlight areas</td>
<td>Enable the Shadows, Midtones, and Highlights check boxes, respectively.</td>
</tr>
<tr>
<td>Retain the image original brightness level</td>
<td>Enable the Preserve luminance check box.</td>
</tr>
<tr>
<td>Add cyan or red</td>
<td>Move the Cyan-Red slider to the left or right, respectively.</td>
</tr>
<tr>
<td>Add magenta or green</td>
<td>Move the Magenta-Green slider to the left or right, respectively.</td>
</tr>
<tr>
<td>Add yellow or blue</td>
<td>Move the Yellow-Blue slider to the left or right, respectively.</td>
</tr>
</tbody>
</table>

The Color balance effect has been used to shift the colors in the image from blue to yellow.

To apply the Gamma effect
1. Select a bitmap.
2. Click Effects ➔ Adjust ➔ Gamma.
3. Move the Gamma value slider.
Higher values brighten midtones; lower values darken them.

Adjusting the midtones lets you increase the detail in a low-contrast image without affecting the shadows or highlights.

To adjust hue, saturation, and lightness

1. Select a bitmap.
2. Click Effects  Adjust  Hue/Saturation/Lightness (or press Ctrl + Shift + U).
3. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the hue, saturation, and lightness for all channels</td>
<td>Enable the Master option in the Channels area.</td>
</tr>
<tr>
<td>Set the hue, saturation, and lightness of a channel</td>
<td>Enable the Red, Yellow, Green, Cyan, Blue, Magenta, or Grayscale option in the Channels area.</td>
</tr>
<tr>
<td>Set the dominant color in an image</td>
<td>Move the Hue slider to redistribute the colors in an image.</td>
</tr>
<tr>
<td>Set the strength of colors</td>
<td>Move the Saturation slider. A setting of -100 results in a grayscale image. A setting of 100 produces vibrant, unnatural colors.</td>
</tr>
<tr>
<td>Set the amount of white (positive values) or black (negative values)</td>
<td>Move the Lightness slider.</td>
</tr>
</tbody>
</table>

The Before and After color ribbons help you compare the original colors and the new colors.
To replace colors

1. Select a bitmap.
2. Click Effects ➤ Adjust ➤ Replace Colors.
3. In the Original area, click the eyedropper tool and sample a seed color from the image, or choose a color from the color picker.
   - The Range control shows the range of selected colors.
   - In the thumbnail preview, the selected colors appear covered by a lighter overlay.
4. In the New area, click the eyedropper tool and sample a color from the screen, or choose a color from the color picker.
5. To smooth the transition between selected and unselected pixels, move the Smooth slider.

You can also

Adjust the selected hue range

Point to one of the edges of the color band on the Hue range ring, and when the hand cursor appears, drag up and down. To shift the entire hue range of selected colors, click the handle of the color band on the Hue range ring, and drag around the ring.

Note: When the color band is small, only pixels that are very similar to the color you selected are selected and replaced; when the color band is bigger, more pixels are selected and replaced.

Adjust the saturation range of a hue’s shades to be included in the selection

Point to the inner or outer edge of the color band on the Saturation range circle, and drag when the pointer changes to a hand.
You can also

Replace a single color

Enable the **Single color** check box.

**Note:** This feature is useful for replacing the color in areas filled with a uniform color.

Set the hue, saturation, and lightness of the output color

Move the **Hue**, **Saturation**, and **Lightness** sliders, respectively.

![Image of blue flowers with purple flowers](image)

*The Replace colors effect has been applied to replace all instances of the color blue with purple.*

To preview the image in the dialog box, click the **Preview** button. For more information about previewing images while adjusting settings, see “To apply a bitmap effect to an object” on page 494.

Some versions of CorelDRAW let you use only an earlier version of this filter, which is known as **Replace Colors (Legacy)**.

The **Replace Colors (Legacy)** filter also lets you edit Replace Colors adjustments to images that are saved to the previous version of CorelDRAW.

**Tone Curve filter**

The **Tone curve** filter lets you perform color and tonal corrections by adjusting either individual color channels or the composite channel (all channels combined).
Individual pixel values are plotted along a tone curve that appears in a graph and represents the balance between shadows (bottom of graph), midtones (middle of graph), and highlights (top of graph).

The x-axis of the graph represents the tonal values of the original image; the y-axis of the graph represents the adjusted tonal values. Moving the curve up and to the left lightens the image and increases the color in any channel; moving the curve down and to the right darkens the image or decreases the color of a given channel. If you have an image with a blue cast, for example, you can decrease the blue in the image by selecting the Blue channel from the Channel list box and moving the curve down and to the right.

You can adjust the color and tone of an image by dragging the tone curve interactively in the preview window, adding one or more nodes to the tone curve, selecting areas in the image window, or applying a preset. You can adjust multiple points along a curve, so you can lighten the shadows and darken the highlights.

You can also save tone curve settings as presets to use with other images. Response curve files are saved with the extension .pst.
To apply the Tone curve effect
1 Select a bitmap.
2 Click Effects ▶ Adjust ▶ Tone curve.
3 Choose a color channel from the Channel list box.
4 Choose a curve style from the Style list box.
   • Curve — smooths the distribution of the values
   • Straight — retains straight line segments between nodes
   • Freehand — lets you draw a freehand curve
   • Gamma — lets you weigh corrections toward the midtones
5 Click and drag the curve in the preview window to adjust the bitmap interactively.

You can also

View the tone curves for all channels at once  Enable the Display all channels check box.
Adjust specific areas in an image  Click the Eyedropper tool, and click in the image. The pixels that you select appear as nodes on the tone curve.
Add a node to the tone curve  Click where you want to add a node along tone curve.
Smooth a freehand curve  Click the Smooth button.
   Click and hold the Smooth button down to continuously smooth the tonal curve.
Reset the tone curve for a selected channel  Click Reset Active Channel.
Reset the tone curve for all channels  Click Reset.
Apply a preset  Choose a preset from the Presets box.
Save tone curve settings as a preset  Click the Save button to the right of the Presets box and locate the folder where you want to save the preset.

To invert the selected tonal curve, click one of the Mirror Curve buttons.

The histogram lets you view the adjusted tonal range and evaluate the results. For more information about histograms, see “Using the histogram” on page 783.
Transform color and tone

You can transform the color and tone of an image to produce a special effect. For example, you can create an image that looks like a photographic negative or flatten the appearance of an image. To transform the color and tone of images, you can use the following effects:

• **Deinterlace** — lets you remove lines from scanned or interlaced images
• **Invert colors** — lets you reverse the colors of an image. Inverting an image creates the appearance of a photographic negative.

The Invert effect makes a negative of an image by converting all color values to their opposites: black becomes white, blue becomes yellow, and so on.

• **Posterize** — lets you reduce the number of tonal values in an image. Posterize removes gradations and creates larger areas of flat color.

The Posterize effect converts color ranges in an image to solid blocks of color.

To transform color and tone

1. Select a bitmap.
2. Click **Effects** ➤ **Transform**, and click any of the following:
   - **Deinterlace** — to remove lines from scanned or interlaced images. **Even lines** removes even lines. **Odd lines** removes odd lines. **Duplication** fills the gaps between the horizontal lines by duplicating the colors of the adjacent pixels. **Interpolation** fills the spaces with colors created by averaging the surrounding pixels.
   - **Invert Colors** — to invert the color values in an image
   - **Posterize** — to reduce the number of tonal values in an image. Move the **Level** slider to set the level at which posterization begins. A level of 2 results in drastic posterization; a level of 32 has no effect on most images.
Edit bitmaps with Corel PHOTO-PAINT

You can access Corel PHOTO-PAINT, a complete image-editing application, from within CorelDRAW. When you finish editing a bitmap, you can quickly resume your work with CorelDRAW.

To send a bitmap to Corel PHOTO-PAINT, you can click the Edit bitmap button on the property bar, or you can use the Edit bitmap command from the Bitmaps menu. You can also enable an option that lets you access Corel PHOTO-PAINT by double-clicking a bitmap.

You can copy selected objects from Corel PHOTO-PAINT and then paste them into your drawing. The selected objects are pasted as a group of bitmaps.

For more information about editing images with Corel PHOTO-PAINT, click Help  Product Help from the Corel PHOTO-PAINT menu bar.

To edit a bitmap with Corel PHOTO-PAINT

1. Using the Pick tool , select the bitmap that you want to edit.
2. On the property bar, click the Edit bitmap button to start Corel PHOTO-PAINT.
   The selected bitmap is displayed in the image window of Corel PHOTO-PAINT.
3. Edit the bitmap.
4. On the standard toolbar, click Finish editing to quit Corel PHOTO-PAINT.
   The edited bitmap appears on the drawing page of CorelDRAW.

   You can also use this procedure to edit groups of bitmaps. Corel PHOTO-PAINT opens the group of bitmaps as separate objects. If the bitmaps in the group have different color modes, you are prompted to change the color mode of all bitmaps in the group to the color mode of the bottom-most bitmap.

   You can also open Corel PHOTO-PAINT by clicking Bitmaps  Edit bitmaps.

To access Corel PHOTO-PAINT by double-clicking a bitmap

1. Click Tools  Options  CorelDRAW.
2. Click Edit.
3. On the Edit page, enable the Double-click to edit bitmaps in Corel PHOTO-PAINT check box.
   Enabling this check box lets you access Corel PHOTO-PAINT by double-clicking the bitmap in CorelDRAW.
Bitmap color modes

Changing an image to another color mode, such as RGB, CMYK, or Grayscale, changes a bitmap’s color structure.

This section contains the following topics:

- “Change the color mode of bitmaps” (page 797)
- “Change bitmaps to black-and-white” (page 798)
- “Change bitmaps to duotones” (page 799)
- “Change bitmaps to the paletted color mode” (page 800)

Change the color mode of bitmaps

The colors of the images that you work with in CorelDRAW are based on color modes. Color modes define the color characteristics of images and are described by their component colors. The CMYK color mode is composed of cyan, magenta, yellow, and black values; the RGB color mode is composed of red, green, and blue values.

Although you may not be able to see the difference between an image in the CMYK color mode and an image in the RGB color mode on screen, the images are quite different. For the same image dimensions, an RGB image has a smaller file size than a CMYK image, and the RGB color space, or gamut, can display more colors. Therefore, images intended for the web or desktop printers, which require accurate color fidelity, are generally in RGB mode. Where accurate print reproduction is needed, such as on a commercial printing press, images are generally created in CMYK mode. Paletted color images attempt to preserve color fidelity while reducing the file size, making them ideal for on-screen uses.

Each time you convert an image, you may lose color information. For this reason, you should save an edited image before you change it to a different color mode. For more information about color modes, see “Color models” on page 405.

CorelDRAW supports the following color modes:

- Black and White (1-bit)
- Duotone (8-bit)
- Grayscale (8-bit)
- Paletted (8-bit)
- RGB Color (24-bit)
- Lab Color (24-bit)
- CMYK Color (32-bit)
To change the color mode of a bitmap
1  Click a bitmap.
2  Click Bitmaps ▶ Mode, and click a color mode.

The current mode of the selected bitmap is not available in the menu.

Change bitmaps to black-and-white
You can change any image to a black-and-white image. In addition to conversion settings such as threshold, screen type, and intensity, there are seven conversion options that affect how the converted images will look.

Conversion

<table>
<thead>
<tr>
<th>Conversion</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line art</td>
<td>Produces a high-contrast, black-and-white image. Colors with a grayscale value lower than the threshold value that you set change to black, while colors with a grayscale value higher than the threshold value change to white.</td>
</tr>
<tr>
<td>Ordered</td>
<td>Organizes the gray levels into repeating geometric patterns of black and white pixels. Solid colors are emphasized and image edges are hard. This option is best suited for uniform colors.</td>
</tr>
<tr>
<td>Halftone</td>
<td>Creates different shades of gray by varying the pattern of black and white pixels in an image. You can choose the screen type, angle for the halftone, lines per unit, and the unit of measure.</td>
</tr>
<tr>
<td>Cardinality-Distribution</td>
<td>Creates a textured look by applying a calculation and distributing the result to the screen.</td>
</tr>
<tr>
<td>Jarvis</td>
<td>Applies the Jarvis algorithm to the screen. This form of error diffusion is suitable for photographic images.</td>
</tr>
<tr>
<td>Stucki</td>
<td>Applies the Stucki algorithm to the screen. This form of error diffusion is suitable for photographic images.</td>
</tr>
<tr>
<td>Floyd-Steinberg</td>
<td>Applies the Floyd-Steinberg algorithm to the screen. This form of error diffusion is suitable for photographic images.</td>
</tr>
</tbody>
</table>

To change a bitmap to a black-and-white image
1  Click a bitmap.
2  Click Bitmaps ▶ Mode ▶ Black-and-white (1-bit).
3  Choose an option from the Conversion method list box.
4  Move the Intensity slider.
The **Intensity** slider is not available for the **Halftone** conversion option.

### Change bitmaps to duotones

To convert an image to a duotone, you change a bitmap to the grayscale color mode and enhance it using one to four additional colors, giving the image greater tonal depth.

The following four variations of the color mode correspond to the number of additional inks:

- **Monotone** — a grayscale image colored with a single tone
- **Duotone** — a grayscale image colored with two tones. In most cases, one is black and the other is colored.
- **Tritone** — a grayscale image colored with three tones. In most cases, one is black and the other two are colored.
- **Quadtone** — a grayscale image colored with four tones. In most cases, one is black and the other three are colored.

![The four color mode variations. From left to right: the original image, monotone, duotone, tritone, and quadtone.](image)

### Adjusting tone curves

When you change an image to a duotone, a tone curve grid that represents the dynamic tone curves that are used throughout the conversion is displayed. The horizontal plane (x-axis) displays the 256 possible shades of gray in a grayscale image (0 is black; 255 is white). The vertical plane (y-axis) indicates the intensity of a color (from 0 to 100 percent) that is applied to the corresponding grayscale values. For example, a grayscale pixel with a color value of 25 is printed with a 25-percent tint of the color. By adjusting the tone curves, you can control the color and intensity of the tone that is added to an image.

### Saving and loading inks

You can save an adjusted duotone tone curve and ink settings and then load them for use with other bitmaps.

### Specifying how overprint colors display

When you change an image to a duotone, you can specify the colors to overprint when you print an image. Overprint colors are used to preserve color integrity when inks overlap. When you display the image, each color is applied on the screen in sequence, creating a layered effect.

You can view all instances in which the colors you choose for the duotone conversion overlap. Associated with each instance is the color that is produced by the overlap. You can also choose new overprint colors to see how they overlap.

Duotones hold their color ink information when you save to Encapsulated PostScript (EPS), Portable Document Format (PDF) and CorelDRAW (CDR) file formats. Other file formats don’t support duotone images.
To change an image to a duotone
1. Click a bitmap.
2. Click Bitmaps ➤ Mode ➤ Duotone (8-bit).
3. Click the Curves tab.
4. Choose a duotone type from the Type list box.
5. Click an ink color in the Type window, and click Edit.
6. In the Select color dialog box, choose a color, and click OK.
   If you want to adjust the color's tone curve, click the ink tone curve on the grid to add a node, and drag the node to adjust the percentage of color at that point on the curve.
7. Repeat steps 5 and 6 for each ink color you want to use.

You can also

Display all the ink tone curves on the grid.  
Enable the Show all check box.

Save the ink settings  
Click Save. Choose the disk and folder where you want to save the file, and type a filename in the File name box.

Specify how overprint colors display  
Click the Overprint tab, and enable the Use overprint check box. Double-click the color you want to edit, and choose a new color.

💡 You can load preset ink colors by clicking Load, locating the file in which the ink settings are stored, and double-clicking the filename.

💡 You can zoom in and out of the image by using the zoom tools above the preview window, and you can pan to another area of the image by using the Pan tool.

Change bitmaps to the paletted color mode

The paletted color mode, also called indexed color mode, is sometimes used for images on the web. When you convert an image to the paletted color mode, a fixed color value is assigned to each pixel. These values are stored in a compact color table, or palette, containing up to 256 colors. As a result, the paletted color mode image contains less data than a 24-bit color mode image, and it has a smaller file size.

Conversion to paletted color mode works best on images that have a limited range of colors.

Choosing, editing, and saving a color palette

When you change an image to the paletted color mode, you can use a predefined palette, or you can customize a color palette by replacing individual colors.

Saving conversion settings

After you choose a color palette and set the dithering and range sensitivity for changing an image to the paletted color mode, you can save the settings as a conversion preset that you can use with other images. You can add as many conversion presets as you want.

The color palette you use is called the processed color palette. It can be saved for use with other images.

For more information about the predefined color palettes available for the paletted color mode, see “Palette types” on page 801. For more information about creating and opening custom color palettes, see “Create and edit color palettes” on page 417.
Dithering

Changing images to the paletted color mode lets you use dithering to enhance color information. Dithering places pixels with specific colors or values relative to other pixels of a specific color. The relationship of one colored pixel to another creates the appearance of additional colors that do not exist in the color palette.

You can use two types of dithering: ordered dithering and error diffusion. Ordered dithering approximates color blends using fixed dot patterns; as a result, solid colors are emphasized and edges appear harder. Error diffusion scatters pixels irregularly, making edges and colors softer. Jarvis, Stucki, and Floyd-Steinberg are conversion options that provide error diffusion.

The Ordered dithering option applies more quickly than the error diffusion options (Jarvis, Stucki, and Floyd-Steinberg) but is less accurate.

Specifying a range-sensitivity color

You can change an image to the paletted color mode and specify a focus color and a range sensitivity for the focus color, so that the focus color and colors that fall within the range settings are included in the processed color palette. You can also specify how much emphasis to place on the range sensitivity. Because the palette has a maximum of 256 colors, emphasizing a focus color reduces the number of colors that fall outside the range sensitivity.

Palette types

The table below outlines available palette types.

<table>
<thead>
<tr>
<th>Palette type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Uniform Colors</td>
<td>Provides a range of 256 colors with equal parts of red, green, and blue</td>
</tr>
<tr>
<td>Standard VGA</td>
<td>Provides the Standard VGA 16-color palette</td>
</tr>
<tr>
<td>Adaptive</td>
<td>Provides colors original to the image and preserves the individual colors (the entire color spectrum) in the image</td>
</tr>
<tr>
<td>Optimized</td>
<td>Creates a color palette based on the highest percentage of colors in the image. You can also specify a range-sensitivity color for the color palette. This is the most common color palette for photographic images.</td>
</tr>
<tr>
<td>Grayscale</td>
<td>Provides 256 shades of gray, ranging from black to white</td>
</tr>
<tr>
<td>System</td>
<td>Provides the predefined palette of colors used by the operating system</td>
</tr>
<tr>
<td>Custom</td>
<td>Lets you add colors to create a customized color palette</td>
</tr>
</tbody>
</table>

To change an image to the paletted color mode

1. Click a bitmap.
2. Click Bitmaps ➤ Mode ➤ Paletted (8-bit).
3. Click the Options tab.
4. Choose a color palette type from the Palette list box.
5 Choose an option from the Dithering list box.

6 Move the Dither intensity slider.

If you want to save the conversion settings as a preset, click the Add preset button, and type a name in the Save preset box.

---

You can achieve better color fidelity by choosing the palette you want to use when you change an image to a paletted bitmap or when you export a GIF or PNG. For example, the standard color palette provides more colors than necessary for an image with a limited range of colors, but you can choose an optimized palette to ensure that color representation is accurate.

---

You can choose a custom color palette by clicking Open, locating the color palette file you want, and double-clicking the filename. You can load preset conversion settings by choosing a preset from the Preset list box.

---

To create a custom processed color palette

1 Click a bitmap.

2 Click Bitmaps ▸ Mode ▸ Paletted (8-bit).

3 Click the Processed palette tab.

4 Click a color, and click the Edit button.

5 In the Color table, specify the color you want, and click Edit color.

6 Edit the color, and click OK.

7 Click the Save palette as button to save the new palette.

8 Choose the folder where you want to store the color palette.

9 Type a name in the File name box, and click Save.

---

To change a bitmap by setting range sensitivity

1 Click a bitmap.

2 Click Bitmaps ▸ Mode ▸ Paletted (8-bit).

3 Click the Options tab.

4 Choose Optimized from the Palette list box.

5 Enable the Color range sensitivity to check box.

6 Click the Eyedropper tool, and click a color in the image.

7 Click the Range sensitivity tab.

8 Move the range sensitivity sliders.

If you want to preview the color palette, click the Processed palette tab.
CorelDRAW lets you trace bitmaps to convert them to fully editable and scalable vector graphics. You can trace artwork, photos, scanned sketches, or logos and then easily integrate them into your designs.

For information about the difference between vector graphics and bitmaps, see “Vector graphics and bitmaps” on page 61.

This section contains the following topics:
- “Trace bitmaps” (page 803)
- “PowerTRACE controls” (page 806)
- “Preview traced results” (page 808)
- “Fine-tune traced results” (page 808)
- “Adjust colors in traced results” (page 810)
- “Default tracing options” (page 813)
- “Tips for tracing bitmaps” (page 813)

Trace bitmaps
You can trace a bitmap in one step by using the Quick Trace command. Alternatively, you can choose a suitable tracing method and preset style and then use the PowerTRACE™ controls to preview and adjust the traced results. CorelDRAW offers two methods for tracing bitmaps: Centerline Trace and Outline Trace.

Choosing a tracing method
The Centerline Trace method uses unfilled closed and open curves (strokes) and is suitable for tracing technical illustrations, maps, line drawings, and signatures. This method is also referred to as “stroke tracing.”
The Centerline Trace method was used to convert the original bitmap (top) into a vector graphic (bottom).

The Outline Trace method uses curve objects with no outlines and is suitable for tracing clipart, logos, and photo images. The Outline Trace method is also referred to as “fill” or “contour tracing.”

Choosing a preset style

A preset style is a collection of settings that are appropriate for the specific type of bitmap you want to trace (for example, line art or a high-quality photo image). Each tracing method comes with specific preset styles.

The Centerline Trace method offers two preset styles: one for technical illustrations and another for line drawings.

The Outline Trace method offers the following preset styles that are suitable for line art, logos, clipart, and photo images.
Adjusting traced results

You can adjust the traced results by using the controls in the PowerTRACE dialog box. For more information, see “Fine-tune traced results” on page 808 and “Adjust colors in traced results” on page 810.

To trace a bitmap by using Quick Trace
1. Select a bitmap.
2. Click Bitmaps ➤ Quick Trace.

You can also trace a bitmap in one step by clicking the Trace Bitmap button on the property bar and clicking Quick Trace.

You can change the settings that are used by Quick Trace. For more information, see “Default tracing options” on page 813.

To trace a bitmap by using the Centerline Trace method
1. Select a bitmap.
2. Click Bitmaps ➤ Centerline Trace, and click one of the following:
   • Technical Illustration — to trace black-and-white illustrations with thin, faint lines
   • Line Drawing — to trace black-and-white sketches with thick, prominent lines

   If necessary, adjust the traced results by using the controls in the PowerTRACE dialog box.

You can also access PowerTRACE from the Trace Bitmap button on the property bar.

To trace a bitmap by using the Outline Trace method
1. Select a bitmap.
2 Click Bitmaps ➤ Outline Trace, and click one of the following:
- Line Art — lets you trace black-and-white sketches and illustrations
- Logo — lets you trace simple logos with little detail and few colors
- Detailed Logo — lets you trace logos that contain fine detail and many colors
- Clipart — lets you trace ready-to-use graphics that vary according to their amount of detail and number of colors
- Low Quality Image — lets you trace photos that lack fine detail (or that contain fine detail that you want to ignore)
- High Quality Image — lets you trace high-quality, highly detailed photos

If necessary, adjust the traced results by using the controls in the PowerTRACE dialog box.

**PowerTRACE controls**

The **PowerTRACE** dialog box contains controls that help you preview and edit traced results.

Circled numbers correspond to the numbers in the following table, which describes the main controls of PowerTRACE.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Preview window</td>
<td>Lets you preview the traced result and compare it to the source bitmap</td>
</tr>
<tr>
<td>Control</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| 2. **Preview list box**    | Lets you choose one of the following previewing options:  
  • *Before and after* — lets you display both the source bitmap and the traced result  
  • *Large preview* — lets you preview a traced result in a single-pane preview window  
  • *Wireframe overlay* — lets you display a wireframe (outline) view of the traced result on top of the source bitmap                                                                                                                                                                                                                                   |
| 3. **Overlay slider**      | Controls visibility of the source bitmap below the wireframe when the *Wireframe overlay* option is selected                                                                                                                                                                                                                                                                                         |
| 4. **Zooming and panning tools** | Let you zoom in and out of an image displayed in the preview window, pan an image displayed at a zoom level higher than 100%, and fit an image to the preview window.                                                                                                                                                                                                                             |
| 5. **Settings page**       | Contains controls for adjusting the traced results.  
  For more information about adjusting traced results, see “Fine-tune traced results” on page 808.                                                                                                                                                                                                                                                                                       |
| 6. **Colors page**         | Contains controls for modifying the colors of the traced results.  
  For more information, see “Adjust colors in traced results” on page 810.                                                                                                                                                                                                                                                                                                                     |
| 7. **Adjustments page**    | Lets you choose from a number of image optimization options that improve the quality of the source bitmap and enhance the trace results. For more information, see “Tips for tracing bitmaps” on page 813.                                                                                                                                                                                                                   |
| 8. **Trace type list box** | Lets you change the tracing method                                                                                                                                                                                                                                                                                                                                                                    |
| 9. **Image type list box** | Lets you choose a suitable preset style for the image to be traced. The available preset styles change, depending on the tracing method you choose.                                                                                                                                                                                                                                                      |
| 10. **Options button**     | Lets you access the PowerTRACE options page in the **Options** dialog box to set default tracing options. For more information, see “Default tracing options” on page 813.                                                                                                                                                                                                                     |
| 11. **Traced result details area** | Provides information about the progress of the trace operation, as well as details such as the number of objects, nodes, and colors in the traced result. The information updates dynamically as you adjust the settings in the PowerTRACE dialog box.                                                                                                                                                                           |
| 12. **Reset button**       | Lets you restore the first settings used to trace the source bitmap                                                                                                                                                                                                                                                                                                                               |
| 13. **Undo** and **Redo**  | buttons Let you undo and redo the last action you performed                                                                                                                                                                                                                                                                                                                                          |
## Summary

**Control**

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>14. Time estimate</td>
<td>Displays the estimated time to complete the trace operation</td>
</tr>
</tbody>
</table>

### Preview traced results

By default, PowerTRACE displays both the source bitmap and the traced result. You can also preview a traced result in a single-pane preview window, or you can display a wireframe (outline) view of the traced graphic on top of the source bitmap.

You can zoom in and out to get a better view of the graphic, and you can pan to view areas that fall outside the preview window.

#### To preview traced results

- In PowerTRACE, choose one of the following options from the Preview list box:
  - **Before and after** — displays both the source bitmap and the traced result
  - **Large preview** — displays a preview of the traced result in PowerTRACE
  - **Wireframe overlay** — displays a wireframe (outline) preview of the traced result on top of the original bitmap. To control the visibility of the original bitmap underneath the wireframe, move the Overlay slider.

You can also

- **Zoom in or out**
  
  Click the **Zoom in** or **Zoom out** tool, and click in the preview window.

- **Fit an image in the preview window**
  
  Click the **Zoom to fit** tool.

- **Pan a graphic**
  
  Click the **Pan** tool and drag the graphic.

### Fine-tune traced results

PowerTRACE lets you perform the following adjustments to fine-tune your trace results.

#### Adjusting detail and smoothing

You can adjust the amount of detail in the traced result and smooth curved lines. When you adjust detail, you change the number of objects in the traced result. If you used the Outline Trace method to trace the bitmap, adjusting the traced result also changes the number of colors. Smoothing changes the number of nodes in the traced result. You can also control the appearance of corners in the traced result by setting the threshold for corner smoothness.
Completing a trace

By default, the source bitmap is preserved after being traced, and objects in the traced result are automatically grouped. You can have the source bitmap automatically deleted after the trace is complete.

Removing and preserving the background

You can choose to remove or preserve the background in the traced result. With the Outline Trace method, you can also specify the background color to be removed. If the background color around the edges is removed but some background color still shows through some areas of the image, you can remove the background from the entire image.

Setting other Outline Trace options

By default, object areas that are hidden from view by overlapping objects are removed from the traced result. You can choose to keep the underlying object areas. This feature is useful for traced results that will be output to vinyl cutters and screen printers.

To reduce the number of objects in the traced result, you can combine adjacent objects of the same color. You can also group objects of the same color so that you can manipulate them more easily in CorelDRAW.

Undoing and redoing actions

You can adjust the settings in PowerTRACE and retrace a bitmap as many times as necessary until you are satisfied with the result. If you make a mistake, you can undo or redo an action, or you can revert to the first traced result.

To fine-tune traced results

1. Select a bitmap.
2. Do one of the following:
   - Click Bitmaps ➤ Centerline Trace, and click a command.
   - Click Bitmaps ➤ Outline Trace, and click a command.
3. Move any of the following sliders:
   - **Detail** — lets you control the amount of original detail that is preserved in the traced result. Higher values maintain more detail and result in a greater number of objects and colors; lower values discard some detail and result in fewer objects.
   - **Smoothing** — lets you smooth curved lines and control the number of nodes in the traced result. Higher values result in fewer nodes and produce curves that do not closely follow the lines in the source bitmap. Lower values result in more nodes and produce more accurate trace results.
   - **Corner smoothness** — This slider works in conjunction with the **Smoothing** slider and lets you control the appearance of corners. Lower values maintain the appearance of corners; higher values smooth corners.
You can also

Change the tracing method

Choose a method from the **Trace type** list box.

Change the preset style

Choose a preset style from the **Image type** list box.

Keep the source bitmap after a trace

Disable the **Delete original** check box.

Discard or preserve the background in the traced result

Enable or disable the **Remove background** check box.

Specify the background color you want to remove (Outline Trace)

Enable the **Specify** option, open the color picker, click the **Eyedropper** tool, and click a color in the preview window.

To specify an additional background color to remove, hold down **Shift**, and click a color in the preview window.

The last specified color is displayed next to the **Eyedropper** tool.

Remove a background color from the entire image (Outline Trace)

From the **Remove** list box, choose **Color from entire image**.

Keep object areas that are hidden by overlapping objects (Outline Trace)

In the **Objects** area, disable the **Remove overlap** check box.

Group objects by color (Outline Trace)

In the **Objects** area, enable the **Group by color** check box.

This check box is available only when the **Remove overlap** check box is enabled.

Merge adjacent objects that have the same color (Outline Trace)

In the **Objects** area, enable the **Merge adjacent** check box.

Undo or redo an action

Click the **Undo** or **Redo** button.

Revert to the first traced result

Click **Reset**.

You can also access PowerTRACE from the **Trace Bitmap** flyout button on the property bar.

### Adjust colors in traced results

When the source bitmap is traced, the application generates a color palette for the traced result. The color palette uses the color mode of the source bitmap (for example, RGB or CMYK). The number of colors on the color palette is determined by the number of colors in the source bitmap and the selected preset style.

You can change the color mode of the traced result, and you can reduce the number of colors in the traced result.
Sorting colors
To edit the color palette more easily, you can sort colors by similarity or frequency. Sorting by similarity arranges the colors based on their hue and lightness. Colors of similar hue and lightness appear close to each other on the color palette. Sorting by frequency arranges the colors based on how much they are used in the traced results. The colors that are used most appear at the top of the color palette.

Selecting colors
You can select a color by clicking it on the color palette of the traced result or by clicking the color in the preview window. You can also select multiple colors.

Editing, merging, and deleting colors
When editing a color, you can choose a color from a color model that is different from that of other colors on the palette. For example, if you are editing a color in an RGB traced result, you can change the color to a spot color, creating a mixed color palette. This feature is useful when you are preparing the traced result for commercial printing.

With the Outline Trace method, you can also merge and delete colors.

By default, when two or more colors are merged, their color values are averaged to produce a new color. The merged colors are replaced by the new color. However, you can change the default setting to replace the colors to be merged with the first color that you selected. For information on how to change the default setting, see “Default tracing options” on page 813.

When you delete a color from the color palette, the deleted color is replaced by the next color on the color palette.

Using and creating color palettes
If you want the traced result to contain only colors from a specific color palette, you can open that color palette in PowerTRACE. The colors of the traced result are replaced by their closest match on the color palette.

After you edit the color palette of the traced graphic, you can save it to create a custom color palette for later use.

To adjust the colors of a traced result
1 Select a bitmap.
2 Do one of the following:
   • Click Bitmaps ▶ Centerline Trace, and click a command.
   • Click Bitmaps ▶ Outline Trace, and click a command.
3 Click the Colors tab, and perform any of the following tasks.
To | Do the following
---|---
Change the color mode | Choose a color mode from the **Color Mode** list box.
Reduce the number of colors in a traced result (Outline Trace) | Type a value in the **Number of colors** box, and click outside the box.
Select a color | Do one of the following:
  • Click a color on the color palette. The selected color swatch button appears pressed.
  • Click the **Eyedropper** tool, and click a color in the preview window. A marquee appears around the selected color. To select an additional color, hold down **Shift**, and click a color in the preview window. To deselect a color, hold down **Ctrl**, and click a color.
Select a range of adjacent colors | Hold down **Shift**, and click the first and last color swatch in the range you are selecting on the color palette.
Select multiple nonadjacent colors | Hold down **Ctrl**, and click the nonadjacent color swatches on the color palette.
Edit a color | Select the color you want to edit, click **Edit**, and modify settings in the **Select color** dialog box.
Merge colors (Outline Trace) | Select the colors that you want to merge, and click **Merge**.
If you want to specify how to merge the colors, click **Options** to access the **Options** dialog box, and enable an option in the **Merge colors** area.
Delete a color from a traced result (Outline Trace) | Select a color, and click the **Delete color** button  
The deleted color is replaced by the next color on the color palette.
Use a custom color palette | Click the **Open color palette** button  , find the folder where the palette is stored, and click a filename.
Each color of the traced graphic is mapped to a similar color on the custom palette.
Create a custom color palette from the edited color palette of a traced result | Click the **Save color palette** button  , in the **Save palette as** dialog box, type a name in the **File name** box.

*The number of colors cannot be reduced, and colors cannot be merged, when you use the Centerline Trace method.*
To increase the number of colors in a traced result, you need to change the preset style or increase the amount of detail. For information about how to change the preset style and the amount of detail, see “To fine-tune traced results” on page 809.

Default tracing options

You can enable any of the following tracing options.

- **Quick Trace method** — You can change the default Quick Trace settings to any preset style, or to the most recently used settings.
- **Merge colors** — You can choose whether to merge colors in a traced result by averaging their values or by replacing the colors to be merged with the first color you select.

To set default tracing options

1. Click **Tools ▶ Options ▶ CorelDRAW**.
2. Click **PowerTRACE**.
3. Perform any of the following tasks.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a Quick Trace method</td>
<td>From the <strong>Quick Trace method</strong> list box, choose a preset style or the most recently used settings.</td>
</tr>
<tr>
<td>Choose how to merge colors in a traced result</td>
<td>In the <strong>Merge colors</strong> area, enable an option. The <strong>Average colors</strong> option replaces the colors to be merged with a color of their average value. The <strong>Replace with first selected color</strong> option replaces the colors to be merged with the first selected color.</td>
</tr>
</tbody>
</table>

You can also access the **PowerTRACE** page by clicking **Options** in PowerTRACE.

Tips for tracing bitmaps

The following tips can help you achieve high-quality trace results.

- Use high-quality source bitmaps.
- If your image has low resolution, try upsampling it. Click the **Adjustments** tab in the PowerTRACE dialog box, and choose an upsampling mode. Based on the analysis of a large number of artistic images and photographs, the two artificial intelligence methods, **Illustration** and **Photorealistic**, use neural network algorithms to reduce noise and pixelation and maintain color. With its low-level blurring and sharpening techniques that create cartoon-like effects, the **Illustration** method is great for images such as logos, drawings, illustrations, and paintings created in graphic design software. The **Photorealistic** method works well for resizing photos. For more information about resampling images, see “Bitmap dimensions and resolution” on page 769. Depending on your system hardware configuration, upsampling an image with the **Illustration** and **Photorealistic** methods can take from a couple of seconds to several minutes. CorelDRAW displays a progress control to indicate the estimated time to complete the trace operation. The estimated time does not take into account any processes or applications which you may initiate after you start tracing and which may affect performance.
- If dithering or JPEG compression was used in the source bitmap, the bitmap may contain additional noise. To remove artifacts and noise from a bitmap, click the **Adjustments** tab in the PowerTRACE dialog box, and enable the **Remove JPEG artifacts** check box.
- For best results when you use the Centerline Trace method, convert the bitmap to the black-and-white color mode before tracing. Note that in this case you cannot adjust detail.
- When tracing technical illustrations and sketches with faint lines, you can improve the results by applying the **Find edges** special effect to the source bitmap. To do this, click **Effects ▶ Contour ▶ Find Edges**.
- For outline tracing, reduce the color depth of the bitmap by changing the color mode, and then adjust the color and contrast.
- You can adjust the traced results at any time, including during a trace, by changing the PowerTRACE settings.
• You can shape a bitmap before tracing it. Click the **Shape** tool in the toolbox, click the bitmap, drag any of the nodes until the bitmap is the shape you want, and then trace the bitmap.

• If important detail has been removed from the traced results, try choosing **None** from the **Remove** list box on the **Settings** page of PowerTRACE. You can also try choosing **Color from entire image** from the **Remove** list box, enabling the **Specify** option, and sampling the color you want to specify as a background color.

• If background color is removed around the edges but remains within image areas, from the **Remove** list box choose **Color from entire image**.

• If too many colors or details are lost, move the **Detail** slider on the **Settings** page.

• To preserve detail in bitmaps that have fine details, thin lines, and no anti-aliasing applied, choose **Line art** from the **Image type** list box on the **Settings** page.

• Try applying the AI-powered **Art Style** effects to a bitmap (**Effects** ➤ **Creative** ➤ **Art Style**) before vectorizing it with PowerTrace. For more information about these effects, see “Art Style” on page 523.
RAW camera files

You can import and process RAW camera files in CorelDRAW.

This section contains the following topics:

• “Use RAW camera files” (page 815)
• “Import RAW camera files in CorelDRAW” (page 816)
• “Adjust the color and tone of RAW camera files” (page 818)
• “Sharpen RAW camera files and reduce noise” (page 821)
• “Preview RAW camera files and obtain image information” (page 822)

You can also download AfterShot 3 HDR to edit and process RAW camera files. For more information, see “AfterShot 3 HDR” on page 124.

Use RAW camera files

RAW camera files contain picture data that is captured by the image censor of a digital camera. These files are called RAW because, unlike JPEG and TIFF files, they contain minimal in-camera processing and need to be edited and prepared for printing in an image-editing application.

With RAW camera files, you can control the processing of image data, rather than having the camera make automatic color adjustments and conversions. You can adjust the white balance, tonal range, contrast, color saturation, and sharpness of a RAW image without any loss of image quality. In addition, you can reprocess RAW images at any time to achieve the results you want. In this sense, RAW camera files can be compared to an exposed but undeveloped film.

To take advantage of RAW camera files, you need to set your camera to save files to its own RAW file format. CorelDRAW lets you import RAW camera files from supported camera models. Supported camera models include:

• Canon EOS-1D X, Canon EOS 650D, Canon 5D Mark III, Canon G1-X, Canon ID-X, Canon EOS 6D, Canon A3300, Canon EOS C500, Canon EOS SX50
• Casio EX-ZR100
• Fuji X-Pro1, Fuji X-S1, Fuji XS50, Fuji X20, Fuji X100S, Fuji SL1000, Fuji X-E1, and Fuji XF1
• Olympus XZ-10
• Pentax K-5 II (s)
• Samsung EX2F, Samsung NX300, Samsung NX1000, Samsung NX20
• Sigma SD1, Sigma SD15, Sigma DP cameras
• Sony RX100

In addition, the Adobe’s lossy Digital Negative (DNG) file format and the Imacon Flexframe 3f format are now supported.
For more information about supported cameras, visit the Corel Knowledge Base.

Import RAW camera files in CorelDRAW

When you open single or multiple RAW camera files in CorelDRAW, they are first displayed in the Camera RAW Lab. You can use the controls in the Camera RAW Lab to adjust the color and tone of the RAW camera images. If you are satisfied with the adjustments of a file, you can apply the same adjustments to the remaining files.

After processing RAW camera files, you can edit them further by using the tools and effects available in CorelDRAW. Then, you can save the RAW camera files as TIFF or JPEG files, or you can save them to any other file format supported by CorelDRAW.

Note that RAW camera files cannot be saved to a RAW camera file format in CorelDRAW. Any changes made to the RAW camera files in the Camera RAW Lab are lost unless you save the files to a supported file format.

Processing RAW camera files

The Camera RAW Lab includes controls that are organized in a logical order for color correction and other adjustments of RAW camera images. It is recommended that you start from the top of the Color page and work your way down. Once you finish correcting the color and tone of your image, you can sharpen it and remove noise by using the controls on the Detail page. For information about the settings on the Color page, see “Adjust the color and tone of RAW camera files” on page 818. For information about the settings on the Detail page, see “Sharpen RAW camera files and reduce noise” on page 821.
Camera RAW Lab: circled numbers correspond to the numbers in the following table, which describes the main components of the lab.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Rotation tools</td>
<td>Let you rotate the image 90 degrees clockwise and counterclockwise</td>
</tr>
<tr>
<td>2. Zooming and panning tools</td>
<td>Let you zoom in and out of an image displayed in the preview window, pan an image displayed at a zoom level higher than 100%, and fit an image to the preview window</td>
</tr>
</tbody>
</table>
### Component Description

3. **Preview modes and Preview window**
   - Let you preview the adjustments made to a RAW camera image in a single or split window. To compare the original and the adjusted image, you can display them side by side.

4. **Color page**
   - Contains controls that let you adjust the color and tone of RAW camera images to remove color casts and reveal hidden detail.

5. **Detail page**
   - Contains controls that let you remove noise from RAW camera images.

6. **Properties page**
   - Contains controls that let you view information about a RAW camera image, such as size, color mode, and camera settings.

7. **Undo and Redo buttons**
   - Let you undo and redo the last action you performed.

8. **Reset button**
   - Lets you clear all corrections so that you can start with the original RAW camera image.

9. **Create snapshot**
   - Lets you capture the corrected version of an image in a “snapshot” at any time. Thumbnails of the snapshots appear in a window below the image.

10. **Histogram**
    - Lets you preview the tonal range of the image.

### To import a RAW camera file

1. Click **File ▶ Import**.
2. Select the RAW camera file or files that you want to import, and click **Import**.
3. In the **Camera RAW Lab**, adjust the color and tone of the RAW camera image. If necessary, you can also sharpen the image and reduce the amount of noise.
   - If you selected multiple RAW camera files and want to apply the same adjustments to all of them, enable the **Apply to all remaining files** check box.

💡 You can rotate the image by clicking the **Rotate left** button ⬅️ or **Rotate right** button ⬅️.

### Adjust the color and tone of RAW camera files

You can adjust the color and tone of an image by using the following settings.

#### Color depth

Color depth refers to the number of colors an image can contain. One of the advantages of using RAW camera files is that they can contain more colors than photos saved as JPEG or TIFF files. This greater number of colors makes it easier to reproduce colors accurately, reveal detail in shadows, and adjust brightness levels.
The Camera RAW Lab lets you process the RAW camera files as 48-bit or 24-bit images. 48-bit images offer more accurate color representation and prevent loss of image quality during retouching. Note that some of the special effects available in CorelDRAW cannot be applied to 48-bit images.

White balance

White balance is the process of removing unnatural color casts from images so that image colors appear as they do in real life. White balance takes into consideration the lighting conditions in which a photo was taken and sets the color balance to produce realistic image colors.

By default, when a RAW camera file is brought into CorelDRAW, it reflects the camera setting for white balance. This setting appears as the preset As shot in the White balance list box. If you are not satisfied with this setting, you can have the white balance adjusted automatically by choosing the preset Auto. You can also apply any of the following presets: Daylight, Cloudy, Shade, Tungsten, Fluorescent, or Flash. These presets let you simulate different lighting conditions.

In addition, you can use the Eyedropper tool to automatically adjust the contrast in an image according to the white or gray point that you sample in the preview window.

If the White balance options do not produce the results you want, you can use the following controls to remove color casts:

- **Temperature** slider — lets you correct color casts by adjusting the color temperature of an image to compensate for the lighting conditions at the time the photo was taken. For example, to correct a yellow color cast caused by taking a photo indoors in dim incandescent lighting, you can move the slider to the left. Conversely, to correct a blue color cast caused by intense lighting conditions, you can move the slider to the right.

- **Tint** slider — lets you correct color casts by adjusting the green or magenta in an image. You can add green by moving the slider to the right; you can add magenta by moving the slider to the left. Moving the Tint slider after using the Temperature slider lets you fine-tune an image.

Tonal adjustments

You can use the following controls to adjust the tone of RAW camera files.

- **Saturation** slider — lets you adjust the vividness of colors. For example, by moving the slider to the right, you can increase the vividness of a blue sky in an image. By moving the slider to the left, you can reduce the vividness of colors.

- **Exposure** slider — lets you compensate for the lighting conditions at the time the photo was taken. Exposure is the amount of light allowed to fall on the image sensor of a digital camera. High exposure values result in areas that are completely white (no detail); low values result in increased shadows. Exposure values (EV) range from -3.0 to + 3.0.

- **Brightness** slider — lets you brighten or darken an entire image. If you want to darken only the darkest areas of an image, you must use the Shadow slider.

- **Shadow** slider — lets you adjust the brightness in the darkest areas of an image without affecting the lighter areas. For example, a bright light behind a photo subject (backlighting) at the time a photo is taken can cause the subject to appear in shadow. You can correct the photo by moving the Shadow slider to the right to lighten dark areas and reveal more detail.
Using the histogram

While you are making adjustments, you can view the tonal range of the image on the histogram to check for any clipping of shadow or highlight areas. Clipping is the shifting of image pixels to white (highlight clipping) or black (shadow clipping). Clipped highlight areas appear completely white and contain no detail; clipped shadow areas appear completely black and contain no detail.

The button on the left side of the histogram displays a warning if the image contains shadow clipping. The button on the right side of the histogram displays a warning if the image contains highlight clipping. You can also choose to apply shading to the clipped areas in the preview window.

To adjust the color and tone of a RAW camera file

1. Click File ➔ Import.
2. Select the RAW camera file or files that you want to import, and click Import.
3. To remove a color cast, select the Auto option from the White balance list box.
   - If you are not satisfied with the results, you can set the white point more precisely by using the Eyedropper tool 🔄 to sample a white or gray color in your image.
4. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulate different lighting conditions</td>
<td>Select an option from the White balance list box.</td>
</tr>
<tr>
<td>Correct color in the image</td>
<td>Adjust the Temperature slider, and then fine-tune the color correction by adjusting the Tint slider.</td>
</tr>
<tr>
<td>Make colors more vivid or less vivid</td>
<td>Move the Saturation slider to the right to increase the amount of color in the image or to the left to decrease the amount of color in the image.</td>
</tr>
<tr>
<td>Adjust exposure</td>
<td>Move the Exposure slider to the left to compensate for high-exposure camera settings or to the right to compensate for low-exposure camera settings.</td>
</tr>
<tr>
<td>Brighten or darken an image</td>
<td>Move the Brightness slider to the right to lighten the image or to the left to darken the image.</td>
</tr>
<tr>
<td>Adjust the brightness in the darker areas of an image without changing the lighter areas</td>
<td>Move the Shadow slider.</td>
</tr>
<tr>
<td>Show clipped shadow areas</td>
<td>Click the button to the left of the histogram.</td>
</tr>
<tr>
<td>Show clipped highlight areas</td>
<td>Click the button to the right of the histogram.</td>
</tr>
</tbody>
</table>
You can capture the current version of your image by clicking **Create snapshot**. Thumbnails of the snapshots appear in a window below your image. Each snapshot is numbered sequentially and can be deleted by clicking the close button in the upper right corner of the snapshot title bar.

To change a color or tone setting one increment at a time, you can click in the box to the right of a slider, and press the **Up** or **Down** arrow keys.

You can undo or redo the last correction you made by clicking **Undo** or **Redo**. To undo all corrections, click **Reset to original**.

**Sharpen RAW camera files and reduce noise**

You can sharpen RAW camera files to enhance image edges.

RAW camera files may contain luminous (grayscale) and color (chroma) noise that is especially obvious in the darker areas of an image. Luminous noise appears as a “white snow” effect; color noise appears as random pixels of different colors scattered against image areas. You can reduce noise in RAW camera files to improve image quality.

**Before (left) and after (right) the amount of noise is reduced in a RAW camera image**

To sharpen a RAW camera file

1. Click **File** ➔ **Import**.
2. Select the RAW camera file or files that you want to import, and click **Import**.
3. In the **Camera RAW Lab**, click the **Detail** tab.
4. Move the **Sharpness** slider to enhance the edges in an image.

To reduce noise in a RAW camera file

1. In the **Camera RAW Lab**, click the **Detail** tab.
2. Move any of the following sliders to the right:
   - **Luminance noise** — to reduce the amount of luminance noise
   - **Color noise** — to reduce the amount of color noise. Note that higher settings may decrease the color accuracy of an image.

Adjusting both the **Luminance noise** and **Color noise** settings produces better results.
Preview RAW camera files and obtain image information

By previewing RAW camera files in various ways, you can evaluate the color and tone adjustments you make. For example, you can rotate images, pan to a new area, zoom in or out, and choose how to display the processed image in the preview window.

You can obtain information about the color mode, size, and resolution of a RAW camera file. In addition, you can obtain information about the camera and camera settings used when the photo was taken.

To preview a RAW camera file

1. Click File ➤ Import.
2. Select the RAW camera file or files that you want to import, and click Import.
3. In the Camera RAW Lab, perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan to another area of an image</td>
<td>Using the Pan tool <img src="image" alt="Pan tool" /> drag the image until the area that you want to see is visible.</td>
</tr>
<tr>
<td>Zoom in and out</td>
<td>Using the Zoom in tool <img src="image" alt="Zoom in tool" /> or Zoom out tool <img src="image" alt="Zoom out tool" />, click in the preview window.</td>
</tr>
<tr>
<td>Fit an image in the preview window</td>
<td>Click the Zoom to fit <img src="image" alt="Zoom to fit button" /> button.</td>
</tr>
<tr>
<td>Display an image at its actual size</td>
<td>Click the 100% <img src="image" alt="100% button" /> button.</td>
</tr>
<tr>
<td>View the corrected image in a single preview window</td>
<td>Click the Full preview button <img src="image" alt="Full preview button" /></td>
</tr>
<tr>
<td>View the corrected image in one window and the original image in another window</td>
<td>Click the Before and after full preview button <img src="image" alt="Before and after full preview button" /></td>
</tr>
<tr>
<td>View the image in one window with a divider between the original and corrected versions</td>
<td>Click the Before and after split preview button <img src="image" alt="Before and after split preview button" /> Move your pointer over the dashed divider line, and drag to move the divider to another area of the image.</td>
</tr>
</tbody>
</table>

To obtain information about a RAW camera file

- In the Camera RAW Lab, click the Properties tab, and view any of the properties that are available for the selected RAW camera file, such as color space, camera manufacturer and model, focal length, exposure time, and ISO speed ratings.
Printing

Print basics.......................................................................................................................................................................................... 825
Print merge.......................................................................................................................................................................................... 835
Prepare files for print service providers................................................................................................................................................ 851
CorelDRAW provides extensive options for printing your work.

This section includes the following topics:
- “Print your work” (page 825)
- “Lay out print jobs” (page 826)
- “Preview print jobs” (page 827)
- “Print styles” (page 828)
- “Fine-tune print jobs” (page 829)
- “Print colors accurately” (page 830)
- “Print to a PostScript printer” (page 832)
- “Preflight summaries” (page 834)

Print your work

Using CorelDRAW, you can print one or more copies of the same drawing. You can also specify the page type and the page range that you want to print.

Before printing a drawing, you can specify printer properties, including paper size and device options. For example, you can specify printer features such as duplexing stapling.

To set printer properties

1. Click File ➤ Print.
2. Click the General tab.
3. In the Destination area, choose a printer from the Printer list box.
4. Click the Printer preferences button.
5. Set any properties in the dialog box.

To print your work

1. Click File ➤ Print.
2. Click the General tab.
3 In the **Destination** area, choose a printer from the **Printer** list box.

4 In the **Destination** area, choose a page size and orientation option from the **Orientation** list box.

5 In the **Copies** area, type a value in the **Number of copies** box.
   If you want the copies collated, enable the **Collate** check box.

6 In the **Print range** area, enable one of the following options:
   - **Current document** — prints the active drawing
   - **Current page** — prints the active page
   - **Pages** — prints the pages that you specify
   - **Documents** — prints the documents that you specify
   - **Selection** — prints the objects that you have selected
     If you enable the **Pages** option, you can choose to print a range of pages, only even pages, only odd pages, or both even and odd pages.

**You can also**

- Automatically match the printer orientation to the document orientation
  In the **Destination** area, choose **Match orientation** from the **Orientation** list box.

- Apply the printer’s default page size
  In the **Destination** area, choose **Use printer default** from the **Orientation** list box.

---

You must select objects before printing a selection.

Certain printers support the automatic matching of page size and orientation. To enable this option, you need to modify the driver compatibility settings for the printer by clicking **Tools**  ➤ **Options**  ➤ **Global** and clicking **Printing**. Next, click **Driver compatibility**, and enable the **Print to fit the paper size** check box. In the **Print** dialog box, you can then choose **Match orientation and size** from the **Orientation** list box.

**Lay out print jobs**

You can lay out a print job by specifying the size, position, and scale. Tiling a print job prints portions of each page on separate sheets of paper that you can assemble into one sheet. You would, for example, tile a print job that is larger than your printer paper.

**To specify the size and position of a print job**

1 Click **File**  ➤ **Print**.

2 Click the **Layout** tab.

3 In the **Image position and size** area, enable one of the following options:
   - **As in document** — maintains the image size as it is in the document
   - **Fit to page** — sizes and positions the print job to fit to a printed page
   - **Reposition artwork to** — lets you reposition the print job by choosing a position from the list box
Enabling the Reposition artwork option lets you specify size, position, and scale in the corresponding boxes.

You can also choose an imposition layout, such as 2 x 2 (4-up) or 2 x 3 (6-up), from the Imposition layout list box. For more information, see “Imposition layouts” on page 852.

To tile a print job
1 Click File ➤ Print.
2 Click the Layout tab.
3 Enable the Tiled pages check box.
4 Type values in the following boxes:
   • Tile overlap — lets you specify the amount by which to overlap tiles
   • % of page width — lets you specify the percentage of the page width the tiles will occupy

You can include tiling alignment marks by enabling the Include tiling marks check box.

Preview print jobs
You can preview your work to show how the position and size of the print job will appear on paper. For a detailed view, you can zoom in on an area. You can view how the individual color separations will appear when printed.

Before printing your work, you can view a summary of issues for a print job to find potential printing problems. For example, you can check the current print job for print errors, possible print problems, and suggestions for resolving issues.

To preview a print job
• Click File ➤ Print Preview.

To close the print preview, click File ➤ Close print preview.

You can quickly preview a print job in the Print dialog box by clicking File ➤ Print and clicking the Mini preview button.

To magnify the preview page
1 Click File ➤ Print Preview.
2 Click the Zoom tool in the toolbox and marquee selecting an area.

To preview color separations
1 Click File ➤ Print Preview.
2 On the property bar, click the Enable color separations button.
You can preview the composite by clicking View ➤ Preview separations ➤ Composite.

You can view individual color separations by clicking the tabs at the bottom of the application window.

To view a summary of issues for a print job
1. Click File ➤ Print.
2. Click the Preflight tab.
   - If there are no print job issues, the tab name displays as No issues. If there are issues, the tab name displays the number of issues that were found.
   - If you want to exclude certain issues from the preflight check, click the Settings button, double-click Printing, and disable any check boxes that correspond to issues you want overlooked.

You can save settings by clicking the Add preflight settings button and typing a name in the Save preflight style as box.

Print styles
A print style is a set of saved printing options. Each print style is a separate file. This lets you move a print style from one computer to another, back up a print style, and keep document-specific styles in the same directory as the document file.

You can select an existing print style, create a new print style, or edit a print style and save the changes. You can also delete print styles.

To choose a print style
1. Click File ➤ Print.
2. Click the General tab.
3. Choose one of the following from the Print style list box:
   - CorelDRAW defaults
   - Browse

To create a print style
1. Click File ➤ Print.
2. Click the General tab.
3. Set any printing options.
4. Click Save as.
5. Choose the folder where you want to save the print style.
6. Type a name for the style in the File name box.

You can also save a print style by clicking File ➤ Print preview, and clicking the Save print style as button.

To edit a print style
1. Click File ➤ Print Preview.
2. Choose a print style from the Print style list box.
3. Modify any of the printing options.
4. Click Save as.
5. Choose the folder where the print style is stored.
6. Click the filename.
7. Click Save.

You should save the modified settings as a print style or apply the changes before canceling; otherwise, you’ll lose all the modified settings.

To delete a print style
1. Click File ➤ Print Preview.
2. Select a print style.
3. Click the Delete print style button.

Fine-tune print jobs
You can fine-tune print jobs to ensure print quality. Because problems sometimes occur when you are printing text to a non-PostScript printing device (GDI printer), you can decrease printing time by specifying driver compatibility for non-PostScript printing devices. For more information, see “Print colors accurately” on page 830.

If a printing device has difficulty processing large bitmaps, you can divide a bitmap into smaller, more manageable chunks by setting an output threshold. If any lines appear when the printing device prints the chunks, you can set an overlap value to produce a seamless image.

On occasion, you may experience difficulties with printing complex files. To print complex files, you may need to spend a considerable amount of time fixing and correcting the files. Another option is to convert a page to a bitmap, also known as rasterizing, which can allow you to print complex files more easily.

To reduce file size, you can downsample bitmaps. Because bitmaps are made up of pixels, when you downsample a bitmap, the number of pixels per line decreases, which decreases the file size.

To specify driver compatibility settings
1. Click Tools ➤ Options ➤ Global.
2. Click Printing, and then click Driver compatibility.
3. Choose a non-PostScript printing device from the Printer list box.
4. Enable any of the check boxes that correspond to the settings that you want to specify.

To choose a threshold and chunk overlap
1. Click Tools ➤ Options ➤ Global.
2. Click Printing.
3. In the Special settings area, choose values from the following list boxes:
   - Bitmap output threshold (K)
   - Bitmap chunk overlap
To print as a bitmap
1. Click File ➤ Print.
2. On the General tab, enable the Print as bitmap check box, and type a number in the dpi box to set the resolution.

To downsample bitmaps
1. Click File ➤ Print.
2. Click the Prepress tab.
3. In the Bitmap downsampling area, enable any of the following check boxes and type a value in the corresponding box:
   • Color and grayscale
   • Monochrome

   Downsampling bitmaps affects them only when their resolution is higher than the resolution specified in the Bitmap downsampling area.

Print colors accurately
CorelDRAW allows you to manage colors when printing to ensure accurate color reproduction. You can print the document with the document colors settings applied or you can choose alternate color settings only for printing. You can also print a document using the color proofing settings that you previously specified in the Color Proofing docker.

In addition, you can choose a rendering intent to effectively interpret the out-of-gamut colors when printing. The rendering intent that you choose depends on the graphic content of the document.

For more information about color management, see “Manage colors for print” on page 481.

Notes for GDI printers
GDI printers support only two color spaces: RGB and Grayscale. If your document contains colors from multiple color spaces, for example RGB, CMYK, and spot colors, you must convert all the colors to RGB or Grayscale before printing.

You can determine if a printer is a GDI printer by clicking File ➤ Print and choosing a printer from the Printer list box. If the PostScript tab does not appear at the top of the dialog box, the selected printer is a GDI printer.

The following table describes different ways of managing color when printing to a GDI printer.

<table>
<thead>
<tr>
<th>How to</th>
<th>In the Print dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print the document and preserve the RGB or Grayscale colors</td>
<td>Click the Color tab, and choose the appropriate color mode from the Output colors list box.</td>
</tr>
<tr>
<td>Print the document with original colors</td>
<td>Click the Color tab, and choose the document color profile from the Document profile area of the Color profile list box.</td>
</tr>
<tr>
<td>Print the document and convert the document colors to the printer colors</td>
<td>Choose the printer color profile from the Color profile list box.</td>
</tr>
</tbody>
</table>
Notes for PostScript printers

Most PostScript printers support the use of multiple color spaces in a document. For example, a document can contain colors from multiple colors spaces, such as RGB, CMYK, and Grayscale.

The following table describes different ways of managing color when printing to a PostScript printer.

<table>
<thead>
<tr>
<th>How to</th>
<th>In the Print dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print the document with the original colors</td>
<td>Click the Color tab, and choose Native from the Output colors list box.</td>
</tr>
<tr>
<td>Print a document that contains multiple color modes using one color mode</td>
<td>Click the Color tab, and choose a color mode from the Output colors list box. If the printer supports only one color mode, you can control the color conversion within CorelDRAW.</td>
</tr>
<tr>
<td>Print a document that contains only one color mode</td>
<td>Click the Color tab, and choose the color profile from the Output color as list box and from the Color profile list box.</td>
</tr>
</tbody>
</table>

To specify color settings for printing

1. Click File ➤ Print.
2. Click the Color tab.
3. Enable the Document color option.
   If you selected a PostScript printer, you can choose one of the following options from the Color conversions list box:
   • CorelDRAW — lets the application perform the color conversion
   • (selected printer) — lets the selected printer perform the color conversion (This option is only available for PostScript printers.)
4. Choose a color model from the Output colors list box.
   This allows you to merge all document colors into a specific color model when printing.

You can also

- Convert spot colors to process colors
  Enable the Convert spot colors to check box.
  If you selected Native from the Output colors list box, you need to select a color mode from the list box.

- Choose a color profile for correcting colors when printing to a specific printer
  Choose a color profile from the Color profiles list box.
  This option is available only for certain color models.

- Retain the color values associated with the selected color model
  Enable the Preserve (color model) numbers check box.

To print using color proofing settings

1. Click File ➤ Print.
2. Click the Color tab.
3. Enable the Color proof option to apply the color settings that are defined in the Color Proofing docker.
If you want to correct the proof colors, you can choose a color profile from the Color profile list box.

4 Click Print.

To specify a rendering intent for printing

1 Click File ➤ Print.
2 Click the Color tab.
3 From the Rendering intent list box, choose one of the following options:
   • Relative colorimetric — for producing proofs on printers, without preserving the white point
   • Absolute colorimetric — for preserving the white point and proofing
   • Perceptual — for a variety of images, especially bitmaps and photographs
   • Saturation — for vector graphics and for preserving highly saturated colors (lines, text, and solid-colored objects, such as charts)

Print to a PostScript printer

PostScript is a page-description language that sends printing instructions to a PostScript device. All the elements in a print job (for example, curves and text) are represented by lines of PostScript code that the printing device uses to produce the document. For improved compatibility, you can choose a device-independent PostScript option. You can also select a PostScript Printer Description (PPD) file. A PostScript Printer Description file describes the capabilities and features of your PostScript printer and is available from your printer’s manufacturer.

You can automatically increase the fountain steps in a fountain fill to decrease banding. Increasing the number of steps used to render fountain fills produces smoother shading when printing. To ensure that your print jobs print properly, you can also reduce curve complexity by increasing flatness. Curve flatness determines how smooth a curve appears when printed.

A print job that contains too many fonts may not print properly, and a print job that contains too many spot colors increases file size. You can set the PostScript options to warn you when a print job contains more than a set number of fonts or spot colors.

By default, the printing device driver downloads Type 1 fonts to the printing device. You can disable the Download Type 1 Fonts option so that fonts are printed as graphics (either curves or bitmaps). This may be useful when the file contains many fonts that would take a long time to download or would fail to download because of their file size. Bitmap versions of TrueType fonts look better in small print and print faster than regular fonts. You can choose the maximum number of bitmap fonts that a print job can contain.

To select a PostScript Printer Description (PPD) file

1 Click File ➤ Print.
2 Click the General tab.
3 In the Destination area, choose a PostScript printer from the Printer list box.
4 Enable the Use PPD check box.
5 Choose the folder where the file is stored.
6 Double-click the filename.

To print to a PostScript device

1 Click File ➤ Print.
2 Click the General tab.
3 In the Destination area, choose a PostScript printer from the Printer list box.
4 Click the PostScript tab.
5 From the list box in the Compatibility area, choose the PostScript level that corresponds to the printer.

   If you want to compress bitmaps when printing, choose an option from the Compression type list box in the Bitmaps area. If you choose JPEG compression, you can move the JPEG quality slider to adjust the compression.
Bitmap compression settings can be saved in PostScript Interpreted (PS or PRN) files when you print to a file using a PostScript driver. For information about printing to a file, see “To print to a file” on page 851.

To test fountain fills for banding
1. Click File ➤ Print.
2. Click the Preflight tab.
   - If there are no print job issues, the tab name displays as No issues. If there are issues, the tab name displays the number of issues that were found.
3. Click Settings.
5. Enable the Banded fountain fills check box.
   - If you want to optimize fountain fills to reduce complexity, enable the Optimize fountain fills check box on the PostScript tab.

Testing fountain fills for banding applies only to linear fountain fills.

To automatically increase fountain steps
1. Click File ➤ Print.
2. Click the PostScript tab.
3. Enable the Auto increase fountain steps check box.

To reduce curve complexity
1. Click File ➤ Print.
2. Click the PostScript tab.
3. Enable the Auto increase flatness check box.

Reducing curve complexity can help alleviate printing problems caused by curves that have too many nodes on each curve, but it results in increased printing time.

To set color separations and font warning options
1. Click Tools ➤ Options ➤ Global.
2. In the left pane of the dialog box that appears, click Printing.
3. Click the Print Style tab.
4. From the Spot color separations warning list box, choose one of the following options:
   - If any spot colors are used
   - If more than 1 spot color used
   - If more than 2 spot colors used
   - If more than 3 spot colors used
5. From the Many fonts (Preflight) list box, choose a number.
To disable the downloading of Type 1 fonts

1. Click File ➤ Print.
2. Click the PostScript tab.
3. Disable the Download Type1 fonts check box.

Type 1 fonts can be downloaded only for PostScript devices.

When the Download Type1 fonts check box is enabled, the Convert TrueType to Type1 check box is enabled by default. This ensures that TrueType fonts are converted to Type 1 fonts so that they can be downloaded. Disable the Convert TrueType to Type1 check box only if the output device has difficulty interpreting Type 1 fonts.

Preflight summaries

Preflight checks the status of your file before you decide to output it and provides a summary of issues and potential problems, and suggestions for resolving them. You can specify which issues Preflight checks for. You can also save Preflight settings. For more information about specific Preflight settings, see any of the following:

• To check for issues related to printing a file, see “To view a summary of issues for a print job” on page 828.
• To check for issues related to publishing a PDF file, see “To view the preflight summary for a PDF file” on page 906.
• To check for issues related to exporting to Adobe Illustrator (AI), see “To view the preflight summary for an AI file” on page 913.
• To check for issues related to exporting a SWF file, see “To view the issues summary for an Adobe Flash file” on page 944.
• To check for issues related to exporting an SVG file, see “Scalable Vector Graphics (SVG)” on page 940.
Print merge

CorelDRAW lets you combine text from a data source with a drawing to create personalized documents, such as posters, calendars, business cards, certificates for events, postcards, invitations, or targeted marketing documents, where each printed document contains specific information from a record in a data source, such as a text file or an ODBC data source (a Microsoft® Access™ file).

The print merge workflow involves several steps. First, you create or import a data source file. A data source supplies information for a drawing during the merge. For more information, see “Prepare a data source file” on page 836. Next, you create a form document by inserting fields from the data source into a drawing. A form document provides the structure and layout for a merged document. For more information, see “Create a form document” on page 843. Finally, you merge the documents, producing multiple variations of your artwork. For more information, see “Merge data” on page 850.

This section includes the following topics:

- “Prepare a data source file” (page 836)
- “Create a form document” (page 843)
- “Merge data” (page 850)
Prepare a data source file

The first step in the print merge process is to prepare the data source file. Information in a data source file is organized into columns, fields, and records. A field refers to a single unit of data within a record, while a column refers to a set of related fields that share the same data type and format. A record can have one or more columns.

<table>
<thead>
<tr>
<th>First Name</th>
<th>Last Name</th>
<th>Photograph</th>
<th>Address</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>Smith</td>
<td>C:\Photos\JohnSmith.png</td>
<td>4512 Lorem Str.</td>
<td>XXX-XXX-XX</td>
</tr>
<tr>
<td>Julie</td>
<td>Johnson</td>
<td>C:\Photos\JulieJohnson.png</td>
<td>2812 Ipsum Str.</td>
<td>XXX-XXX-XX</td>
</tr>
</tbody>
</table>

In this example, every record includes a first name, last name, photograph, address, and phone number. Each item within a column, such as ‘4512 Lorem Str.’ and ‘2812 Ipsum Str.’, is recognized as a field.

You can create a data source or import an existing one. CorelDRAW supports the following data source files: Text (TXT) files, comma-separated values (CSV) files, Rich Text Format (RTF) files, Excel Workbook (XLSX) files, and files that can be opened by means of an ODBC data source.

Create data source files in CorelDRAW

Columns can contain several types of data, including text, numeric values, or file paths.

Text data consists of both alphabetic or numeric characters, such as names, addresses, phone numbers, or email addresses.

Numeric data includes any type of numerical values, such as integers or decimal numbers. You can choose formatting options for numeric fields and set them to increment automatically when values are added.

In path columns, you can specify file paths for image assets, such as logos, icons, or photographs. You can enter a path manually or browse for a file. If you enter paths manually, make sure you follow the file system location conventions and rules of your operating system. The application supports only valid file paths on local and network drives, and not URLs.
When you access the Configure Data Source dialog box or sync with the data source, the application validates the paths. An “X” before a filename indicates that a file path is invalid, or the file cannot be found in the specified location.

CorelDRAW lets you add, delete, and rename columns. When you add a column manually, there are no records by default. If you want to automatically populate a column with data, you can import the column from a data source file. For more information about importing columns, see “To import a column from a data source file” on page 842.

You can add and delete records, and edit fields in records. All records are selected by default; however, if you want to use only the data from specific records, you can quickly deselect all records, and then select only the ones you need. In addition, you can add a record to the list of selected records when browsing records in single-record view (View Single Record).

Depending on your preferences and requirements, you can view one record or multiple records at a time. If you need to scan through the entire dataset or compare information across different records, you can use the viewing mode that displays all records (View All Records). When you need to focus on a specific record in detail, the single record viewing mode (View Single Record) provides a clean and uncluttered interface, minimizing distractions from other records.

CorelDRAW offers several methods for navigating and locating records. To quickly find the information you need, you can scroll through records, browse through a list, or directly go to a specific record.

You can quickly remove all merge data if needed. This can be helpful when you want to reset the document to its original state and start from scratch. It offers convenience and efficiency by providing a quick and easy way to clear the merge data without manually deleting each individual record and column.

Create data source files in a text editor

You can create a data source in a text editor. Open a new file and indicate the number of columns you want to include on the first line. For example:
On the second line, specify the names of the columns by separating them with a backslash. Each column must begin and end with a backslash. To indicate that a column contains file paths, pre-pend the “at” (@) symbol before the column name. For example:

```
\Name\\Date\\Instructor\\@Photo\n```

On the next lines, enter the data that you want to appear in the merged document. Each line constitutes a record. For example:

```
Pixie Parsons\6 September 2023\Mr. Randy Harris\"C:\Users\admin\Documents\UserProfilePictures\RandyHarrisPicture.jpg"\n```

Once you add the information you need, save the file as an ANSI text file (.TXT extension) or as an RTF file. Below is an example of a TXT data source:

```
Pixie Parsons,6 September 2023,Mr. Randy Harris,"C:\Users\admin\Documents\UserProfilePictures\RandyHarrisPicture.jpg"
```

In comma-delimited (CSV) files, fields are separated by commas or tabs, records are separated by paragraph breaks. For example:

```
Name,Date,Instructor,@Photo
Pixie Parsons,6 September 2023,Mr. Randy Harris,"C:\Users\admin\Documents\UserProfilePictures\RandyHarrisPicture.jpg"
Shirley Wilkinson,13 January 2023,Ms. Corinne Pitts,"C:\Users\admin\Documents\UserProfilePictures\CorinnePittsPicture.jpg"
```

You can also create a data source in a spreadsheet application, such as Microsoft Excel. To indicate that a column contains file paths, pre-pend the “at” (@) symbol before the column name preceded by the single quote (or apostrophe) symbol “’” as an escape character. For example:

```
’@Photo
```

**Import and sync with data source files**

If you prefer to create and modify the data source in a text editor or spreadsheet application, you can import it into CorelDRAW and synchronize it as needed. The application maintains a link to the data source file and lets you update the data in your project with the latest changes from the source. If a data source file is missing, you have the option to link to a new location or use the embedded data instead. When you synchronize, any manual modifications to the data, including adding, deleting, or editing columns, are not retained. To keep the changes, you can either save the data to a new file or overwrite the linked data source file.

Apart from importing a data source file, you can selectively bring in data from specific columns. This allows you to choose and merge data from diverse sources, expanding your possibilities. When deciding between importing a data source or single columns, consider your specific needs. Importing the entire data source is an ideal choice when all the required information is contained within a single source. The ability to sync the data in your document with any subsequent changes made to the source is particularly beneficial if you anticipate future modifications to the data source, as it enables you to maintain up-to-date information in your project. By choosing to import individual columns, on the other hand, you attain the benefits of focused selection and increased versatility in merging data from various sources. It is important to note that while the syncing functionality is not available in this scenario, the ability to combine data elements according to your preferences and requirements adds valuable flexibility to your workflow. Moreover, you have the option to export the data to a new file and conveniently link to it if needed.
Export data source files

When you create a data source in CorelDRAW, you can save it to a new file which can be helpful for accessing and managing the data in a text editor or spreadsheet application. If you want to overwrite an existing file, make sure the file is not read-only. You can save all records or only selected records.

Save merge data in files

Whether you create a data file in CorelDRAW or import an existing data file into CorelDRAW, by default, the data is saved in your document and is retained until you perform the data merge. You can choose not to store the data with documents.

To create a data source file by using CorelDRAW

1. Click File > Print Merge > Create/load Print Merge.
2. In the Configure Data Source dialog box, click Add Column.
3. In the Add Column dialog box, type a column name in the Name box.
4. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To create</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A text column</td>
<td>Enable the Text option in the Type area.</td>
</tr>
<tr>
<td>A numeric column</td>
<td>Enable the Numeric option in the Type area. In the Numeric field options area, you can apply formatting to the data in a numeric field by choosing a format from the Format list box, and automatically increment the value in a numeric field by enabling the Continually increment value check box and specifying starting and ending values in the corresponding boxes. Note: Different numeric formats are available in CorelDRAW. For example, the X.0 format represents the value 1 as 1.0; the 00X format represents the value 1 as 001.</td>
</tr>
<tr>
<td>A column that contains paths</td>
<td>Enable the Path option in the Type area.</td>
</tr>
</tbody>
</table>

5. Click Add. Repeat steps 2 to 5 until you add the columns you want.
6. Click the Add a record button and enter data in the fields corresponding to that record. Repeat this step for each record.
7. Click Continue to go to the next step in the data merge process and create the form document. For more information, see “To create a form document” on page 848.

Note: Clicking Cancel closes the Configure Data Source dialog box without saving any changes. If you want to retain the data but postpone the creation of the form document and data merge, click Continue, and close the Configure Data Source dialog box.

You can also

- Rename a column
  - Click a field in the list, and click Configure Columns. In the Configure Columns dialog box, choose a column from the Select column list box, and click Edit Column. Enter a new column name in the Name box.
You can also

Delete a column
Click a field in the list, and click Configure Columns. In the Configure Columns dialog box, choose a column from the Select column list box, and click Delete Column.

Edit a field in a record
Click a field in a record to select it, and then click in the field again to edit the data.
Tip: To edit a file path, click inside a field that contains a path, and do one of the following:
  • Enter a new path or modify the existing path.
  • Click the Select file button. Navigate to the folder where you store the file you want, click a file, and click Open.

Delete a record
Click a record, and click the Delete a record button.

View records
Click one of the following:
  • View All Records — lets you display all records in a source data file
  • View Single Record — lets you display the selected record

Browse records
Click any of the following buttons:
  • First record
  • Next record
  • Previous record
  • Last record
Tip: You can also use the Up or Down arrow keys to navigate between records.

Go to a specific record
Type the record number in the Go to Record box, and click Go to Record.

Select or deselect a record
Do one of the following:
  • In multi-record view (View All Records), enable or disable the check box for a record.
  • In single-record view (View Single Record), click the Select record or Deselect record button, respectively.
Tip: To select or deselect all records in multi-record view (View All Records), click the Select all or Deselect all button, respectively.
You can also

Delete all print merge data in a document

Click the **Clear print merge data** button.

**Note**: Any print merge fields that may have been added in the form document are retained. If you no longer need them, you can delete them.

### To export a data source

1. Do one of the following.
   - Create a data source in CorelDRAW. For information, see “To create a data source file by using CorelDRAW” on page 839.
   - Open a CorelDRAW document with print merge data.

2. In the **Configure Data Source** dialog box (File ➔ Print Merge ➔ Edit Print Merge), perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save all records</td>
<td>Click <strong>Save Data Source</strong>.</td>
</tr>
<tr>
<td>Save selected records only</td>
<td>Ensure that only the check boxes corresponding to the records you want to include in the data source file are enabled. Click <strong>Save Data Source</strong>. In the <strong>Save As</strong> dialog box, enable the <strong>Selected records only</strong> check box.</td>
</tr>
</tbody>
</table>

3. Type a filename, choose the drive and folder where you want to save the file, choose a file format, and click **Save**.

### To create a data source by using a text editor

1. Open a text editor, and create a new file.

2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To create a data source in this format</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>TXT or RTF</td>
<td>On the first line, type the number of merge fields that you want to insert in the drawing. On the second line, type the names of the merge fields by separating them with a backslash. To indicate that a column contains file paths, pre-pend the “at” (@) symbol before the column name. Begin and end each merge field with a backslash. On the next lines, type the data that you want to appear in the merged document. Each line constitutes a record. Save the file as an ANSI text file (.txt extension) or as an RTF file.</td>
</tr>
</tbody>
</table>

**Notes**:
- Backslashes function as markers to indicate the beginning and end of merge fields; therefore, you cannot use them as data in fields.
- Data in fields must end with a character. Blank spaces or lines before backslashes prevent the merge from being completed successfully.
To create a data source in this format

CSV

On the first line, type the names of the merge fields by separating them with a comma or tab. To indicate that a column contains file paths, pre-pend the “at” (@) symbol before the column name. On the next lines, type the data that you want to appear in the merged document. Each line constitutes a record. Save the file as a comma-delimited (.CSV) file.

To import a data source file

1. Click File ➤ Print Merge ➤ Create/load Print Merge.
2. In the Configure Data Source dialog box, click the Import Data Source.
   If you are importing data from an Excel workbook with multiple sheets, choose a sheet.
3. In the Open dialog box, navigate to the drive and folder where the data file is stored.
5. Click Open.

To ensure the correct rendering of characters in print merge data when importing TXT or CSV files, it is recommended to include a BOM (Byte Order Mark).

Empty columns are ignored on import.

When you import a data source file that contains paths, the application validates the paths. If a file cannot be found in a specified location, an “X” appears before the filename.

To import a column from a data source file

1. Click File ➤ Print Merge ➤ Create/load Print Merge.
2. In the Configure Data Source dialog box, click Add Column.
3. In the Add Column dialog box, click the Import column button ↓
4. In the Open dialog box, navigate to the drive and folder where the data file is stored.
5. Choose a file.
6. Click Open.
7. Perform a task from the following table.

To import a column from

A data source in a TXT, RTF, or CSV format or an Excel workbook with one sheet

An Excel workbook with multiple sheets

In the Choose column dialog box, click a column name, and click Add.

In the Select Tab dialog box, click a worksheet in the list of available worksheet tabs, and then click a column in the list of available columns. Click OK.

8. In the Type area, enable one of the following options:
   • Text — to denote that the column contains text
   • Numeric — to denote that the column contains numeric data
   • Path — to denote that the column contains file paths
9. Click Add.

A check mark ✓ appears beside the button to indicate that the data from the column has been imported successfully and the tooltip shows the filename and location of the data source.
Columns must have unique names.

After importing the columns you need, you can save the data to a new file and link to it if needed. For information about saving data source files, see “To export a data source” on page 841.

To import an ODBC data source file

1. Click File ➤ Print Merge ➤ Create/load Print Merge.
2. In the Print Merge dialog box, click Open ODBC Data Source.
3. In the Select Data Source dialog box, do one of the following:
   - Click the File Data Source tab, and select the file data source that describes the drive that you wish to connect to. You can use any file data source that refers to an ODBC driver that is installed on your machine.
   - Click the Machine Data Source tab, under Data Source Name, select a data source type, and click OK.
4. Choose the database that you want to import, and click OK.
5. Choose a table, and click OK.

To sync linked data with the latest version of the data source

- Click the Sync with data source button.

The Sync with data source button appears grayed out when there is no data source linked to a drawing. After you import a data source, the tooltip of the Sync with data source button shows the location of the data source.

When changes are made to the data source, such as updating its contents or renaming or moving the file to a new location, the Sync with data source button indicates the availability of a more recent version or denotes that the application is unable to access the data source.

To save merge data in or remove merge data from a document

1. Click Tools ➤ Options ➤ CorelDRAW.
2. Click the Document button.
3. In the list of settings, click Save.
4. Enable or disable the Save print merge data in document option to retain print merge data or clear print merge data when saving a document, respectively.

If you choose not to save print data in a drawing, any data fields that you may have added in the form document are retained.

Create a form document

Once your data source is ready, you need to set up the form document. The form document serves as a template for the merged document, and it can include standard drawing elements as well as merge fields (also known as ‘data fields’.) During the merge process, the merge fields are populated with data from the source.

When inserting merge fields, you can choose from several available data types: text, image, and QR code.
Text fields

Text data fields can be inserted within artistic or paragraph text or as standalone objects.

A text object can contain one or more text merge fields. You can manipulate a print merge text object like any other text object. For more information about working with text, see “Add and manipulate text” on page 597.

Image fields

To add an image data field, you must select a placeholder graphic. It is a temporary image that will be replaced with actual images during the data merge. It also serves a design purpose by defining a space and location in the drawing where the actual images will be inserted at a later point. When you know the dimensions of the images for the data merge beforehand, you can choose a placeholder image that matches the dimensions of your artwork. If the images for the data merge have different dimensions than the placeholder image, you need to decide how to fit them into the bounding box. CorelDRAW offers several options to control the size of graphics in the merged document.

With the Actual size option, the image is not resized and is placed in its original location.

The Fit proportionally option resizes the image so that its longest dimension fits inside the bounding box. The image is not distorted, and its aspect ratio is preserved. The entire image is visible, but there may be empty areas in the bounding box.
The **Fill proportionally** option resizes the image so that it fills the bounding box without being distorted. The image aspect ratio is preserved. The bounding box is full, but there may be parts of the image that fall outside the bounding box and are not visible.

With the **Stretch to fill** option, the image is resized and distorted so that it fills the bounding box. The image aspect ratio is not preserved. The bounding box is full, and the whole image is visible.

You can manipulate a print merge image object like any other bitmap object; for example, you can crop it, add perspective to it, shape it with an envelope, place it into a PowerClip frame, apply color masks, special effects, and change its color and tone. For more information about using bitmaps in CorelDRAW, see "Work with bitmaps" on page 767. If you choose to insert an image at its actual size, any sizing and scaling adjustments made to the placeholder image will be ignored.
QR code fields

To insert a QR code field, you need to select a QR code type and choose any relevant options. Depending on the QR code type, some fields are mandatory. For example, if you intend to add an SMS QR code field, you need to provide a phone number as a requirement. CorelDRAW offers two options to control the size of QR codes in the merged document. With the Actual size option, the QR code is not resized and is placed at its original size.

The Fill proportionally option scales the QR code so that it fills the bounding box without being distorted. The image aspect ratio is preserved.

You can manipulate a print merge QR code object like any other QR code object. For example, you can use the Properties docker to customize the pixel fill, the background fill, the pixel outline, as well as the pixel shape and corner roundness. For more information about QR codes, see “QR codes” on page 367. Note that you cannot make sizing and scaling adjustments to a QR code object that is inserted at its actual size.

CorelDRAW lets you set the reference point to use when positioning or scaling images and QR code objects within the bounding box. The reference point, also known as 'anchor point' or 'object origin', can be the center of a print merge object or any of the selection handles on the object’s bounding box. When an object is scaled, it is scaled relative to its origin point.
Edit fields

You can change the column data associated with a merge field; however, it’s important to note that the field type cannot be changed. For example, if you select an existing SMS QR code field, you can change it to an Email address field or any other QR code type, but you cannot change the QR code field to an image field. Apart from updating the column data for an image field, you have the option to substitute the placeholder image and modify its position and scaling preferences. In the case of QR codes, you can also alter their type, position, and scaling choices.

Identify, find, and replace data fields

You can easily identify merge fields on the drawing page with the help of blue selection handles. Additional information about merge fields can be found on the Status bar and in the Summary section of the Properties docker. In complex files with numerous objects and data fields, the Find and Replace docker is highly effective for quickly locating merge fields. For more information about finding and replacing objects, see "Find and replace objects" on page 359.
To create a form document

1. Open a drawing.
2. Do one of the following:
   - To import or create a data source file, click File ➤ Print Merge ➤ Create/load Print Merge.
     For information on importing and creating data source files, see “Prepare a data source file” on page 836.
   - To modify existing print merge data, click File ➤ Print Merge ➤ Edit Print Merge.
3. After you finish configuring the data for the merge, click Continue.
4. In the Print Merge dialog box, perform a task from the following table.

To insert

<table>
<thead>
<tr>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>A text field</td>
</tr>
<tr>
<td>Enable the Text option. Choose a column name from the Data source columns list box. Click Insert Field.</td>
</tr>
<tr>
<td>CorelDRAW places the merge field in a default position. To reposition the merge field, drag it to a new location on the drawing page.</td>
</tr>
<tr>
<td>An image field</td>
</tr>
<tr>
<td>Enable the Image option. Choose a column name from the Data source columns list box. In the Placeholder image area, do one of the following:</td>
</tr>
<tr>
<td>- Click Browse. In the Open dialog box, choose the folder where the file is stored, click the file name, and click Open.</td>
</tr>
<tr>
<td>- Enter a valid path.</td>
</tr>
<tr>
<td>In the Align and scale area, choose a reference point to use when positioning or scaling the images within the bounding box. Choose one of the following scaling options to specify how to fit the images inside the placeholder container:</td>
</tr>
<tr>
<td>- Actual size — inserts images at their actual size</td>
</tr>
<tr>
<td>- Fill proportionally — resizes images so that they fill the bounding box without being distorted</td>
</tr>
<tr>
<td>- Fit proportionally — resizes images so that their longest dimension fits inside the bounding box</td>
</tr>
<tr>
<td>- Stretch to fill — resizes and distorts images so that they fill the bounding box</td>
</tr>
</tbody>
</table>
To insert

An image field

Do the following

Click Insert Field. Do one of the following:

• Click the drawing page to maintain the dimensions of the file and position its top-left corner where you click.
• Drag on the drawing page to position and resize the file. The import cursor displays the dimensions of the resized file as you drag on the drawing page.

Notes:

• Only bitmap images are supported.
• Resizing and scaling a placeholder image that is inserted at its actual size is not supported.

A QR code field

Enable the QR code option. In the Type area, select a QR code type, and specify the required or optional fields that are relevant for your project. In the Align and scale area, choose a reference point to use when positioning or scaling the QR codes within the bounding box. Choose one of the following scaling options to specify how to fit the QR codes inside the placeholder container:

• Actual size — inserts QR codes at their actual size
• Fit proportionally — resizes QR codes so that they fill the bounding box without being distorted

Click Insert Field. CorelDRAW places the merge field in a default position. To reposition the merge field, drag it to a new location on the drawing page.

5 Click a blank space in the document to deselect the print merge field you just inserted and repeat step 4 to insert additional fields.

To edit a merge field

1 On the drawing page, right-click a merge field, and click Update Field.
2 In the Print Merge dialog box, perform a task from the following table.

To edit

Do the following

A text field

Choose a column name from the Data source columns list box.

An image field

Modify any relevant settings, such as column name, placeholder image, alignment and scale options.

A QR code field

Modify any relevant settings, such as column name, QR code type, alignment and scale options.

3 Click Update Field.

To find and select merge fields

1 Click Edit ➤ Find and Replace.
2 In the Find and Replace docker, choose Find Objects from the list box at the top of the docker.
3 Enable the Properties option.
4 Click Add Query, and then in the Find Objects dialog box, enable the Print Merge Fields check box under Object Types.
5 Enable the Type check box in the right pane of the dialog box, and choose one of the following options:

• Text — to search for text fields
• Image — to search for image fields
• QR code — to search for QR code fields

6 Click OK.

7 In the Find and Replace docker, click any of the following buttons:
• Find Next > or Find Previous < — to scroll through objects that meet the search criteria
• Find All or Find All on Page — to select all objects on the active page that meet the search criteria
• Edit Query — to modify the search criteria

Merge data

CorelDRAW provides different output options for merge documents. You can print a merge document or save it to a new document. When you print a merge document, the form document is merged with the data source file during printing. When you save the merged document to a new file, the application merges the form document with the data from the data source file in a new CorelDRAW file. You can use this file to preview your final output and make minor adjustments before printing. For major changes, such as the addition or repositioning of merge fields or the addition of new records, you must work in the form document as the data source is not saved in the merged file.

To print a merge document

1 Do one of the following:
   • Click File ➤ Print Merge ➤ Print Merged Document.
   • In the Print Merge dialog box, click Print Merged Document.

2 Specify any printer settings.
   To preview your job before you print it, click Print Preview. For information about previewing print jobs, see “Preview print jobs” on page 827.

3 Click Print.
   If you want to print all records and pages, enable the Current document option.

To save a merge document to a new file

• Do one of the following:
   • Click File ➤ Print Merge ➤ Create Merged Document.
   • In the Print Merge dialog box, click Create Merged Document.

To print the merge document, click File ➤ Print.
Prepare files for print service providers

With CorelDRAW, you can prepare a print job for sending to a print service provider.

This section contains the following topics:
• “Prepare for a print service provider” (page 851)
• “Imposition layouts” (page 852)
• “Printers’ marks” (page 854)
• “Maintain OPI links” (page 856)
• “Color separations” (page 857)
• “Color trapping and overprinting” (page 858)
• “In-RIP trapping settings” (page 861)
• “Print to film” (page 863)
• “Prepare banners for printing” (page 864)
• “Work with a print service provider” (page 866)

Prepare for a print service provider

You can print a drawing to a file, which lets the print service provider send the file directly to an output device. If you are unsure about which settings to choose, consult the print service provider.

For more information about commercial printing, see “Work with a print service provider” on page 866.

To print to a file

1. Click File ➤ Print.
2. Click the General tab.
3. In the Destination area, enable the Print to file check box, and choose one of the following from the list box:
   • Single file — prints all pages in a document to a single file
   • Pages to separate files — prints each page to a separate file
   • Plates to separate files — prints each plate to a separate file
4. Click Print.
5. Choose one of the following from the Save as type list box:
   • Print file — saves the file as a PRN file

Prepare for a print service provider | 851
• **PostScript file** — saves the file as a PS file

6 Choose the folder where you want to save the file.

7 Type a filename in the **File name** box.

8 Click **Save**.

If you prefer not to prepare PostScript files, print service providers equipped with the application in which you created your work can take the original files (for example, CorelDRAW files) and apply the required prepress settings.

### Imposition layouts

Working with imposition layouts lets you print more than one page of a document on each sheet of paper. You can choose a preset imposition layout to create documents such as magazines and books to print on a commercial printing press; produce documents that involve cutting or folding, such as mailing labels, business cards, pamphlets, or greeting cards; or print multiple thumbnails of a document on one page. You can also edit a preset imposition layout to create your own layout.

You can select a binding method by choosing from three preset binding methods, or you can customize a binding method. When you choose a preset binding method, all but the first signature are automatically arranged.

You can arrange pages on a signature manually or automatically. When you arrange the pages automatically, you can choose the angle of the image. If you have more than one page across or down, you can specify the size of gutters between pages; for example, you can choose the automatic gutter spacing option, which sizes gutters so that the document’s pages fill the entire available space in the layout.

When printing on a desktop printer, you can adjust the margins to accommodate the non-printable area of a page. If the margin is smaller than the non-printable area, the edges of some pages or some printers’ marks may be clipped by your printer.

#### To choose a preset imposition layout

1 Click **File**  ➤ **Print**.
2 Click the **Layout** tab.
3 Choose an imposition layout from the **Imposition layout** list box.

The layout you choose does not affect the original document, only the way it is printed.

#### To edit an imposition layout

1 Click **File**  ➤ **Print**.
2 Click the **Layout** tab.
3 Choose an imposition layout from the **Imposition layout** list box.
4 Click **Edit**.
5 Edit any imposition layout settings.
6 Click **File**  ➤ **Save imposition layout**.
7 Type a name for the imposition layout in the **Save as** box.

When editing an imposition layout, you should save it with a new name; otherwise the settings for a preset imposition layout will be overwritten.
To select a binding method
1. Click File ➤ Print Preview.
2. Click the Imposition layout tool.
3. Choose Edit basic settings from the What to edit list box on the property bar.
4. Type values in the Pages across/down boxes.
   If you want the page to be double-sided, click the Single/double sided button.
5. Choose one of the following binding methods from the Binding mode list box:
   • Perfect binding — cuts apart individual pages and glues them at the spine
   • Saddle stitch — folds pages and inserts them into one another
   • Collate and cut — collates and stacks all signatures together
   • Custom binding — lets you arrange the pages that are printed in each signature
   If you choose either Saddle stitch or Custom binding, type a value in the corresponding box.

When you click the Single/double sided button for double-sided printing, and you are printing on a non-duplex printing device, a wizard automatically provides instructions on how to insert the paper into the printer, so that you can print on both sides of the page.

To arrange pages
1. Click File ➤ Print Preview.
2. Click the Imposition layout tool.
3. Choose Edit page placements from the What to edit list box on the property bar.
4. Click one of the following buttons:
   • Intelligent auto-ordering — automatically arranges the pages on a signature
   • Sequential auto-ordering — arranges the pages from left to right and top to bottom
   • Cloned auto-ordering — places the working page in each frame of the printable page
   If you want to arrange the page numbering manually, click on the page and specify the page number in the Page sequence number box.
5. Choose an angle from the Page rotation list box.

To edit gutters
1. Click File ➤ Print Preview.
2. Click the Imposition layout tool.
3. Choose Edit Gutters & Finishing from the What to edit list box on the property bar.
4. Click one of the following buttons:
   • Auto gutter spacing — sizes gutters so that the document’s pages fill the entire available space in the layout
   • Equal gutters — lets you set equal horizontal and vertical gutters
5. Click one of the following buttons:
   • Cut location — places cut marks between pages
   • Fold location — places fold marks between pages
If you click the Equal gutters button, you must specify a value in the Gutter Size box.

You can edit the gutters only if you’ve selected an imposition layout with two or more pages across and down.

To adjust margins
1 Click File ➤ Print Preview.
2 Click the Imposition layout tool.
3 Choose Edit margins from the What to edit list box on the property bar.
4 Click one of the following buttons:
   • Auto margins — sets the margins automatically
   • Equal margins — lets you make the right margin equal to the left one, and the bottom margin equal to the top one

If you click the Equal margins button, you must specify values in the Top/left margin boxes.

When preparing a job for a commercial press, the print service provider may request minimum margin sizes, such as for page grippers and printers’ marks.

Printers’ marks

Printing printers’ marks lets you display information on a page about how a document should be printed. You can specify the position of the printers’ marks on the page.

The available printers’ marks are as follows:

• Crop/fold marks — represent the size of the paper and print at the corners of the page. You can print crop/fold marks to use as guides to trim the paper. If you print multiple pages per sheet (for example, two rows by two columns), you can choose to print the crop/fold marks on the outside edge of the page so that all crop/fold marks are removed after the cropping process, or you can choose to add crop marks around each row and column. Crop/fold marks ensure that marks appear on each plate of a separated CMYK file.

• Bleed limit — determines how far an image can extend beyond the crop marks. When you use a bleed to extend the print job to the edge of the page, you must set a bleed limit. A bleed requires that the paper you are printing on is larger than the size of paper you ultimately want, and the print job must extend beyond the edge of the final paper size.

• Registration marks — are required to line up film for proofing or printing plates on a color press. They print on each sheet of a color separation.

• Color calibration bars — are color scales that print on each sheet of a color separation and ensure accurate color reproduction. To see calibration bars, make sure that the page size of the print job is larger than the page size of the work you are printing.

• Densitometer scales — is a series of gray boxes ranging from light to dark. These boxes are required to test the density of halftone images. You can position the densitometer scale anywhere on the page. You can also customize the levels of gray that appear in each of the seven squares on the densitometer scale.

• Page numbers — helps you collate pages of an image that do not include any page numbers or do not contain page numbers that correspond to the actual number of pages

• File information — prints file information, such as, the color profile; halftone settings; name, date, and time the image was created; plate number; and job name

To print crop and fold marks
1 Click File ➤ Print.
2 Click the Prepress tab.
3 In the Finishing marks area, enable the Crop/fold marks check box.

If you want to print all crop/fold marks, disable the Exterior only check box.
To print crop and fold marks, ensure that the paper on which you print is 0.5 inches larger on all sides than the page size of the image that you are printing.

To set crop and fold marks, see “To edit gutters” on page 853.

To print composite crop and fold marks
1. Click Tools ➤ Options ➤ Global.
2. Click Printing.
3. Click the Print Style tab.
4. From the Composite crop marks (PS) list box, choose Output on all plates.

To set a bleed limit
1. Click File ➤ Print.
2. Click the Layout tab.
3. Enable the Bleed limit check box.
4. Type a value in the Bleed limit box.

Usually, a bleed limit of 0.125 to 0.25 inches is sufficient. Any object extending beyond that uses memory needlessly and may cause problems when you print multiple pages with bleeds on a single sheet of paper.

To print registration marks
1. Click File ➤ Print.
2. Click the Prepress tab.
3. In the Registration marks area, enable the Print registration marks check box.
4. Choose a registration mark style from the Style picker.

To print registration marks, ensure that the paper on which you print is 0.5 inches larger on all sides than the page size of the image that you are printing.

To print color calibration bars and densitometer scales
1. Click File ➤ Print.
2. Click the Prepress tab.
3. In the Calibration bars area, enable any of the following check boxes:
   • Color calibration bar
   • Densitometer scales

If you want to customize the levels of gray in one of the densitometer scale squares, choose a number from the Densities list (lower values represent lighter squares), and type a new density for that square.
To print page numbers
1 Click File ➤ Print.
2 Click the Prepress tab.
3 In the File information area, enable the Print page numbers check box.
   If you want to position the page number inside the page, enable the Position within page check box.

To print file information
1 Click File ➤ Print.
2 Click the Prepress tab.
3 In the File information area, enable the Print file information check box.
4 Type a job name in the Print file information box.
   If you want to position the file information inside the page, enable the Position within page check box.

To position printers’ marks
1 Click File ➤ Print Preview.
2 Click the Marks placement tool.
3 Click the Auto-position marks rectangle button on the property bar.
4 Type values in the Marks alignment rectangle boxes.

You can also change the position of printers’ marks by clicking a printers’ mark icon in the print preview window and dragging the bounding box.

If you want to affix printers’ marks to the object’s bounding box instead of to the page bounding box, click File ➤ Print, click the Prepress tab, and enable the Marks to objects check box.

Maintain OPI links
Open Prepress Interface (OPI) lets you use low-resolution images as placeholders for the high-resolution images that appear in your final work. When a print service provider receives your file, the OPI server substitutes the high-resolution images for the low-resolution placeholders.

To maintain OPI links
1 Click File ➤ Print.
2 Click the PostScript tab.
   The PostScript tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
3 Enable the Maintain OPI links check box.

The Maintain OPI links option is available for PostScript devices only.
You can reduce your work time by using OPI and print management server solutions, such as Creo Color Central. Low-resolution samples are automatically created from the high-resolution originals and are placed in CorelDRAW. These files contain their own OPI
comments, which the Creo Color Central server recognizes when it receives the job and then substitutes the high-resolution version of the file for the low-resolution version.

Low-resolution images must be flagged as OPI images (this must be done using third-party software) before you can import them into a document.

**Color separations**

When you send color work to a print service provider or printing shop, either you or the print service provider must create color separations. Color separations are necessary because a typical printing press applies only one color of ink at a time to a sheet of paper. You can specify the color separations to print, including the order in which they print.

Printing presses produce color using either process color or spot color, or both. You can convert the spot colors to process colors at printing time. For more information on spot and process colors, see “Choose colors” on page 408.

When setting halftone screens to print color separations, we recommend that you use the default settings; otherwise, screens can be improperly set and result in undesirable moiré patterns and poor color reproduction. However, if you are using an imagesetter, the screen technology should be set to match the type of imagesetter the print service provider uses. Before customizing a halftone screen, consult the print service provider to determine the correct setting.

If you have overprinted areas, you can choose how you want those areas to print. For more information about overprinting, see “Color trapping and overprinting” on page 858.

**To print color separations**

1. Click **File ➤ Print**.
2. Click the **Color** tab.
3. Enable the **Separations** option.

   If you want to print specific color separations, click the **Separations** tab, and enable the corresponding check box in the list of color separations.

   You can change the order in which color separations print, by clicking **Advanced** in the **Options** area. In the separations list at the bottom of the dialog box, click in the **Order** column next to the color separation that you want to change. Chose a new order value from the list box.

   If you want to print separations using a color profile that is different from the document color profile, you can click the **Color** tab and choose a color profile from the **Color profile** list box.

**To convert spot colors to process colors**

1. Click **File ➤ Print**.
2. Click the **Color** tab.
3. Enable the **Separations** option.
4. Enable the **Convert spot colors to** check box.

   Changing the spot colors to process colors does not affect the original CorelDRAW file; it affects the way colors are sent to the printer.

**To customize a halftone screen**

1. Click **File ➤ Print**.
2 Click the Color tab.
3 Enable the Separations option.
4 Click the Separations tab.
5 In the Options area, click Advanced.
6 Change any of the following settings:
   • Screening technology
   • Resolution
   • Basic screen
   • Halftone type

You can set the screen frequency, screen angle, and overprint options for spot colors as well as process colors. For example, if you have a fountain fill made up of two spot colors, you can set one to print at 45 degrees and the other at 90 degrees.

Color trapping and overprinting

When colors are trapped, they are intentionally overlapped so that misalignments of print separations are not noticeable. In manual trapping, one color must overprint the other. Overprinting is achieved by printing one color over another. Overprint trapping works best when the top color is much darker than the underlying color; otherwise, an undesirable third color may result (for example, cyan over yellow results in a green object). In some cases, you might actually want to create a third color; for example, you can overprint two spot colors to create a third color.

How overprinted colors mix depends on the type of colors and ink you are mixing and the types of objects you are overprinting. For example, an object that uses a CMYK color overprints differently from an object that uses a spot color. Bitmaps also overprint differently from vector objects. You can preview a simulation of how overprinted colors will mix by enabling the Enhanced viewing mode and the Simulate overprints viewing mode. For more information about choosing a viewing mode, see “Viewing modes” on page 74. Some variation between the preview and the printed version may occur, depending on the printer you use.

When you are ready to print, you can choose to preserve overprint settings if you want to trap objects in a document, or if you want to mix the overlapping colors for effect. You can also choose to knock out the overprinted areas so that only the top color is visible. If you want to print a proof version of the file, you can simulate overprints. Simulating overprints rasterizes the file, and it prints using process colors only.

You can set a group of objects to overprint. You can allow text to overprint overlying objects. You can also overprint bitmaps; or each vector object’s fill, or outline, or both. In addition, you can overprint specific color separations and specify in which order they will print, as well as whether you want to overprint graphics, or text, or both.

The two methods for automatic color trapping include always overprinting black and auto-spreading. Overprinting black creates a color trap by causing any object that contains 95% black or more to overprint any underlying objects. This option is useful for artwork containing a lot of black text, but it should be used with caution on artwork with a high graphics content. You can adjust the threshold, if the print service provider recommends a black threshold value other than 95%.

Auto-spreading creates color trapping by assigning an outline to an object that is the same color as the object’s fill and having it overprint underlying objects. Auto-spreading is created for all objects in the file that meet three conditions: they do not already have an outline, are filled with a uniform fill, and have not already been designated to overprint.

For advanced trapping options, see “In-RIP trapping settings” on page 861.

To preserve or ignore overprints when printing
1 Click File ➤ Print.
2 Click the Color tab.
3 Choose one of the following options:
   • Composite
• Separations

4 Click one of the following tabs:
  • Separations
  • Composite

5 From the Document overprints list box, choose one of the following options:
  • Ignore — does not overprint areas; color on top prints and underlying colors are knocked out
  • Preserve — preserves overprinted areas

To print a simulated overprint

1 Click File ➤ Print.
2 Click the Color tab.
3 Enable the Composite option.
4 Click the Composite tab.
5 From the Document overprints list box, choose Simulate.
   The Simulate option rasterizes the file; the file is printed with process colors.

To overprint selected objects

1 Select an object.
2 Click Object, and choose any of the following:
   • Overprint outline
   • Overprint fill
   • Overprint bitmap

You can also set an object to overprint by right-clicking the object and choosing an overprint option from the context menu.

To print text over underlying objects

1 Using the Text tool A, select the text.
2 In the Character area of the Properties docker, click the arrow button ▼ located at the bottom of Paragraph area to display additional options.
3 Enable the Overprint fill check box.

To overprint selected color separations

1 Click File ➤ Print.
2 Click the Color tab.
3 Enable the Separations option.
4 Click the Separations tab.
5 In the Options area, click Advanced.
6 Choose a color separation from the Screening technology list box.
7 In the Overprint column, click one or both of the following icons:
   • Overprint graphics ✓
   • Overprint text A
The icons appear darker when the separation is set to overprint.

You can change the order in which color separations print by selecting a color separation and choosing an order from the Order list box.

To trap by always overprinting black
1. Click File ➤ Print.
2. Click the Color tab.
3. Choose one of the following options:
   • Composite
   • Separations
4. Click one of the following tabs:
   • Separations
   • Composite
5. In the Options area, enable the Always overprint black check box.

To set the overprint black threshold
1. Click Tools ➤ Options ➤ Global.
2. Click the Print Style tab.
3. Choose a number from the Overprint black threshold (PS) list box.

   The number you choose represents the percentage of black above which black objects overprint.

To trap by auto-spreading
1. Click File ➤ Print.
2. Click the Color tab.
3. Choose one of the following options:
   • Composite
   • Separations
4. Click one of the following tabs:
   • Separations
   • Composite
5. Choose one of the following options from Automatic trapping list box:
   • Auto-spreading option, and type a value in the Maximum box.
   • Fixed width option, and type a value in the Width box.
6. Type a value in the Text above box.
The value that you type in the **Text above** box represents the minimum size to which auto-spreading is applied. If you set this value too low, small text may be rendered illegible when auto-spreading is applied.

The amount of spread assigned to an object depends on the maximum trap value specified in the **Maximum** box and the object’s color. The lighter the color, the greater the percentage of the maximum trap value. The darker the color, the smaller the percentage of the maximum trap value.

**In-RIP trapping settings**

In-RIP trapping allows you to specify advanced trapping settings. Before selecting In-RIP trapping, ensure that your PostScript 3 printer supports In-RIP trapping options.

You can select a trap width — the amount that one color spreads into another. You can also specify image trap placement, which determines where the trap occurs. You can, for example, specify whether the trap is a **choke** or a **spread**, depending upon the neutral densities of adjacent colors. Neutral density indicates the lightness or darkness of a color and helps determine how adjacent colors spread into one another.

You can specify a **threshold** at which a trap is created by specifying a step trap limit. If trap colors are of similar neutral densities, the trap placement adjusts accordingly. The step trap limit specifies a threshold at which a trap adjusts.

Before trapping, you can set the inks; for example, you can set an ink to opaque, as in the case of a metallic ink, so that nothing shows through it. To reduce the visibility of a trap, you can decrease the amount of ink color in a trap. This is especially helpful in the case of pastel colors, contrasting colors, and colors with similar neutral densities.

**To select a trap width**

1. Click **File** ➤ **Print**.
2. Click the **Color** tab.
3. Enable the **Composite** option.
4. Click the **PostScript** tab.
   - The **PostScript** tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
5. Choose **PostScript 3** from the **Compatibility** list box.
6. Click the **Composite** tab.
7. Enable the **PostScript level 3 In-RIP trapping** check box.
8. Click **Settings**.
9. Type a value in the **Trap width** box.
   - If you are trapping to black, type a value in the **Black trap width** box.

**To select In-RIP trapping options**, you must have selected **PostScript 3** from the **Compatibility** list box under the **PostScript** tab of the **Print** dialog box.

**To specify image trap placement**

1. Click **File** ➤ **Print**.
2. Click the **Color** tab.
3. Enable the **Composite** option.
4. Click the **PostScript** tab.
   - The **PostScript** tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
5 Choose PostScript 3 from the Compatibility list box.
6 Click the Composite tab.
7 Enable the PostScript Level 3 In-RIP trapping check box.
8 Click Settings.
9 From the Image trap placement list box, choose one of the following placements:
   • Neutral density — used to determine the lighter object and thus the direction and placement of the trap
   • Choke — used to trap a dark foreground object to a light background image
   • Spread — used to trap a light foreground object to a dark background image
   • Centerline — used when adjacent images and objects have similar neutral densities or when image density changes along an object’s edge

   If you want to trap an object to an image, enable the Trap objects to images check box.

To specify a threshold
1 Click File ➤ Print.
2 Click the Color tab.
3 Enable the Composite option.
4 Click the PostScript tab.
   The PostScript tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
5 Choose PostScript 3 from the Compatibility list box.
6 Click the Composite tab.
7 Enable the PostScript 3 In-RIP trapping check box.
8 Click the Settings button.
9 Type a value in one or more of the following boxes:
   • Step limit — specifies a threshold between color variations. The lower the threshold value, the more likely it is that a trap will be created.
   • Black limit — specifies the threshold at which process black is considered pure black
   • Black density limit — specifies a neutral density value for the black ink
   • Sliding trap limit — specifies the difference between the neutral densities of adjacent colors at which a trap adjusts (slides) from the darker side of a color edge toward the centerline. The lower the sliding trap limit, the more gradual the transition.

   To choose In-RIP trapping options, you must have selected PostScript 3 from the Compatibility list box under the PostScript tab in the Print dialog box.

To set inks for trapping
1 Click File ➤ Print.
2 Click the Color tab.
3 Enable the Composite option.
4 Click the PostScript tab.
   The PostScript tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
5 Choose PostScript 3 from the Compatibility list box.
6 Click the Composite tab.
7 Enable the PostScript Level 3 In-RIP trapping check box.
8 Click the Settings button.
9 In the Type column, select one of the following for each color separation:
• **Transparent** — the selected ink doesn’t get trapped, but anything beneath it does
• **Neutral density** — the neutral density of the selected ink determines how it is treated
• **Opaque** — the selected ink is treated as opaque
• **Opaque ignore** — the selected ink doesn’t get trapped nor does anything beneath it

To choose In-RIP trapping options, you must have selected **PostScript 3** from the **Compatibility** list box under the **PostScript** tab in the Print dialog box.

**To select a trap color reduction**

1. Click **File** ➤ **Print**.
2. Click the **Color** tab.
3. Enable the **Composite** option.
4. Click the **PostScript** tab.
   
   The **PostScript** tab only appears for non-GDI printers. For more information, see “Notes for GDI printers” on page 830.
5. Choose **PostScript 3** from the **Compatibility** list box.
6. Click the **Composite** tab.
7. Enable the **PostScript 3 In-RIP trapping** check box.
8. Click the **Settings** button.
9. Type a value in the **Trap color reduction** box.

A reduction value of 100% indicates no reduction, while a lower value reduces the neutral density.

**Print to film**

You can set up a print job to produce negative images. An imagesetter produces images on film that may need to be produced as negatives depending on which printing device you are using. Consult your print service provider to determine whether you can produce images on film.

You can specify to print with the emulsion down. Printing with the emulsion down produces a backward image on desktop printers.

**To print a negative**

1. Click **File** ➤ **Print**.
2. Click the **Prepress** tab.
3. In the **Paper/film settings** area, enable the **Invert** check box.

Do not choose negative film if you are printing to a desktop printer.

**To specify film with the emulsion down**

1. Click **File** ➤ **Print**.
2. Click the **Prepress** tab.
3. In the **Paper/film settings** area, enable the **Mirror** check box.
Prepare banners for printing

You can add borders and grommet markers to prepare banners for printing. Grommets are rings or edge strips inserted into holes through thin material such as textile fabric or composite of carbon fiber. Strings or ropes can be inserted through the grommets to stretch a banner properly.

You can create a banner from the active page or from selected objects on the page.

Borders can be used in two ways. You can add a border to a design that has important graphic or text elements around the edges to prevent cutoffs in the final banner. Alternatively, you can add a border that can be folded before placing the grommets to make the banner edges sturdier.

CorelDRAW lets you add borders that have the page background color or a solid color of your choice. You can also stretch or mirror the document edges to add a border. You can specify the border size, which is the height of the area added to the top and bottom of the document and the width of the area placed to the right and left of the document.

You can specify the size and number of the grommet markers, and you can place them within the boundaries of the original page or in the border areas. In addition, you can specify the margin — the distance from the grommet edge to the page edge. Grommet markers can be placed in the corners or along the top, bottom, left and right edges of the design. With this placement method, you can specify the number of grommet markers to be added vertically and horizontally. You can also add grommet markers by specifying the approximate space between them.

CorelDRAW saves your changes to a new document, which can be sent for printing, leaving the original document unchanged.

Borders and grommet markers cannot be brought into Focus mode. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

The Border and Grommet dialog box.
**To prepare a banner design for printing**

1. Click **Layout ➤ Border and Grommet**.
2. Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add borders and grommet markers to a document based on the active page</td>
<td>In the <strong>Source</strong> area, enable the <strong>Page</strong> option.</td>
</tr>
<tr>
<td>Add borders and grommet markers to a document that includes only the selected object</td>
<td>In the <strong>Source</strong> area, enable the <strong>Selection</strong> option. This option is unavailable if there are no selected objects on the page.</td>
</tr>
<tr>
<td>Add a border</td>
<td>In the <strong>Border</strong> area, enable the <strong>Add border</strong> check box.</td>
</tr>
<tr>
<td>Choose a border type</td>
<td>In the <strong>Border</strong> area, choose an option from the <strong>Type</strong> list box:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Page</strong> — uses the page background color</td>
</tr>
<tr>
<td></td>
<td>• <strong>Color</strong> — lets you select a solid color</td>
</tr>
<tr>
<td></td>
<td>• <strong>Stretch</strong> — stretches the document edges to create a border</td>
</tr>
<tr>
<td></td>
<td>• <strong>Mirror</strong> — mirrors the document edges to create a border</td>
</tr>
<tr>
<td>Set the border size</td>
<td>In the <strong>Border</strong> area, type a value in the <strong>Size</strong> box.</td>
</tr>
<tr>
<td>Add grommets</td>
<td>Enable the <strong>Add grommets</strong> check box.</td>
</tr>
<tr>
<td></td>
<td>If you want CorelDRAW to take into account the border area when placing grommet markers, enable the <strong>Use border area</strong> check box. Disabling this option places grommet markers within the boundaries of the original page.</td>
</tr>
<tr>
<td>Set the grommet size</td>
<td>In the <strong>Grommet</strong> area, type a value in the <strong>Size</strong> box.</td>
</tr>
<tr>
<td>Set the distance from the grommet markers’ edge to the closest page edge</td>
<td>In the <strong>Grommet</strong> area, type a value in the <strong>Margin</strong> box.</td>
</tr>
<tr>
<td>Specify the number and placement of grommet markers</td>
<td>In the <strong>Placement and Distribution</strong> area, enable the <strong>Number of grommets</strong> option, and type values in the <strong>Vertical</strong> and <strong>Horizontal</strong> boxes.</td>
</tr>
<tr>
<td></td>
<td>Click any of the following buttons:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Corners</strong> — places the grommet markers in the page corners</td>
</tr>
<tr>
<td></td>
<td>• <strong>Top</strong> — places the grommet markers along the top of the page</td>
</tr>
<tr>
<td></td>
<td>• <strong>Bottom</strong> — places the grommet markers along the bottom of the page</td>
</tr>
<tr>
<td></td>
<td>• <strong>Left</strong> — places the grommet markers along the left edge of the page</td>
</tr>
<tr>
<td></td>
<td>• <strong>Right</strong> — places the grommet markers along the right edge of the page</td>
</tr>
</tbody>
</table>
To Add grommet markers by specifying the space between them

Do the following In the Placement and Distribution area, enable the Spacing option, and type values in the Vertical and Horizontal boxes.

Start from scratch Click Reset.

Work with a print service provider

When you send a file to a print service provider, the provider takes your file and converts it directly to film or to plates.

When you prepare a print job for printing, you can send camera-ready paper output or the work on disk. If you send the work on disk, the print service provider needs either a PostScript file or a native file from the application that you use. If you are creating a file to send to an imagesetter or a plate-setter, speak with the print service provider about the best file format and printing device settings to use. Always provide a final printout of the work to the print service provider, even if it is only a black-and-white representation. This helps the print service provider to identify and assess any potential problems.

Before printing a drawing, you must choose and properly configure the appropriate printing device driver. Consult the printing device manufacturer instructions, or the print service provider or printing shop that you use to print the work, to find out the best way to set up the printing device driver.
Create objects for the web

CorelDRAW lets you export objects and projects to bitmaps that are optimized for viewing in a web browser. If you have WordPress accounts, you can export objects and projects to bitmaps and seamlessly upload these bitmaps to your WordPress media libraries. You can also make paragraph text web-compatible.

You can also create interactive rollovers from CorelDRAW objects. In addition, you can add hyperlinks and bookmarks to a drawing.

After creating the web-compatible object in CorelDRAW, you can add the object to a design using a web-authoring tool.

This section contains the following topics:
• "Create pixel-perfect graphics for the web" (page 869)
• "Export bitmaps for the web" (page 870)
• "Export and upload bitmaps to WordPress" (page 875)
• "Save and apply web presets" (page 876)
• "Export objects with transparent colors and backgrounds" (page 876)
• "Web-compatible text" (page 877)
• "Rollovers" (page 878)
• "Bookmarks and hyperlinks" (page 879)
• "Add hotspots and alternate text to objects" (page 880)

Create pixel-perfect graphics for the web

The following tips can help you create pixel-perfect graphics for the web:
• Choose pixels as the unit of measurement of your document.
• Check the dimensions of objects in pixels in the Object size box on the property bar. Adjust the object size to whole numbers before exporting the document. If you plan to scale an object, use even numbers to ensure proper object scaling.
• Use Pixels view (View ➤ Pixels) at a zoom of 800% or higher to view and evaluate the results.
• In new documents, the pixel grid is aligned with the lower-left corner of the document page to help you create pixel-perfect designs on export, without blurry edges and with predictable pixel dimensions. Keep the Align page with pixel grid setting enabled for best results. If you’re working with legacy files, the page is automatically aligned to the center to keep the default alignment in previous versions of CorelDRAW. For more information, see “To change the settings of the pixel grid” on page 742.
• Make sure snapping to pixel is enabled so that objects you move or draw automatically snap to either the center or edge of the pixel grid (depending on the objects outline properties). For information about how to enable or disable snapping to pixel, see “To change the settings of the pixel grid” on page 742.
• Align objects and nodes with the pixel grid. For more information, see “To align an object with the pixel grid” on page 332 and “To align nodes with the pixel grid” on page 223.

Export bitmaps for the web

CorelDRAW lets you export documents to the following web-compatible file formats: GIF, PNG, JPEG, and WEBP.

While specifying exporting options, you can preview an image with up to four different configurations of settings. You can compare file formats, preset settings, download speeds, compression, file size, image quality, and color range. You can also examine previews by zooming and panning within the preview windows.

Component | Description
--- | ---
1. Preview window | Displays a preview of the document.
2. Preview modes | Lets you preview the adjustments in a single or split frame.
3. Zooming and panning tools | Lets you zoom in and out of a document displayed in the preview window, pan an image displayed at zoom level higher than 100%, and fit an image in the preview window.
4. Preset list box | Lets you choose preset settings for a file format.
5. Export settings | Lets you customize export setting, such as color, display options, and size.
### Component

<table>
<thead>
<tr>
<th>6. Format information</th>
<th>Lets you view file-format information, which is available for each preview frame.</th>
</tr>
</thead>
<tbody>
<tr>
<td>7. Speed list box</td>
<td>Lets you choose an Internet speed for saving the file.</td>
</tr>
</tbody>
</table>

You can export web-compatible files using preset settings. This allows you to optimize the file, without the need to modify individual settings. You can also customize the settings to produce a specific result. For example, you can adjust its color, display quality, and file size.

### Choosing a web-compatible file format

This table is a quick reference for choosing a web-compatible file format.

<table>
<thead>
<tr>
<th>File format</th>
<th>Ideal for</th>
</tr>
</thead>
<tbody>
<tr>
<td>GIF</td>
<td>Line drawings, text, images with few colors, or images with sharp edges, such as scanned black-and-white images or logos. GIF offers several advanced graphic options, including transparent backgrounds, interlaced images, and animation. It also lets you create custom palettes for the image.</td>
</tr>
<tr>
<td>PNG</td>
<td>Various image types, including photos and line drawings. The PNG file format (unlike the GIF and JPEG formats) supports the alpha channel. This allows you to save transparent images with superior results.</td>
</tr>
<tr>
<td>JPEG</td>
<td>Photos and scanned images. JPEG files use file compression to store an approximation of an image, which results in some loss of image data, but does not compromise the quality of most photographs. You can choose the image quality when you save an image — the higher the image quality, the larger the file size.</td>
</tr>
<tr>
<td>WEBP</td>
<td>Various image types, including photos, line drawings, icons, images with text. The WEBP format provides both lossless and lossy compression and supports transparency. WEBP lossless images are smaller than PNG files, and WEBP lossy images are smaller than JPEG images. You can control the compression factor for RGB channels and the ratio between encoding speed, file size, and quality. For more information, see “Google Web Picture (WEBP)” on page 946.</td>
</tr>
</tbody>
</table>

When you export a file to the PNG, JPEG, GIF, and WEBP formats, you can crop your artwork to the boundaries of the drawing page to remove unwanted objects and reduce file size. Any parts of an object that fall outside the page will appear cropped in the exported file.

### Exporting palette-based documents

Palette-based documents, such as paletted GIF and 8-bit PNG, allow individual pixels to retain their exact color value. This lets you control the display of colors in the file when exporting. Palette-based documents also allow you to introduce transparency to a file by choosing...
a color in the image and making it transparent. For information, see “Export objects with transparent colors and backgrounds” on page 876.

To adjust the object-export preview

1. Click File ➤ Export For ➤ Web.
2. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the bitmap in a single preview frame</td>
<td>Click the <strong>Full preview</strong> button 📸.</td>
</tr>
<tr>
<td>View two versions of the bitmap in side-by-side frames</td>
<td>Click the <strong>Two vertical previews</strong> button 📸.</td>
</tr>
<tr>
<td>View the two versions of the bitmap with one frame placed above the other</td>
<td>Click the <strong>Two horizontal previews</strong> button 📸.</td>
</tr>
<tr>
<td>View four versions of the bitmap in separate frames</td>
<td>Click the <strong>Four previews</strong> button 📸.</td>
</tr>
<tr>
<td>Fit a bitmap in the preview window</td>
<td>Click the <strong>Zoom to fit</strong> button 🕵️.</td>
</tr>
<tr>
<td>Display each pixel in the image data to a single pixel on-screen</td>
<td>Click the <strong>Zoom 1:1 pixel</strong> button 📸.</td>
</tr>
<tr>
<td>Display a bitmap at its actual size</td>
<td>Click the <strong>Zoom to actual size</strong> button 🕵️.</td>
</tr>
<tr>
<td>Pan to another area of the bitmap</td>
<td>Using the <strong>Pan tool</strong> 🕵️, drag the image until the area you want to see is visible.</td>
</tr>
<tr>
<td>Zoom in and out</td>
<td>Using the <strong>Zoom in tool</strong> + or <strong>Zoom out tool</strong> −, click in the preview window.</td>
</tr>
<tr>
<td>Change the display options for the object in a preview frame</td>
<td>Click a frame, then choose different export settings from the export settings area.</td>
</tr>
</tbody>
</table>

To export a web-compatible bitmap

1. Click File ➤ Export For ➤ Web.
2. In the **Export for web** dialog box, choose preset settings from the **Preset** list box in the upper-right corner of the dialog box.
   If you want modify the preset settings, you can change the exporting options in the dialog box.
3. Click **Save as**.
4. Choose the drive and folder where you want to save the file.
5. Type a name in the **File name** box.
6. Click **Save**.
You can also

Choose a color mode
In the **Settings** area, choose a color mode from the **Color mode** list box.
This option is unavailable for the GIF file format.

Embed the color profile
In the **Advanced** area, enable the **Embed color profile** check box.

💡
To crop your artwork to the boundaries of the drawing page, enable the **Crop to page on export** check box in the **Transformation** area.
You can choose an Internet connection speed from the **Speed** list box at the bottom of the dialog box.
You can also export to a web-compatible format by clicking **File** ➤ **Export**, and choosing a file format from the **Save as type** list box.

**To resize an object when exporting a web-compatible bitmap**
- In the **Transformation** area of the **Export for web** dialog box, perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a unit of measurement for the bitmap</td>
<td>Choose a unit of measurement from the <strong>Units</strong> list box.</td>
</tr>
<tr>
<td>Specify the bitmap dimensions</td>
<td>Type values in the <strong>Width</strong> and <strong>Height</strong> boxes.</td>
</tr>
<tr>
<td>Resize the bitmap to a percentage of its original size</td>
<td>Type values in the <strong>Width %</strong> and <strong>Height %</strong> boxes.</td>
</tr>
<tr>
<td>Avoid distortion by maintaining the width-to-height ratio of the bitmap</td>
<td>Enable the <strong>Maintain aspect ratio</strong> check box.</td>
</tr>
<tr>
<td>Specify the bitmap resolution</td>
<td>Type a value in the <strong>Resolution</strong> box.</td>
</tr>
<tr>
<td>Maintain the size of the file on your hard disk when you change the resolution of the bitmap</td>
<td>Enable the <strong>Maintain size</strong> check box.</td>
</tr>
</tbody>
</table>

**To customize options for exporting a JPEG bitmap**
1. In the **Export for web** dialog box, choose **JPEG** from the **Format** list box.
2. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control document quality</td>
<td>In the <strong>Settings</strong> area, choose a quality option from the <strong>Quality</strong> list box, or type a percentage value.</td>
</tr>
<tr>
<td>Choose an encoding setting</td>
<td>In the <strong>Settings</strong> area, choose an option from the <strong>Sub-format</strong> list box.</td>
</tr>
</tbody>
</table>
To

Blur the transition between adjacent pixels of different colors

In the **Settings** area, type a value in the **Blur** box.

Load the JPEG file gradually in certain web browsers to display only portions of the image before it finishes loading

In the **Advanced** area, enable the **Progressive** check box.

Use the optimal encoding method to produce the smallest JPEG file size

In the **Advanced** area, enable the **Optimize** check box.

You can also

Apply the document-color settings

In the **Advanced** area, enable the **Use document color settings** option.

Apply the color-proof settings to the document

In the **Advanced** area, enable the **Use color proof settings** option.

Enable the overprinting of black when exporting to CMYK

In the **Settings** area, enable the **Overprint black** check box.

Apply a matte color to the object’s background to help blend the edges of anti-aliased objects

In the **Settings** area, open the **Matte** color picker, and click a color.

To specify display-quality options for exporting web-compatible bitmaps

- In the **Export for web** dialog box, perform one or more tasks from the following table.

To

Apply a matte color to the object’s background to help blend the edges of anti-aliased objects

In the **Settings** area, open the **Matte** color picker, and click a color.

Smooth the edges of the object

In the **Advanced** area, enable the **Anti-aliased** check box.

Load the file gradually in certain web browsers to display only portions of the image before it finishes loading

In the **Advanced** area, enable the **Interlaced** check box. This option is unavailable for the JPEG file format.

To specify color settings for exporting to the GIF or Paletted 8-bit PNG file format

- In the **Export for web** dialog box, perform one or more tasks from the following table.

To

Choose a color mode

In the **Settings** area, choose a color mode from the **Color mode** list box. This option is unavailable for the GIF file format.
<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a color palette</td>
<td>In the <strong>Settings</strong> area, choose a palette from the <strong>Color palette</strong> list box.</td>
</tr>
<tr>
<td>Specify a dithering setting and amount</td>
<td>In the <strong>Settings</strong> area, choose a dithering option from the <strong>Dithering</strong> list box, and type a value in the box. For information about dithering, see “Dithering” on page 801.</td>
</tr>
<tr>
<td>Embed the color profile</td>
<td>In the <strong>Advanced</strong> area, enable the <strong>Embed color profile</strong> check box.</td>
</tr>
</tbody>
</table>
| Load a color palette | In the **Settings** area, click the arrow next to **Color palette** list box, and click **Load palette**.  
This option is unavailable for the GIF file format. |
| Sample a color and add it to a color palette | In the **Settings** area, click the **Eyedropper**, and then click in the drawing window to choose a color. Click the **Add the sampled color to palette** button. |
| Add or modify colors | Double-click a color swatch on the color palette. |
| Choose the number of colors that you want to display | In the **Settings** area, choose a value from the **Number of colors** list box. |
| Delete a color from the color palette | In the **Settings** area, click a color on the color palette, and then click the **Delete the selected color** button. |

> You can also add transparency to a palette-based document by choosing a color in the image and making it transparent. For information, see “Export objects with transparent colors and backgrounds” on page 876.

**Export and upload bitmaps to WordPress**

With CorelDRAW, you can export your projects to bitmap images suitable for WordPress and then upload them to your WordPress account without leaving the application.

You can export your entire project or only selected objects to a JPEG, GIF, or PNG file. After choosing the file format and options you want, you can upload the image to your WordPress account. If you have multiple WordPress sites, you can choose to which site to upload the bitmap. The exported bitmap is added to the media library of the selected site.

When you upload bitmaps to WordPress for the first time, you must authenticate your WordPress account and log in. If you have more than one WordPress account, you can switch accounts at any time.

**To export and upload a bitmap to WordPress**

1. Select the objects that you want to export, or deselect all objects to export the entire project.
2. Click **File ➤ Export For ➤ WordPress**.
In the **Export for WordPress** dialog box, choose the file format you want from the **Format** list box, and adjust any export settings you want.

The **Export for WordPress** dialog box lets you access the same export options that are available in the **Export for Web** dialog box. For detailed information about export options, see "Export bitmaps for the web" on page 870.

4 Click **Upload**.

5 In the **Upload to WordPress** dialog box, perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authenticate your WordPress account and log in</td>
<td>Click <strong>Authenticate your WordPress</strong> account.</td>
</tr>
<tr>
<td>Choose a WordPress site</td>
<td>Choose a site from the <strong>Site</strong> box.</td>
</tr>
<tr>
<td>Upload the bitmap</td>
<td>Click <strong>Upload</strong>.</td>
</tr>
<tr>
<td>Log in to another WordPress account</td>
<td>Click <strong>Log out or switch accounts</strong>.</td>
</tr>
</tbody>
</table>

The exported bitmap is saved to a temporary file, which is deleted after you upload the image to WordPress.

**Save and apply web presets**

Web presets allow you to save custom settings for exporting web-compatible file formats.

**To save a preset for exporting web-compatible images**

1 In the **Export for web** dialog box, choose a file format from the **Format** list box.
2 Choose the settings that you want to store as a preset.
3 Click the arrow next to the **Preset** list box, and click **Save preset**.
4 Type the name of the preset in the **File name** box.
5 Click **Save**.

TIP

You can delete the preset you saved by choosing it from the **Preset** list box, clicking the arrow next to the **Preset** list box, and clicking **Delete preset**.

**To apply a preset for exporting web-compatible images**

1 In the **Export for web** dialog box, click the arrow next to the **Preset** list box, and click **Load preset**.
2 Click the name of the file.
3 Click **Open**.

**Export objects with transparent colors and backgrounds**

CorelDRAW lets you export palette-based bitmaps, such as paletted GIF or 8-bit PNG, with transparent colors and backgrounds. These bitmaps can contain objects, such as buttons and logos, which are commonly used on webpages with colored or patterned backgrounds.
If you place an object with an opaque background onto a webpage, the object background color appears as a rectangle on the page. By making an object background transparent, the object background blends in with the page. Transparent object backgrounds also let you change the color or pattern of a webpage background without having to change the backgrounds of the objects to match.

You can create a GIF with a transparent background to use on a webpage.

To save a bitmap with a transparent background

1. In the Export for web dialog box, choose a paletted file format, such as GIF or Paletted 8-bit PNG, from the Format list box.
2. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make the background of the object transparent</td>
<td>In the Settings area, enable the Transparency check box.</td>
</tr>
<tr>
<td>Make a selected color transparent</td>
<td>Click the Eyedropper tool, and then click the image in the preview window to choose a color. In the Settings area, click the Make the selected color transparent button.</td>
</tr>
<tr>
<td>Apply a matte color to the object's background to help blend the edges of anti-aliased objects</td>
<td>In the Settings area, open the Matte color picker, and click a color.</td>
</tr>
</tbody>
</table>

For best results, choose None from the Dithering list box in the Settings area.

Web-compatible text

When you convert paragraph text to web-compatible text, you can edit the text of the published document in an HTML editor. The default web font style is used automatically unless you override it with another font. If you choose to override it, the default font is used when visitors to your website don’t have the same font installed on their computers. The bold, italic, and underline text styles are also available. You can apply uniform fills, but not outlines, to web-compatible text.

To make text web-compatible

- Using the Pick tool, select the paragraph text frame. Click Text > Make text Web-compatible.

Ensure that the web-compatible text does not intersect or overlap other objects or extend beyond the boundaries of the drawing page; otherwise the text will be converted to a bitmap, and it will lose its Internet properties.

Artistic text cannot be converted to web-compatible text and is always treated as a bitmap. However, you can convert it to paragraph text and then make it web compatible. For information on converting text, see “Find, edit, and convert text” on page 608.
Rollovers

Rollovers are interactive objects that change in appearance when you click or point to them. You can create rollovers using objects.

To create a rollover, you add the following rollover states:

- Normal — the default state of a button when no mouse activity is associated with the button
- Over — the state of a button when the pointer passes over it
- Down — the state of a clicked button

You can apply different object properties to each of the rollover states. You can also preview the rollover states.

To create a rollover object

1. Select an object.
2. Click Object ‣ Rollover ‣ Create Rollover.

To modify an object’s rollover state

1. Click the rollover object to select it.
2. Click Window ‣ Dockers ‣ Links and Rollovers.
3. In the Links and Rollovers docker, click the Edit rollover button and choose a state from the Active rollover state list box:
   - Normal
   - Over
   - Down
4. Modify the object properties, such as the color.
5. Repeat steps 4 and 5 to modify the other states if needed.
6. Click the Finish editing rollover button.

You can also

Delete a rollover state

On the Internet toolbar, click the Delete rollover state button.
You can also

**Duplicate a rollover state**

On the **Internet** toolbar, click the **Duplicate rollover state** button.

**Undo a rollover**

On the **Internet** toolbar, click the **Extract rollover objects** button.

**Specify what frame appears when the rollover is clicked**

On the **Internet** toolbar, chose a target frame from the **Target** list box.

---

You cannot close a drawing in which you are editing a rollover. You must finish editing first.

Rollover objects in edit mode cannot be brought into Focus mode, but rollover objects not already in edit mode can be brought into focus. Entire rollover objects can be brought into focus, but not individual rollover state objects. For more information about Focus mode, see “Edit objects in Focus mode” on page 305.

---

To preview a rollover

1. Click **Object ➤ Rollover ➤ Rollover Live Preview**.
2. In the drawing window, point to the rollover to view the **Over** state, and click the rollover to view the **Down** state.

---

To view rollover properties

1. Click **Window ➤ Dockers ➤ Objects**.
2. In the **Objects** docker, click the page and layer where the rollover resides.
3. Click the rollover name, and expand the **Normal**, **Over**, and **Down** states.

---

You can preview a rollover object’s states in the drawing page by clicking **Object ➤ Rollover ➤ Rollover Live Preview**.

---

**Bookmarks and hyperlinks**

CorelDRAW lets you add bookmarks and hyperlinks to your document. You can apply these to objects, including text objects, rollovers, and bitmaps. For information, see “PDF hyperlinks, bookmarks, and thumbnails” on page 898.

**Bookmarks**

To create a link within a file, you can assign a bookmark to text or to an object. You can then assign a link to an object so that, when it’s clicked, it opens the bookmark.

**Hyperlinks**

You can also assign a hyperlink to an object. You can link to a web address, FTP server, email address, bookmark, or file. When the object is clicked, it opens to the assigned location in a appropriate application. After you create hyperlinks, you can display and verify them. You can also delete links and bookmarks. When working with text, you can assign a hyperlink to both artistic and paragraph text.

---

To assign a bookmark

1. Click **Window ➤ Dockers ➤ Sources**.
In the workspace, click the object that you want to bookmark.

Click the New bookmark button.

Type the name of the bookmark in the name box.

To assign a hyperlink to objects and text

1. Click Window  Dockers  Sources.
2. Using the Pick tool , click the object or text object to which you want to apply a hyperlink.

When you assign a hyperlink to a text object, the color of the hyperlink is the same as the text object. For information about changing the color of a text object, see “To quickly change the color of a text object” on page 628.

3. Click the New link button.

4. From the Link type list box, choose one of the following link types:

Link types

http:// or https:// Type a web address, or URL, for a webpage that opens when you click the link.

ftp:// Type a web address, or URL, to the FTP server that opens when you click the link.

mailto: Type an email address.

file:// Click the browse button and navigate to the file that you want to open when you click the link.

bookmark Choose a previously created bookmark from the list.

To verify a link

1. Click Window  Dockers  Sources.
2. Choose the link that you want to open.
3. Click the Open link button.

To delete a bookmark or link

1. Click Window  Dockers  Sources.
2. Choose the link or bookmark that you want to delete.
3. Click the Delete button.

Add hotspots and alternate text to objects

You can also set a hotspot that follows the outline of the object, or fills the object’s bounding box. CorelDRAW applies a crosshatch pattern to an object containing a link. You can change the color of the crosshatch pattern as well as its background fill. In addition, you can add alternate text to objects for text-only browsers or screen readers.
To set a hotspot

1. Click Window ➤ Dockers ➤ Links and Rollovers.
2. In the workspace, click the object to which you want to add a hotspot.
3. In the Links and Rollovers docker, choose Link from the Behavior list box, and type a web address in the URL box.
4. In the Define hotspot using area, click one of the following buttons:
   • Shape — defines the hotspot using the object’s shape
   • Bounds — defines the hotspot using the object’s bounding box
5. Open the Background color picker and click a color.
6. Open the Cross-hatch color picker and click a color.

If you choose a hyperlinked object first and then change the crosshatch and background hotspot colors, the change applies to the selected object only.

To add alternate text to an object

1. Click Window ➤ Dockers ➤ Links and Rollovers.
2. In the workspace, click the linked object to which you want to add alternate text.
3. In the Links docker, type the alternate text in the Alt comments text box.
Import and export

Import and export files and assets.................................................................885
Export to PDF...............................................................................................895
Work with office productivity applications..................................................909
Supported file formats..............................................................................911
Import and export files and assets

Your application provides filters that convert files from one format to another when you import or export files and assets.

This section contains the following topics:

• “Import files” (page 885)
• “Export files” (page 889)
• “Export objects and pages” (page 891)

Import files

You can import files created in other applications. For example, you can import an Adobe Portable Document Format (PDF), JPEG, or Adobe Illustrator (AI) file. You can import a file and place it in the active application window as an object. You can also resize and center a file as you import it. The imported file becomes part of the active file. While importing a bitmap, you can resample it to reduce the file size, or crop it to eliminate unused areas of the image. You can also crop a bitmap to select only the exact area and size of the image that you want to import.

The Sources docker lets you add linked files that were saved to a bitmap format such as JPEG or PNG. You can also import linked Corel DESIGNER (DES), CorelDRAW (CDR), Comma-separated Values (CSV) as well as Excel Workbook (XLS or XLSX) files. You can open the source of a linked file for editing, and you can sync the linked content with the latest version of the source file. You can break the link between the imported file and its source at any time so that you can edit the files independently of each other.

When you import a file from an earlier version of CorelDRAW that contains text in a language different from the language of your operating system, you can use code page settings to ensure that object names, keywords, and notes saved with the file are displayed correctly.

To import a file into an active drawing

1. Click File ➤ Import.
2. Choose the folder where the file is stored.
   If necessary, you can search for a file by using the search box. You can search for such things as file name, title, subject, author, keyword, comment, bitmap name, object name, and so on.
3. Choose a file format from the list box next to the File name box.
   If you don’t know the file’s format, choose All file formats.
4. Click the file name.
   If the file contains text in a language different from that of your operating system, choose the corresponding option from the Select code page list box to ensure that object names, keywords, and notes are correctly displayed.
These options are not available for all file formats.

5 Click **Import**, and do one of the following:

- Click the drawing page to maintain the dimensions of the file and position its top-left corner where you click.
- Drag on the drawing page to resize the file. The import cursor displays the dimensions of the resized file as you drag on the drawing page.
- Press **Enter** to center the file on the drawing page.
- Press the **Spacebar** to place the file in the same position as it was in the original file (CDR and AI files only).

Active snapping options are applied to the imported file.

You can also

**Link to a bitmap externally instead of embedding it**

Click the arrow on the **Import** button, and then click **Import as externally linked image**.

If you want to display a list of the linked images, click **Window ➤ Dockers ➤ Sources**.

**Link to a high-resolution file for Open Prepress Interface (OPI) output**

Click the arrow on the **Import** button, and then click **Import as high-resolution file for output using OPI**.

This procedure inserts a low-resolution version of a TIFF or Scitex® Continuous Tone (CT) file into a document. The low-resolution version is linked to the high-resolution image, which resides on an Open Prepress Interface (OPI) server.

**Merge layers in an imported bitmap**

Enable the **Combine multi-layer bitmap** check box.

**Save the embedded International Color Consortium (ICC) profile**

Enable the **Extract embedded ICC profile** check box to save the ICC profile to the color folder where the application is installed.

This option is not available for all file formats.

**Check for watermark or copyright information**

Enable the **Check for watermark** check box.

This option is not available for all file formats.

**Use the default settings for the filter instead of opening the dialog box**

Enable the **Do not show filter dialog** check box.

This option is not available for all file formats.

**Preserve layers and pages in an imported file**

Enable the **Maintain layers and pages** check box. If you disable the check box, all layers are combined into a single layer.

This option is not available for all file formats.

**Select the pages to import when importing multi-page TIFF documents**

In the **Import TIFF** dialog box, enable an option in the **Select the page(s) to import** area.

This option is available only for the TIFF file format.
You can also

Open only part of an image In the Load partial file dialog box, type the range of frames to open in the Load frames box.

Not all importing options are available for all file formats.

You can import multiple files. Hold down Shift and click to select consecutive files in a list. Hold down Ctrl and click to select non-consecutive files.

To import an externally linked file
1 Click Window ➤ Dockers ➤ Sources.
2 Click the Add linked file button at the bottom of the Sources docker.
3 Browse to the drive and folder where the file is stored.
4 Click Import.
5 Click in the workspace to place the file.

To work with externally linked files
1 Click Window ➤ Dockers ➤ Sources.
2 In the Sources docker, click a linked file.
3 Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the source of a linked file</td>
<td>Click the Open source file button</td>
</tr>
<tr>
<td>Sync a linked file with the latest version of its source</td>
<td>Click the Sync linked file button</td>
</tr>
<tr>
<td>Break the link to the source file</td>
<td>Click the Break link button</td>
</tr>
</tbody>
</table>

To resample a bitmap while importing
1 Click File ➤ Import.
2 Choose the folder where the image is stored.
   If necessary, you can search for an image by using the search box. You can search for such things as file name, title, subject, author, keyword, comment, bitmap name, object name, and so on.
3 Choose a file format from the list box beside the File name box.
If you don’t know the file’s format, choose All file formats.

4 Click the file name.

5 Click the arrow next to the Import button, and then click Resample and load.

6 In the Resample image dialog box, type values in any of the following boxes:
   • Width — specifies the width of the graphic in a chosen unit of measure or as a percentage of its original width
   • Height — specifies the height of the graphic in a chosen unit of measure or as a percentage of its original height

7 In the Resolution area, type values in the following boxes:
   • Horizontal — lets you specify the horizontal resolution of the graphic in pixels or dots per inch (dpi)
   • Vertical — lets you specify the vertical resolution of the graphic in pixels or dots per inch (dpi)

8 Click the drawing page.

You can also

Maintain the width-to-height ratio of the image
   Enable the Maintain aspect ratio check box.

Change the unit of measure
   Choose a unit type from the Units list box.

Maintain equal horizontal and vertical resolution values automatically
   Enable the Identical values check box.

If a dialog box for the import format opens, specify the options you want. For detailed information about file formats, see “Supported file formats” on page 911.

Not all importing options are available for all file formats.

To crop a bitmap while importing

1 Click File ➤ Import.

2 Choose the folder where the image is stored.
   If necessary, you can search for an image by using the search box. You can search for such things as file name, title, subject, author, keyword, comment, bitmap name, object name, and so on.

3 Choose a file format from the list box beside the File name box.
   If you don’t know the file’s format, choose All file formats.

4 Click the file name.

5 Click the arrow next to the Import button, and click Crop and load.

6 In the Crop image dialog box, type values in any of the following boxes:
   • Top — specifies the area to remove from the top of the graphic
   • Left — specifies the area to remove from the left edge of the graphic
   • Width — specifies the width of the graphic that you want to keep
   • Height — specifies the height of the graphic that you want to keep

7 Click the drawing page.

   You can also resize a graphic by dragging the selection handles in the preview window.
   You can change the unit of measure by choosing a unit type from the Units list box in the Crop image dialog box.
Export files

You can use the File ▶ Export command to export files to a variety of bitmap and vector file formats that can be used in other applications. For example, you can export a file to the Adobe Illustrator (AI) or JPG format. You can also export a file so that it is optimized for use with a suite of office productivity applications, such as Microsoft Office or Corel WordPerfect Office.

The Export docker lets you simultaneously export assets in your document to multiple files. You can export one or more objects and pages, or a group of objects to a variety of file formats. For more information, see “Export objects and pages” on page 891.

When you are exporting a file, the original file is left open in the drawing window in its existing format.

You can use the File ▶ Save as command to save files to various vector formats. After you save a file to a different format, the saved file is displayed immediately in the drawing window. It is recommended that you first save the file as a CorelDRAW (CDR) file because some file formats do not support all of the features found in a CorelDRAW file.

When you export a file to the PNG, JPEG, GIF, WEBP, and PDF formats, you can crop your artwork to the boundaries of the drawing page to remove unwanted objects and reduce file size. Any parts of an object that fall outside the page will appear cropped in the exported file.

To export a file

1. Click File ▶ Export.
2. Choose the folder where you want to save the file.
3. Choose a file format from the Save as type list box.
4. Type a file name in the File name list box.
5. Enable any of the following check boxes:
   - Export this page only — exports only the current page in a multipage file
   - Export pages to separate files — exports each page in a multipage file to a separate file
   - Selected only — saves only the objects selected in the active drawing
   - Do not show filter dialog — suppresses dialog boxes that offer more advanced exporting options
   - Crop to page on export — crops your artwork to the boundaries of the drawing page
   These options are not available for all file formats.
6. Click Export.
   If a dialog box for the export format opens, specify the options you want. For detailed information about file formats, see “Supported file formats” on page 911.

You can also

Compress a file on export

Choose a compression type from the Compression type list box.

Specify information about a file

Type any comments you want in the Notes box.

Not all of the options or compression types in the Export dialog box are available for all file formats. Objects on a hidden layer are displayed in the exported file unless the printing and exporting function for the hidden layer is disabled. For information about the options available when you export to a bitmap file format, see “To convert a vector graphic to a bitmap when exporting” on page 768.

If you are using an expired trial version, you will not be able to export files.
You can specify which layers will appear in the exported file. For more information, see “To enable or disable printing and exporting of a layer” on page 380.

To export a file to Microsoft Office or WordPerfect Office

1 Click File ➤ Export For ➤ Office.
2 From the top list box, choose the office productivity suite to which the file will be exported:
   • Microsoft Office — lets you set options to meet the output requirements of Microsoft Office applications
   • WordPerfect Office — optimizes the image for Corel WordPerfect Office by converting it to a WordPerfect Graphics file (WPG)
3 If you chose Microsoft Office, choose the option that best suits how you intend to use the file from the middle list box:
   • Compatibility — lets you save the drawing as a Portable Network Graphic (PNG) bitmap. This preserves the appearance of the drawing when you import it into an office application.
   • Editing — lets you save the drawing in the Extended Metafile Format (EMF). This retains most of the editable elements in vector drawings.
4 If you chose Microsoft Office and Compatibility, choose an optimization option from the Optimized for list box:
   • Presentation — lets you optimize the file for outputs such as slide shows or online documents (96 dpi)
   • Desktop printing — lets you maintain good image quality for desktop printing (150 dpi)
   • Commercial printing — lets you optimize the file for high-quality printing (300 dpi)
   An estimated file size appears in the lower-left corner of the dialog box.
5 Click OK.
6 Locate the folder in which you want to save the file.
7 Type a file name in the File name list box.
8 Click Save.

You can also

Zoom in and out in the preview window
Using the Zoom in or Zoom out tool, click in the preview window.

Pan to view another area of the drawing
Using the Pan tool, drag in the preview window until the area that you want to see becomes visible.

The optimization options are available only if you choose the Microsoft Office and Compatibility options.

Layers in a drawing are flattened when exported to Microsoft Office or Corel WordPerfect Office.

To save a file to a different format

1 Click File ➤ Save As.
2 Choose the folder where you want to save the file.
3 Choose a file format from the Save as type list box.
4 Type a file name in the File name list box.
5 Enable any of the following check boxes:
   • Selected only — saves only the objects selected in the active drawing
• **Save with embedded VBA project** — lets you save, with the file, macros you have created in the VBA editor
  
  These options are not available for all file formats.

6  

**Click Save.**

You can also:

- **Specify information about a file**
  - Type any comments you want in the **Add comments** box.

- **Add keywords**
  - Type any keywords you want in the **Add a tag** box.

### Export objects and pages

CorelDRAW lets you manage and export assets using the Export docker. You can export one or more objects and pages, or a group of objects to the PDF, JPEG, PNG, SVG, EPS, TIFF, GIF, BMP, CGM, PSD, WEBP, CDR, AI, DWG, and DXF formats.

To export an object, you must select it in the document and add it to the Export docker. You can also select multiple objects or pages and add them to the export list with a single click; each asset will appear as a separate entry in the list. For more information about selecting objects, see “**Select objects**” on page 302. For information on selecting pages, see “**Select and activate pages**” on page 729.

You can remove a selected item from the export list, and you can select all items in the list and remove them at once.

By default, when you add an asset for export, the filename that appears in the export list is the same as the name of the object in the Objects docker (Object ➤ Objects). To change the filename of an export item, you can rename it in the Export docker. You can also add a suffix to the filename to make it more meaningful and descriptive. For example, if you are exporting the same design asset to different sizes, you can add a suffix to indicate the size.

You can export an asset multiple times with different settings. For example, to quickly export a logo to the JPEG and PDF formats, add the logo once, duplicate it in the export list, and then adjust the options you want.

CorelDRAW also lets you reuse export settings. For example, to export several designs of a banner with the same settings, add the first design to the list and specify the export options. Next, select the other versions and add them to the export list with a single click by using the export settings of the first design. Export settings are object-specific; if you delete an object from a document, the object is automatically removed from the Export docker, and you can no longer use the settings associated with this item.

In the Export docker, pages are listed first and are arranged in the order in which they appear in the document regardless of the sequence in which you add them for export. All objects are listed next in the order in which they appear in the Objects docker. For example, in a multipage document, objects on page 1 will be listed before objects on page 5.

### To manage export assets

- Perform a task from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an object to the export list</td>
<td>Select an object in the document window, and click <strong>File ➤ Export docker ➤ Add selection.</strong></td>
</tr>
<tr>
<td>Add the active page to the export list</td>
<td>Click <strong>File ➤ Export docker ➤ Add current page.</strong></td>
</tr>
<tr>
<td>To</td>
<td>Do the following</td>
</tr>
<tr>
<td>----</td>
<td>-----------------</td>
</tr>
<tr>
<td>Add multiple assets to the export list</td>
<td>Select multiple assets in the document window, and click <code>File &gt; Export docker &gt; Add selection</code>. Each asset is added as a separate item to the export list.</td>
</tr>
<tr>
<td>Add all pages to the export list</td>
<td>Click <code>File &gt; Export docker &gt; Add all pages</code>. You can separate the pages into unique export list items by clicking the <code>Options</code> button beside the entry and clicking <code>Separate pages</code>.</td>
</tr>
<tr>
<td>Add specific pages to the export list</td>
<td>Click <code>File &gt; Export docker &gt; Add all pages</code>. Click the <code>Options</code> button beside the entry, and enter specific pages, page ranges or both, separated by commas in the <code>Pages</code> box.</td>
</tr>
<tr>
<td>Remove an item from the export list</td>
<td>Click the <code>Delete</code> button beside the item you want to remove from the list.</td>
</tr>
<tr>
<td>Remove all items from the export list</td>
<td>Click the <code>Select all</code> button, and then click the <code>Delete</code> button at the bottom of the <code>Export docker</code>.</td>
</tr>
<tr>
<td>Duplicate an item in the export list</td>
<td>Click the <code>Options</code> button beside the item you want to duplicate, and click <code>Duplicate</code>.</td>
</tr>
<tr>
<td>Add an asset by reusing the settings of an item in the export list</td>
<td>In the document, select an asset. In the <code>Export docker</code>, click the <code>Options</code> button beside the entry whose settings you want to copy, and click <code>Add asset with these settings</code>.</td>
</tr>
<tr>
<td>Rename an asset</td>
<td>Click the name label, and enter a new name.</td>
</tr>
</tbody>
</table>

You can also open the `Export docker` by clicking `Window > Dockers > Export`. You can also add items to the export list by clicking the `Add` button at the bottom of the `Export docker`, and choosing an option.

**To export an asset**
1. Add an asset to the export list of the `Export docker`.
2. Choose a file format from the `File format` list box. If you want to make the filename more descriptive and meaningful, enter a suffix.
3. Click the `Destination folder` button, and browse to the drive and folder where you want to save the file.
4. Click the `Options` button, and click `Export Item`. 

892 | CorelDRAW User Guide
You can also

Export multiple items

In the Export docker, enable the Select Item check boxes beside the items that you want to export. Click Export.

Tip: To export all items in the list, click the Select all button, and then click Export.

Modify export settings

In the Export docker, click the Settings button, and specify the options you want.

Outline width and position impact object dimensions during export to bitmap formats. If the outline is centered on, or is outside of, the object’s edge, the exported object will have larger dimensions than those displayed in the Object size boxes on the property bar when the object is selected. To keep the exported object the same size as the one in your drawing, choose the Inside outline option in the Position area of the Properties docker. For more information, see “To specify line and outline settings” on page 175. Objects not aligned to an even number of pixels or text extending beyond its bounding box will also increase the dimensions on export to ensure all selected pixels in a document are exported.

The Export button is grayed out when there are no items selected.

To export linked groups, such as contours, blends, extrusions, shadows, and objects created with the Artistic media tool, first group the objects in the linked group, and then add the group to the Export docker. For example, if you want to export an object with an inner shadow, create a group from the object and the shadow, and then add the group to the Export docker. For information about how to group objects, see “To group objects” on page 356.

You can also duplicate a page and export it to a new document. For more information, see “To duplicate and export a page to a new document” on page 728.

To choose the default file format for new items

• From the Default file format list box at the bottom of the Export docker, choose a default file format.
Export to PDF

PDF is a file format designed to preserve fonts, images, graphics, and formatting of an original application file.

This section contains the following topics:
- “Export to PDF” (page 895)
- “PDF hyperlinks, bookmarks, and thumbnails” (page 898)
- “Comments in PDF files” (page 898)
- “Reduce PDF file size” (page 898)
- “Text and fonts in PDF files” (page 900)
- “Encode PDF files” (page 901)
- “View options for EPS files” (page 902)
- “PDF color management options” (page 902)
- “PDF security options” (page 903)
- “Optimize PDF files” (page 905)
- “PDF preflight summaries” (page 906)
- “Prepare PDF files for a print provider” (page 906)

Export to PDF

You can export a document as a PDF file. A PDF file can be viewed, shared, and printed on any platform provided that users have Adobe Acrobat, Adobe Reader, or a PDF-compatible reader installed on their computers. A PDF file can also be uploaded to an intranet or the web. You can also export an individual selection or an entire document to a PDF file.

When you export a document as a PDF file, you can choose from several PDF presets, which apply specific settings. For example, with the Web preset, the resolution of the images in the PDF file is optimized for the web.

You can also create a new PDF preset or edit any existing preset. PDF file security settings are not saved with a PDF preset. For information about PDF file security options, see “PDF security options” on page 903.

If you have used symbols in a document, they will be supported in the PDF file. For more information on symbols, see “Symbols” on page 383.

To export a document as a PDF file
1. Click File ➤ Publish to PDF.
You can also save a PDF file by clicking the Publish to PDF button on the Standard toolbar.

2 Locate the folder in which you want to save the file.

3 Type a filename in the File name box.

4 Choose one of the following options from the PDF preset list box:
   • Archiving (CMYK) — creates a PDF/A-1b file, which is suitable for archiving purposes. In comparison to traditional PDF files, PDF/A-1b files are better suited for long-term preservation of documents because they are more self-contained and more device-independent. PDF/A-1b files include embedded fonts, device-independent color, and their own description as XMP metadata. This PDF style preserves any spot or Lab colors included in the original document, but it converts all other colors, such as grayscale or RGB, to the CMYK color mode. In addition, this style embeds a color profile to specify how CMYK colors should be interpreted on the rendering device.
   • Archiving (RGB) — similarly to the previous style, creates a PDF/A-1b file, preserving any spot and Lab colors. All other colors are converted to the RGB color mode.
   • Current proof settings — applies the proofing color profile to the PDF
   • Document distribution — creates a PDF file that can be printed on a laser or desktop printer and is suitable for general document delivery. This style enables JPEG bitmap image compression and can include bookmarks and hyperlinks.
   • Editing — creates a high-quality PDF file intended to be sent to a printer or digital copier. This style enables LZW compression, embeds fonts, and includes hyperlinks, bookmarks, and thumbnails. It displays the PDF file with all the fonts, with all of the images at full resolution, and with hyperlinks, so that you can edit the file at a later date.
   • PDF/X-1a — enables ZIP bitmap image compression, converts all objects to the destination CMYK color space
   • PDF/X-3 — This style is a superset of PDF/X-1a. It allows both CMYK and non-CMYK data (such as Lab or Grayscale) in the PDF file.
   • Prepress — enables ZIP bitmap image compression, embeds fonts, and preserves spot color options best designed for high-end quality printing. Before preparing a PDF file for printing, it’s always best to consult your print provider to find out which settings are recommended.
   • Web — creates a PDF file intended for online viewing, such as a PDF file to be distributed by email or published on the web. This style enables JPEG bitmap image compression, compresses text, and includes hyperlinks.

5 Click Settings.
   The PDF settings dialog box appears.

6 In the Export range area, enable one of the following options:
   • Current document — exports the current document
   • Documents — exports the documents that you specify
   • Selection — exports the objects that you have selected
   • Current page — exports the active page
   • Pages — exports the pages that you specify

7 In the Page size area, choose one of the following options:
   • Defined by document — applies the page size that is defined in the document
   • Defined by selected objects — allows the page size to be determined by the size of the objects on the page

8 Click OK.

9 Click Save.

If you want to create a PDF file for archiving purposes that conforms to the PDF/A-1b standards, embedding must be allowed for all the fonts in your document. To check for fonts that cannot be embedded, view the preflight summary of the PDF file. For more information about viewing summaries, see “To view the preflight summary for a PDF file” on page 906. You can substitute any fonts that cannot be embedded, or you can convert all text to curves by enabling the Export all text as curves check box on the Objects page of the Publish to PDF settings dialog box.

If the document contains a 3D model, click Settings in the Publish to PDF dialog box, and choose Acrobat 8.0 or higher from the Compatibility list box to ensure that the 3D model is interactive in PDF readers.

To check if a font can be embedded, you can view licensing information and embedding restrictions by using a free tool, such as the Font properties extension tool available on the Microsoft website.
To export multiple documents as a single PDF file
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   The PDF settings dialog box appears.
5. On the General tab, enable the Documents option from the Export range area.
6. Enable the check box for each document you want to save.
7. Click OK.
8. Click Save.

To create a PDF preset
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
5. In the PDF settings dialog box, specify any settings.
6. Click the General tab.
7. Click the Add PDF preset button next to the PDF preset list box.
8. Type a name for the style in the Save PDF preset as list box.
9. Click OK.
10. Click Save.

If you want to delete a PDF style, select the style and click the Delete PDF Preset button next to the PDF preset list box.

To edit a PDF preset
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
5. In the PDF settings dialog box, specify any settings.
6. Click the General tab.
7. Click the Add PDF preset button next to the PDF preset list box.
8. Choose the style you want to edit from the Save PDF preset as list box.
9. Click OK.
10. Click Save.

If you save changes you make to preset settings, the original settings will be overwritten. To avoid this, save any changes to preset settings with a new name.
PDF hyperlinks, bookmarks, and thumbnails

You can include hyperlinks, bookmarks, and thumbnails in a PDF file. Hyperlinks are useful for adding jumps to webpages or to Internet URLs. Bookmarks allow you to link to specific areas in a PDF file. You can specify whether bookmarks or thumbnails are displayed when the PDF file is first opened in Adobe Acrobat or Acrobat Reader.

For information about assigning hyperlinks and bookmarks, see “Bookmarks and hyperlinks” on page 879.

To include hyperlinks, bookmarks, and thumbnails in a PDF file

1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   The PDF settings dialog box appears.
5. Click the Document tab.
6. In the Bookmarks area, enable any of the following check boxes:
   - Include hyperlinks
   - Generate bookmarks
   - Generate thumbnails
   If you want to display bookmarks or thumbnails on startup, enable the Bookmarks or Thumbnails button in the On start area.
7. Click OK.
8. Click Save.

Comments in PDF files

If a document includes comments, you can exclude them from the exported PDF file or keep them. By default, some PDF presets, such as Prepress, Archiving, and PDF/X, exclude comments from PDF files; other presets, such as Document Distribution, Editing, and Web, include comments in PDF files.

To include or exclude comments

1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file, and type a filename.
3. Click Settings.
   The PDF settings dialog box appears.
4. Click the Document tab.
5. Enable or disable the Include comments check box.
6. Click OK.
7. Click Save.

Reduce PDF file size

You can compress bitmap images, text, and line art to reduce the size of a PDF file. Options for bitmap image compression include JPEG, LZW, and ZIP. Bitmap images that use JPEG compression have a quality scale ranging from 100% (high quality, less compression) to 1% (lower quality, more compression). The higher the image quality, the larger the file size.

You can also reduce the size of a PDF file by downsampling color, grayscale, or monochrome bitmap images.
Another way to reduce the file size of a PDF file is by excluding objects that don’t reside on the drawing page. Most PDF viewers don’t show such objects but information about them is stored in the PDF file, increasing its file size.

To set the bitmap compression in a PDF file

1. Click **File ➤ Publish to PDF**.
2. Locate the folder in which you want to save the file.
3. Type a filename in the **File name** box.
4. Click **Settings**.
   The **PDF settings** dialog box appears.
5. Click the **Objects** tab.
6. Choose one of the following from the **Compression type** list box:
   • **None**
   • **LZW**
   • **JPEG**
   • **ZIP**
   • **JP2**
7. Click **OK**.
8. Click **Save**.

   The **JP2** (JPEG 2000) option is available only for Adobe Acrobat 6.0, Adobe Acrobat 8.0, and Adobe Acrobat 9.0.

   If you choose **JPEG** compression, you can specify the compression quality by moving the **JPEG quality** slider.

To compress text and line art in a PDF file

1. Click **File ➤ Publish to PDF**.
2. Locate the folder in which you want to save the file.
3. Type a filename in the **File name** box.
4. Click **Settings**.
   The **PDF settings** dialog box appears.
5. Click the **Objects** tab.
6. Enable the **Compress text and line art** check box.
7. Click **OK**.
8. Click **Save**.

To downsample bitmap images in a PDF file

1. Click **File ➤ Publish to PDF**.
2. Locate the folder in which you want to save the file.
3. Type a filename in the **File name** box.
4. Click **Settings**.
   The **PDF settings** dialog box appears.
5. Click the **Objects** tab.
6. Enable any of the following check boxes, and type a value in the corresponding box:
• Color
• Grayscale
• Monochrome

7 Click OK.
8 Click Save.

Downsampling color, grayscale, or monochrome bitmap images is effective only when the resolution of the bitmap image is higher than the resolution specified in the Downsampling area.

To exclude objects that are outside the drawing page from a PDF file
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the General tab.
6 Enable the Export only objects on page check box.
7 Click OK.
8 Click Save.

All objects that reside only partially on the page, except text and mesh fill objects, will be cropped to remove areas that are outside the page.

Text and fonts in PDF files

You can determine how the text in your PDF file outputs by setting text and font options.

You can embed fonts in a PDF file. Embedding increases the file size but makes a PDF file more portable, since the fonts do not have to reside on other systems. When you embed base 14 fonts, the fonts are added to your PDF file, thus eliminating font variances on different systems. The base 14 fonts are resident on all PostScript devices.

You can also convert TrueType fonts to Type 1 fonts, which can increase file size if there are many fonts in a file. When you convert fonts, you can reduce file size by subsetting fonts if you use only a smaller number of characters (for example, English characters A to E). You can also include a percentage of fonts used. For example, you can create a subset that contains 50 percent of the fonts. If the number of characters used in the document exceeds 50 percent, the whole set of characters is embedded. If the number of characters used in the document is less than 50 percent, only the characters used are embedded.

You can also eliminate font variances on different computers by exporting text as curves. For example, if you are using unusual text characters, you can export the text as curves. Exporting text as curves increases the complexity of the file and can increase file size. For general document publication, embed fonts in a document rather than convert text to curves.

To embed fonts in a PDF file
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
The PDF settings dialog box appears.
5 Click the Objects tab.
6 Enable the Embed fonts in document check box.
   If you want to install the basic fonts to your PDF file, enable the Embed base 14 fonts check box.
7 Click OK.
8 Click Save.

Enabling the Embed base 14 fonts check box increases file size, and, therefore, it is not recommended for publishing to the web.

To convert TrueType fonts to Type 1 fonts
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the Objects tab.
6 Enable the Convert TrueType to Type 1 check box.
   If you want to reduce file size, you can create a subset of fonts by enabling the Subset fonts check box and typing a percentage of fonts used in the % box.
7 Click OK.
8 Click Save.

If you create a subset of fonts, some characters from the font may not be present in the file when editing the PDF file in Adobe Acrobat.

To export text as curves
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the Objects tab.
6 Enable the Export all text as curves check box.
7 Click OK.
8 Click Save.

Encode PDF files
ASCII and binary are encoding formats for documents. When you publish a file to PDF, you can choose to export ASCII or binary files. The ASCII format creates files that are fully portable to all platforms. The binary format creates smaller files, but they are less portable, because some platforms cannot handle the file format.
To specify an encoding format for a PDF file
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   The PDF settings dialog box appears.
5. Click the Document tab.
6. Enable one of the following options:
   • ASCII 85
   • Binary
7. Click OK.
8. Click Save.

View options for EPS files
EPS files are PostScript files that are embedded in a document. You can choose how encapsulated PostScript (EPS) files are viewed in a PDF document. The PostScript option includes high-resolution images in the PDF document but does not let you view them in Adobe Acrobat. The Preview option includes high-resolution images in the PDF file and displays their low-resolution bitmap representation in Adobe Acrobat.

To choose a viewing option for EPS files
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   The PDF settings dialog box appears.
5. Click the Objects tab.
6. Choose one of the following from the EPS files list box:
   • PostScript — includes high-resolution images in the PDF document but does not let you view them
   • Preview — includes high-resolution images in the PDF file and displays their low-resolution bitmap representation
7. Click OK.
8. Click Save.

PDF color management options
You can specify color management options for exporting files to PDF. You can choose a color profile or leave the objects in their original color space. You can also embed the color profile with the PDF.

If you have spot colors in your file, you can either preserve the spot colors or convert them to process colors so that the file produces four plates for CMYK output.

If you want to export to PDF for the purpose of soft-proofing the document, you can apply the document’s color proofing settings. In addition, you can choose additional soft-proofing options, such as preserving document overprints and overprinting black.

To specify color management options for exporting PDF files
1. Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the Color tab.
6 Enable the Use document color settings option.
7 Choose a color profile option from the Output color list box:
   • RGB
   • CMYK
   • Grayscale
   • Native
8 Click OK.
9 Click Save.

You can also

Apply proofing color profile to the PDF
   Enable the Use color proof settings option.

Convert all spot colors applied in the document to the chosen color profile
   Enable the Convert spot colors to check box.

Embed the color profile in the PDF
   Enable the Embed color profile check box.

Simulate how overprints appear, which is useful for soft-proofing the document
   In the Other color controls area, enable the Preserve document overprints check box.

Enable the overprinting of black
   In the Other color controls area, enable the Always overprint black check box.

If you choose the Native option from the Output color list box, a maximum of three color spaces are displayed, or embedded, in the PDF file.

PDF security options

You can set security options to protect PDF files that you create. Security options let you control whether, and to what extent, a PDF file can be accessed, edited, and reproduced when viewed in Adobe Reader.

The level of security that is available is also determined by which version of Adobe Reader you use to create the PDF file. The encryption levels provided by Adobe Reader have increased over time. For example, if you save to Adobe Reader version 6, or lower, it has standard encoding, version 8 has 128-bit encoding, and version 9 has 256-bit encoding. For more information about choosing a version, see “Optimize PDF files” on page 905.
The security options are controlled by two passwords: the Permission password and the Open password.

The Permission password is the master password that lets you control whether a file can be printed, edited, or copied. For example, as the owner of the file, you can protect the integrity of the file’s content by choosing permission settings that prevent editing.

You can also set an Open password that lets you control who can access the file. For example, if your file contains sensitive information, and you want to limit the users who can view it, you can set an Open password. It is not recommended that you set an Open password without setting a Permission password, because users would then have unrestricted access to the PDF file — including the ability to set a new password.

The security options are applied when you save the PDF file. These settings can be viewed when a PDF file is opened in Adobe Acrobat.

To open and edit a secured PDF file, you must enter the Permissions password (or the Open password if no Permission password is set). For information about opening and importing PDF files, see “Adobe Portable Document Format (PDF)” on page 934.

To set PDF file permissions
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   The PDF settings dialog box appears.
5. Click the Security tab.
6. Enable the Permission password check box.
7. Type a password in the Password box.
8. Retype the password in the Confirm password box.
9. In the Printing permissions box, choose one of the following options:
   • None — lets users view the PDF on-screen but prevents them from printing the PDF file
   • Low resolution — lets users print a low resolution version of the PDF file. This option is available for PDF files compatible with Adobe Acrobat 5 or higher.
   • High resolution — lets users print a high resolution version of the PDF file
10. In the Editing permissions box, choose one of the following options:
    • None — prevents users from editing the PDF file
    • Insert, delete, and rotate pages — lets users insert, delete, and rotate pages when editing the PDF file. This option is available for PDF files compatible with Adobe Acrobat 5 or higher.
    • Any except extracting pages — lets users edit the PDF file but prevents them from removing pages from the file
    If you want to allow copying of content from the PDF file to other documents, enable the Enable copying of content check box.
11. Click OK.
12. Click Save.

The Permission password is the master password for the document. It can be used by the file owner to set permissions, or to open the file if an Open password is set.

Some PDF compatibility options, such as PDF/X-3 and PDF/A-1b, do not let you set PDF file permissions. If you choose such a compatibility option, all controls on the Security page appear disabled. To change the compatibility, see “To select a compatibility option” on page 905.

To set a user password for a PDF file
1. Click File ➤ Publish to PDF.
2. Locate the folder in which you want to save the file.
3 Type a filename in the File name box.

4 Click Settings.
   The PDF settings dialog box appears.

5 Click the Security tab.

6 Enable the Open password check box.

7 Type a password in the Password box.

8 Retype the password in the Confirm password box.

9 Click OK.

10 Click Save.

   If you set an Open password, it is recommended that you also set a Permission password.

Optimize PDF files

You can optimize PDF files for different versions of Adobe Acrobat or Acrobat Reader by choosing a compatibility option that matches the type of viewer used by the recipients of the PDF file. In CorelDRAW, you can select one of the following compatibility options: Acrobat 4.0, Acrobat 5.0, Acrobat 6.0, Acrobat 8.0, Acrobat 9.0, PDF/X-1a, PDF/X-3, or PDF/A-1b. The available controls differ, depending on which compatibility option you choose. If you are publishing a PDF file for a wide distribution, it is better to choose an earlier compatibility option such as Acrobat 8.0 or 9.0 to ensure that the file can be viewed in earlier versions of Acrobat. However, if security is a concern, you may want to choose a later version because the encryption levels are higher. For more information, see “PDF security options” on page 903.

You can optimize the viewing of a PDF document on the web to speed up the loading time of the PDF.

If you added complex fills to the document, you can choose to convert them to bitmaps, which is also known as rasterizing. This may increase the PDF file size, but it will ensure that the complex fills display correctly.

To select a compatibility option

1 Click File ➤ Publish to PDF.

2 Locate the folder in which you want to save the file.

3 Type a filename in the File name box.

4 Click Settings.
   The PDF settings dialog box appears.

5 Click the General tab.

6 From the Compatibility list box, choose a compatibility option.

   To preserve layers and layer properties in the published PDF file, you must choose the Acrobat 6.0, Acrobat 8.0, or Acrobat 9.0 option. Note that master layers will not be preserved.

   To preserve transparencies in the published PDF file, you must choose the Acrobat 5.0, Acrobat 6.0, Acrobat 8.0, or Acrobat 9.0 option.

To optimize a PDF file for viewing on the web

1 Click File ➤ Publish to PDF.

2 Locate the folder in which you want to save the file.

3 Type a filename in the File name box.

4 Click Settings.
The PDF settings dialog box appears.

5 Click the Document tab.
6 Enable the Optimize for web check box.

To convert complex fills to bitmaps
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the Objects tab.
6 Enable the Render complex fills as bitmaps check box.

PDF preflight summaries
Before saving a document as a PDF file, you can preflight your document to find potential problems. Preflighting checks and displays a summary of errors, possible problems, and suggestions for resolving issues. By default, many PDF issues are checked during a preflight, but you can disable the issues that you do not want to check.

To view the preflight summary for a PDF file
1 Click File ➤ Publish to PDF.
2 Locate the folder in which you want to save the file.
3 Type a filename in the File name box.
4 Click Settings.
   The PDF settings dialog box appears.
5 Click the Preflight tab.
   If there are no print job issues, the tab name displays as No issues. If there are issues, the tab name displays the number of issues that were found.

   You can limit the issues to check during the preflight by clicking the Preflight tab, clicking the Settings button ➤, and, in the Preflight settings dialog box, disabling the check boxes next to the items that you want the preflight to overlook.

You can save settings by clicking the Add preflight settings button ➤ and typing a name in the Save preflight style as box.

Prepare PDF files for a print provider
Open Prepress Interface (OPI) lets you use low-resolution images as placeholders for the high-resolution images that appear in your final work. When a print provider receives your file, the OPI server substitutes the low-resolution images with the high-resolution images.

Printers’ marks provide information to the print provider about how the work should be printed. You can specify which printers’ marks to include on the page. The available printers’ marks are as follows:

• Crop marks — represent the size of the paper and appear at the corners of the page. You can add crop marks to use as guides in trimming the paper. If your output has multiple pages per sheet (for example, two rows by two columns), you can add the crop marks on the outside edge of the page so that all crop marks are removed after the cropping process, or you can choose to add crop marks around each row and column. A bleed determines how far an image can extend beyond the crop marks. A bleed requires that the paper
you are printing on is larger than the size of paper you ultimately want, and the image area must extend beyond the edge of the final paper size.

- **Registration marks** — are required to line up the film, analog proofs, or print plates on a color press. Registration marks print on each sheet of a color separation.
- **Densitometer scale** — is a series of gray boxes ranging from light to dark. These boxes are required to test the density of halftone images. You can position the densitometer scale anywhere on the page. You can also customize the levels of gray that appear in each of the seven squares on the densitometer scale.
- **File information** — can be printed, including the color profile; name, date, and time the image was created; and page number.

**To maintain OPI links in a PDF file**

1. Click File ➔ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   - The PDF settings dialog box appears.
5. Click the Prepress tab.
6. Enable the Maintain OPI links check box.

Don’t use OPI links if you are not sure whether your PDF file is destined for an OPI server.

**To include printers’ marks in a PDF file**

1. Click File ➔ Publish to PDF.
2. Locate the folder in which you want to save the file.
3. Type a filename in the File name box.
4. Click Settings.
   - The PDF settings dialog box appears.
5. Click the Prepress tab.
6. Enable any of the following check boxes:
   - Crop marks
   - File information
   - Registration marks
   - Densitometer scales

If you want to include a bleed, enable the Bleed limit check box, and type a bleed amount in the corresponding box.

Usually, a bleed amount of 0.125 to 0.25 inch is sufficient. Any object extending beyond this amount uses space needlessly and may cause problems when you print multiple pages with bleeds on a single sheet of paper.
Work with office productivity applications

CorelDRAW is highly compatible with office productivity applications such as Microsoft Word and WordPerfect Office. You can import and export files between applications, and you can copy or insert objects from CorelDRAW into office productivity documents.

This section contains the following topics:

• “Import files from office productivity applications” (page 909)
• “Export files to office productivity applications” (page 909)
• “Add objects to documents” (page 909)

Import files from office productivity applications

CorelDRAW lets you import files created in other applications. For example, you can import a file from a Microsoft Office or WordPerfect Office application. For more information about importing files, see “WordPerfect Document (WPD)” on page 948 and “Microsoft Word (DOC, DOCX, and RTF) technical notes” on page 920.

Export files to office productivity applications

You can export a file so that it is optimized for use with office productivity applications such as Microsoft Word or WordPerfect. For more information about exporting files from CorelDRAW, see “To export a file to Microsoft Office or WordPerfect Office” on page 890.

Add objects to documents

CorelDRAW lets you copy an object and paste it into a drawing. You can also copy an object and place it into a document created in an office productivity application such as Microsoft Word or WordPerfect. For more information about copying objects, see “Copy, duplicate, and delete objects” on page 311. You can insert an object into a CorelDRAW document, or into an office productivity document, such as a Microsoft Word or WordPerfect document. For more information about inserting objects into CorelDRAW, see “Creative tools and content” on page 107. For information about inserting objects into office productivity documents, see “Insert linked or embedded objects” on page 365, or see the office productivity application’s Help.
Supported file formats

A file format defines how an application stores information in a file. If you want to use a file created in a different application than the one you are currently using, you must import that file. Conversely, if you create a file in one application and want to use it in another application, you must export the file to a different file format.

When you name a file, an application automatically appends a filename extension, usually three characters in length (for example, .cdr, .bmp, .tif, and .eps). This filename extension helps you and the computer differentiate between files of different formats.

The following list includes all file formats used in this application. Note that not all file format filters are installed by default. If you cannot export or import a file from the list, you need to update your installation of CorelDRAW Graphics Suite. For more information, see "Modify and repair installations" on page 25.

- "Adobe Illustrator (AI)" (page 912)
- "Adobe Type 1 Font (PFB)" (page 914)
- "Windows Bitmap (BMP)" (page 915)
- "OS/2 Bitmap (BMP)" (page 916)
- "Computer Graphics Metafile (CGM)" (page 916)
- "CorelDRAW (CDR)" (page 917)
- "Corel Presentation Exchange (CMX)" (page 917)
- "Corel PHOTO-PAINT (CPT)" (page 918)
- "Corel Symbol Library (CSL)" (page 918)
- "Cursor Resource (CUR)" (page 919)
- "Microsoft Word (DOC, DOCX, or RTF)" (page 919)
- "Microsoft Publisher (PUB)" (page 921)
- "Corel DESIGNER (DES, DSF, DS4, or DRW)" (page 921)
- "AutoCAD Drawing Database (DWG) and AutoCAD Drawing Interchange Format (DXF)" (page 922)
- "Encapsulated PostScript (EPS)" (page 924)
- "PostScript (PS or PRN)" (page 928)
- "GIF" (page 929)
- "High Efficiency Image File Format (HEIF)" (page 929)
- "JPEG (JPG)" (page 930)
- "JPEG 2000 (JP2)" (page 930)
- "Kodak Photo CD Image (PCD)" (page 932)
- "PICT (PCT)" (page 933)
- "PaintBrush (PCX)" (page 933)
- "Adobe Portable Document Format (PDF)" (page 934)
Adobe Illustrator (AI)

The Adobe Illustrator (AI) file format was developed by Adobe Systems, Incorporated for the Macintosh and Windows platforms. It is primarily vector-based, although later versions support bitmap information.

You can import AI files for use in CorelDRAW or export CorelDRAW files to the AI file format. Before exporting a document as an AI file, you can preflight your document to find potential problems. Preflighting checks and displays a summary of errors, possible problems, and suggestions for resolving issues. By default, many AI issues are checked during a preflight, but you can disable the issues that you do not want to check.

To import an Adobe Illustrator file
1. Click File > Import.
2. Locate the folder in which the file is stored.
3. Click the filename.
4. Click Import.
5. Click in the drawing page where you want to import the file.

To export an Adobe Illustrator file
1. Click File > Export.
2. Locate the folder in which you want to save the file.
3. Choose AI - Adobe Illustrator from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. From the Compatibility list box, choose an Adobe Illustrator file format.
7. In the Export range area, enable one of the following options:
   - Current document — exports the active drawing
   - Current page — exports the active page
- Selection — exports the objects that you have selected
- Pages — exports the pages that you specify (This option is only available for CS 4 and later versions.)

In the Export text as area, enable one of the following options:
- Curves — lets you export text as curves
- Text — lets you export text as editable characters

You can also

Convert transparent areas to bitmaps

In the Transparency area, enable the Preserve appearance and convert transparent areas to bitmaps option.

(This option is only available for version 8 and lower.)

Discard transparent areas and preserve curves and text

In the Transparency area, enable the Preserve curves and text by removing transparent effects option.

(This option is only available for version 8 and lower.)

Convert an outline to an object to create an unfilled closed object with the outline’s shape

In the Options area, enable the Convert outlines to objects check box.

Convert complex outlines to curves

In the Options area, enable the Simulate complex filled curves check box.

Convert spot colors to process colors

In the Options area, enable the Convert spot colors to CMYK check box.

Embed the color profile

In the Options area, enable the Embed color profiles check box.

Generate a preview of the document in the Adobe Illustrator File open dialog box

In the Options area, enable the Include preview images check box.

If you enable the Simulate complex filled curves check box, an object that is composed of complex curves, such as a text object that was converted to curves, may be broken into several objects on export to help minimize the complexity of the object.

If you disable the Include placed images check box and export the file, the exporting process generates one Adobe Illustrator file and a series of EPS files. The EPS files contain individual objects and images which are linked to the AI file. Always store the EPS files with the AI file to preserve the link to the AI file.

To view the preflight summary for an AI file

1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose AI - Adobe Illustrator from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
In the Adobe Illustrator Export dialog box, click the second tab. You can limit the issues to check during the preflight by clicking the Settings button, double-clicking AI Export, and disabling the check boxes next to the items that you want the preflight to overlook.

You can save settings by clicking the Add preflight settings button and typing a name in the Save preflight style as box.

Adobe Illustrator (AI) technical notes

Importing an AI file

- You can import AI file formats up to and including Adobe Illustrator CS6.
- For files saved in Adobe Illustrator CS or higher with PDF-compatibility, text can be imported as text or curves.
- Objects with gradient fills that were created in CS5 may not appear correctly when imported.
- Corel programs cannot import AI files containing bitmaps linked as EPS files.
- Adobe Illustrator graphics are imported into the program as a group of objects. Click Object ➤ Group ➤ Ungroup to manipulate objects in the imported graphic. If you open an AI file instead of importing it, you do not need to ungroup objects.
- Flash movies embedded in AI files are not imported.
- For AI CS4, CS5, and CS6 files, each Artboard is imported as an individual CorelDRAW page. In multi-page documents, objects that are placed off a page are placed on the first page of the CorelDRAW document.
- Objects filled by using Global Colors (color schemes) appear correctly in CorelDRAW, but the Global Colors are not maintained as color styles.
- Symbols, objects with patterns, and objects that have 3d extrude or bevel applied are converted as curves.
- Objects that have the Feather or Transparency effect applied are converted using the applicable lens effect in CorelDRAW.
- Objects that have the texture, drop shadow, blur, or brushstroke effect applied are converted as bitmap objects in CorelDRAW.

Exporting an AI file

- During export conversion, objects can become complex, making it difficult to edit them in other drawing programs or in CorelDRAW if you reimport them. To avoid this problem, save the file to the CorelDRAW (CDR) format before exporting it, and use CorelDRAW for all editing.
- If you create a file that will be printed in other programs, such as Adobe PageMaker, export it using the Encapsulated PostScript (EPS) filter, not the Adobe Illustrator (AI) filter. The Encapsulated PostScript filter supports more drawing effects than the Adobe Illustrator filter does and yields better results overall.
- Most linear and radial fountain fills are preserved. Conical and square fountain fills are exported as a series of filled bands, an effect similar to that achieved by blending. You can set the number of bands by clicking Tools ➤ Options ➤ CorelDRAW. Click Display, and type a number in the Preview fountain steps box. The maximum number of bands supported is 256.
- You can export text as text when you are exporting AI files from versions CS and later.
- When exporting multi-page CorelDRAW files to CS4 or later version, individual pages are exported as Artboards. The Arrange by row format is used for the layout of the Artboards.
- When exporting multi-page CorelDRAW files to CS4 or later version, objects that are placed off of the page are removed.
- Some OpenType features are not supported by Adobe Illustrator.

Adobe Type 1 Font (PFB)

The Adobe Type I Font (PFB) is a file format that stores Adobe Type 1 fonts. Most Type 1 fonts are single master fonts that permit only style editing; for example, Roman, italic, bold. A single master Type 1 font contains two files: a Printer Font Metrics (PFM) file and a Printer Font Binary (PFB) file.

Some Type 1 fonts are also available in multiple master format. You can customize design elements of multiple master fonts such as weight, width, style, and optical size. A multiple master base font is the multiple master font itself, from which you create variations called multiple master instances. A multiple master base font is composed of a PFM file, a PFB file, and a Multiple Master Metrics (MMM) file. A multiple master instance is composed of a PFM file and a PostScript Printer Stub (PSS) file.
Adobe Type 1 Fonts technical notes

• Adobe Type 1 fonts exported from CorelDRAW are unhinted.
• Each exported character constitutes a single object. Before you export multiple objects, you must combine them by clicking **Object > Combine**. You cannot export multiple objects or grouped objects.
• For best results, avoid intersecting lines. Any object in your character should lie completely inside or outside of others, as shown in the following example.

![Correct and Incorrect Examples](image)

*Left to right: three objects correctly combined; five objects correctly combined; five objects incorrectly combined*

• Fill and outline attributes applied to objects are not exported.
• Adobe Type 1 fonts you create are compatible with Adobe Type Manager version 2.0, but not with earlier versions.

Windows Bitmap (BMP)

The Windows **bitmap** (BMP) file format was developed as a standard for representing graphic images as bitmaps on the Windows operating system.

To import a bitmap file

1. Click **File > Import**.
2. Locate the folder in which the file is stored.
3. Choose **BMP - Windows bitmap (*.bmp; *.dib; *.rle)** from the list box next to the **File name** box.
4. Click the filename.
5. Click **Import**.
6. Click the drawing page.

To export a bitmap file

1. Click **File > Export**.
2. Locate the folder in which you want to save the file.
3. Choose **BMP - Windows bitmap** from the **Save as type** list box.
4. Type a filename in the **File name** list box.
5. Click **Export**.
6. In the **Convert to bitmap** dialog box, adjust the width, height, resolution, color mode, or any of the other settings.
Windows Bitmap (BMP) technical notes

Importing a BMP file
- You can import Windows Bitmap files conforming to the Windows and OS/2 BMP specifications.
- Windows Bitmap files may be black-and-white, 16 colors, grayscale, paletted, or RGB color (24-bit), and print accordingly, depending on your printer.
- Run-length encoding (RLE) compression may be used on all bitmaps, except RGB color (24-bit), and black-and-white bitmaps.
- The resolution ranges from 72 to 300 dpi, or higher if you choose custom settings.
- The maximum image size is 64,535 × 64,535 pixels.

Exporting a BMP file
- Because raster images such as bitmaps are mapped pixel by pixel to the page, the resolution does not increase. Instead, your bitmap appears jagged, with an apparent loss of resolution.

OS/2 Bitmap (BMP)

This type of bitmap file is designed for the OS/2 operating system. The OS/2 Bitmap file format supports a maximum image size of 64,535 × 64,535 pixels. OS/2 uses Run-length encoding (RLE) compression.

OS/2 Bitmap (BMP) technical notes
- Corel programs support Standard Version 1.3 and Enhanced Version 2.0, or later versions of the OS/2 Bitmap file format.
- Corel programs support the following color depths when importing and exporting BMP files: 1-bit black and white, 256 shade (8-bit) grayscale, 16-color (4-bit) and 256-color (8-bit) paletted, and 24-bit RGB.

Computer Graphics Metafile (CGM)

Computer Graphics Metafile (CGM) is an open, platform-independent metafile format used for storing and exchanging two-dimensional graphics. It supports RGB color. CGM files can contain both vector graphics and bitmaps, but they usually contain one graphic type or the other — rarely both.

CorelDRAW imports CGM Version 1, 3, and 4 files and exports version 1, 3, and WebCGM 1.0 profile files.

WebCGM is a binary file format that supports hyperlinks, document navigation, picture structuring and layers, as well as searching on WebCGM picture contents. It also supports Unicode and web fonts. The WebCGM profile is used widely in web electronic documents.

To import a CGM file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose CGM - Computer Graphics Metafile (*.cgm) from the list box next to the File name box.
4. Click the filename.
5. Click Import.

To export a CGM file
1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose CGM - Computer Graphics Metafile from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
In the CGM export dialog box, choose a version from the Version list box.

**Computer Graphics Metafile (CGM) technical notes**

**Importing a CGM file**
- CorelDRAW can import CGM Version 1, 3 and 4 files.
- The CGM filter accepts only markers supported by the CGM file format standard. Private-use markers are ignored.
- Text is editable, provided the file is exported from the source program with the correct text options specified. The typeface you see may not correspond to the one used in the source program; however, you can easily correct the typeface in the Corel program.
- If the CGM file contains a font that is not on your computer, the PANOSE font-matching dialog box lets you replace the font with an available one.

**Exporting a CGM file**
- CorelDRAW can export version 1 and 3 CGM as well as WebCGM 1.0 files.
- CGM files can be saved in text or binary format provided the selected profile supports text encoding. Text-encoded files can be opened in an ASCII text editor.
- PostScript textures are converted to curves.

**CorelDRAW (CDR)**

CorelDRAW (CDR) files are primarily vector graphic drawings. Vectors define a picture as a list of graphic primitives (rectangles, lines, text, arcs, and ellipses). Vectors are mapped point by point to the page, so if you reduce or increase the size of a vector graphic, the original image will not be distorted.

Vector graphics are created and edited in graphics design applications, such as CorelDRAW, but you can also edit vector graphics in image-editing applications such as Corel PHOTO-PAINT. You can use vector images of various formats in desktop publishing programs.

To import a CorelDRAW file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose CDR - CorelDRAW (*.cdr) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

**CorelDRAW (CDR) technical notes**
- Imported CorelDRAW files appear as a group of objects. Click Object ➤ Group ➤ Ungroup to manipulate individual objects in the imported graphic.

**Corel Presentation Exchange (CMX)**

Corel Presentation Exchange (CMX) is a metafile format that supports bitmap and vector information and the full range of PANTONE, RGB, and CMYK colors. Files saved in CMX format can be opened and edited in other Corel applications.

To import a Corel Presentation Exchange file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose one of the following from the list box next to the File name box:
   - CMX - Corel Presentation Exchange — for files created in Corel Presentations X6 or later
To export a Corel Presentation Exchange file

1. Click **File ➤ Export**.
2. Locate the folder in which you want to save the file.
3. Choose one of the following from the **Save as type** list box:
   - **CMX - Corel Presentation Exchange** — for versions 16.0 or later
   - **CMX - Corel Presentation Exchange legacy** — for versions 15.0 or earlier
4. Type a filename in the **File name** list box.
5. Click **Export**.

**Corel Presentation Exchange (CMX) technical notes**

- The following versions are supported: 5, 6, 7, 8, 9, 10, 11, 12, X3, X4, X5, and X6.

---

**Corel PHOTO-PAINT (CPT)**

Files saved to the Corel PHOTO-PAINT (CPT) file format are **bitmaps** that represent shapes as **pixels** arranged to form an image. When you save a graphic to the Corel PHOTO-PAINT format, masks, floating objects, and lenses are saved with the image. CorelDRAW can import and export files in Corel PHOTO-PAINT format, including files that contain color and **grayscale** information.

To export a Corel PHOTO-PAINT file

1. Click **File ➤ Export**.
2. Locate the folder in which you want to save the file.
3. Choose **CPT - Corel PHOTO-PAINT image** from the **Save as type** list box.
4. Type a filename in the **File name** list box.
5. Click **Export**.
6. In the **Convert to bitmap** dialog box, adjust the width, height, resolution, color mode, or any of the other settings.

   ![Note]
   
   You can export CorelDRAW layers as objects in the CPT file format.
   
   You can export to an image with transparent background.

**Corel PHOTO-PAINT (CPT) technical notes**

- This filter is available in CorelDRAW, Corel PHOTO-PAINT, and Corel DESIGNER.
- Corel PHOTO-PAINT files may be **black-and-white**, **grayscale**, **paletted**, **CMYK color** (32-bit), **RGB color** (24-bit), or **Lab**.

---

**Corel Symbol Library (CSL)**

Corel Symbol Library (CSL) files store symbols that can be used in other files.

Corel Symbol Library (CSL) files can be stored locally or on a network, allowing easy deployment and management of symbol collections.

For more information, see “Symbol collections and libraries” on page 388.
Cursor Resource (CUR)

The Windows 3.x/NT Cursor Resource (.cur files) file format is used to create cursors for Windows 3.1, Windows NT, and Windows 95 interfaces. It supports cursor graphic elements that are used in Windows pointers. You can select a color for Transparent and Inverse masks.

The Windows 3.x/NT Cursor Resource file format supports a maximum image size of $32 \times 32$ pixels.

Cursor Resource (CUR) technical notes

- Corel programs support the following color depths when importing .cur files: 1-bit black-and-white, 16-color (4-bit) paletted, and 256-color (8-bit) paletted.

Microsoft Word (DOC, DOCX, or RTF)

You can import the following Microsoft Word files:

- Microsoft Word Open XML Document (DOCX) files. This file format is based on Open XML and uses ZIP compression. It was introduced with Microsoft Word 2007.
- Rich Text Format (RTF) files. Rich Text Format (RTF) is a text format that stores plain text and text formatting, such as bold. When you import an RTF file to CorelDRAW, the text and any embedded Windows Metafile Format (WMF) graphics are transferred. However, graphic elements are not transferred in an RTF file exported from Corel DESIGNER.

Because Microsoft Word is a proprietary file format, it’s sometimes difficult to precisely import all aspects of a Microsoft Word file in CorelDRAW. To successfully import text with fewer inconsistencies, it is recommended that you install the Microsoft Office Compatibility Pack. If the Microsoft Office Compatibility Pack was not previously installed on your computer, you will be prompted to install it when you attempt to import text.

To import a Microsoft Word file

1. Click File ➤ Import.
2. Choose DOC, DOCX - MS Word or RTF - Rich Text Format from the All file formats list box.
3. Choose the drive and folder where the file is stored.
4. Click the filename.
5. Click Import.

If the Microsoft Office Compatibility Pack was not previously installed on your computer, the Install compatibility pack dialog box appears. The installation of the Microsoft Office Compatibility Pack is highly recommended. To proceed with the installation, click OK and follow the instructions in the installation wizard.

6. In the Importing/Pasting text dialog box, you can choose to maintain or discard text formatting. You can also choose to import tables as tables or text.
7. Position the import cursor in the drawing window, and click.

Any embedded Windows Metafile Format (WMF) or Enhanced Metafile Format (EMF) graphics are preserved in the imported file. If the file contains other graphic elements, these are lost during conversion and do not appear in CorelDRAW.
You can place your imported text by dragging a marquee to define a paragraph text box, or by pressing the Spacebar to place the imported text in the default location.

If you import text and choose not to install the Microsoft Office Compatibility Pack, the Install compatibility pack dialog box will reappear the next time you import text, unless you enable the Do not ask me this question again check box. You can reactivate the Install compatibility pack dialog box by clicking Tools ▶ Options ▶ CorelDRAW, clicking Warnings, and enabling the Installing Compatibility Pack for DOC and DOCX check box from the Show warnings when list box.

To export a Microsoft Word file
1. Open a drawing that contains a text object.
2. Click File ▶ Export.
3. Choose DOC - MS Word for Windows 6/7 or RTF - Rich Text Format from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.

The filename extension for the format you choose is appended to the filename automatically.

Only text in drawings can be exported to the Microsoft Word file formats. Other graphical elements, such as lines, curves, and rectangles, are lost during conversion and do not display in the file. To export graphics, use a graphic format such as WMF.

Microsoft Word (DOC, DOCX, and RTF) technical notes

Importing a DOC, DOCX, and RTF file
- To successfully import text with fewer inconsistencies, it is recommended that you install the Microsoft Office Compatibility Pack. If the Microsoft Office Compatibility Pack was not previously installed on your computer, you will be prompted to install it when you attempt to import text.
- The following Microsoft Word versions are supported: Microsoft Word 97-2007, Microsoft Word for Windows 6/7, Microsoft Word for Windows 2.x, Microsoft Word 3.0, 4.0, 5.0, and 5.5.
- The embedded-field method for building indexes in Microsoft Word is supported, but the style-implied method for building indexes is not.
- The Corel program matches the fonts in the file you are importing with the same or similar fonts, depending on the fonts installed on your computer. However, the Normal text style in Microsoft Word is converted to the default text style. To set the default text style, click Tools ▶ Save Settings as Default. Under Document Styles, enable the Styles check box.
- Whenever possible, the program automatically converts characters available in the sets “Symbol” or “MS Linedraw” to the corresponding Windows character set entries.
- Most fonts are proportionally spaced, and text is reflowed when imported. As a result, soft line and page breaks often appear in new locations if you are converting to a fixed-pitch or nonscalable font.
- When you import text, the page size in the original document is ignored. The text is adjusted to fit the current page size, which may affect the placement of text.
- If a table is longer than the current page, the table data continues down and off the page.
- Nested tables are not fully supported. The text within a nested table appears within the text box of the top-level table cell as text only (no bounding lines).
- Nested bullets are not fully supported.
- Objects and graphs are not supported.
- Equations are not maintained — the data and results may be maintained but they are unlinked.
- Text direction is not maintained.
Microsoft Publisher (PUB)

Microsoft Publisher (PUB) is the native format for files created in Microsoft Publisher, an application in the Microsoft Office line of products used for creating publications and market materials.

Microsoft Publisher (PUB) technical notes
- Exporting is not supported.
- Two-page spread is imported as separate pages.
- Master pages are not supported. A master page is imported as a separate layer on the page. The name of the layer corresponds to the name of the master page in Microsoft Publisher.
- Headers and footers are not supported. Text from the header/footer is placed in the appropriate position on each page.
- Tables are supported. Not all border types are supported. If a border type is not supported, it is replaced with an outline of the desired thickness and color.
- Border art is not supported.
- Styles are not supported. Style and formatting attributes are mapped to text.
- Some underline styles are not supported. Unsupported underline styles are replaced with the best-match underline style available in CorelDRAW.
- Shadow, Emboss, and Engrave font effects are not supported.
- Horizontal rules in text objects are not supported.
- Color schemes are not supported. Color scheme colors are mapped to object colors.
- Font schemes are not supported. Font names and styles are mapped to their equivalents in CorelDRAW.
- 3D shapes are supported. Surface textures are not supported.
- Word art is imported as artistic text in CorelDRAW. Surface textures for extrudes are not supported.
- Linked text boxes are supported.
- Bookmarks and hyperlinks are supported.
- Form objects (Microsoft Publisher 2002) are not supported.

Corel DESIGNER (DES, DSF, DS4, or DRW)

You can import Corel DESIGNER files. Files from version 10 and later have the filename extension .des. Files from Micrografx versions 6 to 9 have the filename extension .dsf. Version 4 files have the filename extension .ds4. The .drw filename extension is used for a Micrografx 2.x or 3.x file. Micrografx template files (DST) are also supported.

To import a Corel DESIGNER file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose DES - Corel DESIGNER (*.des) or DSF, DRW, DST, MGX - Corel/Micrografx Designer (*.dsf; *.drw; *.ds4) from the list box next to the File name box.
4. Click the filename.
5. In the Import dialog box, adjust any of the settings.
6. Click Import.
7. Click the drawing page.

Corel DESIGNER (DSF) technical notes
- Guidelines and grid settings are not converted.
- Snap points are not converted — the program preserves the default gravity settings.
• Objects on some pages may be grouped together. You may want to select the group and then ungroup it before editing.
• DSF files display OLE data as picture objects. OLE data object types are lost in the conversion.
• Curvygons are converted to curves.
• Gradient transparency may be offset in some cases.
• Hatch fills are rendered but are actually part of the object fill. They are separate objects that are grouped.
• Unclosed, filled lines are converted to two objects: one for the line and one for the fill.
• Warped text is converted to curves.
• Repelled text (block text that wraps around an object) is converted to multiple text objects.
• Each line of a nonrectangular text object (text placed within an object) is converted to a separate text object.
• For block text that has many transformations, tab stops may stretch or shrink.
• Text flowing between containers is not preserved; each container is converted to a separate object.
• Dimensions of text in small caps vary when the text is imported.

Corel DESIGNER (DES) technical notes
• B-splines are preserved in the imported file but cannot be modified before you convert them to curve objects. For information about converting objects to curve objects, see “To convert objects to curve objects” on page 214.
• Hatch fills are preserved but cannot be modified in CorelDRAW. You can, however, apply a hatch fill to other objects in a drawing. For more information, see “To copy fill, outline, or text properties from one object to another” on page 324.
• Enhanced line styles are preserved but you can modify only some of their properties. For example, you can change the color and width of the lines, but you cannot modify the line pattern. You can apply an enhanced line style to other objects.

AutoCAD Drawing Database (DWG) and AutoCAD Drawing Interchange Format (DXF)
AutoCAD Drawing Database (DWG) files are vector files used as a native format for AutoCAD drawings.

The Drawing Interchange Format (DXF) is a tagged data representation of the information contained in an AutoCAD drawing file. The Drawing Interchange format is a native file format of AutoCAD. It has become a standard for exchanging CAD drawings and is supported by many CAD applications. The Drawing Interchange format is vector-based and supports up to 256 colors.

To import an AutoCAD Drawing Database file (DWG) or AutoCAD Drawing Interchange Format (DXF)
1 Click File ➤ Import.
2 Locate the folder in which the file is stored.
3 Choose DWG - AutoCAD (*.dwg) or DXF - AutoCAD (*.dxf) from the list box next to the File name box.
4 Click the filename.
5 Click Import.
6 From the 3D projection list box in the Import AutoCAD file dialog box, choose a plane projection of a three-dimensional object as seen from a given focal point.
   If you want to reduce the number of nodes on the imported object, enable the Auto-reduce nodes check box.
7 In the Scaling area, enable one of the following options:
   • Automatic — scales the drawing using the scale of the AutoCAD source file
   • English (1 unit = 1 inch) — lets you scale the drawing in inches
   • Metric (1 unit = 1 mm) — lets you scale the drawing in millimeters
8 Click OK.
   If the file is password protected, type the password in the Password box.
If views are specified in your file, they appear automatically in the **3D projection** list box.

If your computer is missing a font that is included in a file you are importing, a **PANOSE font matching** dialog box appears and lets you substitute the font with a similar font.

**To export an AutoCAD Drawing Database file (DWG) or an AutoCAD Drawing Interchange file (DXF)**

1. Click **File ➤ Export**.
2. Locate the folder in which you want to save the file.
3. From the **Save as type** list box, choose one of the following options:
   - **DWG - AutoCAD**
   - **DXF - AutoCAD**
4. Type a filename in the **File name** list box.
5. Click **Export**.
6. In the **Export to AutoCAD** dialog box, choose an AutoCAD version from the **Export version** list box.
7. Choose a unit of measure from the **Export units** list box.
8. In the **Export text as** area, enable one of the following options:
   - **Curves** — lets you export text as curves
   - **Text** — lets you export text as editable characters
9. In the **Export bitmap as** area, enable one of the options to export the bitmaps in a drawing to a supported bitmap format.
10. In the **Fill unmapped fills** area, enable one of the following options:
    - **Color** — fills all unmapped fills with color. To change the color, click the **Color** picker and choose a color on the palette.
    - **Unfilled** — leaves unmapped fills unfilled

**AutoCAD Data Interchange Format (DXF) technical notes**
- The program supports AutoCAD files from version R2.5 to 2018.
- Layers are retained on import and export.

**Importing an AutoCAD DXF file**
- If a DXF file is too complex to import into CorelDRAW, you can configure your AutoCAD output device as an HP7475 plotter and perform a plot-to-file of the drawing. Then you can try importing this plot file with the HPGL import filter. Newer versions of AutoCAD allow you to create EPS files.
- Corel graphics programs try to center the imported image. The image is scaled down if the coordinates are larger than the maximum page size available in CorelDRAW — 150 by 150 feet.
- Solid and trace entities are filled.
- Dimension lines are imported as dimension objects.
- A point is imported as an ellipse of minimum size.
- Files exported as “Entities only” may not appear as expected in the Corel program because of a lack of header information.
- Imported AutoCAD files that contain formatted paragraph text preserve text formatting such as spacing, alignment, and indents.
- Justification of text entries may not be preserved, especially if fonts are replaced in the imported files. For best results, avoid justification of text.
- If the DXF file contains a font that is not on the user’s computer, the **PANOSE font matching** dialog box lets the user replace the font with an available one.
- 3D objects are not supported.

**Exporting an AutoCAD DXF file**
- CorelDRAW saves drawings in a vector format accepted by computer-aided design/computer-aided manufacturing (CAD/CAM) programs and devices, such as AutoCAD and certain computer-driven sign and glass cutters.
- Files exported to AutoCAD version 2007 may not display correctly in AutoCAD 2007.
• Password protection is not available in the exported files.
• Only the outlines of objects are exported.
• Filled objects with no outlines have an outline appended to them on export.
• All text is exported by using a generic font. Text formatting is not preserved.

AutoCAD Drawing Database (DWG) technical notes
• CorelDRAW can import AutoCAD and export files from version R2.5 to 2018.
• Password protection is not available in the exported files.
• If the DWG file contains a font that is not on your computer, the PANOSE font matching dialog box lets you replace the font with an available one.

Encapsulated PostScript (EPS)
EPS files can contain text, vector graphics, and bitmaps and are intended to be included (encapsulated) in other documents. Unlike other PostScript files, which can contain multiple pages, an EPS file is always a single page.

EPS files usually contain a preview image (header) that lets you view the file content without the help of a PostScript interpreter. An EPS file without a preview image is displayed as a gray box in Corel applications.

You can import and export EPS files. You can import an EPS file as a group of editable objects as you would import any other PostScript (PS) file. You can also bring the file as encapsulated, placing the preview image in the drawing window. The preview image is linked to the file. It is recommended that you import an EPS file as encapsulated in the following situations:
• You want text in the EPS file to be displayed with the original fonts, without any font substitutions.
• You are working with a large EPS file, and you don't want to slow down the application.

During the CorelDRAW Graphics Suite installation, you have the option of installing Ghostscript, which is an application that interprets the PostScript file format. Ghostscript allows you to import PostScript Level 3 files. If you did not install Ghostscript when you first installed the product, you can do so now.

To import an encapsulated PostScript file
1 Click File ➤ Import.
2 Locate the folder in which the file is stored.
3 Choose PS, EPS, PRN - PostScript (*.ps; *.eps; *.prn) from the list box next to the File name box.
4 Click the filename.
5 Click Import.
6 In the Import EPS dialog box, enable one of the following options:
   • Import as editable — brings in the file as a group of CorelDRAW objects that you can modify
   • Place as encapsulated PostScript — places the preview image in the drawing. You cannot modify specific parts of the file, but you can edit the file as a whole by applying transformations, such as sizing and rotation.
7 If you are importing the file as editable, enable one of the following text options:
   • Text — preserves text objects in the imported file so that you can edit the text
   • Curves — converts text to curves
8 Click OK.
9 Click the drawing page.
Some restrictions apply when you modify EPS files imported as editable. For more information, see “PostScript (PS or PRN) technical notes” on page 928.

If the EPS file contains text converted to curves, the text in the imported file is not editable, even if you choose to import the text as text.

You can also drag an EPS file from Windows Explorer into the drawing window.

**To export an encapsulated PostScript file**

1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose EPS - Encapsulated PostScript from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. In the EPS export dialog box, adjust any of the settings.

**To set general exporting options**

1. In the EPS export dialog box, click the General tab.
2. Perform one or more tasks from the following table.

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the color mode for exporting to eps</td>
<td>In the Color management area, choose an option from the Output colors as list box:  • Native  • RGB  • CMYK  • Grayscale  If you choose the Native option, all objects preserve the color mode in which they were created, for example RGB, CMYK, Grayscale, or spot.</td>
</tr>
<tr>
<td>Convert spot colors</td>
<td>In the Color management area, enable the Convert spot colors to check box, and select an option from the list box.</td>
</tr>
<tr>
<td>Choose a file format for previewing the PostScript image</td>
<td>In the Preview image area, choose one of the following options from the Type list box:  • None  • TIFF  • WMF  If you choose the TIFF format, choose a color mode and resolution.</td>
</tr>
</tbody>
</table>
To Do the following
Specify how to export text

- **Curves** — lets you export text as curves
- **Text** — lets you export text as editable characters

If you want to include PostScript font information with your file, enable the **Include fonts** check box.

Choose a compatibility option

From the **Compatibility** list box, choose a PostScript level that is supported by the printer or the application with which you will be printing or displaying the file.

Objects are always output as **CMYK**. Bitmaps have the option of different color modes.

If you choose the 8-bit TIFF format for previewing images, you can make the background of the bitmap transparent by enabling the **Transparent background** check box in the **Preview image** area.

To set advanced exporting options

1. In the EPS export dialog box, click the **Advanced** tab.
2. Perform one or more tasks from the following table.

To Do the following
Specify the author’s name

Type a name in the **Author** box.

Apply bitmap compression

In the **Bitmap compression** area, enable the **Use JPEG compression** check box. Move the **JPEG quality** slider to adjust the quality of the bitmaps.

Apply a trapping option

In the **Trapping** area, enable any of the following options:

- **Preserve document overprint settings** — maintains current settings on objects
- **Always overprint black** — creates a color trap by causing any objects that contain at least 95 percent black to overprint any underlying objects
- **Auto-spreading** — creates a color trap by assigning an outline to an object that is the same color as its fill and having it overprint underlying objects
- **Maximum** — lets you specify the amount of spread that the Auto-spreading option assigns to an object

If you want to specify the minimum font size to which Auto-Spreading is applied, type a value in the **Text above** box.

If you want the outlines of all objects on the page to have the same width, enable the **Fixed width** check box.
To apply a bounding box

- Objects — aligns the bounding box exactly to the objects in the file
- Page — aligns the bounding box to the page
- Bleed limit — lets you specify how far the bleed extends beyond the edge of the area to be printed
- Crop marks — lets you use crop marks as alignment aids when you trim the print output to its final size
- Floating point numbers — lets you use numbers with decimals

Maintain OPI link

Enable the Maintain OPI link check box to use low-resolution images as placeholders for high-resolution images.

Automatically increase fountain steps

Enable the Auto-increase fountain steps check box to automatically increase the number of steps used to create fountain fills.

The Use JPEG compression check box remains disabled until you choose a PostScript level that supports this feature.

To install Ghostscript

1. Close any open programs.
2. On the Windows taskbar, click Start ➤ Control panel.
3. Click Uninstall a program.
4. Double-click CorelDRAW Graphics Suite from the Uninstall or change a program page.
5. Enable the Modify option.
6. On the Features page, enable the GPL Ghostscript check box.
7. Follow the instructions in the installation wizard.

Encapsulated PostScript (EPS) technical notes

Importing an EPS file

- When you import an EPS file as editable, the PostScript information in the file is converted to native CorelDRAW objects that you can edit with some restrictions. For information about these restrictions, see “PostScript (PS or PRN) technical notes” on page 928.
- If the encapsulated PostScript file was imported with the Place as Encapsulated PostScript option, and if it contains a preview image (called a header), the preview image is imported and displayed. The EPS information remains attached to the header and is used when the image is printed to a PostScript printer.

Exporting an EPS file

- On a PostScript printer, graphics exported to the encapsulated PostScript (EPS) format print from other programs exactly as they do from a Corel graphics programs.
- You can save a header to the Tagged Image file format (TIFF) or Windows Metafile format (WMF) in black and white, 4-bit grayscale or color, or 8-bit grayscale or color. You can set the header resolution between 1 and 300 dots per inch (dpi); the default header resolution is 72 dpi. If the program importing the EPS file has a limitation on the image header size, you might receive an error message stating that the file is too large. To reduce file size, in the EPS export dialog box, choose Black and White from the Mode box, and lower the header resolution before exporting the file. The setting determines only the resolution of the header and has no impact on the print quality of a drawing. Color headers are useful for viewing EPS files. If the program in which you are going to use the file does not support color headers, try exporting with a mono header instead. You can also export without a header.
- Along with the graphic, exported EPS files contain a filename, program name, and date.
- To save font information in an EPS file, enable the Include fonts check box in the Export text as area.
• If you export text as curves, text is converted to vector curves.
• If a font used in the file is not available on the printer or has not been saved in the file, either the text is printed in Courier font or the
  drawing is not printed.

PostScript (PS or PRN)

PostScript (PS) files use PostScript language to describe the layout of text, vector graphics, or bitmaps for printing and display purposes. They
  can contain multiple pages. PostScript files are imported as a group of objects that you can edit.

PostScript files usually have a .ps filename extension, but you can also import PostScript files with a .prn extension. Files with a .prn filename
  extension, commonly known as Printer (PRN) files, contain instructions about how a file should be printed. These files let you reprint a
  document even if the application in which the document was created is not installed on your computer.

During the CorelDRAW Graphics Suite installation, you have the option of installing Ghostscript, which is an application that interprets the
  PostScript file format. Ghostscript assists the file importing process. If you did not install Ghostscript during the installation, see "To install
  Ghostscript" on page 927.

You can also import encapsulated PostScript (EPS) files. For more information, see "Encapsulated PostScript (EPS)" on page 924.

To import a PostScript (PS or PRN) file

1 Click File ➤ Import.
2 Locate the folder in which the file is stored.
3 Choose PS, EPS, PRN - PostScript (*.ps; *.eps; *.prn) from the list box next to the File name box.
4 Click the filename, and click Import.
5 In the Import text as area, enable one of the following text options:
  • Text — preserves text objects in the imported file so that you can edit the text
  • Curves — converts text to curves
6 Click OK.
7 Click the drawing page.

When the PostScript file contains text converted to curves, the text in the imported file is not editable, even if you choose to import
  the text as text.

PostScript (PS or PRN) technical notes

• PostScript files containing mesh fills with spot colors, DeviceN images, or duotone images cannot be imported. Installing Ghostscript
  resolves this issue.
• Mesh fills in the CMYK color mode are imported as bitmaps and cannot be edited.
• Gradient fills are imported as a group of filled objects simulating the gradient fill appearance and cannot be edited as gradient fills.
• RGB bitmaps are converted to CMYK in imported PS files. Installing Ghostscript resolves this issue.
• Font information is maintained only if the font was embedded in the original file before it was imported.
• Files that are too large cannot be imported into some programs because of memory limitations. This problem can be caused by complex
  gradient fills that increase the number of objects in a graphic.
• Only Printer (PRN) files, PS files, and EPS files in PostScript format are supported.
**GIF**

**GIF** is a bitmap-based format designed for use on the web. It is highly compressed to minimize file transfer time and supports images with up to 256 colors. The GIF file format supports a maximum image size of \(30,000 \times 30,000\) pixels and uses LZW compression. For more information about exporting images to the GIF file format, see “Export bitmaps for the web” on page 870.

The GIF format provides the ability to store multiple bitmaps in a file. When the multiple images are displayed in rapid succession, the file is called an animated GIF file.

For Internet use, you can also save images to the JPEG and PNG formats. If you want to publish an image to the web and are not sure which format to use, see “Export bitmaps for the web” on page 870.

**To import a GIF file**

1. Click **File ▶ Import**.
2. Locate the folder in which the file is stored.
3. Choose **GIF - CompuServe Bitmap (*.gif)** from the list box next to the **File name** box.
4. Click the filename.
5. Click **Import**.
6. Click the drawing page.

You can also

- Resample a graphic while importing For more information, see “To resample a bitmap while importing” on page 887.
- Crop a graphic while importing For more information, see “To crop a bitmap while importing” on page 888.

You can drag on the drawing page to resize the image.

**GIF technical notes**

- Corel programs import versions 87A and 89A of the GIF file format, but export only to version 89A. Version 87A supports basic features and interlacing. The newer version, 89A, includes all features found in 87A plus the ability to use transparent colors and to include comments and other data from the image file.
- Corel programs support the following color depths when importing animated GIF files: black and white (1-bit), 16 colors, grayscale (8-bit), and 256 color paletted (8-bit).

**High Efficiency Image File Format (HEIF)**

The High Efficiency Image File Format (HEIF) supports individual images, image sequences, animation, and image metadata. Developed by the Moving Picture Experts Group (MPEG), this file format is based on the High Efficiency Video Compression (HEVC). Compared to JPEG files, HEIF files have a smaller file size without sacrificing image quality.

You can import HEIF files in CorelDRAW. For more information, see “To import a file into an active drawing” on page 885.
HEIF technical notes

Importing a HEIF file
• HEIF files have a .heif or .heic file extension.
• When you import a file that contains an image sequence, only the key (master) image of the sequence is imported.
• HEIF files that contain animation are not supported.

JPEG (JPG)

JPEG is a standard format developed by the Joint Photographic Experts Group. Through the use of superior compression techniques, this format allows the transfer of files among a wide variety of platforms. JPEG supports 8-bit grayscale, 24-bit RGB, and 32-bit CMYK color modes.

The JPEG format is commonly used on the web. For more information about exporting to the JPEG file format, see “Export bitmaps for the web” on page 870.

To import a JPEG file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose JPG - JPEG Bitmaps (*.jpg; *.jtf; *.jff; *.jpeg) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

You can also

Resample a graphic while importing
For more information, see “To resample a bitmap while importing” on page 887.

Crop a graphic while importing
For more information, see “To crop a bitmap while importing” on page 888.

You can drag on the drawing page to resize the image.

JPEG technical notes
• JPEG files can contain EXIF data. This data may affect how the JPEG files open.

JPEG 2000 (JP2)

The JPEG 2000 (JP2) file format is a JPEG image with advanced compression and file data capabilities. JPEG 2000 standard files can store more descriptive file data (or metadata), such as dimensions, tone scale, color space, and intellectual property rights, than JPEG 2000 codestream files. Codestream files are optimized for network transmission since they resist bit errors that can cause data loss on low-bandwidth channels.

Not all web browsers support JPEG 2000 formats. You may require a plug-in to view these files.
When you export the image to a JP2 file, you can choose to view download progression by resolution, quality, and position.

**To import a JPEG 2000 file**
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose JP2 - JPEG 2000 Bitmaps (*.jp2; *.j2k) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

**To export a JPEG 2000 bitmap**
1. Click File ➤ Export.
2. Choose JP2 - JPEG 2000 bitmaps from the Save as type list box.
3. Type a name in the File name box.
4. Click Export.
5. Choose a JPEG 2000 preset from the Preset list box in the upper-right corner of the dialog box.
   If you want modify the preset settings, you can change the exporting options in the dialog box.
6. Click OK.

**You can also**

- Choose a color mode
  In the Settings area, choose a color mode from the Color mode list box.

- Embed the color profile
  In the Advanced area, enable the Embed color profile check box.

- Control image quality
  In the Settings area, choose a quality option from the Quality list box or type a value.

- Set the JPEG 2000 download from low to high resolution so that the size of the entire image increases
  In the Advanced area, choose Resolution\Quality from the Progression list box.

- Set the JPEG 2000 download from the upper-left corner of the image to the lower-right corner
  In the Advanced area, choose Resolution\Position from the Progression list box.

- Set the JPEG 2000 download from the upper-left corner of the image to the lower-right corner
  In the Advanced area, choose Position from the Progression list box.

- Set the JPEG 2000 download progressively by color channel
  In the Advanced area, choose Channels from the Progression list box.

- Allow JPEG 2000 codestream
  In the Advanced area, enable the Codestream check box.
JPEG 2000 (JP2) technical notes

- CorelDRAW can import either JP2 or JPC files but export only to the JP2 format.
- CorelDRAW supports exporting JPEG 2000 files in 24-bit RGB, and 8-bit grayscale.
- CMYK, 48-bit RGB, and black-and-white images are not supported for export.

Kodak Photo CD Image (PCD)

Kodak Photo CD image file is a raster format developed by Eastman Kodak for scanning photographic images onto compact discs. PCD images are derived from 35-mm film negatives or slides that have been converted to digital format and stored on a CD. Photo CD allows high-quality digital storage and manipulation of photographic images. The PCD format is typically used by photofinishers and service bureaus who provide the service of placing photographs on CDs.

This file format is not supported by the 64-bit version of the application.

To import a Kodak Photo CD image file

1. Click File ➤ Import.
2. Choose the folder in which the file is stored.
3. Choose PCD - Kodak Photo-CD image (*.pcd) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. In the PCD import dialog box, move any of the following sliders:
   - Brightness — lets you set the amount of light
   - Contrast — lets you specify the contrast between the pixels in the image
   - Saturation — lets you specify the purity of a color
   - Red — lets you specify the amount of red in the image
   - Green — lets you specify the amount of green in the image
   - Blue — lets you specify the amount of blue in the image
7. From the Resolutions list box, choose an image size.
8. From the Image type list box, choose a color mode.
9. Position the import placement start cursor on the drawing window, and click.

You can also

Resample a graphic while importing

For more information, see “To resample a bitmap while importing” on page 887.

Crop a graphic while importing

For more information, see “To crop a bitmap while importing” on page 888.

You can drag on the drawing page to resize the image.

You can remove the adjustments made by the photofinisher at the time the original image was scanned and placed on the Photo CD disk by enabling the Subtract scene balance check box.

You can identify out-of-gamut areas of the image by enabling the Show colors out of gamut check box, which renders the out-of-gamut pixels in pure red or pure blue.
Kodak Photo CD Image (PCD) technical notes

- Kodak Photo CD (PCD) images may be subject to copyright. The Corel program does not display a warning message about this.
- Other Kodak-compatible programs may install the Kodak pcdlib.dll file in the Windows folder instead of the Windows\System folder. This difference in the folder location produces an error message.
- When you import Photo CD files, a dialog box appears and prompts you to choose the desired file resolution and color. The resolution is limited to 72 dpi and the maximum image size is 3072 × 2048 pixels.
- You can import the following color modes: RGB (24-bit), paletted (8-bit), and grayscale (8-bit).

PICT (PCT)

The Macintosh PICT file format was developed for the macOS platform by Apple Computer Inc. It is a native file format of QuickDraw and can contain both vectors and bitmaps. The Macintosh PICT file format is widely used in Macintosh applications.

To import a PICT file

1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose PCT - Macintosh PICT (*.pct; *.pict) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

You can drag on the drawing page to resize the image.

To export a PICT file

1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose PCT - Macintosh PICT from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.

PICT (PCT) technical notes

- Corel graphics programs can import vector drawings and bitmaps contained in PICT (PCT) files.
- Objects that contain a fill and an outline open as a group of two objects. One object is the outline, and the other is the fill.
- PICT fills are often bitmap patterns, and the Corel program tries to maintain these fills as bitmap patterns.
- Pattern outlines are converted to a solid color.
- Text in PICT files opens as editable text. If a typeface in the imported file is not available on your computer, it is converted to the font that it most closely resembles.
- Text alignment may not be preserved in the original file. This is due to the differences in font size, and intercharacter and interword spacing between the two formats. Any misalignment is easily corrected using the text formatting settings in the program.

PaintBrush (PCX)

The PaintBrush (PCX) file format is a bitmap format originally developed by the ZSoft Corporation for the PC Paintbrush program.
To import a PaintBrush file
1 Click File ➤ Import.
2 Locate the folder in which the file is stored.
3 Choose PCX - PaintBrush (*.pcx) from the list box next to the File name box.
4 Click the filename.
5 Click Import.
6 Click the drawing page.

To export a PaintBrush file
1 Click File ➤ Export.
2 Locate the folder in which you want to save the file.
3 Choose PCX - PaintBrush from the Save as type list box.
4 Type a filename in the File name list box.
5 Click Export.
6 In the Convert to bitmap dialog box, adjust the width, height, resolution, color mode, or any of the other settings.
7 In the Convert to paletted dialog box, adjust any of the settings.

PaintBrush (PCX) technical notes

Exporting a PCX file
- Bitmaps may be black-and-white, 16 colors, grayscale (8-bit), paletted (8-bit), or RGB color (24-bit).
- Run-length encoding (RLE) compression is supported, and the maximum image size is 64,535 × 64,535 pixels.
- These files may contain one, two, or four color planes.
- This file format is supported in CorelDRAW and Corel PHOTO-PAINT.

Importing a PCX file
- PCX files can be imported if they conform to the following PCX specifications: 2.5, 2.8, and 3.0.
- Bitmaps may be black-and-white, 16 colors, grayscale (8-bit), paletted (8-bit), or RGB color (24-bit).
- RLE compression is supported and the maximum image size is 64,535 × 64,535 pixels.
- These files may contain one, two, or four color planes. Files containing three color planes or more than four color planes cannot be imported.

Adobe Portable Document Format (PDF)
The Adobe Portable Document Format (PDF) is a file format designed to preserve fonts, images, graphics, and formatting of an original file. Using Adobe Reader and Adobe Acrobat, a PDF file can be viewed, shared, and printed by macOS, Windows, and UNIX users.

You can open or import a PDF file. When you open a PDF file, it is opened as a CorelDRAW file. When you import a PDF file, the file is imported as grouped objects and can be placed anywhere within your current document. You can import an entire PDF file, individual pages from the file, or multiple pages.

Some PDF files are secured by a password. You are prompted to enter a password before you can open and edit a secured PDF file. For information about PDF security options, see “PDF security options” on page 903.

You can save a file in the PDF format. For more information, see “Export to PDF” on page 895.

Importing text
The method by which PDF files store information affects how text looks and how easily it can be edited. To help ensure the best results for your document, you can choose whether to import the text in your file as text or as curves.
When you import text as text, the font and text are preserved, and the text is fully editable as artistic or paragraph text. However, some effects and formatting may be lost. This option is recommended if you have a PDF file that contains large blocks of text, such as a newsletter, and you want to reformat the text or add text content.

When you import text as curves, the appearance of the text, including all effects applied to it, are preserved, and each letter is converted to a curve object. With this option, the text formatting features can no longer be used to edit the text. If you have a PDF file that contains a small amount of text that does not require editing, or if you do not have the fonts used in the PDF file, you can import the text as curves. For more information about converting text to curves, see “Find, edit, and convert text” on page 608.

Importing comments

Some PDF files can contain comments and annotations. These may consist of text, curves, and other drawings or shapes that are added to the PDF document by a reviewer. If commenting rights have been granted, you have the option of importing the comments with the PDF file. When comments are imported, they are placed on a separate “Comments” layer in the document. By default, this layer is set as non-printable.

If the PDF document contains comments written by multiple reviewers, the comments are grouped on the “Comments” layer based on the author’s name.

Cropping content

Some PDF files may contain objects that fall outside the drawing page. You can crop object parts that are not on the drawing page, or you can leave them intact.

To import an Adobe Portable Document Format file

1 Click File ➤ Import.
2 Locate the folder in which the file is stored.
3 Choose PDF - Adobe Portable Document Format or All file formats from the list box next to the File name box.
4 Click the filename.
5 Click Import.
   If the file is protected by a password, type a valid password in the Password box.
6 In the Import text as area, choose one of the following options:
   • Text — lets you edit and reformat the text from the PDF file
   • Curves — converts text to curves. Choose this option when you do not need to edit the text from the PDF file, and you want to maintain the appearance of the original text.
   If you are importing a multipage document, select the pages you want to import, and click OK.
   If the document contains comments that you want to import, enable the Import comments and place on a separate layer check box.
   If the document contains objects that fall outside the drawing page, you can choose to crop them to the drawing page or leave them intact by enabling or disabling the Crop content to drawing page check box.
7 Click the drawing page.
   If a block of text is imported as separate text objects, you can combine the text objects by selecting them and clicking Object ➤ Combine.

Adobe Portable Document Format (PDF) technical notes

Publishing a PDF file
• Texture fills created in CorelDRAW are exported and imported as bitmap patterns.
• Embedded 3D models are exported as embedded interactive 3D objects. If a document contains a 3D model, click Settings in the Publish to PDF dialog box, and choose Acrobat 9.0 or higher from the Compatibility list box to ensure that the 3D model is interactive in PDF readers.
Importing a PDF file

- Digital signatures are not supported.
- PDF Portfolios are not supported.
- Multimedia files — such as .mov, .mp3, .mp4, .mpeg, or .swf — are not supported and, as a result, are removed from the PDF file when imported in CorelDRAW.
- File link annotations are imported as artistic text.
- Transparency applied to text and graphics is preserved.
- Character attributes of text, including OpenType features, are preserved.
- DeviceN color spaces may be converted to RGB or CMYK processed colors in the imported file, depending on the file content.
- Layers are preserved in files created with Adobe Acrobat 6 and later.
- Xform objects, headers and footers are converted to symbols.
- Symbols are preserved when PDF files created with version 1.3 or later undergo round-tripping.
- Comments are preserved and imported on a separate “Comments” layer in the document.
- Text annotations, including free text and pop-up annotations, are imported as paragraph text.
- Sticky Notes display as a rectangle with the appropriate background and border color. Headers in Sticky Notes are not supported.
- Line annotations display as straight lines with the appropriate width and color. Arrows with different fill and outline colors display fill and outline of the same color.
- Square and circle annotations display as rectangles and ellipses with the appropriate fill/outline properties. Polygon and polyline annotations are mapped as polylines with similar fill/outline properties. Cloud shapes display as polygons.
- Text markup annotations, such as highlights, underlining, and strikeouts, are imported.
- Standard ink and stamp annotations are supported. Custom stamp annotations are not supported.

HPGL Plotter File (PLT)

The HPGL Plotter File (PLT) format, developed by Hewlett-Packard, is vector-based. It is used in programs such as AutoCAD for printing drawings on plotters. Other Corel applications can interpret a SUBSET of the HPGL and HPGL/2 command set. This format uses a scaling factor of 1,016 plotter units to 1 inch.

To import an HPGL Plotter file

1. Click File ➔ Import.
2. Locate the folder in which the file is stored.
3. Choose PLT - HPGL Plotter File (*.plt; *.hgl) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. In the HPGL options dialog box, adjust any of the settings.
7. Click OK.

To export an HPGL Plotter file

1. Click File ➔ Export.
2. Locate the folder where you want to store the file.
3. Choose PLT - HPGL Plotter File from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. In the HPGL export dialog box, adjust any of the settings.
7. Click OK.
HPGL Plotter (PLT) technical notes

Importing a PLT file

- Corel programs support versions 1 and 2 of PLT file formats although some features of version 2 are not supported.
- You can import images larger than the Corel program’s maximum page size by enabling the Scale option in the HPGL options dialog box, which lets you resize the imported image.
- The curve resolution factor can be set to a value between 0.0001 and 1.0 inch. The value can be very precise; up to eight decimal places are accepted. A setting of 0.0001 results in the highest resolution, but it also greatly increases file size. A curve resolution of 0.004 inch is recommended.
- The PLT file format does not contain color information. Instead, the various objects in a PLT file have certain pen numbers associated with them. When imported into a Corel program, each pen number is assigned a specific color. You can specify the color assigned to a particular pen, so that you can match the original colors of the graphic.
- The Pen selection list contains 256 pens, although not all of the pens may be assigned. You can change the color assignments by choosing the pen and then choosing a new color for that pen from the Pen color list box. Choosing Custom colors brings up a color definition dialog box that allows you to define a custom color according to RGB values.
- You can change the pen width assignments by choosing the pen and then choosing a new width for that pen from the Pen width list box.
- You can change the pen velocity by choosing the pen and then choosing a new velocity for that pen from the Pen velocity list box. This is useful only for exporting PLT files.
- You can set a defined pen to the Unused option. You can also reset the current Pen Library pen settings to the previously saved settings.
- Corel programs support numerous dotted, dashed, and solid line types of the PLT file format. The pattern number of a line in a PLT file is translated to a line type pattern.
- If the PLT file contains a font that is not on the user’s computer, the PANOSE font matching dialog box lets the user replace the font with an available one.

Exporting a PLT file

- In CorelDRAW, you now have the option of setting the Plotter origin to Top left.
- Only the outlines of objects are exported to the PLT file format.
- Dotted lines, dashed lines, and arrowheads are mapped to standard line types of the PLT file format.
- Bézier curves are converted to line segments.
- Outline thickness and calligraphic settings are lost.
- Outline colors are limited to eight: black, blue, red, green, magenta, yellow, cyan, and brown.

Portable Network Graphics (PNG)

The Portable Network Graphics (PNG) file format is an excellent file format for lossless, portable, and well-compressed storage of bitmaps. It takes up a minimum amount of disk space and can be easily read and exchanged between computers. The Portable Network Graphics format provides a replacement for the GIF format and can also replace many common uses of the TIFF format.

The Portable Network Graphics format is designed to work well in online viewing, such as on the web, and it’s fully streamable with a progressive display option. Some web browsers do not support all formatting and features. You can export images to the Portable Network Graphics file format if you want to use transparent backgrounds, image interlacing, image maps, or animation in your webpages.

Exporting graphics to the Portable Network Graphics format converts them to bitmaps that can be used in desktop publishing programs and Microsoft Office applications. You can also edit Portable Network Graphics in image-editing programs such as Corel PHOTO-PAINT and Adobe Photoshop. For more information, see “Export bitmaps for the web” on page 870.

You can also save images to the GIF and JPEG formats to use on the Internet. If you want to publish an image to the web but are not sure which format to use, see “Export bitmaps for the web” on page 870.

To import a Portable Network Graphics file

1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3 Choose **PNG - Portable Network Graphics (\*.png)** from the list box next to the **File name** box.
4 Click the filename.
5 Click **Import**.
6 Click the **drawing page**.

**You can also**

Resample a graphic while importing

For more information, see “To resample a bitmap while importing” on page 887.

Crop a graphic while importing

For more information, see “To crop a bitmap while importing” on page 888.

You can drag on the drawing page to resize the image.

**Portable Network Graphics (PNG) technical notes**

- You can import Portable Networks Graphics (PNG) files from 1-bit black and white to 24-bit color; 48-bit color is not supported.
- Masks and indexed-color, grayscale, and true color images are supported. Masks, however, are not saved in 1-bit black-and-white or 8-bit paletted files.
- **LZ77** compression is supported, and the maximum image size is 30,000 × 30,000 pixels. Sample depths range from 1 to 16 bits.
- The PNG file format also checks full-file integrity and detects common transmission errors. The PNG file format can store gamma and chromatic data for improved color matching on different platforms.

**Adobe Photoshop (PSD)**

The Adobe Photoshop (PSD) file format is the native bitmap file format for Adobe Photoshop.

**To import an Adobe Photoshop file**

1 Click **File ‣ Import**.
2 Locate the folder in which the file is stored.
3 Choose **PSD - Adobe Photoshop (\*.psd; \*.pdd)** from the list box next to the **File name** box.
4 Click the filename.
5 Click **Import**.
6 Click the **drawing page**.

**You can also**

Resample a graphic while importing

For more information, see “To resample a bitmap while importing” on page 887.

Crop a graphic while importing

For more information, see “To crop a bitmap while importing” on page 888.
To export an Adobe Photoshop file

1. Click File ▶ Export.
2. Locate the folder in which you want to save the file.
3. Choose PSD - Adobe Photoshop from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. In Convert to bitmap dialog box, adjust the width, height, resolution, color mode, or any of the other settings.

You can export to an image with a transparent background.

Adobe Photoshop (PSD) technical notes

Importing a PSD file

- Monotone, grayscale, duotone, 48-bit RGB, and up to 32-bit CMYK images are supported.
- Some layer effects cannot be imported. (Gradient map adjustment layer is imported without Noise, Opacity stops, and Dither.)
- Imported layers using the Darken Color and Lighten Color blend modes map to the If Darker and If Lighter merge modes, respectively. For more information about working with merge modes, see "Merge modes" on page 456.
- Files that contain spot color channels are imported as multichannel (DeviceN) bitmaps.

Exporting a PSD file

- This format supports 1-bit black-and-white and up to 32-bit CMYK color images.
- Layers are supported.
- Text is rasterized.
- Spot color channel information is preserved in the exported file.

Corel Painter (RIF)

Imported Corel® Painter® (RIF) files retain information such as floating objects, which makes the files much larger than GIF or JPEG files. Corel Painter files can be imported for resizing and adjusting floaters.

To import a Corel Painter file

1. Click File ▶ Import.
2. Locate the folder in which the file is stored.
3. Choose RIFF - Painter (*.rif) from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

You can also

Resample a graphic while importing

For more information, see “To resample a bitmap while importing” on page 887.
You can also

Crop a graphic while importing

For more information, see “To crop a bitmap while importing” on page 888.

Corel Painter (RIF) technical notes

- The embedded color profile is preserved, but can be changed after importing the file.
- If the Corel Painter image contains a transparent background, which is called a canvas in Corel Painter, it is preserved.
- Vector shapes are not preserved in the imported file.
- Text and annotations are not preserved.
- Bitmap layers are imported as grouped objects.
- Liquid Ink, Watercolor, Digital Watercolor, and plug-in layers are imported as RGB objects.
- Mosaics and tessellations are imported as RGB objects.
- Image slicing is not retained.

Scalable Vector Graphics (SVG)

Scalable Vector Graphics (SVG) is an open standard graphics file format that allows designers to put the power of vector graphics to work on the web. It was created by the World Wide Web Consortium (W3C).

SVG files are described in Extensible Markup Language (XML). They are vector graphic images, which can provide superior detail and faster download times than bitmaps. Compressed SVG files have an .svgz filename extension.

Unicode support

SVG files support Unicode encoding for text. When exporting an SVG file, you can choose a Unicode encoding method.

Embedding and linking

You can embed information in an SVG file, or you can create additional files to store some of the information. For example, you can embed a style sheet in an SVG file, or you can create an external cascading style sheet and link it to the SVG file. JavaScript, which may be used for rollovers and interactive effects, is embedded in the exported file by default. But you can choose to store it as a separate file linked to the SVG file. Also, you can embed bitmaps, or you can save bitmaps as externally linked files.

Exporting text

You can export text as text or curves. When exporting text as text, you can choose to embed all fonts in an SVG file to have full editing capabilities. You can also embed only the fonts used, and common English or common Roman fonts.

Using preset export options

To make your work easier, you can use preset export options, and you can create custom preset export options that you can reuse later.

Using SVG colors

SVG colors correspond to color keywords. You can use the SVG color palette available in the application to help ensure that colors in the exported SVG file are defined by color keywords. To ensure that the SVG color names you choose are retained in the SVG exported file, it is recommended that you disable color correction. For information about color correction, see “About color management” on page 465.

Adding reference information to SVG objects

Reference information can be added and retained in an exported SVG object. You can add information to an object so that the information appears in the file’s XML tags. These tags are derived from the data field names, each of which is formatted as general text, data and time, linear and angular dimensions, or numbers. For example, you can name individual objects in the drawing and add comments for each of these objects. The name and comments for each object display in the tags of the exported SVG file. For more information about assigning information to objects, see “Assign and copy object data” on page 394.
To import a Scalable Vector Graphics file
1 Click File   Import.
2 Locate the folder in which the file is stored, select the file, and click Import.
3 In the Import SVG file dialog box, enable one of the following options:
   • Automatic — scales the drawing using the scale of the source file
   • English (1 unit = 1 inch) — lets you scale the drawing in inches
   • Metric (1 unit = 1 mm) — lets you scale the drawing in millimeters
4 Choose a drawing scale from the Scaling list box.
5 Click OK.
6 Click the drawing page where you want to place the file.

For more information about importing SVG files, see "Importing an SVG file" on page 942.
For more information about placing the imported file, see "To import a file into an active drawing" on page 885.

To export a Scalable Vector Graphics file
1 Click File   Export.
2 In the Export dialog box, locate the folder in which you want to save the file, and type a filename in the File name list box.
3 Choose SVG - Scalable vector graphics or SVGZ - Compressed SVG from the Save as type list box.
4 Click Export.
5 In the SVG Export dialog box, choose an SVG version for the exported file from the Compatibility list box.
6 From the Encoding method list box, choose one of the following encoding options:
   • Unicode - UTF-8 — produces a smaller file size. This is the default encoding method and is useful in most circumstances.
   • Unicode - UTF-16 — produces a bigger file size
7 Choose one of the following options from the Styling options list box:
   • Presentation attributes — lets you specify attributes directly in an element in the exported file
   • Internal style sheet — uses the CLASS attribute to embed the style sheet in the Scalable Vector Graphics file
   • External CSS — creates an external cascading style sheet file and links it to the Scalable Vector Graphics file

JavaScript related to rollovers can be saved to a separate file by enabling the Link Externally check box in the JavaScript area.

8 In the Export text area, enable one of the following options:
   • As text — exports text as editable characters, known as glyphs
   • As curves — exports text as curves

You must embed fonts when you require the display of a specific font that the users may not have installed on their computers.
As the number of fonts or fountain fill steps increases, so does the size of the file.
Objects with mesh fills or drop shadows are exported as bitmaps.
If no single element in a drawing is selected, the content of the entire page is exported.

To choose a color by using the SVG color palette
1 Select an object.
2 Click Window   Color Palettes   More Palettes.
3 From the Palette libraries folder, double-click the Process folder.
4 Enable the SVG colors check box.
5 Click a color swatch on the SVG color palette.

To add reference information to a Scalable Vector Graphics object
1 Select an object using the Pick tool .
2 Click Window  Dockers  Object Data.
3 In the Name/value list, click a data field name.
4 Type the information in the text box.

You can also

- Rename a data field
  Click the Open field editor button  Choose the name of the data field, and type a new name.
- Add a data field
  Click the Open field editor button. Click New Field, and type the name of the new field.
- Change the data field format
  Click the Open field editor button. Click a field name and then click the Change button. Enable a field type option.

Fields containing no values are ignored when a file is exported to the Scalable Vector Graphics format.

Scalable Vector Graphics (SVG) technical notes

Importing an SVG file
- Most of the information in SVG files created in other programs is preserved in the imported file, even if CorelDRAW does not support a feature. For example, information about ink strokes in an SVG file created in another program is preserved in the imported file, even though the ink strokes are not displayed.
- Clipped and masked objects are imported as PowerClip objects.
- Group, object, and symbol names and IDs are retained in the imported file.
- Symbols in the imported file appear in the Symbols docker.
- Bitmap files embedded in an SVG file are retained.
- Links to external files, such as GIF, PNG, or JPEG files, are supported on import unless the external files are stored on the web.
- SVG color definitions and names are supported.
- Round-tripping is supported.
- Metadata is supported.
- Hyperlinks are supported.

Exporting an SVG file
- Scalable Vector Graphics (SVG) allows three types of graphic objects: vector graphic shapes (for example, paths consisting of straight lines and curves), images, and text.
- Drop shadows are rasterized in SVG files.
- All CorelDRAW symbols are supported on export as SVG symbols.
- Object, layer, group, and symbol names are also supported. If the names are the same, the SVG file appends unique numbers to the object IDs. Invalid names are corrected on export.
- Graphical objects can be grouped, styled, transformed, and combined into previously rendered objects.
• You can export text as editable characters, so that after you publish an SVG graphic to the web, text continues to be recognized as text. Text strings can be restyled, copied and pasted, or indexed by search engines. Text can also be edited by SVG-capable editing programs, eliminating the need for maintaining multiple versions of graphic images for editing.

• The SVG standard allows the use of Cascading Style Sheets (CSS) to define font, text, and color properties of objects on a page.

• Layers are retained as groups in the exported file. If you import the file back into CorelDRAW, the layer groups are converted into layers with the original layer names preserved.

• Only the active page in a drawing is exported. If you want to export only a part of a drawing, enable the Selected only check box in the Export dialog box.

• URLs assigned to text objects are retained in the exported file.

• Transformations, such as rotation and skewing, are usually retained in the exported files. In some cases, transformations may be lost, and transformed shapes may be converted into curves.

Adobe Flash (SWF)

Important note! Support for Flash content was discontinued on January 12, 2021. We don’t recommend exporting files to the Adobe Flash (SWF) format. For more information, see https://www.adobe.com/ca/products/flashplayer/end-of-life.html.

Adobe Flash is a file format for creating and displaying vector-based images and animation. Macromedia Flash files are extremely compact and of high quality, making them ideal for use on the web.

Before you save a file to the Adobe Flash file format, you can determine whether the file has potential export problems. You can check the current file and display a summary of errors, possible problems, and a suggestion for resolving the issue.

To export an Adobe Flash file

1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose SWF - Adobe Flash from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. In the Flash export dialog box, choose values from any of the following list boxes:
   • JPG compression — specifies the amount of JPEG file compression
   • Resolution (dpi) — specifies the resolution of the image
   • Smoothing — tones down differences between adjacent pixels
7. Enable one of the following options in the Bounding box size area:
   • Page — applies the bounding box to the page
   • Objects — aligns the bounding box to the objects in the file
8. Enable any of the following check boxes in the Optimization area:
   • Convert dashed outlines — converts dashed outlines to solid lines
   • Rounded caps and corners — rounds the corners and endpoints of lines and curves
   • Use default fountain steps — lets you use the default number of steps for fountain fills

You can also

Prevent a Adobe Flash file from being loaded into the Adobe Flash editor

Enable the File protection from import check box.

The more you compress a sound, the smaller the size and the lower the sound quality.
You can save the settings in the Flash export dialog box to a preset by clicking the Add preset button and typing a name in the Setting name box.

To preview an Adobe Flash file in a browser, you must have the Adobe Flash Player plug-in installed on your computer.

To view the issues summary for an Adobe Flash file
1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose SWF - Adobe Flash from the Save as type list box.
4. Type a filename in the File name list box.
5. Click Export.
6. In the Flash export dialog box, click the Issues tab.
7. Click an error or warning in the error list to see the details and suggestions for resolving the issue.

If you want to overlook certain issues, click Settings, and disable the check boxes that correspond to those issues.

The Issues tab heading indicates the number of issues. The icon on the tab heading changes, depending on the severity of the issue or issues identified.

Adobe Flash (SWF) technical notes
• Adobe Flash (SWF) files cannot be imported into CorelDRAW.

TARGA (TGA)
The TARGA (TGA) graphics format is used for saving bitmaps. It supports various compression systems and can represent bitmaps ranging from black-and-white to RGB color. You can import or export TGA files in CorelDRAW.

For more information about importing files, see "Import files" on page 885.

To import a TARGA file
1. Click File ➤ Import.
2. Locate the folder in which the file is stored.
3. Choose TGA - Targa bitmap from the list box next to the File name box.
4. Click the filename.
5. Click Import.
6. Click the drawing page.

To export a TARGA file
1. Click File ➤ Export.
2. Locate the folder in which you want to save the file.
3. Choose TGA - Targa bitmap from the Save as type list box.
4. Type a filename in the File name list box.

To compress an image while exporting it, choose a compression type from the Compression type list box.
5 Click Export.
6 In the Convert to bitmap dialog box, adjust the width, height, resolution, color mode, or any of the other settings, and click OK.
7 In the TGA export dialog box, enable one of the following options:
   • Normal
   • Enhanced

   Black-and-white images cannot be saved as TARGA files.

**TARGA (TGA) technical notes**
- The following features are supported: uncompressed color-mapped images, uncompressed RGB images, run-length encoding (RLE) compressed color-mapped images, RLE-compressed RGB images (types 1, 2, 9, and 10 as defined by the AT&T Electronic Photography and Imaging Center), and masks.
- The type of file produced depends on the number of colors exported. For example, 24-bit color TARGA (TGA) files are exported as RLE-compressed RGB bitmaps.
- You can import TGA files from 8-bit grayscale to 24-bit RGB.
- Masks are not saved in 1-bit black-and-white or 8-bit paletted files.
- RLE compression is supported, and the maximum image size is 64,535 × 64,535 pixels.

**TIFF**
The Tagged Image File format (TIFF) is a raster format designed as a standard. Almost every graphics application can read and write TIFF files. TIFF supports various color modes and bit depths.

For information about importing TIFF files, see “To import a file into an active drawing” on page 885.

**To export a TIFF file**
1 Click File ➤ Export.
2 Locate the folder in which you want to save the file.
3 Choose TIF - TIFF bitmap from the Save as type list box.
4 Type a filename in the File name list box.
5 Click Export.
6 In the Convert to bitmap dialog box, adjust the width, height, resolution, color mode, or any of the other settings, and click OK.

**TIFF technical notes**
- When importing a TIFF that contains multiple pages, you can import all pages or choose the individual pages that you want to import.
- Black-and-white, color, and grayscale TIFF files up to and including the 6.0 specification can be imported and exported.
- TIFF files compressed using JPEG, ZIP, CCITT, Packbits 32773, or LZW compression can also be imported. However, you may notice additional loading time with these files because the program decodes the file compression.

**TrueType Font (TTF)**
The TrueType Font (TTF) file format was created jointly by Apple Computer and Microsoft Corporation. It is the most common format for fonts used in both Macintosh and Windows operating systems. The TTF file format prints font characters as bitmaps or vectors depending on the capabilities of your printer. True Type fonts appear the same in print and on-screen, and they can be resized to any height.
TrueType Fonts (TTF) technical notes

- TrueType fonts exported from CorelDRAW are unhinted.
- Each exported character constitutes a single object. Before you export multiple objects, you must combine them by clicking **Object > Combine**. You cannot export multiple objects or grouped objects.
- Fill and outline attributes applied to objects are not exported.
- For best results, avoid intersecting lines. Any object in your character should lie completely inside or outside of others, as shown in the following example.

![Examples of object combinations](image)

*Left to right: three objects correctly combined; five objects correctly combined; five objects incorrectly combined*

Visio (VSD)

- VSD is the Visio drawing format. It can contain bitmaps and vectors.
- You can import all VSD file types, up to VSD 2007.
- Rectangle shapes are imported as rectangle objects.
- Circle and ellipse shapes are imported as ellipse objects.
- Curvygon, pentagon, hexagon, heptagon, octagon, and megagon shapes are imported as polygon objects.
- All other shapes are imported as polycurves.

Google Web Picture (WEBP)

CorelDRAW offers support for the Google Web Picture (*.webp) file format. This open standard format developed by Google provides lossless and lossy compression for images designed for use on the web.

You can import WEBP files in CorelDRAW or export CorelDRAW files to the WEBP file format. You import WEBP files as you would any other supported file. For more information about importing files, see "Import files" on page 885. When you export a file to the WEBP format, you can choose from several presets to suit your needs. You can also create a new preset from scratch or edit any existing preset and save it as a custom preset. For more information about creating presets, see "To save a preset for exporting web-compatible images" on page 876.

You can choose between two compression methods: lossy and lossless. With lossless compression, images do not lose any quality but are larger in size. With lossy compression, images are smaller in size, but suffer a quality loss. You can control the compression factor for RGB channels by modifying the **Quality** setting. When using the lossy method, a small factor produces a smaller file with lower quality. A value of 100 lets you achieve the best quality. With the lossless method, the **Quality** setting adjusts the compression. A small factor enables faster encoding speed but produces a larger file. A value of 100 lets you achieve maximum RGB compression and generate smaller files.

You can also control the ratio between encoding speed, file size, and quality by adjusting the **Compression ratio**. Lower values produce larger files with lower compression quality, and faster processing time. Higher values produce smaller files with higher compression quality, and slower encoding time.

When exporting to the WEBP file format, you can preserve the transparent background of images.
Images can be resized on export by using the Transformation controls.

To import a WEBP file
1 Click File ▶ Import.
2 Locate the folder in which the file is stored.
3 Choose WEBP – Google Web Picture (*.webp) from the list box next to the File name box.
4 Click the filename.
5 Click Import.
6 Click the drawing page.

When importing WEBP files, transparency is maintained.

To export a WEBP file
1 Click File ▶ Export.
2 Choose the folder where you want to save the file.
3 Choose WEBP – Google Web Picture (*.webp) from the Save as type list box.
4 Type a filename in the File name list box.
5 Click Export.
6 In the WebP dialog box, choose a preset from the Preset list box in the upper-right corner of the dialog box.

<table>
<thead>
<tr>
<th>Preset</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low quality WEBP</td>
<td>Using lossy encoding, this preset produces images with small file size, low RGB compression quality, and fast conversion time.</td>
</tr>
<tr>
<td>Medium quality WEBP</td>
<td>Using lossy encoding, this preset produces images with medium quality and file size and moderate RGB compression.</td>
</tr>
<tr>
<td>High quality WEBP</td>
<td>Using lossless encoding, this preset produces images with maximum RGB compression, larger file size, and slow processing time.</td>
</tr>
<tr>
<td>Custom</td>
<td>Lets you specify custom settings</td>
</tr>
<tr>
<td>Original</td>
<td>Maintains the original settings of the image</td>
</tr>
</tbody>
</table>

7 Click OK.

You can also

Choose an encoding method | Enable one of the following options:
----------------------------|-------------------------------|
                          | • Lossy                        |
                          | • Lossless                     |
You can also

- Set the compression factor for RGB channels: Choose an option from the **Quality** list. Lower values produce smaller files at the expense of image quality. Higher values produce larger files with higher image quality.

- Set the ratio between encoding speed, file size, and quality: Choose an option from the **Compression ratio** list. Lower values produce larger files with lower compression quality, and faster processing time. Higher values produce smaller files with higher compression quality, and slower encoding time.

- Export an image with alpha transparency: Enable the **Transparency** check box.

- Resize a file on export: See “To resize an object when exporting a web-compatible bitmap” on page 873.

- Set preview options in the **Export to WEBP** dialog box: See “To adjust the object-export preview” on page 872.

**WordPerfect Document (WPD)**

The WordPerfect Document format (WPD) is the native file format for WordPerfect files. CorelDRAW supports WPD files from versions 4.2 to 14. WordPerfect files for versions 4 and 5 have the file extensions .wp4 and .wp5.

For more information, see “General notes on importing text files” on page 952.

**WordPerfect Document (WPD) technical notes**

- When you import text from a WPD file, you can maintain formatting, maintain fonts and formatting, or discard fonts and formatting.
- When you import or export a WordPerfect file, only text is transferred. Graphic elements are not imported or exported.
- The following features are not supported: index functions, text in tables of contents, and style sheets.
- Equations and formulas created in the WordPerfect equation language are converted to regular text.
- Graphic features like HLine and VLine are not converted.
- When importing text, the page size in the original document is ignored. The text is fit to the current page size, which may affect the placement of text.

**WordPerfect Graphic (WPG)**

The Corel WordPerfect Graphic file format (WPG) is primarily a vector graphic format, but it can store both bitmap and vector data. The WPG files may contain up to 256 colors, chosen from a palette of more than 1 million colors.

**To import a WordPerfect Graphic file**

1. Click **File ➤ Import**.
2. Locate the folder in which the file is stored.
3. Choose **WPG - Corel WordPerfect Graphic (*.wpg)** from the list box next to the **File name** box.
4. Click the filename.
Click **Import**.

Click the **drawing page**.

Any embedded Windows Metafile Format (WMF) or Enhanced Metafile Format (EMF) graphics are preserved in the imported file. If the file contains other graphic elements, these are lost during conversion and do not appear in CorelDRAW.

### To export a WordPerfect Graphic file

1. Click **File** ➤ **Export**.
2. Locate the folder in which you want to save the file.
3. Choose **WPG - Corel WordPerfect Graphic** from the **Save as type** list box.
4. Type a filename in the **File name** list box.
5. Click **Export**.
6. Enable one of the following options in the **Export colors** area:
   - **16 colors** — exports the image as a 16-color image
   - **256 colors** — exports the image as a 256-color image
7. Enable one of the following options in the **Export text as** area:
   - **Text** — exports text as editable characters
   - **Curves** — exports text as curves
8. Enable one of the following options in the **Export file as** area:
   - **WordPerfect Version 1.0** — supported by WordPerfect 5.1 and earlier
   - **WordPerfect Version 2.0** — supported by WordPerfect 6 and later

### WordPerfect Graphic (WPG) technical notes

- Graphics Text Type 2 is not supported.

### RAW camera file formats

A RAW camera file is a data file captured by the image censor of a high-end digital camera. RAW camera files contain minimal in-camera processing, such as sharpening or digital zoom, and they give you full control over the sharpness, contrast, and saturation of images. Various RAW camera file formats exist, so the files can have different filename extensions, such as .nef, .crw, .dcr, .orf, or .mrw.

You can import RAW camera files directly into CorelDRAW. For more information, see "Use RAW camera files" on page 815.

### Wavelet Compressed Bitmap (WI)

This file format is not supported by the 64-bit version of the suite.

#### Importing a WI file

- Corel programs support the following color depths when you import Wavelet Compressed Bitmap (.wi) files: 256-shade (8-bit) grayscale, and 24-bit RGB.

#### Exporting a WI file

- Corel programs support the following color depths when you export to the Wavelet Compressed Bitmap file format: 256 shade (8-bit) grayscale, 24-bit RGB.
- The Wavelet Compressed Bitmap file format supports Wavelet compression. It also supports a minimum image size of 16 pixels and a maximum size of 2,048 pixels.
**Windows Metafile Format (WMF)**

Developed by Microsoft Corporation, this file format stores both vector and bitmap information. It was developed as the file format for Microsoft Windows 3. It supports 24-bit RGB color and is supported by most Windows applications.

**Windows Metafile Format (WMF) technical notes**

**Importing a WMF file**
- CorelDRAW substitutes fonts that are missing from a file in the WMF format from similar fonts available on your computer.
- The following features are not supported: PANOSE font matching and rotated and skewed bitmaps.

**Exporting a WMF file**
- The WMF format is used to export graphics to Windows programs.
- A header contains additional information, such as sizing. Therefore, a WMF file can successfully be exported from CorelDRAW if the header is included.
- Text is maintained as text when exported, and WMF files can be very large. This can cause problems in programs that limit the size of imported files.
- The Windows Metafile Format is 16 bits, while CorelDRAW is 32 bits. When you export a WMF file, the 32-bit numbers are converted to 16 bits. For example, lines that are thinner than 0.01388 inch appear as hairlines because the WMF format does not have enough precision to specify these widths accurately.

**Additional file formats**

CorelDRAW also supports the following file formats:
- ANSI Text (TXT) — ANSI Text (TXT) is a vector format that stores ANSI characters. This format is able to store text information but not formatting information, such as the font type or size. When a TXT file is imported to or exported from CorelDRAW, only the text is transferred. If the file has graphic elements, they are not imported or exported.
- CALS Compressed Bitmap (CAL) — CALS Raster (CAL) is a bitmap format used mainly for document storage by high-end CAD programs. It supports a monochrome (1-bit) color depth and is used as a data graphics exchange format for computer-aided design and manufacturing, technical graphics, and image-processing applications.
- Corel ArtShow 5 (CPX) — The CPX file format is a native file format of Corel ArtShow 5. It can contain both vectors and bitmaps.
- Corel Presentations (SHW) — The SHW file format is a native format of Corel Presentations.
- CorelDRAW Compressed (CDX) — The CDX file format is a compressed CorelDRAW file.
- Corel DESIGNER or CorelDRAW Template (CDT) — The CDT file format is for a Corel DESIGNER or CorelDRAW template file.
- Encapsulated PostScript (Desktop Color Separation) — The DCS file format, developed by QuarkXPress, is an extension of the standard encapsulated PostScript (EPS) file format. Typically, the DCS file format consists of five files. Four of the five files contain information about high-resolution color. This information is expressed in CMYK (cyan, magenta, yellow and black) format. The fifth file, considered the master file, contains a PICT preview of the DCS file.
- EXE — The EXE format is a Windows 3.x/NT bitmap resource and can store an ICO file as a Windows 3.x/NT icon resource.
- FPX — The FlashPix file format stores images at different resolutions in a single file. This file format is not supported by the 64-bit version of the suite.
- Frame Vector Metafile (FMV) — The FMV file format is used for a Frame Vector Metafile.
- GEM Paint (IMG) — GEM Paint (IMG) is a bitmap format that is the native bitmap file format of the GEM environment. IMG files support 1- and 4-bit paletted color and are compressed by using an RLE method. IMG was a common format in the early days of desktop publishing.
- GEM File (GEM) — The GEM file format is used for a GEM file.
- GiMP (XCF) — XCF is the native GIMP format. It supports layers and other GIMP-specific information.
- ICO — The ICO format is a Windows 3.x/NT icon resource.
- Lotus PIC (PIC) — The PIC file format is used for a Lotus PIC file.
• MacPaint Bitmap (MAC) — MacPaint (MAC) is a bitmap format that uses the filename extensions MAC, PCT, PNT, and PIX. It is the format used by the MacPaint program that was included with the Macintosh 128. It supports only two colors and a palette of patterns. It is used mainly by Macintosh graphics applications to store black-and-white graphics and clipart. The maximum size for MAC images is 720 × 576 pixels.
• Macromedia FreeHand (FH) — the FH format is the native vector file format for Macromedia Freehand. Corel graphics applications support versions 7 and 8 of Macromedia FreeHand.
• MET Metafile (MET) — The MET file format is for a MET Metafile.
• Micrografx Picture Publisher 4 (PP4) — The PP4 file format is a native file format of Micrografx Picture Publisher 4.
• Microsoft Excel (XLS) — The XLS file format is the native file format of a Microsoft Excel workbook.
• Microsoft PowerPoint (PPT) — The PPT file format is native to Microsoft PowerPoint.
• NAP Metafile (NAP) — The NAP file format is used for a NAP Metafile.
• Fill File (FILL) — This file format is used for saving custom fills in CorelDRAW.
• PostScript Interpreted (PS or PRN) — PRN PostScript (PS or PRN) is a metafile format for PostScript printers. This format is written in ANSI text. The PostScript Interpreted import filter can import PS, PRN, and EPS PostScript files.
• SCITEX CT Bitmap (SCT) — The SCT file format is used for importing 32-bit color and grayscale SCITEX images. SCITEX bitmaps are created from high-end scanners. The bitmaps are then processed for output by film recorders or high-end page layout programs.
• WB — WB is the file format for Quattro Pro 6, 7, and 8 spreadsheets.
• WK — WK (.wk3, .wk4) is the extension of Lotus 1-2-3 spreadsheets.
• WSD — WSD is the document format for Wordstar 2000 and Wordstar 7.
• XPixMap Image (XPM) — The XPM file format is used with an XPixMap Image file.

**Recommended formats for importing graphics**

The table below shows what file formats to use when you are importing graphics from other applications.

<table>
<thead>
<tr>
<th>Application</th>
<th>Recommended import format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adobe Illustrator</td>
<td>AI, PDF</td>
</tr>
<tr>
<td>AutoCAD</td>
<td>DXF, DWG, HPGL (PLT files)</td>
</tr>
<tr>
<td>CorelDRAW</td>
<td>CDR, Clipboard</td>
</tr>
<tr>
<td>Deneba Canvas, Macromedia FreeHand and other vector packages</td>
<td>PCT, AI</td>
</tr>
<tr>
<td>Microsoft Office</td>
<td>WMF, PNG. For more information, see “Work with office productivity applications” on page 909.</td>
</tr>
<tr>
<td>WordPerfect Office</td>
<td>WPG</td>
</tr>
<tr>
<td>Micrografx Designer</td>
<td>DSF, DRW, AI, DS4</td>
</tr>
</tbody>
</table>

To import text from a text-editing application, you can use RTF files, or you can copy the text to the Clipboard and then paste it in your project.
Recommended formats for exporting graphics

When exporting graphics to be used in Adobe PageMaker, use the encapsulated PostScript file format if you have a PostScript printer. If you have a non-PostScript printer, the WMF format is recommended.

The following table lists the recommended file formats for exporting to page layout and desktop publishing packages that have graphics editing capabilities.

<table>
<thead>
<tr>
<th>Application</th>
<th>Recommended format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adobe Illustrator</td>
<td>AI, PDF</td>
</tr>
<tr>
<td>Adobe PageMaker</td>
<td>EPS, WMF</td>
</tr>
<tr>
<td>AutoCAD</td>
<td>DXF</td>
</tr>
<tr>
<td>Macromedia FreeHand and other vector programs</td>
<td>PCT, AI</td>
</tr>
<tr>
<td>Microsoft Office</td>
<td>PNG, WMF</td>
</tr>
<tr>
<td>WordPerfect Office</td>
<td>WPG</td>
</tr>
<tr>
<td>Micrografx Designer</td>
<td>CGM</td>
</tr>
</tbody>
</table>

The HPGL or DXF outlines formats are recommended for exporting graphics to be output to devices such as plotters and computer-driven cutters.

General notes on importing text files

- When you import a text file into a Corel program, it appears almost the same as in the source program. However, some formatting attributes and page layout features may not be supported. In such cases, the program tries to simulate the results of a feature when a reasonable substitution can be made.
- The following word-processing features are not supported: headers, footers, footnotes and endnotes, columns, and macros.
- Font matching support is included. You can modify font-matching settings in the Font matching results dialog box. Fonts are converted by size and by family, provided the source file format includes font family information that the program can access.
- Rich Text Format (.rtf) files are automatically converted to the Microsoft Windows ANSI (American National Standards Institute) character set. The Macintosh Character Set and Standard IBM PC Code Page 437 are also supported.
- Corel graphics programs match characters as closely as possible. Font matching is used if the imported text font is not on the user’s system. However, if a match cannot be made, the font characters appear in the program as unrecognizable text.
- Conversion of font sizes is supported.
- Corel graphics programs support all font families for the following word-processing programs and formats: Corel WordPerfect, Microsoft RTF, Microsoft Word PC, Microsoft Word Macintosh, Word for Windows.
- Corel graphics programs support only selected fonts from the fonts supported by Ami Professional. This typically includes Standard PostScript fonts and the Standard HP PCL fonts.
- When Macintosh files are converted, font support is limited to the supported font families of the Windows formats.
- Fonts converted to formats other than those listed in the table above are mapped to fonts that Corel graphics programs find as the best fit.
• You may encounter alignment problems when converting from and to a proportional and nonproportional font. Therefore, if you import a document created in a nonproportional font to a proportional font, some pages may have more text on a page than the original document.

• Source documents that contain a table of contents and index are converted into the appropriate functions in an .rtf file.

• Data that is automatically outlined is converted to regular text.

• Style sheet properties are converted to RTF. The file appears as in the source program; however, the style sheet from the original program is not imported.

• Text contained within a frame or a positioned object is retained.
Customize and automate

Customize CorelDRAW.................................................................................................................................957

Use macros and scripts to automate tasks........................................................................................................ 973
Customize CorelDRAW

You can customize your application by arranging command bars and commands to suit your needs and changing the color of window borders. Command bars include menus, toolbars, the property bar, the toolbox, and the status bar.

Help topics are based on the application’s default settings. When you customize command bars, commands, and buttons, the Help topics associated with them do not reflect your changes.

You can change and restore default preferences, customize the toolbar, and customize the list of available file filters.

This section contains the following topics:

- “Choose options” (page 957)
- “Configure GPUs” (page 958)
- “Save and restore defaults” (page 959)
- “Create workspaces” (page 959)
- “Import and export workspaces” (page 960)
- “Customize workspace appearance” (page 961)
- “Customize keyboard shortcuts” (page 963)
- “Customize menus” (page 965)
- “Customize toolbars and other command bars” (page 966)
- “Customize the toolbox” (page 969)
- “Customize the property bar” (page 969)
- “Customize the status bar” (page 971)
- “Customize filters” (page 972)

Choose options

The following categories of options are available to help you match settings to your workflow.

- **Application Options** (Tools ▶ Options ▶ CorelDRAW) are specific to CorelDRAW. You can choose the application behavior on startup, customize display colors, and adjust auto-save and backup settings. Other application options apply to editing objects, text, your digital pen, snapping, PowerClip, PowerTRACE, warnings, and plug-ins.

- **Customization Options** (Tools ▶ Options ▶ Customization) let you adjust the size of the user interface (UI) elements, pick a UI theme, and set the window border and desktop colors. In addition, you can rearrange command bars and controls, and you can create toolbars for your most commonly used controls. For more information, see “Customize workspace appearance” on page 961, “Customize menus” on page 965, “Customize toolbars and other command bars” on page 966, “Customize the property bar” on page 969, and “Customize the status bar” on page 971.
**Tool Options** ([Tools] ➤ [Options] ➤ [Tools]) let you set the default behavior of commonly used tools such as the **Pick**, **Eraser**, **Zoom**, **Pan**, **Rectangle**, **Ellipse**, **Connector**, **Dimension**, and **Mesh Fill** tools.

**Global Options** ([Tools] ➤ [Options] ➤ [Global]) affect the entire suite. You can choose the language of the user interface, adjust print settings, and change the location for saving content such as fills, fonts, and color palettes. You can also customize the list of the active file filters, and you can adjust privacy and personalization settings. For example, you can opt out of feature tracking, and you can update your profile to receive better recommendations for learning materials.

**Document Options** ([Layout] ➤ [Document Options]) apply to the active document. They include page size, page viewing mode, layout, grid, ruler, and guideline settings as well as duplicate offset. These options are available only when a document is open.

In addition, you can access color management options to manage document colors for display and printing. For more information, see “Get started with color management” on page 469.

Each category of options is accessible from a different menu command and brings up a specific page in the **Options** dialog box. If you cannot find the setting you need, you can switch to another category with a single click.

### To switch to another category of options
- Click one of the following buttons in the upper-right corner of the **Options** dialog box:
  - **Document**
  - **CorelDRAW**
  - **Customization**
  - **Tools**
  - **Global**
  - **Workspaces**

*Switch between categories by clicking the corresponding button in the Options dialog box.*

### Configure GPUs

If your system has multiple available graphics processing units (GPUs), you can select which one CorelDRAW Graphics Suite uses for various processing tasks.

CorelDRAW Graphics Suite utilizes GPU hardware acceleration in the following areas:
- **Display** – provides fluid panning, zooming, and screen rendering
- **Effects** – lets you apply bitmap effects as lenses, providing greater precision and design freedom
- **Art Styles** – these presets use AI technology to modify an image or object, producing a stylized version while preserving the original content
- **Resampling** – AI-powered upsampling is used to enlarge images and trace bitmaps, resulting in clean edges, sharpness, and fine details
- **JPEG Artifact Removal** – advanced machine-learning technology is used to remove JPEG compression artifacts, restoring both color and detail in images

### To configure GPUs

1. Click **Tools** ➤ **Options** ➤ **Global**.
   - By default, the **Use hardware acceleration** check box is enabled.
2  Choose a GPU from the **Use hardware acceleration** list box.

3  Enable or disable the check boxes that correspond with the areas of hardware acceleration that you want to turn on or off:
   - Display
   - Effects
   - Art Styles
   - Resampling
   - JPEG Artifact Removal

If the selected GPU is not normally used for display, CorelDRAW Graphics Suite will continue to use the OS-designated GPU for display to maintain optimal performance. The selected GPU will be used for all other hardware acceleration options.

Changes made to the GPU configuration may require an application restart.

### Save and restore defaults

Many application settings apply to the active drawing only. These include page layout options, grid and ruler settings, guideline settings, style options, save options, some tool settings, and web publishing options. Saving the current settings as defaults lets you use the settings of the active drawing for all new drawings you create. You can save all current settings as defaults or only specific settings.

If you find that the changed settings are no longer useful, or you no longer can find controls easily, you can restore the default settings by resetting the current workspace.

**To save current settings as defaults**

1. Click **Layout ▶ Document Options**.
2. Click **Save as Default**.
3. Enable the check boxes that correspond to the settings you want to save.

**To reset the current workspace**

1. Exit the application.
2. Restart the application while holding down F8.

Resetting the workspace restores the default application, document and tool options. Global options are not reset because they are not stored in the workspace.

Customizations made to the workspace appearance and command bars are lost.

### Create workspaces

You can create workspaces to make more accessible the tools that you use most often. For example, you can open dockers or add tools to toolbars. You can also delete the custom workspaces that you create.

Before creating a workspace, you can try the workspaces that are included with the application. These workspaces are optimized for a number of common workflows. For more information, see “Choose a workspace” on page 105.

You can change the default location to which workspaces are saved. For more information, see “Change content locations” on page 125.

**To create a workspace**

1. Click **Tools ▶ Options ▶ Workspaces**.
2 Click Duplicate.

3 In the Duplicate Workspace dialog box, type the name of the workspace in the Name box.

   If you want to include a description of the workspace, type a description in the Description box.

   If you don’t want to use the new workspace right away, choose another workspace, and disable the Set as Current check box.

To delete a workspace

1 Click Tools  Options  Workspaces.
2 Choose a workspace from the Workspace list.
3 Click Delete.

   You cannot delete the Default workspace.

Import and export workspaces

You can import custom workspaces created on other computers or in other versions of the application (back to version X6). When importing a workspace, you can select which workspace elements to import. For example, you can import docker settings and position, but you can discard application settings such as startup options. You can also import the selected workspace elements into the current workspace or into a new workspace. You can base the new workspace on one of the available workspaces, and you can give it a name and description.

You can also export the workspaces that you create to share them with others.

To import a workspace

1 Click Window  Workspace  Import.
2 In the Open dialog box, locate the workspace file you want to import, and click Open.
3 In the Import Workspace dialog box, select the workspace elements that you want to import. By default, all workspace elements are selected.
4 Enable one of the following options:
   - Current workspace — to replace the workspace elements of the current workspace with the imported workspace elements. For example, if you choose to import all toolbars, the toolbars of the current workspace are replaced with the imported ones.
   - New workspace — creates a workspace that includes the imported workspace elements.

You can also

Specify the name of the new workspace

Type a name in the Name box.

Base the new workspace on an existing workspace

Choose a workspace from the Base on list box.

   The imported workspace elements will be merged with the base workspace.

Add a workspace description

Type a description in the Description box.
Any new features that were not available when the workspace was created are added to the imported workspace. The new features may not be in the same location as they appear in the default workspace. Custom icons may not be scaled properly in imported workspaces created in versions X6 and X7.

To export a workspace

1. Click Window ▶ Workspace ▶ Export.
2. In the Export Workspace dialog box, enable the check boxes beside the workspace items you want to export.
3. Click Export.
4. Choose the folder where you want to save the file.
5. Type a filename in the File name box.
6. Click Save.

The workspace items available for export are dockers, toolbars (including the property bar and toolbox), menus, and shortcut keys. A workspace is exported as a .cdws file.

Customize workspace appearance

You can customize the size of user interface items, choose a theme, and change the color of window borders and the desktop.

Center dialog boxes

By default, all dialog boxes appear centered in the application window. However, you can position a dialog box where you want all dialog boxes to appear, and then disable the Center dialog boxes setting. The next time you open a dialog box, it will appear in your preferred location on the screen.

Scaling

You can change the size of user interface (UI) items by changing the scaling level. The scaling level is relative to the scaling level of the operating system. The default setting is 100%, which means that UI items in the application appear the same size as similar UI items in the operating system. Scaling by 200% makes the application UI items appear twice as large as the UI items of the operating system.

Theme

To make the workspace lighter or darker, you can choose one of the following themes: Light, Medium, Dark, or Black.

Window border color

You can customize the application window and dialog boxes by changing the color of their borders.

Desktop color

You can change the color of the desktop, the area surrounding the drawing page, to suit your documents. For example, if the document contains dark colors, you can change the desktop color from white to gray for lower contrast.
Choose colors

To choose the color you want for the desktop and window borders, you can quickly sample any onscreen color; or you can use color sliders, color viewers, or color palettes.

To change the workspace appearance
1. Click Tools ➤ Options ➤ Customization.
2. Click Appearance.
3. Change the settings you want.

To specify a window or desktop color by using various color tools
• In the Color area, open the Desktop or Window border color picker, and perform a task from the following table.
To Do the following

Sample a color

Click the Color eyedropper tool and click an onscreen color.

Use color sliders

Click the Show color sliders button, choose a color mode from the list box, and move the sliders.

Use a color viewer

Click the Show color viewers button, choose a color mode from the list box, and click a color on the color viewer.

Choose a color from a color palette

Click the Show color palettes button, choose a color palette from the Palette Libraries, and click a color.

Access additional color options

Click the More color options button and choose an option. The options are dependent on the selected method such as sampling or using a color viewer, color sliders or a color palette.

Customize keyboard shortcuts

Although your application has preset keyboard shortcuts, you can change them, or add your own shortcuts, to suit your working style. When you no longer need a keyboard shortcut, you can delete it.

You can print a list of keyboard shortcuts. You can also export a list of keyboard shortcuts to the CSV file format — a comma delimited format that is easily opened by word processors and spreadsheet applications.

When you change keyboard shortcuts, the changes are saved in a file called an accelerator table. Your application comes with the following accelerator tables, which can be customized to suit your work habits:

• Anchor Editing table — contains shortcut keys for anchor editing
• Curve Editing table — contains shortcut keys for editing curves
• Main table — contains all non-text-related shortcut keys
• Print Merge — contains shortcut keys for using the Print Merge feature
• Print Preview — contains shortcut keys for print preview options
• Table Editing table — contains non-text-related shortcut keys for table editing
• Table Text Editing table — contains shortcut keys for editing text in tables
• Text Editing table — contains all text-related shortcut keys

When using a keyboard shortcut that contains a number, make sure to press the number at the top of the keyboard not on the number pad.

To assign a keyboard shortcut to a command

1 Click Tools » Options » Customization.
2 In the left pane of the Options dialog box, click Commands.
3 Click the Shortcut Keys tab.
4 Choose a shortcut key table from the Shortcut key table list box.
5 Choose a command category from the top list box (for example, File).
6 Click a command in the **Commands** list (for example, **Export**). The shortcut keys currently assigned to the selected command are displayed in the **Current shortcut keys** box.

7 Click the **New shortcut key** box, and press a key combination. If the key combination is already assigned to another command, that command is displayed in the **Currently assigned to** area.

8 Click **Assign**.

If the same keyboard shortcut is already assigned to another command, the second assignment overwrites the first. By enabling the **Assign and go to conflict** check box, you can automatically navigate to the command whose shortcut you reassigned and assign a new shortcut.

You can view all of the existing keyboard shortcuts by clicking **View All**.

You can replace all custom shortcuts with the default ones by clicking **Reset All**.

### To delete a keyboard shortcut

1 Click **Tools** ➤ **Options** ➤ **Customization**.
2 In the left pane of the **Options** dialog box, click **Commands**.
3 Click the **Shortcut Keys** tab.
4 Choose a shortcut key table from the **Shortcut key table** list box.
5 Choose a command category from the top list box (for example, **File**).
6 Click a command in the **Commands** list (for example, **Export**).
7 Click a shortcut key in the **Current shortcut keys** box.
8 Click **Delete**.

### To print keyboard shortcuts

1 Click **Tools** ➤ **Options** ➤ **Customization**.
2 In the left pane of the **Options** dialog box, click **Commands**.
3 Click the **Shortcut Keys** tab.
4 Click **View all**.
5 Click **Print**.

### To export a list of keyboard shortcuts

1 Click **Tools** ➤ **Options** ➤ **Customization**.
2 In the left pane of the **Options** dialog box, click **Commands**.
3 Click the **Shortcut Keys** tab.
4 Click **View All**.
5 Click **Export to CSV**.
6 Type a filename in the **File name** box.
7 Choose the folder where you want to save the file.
8 Click **Save**.
Customize menus

Corel customization features let you modify the menu bar and the menus it contains. You can change the order of menus and menu commands; add, remove, and rename menus and menu commands. You can search for a menu command if you do not remember the menu in which it belongs. You can also reset menus to the default setting.

The customization options apply to the menu bar menus as well as to shortcut menus that you access by right-clicking.

Help topics are based on the application’s default settings. When you customize menus and menu commands, the Help topics associated with them do not reflect your changes.

To change the order of menus and menu commands

1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
3. In the application window, drag a menu on the menu bar to the left or right.
   - If you want to change the order of menu commands, click a menu on the menu bar, click a menu command, point to the top-level menu again, and drag the command up or down.
   - If you want to change the order of context menu commands, right-click in the application window to display the context menu, and drag a menu command to a new position.

To rename a menu or menu command

1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
3. Choose a command category from the top list box.
4. Click a menu or command in the list.
5. Click the General tab.
6. Type a name in the Caption box.

An ampersand (&) before a letter in the Caption box indicates a shortcut, also known as an accelerator key. Menus are displayed by pressing Alt + the letter. Commands are invoked by pressing the letter that is underlined when the menu is displayed.

You can reset the name to the default by clicking Restore Defaults.

To add or remove an item on the menu bar

1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
   - If you want to remove an item, press Alt and drag it off the menu bar.
3. Choose a command category from the top list box.
4. Drag an item to the menu bar.

To find a menu command quickly

1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
3 In the Search box, type the command name or a relevant keyword. The results are updated automatically as you type.

To modify the menu bar appearance

1 Click Tools ▶ Options ▶ Customization.
2 In the left pane of the Options dialog box, click Command Bars.
3 Choose Menu bar from the list.
4 In the Menu bar mode section, enable one of the following options:
   • Normal mode — displays all available menus
   • File mode — displays a limited selection of menus

For information about the other settings on this page, see “To modify toolbar appearance” on page 968.

To reset menus to the default setting

1 Click Tools ▶ Options ▶ Customization.
2 In the left pane of the Options dialog box, click Command Bars.
3 Choose Menu bar from the list.
4 Click Reset.

Customize toolbars and other command bars

You can customize toolbar position and display. For example, you can move or resize a toolbar, and you can choose to hide or display a toolbar. The terms toolbars and command bars are used interchangeably in the user interface and documentation of the application.

Toolbars can be either docked or floating. Docking a toolbar attaches it to the edge of the application window. Undocking a toolbar pulls it away from the edge of the application window, so it floats and can be easily moved around. You can create, delete, and rename custom toolbars. You can customize toolbars by adding, removing, and arranging toolbar items. You can adjust toolbar appearance by resizing buttons; and displaying images, captions, or both. You can also replace toolbar button images.

When moving, docking, and undocking toolbars, you use the grab area of the toolbar.

For a

Docked and unlocked toolbar

The grab area is

Identified by a dotted line at the top or left edge of the toolbar

Floating toolbar

The title bar. If the title is not displayed, the grab area is identified by a dotted line at the top or left edge of the toolbar.

If you do not want to move docked toolbars by mistake, you can lock them. Locked toolbars do not have a dotted line along their left edge.
The procedures in this topic apply to toolbars as well as other command bars such as the menu bar, property bar, status bar, toolbox, and context menu bar.

To customize toolbar position and display

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move a toolbar</td>
<td>Unlock the toolbar, click the toolbar’s grab area, and drag the toolbar to a new position.</td>
</tr>
<tr>
<td>Dock a toolbar</td>
<td>Click the toolbar’s grab area, and drag the toolbar to any edge of the application window.</td>
</tr>
<tr>
<td>Undock a toolbar</td>
<td>Unlock the toolbar, click the toolbar’s grab area, and drag the toolbar away from the edge of the application window.</td>
</tr>
<tr>
<td>Resize a floating toolbar</td>
<td>Point to the edge of the toolbar and, using the two-directional arrow, drag the edge of the toolbar.</td>
</tr>
<tr>
<td>Hide or display a toolbar</td>
<td>Click Tools ▶ Options ▶ Customization. Click Command Bars, and disable or enable the check box next to the toolbar name.</td>
</tr>
<tr>
<td>Reset a toolbar to its default setting</td>
<td>Click Tools ▶ Options ▶ Customization. Click Command Bars, click a toolbar, and click Reset.</td>
</tr>
</tbody>
</table>

Docked toolbars cannot be moved when they are locked. For information about unlocking toolbars, see “To lock or unlock toolbars” on page 969.

To add, delete, or rename a custom toolbar

<table>
<thead>
<tr>
<th>To</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a custom toolbar</td>
<td>Click Tools ▶ Options ▶ Customization. Click Command Bars, click New, and type a name in the Command bars list. Close the dialog box. Holding down Alt + Ctrl, drag a tool or button in the application window to the new toolbar. You can also drag commands from the Commands list in the Options dialog box.</td>
</tr>
</tbody>
</table>
To Do the following

Delete a custom toolbar
Click Tools ➤ Options ➤ Customization. Click Command Bars, click a toolbar, and click Delete.

Rename a custom toolbar
Click Tools ➤ Options ➤ Customization. Click Command Bars, click the custom toolbar name to select it, and then click it one more time to enter edit mode. Type a new name.

To add, remove, and position an item on a toolbar
1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
3. Choose a command category from the top list box.
4. Drag a toolbar item from the list to a toolbar in the application window.
   If you want to remove an item from a toolbar, drag the toolbar item off the toolbar.
5. On the toolbar in the application window, drag the toolbar item to a new position.
   If you want to move a toolbar item to another toolbar, drag the toolbar item icon from one toolbar to the other.

💡 You can copy a toolbar item to another toolbar by holding down Ctrl while dragging a toolbar item. If the Options dialog box is not open, you must hold down Alt+Ctrl.

To modify toolbar appearance
1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Command Bars.
3. To change the button size on all toolbars, choose a size from the Global button size list box.
4. Click a toolbar name in the list.
5. Choose a button size from the Size list box in the Button properties area.
6. From the Style list box in the Button properties area, choose one of the following:
   - Default
   - Image Only
   - Caption Only
   - Caption to Right of Image

   If you want to hide the title when the toolbar is floating, disable the Show title when toolbar is floating check box.

💡 You can reset a built-in toolbar to its default settings by clicking Reset.
   You can lock all toolbars by enabling the Lock toolbars check box.

To replace a toolbar button image
1. Click Tools ➤ Options ➤ Customization.
2. In the left pane of the Options dialog box, click Commands.
3. Choose a command category from the top list box.
4 Click a toolbar command.
5 Click the General tab.
6 In the Icon area, click Browse, and navigate to the icon you want to use.

The image you want to use must have an .ico extension.

You can reset toolbar button images to the default settings by clicking Restore Defaults.

To lock or unlock toolbars
• Click Window → Toolbars → Lock toolbars.

The Lock toolbars command is enabled when a check mark appears beside it. When you launch the application for the first time, the toolbars are locked by default.

Floating toolbars cannot be locked.

You can also lock or unlock toolbars by right-clicking a toolbar and clicking Lock toolbars.

Customize the toolbox
You can add or remove tools from the toolbox. If you modify the toolbox, you can reset the default settings at any time.
You can also modify the appearance of buttons in the toolbox and more. For more information, see “Customize toolbars and other command bars” on page 966.

To customize the toolbox
1 At the bottom of the toolbox, click the Quick customize button.
2 To add or remove tools, enable or disable any of the check boxes.

You can also

Reset the toolbox
Click the Reset toolbar button.

Customize the toolbox
Click the Customize button.

Customize the property bar
You have control over the placement and content of the property bar. You can move the property bar anywhere on screen. Placing it inside the application window creates a floating property bar. Placing it on any of the four sides of the application window docks it, making it part of the window border.
When moving, docking, or undocking the property bar, you use the grab area of the property bar, which is the same as the grab area of a toolbar. For more information about the grab area, see “Customize toolbars and other command bars” on page 966.

You can also customize the property bar by adding or removing tools. This lets you customize what appears on the property bar when you choose various tools. For example, when the Text tool is active, you can have the property bar display additional commands for text-related tasks such as increasing or decreasing font size, or changing case. You can also reset the property bar to its default settings.

Plus, you can change the size and style of the buttons on the property bar. For more information, see “To modify toolbar appearance” on page 968.

To position the property bar

To
Do the following

Move the property bar
Unlock the property bar, click the property bar’s grab area, and drag the property bar to a new position.

Undock the property bar
Click the property bar’s grab area, and drag the property bar away from the edge of the application window.

Dock the property bar
Click the property bar’s grab area, and drag the property bar to any edge of the application window.

To add or remove a toolbar item on the property bar

1 On the property bar, click the Quick customize button.
2 Enable or disable the check boxes next to the items that you want to add or remove.

You can also

Reset the property bar
Click the Reset toolbar button.

Customize the property bar
Click the Customize button.

The new item is displayed on the property bar for the active tool or task. When the property bar content changes, the item is not displayed. The new item is displayed again when the related tool or task is activated.

You can also customize the property bar by clicking Tools  Options  Customization. In the left pane of the Options dialog box, click Commands, choose a command category from the top list box, and then drag a toolbar item from the list to the property bar. If you want to remove an item from the property bar, press Alt and drag the toolbar item icon off the property bar.

You can also modify the buttons on the property bar. For more information, see “To modify toolbar appearance” on page 968.
Customize the status bar

The status bar displays information about selected objects, such as color, fill type, and outline. The status bar also shows the current cursor position and relevant commands. In addition, it displays document color information, such as the document color profile and color proofing status. You can customize the status bar by changing the information that is displayed and by resizing it. You can also customize the status bar by adding, removing, and resizing toolbar items. In addition, you can restore the status bar to its default settings. You can also place the status bar at the top of the application window to see the displayed information more easily.

To change the information the status bar displays

- Click the button next to the displayed information and choose one of the following options:
  - Tool Hints
  - Object Details
  - Cursor Coordinates
  - Document Color Settings

To resize the status bar

1. Click Tools ➤ Options ➤ Customization.
2. Click Command Bars.
3. Choose Status bar from the list.
4. In the Status bar properties area, type 1 or 2 in the Number of lines when docked box.

To add or remove a toolbar item on the status bar

1. Click Tools ➤ Options ➤ Customization.
2. Click Commands.
3. Choose a command category from the top list box.
4. Press Alt and drag a toolbar item from the list to the status bar.
   
   If you want to remove a toolbar item from the status bar, drag the item off the status bar.

To resize toolbar items on the status bar

1. Click Tools ➤ Options ➤ Customization.
2. Click Command Bars.
3. Click Status bar, and enable the check box.
4. Choose one of the following options from the Size list box in the Button properties area:
   - Small
   - Medium
   - Large

To change the position of the status bar

- Right-click the status bar, click Customize ➤ Status bar ➤ Position, and click Top or Bottom.

To restore the status bar default settings

- Right-click the status bar, and click Customize ➤ Status bar ➤ Reset to Default.
Customize filters

Filters are used to convert files from one format to another. They are organized into four types: raster, vector, animation, and text. You can customize filter settings by adding or removing filters so that only the filters you need are loaded. You can also change the order of the list of filters and reset filters to the default setting.

To add a filter

1. Click Tools ➤ Options ➤ Global.
2. Click File Formats.
3. Click a type of filter in the Available file types list.
4. Click a filter.
5. Click Add.

To remove a filter

1. Click Tools ➤ Options ➤ Global.
2. Click File Formats.
3. Click a filter in the Active filters list.
4. Click Remove.

To change the order of the list of filters

1. Click Tools ➤ Options ➤ Global.
2. Click File Formats.
3. Click a filter in the Active filters list.
4. Click one of the following:
   • Move Up — moves the filter up the list
   • Move Down — moves the filter down the list

💡 You can reset the Active filters list to the default setting by clicking Reset to Default.
Use macros and scripts to automate tasks

You can use macros and scripts to speed up repetitive tasks, combine multiple or complex actions, or make an option more easily accessible. You create macros by using the built-in features for Visual Basic for Applications (VBA) or Visual Studio Tools for Applications (VSTA), and you can create scripts by using the built-in JavaScript features.

Using a macro (or script) is similar to using the speed-dialing feature on a phone. On many phones, you can set a frequently dialed number to a speed-dial button; then, the next time you need to dial that number, you can save time by pressing its speed-dial button. Similarly, a macro lets you set the actions that you want to repeat; then, the next time that you need to repeat those actions, you can save time by playing that macro.

This section contains the following topic:
- “Macros” (page 973)
- “JavaScript scripts” (page 980)

Macros

You can save time by using a macro to automate a series of repetitive tasks. A macro lets you specify a sequence of actions so that you can quickly repeat those actions later.

You don’t need any programming experience to use macros — in fact, the basic tools for working with macros are available within the main application window. However, if you want to have more control over your macros, you can use the following built-in programming environments:
- Microsoft Visual Studio Tools for Applications (VSTA) — the successor to VBA, and an excellent choice for developers and other programming experts. VSTA provides the tools and features that you need to create the most advanced macro projects.
- Microsoft Visual Basic for Applications (VBA) — a subset of the Microsoft Visual Basic (VB) programming environment, and an excellent choice for beginners. You can use VBA to create basic macros for personal use, but you can also use it to create more advanced macro projects.

For detailed information on the differences between VBA and VSTA, please see the programming guide on the Developer area on the CorelDRAW community website.

Getting started with macros

The macro features for VBA and VSTA are installed with the software by default, but you can manually install these features if necessary. You can specify options for the VBA feature.
To use VSTA macro features with CorelDRAW, you must have Microsoft Visual Studio 2019 installed. To use the VSTA Editor, you must first install Microsoft Visual Studio 2019, Community, Professional, Premium, Ultimate or Enterprise Edition; and then reinstall Microsoft Visual Studio Tools for Applications 2019 from microsoft.com.

If you install Microsoft Visual Studio after installing CorelDRAW Graphics Suite, you must re-install the VSTA macro features by modifying your CorelDRAW Graphics Suite installation. For more information, see “To manually install the macro features” on page 975.

The macro features provide several tools for working with macros in the main application window:

- Macros toolbar — provides easy access to common macro functions
- Scripts docker — provides easy access to all available macro projects for VBA, and to basic functions for working with those projects
- Script Editor (formerly the Visual Basic Editor) — provides advanced functions for creating VBA-based macro projects
- Visual Studio Editor — provides advanced functions for creating VSTA-based macro projects. The VSTA Editor is accessible only if you have Microsoft Visual Studio 2019 installed.

Creating macros

Macros are stored in modules (also called “code modules”), which are stored in macro projects. The Scripts docker lets you view and manage all of the macro projects, modules, and macros that are available to you.

You can use the Scripts docker to create macro projects in the form of Global Macro Storage (GMS) files or Corel VSTA Projects (CGSaddon). Using such files is an excellent way to bundle the components of your macro project for sharing with others. You can use the Scripts docker to open (or “load”) the macro projects that you create, as well as the macro projects that install with the software or that are otherwise made available to you. You can also use the Scripts docker to rename macro projects, as well as to copy and close (or “unload”) GMS-based and VSTA macro projects.

Some macro projects are locked and cannot be modified.

When you create a document, a macro project for that document is automatically added to the Scripts docker. Although you can store macros within the macro project for a document — for example, to create an all-in-one template — it is recommended that you instead use GMS files to store your macro projects.

Each macro project contains at least one module. You can use the Scripts docker to add a module to a VBA-based macro project, or to open existing modules for editing. You can also use the Scripts docker to rename or delete VBA modules.

The editing feature is disabled for some modules.

Finally, you can use the Scripts docker to create macros within the available modules. You don’t need any programming experience to create macros; however, if you have programming experience and want to edit VBA macros, you can do so by using the Script Editor. You can also use the Scripts docker to rename and delete VBA macros.

Recording macros

You can record macros and save them for later use.

You can also record temporary macros for actions that you need to repeat only a few times. A temporary macro is accessible until a new temporary macro is recorded.

The recording feature is disabled for some macro projects.
Before recording a macro, make sure that you know exactly which actions you want to record and the order in which you want to record them. When you start recording, the macro recorder captures every change that you make in a drawing. For example, if you create a shape, resize the shape, and then change its color, the macro records all the changes. When you are done making the changes, you must stop recording the macro.

**Playing macros**

You can perform the actions that are associated with a macro by playing that macro.

You can also play a temporary macro.

**Learning more about macros**

The Developer area on the CorelDRAW community website can help you with its wealth of useful resources: a programming guide, detailed Object Model reference documentation with code samples, object model diagrams, and in-depth programming articles and tutorials.

The Object Model reference documentation, also referred to as API documentation, includes help on every feature and function that can be automated in the applications. (Collectively, these features and functions are called an “object model.”) You can easily access relevant documentation from within the Script Editor.

The Object Model diagrams provide a hierarchical representation of the features and functions that can be automated in CorelDRAW, Corel PHOTO-PAINT, and Corel DESIGNER.

For more detailed information about VBA and its programming environment, please consult the Microsoft Visual Basic Help from the Help menu in the Script Editor.

For more detailed information about VSTA and its programming environment, please consult the Help menu in the VSTA Editor.

**To manually install the macro features**

1. On the Windows Control Panel, click **Uninstall a program**.
2. Double-click **CorelDRAW Graphics Suite** on the **Uninstall or change a program** page.
3. Enable the **Modify** option in the wizard that appears, and follow the instructions.
4. On the **Features** page of the installation wizard, enable the following check boxes in the **Utilities** list box:
   - Visual Basic for Applications
   - Visual Studio Tools for Applications

   The macro features for VBA and VSTA are installed with the software by default.

**To specify VBA options**

1. Click **Tools ▶ Options ▶ CorelDRAW**.
2. Click **VBA**.
3. In the **Security** area, specify how to control the risk of running malicious macros by clicking **Security Options**. If you want to bypass this security feature, enable the **Trust all installed GMS modules** check box, and then proceed to step 6.
4. On the **Security level** page of the **Security** dialog box, enable one of the following options:
   - **Very high** — allows only macros installed in trusted locations to run. All other signed and unsigned macros are disabled.
   - **High** — allows only signed macros from trusted sources to run. Unsigned macros are automatically disabled.
• **Medium** — lets you choose which macros run, even if they are potentially harmful
• **Low (not recommended)** — allows all potentially unsafe macros to run. Enable this setting if you have virus-scanning software installed, or if you check the safety of all documents that you open.

5. On the **Trusted publishers** page of the **Security** dialog box, review which macro publishers are trusted. Click **View** to display details on the selected macro publisher, or click **Remove** to delete the selected macro publisher from the list.

   If desired, you can enable or disable the **Trust access to Visual Basic project** check box for the selected macro publisher.

6. Disable the **Delay load VBA** check box if you want to load the VBA feature at start-up.

### To access the macro tools

To

**Display the Macros toolbar**

Click **Window**  **Toolbars**  **Macros**.

A check mark next to the command indicates that the toolbar is displayed.

**Display the Scripts docker**

Click **Tools**  **Scripts**  **Scripts**.

**Display the Script Editor**

Do one of the following:

• Click **Tools**  **Scripts**  **Script Editor**.

• Click the **Script Editor** button on the **Macros** toolbar.

• Right-click **Visual Basic for Applications** in the **Scripts** docker, and then click **Show IDE**.

**Display the Visual Studio Editor**

Click **Tools**  **Scripts**  **Visual Studio Editor**. (VSTA must be installed on your computer.)

### To create a macro project

**In the Scripts docker**, do one of the following:

• Click **Visual Studio Tools for Applications** in the list, click **New**, and then click **New macro project**.

• Click **Visual Basic for Applications** in the list, click **New**, and then click **New macro project**.

You can also

**Open (or “load”) a macro project**

Do one of the following:

• Click **Visual Studio Tools for Applications** in the list, click **Load**, and then choose the project.

• Click **Visual Basic for Applications** in the list, click **Load**, and then choose the project.

**Rename a macro project**

Right-click the project in the list, and then click **Rename**.

**Copy a GMS-based macro project**

Right-click the project in the list, click **Copy to**, and then choose the target location for the copied project.

You cannot copy a document-based macro project. Such projects are stored within a document and cannot be managed separately from that document.
You can also

Display or hide all modules in the list

Add a module to a VBA macro project

Edit a module in a VBA macro project

Rename a module in a macro project

Delete a module from a macro project

Close (or “unload”) a GMS-based macro project

Some macro projects are locked and cannot be modified.

To create a macro

- In the Scripts docker, do one of the following:
  - Click the container you want, click New, and then click New macro.
  - Right-click the desired container module, and then click New macro.

You can also

Edit a macro

Delete a macro
Some macro projects are locked and cannot be modified.

To record a macro

1. Click Tools ➤ Scripts ➤ Start Recording. The Record macro dialog box appears.
2. In the Macro name box, type a name for the macro. Macro names can contain numerals, but they must begin with a letter. Macro names cannot contain spaces or non-alphanumeric characters other than underscores (_).
3. In the Save Macro In box, choose the macro project to which you want to save the macro.
4. Type a description of the macro in the Description box, and then click OK.
5. Perform the actions that you want to record.
   The application begins recording your actions. If you want to pause recording, click Tools ➤ Scripts ➤ Pause recording. Repeat this step to resume recording.
6. To stop recording, click File ➤ Scripts ➤ Stop Recording.

You can also

Save the actions in the Undo list as a VBA macro or a script. Click Window ➤ Dockers ➤ History, perform the actions that you want to record, and then click the Save as a script button in the History docker.

You cannot record a macro if all available macro projects are locked.

Not all actions can be recorded — some because of their complexity (although many such actions can be manually coded in the Script Editor). When an action cannot be recorded, a comment is placed in the macro code (“The recording of this command is not supported.”), but the recording process continues until you stop it. You can view any comments in the code by opening the macro in the Script Editor.

By default, macros are recorded in the GlobalMacros project so that they can be accessed from other documents. However, you can change the default macro project for recordings by right-clicking another project in the Scripts docker, and then clicking Set as recording project. You cannot specify a locked macro project.

You can cancel recording a macro, and discard any commands recorded thus far, by clicking Tools ➤ Scripts ➤ Cancel recording.

You can also record, pause, and stop recording a macro by using the Macros toolbar or the Scripts docker (File ➤ Scripts ➤ Scripts).

To record a temporary macro

1. Click Tools ➤ Scripts ➤ Record Temporary Script.
2. Perform the actions that you want to record.
   The application begins recording your actions. If you want to pause recording, click Tools ➤ Scripts ➤ Pause Recording. Repeat this step to resume recording.
To stop recording, click **File ➤ Scripts ➤ Stop Recording.**

The macro is temporarily saved to the default recording project. When the current session is ended, the macro is deleted from that project.

You cannot record a temporary macro if all available macro projects are locked.

Not all actions can be recorded.

By default, macros are recorded in the **GlobalMacros** project so that they can be accessed from other documents. However, you can change the default recording project by right-clicking another project in the **Scripts** docker, and then clicking **Set as recording project.** (You cannot specify a locked macro project.) If you want, you can create multiple temporary recordings by assigning each one to its own macro project.

You can cancel recording a macro, and discard any commands recorded thus far, by clicking **Tools ➤ Scripts ➤ Cancel Recording.**

You can also pause and stop recording a temporary macro by using the **Macros** toolbar or the **Scripts** docker (**Tools ➤ Scripts ➤ Scripts**).

**To play a macro**

- Do any of the following:
  - Click **Tools ➤ Scripts ➤ Run Script**, or click the **Run macro** button on the **Macros** toolbar. From the **Macros in** list box, choose the project or file in which the macro is stored. From the **Macro name** list, choose the macro. Click **Run.**
  - In the **Scripts** docker, double-click the macro in the list.
  - In the **Scripts** docker, click the macro in the list, and then click the **Run** button.
  - In the **Scripts** docker, right-click the macro in the list, and then click **Run.**

**To play a temporary macro**

- Click **Tools ➤ Scripts ➤ Run Temporary Script.**

This option is enabled only after you record a temporary macro.

If you have created multiple temporary macros, you must specify which macro project contains the one that you want to run. Right-click the project in the **Scripts** docker, and then click **Set as recording project.**

**To access Object Model reference documentation from within the Script Editor**

1. While in Microsoft Visual Basic for Applications, press **F2** to display the Object Browser.
   The Object Browser displays all the features and functions that can be automated in the Script Editor.

2. Choose **VGCore** from the **Library** list box.
   The Object Browser is updated to display only the features and functions of CorelDRAW that can be automated in the Script Editor. Collectively, these features and functions are called an “object model.”

3. Click an item in the Object Browser, and press **F1**.

You can also display information for any item in the **Code** window of the Script Editor by clicking that item and pressing **F1**.
JavaScript scripts

You can save time by using a JavaScript script to automate a series of repetitive tasks. The Scripts docker (Tools ▶ Scripts ▶ Scripts) lets you load, run, rename, and delete scripts.

You can record scripts and save them for later use. You can also record temporary scripts for actions that you need to repeat only a few times. A temporary script is accessible until a new temporary script is recorded.

Before recording a script, make sure that you know exactly which actions you want to record and the order in which you want to record them. When you start recording, the script recorder captures every change that you make in a drawing. For example, if you create a shape, resize the shape, and then change its color, the script records all the changes. When you are done making the changes, you must stop recording the script.

You can perform the actions that are associated with a script by playing that script. You can also play a temporary script.

To load a script
• In the Scripts docker, click Load, and then choose the folder where the script is located.

To record a script
1 Click Tools ▶ Scripts ▶ Start Recording.
   The Record script dialog box appears.
2 In the Macro name box, type a name for the script.
3 In the Save Macro In box, click User Scripts.
4 Type a description of the script in the Description box, and then click OK.
5 Perform the actions that you want to record.
   The application begins recording your actions. If you want to pause recording, click Tools ▶ Scripts ▶ Pause recording. Repeat this step to resume recording.
6 To stop recording, click Tools ▶ Scripts ▶ Stop Recording.

You can cancel recording a macro, and discard any commands recorded thus far, by clicking Tools ▶ Scripts ▶ Cancel Recording.

You can also record, pause, and stop recording a macro by using the Scripts docker (Tools ▶ Scripts ▶ Scripts).

To record a temporary script
1 Click Tools ▶ Scripts ▶ Record Temporary Script.
2 Perform the actions that you want to record.
   The application begins recording your actions. If you want to pause recording, click Tools ▶ Scripts ▶ Pause Recording. Repeat this step to resume recording.
3 To stop recording, click Tools ▶ Scripts ▶ Stop Recording.
Not all actions can be recorded.
You can cancel recording a script, and discard any commands recorded thus far, by clicking Tools ➤ Scripts ➤ Cancel Recording.
You can also pause and stop recording a temporary macro by using the Scripts docker (Tools ➤ Scripts ➤ Scripts).

To play a script
• In the Scripts docker, click the script in the list, and then click the Run button ➤.

To play a temporary script
• Click Tools ➤ Scripts ➤ Run Temporary Script.

This option is enabled only after you record a temporary script.

To edit a script
• In the Scripts docker, click the script in the list, and then click the Edit button ☑️.
The script is usually displayed in Notepad. If the script fails to open, make sure to associate JavaScript files with Notepad. For more information, see “To associate JavaScript files with Notepad” on page 981.

To rename a script
• In the Scripts docker, click the script name twice and type the new name.

To delete a script
• In the Scripts docker, click the script in the list, and then click the Delete button ☑️.

To associate JavaScript files with Notepad
1 In File Explorer, right-click a JavaScript file, and click Properties.
2 On the General tab of the dialog box, click Change in the Opens with area.
3 Choose to open .js files in Notepad.
Reference

CorelDRAW for Adobe Illustrator users ...............................................................................................................................................985
Glossary............................................................................................................................................................................................... 991
Adobe Illustrator and CorelDRAW have many similarities, which makes it easy to move from one graphics application to the other. Although they share most basic drawing and design capabilities, Adobe Illustrator and CorelDRAW are distinguished by some differences in both terminology and tools. Understanding these differences lets you make a quick transition to CorelDRAW.

This section contains the following topics:
- “Compare terminology” (page 985)
- “Compare tools” (page 986)
- “Using the Adobe Illustrator workspace” (page 989)

**Compare terminology**

The terms and concepts in Adobe Illustrator and CorelDRAW differ for some features. Adobe Illustrator terms are listed below with their CorelDRAW equivalents.

<table>
<thead>
<tr>
<th>Adobe Illustrator term</th>
<th>CorelDRAW term</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions/Scripts</td>
<td>Macros/Scripts</td>
</tr>
<tr>
<td>Anchor points</td>
<td>Nodes</td>
</tr>
<tr>
<td>Artwork</td>
<td>Drawing</td>
</tr>
<tr>
<td>Clipping mask</td>
<td>PowerClip</td>
</tr>
<tr>
<td>Direction points</td>
<td>Control handles</td>
</tr>
<tr>
<td>Guides</td>
<td>Guidelines</td>
</tr>
<tr>
<td>Smart guides</td>
<td>Dynamic guides</td>
</tr>
</tbody>
</table>
### Adobe Illustrator term | CorelDRAW term
--- | ---
Gradient fill | Fountain fill
Live Color | Color styles, color harmonies
Outline view | Wireframe view
Panels | Dockers
Path | Curve
Placing files | Importing files
Rasterizing | Converting to a bitmap
Stroke | Outline
Swatches panel | Color palette

### Compare tools
The following table lists Adobe Illustrator tools and the corresponding CorelDRAW tools. Many of the tools create the same result but operate slightly differently.

<table>
<thead>
<tr>
<th>Adobe Illustrator tool</th>
<th>CorelDRAW tool</th>
</tr>
</thead>
</table>
| Add Anchor Point tool  | Shape tool | . See “To add or delete a node” on page 227.
| Area Type tool         | Text tool A | . See “To add paragraph text” on page 601.
| Blend tool             | Blend tool | . See “To blend objects” on page 575.
| Bloat tool             | Envelope tool | . See “To apply an envelope” on page 245.
| Convert Anchor Point tool | Shape tool | . See “To shape a curve object by using cusp, smooth, or symmetrical nodes” on page 229.
| Delete Anchor Point tool | Shape tool | . See “To add or delete a node” on page 227.
| Direct Selection tool  | Shape tool | . See “To select a node” on page 215.
<table>
<thead>
<tr>
<th>Adobe Illustrator tool</th>
<th>CorelDRAW tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Shadow tool</td>
<td>Drop shadow tool</td>
</tr>
<tr>
<td>Gradient tool</td>
<td>Interactive fill tool</td>
</tr>
<tr>
<td>Line Segment tool</td>
<td>Freehand tool</td>
</tr>
<tr>
<td>Live Paint Bucket tool</td>
<td>Polyline tool</td>
</tr>
<tr>
<td>Live Trace command</td>
<td>Bitmaps Quick Trace command</td>
</tr>
<tr>
<td>Measure tool</td>
<td>Dimension tool</td>
</tr>
<tr>
<td>Mesh tool</td>
<td>Mesh fill tool</td>
</tr>
<tr>
<td>Paintbrush tool</td>
<td>Artistic media tool</td>
</tr>
<tr>
<td>Pan tool</td>
<td>Brush tool</td>
</tr>
<tr>
<td>Path Type tool</td>
<td>Pan tool</td>
</tr>
<tr>
<td>Pathfinder effects</td>
<td>Text tool</td>
</tr>
<tr>
<td>Pencil tool</td>
<td>Freehand tool</td>
</tr>
<tr>
<td>Pucker tool</td>
<td>Envelope tool</td>
</tr>
</tbody>
</table>

See “To add a drop shadow or an inner shadow” on page 566.

See “Fountain fills” on page 426.

See “To draw a curve by using the 3-point curve tool” on page 162.

See “Lines” on page 155.

See “To apply a fill to an enclosed area” on page 444.

See “Dimension lines” on page 194.

See “To apply a mesh to an object” on page 441.

See “To draw a calligraphic line” on page 167.

See “Brushstrokes” on page 186.

See “To pan in the drawing window” on page 71.

See “To fit text to a path” on page 615.

See “Trim objects” on page 258 and “Weld and intersect objects” on page 262.

See “To add a line by using the Freehand tool” on page 158.

See “To apply an envelope” on page 245.
<table>
<thead>
<tr>
<th>Adobe Illustrator tool</th>
<th>CorelDRAW tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reflect tool</td>
<td>Mirror buttons. See “To mirror an object” on page 349.</td>
</tr>
<tr>
<td>Reshape tool</td>
<td>Shape tool. See “Stretching nodes” on page 229.</td>
</tr>
<tr>
<td>Rotate tool</td>
<td>Pick tool. See “To rotate an object” on page 348.</td>
</tr>
<tr>
<td>Rounded Rectangle tool</td>
<td>Rectangle tool. See “To draw a rectangle or square with rounded, scalloped, or chamfered corners” on page 203.</td>
</tr>
<tr>
<td>Save For Microsoft Office command</td>
<td>File  Export For  Office command</td>
</tr>
<tr>
<td>Scale tool</td>
<td>Pick tool. See “Size and scale objects” on page 346.</td>
</tr>
<tr>
<td>Scissors tool</td>
<td>Knife tool. See “To split an object” on page 257.</td>
</tr>
<tr>
<td>Selection tool</td>
<td>Pick tool. See “To select objects” on page 303.</td>
</tr>
<tr>
<td>Shear tool</td>
<td>Pick tool. See “Skew and stretch objects” on page 232.</td>
</tr>
<tr>
<td>Star tool</td>
<td>Star and Complex star tools. See “To draw a star” on page 206.</td>
</tr>
<tr>
<td>Symbol Sprayer tool</td>
<td>Sprayer tool. See “To spray a pattern” on page 189.</td>
</tr>
<tr>
<td>Twirl tool</td>
<td>Distort tool. See “To distort an object” on page 241.</td>
</tr>
<tr>
<td>Type tool</td>
<td>Text tool. See “To add paragraph text” on page 601 and “To add artistic text” on page 599.</td>
</tr>
<tr>
<td>Vertical Type tool</td>
<td>Paragraph formatting docker. See “To choose a text orientation for Asian text” on page 655.</td>
</tr>
<tr>
<td>Warp tool</td>
<td>Smudge tool. See “To smudge an object” on page 234.</td>
</tr>
<tr>
<td></td>
<td>Envelope tool. See “Shape objects by using envelopes” on page 243.</td>
</tr>
</tbody>
</table>
Adobe Illustrator tool

CorelDRAW tool

Width tool

Variable Outline tool. See “To vary the width of an outline” on page 182.

Wrinkle tool

Roughen tool. See “To roughen an object” on page 236.

Using the Adobe Illustrator workspace

CorelDRAW includes a workspace that has the look and feel of Adobe Illustrator. This workspace can help you find menu commands and tools more easily. For information about changing your workspace, see “To choose a workspace” on page 106.
accelerator table
A file that contains a list of shortcut keys. Different tables are active depending on the task that you are performing.

add-in
A separate module that extends the functionality of an application.

alignment guides or live guides
Temporary guidelines that help align objects as you create, resize, or move them in relation to other nearby objects.

anchor point
The point that remains stationary when you stretch, scale, mirror, or skew an object. Anchor points correspond to the eight handles that appear when an object is selected, as well as the center of a selection box marked by an X.

animation file
A file that supports moving images; for example, animated GIF and QuickTime (MOV).

anti-aliasing
A method of smoothing curved and diagonal edges in images. Intermediate pixels along edges are filled to smooth the transition between the edges and the surrounding area.

arrow keys
Direction keys that move or “nudge” selected objects in small increments. You can also use arrow keys to position the cursor when you type or edit text on-screen or in a dialog box.

artistic text
A type of text created with the Text tool. Use artistic text to add short lines of text, such as titles, or to apply graphic effects, such as fitting text to a path, creating extrusions and blends, and creating all other special effects. An artistic text object can contain up to 32,000 characters.
aspect ratio
The ratio of the width of an image to its height (expressed mathematically as x:y). For example, the aspect ratio of an image that is 640 x 480 pixels is 4:3.

B
base color
The color of the object that appears under a transparency. The base color and the color of the transparency combine in various ways depending on the merge mode you apply to the transparency.

baseline
An invisible line upon which text characters sit.

baseline grid
A series of evenly spaced horizontal lines that follow the pattern of a ruled notebook and help align text and objects.

baseline shift
The process of moving text characters above or below the baseline.

Bézier line
A straight or curved line made up of segments connected by nodes. Each node has control handles that allow the shape of the line to be modified.

bit depth
The number of binary bits that define the shade or color of each pixel in a bitmap. For example, a pixel in a black-and-white image has a depth of 1 bit, because it can only be black or white. The number of color values that a given bit depth can produce is equal to 2 to the power of the bit depth. For example, a bit depth of 1 can produce two color values (2^1=2), and a bit depth of 2 can produce 4 color values (2^2 = 4).

Bit depth ranges between 1 and 64 bits per pixel (bpp) and determines the color depth of an image.

bitmap
An image composed of grids of pixels or dots.

See also vector graphic.

black point
A brightness value that is considered black in a bitmap image. In Corel PHOTO-PAINT, you can set the black point to improve the contrast of an image. For example, in a histogram of an image, with a brightness scale of 0 (dark) to 255 (light), if you set the black point at 5, all pixels with a value greater than 5 are converted to black.

black-and-white color mode
A 1-bit color mode that stores images as two solid colors — black and white — with no gradations. This color mode is useful for line art and simple graphics. To create a black-and-white photo effect, you can use the grayscale color mode.

See also grayscale.

bleed
The part of the printed image that extends beyond the edge of the page. The bleed ensures that the final image goes right to the edge of the paper after binding and trimming.

blend
An effect created by transforming one object into another through a progression of shapes and colors.

bookmark
An indicator for marking an address on the Internet.
bounding box
The invisible box indicated by the eight selection handles surrounding a selected object.

brightness
The amount of light that is transmitted or reflected from a given pixel. In the HSB color mode, brightness is a measure of how much white a color contains. For example, a brightness value of 0 produces black (or shadow in photos), and a brightness value of 255 produces white (or highlight in photos).

C
calligraphic angle
The angle that controls the orientation of a pen to the drawing surface, like the slant of the nib on a calligraphy pen. A line drawn at the calligraphic angle has little or no thickness, but widens as its angle gets farther from the calligraphic angle.

cascading style sheet (CSS)
An extension to HTML that allows styles such as color, font, and size to be specified for parts of a hypertext document. Style information can be shared by multiple HTML files.
See also HTML.

center of rotation
The point around which an object rotates.

CGI script
An external application that is executed by an HTTP server in response to an action you perform in a web browser, such as clicking a link, image, or another interactive element of a webpage.

character
A letter, number, punctuation mark, or other symbol.

child color
A color style created as a shade of another color style. For most of the available color models and palettes, child colors share the same hue as the parent, but have different saturation and brightness levels.
See also parent color.

choke
In commercial printing, a form of trapping created by extending the background object into the foreground object.

clipart
Ready-made images that can be imported into Corel applications and edited if required.

Clipboard
An area that is used to temporarily store cut or copied information. The information is stored until new information is cut or copied to the Clipboard, replacing the old.

close clone
A copy of an object or an area of an image that is linked to a master object or image area. Most changes made to the master are automatically applied to its clones.
See also symbol.

closed object
An object defined by a path whose start point and end point are connected.

closed path
A path whose start point and end point are connected.
color cast
A color tint that often occurs in photos as a result of lighting conditions or other factors. For example, taking a photo indoors in dim incandescent light can result in a yellow color cast, and taking a photo outdoors in bright sunlight can result in a blue color cast.

color depth
The maximum number of colors an image can contain. Color depth is determined by the bit depth of an image and the displaying monitor. For example, an 8-bit image can contain up to 256 colors, while a 24-bit image can contain roughly up to 16 million colors. A GIF image is an example of an 8-bit image; a JPEG image is an example of a 24-bit image.

color object or control group
An object or a group of objects to which a special effect, such as an extrusion, blend, drop shadow, or contour, is applied. You can edit the control object or group by changing its shape, color or position or by applying a transformation, thus modifying the overall appearance of the special effect.
With blends, the start and end objects of the blend are the control objects.

CMY
A color mode made up of cyan (C), magenta (M), and yellow (Y). This mode is used in the three-color printing process.

CMYK
A color mode made up of cyan (C), magenta (M), yellow (Y), and black (K). CMYK printing produces true blacks and a wide tonal range. In the CMYK color mode, color values are expressed as percentages; therefore, a value of 100 for an ink means that the ink is applied at full saturation.

code page
A code page is a table in the DOS or Windows operating system that defines which ASCII or ANSI character set is used for displaying text. Different character sets are used for different languages.

color channel
An 8-bit grayscale version of an image. Each channel represents one level of color in the image; for example, RGB has three color channels, while CMYK has four. When all the channels are printed together, they produce the entire range of colors in the image.
See also RGB and CMYK.

color gamut
The range of colors that can be reproduced or perceived by any device. For example, a monitor displays a different color gamut than a printer, making it necessary to manage colors from original images to final output.

color mode
A system that defines the number and kind of colors that make up an image. Black-and-white, grayscale, RGB, CMYK, and paletted are examples of color modes.

color model
A simple color chart that defines the range of colors displayed in a color mode. RGB (red, green, blue), CMY (cyan, magenta, yellow), CMYK (cyan, magenta, yellow, black), HSB (hue, saturation, brightness), HLS (hue, lightness, saturation), and CIE L*a*b (Lab) are examples of color models.

color palette
A collection of solid colors from which you can choose colors for fills and outlines.

color profile
A description of the color-handling capabilities and characteristics of a device.

color separation
In commercial printing, the process of splitting colors in a composite image to produce a number of separate grayscale images, one for each primary color in the original image. In the case of a CMYK image, four separations (one for cyan, magenta, yellow, and black) must be made.
color space
In electronic color management, a virtual representation of a device or the color gamut of a color model. The boundaries and contours of a device's color space are mapped by color management software.
See also color gamut.
color swatch
A solid-colored patch in a color palette.
color trapping
A printing term used to describe a method of overlapping colors to compensate for misaligned color separations (misregistration). This method avoids white slivers that appear between adjoining colors on a white page.
See also spread, choke, and overprinting.
color value
A set of numbers that define a color in a color mode. For example, in the RGB color mode, color values of 255 for red (R) and zero for both green (G) and blue (B) result in the color red.
combined object
An object created by combining two or more objects and converting them into a single curve object. A combined object takes on the fill and outline attributes of the last selected object. Sections where an even number of objects overlapped have no fill. Sections where an odd number of objects overlapped are filled. The outlines of the original objects remain visible.
Common Shapes
Predefined shapes, such as basic shapes, arrows, stars, and callouts. Common Shapes often have glyphs, which let you modify their appearance.
compound blend
A blend created by blending the start or end object of one blend with another object.
concave
Hollowed or rounded inward like the inside of a bowl.
content
The object or objects that appear inside a container object when you apply PowerClip effects.
This term is also used to describe graphics resources included with the product such as clipart, photos, symbols, fonts, and objects.
constrain key
A key you hold to constrain drawing and editing to a shape or at an angle. The default key is Ctrl. You can change the default key to Shift, the Windows standard, on the Pick tool page of the Options dialog box.
contour
An effect created by adding evenly spaced concentric shapes inside or outside the borders of an object. This effect can also be used for creating cuttable outlines for devices, such as plotters, engraving machines, and vinyl cutters.
contrast
The difference in tone between the dark and light areas of an image. Higher contrast values indicate greater differences and fewer gradations between dark and light.
control object
The original object used to create effects such as envelopes, extrusions, drop shadows, contours, and objects created with the Artistic media tool. Changes made to the control object control the appearance of the effect.
control handles (CorelDRAW)
The handles that extend from a node along a curve that is being edited with the Shape tool. Control handles determine the angle at which the curve passes through the node.
convex
Curved or rounded outwards like the exterior of a sphere or circle.

crop
To cut unwanted areas of an image without affecting the resolution of the part that remains.

curve object
An object that has nodes and control handles, which you can manipulate to change the object’s shape. A curve object can be any shape, including a straight or curved line.

cusp
A point or corner created where two curves meet.

D
desktop
The area in a drawing where you can experiment and create objects for future use. This area is outside the borders of the drawing page. You can drag objects from the desktop area to the drawing page when you decide to use them.

DeviceN
A type of color space and device color model. This color space is multi-component, allowing color to be defined by other than the standard set of three (RGB) and four (CMYK) color components.

diacritical mark
An accent mark above, below, or through a written character; for example, the acute (é) and cedilla (ç) accents.

dimension line
A line that displays the size of objects or the distance or angle between objects.

dithering
A process used to simulate a greater number of colors when only a limited number of colors are available.

document grid
A series of evenly spaced horizontal and vertical lines that are used to help draw and arrange objects.

document navigator
The area at the bottom of the application window that contains controls for moving between pages and adding pages. The document navigator also displays the page number of the active page.

dpi (dots per inch)
A measure of a printer’s resolution in dots per inch. Typical desktop laser printers print at 600 dpi. Imagesetters print at 1270 or 2540 dpi. Printers with higher dpi capabilities produce smoother and cleaner output. The term dpi is also used to measure scanning resolution and to indicate bitmap resolution.

drawing
A document you create in CorelDRAW.

drawing page
The portion of a drawing window enclosed by a rectangle with a shadow effect.

drawing window
The portion of the application window on which you can create, add, and edit objects.

drop shadow
A three-dimensional shadow effect that gives objects a realistic appearance.
duotone
An image in the duotone color mode is an 8-bit grayscale image that has been enhanced with one to four additional colors.

dynamic guides
Temporary guidelines that appear from the following snap points in objects — center, node, quadrant, and text baseline.

E
embedding
The process of placing an object created in one application into a document created in a different application. Embedded objects are included entirely in the current document; they are not linked to their source files.

encoding
Determines the character set of text, letting you correctly display text in the appropriate language.

envelope
A closed shape that can be placed around an object to change the object’s shape. An envelope consists of segments connected by nodes. After an envelope has been placed around an object, the nodes can be moved to change the shape of the object.

exposure
A photographic term referring to the amount of light used to create an image. If not enough light is permitted to interact with the sensor (in a digital camera) or film (in a traditional camera), the image appears too dark (underexposed). If too much light is permitted to interact with the sensor or film, the image appears too light (overexposed).

extrusion
A feature that lets you apply a three-dimensional perspective by projecting lines from an object to create the illusion of depth.

F
feathering
The level of sharpness along the edges of a drop shadow.

fill
A color, bitmap, fountain, or pattern applied to an area of an image.

filter
An application that translates digital information from one form to another.

floating object
A bitmap with no background. Floating objects are also referred to as photo objects or cutout images.

font
A set of characters with a single style (such as italic), weight (such as bold), and size (such as 10 point) for a typeface such as Times New Roman.

fountain fill
A smooth progression of two or more colors applied to an area of an image that follow a linear, radial, conical, or square path. Two-color fountain fills have a direct progression from one color to another, while custom fills may have a progression of many colors.

fountain step
The shades of color that make up the appearance of a fountain fill. The more steps in a fill, the smoother the transition from the beginning color to the end color.

freehand marquee select
To marquee select objects or nodes while dragging the Shape tool and controlling the shape of the marquee box enclosure as if you were drawing a freehand line.

See also marquee select.
FTP (File Transfer Protocol)
A method of moving files between two computers. Many Internet sites have established repositories of material that can be accessed by using FTP.

G
GIF
A graphic file format designed to use a minimum of disk space and be easily exchanged between computers. This format is commonly used to publish images of 256 or fewer colors to the Internet.

glyph
Diamond-shaped handles that can be dragged to alter the form of a shape.

glyph (typographic)
A typographic glyph corresponds to a single character of a typeface.

grab area
The area of a command bar that can be dragged. Dragging the grab area moves the bar, while dragging any other area of the bar has no effect. The location of the grab area depends on the operating system you are using, the orientation of the bar, and whether the bar is docked or undocked. Command bars with grab areas include toolbars, the toolbox, and the property bar.

grayscale
A color mode that displays images by using 256 shades of gray. Each color is defined as a value between 0 and 255, where 0 is darkest (black) and 255 is lightest (white). Grayscale images, especially photos, are commonly referred to as “black and white.”

greeking
A method of representing text by using either words that have no meaning or a series of straight lines.

grid
A series of evenly spaced horizontal and vertical lines that are used to help draw and arrange objects.
See also document grid.

group
A set of objects that behave as one unit. Operations you perform on a group apply equally to each of its objects.

guideline
A horizontal, vertical, or slanted line that can be placed anywhere in the drawing window to aid in object placement.

gutter
The space between columns of text, also called the alley. In printing, the white space formed by the inside margins of two facing pages.

H
halftone
An image that has been converted from a continuous tone image to a series of dots of various sizes to represent different tones.

handles
A set of eight black squares that appear at the corners and sides of an object when the object is selected. By dragging individual handles, you can scale, resize, or mirror the object. If you click a selected object, the shape of the handles changes to arrows so that you can rotate and skew the object.

highlight, shadow, and midtone
Terms used to describe the brightness of pixels in a bitmap image. Brightness values range from 0 (dark) to 255 (light). Pixels in the first third of the range are considered shadows, pixels in the middle third of the range are considered midtones, and pixels in the last third of the range are considered highlights. You can lighten or darken specific areas in images by adjusting the highlights, shadows, or midtones. A histogram is an excellent tool for viewing and evaluating the highlights, shadows, and midtones of images.
histogram
A histogram consists of a horizontal bar chart that plots the brightness values of the pixels in your bitmap image on a scale from 0 (dark) to 255 (light). The left part of the histogram represents the shadows of an image, the middle part represents the midtones, and the right part represents the highlights. The height of the spikes indicates the number of pixels at each brightness level. For example, a large number of pixels in the shadows (the left side of the histogram) indicates the presence of image detail in the dark areas of the image.

hotspot
The area of an object that you can click to jump to the address specified by a URL.

hotspotting
The process of adding data to objects or groups of objects so that they respond to events, such as pointing or clicking. For example, you can assign a URL to an object, making it a hyperlink to an external website.

hot zone
The distance from the right margin at which hyphenation begins.

HSB (hue, saturation, brightness)
A color model that defines three components: hue, saturation, and brightness. Hue determines color (yellow, orange, red, and so on); brightness determines perceived intensity (lighter or darker color); and saturation determines color depth (from dull to intense).

HTML
The World Wide Web authoring standard comprised of markup tags that define the structure and components of a document. The tags are used to tag text and integrate resources (such as images, sound, video, and animation) when you create a webpage.

hue
The property of a color that allows it to be classified by its name. For example, blue, green, and red are all hues.

hyperlink
An electronic link that provides access directly from one place in a document to another place in that document or to another document.

icon
A pictorial representation of a tool, object, file, or other application item.

input stroke
A stroke that you make as you sketch with the LiveSketch tool. Input strokes are adjusted and converted to Bézier curves based on the time and distance between them.

image map
A graphic in an HTML document that contains clickable areas that link to locations on the World Wide Web, to other HTML documents, or to graphics.

image resolution
The number of pixels per inch in a bitmap measured in ppi (pixels per inch) or dpi (dots per inch). Low resolutions can result in a grainy appearance of the bitmap; high resolutions can produce smoother images but result in larger file sizes.

imagesetter
A high-resolution device that creates film or film-based paper output used in the production of plates for printing presses.

insert
To import and place a photo image, clipart object, or sound file into a drawing.

intensity
Intensity is a measure of the brightness of the light pixels in a bitmap compared with the darker midtones and dark pixels. An increase in intensity increases the vividness of whites while maintaining true darks.
interlacing
In GIF images, a method that lets you display a web-based image on the screen at a low, blocky resolution. As the image data loads, the image quality improves.

intersection
The point at which one line crosses another.

J

JavaScript
A scripting language used on the web to add interactive functions to HTML pages.

JPEG
A format for photographic images that offers compression with some loss of image quality. Because of their compression (up to 20 to 1) and small file size, JPEG images are widely used in Internet publishing.

JPEG 2000
An improved version of the JPEG file format that features better compression and allows you to attach image information and assign a different compression rate to an image area.

justify
To modify the spacing between characters and words so that the edges on the left, right, or both margins of a block of text are even.

K

kerning
The space between characters, and the adjustment of that space. Often, kerning is used to place two characters closer together than usual, for example WA, AW, TA, or VA. Kerning increases readability and makes letters appear balanced and proportional, especially at larger font sizes.

knockout
A printing term that refers to an area where underlying colors have been removed so that only the top color prints. For example, if you print a small circle on a large circle, the area under the small circle is not printed. This ensures that the color used for the small circle remains true instead of overlapping and mixing with the color used for the large circle.

L

Lab
A color model that contains a luminance (or lightness) component (L) and two chromatic components: “a” (green to red) and “b” (blue to yellow).

layer
A transparent plane on which you can place objects in a drawing.

leader tabs
A row of characters placed between text objects to help the reader follow a line across white space. Leader tabs are often used in place of tab stops, especially before text that is flush right such as in a list or table of contents.

leading
The spacing between lines of text. Leading is important for both readability and appearance.

linking
The process of placing an object created in one application into a document created in a different application. A linked object remains connected with its source file. If you want to change a linked object in a file, you have to modify the source file.

library
A collection of symbol definitions that are included in a CorelDRAW (CDR) file. To share a library between drawings, you can export it to the Corel Symbol Library (CSL) file format.
ligature
A character consisting of two or more letters joined together.

lightness
The level of brightness that is shared between a transparency and the object to which it is applied. For example, if a transparency is applied to an object whose color appears bright, the transparency color takes on a comparable brightness. The same is true for a transparency that is applied to an object whose color appears dark — the transparency takes on a comparable darkness.

lossless
A kind of file compression that maintains the quality of an image that has been compressed and decompressed.

lossy
A kind of file compression that results in noticeable degradation of image quality.

LZW
A lossless file compression technique that results in smaller file size and faster processing time. LZW compression is commonly used on GIF and TIFF files.

M
marquee select
To select objects or nodes by dragging the Pick tool or Shape tool diagonally and enclosing objects in a marquee box with a dotted outline.

master object
An object that has been cloned. Most changes you make to the master object are automatically applied to the clone.

master layer
A layer on a master page whose objects appear on every page of a multipage drawing. A master page can have more than one master layer.

master page
A virtual page that contains global objects, guidelines, and grid settings that apply to all pages in your document.

mesh fill
A type of fill that lets you add patches of color to the inside of a selected object.

metadata
Information about an object or a file. Examples of metadata include: title, name, tags, keywords, comments.

micro nudge
To move an object in small increments.
See also nudge and super nudge.

midpoint
The point of a Bézier line that divides it into two parts of equal length.

miter limit
A value that determines when two lines that meet at a sharp angle switch from a pointed (mitered) joint to a squared-off (beveled) joint.

moiré pattern
The visual effect of radiating curves created by superimposing two regular patterns. For example, a moiré pattern can result from overlapping two halftone screens of different angles, dot spacing, and dot size. Moiré patterns are the undesirable result of rescreening an image with a different halftone screen or with the same halftone screen on an angle different from the original.

multiple select
To select multiple objects by using the Pick tool, or multiple nodes by using the Shape tool.
nested group
A group of two or more groups that behaves as one object.

nested PowerClip objects
Containers that hold other containers to form complex PowerClip objects.

nodes
The square points at each end of a line or curve segment. You can change the shape of a line or curve by dragging one or more of its nodes.

noise
In bitmap editing, random pixels on the surface of a bitmap, resembling static on a television screen.

nonprinting characters
Items that appear on the screen but do not print. They include the rulers, guidelines, table gridlines, hidden text, and formatting symbols, such as spaces, hard returns, tabs, and indents.

nudge
To move an object in increments.
See also micro nudge and super nudge.

object (CorelDRAW)
A generic term for any item you create or place in a drawing. Objects include lines, shapes, graphics, and text.

one-point perspective
An effect created by lengthening or shortening one side of an object to create the impression that the object is receding from view in one direction.

opacity
The quality of an object that makes it difficult to see through. If an object is 100 percent opaque, you cannot see through it. Opacity levels under 100 percent increase the transparency of objects.
See also transparency.

open object
An object defined by a path whose start point and end point are not connected.

origin
The point in the drawing window at which the rulers intersect.

output resolution
The number of dots per inch (dpi) that an output device, such as an imagesetter or laser printer, produces.

outline
The line that defines the shape of an object.

overexposure
Excessive light in an image that gives it a washed-out appearance.
See also exposure.

overprinting
Overprinting is achieved by printing one color over another. Depending on the colors you choose, the overprinted colors mix to create a new color, or the top color covers the bottom color. Overprinting a dark color on a light color is often used to avoid registration problems that occur when color separations are not precisely aligned.
See also color trapping, choke, and spread.

P

paletted color mode
An 8-bit color mode that displays images of up to 256 colors. You can convert a complex image to the paletted color mode to reduce file size and to achieve more precise control of the colors used throughout the conversion process.

pan (CorelDRAW)
To move the drawing page around in the drawing window. Panning changes the page view in the same way that scrolling moves the drawing up, down, to the left, or to the right in the drawing window. When working at high magnification levels where not all of the drawing is displayed, you can quickly pan to see parts of the drawing that were previously hidden.

PANOSE font matching
A feature that lets you choose a substitute font if you open a file that contains a font not installed on your computer. You can make a substitution for the current working session only, or you can make a permanent substitution, so that the new font is automatically displayed when you save and reopen the file.

PANTONE process colors
The colors that are available through the PANTONE Process Color System, which is based on the CMYK color model.

paragraph text
A text type that allows you to apply formatting options and directly edit large blocks of text.

parent color
An original color style that you can save and apply to objects in a drawing. You can create child colors from the parent color.

See also child color.

path
The basic component from which objects are constructed. A path can be open (for example, a line) or closed (for example, a circle), and it can be made up of a single line or curve segment or many joined segments.

pattern fill
A fill consisting of a series of repeating vector objects or images.

perpendicular line
A line that intersects another line at a right angle.

pixel
A colored dot that is the smallest part of a bitmap.

See also resolution.

PNG (Portable Network Graphics)
A graphic file format designed for use in online viewing. This format can import 24-bit color graphics.

point
A unit of measure used primarily in typesetting to define type sizes. There are approximately 72 points to an inch and 12 points to a pica.

PostScript fill
A type of texture fill designed using the PostScript language.

PowerClip effect
A way of arranging objects that lets you contain one object inside another.

PowerClip object
An object created by placing objects (contents objects) inside other objects (container objects). If the contents object is larger than the container object, the contents object is automatically cropped. Only the contents that fit inside the container object are visible.
**pressure-sensitive pen**

A stylus that you can use to access commands and draw your images. To use with CorelDRAW, you must install the pressure-sensitive pen, along with a pressure-sensitive tablet and its corresponding drivers.

**process color**

In commercial printing, colors that are produced from a blend of cyan, magenta, yellow, and black. This is different from a spot color, which is a solid ink color printed individually (one printing plate is required for each spot color).

**progressive**

In JPEG images, a method of having the image appear on screen in its entirety, at a low, blocky resolution. As the image data loads, the image quality progressively improves.

**Q**

**QuickCorrect**

A feature that automatically displays the fully worded form for abbreviations or the correct form for errors as you type. You can use QuickCorrect to capitalize words or to correct common spelling and typographic errors automatically; for example, QuickCorrect can replace “asap” with “as soon as possible” and “hte” with “the.”

**R**

**radius**

As applied to the Dust & Scratch filter, sets the number of pixels surrounding the damaged area that are used to apply the filter.

**range sensitivity**

A paletted color mode option that lets you specify a focus color for the paletted conversion. You can adjust the color and specify its importance to guide converting.

**rasterized image**

An image that has been rendered into pixels. When you convert vector graphic files to bitmap files, you create rasterized images.

**render**

To capture a two-dimensional image from a three-dimensional model.

**resample**

To change the resolution and dimensions of a bitmap. Upsampling increases the size of the image; downsampling decreases the size of the image. Resampling with fixed resolution lets you maintain the resolution of the image by adding or subtracting pixels while varying the image size. Resampling with variable resolution keeps the number of pixels unchanged while changing the image size, resulting in lower or higher resolution than that of the original image.

**resolution**

The amount of detail that an image file contains, or that an input, output, or display device is capable of producing. Resolution is measured in dpi (dots per inch) or ppi (pixels per inch). Low resolutions can result in a grainy appearance; high resolutions can produce higher quality images but result in larger file sizes.

**rich text**

Rich text supports text formatting, such as bold, italics, and underlining, as well as different fonts, font sizes, and colored text. Rich text documents can also include page formatting options, such as custom page margins, line spacing, and tab widths.

**RGB**

A color mode in which the three colors of light (red, green, and blue) are combined in varying intensities to produce all other colors. A value between 0 and 255 is assigned to each channel of red, green, and blue. Monitors, scanners, and the human eye use RGB to produce or detect color.

**rollover**

An interactive object or group of objects that changes its appearance when you click or point to it.
round-tripping
The conversion of a document saved in one file format, such as Portable Document Format (PDF), to another format, such as Corel DESIGNER (DES) and then back again.

rotate
To reposition and reorient an object by turning it around its center of rotation.

ruler
A horizontal or vertical bar marked off in units and used to determine the size and position of objects. By default, the rulers appear on the left side and along the top of the application window, but they can be hidden or moved.

S
saturation
The purity or vividness of a color, expressed as the absence of white. A color that has 100 percent saturation contains no white. A color with 0 percent saturation is a shade of gray.

scale
To change an object’s horizontal and vertical dimensions proportionally by a specified percentage. For example, scaling a rectangle that is 1 inch high and 2 inches wide by 150 percent results in a rectangle that is 1.5 inches high and 3 inches wide. The aspect ratio of 1:2 (height to width) is maintained.

seed color
The color of the first pixel that you click when you define a mask. This color is used by the tolerance value to set the sensitivity of the color detection in color masks.

segment
The line or curve between nodes in a curve object.

selection box
An invisible rectangle with eight visible handles that appears around any object you select using the Pick tool.

shape recognition
The ability to recognize and convert hand-drawn shapes into perfect forms. To take advantage of shape recognition, you must use the Smart drawing tool. For example, you can draw four pen strokes to sketch a rectangle, and the application will convert your hand-drawn lines into a perfect rectangle.

simple wireframe view
An outline view of a drawing that hides fills, extrusions, contours, and intermediate blend shapes. Bitmaps are displayed in monochrome.

See also wireframe view.

size
To change an object’s horizontal and vertical dimensions proportionally by changing one of the dimensions. For example, a rectangle with a height of 1 inch and a width of 2 inches can be sized by changing the value of the height to 1.5 inches. A width of 3 inches automatically results from the new height value. The aspect ratio of 1:2 (height to width) is maintained.

skew
To slant an object vertically, horizontally, or both.

snap
To force an object that is being drawn or moved to align automatically to a point on the grid, a guideline, or another object.

source object
The object you use to perform a shaping action on another object, such as welding, trimming, or intersecting. The source object receives the fill and outline attributes of the target object.

See also target object.
splash screen
The screen that appears when CorelDRAW starts. It monitors the progress of the startup process and provides information about copyright and registration.

split blend
A single blend that is broken into two or more components to create a compound blend. The object where the blend is split becomes the end object for one component of the blend and start object for the other.

spot color
In commercial printing, a solid ink color that prints individually, one plate per spot color.

spread
In commercial printing, a type of trap that is created by extending the foreground object into the background object.

style
A set of attributes that controls the appearance of a specific type of object. There are three style types: graphic styles, text styles (artistic and paragraph), and color styles.

stylus
A pen device, used in conjunction with a pen tablet, that allows you to draw paint strokes. A pressure-sensitive stylus allows you to vary your strokes with subtle changes in pressure.

subpaths (CorelDRAW)
Subpaths are the basic curves and shapes from which a single curve object is constructed.

subscript
Text characters that are positioned below the baseline of the other characters in a line of text.

subtractive color model
A color model, such as CMYK, that creates color by subtracting wavelengths of light reflected from an object. For example, a colored ink appears blue if it absorbs all colors except blue.

super nudge
To move an object in large increments by pressing Shift and an Arrow key. The super nudge value is multiplied by the nudge value to obtain the distance by which the object is moved.

See also nudge and micro nudge.

superscript
Text characters that are positioned above the baseline of the other characters in a line of text.

swap disk
Hard drive space used by applications to artificially increase the amount of memory available in your computer.

swatch
One of a series of solid-colored patches used as a sample when selecting color. A printed booklet of swatches is called a swatchbook. Swatch also refers to the colors contained in the color palette.

symbol
A reusable object or group of objects. A symbol is defined once and can be referenced many times in a drawing.

symbol instance
An occurrence of a symbol in a drawing. A symbol instance automatically inherits any changes made to the symbol. You can also apply unique properties to each instance, including size, position, and uniform transparency.
Tangent
A straight line that touches a curve or an ellipse at a point, but does not cross the curve or ellipse at that point.

Target object
The object you perform a shaping action on, such as welding, trimming, or intersecting with another object. The target object retains its fill and outline attributes while copying these attributes to the source objects used to perform the action.

See also source object.

Temperature
A way of describing light in terms of degrees Kelvin — lower values correspond to dim lighting conditions that cause an orange cast, such as candlelight or the light from an incandescent light bulb. Higher values correspond to intense lighting conditions that cause a blue cast, such as sunlight.

Template
A predefined set of information that sets the page size, orientation, ruler position, and grid and guideline information. A template may also include graphics and text that can be modified.

Text baseline
The imaginary horizontal line that text characters appear to be placed on.

Text frame
The rectangle that appears as a series of dashed lines around a block of paragraph text created using the Text tool.

Text style
A set of attributes that controls the appearance of text. There are two text style types: artistic text styles and paragraph text styles.

Texture fill
A fractally generated fill that, by default, fills an object or image area with one image instead of with a series of repeating images.

Threshold
A level of tolerance for tonal variation in a bitmap.

Thumbnail
A miniature, low-resolution version of an image or illustration.

Tick
Invisible divisions to which your pointer gravitates.

Tiling
The technique of repeating a small image across a large surface. Tiling is often used to create a patterned background for webpages.

Tint
In photo editing, a tint often refers to a semitransparent color applied over an image. Also called a color cast.

In printing, a tint refers to a lighter shade of a color created with halftone screening — for example, a spot color.

See also halftone.

Tonal range
The distribution of pixels in a bitmap image from dark (a value of zero, indicating no brightness) to light (a value of 255, indicating full brightness). Pixels in the first third of the range are considered shadows, pixels in the middle third of the range are considered midtones, and pixels in the last third of the range are considered highlights. Ideally, the pixels in an image should be distributed across the entire tonal range. A histogram is an excellent tool for viewing and evaluating the tonal range of images.

Tone
The variations in a color or the range of grays between black and white.
transparency
The quality of an object that makes it easy to see through. Setting lower levels of transparency causes higher levels of opacity and less visibility of the underlying items or image.

See also opacity.

trapping
See color trapping.

TrueType fonts
A font specification developed by Apple. TrueType fonts print the way they appear on the screen and can be resized to any height.

TWAIN
By using the TWAIN driver supplied by the manufacturer of the imaging hardware, Corel graphics applications can acquire images directly from a digital camera or scanner.

two-point perspective
An effect created by lengthening or shortening two sides of an object to create the impression that the object is receding from view in two directions.

U
underexposure
Insufficient light in an image.

See also exposure.

uniform fill
A type of fill used to apply one solid color to your image.

See also fill.

Unicode
A character encoding standard that defines character sets for all written languages in the world by using a 16-bit code set and more than 65,000 characters. Unicode lets you handle text effectively regardless of the language of the text, your operating system, or the application you are using.

URL (Uniform Resource Locator)
A unique address that defines where a webpage is located on the Internet.

V
vanishing point
A marker that appears when you select an extrusion or an object to which perspective has been added. With an extrusion, the vanishing point marker indicates the depth (parallel extrusion) or the point at which the extruded surfaces would meet if extended (perspective extrusion). In both cases, the vanishing point is indicated by an X.

vector graphic
An image generated from mathematical descriptions that determine the position, length, and direction in which lines are drawn. Vector graphics are created as collections of lines rather than as patterns of individual dots or pixels.

See also bitmap.

vector object
A specific object within a drawing that is created as a collection of lines rather than as patterns of individual dots or pixels. Vector objects are generated from mathematical descriptions that determine the position, length, and direction in which lines are drawn.
watermark
A small amount of random noise added to the luminance component of the image pixels which carries information about the image. This information survives normal editing, printing, and scanning.

WEBP
The WEBP format provides both lossless and lossy compression and supports transparency in images designed for use on the web. WEBP lossless images are smaller than PNG files, and WEBP lossy images are smaller than JPEG images.

weld
To combine two objects into a single curve object with a single outline. A source object is welded to a target object to create a new object that takes on the fill and outline attributes of the target object.

white point
The measurement of white on a color monitor that influences how highlights and contrast appear.
In image correction, the white point determines the brightness value that is considered white in a bitmap image. In Corel PHOTO-PAINT, you can set the white point to improve the contrast of an image. For example, in a histogram of an image, with a brightness scale of 0 (dark) to 255 (light), if you set the white point at 250, all pixels with a value greater than 250 are converted to white.

Windows Image Acquisition (WIA)
A standard interface and driver, created by Microsoft, for loading images from peripheral devices, such as scanners and digital cameras.

wireframe view
An outline view of a drawing that hides fills but displays extrusions, contour lines, and intermediate blend shapes. Bitmaps are displayed in monochrome.
See also simple wireframe view.

workspace
A configuration of settings that specifies how the various command bars, commands, and buttons are arranged when you open the application.

zoom
To reduce or magnify the view of a drawing. You can zoom in to see details or zoom out for a broader view.

ZIP
A lossless file compression technique that results in smaller file size and faster processing time.